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SA is used in many high-profile applications throughout a wide array 
of industries, from manufacturing to science and research. Some of 
these industries include:

 ■ Aerospace (aircraft and spacecraft)

 ■ Shipbuilding

 ■ Particle Accelerators

 ■ Nuclear Energy

 ■ Automotive

 ■ Heavy Equipment

 ■ Machining

You are about to embark on learning how to adeptly use the most 
powerful portable metrology software ever created. We think this 
learning period will prove to be remarkably short. Most users are able 
to confidently acquire and analyze data after only one day. In fact, it’s 
quite possible that you can start using SpatialAnalyzer simply by per-
forming a few trial and error “test drives”. The software is robust, and 
in general, it will politely inform you if you try something impossible.

We suggest that you may ultimately save time and grief by taking 
the time to read through this manual. Don’t be too particular about 
memorizing anything—after all, this document is available from 

Note:  This user manual is 
currently under develop-

ment.

CH
A

PT
ER

Congratulations on your purchase of SpatialAnalyzer, 
the world’s leading portable metrology software plat-
form. SpatialAnalyzer is a traceable, graphical metrolo-
gy software package that can simultaneously commu-
nicate to virtually any number and type of dimensional 
measurement systems and perform complex analysis 
tasks with ease.

1Welcome
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within SpatialAnalyzer. We hope you will obtain an understanding of 
the philosophy behind SpatialAnalyzer by reading this manual. If you 
are unable to read the manual, it also serves as an excellent reference 
when you have questions.

Above all else, the goal of our work has been to develop a software 
package where users of all levels of expertise may actually enjoy tak-
ing and analyzing measurements and may have confidence in the 
numbers they report.

About This Manual
New River Kinematics (NRK) regularly updates this manual to incor-
porate the most recent updates and changes to SA. However, due to 
the fact that this manual is currently under development, and due to 
the rapid pace of NRK’s software development, you may encounter 
out-of-date material. NRK is aware of this and is working to bring con-
tent up-to-date.

SpatialAnalyzer comes in several packages. In cases where it may be 
ambiguous, we try to make it clear if a capability is not available in a 
specific SA package.

If you have any comments or suggestions for this manual, or if you 
notice any errata, please report them to support@kinematics.com.

Conventions
A standard set of conventions have been established to help ensure 
that this document is easy to read. The established standards are de-
scribed here:

The titles of windows and dialogs will appear like this: Best Fit Trans-
formation.

Menu choices appear like this: Construct>Points>Enter.

Checkboxes, dropdowns, and other control choices appear like this: 
Show Scale indicator in View.

Button titles appear like this: Apply.

Keyboard combinations appear like this: Ctrl+D.

Named fields or boxes that subdivide areas of the user interface will 
appear like this: Degrees of Freedom.

Filenames appear like this: License10734.met.

Text that you should type in will appear like this: Nominal.

New terms will look like this: relationship Minimization.

Note:  An important note 
that accompanies the text 

appears in a box like this.

Warning:  A warning box, 
like this, will appear any-
time there is information 

considered to be of a critical na-
ture for either data integrity or 
measurement data accuracy. Fail-
ure to heed warnings could po-
tentially lead to loss of data or in-
correct results.

Tip:  Tips or recommenda-
tions that include best prac-

tices or time-saving techniques 
will appear in a box like this.

mailto:support%40kinematics.com?subject=Support%20Question
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Hyperlinks or links to other locations in this document look like this: 
support@kinematics.com.

WARNING: UNITED STATES COPYRIGHT LAW PROTECTS THIS MANUAL, 
ASSOCIATED SOFTWARE, ALGORITHMS, AND VISUAL CONTENT.

A Closer Look
Additional information that is not critical, but may be of interest to curious readers, is printed 
in an box like this.
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This Page Intentionally Left Blank.
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SA 2014.06.17

Slots

Support for both rounded and square slots has been added.

Construction
Use Construct > Slots > Enter to construct round or square slots relative 
to the working coordinate frame.

From Surface Faces
Given a merged CAD surface, you can extract a slot by using the new 
command Construct > Slots > From Surface Faces. Simply click on the inte-
rior wall of the slot and the nominal slot will be created.

Geometry Fitting
Geometry fit now supports rounded and square slots. Use Construct > 
Slots > Fit to Points or select the Slot geometry type from the Geometry 
Fit dialog.

You can construct standard (best fit) slots (rounded or square), as well 
as max inscribed and min circumscribed slots.

For best results, measure at least 7 points for a slot, spread along both 

CH
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One of the advantages of SpatialAnalyzer is that devel-
opment occurs at a brisk pace. New feature requests, 
bug fixes, and changes are implemented quickly, giving 
you the opportunity to start taking advantage of newly 
implemented features in a very short period of time.

2What’s New In SA
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ends and the straight segments.

Slot Centers
To create a line along the center of one or more slots, use the new 
command Construct > Lines > Center of Slot(s).

Geometry Relationships
You can now create geometry relationships for slots. Icons have been 
added in the Relationships tab in the Toolkit:
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GD&T
GD&T now supports both SA Objects and CAD slot features. When 
using slots from CAD faces, it is necessary to enable the is Slot? option 
in the Features section of the Annotation Properties dialog in order for 
the selected face(s) to be recognized as part of that feature. 

Relationship Naming/Deletion

Renaming a relationship will cause the objects it created to also be 
renamed. Deleting a relationship will cause the objects it created to 
also be deleted. 

A Name field has been added to the Relationships tab in the Toolkit 
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which allows you to control the name of the relationship you create. 
If left blank, then the default name will be used. 

Toolkit Repeat Feature

A repeat checkbox has been added to the relationships tab of the 
toolkit (see previous image). When enabled, advancing forward in the 
Inspection tab or completing a feature with a measurement count 
limit will automatically create a new feature with the same properties 
as the last created feature.

This is particularly useful if you have to measure a large number of 
similar features, such as 100 holes. Simply define the first hole, enable 
the repeat option, and as you advance past the first hole, new circle 
features will be created for you.

Single Point Circle Geometry Relationships

Support has been added for single point circles in a geometry rela-
tionship. As a reminder, single point circles allow you to lay a probe in 
a hole (assuming the hole diameter is smaller than the probe diam-
eter) and create a circle with a single measurement, based on how far 
the probe sinks into the hole.

To create a single point circle geometry relationship, create a circle 
relationship as usual, and enable a projection plane. If the relation-
ship has exactly one point, a single point circle will be created. If you 
continue measuring additional points, a regular circle relationship 
will be created instead. Note that the measured point must be on the 
positive side of the projection plane.

New Relationship Tree Icons

Several new relationship tree icons have been added to help you dis-
tinguish among different types of relationships in the tree:

Rewritten MP Editor

A new, entirely-rewritten MP Editor is available in this release.
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The new editor brings a huge number of improvements over the pre-
vious script editor interface, making script development faster, easier, 
and requiring less mouse clicks. For detailed information on using 
this editor, refer to the chapter “Measurement Plans” in the SA User 
Manual.

To open the new editor, select Scripts > Create/Edit Measurement Plan, then 
click to open the new editor.

note: the new Mp editor is still in beta testing mode—exercise caution if 
using it with production scripts. 

New Measurement Plan Command

 ■ Construct Frames from Point Measurement Probing 
Frames. Creates frames from points that have ijk vectors stored 
(supported by certain instruments).

Dimensions

Dimensions can now be oriented to always face the screen (Screen) 
in addition to the original setting to have them oriented along the 
dimension (along).

This setting can be changed in the properties of a dimension, or you 
can right-click on the Dimensions category in the tree and select 
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Common Properties from the context menu to adjust the text size or dis-
play orientation for all dimensions in a collection.

Right-click selection in the graphical view has been implemented for 
dimensions as well.

Google Glass

A Google Glass app is now available which displays watch window 
data on the glass, allowing it to perform as a Heads-Up Display. 

The app is not yet available on the Google app store and requires 
manual installation. For more information, refer to the chapter “Watch 
Windows” in the SA User Manual or contact support@kinematics.com 
for download and installation instructions.

Laser Tracker Interface Enhancements

Stable Start and Recovery Triggers
You may now edit the parameters for the stable start and recovery 
triggers by clicking on the General Settings icon . This applies to 
any measurement’s stable start trigger, stable recovery after beam 
break, measurement restart, and stable start for measurement modes 
such as projection planes and hidden points (vector bars).

mailto:support%40kinematics.com?subject=Google%20Glass%20Install%20Instructions
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Cardinal Point Offsets
For specialized applications, you can now specify the offsets for cardi-
nal points created through the laser tracker interface or in Measure-
ment Plans through Geometry Fit Profiles.

This control is found in the Output Parameters dialog of the tracker 
interface fit dialog or in the geometry fit profile settings. Both offsets 
default to 0.0 to preserve existing behavior. 

User Interaction Mode
Laser trackers are now aware of SA’s User Interaction mode. If set to 
Silent, the interface will suppress most error messages that require 
user interaction. This is meant for automation, where user interaction 
is not desired.

High Point
The planar offset for all High Point measurements is now set to zero 
for better representation, since offset compensation is applied to the 
high point. The radial offset is still that of the target specified for the 
measurement.

For along axis high point, the point is shifted in the negative direction 
of the axis.

For from axis high point, the point is shifted toward the axis.

Auto-Incrementing Point Names

A check box option to auto-increment point names has been added. 
This setting does not persist. Each time the interface starts, it will be 
enabled to increment the point name (consistent with existing be-
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havior). The primary purpose of this feature is to take multiple obser-
vations for the same point. It does not apply to spatial or temporal 
scans, or to measurements initiated from SA (such as auto-measure). 

Tracker Toolbar
 ■ Reflectors and Targets. You can now access the Reflectors and 

Targets dialog from the Toolbar. Right-click a target quick se-
lect and choose Define New Target.

 ■ Loop and Iterate Toolkit. Loop and iterate toolkit has been 
added as an optional parameter for Spatial Scan in the tracker 
toolbar. This allows you to measure a set of circles defined in 
the Toolkit without returning to the computer between each 
iteration. When checked, this option sets the spatial scan to 
a stable start trigger, loop stop trigger and profile iterations 
to zero. It also iterates toolkit trapping to the next circle after 
each loop. When unchecked, this option sets the spatial scan to 
beam break stop trigger, one iteration, and no longer iterates 
the trapping from the toolkit. To navigate to this option, simply 
right-click on the spatial scan icon in the toolbar.

For additional fixes and improvements, refer to the Sa readme file.
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SA 2014.04.15

Relationship Links

As a convenience, points or objects associated with a relationship are 
now displayed in the tree under the relationship:

This allows you to identify the associated entities quickly, and to ac-
cess the properties of the associated objects directly under the rela-
tionship.

Relationships also list the points included in the relationship directly, 
as well as any cardinal points created by the relationship or projection 
planes used by the relationship. The geometry relationship icon now 
matches the object type being fitted as well.

You can interact with these tree entries just as you would elsewhere 
in the tree.

This capability is currently supported for Point to Point, Point to Ob-
ject, Frame to Frame, Object to Object Direction, Geometry, and Aver-
age Point relationships.

Max Inscribed/Min Circumscribed Circle Fits

You can now create Maximum Inscribed and Minimum Circumscribed 
circle fits in the geometry fit, tracker, and geometry relationship inter-
faces:

(For geometry relationships, the setting is found by clicking the Fit 
Settings button). These options will yield the largest circle that fits in-
side the available data, or the smallest circle that will encompass the 
available data, respectively.

Note that these fit algorithms are sensitive to coverage—to avoid a fit 
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error, try to ensure you have at least 180 degrees of circle coverage.

The fit mode (least squares, maximum inscribed, or minimum circum-
scribed) is recorded in the fit event and reported by the relationship 
as well.

High Resolution Graphic Export

When saving the graphical view to a file via File > Capture Graphics > To 
File (BMP/JPG/PNG/GIF/TIFF), you can now specify a render scale factor, 
enabling high resolution image exports of anything in the graphical 
view. When prompted, enter the desired scale factor. A value of 2.0, 
for example, will render an image that is twice the resolution of the 
graphical view.
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LAP CAD-Pro Laser Projector: New Interface

A new interface has been added for the LAP CAD-Pro Laser Projector.

This interface supports creating alignment (calibration) files from SA.

To align the projector, select Instrument > Laser Projector > Alignment from 
the menus.  After selecting the instrument and alignment points, a 
dialog will guide you through driving the projector to each point in 
sequence with the mouse.

Once you’ve driven to all the points, the projector will calibrate and a 
file with the alignment target positions and galvo angles will be cre-
ated.

You can use this file to register the projector with a single click after 
the one time manual drive, as long as the projector is not moved.

To project objects, select Instrument > Laser Projector > Project Objects. Se-
lect the objects to project. SA will project the objects and create a 
projection file using the name of the first object.
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Once you have created multiple projections, you can switch among 
them using the Previous, Current, and Next buttons in the instrument 
interface.

Measurement Plan support has been added to control the current 
projection as well. Refer to the “Instrument Operational Check” com-
mand in the MP Command Reference.

AICON DPA: New Interface

An instrument interface has been introduced to support the AICON 
DPA system.

This interface supports the import of points from the DPA system.

Laser Tracker Interface Enhancements

 ■ You can now iterate measurement profiles indefinitely (until 
you abort the profile) by setting the iterate this profile option 
to 0 iterations:

 ■  Clicking on a measurement profile name in the Measurement 

file:.\MP%20Command%20Reference.pdf
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Profiles dialog (below) will copy the name to the clipboard, for 
easy use in Measurement Plan commands:

 ■ You can now enable or disable use of a Faro tracker’s camera 
during a search operation. This is independent of whether the 
camera is used for catching the beam outside of a search op-
eration. To toggle this setting, click the gear icon in the 
tracker interface, then click the Faro button. In the Faro Tracker 
Settings dialog, toggle the Camera Search enabled option:

New Measurement Plan Commands

 ■ Get Instrument Model. Retrieves the name of the specified 
instrument.

 ■ Create Point to Point Dimension. Creates a dimension be-
tween two points.

 ■ Create Point to Object Dimension. Creates a dimension be-
tween a point and an object.

 ■ Create Object to Object Dimension. Creates a dimension be-
tween two objects.

 ■ Create Diameter Dimension. Creates a diametrical dimension  
for a circle, sphere, or cylinder.

 ■ Create Radius Dimension. Creates a radial dimension for a 
circle, sphere, or cylinder.

 ■ Set OPC DA Tag Value Double. Creates or overwrites a double 



18

SPATIALANALYZER USER MANUAL

value in the OPC server’s address space with the specified tag.

 ■ Get OPC DA Tag Value Double. Retrieves the double value as-
sociated with the specified tag from the OPC server’s address 
space.

 ■ Set OPC DA Tag Value Integer. Creates or overwrites an inte-
ger value in the OPC server’s address space.

 ■ Get OPC DA Tag Value Integer. Retrieves the integer value as-
sociated with the specified tag from the OPC server’s address 
space.

The “Instrument Operational Check” command has a number of new 
commands for instrument control, ranging from Innovo teach and 
measure controls to LAP CAD-Pro projector control.

The “Dock Instrument Interface” command now also supports the 
Sokkia Net1 and Leica total station interfaces, and the Leica Automa-
tion Interface.

For more information, refer to the MP Command Reference.

OPC Data Server

SA now has the capability of acting as an OPC Data Access server for 
broadcasting real-time data to other applications or hardware devic-
es. OPC stands for “Open Platform Communications” (originally “OLE 
for Process Control”) and is a specification establishing standards for 
communication of real-time plant data between control devices and 
software from different manufacturers.

The server can also be accessed via Measurement Plans. For more in-
formation, refer to “The OPC Interface” in the SA User Manual.

What’s New In SA

You can now access the What’s New document (this document) di-
rectly from SA using Help>What’s New in SA.

For additional fixes and improvements, refer to the Sa readme file.

file:.\MP%20Command%20Reference.pdf
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SA 2014.02.04

New Instrument Interface: Leica ScanStation P20

Support for the Leica Geosystems ScanStation P20 room scanner has 
been added. You must have a firmware license to activate the api 
data access toggle on the P20. You can toggle this on the scanner 
in Status>System Information>Options. The setting must be explicitly acti-
vated (it is deactivated by default).

Contact your Leica Geosystems representative for more information.

Arm Toolbar: Stream Points Settings

When working in the arm toolbar, you can now right-click the Stream 
Points button to set temporal or spatial scanning mode.

Shift Pts Along Vector

A new laser tracker measurement operation called “Shift Pts Along 
Vector” has been added. Along with it, a new measurement profile 
called “Scan Shifted Pts” or “Measure Shifted Pts” has been added.

With this operation, you define or measure a plane (as with projection 
planes) and define an offset (positive or negative). As you measure, 
each point is shifted by the specified amount.

Note that to reduce potential for confusion, the shifted points will 
retain offsets. Therefore, offset compensation should be considered 
when deciding on your shift offset. (In other words, if you want to cre-
ate the point exactly 2” above the center of a 1.5” SMR, use 2” for the 
offset value—not 1.25”).
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Sending Measured Plane Points

Laser tracker measurement operations that provide the option of 
measuring a projection or reference plane in situ now also provide an 
option to send measured points, so that the points defining the plane 
now appear in SA as well.

Report Image Drag and Drop

Supported images can now be dragged from the desktop directly 
into an SA Report. The file will be automatically embedded into the 
open job file’s tree.

Image Export From the Tree

Any embedded image in the tree can now be exported to an external 
image file by right-clicking the picture in the tree and selecting Export 
To File (BMP/JPG/PNG/GIF/TIFF).

MP Editor Improvements

The MP Editor has been modified to make resizing easier. In older ver-
sions, resizing the MP Editor required resizing multiple nested tables. 
Now, the window holds just one nested table which automatically re-
sizes with the window.

Also, MP commands with very long argument lists are now displayed 
in their entirety, without requiring you to scroll down in a nested ta-
ble.
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New MP Commands

 ■ Query Points to Single Point. Performs a query from multiple 
points to a single point, creating a vector group.

 ■ Make Collection Object Name Ref List from Objects associ-
ated with Instruments. Creates a list of all objects associated 
with one or more instruments.

 ■ Get Folders by Wildcard. Obtains a list of folders that match a 
set of wildcard criteria.

 ■ Get Folder Notes. Retrieves the notes associated with a folder.

 ■ Set Folder Notes. Sets the notes associated with a folder.

 ■ Get Folder Collections. Retrieves a list of collections inside a 
specified folder.

 ■ Output SA Report to Excel. Sends an SA report to an Excel file.

 ■ Make a Double List. Creates a list of double values.

 ■ Add Double to Double List. Adds a double value to an exist-
ing list.

 ■ Get Double List Max/Min. Retrieves the maximum and mini-
mum values from a list of double values.

 ■ MP control has been added for major theodolite functional-
ity. Refer to the Instrument Operational Check command in the MP 
Command Reference for details.

 ■ MP control has been added for Powerlock, SmartFind, and I-
Vision. Refer to the Instrument Operational Check command in the 
MP Command Reference for details.
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SA 2013.12.10

Arm Instrument Toolbar

A new instrument toolbar has been added for portable CMM arm 
operation. The arm toolbar is a greatly simplified interface for taking 
simple measurements with an arm. It is perfect for taking simple mea-
surements or measuring an inspection routine with the SA Toolkit. 

To access this new toolbar, click the Switch to Instrument Toolbar but-
ton  in the arm interface. For details on using the new toolbar, refer 
to “Measuring with Arms” in the SA User Manual.

New Relationship Types: Average Point

Two new relationship types have been added:

 ■ Average Point. Creates a point that is the average of all associ-
ated points.

 ■ Average Point to Nominal. Creates a point that is the average 
of all associated points, and compares it to a nominal point.

The points can be projected to a plane before averaging.
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These relationships are accessible in the menus via Relationships>Average 
Point>Average Point and Relationships>Average Point>Average Point to Nomi-
nal. They are also available as new icons in the Relationships tab of the 
SA Toolkit.

PDF Image Compression Control

You can now disable image compression when outputting a report 
to PDF format. This will yield a higher quality report image, at the ex-
pense of larger file size.

To disable compression, uncheck the image Compression option in 
the PDF Printing section of the SA report settings dialog.

Toolkit/Toolbar Keyboard Shortcuts

Keyboard shortcuts and T-Probe/4-button remote functions have 
been added for the SA Toolkit and Instrument Toolbars:

 ■ F6 (‘A’ button). Toggle measurement in the instrument tool-
bar.

 ■ F7 (‘B’ button). Go to the next feature in the toolkit.

 ■ Ctrl + F7. Go to the previous feature in the toolkit.

 ■ F8 (‘C’ button). Remove last point in the toolbar.

 ■ Ctrl + F8. Stop trapping in the toolkit.

 ■ F9 (‘D’ button). Iterate the measurement mode in the toolbar.

 ■ F10. Iterate the active target in the toolbar.

 ■ F12. Find the reflector (target search) in the toolbar.
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New Instrument Supported: Leica Nova Series MultiStations

Support has been added for the new Leica Nova series multiStations. 
These instruments support traditional total station behavior, but also 
incorporate perimeter scanning technology.

This includes both scanning and camera capture. Remote video can 
be watched with VLC player, which can be downloaded at http://
www.videolan.org/vlc/.  Once installed, a ‘Video’ button will appear 
on the interface camera dialog.

Leica B-Probe Support

SA now supports the new B-Probe from Leica, which works with the 
AT402 laser tracker.

Note: Both the B-Probe and the 402 must have compatible firmware 

http://www.videolan.org/vlc/
http://www.videolan.org/vlc/
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versions for proper operation. Refer to Leica for more information.

Leica AT 402 Enhancements

 ■ Discovery Support Added. The connection dialog for AT402s 
now supports IP discovery. .NET Framework v4.5 or later is re-
quired.

 ■ Color Overview Camera Support. Support for color imagery 
from the overview camera has been added. This requires a new 
OCX file to be installed, available at ftp://ftp.kinematics.com//
pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Lei-
ca/EmScon/Camera/.

Leica EmScon Enhancements

 ■ Brightness & Contrast Controls. Controls for brightness and 
contrast of the overview camera have been added to the video 
window.

 ■ SensorError SDK Support. Error conditions are now reported 
with more detail and potentially with proposed solutions.

 ■ PowerLock button. The PowerLock toggle button has been 
added back by popular request.

MeteoStation As External Weather Source

AT MeteoStations can now be connected directly to your computer 
and used as an external weather source for the laser tracker interface. 
If connected to an EmScon controller, it should still be set as an inter-
nal weather source.

Note that this may require installation of a USB to COM driver so 
that the MeteoStation creates a COM port when plugged into the 

ftp://ftp.kinematics.com//pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Camera/
ftp://ftp.kinematics.com//pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Camera/
ftp://ftp.kinematics.com//pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Camera/
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computer (available from ftp://ftp.kinematics.com/pub/SA/Install/
Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Driver%20
USBtoCOM%20for%20ATMeteo%20as%20External%20Weather%20
Source/).

Leica Total Station Manual Weather Input

Manual weather data can now be entered in the options dialog for 
Leica total stations.

New MP Commands

 ■ Import SAT File. Imports a .SAT file into the current job.

 ■ Import MP File as Embedded MP. Imports an MP file into the 
current job as an embedded MP.

 ■ Delete from ODBC Database. Deletes records from an ODBC 
database.

 ■ Show Items in Tree. Shows specified items in the tree, option-
ally collapsing all other tree categories.

 ■ Construct Point Clouds from Existing Clouds - Uniform 
Spacing. Creates a point cloud as a uniformly-spaced subset 
of existing clouds.

 ■ Make a Datum Ref List from a Collection. Creates a list of all 
datums in a collection.

 ■ Get i-th String From String Ref List (Iterator). Iterates 

ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Driver%20USBtoCOM%20for%20ATMeteo%20as%20External%20Weather%20Source/
ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Driver%20USBtoCOM%20for%20ATMeteo%20as%20External%20Weather%20Source/
ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Driver%20USBtoCOM%20for%20ATMeteo%20as%20External%20Weather%20Source/
ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/Laser%20Trackers/Leica/EmScon/Driver%20USBtoCOM%20for%20ATMeteo%20as%20External%20Weather%20Source/
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through a list of strings, retrieving a string on each iteration.

 ■ Get Number of Datums in Datum Ref List. Returns the num-
ber of datums in a list of datums.

 ■ Get i-th Datum From Datum Ref List. Retrieves a specific da-
tum from a list of datums.

 ■ Get i-th Datum From Datum Ref List (Iterator). Iterates 
through a list of datums, retrieving one datum on each itera-
tion.

 ■ Refresh Datums/Feature Checks From Annotations. Up-
dates the datums/feature checks associated with the specified 
annotations.

 ■ Set Relationship Position Fit Constraints (Vector Type). Sets 
positional constraints for a frame to frame relationship.

 ■ Set Relationship Orientation Fit Constraints (Vector Type). 
Sets orientational constraints for a frame to frame relationship.

 ■ Start Robot/Machine Interface. Starts the interface for a ro-
bot/machine.

 ■ Stop Robot/Machine Interface. Stops the interface for a ro-
bot/machine.
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SA 2013.10.02

Tracker Instrument Toolbar

This release has a newly-developed interface for efficient measure-
ment with laser trackers—the Instrument Toolbar.

This new interface is greatly simplified for more streamlined interac-
tion with laser trackers. Less-common detailed settings have been 
stripped away, leaving just the essential elements of day-to-day mea-
surement, particularly suited to measurement using the Inspection 
tab of the SA toolkit. It can be used for single point, stable point, spa-
tial scan, tooling ball, and 4 additional user-defined measurement 
modes. You will likely find that this new streamlined interface covers 
a large proportion of your measurement needs, unless finer control is 
desired (in which case the traditional tracker interface can be used).

To access this new toolbar, click the Switch to Instrument Toolbar but-
ton  in the laser tracker interface. For much more on the new track-
er instrument toolbar, refer to “Measuring with Laser Trackers” in the 
SA User Manual.

Instrument Connection Indicator

Connected instruments are now clearly indicated in the graphical 
view by a new Instrument Connection Indicator, a translucent green 
ring that hovers around the base of the instrument.

The display and size of this indicator can be controlled in the User Op-
tions > Display tab.

Heads-Up Display

The graphical view is now equipped with a heads-up display (HUD) 
that includes feature name (if trapping to a feature), number of total 
points measured (if applicable), target name, measured coordinates, 
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and RMS (if applicable). The HUD’s font, color, transparency, size, and 
dwell time (how long it persists before clearing from the screen) are 
all adjustable.

Measurement Count

For measurement trapping (both to relationships and GD&T Datums 
and Feature Checks) you can now prescribe a specific number of 
points to be measured for a feature, and measurement trapping will 
automatically advance to the next feature when all measurements 
have been received. The current count is also displayed in the HUD.

You can also set the default number of points to be used for different 
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feature types on the User Options > Analysis tab. Use 0 to indicate that 
you do not want a prescribed limit on the number of points.

SA Toolkit Feature Projection Planes

The projection plane options have been improved in the Relation-
ships tab of the SA Toolkit for projection planes.

There are now three options:

 ■ None. Does not use a projection plane for the feature.

 ■ Selected Plane. Identical to the “Selected Plane” checkbox of 
previous versions. You choose a specific plane which will be 
used as a projection plane.

 ■ Plane for Each Feature. When selected, each additional fea-
ture added to the inspection routine will also have a projection 
plane feature added, so that you first measure the projection 
plane, then the feature to project to it.

Layout Planes on a Curve

A new command (Construct > Planes > Layout on a Curve Spaced at a Distance) 
has been added to lay planes along a B-Spline spaced at a specified 
interval. The planes will be oriented perpendicular to the curve.

Revolved Surfaces

You can now create a revolved surface by revolving a B-Spline about 
an object’s axis using Construct > Surfaces > From B-Spline Rotated about an 
Object. Select the B-Spline, the object, and then choose the axis about 
which to rotate, and the revolved surface will be created.
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Swept Surfaces

Swept surfaces can now be created using the new Construct > Surfaces 
> From B-Spline Swept along another B-Spline command. Chose a B-Spline 
for the profile (can be open or closed), a B-Spline for the sweep path 
(can be open or closed), and indicate whether the sweep should be 
performed using pure translation (no rotation) or whether the profile 
spline should be permitted to rotate through the sweep.

Surfaces From B-Splines or Point Groups

Using Construct > Surfaces > From B-Splines or Construct > Surfaces > From 
Point Groups, surfaces can now be created from as little as two B-Splines 
or point groups, where previously four were required.
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B-Spline Reversal

Multiple B-Splines can now be reversed simultaneously. In a B-Spline’s 
properties dialog, click the Reverse Multiple B-Splines button.

Vector Group Export

Settings for finer control over vector group exporting have been add-
ed to the File > Export > Vector Group command.

With these new options, you can:

 ■ Overwrite or append to an existing file

 ■ Specify the vector name format

 ■ Control decimal precision

 ■ Optionally include the length of the vector in the output.

Improved GD&T Surface Datum Handling

In previous versions, general surface features used as datums did not 
preserve primary/secondary/tertiary relationships. With this improve-
ment, you can now use general surfaces as datums while preserving 
primary/secondary/tertiary datum priorities.
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In order to do this, each general surface datum must be associated 
with an “offset” line or plane which defines the degrees of freedom 
that will be locked once the alignment to that datum surface has 
completed.

This is best explained with an example. Suppose a mostly-horizontal 
surface with some curvature is desired to be used as a primary datum, 
and a protruding vertical surface is intended to be the secondary 
datum. The primary surface can be defined with a horizontal offset 
plane. This implies that after the data is aligned to the mostly-hori-
zontal surface using all degrees of freedom,  the secondary datum is 
used for alignment with translation along the vertical direction and 
rotation about the horizontal axes disallowed.

The offset plane or line must be associated with the annotation be-
fore the datum is created. Also, a rough alignment using other meth-
ods (such as manual positioning, relationship fitting, Quick-Align, 
etc.) is recommended prior to evaluating general surface checks to 
maximize surface projection quality.

GD&T Cross Section Analysis Control

For GD&T checks which involve analysis of cross-sections, you can 
now control the distance between points (along the primary axis) 
used to group points together as a single cross section.
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Manual GD&T Alignment

You can now evaluate GD&T feature checks by disabling datum align-
ment completely—that is, by manually aligning before performing 
the check.

In the feature check’s Properties dialog, disable the enable datum 
alignment checkbox. Doing so implies that the feature check will be 
evaluated using the current alignment. Note that this generally will 
not adhere to the GD&T standard.

When evaluated this way, the feature check has its datums crossed 
out and the text MANUAL ALIGNMENT - DATUMS NOT USED will ap-
pear in the feature check’s summary table in the report bar.

Reporting Improvements

Table Styling
The new Report Table Style Settings dialog—accessible by clicking 
the Table Styling Options button below—holds the existing table for-
matting options, and additionally now provides access to control of 
table header background colors and the text color.
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Checkboxes
Checkboxes can now be added to reports.

To add a checkbox, right-click the report and select Add New CheckBox.

Repeated Paste
Items can now be pasted multiple times into reports.

Field/Combo Box Excel Support
Fields and combo boxes are now supported for Excel export.

Measurement Plans

Automatic Backups
Automatic backups are now available for the MP Editor. The User Op-
tions > Machine Configuration tab has settings for enabling backups 
and setting the backup interval.

When enabled, the MP Editor will save backups of the script being 
edited to your backup directory, assuming changes have been made 
since the last save. Backups are saved to the same location for both 
embedded and external scripts.

Reference List Editing: Delete All
When editing reference lists, you can now click Delete All to remove 
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all items from the list at one time.

25 New Commands
 ■ Get Instrument Target Status. Returns information on the 

current instrument target.

 ■ Open XML File. Opens an arbitrary XML file for reading and 
writing.

 ■ Set XML Attribute. Modifies or creates one or more XML at-
tributes for a specified node.

 ■ Get XML Attribute. Reads one or more attributes from a speci-
fied node.

 ■ Close XML File. Closes the XML file.

 ■ Add Item to SA Report at Location. Adds an item to a report 
with an optional specified page number and position on the 
page.

 ■ Get Custom Table Cell String. Retrieves a string from a table’s 
cell.

 ■ Get Custom Table Cell Double. Retrieves a double from a ta-
ble’s cell.

 ■ Make a String from a String Ref List. Converts a string refer-
ence list into a single concatenated string.

 ■ Construct Points at Projection on Surfaces - Parallel to WCF 
Axis. Creates points by projecting them to a surface along a 
working coordinate frame axis.

 ■ Construct Points at Projection on Surfaces - Radial from 
WCF Axis. Projects points radially to a surface from an axis of 
the working coordinate frame. This essentially creates a cylin-
drical projection.

 ■ Construct Points at Projection on Surfaces - Spherical from 
WCF Origin. Projects points spherically outward from the ori-
gin of the working coordinate frame’s origin.
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 ■ Get Collection Notes. Retrieves the notes for a collection.

 ■ Set Collection Notes. Sets the notes for a collection.

 ■ Get Object Notes. Retrieves the notes for an object.

 ■ Set Object Notes. Sets the notes for an object.

 ■ Get Point Notes. Retrieves the notes for a specific point.

 ■ Set Point Notes. Sets the notes for a specific point.

 ■ Set Relationship Associated Data. Associates data with the 
specified relationship.

 ■ Get Relationship Associated Data. Retrieves the data associ-
ated with the specified relationship.

 ■ Get Vector Group Colorization Options. Retrieves the color-
ization options for the specified vector group.

 ■ Get Vector Group Display Attributes. Retrieves the display 
attributes associated with a specified set of colorization op-
tions.

 ■ Construct Point Clouds from Existing Cloud Points - Run-
time Select. Constructs a point cloud from cloud points select-
ed by the user at runtime.

 ■ Enable/Disable Alignment for Feature Check. Enables or 
disables GD&T alignment for a given feature check. If disabled, 
the alignment in place at runtime is used for the feature check 
evaluation.

 ■ Show/Hide Annotations For Datums. Permits showing or 
hiding, as well as highlighting, of annotations associated with 
specified datums.

For other improvements, changes, and fixes, please refer to the SA 
Readme file.
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SA 2013.08.02

Expanded File Import/Export Support

The command File>Export>Other>Surface Wireframe Curve File(s) (.crv) has 
been added. This command writes a wireframe representation of  se-
lected surfaces to a text file containing 6 comma-separated values 
defining two endpoints of a line in Cartesian coordinates: Ax, Ay, Az, 
Bx, By, Bz.

The command File>Import>Custom Formats>Leica ADF (.adf) has been add-
ed to support the import of Leica ADF files.

Direct CAD Access import support has been added for the following 
file formats:

 ■ ACIS v23 (.SAT, .SAB)

 ■ Autodesk Inventor 2014

 ■ CATIA V5-6R2013 (R23)

 ■ Adobe 3D PDF (.PRC)

 ■ Rhinoceros (.3DM)

 ■ Siemens NX 8.5

Hidden Point Fixtures

In the User Options>Hidden Point-Bar Database tab, you can now define a 
hidden point fixture. This allows you to use three or more points to 
define another point on a fixture. Also, hidden points now support 
target offsets for the computed point.

To use this new feature, first measure all points on the fixture and con-
struct the hidden point manually. Then, in the Hidden Point-Bar Da-
tabase tab, click to add an N Point frame. Add the points defining the 
fixture’s orientation, then choose to pick the hidden point, and enter 
offsets for the hidden point if desired.
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Remove Measurements By Instrument

The new command Analysis>Measurement Simulations>Remove Measure-
ments By Instrument will remove all measurements associated with a 
specific instrument, leaving non-measured points behind.

Grid By Distance

In addition to the existing command to lay out points on a grid based 
on a count (which has been renamed to Construct>Point(s)>Layout>Grid 
by Count), a new command has been added to lay points out on a grid 
based on a spacing (Construct>Point(s)>Layout>Grid by Distance).

This command maintains the specified spacing, laying off points in-
side the specified boundary.
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New Deletion Commands

Two new commands for deleting relationships and pictures have 
been added: Edit>Delete>Delete Relationships and Edit>Delete>Delete Pic-
tures. These allow the deletion of one or more relationships or pictures 
in one command.

Tree Improvements

Several new commands have been added to the context menu in the 
tree:

 ■ Hide All. Hides everything in the SA job.

 ■ Show All. Shows everything in the SA job.

 ■ Delete Empty Folders. Deletes all empty folders or folders 
containing only empty folders from the SA job.

 ■ Delete Empty Collections. Deletes all empty collections from 
the SA job.

To access these new menu items, right-click in an empty area of the 
tree.

Also, (Working) now appears next to the working coordinate frame 
in the tree.

Italian Language Support

Italian is now included as a stock language in SA. Stock language 
translations are now available in the SA Viewer as well.

XML Import

The XML import and export format has been published for the ben-
efit of all users. For more information, refer to “Importing XML Files” in 
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the chapter “Working With Files”.

GD&T: Line Profile Check

A line profile check has been added to GD&T. Line profile checks re-
quire objects with directional information (“direction objects”) to be 
associated with the annotation; these are used to determine how the 
measurements are grouped into cross-sections. Direction objects can 
be associated in the annotation properties dialog or when using the 
GD&T toolbar through an additional prompt during creation.

All measurements within 1 mm of each other in the specified direc-
tion are grouped together and analyzed as a cross-section. If multiple 
direction objects are used, the direction is obtained by averaging the 
individual object directions.

GD&T Actual Features & Solved Points

The GD&T Options dialog has two new options: Create actual Features 
and Create Solved points.

 ■ Create Actual Features. Creates actual measured geometric 
features for GD&T checks. For instance, if performing a flat-
ness check, the plane representing the orientation of the plane 
used for the flatness check is created. This allows you to query 
your measured points to this plane to determine high and low 
points, for instance.

 ■ Create Solved Points. This creates the center points used for 
true position analysis when determining if a feature is out of 
tolerance.



42

SPATIALANALYZER USER MANUAL

GD&T Actual Diameter Override

For cases in which a single feature check has been applied to multiple 
cylindrical features , you can you now create size checks for individual 
features and enable actual diameter Override to apply an actual diam-
eter value for that feature without explicitly measuring it.

For instance, in the case of a true position check at MMC, any hole 
larger in diameter than MMC will result in a bonus tolerance. To ap-
ply this bonus tolerance to the true position check without physically 
measuring the size of the hole, you would create a diameter check for 
the hole, enable its actual diameter Override option, and type in an 
actual diameter. This will result in a bonus tolerance being calculated 
and applied, but without requiring you to measure the actual size of 
the hole.

Feature Inspection Auto Filter Cloud Organization

The GD&T>Feature Inspection Auto Filter command has a new Create Cloud 
for each datum/Check option which will create a separate point cloud 
for each datum or feature check. Keep in mind that this may create 
multiple copies of a given cloud point, since one point may be associ-
ated with multiple datums or feature checks.

Reporting Improvements

Fields
A new ComboBox widget is now available within reports. Combo 
boxes allow you to present a drop down list to a user in a report. The 
list items may be populated from report tags or static text. Simply 
right-click in the field, select Cell Options>Make ComboBox.
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New Tag
A new system tag has been added, <<Filename Short>>, which 
lists the current filename without the full path.

Borderless Tables
Borderless tables can now be created in reports by right-clicking a cell 
and selecting Cell Options>Disable All Cell Borders. Select Cell Options>Enable 
All Cell Borders to re-enable them.

Text Properties
The properties of a text block now contain controls for font, back-
ground color, text color, border color, and thickness.

Arrowhead Ends
Line arrowheads can now be added to just the start, just the end, or 
both ends of a line.
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Vector Group TCB Option
The report options for vector groups now has a tCB checkbox which 
allows disabling the display of the tolerance color box column in its 
table on a report.

USMN Max Instruments Per Point
The User Options>Reporting tab has a new USMn Max instruments per 
point option in the Event Reporting box, which controls the maximum 
number of instruments listed per point within the event details table.

Callout Styling
Individual callouts can now have their own leader/border thickness/
color and fonts. To modify an individual callout’s settings, right-click 
the callout and select Callout Styling.

Callout Snapping

Callouts with leader lines can now be constrained along 45 degree 
angle increments. Simply hold down the Shift key while dragging a 
callout with a leader line to snap the callout and its leader line.

SpatialAnalyzer Directories

The User Options>Machine Configuration tab now allows you to select spe-
cific directories for each of the standard SA directories, avoiding the 
need to edit the registry to make such changes.
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Tracker Interface: Remove Simulation Delays

The laser tracker interface has a new option remove simulation delays 
when connected to a simulated interface. This allows for faster testing  
when simulated measurements are being performed.

When enabled, the “Point-At” command (e.g. double right-clicking a 
point in SA) will now simulate a beam lock immediately.

New Interface: API Axxis 7-100 7-DOF Probe Arm

A new interface has been added for the API Axxis 7-100 7-DOF probe 
arm. This arm runs under the API Baces interface, similar to the 6-100 
arm. It supports the new style 7-100 arms with the probe only (no 
scanner) attached.

New Interface: OmniTrak 2

A new interface has been added for the API OmniTrak 2 laser tracker.
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This interface uses the API Device Interface, and has as of yet been 
untested with hardware.

New Interface: Leica AT4xx

This interface has been added to support the Leica AT402. The AT4xx 
designation is for support of future models. Note that the AT401 can 
be run via this interface, but the initial AT401 interface and instru-
ment model in SA are preserved for continuity.

New Interface: Assembly Guidance Laser Guide Projector

A new interface has been added for the Assembly Guidance Laser 
Guide projector.

This interface supports creating calibration (registration) files from 
SA. Simply select Instrument>Laser Projector>Alignment. You will be 
prompted to select the projector and the group of points you will 
use to align the projector. In the interface, the UI will be displayed to 
guide you through driving the projector to each point in sequence 
with the mouse. Once you have driven to all the points, the projector 
will register and a file with the registration targets will be created. You 
may use this file to register the projector with a single click after the 
one-time manual drive, so long as the projector is not moved.

This interface supports projections from SA or from pre-created files. 
You are able to project objects from SA by selecting Instrument>Laser 
Projector>Project Objects. The selected object will be projected and a file 
will be created using the name of the first object. You have the capa-
bility to set the interface to add objects to an existing projection file, 
or to create a new file with each new projection. This way, you may 
create your own database of projection files simply by writing them 
to a common folder on your hard drive.

Once you have created a projection database, you can use the Previ-
ous, Current, and Next buttons in the interface to run through a given 
folder of projection files. You must install LASERGUIDESDK_3_03_11.
exe (or later) before running the interface. This may be downloaded 
from the NRK FTP site: ftp://ftp.kinematics.com/pub/SA/Install/Driv-
er%20Downloads/AssemblyGuidance%20LaserProjector/.

This FTP location also has batch files which need to be executed to 
register the projector DLL in the SA install.

ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/AssemblyGuidance%20LaserProjector/
ftp://ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/AssemblyGuidance%20LaserProjector/
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Automation

SDK Code Generation & Commented Lines
SDK code generation now ignores MP lines which have been com-
mented out.

MP Indentation
Indentation in the MP editor can now be controlled using Tab and 
Shift+Tab. Select one or more lines, then press these keystrokes to 
add or remove indentation, respectively.

New MP Commands
33(!) new MP commands have been added in this release. They are 
fully documented in the MP Command Reference, but are briefly list-
ed here for convenience:

 ■ Reverse Plane Normals. Reverses a plane’s normals.

 ■ Get Feature Check Cylinder Eval Options. Retrieves cylinder 
evaluation options for a cylindrical feature check.

 ■ Set Feature Check Cylinder Eval Options. Sets cylinder eval-
uation options for a cylindrical feature check.

 ■ Evaluate Feature Checks. Calculates one or more feature 
checks.

 ■ Start/Stop Feature Check Trapping. Starts or stops trapping 
to an individual feature check.

 ■ Get GD&T Options. Retrieves the job file’s GD&T options.

 ■ Set GD&T Options. Sets the job file’s GD&T options.

 ■ Start/Stop Relationship Trapping. Starts or stops trapping to 
a specific relationship.

 ■ Get Number of Pictures in Picture Name Ref List. Obtains 
the number of pictures in a picture list.

 ■ Get i-th Picture From Picture Name Ref List. Retrieves a spe-
cific picture from a picture list.

 ■ Add a Picture to Picture Name Ref List. Adds a picture to a 
picture list.
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 ■ Construct Surface from Point Groups. Fits a surface to points 
arranged by point group.

 ■ Construct Frame at Robot Link. Creates a frame on a robot’s 
linkage.

 ■ Make Axis Identifier from String. Converts a string to an “Axis 
Identifier” for use in a frame construction command.

 ■ Make a Collection Vector Group Name Ref List - Runtime 
Select. Prompts the user to select one or more vector groups.

 ■ Make a Point Name Ref List - Wildcard Select. Creates a list of 
points based on a wildcard string.

 ■ Make a Report Ref List - Runtime Select. Makes a list of re-
ports from a user selection.

 ■ Make a Report Ref List from a Collection. Makes a list of all 
reports in a collection.

 ■ Make a Picture Name Ref List. Creates a list of pictures.

 ■ Make a Picture Name Ref List - Runtime Select. Makes a list 
of pictures from a user selection.

 ■ Make a Point Name - Ensure Unique. Creates a unique point 
name guaranteed to not be used in the file.

 ■ Make a Collection Object Name - Ensure Unique. Creates a 
unique object name guaranteed to not be used in the file.

 ■ Import Nominals from XML File. Imports nominal points 
from an XML file.

 ■ Merge Measurements into XML File. Merges measured 
points into an XML file.

 ■ Rename Picture. Renames a picture.

 ■ Cloud Display Control. Sets the size and thinning for cloud 
points.

 ■ Find Files in Directory. Retrieves a list of files in a given direc-
tory.

 ■ Get Directory and Filename from Path. Splits a path into a 
directory and a filename.

 ■ UDP Send String. Sends a UTF-8 string via UDP over the net-
work.

 ■ UDP Receive String. Receives a UTF-8 string via UDP over the 
network.

 ■ Ask for User Decision from Image. Displays an image that has 
clickable regions to get input from the user.
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 ■ Get Datum Measurements. Retrieves the points/clouds asso-
ciated with a specific datum.

 ■ Set Datum Measurements. Sets the points/clouds associated 
with a specific datum.

For other improvements, changes, and fixes, please refer to the SA 
Readme file.
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SA 2013.03.22

Closest Points between Two Surfaces

This command finds the closest points between two surfaces, which 
is particularly useful for determining clearance/interference for vir-
tual fit-up and other alignment applications. From the menu, select 
Construct>Points>Closest Points between 2 Surfaces. Pick two surfaces and 
this creates two points, one on each surface, minimizing the distance 
between the two.

Relationship Fit Filters

A series of filters have been added to the Minimize Relationships dia-
log (see image below). This filter provides three options:

 ■ Hide all Relationships not included in the fit. This will re-
move any unchecked (excluded) relationships from the Mini-
mize Relationships dialog.

 ■ Hide Geometry Relationships that are not included in the 
fit. Only geometry relationships that are unchecked (excluded) 
will be filtered out of the Minimize Relationships dialog.

 ■ Check all Relationships (include all in fit). Selects (checks) all 
relationships in the collection for inclusion in the Minimize Re-
lationships dialog.
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Stock Language Translation-French

French is now included as a stock language in SA.

Geometry Relationship Storage

The results of geometry relationships are now stored in the SA file 
instead of being recalculated on open. This avoids potentially lengthy 
file open commands in certain cases which required a large number 
of geometry relationships to be recalculated.

SA Remote

You now have the ability to browse for available tracker interfaces, 
removing the need to manually key in an IP address.

Support for Wavefront Objects File (.obj)

Files formatted in Wavefront’s .obj file format may now be import-
ed via the File>Import>Custom Formats>Wavefront Objects File (.obj) menu 
command.

SolidWorks 2013 Support

SolidWorks 2013 file formats are now supported through the Direct 
CAD Access import option.

DXF Export

When exporting a .DXF file via File>Export>DXF File, there is now added 
support for exporting point clouds, as well as controlling whether or 
not point labels are included.

Direct CAD Access Settings: Reset to Defaults

In the Direct CAD Access Settings dialog, a new Reset to Defaults but-
ton restores the settings to factory defaults.

USMN Dialog

A number of minor improvements have been made to the USMN dia-
log. You can now right-click any instrument in the instrument list of 
the USMN dialog to access its properties or to check/uncheck all in-
struments. The point list has checkboxes for easily removing points 
from the USMN solution, and you can right-click any point in the 
point list to access its properties or to check/uncheck all points from 
the solution. Right click menu support has been added to the proper-
ties for the instrument list as well as the point list. Simply right click 
and you now have the option to select/unselect all. Check boxes have 
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also been added to determine active points.

Working Frame in Report Bar

The report bar now displays the name and collection of the working 
coordinate frame (see below).

Remove Last Point Assignment

remove Last point can now be assigned to a function key in the instru-
ment interface. This also means that this function can be assigned to 
a programmable remote, such as a T-Probe or RF Remote.

Reporting Improvements

Pictures
Pictures within reports may now be rotated clockwise in 90 degree 
increments. Simply right-click an image and select Rotate 90 from the 
context menu.
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Templates
Report templates now support scale bars, so they can be added to a 
template (see below).

Movement Constraints
Object movement in a report can be constrained to the horizontal 
or vertical direction by holding the SHIFT key down while dragging 
an object. This permits more precise alignment and positioning on 
reports.

Copy/Paste
Report items can be copied/pasted using the new Copy and Paste con-
text menu items (see below).

Export to Excel
Single and multiple items can be exported from an SA report to an 
Excel spreadsheet using the new Export to Excel context menu (see be-
low).
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Measurement Plan Improvements

In the Utility Operations>Delay for Specified Time command, you can now 
suppress the display of the progress dialog using the argument Show 
progress dialog?

The Reporting Operations>Set Report Options for Object command now sup-
ports relationships.

The Instrument Operations>Instrument Operational Check command sup-
ports several new operations:

 ■ “Show Big Group/Target Window”. Displays the resizable 
group/target window, which remembers its size and posi-
tion onscreen. This will return SUCCESS if the dialog is already 
showing.

 ■ “Close Big Group/Target Window”. Closes the resizable 
Group/Target window if it is open.

 ■ “API DI Enable iVision Single SMR”. Enables iVision Single 
SMR mode.

 ■ “API DI Enable iVision Multi SMR”. Enables iVision Multi-SMR 
mode.

 ■ “API DI Disable iVision”. Disables iVision functionality.

A number of new commands have been added to Measurement 
Plans. These include:

 ■ Variables>Set Collection Object Name Variable. This creates a variable 
of type collection object name.

 ■ Variables>Get Collection Object Name Variable. This retrieves the val-
ue for a variable of type collection object name.

 ■ Construction Operations>Callouts>Create Vector Callout. Creates a vec-
tor callout in a callout view.

 ■ Construction Operations>Callouts>Create Point Comparison Callout. Cre-
ates a point comparison callout in a callout view.

 ■ Construction Operations>Callouts>Create Relationship Callout. Creates a 
relationship callout in a callout view.

 ■ Construction Operations>Callouts>Delete Callout View. Deletes a call-
out view.

 ■ Construction Operations>Callouts>Rename Callout View. Renames a 
callout view.

 ■ Utility Operations>Create Robot Calibration. Creates a robot calibra-
tion.

 ■ Utility Operations>Delete Robot Calibration. Deletes a robot calibra-
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tion.

 ■ Utility Operations>Import Poses Match to Measurements. Imports a set 
of poses and associates them with measurements.

 ■ Utility Operations>Perform Robot Calibration. Performs a robot cali-
bration procedure.

 ■ Utility Operations>Start/Stop Robot Calibration Trapping. Starts or 
stops measurement trapping for a robot calibration.

 ■ Utility Operations>Make a Collection Instrument ID from a Collection and 
an Integer. Creates a value of type collection instrument ID from 
a collection and integer.

 ■ Utility Operations>Make a Collection Machine ID from a Collection and an 
Integer. Creates a value of type collection machine ID from a col-
lection and an integer.

 ■ Utility Operations>Make a Collection Instrument ID - Runtime Select. 
Prompts the user to select a single instrument, from which a 
collection instrument ID is retrieved.

 ■ Utility Operations>Set Active Robot Calibration. Sets a specific robot 
calibration to be the active calibration.

Geometry Triggers: Concentric Cylinders

Concentric cylinders can now be used as geometry triggers in laser 
tracker, portable arm, and NDI OptoTrak instrument interfaces. Set 
Closest Point or Interpolate at the time of concentric cylinder creation.

`
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API Device Interface Upgrade

The API Device Interface has been updated to version 4.6.1.0. This ver-
sion provides support for new Innovo camera functions, namely the 
ability to enable/disable the camera in single or multi-SMR mode.

TTL triggered data can also now be buffered as well. The buffer size 
can be set in the DI settings dialog.

All emScon Trackers

Updated the TPWizard SDK to v.2.0.0.4978 for AT-401 and AT-901 
trackers. Results from all checks/compensations will be added to the 
instrument History in SA (right-click on the instrument in the tree, 
and select History from the context menu).

Deeper support for external triggering has been incorporated into 
the instrument interface, such as the ability to set the Minimal Time 
Delay, Clock Transition (positive or negative edge), and Trigger Start 
Signal (high or low active). For faster triggering (External Source and 
Event Trigger Mode), you need to run a measurement profile with a 
Temporal Scan acquisition, and be sure to note what the operation is  
sending to SA. For more information on external triggering, see the 
Laser Tracker notes in the Readme file for SA 2011.12.22.

Leica AT-401

Automeasure now uses a routine that improves speed of an automea-
sure operation.

A new outdoor measurement mode is supported, and can be toggled 
from the Settings>Leica 4xx menu. When on, this measurement mode 
overrides the FAST, STANDARD, and PRECISE modes, no matter which 
is set.  This mode is used for all measurements until toggled off. (The 
Power Lock Mode settings—indoor, Outdoor <80m, and Outdoor 
>80m—have been deprecated by this new Outdoor Measure Mode.

For other improvements, changes, and fixes, please refer to the SA 
Readme file.



57

CHAPTER 2 ■ WHAT’S NEW IN SA

SA 2013.01.09

Jump To Views

You can now jump back and forth through previous views us-
ing View>View Control>Go to Prev View and >Go to Next View or using the 
Ctrl+Alt+← and Ctrl+Alt+→ keyboard shortcuts. This allows you 
to jump to a previous (or next) view on which you remained for at 
least 1 second.

SA Report Header and Footer Improvements

The SA Report Page Settings dialog has new header and footer set-
tings. A new hide First page header and Footer option will prevent the 
header and footer from displaying on the first page so that you can 
include a customized first page such as a title page.

There are also two new options which, when enabled, will draw the 
separator line below the header or above the footer: draw header 
Separator Line and draw Footer Separator Line.

Relationship Trapping by Selection

You can now trap points to a relationship by selection. For example, 
with a circle geometry relationship, if you want to add points to the 
circle fit, you can individually click points to add to the fit without 
having to reselect all of the points.

To trap additional points by selection, right-click a relationship in the 
tree and select Trap Selections from the context menu. Then click points 
to add to the relationship. When finished, press ESC or Enter.
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F2 Selection by Object Type

In object selection commands (such as Delete Object), you can now F2-
select objects by type. For instance, you can quickly select all circles 
in the Object Selection dialog by clicking the new By Object Type but-
ton.  When the By Object Types window appears, select one or more 
object types from your job, then click OK. All objects of that type will 
be selected.

The By Object Types window allows toggle selection, so that multiple 
types can be selected simultaneously. Simply click a row to toggle its 
selection state.
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Fit Results from Instrument Interface

When geometry is created via a measurement profile, the results of 
the fit (residuals, weighting, etc.) are now stored in both the geom-
etry’s notes and the instrument history. Data is stored for up to 500 
points to control file size.

Steinbichler AC File Format Support

Files formatted in the .AC file format that originated from a Stein-
bichler scanner (such as a T-Scan) can now be imported via the 
File>Import>Custom Formats>Steinbichler AC File menu.

T-Mac Tracker Pilot Support

Support has been added for Leica’s Tracker Pilot T-Mac to run manu-
facturer checks and compensations. If you have emScon v.3.8 or high-
er, you will need to install Leica Tracker Pilot T-Mac. This augments the 
check/configure/compensate functions found in the emScon Web 
App Server.

To run these new routines, select Check/Cal>Tkr Specific (Mfcr) from the 
tracker interface. You will be given the choice of running the T-Mac 
Tracker Pilot functions, or the Web App. As with the 401, the interface 
will disconnect from the tracker before running TP commands, and 
reconnect after.

If you are running an emScon version lower than 3.8, the Web App 
will be launched immediately, as always.

Multi-Pass Auto-Measure File Export

While performing automatic measurement using the 
Instrument>Automatic Measurement>Auto Measure command, a new ap-
pend all passes to File option allows you to specify a file for export. SA 
will then append each pass of automatic measurement to a file.
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Relocating Pictures to Another Collection

Pictures can now be moved to different collections. You can move the 
whole collection’s pictures by right-clicking the Pictures category 
in the tree and selecting Move all to another Collection, or an individual 
picture by right-clicking the picture and selecting Move to another Col-
lection from the context menu.

Standard CAD Import: Match Point Color

When importing a standard CAD file via File>Import>Standard CAD For-
mats, a new Use point Color information if available (1 group per color) 
option will set the group of an imported point to match the same 
color as the source CAD file’s point, if that color is available. Of course, 
since a point group can only have one color, this option will create a 
new point group for each color, and organize the points into different 
groups by color.
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LPT Laser Projector Enhancements

A new Browse button has been added next to the online projector 
part. This allows you to upload parts from the current job’s part da-
tabase, and fully enables 2-way communication with the parts data-
base. Plies are still added to the current part in the database as you 
project from SA, as always.

At startup, the interface looks for the current projector part in the LPT 
database. If it is found, the part is automatically uploaded from the 
database to ensure synchronicity. This is also true for the MP “Set Part 
Name “ command.

Units are now supported passively. The current job’s units of measure 
are queried at start up time, and everything written to the database 
is written in those units. The job name and its units are now displayed 
in a new connection status indicator at the top of the main interface 
window.

RDS v3.6 Support

Support for v3.6 of Hexagon’s RDS has been added.

New MP Commands

For details on these new MP commands, see the MP Command Refer-
ence.

 ■ Move Robot/Machine to Joint Pose (6DOF). Permits you to 
explicitly set the joint values for 6DOF robots and machines.

 ■ Simulate Robot/Machine Path, Output CSV File. This com-
mand will simulate a robot’s path through a set of frames and 
export the joint values to a text file.

 ■ Set Vector Group Report Options. Sets all of the report op-
tions for a vector group.

 ■ Set Relationship Report Options. Sets all of the report op-
tions for a relationship (group to group, points to objects, 
clouds to objects, and point to point).

 ■ Set Point Delta Report Options. Creates report options which 
can then be referenced by the Set Vector Group Report Options or 
Set Relationship Report Options commands.

For additional improvements, changes, and fixes, please refer to the 
SA Readme file.

file:.\MP%20Command%20Reference.pdf
file:.\MP%20Command%20Reference.pdf
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SA 2012.12.06

Repeat Alignments

Any instrument’s alignment can now be repeated, making alignments 
as part of a repeatable process easier to set up.

Whenever an instrument is aligned using Quick Align, Measure Nomi-
nal Points, or the Frame Wizard, the alignment parameters are stored 
with the instrument. This alignment can then be repeated at any time.

To Repeat an Instrument’s Alignment:

 ■ In the Inspection tab of the SA Toolkit, click the Repeat Last but-
ton while connected to an instrument.

This will automatically recall the previously saved alignment param-
eters, which can then be modified or committed.

Clicking the New button is a convenient way to perform a new align-
ment on the connected instrument.

Geometry Relationship Point Lists

You now have access to and control over point lists for geometry re-
lationships. Simply click the Point List button in the Geometry Rela-
tionship Report Options dialog. You can also access the point list by 
right-clicking a geometry relationship in the tree and selecting View 
Point List. Just as in the Geometry Fitting dialog, you can deactivate 
points, deactivate points exceeding a critical threshold, and sort by 
name or error.



63

CHAPTER 2 ■ WHAT’S NEW IN SA

A new option has been added to the Geometry Relationship Report 
Options dialog to permit the display of these points on a report. Sim-
ply select the Show Point List Details In Report option, and when the 
geometry relationship is added to a report, the point list will be in-
cluded.

Stock Language Translation

Five stock languages are now included with SA:

 ■ English

 ■ German

 ■ Spanish

 ■ Russian

 ■ Chinese

Set Viewpoint From Object

The new View>View Control>Set Viewpoint From Object command aligns 
the viewpoint down the -Z axis of the selected object.

Set Viewpoint From Surface Point

You can now align the view to look directly down the normal to a sur-
face at a specific point. Select View>View Control>Set Viewpoint From Sur-
face Point, then click on a surface. The view will realign to look directly 
down the normal of the surface at the selected point.
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Reporting Improvements

Insert/Delete Page
Pages can now be inserted or deleted in an SA report. To do so, right-
click in the report and choose Insert Page or Delete Page. These menu 
items are only available if the action is possible from the right-click 
location.

 ■ Pages can only be inserted if there are no report items inter-
secting the horizontal line where the click was initiated.

 ■ Pages can only be deleted if the page does not contain any 
report items.

Disabled Table Truncation
You can disable truncation on a per-table basis (regardless of the Max-
imum number of rows per table setting in the User Options Reporting 
tab) by right-clicking the table and selecting Do Not Truncate from the 
context menu.

Remove Trailing Empty Pages
In the Report Designer, there is a new option to remove all empty 
pages at the end of a report. Simply select Edit>Remove Trailing Empty 
Pages.

Colorization of In-Tolerance Fields
A new report option has been added for coloring in-tolerance delta 
fields green (see below).
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GD&T Improvement: Check Pre-Eval Validator

In the User Options  Analysis tab, in the GD&T Options dialog (ac-
cessible by clicking the GD&T Options button), a check Pre-Eval Valida-
tor has been added. This performs standard-specific validation checks 
on measurement data prior to a GD&T evaluation. 

The GD&T evaluation results are equivalent regardless of setting, 
since the standards in that area do not differ. However, depending 
on which standard is active (ASME 1994, ASME 2009, ISO 1983, or ISO 
2004), different checks may be performed on the initial data. This may 
result in a check failing even though it may have passed in an earlier 
version of SA.

Note that the None option maintains the equivalent behavior of pre-
vious versions of SA. This setting is saved with the job file.

GD&T Improvement: Evaluate All Feature Checks

A new option has been added to force a recalculation of all feature 
checks in an entire job. Simply select GD&T > Evaluate All Feature Checks.

Point to Object Dimensions: Radial Offsets

Point to object dimensions can now compensate for radial offsets in 
addition to planar offsets. Simply check the Use radial Offset Compo-
nent option. This is useful, for instance, when determining the dis-
tance to an edge that was measured with a pin nest.
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Laser Trackers: Projection Plane Settings

New settings have been established for measurement operations 
that accept projection planes, including:

 ■ Circle

 ■ Patch Point

 ■ Single Point Circle

Left-click the projection or intersection plane option in the opera-
tion’s parameters to select an existing plane to use. Right-click to 
specify options for automatically fitting the points while measuring:

 ■ Regenerate in SA. This option automatically creates the con-
struction plane after the profile completes.

 ■ Remove from Profile. Clears an existing selected plane from 
the profile.

 ■ Fit To Points. When checked SA will automatically fit a plane to 
the measured points. Specify the number of points to measure 
here.

Laser Trackers: 3-Plane Point

This new measurement operation in the laser tracker interface auto-
mates the process of measuring a “corner point”—a point that is con-
structed by measuring 3 intersecting planes. Many different acquisi-
tion modes can be used with this operation, including discrete point, 
stable point, and spatial scan.



67

CHAPTER 2 ■ WHAT’S NEW IN SA

To define or measure the three planes, use the instructions in “Laser 
Trackers: Projection Plane Settings” on page 66.

Laser Trackers: Adding Targets with Custom Radial Offsets

When adding defined targets in the laser tracker interface using the 
Add: From Selected Reflector button, you can now specify both the 
planar and radial offsets. This allows you to set these offsets in this 
dialog instead of the Targets table.

The default values for these fields will change depending on the size 
of the selected reflector and your current active units.

Laser Trackers: Circle Fit Point on Normal Option

When measuring a circle in the laser tracker interface or fitting a circle 
using Measurement Plans, the circle fit output parameters now have 
a Make pt on normal option.
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When checked (if Make Cardinal pts is enabled), the fit will create a 
cardinal point on the circle’s normal (existing behavior). You can now 
turn this option off to create a cardinal point only on the circle center.

Inspection Routine Navigation Enhancements

You can now program function keys (or remotes that emulate func-
tion keys) for “Next”, “Previous” and “Stop” navigation operations, pri-
marily to allow easier progression through an inspection routine in 
the SA Toolkit.

You can now also program CMM arm buttons for Next/Previous to 
correspond to a short/long button press.

Laser Radar: Video Source Selection

In the Laser Radar interface, you can now explicitly choose the video 
source. From the interface, select Settings>Video Settings>Video Capture 
Device.
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Leica TDA5005 GeoCOM Interface Added

A GeoCOM-based interface has been added for the Leica TDA5005 
that does not require the use of the NRK embedded SpatialAnalyzer 
application. This interface looks similar to the TDRA6000 interface. For 
this to function properly, the instrument must be added as a ‘Leica 
TDA5005 Total Station (GeoCOM)’ type (see below). 

For the GeoCOM mode to work properly, the instrument must be 
in the ‘MEAS’ program, running from its top level menu. Entering 
lower-level menu items within the program will cause the device 
to cease GeoCOM communication until returning to the top level 
menu. The TDA5005 should be configured with GSI Communication: 
9600/N/8/1/No Protocol and GeoCOM Communication: 9600/N/8/1/
GeoCOM Protocol.
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MP Script Searching

The MP Editor now has a Search field which allows you to search the 
current script to find a command or comment (below).

This can save a lot of time when working on a lengthy script.

Measurement Plan Commands

A number of new commands have been added to Measurement 
Plans. These include:

 ■ View Control>Show/Hide Instrument Probe Tip. Shows or 
hides the probe tip in the graphical view.
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 ■ View Control>Show/Hide Points. Shows or hides individual 
points.

 ■ Construction Operations>Points and Groups>Copy Group 
Excluding Obscured Points. Creates a new group of points by 
excluding points from source groups that are not visible to a 
specific instrument (because they are obscured by surfaces).

 ■ Analysis Operations>Get Cone Properties. Obtains the 
properties of a cone.

 ■ Instrument Operations>Delete Measurements. Deletes a 
set of specified measurements from an instrument.

 ■ Instrument Operations> Advanced Instrument Opera-
tions> Issue Instrument Actuator Command. asfd

 ■ Instrument Operations> Advanced Instrument Opera-
tions> Set Instrument Axes.

 ■ Instrument Operations> Advanced Instrument Opera-
tions> Set Alignment Projector.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Hardware Connect.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Hardware Disconnect.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Verify Hardware Connection.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Set Red Laser Intensity.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Self Test.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)>  LR Self Test - Linearization.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Self Test - Flip Test.

 ■ Instrument Operations> Nikon Metrology - Metris Laser 
Radar (LR)> LR Self Test - LO Sep.

 ■ Instrument Operations> Start Instrument Interface. Added 
a “Run in Simulation” argument to force immediate simulation 
mode, useful for testing scripts.

 ■ Instrument Operations> Locate Instruments (USMN). Add-
ed arguments for “point groups to exclude” and “exclude points 
measured by only one instrument.”

 ■ Relationship Operations>Make Group to Group Relation-
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ship. Added arguments for placing tolerances and constraints 
on the relationship.

 ■ File Operations>File Import>Import Leica GSI File. Imports 
the Leica GSI file format.

 ■ View Control>Show Labels. Independent control is now pro-
vided for turning point labels and object labels on or off.

 ■ Process Flow Operations>Ask For ... Font control is now pro-
vided in the “Ask For ...” commands.

For additional improvements, changes, and fixes, please refer to the 
SA Readme file.
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SA 2012.09.14

Threaded Projection

Multi-threaded processing has been added for surface projection op-
erations. Any operation that involves projection to surfaces is now up 
to several times faster! This includes operations such as:

 ■ Relationship fitting

 ■ Queries and vector group creation

 ■ Feature Inspection Auto-Filter

 ■ Auto-Filter to Faces

If your machine has multiple processor cores, you will see a speed im-
provement unless multi-processing is disabled in the SA user options 
(it’s enabled by default).

Selective CAD Import

For CAD formats that support part assemblies (such as CATIA’s .Cat-
Product files), you can now choose which individual components in 
the assembly to import, instead of making an attempt to import the 
entire assembly. Moreover, the contents of any CAD file being import-
ed are displayed before import so that you can choose which specific 
items to include in the operation.

To access this capability, import a CAD file using Direct CAD Access. In 
the Direct CAD Access dialog, ensure that the Selective import (Choose 
which Components to import) option is checked (see next page).
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Report Shapes

To help with annotating your reports, you can now draw boxes, el-
lipses, and lines (or arrows) directly on reports. Draw in any color or 
using several different line thicknesses or line styles.
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Report Object Locking

Individual items on reports can now be locked, which “freeze-dries” 
values and prevents those items from being modified in the report 
designer. Simply right-click an object on a report and select Locked Ob-
ject from the context menu to toggle the object’s locked state.

Report Undo

Undo support (Edit>Undo or Ctrl+Z) has been added to the report 
designer.

Automatic Measurement Selection

The Graphical Selection Mode dialog (View>Graphical Selection Mode) has 
a new option, automatically Select new Measurements. When enabled, 
incoming point measurements are automatically applied to the cur-
rent selection. For example, with this option enabled, if you’d like to 
construct a line between two points, you can select Construct>Line>2 
Points from the menu, them measure two points with an instrument, 
and the line will be created between them. When this mode is active, 
an [M] will appear in the command prompt and the feature naviga-
tion buttons will accept a prompt (next) or cancel/back up a prompt 
(previous).

Note:  Even with this mode 
active, selection via the 

graphical interface still works nor-
mally.
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New Commands

A number of new commands have been added, including the follow-
ing:

 ■ Construct>B-Splines>From Circles. Creates a B-Spline from 
a circle.

 ■ Edit>Delete Cloud Points>By Radial Distance From Points. 
Enables you to quickly delete cloud points inside of (or outside 
of ) a specified distance from a set of reference points. This is 
particularly useful for deleting registration sphere data from a 
scan once sphere centers have been extracted.

 ■ Relationships>Geometry Comparison>Select Nominal Ge-
ometries. Creates a geometry relationship with the specified 
nominal geometry. (This command supports F2 selection).

 ■ Construct>Point Clouds>From Existing Point Clouds Uni-
form Spacing. Takes source point clouds and creates a new 
cloud from them with as close to even cloud point spacing as 
possible (you can specify the desired spacing).

 ■ Construct>Points>From Cloud Points>Pick Clouds. Creates 
point from source cloud points using a desired subsampling 
value.

 ■ Query>Point to>Point along a Curve. Provides the distance 
between two points along a specified curve.

New Measurement Plan Commands & Features

 ■ Analysis Operations>Query Point to Point Along Curve. 
Provides the distance between two points along a specified 
curve.

 ■ Construction Operations>Points and Groups>Construct 
Points Auto-Correspond 2 groups Proximity. Copies a group 
of points to be renamed and renames the copied points based 
on proximity to reference points.

 ■ Construction Operations>Points and Groups>Construct 
Points Auto-Correspond 2 groups Inter-Point Distance. 
Copies a group of points to be renamed and renames the cop-
ied points based on the inter-point distance method.

 ■ Other MP Types>Make Projection Options. Creates projec-
tion options for use with vector groups.

 ■ Other MP Types>Make a Transform from Doubles (Matrix 
Elements). Creates a transform data type from 16 source ma-
trix values.
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 ■ Other MP Types>Decompose Transform into Doubles (Ma-
trix Elements). Extracts the 16 transform matrix values from a 
transform data type.

 ■ Reporting Operations>Delete Picture. Deletes a picture 
from the SA file.

The MP Editor now supports drag and drop loading of MPs from ex-
ternal files. Simply drag an MP file onto the MP editor, and it will be 
opened.

A new button, Show Step References, has been added which shows 
the steps that reference the selected step. 

For a list of dozens of other updates and changes, refer to the SA Re-
adme file.
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SA 2012.07.09

SA Toolkit Bar

The SA Toolkit bar provides a set of new 
tabs for quick access to functionality relat-
ed to GD&T, part inspection, analysis, and 
reporting.

 ■ GD&T. What was formerly known as 
the GD&T bar has been brought on 
as a tab in the Toolkit bar.

 ■ Relationships. The relationships 
tab enables one-click definition of 
features (defined by CAD or using 
primitive geometry) primed for easy 
inspection using geometry relation-
ships, with or without projection 
planes. Other relationships can be 
easily defined as well.

 ■ Inspection. The inspection tab pres-
ents all trappable features from all 
collections—relationships, datums, and feature checks—in a 
single list. This allows you to easily advance through an inspec-
tion routine, trapping measurements for each feature, and in-
stantly providing inspection results against nominal data.

 ■ Analysis. Some of the more commonly-used analysis tools, 
such as the frame wizard and geometry fitting, are presented 
together in the analysis tab.

 ■ Reporting. Functionality for creating reports, making dimen-
sions, and creating/annotating callout views is gathered to-
gether in the reporting tab.

To display the Toolkit bar, right-click on the menu/toolbar/status bar 
area of the SA interface and select Toolkit.

Reporting Enhancements

Headers/Footers & Templates
You can now define custom headers and footers for your own reports, 
including elements that update automatically (such as SA version, 
page number, and date). Headers and footers can contain anything a 
report body can contain: images, text, tables, and fields—simply drag 
elements as you would anywhere else on the report (see following 
image). While in the header/footer edit mode (accessible by double-
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clicking a header/footer, right-clicking a header/footer or by selecting 
Edit>Modify Header/Footer from the report window), you can resize the 
header/footer by dragging its divider.

When you’re happy with your header and footer, exit the mode by 
selecting Edit>Modify Header/Footer again. This will lock the header and 
footer in place, although dynamic fields will update as usual. If you’d 
like to set the report as a template for future reports, right-click the 
SA report in the tree and choose Default Template, or select File>Make De-
fault Template from the report window. This can also be done through 
the User Options>Reporting tab. Any additional reports created in the file 
will match the template’s format.

To use the template in other files, you can import the SA file contain-
ing the report template into the other file.

Keyboard Zooming
You can now zoom in and out in the report window using the + and - 
keys. Zooming to 100% can be accomplished by pressing Enter.

Jump to Page
Quickly jump to any page in your report by pressing Ctrl-G (for Go) 
while in the report window.

Image Border Control
Disable the display of borders around images from the report’s page 
settings options by clearing the draw images with Border checkbox.

Page Settings for Report Templates
Page settings for report templates can now be controlled from the SA 
Report Template properties dialog. In that dialog, click on the Page 
Settings button to define the parameters for the final generated re-
port.

Assigned Reporting Frames
Individual objects can now be reported/displayed with respect to a 
specified coordinate frame—not necessarily the active frame. This al-
lows you to have any coordinate frame active while always viewing a 
given object relative to its assigned coordinate frame.
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To assign a specific reporting frame to an object, right-click the object 
and select Reporting Frame from the context menu.

Be aware that the reporting frame applies to reported values in the 
report bar and reports only. For example, when double-clicking a 
point to view its coordinates, you will always see the coordinates rela-
tive to the active coordinate frame, regardless of the point group’s 
assigned reporting frame.

Clipping Planes

Support for full clipping planes has been added to the graphical view. 
This is a great option when you want to display a cutaway or cross-
section of your data. You can define as many clipping planes as you’d 
like, and any of them can be active at any one time.

Any number of objects can define the position and orientation of 
clipping cubes, and each clipping cube can have up to six clipping 
planes. You can interactively drag and resize the clipping box to repo-
sition the clipping planes.

GD&T: Fit to Points

A new creation option has been added to GD&T: Sa Objects (fit to 
points). This enables you to create a form or orientation GD&T check 
directly from measurements, instead of creating nominal geometry 
first.
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For example, to perform a circularity check on a set of measured 
points,  ensure that Sa Objects (fit to points) is selected. Click the circu-
larity button, select the measurements, then press Enter. The circu-
larity results will be calculated immediately.

Tracker Interface

A number of enhancements have been made to the tracker interface 
in order to better communicate current target and measurement pro-
file settings and provide access to common functions, as displayed 
below.

 ■ The Target/Reflector Quick Select box now displays text on the 
four pre-select buttons indicating the current target instead. 

 ■ An icon indicative of the current tooling setting is displayed 
underneath the quick-select buttons. These images indicate if 
the assigned setting is just for an SMR or is defined for use with 
additional tooling (such as a flat nest or pin nest).

 ■ The four measurement profile quick select buttons now dis-
play icons underneath them indicating both the acquisition 
and operation modes for the profile assigned to each button.

 ■ With all quick select buttons, you can hover over them to dis-
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play the full name of the assigned tooling definition/measure-
ment profile.

 ■ For trackers that support Leica’s PowerLock, a new toggle but-
ton has been added to the left of the interface docking icon to 
enable you to quickly activate or deactivate this functionality.

 ■ A new Inspection Navigation box has been added to the bot-
tom of the interface which enables easy navigation through 
trappable features. Easily advance forward or backward to the 
next trappable feature, or stop trapping altogether directly 
from the tracker interface.

Geometry Relationship Features

Several changes have been made to geometry relationships that im-
prove flexibility and functionality.

 ■ Projection planes can now be defined for line, circle, and 
ellipse geometry relationships. This can be accomplished 
by either choosing the project to plane option in the relation-
ship’s properties (below), or clicking the projection plane: active 
checkbox in the Relationships tab of the SA Toolkit bar. In the 
latter case, the selected projection plane will remain active and 
apply to all following geometry relationships until the check-
box is cleared.

 ■ Geometry Relationships can now be switched between “fit 
only” and “fit and compare” types. By selecting the Compare 
to nominal option (above), you can select nominal geometry 
to use for “fit and compare” relationships. If you simply want a 
basic geometry fit relationship, simply clear the checkbox.

 ■ Nominal Geometry can be created from the relationship 
properties. If you have an existing “fit only” relationship, you 
can create nominal geometry for it and convert it to a “fit and 
compare” relationship by clicking the Create Nominal button in 
the relationship’s properties.

 ■ New menu item for fit and compare relationships. A new 
menu item (Relationships>Geometry Comparison>Select Nominal Ge-
ometries) has been added, along with a button on the SA Tool-
kit’s new Relationships toolbar, that creates fit and compare 
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relationships from SA objects such as planes and circles. This 
is similar to Relationships>Geometry Comparison>Fit and Compare to 
Nominal, but doesn’t prompt for existing measured points.

 ■ New option to clear point associations. Point associations 
for any type of relationship can now be cleared by selecting the 
new Clear Point Associations context menu item. This is available 
for both individual relationships and the parent relationship 
category in the tree. (From the SA Toolkit’s Relationships tab, 
you can also choose to delete the cleared points from the file).

 ■ Access to fit settings prior to measurement. Geometry re-
lationships now allow access to fit settings prior to assigning 
points, so you can now prepare the relationship in a template 
file prior to measurement.

Quick Align and Best-Fit Transformation with Cloud Points

Quick Align and classic best-fit transformation can now be performed 
directly with cloud points. This is intended to be used to align cloud 
data to CAD surfaces after measurement, and has been implemented 
to avoid the need to first convert clouds to points for use with the ex-
isting commands. Three new menu items have been added to support 
this: Analysis>Best-Fit Transformation>Point Clouds to Surfaces/Objects>Quick 
Align Clouds to CAD, Analysis>Best-Fit Transformation>Point Clouds to Surfaces/
Objects>Point Clouds to Objects, and Instrument>Locate>Quick Align Clouds to 
CAD.

Frames from Probe Measurements

Frames can now be constructed from probe measurements (from 
devices such as the Intelliprobe 360 or T-Probe) if the measure-
ments have probing direction information. Use the new command 
Construct>Frames>From Point Measurement Probing Frames.

Show Points

Selected points can now be shown in one command using the new 
View>Show Points command.

New MP Commands

For details on these new MP commands, see the MP Command Refer-
ence.

 ■ Reporting Operations>Report Bar>Add Custom Tables to 
Report Bar. Adds one or more custom tables as tabs in the Re-
port Bar.

 ■ Reporting Operations>Custom Report Tables>Set Custom 

file:.\MP%20Command%20Reference.pdf
file:.\MP%20Command%20Reference.pdf
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Table Cell Font. Sets the font for a specific cell in a custom ta-
ble.

 ■ Reporting Operations>Custom Report Tables>Delete Cus-
tom Table. Deletes a custom table from the tree.

 ■ Reporting Operations>Set Scale for Picture. Assigns a scale 
value to a picture to control its size when added to a report.

 ■ Reporting Operations>Append Items to SA Report. Se-
quentially adds one or more items to an SA report.

 ■ Reporting Operations>Make New SA Report. Creates a new, 
empty SA report (using a defined template, if one exists).

 ■ Reporting Operations>Output SA Report to PDF. Exports an 
SA report to a PDF file.

 ■ Utility Operations>Copy Directory. Copies a directory from 
one location on the file system to another, optionally replacing 
the destination folder’s contents.

 ■ Utility Operations>Set Notification Cancel Override. When 
enabled, the Cancel button and “X” in the corner of the window 
are not displayed in dialogs resulting from any “notification” 
command (such as Notify User String).

 ■ Utility Operations>Set Automatic Backup State. Enables or 
disables full file and measurement automatic backups.

 ■ Utility Operations>Move Robot/Machine through Path. 
Commands a robot/machine to pass through a sequential set 
of coordinate frames, optionally interpolating between those 
frames as linear segments or as a smooth spline.

 ■ View Control>Set View Clipping Plane. Creates a clipping 
plane on a specified object.

 ■ Construction Operations>Frames>Construct Frame - Aver-
age of Other Object Frames. Creates a frame with the average 
position and orientation of the supplied frames.

 ■ Construction Operations>Other MP Types>Decompose 
Transform into Vectors (Origin and Axes). Converts a trans-
form value into four vectors: one for the origin and one for each 
of the three axes defining the transform.

 ■ Construction Operations>Other MP Types>Make a World 
Transform Operator (from Transform and Scale). Converts 
a separately supplied transform and scale factor in to a single 
world transform operator.

 ■ Process Flow Operations>Ask for User Decision Extended. 
Provide a question or prompt and a series of choices to appear 



85

CHAPTER 2 ■ WHAT’S NEW IN SA

in buttons. Clicking a button will jump to a specified step. Sim-
ilar to “Ask for User Decision”, except allows many more than 
three potential answers.

 ■ Analysis Operations>Query Frame to Frame. Queries the 
delta between two coordinate frames.

 ■ Analysis Operations>Query Point to Objects. Compares a 
point to one or more objects and returns the resulting devia-
tion.

 ■ Analysis Operations>Remove i-th Object From Collection 
Object Name Ref List. Removes the specified object from a 
collection object name reference list.

 ■ Analysis Operations>Remove i-th Point Name From Point 
Name Ref List. Removes the specified point from a point name 
reference list.

 ■ Analysis Operations>Auto Filter Points/Groups/Clouds to 
Surface Faces. Filters a set of points, groups, and/or clouds to a 
series of provided surfaces. Equivalent to the Construct>...>Auto 
Filter to Faces commands.

 ■ Instrument Operations>Dock Instrument Interface. Docks 
or undocks an instrument interface to the SA user interface.

New MP Editor Features

 ■ Recent Files. A list of recent files are now displayed in the MP 
Editor.

 ■ Moving Blocks of Steps. An entire block of MP steps can now 
be moved up or down in the MP Editor. Select the steps you’d 
like to move, then click the up or down arrow to move the set 
of steps as a unit.

New Robot/Machine Features

 ■ Simulate Motion Through Frames. Right-click a robot or ma-
chine and select Simulate Motion>Path Through Frames to run the 
inverse kinematics calculation and display the robot’s pose at 
each of the selected frames.

 ■ Command Motion Through Frames. Right-click a robot or 
machine and select Command Controller Motion>Run Path Through 
Frames to use manipulator kinematics to send frames directly 
to the controller, or have SA run a kinematics calculation and 
send joint sets to the controller for a calibrated path. Paths can 
be linearly interpolated between frames or via controller-cre-
ated splines.
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 ■ Imported Joint Sets. For defining machine/robot poses, you 
can now import joint sets and match them with frames in SA 
instead of just importing points. To do this, right-click the cali-
bration and select Import Joint Poses and Match to Frames.

For a list of dozens of other updates and changes, refer to the SA Re-
adme file.
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SA 2012.03.13

Surface Colorization

You can now generate colorized deviation maps based off of devia-
tion of points from surfaces. This is similar to the view for a vector 
group, in which measurements indicating excess material are blue 
and measurements indicating too little material are red, except that 
the colors are interpolated and “painted” across the mesh. This is in-
tended for use as another tool in visually reporting measurement de-
viation. This is available via Construct>Colorized Graphical Mesh>From Point 
Proximity, and replaces the Construct>Polygonized Mesh>Colorized Mesh from 
Nominal Face and Actual Data command from previous versions.

Offset Surfaces
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Using the new Construct>Surfaces>From Point Groups command, surfaces 
will now be created taking into account measurement offsets. This 
allows you to create offset surfaces using any desired offset. This new 
command replaces the former Construct>Surfaces>From Point Groups 
(Interpolate) and Construct>Surfaces>From Point Groups (Approximate) com-
mands.

Cylindrical/Spherical Report Options

Vector group and relationship reports now support output in Cylin-
drical and Spherical coordinates in addition to Cartesian coordinates.

File Integrity Verification

When saving an .xit or .xit64 file, SA will now calculate and store 
a checksum with the file. This checksum is unique to the file—some-
what like a fingerprint. Upon loading the file at a later time, SA will 
automatically examine this checksum value and use it to verify that 
the contents of the file have not changed. This means that SA will 
provide an indicator as to whether the file’s contents have changed or 
become  corrupt since the file was saved.

A new option in the User Options>Machine Configuration tab, Verify File 
Checksums after Saving, verifies the contents of a file immediately af-
ter it has been saved, and ensures that the file contents match the 
current SA file. This option, when checked, provides early and imme-
diate warning to file corruption, giving you an opportunity to re-save 
without losing any data. This feature is useful for all users, but is par-
ticularly aimed at those working with temporary storage media (such 
as thumb drives) which have been known to experience file corrup-
tion issues in the past.

USMN Filtering

A number of improvements have been made to the USMN dialog that 
allow for faster selection filtering of points and a dramatic speed-up 
in the main USMN dialog when dealing with networks with very large 
numbers of points.

After initially selecting the instruments to be a part of the USMN dia-
log, you are now presented with a USMN Network Build Settings dia-
log. This dialog allows you to remove entire instruments or groups 
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from the USMN process. For example, if you have 8000 scanned 
measurements associated with an instrument but which are not in-
volved in the USMN network, you can choose to exclude this group 
to minimize the number of points displayed in the USMN dialog. (This 
is equivalent to the Exclude Measurements button in the USMN dia-
log—the functionality is just available earlier in the process).

The dialog will also highlight red any pairs of point groups that have 
one or more measured points with the same name and are measured 
by the same instrument (to aid in detecting point name collisions).

Any point groups that contain point names that are not repeated 
in any other point groups will be highlighted blue, to indicate that 
the groups may not be involved in the USMN network and that you 
may not want to include them in the USMN solution (of course, those 
points will still be transformed along with the instrument (ie. “come 
along for the ride”) in the USMN solution.

Finally, there is an exclude points measured by only one instrument op-
tion to automatically exclude points from the USMN dialog that are 
not measured by other instruments. These points are not involved in 
the USMN network and therefore there is no need to explicitly show 
them in the USMN dialog.

Uncertainty Cloud Scale Control

Note:  Any points for which 
you would like to calculate 

uncertainties must be included in 
the USMN dialog. As a result, do 
not use exclude points measured 
by only one instrument if you 
would like to calculate uncertain-
ties for those points.
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The scale of rendered uncertainty clouds is now controlled by a more 
intuitive Cloud Magnification field, instead of the old Cloud Radius Rela-
tive to Target Radius setting. Like vector groups, this allows you to now 
directly scale uncertainty clouds such that a Cloud Magnification of 
3000 will render clouds 3000 times their true size. In previous ver-
sions, the scale was indirectly determined based on the target radius.

Underconstrained Feature Checks

When underconstrained feature checks are evaluated (that is, feature 
checks that have more than one solution), the evaluation will stop 
at the last iteration and present a message that the solution is not 
unique. Previously, the check simply produced an error message.

Transformation Matrix Copy/Paste

You can now paste 4x4 transformation matrices from the clipboard 
into any object’s transformation matrix in SA. To do this, copy the 
4x4 values to the clipboard (in row-major order, ie. row 1 column 1, 
then row 1 column 2...row 4 column 3, then row 4 column 4). Then, in 
any object’s transformation properties, click the View Matrix button. 
Check the allow editing checkbox, then click the Paste button.

You can also copy an object’s existing transformation matrix to the 
clipboard so that it can be pasted to a text file or Excel. With the allow 
editing checkbox deselected, click the Copy button when viewing any 
object’s transformation matrix. It can then be pasted from the clip-
board to another application.

Vector Group Construction Enhancements

The Construct>Vector Group>From Lines command has been enhanced 
to support general objects with direction (such as planes, circles, 

Note:  The last row in the 
pasted transformation ma-

trix should be (0, 0, 0, 1).
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cylinders, etc). The command has been renamed to Construct>Vector 
Group>From Object Directions.

Frame Export Options

When exporting frames via File>Export>Frames (and object’s frames), you 
now have the option of exporting either fixed values (XYZRxRyRz) or 
full transformation matrices.

Geometry Fit Graph: Tick Spacing

The tick spacing on geometry fit graphs has been improved to land 
on more even numbers and to also display the zero-error point in the 
graph, as depicted below.

Improved Reporting Image Quality

The quality of images such as screenshots, charts, and imported im-
ages displayed in the Report Bar and SA Reports has been greatly im-
proved.

ASCII Import: Points With Asymmetric Tolerances

A new format has been added for ASCII import which allows for the 
import of points with asymmetric tolerances: pointname x Y Z thx tLx 
thy tLy thz tLz thd tLd (point tolerance).



92

SPATIALANALYZER USER MANUAL

New Wildcard Deletion Commands

Two new edit commands have been added: Edit>Delete Folders by Wild-
card and Edit>Delete Collections by Wildcard. These commands allow you 
to delete folders and collections from the tree using a wildcard search 
criteria.

New MP Commands

For details on these new MP commands, see the MP Command Refer-
ence.

 ■ Construction Operations>Points and Groups>Construct 
Points Layout on Grid. Creates a point group by laying out 
points on a grid.

 ■ Construction Operations>Collections>Delete Collections 
by Wildcard. Deletes a set of collections based on a wildcard 
search criteria.

 ■ Construction Operations>Folders>Delete Folders by Wild-
card. Deletes a set of folders based on a wildcard search crite-
ria.

 ■ Construction Operations>GD&T>Delete Feature Checks. 
Deletes a list of GD&T feature checks.

 ■ Construction Operations>Other MP Types>Make an Event 
Reference List-Wildcard Selection. Makes a list of reportable 
events based on wildcard selection criteria.

 ■ Analysis Operations>Events>Get Number of Events in 
Event Ref List. Obtains the number of events in an event refer-
ence list.

 ■ Analysis Operations>Events>Get i-th Event From Event Ref 
List. Obtains the event at the specified index of an event refer-
ence list.

 ■ Analysis Operations>Events>Get i-th Event From Event Ref 
List (Iterator). Iterates through an event reference list, retriev-
ing successive events in the list.

 ■ Analysis Operations>Events>Rename Event. Renames an 
event.

 ■ Analysis Operations>Events>Delete Event. Deletes an 
event.

 ■ Reporting Operations>Report Bar>Add Events to Report 
Bar. Adds one or more events (in order) as separate tabs in the 
Report Bar.

 ■ Utility Operations>Set View Idle Update Frequency. Sets 

file:.\MP%20Command%20Reference.pdf
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the frequency at which the graphical view is updated.

 ■ Reporting Operations>Combine SA Reports. Combines sep-
arate SA reports into a single report.

 ■ Reporting Operations>Custom Report Tables>Make Cus-
tom Table. Creates a custom table in the tree for later addition 
to a report.

 ■ Reporting Operations>Custom Report Tables>Clear Cus-
tom Table. Clears a custom table.

 ■ Reporting Operations>Custom Report Tables>Set Custom 
Table Title. Sets the title for a custom table.

 ■ Reporting Operations>Custom Report Tables>Set Custom 
Table Header Cell. Sets a header for one or more consecutive 
columns in a table.

 ■ Reporting Operations>Custom Report Tables>Set Custom 
Table Cell String. Places the specified string into a custom ta-
ble.

 ■ Reporting Operations>Custom Report Tables>Set Custom 
Table Cell Double. Places the specified double into a custom 
table.

 ■ Reporting Operations>Custom Report Tables>Set Custom 
Table Cell Color. Sets a cell’s foreground and background color 
in a custom table.

 ■ Reporting Operations>Custom Report Tables>Add Custom 
Table to SA Report. Adds a custom table to an existing SA re-
port.

New Tracker Acquisition Mode: Hidden Point

A new acquisition mode has been added to the laser tracker interface: 
Hidden Point. This mode measures two points, then automatically 
creates a hidden point based on the offsets specified in the acquisi-
tion mode’s parameters. This acquisition mode is part of a new Hid-
den Point measurement profile.
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New Tracker Operation: Patch Points

This operation projects points to a defined plane as they’re mea-
sured—appropriate for measuring patch points.

RMS Monitor Improvements

The laser tracker interface’s RMS Monitor now persists its state be-
tween interface usage. If the RMS Monitor is open when the tracker 
interface is closed, then it will remain open when the interface is lat-
er reopened. Also, the RMS Monitor now also indicates stable point 
state (Waiting for Move, Waiting for Stable, etc.) which can be resized 
for easier viewing from a distance.
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New Instrument Interface: Steinbichler/Leica Probe Scanner for T-Probe

Support for the Steinbichler/Leica Probe Scanner has been added to 
SA. After starting the emScon tracker interface, the scanner is con-
nected to a T-Probe and data is collected through ProbeScan, in the 
same way that the T-Scan interface runs through T-Scan Collect.

The settings are very similar to the T-Scan interface, with the excep-
tion of a few options. Shutter time teaching is supported (using but-
ton C or D on the T-Probe), and success or failure is reported in the 
interface’s status window.

Portable CMM Arms

A new measurement mode, Single pt hole, has been added to the Por-
table CMM interface. This mode functions identically to the tracker 
mode of the same name. the probe radius and depth sunk beneath 
the measured plane determine the radius of the measured hole.

Windows 7 Taskbar Progress Support

For users running Windows 7, support has been added to display 
progress bars in the taskbar.

For more improvements and updates, refer to the SA Readme file.
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SA 2011.12.22

SA 64-bit

The 64-bit version of SA 
is here!

SA 64-bit provides sig-
nificant performance 
improvements (20% 
or more in some cas-
es), and enables han-
dling enormous data 
sets and CAD files. For example, 500 million cloud 
points can be handled comfortably in 64-bit SA on a 
system with 16 GB of RAM.

From the 64-bit version of SA, you can now save .xit files into two for-
mats: .xit, and .xit64. The traditional .xit files can be opened 
by both 32- and 64-bit versions of SA. The .xit64 format can only 
be opened by 64-bit SA, but will maintain all data when saving ex-
tremely large files.

The SA install now contains both a 32-bit version of SA (for compat-
ibility with existing 32-bit systems), and a 64-bit version of SA. Both 
versions are installed by default.

To run the 64-bit version of SA, select it from the Windows Start menu.

Dimensioning

Create dynamic dimensions for lengths and angles 
between any combination of points and objects. 
These dimensions update in real-time as the 
geometry changes. Dimensions can be 
placed to compare against an object’s axis, 
origin, plane, 
or surface, and 
allows you to 
add offsets (for 
inside mea-
surements) or 
subtract them 
(for outside 
measurements).
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SA Remote Update

With the 2011.12.13 update to SA Remote, you can now record mea-
surements while in a watch update mode.

Automatic Drift Check Refitting

The Instrument>Drift Check command now automatically shows what 
your deltas would look like if a refit were performed both keeping 
scale constant and allowing scale to vary.

If a best fit with fixed scale significantly improves the results, that in-
dicates that the instrument has moved relative to your monuments. 
If a best fit with scaling is required, then your reference system has 
scaled, and therefore the part has likely scaled as well.

Two new buttons: Add New Instrument: Transform and Add new In-
strument: Transform and Scale will conveniently add another instru-
ment, activate its interface, and place you into a completed Measure 
Nominals dialog, allowing you to apply a best fit or best fit with vary-
ing scale without measuring any additional points.

Set Viewpoint from Frame

The viewpoint can now be directly set from an existing frame using 
View>View Control>Set Viewpoint From Frame and View>View Control>Set 
Viewpoint From Frame>Clip Behind XY-Plane. The second of the two new 
commands will set up a clipping plane such that everything closer 
than the XY plane is removed from the view. This yields a cross-sec-
tional cut through a surface.
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New MP Commands

For details on these new MP commands, see the MP Command Refer-
ence.

 ■ Instrument Operations>Get Instruments with Observa-
tions on Target. Returns the list of instruments that have ob-
servations on (measurements of ) the specified target.

 ■ View Control>Set Point of View from Frame. Sets the point 
of view to match the orientation of a given coordinate frame, 
optionally clipping the view in front of the frame’s XY plane.

 ■ Analysis Operations>Query Clouds to Objects. Queries one 
or more point clouds to one or more objects, creating point 
groups or vector groups in the process.

 ■ Analysis Operations>Get Geom Relationship Criteria. Re-
trieves the nominal, measured, delta, low tolerance, and high 
tolerance values (as applicable) for a specific geometry rela-
tionship parameter.

 ■ Analysis Operations>Reverse Surface Normals. Reverses 
the normals of specified surfaces.

 ■ Construction Operations>Construct Objects from Surface 
Faces-Runtime Select. Creates a set of primitive geometric 
shapes (planes, cylinders, spheres, cones, lines, points, and cir-
cles) from CAD surfaces selected by the user at runtime.

 ■ Construction Operations>Points and Groups>Construct 
Points from Surface Faces-Runtime Select. Creates points 
from CAD surfaces selected by the user at runtime.

 ■ Construction Operations>Planes>Construct Planes from 
Surface Faces-Runtime Select. Creates planes from CAD sur-
faces selected by the user at runtime.

 ■ Construction Operations>Cylinders>Construct Cylinders 
from Surface Faces-Runtime Select. Creates cylinders from 
CAD surfaces selected by the user at runtime.

 ■ Construction Operations>Spheres>Construct Spheres 
from Surface Faces-Runtime Select. Creates spheres from 
CAD surfaces selected by the user at runtime.

 ■ Construction Operations>Lines>Construct Lines from Sur-
face Faces-Runtime Select. Creates lines from CAD surfaces 
selected by the user at runtime.

 ■ Construction Operations>Cones>Construct Cones from 
Surface Faces-Runtime Select. Creates cones from CAD sur-
faces selected by the user at runtime.
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 ■ Construction Operations>Circles>Construct Circles from 
Surface Faces-Runtime Select. Creates circles from CAD sur-
faces selected by the user at runtime.

 ■ Construction Operations>Polygonized Surfaces>Construct 
Polygonized Surface from Point Clouds. Creates a 
polygonized surface (mesh) from a set of input point clouds. 
This command is the MP equivalent to the Construct>Polygonized 
Mesh>From Point Clouds menu command.

 ■ Construction Operations>Cones>Construct Cone. Creates a 
cone.

 ■ Excel Direct Connect>Run Macro. Runs a macro stored in an 
Excel workbook.

 ■ Excel Direct Connect>Write>Write Picture. Places a picture 
stored in the SA tree into an Excel workbook.

 ■ Utility Operations>Get Tick Count. Returns an approximately 
millisecond-accurate tick count (timer value) of the computer 
clock, in seconds.

 ■ Utility Operations>Scale Objects. Scales a list of objects 
about the working coordinate frame.

 ■ Analysis Operations> Relationship Operations> Relation-
ship Attributes> Make Vector Tolerance. Creates a vector 
tolerance that can be fed into another command, such as Make 
Point to Point Relationship.

 ■ Analysis Operations> Relationship Operations> Relation-
ship Attributes> Make Vector Constraint. Creates a vector 
fit constraint that can be fed into another command, such as 
Make Point to Point Relationship.

Independent Decimal Precision Settings

You can now set independent decimal precision settings for the fol-
lowing different types of values:

 ■ Lengths

 ■ Angles

 ■ Scales

 ■ Unit Vectors

 ■ Weights

Angle Representations

You can now control whether angles are represented in the -180° to 
180° range, or in the 0° to 360° range.
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Measurement Simulation Ranges

When fabricating measurements for a simulation, you can now spec-
ify a distance envelope, measured from the instrument. Any points 
outside of this envelope will not have measurements fabricated.

Vector Groups: Continuous (Entire Range) Color Ranging Method

A new Continuous (Entire Range) color ranging method has been 
added to Vector Groups. This option examines the max and min de-
viations in the vector group and uses this range to span the entire 
color range.

Multiple Frame Sizes

Frames can now be assigned a custom size separate from the default 
frame size in the User Options. This is useful when different sized fea-
tures have separate coordinate frames, and you want the coordinate 
frames to be similar to the scale of the features.

Printing Invisibility

Right-click an object in an SA Report and toggle the printing invis-
ibility option to prevent the item from appearing in printed reports.

Relationship Reporting Details

Relationship summaries in the tree, report bar, and SA reports now 
contain additional reporting details, including:

 ■ Subsampling

 ■ Constraints

 ■ Outlier rejection

 ■ Ignored edge projections

 ■ Overridden target offsets

 ■ Added material thickness
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Relationship Minimization Context Menu

You can now minimize relationships by right-clicking any relation-
ship category in the tree and selecting the desired command from 
the context menu.

MP Watcher

An option has been added to automatically show the MP Watcher 
when an MP breakpoint is hit. This option can be enabled in the User 
Options>Automation tab.

Geometry Fitting: Object Association

If all measurements used in a fit are associated with a single instru-
ment, then the resulting geometry is now also associated with the 
instrument (does not apply to cloud points).

Geometry Relationships: Cardinal Points

Fit only and Fit & Compare to Nominal Relationships now have a set-
ting to enable the creation of dynamically updated cardinal points for 
the fit.

Hexagon SE Absolute Arms with CMS and Perceptron v5 Shark Scanners

Support has been added for Perceptron v5 Shark and CMS scanners 
for use with Hexagon Absolute SE arms. Once set up in RDS Control 
Panel, both will act like integrated scanners. Just mount the scanner, 
switch it on, and go.

For additional improvements, changes, and fixes, refer to the SA Re-
adme file.
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SA Packages
SA is available in three forms: SA Professional, SA Ultimate, and SA 
Machine. The details of the functionality provided in each of these 
packages in provided below.

SA Professional

SA Professional with Native CAD is the professional measurement, 
alignment, inspection, analysis, and reporting software for all porta-
ble metrology instruments. In addition to all essential measurement 
needs, it includes several key inspection features, geometry inspec-
tion, and measurement automation.

MEASUREMENT
SA Professional offers 100% traceability from measurement to report-
ing. All measurement data is stored alongside time stamps, instru-
ment information, weather data, and other measurement parame-
ters. Log files track user actions, fit results, and more, allowing you to 
see the entire history of the job file.

ALIGNMENT
An essential part of the measurement process is the alignment of 

You are about to start your journey toward learning the 
world’s most powerful portable metrology software 
package. But you can’t take the first step until the soft-
ware’s installed!

Getting Started
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measurements to a known coordinate system. SA Professional in-
cludes a variety of alignment methods ranging from traditional 3-2-1 
alignments to more advanced surface fits.

BUILD
The Relationship functionality offers an easy way to calculate and ob-
serve part deviation. Relationships are dynamic in nature and update 
automatically if part alignment or data changes.

EVALUATION & ANALYSIS
A user-friendly interface permits both graphical and numerical de-
piction of measurement uncertainty, enhancing your perspective of 
measurement quality.

REPORTING
SA Professional offers quick, user-friendly reporting functionality. 
Quick Reports are ideal for on-location reporting, report templates 
are perfect for repetitive work, and the Report Designer allows you to 
drag and drop items to develop custom reports using tables, charts, 
and graphics.

GD&T INSPECTION
GD&T allows you to import CAD with GD&T annotations, create an-
notations manually, and inspect to GD&T standards with real-time 
reporting.

GEOMETRY INSPECTION
Geometry inspection enables you to define design-based inspection 
routines from a CAD model or primitive geometry.

NATIVE CAD
Native CAD provides import support for such major applications as 
CATIA V4, V5, Pro/Engineer, SolidWorks, Unigraphics, and other CAD 
formats.

SA Ultimate

SA Ultimate is the premier measurement, optimization, analysis, re-
porting, and automation software suite for all portable instruments. It 
includes everything contained in SA Professional, plus the following 
features:

REAL-TIME ALIGNMENT
Transformation Tracking allows you to track moving parts in real-time 
so that you can monitor a part’s position as it is guided into place.

ADVANCED FIT OPTIMIZATION
Relationship minimization provides the power necessary for ad-
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vanced alignments and can help bring an out-of-tolerance part back 
within tolerance. You can also define fit envelopes to satisfy multiple 
constraints/requirements.

COMPLEX INSTRUMENT NETWORKS
USMN is an extremely powerful feature that leverages the uncertainty 
characteristics of different instruments to provide a much more accu-
rate instrument network than that of traditional alignment methods. 
It is used by many metrology groups to solve large-scale networks 
such as accelerator rings, full submarine surveys, and large machinery 
analysis.

AUTOMATION
The Measurement Plan and SA SDK functions can add a significant 
layer of automation to your processes.

Generating simple to complex scripts can greatly improve workflow 
and productivity, reducing analysis time from days to minutes while 
eliminating errors and saving significant resources.

PIPE FITTING
The Pipe Fitting function is used in large piping applications when 
precision cuts must be determined.

Precision measurements and optimization greatly improve accuracy, 
ultimately reducing the cost of rework.

DATABASE OUTPUT
Database output is an additional reporting feature that gives you the 
ability to transfer SA data to databases and track projects/data long-
term.

SA Machine

SA Machine with Native CAD contains all features of SA Ultimate, but 
also allows users to interface with robots and CNC machines. This 
permits calibration and real-time compensation of robots and large-
volume CNC machines to high degrees of accuracy. It also enables 
robotic scripting, teach pendant behavior, and linear or joint space 
robotic control.
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Feature Summary

Features SA Professional SA Ultimate SA Machine

Measurement:

Traceability

Simultaneous Instrument Interfacing

Over 120 Supported Instruments

Alignment:

Best Fit

Feature Based

Points to Surfaces

Standard Instrument Network Bundle

Relationship Fitting

Advanced Network Optimization (USMN)

Inspection:

Geometric Dimensioning & Tolerancing

Geometry Inspection

Build:

Relationships

Watch Windows

Transformation Tracking & Guiding

Evaluation & Analysis:

Queries

Spatial Transformations

Robust Fit Algorithms (NIST & PTB Certi-
fied)

Measurement Uncertainty Analysis

Relationship Optimization (independent-
ly moving objects)

Reverse Engineering

CAD Interface:

Standard CAD Exchange (IGES, STEP, etc.)

Native CAD Access (CATIA, ProE, NX, etc.)

Automation:

Automatic Measurement

Measurement Plan Scripting

Software Development Kit (SDK)

SA Reporting:

Standard Output (Excel, Word, PDF, Text)

Graphical Callout Annotations
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Features SA Professional SA Ultimate SA Machine

Quick Reports

Drag & Drop Reporting

Database Output (ODBC)

Pipe Fitting:

Pipe Cut Optimization

Robotics:

Kinematic Modeling

Kinematic Calibration

Direct Motion Control

Graphical Simulation

System Requirements
SpatialAnalyzer is capable of running on most modern computing 
platforms, both 32 and 64-bit.

Minimum Requirements

Microsoft  Windows XP™ SP3 or later.

512 MB system RAM

560 MB free disk space for installation (more for your data files)

1024 x 768 screen resolution

Microsoft .NET 4.0 Runtime (if using the Laser Radar Interface)

Recommendations for Optimal Performance

3 GHz or faster Dual-Core 64-bit processor

Windows 7™  (64-bit)

8 GB system RAM (64-bit systems)

1280x1024 or higher screen resolution

Hardware-accelerated graphics card supporting OpenGL®

1 GB of free hard disk space

Supported Auxiliary Input Devices

3DConnexion®  SpaceNavigator™  (USB)

3DConnexion®  SpaceExplorer™  (USB)

3DConnexion®  SpacePilot™  (USB)
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3DConnexion®  SpacePilot™  PRO (USB)

Check My Computer

SA provides a utility named Check My Computer that detects certain 
system configuration issues that may result in errors or problems 
while running SA. While this tool does not detect all issues—and while 
some checks may fail even though you never experience problems in 
SA—this is a useful diagnostic tool to use when you do encounter a 
problem. This tool does the following:

 ■ Checks for certain problematic software known to interfere 
with certain aspects of SA operation.

 ■ Verifies that a default printer is installed.

 ■ Checks for TCP/IP availability (a network interface).

 ■ Checks firewall settings.

 ■ Ensures that your computer’s network interface provides sup-
port for UDP broadcasting.

 ■ Ensures that your computer’s network interface provides sup-
port for socket communication and that it is not blocked.

 ■ Checks your User Account Control settings (Windows 7 and 
later) to ensure they’re not set too high.

 ■ Provides convenient access to system information and network 
configuration settings.

If you encounter an issue running SA, it is recommended to run this 
utility to check for problems and to contact support if necessary to 
find a resolution.

To Run the Check My Computer Utility

 ■ From SA, Select Help>Check My Computer, or

 ■ From the Windows Start menu, in the SA install folder, select 
the Check My Computer entry.

 ■ In the Main toolbar, click the SA Network icon.

Installation

Installing SA

The SA Installer will guide you through installing the following:

 ■ SpatialAnalyzer™ Application

 ■ Documentation (this document)

 ■ Hardware lock driver
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The installer is included with your provided USB flash drive and is also 
available for download at www.kinematics.com/download.

To Install SpatialAnalyzer:

1. Double-click SpatialAnalyzer 2014.XX.XX-Install-
er.exe.

2. Choose a destination folder (the default folder is usually pref-
erable), then click Next.

3. Leave both components (hardware driver & SA application) 
checked unless you have a specific reason to deselect a com-
ponent. (For instance, if you are an OEM running a software 
lock, you would not need to install the Sentinel Hardware 
Driver).  Click Next.

4. Choose additional install options.  The Check My Computer 
utility will check your system for some common configuration 
issues that often cause problems with instrument communi-
cation in SA.  When done selecting options, click Install.

SA is continuously updated with improvements and new features, 
and new beta releases are posted frequently. If your maintenance 
supports upgrading, you are encouraged to download the latest ver-
sion and explore the newest functionality.

Installer Command-Line Options

The SA Installer supports several command-line options. These are 
typically most useful for IT departments that wish to do a silent or 
automated install. The most command-line options can be combined 
and are as follows:

 ■ /?. Lists the command line options.

 ■ /S. Performs a silent install (this must be a CAPTIAL S). The in-
staller will operate in the background with no user interven-
tion.

 ■ /CREATESHORTCUT. Creates a desktop shortcut when run in 
silent mode.

 ■ /TEMPUNITS=[Celsius, Fahrenheit]. Sets the default temper-
ature units for the install. If omitted, Fahrenheit will be used as a 
default, unless SA was installed previously, in which the temper-
ature units will not change. Ex. usage: /TEMPUNITS=Celsius.

 ■ /LENGTHUNITS=[Inches, Feet, Millimeters, Centimeters, 
Meters]. Sets the default length units for the install. If omitted, 
inches will be used as a default, unless SA was installed previ-
ously, in which the length units will not change. Ex. usage: /
LENGTHUNITS=Millimeters.

Note:  Updated SA versions 
may require a new version of 

the hardware lock driver, so it is 
best to leave that option 
checked.  Older drivers will be up-
dated, if necessary.

http://www.kinematics.com/download
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To Install SA with Command-Line Options:

 ■ At the command line, follow the executable name with the 
options. For instance, the following installs SpatialAnalyzer si-
lently in the background while also creating a desktop shortcut 
and setting the length units to millimeters: SpatialAnalyz-
er 2014.XX.XX-Installer.exe /S /CREATESHORTCUT 
/LENGTHUNITS=Millimeters

To Check for SA Updates:

 ■ Select Help>Check for SA Updates,

 ■ Choose Help>SpatialAnalyzer License Management>View Maintenance 
Support and Subscription Status, then click the Check for Updates 
button, or

 ■ Navigate to http://www.kinematics.com/products/spatialana-
lyzer/download-software.html.

Instrument Drivers

Most portable measurement devices (instruments) require a driver 
to be installed in order to properly communicate with SpatialAnalyz-
er.  When configuring a new instrument, it is always best to follow the 
instrument manufacturer’s recommended installation procedure and 
to install their software components/drivers as provided by the hard-
ware manufacturer.  However, the minimum drivers required for com-
municating with SA for most supported instruments are provided in 
a single bundled instrument driver installer provided by NRK.  This in-
staller is included with the provided USB flash drive and is also avail-
able for download at www.kinematics.com/download.

You can also locate drivers for your instrument on NRK’s FTP site at 
ftp://ftp.kinematics.com/pub/SA/Install/Driver Downloads/.

To Install Instrument Drivers using the Bundled Instrument Driver Installer:

1. Double-click SA Instrument Mfg Drivers.exe.

2. Select the desired instrument drivers to install and click Next.

3. You will be guided through the installation for the selected 
instruments.  Note that the installers are usually provided by 
the hardware manufacturers, and each one is different.  Con-
tact NRK if you have problems while installing.

Licensing
Your SpatialAnalyzer license is controlled by a USB hardware lock. The 
hardware lock and driver must be installed before using SpatialAna-
lyzer.  The driver is installed by default as part of the SA install.

http://www.kinematics.com/products/spatialanalyzer/download-software.html
http://www.kinematics.com/products/spatialanalyzer/download-software.html
http://www.kinematics.com/download
ftp://ftp.kinematics.com/pub/SA/Install/Driver Downloads/
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Meta-key File Installation

Meta-key files (extension .met) are used to upgrade or extend a li-
cense. They are small encrypted files that the software opens and 
uses to enable additional capability in your license. Normally, a new 
user with a hardware lock will have no need for a meta-key. However, 
if software licensing is extended or renewed, a user may receive a 
meta-key to extend the license for an additional period of time. By 
placing this meta-key file in the Analyzer Data\License directory, 
the hardware lock can be upgraded. When the file is present in the Li-
cense folder, it supersedes the information that has been hard-coded 
onto the hardware lock.

Meta-keys have filenames like License12345.met, where the 5-dig-
it number matches the serial number on the key.

To install an SA Meta-key File:

1. Double-click the .mez file you received from NRK and SA will 
automatically install it.

2. Ensure that the hardware lock with the matching serial num-
ber is installed in the USB port.

3. Run SpatialAnalyzer.

4. Choose the Help>SpatialAnalyzer License Management>View Current 
License Information menu option to verify your license.

Viewing Your License Information

Occasionally—particularly when contacting customer support—it 
may be necessary to examine the details of your SpatialAnalyzer li-
cense, such as the serial number, user and company, upgrade date, 
and available software components. You can  view the details of the 
current license in use at any time.

To View the Current License Information

1. From the SA menu, select Help>SpatialAnalyzer License 
Management>View Current License Information.

2. A window will be displayed showing your license details, and 
this text will be automatically copied to the Windows clip-
board.

A Closer Look
When SA starts up, it first looks for a hardware lock.  It retrieves the license information and 
serial number from the hardware lock, then checks your Analyzer Data\License folder 
to see if there is a meta-key file matching the hardware key’s serial number.  If found, it uses 
the meta-key file to update the license information from the lock.

You may also wish to view your maintenance subscription informa-

Note:  If a hardware lock is 
moved to a different com-

puter, the meta-key file must be 
transferred with it by copying the 
file into the new computer’s Ana-
lyzer Data\License fold-
er. Failure to do this will result in 
the hardware lock reverting to its 
original license settings.
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tion, which will indicate the date software maintenance will expire.

To View Your Maintenance Subscription Information:

 ■ From the menu, select Help > SpatialAnalyzer License Management > 
View Maintenance and Support Subscription Status.

To Request Renewal for Your Maintenance and Support Subscription:

 ■ Select Help > SpatialAnalyzer License Management > Request Mainte-
nance and Support Renewal, or

 ■ Choose Help > SpatialAnalyzer License Management > View Maintenance 
and Support Subscription Status, then click the Request Upgrade/Re-
newal button.

Certification
SpatialAnalyzer has been certified by the National Institute of Stan-
dards and Technology (NIST), the Physikalisch-Technische Bunde-
sanstalt (PTB), and the National Physical Laboratory (NPL).

How to Get Help

Documentation

If you need help, the easiest source of information is the SA User 
Manual (this document). This document is in PDF format and is fully 
searchable.

To Access the SpatialAnalyzer User Manual:

Do one of the following:

Click the User Manual icon in the Main Toolbar,

Select Help>User Manual, or

In the Windows Start Menu, navigate to the SA install folder, then the 
Documentation subfolder, and select the SpatialAnalyzer User 
Manual link.

Every SA Release has a complete Readme file documenting every 
change to the software, organized by software version. This is often 
a useful source of information, particularly with determining instru-
ment driver compatibility with a given SA version.

To View the SA Readme File:

 ■ Select Help>View the SA Read Me File, or

 ■ From the Windows Start Menu, navigate to the SA install folder, 
then the Documentation subfolder, and select the Release 
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Notes link.

Customer Support

If you need help setting up or using SpatialAnalyzer, there are several 
ways that you can reach customer support:

 ■ E-mail. support@kinematics.com

 ■ Telephone. Dial +1 (757) 565-1500 and choose the support 
option (option 1). Be aware that this will transfer you directly to 
a voice mailbox, but your call will be returned promptly.

 ■ Web. Navigate to www.kinematics.com and choose the sup-
port link, or from within SA, select Help>Visit NRK Website!

Regardless of how you contact us, we try to respond to all support 
requests in less than 24 hours.

Context-Sensitive Help

SA has a context-sensitive help system wherein you can click on menu 
items, interface components, or select dialogs in order to be directed 
to that topic in this User Manual.

To Initiate Context-Sensitive Help:

1. In SA, press Shift + F1. The mouse cursor icon will change
to indicate that you are now in context-sensitive help 

mode.

2. Click on a menu item, toolbar item, or interface item to be 
directed to the topic in the user manual.

Some dialogs have a question mark in their upper-right corner. Click 
this question mark to be directed to the appropriate topic in the doc-
umentation.

Tutorials & Sample Files

SA comes with a variety of sample files to demonstrate some of the 
key features of SA. Most of these sample files are used in the Tutorials 
chapter toward the end of this manual.

To Open a Sample File:

From the menu, select Help>Open Sample SA Files.

Tip:  We recommend against 
contacting support person-

nel directly via their e-mail ad-
dress or phone number.  Doing so 
may result in a delayed support 
response, as the support individ-
ual may be out of the office or 
otherwise unreachable.

mailto:support%40kinematics.com?subject=Customer%20Support%20Question
http://www.kinematics.com
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Architecture
SA has been designed from the ground up with a very decentral-
ized concept of operation. That is, the software’s various parts do not 
necessarily need to be running on the same computer. Because of 
its network architecture, SA is able to communicate with its various 
instrument interfaces via the TCP/IP network protocol, which permits 
a number of interesting capabilities. In addition, instruments them-
selves can communicate to SA through a wide array of protocols/
interfaces, including TCP/IP, Serial RS-232, Bluetooth, and USB. Each 
method requires that the settings be configured to allow proper com-
munication between SA and the instrument(s).

Figure 4-1. The components 
involved in measuring with an 
instrument in SA. From left to 
right: the Host (SpatialAnalyzer 
itself ), the Interface, and the 
Instrument.

There are three main components to an SA configuration: The host 

It is important to have a good understanding of SA’s 
“modus operandi”. Having a good fundamental under-
standing of how SA operates will prove to be extremely 
useful and will make you a more effective user of the 
software. In this section, we’ll describe some of the fun-
damental principles surrounding SA and its use.

SA Fundamentals
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SpatialAnalyzer session, the instrument interface, and the instrument 
(see Figure 4-1).

Host SpatialAnalyzer Session

The host SpatialAnalyzer session is an instance of SA running on a 
computer that will be the destination for measured data. While it is 
usually the same computer as the one running the instrument inter-
face (see Figure 4-2), it can be any computer that is connected via 
TCP/IP on the local network to the computer running the instrument 
interface (see Figure 4-3).

Figure 4-2. A host SA session 
and an instrument interface 
running on the same computer.

The flexibility provided by the separation of host, interface, and in-
strument means that you can run multiple instruments and interfaces 
all in the same SA job.

Figure 4-3. A host SA session 
and an instrument interface 
running on different comput-
ers.

Instrument Interface

The instrument interface is the application that directly connects with 
an instrument, “speaks the instrument’s language”, and directs mea-
sured data to the host SA session. When starting the instrument in-
terface, you must choose which SA session will be the destination for 
measured data--if multiple computers on a network are all running 
SA, any one of them could have measured data sent to it. If not on the 
same computer, the host SA session should be located on the same 
network as the instrument interface. You must also define how the 
interface should connect with the instrument. (For example, which 
COM port, or using which IP address?)

There are two primary requirements in order to start up an instru-
ment interface:
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 ■ In order for a host SA session to be a destination for measured 
data, you must add the appropriate instrument to the job file 
on the SA host, and it must be discoverable on the network.

 ■ In order to connect to the instrument, the interface must be 
able to communicate with it: Either directly via an interface 
such as USB or Bluetooth, or via a network using TCP/IP.

A single instrument interface can connect to only one SA host session 
and only one instrument at a time. However, any one computer may 
run multiple instrument interfaces (connected to different instru-
ments) at the same time.

The instrument interface is the mediator between the SA host and 
the instrument. The interface sends commands to the instrument to 
control its behavior, and the instrument sends data and state infor-
mation back to the interface. The interface then grooms this data as 
necessary and sends it on to the SA host.

Instruments

Each instrument must be able to communicate with its respective in-
strument interface, and therefore must be set up correctly to talk to 
the computer running the interface. This is handled in a number of 
ways depending on the method that the instrument uses to connect 
to the computer. Detailed information on the proper setup for instru-
ments using each communication protocol is found in the Instrument 
Interfaces section.

The following graphics illustrate just a few of the many possible ways 
to connect instruments with SpatialAnalyzer.

Figure 4-4. A single computer 
connected directly to an instru-
ment via TCP/IP. This is the most 
common setup.

In Figure 4-4, since the instrument is connected directly to the host 
computer via a network cable and the TCP/IP protocol, no other com-
munication hardware is required. The interface runs on the same 
computer as the host SA session. This is the most common way to 
connect in SA.
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Figure 4-5. Two computers 
connected directly to the host 
computer: One via USB, the 
other via TCP/IP.

In Figure 4-5, one instrument is connected via USB, and the other 
through TCP/IP. The instruments are connected directly to the same 
computer on which the instrument interfaces and the host SA session 
are running. Only one instrument might be running at a time, or two 
instrument interfaces might be running simultaneously in a single 
session of SA.

Figure 4-6. Multiple instru-
ments and computers on a 
local network connected via 
TCP/IP and an ethernet switch. 
The interfaces may be running 
on a different computer than 
the host.

With this configuration (Figure 4-7), a connection to the internet is 
not used. Instead, one or more instruments and one or more comput-
ers are connected to a local network through a network hub or switch 
(and the TCP/IP protocol). One SA host computer may be running in-
strument interfaces for all instruments, or the interfaces may be run 
on separate networked computers. Or, three instances of SA might be 
running on three different computers to control the three different 
instruments.

While the configuration in Figure 4-7 is rare, it is technically possible. 
In this case, an instrument is connected via TCP/IP over the internet to 
an instrument interface, perhaps on the other side of the world. The 
interface then connects to the SA host via the local network. As long 
as you can ping the desired instrument from the computer running 
the instrument interface, you can connect to it.
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As you can see, the networked architecture of SA lends immense flex-
ibility to the way that you measure and operate on data. With this set-
up, it is possible for an operator in a metrology office to control a laser 
radar hanging from a gantry crane in a facility on the other side of the 
world. Or, one workstation might be set up to receive measurement 
data, and three operators with laptops might measure data with their 
own instruments and send it to the receiving workstation.

Figure 4-7. Networked 
configuration. Instrument and 
interface connected via TCP/IP 
over the internet, and the host 
SA session is connected to the 
interface via a local network.

While there are many different configurations and possibilities, most 
users end up with one of the first three configurations illustrated 
above.

Selection Filtering
In any SA file, there are four main types of entities. Three of them have 
a represented position in space (that is —they have a position and, 
with the exception of points, an orientation), and the fourth encom-
passes everything else. These entity types are described below:

 ■ Points. This includes measured points (recorded by an instru-
ment) and constructed points (created via any other method).

 ■ Instruments. This includes only measurement instruments.

 ■ Objects. Anything that has a position and orientation in space 
that is not a point or instrument is an object. This includes 
entities such as lines, point groups, vector groups, cylinders, 
spheres, planes, surfaces, and point clouds.

 ■ Other. Anything that is not a point, object, or instrument. For 
example, relationships, Measurement Plans, scale bars, charts, 
and vector groups.

Knowing these four entity types is important, because most com-
mands in SA are filtered for the proper entity type. For instance, the 
Edit>Delete Objects command only allows selection of objects—at-
tempting to select a point will choose its parent point group instead 
(because a point is not an object, but a point group is).



120

SPATIALANALYZER USER MANUAL

Double Colon Format
When referring to an entity in your SA file, it is important to know 
where it is organized in your job file. For instance, in what collection  
is a specific surface located?

You will notice a specific syntax used in SA in various dialogs to de-
scribe the organizational location of an item in SA. A specific point is 
referred to by listing its containing collection, enclosing point group, 
and target name separated by pairs of colons, which act as separators:

Measured::Tie-Ins::3

This is an unambiguous reference to the point named 3 in the point 
group named Tie-Ins, which is inside the collection named Mea-
sured.

Objects and other entities have a similar syntax, but only the collec-
tion and entity name are used:

Nominal::Centerline

This name refers to an object named Centerline inside the Nomi-
nal collection.

Instruments are referred to by their instrument index number. An in-
strument index number is a unique number that is assigned to each 
instrument in a given collection. The first instrument added to a col-
lection becomes instrument index number 0, the second is 1, and 
so on. When an instrument is moved from one collection to another, 
its index number changes. If the fourth instrument in collection A is 
moved to collection B, and there are already 2 instruments in collec-
tion B, the instrument will change from index number 3 in the old 
collection to index number 2 in the new collection.

The syntax for instruments is similar to that for objects, except instead 
of using an object name, the instrument index number is used in-
stead:

ThisCollection::1

This name refers to the second instrument in the ThisCollection 
collection. Sometimes, you will also see this syntax with the instru-
ment name at the end, such as

ThisCollection::1 - Zeiss ETh 2 Theodolite

The double colon syntax is used in several places in SA—for example, 
when displaying full point names or instrument names in the graphi-
cal view, when viewing an instrument interface, or when working in 
Measurement Plan scripts.
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The Wire Model
One of the most important things to keep in mind when working in 
SA is that measurements are linked and tied directly to the instru-
ment that measured them. If you move an instrument (using 
Instrument>Drag Instruments Graphically) from one area of the SA work-
space (Figure 4-8) to another (Figure 4-9), you will find that all of the 

Figure 4-8. An instrument has 
measured the surface of this 
part. Prior to alignment, the 
measured points are not yet 
located to the CAD surfaces.

targets that were measured by that instrument also move along with 
it. You can think of each of the measured points as having a straight 
piece of wire between the instrument and the measurement—the in-
strument and its measurements move together as a rigid body.

Figure 4-9. After alignment, 
the points are aligned to the 
CAD surface. Here, the instru-
ment was moved. The points 
just “came along for the ride”.

This behavior has a number of important benefits, and if you stop to 
think about it, the behavior most accurately reflects reality. When a 
measurement is recorded, the instrument provides to SA the position 
of the probe relative to the instrument’s reference system. For spheri-
cal measurement devices such as total stations, laser trackers, and la-
ser radars, this consists of a horizontal and vertical angle and a dis-
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tance component. These three values indicate where the point is 
located relative to the instrument’s reference--usually its optical cen-
ter. The only thing the instrument knows about the measurement is 
the location of that measurement relative to itself—it (typically) 
knows nothing about where the measurement is located in the real 
world.

The link between the position of the instrument and the position of 
the measurement (relative to the instrument) should really never be 
broken, because if the two were to become disassociated relative to 
each other, then the value of the measurement is lost. That is, its posi-
tion (and therefore the measurement) becomes meaningless to us. 
Therefore, it makes sense that SA maintains and keeps track of this 
relationship.

The Alignment Process
Tied to the association between the instrument and its measurements 
is the idea of alignment. Alignment is really the process of positioning 
the digital instrument in the SA file until it ends up in the same cor-
responding position as the instrument in the real world. For example, 
Figure 4-8 shows an instrument and its measurements prior to align-
ment, and Figure 4-9 shows that same instrument after alignment. In 
both cases, the only thing that was moved was the instrument—the 
measurements merely moved as a result of being rigidly tied to the 
instrument. Put another way, the measurements “came along for the 
ride”.

As long as a reference system is measured to properly perform an 
alignment at some later time, alignment is not required to be per-
formed as one of the first steps in the measurement process. If align-
ment to CAD surfaces or other instruments is not required, then there 
is no need to perform any alignment at all.

You can measure features on a part, measure a reference system, 
move the instrument, measure more features and the reference sys-
tem, and then measure again from a third perspective, all without 
once performing an alignment. Only when the analysis is performed 
are the instruments required to be aligned (so that you can extract 
meaningful information from the data). As a result, you can measure 
everything on the shop floor and perform the alignment at your desk 
at the end of the day.

Note:  If you are performing 
a build operation or need 

on-the-spot comparison of mea-
surements to CAD or to your refer-
ence system, then the alignment 
must be performed at that time.
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Feature Measurement
One important general rule to follow in SA is that each feature should 
be measured into its own point group when possible (see Figure 
4-10). One intended meaning for the term feature in this case is a spe-
cific portion of a measured part. For instance, measurements on the 
inside of a hole should go into one group, measurements of the top 
surface of the part should go into another, and measurements of the 
side of the part should go into a third. But another intended meaning 
of feature in this context is to refer to any set of related points. So, for 
instance, all points in a drift check should be measured into their own 
point group, and the reference points (fiducials) should be measured 
into another.

Figure 4-10. Proper feature-
based organization of point 
groups. Measurements for each 
individual feature on this part 
are organized into separate 
point groups.

SA is designed around the assumption that features are measured 
into their own individual point groups. If you follow this rule, you will 
find that working in SA becomes much easier and more intuitive. The 
only time when this rule does not apply is when measuring with the-
odolites. Since theodolite measurement requires at least two obser-
vations to calculate a target position, each observation of a given tar-
get should be measured under the same point.

Offset Compensation
When storing measurements, SA always records the point represent-
ing the center of the probe (SMR, ruby tip, etc). Unless non-contact or 
zero-offset measurement is being performed (such as measurement 
with a laser radar, scanner, point probe, or photogrammetry), the re-
corded point will not represent the point where the probe touched 
the measured surface, but instead will be at its center (see Figure 
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4-11). (For zero-offset measurement, the recorded point is at the 
point of contact). What this means, of course, is that the distance be-
tween the measured point and the measured surface is not zero, but 
is instead equal to the probe radius (also known as the planar offset).

In order to properly compensate for probe offsets, two values must be 
known: the probe offset, and the surface direction. These two proper-
ties are discussed in the following sections.

Figure 4-11. The recorded 
point for any measurement is 
always at the probe center.

Recorded PointProbe

Probe Offsets

When a measurement is recorded, SA stores not only the probe cen-
ter point, but also the corresponding offsets. There are actually two 
offsets used: a planar offset and a radial offset. The planar offset is an 
offset perpendicular (or normal) to the resulting geometry, whereas 
the radial offset is an offset in the plane of the geometry.

The planar offset is used to offset the measured point toward a sur-
face, line, or curve. The radial offset is used to offset measurements in-
ward or outward when measuring or fitting circles and ellipses using 
tooling that introduces a radial offset, such as a pin nest (see Figure 
4-12).

Figure 4-12. The radial offset 
is used for shifting measure-
ments inward or outward when 
using a pin nest.

Radial O�set

Hole Edges
Probe O�set

Pin Nest O�set

If just a spherical probe is used (such as a ruby tip or an SMR), the ra-
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dial offset is ignored (it is never used). If additional target tooling is 
used—such as the pin nest in Figure 4-12, the offsets attributable to 
the additional tooling are included in the point’s offset. For instance, 
the pin nest pictured introduces 0.25” of additional planar offset and 
0.125” of radial offset on top of the SMR’s 0.75” planar offset. This 
yields a total planar offset of 1.0” and a total radial offset of 0.125”.

Whenever a measured point is compared to an object such as a CAD 
surface, line, or curve, probe offset compensation is automatically ap-
plied, and the reported deviation is actually the deviation between 
the point of contact and the corresponding closest point on the ob-
ject of interest. Likewise, whenever geometry is created from mea-
sured points, the resulting geometry is automatically offset from the 
measured points, and the resulting geometry represents the surface 
actually measured.

Obviously, in order for SA to compensate for offsets correctly, the cor-
rect offsets must be stored with the measured points. Offsets should 
be set in the appropriate instrument interface whenever target tool-
ing is changed, and as a result measured points should have the cor-
rect offsets as they are measured. However, if you forget to set the 
proper offsets when measuring, you can always correct them after 
the fact by changing the offsets on measured points. (More informa-
tion on this can be found in the Measurement section).

Surface Normal Direction

In addition to having the proper stored offsets, one additional factor 
is required to be correct in order to perform a properly compensated 
analysis: it is critical that the direction of the surface normals being 
used in any comparison are facing the proper direction. Consider the 
example in Figure 4-13, in which four measurements were taken with 
an SMR at four positions on a measured surface (the blue dashed sur-
face in the illustration). Note that, for clarity, the as-built error in the 
measured surface is greatly exaggerated here.

Figure 4-13. Proper offset 
compensation is applied when 
the surface normal faces the 
side to be measured.

Surface
Normal

Nominal Surface

Measured Surface

Suppose we wish to compare our measurements to the nominal CAD 
part in order to determine whether the as-built part is “high” or “low” 
of the ideal design. When comparing the measured point to the nom-
inal surface, SA first calculates the deviation from the nominal surface 
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to the recorded point (the purple vector), and then adds the probe 
offset in the direction opposite to the surface normal (the red vector 
in the illustration). The resulting vector (green) indicates the devia-
tion between the measured surface and the nominal surface. In this 
example, the first three measurements are low of nominal, and the 
last measurement is high of nominal.

To visualize how an incorrect surface normal direction can result in 
incorrect results, suppose that the surface normal in Figure 4-13 is 
accidentally reversed and is now facing the wrong direction (Figure 
4-14), with all else being the same. The deviation from the nominal 
surface to the measured point stays the same (purple vector). Again, 
SA adds the probe offset in the direction opposite to the surface nor-
mal, but since the surface normal is facing the wrong direction, the 
offset compensation is performed in the wrong direction. As a result 
(green vectors), the reported deviation is off by exactly the probe di-
ameter—a very large error!

Figure 4-14. Offset compen-
sation applied when a surface’s 
normal is facing the wrong 
direction. This will result in 
incorrect results! Surface

Normal

Nominal Surface

Measured Surface

This behavior leads to a golden rule in SA—one that is referred to in 
various places in the SA dialogs. The rule is that in order for deviations 
to be reported properly, all surface normals must face the side being 
measured. Put another way, the surface normal direction for the sur-
faces being compared should point to the side from which you’re ap-
proaching the part with the probe (the other direction should point 
into the part’s “material”).

There is one simple way to ensure that you comply with this rule: 
When working with surfaces, you want to ensure that the normals all 
point toward the “outside” of the object—that is, they should point 
away from the material of the part. If you imagine that your CAD part 
is submerged in the ocean, the surface normals should point to the 
side where the water is touching the surface. Upon importing CAD to 
be used in analysis, one of your first steps should be to ensure that the 
surface normal directions are all correct, and to correct any normals 
that point inward.

For information on identifying surfaces whose normals are facing the 
wrong direction, see the Surface Backsides section in “The Graphical 
View”.

Warning:  If surface nor-
mals are facing the wrong 
direction, the calculated 

deviation will typically be in error 
by exactly the probe diameter.

Warning:  If stored target 
offsets are incorrect, the 
calculated deviation (or 

the location of geometry result-
ing from a geometry fit) will be 
incorrect.
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Comparing Measurements to Points and Objects
The fact that SA automatically compensates for probe offsets results 
in a few rules that should be kept in mind when performing compari-
sons between measured points, objects, and surfaces:

 ■ When comparisons between points are performed, the com-
parison is always between centers. Point to point deltas and 
best-fits, for example, always compare center to center. This 
leads to a corollary that if two separate points are to represent 
the same point in space (such as for a reference monument), 
their centers should be coincident. This might seem obvious, 
but if the same point is measured twice with probes that have 
different offsets, a physical target adapter is required to make 
one of the offsets match the other.

 ■ When comparisons between points and objects or surfaces 
are performed, the comparison automatically compensates for 
probe offset.

There are a few cases where you will want to override this behavior 
and ignore offsets, however.

Figure 4-15. Comparing a 
measured point with 3/4” offset 
to a line.

dMag=0.75”

0.75”

For example, suppose a measured point with a 3/4” offset lies directly 
on a line. This would appear in SA as indicated at left in Figure 4-15. A 
normal comparison between the point and the line will indicate a de-
viation of 0.75” as depicted at right, because offset compensation is 
being applied. That is, you are 0.75” from touching the line. Typically, 
however, in this situation you want to compare the center of the 
probe to the axis. For instance, perhaps you’ve set the probe in a hole 
to take a measurement, and you want to compare the measurement 
to the nominal hole center. In that case, you’ll want to ignore the off-
set so that this situation would indicate a deviation of zero. There are 
several ways to do this in SA, including overriding target offsets to 
zero or using commands that specifically ignore offsets.
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Measured Points vs. Cloud Points
It is important to understand the distinction between measured 
points and cloud points, and to know when it is more appropriate to 
use one instead of the other when taking measurements. Both points 
and clouds are discussed in more detail in later chapters—however 
in this section we will discuss the broad differences between the two 
entities.

Measured points carry with them a relatively large amount of over-
head. They are not simply an XYZ coordinate with a name, but ac-
tually store quite a bit of information. As described in “Traceability” 
on page 130, measured points store metadata in addition to the 
measurement itself and its offsets. Weather parameters (temperature, 
pressure, and humidity), RMS data, measurement mode informa-
tion, timestamps, and other information are all stored with a point 
for traceability and documentation purposes. While this information 
is useful and great to have, it also means that a measured point puts 
a relatively large strain on the data processing and computing capa-
bilities of the machine. Storing and handling that wealth of data can 
become relatively stressful on a computer’s resources if there is a very 
large number of points.

Cloud points, on the other hand, are designed for very large quanti-
ties of measurements and are optimized to be much more lightweight 
from a computer resources perspective. Cloud points only store an 
XYZ value. They have no metadata and no individual names or offsets, 
and therefore use the smallest possible computer resources. Instead, 
the point cloud itself (which is the container for the cloud points) 
stores the offsets for the measurements. Although cloud points (col-
lectively known as a cloud) are typically created from scanning devic-
es, they can be created by discrete measurements from instruments 
like laser trackers and portable arms as well.

So the question to answer is: when should a measurement be taken as 
a regular measured point, and when should it be recorded as a cloud 
point? The general rule of thumb is that if you are performing any 
type of surface scanning consisting of a large (>10,000) number of 
points, you should use point clouds. Note that nothing in this rule of 
thumb refers to the type of instrument being used. That is—whether 
or not you are using an actual scanner is of no consequence. If you are 
“scrubbing” a surface with an SMR and scanning with a laser tracker, 
for instance, that is considered scanning and point clouds should be 
used.

Note:  All points in a cloud 
should be measured with 

the same offset. If you change 
probes and the offset changes, 
put those points into a different 
cloud.

Tip:  For best performance, 
measure into a cloud when-

ever recording a large number of 
points (>10,000).
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Unbounded Geometry
There are several primitive geometry types in SA that are unbounded. 
This means that the geometry extends infinitely without bound. For 
an example of this, refer to Figure 4-16.

Although a plane in SA is depicted in the graphical view with a bound-
ary (blue line), this is only so that the plane is visible in the graphical 
view. From an analysis perspective, the plane extends infinitely in two 
dimensions, just as it might be defined in an academic math class. 
Keep in mind that any time you compare a point to unbounded prim-
itive geometry, the geometry will behave as if it extends infinitely 
along its unbounded edges. The following primitive geometry types 
are unbounded:

 ■

Figure 4-16. A plane in SA 
has a graphical depiction (blue 
lines) so that it can be seen, 
but from an analysis perspec-
tive it extends infinitely in two 
dimensions. When compared 
to a point beyond its graphical 
depiction, a plane is extended 
infinitely. The closest point to 
this measurement on the de-
picted plane is shown as a red 
dot above.

x

y

z

Planes

 ■ Lines

 ■ Cylinders (lengthwise)

 ■ Paraboloids

 ■ Cones

If you would like the geometry to be bounded for analysis purposes, 
it must be converted to a surface.

The Working Frame
SA has a concept known as the working frame. The working frame is 
a coordinate frame through which all data is represented or mapped. 
Put another way, it is the active coordinate frame. Any coordinate 
frame can be made the working frame, and when a frame is working, 
all data (point coordinates, delta values, rotations) is represented in 
SA with respect to that frame unless specified otherwise. 
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It is important to recognize that changing a coordinate frame does 
not physically move anything in space—it merely results in a change 
in the reference system used to represent that same position and ori-
entation. This allows you to take measurements in any arbitrary de-
fault coordinate system and represent them in a system that better 
describes the data.

A Closer Look
You can assign a frame of reference to a watch window in order to see deviations represent-
ed in a given frame regardless of the working frame. You can also specify a reporting frame 
for an object in order to view that object’s properties on a report with respect to a specific 
coordinate frame. (Those values will still be represented outside of reports with respect to 

the working coordinate frame. That is, if you assign a reporting frame to a point group, the coordinates will be 
represented in the active coordinate frame unless viewing them in a report).

The Default Collection
Collections are organizational elements used to contain entities in 
a hierarchy in SA. Just as there is always exactly one working frame, 
there is always exactly one default collection. The default collection 
(colloquially referred to as the working collection) is the organization-
al container inside which all newly created entities are placed, unless 
specified otherwise. For example, if a circle is created as the result of a 
geometry fitting operation, that circle will be placed into the default 
collection.

Traceability
One of the unique features of SA is its traceability. Traceability refers 
to maintaining an unbroken chain of comparisons relating measure-
ments back to a defined standard (Figure 4-17). National measure-
ment institutes such as the National Institute of Standards and Tech-
nology (NIST-USA), the National Physical Laboratory (NPL-UK), and 
the Physikalisch-Technische Bundesanstalt (PTB-Germany) all main-
tain national standards for weights and measures for their respective 
countries. Properly calibrated measurement instruments are evalu-
ated and certified to this standard, which establishes the first link in 
this chain.

The chain is continued through measurement in SA. Each measured 
point in SA contains an array of metadata that describes auxiliary in-
formation about the measurement, such as the instrument (and serial 
number) that measured it, the time and date it was measured, who 
measured it, weather factors such as temperature/pressure/humid-
ity, and more (see Figure 4-17). This information all helps maintain a 
complete record of the data.
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In addition, actions performed in a given job file are logged, and enti-
ties themselves have historical logs that indicate how they have been 
modified throughout their existence. Entities even maintain informa-
tion about how they were created in the first place. All of this infor-
mation helps provide a complete picture of traceability for your mea-
surements. If a specific instrument begins to show anomalies, you can 
look at any previous measurements, perhaps from weeks or months 
earlier, and identify which instrument measured it. This might give 
you cause to question those measurements as well—but without this 
traceability metadata, such a correlation may not have been possible.

NIST further maintains that “Traceability of measurement requires the 
establishment of an unbroken chain of comparisons to stated refer-
ences, each with a stated uncertainty”.1 Measurement uncertainty 
information can also be calculated for any measurement in SA, pro-
viding compliance with this policy but also providing a number of 
additional benefits as well (such as USMN—Unified Spatial Metrology 
Network).

Figure 4-17. Some of the 
traceability metadata stored 
with a laser tracker measure-
ment.

1 NIST Policy on Metrological Traceability.
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There are several components to the SpatialAnalyzer interface. Each 
component comes in a separate window which can be docked to  the 
edge of the screen or to the edge of another window. The compo-
nents can be closed independently to allow you to maximize your 
screen space and to enable you to customize the user interface for 
the specific task at hand.

As depicted on the next page, the various components of the SA in-
terface include:

 ■ Menu Bar. A list of menu commands as seen in nearly all Win-
dows applications.

 ■ Toolbars. Strips of icons that provide convenient graphical ac-
cess to common commands. By default, SA provides the Color/
WCF Toolbar and the Main Toolbar, although you can create ad-
ditional custom toolbars.

 ■ Treebar. A hierarchical view of all entities in the open job. For 
brevity this will typically be referred to simply as the tree.

 ■ Graphical View. A three-dimensional rendered view of the 
current job.

 ■ Report Bar. Displays important information about the select-
ed item and a convenient way to generate reports.

SpatialAnalyzer provides a user-friendly interface to 
access all of your measurement data. There are often 
several ways  to perform a given task, enabling you to 
choose a preferred method of interacting with the ap-
plication.

Exploring The 
User Interface
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 ■ Status Bar. Displays the software version number, non-critical 
messages, and includes a few other minor indicators.

Menu Bar

Color/WCF Toolbar

Main Toolbar

Treebar

Graphical View

Report Bar

Status Bar

As Figure 5-1 indicates, additional components may be visible (but 
aren’t displayed by default):

 ■

Figure 5-1. Additional User 
Interface windows.

Instrument Docking Bar

MP Bar

SA Toolkit

MP Bar. Displays Measurement Plan commands as they exe-
cute (requires SA Ultimate or greater).

 ■ Instrument Docking Bar. Houses instrument interfaces when 
they are docked inside the SA window.

 ■ SA Toolkit. Provides access to Geometric Dimensioning & Tol-
erancing as well as convenient access to tools for inspection, 
relationships, analysis, and reporting.
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To Hide an Interface Component:

 ■ Click the icon in the corner of the window, or

 ■ Right-click on the menu bar, toolbar, or a window title bar and 
uncheck the component you wish to hide. Check it to show it 
again.

Interface components can be set to auto-hide, so that they collapse 
into a tab at the edge of the screen when not active.  This provides for 
more space to work in other interface windows.

To Set an Interface Component to Auto-Hide:

Click the icon. When the mouse is moved away from the window, it 
will collapse into a tab (after a short delay). Roll over the tab and click 
the icon to disable the auto-hide behavior.

Figure 5-2. Docking the MP 
Bar to the bottom of the tree.

You can rearrange the positioning of the different user interface com-
ponents using docking. Interface components can be undocked, 
docked to the edge of the application screen, or docked along the 
edge of another interface component.

To Undock an Interface Component:

 ■ Click and drag the title bar for the component away from its 
current position.

To Dock an Interface Component to the Edge of the Screen or Another Component:

 ■ Click and drag the title bar for the component. As you drag, a 
series of boxes representing locations to dock the window will 
appear. Drag over an icon to dock to a specific position (see 
Figure 5-2).

You can customize the user interface, and then save this customiza-
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tion to a User Interface Profile.  For more information, see “Custom UI 
Profiles” on page 144.

Toolbars
Toolbars provide icons for quick access to frequently-used functional-
ity and are organized into related groups. There are two factory-de-
fault toolbars that ship with SpatialAnalyzer: the Main Toolbar and the 
Color/WCF Toolbar.

Main Toolbar

Figure 5-3. The Main Toolbar.

User Manual. Opens the manual (this document) for SpatialAna-
lyzer.

New. Starts a new job file.

Open. Opens a saved job file.

Auto Import. Imports a file automatically based on its file type.

Save. Saves the current job file.

User Options. Opens the user options dialog.

Object Properties. Displays the properties of an object after click-
ing the object in the graphical view.

Add Instrument. Adds an instrument to the current job.

Run Instrument Interface. Starts an instrument’s interface.

SA Network. Opens the SA Network Browser.

Rendering Settings. Switches between Wireframe, Hidden 
Line Removed, Solid+Edges, and Solid rendering modes.

Views. Selects, edits, and saves preset views.

Background. Changes the background and highlight colors.

View Rotation Center. Defines a pivot point for view rotations.

Autoscale. Automatically scales the graphical view to fit all visible 
entities.

Callout View. Adds callout views to the active collection.

Color Objects. Changes the color of selected objects in the graph-
ical view.

F2 - Select from a List. Opens the F2 selection dialog.

Enter - End Multiple Selection. Equivalent to pressing the Enter 
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key. Ends multiple-select mode.

Graphical Selection Mode. Changes the method for graphically se-
lecting items with the mouse.

Capture Graphics Picture. Captures the current graphics view as 
an image for use in reports or other documents.

Color/WCF Toolbar

Figure 5-4. The Color/WCF 
Toolbar.

Working Color.  Changes the working color.

Working Frame. Displays the current working frame 
and allows you to pick a new one.

User Interface Profiles. Used to define and activate custom user 
interface profiles. For more information, see “Custom UI Profiles” on 
page 144.

Toolbars can be rearranged by dragging on their toolbar grips(see 
Figure 5-5). You can completely undock a toolbar from the menus, or 
simply rearrange them. To dock a toolbar back into its original loca-
tion, drag the grip to slide the toolbar back into place.

Figure 5-5. Rearranging a 
toolbar by grabbing its grip.

You can create your own custom toolbars. For more information, see 
“Custom UI Profiles” on page 144.
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Treebar

Database Tab

Figure 5-6. The database tab.

The Database tab of the tree displays a hierarchical view of all entities 
in the current job (see Figure 5-6). It’s called the Database tab because 
it reveals all of the entities in SA’s underlying measurement database. 
This provides quick access to items of interest and enables simple but 
effective organization and management of properties. The tree con-
tains items such as instruments, point groups, reports,  embedded 
files, and geometric objects (lines, planes, etc). Headings or parent 
items within the tree can be expanded by clicking on the button to 
expose child data (on some machines, this appears as an icon). Click-
ing the button will collapse these items again. Right-clicking on an 
entry will display a context menu of commands that relate to the se-
lected item.

The hierarchical tree displays a number of different entities depend-
ing on what is present in the current job file:

Folders. Like folders in Windows Explorer, you can sort collections 
into folders to organize the SA file.

Collections. An organized collection of entities (objects, instru-
ments, reports, etc) that can be managed as a set in the tree.

Frames. Coordinate frames.

Instruments. Measurement instruments—laser trackers, portable 
CMMs, etc.

Point Groups. A series of points (measured or constructed) that are 
conveniently treated as a single object.
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Lines. Geometric lines with a begin/end point and a defined direc-
tion.

B-Splines. Curves that have a mathematical definition and a de-
fined direction along the curve.

Planes. Planar geometry that, while drawn with a finite size in the 
graphical view, extends infinitely in two dimensions.

Circles. Circular geometry.

Ellipses. Elliptical geometry.

Cylinders. Cylindrical geometry.

Spheres. Spherical geometry.

Cones. Conical geometry.

Paraboloids. Parabolic geometry.

Polygonized Surfaces. Unlike regular surfaces, polygonized sur-
faces are faceted and have no true mathematical definition for the 
surface (except for its planar facets).

Surfaces. Surfaces are parametrically defined and have a complete 
mathematical definition for every point on the surface. They are exact 
representations of a given surface.

Vector Groups. Vector groups represent the deviation between 
two entities as one or more vectors.

Point Clouds. Groups of points typically gathered from non-con-
tact measurement devices (such as a laser line scanner or coherent 
laser radar).

1-D Data. One-dimensional (scalar) data that has been measured 
by an auxiliary device (such as a digital micrometer).

Relationships. Dynamic (continuously updated) comparisons be-
tween entities.

Perimeters. Boundaries that are used to define automated scan ar-
eas.

Callouts. Callout views enable you to add captions, labels, and call-
outs in the graphical view.

Charts. A number of different statistical charts can be created as a 
result of various operations in SA.

SA Docs. An RTF (Rich-Text File) based reporting format that can 
be generated in SA.

SA Report Templates. A template defined for a report in advance, 
which enables generation of that report with updated data at any 
time.
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Measurement Plans. Scripted programs that can automate mea-
surement, analysis, and reporting operations.

Embedded Files. Any file can be embedded into an SA file for quick 
access or to conveniently link a file with the SA job.

Graphical Entities. Geometric shapes (such as boxes and pyramids) 
that act as purely visual elements and cannot participate in any analy-
sis.

Crib Sheets. Macros to help automate the naming of points and 
the way in which they’re measured.

SA Docs. A legacy reporting format that is no longer used, but may 
be used in older .xit files.

Annotations. Annotations associated with a feature for use with 
SA’s GD&T functionality.

Datums. Datums for use with SA’s GD&T functionality.

Feature Checks. Analysis results for use with SA’s GD&T functional-
ity.

Pictures. Imported images or graphical view screenshots that can 
be dragged into SA Reports.

SA Reports. One of several types of reports that can be created in 
SA.

Events. Easily-reportable records of significant events (such as fit-
ting geometry, minimizing relationships, or importing a CAD file) that 
have taken place in the file.

Robots and Machines. The robots or CNC machines in the current 
job file.

Scale Bars. Any defined scale bars.

Dimensions. Defined dimensions between any two entities.

Custom Report Tables. Custom tables generated via scripting that 
can be used in reports.

All of the above items (with the exception of Folders and Collections) 
are actually categories of items. The tree organizes items in a collec-
tion by their category--the individual items of that category are listed 
under the category. For instance, in the Instruments category, there 
might be three actual instruments.

Explorer Tab
The Explorer tab displays the file and directory structure of the local 
computer. This is a convenient way of navigating the disk to find files 
to import into the current SA job.
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Report Bar

Figure 5-7. The Report Bar 
showing properties for a coor-
dinate frame.

The Report Bar (Figure 5-7) displays the detailed properties of the cur-
rently selected item in the tree. It can also serve as a report generator 
by allowing multiple tabs of information to be compiled into a single 
report. For details on the report bar and reporting, refer to the Re-
porting section.

To Toggle Display of the Report Bar:

 ■ Right-click in the menus, toolbars, or status bar area of the in-
terface and select Report Bar from the context menu, or

 ■ From the menus, select Reports>Report Bar Visible.

Status Bar
The Status Bar (Figure 5-8) is a small bar at the bottom of the interface 
that has a number of minor, auxiliary displays. The left side of the bar 
will display any minor, low-importance messages that may arise dur-
ing the course of your work (for example, when copying data to the 
clipboard from the Report Bar).

Figure 5-8. The Status Bar.

To the right of this message area is the SA version. In Figure 5-8, SA 
2012.07.05 (a beta version) is running. Next to the version number is 
the current length unit setting. The three slots to the right of the units 
display indicate whether Caps Lock, Num Lock, or Scroll Lock 
are active on the keyboard (respectively). Two small processor icons 
on the right side of the status bar light up when SA is in a multi-
threaded operation.
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MP Bar

Figure 5-9. The MP Bar with 
an MP loaded.

The MP Bar (Figure 5-9) is normally only visible when a scripted Mea-
surement Plan has been loaded for execution. The main window lists 
each command of the MP, as well as a pointer indicating the com-
mand which will be executed next, and the status (success, partial 
success, or failure) of each step. The MP Bar has a button to start exe-
cuting the current MP , execute the next step in the MP , and 
terminate/close the current MP . The tabs at the bottom of the 
MP Bar display the primary MP and any MP subroutines currently ex-
ecuting.

Instrument Docking Bar

Figure 5-10. The tracker 
interface inside the Instrument 
Docking Bar.

 The Instrument Docking Bar (Figure 5-10) is a window that houses 
the currently docked instrument interface. It enables the instrument 
interface, which is actually a separate application from SA, to be 
docked onto one edge of the SpatialAnalyzer interface.

SA Toolkit
The SA Toolkit (Figure 5-11) contains five tabs that provide conve-
nient access to a number of useful SA tools. These tabs include GD&T, 
Relationships, Inspection, Analysis, and Reporting.
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 ■

Figure 5-11. The SA Toolkit.

GD&T. Tools for creating GD&T checks from CAD surfaces, 
primitive objects, or directly from points.

 ■ Relationships. Tools for quickly creating various types of rela-
tionships.

 ■ Inspection. Provides access to a list of inspection-ready items 
with buttons for advancing through the inspection.

 ■ Analysis. One-click access to many analysis tools.

 ■ Reporting. Buttons for creating reports, dimensions, and call-
outs.

UI Themes
A number of standard user interface themes are available to change 
the look of the SA interface. Three of the 14 interface styles are pic-
tured below:
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Figure 5-12. Top to bottom: 
MS Office XP, MS Office 2007 
(black), and MS Office 2003 
themes.

To Change the Look of the SA Interface:

 ■ In the View>User Interface Features>UI Theme menu, choose a 
theme from the list. The interface will update immediately.

Custom UI Profiles
A large portion of the SA user interface is customizable. With user in-
terface customization you can:

 ■ Add, rearrange, delete, and rename menu items,

 ■ Create custom toolbars and menus,

 ■ Save menu and toolbar docking locations,

 ■ Create custom keyboard shortcuts, and

 ■ Create custom icons.

This allows you to modify an interface to display only the commands 
you use while hiding unused features and leaving more room to work.

User interface settings are saved as profiles, with an .saprofile ex-
tension in the Analyzer Data\Templates directory. Once saved, 
they can later be recalled, or easily transferred to another computer 
by copying the file into the same directory on another machine. The 
selected profile becomes the default used when SA starts, and is 
saved as a machine setting.

Figure 5-13. The User Inter-
face Profiles dialog.

To Create a Custom User Interface Profile:

1. Do one of the following:

Note:  The user interface 
theme is saved as a machine 

setting.
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 ■ Click the User Interface Customization button in the 
Color/WCF Toolbar, or

 ■ Select View>User Interface Customization.

2. Click the Customize Current Profile button (Figure 5-13). This 
places you into Customize mode, which allows you to edit the 
properties of toolbar and menu items instead of performing 
their equivalent operations. (For details on customization, 
read the following sections). Customize mode ends when you 
return to the User Interface Profiles dialog.

3. When finished customizing the profile, click the Save Current 
Profile button. Enter a profile name, and click OK.

To Delete a Custom User Interface Profile:

1. Do one of the following:

 ■ Click the User Interface Customization button in the 
Color/WCF Toolbar, or

 ■ Select View>User Interface Customization.

2. Select the profile in the list that you’d like to delete (Figure 
5-13).

3. Click the Delete button. The profile will be deleted from the 
list and from the Analyzer Data\Templates directory.

To Reset to the Factory Default User Interface Profile:

 ■ In the User Interface Profiles dialog (Figure 5-13), choose <Fac-
tory Defaults> from the list, or

 ■ From the menus, choose View>User Interface Features>Reset GUI 
Toolbar Layout.

Customizing Toolbars & Menus

The Toolbars tab (Figure 5-14) allows you to show and hide toolbars, 
as well as create your own. Custom toolbars are treated just like  stan-
dard toolbars and act identically. Checked toolbars are displayed, 
while unchecked toolbars are hidden. The following assumes you are 
in customize mode (see “To Create a Custom User Interface Profile:” 
on page 144).

Warning:  User Interface 
profiles are not forward-
compatible. Once a pro-

file file is saved, it cannot be 
opened by a previous version of 
SA.
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Figure 5-14. The Toolbars tab 
of the Customize dialog.

To Create a Custom Toolbar:

1. In the Toolbars tab, click the Create button.

2. Give the toolbar a unique, descriptive name.

3. The new toolbar will appear in the list, and an empty toolbar 
will appear in the user interface (Figure 5-15).

Figure 5-15. A new custom 
toolbar named MyToolbar 
has been added. Notice the 
empty toolbar below the main 
toolbar.

While in Customize mode (see “To Create a Custom User Interface Pro-
file:” on page 144), you can modify toolbars as well as menu items. 
You can drag items to create new menus, drag them into current 
menus, or drag them into toolbars.

To Move an Item:

 ■ Drag a menu, menu item, or toolbar button to the desired posi-
tion. Drag it back to reverse the process.

To Add a Separator Between Items in a Custom Toolbar or Menu:

 ■ Right-click an item and choose Begin a Group. The separator will 
be placed before the selected item.
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Figure 5-16. A group separa-
tor has been added after the 
Scripts menu.

To Delete an Item from a Custom Toolbar or Menu:

 ■ Drag the item into an “empty” area of the screen (not over any 
menu or toolbar). The mouse cursor will change to , signify-
ing that the item will be deleted, or

 ■ Right-click the item and choose Delete.

To Add a New Item to a Custom Toolbar or Menu:

 ■ From the Commands tab, choose a menu category from the 
list at left. Then drag a command from the list at right to the 
toolbar or menu.

The appearance of items in a toolbar or menu can be changed. You 
can view an item as an icon only, text only, or both. You can even 
modify the icon for an item.

To Change the Appearance of a Toolbar Item:

 ■ Right-click the item and select from either Default Style, Text Only 
(Always), Text Only (In Menus), or Image and Text.

 ■ Default Style. This will display the icon if one is available. Oth-
erwise, it will display text.

 ■ Text Only (Always). This will display the item as text, regard-
less of whether it is on a toolbar or in a menu.

 ■ Text Only (In Menus). This will display the item as an icon 
when in a toolbar (if an icon is available), and as text when in a 
menu.

 ■ Image and Text. This will display both the icon (if available) 
and the text for the item, regardless of whether it is in a menu 
or a custom toolbar.

Figure 5-17. Two icons 
displayed with the image and 
text option.

To Change the Text Associated with an Item:

 ■ In Customize mode, right-click the item and click in the Name 
text field. Enter a new name for the item. Note that this will only 
be displayed if the current appearance setting displays text.

 To Reset an Item to its Default Appearance:

 ■ Right-click the item and choose Reset.

To Change a Toolbar Icon’s Appearance:

 ■ In Customize mode, right-click the item and choose Edit But-
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ton Image. This will open a simple editor to allow you to modify 
the icon, as depicted in Figure 5-18:

Figure 5-18. The Button 
Editor.

To Reset a Button’s Image Back to Defaults:

 ■ In Customize mode, right-click the item and choose Reset Button 
Image.

To Copy or Paste a Button Image:

 ■ In Customize mode, right-click the item and choose Copy Button 
Image or Paste Button Image.

To Assign a Supplied Image to an Icon:

 ■ In Customize mode, right-click the item and choose Change But-
ton Image, then choose an image from the list.

Keyboard Shortcuts

You can create custom keyboard shortcuts for virtually every com-
mand available to you in SA. Keyboard shortcuts are defined in the 
Keyboard tab of the Customization window. These keyboard shortcuts 
are saved as part of the custom user interface profile.

To Define a Keyboard Shortcut for a Command:

1. In the Keyboard tab (Figure 5-19), choose the desired catego-
ry and command from the list.

Note:  If a command does 
not come with a default 

icon, a custom icon cannot be 
added.
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2. 

Figure 5-19. Assigning cus-
tom keyboard shortcuts.

Click in the Press new shortcut key field, then enter the de-
sired shortcut.

3. If the shortcut is currently assigned to another command, it 
will appear in the Shortcut currently used by: field as a warning.

4. Click the Assign button to assign the new shortcut.

To Remove a Keyboard Shortcut:

 ■ Select the Category and Command from the Keyboard tab, then 
choose the shortcut from the Current keys: box and click Remove.

To Reset Keyboard Shortcuts to the Defaults:

 ■ In the Keyboard tab, click the Reset All button.

Options

The Customize dialog provides several additional options for control-
ling the display and behavior of the interface (Figure 5-20).

 ■ Always Show Full Menus. If disabled, menu items which are 
used rarely are not displayed. As a result, only an abbreviated 
menu is displayed. Click the down-arrow in the menu listing to 
view all commands for that menu.

 ■ Show Full Menus After Short Delay. If selected, the abbrevi-
ated menu will be displayed for a moment, followed by the full 
menu. (Disabled if always Show Full Menus is selected).

 ■ Animate Menu When Expanding. Animates the menu as it ex-
pands from the abbreviated menu to the full menu. (Disabled if 
always Show Full Menus is selected).

 ■ Highlight Rarely Used Menu Items. Menu items which are 
not used often will be highlighted.

 ■ Display Menus With Shadows. Renders a shadow around 
menus.

Tip:  You can assign a key-
board shortcut to a main 

menu item by placing an amper-
sand before the letter that you’d 
like to become the shortcut—for 
example, &GD&&T. This will allow 
you to open the GD&T menu by 
typing Alt+G. To place a single 
ampersand in a menu item, the 
name field must have two con-
secutive ampersands (to distin-
guish it from the keyboard short-
cut assignment), as illustrated in 
this example.
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 ■ Large Icons in Toolbars. When selected, large icons will be 
rendered in the toolbars. This is useful for very high resolution 
displays (or poor resolution eyeballs!)

 ■ Large Icons in Menus. When selected, icons displayed along 
menu items will be drawn in large size.

 ■ Show Screen Tips on Toolbars. When selected, displays 
tooltip information for toolbar icons.

 ■ Show Screen Tips on Menus. When selected, displays tooltip 
information for menu items.

 ■ Show Shortcut Keys in Screen Tips. When selected, displays 
the assigned shortcut key for a toolbar item as part of its tooltip 
information.

 ■ Menu Animations. Controls the transition used to display 
menus as they expand.

Figure 5-20. Changing UI 
options in the Options tab.

To Reset the Historical Usage Information for Menus and Toolbars:

 ■ Click the Reset menu and toolbar usage data button.

Language Translation
SpatialAnalyzer comes with seven stock languages:

 ■ English

 ■ Chinese

 ■ French

 ■ German

 ■ Italian

 ■ Russian

 ■ Spanish

If you would like to add an additional language, SA has a language 



151

CHAPTER 5 ■ EXPLORING THE USER INTERFACE

translation tool that can be used to translate menu items, dialogs, and 
other user interface elements. Language translation files are stored 
as .lan files which can be transferred to different computers and 
loaded into the interface. Several SA resellers also offer ready-made 
language translation files to customers.

Figure 5-21. The Language 
Settings dialog.

The language translation interface (Figure 5-21) works by storing 
translations from English to a specified language. If a certain phrase 
has not been translated, it will remain in the default English language.

To Make A Stock Language Translation Active:

1. Select File>Language Translation.

2. From the Language Translation dialog, select the desired lan-
guage, then click the Close button. If the window indicates 
that a custom translation is active, it must be deactivated first 
before choosing a stock language.

The active stock language will also apply to instrument interfaces un-
less a specific language has been loaded into that interface.

You cannot modify a stock language—it is read-only. However, you 
can create a new translation based off of a stock language, as de-
scribed below.

All custom translation is performed in the Language Settings dialog. 
To access this dialog, click the User Options icon,  and in the Display 
tab, click the Custom Language File button.

To Create a New Language Translation:

1. In the Language Settings dialog, click the New button.

2. In the dropdown, choose Empty Language File to create a new 
language file, or Language File based on to create a custom lan-
guage file based on one of the stock languages.

3. Assign a filename for the translation file and click OK.

Note:  Language settings are 
saved with custom user pro-

files. If you attempt to create a 
new language translation file 
while a custom user profile is ac-
tive, the user interface will be re-
turned to the default.

Note:  After changing the ac-
tive language, you may need 

to restart any running instrument 
interfaces for the new language 
to take effect.
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SA will build a database of phrases to translate and present the NRK 
Language Translation Interface. If the translation is based off of a 
stock language file, you will find that many of the phrases are already 
translated.

To Load an Existing Language Translation File:

 ■ In the Language Settings dialog, click the Browse button, and se-
lect a language translation file. The translations will immedi-
ately be applied to the user interface.

To Remove All Translations and Return to the Default Language of English:

 ■ Click the Clear (no translation active) button.

To Edit the Active Translation File:

 ■ Click the Edit Translation File button.

Character Sets

Certain languages (Asian languages in particular) do not use a tra-
ditional Latin character set (standard). To account for this, they may 
require an expanded character set in order to be displayed properly.

To Modify the Character Set Used for Dialogs:

 ■ Click the Standard or Expanded character set (Chinese, Japanese) 
buttons.

To Modify the Font Type and Size Used for Dialogs:

 ■ Enter a new font name or size into the dialogs.

Creating a Translation

The language translation interface (Figure 5-22) allows any phrase 
that is used in SA to be selected and translated. Once a translation 
has been added for a particular phrase, it will appear translated in the 
interface. The top list contains phrases that have not been translated. 
The bottom list contains phrases that have been translated, and lists 
both the original English and the translated phrase.

To Assign a Name for the Language:

 ■ Type a language name in to the Language Name field, then click 
Apply.

To Search for an Untranslated Phrase:

1. In the top search field, type in a phrase. As you type, the first 
matching item will be highlighted.

2. To find the next result, click the Next Missing Phrase button 
again.

Note:  The search field al-
lows you to enter phrases 

with wildcard characters (* and 
?). For example, to search for the 
phrases “Password Protection” 
and “Projection”, enter 
Pro?ection in the search field.
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To Save the Current State of the Language File and Apply Changes:

 ■ Click the Save button.

Figure 5-22. The Language 
Translation Interface.

To Apply a Translation to a Phrase:

1. Select the phrase from the top list of untranslated phrases.

2. Click the Add button.

3. In the Translation Entry window, enter the translated phrase. 
To automatically assign an ALT keyboard shortcut to a menu 
item, precede the desired letter with an ampersand. To enter 
an ampersand in the phrase, use two consecutive amper-
sands (&&).

4. When finished, click OK. The translated phrase will appear in 
the list at the bottom, and the phrase will disappear from the 
top list of untranslated phrases.

To Edit or Delete a Translated Phrase:

 ■ Select the phrase in the bottom list of translated phrases and 
click Edit or Delete.
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To Search for an Original Phrase (English):

1. Enter the search text in the lower-left search field. As you type, 
the first matching phrase will be highlighted. Wildcard char-
acters (* and ?) may be used in this search field.

2. To find the next matching phrase, click the Next English Phrase 
button.

To Search for a Translated Phrase (Translated Language):

1. Enter the search text in the lower-right search field. As you 
type, the first matching phrase will be highlighted. Wildcard 
characters (* and ?) may be used in this search field.

2. To find the next matching phrase, click the Next Foreign Phrase 
button.

To Clear Untranslated Phrases From The Dialog:

 ■ Click the Clear button. All untranslated phrases will be removed 
from the list.

Merging Language Files

Multiple language files can be merged into a single language file. 
Consider translating an instrument interface, which is performed in 
the instrument interface itself. This translation is saved into a sepa-
rate translation file. You can merge an instrument interface transla-
tion file into the SA translation file so that a separate translation does 
not need to be applied to the instrument interface. (This is how the 
stock language files work).

To Merge Language Files:

1. From the NRK Language Translation Interface dialog, click the 
Import button.

2. In the file filter dropdown, change the file type to Language 
File (*.lan).

3. Select the desired language file to merge, then click Open.

4. Confirm the merge procedure. The translated phrases from 
the language file will be merged into the current file.

Using .CSV Files For Translation

Once translations have been applied, converting one language to 
another is made easier with the ability to use .CSV files. Translated 
phrases (those appearing in the bottom list) may be exported to a 
two-column .CSV format, which allows you to simply change a trans-
lation to another language using a spreadsheet program such as Ex-
cel. This way, you can avoid having to click the Edit button for each 
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translated phrase.

To Export Translated Phrases to .CSV Format

1. Ensure the desired phrases to translate already have some 
sort of translation applied to them (so that they appear in the 
bottom list).

2. Click the Export button, and choose a file name for the .CSV 
file.

To Edit an Exported .CSV Translation File

1. In a program capable of working with the CSV format (such as 
Microsoft Excel or Notepad), open the .CSV file.

2. Leave the first column (English Phrases) alone, but change the 
second column (Translated phrases) to the desired language.

3. Save the .CSV file without changing its format.

To Import a .CSV Translation File

1. In the Language Translation Interface, click the Import button.

2. Choose the file to import and click OK. The new phrases will 
load into the translated phrases section of the window.

Figure 5-23. SA with a Ger-
man language translation 
active.
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The graphical view is drawn as a parallel projection—that is, lines of 
perspective do not converge in the distance but are instead paral-
lel. This is done for a very good reason: there is no “vanishing point”, 
therefore objects appear the same size regardless of their distance 
from the viewpoint. From a practical perspective, this allows you to vi-
sually estimate size and position differences among objects without 
worrying about  whether their distance from the viewpoint is affect-
ing their apparent size.

Navigating the Graphical View
The graphical view provides a graphics-accelerated, three-dimen-
sional rendered view of everything in your job. It allows you to in-
spect, select, and operate on objects graphically. In order to take ad-
vantage of this realistic view of your data, it’s important to be able to 
navigate the view with ease.

Zoom

To Zoom In and Out:

 ■ Hold down Ctrl and click-drag the mouse up or down, or

 ■ Scroll the mouse wheel up/down, or

The graphical view is arguably the most important sin-
gle display in all of SpatialAnalyzer. It allows for graphi-
cal selection, provides visual feedback, and allows you 
to visualize your measurements and data.

The Graphical 
View
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 ■ Press the PgUp/PgDn key, or

 ■ From the menus, choose View>View Control>Zoom>In [Out], or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 159).

To Zoom Into a Region of the View:

Hold down the left mouse button, drag the mouse to define a rect-
angle, and release the mouse button. The view will zoom into the de-
fined region.

Autoscale

Autoscale will zoom and center the view so that all visible objects are 
displayed in the graphical view at once.

To Autoscale the View:

 ■ In the main toolbar, click the Autoscale button, or

 ■ In the menu, select View>View Control>Zoom>Autoscale, or

 ■ Press Alt+A, the default keyboard shortcut.

Pan

To Pan the View:

 ■ Hold down the Shift key and drag the mouse in the graphical 
view, or

 ■ Use the keyboard arrow keys (Up, Down, Left, and Right), or

 ■ Select View>View Control>Pan>Up/Down/Left/Right, or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 159).

To Center the View on a Point:

 ■ Middle-click anywhere in the graphical view.

Rotate

To Rotate the View (Freeform):

 ■ Hold down the right mouse button and drag, or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 159).

The viewpoint can be rotated about an axis perpendicular to the 
screen (this is referred to as spinning the view).

To Spin the View:

 ■ Hold down the Ctrl key and right-click-drag the mouse.

 ■ Normally, SA chooses the entity closest to the center of the 
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graphical view to become the pivot point for rotation. How-
ever, if desired you can select a specific point to serve as the 
rotation pivot point.

To Set a Specific Point as the Rotation Pivot Point:

1. On the Main Toolbar, click the View Rotation Center button.

2. Click a point to set the pivot point.

By default, SA uses the Front of Sphere view rotation mode. When ro-
tating in this mode, the rotation center is considered to be at the cen-
ter of a sphere, while the cursor is “stuck to” the front of the sphere 
and spinning it. This rotation sense can be reversed to Back of Sphere 
mode in the User options Machine Configuration tab.

To Reverse the View Rotation Sense:

In the User options Machine Configuration tab, change the Front of 
Sphere Mode setting.

Center In View

If you have an item in the tree and are having trouble finding it in the 
graphical view, you can easily center the view on an object, point, 
instrument. (Does not apply to point groups, point clouds, vector 
groups, annotations, datums, feature checks, or dimensions).

To Center the View on an Item:

 ■ Right-click the item in the tree or graphical view and select Cen-
ter In View from the context menu.

Adjust View Components

If desired, you can control the viewpoint (zoom, rotation, and pan-
ning) through the Point of View dialog. To open the Point of View dia-
log, choose View>View Control>Adjust View Components.

Figure 6-1. The Point of 
View dialog has controls for 
zoom, rotation, and panning, 
as well as transformation dia-
log increment fields.

Each of these buttons works similar to the manual view operations, 
except that the rotation buttons rotate about axes that are horizontal, 
vertical, or perpendicular to the screen.

This dialog also contains fields for controlling how much an object’s 

Tip:  Centering the view on a 
point is an easy way to make 

that point the center of rotation.
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position or orientation changes when an up/down arrow is clicked in 
a transformation dialog.

 ■ Position. Controls the increment applied to positional values.

 ■ Rotation (deg). Controls the angular increment applied to an-
gular values.

Jumping to Previous/Next Views

It is often useful to jump back and forth among various recent views. 
As you navigate throughout the graphical view, if you remain at a 
given viewpoint for at least one second, SA will store the viewpoint. 
You can then quickly navigate back and forth between previous and 
next views.

These views are not saved with the SA file. If you manually change 
views while at an earlier view in the list, later views are removed from 
the list.

To Navigate Among Previous Views:

 ■ To jump to a previous view, press Ctrl+Alt+← or select 
View>Viewpoint Control>Go to Prev View from the menus.

 ■ To jump to the next view, press Ctrl+Alt+→ or select 
View>Viewpoint Control>Go to Next View from the menus.

Set Viewpoint From Frame

The viewpoint can be set from any existing frame using the View>View 
Control>Set Viewpoint From Frame command. The resulting view will look 
down the +Z axis.

To Set a Viewpoint From a Frame:

1. Select View>View Control>Set Viewpoint From Frame.

2. At the prompt, select the frame you’d like to use for orienting 
the view.

Set Viewpoint From Instrument Updates

The viewpoint can be set by the current probe position/orientation 
for instruments that provide 6-DOF information, such as portable 
CMM arms or probes. This enables the capability to “fly around” a part 
using an instrument, or to update the viewpoint while measuring.

To Set the Viewpoint Based on Instrument Updates:

1. Select View>View Control>Set Viewpoint From Instrument Updates.

2. At the prompt (if more than one instrument is available), se-
lect the instrument to use for establishing the viewpoint.

Note:  The smoothness of 
the transition between 

views is controlled in the User 
Options>Display tab with the 
View animation Steps option.

Note:  For some instruments, 
you may need to put the in-

strument interface into a mode 
that sends updates to see an up-
date in the view.
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Set Viewpoint From Object

Any object’s orientation can be used as the basis for a viewpoint. The 
resulting view will look down the -Z axis of the object.

To Set a Viewpoint From an Object:

1. From the menu, select View>View Control>Set Viewpoint From Ob-
ject.

2. At the prompt, select the object to use for establishing the 
viewpoint.

Set Viewpoint From Surface Point

You can also set the viewpoint to look at a surface along its normal.

To Set a Viewpoint From a Surface Point:

1. From the menus, select View>View Control>Set Viewpoint From Sur-
face Point.

2. At the prompt, click on the surface where you’d like to look.

View Clipping

Circumstances might arise in which you want to clip portions of the 
graphical view. Two major examples include:

 ■

Figure 6-2. Viewing a model, 
measurements, and a vector 
group with an active clipping 
region.

Removing data (such as point cloud data) outside of a region in 
order to simplify the view. This may be done for reporting rea-
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sons (to obtain a clear screenshot for a report) or just to be able 
to more easily work in the view. For example, if you have point 
cloud scans of the inside and outside of a building, you might 
clip away the near “wall” so that you can view the data on the 
inside of the building without also seeing the wall data.

 ■ Displaying a “section cut”. You might do this to “cut away” por-
tions of your CAD or data in order to display only a region of 
interest, as in Figure 6-2.

A clipping region is defined by a box that can be moved or have any 
of its sides scaled along a coordinate direction. The orientation of the 
region (its rotation in space) can be defined by any object, and each 
of the six faces of the box can have clipping enabled or disabled.

To Set A Clipping Region:

1. From the menus, select View>View Control>Clipping Planes or 
press Alt-X.

2. In the Clipping Entities dialog, click the Add button.

3. Select any object to define the initial position and orientation 
of the clipping box.

4. Mouse over the center of a face (it will turn black) and click it 
to toggle that face’s clipping plane.

5. Mouse over the center of any edge (an icon will appear) and 
drag to move the clipping region along that edge’s direction.

6. Mouse over the end of any edge (an icon will appear) and 
drag to grow or shrink the region along that edge’s direction.

7. When you’re happy with your region, click the Close button, or 
leave the dialog open if desired.

To Assign Numeric Boundaries to a Clipping Region:

1. Create the clipping region as described above in “To Set A 
Clipping Region:” on page 162.

2. In the Clipping Entities dialog, double-click on a clipping re-
gion or select it and click the Edit button.

3. In the resulting Clipping Volume Properties dialog, check the 
regions you’d like to be active, and enter desired values for 
each clipping plane.

To Delete a Clipping Region:

 ■ In the Clipping Entities dialog, select the clipping region to de-
lete, then click the Delete button.

You can define as many clipping regions as you’d like. Any of them 
can be activated or deactivated.

Note:  Clipping regions are 
tied to the object used to de-

fine the position and orientation 
of the clipping cube. If the object 
moves or rotates, the clipping 
planes will move or rotate along 
with it.
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To Activate or Deactivate a Clipping Region:

 ■ In the Clipping Entities dialog, check (to activate) or uncheck 
(to deactivate) the clipping region’s checkbox.

Multiple Graphical Views
Multiple graphical views (see Figure 6-3) can be displayed by select-
ing View>New Graphical View Window. This allows you to simultaneously 
view and interact with your job from multiple perspectives.

Figure 6-3. An auxiliary view 
has been opened to view and 
interact with this door panel 
from a different perspective.

Auxiliary graphical views can be rotated, positioned, and rendered in-
dependent of the primary graphical view, and they also support se-
lection.  Hold the Ctrl key while changing the render mode, auto-
scaling, or creating a snapshot of the screen to have the setting apply 
across all open graphical view windows.

You can add as many auxiliary views as you’d like, although more than 
two auxiliary views begins to become unmanageable without mul-
tiple computer displays.

Heads-Up Display
The graphical view has a Heads-Up Display (HUD) that displays a vari-
ety of measurement information (see Figure 6-4), including:

 ■ Feature Name (if trapping measurements to a feature)

 ■ Current Point Number (if trapping to a feature with a prescribed 
number of measurements)

 ■ Point coordinates

 ■ Point name (when not trapping)

 ■ RMS error (if the RMS error of a sampled measurement exceeds 
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the warning threshold)

You can control whether the HUD is displayed, the font, color, translu-
cency, and dwell time for the display all from the user options.

Figure 6-4. The Heads-Up 
Display.

To Modify Settings for the Heads-Up Display:

1. From the SA Toolbar, click the User Options icon.

2. In the Display tab, click the Heads Up Display Settings button 
(Figure 6-5).

Figure 6-5. The Heads Up 
Display Options dialog.

To Enabled/Disable the Heads-Up Display:

 ■ In the HUD options dialog, enable or disable the Show hUd 
when a point is measured or trapping is activated checkbox.

To Change the Font used by the Heads-Up Display:

 ■ In the HUD options dialog, click the Font button, then choose a 
new font from the dialog.

To Change the Color of HUD Text:

 ■ In the HUD options dialog, click the color swatch and choose a 
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new color.

To Change the Translucency of the Heads-Up Display:

 ■ In the HUD options dialog, set the Translucency (0 to 1) field to 
a value between 0 (fully transparent) and one (fully opaque).

To Change How Long the HUD Remains On-Screen:

 ■ In the HUD options dialog, set the Dwell Time before removal op-
tion (in seconds).

Saved Viewpoints
You can save custom viewpoints in order to quickly return to a preset 
view orientation.

To Save a Custom Viewpoint:

1. Orient the view to the desired position.

2. Click the Views icon in the Main Toolbar, or select View>View 
Control>Set Viewpoint.

3. In the View List dialog, click Add Current, as depicted in Figure 
6-6.

4. 

Figure 6-6. The View List 
dialog.

In the Preset View dialog, type a name for your custom view 
(Figure 6-7).

5. 

Figure 6-7. Entering the 
name for a custom view.

If you would like the view to restore the current zoom set-
tings, select restore Zoom Settings.

6. To view position and orientation information about the view, 
click the Show Details button.

7. Click OK. Your custom view will now be available in the View 
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List:

Figure 6-8. The custom view 
has been added to the view 
list.

To Restore a Custom Viewpoint:

 ■ Click the down-arrow next to the Views icon and pick the 
view from the list, or

 ■ In the View List dialog, double-click the desired view or select 
it and choose OK.

To Edit a Custom Viewpoint:

 ■ In the View List dialog, select the view and choose Edit.

To Delete a Custom Viewpoint:

 ■ In the View List dialog, select the view to delete and click De-
lete.

To Delete All Viewpoints:

 ■ In the View List dialog, click Delete All.

To Restore the Default Viewpoints:

In the View List dialog, click Reset to Defaults.

By default, saved view directions are based on the orientation of the 
world coordinate frame. For example, if a view is saved looking along 
the world frame’s Z-axis, then when the view is restored, it will again 
be looking along the Z-axis of the world frame, regardless of the ac-
tive frame. However, you can choose to restore saved view directions 
relative to the working frame instead. By doing so, restoring the view 
described above would look along the Z-axis of the active frame.

To Restore a Viewpoint Based on the Working Frame:

 ■ In the User Options>Display tab, check the View relative to Work-
ing Frame option.

Rendering Modes
SA provides four rendering modes for viewing geometry: Wireframe, 
Hidden Line Removed, Solid+Edges, and Solid. The rendering modes 
are selected from the Main Toolbar.
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 ■ Wireframe. Geometry is displayed as edges only, and hid-
den edges are visible, as depicted in Figure 6-9.

 ■

Figure 6-9. Wireframe ren-
dering mode.

Hidden Line Removed. Geometry is displayed as edges 
only, but hidden edges are not displayed, as depicted in 
Figure 6-10. 

Here

Figure 6-10. Hidden Line 
Removed rendering mode.

 is the same view with silhouettes turned on:

 ■

Figure 6-11. Silhouettes 
have been drawn in this hid-
den line view.

Solid+Edges. Solid surfaces are rendered in addition to 
edges, as shown in Figure 6-12.

 ■

Figure 6-12. Solid+Edges 
rendering mode.

Solid. Solid surfaces are rendered without edges, as depict-

Note:  By default, silhouette 
edges are not rendered in 

Hidden Line Removed mode.  To 
draw silhouettes, in the User 
Options>Display tab, check draw 
Silhouettes in hidden Line removed 
Mode.

Note:  Because of the neces-
sary computation time, each 

time the view is rotated, you need 
to click the Hidden Line Removed 
icon to redraw silhouettes if you 
want to see them. the draw Sil-
houettes in hidden Line removed 
Mode setting is saved with the SA 
file.

Note:  When a file is first 
opened, the rendering 

method always defaults to wire-
frame mode. This prevents a po-
tentially lengthy rendering pro-
cess from starting immediately 
after a file is loaded.
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ed in Figure 6-13.

Figure 6-13. Solid rendered 
mode.

Surface Backsides
Every surface in SA (in addition to other entities, such as planes) has a 
positive and a negative side (see Figure 6-14). In order to properly ac-
count for a probe’s target offsets, it is important that all comparisons 
be performed against the positive side of a surface. In order for you to 
determine the positive side, SA renders the negative side of surfaces 
in a special, user-definable color (a light gray by default).

Figure 6-14. The same sur-
face as viewed from the front 
(left) and back (right) with 
highlight Surface Back-sides 
enabled.

Although the default gray is usually sufficient, you can choose a cus-
tom color to denote surface backsides. It is best to choose an unusual 
color which is not one of the typical working colors.

If desired, you can disable surface backside highlighting so that both 
the front and back  side of surfaces appear in the same color.

To Disable Surface Back-Side Highlighting:

 ■ In the User Options>Display tab, uncheck the highlight Surface 
Back-sides option.

To Change the Color of Surface Back-sides:

1. Ensure the highlight Surface Back-sides option is selected.

2. Click the Color button, then choose a new color.

Note:  The highlight Surface 
Back-sides setting is saved as 

a machine setting.



169

CHAPTER 6 ■ THE GRAPHICAL VIEW

Background/Highlight Color

Figure 6-15. The Background 
dialog.

The background of the graphical view can be set to a solid color or a 
gradient, and you can also adjust the highlight color used in SA.

To Adjust Background Color Settings:

 ■ Click the Background icon in the Main Toolbar.

To Change the Background Color to a Solid Color:

 ■ Click the Solid radio button, then click the color swatch to 
change the color.

 ■ Click the Black button to change the background color to black.

 ■ Click the White button to change the background color to 
white.

To Change the Background Color to a Gradient:

 ■ Click the Gradient radio button, then choose a start and end 
color. Specify whether you’d like a horizontal or vertical gradi-
ent.

The highlight color is used when an object is selected or when it is 
explicitly highlighted using the Highlight command.

To Change the Highlight Color:

 ■ Under the Highlight Color section, click the color swatch and 
choose a new color, or

 ■ Click the Auto Set button, which will automatically select a 
highlight color that has high contrast when compared to the 
current background color.

Tip:  For fastest rendering, set 
your background to a solid 

color. Solid backgrounds redraw 
faster than gradient backgrounds.
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To Restore the Factory Default Background/Highlight Colors:

 ■ Click the Restore Defaults button.

Hardware Acceleration
If your graphics card supports it, SpatialAnalyzer provides OpenGL™ 
hardware acceleration for the graphical view. This option is enabled 
by default, and provides a significant performance increase—partic-
ularly with complex models and large amounts of geometry.

To Enable or Disable Hardware Acceleration:

1. Open the User Options dialog by clicking the icon.

2. On the Display tab, click the Performance Options button.

3. Check or uncheck the Use hardware accelerated rendering if 
available option (Figure 6-16).

Figure 6-16. Enabling hard-
ware acceleration for faster 
graphics performance.

After changing the hardware acceleration option, it is necessary to 
exit SA and restart for the new setting to take effect.

SA has a built-in Frames-per-second (FPS) monitor that you can use 
to determine whether hardware acceleration is improving rendering 
performance in your job (see Figure 6-17). The FPS monitor displays a 
running average of the rendered frame rate. The progress bar under 
the frame rate shows how “full” the measurement buffer has become. 

Note:  Some graphics cards 
may cause visual artifacts 

with hardware-accelerated ren-
dering enabled. If you see these 
artifacts, first ensure that you 
have the latest drivers for your 
graphics card. If the artifacts per-
sist, disable hardware accelera-
tion.
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For the most accurate value, continue rotating the view until this buf-
fer is nearly full.

To Test the Effectiveness of Hardware Acceleration on Your Machine:

1. Open the User Options dialog by clicking the icon.

2. On the Display tab, click the Performance Options button.

3. Select the display Frames-per-Second (FpS) Monitor option.

Figure 6-17. The Frames-per-
second (FPS) monitor indicates 
how quickly the graphical 
view is being redrawn.

Surface Rendering Options
CAD surfaces (sometimes referred to as B-Reps or NURBS—Non-ra-
tional Uniform B-Splines) are mathematically defined and therefore 
have an “exact” representation. However, curved surfaces must be 
converted into a series of approximated flat faces in order to be ren-
dered in the graphical view. The quality of this approximation is de-
termined by the Surface Rendering Options (see Figure 6-18).

Figure 6-18. The Surface 
Rendering Options dialog.

If you find that your curves and surfaces are not being represented 
accurately enough for your liking, or if you see “tearing” in your CAD 
surfaces, you can modify the surface rendering options.

 To Change the Surface Rendering Options:

 ■ In the User Options>Display tab, click the Surface Rendering 
Options button. Choose the desired settings, then click OK.

The adjustable options that affect surface rendering are as follows:

Note:  You will not see a 
framerate that exceeds the 

refresh rate of your display--typi-
cally around 60 fps.

Note:  Surface rendering op-
tions only affect the depic-

tion of the CAD in the graphical 
view.   In calculations, the exact 
surface is always used.



172

SPATIALANALYZER USER MANUAL

 ■ Max Trimmed Edge Angle. Specifies the maximum length of 
edge segments for trimmed edges. A lower value gives a high-
er quality representation. Use a value of 0 to default to a low-
quality setting.

Figure 6-19. Max trimmed 
edge angle: 65 (left) and 15 
(right).

Note that this setting also applies to spline curves:

 ■

Figure 6-20. Max trimmed 
edge angle: 125 (left) and 5 
(right).

Max Facet Chordal Deviation. Specifies the maximum allow-
able distance between a rendered edge and the surface with 
which it is associated. Use a value of 0 to default to a low-qual-
ity setting.

Figure 6-21. Max facet 
chordal deviation of 0.000 (left) 
and 0.001 (right).

When laying out points on an object’s vertices, this setting affects 
how many points are constructed.

 ■ Max Facet Edge Length. Specifies the maximum allowable 
length of each edge segment.

 ■ Max Facet Aspect Ratio. Specifies the maximum aspect ratio 
(length vs. width) of each rendered facet.

 ■ Force Re-render of all surfaces. Checking this option will force 
SA to recalculate surfaces using the latest settings in the win-
dow. If unchecked, and surfaces have already been rendered, 
then the settings will not take effect until the file is reopened.
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Labels

Figure 6-22. Point and 
object labels are visible in this 
view.

Labels can be turned on in the graphical view for displaying names of 
points, objects, and instruments (see Figure 6-22). This is often useful 
for visually distinguishing different objects, but can become over-
whelming in complicated files—so you can toggle label visibility.

You can specify the font with which to display labels, as well as the 
text size.

To Change the Font Used for Labels:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Font Settings... button in the Labels 
box.

3. Select the desired font, style, size, and color (the other options 
will not apply).

Labels can be controlled individually for points (which also displays 
instrument labels) or objects.

To Toggle the Display of Labels:

 ■ Points and Instruments. Toggle View>Show Point Labels or press 
Alt+L (default keyboard shortcut).

 ■ Objects. Toggle View>Show Object Labels.

Point labels can display just the target name (such as STAR_EAST_5 
in Figure 6-22) or can display the entire collection, group, and target 
name (such as Controls::Network::STAR_EAST_5).

To Toggle the Display of Full Point Names:

1. Click the User Options icon in the toolbar.

2. In the Display tab, check or uncheck the Use Full names check-

Tip:  Displaying a large num-
ber of labels simultaneously 

in the graphical view can signifi-
cantly slow down display perfor-
mance. Hide items not in use or 
turn labels off to speed up display 
speed.
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box.

To Display Instrument Labels Without Point Labels:

1. Click the User Options icon in the toolbar.

2. In the Display tab, uncheck the display Labels checkbox.

3. Ensure that View>Show Point Labels is turned on.

When point labels are enabled, by default they are displayed even 
when the corresponding point is hidden behind a surface. To avoid 
confusion, you can set the graphical view to hide labels for points that 
are not visible from the current point of view.

Figure 6-23. Hide obstructed 
labels disabled (left) and en-
abled (right).

To Hide Labels for Hidden (Obstructed) Points:

 ■ Select View>Hide Obstructed Labels.

When point labels are displayed, by default SA will label the axes of 
coordinate frames as X, Y, and Z. This can be disabled.

To Disable Labeling of Frame Axes:

1. Click the User Options icon in the toolbar.

2. In the Display tab, uncheck the draw Labels checkbox in the 
Coordinate Frames box.

The Hover Window
If you are looking at an item in the graphical view, finding that item’s 
name—or where it is located in the tree—can be a difficult task, par-
ticularly if the file is complicated and has lots of objects. The Hover 
window is a floating dialog, so it can be left up and “floating” over the 
graphical view. When you hover over an item in the graphical view, 
the Hover window will indicate the collection, name, type,  and loca-
tion of the item in the tree, the coordinates of a point (in Cartesian, 
Cylindrical, or Spherical coordinates, the deltas for a vector, or the 
number of measurements associated with an instrument.

Note:  Hiding obstructed la-
bels is computationally in-

tensive and can slow down the 
graphical view considerably. For a 
more efficient method, simply 
hide the points.
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To Toggle Display of the Hover Window:

Do one of the following:

 ■ From the menu, select View>Hover (nearest point), or

 ■ Press Ctrl+H (the default keyboard shortcut), or

 ■ From the Toolkit’s Analysis tab, click the Hover Window

Figure 6-24. The Hover win-
dow showing the name and 
coordinates of a point.

The Hover window has a filter that you can apply to indicate what can 
be “hovered”.

 ■ Auto. No filter is applied—SA will provide information for 
points, objects, vectors, or instruments—whatever you roll 
over.

 ■ Points. Information will only be displayed when the cursor is 
rolled over a point.

 ■ Objects. Information will only be displayed when the cursor is 
rolled over an object.

 ■ Vectors. Information will only be displayed when the cursor is 
rolled over a vector.

 ■ Instruments. Information will only be displayed when the cur-
sor is rolled over an instrument.

To Set the Hover Window Filter:

 ■ With the Hover window displayed, choose either the auto, 
points, Objects, Vectors, or instruments option.

To Find an Item in the Tree:

1. Activate the Hover window and ensure that the Show in tree 
option is selected.

2. Hover the mouse cursor of the item of interest. The tree will 
be expanded and auto-scrolled to reveal the item, and it will 
be selected.

3. To keep the selection active and the tree expanded, turn off 
the hover window while hovering over an item by pressing 
Ctrl+H.

To Change the Coordinate System for Viewing Point Coordinates:

 ■ In the Hover window, choose the Cartesian, Cylindric, or Spheri-
cal option.
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Object-Specific Rendering Modes
It is often useful to make a specific object or instrument in the graphi-
cal view partially transparent (translucent) or to render it differently 
than other objects. For example, if a measured part has an area of 
insufficient material, its corresponding vector group will point into 
the CAD model. As a result, this vector will be nearly invisible when 
the CAD is rendered in Solid, Solid+Edges, or Hidden Line Removed 
mode. As another example, depending on viewing angle, sometimes 
the instrument’s graphical representation, a surface, or the active co-
ordinate frame will obstruct the work area that you’re most interest-
ed in (see Figure 6-25). A third case might involve a surface that you 
want to see through. While there is always the option of hiding the 
obstructing items, often times it is desirable to keep them visible. In 
such circumstances, translucency allows you to avoid hiding the ob-
jects, but still be able to see through them to the work area.

Figure 6-25. Viewing the 
work area through a translu-
cent instrument.

To Toggle Instrument Translucency:

 ■ Select View>Translucent Instruments.

To Toggle Frame Translucency:

 ■ Select View>Translucent Working Frame.

Surfaces and primitive objects can be set to a specific level of trans-
lucency or can be independently set to render in solid or wireframe 
mode.

To Set the Rendering Mode of an Individual Surface or Primitive Object:

1. Right-click the object in the tree or graphical view.

2. Select Translucency.

3. Select a desired rendering mode. If translucent is selected, 
choose an opacity level with the slider.

To Set the Rendering Mode of Multiple Surfaces or Primitive Objects:

1. Select View>Object Visibility>Translucency>Individual Objects or >All 
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Objects as desired.

2. If >Individual Objects was selected, select the objects of interest 
and press Enter.

3. Select a desired rendering mode. If translucent is selected, 
choose an opacity level with the slider.

Visibility
Figure 6-26. The frame 
named Frame1 in this collec-
tion is hidden.

All of the items listed above can be shown or hidden. Hiding an item 
will remove it from the graphical view, and (unless it is a folder or col-
lection) will dim the item’s name in the tree to gray (see Figure 6-27).

Hiding items not in use has a number of benefits, chief of which are:

 ■ The graphical view becomes less cluttered, and it’s easier to 
work with the items of interest.

 ■ If many items are being displayed at once, hiding those not in 
use will speed up the graphics considerably.

 ■ Graphical selection becomes easier, because there are less 
items to pick incorrectly.

To Toggle An Individual Item’s Visibility:

 ■ Right-click the item in the tree or graphical view and toggle the 
Show option.

To Hide or Show All Items In a Container or Category:

 ■ Right-click the container (collection or folder) or category in 
the tree and select Hide All or Show All.

To Hide or Show Individual Points:

 ■ Right-click the point in the tree or graphical view and toggle 
the Show setting to toggle visibility of individual points, or

Select View>Show Points or >Hide Points, then select the points to show 
or hide.

To Hide or Show Multiple Objects:

 ■ Select View>Object Visibility>Hide Objects or >Show Objects.

To Show All Objects:

 ■ Select View>Object Visibility>Display All.

You can also filter the graphical view to display items only from a spe-
cific source. This source can be either SA itself, or an imported CAD 
file. This allows you to immediately hide objects imported from one 
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or more CAD files, or to immediately hide native SA objects.

To Filter The View By CAD Source:

1. Select View>Object Visibility>Filter By CAD Source.

2. In the Show Selected Sources dialog, select the sources you’d 
like to show, then click OK.

3. The filter will apply until you change it again.

Miscellaneous Settings & Commands

View Animation Steps

Sometimes, switching from one saved viewpoint to another can be 
disorienting. If you find that switching from one saved view to an-
other is too jarring, you can increase the number of animation steps 
as the view transitions from one saved viewpoint to another. This has 
the effect of smoothing out (and slowing down) the transition.

To Change the Number of View Animation Steps:

1. Click the User Options icon in the toolbar.

2. In the Display tab, change the View animation steps value. The 
value is the number of frames used to animate from one view 
to the other.

Arrowhead Sizes

You can change the size of arrowheads on vectors with the Line arrow 
size factor setting (see Figure 6-27).

Figure 6-27. Line arrow 
size factors of 0.01 (left), 0.05 
(middle), and 0.1 (right).

To Change the Size of Arrowheads on Vectors:

1. Click the User Options icon in the toolbar.

2. In the Display tab, change the Line arrow size factor setting to a 
different value. A small change goes a long way!

Note:  Vector arrowheads 
also get larger as the vector 

gets longer.
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Scale Indicator

Figure 6-28. The scale 
indicator. These points are ap-
proximately 100 inches apart.

To get a better grasp on the scale of the current zoom setting, you can 
display a scale indicator—somewhat like a distance legend on a 
map—that indicates the size of distances in the graphical view (Fig-
ure 6-28). The scale indicator automatically updates and adjusts itself 
as you zoom in and out in the view.

To Display the Scale Indicator:

1. Click the User Options icon in the toolbar.

2. In the Display tab, check the Show Scale indicator in View 
checkbox.

Connection Indicator

If you have more than one instrument in your job file, it may begin to 
get confusing as to which instrument is currently connected to the in-
strument interface (that is, which instrument in the SA file is currently 
live). The connection indicator (Figure 6-29) is designed to highlight 
the connected instrument and prevent the confusion.

Figure 6-29. The connection 
indicator.

You can control whether the indicator is displayed, and if so, how 
large it is drawn.
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To Adjust the Connection Indicator:

1. Click the User Options icon in the toolbar.

2. In the Display tab, enable or disable the Connection indicator 
checkbox.

3. To change the size of the indicator, change the Radius value.

Uncertainty Fields

As discussed in “Measurement Uncertainty”, uncertainty fields allow 
you to visualize the uncertainty of a measurement as a cloud of points 
(Figure 6-30). Uncertainty clouds provide a reference for determining 
relative uncertainty magnitude, shape, and distribution when com-
paring measurements.

Figure 6-30. Viewing 
uncertainty fields for a set of 
measurements.

You can choose to display these uncertainty fields in the graphical 
view, or to hide them.

To Toggle Display of Uncertainty Fields:

 ■ From the menu, select View>Show Uncertainty Fields.

Uncertainty fields are rendered in the graphical view at a certain mag-
nification level so that they can be easily seen.

To Change the Size of Uncertainty Fields:

1. Click the User Options icon in the toolbar.

2. In the Analysis tab, change the Cloud Magnification value to the 
desired amount.

By default, uncertainty clouds are drawn as individual dots on the 
screen, each representing a sample of the overall uncertainty cloud. 
For ease of viewing, you may prefer to draw the cloud with lines in-
stead of dots (Figure 6-31).

To Draw Uncertainty Clouds as Lines:

1. Click the User Options icon in the toolbar.

2. In the Analysis tab, enable the draw using lines option.
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Figure 6-31. Uncertainty 
clouds drawn as dots (left) and 
lines (right).

Cloud Display Control

When working in scan data, it is common to be dealing with tens or 
hundreds of millions of cloud points. Rendering a large number of 
cloud points on-screen would lead to very sluggish graphical view 
performance.

Whenever you rotate/pan/zoom in the graphical view, any displayed 
point clouds are automatically thinned while the view adjustment 
operation is in-place. Once complete, the original point cloud is dis-
played.

You can further limit the number of cloud points rendered on-screen 
using the Cloud Display Control (Figure 6-32).

Figure 6-32. Viewing a cloud 
at 1:40 density, with each 
cloud point drawn as a 1-pixel 
dot.

To Display the Cloud Display Control:

 ■ From the menu, select View>Cloud Display Control, or
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 ■ Press Ctrl+T (default keyboard shortcut).

Figure 6-33. Viewing a cloud 
at 1:3175 density, with each 
cloud point drawn as a 3x3 
pixel square.

 ■ Thin. The thinning factor for display. 1 indicates that all cloud 
points are displayed. 100 indicates that only every hundredth 
cloud point is displayed.

 ■ Size. The size of the rendered cloud point, in pixels. 2 indicates 
the cloud is to be drawn as a 2x2 pixel square.

When cloud thinning is enabled and you graphically select cloud 
points, all cloud points will be selected—not just those that are ren-
dered.

Highlighting

As a job file grows to hold more objects and measurements, it may 
become somewhat difficult to distinguish objects in the graphical 
view. While hiding items not of concern is probably the most com-
mon solution to this, often times it is faster to simply select an ob-
ject by name in the tree and highlight it. Highlighting an item does 
two things: it changes the item in the graphical view to the current 
highlight color, and it also colors the item in the tree a bold blue. Do-
ing this enables you to pinpoint the selected object while keeping 
all objects of interest visible. In addition to individually highlighting 
objects, you can also highlight points, collections, instruments, and 
folders. (Highlighting a collection or folder highlights everything in-
side that collection or folder).

Tip:  When working with 
large numbers of cloud 

points, selecting graphically can 
be a very slow operation. Select a 
cloud using F2 selection wherev-
er possible.
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There are also cases in which simply hiding items does not provide 
sufficient information. For instance, you can right-click a relationship 
and ask it to highlight its associated points or objects in order to iden-
tify which entities are associated with that relationship. This is infor-
mation that cannot be revealed by simply hiding objects.

To Highlight a Point, Object, Instrument, Collection, or Folder:

 ■ Right-click the item in the tree or graphical view and select 
Highlight.

To Highlight the Points or Objects Associated With a Relationship:

 ■ Right-click the relationship in the tree and select Highlight Enti-
ties.

To Clear Highlights:

 ■ Right-click the item(s) in the tree or graphical view and un-
check the Highlight setting, or

 ■ Select View>Clear all Highlights to clear all highlighted items.

View Refresh

Rarely, you might occasionally find the need to manually refresh the 
view. If you are uncertain that the view updated after performing an 
action, you can refresh the view to ensure that you’re looking at the 
latest rendering of the graphical view.

To Refresh the Graphical View:

 ■ Select View>Refresh from the menu, or

 ■ Press F5, the default keyboard shortcut.

Copying the Graphical View to the Clipboard

You can quickly and conveniently copy just the current graphical 
view to the clipboard for pasting in other applications (such as into 
an Excel or Word document).

To Copy the Graphical View to the Clipboard:

 ■ From the menus, select Edit>Copy graphics to clipboard.

Creating a Movie Capture of the Screen

SA comes with a tool for capturing video of the screen (or certain win-
dows) to a video file. This may be useful for sharing your work with 
others or communicating an important feature to a customer.

To Create a Movie Capture of the Screen:

1. From the menus, select View>Create AVI Movie>New File.

2. When prompted, specify a filename for the resulting video.
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3. The Image Capture Options dialog appears (Figure 6-34).

4. 

Figure 6-34. Options for an 
video capture.

Select the desired settings, then click Create AVI File.

Capture Modes

 ■ Entire Screen. The entire screen will be captured.

 ■ SA Window. Only the boundary of the SA window will be cap-
tured.

 ■ SA Graphics Window. Only the graphical view will be cap-
tured.

Output Size (pixels)

Controls the resolution of the resulting video file.

Capture Method

 ■ Continuous. Captures frames with a specified delay between 
frames.

 ■ Triggered: Capture when mouse wheel used. Captures a 
frame only when the mouse wheel is used.

 ■ Triggered: Capture everytime the graphics window re-
draws. Captures a new frame whenever the graphical view is 
redrawn.

Frame Rate

 ■ Playback Rate (frames per second). Indicates the playback 
rate of the video—the number of video frames displayed per 
second.

5. If applicable, choose the appropriate video compression set-
tings.

6. Start recording by selecting View>Create AVI Movie>Start Record-
ing or press Alt+1.
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To Pause or Resume Video Recording:

 ■ To pause, select View>Create AVI Movie>Stop Recording or press 
Alt+2.

 ■ To resume, select View>Create AVI Movie>Start Recording or press 
Alt+1.

To Finish Recording:

1. First stop recording using the View>Create AVI Movie>Stop Record-
ing command or press Alt+2.

2. Select View>Create AVI Movie>Close File.

Controlling Target Icon Size

You can control the size of constructed and measured points (targets) 
as displayed in the graphical view. Targets can be drawn at a fixed 
size—which does not change regardless of zoom level—or a varied 
size, in which the points get larger as you zoom in. The former avoids 
clutter when multiple points are spaced closely together, whereas the 
latter gives a visual indication of scale on the current view.

Figure 6-35. Targets dis-
played at 5 pixel size (top) and 
15 pixel size (bottom).

To Use a Fixed Target Size:

1. Click the User Options icon in the toolbar.

2. In the Targets area of the Display tab, ensure that Fix size in view 
us checked, and enter the desired pixel size for the targets.

To Use a Variable Target Size:

1. Click the User Options icon in the toolbar.

2. In the Targets area of the Display tab, ensure that Fix size in view 
is unchecked. Set the icon radius to the desired size, in job 
units.



186

SPATIALANALYZER USER MANUAL

This Page Intentionally Left Blank.



CH
A

PT
ER 7

187

Selection

Figure 7-1. A selection 
prompt displayed in the 
graphical view.

SA generally follows the action-Object selection paradigm when it 
comes to issuing menu commands. This implies that you first choose 
a command or operation, and then select the items to which the op-
eration should be applied. Depending on the operation, multiple se-
lection steps may be required. When an object is selected, it will 
change to the selected highlight color and its listing in the tree will 
become bold blue.

You can select entities visually in the graphical view. When an opera-
tion requires a user to make a selection, a selection prompt will ap-

This chapter will help you to learn the ins and outs of 
working in SA on a day-to-day basis, which will speed 
up your workflow and allow you to complete your work 
as quickly as possible.

Working In SA
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pear as in Figure 7-1.

The entities that you will be prompted to select will depend on the 
selected command (one of the benefits of the Action-Object para-
digm). SA will filter entity types for you, so that if you are prompted 
to select points, you will only be allowed to select points—not instru-
ments or objects.

To Abort a Command and Exit the Selection Mode:

 ■ Press the Esc key. The selection prompt will disappear and the 
command will be cancelled.

In many commands, the prompt permits you to select more than one 
item—usually as many items as desired. You can continue to select 
items using the selection methods below until satisfied, at which time 
you must indicate to the prompt that you are finished selecting items.

To Complete Selection:

 ■ Press the Enter key.

There are several ways to make selections in SA:

 ■ Graphically. Pick items directly in the graphical view.

 ■ Treebar Selection. Pick items using the tree.

 ■ F2 Selection. Pick items from a filtered list.

 ■ Wildcard Selection. Pick items based on naming criteria using 
wildcards.

 ■ By Color. Pick items based on their color.

 ■ By Type. Pick items based on their type.

Each of these selection methods is discussed in more detail in the fol-
lowing sections.

Graphical Selection

One way to graphically select items is to simply click them in the 
graphical view.

To Graphically Select Items One at a Time:

 ■ With a prompt displayed, single-click the item in the graphical 
view. The item’s selection state will be toggled—once selected, 
clicking an item again will remove it from the selection.

You can also graphically select multiple items at one time. To do this, 
SA provides graphical selection modes.

Graphical Selection Modes
There are two graphical selection modes in SA: rectangle and poly-
gon.
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Figure 7-2. Selecting a set 
of points using a rectangular 
selection marquee.

Rectangle mode allows you to draw a rectangle around the entities of 
interest, as illustrated in Figure 7-2. Everything inside the rectangle is 
either selected (or deselected), whereas the selection states of items 
outside of the rectangle remain unchanged.

To Select Multiple Items Using Rectangular Selection:

1. Ensure you are in rectangle graphical selection mode (see 
“Graphical Selection Options” on page 190).

2. While pressing the Shift key, click and hold the mouse but-
ton to define one corner of the rectangle.

3. Drag to the opposite corner of the rectangle, then release the 
mouse button.

Polygon selection mode allows you to draw a polygon of any shape to 
define the selection, as depicted in Figure 7-3.

Figure 7-3. Points are being 
selected through the use of a 
polygon selection marquee.

Items inside the polygon are either selected (or deselected), whereas 
items outside of the polygon are not affected.

Tip:  If you’ve started to de-
fine a selection in the wrong 

place, drag the mouse back over 
the starting corner of the rectan-
gle. When the cursor changes 
back to an arrow, release the 
mouse button. You will remain in 
the selection mode but nothing 
will be selected.

Note:  If you release the Shift 
key prior to releasing the 

mouse button, you will define an 
autoscale region, not an entity se-
lection.

Note:  To remove selected 
items from the selection, 

hold down both the Shift and 
Alt keys.
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 To Select Multiple Entities Using Polygon Selection:

1. Ensure you are in polygon graphical selection mode (see 
“Graphical Selection Options” on page 190).

2. While pressing the Shift key, single-click to define each ver-
tex of the polygon.

3. For the last vertex, locate the mouse cursor where you’d like 
the vertex to be and release the Shift key.

To Change the Selection Mode During a Selection:

 ■ Press the F3 key.

Graphical Selection Options 
The Graphical Selection Mode dialog (Figure 7-4) provides a number 
of options to allow you to control graphical selection. You can pick 
the selection mode as well as define whether entities inside, outside, 
or crossing the selection boundary should be selected.

To Open the Graphical Selection Mode Dialog:

 ■ Choose View>Graphical Selection Mode, or

 ■ Select the Graphical Selection Mode icon from the Main 
Toolbar.

To Change Graphical Selection Modes:

 ■ Choose the rectangle or polygon radio button.

Figure 7-4. The Graphical 
Selection Mode dialog allows 
you to define the behavior of 
the selection marquee.

To Select Whether Entities Inside or Outside the Selection Region Should Be Selected:

 ■ Choose the Select items inSide shape or Select items OUtSide 
shape radio button.

Note:  To remove entities 
from the selection, hold 

down Shift, then hold down 
Alt and make your selection. 
When finished defining the poly-
gon, release the Shift key, but 
keep the Alt key depressed.

Note:  The graphical selec-
tion mode options will per-

sist until SA is closed.
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To Define Whether Entities Crossing a Selection Region are Selected:

 ■ Check or uncheck the Objects must be entirely in or out check-
box.

Treebar Selection

Any item can also be selected in the tree. Selecting items in the tree 
provides an advantage over the graphical view in cases where there 
are many entities overlapping, when the item is not visible, does not 
have a representation in space, or when the geometry of the view 
makes it difficult to determine which items are actually selected.

To Select Items in the Tree:

 ■ With a prompt displayed, double-click the item in the tree. 
Double-click the entity again to toggle its selection state.

F2 Selection

The F2 selection window (Figure 7-5) provides significant advantages 
for selection in cases where multiple items need to be selected. F2 
selection filters out entity types that don’t apply to the current selec-
tion and lists the remaining items in a hierarchical view similar to the 
treebar.

Figure 7-5. The F2 Selection 
dialog.

There are three variants of the F2 selection window: there is a window 
specific to point selection mode, object selection mode, and instru-
ment selection mode. Each is slightly different and has options par-
ticular to the specific mode.
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To Use the F2 Selection Window:

1. During selection (while the prompt is displayed), do one of 
the following:

 ■ Press F2,

 ■ Click the F2 - Select from a list icon in the toolbar, or

 ■ From the menu, select View>Point Selection Tree-View.

2. Select the desired items, then click the OK button.

3. Continue selecting items using other methods (if desired), 
then confirm your selection by pressing the Enter key.

To Expand or Collapse the Entire Tree of Items (Point/Object Selection Modes):

 ■ Click the Expand or Collapse button.

To Select All Items in a Folder or Collection:

 ■ Check the box next to the folder or collection name.

To Select an Entire Category or an Entire Point Group (Point/Object Selection Mode):

 ■ Check the box next to the category/point group (for example, 
Spheres, Point Groups, or Frames).

To Select All But a Few Items in a Category or Point Group (Object/Point Selection Modes):

 ■ Check the box next to the category type, then uncheck indi-
vidual items within that category.

To Select Contiguous Rows of Items (Object/Point Selection Modes):

1. Check the box next to the first item in the list.

2. Hold down Shift and check the box next to the last item in 
the list.

To Select All Items in the List:

 ■ Click the All button.

To Deselect All Items in the List:

 ■ Click the None button.

Wildcard Selection
Wildcard selection is a powerful way to select items by name from the 
F2 window. To use it, click the By name using wildcards button, which 
opens the dialog in Figure 7-6.
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Figure 7-6. The Wildcard 
Selection dialog.

This dialog may appear slightly different depending on whether the 
current command allows you to select points or objects. In this dia-
log, asterisks (*) represent a set of contiguous characters, and ques-
tion marks (?) represent a single character.

This dialog allows you to enter selection criteria based on collection, 
object, and point names. In each criteria field, enter a search string. 
Any entities that match all of the entered criteria will be selected.

Examples (all based on point selection):

To Select: Enter the following into the fields:

Collection Group Target

All points in all collections * * *

All points in all collections containing 
“Survey”

SURVEY * *

All points in the Survey collection from 
point groups whose names contain 
“Instrument”, followed by any string, fol-
lowed by “Measured”

SURVEY INSTRUMENT*MEASURED *

To select everything except the items selected by the search criteria, 
check the Inverse Selection Mode option. After completing a wild-
card selection, the items are selected (signified by the checked check-
box next to their entry in the list) but the F2 dialog remains open so 
that you can modify your selection or add to it. You can even add the 
result of another wildcard selection to your currently selected items.

To Select Based on Wildcards:

1. At a selection prompt, open the F2 Selection Window.

2. Click the By Name Using Wildcards button.

3. Type in your criteria, then click OK.

4. Modify the selection as needed, or perform another wildcard 
selection.

5. Click OK to select the items.

Selection By Object Type
The F2 selection window enables you to select items by their type 
(see Figure 7-7). Although this is not particularly useful when select-

Warning:  Wildcard selec-
tion automatically adds 
an asterisk (*) at the be-

ginning and end of your search 
text. This may result in selection 
of more items than desired.

Note:  The wildcard selec-
tion criteria, like all names in 

SpatialAnalyzer, are not case sen-
sitive.



194

SPATIALANALYZER USER MANUAL

ing items in a single collection (because those items are already orga-
nized by type and can be easily selected by clicking one checkbox), if 
you have multiple collections of items that you want to select by type, 
this can save you some time.

To Select Objects By Type:

1. In an object selection mode, call up the F2 selection dialog.

2. Click on the By Object Type button.

3. In the Select Object Types dialog, select the object types you’d 
like to select, then click the OK button.

Figure 7-7. Selecting all 
point groups by their object 
type.

Selection By Color

It may be desirable to use object color to characterize different enti-
ties in the job file. For instance, you may decide to color all nominal 
objects yellow, and all as-built or measured objects blue. If you fol-
low this colorization scheme, then you can easily select all nominal or 
measured objects using selection by color.

There are two ways to select objects by color. You can select graphi-
cally by color, or you can F2-select by color. Both color selection 
modes apply to object selection only, because only objects can be 
assigned a color. When selecting graphically by color, you choose a 
single item whose color defines the color to select. SA will then auto-
matically also select all objects that match that color. F2 selection by 
color allows you to directly pick a color (not an object) and SA selects 
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all objects of that color.

To Graphically Select Objects By Color

1. While in object selection mode, press the F3 key or click on 
the Graphical Selection Mode icon.

2. In the Graphical Selection Mode dialog, click the Select Ob-
jects by Color (Applies Once) button.

3. Click on an object whose color defines the color you’d like to 
select.

To F2 Select Objects By Color

1. With a selection prompt displayed, press the F2 key or click 
the list selection icon.

2. In the resulting Object Selection dialog, click the By Color but-
ton.

3. In the Select Color dialog, check one of the colors in the list. 
(Only the colors in use in the file will be displayed).

4. Click OK. You will be notified how many objects matched the 
color criteria, and they will be added to your selection.

Context Menus
Context menus play an important part in the SpatialAnalyzer work-
flow. They allow you to select commands directly related to an item 
by selecting that item instead of looking for a command in a menu. In 
some cases, commands are available in context menus and nowhere 
else. To access a context menu, simply right-click an item or object. 
If it has a context menu, it will be displayed adjacent to the mouse 
cursor.

Context menus are frequently used in the graphical view. Right-click-
ing an entity in the graphical view reveals its context menu, allow-
ing quick access to commands related to that entity (see Figure 7-8). 
There are several commands that appear in the graphical view con-
text menus that are not found anywhere else.
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Figure 7-8. The context 
menu for this tire contains a 
command to reveal the sur-
face in the tree.

Right-clicking an entity in the SA tree will also present a context menu 
and is one of the most common actions performed in the tree (Figure 
7-9).

Figure 7-9. The context 
menu in the tree.

Organizing Your Job
In a typical measurement job, you’ll be working with many different 
types of objects in a file: instruments, coordinate frames, measured 
points, geometry, CAD data, reports, and more. Without a way to or-
ganize this data, it would be easy to quickly get lost amongst the va-
riety of entities in the file. Fortunately, SA provides a flexible way to 
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organize this data so that it can be accessed conveniently and with-
out confusion. The primary player in all of this organization is the tree, 
in which the items in your job are displayed in a hierarchical fashion.

Folders and Collections are two primary constructs that enable this or-
ganizational capability.

Folders

Figure 7-10. Multiple folders 
and collections in a hierarchy 
in the tree.

Folders allow you to sort and arrange your job information in the tree 
in a way that makes the most sense based on the way you work (Fig-
ure 7-10). You can create nested folders and move collections from 
one folder to another. You can expand and collapse a folder hierarchy, 
hide folders, rename and move folders, and change their order in the 
tree. Folders can only contain other folders or collections. You cannot 
put an instrument, point group, coordinate frame, or any other entity 
directly inside of a folder.

To Create a New Folder:

 ■ Right-click an empty area of the tree or on any folder and 
choose New Folder.

To Create a New Sub-Folder:

 ■ Right-click the folder you’d like to be the parent of the new 
sub-folder, and choose New Sub-Folder.

To Delete a Folder:

 ■ Right-click a folder in the tree and choose Delete. All items with-
in the selected folder will be deleted.

To Delete Multiple Folders by Name:

1. From the menu, select Edit>Delete>Delete Folders By Wildcard...

2. Type a wildcard search criteria (* and ? are allowable wildcard 
characters) into the Search Criteria field.

3. Click the OK button and confirm the deletion action.

To Rename a Folder:

 ■ Right-click the folder and choose Rename.

To Expand or Collapse an Entire Folder Hierarchy:

 ■ Right-click the folder and choose Expand All or Collapse All.

To Change the Order of Folders in the Treebar:

 ■ Right-click a folder and choose Change Order In List>Move Up (Move 
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Down).

Collections

A collection refers to a group of objects, measured data, reports, and 
other entities that can be managed as a group from the tree, and as 
depicted with an open box icon . This “collection” of objects serves 
to group related data in a logical manner, making measurement and 
analysis more intuitive.

A job may have any number of collections. However, only one of these 
collections may be the active collection at any one time. When a col-
lection is active, it is considered to be the default collection. Any new-
ly-created entities (e.g., Points, Instruments, Planes, Lines, Reports, 
Relationships, etc) are created in the active collection unless a differ-
ent collection is explicitly specified. The active collection is depicted 
in the tree by a bold blue font. Notice in Figure 7-10 that any folders 
enclosing the active collection are also highlighted with a bold blue 
font so that you can find the active collection if the folder hierarchy is 
collapsed.

To Create a New Collection:

 ■ Right-click an empty area of the tree, any collection, or any 
folder and choose New Collection, or

 ■ Measure a point or object into a collection that does not al-
ready exist (see Measurement).

To Rename a Collection:

 ■ Right-click the collection in the tree and choose Rename.

To Delete a Collection:

 ■ Right-click a collection in the tree and choose Delete.

To Delete Multiple Collections:

 ■ Right-click a collection in the tree and choose Delete Multiple Col-
lections, or

 ■ Right-click an empty area of the tree and choose Select Collec-
tions to Delete.

To Delete Multiple Collections By Name:

1. From the menu, select Edit>Delete>Delete Collections By Wildcard...

2. Type a wildcard search criteria (* and ? are allowable wildcard 
characters) into the Search Criteria field.

3. Click the OK button and confirm the deletion action.

To Copy a Collection:

 ■ Right-click a collection and choose Copy.

Note:  If you measure 
points  (through an instru-

ment interface) into a collection 
that does not already exist, the 
collection will be created auto-
matically for you.
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To Change the Order of Collections in the Treebar:

 ■ Right-click the collection and choose Change Order In List>Move Up 
(Move Down).

To Make a Collection Active:

 ■ Right-click the collection and choose Make active default collection.

To Move a Collection to a Folder:

1. Right-click the collection and choose Move Collection to Folder.

2. Choose the destination folder from the resulting dialog.

When objects are created inside of a collection (either explicitly or as 
the result of an operation), SA automatically organizes those objects 
by their type inside what is referred to as a category. A category is 
simply a container that holds all like items in a given collection. For in-
stance, all point groups in a given collection are placed into the Point 
Groups category, and all instruments in a collection are placed into 
the Instruments category. This behavior makes it easy to keep your 
file’s elements organized by type.

Relocating Items to Another Collection

A common use for collections is to organize nominal and measured 
data separately. Another use is for organizing multiple states of mea-
sured data (for instance, measuring an assembly at various stages in 
the production process). You may occasionally come across the need 
to move items from one collection to another.

To Relocate an Item to Another Collection:

1. Right-click the item in the tree or graphical view and select 
Move to Another Collection from the context menu.

2. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The item will be moved 
into the destination collection.

To Relocate Multiple Objects to Another Collection:

1. From the menu, select Edit>Relocate Objects to another Collection.

2. Select the objects you’d like to relocate.

3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The objects will be moved 
into the destination collection.

To Relocate Multiple Instruments to Another Collection:

1. From the menu, select Edit>Relocate Instruments to another Collec-
tion.

2. Select the instruments you’d like to relocate.

Note:  To move a collection 
out of all folders, choose the 

Root folder as the destination.

Note:  A common mistake 
for new users is to try to dou-

ble-click a category in the tree to 
select it. You must expand the cat-
egory to reveal the actual items 
inside it.
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3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The instruments will be 
moved into the destination collection.

To Relocate Multiple MPs to Another Collection:

1. From the menu, select Edit>Relocate MPs to another Collection.

2. Select the scripts you’d like to relocate.

3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The MPs will be moved 
into the destination collection.

Rearranging Points

At some point while working in a file, you will likely want to rearrange 
your points by moving them from one point group to another. There 
are several ways to do this.

To Relocate Points into a Separate Group:

1. From the menu, select Construct>Points>From Existing Points>Move.

2. Select the points to relocate.

3. In the dialog, enter a name for a new group into which to 
place the points. This group must not already exist.

4. The points will be removed from the current group and placed 
into the new group. The point names will be prepended with 
the source group name.

To Relocate a Single Point into a Different Group:

Renaming a point and giving the point a different collection or group 
will move it into that collection/group. If the collection or group does 
not already exist, it will be created for you.

1. Right-click the point to relocate and choose Rename from the 
context menu.

2. In the Rename Point dialog, enter a new collection or group 
name, then click OK.

The Group Manager
You can rearrange points in an intuitive way using the Group Man-
ager. The Group Manager is a Windows Explorer-like dialog that al-
lows you to drag and drop points from one group to another, and also 
provides the capability for renaming, group creation/deletion, search 
and replace, sorting, and more.

To Call Up The Group Manager:

 ■ From the menu, select Edit>Group Manager...

The Group Manager is shown in Figure 7-11.
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Figure 7-11. The Group 
Manager.

On the left side of the group manager is a list of all groups in your job, 
organized by collection. At right is a list of the points in the selected 
group, as well as their coordinates.

To Create a New Group:

1. Right-click anywhere on the left side of the Group Manager 
and select New from the context menu.

2. Type a new group name, then click OK.

To Delete a Group:

 ■ Right-click a group on the left side of the Group Manager and 
select Delete from the context menu.

To Rename a Group:

1. Right-click a group on the left side of the Group Manager and 
select Rename from the context menu.

2. Enter a new name for the group, then click OK.

To Relocate Points to a Different Group:

1. Select the points to relocate from the right side of the win-
dow. You can only select points from one group at a time, al-
though multi-selection is allowed.

2. Do one of the following:

 ■ Drag the selected points to the destination group, or

 ■ Right-click the selection and select Cut from the context menu, 
then right-click the destination group and select Paste from the 
context menu.

To Copy Points To Another Group:

1. Select the points to copy on the right side of the window. You 
can only select points from one group at a time, although 
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multi-selection is allowed.

2. Do one of the following:

 ■ Right-click the selection and choose Copy from the context 
menu, then right-click the destination group and select Paste 
from the context menu, or

 ■ Right-click the selection and choose Copy selections into a New 
Group from the context menu. Type a new group name, then 
click OK.

To Create New Points:

1. Select the group to contain the new points on the left side of 
the Group Manager.

2. Right-click the right side of the window and select New from 
the context menu.

3. Enter the Cartesian coordinates for the point, then click OK.

4. Enter the name for the new point, then click OK.

To Delete Points:

 ■ Select one or more points, then right-click the selection and 
choose Delete from the context menu.

To Sort Points by Name or Coordinate Value:

 ■ In the Group Manager, click a column header to sort by that 
value. Click again to sort in the reverse direction.

To Find Points:

1. Right-click a point or selection (select points to search 
amongst first, if desired) and select Find... from the context 
menu.

2. Type a search string, and choose either the Selection option to 
search the selection, or the Group option to search the entire 
group.

3. Click the OK button. The list of points will be filtered to show 
only the matching points. (Click the group name to reset the 
list).

To Perform Search and Replace in Point Names:

1. Select points (if desired), then right click the selection and 
choose Replace... from the context menu.

2. In the Replace dialog, enter text to search for, and the text 
to replace it with. Choose Selection, Group, or All to indicate 
whether you want to search among the selection, entire 
group, or all points.

3. Click the OK button. All matching text substrings are replaced.
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To Access Point Properties:

 ■ Double-click a point in the Group Manager, or

 ■ Right-click a point and select Properties from the context menu.

To Access Group Properties:

 ■ Right-click a group and select Properties from the context menu.

Naming & Renaming Items

If you create objects in SA without properly naming them—that is, 
by using the default names provided by SA—you will soon find that 
your job file becomes completely unmanageable. In all but the sim-
plest of measurement files, there are enough entities created that you 
can quickly lose track of what each entity represents. Therefore, best 
practice is to clearly name all items in your file when you create them. 
Doing so makes the file easier to work with, keeps it organized, and 
also allows you (or another person) to look at the file perhaps years 
later and still understand the data inside it.

Choosing a name is entirely up to you, although there are a few rules 
that should be followed.

 ■ Names are not case-sensitive. A group named TEST is not dis-
tinguishable from a group named test.

 ■ Spaces are allowed, but depending on the letters surrounding 
the space, it is often difficult to determine if a name contains 
a space at all (or perhaps multiple spaces). If you’re worried 
about potential confusion, avoid the use of spaces.

 ■ Multiple points in the same point group cannot have the same 
name. They must be unique.

 ■ Multiple objects may have the same name in a given collec-
tion, however this is not recommended if you expect to use 
scripting (Measurement Plans), as this leads to potential am-
biguity within your script as to which object you are referring.

 ■ Avoid long consecutive sequences of numeric digits at the 
end of a point or group name. Keep them to less than 20 dig-
its. (Otherwise, incrementing and decrementing of point and 
group names will not function correctly).

To Rename a Group of Points:

Do one of the following:

1. Do one of the following:

 ■ From the menu, select Edit>Rename>Group of Points, or

 ■ Right-click a group in the tree and select Rename from the con-
text menu.

2. At the prompt, enter a new name for the group, then click OK.
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To Rename a Point:

1. Right-click a point and select Rename from the context menu, 
or select Edit>Rename>Single Point.

2. At the prompt, enter a new Collection/Group/Target name (as 
desired), then click OK.

To Rename Objects:

 ■ Right-click the object and select Rename from the context menu. 
(If this menu item is not available, choose the Properties menu 
item and the name will be found in that dialog).

Renaming Using Unique Names

Figure 7-12. Automatically 
removing duplicate names.

Occasionally, you will be presented with a file in which several objects 
have the same name. This is sometimes the case when importing an 
external CAD file, for instance. You can easily automatically rename a 
series of objects, ensuring that they all have unique names (Figure 
7-12). SA will rename the objects by appending the type of object 
with a unique number and using that for the new name.

To Rename Objects Using Unique Names:

1. From the menu, select Edit>Rename>Objects by Assigning Unique 
Names.

2. At the prompt, select the objects to rename.

SA will rename each of the objects in turn, ensuring that the names 
are unique.

Renaming Using A Name Pattern
You can rename points and objects using a name pattern. Suppose 
you wish to rename a set of objects and call them Obj1, Obj2, Obj3, 
etc. This would use a name pattern that looks like this: Obj%d. When 
renaming using a name pattern, you can specify any prefix or suffix 
for the name, then add the wildcard %d to the search field. The %d 
characters will be replaced by an actual number when the command 
is performed. By default, the first number is 1, but you can specify 
your own starting value.

To Rename Objects Using a Name Pattern:

1. From the menu, select Edit>Rename>Objects Using a Name Pattern.

2. Select the objects you’d like to rename.

3. In the Pattern for Rename dialog (Figure 7-13), specify the 



205

CHAPTER 7 ■ WORKING IN SA

pattern and a starting value, then click OK.

Figure 7-13. Renaming a 
group of objects using a name 
pattern.

To Rename Points Using a Name Pattern:

1. From the menu, select Edit>Rename>Points Using a Name Pattern.

2. Select the points to rename.

3. In the Pattern for Rename dialog (Figure 7-13), specify the 
pattern and a starting value, then click OK.

Renaming By Proximity
Renaming by auto-corresponding to points uses a group of points as 
a name reference. A different group of points is then renamed based 
on the reference group’s names.

You can rename points by proximity to a set of reference points. This 
is extremely useful for quickly renaming points in preparation for a 
Point to Point Best-Fit operation. When renaming by proximity, SA 
will search for a point in a reference group that is closest to a point 
in the group to rename. As long as the reference point is within the 
specified threshold, the point to rename will be assigned the same 
name as the reference point (see Figure 7-14). Note that the refer-
ence group and group to rename need not have the same number of 
points. Points that don’t have a match will be ignored.

Figure 7-14. Before renam-
ing points by proximity (left) 
and after (right).

The renaming operation is controlled by a proximity distance Match 
tolerance. This is the furthest that a reference point can be located 
relative to the point to rename to be considered a match.

Probably the most common use for this is when remeasuring a set of 
tie-in points after an instrument has drifted (moved) beyond the de-
sired threshold. After remeasuring the tie-in points, since the instru-
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ment has only slightly changed position, they will be relatively close 
to the nominal tie-ins. In this case, you need not be concerned with 
the proper naming of the points. Simply measure them, and SA will 
take care of automatically renaming them for you.

To Automatically Rename Points by Proximity:

1. From the menu, select Edit>Rename>Points by Auto-Corresponding 
2 Groups>Proximity.

2. At the prompt, select the reference group—you may need to 
select it from the tree. This is the group containing the proper 
point names that you’d like to assign to the other group.

3. At the second prompt, select the group to be renamed—you 
may need to select it from the tree.

4. In the Input dialog, specify the Proximity Distance Match Toler-
ance.

5. If any matches are found within the specified threshold, you 
will be presented with the Residuals dialog. This dialog lists 
the original point names, and their proposed new names. 
Click the Save to File button to save this list to a text file, or the 
Accept button to accept the proposed new names.

Renaming By Inter-Point Distance

Figure 7-15. A set of points 
before renaming by inter-
point distance (left) and after 
(right).

You will often want two sets of points to have matching correspond-
ing point names. Suppose you have a set of nominal reference points 
in your SA file that you’d like to use for tie-ins. Assuming your instru-
ment hasn’t yet been located to the nominal points (as it typically will 
not be), the measured points will not be close to the reference points. 
In order for a Point to Point Best-Fit operation to successfully execute, 
corresponding point names must match up. If you forget to name the 
points correctly as you measure them, the fit will not succeed. While 
you could manually rename each individual point, this command 
performs that process automatically (Figure 7-15), and is a big time-
saver in this situation. The command is governed by an inter-point dis-
tance match tolerance. This tolerance is the maximum allowable differ-
ence between the spacing of any proposed pair of renamed points 
and the corresponding spacing of that same pair of points in the ref-
erence group. If the difference exceeds this value, the set is not con-

Note:  If (due to the thresh-
old) matches are found for 

some points but not others, 
points that did not have matches 
will have Orig. prepended to the 
point name. This is to ensure 
uniqueness—another point that 
did have a match may have been 
renamed to the unmatched 
point’s name.

Note:  If the threshold is very 
large, SA will only use the 

closest reference point to each 
measured point.
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sidered a match.

Note that the reference group and group to rename need not have 
the same number of points. Any points that don’t match will be ig-
nored.
To Rename Points By Inter-Point Distance:

1. From the menu, select Edit>Rename>Points by Auto-Corresponding 
2 Groups>Inter-Point Distance.

2. At the prompt, select the reference group containing the de-
sired point names.

3. Then, select the group containing the points to rename.

4. In the Input dialog, enter the desired Inter-point distance match 
tolerance.

5. If any matches are found within the specified threshold, you 
will be presented with the Residuals dialog. This dialog lists 
the original point names, and their proposed new names. 
Click the Save to File button to save this list to a text file, or the 
Accept button to accept the proposed new names.

Deleting Items

To keep your job file clean, you should delete any items that you no 
longer need. If you are certain that a measurement was erroneous, for 
instance, it is best to delete it on the spot and remeasure. This mini-
mizes clutter in the job file and helps make the file more understand-
able. There are numerous ways to delete items in SA.

To Delete Objects:

1. From the menu, select Edit>Delete>Delete Objects, or press the 
Delete key.

2. Select the objects to delete.

To Delete an Entity:

1. Right-click the item in the tree or graphical view.

2. From the context menu, select Delete.

To Delete Points:

1. From the menu, select Edit>Delete Points, or press Alt+D.

2. Select the points to delete.

To Delete Cloud Points:

1. From the menu, select Edit>Delete Cloud Points>Selected Points.

2. Select the cloud points to delete.

Sometimes you may wish to delete cloud points based on their ra-

Note:  If (due to the thresh-
old) matches are found for 

some points but not others, 
points that did not have matches 
will have Orig. prepended to the 
point name. This is to ensure 
uniqueness—another point that 
did have a match may have been 
renamed to the unmatched 
point’s name.

Note:  If the threshold is very 
large, SA will only use the 

closest reference point to each 
measured point.
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dial distance from a set of points. For instance, once you’ve scanned a 
set of registration spheres and extracted the sphere centers, you may 
wish to delete the scan data of the spheres themselves (so they do 
not interfere with other analysis).

To Delete Cloud Points by Their Radial Distance From Reference Points:

1. From the menu, select Edit>Delete Cloud Points>By Radial Distance 
from Points.

2. Select the point cloud(s) of interest.

3. When prompted, pick the points to use as the reference points.

4. Specify a radial distance.

5. At the prompt, specify whether the cloud points inside or out-
side of the radius should be deleted.

To Delete Vectors:

1. From the menu, select Edit>Delete Vectors.

2. Select the vectors to delete.

SA keeps track of the source of objects—whether they were created 
natively in SA or imported from CAD files. As a result, you can delete 
objects that were imported from a specific CAD file.

To Delete Objects From a Specific CAD Source:

1. From the menu, select Edit>Delete>Delete CAD Objects By Source.

2. In the Delete Objects by CAD Source dialog, select the source 
CAD file, then click OK.

To Delete Pictures:

1. From the menu, select Edit>Delete>Delete Pictures.

2. Select the pictures to delete.

To Delete Relationships:

1. From the menu, select Edit>Delete>Delete Pictures.

2. Select the pictures to delete.

The Layer Manager

Often, when working with complex files, you may find yourself show-
ing and hiding sets of related objects in the tree. For instance, if you 
have a CAD model and measurements of several sub-systems on 
an assembly, you may wish to view only a given sub-system in the 
graphical view.

For this purpose, you can create layers. You can assign objects to cer-
tain layers, then show or hide layers. This serves as a very quick way to 
show and hide multiple objects at once.
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Every file contains a Default layer that cannot be deleted.

To Show the Layer Manager:

 ■ From the menu, select View>Layer Manager. The Layer Manager 
dialog appears (Figure 7-16).

Figure 7-16. The Layer 
Manager.

To Define a New Layer:

1. In the SA file, show only those objects you’d like to appear on 
the layer.

2. In the Layer Manager, click the Make New Layer button.

3. Type a new name for the layer, then click OK.

4. The Layer Manager will show the new layer and indicate the 
number of objects on the layer, and the number of objects 
currently visible.

To Show or Hide Layers:

1. In the Layer Manager, select one or more layers to hide or 
show.

2. Click one of the following buttons:

 ■ Hide. Hides the selected layer. Objects already hidden remain 
hidden.

 ■ Hide Only. Hides only the selected layer. Objects on other lay-
ers are shown.

 ■ Hide All. Hides all layers. The only remaining visible objects 
will be those that don’t belong on a layer.

 ■ Show. Shows the selected layer in addition to the objects al-
ready visible.

 ■ Show Only. Shows only the contents of the layer, hiding all 
other objects.

 ■ Show All. Shows all layers. The only remaining hidden objects 
will be those that don’t belong on a layer.
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To Rename a Layer:

1. In the Layer Manager, select the layer to rename, then click 
the Rename button.

2. Type a new name for the layer, then click OK.

To Delete a Layer:

1. In the Layer Manager, select one or more layers to delete.

2. Click one of the following buttons:

 ■ Delete Layers and Entities. Deletes the layers and any objects 
on those layers.

 ■ Delete Layers - Leave Entities. Deletes the layers but any ob-
jects on those layers remain.

To Add or Remove an Object From a Layer:

1. Right-click on the object in the tree or graphical view and se-
lect Layer Info from the context menu.

2. The Layer List dialog appears, showing the layers that cur-
rently contain the object.

Figure 7-17. The Layer List 
dialog. This object is only on 
the default layer.

3. Do one of the following:

 ■ To remove the object from a layer, select the layer and click Re-
move From Layer.

 ■ To add the object to one or more layers, click the Add to Layer 
button. In the Add to Layers dialog, select the layers you’d like 
to add the object to, then click OK.

Configuring SpatialAnalyzer
There are a wide variety of settings in SpatialAnalyzer that provide 
significant control over the application’s configuration. These set-
tings can be stored in one of several different ways, depending on 
the scope of the setting:
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 ■ Factory Defaults. Factory default settings are stored as part of 
SA itself. These are the settings that apply when no other set-
tings override them.

 ■ Job Files. These are settings that are stored as part of the job 
file because it makes the most sense for them to be a property 
of a specific job file. Opening up a job file will restore its job file 
settings, regardless of the computer on which file is opened.

 ■ User Interface Profile. These are settings that are stored as 
part of a customized user interface profile.

 ■ Machine Settings. These settings are stored in the Windows 
Registry and apply at the computer level. Machine settings 
apply on a given computer, regardless of the current job file. 
(Although a user interface profile is stored in a profile file, the 
active profile is stored as a machine setting).

 ■ Persistence Files. Persistence files contain configuration in-
formation and can easily be transferred from one computer to 
another.

Job File Settings

A number of the more general job file settings are described below—
however be aware that this list is not all-inclusive.

Units
Anywhere a number with units is displayed in SA, it is presented in 
the active unit system, unless indicated otherwise. A job file can be 
set to one of five different length units: meters, centimeters, millime-
ters, feet, or inches. Temperature units can be set to either Fahrenheit 
or Celsius. The active job’s length units are displayed in the status bar 
(Figure 7-18). Angular units are always presented in decimal degrees, 
but can be specified to present data in ±180° format or 0-360° format.

Figure 7-18. The active 
length units are displayed in 
the SA Status Bar.

To Change the Job File Units

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Units tab.

3. Select the desired length or temperature units.

To Change the Representation of Angles

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Units tab.
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3. Select the appropriate setting in the Angle Representation box.

To Set the Default Job File Units (No Template File In Use)

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Machine Configuration tab.

3. Click the No Template Default Options button.

4. In the New File Defaults dialog, select the preferred units.

Decimal Precision
Internally, calculations in SA are performed (and numbers are stored) 
with a high degree of decimal precision. However, when numeric re-
sults are displayed in the user interface, they are typically rounded to 
a preferred decimal precision in order to simplify the display. You can 
control the number of decimal places used when displaying different 
categories of values. Specifically, you can independently control deci-
mal precision for length, angle, scale, unit vector, and weight values.

You can change the decimal precision for a given file at any time with-
out incurring any additional internal numerical error.

To Change the Decimal Precision

1. Click the User Options icon in the Main toolbar.

2. In the Decimal Digits for Display box of the Display tab, change 
the Length, Angle, Scale, Unit Vector, and Weight decimal preci-
sion as desired.

To Set the Default Job File Decimal Precision (No Template File In Use)

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Machine Configuration tab.

3. Click the No Template Default Options button.

4. In the New File Defaults dialog, enter the preferred display 
decimal precision.

A Closer Look
Having a different decimal precision for different types of numbers is useful, since different 
types of numbers are expressed in different units.  For example, three digits of decimal preci-
sion for an angle (eg. 0.001°) is only accurate to 3.6 arcseconds--not enough for some applica-
tions. However, three digits of decimal precision in length when working in millimeters is too 

much precision for most applications (1 micron).

Reporting Tolerances
Reporting tolerances specify the threshold at which pointing errors 
or uncertainties are flagged in reports.

Angle-Distance Weights
Angle-distance optimization weighting values provide you with con-
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trol over the weight of angular measurements compared to distance 
measurements for bundle adjustments and point calculation. You 
can weight distance and angular measurement components equally, 
or you can completely disregard distance or angular measurement 
components.

To Edit the Angle-Distance Weights

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, click the 
Edit Angle-Distance Weights button.

3. In the resulting Optimization Weighting Values dialog, drag 
the slider to the left to apply more weight to angular compo-
nents, or to the right to apply more weight to distance com-
ponents. You can optionally type relative weights for each 
into the two text fields.

Optimization Parameters
You have control over a number of parameters involved in certain cal-
culations. These are found in the Optimization Parameters section of 
the Units tab in the User Options.

Convergence Tolerance

Optimizations are involved in many different aspects of SpatialAna-
lyzer’s computations. While these optimizations usually have a sin-
gle “best” answer in theory, in reality often they can only be found 
through iterative analysis. As a result, finding the “correct” answer 
would theoretically take an infinite amount of time.

Consider a best fit optimization: once the computer finds what it 
perceives as the solution that best fits a series of measurements to a 
CAD surface, it will stop. However, if you were to increase the internal 
decimal precision and “jiggle” the points around with even more fine 
movements and rotations, it could find a better solution than the so-
lution initially proposed.

Continuously increasing the decimal precision and making finer ad-
justments becomes unwieldy after a short time, and it would most 
certainly try your patience. While a best fit showing 1x10-12 inches of 
RMS error is better than a best fit showing 1x10-11 inches of error, we 
don’t particularly care, because the difference is much less than the 
accuracy of the measurement in the first place. The additional com-
putation required to reach the better solution is just not worth our 
time.

As a result, SA follows a set of rules that tell it when an optimization 
is “good enough”. When SA notices that the difference between two 
iterations in a solution is smaller than these thresholds, the solution 
terminates, because the result is considered to be “good enough”. The 
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default values provided for the convergence tolerances have been 
found to work well for a wide array of measurement devices and geo-
metric optimizations.

To Edit the Convergence Tolerance Settings

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, specify new 
length and angular convergence tolerance values.

 ■ Length (object fits). When the RMS error of a fit (such as a ge-
ometry fit, surface fit, or relationship fit) does not change by 
more than this value, the optimization process terminates. Us-
ing a smaller value here will theoretically give a better solution, 
but will increase the computation time required for the fit.

 ■ Angular (bundle adj). When the RMS pointing error in a bun-
dle adjustment does not change by more than this value from 
one iteration to the next, the bundle adjustment process ter-
minates. Using a smaller value here will theoretically give a bet-
ter solution, but will increase the computation time required 
for the fit.

Perturbations/Damping

For many of the numeric optimizations within SA, the partials matrix 
is computed using numerical differentiation. A value is changed by a 
delta (referred to as a perturbation), and the result is computed. The 
deltas used to offset the values in an optimization are set here. At each 
step, one portion of the partials matrix is populated. If these values 
are too small, you can experience sensitivity problems. The perturba-
tion may be so small that the change in the objective is negligible 
and therefore the optimization proceeds without accurate direction. 
If the values are too large, it is possible to miss nuances in the solution 
space by moving over the ideal solutions.

To Adjust the Perturbation/Damping Values

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, specify 
new length and angular perturbation values, or specify a new 
damping factor.

 ■ Length Perturbation. The length perturbation is the amount 
of perturbation along the X, Y, and Z axes. In the case of a best-
fit transformation, for example, the X value is adjusted by the 
length perturbation. The objective function is recomputed, 
and this process is repeated with adjustments to the Y and Z 
values.

 ■ Angular Perturbation. After perturbing X, Y, and Z, the Rx val-
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ue is perturbed by the angular perturbation, then Ry, then Rz. 
At each step, one portion of the partials matrix is populated. 
If these values are too small, you can experience sensitivity 
problems. The perturbation may be so small that the change in 
the objective is negligible and therefore the optimization pro-
ceeds without accurate direction. If the values are too large, it 
is possible to miss nuances in the solution space by moving 
over the ideal solutions.

 ■ Damping. Once the partials matrix is computed for a given 
step in an optimization, the matrix is inverted, and multiplied 
by the residual errors. This results in a vector describing how 
to move the input variables to minimize the objective is the 
system were truly linear. Since the systems we deal with in co-
ordinate metrology are usually non-linear, the delta vector will 
most likely not move to the optimal solution. For this reason, 
we scale the vector by the damping factor to retard its effect. 
After making the move, the partial determination process re-
peats until an acceptable solution is reached.

Machine Settings

Although most parameters associated with work in SA are stored as 
part of the job file, many are instead stored on the computer. These 
settings are those that are more appropriate to be consistent on a 
given computer and do not necessarily have anything to do with a 
given SA file. For instance, the setting defining the file system loca-
tion for SA backup files is a setting more appropriate to the computer 
instead of the SA file—regardless of which SA file is opened, it should 
always be saved to a certain backup folder.

SpatialAnalyzer Directories
SA uses a folder structure for storing certain files, such as measure-
ment backups, templates, and instrument interface settings. You can 
control where this folder structure is located. By default, the folder 
structure is placed into the root of the C:\ drive and consists of the 
following:

 ■ C:\Analyzer Data\. The base of the SA folder structure.

 ■ C:\Analyzer Data\Reports\. The location for generated re-
ports.

 ■ C:\Analyzer Data\Templates\. The location for the default 
template file, as well as any other template files or custom user 
interface configuration files.

 ■ C:\Analyzer Data\Scripts\. This folder can be used to store 
Measurement Plan Scripts, although scripts can be located 
anywhere on the file system.
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 ■ C:\Analyzer Data\Persistence\. This folder contains instru-
ment interface settings files, configuration files, parameter 
files, and other configuration information.

 ■ C:\Analyzer Data\Backup\. All automatic backup files are 
saved to this folder. Measurement backups are saved to a sub-
directory of this directory named Measurements.

To Change the Location of SA’s Entire Folder Structure

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab, click the Select Root Directory 
to contain “Analyzer Data” and its subdirectories button.

3. Choose a new folder.

The individual folder locations and names can also be changed di-
rectly from this dialog.

To Change the Location of an Individual SA Directory

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab’s SpatialAnalyzer Directories 
box, select the desired directory.

3. Click the Pick new Directory for Selected Entry button.

4. Select the desired folder from the folder browser.

Parallel Processing
Many operations in SA are multi-threaded, such as USMN calculations, 
surface queries and projection, and point cloud filtering. However, in 
order to reap the substantial performance benefit of multi-threading, 
SA’s parallel processing must be enabled (and your computer must 
support multi-threading).

To Enable Parallel Processing

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab, check the Use multiple proces-
sors if available option.

Fault Handling
Should you ever experience a crash or other serious runtime error 
while using SA, you can configure SA to automatically collect informa-
tion on this error and send it on to New River Kinematics for analysis. 
(This is similar to the Windows error reporting functionality). You can 
also choose to send a large diagnostic file, which is a more complete 
record and picture of SA’s state at the time of the error.

To Enable Fault Handling

1. Click the User Options icon in the Main toolbar.

Note:  When a multi-thread-
ed operation is underway, 

the two gears on the right side of 
the SA status bar will light up.
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2. In the Fault Handling section of the Machine Configuration tab, 
enable the Collect diagnostic info from faults option.

3. To also send large diagnostic files, select the enable large diag-
nostic file option.

Security

You can place security restrictions on SA in order to restrict the access 
of different classes of users to SA’s functionality. For example, you can 
prevent a user or class of users from saving a job file, measuring, de-
leting objects, moving objects, or using Measurement Plans.

To enable security restrictions, you first must create at least two secu-
rity classes: One that provides administrator privileges, and another 
to provide restricted access. A security class defines the rights and 
privileges a group of people belonging to that class will have. The dif-
ferent rights that can be restricted are listed here:

 ■ Edit Security Options. Members can edit security settings 
(normally this privilege is only granted to an administrator 
class).

 ■ Save Jobs. Members can save files.

 ■ Print Jobs. Members can print reports.

 ■ Measure. Members can take measurements.

 ■ Delete Objects. Members can delete objects.

 ■ Delete Points. Members can delete individual points.

 ■ Delete Collections. Members can delete entire collections.

 ■ Import Files. Members can import files into the current job file.

 ■ Move Objects. Members can move (transform) objects.

 ■ Copy Objects. Members can make copies of objects.

 ■ Edit Points. Members can change point and target properties.

 ■ Use MP. Members can run Measurement Plan scripts.

 ■ Instrument Properties. Members can modify instrument 
properties.

 ■ Bundle Adjust. Members can perform bundle adjustments.

To Create a Security Class

1. Click the User Options icon in the Main toolbar.

2. In the Security Classes section of the Security tab, click the New 
button.

3. Give the class a name, and deselect the privileges you’d like to 
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restrict. Then click OK.

To Remove a Security Class

 ■ In the Security Classes section of the Security tab, select the class 
you’d like to delete and click the Remove button.

To Edit a Security Class

1. In the Security Classes section of the Security tab, select the class 
you’d like to edit and click the Edit button.

2. Change the name of the class and/or the associated privileg-
es, then click OK.

Once two or more classes have been created, you need to create 
users. These users need not refer to unique people (although they 
can)—that is, multiple people can use the same user name.

To Create Users

1. In the Users section of the Security tab, click the New button.

2. Enter a name for the user, then type and confirm a password 
for the user.

To Remove Users

 ■ In the Users section of the Security tab, select the user you’d like 
to delete, then click the Remove button.

To Edit Users

1. In the Users section of the Security tab, select the user you’d like 
to edit, then click the Edit button.

2. Modify the username and/or the password for the user, then 
click OK.

The last step, once classes and users have been created, is to assign 
users to a class. A single user can belong to one or more classes. When 
a user belongs to more than one class, the user receives the combined 
privileges of all classes to which he belongs.

To Assign Classes To a User

1. In the Users section of the Security tab, select the user you’d like 
to assign to a security class.

2. Next to the Belongs to classes box, click the Add button.

3. Select a class to add to the user, then click OK.

To Remove a Class From a User

1. In the Users section of the Security tab, select the user to mod-
ify.

2. In the Belongs to classes box, select the class to remove from 
the user.
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3. Click the Remove button.

Once your users, security classes, and privileges have been set up, you 
must enable security restrictions in SA, or else no change in behavior 
will occur.

To Enable Security

1. Click the User Options icon in the Main toolbar.

2. In the Security tab, ensure that all classes and users are set up 
correctly. Also verify that at least one user has full access to 
the edit Security Options privilege, and that the user’s user-
name and password is known.

3. Uncheck the always auto-login with full access checkbox.

4. Restart SA. A username and password will be required to start 
the application.

With the always auto-login with full access option disabled, you can 
also use the Login Now button to log in as a different user without 
restarting SA. This is useful for conveniently testing the privileges of 
different security classes.

To Disable Security

1. Login to SA using a username that has access to the edit Secu-
rity Options privilege (typically the “administrator”).

2. Click the User Options icon in the Main toolbar.

3. In the Security tab, enable the always auto-login with full access 
option.

System Diagnostics
SA provides a number of system tools and utilities to monitor config-
uration and diagnose potential issues with your system or file setup. 
These tools are listed below.

Memory Monitor

Large files (particularly those containing dense scan data or complex 
CAD files) can easily consume the available RAM on your system. To 
monitor your available/used RAM, SA provides a convenient memory 
monitor utility, which displays SA’s memory usage, total system mem-
ory usage, total RAM, and operating system information.

To View the Memory Monitor

 ■ From the menu, select Help>Diagnostics>Memory Monitor.
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Check Job Data Consistency

You can verify the integrity and consistency of any SA file. This tool 
will examine an SA file and verify that there are no corrupt internal 
references.

To Verify the Integrity of an SA File

1. Open the SA file.

2. Select Help>Diagnostics>Advanced>Check Job Data Consistency.

3. A dialog will be displayed indicating whether any errors were 
found, and a log of the findings will be saved to the Analyz-
er Data\Reports\_SAJobFileConsistencyReport.
txt file.

Regenerate References

If any issues are found with the Check Job Data Consistency tool, you 
can attempt to repair them by regenerating references. This will walk 
through the measurements and ensure that each measured point has 
the proper references to its targets.

To Re-Generate Target References

1. Open the SA file.

2. From the menu, select Help>Diagnostics>Advanced>Re-Generate 
Measurement to Target References.

Repeating Commands
Occasionally, the need comes up to repeat a command, perhaps sev-
eral times. While you could search through the menus to find the de-
sired command and select it again, such an approach is not efficient. 
Instead, you can use a keyboard shortcut to repeat the last executed 
command.

To Repeat the Last Executed Command:

 ■ Press Ctrl+Tab, or select Scripts>Repeat Command.

In other cases, you may need to repeat a series of non-consecutive 
commands several times. In such a situation, the Repeat Command 
menu option will not help you, since it only executes the most recent 
command. Instead, you can ask SA to display a command history of 
the most recently executed commands (Figure 7-19), with the most 
recent at the top.

Note:  Regenerating refer-
ences is not normally neces-

sary. It should only be performed 
if a job file consistency check indi-
cates errors.
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Figure 7-19. The command 
history.

To Select a Recent Command From the Command History:

 ■ Press Ctrl+Shift+Tab or select Scripts>Command History, then 
select the desired command from the resulting list.

Working With Items
Many items in an SA job have some sort of representation in space. 
In a few cases in which the items are containers (collections, folders, 
point groups, and categories), the position and orientation of an item 
is not clearly defined, but still exists. For example, a collection can be 
moved and rotated (that is—a relative movement can be applied to 
it), but you would have a difficult time determining where that col-
lection is specifically located in space. The list below indicates the de-
fined positions and orientations of the various items in SA that have a 
representation in space:

 ■ Folders. The specific position and orientation is undefined.

 ■ Collections. The specific position and orientation is undefined.

 ■ Coordinate Frames. The position is defined by its origin, and 
its orientation is defined by its axes. The primary direction of a 
coordinate frame is its Z axis.

 ■ Point Groups. The specific position and orientation is unde-
fined.

 ■ Lines. The position is defined by its “begin” point. The line itself 
describes its Z direction.

 ■ Instruments. The position is determined by the base, optical 
center, or other defined origin of the instrument. The stand-
ing axis of an instrument is its Z axis, and typically the X axis 
is defined by the “front” of the instrument (although this is not 
always the case).
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 ■ B-Splines. The specific position and orientation is undefined.

 ■ Planes. The position is defined by its centroid. The Z axis is de-
fined by its normal, and its X axis is typically defined by the first 
defined point in the plane.

 ■ Circles. The position is defined by its center. The Z axis is de-
fined by its normal, but the X and Y axes are undefined.

 ■ Ellipses. The position is defined by its center and the Z axis is 
defined by its normal. The X axis is defined by its major axis, 
and the Y axis is defined by its minor axis.

 ■ Cylinders. The position is defined by the center of its “begin” 
end. The Z axis is defined by its axis. The X and Y axes are un-
defined.

 ■ Spheres. The position is defined by its center, and the X axis 
passes through its poles. The Y and Z axes are undefined.

 ■ Cones. The position is defined by its apex, and the Z axis is de-
fined by its axis. The X and Y axes are undefined.

 ■ Paraboloids. The position is defined by its focal point, and the 
Z axis by its axis. The X and Y axes are undefined.

 ■ Polygonized Surfaces, Surfaces, Vector Groups, Point 
Clouds, and Perimeters. The specific positions and orienta-
tions are undefined.

 ■ Graphical Entities. Each has a defined position and orienta-
tion, but graphical entities are only for graphical purposes and 
are not useful in analysis.

If you’re wondering why this is important, it’s because many different 
operations in SA that require you to define a position or orientation 
allow you select most of the items above to describe that position or 
orientation. For instance, if in the process of constructing a new coor-
dinate frame you’re prompted to specify the X direction for the frame, 
selecting a circle is a valid selection for that prompt—SA will use the 
normal direction of the circle to define the X direction.

All of the objects listed above have a number of common character-
istics, discussed below.

Moving Objects

While there are many commands to automatically apply transforma-
tions to objects based on special alignments and fits, all of the items 
mentioned in “Working With Items” above can be moved manually 
through any of several methods. These methods are described below.
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Entering a Transform

Figure 7-20. The Move Ob-
jects dialog.

The Move Objects dialog (Figure 7-20) provides the ability to apply a 
relative movement to an object by typing in values, expressed in the 
active coordinate frame. In this dialog, you can explicitly type in the 
positional and rotational deltas—these values are initially zero be-
cause they are relative movements from a starting position. Positional 
deltas can be entered in Cartesian (xyz), Cylindrical (rθz), or Spherical 
(rθϕ) values. Rotational deltas can be entered in Fixed notation, euler 
notation, equivalent angle axis notation, or as euler parameters.

To Move One or More Objects by Typing In Values:

1. Right-click an object in the tree or graphical view and select 
Move. Or, to move multiple objects simultaneously, select 
Edit>Move Objects>Enter Transformation and select the objects you 
wish to move.

2. In the Move Objects dialog (Figure 7-20), select the proper for-
mat in which to enter the values from the dropdowns in the 
Position and Orientation boxes. Usually, Cartesian XYZ and Fixed 
XYZ is the intended format.

3. Type in the appropriate values, then press Enter or click the 
Update button.

To Reset an Object Back To Its Original Position:

 ■ Click the Reset button, or

 ■ Manually type zeroes into all numeric fields, then press Enter.

Transforms can be copied from one dialog and pasted in another. This 
allows you to manually transform an object in the Move Objects dia-
log, then apply that same transform to another object.

To Copy and Paste Transforms Between Instruments:

1. In the Move Objects dialog, ensure the transform you want to 
copy is entered.

2. Click the Copy button.

3. Call up the Move Objects dialog for the destination object (see 
“To Move One or More Objects by Typing In Values:” above).
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4. Click Paste.

If you are performing an analysis of your own, you can copy and paste 
raw 4×4 transform matrices between objects, and also export trans-
forms to a comma-delimited .CSV file.

To Copy and Paste Transform Matrices Between Objects:

1. In the Move Objects dialog, click the View Matrix button.

2. In the Transformation Matrix dialog, click the Copy button to 
copy the current matrix to the clipboard, or click Export .csv to 
send it to a comma-delimited file.

3. Call up the Transformation Matrix dialog for the destination 
object.

4. Check the allow editing checkbox, which enables manual ed-
iting of an object’s 4×4 transform matrix.

5. Click the Paste button, or choose Import .csv to import the ma-
trix from a comma-delimited file.

To Edit An Object’s Transformation Matrix Directly:

1. In the Move Objects dialog, click the View Matrix button.

2. Enable the allow editing checkbox.

3. Type the desired values into the 4×4 matrix.

Graphical Dragging
You may wish to move objects by dragging them graphically in the 
view. This is a great way to visually position objects in an approximate 
way without being concerned with exact transformation values.

To Drag Objects Graphically:

1. From the menus, select Edit>Move Objects>Drag Graphically.

2. At the prompt, select the objects you wish to move, then 
press Enter.

3. Use the left mouse button to move the object, and the right 
mouse button to rotate it about an axis perpendicular to the 
view orientation. When finished, press Enter.

Frame to Frame Transformations
Frame to frame transformations make note of the transformation re-
quired to go from one coordinate frame (the source frame) to another 
(the destination frame), and then applies that transformation to se-
lected objects (Figure 7-21).

Tip:  To rotate the object 
about different axes, use 

saved viewpoints to switch to dif-
ferent views without cancelling 
out of the command.
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Figure 7-21. An object prior 
to (top) and after (bottom) a 
frame to frame transformation.

An interesting characteristic about coordinate frames is that they 
store complete information on position and orientation. As a result, 
they can be used to keep a record of an object’s position. As an exten-
sion to that idea, two different coordinate frames store a positional 
and rotational delta (a transformation). Frame to frame transforma-
tions take advantage of this fact. If you plan on applying a transfor-
mation to an object, you can store the object’s initial position by cre-
ating a coordinate frame at its location (the Construct>Frames>On an 
Object command is very handy for this). If, after moving the object, you 
change your mind and would like to put it back to its original posi-
tion, you can create a frame on the object’s current position, then use 
a frame to frame transformation to move the object back to it’s origi-
nal location.

To Apply a Frame to Frame Transformation:

1. From the menu, select Edit>Move Objects>Frame to Frame Transfor-
mation.

2. At the prompt, select the source frame. This is the coordinate 
frame that the transformation will be calculated from.

3. Select the destination frame. This is the coordinate frame that 
the transformation will be calculated to.

4. Now that the positional and rotational deltas have been cal-
culated, select the objects to which you’d like to apply the 
transform. You may choose the source or destination frame, 
if desired.
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5. Confirm or reject the transformation at the prompt.

Point to Point Delta Translations

Figure 7-22. A circle is being 
moved to a nominal position 
through the use of a point 
to point translation. In this 
example, Measured Center 
is the source point, and Nomi-
nal Center is the destina-
tion point.

Often, you will want to apply a pure translation (movement in XYZ 
but no rotation) to one or more objects. Point to point delta transfor-
mations use a source point and a destination point to calculate a po-
sitional delta to apply to one or more objects (Figure 7-22). A point to 
point delta transformation is the 3 degree of freedom analog to a 
frame to frame transformation (which involves movement in 6 de-
grees of freedom). Just as frames can record an object’s position and 
orientation in space, points can record an object’s position in space. 
As such, point to point translations are reversible and can be used to 
“undo” a translation applied to an object—simply reverse the source 
and destination points.

To Move Objects Using a Point to Point Translation:

1. Select Edit>Move Objects>Translate by Point to Point Delta.

2. At the prompt, select the first (source) point.

3. Select the second (destination) point.

4. Choose the objects to translate.

Translating Using Instrument Updates
Updates from a 3 degree-of-freedom device such as a laser tracker 
can be used to translate one or more objects. Note that this is a pure 
translation--no rotations are applied.

When the command is initiated, the initial target position is recorded. 
As the target moves from this initial position, the translation is ap-
plied to the selected objects.

To Translate Objects Using Instrument Updates:

1. Select Edit>Move Objects>Translate Using Instrument Updates.
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2. At the prompt, select the instruments (if more than one exists 
in the file) and the objects you’d like to move. These objects 
will move together as a rigid body.

3. The Translate Objects - by Instrument dialog will appear (see 
Figure 7-23).

Figure 7-23. Translating 
objects using an instrument’s 
3 degree-of-freedom updates.

4. When measurement updates are received from the instru-
ment, the objects will be translated.

5. When finished, you can either click Cancel: Restore Original 
Position, which will put the objects back in their original loca-
tion, or click OK: Leave Objects in Current Position, which will 
accept the transformation and apply it to the objects.

Transforming in 6D Using Instrument Updates
Updates from a 6 degree-of-freedom device (such as a T-Probe, por-
table arm, T-Mac, or STS) can be used to transform one or more ob-
jects. The positional and rotational delta experienced by the device is 
applied to the objects involved in the transformation.

When the command is initiated, the position and orientation of the 
device is recorded. As the device moves and rotates from this initial 
position, the transformation is applied to the selected objects.

To Transform Objects in 6 Degrees of Freedom Using an Instrument’s Updates:

1. Select Edit>Move Objects>Transform in 6D Using Instrument Updates.

2. At the prompt, select the instruments (if more than one exists 
in the file) and the objects you’d like to transform. These ob-
jects will move and rotate together as a rigid body.

3. The Transform (6D) Objects - by Instrument dialog will appear 
(Figure 7-24).
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Figure 7-24. Transforming 
objects using an instrument’s 
6 degree-of-freedom updates.

4. When 6-DOF measurement updates are received from the in-
strument, the object position and orientation will be updated 
automatically.

5. When finished, you can either click Cancel: Leave Objects in 
Current Position to accept the transformation, or Cancel: Re-
store Original Position to move the objects back to their origi-
nal position.

Transforming in 6D Using Multiple Instrument Updates
SA has the capability of synchronizing three degree-of-freedom mea-
surements from 3 or more instruments and combining them to cal-
culate a six degree-of-freedom transformation. This is commonly re-
ferred to as trans-track. For Trans-Track to function correctly, three or 
more instruments must first be tied to a common coordinate system. 
This can be achieved using any accepted technique, such as USMN, 
bundling, or best-fit. Once the instruments are tied together, each in-
strument must measure a single point, which becomes the reference 
point for that instrument.

The Trans-Track operation is then started, and the instruments are si-
multaneously polled for updates. A real-time transformation is then 
calculated, and that transformation is applied to any objects of choice.

To Transform in 6D Using Multiple Instrument Updates:

1. Ensure that you have three or more instruments tied togeth-
er to the same reference system (usually a set of common 
points), and that their interfaces are all running in SA.

2. Affix three targets to the moving object, with one instrument 
watching each target--these will be your reference points.

3. Measure a single reference point from each of the instru-
ments.

4. From the menus, select Edit>Move Objects>Transform in 6D Using 
Multiple Instrument Updates.

Tip:  Spread reference points 
apart as far as possible to 

minimize angular errors in Trans-
Track.

Tip:  The accuracy of the 
Trans-Track operation is limit-

ed to the accuracy of the net-
work, so try to tie instruments to-
gether as accurately as possible.
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5. When prompted, select the instruments that will be part of 
the operation. You must be explicit about the order in which 
you pick the instruments.

6. Now select the earlier-measured reference points that corre-
spond with the instruments. The points must be selected in 
the same order as the instruments. (That is, select the first in-
strument’s reference point first, then the second instrument’s 
point, etc.)

7. When prompted, select the object or objects to which you’d 
like the transformation applied.

8. The Transform Using Multiple Instrument Updates dialog will 
appear (see Figure 7-25).

9. Click the Query Instruments button, and SA will begin polling 
the instruments and calculating the transformation. The dia-
log will list the fit error between the live set of points and the 
reference set. The time lapse among the measurements is also 
displayed.

10. When finished, press Done: Leave Objects in Current Position to 
accept the transformation, or Cancel: Restore Original Position 
to undo any movement.

The Trans-Track dialog also has a few settings that can be modified 
(see Figure 7-26):

 ■ Point Best-Fit Error Tolerance. If a point’s best fit error to the 
corresponding reference point exceeds this threshold, the 
point will be highlighted as a warning.

 ■ Time Lapse Tolerance (sec.). If the time difference between 
the first point and another point exceeds this threshold, the 
point will be highlighted as a warning, indicating that the mea-
surement sync was not acceptable. This can be ignored when-
ever the targets are stationary.

 ■ Delay after update (sec.). The time delay between one set of 
measurements and the next.

Tip:  Be careful to place tar-
gets such that they will be 

visible throughout the range of 
motion of the moving object.

Tip:  Measurements cannot 
be perfectly synced, there-

fore slower movement will result 
in more accurate real-time trans-
formations due to a smaller time 
delay among the instrument 
measurements. Allowing the tar-
gets to become stationary for a 
moment will remove sync-based 
error from the transformation.
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Figure 7-25. Performing a 
Trans-Track operation with 
three laser trackers.

Figure 7-26. Trans-Track 
settings.

Transforming in 6D Using a Batch of Points from an Instrument
Some instrument systems, such as photogrammetry systems, are 
capable of tracking several points simultaneously. SA is capable of 
watching this batch of points and updating the transformation of 
one or more objects as the updates arrive. Since this command only 
involves one instrument, alignment among multiple instruments is 
not required as it is with Transform in 6D Using Multiple Instrument Updates.

To Transform Objects in 6D Using a Batch of Points From An Instrument:

1. From the menus, select Edit>Move Objects>Transform in 6D Using a 
Batch of Points from an Instrument.

2. Select the object(s) that you would like to transform.

3. The Trans-Track a Point Set dialog appears (Figure 7-27).

4. Before moving anything, measure a set of points. This will be 
used as the reference for the initial position.
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Figure 7-27. The Trans-Track 
a Point Set dialog appears.

5. As each set of measurements are taken, the position of the 
selected objects will be updated, and the fit error will be re-
ported in the dialog.

6. When finished, click Done: Leave Objects in Current Position to 
accept the transformation, or Cancel: Restore Object Positions 
to cancel the command and put all objects back into their 
original positions.

Guiding Objects in 6D Using Point Measurements
If you would like to apply 6 degree-of-freedom transformations to 
one or more objects, but only have a 3 degree-of-freedom device 
available, then you can measure a set of reference points to serve as 
the controls for a 6 degree-of-freedom transformation.

The process involves measuring a set of reference points affixed to 
the moving object, and creating a corresponding set of “goal” points 
which represent these reference points transformed to the desired fi-
nal location. You then repeatedly measure the reference points on the 
moving object, and SA will update the position of the moving objects 
and also display a watch window indicating the required motion to 
transform from the current position to the final position (Figure 7-28).
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Figure 7-28. Guiding objects 
using point measurements.

The controls for guiding in 6D are shown in Figure 7-29.

Figure 7-29. The Translate 
Objects using Instrument 
Point Measurements dialog.

 ■ Measurement Group. Defines the name of the point group 
containing the measured points. If you change this, you must 
click the Apply button.

 ■ Cycle All Points. When clicked, this button cycles through all 
reference points, points at their last measured position, search-
es, locks, and measures each point (applies to steerable, tar-
geted instruments only).

 ■ Measure Selected Point. Measures a point and associates it 
with the selected point in the table.

 ■ 3D Translate in Real-Time. Select a point in the table, then 
click this button. SA will track the target as this point and trans-
late the moving objects. This is useful for getting real-time 
feedback on movement, without considering rotational in-
formation. Once you dial in the position, you can switch back 
to full 6 degree-of-freedom measurement of your reference 
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points by toggling this mode back off.

 ■ Watch. Click this button to open a watch window showing the 
transformation, in the active frame, required to get from the 
current position to the goal position.

To Guide Objects in 6D Using Point Measurements:

1. Locate into a coordinate system as necessary.

2. Measure a set of reference points on the moving object. Three 
are required at a bare minimum, more are better.

3. Create a set of corresponding goal points in the destination 
position. This is usually accomplished by copying the refer-
ence group and applying an appropriate transformation to 
the copy.

4. From the menu, select Edit>Move Objects>Guide Objects in 6D using 
Point Measurements.

5. At the prompt, select the destination (goal) group.

6. Select the reference group on the moving object.

7. Select any additional objects you’d like to transform.

8. When the dialog appears, select the appropriate point in the 
table and click Measure Selected Point to measure it. Or, en-
sure targets exist at each reference location and click Cycle All 
Points to measure them all automatically.

9. Using the reported transform, apply the desired movement to 
the moving objects, then repeat the measurement.

10. When satisfied with the final position, click Done: Leave Ob-
jects in Current Position to accept the transformation.

Copying Objects
Objects can be copied. The copy is always placed into the active col-
lection. If the collection containing the copied object is the active col-
lection, the object will be renamed as necessary to maintain unique-
ness. There are two main methods for copying an object: Copying 
and then applying a transform (which can be unity to leave the object 
unmoved), or copying and then applying a point to point translation. 
Keep in mind that since point groups are objects, copying a point 
group will duplicate that group of points. However, since the copied 
points were not actual measured points (after all, they are copies) 
they will be depicted as constructed points.

It is probably most common for copies to be made without applying 
any transformation so that the copy is in the same position as the 
original.

Tip:  Just as with a best fit or 
trans-track operation, spread 

your reference points out to im-
prove your baseline and reduce 
angular errors in the solution.

Note:  When using “Cycle All 
Points”, movements must be 

small enough relative to the pre-
viously measured position to en-
sure that the instrument can still 
find the targets.
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Copy, Then Transform
This method first creates a copy of one or more objects, then permits 
you to optionally type in a transformation to move the copies.

To Copy then Transform:

1. Right-click an object in the tree or graphical view and select 
Copy; or, to copy multiple objects, select Edit>Copy Objects>Copy 
Then Transform or press Ctrl+C.

2. If copying multiple objects, select the objects.

3. The Copy Objects dialog will appear, which is identical to the 
Move Objects dialog. Enter the desired transformation to ap-
ply, or leave the values zeroed out to leave the copy in place.

Copy, Then Translate Point to Point
If you’d just like to translate the copies only, you can create a copy and 
apply a point to point translation to them. This is the copy-based ver-
sion of moving objects using a point to point translation.

To Copy Using Translation Only:

1. In the menus, select Edit>Copy Objects>Translate by Point to Point 
Delta.

2. At the prompt, select the first (source) point.

3. Select the second (destination) point.

4. Specify the objects you’d like to copy, then press Enter.

Mirroring Objects

Objects can be mirrored (reflected) about any of a frame’s three 
planes (XY, XZ, or YZ). This is most often used with symmetric parts. 
For example, if certain nominal features of an aircraft model are only 
available on the left side, it will need to be mirrored to the right side 
when it comes time to work on the right side of the aircraft.

You can either create a mirrored copy of selected objects (creates a 
duplicate, then reflects the duplicate), or you can mirror the objects 
directly without creating any copies. Mirrored copies are placed into 
the active collection and are renamed as necessary to ensure unique-
ness. An object moved via a mirroring operation will not be renamed 
at all. Always use care when mirroring—depending on the object be-
ing reflected and the plane being mirrored about, the object’s normal 
may flip directions.

To Mirror One or More Objects:

1. Select Edit>Mirror Objects>Move (to mirror the source objects) or 
>Copy (to mirror copies of the source objects).
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2. Select the frame about which to mirror.

3. Select the objects to mirror, then press Enter.

4. In the Select Mirror Plane dialog, choose the plane about 
which to mirror, then click the Mirror button.

Scaling Objects

Any object may be scaled by an arbitrary amount. This yields an ob-
ject that has grown or shrunk by the corresponding scale factor rela-
tive to the active coordinate frame. Since the scaling is applied rela-
tive to the active coordinate frame, scaling generally also results in 
object translation (except for a point on the origin of the active frame).

Two different methods can be used for scaling:

 ■ Calculate Scale Based on CTE. With this option, you select a 
material and an initial and final temperature, and SA calculates 
the scale factor automatically using the linear thermal expan-
sion equation. The material entered should be the material of 
the objects being scaled. For example, if you are scaling mea-
surements of a steel plate, steel should be used for the material.

 ■ Enter Scale Manually. You can enter your own scale factor. As 
an example, a scale factor of 2.0 will double the size of the ob-
ject.

To Scale One or More Objects:

1. From the menus, choose Edit>Scale Objects.

2. 

Figure 7-30. The Scaling 
dialog.

At the prompt, select the objects to scale, then press Enter. 
The Scaling dialog will be displayed (see Figure 7-30).

3. Choose the scaling method (either Calculate Scale Based on 
Cte or enter Scale Manually).

Warning:  The most com-
mon situation in which 
an object is scaled is 

when you have point groups or 
other data that is not associated 
with an instrument and you want 
to apply a temperature compen-
sation to it. Other than this situa-
tion, it is not common and is usu-
ally more appropriate to apply a 
scale factor to an instrument.

Note:  The list of materials in 
the CTE Editor is stored in 

the SA file. If you’d like a modifica-
tion to appear in all files, save your 
SA file as a default template.
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4. If scaling manually, enter the desired scale factor. If scaling us-
ing CTE, choose the appropriate material and initial/final tem-
perature. Then click OK.

If the default list of materials is not sufficient for your needs, you may 
wish to enter your own material with a custom coefficient of thermal 
expansion.

To Enter a Custom Material and CTE:

1. In the Scaling dialog, click the Edit button.

2.  In the CTE Editor, use the Add, Edit, and Remove buttons to 
modify the list of materials, then click Done.

Finding Items In The Tree

While working in the graphical view (particularly if the job file is com-
plex and has many entities), you may need to find an item in the tree. 
Searching for the item through the tree is cumbersome in complex 
files, so SA provides the ability to find any item in the tree.

To Find an Item In the Tree:

 ■ In the graphical view, right-click the item and select Show In Tree 
from the context menu. SA will expand, autoscroll, and select 
the item in the tree for you.

Network Browser
SA is a very network-capable application. You may be viewing an SA 
instance running on another computer on your network, or you may 
be connecting an instrument interface to another computer on the 
network. The SA Network Browser allows you to view the network 
and perform a few network-related diagnostic operations.

To Access the SA Network Browser:

 ■ Click the SA Network icon in the Main Toolbar.

The SA Network Browser dialog (Figure 7-31) displays at the root level 
all computers running SA that are visibile on the network, along with 
their IP address. In Figure 7-31, there are four computers running SA 
on the network.
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Figure 7-31. This SA Net-
work Browser lists a number 
of instances of SA running on 
four different computers.

Below the computer name will be listed all open SA files on each com-
puter, and below that all unconnected instruments or other connec-
tions that can be made. In Figure 7-31, the computer named T-SCAN 
has two possible connections: A connection to the Remote Monitor 
and the Remote Window Viewer.

To Refresh the Network Browser List:

 ■ Click the Refresh button.

To Run the Check My Computer Tool:

 ■ Click the Check My Computer button.

To View the IP Settings of Your Computer:

 ■ Click the IP Config button.

To Ping an IP Address:

 ■ Type an IP address into the text field, then click the Ping button.

Remote Monitoring
SA provides the capability to pull an open SA file from any computer  
reachable on the network and work with it. You can also remotely 
view the SA application, graphical view, or HUD windows from an-
other computer (if applicable).

For privacy and security reasons, both of these remote viewing ca-
pabilities require the computer being monitored to have its remote 
Viewable option set.
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To Make a Computer Viewable Via Remote Monitoring:

1. Visit the User Options by clicking the User Options icon on 
the toolbar.

2. Navigate to the Machine Configuration tab and check the re-
mote Viewable option.

Figure 7-32. The remote 
Viewable option.

To Work With the Current File From Another Network Computer:

1. From the menu, select File>Remote Monitor another SpatialAna-
lyzer.

2. When the Remote Monitor Options dialog appears, double-
click any SA file’s Remote Monitor option. Or, select the Use 
manual entry of ip (or computer) and port option and manually 
enter the IP address or computer name and port number to 
connect to, then click OK.

The file will be pulled from the other computer and opened. A time-
stamp will appear in the corner of the graphical view to indicate the 
time when the file was pulled (Figure 7-33).

Figure 7-33. Remotely moni-
toring another instance of SA 
on the network.

To View an Active Window From a Remote Instance of SA:

1. From the menu, select File>Remote Window Viewer.

2. In the resulting Remote Window Monitor Options dialog, dou-
ble-click the Remote Window Viewer entry that you’d like to 

Note:  Computers with the 
remote Viewable option 

turned off will not be visible in 
this list.

Note:  When remote moni-
toring, SA essentially saves 

the file from the remote computer 
and loads it on the local comput-
er. No link is maintained between 
the two files after that point.
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connect to, or select the Use manual entry of ip (or computer) 
and port option and enter an IP address/computer name and 
port number, then click OK.

3. When the Select Remote Window dialog appears, select the 
desired option, then click OK. A separate window will appear, 
which will periodically get updated. You are now watching 
the other computer’s SA instance, live.

Working With The Clipboard
The Windows clipboard is the fastest way for transferring data within 
or among applications. It is far better than manually typing data into 
a different program, and it faster and “cleaner” then exporting data to 
a file and re-importing in the other application.

You can copy the graphical view to the clipboard as an image for past-
ing into any program that supports standard image formats.

To Copy the Graphical View to the Clipboard:

 ■ From the menu, select Edit>Copy graphics to clipboard.

If you’ve copied point data from another source—perhaps an Excel 
file or Notepad text file, you can paste it directly into SA.

To Paste Points From the Clipboard:

1. In the source application (Notepad, Excel, etc.), select the data 
and copy it to the clipboard.

2. From the SA menu, select Edit>Paste Points from Clipboard.

3. Select the appropriate ASCII import options (see the chap-
ter on File Import for detailed information on these options), 
then click Import.

Setting the Working Frame
While working in SpatialAnalyzer, all data is represented relative to 
the active (working) coordinate frame, unless you have specified oth-
erwise. When you examine a point’s coordinates, for instance, you 
are seeing those coordinates relative to the working frame. When 
moving an object, you are entering positional and rotational deltas 
with respect to the working frame. When performing a best-fit and 
restricting rotation about the X or Y axis, the X and Y axes are defined 
by the working frame. As a result, staying mindful of the active frame 
while working in SA is very important.

You can create as many coordinate frames in your job file as you want 
or need. You can also freely switch from one active frame to another 
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at any time. This allows you to view deltas, specify rotational values, or 
look at coordinates with respect to any frame of reference.

To Change the Working Frame:

Do one of the following:

 ■ Click the Working Frame button , then se-
lect the new desired working frame from the list, or

 ■ From the menu, select Edit>Pick Working Frame, and select the 
new frame, or

 ■ Press Alt+W (the default keyboard shortcut), and select the 
new frame, or

 ■ Right-click any coordinate frame you’d like to activate and se-
lect Make Working Frame.

About the World Frame

The WORLD frame exists in every SA file and cannot be removed. This 
frame serves as the reference or base coordinate system for every-
thing in your file. While you can move the world frame, there is usually 
no reason to do so. Deleting a world frame which has been moved 
from its original location will result in automatic creation of a new 
world frame in the original location (which explains why moving a 
world frame could cause confusion if you are not careful).

Object Color
Objects can be given any color, or painted, which you can use for any 
purpose. You can use the color of an object for organizational pur-
poses, to assign special meaning to an object, or simply to make it 
look good. It’s up to you to decide.

SA uses the concept of a working color. Every time a new object is cre-
ated, it is given a color. The color that is assigned is the current—or 
working—color. Think of the working color as an open can of paint—
each object you create is painted, and the working color is used for 
that painting job.

By default, the working color is set to automatically increment. That 
is, when an object is created and assigned a color, the next color in 
a list of 13 random colors is automatically made the working color. 
The result of this is that repeated object creation results in objects of 
different colors so that they are more clearly distinguishable in the 
graphical view.

Warning:  Moving the 
World frame can be dan-
gerous if you are not care-

ful. Modifying this frame requires 
care and is generally not neces-
sary.
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Figure 7-34. Toggling the 
automatically increment color 
option in the Working Color 
dialog.

Successive creation of multiple objects in different colors may be a 
behavior that you like—or, depending on what you’re doing, it may 
not. For instance, you may wish to create a number of nominal objects 
all of the same color, using the assigned color as a cue that the objects 
are in their nominal configuration. In this situation, the automatically 
incrementing working color is not desirable. You can disable working 
color auto-increment so that the current color remains the working 
color until you explicitly change it.

To Set the Working Color:

1. Do one of the following:

 ■ In the Color/WCF toolbar, click the color swatch button , 
which dispays the working color, or

 ■ From the menu, select Edit>Change Working Color.

2. Select a new working color, then click OK. The next object cre-
ated will be assigned the working color.

To Turn Working Color Auto-Increment On or Off:

1. In the Color/WCF toolbar, click the color swatch button .

2. In the Working Color dialog (Figure 7-34), toggle the auto-
matically increment color option.

To Change the Color of One or More Objects:

1. Choose the desired working color as described above in “To 
Set the Working Color:” on page 241.

2. From the toolbar, click the Color Objects button , or select 
Edit>Set Objects to Working Color.

3. Select the objects to paint.

Note:  Selecting Edit>Change 
Working Color does not allow 

selection from a list of existing 
working colors. On the other 
hand, selecting the toolbar but-
ton does.
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You can also change the color of an object directly through its prop-
erties.

To Change the Color of an Object Through Its Properties:

1. Right-click the object in the tree or graphical view and select 
Properties from the context menu.

Figure 7-35. Changing the 
color of a circle through its 
properties dialog.

2. In the dialog (Figure 7-35), click the Color button. Select a new 
color, then click OK.

Accessing Item Properties
Nearly every item in your job has properties associated with it. Some 
properties are general—such as the name of the item and any notes 
associated with it—and other properties are more specific and de-
pend on the object type. These more specific properties are discussed 
in detail later.

To Access the Properties of an Item:

Do one of the following:

 ■ Right-click the item in the tree or graphical view and select 
Properties from the context menu, or

 ■ From the toolbar, click the Object Properties button , then 
select the object to examine (applies to objects only), or

 ■ From the menu, select Edit>Object Properties, then select the ob-
ject to examine (applies to objects only), or

 ■ Press Alt+Q (default keyboard shortcut), then select the object 
to examine (applies to objects only).
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The Calculator
Since you may find the need to perform a quick calculation fairly fre-
quently in SA, a shortcut is provided for calling up the Windows cal-
culator utility.

To Start the Windows Calculator Utility:

 ■ From the menu, select Edit>Calculator.

User Notes
Occasionally you may be interested in recording some field notes. 
You can add user notes to an SA job for later reference or for adding 
to a report. A user note will be added to the tree under the Events
category, and can optionally be added to the job’s log file as well.

To Add a User Note:

1. From the menu, select Edit>Add User Note, or press Ctrl+N (de-
fault keyboard shortcut).

2. In the Enter User Note field, type a summary and details for 
the note.

3. If you’d like the note to also be logged in the job’s log file, se-
lect the Log File option.

4. Click OK.

Adding Notes to Items

You can also add notes and associate them with specific items. For in-
stance, if you’re measuring a cylindrical tank to check for deformation 
when it’s filled, you might want to add a note that a best-fit cylinder 
was created when the tank was filled, and add the quantity of fluid in 
the tank for later analysis.

To Add a Note to an Item:

1. Right-click the item in the tree or graphical view and select 
Properties from the context menu.

2. In the Notes field, enter the desired note, then close the dialog.

Item History
Many different items in your job have a history associated with them. 
An item’s history shows significant events related to the item’s cre-
ation or manipulation. For instance, all item histories indicate when 
the item was added to the job,. A circle’s history may indicate the de-

Note:  Some items, such as 
polygonized surfaces, sur-

faces, and relationships, do not 
have associated notes.
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tails of the geometry fit used to create that circle.

To View an Item’s Historical Log:

 ■ Right-click the item in the tree or graphical view and select His-
tory from the context menu.

To Expand or Collapse all Entries in an Item’s History:

 ■ In the item’s history dialog, click the + or - button.

To Change the Chronological Order in Which an Item’s History is Displaye:

 ■ In the item’s history dialog, choose the ascending or descend-
ing option.

To Copy an Item’s History to the Clipboard:

 ■ In the item’s history dialog, select the entries to copy (or select 
none to copy them all), then click the Copy to Clipboard button.

To Export an Item’s History to a Text File:

 ■ In the item’s history dialog, click the Export Entire Log as Text File 
button. Choose a filename, then click Save.

To Search an Item’s Historical Log:

 ■ In the item’s history dialog, click the Search button. In the re-
sulting Search dialog, type a string to search for, then click Find 
Next.

To Trim an Item’s Historical Log:

 ■ In the item’s history dialog, click the Trim Log button. Confirm 
the action, then specify the number of log entries to keep and 
click the OK button.

Print Setup
Default printing options can be setup through the Print Setup dialog 
(Figure 7-36).

Figure 7-36. The Print Setup 
dialog.

This standard dialog’s options depend on the selected printer but de-
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fine how output from printed reports is handled by the printer. For 
more information, refer to your printer’s documentation.

To Modify Print Settings:

1. From the menu, select File>Print Setup...

2. Choose the desired settings, then click OK.

Command-Line Arguments
SpatialAnalyzer has a series of command-line arguments that allow 
you to automate some tasks when launching the program:

Argument Description

/? Displays a help window showing all of the available 
command-line arguments.

{FILENAME.XIT} Automatically opens the specified SA job file upon launch. 
Replace {filename.xit} with the path to the desired file.

/MP {FILENAME.MP} Runs the specified Measurement Plan file upon launch. 
Replace {filename.mp} with the path to the desired mea-

surement plan file.

/MPE {COLLECTION}::{MP NAME} Runs the specified embedded Measurement Plan upon 
launch. Replace {COLLECTION} with the collection name, 

and {MP Name} with the name of the embedded MP in the 
SA tree.

/QUICK {INSTRUMENT NAME} Launches SA, starts a new file, adds the entered instrument 
name, and starts its interface. Replace {Instrument Name} 
with the name of the instrument (as specified in the Add 

Instrument to SA dialog).

-MINIMIZE Starts SA in a minimized window state.

Combinations of these arguments may be executed at the same time. 
Quotes are required around the elements (filenames, instrument 
names, and object names) if they contain spaces.

Launching SA with Command-Line Arguments

Command-line arguments were traditionally used when running a 
program from the DOS (command prompt) window. Now that graph-
ical operating systems like Windows have become standard, com-
mand-line arguments are usually entered by use of a shortcut icon. 
Regardless, they can still be executed from the Windows command 
prompt.

To Use Command-Line Arguments from the Windows Command Prompt:

1. Windows XP: From the Windows Start menu, choose 
Run. In the dialog, type cmd and press Enter. 
Windows Vista/7: From the Windows Start menu, click in the 
text box labeled Search programs and files. In the box, type cmd 
and press Enter.

2. In the resulting window, navigate to the SpatialAnalyzer in-
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stall directory by typing cd {PATH}, where {PATH} is the 
path to the SA install directory. For example, cd C:\Pro-
gram Files\New River Kinematics\SpatialAnalyz-
er 2011.01.24.  Press Enter.

3. Type “Spatial Analyzer” {ARGUMENTS}, where {ARGU-
MENTS} includes one or more of the arguments listed above. 
Press Enter.

4. SA should launch, using the parameters that you specified in 
the arguments.

To Use Command-Line Arguments via a Shortcut Icon:

1. Create a shortcut for the SpatialAnalyzer program. (See Micro-
soft Windows help if you are unsure how to do this).

2. Right-click on the icon and choose Properties.

3. In the Properties dialog, locate the Target field.

4. Add a space at the end of the text in this field, then add the 
arguments as specified above. When finished, click the OK 
button.

5. Double-click the icon to start SA with the specified param-
eters.

Example Command-Line Arguments

To: Command

Start SA With A File “Spatial Analyzer” “C:\MyFolder\My Tem-
plate File.xit”

“Spatial Analyzer” FileInThisFolder.xit

View the Command-Line Argument Help “Spatial Analyzer” /?

Start an External MP in a Specified File “Spatial Analyzer” /MP C:\MyScripts\
MyMP.mp MyFile.xit

Start an Embedded MP in a Specified File “Spatial Analyzer” /MPE 
Nominal::MyEmbeddedMP MyFile.xit

Add/Startup a Leica Tracker in a New File “Spatial Analyzer” /QUICK “Leica emScon 
Absolute Tracker (AT901 Series)”

Add/Startup an API AXXIS Arm in a Specified 
File

“Spatial Analyzer” /QUICK “AXXIS 6-200 
Arm (3.2m 6 dof)” myFile.xit

Multiple Instances and Exiting SA
SA does not have a “tabbed” interface. If you would like to have mul-
tiple copies of SA open on a single computer, simply open the appli-
cation again. 

To Exit SA:

 ■ From the menu, select File>Exit, click the “X” in the top-right cor-
ner of the application window, or double-click the application 
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icon in the top-left corner of the window.
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SA Files

Creating New Files

Creating a “new” file in SA does not necessarily mean that you’re work-
ing with a blank slate, as you would be in some applications. Even a 
completely new file has at the very least a collection, a coordinate 
frame, and myriads of settings for anything from colors and units to 
decimal precision.

When a new file is created without the existence of a default tem-
plate, SA opens a factory default file—that is, a file that has default 
settings hardcoded by NRK.

To Create A New File:

 ■ From the menu, select File>New, or click the icon on the tool-
bar. If you currently have an SA file open, you will be asked if 
you would like to save it.

If you have an existing file open, you can restore it to the factory de-
fault settings (colors, decimal precision settings, etc).

To Revert a File’s Settings to the Factory Default:

 ■ With the file open, select File>Restore Default Settings. The set-

While working in SA you will likely be working with 
many types of files—SA job (.XIT) files, CAD files con-
taining nominal designs, and text files containing point 
coordinates, for example. This chapter explains how to 
work with external files in SpatialAnalyzer.

Working With 
Files
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tings will return to the defaults. You will of course need to save 
the file to store the changes.

Opening Files

The Open File command permits opening native SpatialAnalyzer files. 
These are commonly referred to as job files and come in one of two 
formats:

 ■ xit. This is a standard 32-bit .xit file. It can be opened by both 
32- and 64-bit versions of SA, but cannot have extremely large 
data sets. It is limited to storing data that will fit in a 32-bit soft-
ware environment.

 ■ xit64. This is a 64-bit SA file. It can only be opened in the 64-bit 
version of SA, but is able to store very large data sets (such as 
extremely dense scan sets).

SpatialAnalyzer job files are backward compatible—you can open an 
.xit or .xit64 file saved in an older version of SA in a newer ver-
sion. However, the reverse is not true—attempts to open a job file 
saved in a newer version of SA into an older version will fail.

To Open an Existing File:

 ■ From the menu, select File>Open, or

 ■ Click the icon on the toolbar, or

 ■ Press the default keyboard shortcut of Ctrl+O, or

 ■ Double-click an SA file in Windows Explorer.

To Open a Recent File:

 ■ From the menu, select File>[Filename] toward the bottom of the 
file menu.

Saving Files

You can save a SpatialAnalyzer job file in one of two formats, as de-
scribed in “Opening Files” on page 250. Any current job file can be 
saved in either format, however it’s important to keep a few things in 
mind:

 ■ If you want to be able to open the file in either the 32-bit or 
64-bit version of SA, you must save the file in the 32-bit (.xit) 
format.

 ■ If the file contains a very large dataset, and you want to pre-
serve the integrity of the data, it must be saved in the 64-bit 
(.xit64) format and cannot be opened in the 32-bit version 
of SA.

 ■ A very large file can be saved in the 32-bit (.xit) format if 
you’d like, however there will likely be loss of data. You will be 

Note:  If you double-click a 
file in Windows Explorer, it 

will be opened in the most recent 
version of SA that has been 
opened.
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warned if this occurs.

File Checksums
To protect against data integrity issues, SA can perform a checksum 
of your SA file immediately after a save operation. This essentially ver-
ifies that the file on disk matches the currently opened file, assuring 
that the save was successful.

To Verify File Checksums After Saving:

1. In the User Options dialog, navigate to the Machine Config-
uration tab.

2. Enable the Verify File Checksums after Saving option.

To Save an SA file:

1. From the menu, select File>Save, click the icon on the tool-
bar, or use the default keyboard shortcut (Ctrl+S).

2. In the Save As dialog, select the desired format from the Save 
as type: dropdown, then click Save.

The first time you save a file, you will be prompted to choose a name 
and format. Subsequent saves will simply save the file and not prompt 
you for a file name or format.

Save As

If you choose to save the current file under a different filename or 
format, you can select the Save As command at any time. This permits 
you to specify a new filename or format, even if you’ve already saved 
the current file.

To Save the File With a New Name or Format:

1. From the menu, select File>Save As.

2. In the Save As dialog, specify a new filename and format, then 
click Save.

Backing Up Files

SA can be configured to capture periodic, automatic backups of your 
working file which requires no user intervention. However, you can 
also automatically save a backup copy of your current file. This back-
up will be saved to the current backup folder and the filename will be 
appended with a timestamp.

To Force A Backup File To Be Saved:

 ■ From the menu, select File>Backup Now. After a short delay, the 
file will be saved to the backup folder.
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Automatic Backups
Losing measurement data or your job progress can be a critical and 
expensive problem. To mitigate this risk, you can set your machine to 
make automatic SA file backups while SA is running. There are two 
types of backups that can be made:

 ■ Job File Backups. These backup files save the same informa-
tion as a standard job file. (In fact, job file backups are simply 
regular SA files that are saved automatically for you).

 ■ Measurement Backups. These backups only store instru-
ments and measurements.

So why are there two types? The main reason is to save space. You 
might be working in a file with a very large complex nominal CAD file. 
There is simply no reason why all of this information should be saved 
in a backup, because the CAD surfaces are typically not modified. As 
a result, they mostly just waste hard disk space. Measurement back-
ups, on the other hand, only store instrument and measurement data 
which is much more critical and significantly smaller in file size. As a 
result, frequent measurement backups can be made without wasting 
hard drive space or causing performance delays, whereas frequent 
job file backups would cause a much bigger hit to performance and 
available drive space. Measurement backups are also regular SA files, 
and can easily be re-merged into the SA file containing the nominal 
CAD data using the File>Import command.

Sometimes, you might open a file, make a few changes, and acciden-
tally overwrite your original file, which could be disastrous without a 
backup. To help prevent this type of mistake, you can optionally ask 
SA to create a file backup automatically upon opening the file, so you 
have a pristine, untouched backup in place.

You can also ask SA to automatically create Measurement Plan back-
up files while making changes in the MP Editor. If the specified time 
has elapsed and changes have occurred to your MP, SA will store a 
backup of your script to the Backups folder.

To Enable Automatic Backups:

1. Click the User Options icon in the Main toolbar.

2. In the Automatic Backups section of the Machine Configuration 
tab, click the enabled checkbox for the appropriate backup 
type.

3. Select a time interval at which enabled backups should occur.

4. If desired, enable the automatically Create on File Open option 
to store a backup upon opening a file.

or
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 ■ To quickly toggle automatic backups without changing other 
backup settings, toggle the Edit>Automatic File Backup setting in 
the menus (this does not apply to MP Backups).

To Restore a Job File Backup

 ■ Select Edit>Undo to Restore Point from the menus. Select a desired 
restore point from the list, or

 ■ Select File>Open and select the desired file in your backup fold-
er.

To Restore a Measurement Backup

 ■ Select File>Open and select the desired file in your backup fold-
er.

To Restore a Measurement Plan Backup

 ■ In the MP Editor, select File>Open and select the desired .MP file 
in the backup folder.

Restore Points

Restore points can be thought of as “quicksaves”. At any time, you can 
create a quick backup of your current files by creating a restore point. 
You can then revert back to the restore point to continue from that 
point. They are not a complete alternative to an undo system (which 
is not available in SA) as they require you to consciously create a re-
store point. However, they are very useful as quicksaves of your work-
ing job file.

To Create a Restore Point:

Do one of the following:

 ■ From the menu, select Edit>Create Restore Point, or

 ■ Press Alt+Space (the default keyboard shortcut).

To Undo to a Restore Point:

Do one of the following:

 ■ From the menu, select Edit>Undo to Restore Point, or

 ■ Press Ctrl+Z (the default keyboard shortcut).

Password-Protecting SA Files

For safety purposes, you may choose to password-protect your SA file 
to prevent accidental or malicious modification. This involves assign-
ing a password to the current job file, then saving it. When the file is 
opened in the future, it requires a password to access the data.

To Password-Protect a Job File:

1. From the menu, select File>Password Protection>Set Password.

Warning:  The password 
protection scheme is not 
intended to be a secure 

method of data storage. Pass-
word protection can be circum-
vented by a hacker relatively eas-
ily. If you need high security, you 
should use a tool designed for 
secure data storage.
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2. In the Set Password dialog, enter your password into both 
fields.

3. When prompted, confirm that you wish to apply a password 
to the file.

4. Save the file. It will now require a password to open.

To Remove a Password From a Job File:

1. From the menu, select File>Password Protection>Remove Password.

2. At the prompt, confirm that you would like to remove the 
password.

3. Save the file. A password will no longer be required to open it.

File Import
SA supports a wide variety of common file formats, making data shar-
ing easy. You can work with various CAD formats, text-based point 
formats, custom formats and embedded formats. The act of import-
ing a file will always merge it into the existing job file.

When a file is imported, the data is transformed by aligning the work-
ing frame or active coordinate system of the imported file to the 
working frame of the current file.

Auto Import

You can let SA choose the proper import method for a file based on its 
file extension. You do this using the Auto Import (by file extension) com-
mand. Be aware that this depends on the file extension to match the 
format of the file. If there is a mismatch, the import will fail.

To Auto-Import a File by Type:

1. Do one of the following:

 ■ From the menu, select File>Auto Import (by file extension), or

 ■ In the toolbar, click the Auto Import icon, or

 ■ Drag the file from Windows Explorer into the graphical view, or

 ■ In the tree, switch to the Explorer tab, find the file to import, 
then double-click it.

2. The appropriate file import command will be triggered.

Importing SpatialAnalyzer Job Files

It is often desirable to merge another SA job (.xit file) into the current 
SA file. This is particularly useful when portions of measurement have 
been accomplished on various computers and files. You can choose 
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which collections should be imported.

To Import Another SA File Into the Current Job Using the Menus:

1. Choose File>Import>SpatialAnalyzer Job File (.xit). Choose the file 
to import.

2. From the SA File Import Filter dialog, check the collections 
you’d like to import.

3. Click Import Selected Collections.

Direct CAD Access

The Direct CAD Access import option allows a user to import native CAD 
files directly into SpatialAnalyzer. The following is a list of supported 
formats:

Manufacturer Format Version Polygonized 
Surfaces Surfaces Annotations

Standard 

PRC 
(.PRC) All Versions

IGES 
(.IGS, .IGES) 5.1, 5.2, 5.3 N/A

Industry Foundation Classes 
(.IFC, .IFCZIP)

IFC2x Editions 2, 
3, & 4 N/A N/A

STEP 
(.STP, .STEP)

AP 203 E1/E2, 
AP 214, AP 242

Stereo Lithography 
(.STL) All Versions N/A N/A

VDA-FS 
(.VDA) v1.0 & v2.0 N/A

VRML 
(.WRL, .VRML) v1.0, v2.0 N/A N/A

Adobe 3D PDF 
(.PRC) All Versions

Rhinoceros 
(.3DM) v4, v5 N/A

CATIA V4 
(.MODEL, .SESSION, .DLV, .EXP) Up to 4.2.5

CATIA V5 
(.CATDRAWING, .CATPRODUCT, 

.CATPART, .CATSHAPE, .CGR)

R4 to R21, V5-
6R2013 (R22)

CATIA V6 
(.3DXML) 2011 to 2013

SolidWorks 
(.SLDASM, .SLDPRT) Up to 2014

ACIS (.SAT, .SAB) Up to v23 N/A

Note:  If any imported col-
lections have the same 

name as existing collections, they 
will be automatically renamed.
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Manufacturer Format Version Polygonized 
Surfaces Surfaces Annotations

NX 
(.PRT)

Unigraphics v11.0 
to NX 9.0

JT 
(.JT) Up to 9.5

Parasolid 
(.X_T, .X_B, .XMT, .XMT_TXT) Up to v26 N/A

Solid Edge 
(.ASM, .PAR, .PWD, .PSM) V19-20, ST-ST6

I-DEAS 
(.MF1, .ARC, .UNV, .PKG)

Up to 13.x (NX 5) 
& NX 6

Pro/ENGINEER 
(.ASM, .NEU, .PRT, .XAS, .XPR) Up to Wildfire 5

Creo Elements/Pro/Parametric 
(.ASM, .NEU, .PRT, .XAS, .XPR)

v5.0 (Pro) 
v2.0 (Parametric)

Inventor 
(.IPT, .IAM) Up to 2014 N/A

To Natively Import a CAD File:

1. From the menu, select File>Import>Direct CAD Access.

2. Select the file you’d like to import.

3. In the Direct CAD Access dialog (if you’ve chosen to show this 
dialog), choose the desired import options.

4. If the Selective import option is checked in the Direct CAD Ac-
cess dialog, the Choose CAD Features dialog will be shown 
(Figure 8-1). Choose the desired features to import, then click 
OK. For more on this dialog, see “Selective CAD Import” on 
page 257.

Figure 8-1. The selective 
CAD import dialog.
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Selective CAD Import
The Choose CAD Features dialog (Figure 8-1) is only displayed when 
the Selective import (Choose which Components to import) option in 
the Direct CAD Access Settings dialog is enabled (see “Direct CAD Ac-
cess Settings” on page 257). It lists all components of the CAD model 
or assembly in a tree-like view on the left, and a legend at right indi-
cates the type and quantity of all of the entities to be imported. In this 
dialog you can choose to deselect entities from the source CAD file 
that you do not wish to import. This provides several benefits:

 ■ It saves you the effort of having to clean up the CAD file of un-
wanted items after import.

 ■ It makes the import process shorter.

 ■ It allows you to circumvent portions of a CAD file that may be 
causing import errors.

Direct CAD Access Settings
The Direct CAD Access Settings control a number of options related 
to import via Direct CAD Access.

To Open the Direct CAD Access Settings:

 ■ From the menu, select File>Import>Direct CAD Access Settings, or

 ■ From the User Options Machine Configuration tab, click the 
Direct CAD Access Settings button.
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Figure 8-2. The Direct CAD 
Access Settings dialog.

The options for this dialog are explained below.

 ■ Entity Types to Import. These checkboxes give you control 
over which types of entities to import. Any unchecked entities 
will not be imported.

 ■ Group Name. All points from the CAD file will be imported into 
a group with this name.

 ■ Import Construction Geometry. For CAD formats that sup-
port it, unchecking this box will exclude construction geom-
etry from the import.

 ■ Import Hidden Entities. For CAD formats that support it, un-
checking this box will exclude hidden entities from the import.

 ■ Import all surfaces as Mesh Graphical Entities. When 
checked, surfaces from the CAD file are imported as Mesh 
Graphical Entities instead of true surfaces. Mesh Graphical En-
tities are useful for visualizing surfaces and have a significantly 
lower requirement for computing resources than surfaces, but 
you cannot analyze against them.
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 ■ Do not import fillets. Usually, CAD surfaces contain minor 
features that may not be important to a metrology inspection. 
Fillets or modeled weld beads are one example of this. To keep 
your imported model as efficient as possible, check this op-
tion to exclude fillets from the import (if the file type supports 
marking the features as such).

 ■ Do not import Dittos (repeated items). Some file formats 
support “dittos”, which are efficient memory copies of surfac-
es that are repeated over and over in a CAD file. For instance, 
hardware such as bolts, nuts, and screws are often modeled as 
dittos to save memory in the CAD application. These are fea-
tures that are rarely inspected by metrology—check this op-
tion to exclude them from the import.

 ■ Ditto Threshold. Some formats support multiple levels of dit-
tos (dittos of dittos, for instance). If necessary, you can modify 
this number to indicate the threshold below which dittos are 
not imported. Higher numbers import less dittos.

 ■ Selective Import (Choose which Components to Import). 
When enabled, the Choose CAD Features dialog is displayed to 
allow you to more finely control which entities are imported 
from the CAD file (see “Selective CAD Import” on page 257).

 ■ Center View on Imported Objects. When enabled, the graph-
ical view will be centered on the imported objects after import.

 ■ Import Into Folders Matching CAD File Hierarchy. When 
enabled, if the source CAD format supports a hierarchy, that 
hierarchy will be preserved in the SA tree using a hierarchy of 
folders and collections.

 ■ Remove Empty Folders. Importing a CAD file into fold-
ers maching the CAD file hierarchy (see previous option) can 
sometimes result in empty folders in the tree. Enabling this op-
tion removes these empty folders after the import operation.

 ■ Prompt if One or More Components Are Missing. Several 
CAD formats support the idea of a product or assembly file, 
which is a master file that has several supporting component 
CAD files. When importing these master files, this option will 
warn you if any subcomponent CAD files that are part of the 
master assembly are not found.

 ■ Do Not Show This Dialog Each Time. When enabled, the Di-
rect CAD Access Settings dialog will not display on import, but 
will use the previous settings. If you want to access the settings 
again, follow the steps in “To Create A New File:” on page 249.

 ■ Surface Normals Mode. This setting has two possible options: 

Tip:  Importing while match-
ing CAD hierarchy can result 

in a somewhat cumbersome, 
cluttered SA job file. Use this op-
tion sparingly, and only when 
needed.
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Mode 1 or Mode 2. Some CAD formats or CAD packages do not 
consistently define or store the direction of surface normals. 
Incorrectly oriented CAD surface normals will cause incorrect 
analysis in SA. While surface normals can always be corrected 
manually, if you find that one mode is importing surfaces in the 
wrong direction, trying Mode 2 might solve the problem.

Importing Standard CAD Formats

SA can import several standard CAD formats using a “classic” import-
er. These formats include:

 ■ STEP. Import via File>Import>Standard CAD Formats>STEP.

 ■ IGES. Import via File>Import>Standard CAD Formats>IGES.

 ■ VDA. Import via File>Import>Standard CAD Formats>VDA.

 ■ SAT. Import via File>Import>Standard CAD Formats>SAT.

In addition to providing additional import formats, you can also use 
this classic import method if you encounter problems attempting to 
import using Direct CAD Access. During the CAD import you can se-
lect from a variety of import options (Figure 8-3):

Figure 8-3. The Classic CAD 
Import Options dialog.

 ■ Import into Group. Points from the CAD file will be imported 
into a group with the specified name.

 ■ Use Point Color Information if available (1 group per col-
or).  Upon importing points from the CAD file, this option will 
set the group color to match the current point color from the 
source file, if that color exists. Each point will be organized into 
a group by its color.
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 ■ Lines/Circles/Curves/Planes/Surfaces/Coordinate Frames. 
Choose which types of entities to import.

 ■ Ignore ‘No Shows’. When selected, items hidden or on a “no 
show” layer in the file (if supported) will not be imported.

 ■ Surface Normals Mode. Equivalent to the same option in the 
Direct CAD Access Settings dialog (see “Direct CAD Access Set-
tings” on page 257).

To Import a Standard CAD Format Using the Classic Importer:

1. Choose File>Import>Classic CAD Importers>(Format).

2. Select the file to import from the dialog, and click OK.

3. Choose the desired CAD import options, then click OK.

4. A summary of the file information will be displayed. To save it 
to file, click Save to File. Otherwise, click Accept.

5. If the current file’s units do not match the source units, you 
will be prompted whether you’d like to convert the units. Click 
Yes or No.

Importing Predefined ASCII Formatted Files

ASCII text files are common in coordinate metrology. They provide a 
standard, human-readable format that many software packages can 
easily import. SpatialAnalyzer supports many formats of ASCII data. 
Figure 8-1 shows an example of a file in “Point Name, X, Y, Z” format.

Figure 8-4. A text file con-
taining point data in Point-
name, X, Y, Z format.

When a file is selected, you will be presented with several options to 
define how SA will import the file (Figure 8-5):

Note:  If units between files 
differ, the units are convert-

ed (if you choose). The CAD data is 
not physically scaled at all.
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 ■

Figure 8-5. The ASCII Import 
dialog.

Format. Choose the format of the ASCII file. SA will automati-
cally delimit using commas, tabs, or spaces (depending on how 
the ASCII file is set up).

 ■ File Units. Define the units used in the ASCII file.

 ■ Group Name. Specify the name to import the points into (only 
applicable if not specified already by the format).

 ■ Ensure new group. Select this option to ensure that points are 
placed into a new point group if the specified group already 
exists.

 ■ Ensure unique names. Verifies that imported point names are 
unique.  If there is a naming conflict, the offending point will 
have an asterisk appended.

 ■ Make Point Cloud. Select this option to import points as a 
point cloud instead of a point group.

 ■ Comment character(s). Any lines that start with the specified 
characters are treated as comment lines and are ignored.

To Import an ASCII-Formatted File:

1. Select File>Import>ASCII: Predefined Formats.

2. Choose the file to import.

3. In the ASCII Import dialog, specify the desired options, then 
click Import.

4. The file will be imported, and you will receive a summary of 
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lines imported and ignored.

Importing ASCII Formatted Points With Offsets

There are two additional ASCII formats for importing points with off-
sets, depending on the format of your source data.

To Import Points With Offsets:

 ■ From the menu, select File>Import>ASCII: Points with 
Offsets><Format>.

<Name><X><Y><Z><Offset>

This option is used when the source file is in the format 
<Name><X><Y><Z><Offset>.

2 Files: <Name><X><Y><Z> + <Name><Offset>

This option is used when there are two source files: One in the format 
<Name><X><Y><Z> and the other in the format <Name><Offset>.

Importing XML Files

XML files containing nominal points and coordinates can be import-
ed into an SA file. At a later time, measured point data can be merged 
back into the XML file, which will associate the actual coordinates 
with the nominal coordinates. The nominal points will be imported 
into a group matching the name of the XML file.

XML Format: Nominal Points
The format of the XML file should have the standard XML format, such 
as the introductory tag:

<?xml version=”1.0” encoding=”UTF-8” ?>

Following this, an enclosing group may contain one or more <POINT> 
elements, containing a NAME attribute and a child <NOMINAL> ele-
ment which itself contains X, Y, and Z attributes. For example:

<?xml version=”1.0” encoding=”UTF-8” ?> 
  <left> 
    <POINT NAME=”Center1”> 
      <NOMINAL X=”1.000” Y=”4.000” Z=”7.000” /> 
    </POINT> 
    <POINT NAME=”Center2”> 
      <NOMINAL X=”3.000” Y=”6.000” Z=”9.000” /> 
    </POINT> 
  </left>

XML Format: Nominal and Measured Points
Once measured data has been obtained, the measured point names 
are matched up with the nominal names in the XML file, and an <AC-
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TUAL> element is added as a child of each matching <POINT> ele-
ment. This <ACTUAL> element contains X, Y, and Z attributes holding 
the measured coordinates. The above XML file might look like the fol-
lowing after merging measured data:

<?xml version=”1.0” encoding=”UTF-8” ?> 
  <left> 
    <POINT NAME=”Center1”> 
      <NOMINAL X=”1.000” Y=”4.000” Z=”7.000” /> 
      <ACTUAL X=”1.002” Y=”3.996” Z=”7.003” /> 
    </POINT> 
    <POINT NAME=”Center2”> 
      <NOMINAL X=”3.000” Y=”6.000” Z=”9.000” /> 
      <ACTUAL X=”3.007” Y=”6.005” Z=”8.998” /> 
    </POINT> 
  </left>

To Import an XML File:

1. From the menu, select File>Import>XML, then select the desired 
XML file.

2. In the XML import dialog, the structure of the points to im-
port will be listed (Figure 8-6). Click the Import Points button.

Figure 8-6. The XML import 
dialog for the above example 
file.

To Merge Measurements to an XML File:

1. From the menu, select File>Import>XML, then select the desired 
XML file.

2. In the XML import dialog (Figure 8-6), click the Merge Mea-
surements and Save button.

3. From the Object Selection dialog, select the point group you’d 
like to merge.

Custom Formats

Many custom file formats can be imported, including the following:

 ■ xyz, ijk Files (IJK). Files in IJK format (containing both position 
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and probe orientation data).

 ■ Digital Network Level Measurements. Measurements from a 
digital level. This is an ASCII file expected to be of the format 
<group>, <target>, <elevation>.

 ■ VSTARS .xyz Files. .xyz files from VSTARS.

 ■ VSTARS Cameras. Camera files from VSTARS in the outstar.txt 
format.

 ■ DMIS Files.

 ■ Polyworks Files. .POL, .PIF, .PF, and .DPI formats are all sup-
ported.

 ■ IMETRIC Files.

 ■ Leica GSI8/GSI16 Files. Files from Leica total stations in GSI8 
or GSI16 format.

 ■ Steinbichler AC Files. This imports data from a Steinbichler 
scanner (such as the T-Scan) originating in .AC format.

 ■ Wavefront Objects Files. This imports data in Wavefront Tech-
nologies’ Objects file (.obj).

 ■ Leica ADF format. Files in Leica’s .adf format.

 ■ 1-D Data (DataMyte).

To Import a Custom File Format:

 ■ From the menu, select File>Import>Custom Formats>...

Embedding Files

You can import any file from the file system and embed it in the SA 
job file. The embedded file is placed into the active collection. This is 
convenient for transporting relevant files with the job file. Of course, 
when doing so the SA job file grows accordingly to store the file. At 
any time, this file can be exported back to the file system.

To Embed a File:

1. Activate the collection into which you’d like to embed the file.

2. From the menu, select File>Import>File as Embedded File.

3. At the prompt, select the file to embed. The file will appear 
under the Embedded Files category of the tree.

Importing Images

You can import any common image format into the SA job. In the 
tree, embedded images appear under the Pictures category in the ac-
tive collection. Importing images is particularly useful because these 
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images can be used in reports. For example, you might have a few 
JPEG images of a measured part taken with a digital camera that 
you’d like to include in your report. Importing these images into the 
SA file gives you the ability to use them in a report.

To Import an Image Into an SA File:

1. Ensure the collection into which you’d like to import the im-
age is active.

2. From the menu, select File>Import>Image.

3. At the prompt, select the image file to import. In the tree, the 
image will appear in the Pictures category of the active collec-
tion.

File Export
There are many ways to export your data from SA. Points, Point 
Clouds, Vector groups and many CAD formats are supported under 
the File>Export menu option.

Exporting ASCII Formatted Points

Points are easily exported from SA to an external ASCII text file. Using 
this method, the points are always exported in the working coordi-
nate frame. There are many export options to give you fine control 
over the export format and data (Figure 8-7). These options are sum-
marized below:

 ■ Target Name. The name of each exported target can be one 
of four options: Collection Group target, Group target, target, or 
none. These options indicate which parts of the point/target 
name are included. For example, exporting using Collection 
Group target exports in the format CollectionName Group-
Name TargetName x y z.

 ■ Coordinate System. Point coordinates can be exported in Car-
tesian, Cylindric, or Spherical coordinates.

 ■ Tolerance. If selected, point tolerances will be exported for 
each point (if available).

 ■ Coordinate uncertainties. If selected, coordinate uncertain-
ties for each point will be exported (if available).

 ■ Time Stamps. If selected, the point’s time stamp will be ex-
ported.

 ■ Target Offsets. If selected, the planar and radial offset of each 
point will be exported.
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 ■ Target Comments. If selected, any comments stored with the 
point will be exported.

 ■ Measurement Details. If selected, measurement details (such 
as RMS error, measurement mode, and sampling method) will 
be exported, if available.

 ■ Separator. Data can be delimited by spaces or commas in the 
exported format.

 ■ Decimal Precision. Numerical values can be exported using 
fixed decimal precision (you specify the number of digits) or 
using full precision scientific notation.

 ■ Include SA Version and Frame Comments. If selected, the SA 
version and working coordinate frame name will be listed at 
the beginning of the file, preceded by // to denote that the 
line is a comment.

 ■ Include Axis Comments. If selected, information about the 
exported coordinate system will be listed at the beginning of 
the file, preceded by // to denote that the line is a comment.

Figure 8-7. The options for 
exporting ASCII points.

To Export Selected Points:

1. From the menu, select File>Export>Points (ASCII File).

2. When prompted, select the desired points to export, then 
press Enter.

3. In the Save As dialog, specify the name for the exported file, 
then click Save.

4. When the ASCII Export dialog appears, choose the desired op-
tions, then click OK. For convenience, the resulting exported 
file will be opened in Notepad.
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To Export an Entire Point Group:

1. In the tree, right-click the desired point group to export, then 
select Export to ASCII File from the context menu.

2. In the  Save As dialog, specify the name for the exported file, 
then click Save.

3. When the ASCII Export dialog appears, choose the desired op-
tions, then click OK. For convenience, the resulting exported 
file will be opened in Notepad.

Exporting Point Clouds

You can export point clouds to an external ASCII file. You can specify 
whether each point is assigned a label in the exported file.

To Export One or More Point Clouds to an ASCII File:

1. From the menu, select File>Export>Point Clouds.

2. Select one or more clouds to export.

3. In the Save As dialog, specify the filename to export, then 
click Save.

4. When prompted, indicate whether you would like each cloud 
point to have a label in the exported file.

To Export a Single Point Cloud to an ASCII File:

1. Right-click any point cloud in the tree and select Export to ASCII 
File.

2. In the Save As dialog, specify the filename to export, then 
click Save.

3. When prompted, indicate whether you would like each cloud 
point to have a label in the exported file.

Exporting Vector Groups

Vector groups can be exported to an ASCII file. The file is exported in 
the following format:

 ■ Name, X, Y, Z, dX, dY, dZ, Signed Magnitude
To Export a Vector Group to an ASCII File:

1. From the menu, select File>Export>Vector Group.

2. At the prompt, select the vector group to export.

3. In the save dialog, specify the name for the ASCII file to ex-
port. For convenience, the exported file will be opened for 
you in Notepad.
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Exporting Object Frames

The coordinate frames for any objects that have representable frames 
(such as coordinate frames, circles, and spheres) can be exported in 
one of two formats:

 ■ Name, X, Y, Z, Rx, Ry, Rz
 ■ Name, r0c0, r0c1, r0c2, r0c3, r1c0...

The first option exports the name of the objects and their positions 
and orientations in space. The second exports the name of the ob-
jects and the 16 elements of their transformation matrix.

To Export Object Frames:

1. From the menu, select File>Export>Frames (and objects’ frames).

2. Select all of the objects defining the frames you’d like to ex-
port.

3. In the Frame Export Settings dialog, select the desired format 
for the exported file, then click OK.

4. In the Save As dialog, specify the name for the exported file. 
Notice that this file is automatically exported as a .CSV file. For 
convenience, the file is automatically opened after successful 
export.

Exporting to CAD Formats

SA jobs can be exported to several different formats, with support for 
points, geometry and surfaces. Only the entity types supported by 
the selected file format will be exported. The supported formats are:

 ■ STEP. You can export the entire SA file or specific objects.

 ■ IGES. You can export the entire SA file or specific objects.

 ■ VDA. You can export the entire SA file or specific objects.

 ■ SAT.

 ■ DXF.

 ■ Metric Vision Instrument Compensation Data Format.

 ■ Imageware Cloud File.

 ■ Surface Wireframe Curve File(s) (.crv). Writes a wireframe 
representation of the selected surfaces to a text file containing 
comma-separated values.

 ■ Polyworks POL File.

 ■ STL. Files can be exported in either ASCII or binary format.
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To Export an SA File to a CAD Format:

1. From the menu, select File>Export>[Format]. If supported, spec-
ify whether the entire model or specific objects should be ex-
ported.

2. If applicable, select the objects you’d like to export.

3. When prompted, specify the name of the file to export.

Exporting Window Placements

When automating SA using Measurement Plans or the SDK, it is 
sometimes desirable to preserve the placement and size of SA win-
dows and dialogs. Consider an example in which a number of client 
computers running at a specified screen resolution will be using a 
series of automation routines. In order to ensure that these measure-
ment computers have all of the windows and dialogs in the exact 
same place as the “development computer”, you can export window 
placements on the development computer, then have the automa-
tion routine import these placements on the client computers using 
the Import SA Windows Placement MP command. This will ensure that the 
client computers position and size the windows exactly the same as 
the development computers.

To Export Window Placements:

1. From the menu, select File>Export>Window Placements.

2. Specify a name for the exported file. The file will be exported 
as a .POS file.

Templates
When you create a new file or start up SpatialAnalyzer, it opens in a 
“factory default” configuration. However, you might wish to specify 
your own read-only configurations for one or more files that are used 
as starting points for your work. Or, you may wish to create a con-
figuration that is used as the default starting point for your job when 
starting up SA or creating a new default file. For instance, you likely 
have a preferred set of default units, decimal precision settings, col-
ors, and other settings you wish to use. Setting these manually each 
time you start a new job would be tedious.

To satisfy this need, SA employs templates. A template is not very dif-
ferent from a regular job file. In fact, it is a job file. The only difference 
is that it is marked as read-only and is typically stored in a standard 
folder on disk (C:\Analyzer Data\Templates), although this is 
not a requirement.
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To Create a New Template File:

1. Configure a job file as desired.

2. From the menu, select File>Save As Read-Only Template.

3. In the dialog, specify the name and location for the template 
file. It will be set as read-only.

To Open an Existing Template File:

1. From the menu, select File>Open Template File.

2. From the dialog, choose the file to open.

The Default Template

Instead of having templates as starting points for a specific job, you 
may also have a preferred default starting configuration for all files. 
SpatialAnalyzer provides the capability to define a default template. 
A default template is a template that is automatically loaded in the 
following situations:

 ■ SpatialAnalyzer is started from the Windows start menu or a 
desktop shortcut.

 ■ File>New is selected from the menu, or the New File icon is 
selected in the toolbar.

Default templates help you avoid repeating the same job file prepa-
ration steps by allowing you to define a starting point for all of your 
job files. They also provide a convenient method for standardizing file 
setup and settings across an organization. If a default template does 
not exist, SA will use factory default settings.

To Create a Default Template

1. Configure an SA file with the settings for your template. Re-
member to set all settings that are saved with an SA file (such 
as the active units and decimal precision settings) as desired.

2. From the menu, choose File>Save As Read-Only Template.

3. In the save dialog, ensure you are in the Analyzer Data\
Templates folder (SA will take you there by default), then 
save the template as default.xit. When you start SA or a 
new file, this file will automatically be restored.

To Remove a Default Template

1. Navigate to SA’s Analyzer Data\Templates folder in Win-
dows Explorer.

2. Delete the default.xit file. Without this file, the factory de-
fault settings will be used.

Note:  Template files are typ-
ically stored in C:\Analyz-

er Data\Templates, although 
this is not mandatory.
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Screen & Graphics Capture
At any time, you can capture either the entire screen or the graphical 
view for printing or output to a standard image file (BMP, JPG, PNG, 
GIF, or TIFF).

To Print or Capture the Screen or Graphical View:

1. From the menu, select File>Capture Screen[Capture Graphics]>To 
Printer[To File (BMP/JPG/PNG/GIF/TIFF)] as appropriate.

2. If capturing to printer, choose the printing options and con-
firm. If capturing to file, select the filename and type, then 
click Save.

3. The Capture Graphics > To File (BMP/JPG/PNG/GIF/TIFF) command al-
lows you to specify a render scale. A value of 1.0 uses the ac-
tual pixel count of the graphical view for the resulting image. 
A value of 3.0 will create an image three times the resolution 
of the graphical view.
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About Points
A point is defined as a specific location in three-dimensional space, 
and may be represented in Cartesian (X/Y/Z), Spherical (r/θ/Φ), or Cy-
lindrical (r/θ/Z) coordinates (depending on the application). With a 
few exceptions coordinates are reported to the user in the working 
coordinate frame.

Points can be created by many methods. For example, they can be 
created from a point construction command or can be the result of 
measurement with a portable metrology device. They may be im-
ported from a CAD file, extracted from sphere scans, or the result of a 
fit to existing data.

Point Groups

In SA, all points must exist inside of a point group. A point group is a 
container for a set of points that are related in some way. The point 
group itself is considered an object, whereas its contained points are 
not objects. All points inside of a point group are treated as a rigid 
body. That is, when you move or rotate a point group, all of the en-
closed point groups move or rotate together, as if rigidly connected.

The point group is the organizational element that is used to organize 

Points are the most fundamental aspect of any mea-
surement. They are the basis from which virtually all 
analysis is performed in portable metrology—therefore 
having a good understanding of how they work in Spa-
tialAnalyzer is crucial.

Points
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your point data by feature. All measurements of a specific hole should 
typically be placed into their own point group. All measurements of 
reference (tie-in) points should typically be placed into their own 
group. Likewise, measurements of a complex surface should typically 
be placed into their own group as well. As mentioned earlier in this 
manual, organizing your point data in this manner will make analysis 
and reporting easier later on.

Since point groups are objects and points themselves are not, only 
point groups have a color. All points inside that group inherit the col-
or of their point group.

There are two types of points that you will see in SA: Constructed 
points and Measured points (also referred to as targets). Both of these 
types of points may appear in the same point group.

Constructed Points

A constructed point is a point that is not associated with any instru-
ment observations or measurements. There are many ways to create 
constructed points. They may have been created manually by enter-
ing coordinates, by intersecting a line with a plane, or may be the re-
sult of importing data from an ASCII file. A constructed point may also 
result from deleting a target’s individual measurement observations.

Figure 9-1. A constructed 
point as seen in the graphical 
view.

A constructed point is represented in the graphical view and the SA 
tree by a 3-D “plus” symbol, as pictured in Figure 9-1 and Figure 9-2.

Figure 9-2. A constructed 
point in the tree named 
MyPoint sits inside the My-
PointGroup group.

Expanding the triangle next to any point will display its coordinates in 
the working frame.

Measured Points

A measured point (also referred to as a target) is a point which has been 
determined from one or more direct instrument observations. For 
traceability purposes, targets they maintain a record about who and 
what measured them, when and how they were measured, weather 
data, sampling statistics, raw measurement data from the instrument, 
and any other pertinent metadata. Because they are tied to instru-
ment measurements, measured points cannot be created through 
typical point construction or analysis methods--they must be mea-
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sured. (There is, however, a way to create targets through measure-
ment simulation).

Measured points are represented in the graphical view by a 3-D plus 
symbol with a diamond around it (Figure 9-3).

Figure 9-3. A measured 
point as it appears in the 
graphical view.

In the tree, targets are represented by a crosshair icon (Figure 9-4).

Figure 9-4. A measured 
target named MyTarget as it 
appears in the tree.

Expanding the triangle next to any point will display its coordinates in 
the working frame.

Point Characteristics
There are a number of characteristics common to both constructed 
and measured points. The Point (Target) Information dialog, shown 
in Figure 9-5, contains the properties of an individual point. In this 
particular figure, a constructed point’s properties are shown.

Figure 9-5. The Point Infor-
mation dialog for a construct-
ed point.

To Display the Properties for a Point:

 ■ Double-click a point in the graphical view or tree, or

 ■ Right-click a point in the graphical view or tree and select Prop-
erties.
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At the top of the Point Information dialog, the collection, group, and 
target name are listed. Below that are the coordinates of the point in 
the working coordinate frame.

To Edit the Coordinates of a Point:

1. Click the Edit Values button. The Edit Point Coordinates dialog 
will appear as shown in Figure 9-6.

2. 

Figure 9-6. The Edit Point 
Coordinates dialog.

Type in the new values and click OK.

If you attempt to edit the coordinates of a measured point (some-
thing you typically should not do), you will receive a warning and the 
measured point will turn into a constructed point. The original mea-
surement data is still preserved with the point, but the measurements 
become deactivated and they need to be reactivated (and the target 
recomputed) to restore the measured point.

Point Tolerance

Each point can be assigned a tolerance (Figure 9-7). Tolerances that 
have been assigned to a point will be used for watch windows and 
other comparisons where applicable. A point tolerance must be as-
sociated with a specific coordinate frame (because it may be asym-
metrical). Tolerances can be applied on any combination of axes, and 
in any combination of sides (high or low).

Figure 9-7. The Point Toler-
ance dialog allows you to 
specify the tolerance for a 
point.

To Add a Tolerance to a Point:

1. In the Point (Target) Information dialog, click the Tolerance 
button, or right-click the point in the tree or view and choose 
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Tolerance.

2. In the resulting Point Tolerance dialog, click the Add button, 
as shown in  Figure 9-7.

3. To pick the applicable coordinate frame from a list, click the 
Pick Frame button and choose the frame from the resulting 
dialog. To specify that the tolerance will apply to the current 
working frame, click the Use Active Frame button.

4. To assign the numeric tolerance value, click the Tolerance but-
ton, which will open the Vector Tolerance dialog (Figure 9-8).

5. 

Figure 9-8. The Vector Toler-
ance dialog.

Check the tolerances that you want to apply, and enter the 
numeric values. The Enable All and Disable All buttons are 
shortcuts to check and uncheck all tolerances. If a value is en-
tered into the Set Values field, then clicking the Set All High, Set 
All +/-, or Set All Low buttons apply the value to all of the high 
tolerances, all of the high and low tolerances, or all of the low 
tolerances, respectively.

6. Click OK to apply the tolerance.

Notes

The Notes field in the Point (Target) Information dialog can be used to 
enter descriptive notes about an individual point.

Targeting Offsets

Each point can be assigned a planar and radial target offset. Enter the 
values in these fields to change them for a single point. These offsets 
will be automatically compensated for when comparing the point to 
surfaces and other geometry. By default, constructed points have off-
set values of zero.

Planar Offset
The planar offset is the most commonly-used offset. It is used in al-
most all situations. To provide examples, the planar offset is used 
when compensating in the planar direction for a pin nest (Figure 9-9), 
when comparing to a cylinder or best-fitting a cylinder to measured 
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points, or when comparing a set of measured points to a surface.

Radial Offset
The radial offset is only used in one situation: when using tooling in-
tended to measure circular and elliptical holes that has a radial offset 
associated with it—that is, when using a pin nest. In Figure 9-9, the 
radius of the pin nest’s shank determines how far outward or inward 
the circle radius or ellipse axis must be offset.

Figure 9-9. Measuring a sur-
face hole with a laser tracker’s 
SMR and Pin Nest.

Radial Offset
Planar Offset

Material

Spherical probes (such as SMRs and balls) have the same planar and 
radial offset, although technically the radial offset is not used.

The following are some sample measurement instrument/tooling 
combinations, and the proper planar and radial offsets associated 
with each:

Measurement Tooling Planar Offset Radial Offset

PCMM arm with 6 mm probe 3 mm (0.1181”) 3 mm (0.1181”)

PCMM arm with 3 mm probe 1.5 mm (0.0591”) 1.5 mm (0.0591”)

PCMM arm with Point Probe 0 0

Tracker with 1.5” (38.1 mm) SMR 0.75” (19.05 mm) 0.75” (19.05 mm)

Tracker with 1.5” SMR and Flat Nest1 1.0” (25.4 mm) N/A (0)

Tracker with 1.5” SMR and Pin Nest 1.0” (25.4 mm) 0.125” (3.175 mm)

Tracker with 1.5” SMR and Edge Nest 1.0” (25.4 mm) 0

Laser Radar (non-contact measurement) 0 0

1 When a flat nest is used, a feature such as a hole cannot be 
measured because there is no tooling feature to properly locate the 
SMR radially. As a result, there is no valid radial offset for this tooling 
combination.
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Accessing A Point’s Group Menu From the Graphical View

Sometimes, you want to select a point and access the properties of 
its enclosing point group. For instance, to change the color of a point 
you would need to access its parent point group. The graphical view’s 
context menu allows you to do just that.

To Access a Point’s Enclosing Group Menu:

 ■ In the graphical view, right-click a point and select Group Menu 
from the context menu. The enclosing group’s context menu 
will be displayed.

Measurements
Measured points carry a number of additional properties that are im-
portant to understand.

How SA Computes a Measured Point’s Location

Determining the location of a measured point at first seems trivial. 
However, it gets significantly more complex when you realize that 
some instruments (such as theodolites) are angle-only measurement 
devices, and do not measure a target’s position in space. With the-
odolites, at least two measurements of a target need to be recorded 
from different points in space to triangulate the location of the point.

Another complication is that one or more instruments may measure 
a single target several times. We will discuss these situations, but let’s 
first look at how SA computes a measured point’s location in a simple 
case, when an instrument provides a point position in space.

When measurements are recorded, SA always records the raw mea-
surement data that came from the instrument. For theodolites, this 
means a horizontal angle (azimuth) and vertical angle (elevation). For  
other line-of-sight devices, it means azimuth, elevation, and distance, 
and for non-spherical measurement devices (such as portable arms) 
the coordinates are provided from the instrument in Cartesian space.

The instrument always provides the location of the measurement 
relative to its own internal reference system—typically at the opti-
cal center or at the base of an instrument. Since each instrument 
has a three-dimensional position and orientation in the job file, SA 
takes these raw measurements and calculates their coordinates in job 
space based on the position of the instrument. When an instrument 
moves, the position of all of its measurements are recalculated.

At any time, you can move a point group containing measured 
points. When you do so, you will break the connection between the 
measured points and their instrument, and the measured points will 
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instantly turn into constructed points to show that you are no longer 
looking at actual measurements. You haven’t lost the original mea-
surement data, however. You can recalculate these measured points 
and turn them back into measurements.

To Recalculate Measured Points:

 ■ From the menu, select Analysis>Re-Compute Targets From Shots. This 
will snap all measurements back into place relative to the in-
strument and convert them back into measured points.

About Target Observations

An observation is a single reported measurement from an instru-
ment. A target, by definition, must have one or more instrument ob-
servations. While the coordinates for a constructed point are easy to 
understand and unambiguous, the coordinates for a target take more 
explanation. It is fairly common, particularly with theodolite measure-
ments, for a given target to have multiple observations that together 
define the coordinate of the point. Consider, for instance, the case 
where three theodolites have measured a common point (see Figure 
9-10 on page 281). Since each measurement has finite error (due 
to encoder error, operator differences, alignment, and other factors), 
the observations will not coincide in space. Put another way, each in-
strument will “see” a slightly different location when measuring the 
same point in space. (The error in Figure 9-10 is greatly exaggerated 
for clarity).

It would be easy to simply take an average of each observation to 
determine the computed target location, but that is not an optimal 
technique, because it assumes that each observation has equal error. 
Instead, SA uses a more accurate technique of computing the coordi-
nate for the target based on an optimization. In Figure 9-10, the com-
puted target location is closer to the leftmost instrument’s observa-
tion, due primarily to the fact that it is closest to the measured point 
and therefore should have the least measurement error.

A view of this situation from above (see Figure 9-11 on page 281) 
makes it even clearer: The closest instrument is most accurate, and 
gets the most influence in calculating the target location. The net re-
sult of this optimization technique is that the computed target loca-
tion’s coordinates are more accurate than they would be if the aver-
age of the observations were used instead.

In the case of a single instrument measuring a point multiple times, 
the end result is that the target coordinate is almost exactly an aver-
age of the individual observations, as the distance to the target is ap-
proximately constant for all observations.
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Figure 9-10. A measured 
target as computed by obser-
vations from three instruments 
(exaggerated for clarity).

Figure 9-11. The instrument 
closest to the target has the 
greatest accuracy and there-
fore gets the largest influence 
in target computation.
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About Target Offsets

Regardless of the type of instrument used, when a measurement is 
performed in SA, the point that is recorded is the center of the probe 
(or the surface intersection point for non-contact measurements). For 
example:

 ■ Laser tracker measurements record the center of the SMR.

 ■ PCMM arm measurements record the center of the probe tip.

 ■ Laser radar measurements record the returned point of con-
tact with the object’s surface.

Figure 9-12. The center of 
the probe is the recorded 
point, and the offset is its 
radius.

Recorded Point

Offset Value

In order to properly compare measured points to geometry or con-
struct geometry from measured points, SA must always know the pla-
nar and radial offset for the measurement tooling that is currently in 
use. In normal use, an instrument interface has an offset assigned 
based on the current probe and tooling being used, and this offset is 
automatically applied to points as they are measured. For example, 
suppose a pin nest and SMR are being used to measure the inside 
diameter of a hole with a laser tracker. If SA is set up to construct a 
circle as a result of the measurement, then once the circle is fit to the 
measured probe centers, it will be offset normal to the circle by the 
planar offset amount, and its radius will be increased by the radial 
offset value. These offsets will align the constructed circle with the 
true location of the edge of the hole, regardless of the measurement 
tooling or probe used for the measurements.

In addition to the target’s offsets, for traceability purposes each in-
dividual measurement observation has a radial and planar offset as 
well.

Characteristics Unique to Measured Points

There are a few characteristics that are unique to measured points 
that you will not see on constructed points (Figure 9-13).
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Figure 9-13. The Target 
Information dialog looks like 
the Point Information dialog 
for constructed points, but has 
a few subtle (but important) 
differences.

Uncertainty
There is an Uncertainty box with a Compute button inside. This is used 
for computing the uncertainty of the measured point and is discussed 
in more detail in the chapter on Measurement Uncertainty.

Measurement Details    
To view the detailed measurement information that comprises a tar-
get, click on the Measurement Details button. (Note that the button 
will display the number of active observations that are being used to 
calculate the target position).

Figure 9-14. Two observa-
tions comprise this measured 
target, and both are active.

In this example (Figure 9-14), there are two active instrument obser-
vations that are being used to calculate the target coordinates. The 
checkboxes at the top of this dialog control which items are visible in 
the table.

 ■ Time. Toggles whether or not the timestamp (date and time) 
for the measurement is displayed.

 ■ Information. Toggles whether measurement details (such as 

Warning:  Deactivated 
observations are not 
used when calculating 

the target coordinate.
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instrument serial number, mode, weather information, etc.) are 
displayed.

 ■ User. Toggles whether the username is displayed.

 ■ Target Offset. Toggles whether the stored offsets for each ob-
servation are displayed.

 ■ Pointing Error. Displays the instrument’s angular and linear 
pointing errors. (Pointing error is the angular error between the 
observation and the computed target location).

Next to these checkboxes, the dialog displays the RMS value of the 
combined angular pointing errors.

To Activate or Deactivate an Observation:

 ■ Check or uncheck the observation in the Instrument column.

To Activate or Deactivate All Observations on a Target:

 ■ Right-click the point in the tree or graphical view and select 
Activate All Measurements or Disable All Measurements as applicable.

To Activate All Measurements to All Targets:

 ■ From the menu, select Analysis>Activate All Measurements.

To Permanently Delete an Observation:

 ■ Select the row in the table and click the Delete button.

An Apex Angle is the angle between two measurement rays, or lines 
of sight, from measurement devices (see Figure 9-15). Ideal measure-
ments with the least amount of error and uncertainty are obtained 
with apex angles of 90 degrees. As the apex angles increase or de-
crease from this value, the measurements have more uncertainty and 
are less reliable. SA can calculate and display the worst apex angle 
from a series of observations comprising a target.
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Figure 9-15. The apex angle 
between two lines of sight to a 
common target.

Apex Angle

To Determine the Worst Apex Angle Comprising a Target:

 ■ Click the Apex Angles button. SA will determine the two obser-
vations that form the worst apex angle, list the angle, and also 
list the two observations that form this angle.

To Point an Instrument’s Graphical Model at its Observation:

 ■ Select the observation of interest and click the Point At w/ 
Graphics button. The instrument’s head will point at the mea-
surement in the graphical view.

Observation Details
You can view the details for an individual instrument observation.

To View the Details for a Single Observation:

 ■ Double-click or right-click the observation, or

 ■ Select the desired row and click the Properties button.

The details for an observation are displayed in the Polar Measure-
ment dialog (see Figure 9-16 on page 286).
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Figure 9-16. A single ob-
servation’s details. This shows 
a laser tracker’s observation 
information.

The top section displays all of the metadata associated with the ob-
servation.

 ■ Use In Calculation. Toggling this option is equivalent to ac-
tivating/deactivating an observation in the Measurement De-
tails dialog.

 ■ Draw Me. Turn this option off to prevent SA from drawing the 
instrument shot (ray) for the observation.

 ■ Theta/Phi/Z (X/Y/Z). Read-only values showing the raw data 
from the instrument, expressed in the instrument’s coordinate 
frame.

 ■ Advanced Options (theodolites only). Mark observations as 
normal, collimation shots, or mirror cube shots (see below).

Each observation can store a planar and radial offset. These offsets 
are normally recorded when the measurement is taken. However, you 
can change them by filling in the Planar and Radial offset values to as-
sign custom offsets to a specific observation.

The Advanced Options button allows you to specify whether the ob-
servation is a normal Shot, a Collimation Shot (you must specify the 
instrument you’re collimating to), or a Mirror Cube Shot (you must 
specify which mirror face was measured). These settings are used to 
help constrain bundle adjustments (see Figure 9-17 on page 287).
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Figure 9-17. Advanced shot 
options for a spherical mea-
surement.

Targeting Offsets
Individual observations can have their own stored planar and radial 
offsets. Constructed points do not have to deal with this, as they do 
not have any observations.

A button labeled Apply offsets to all measurements (see Figure 9-13 
on page 283) is visible below the planar and radial offset fields for 
measured points (you will not see it for constructed points). Clicking 
this button will apply the specified planar and radial offsets to all indi-
vidual observations for the target.

Setting Properties for Multiple Points
Some situations arise in which you’d like to change the properties of 
multiple points at once. For instance, if you accidentally measure a 
large number of points with the wrong target offsets set in the instru-
ment interface, you will need to correct these offsets in order for SA 
to properly apply probe compensation.

You can apply new tolerances or offsets to multiple points using the 
Set Properties for Multiple Points dialog (Figure 9-18).

Figure 9-18. The Set Proper-
ties for Multiple Points dialog.
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To Change Offsets or Tolerances For Multiple Points:

 ■ From the menu, choose Edit>Set Properties for multiple points and 
select the points to modify. This will call up the Set Properties 
for Multiple Points dialog.

To Change Offsets or Tolerances For An Entire Group:

 ■ Right-click a point group and select Set Point Properties from the 
context menu. This will call up the Set Properties for Multiple 
Points dialog.

This dialog has two regions. The top region is for changing the stored 
target offsets, and the bottom region is for changing the point toler-
ances.

 ■ Set Target Offsets. Check this option to change the planar and 
radial offsets of the measured points to the values entered into 
the Planar and Radial fields.

 ■ Set Measurement Offsets Also. This applies the entered off-
sets to the individual observations within a target as well. Very 
rarely would you not want to select this option.

 ■ Set Tolerances. When checked, the tolerances specified via 
the Tolerance Settings button will be applied to the points.

Working With Point Lists
It is often useful to view a list of points and point coordinates in tabu-
lar format, so that you can easily compare against nominals or quickly 
modify a set of points at once (similar to working in Excel). SA’s point 
lists provide this functionality (Figure 9-19).

Figure 9-19. A point list.

To View a Point List:

Do one of the following:

 ■ From the menu, select View>Point Lists for Groups, then select the 
group(s) to view, or

 ■ Right-click a group and select View Point List from the context 
menu (to view a single group).

The list has several buttons at the top:

Note:  The tolerance settings 
dialog is the same as de-

scribed in “Point Tolerance” on 
page 276.
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 ■ Refresh. Refreshes the list to ensure it’s showing the latest in-
formation.

 ■ Copy to Clipboard. Copies the selected rows (or all rows if 
nothing is selected) to the clipboard.

 ■ Export to Text File. Exports the selected rows (or all rows if 
nothing is selected) to a text file.

 ■ Coordinate System. Click this button to switch among Carte-
sian, Cylindrical, and Spherical coordinates.

 ■ Edit. Opens up a new window allowing you to modify the point 
information (see below).

Instead of just viewing the information, a point list can be used for 
modifying point names or coordinates. This is particularly useful be-
cause you can change multiple values at once. For instance, you can 
quickly change the x-coordinate of multiple points in one action.

To Edit a Point List:

Do one of the following:

 ■ With the point list already displayed (see “To View a Point List:” 
on page 288), click the Edit button, or

 ■ Right-click a point group and select Edit Point List from the con-
text menu to edit that group of points.

The Edit Point List dialog is displayed in Figure 9-20.

Figure 9-20. The Edit Point 
List dialog.

To Change a Point’s Name, Coordinate, or Notes:

 ■ Double-click the field you’d like to modify, enter a new value, 
then press Enter.

To Modify Multiple Values At Once:

1. Select multiple fields using Shift+Click (standard Win-
dows range selection) or Ctrl+Click (standard Windows 
non-contiguous selection).

2. Double-click one of the selected fields, type a new value, and 
press Enter. All fields will be updated with the new value.
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The dialog provides a few additional buttons at the top.

 ■ Apply Changes. Modifications are not actually applied to the 
points until you click this button.

 ■ Coordinate System. Choose to switch the display between 
Cartesian, Cylindrical, or Spherical coordinates.

 ■ Cancel. If you cancel, no changes will be applied the points.

Constructing Points
There are many different ways to create points in SA. You can explic-
itly create a point at a specified coordinate or create points through 
an array of geometric analysis functions.

Entering Point Coordinates

The most basic way to create a point is to explicitly enter a point by 
specifying its collection, group, target, and coordinate system. This 
will create a single constructed point in your job.

To Enter a Point:

1. From the menu, select Construct>Points>Enter, or press Ctrl+P 
(default keyboard shortcut). The Add Points to Model dialog 
will appear (Figure 9-21).

Figure 9-21. Constructing a 
point by entering its coordi-
nates.

2. Enter a collection, group, and point name (or select one from 
the dropdown of existing collections or groups).

3. Specify the desired coordinate type (Cartesian, Cylindric, or 
Spheric).

4. Enter the desired coordinate values, then click the Add Point 
button to create the point and continue adding more, or click 
Done to create the point and close the dialog.
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Constructing a Point at the Center of a Line

Creating a point at the center of a line constructs a point halfway be-
tween its endpoints.

To Create a Point at the Center of a Line:

1. From the menu, select Construct>Points>Center>Line.

2. Select the desired line.

3. The Construct New Point dialog will appear (Figure 9-22).

Figure 9-22. The Construct 
New Point dialog.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.

Constructing  Points at the Center of Spheres and Circles

You can construct points at the center of multiple circles or multiple 
spheres with a single command.

To Construct Points at the Center of Circles or Spheres:

1. From the menu, select Construct>Points>Center>Circles or 
>Spheres. The Point Name dialog will appear (Figure 9-23).

Figure 9-23. The Point 
Name dialog.

2. Enter a collection, group, and point name for the first point to 
construct. (Leave the Collection field blank to put the points 
into the active collection). Click OK.

3. Select one or more circles or spheres. Each center point will 
be created, and successive point names will be incremented.
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4. When finished creating centers, press Esc or Enter.

Constructing Points at the Center of a Cylinder

When creating points at the center of cylinders, SA will actually create 
three points: one point at each end on the cylinder’s axis (called EndA 
and EndB), and a third point halfway between the endpoints (called 
Center).

To Create Points at the Center of Cylinders:

1. From the menu, select Construct>Points>Center>Cylinder.

2. Select the cylinder. The points will be placed into the active 
collection, into a group with a name matching that of the cyl-
inder.

Projecting to the Closest Point on Objects

Projecting points to the closest point on an object is equivalent to 
creating points on the object where that object’s surface normals in-
tersect with the original points.

With this command, you can select multiple objects and SA will find 
the closest point among all selected candidate objects. You can also 
select multiple points, and SA will find the closest point for each of 
the candidate points.

You can also offset points away from the surface. This is particularly 
useful when you have nominal points on a surface that you’d like to 
back away from the surface by the probe radius (so that those points 
can serve as proximity triggers for measurement).

To Project Points to the Closest Points on an Object:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Closest Point.

2. Select one or more objects to project to.

3. Select one or more points to project. The Point Naming dialog 
will appear (Figure 9-24).

Figure 9-24. The Point Nam-
ing dialog.
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4. Enter or select the desired group to contain the projected 
points. In the Add Prefix or Add Suffix field, enter a prefix or suf-
fix that you’d like to attach to the point names, then click OK.

5. The Probe Offset dialog will appear. Enter a distance to offset 
the projected points back away from the object’s surface. A 
positive value shifts along the positive direction of the surface 
normal.

Projecting Points Parallel to a Working Coordinate Frame Axis

You can project points along a working coordinate frame axis until it 
intersects with one or more surfaces (Figure 9-25). (If there is no inter-
section, no projected point will be created).

Figure 9-25. Projecting a grid 
of points along the working X 
axis to a surface.

To Project Points Along the Working Coordinate Frame Axis:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Frame Axis>Parallel to WCF Axis.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. When the Select Axis dialog appears, choose the axis to proj-
ect along.

5. The Point Naming dialog will appear (Figure 9-24). Enter or se-
lect the desired group to contain the projected points. In the 
Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.
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Projecting Points Radially from a Working Coordinate Frame Axis

You can also project points radially from a coordinate frame axis. 
Here, one of the axes of the working coordinate frame serves as the 
axis of a cylindrical coordinate system, and the points are projected 
out radially from that axis until they intersect with one or more sur-
faces (Figure 9-26).

Figure 9-26. Projecting radi-
ally from a coordinate frame 
axis.

To Project Radially from a Working Coordinate Frame Axis:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Axes>Radial from WCF Axis.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. When the Select Axis dialog appears, choose the axis from 
which to project radially.

5. The Point Naming dialog will appear (Figure 9-24). Enter or se-
lect the desired group to contain the projected points. In the 
Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

Projecting Points Spherically from a Working Coordinate Frame Origin

Points can be projecting spherically outward from the origin of the 
working coordinate frame (Figure 9-27).
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Figure 9-27. Projecting 
points spherically from the 
working coordinate frame 
origin.

To Project Points Spherically From the Working Coordinate Frame Origin:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Frame Axis>Spherical From WCF Ori-
gin.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. The Point Naming dialog will appear (Figure 9-24). Enter or se-
lect the desired group to contain the projected points. In the 
Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

Projecting Points to a Curve

You can project points directly to any arbitrary curve or curves (Figure 
9-28). The projected points can lie directly on the curves or can be 
backed off the curve by a specified amount. Each point will be pro-
jected to the closest curve among all candidates.

To Project Points to a Curve:

1. From the menu, select Construct>Points>Project Points to>Curves.

2. At the prompt, select the curves to project to.

3. Select the points to project.

4. The Point Naming dialog will appear (Figure 9-24). Enter or se-
lect the desired group to contain the projected points. In the 
Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

5. At the Probe Offset dialog, enter a distance to offset the pro-
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jected points back away from the curve. This value must be 
positive, and always shifts away from the curve.

Figure 9-28. Projecting 
points to a curve.

Creating Points at a 3-Plane Intersection

A point can be created at the intersection of 3 planes. This of course 
requires that no two planes may be parallel.

To Create a Point at the Intersection of 3 Planes:

1. From the menu, select Construct>Points>Intersection>3 Planes.

2. Select the three planes successively.

3. The Construct New Point dialog (see Figure 9-22 on page 
291) will appear. Leave the coordinates as-is (they are calcu-
lated for you), and specify the desired collection, group, and 
point name (or select an existing collection or group from the 
dropdown).

4. Click OK to create the point.

Creating Points at the Intersection of a Plane and Circle

Intersecting a plane and a circle will actually create two points as seen 
in Figure 9-29. It should be noted that the plane and circle cannot be 
parallel or coplanar.

To Create Points at the Intersection of a Plane and Circle:

1. From the menu, select Construct>Points>Intersection>Plane and 
Circle.

2. Select the plane, then the circle. Two new points will be cre-
ated in the active collection’s Intersections group named 
Plane-Circle1 and Plane-Circle2.
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Figure 9-29. Intersecting a 
plane with a circle.

Constructing Points at the Intersection of a Line and Plane

You can intersect a line with a plane to create a point at the intersec-
tion (Figure 9-30).

Figure 9-30. A line and plane 
intersection creating a point, 
even though their depictions 
do not intersect.

There are a few things to keep in mind:

 ■ The line and plane need not physically intersect, since planes 
and lines are treated as infinite in size.

 ■ If the line lies in the plane, or the line is parallel to and not in the 
plane, no points will be created.

To Create a Point at the Intersection of a Line and Plane:

1. From the menu, select Construct>Points>Intersection>Line and 
Plane.

2. Select the line, then the plane.

3. The Construct New Point dialog (Figure 9-22) appears.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.
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Constructing a Point at the Intersection of 2 Lines

You can create a point at the intersection of two lines (Figure 9-31). 
Or, if the lines do not intersect, a point will be created at their mutual 
perpendicular midpoint. (The mutual perpendicular midpoint is half-
way between the closest points between the two lines). If the lines 
are parallel, no point will be created.

Figure 9-31. A point con-
structed at the mutual perpen-
dicular midpoint between two 
lines. In this case, these two 
lines do not intersect.

To Create a Point at the Intersection of Two Lines:

1. From the menu, select Construct>Points>Intersection>2 Lines (mu-
tual perpendicular midpoint).

2. Select the first line, then the second.

3. The Construct New Point dialog (Figure 9-22) appears.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.

Constructing Points at the Intersection of a Line and Circle

Points can be created at the intersection of a line and a circle (Figure 
9-32). The line is first projected to the plane on the circle and then the 
intersection points are created.

Figure 9-32. A line and circle 
intersection creating two 
points.

To Create Points at the Intersection of a Line and Circle:

1. From the menu, select Construct>Points>Intersection>Line and 
Circle.

2. Select the line, then the circle. Two new points will be created 
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in the active collection’s Intersections group.

Constructing Points at the Intersection of a Line and Cylinder

You can create a point at each intersection of a line and cylinder. The 
cylinder and line need not physically intersect, since cylinders and 
lines are treated as infinite in length (Figure 9-33). However, the line 
must pass within the cylinder’s radius.

Figure 9-33. A point at each 
intersection of the line and 
cylinder are created, even 
though their depictions do 
not intersect. Note the length 
of the cylinder does not need 
to be increased, since cylinders 
are infinite in size.

To Create a Point at the Intersection of a Line and Cylinder:

1. From the menu, select Construct>Points>Intersection>Line and Cyl-
inder.

2. Select the line, then the cylinder. A naming dialog appears 
(Figure 9-35). 

3. Specify the desired collection, group, and point names (or se-
lect an existing collection and group from the dropdown).

4. Click OK to create the point.

Constructing Points at the Intersection of a Line and Sphere

You can create a point at each intersection between a line and a 
sphere.
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Figure 9-34. A point is con-
structed at each intersection 
of the line and sphere.

To Create a Point at the Intersection of a Line and Sphere:

1. From the menu, select Construct>Points>Intersection>Line and 
Sphere.

2. Select the line, then the sphere.

3. A naming dialog appears (Figure 9-35).

4. Specify the desired collection, group, and point names (or se-
lect an existing collection and group from the dropdown).

5. Click OK to create the point.

Figure 9-35. The naming dia-
log for line intersections with 
cylinders and spheres.

Constructing Points at the Intersection of 2 B-Splines

Points can be constructed from the intersections of two B-Splines. A 
point will be created at the midpoint of the closest location between 
the two B-splines if they do not intersect (Figure 9-36).

To Create a Point at the Intersection of 2 B-Splines:

1. From the menu, select Construct>Points>Intersection>2 B-Splines.

2. Select the first B-spline, then the second.

3. The Construct New Point dialog (Figure 9-22) will appear. 
Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown.
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4. Click OK to create the point.

Figure 9-36. The pink and 
green B-splines create a 
point where they physically 
intersect, whereas the green 
and purple B-splines create a 
midpoint between their clos-
est locations since they do not 
intersect.

Constructing Points at the Intersection of a B-Spline and Surfaces

You can create a point at the intersection of a B-Spline and a surface 
(Figure 9-37). The command follows the B-Spline from its tail toward 
its head and creates a point when the spline first pierces the surface.

You can select multiple surfaces with this command, but still only one 
intersection point will be created.

Figure 9-37. Intersecting a B-
Spline with a surface to create 
a point.

To Create a Point at the Intersection of a B-Spline and Surfaces:

1. From the menu, select Construct>Points>Intersection>B-Spline and 
Surfaces.

2. Select the B-Spline.

3. Select one or more surfaces to test.

Note:  If the B-Spline inter-
sects multiple times or inter-

sects multiple selected surfaces, 
only one point is created. Which 
point is created is not generally 
clear.
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4. When prompted, enter an approximation tolerance. Gener-
ally, the default value is fine.

5. The Construct New Point dialog (Figure 9-22) will appear. 
Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown.

6. Click OK to create the point.

Constructing Points at the Intersection of Principle Object Axes and Surfaces

A point can be constructed at the intersection of an object’s axis and 
a surface (Figure 9-38). The definition of the axis depends on the type 
of object, but the axis must intersect at a point on the surface and not 
through a hole in the surface.

Figure 9-38. A point created 
at the intersection of a plane’s 
axis and a surface.

To Construct a Point at the Intersection of an Object Axis and Surface:

1. From the menu, select Construct>Points>Intersection>Principle Ob-
ject Axes and Surfaces.

2. Choose the axis object, followed by the surface. 

3. Enter the destination point group name. You also have the 
option of entering a suffix for the points (which will have the 
same name as your object).

4. Click OK.

Shifting Points In a Direction

You can use a selected object to define a direction in which to shift a 
point or selection of points by a specified distance (Figure 9-39). If a 
frame is selected as the object, you will be prompted to choose along 
which axis to shift the points.
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Figure 9-39. Green points 
were copied from the original 
points (red) and shifted along 
the circle’s surface normal.

To Shift Points in a Direction: 

1. From the menu, select Construct>Points>Shift Points>In a Direction.

2. Select the object defining the shift direction, then select the 
points you would like to shift.

3. The Shift Points in Direction dialog will appear (Figure 9-40). 
Enter the shift distance and the point group destination.

Figure 9-40. Shifting points 
along a direction.

4. Click Make Points to create the shifted points.

Shifting Points In Cylindric Coordinates

Points may be shifted cylindrically. Any object that contains direc-
tional  information may be selected to define the axis of the cylinder 
about which the points are shifted (Figure 9-41).

Figure 9-41. The cylinder 
is the object defining the 
cylindrical coordinate system 
and the blue points were cop-
ied from the original points 
(green) and shifted 5.0” along 
the planar and radial direc-
tions.

To Shift Points in Cylindric Coordinates: 

1. From the menu, select Construct>Points>Shift Points>In Cylindric 
Coordinates.

2. Select the object defining the cylindric coordinate system, 
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followed by the points to be shifted.

3. The Shift Points in Cylindric Coordinates dialog will appear 
(Figure 9-42). Enter the radial and planar shifts and the point 
group destination.

Figure 9-42. Specifying the 
radial and planar shift.

4. Click Make Points to create the shifted points.

Laying Out Points on a Grid By Count

A grid of points can be laid out with respect to the XY plane of the 
working coordinate frame. Using this command, you specify the 
range of the grid and the number of points desired along each axis, 
and SA determines the spacing for you automatically.

Figure 9-43. 10x10x1 Grid 
layout of 100 points.

To Lay Out Points on a Grid by Count:

1. Activate the frame you’d like to use to define the grid orienta-
tion.

2. From the menu, select Construct>Points>Layout>Grid by Count.

3. The Make a Grid of Points dialog will appear (Figure 9-44). In 
the Min and Max fields, specify the limits along the coordinate 
directions for the three-dimensional grid. In the Count fields, 
specify the number of rows of points along each direction. 
You can also enter a destination collection, group, and target 
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prefix for the resulting points. 

4. Click Create Points to construct the grid.

Figure 9-44. Entering the X, 
Y, and Z range of the grid, and 
the number of rows of points 
along each axis direction.

Laying Out Points on a Grid By Distance

A grid of points can be laid out with respect to the XY plane of the 
working frame. Using this command, you specify the range of the grid 
and the distance between points, and SA determines the number of 
points for you automatically.

To Lay Out Points on a Grid by Distance:

1. Activate the grid you’d like to use to define the grid orienta-
tion.

2. From the menu, select Construct>Points>Layout>Grid by Distance. 
The Make a Grid of Points dialog will be displayed (Figure 
9-45).

Figure 9-45. Defining 
parameters to create a grid by 
spacing.

3. Specify the range of the grid in all three component direc-
tions, as well as the desired spacing between points along 
each direction. You can also enter a destination collection, 
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group, and target prefix for the resulting points.

4. Click Create Points to construct the grid.

Laying Out Points On a Circle

It is often useful—particularly when laying out nominal bolt hole pat-
terns—to lay out points on a circle. A circular point layout can be con-
structed in the XY plane of the working frame (Figure 9-46).

Figure 9-46. Laying out 16 
evenly-spaced points on a 
circle.

The Layout Points on Circle dialog is shown in Figure 9-47. A number 
of options are available when laying out points, which are discussed 
below:

Figure 9-47. The Layout 
Points on Circle dialog.

 ■ Radius. The radius of the circle defining the points.

 ■ Starting angle. The angle in the working frame’s XY plane, 
from the X axis, at which to lay out the first point.

 ■ Number of points on circle. The number of points to create 
on the circle.

There are two methods for laying out points on the circle:

 ■ Evenly space points around entire circle. The points will be 
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constructed evenly around the entire circle.

 ■ Space points by. You can specify the angle between points. 
If (based on the specified spacing and the number of points) 
more than 360° of the circle is specified, the points will con-
tinue to be laid out around the circle.

You can also control the naming of the resulting points using the 
Group and First Point fields, and whether a center point is created with 
the Create center point option.

To Construct a Layout of Points on a Circle:

1. From the menu, select Construct>Points>Layout>Circle.

2. The Layout Points on Circle dialog will appear (Figure 9-47).

3. Fill in the desired parameters, then click OK to create the 
points.

Generating Random Points

Occasionally, you may come across the need to generate random 
points. (This tends to be more common in training and testing than  
actual production environments).

When generating random points (Figure 9-48), you can specify the 
number of points and the range of the points along each of the three 
axis directions. The points will be randomly created inside this de-
fined box.

Figure 9-48. 100 randomly-
generated points.

To Construct a Random Layout of Points:

1. From the menu, select Construct>Points>Layout>Random Points or 
use the default keyboard shortcut Ctrl+Alt+Z.

2. The Random Point Generator dialog will appear (Figure 9-49). 
Specify the number and range of point coordinates as well as 
the desired group name.
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Figure 9-49. The Random 
Point Generator dialog.

3. Click OK to create the points.

Laying Out Points On A Surface By Clicking

You can click anywhere on a surface to create a point on that surface 
(Figure 9-50). 

Figure 9-50. Laying out 
points on a surface.

To Lay Out Points on a Surface:

1. From the menu, select Construct>Points>Layout>On Surface By 
Clicking.

2. Place the cursor anywhere on the surface and click to create 
a point at that location. If the cursor is not over a surface, a 
point will not be created.

Laying Out Points On An Object Vertex By Clicking

Points can be constructed on an object’s vertices simply by clicking 
near the vertex (Figure 9-51).

Figure 9-51. Several points 
have been laid off on this 
cylinder’s vertices.

To Lay Out Points on Object Vertices by Clicking:

1. From the menu, select Construct>Points>Layout>On Object Vertex 
by Clicking.

Note:  The first click on a sur-
face will incur a small delay 

as the software performs some 
calculations. Remaining clicks on 
the surface will be much faster.

Note:  The points will always 
be created on the surface, 

regardless of render settings.
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2. At the prompt, enter a desired group and starting point name.

3. Click the object near the desired vertices.

4. Press Enter when finished.

Laying Out Points On An Object’s Vertices

You can construct points on all vertices of one or more objects at 
once (Figure 9-52).

Figure 9-52. Points laid out 
on a cylinder’s vertices.

To Lay Out Points on an Object’s Vertices:

1. From the menu, select Construct>Points>Layout>On Object’s Verti-
ces.

2. Select the objects on which you’d like to create vertex points.

3. Enter a name for the destination group, then click OK.

Laying Out Points Evenly On Curves

You can construct any number of evenly-spaced points on one or 
more B-Spline curves (Figure 9-53).

Figure 9-53. 10 points 
spaced evenly on a B-Spline.

To Lay Out Evenly-Spaced Points on a Curve:

1. From the menu, select Construct>Points>Layout>On Curves>n 
Spaced Points.

2. Select one or more B-splines.

Tip:  Increasing surface ren-
dering detail will create more 

vertices for a given surface.
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3. Type a name for the destination group, then click OK.

4. At the prompt, enter the number of points to create on each 
curve, then click OK.

Laying Out Points On Curves With Prescribed Spacing

SA can construct points on one or more curves spaced by a prescribed 
distance (Figure 9-54). This is not a straight-line distance, but a dis-
tance along the curve (as if you’d laid a measuring tape of the pre-
scribed length along the curve). When creating the points, SA places 
the first point exactly on the starting end of the curve.

Figure 9-54. Points on a 
B-spline spaced exactly 2” from 
each other along the curve.

To Create Points Spaced on a Curve by a Prescribed Distance:

1. From the menu, select Construct>Points>Layout>On Curves>Spaced 
at Distance.

2. Select one or more B-splines.

3. Type a name for the destination group, then click OK.

4. Enter the specified distance between points, then click OK.

Laying Out Points On Curves by Clicking

This command allows you to click anywhere on one or more curves 
and create a point at that position on the curve (Figure 9-55).

Figure 9-55. Several points 
created by clicking on a B-
Spline.

To Create Points on a Curve by Clicking:

1. From the menu, select Construct>Points>Layout>On Curves>By 
Clicking.

2. Enter a destination group name for the constructed points, 
then click OK.

3. Type a starting point name, then click OK.
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4. Select one or more curves to consider.

5. Click at the desired locations. SA will create the point on the 
closest point of the closest curve.

Laying Out Points On Lines

As with a curve, you can lay points out on a line by specifying the 
number of points (in which they’re evenly spread along the line) or by 
specifying the spacing (Figure 9-56).

Figure 9-56. A line with 10 
evenly-spaced points.

To Lay Out Points on a Line:

1. From the menu, select Construct>Points>Layout>On Lines.

2. Select one or more lines.

3. The Layout Points on Lines dialog will appear (Figure 9-57).

Figure 9-57. The Layout 
Points on Lines dialog.

 ■ n Spaced Points. SA will create the specified number of points 
spaced evenly along each of the selected lines.

 ■ Spaced at Distance. SA will create points on each line starting 
from the tail of the line, using the prescribed spacing.

 ■ Group. The name for the resulting point group.

4. Choose the desired options, then click OK.

Laying Out Points At The Center of Surface Holes

It is often useful to create points at the center of holes on a surface. 
You can click on a single surface containing surface holes, and SA will 
create points at the center of the holes based on prescribed minimum 
and maximum diameter thresholds (Figure 9-58).

If a surface is dissected and you therefore select just a single surface 
face with holes, the points will be created along that face. If a surface 
is merged and you select a closed shell, points will be created on each 
end of the hole (if it is a thru hole).
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Figure 9-58. These points 
have been constructed at the 
center of surface holes.

SA considers any surface opening that has a circular arc for an edge 
as a surface hole.

To Construct Points at the Center of Surface Holes:

1. From the menu, select Construct>Points>Layout>At Center of Sur-
face Holes.

2. Select one or more surfaces with holes.

3. The Points from Surface Holes dialog will appear (Figure 9-59).

Figure 9-59. The Points from 
Surface Holes dialog.

 ■ Output Group. The name for the destination group.

 ■ Min Dia. The minimum diameter hole for point construction. 
Holes smaller than this diameter will not have center points 
constructed.

 ■ Max Dia. The maximum diameter hole for point construction. 
Holes larger than this diameter will not have center points con-
structed.

 ■ Check Tolerance. This describes the accuracy of the diameter 
check. Smaller values may take incrementally longer, but will 
more accurately check the diameter of the hole. Typically, you 
need not adjust this value unless you encounter unexpected 
behavior.

4. Select the desired options, then click OK.
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Laying Out Points In The View By Clicking

Primarily intended for training and testing purposes, SA enables you 
to construct points by clicking anywhere in the graphical view. These 
points will be created on a plane perpendicular to the viewing direc-
tion (Figure 9-60).

Figure 9-60. Random points 
laid out in the view.

To Construct Points in the Graphical View by Randomly Clicking:

1. From the menu, select Construct>Points>Layout>In View By Click-
ing.

2. Enter a name for the destination point group.

3. Specify a name for the starting point (subsequent point 
names will be incremented.

4. Click anywhere in the graphical view to create each point. 
Press Enter when finished.

Copying Existing Points

Any set or subset of existing points can be easily copied. The copies 
are placed into a new point group.

To Copy Points from Existing Points:

1. From the menu, select Construct>Points>From Existing Points>Copy.

2. Select the points that you want to copy.

3. When prompted, type a destination group name, then click 
OK.

Moving Existing Points Into A New Group

You can quickly and easily relocate a set of points into a new group 
(Figure 9-61). The points may start in the same group or separate 
groups, but they will always end up in the same group. The points are 
relocated (not copied), which means that measurements remain as 
measured points after the command is executed. After the command, 

Note:  Any copied measure-
ments become constructed 

points.

Note:  This command does 
not physically move points, 

as the name might imply.
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the point names will carry a prefix indicating their source group.

Figure 9-61. Relocating 
points into a new group.

To Move Existing Points to a New Point Group:

1. From the menu, select Construct>Points>From Existing Points>Move.

2. Select the points you want to move.

3. At the prompt, enter a name for the destination group, then 
click OK.

Creating a Subset of Points With Greatest Spacing

It is not uncommon to be confronted with point data that is more 
dense than is necessary for a certain operation (Figure 9-62).

Figure 9-62. An overly-dense 
point group.

SA can sample an existing point group and create a new group of 
points at a lower spatial density than the source group (Figure 9-63). 
You can specify the desired number of points, and SA will choose a 
subset of points spread out to match that number.

The original points are untouched. Any subsampled points are a copy 
of the originals.
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Figure 9-63. A subset of the 
original point group.

To Create a Subset of Points with Greatest Spacing:

1. From the menu, select Construct>Points>From Existing 
Points>Subset with Greatest Spacing.

2. Specify the number of points to create.

3. Enter a name for the destination point group.

Converting Cloud Points to Points

You can convert cloud points gathered from a scan into normal con-
structed points. The newly-constructed points retain their existing 
offsets, but will appear as constructed points instead of measured 
points—they will not have any additional measurement metadata 
(which is why cloud points are so much more efficient in the first 
place).

Figure 9-64. Points con-
structed from cloud points.

To Convert Cloud Points Into Constructed Points:

1. From the menu, select Construct>Points>From Cloud Points>Pick 
Cloud Points.

2. Select the points to convert.

3. The Make Points from Clouds dialog will appear (Figure 9-65).

Note:  Creating more than 
about 20,000 constructed 

points will result in increasingly 
sluggish interaction with the soft-
ware. When dealing with very 
large datasets, use cloud points.

Note:  If the cloud is being 
thinned, only the thinned 

subset will be selected.
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Figure 9-65. The Make 
Points from Clouds dialog.

4. Specify the group name, an optional target prefix and start-
ing number, and an offset for the resulting points. If desired, 
select the Get a point every xxx option to subsample the cloud. 

5. Click OK. If subsampling, confirm the dialog.

Converting Clouds to Points

Similar to converting cloud points to points, you can convert an entire 
cloud to points. The procedure is almost identical to creating points 
from cloud points.

To Create Points from Clouds:

1. From the menu, select Construct>Points>From Cloud Points>Pick 
Clouds.

2. Select the points to convert.

3. The Make Points from Clouds dialog will appear (Figure 9-65).

4. Specify the group name, an optional target prefix and start-
ing number, and an offset for the resulting points. If desired, 
select the Get a point every xxx option to subsample the cloud. 

5. Click OK. If subsampling, confirm the dialog.

Filtering Clouds to Points

Given a set of clouds and a set of points, SA can filter the clouds to 
the points. You provide a desired proximity and maximum number 
of points, and choose the existing points to serve as filter points. SA 
will create a new point group containing a subsampled set of up to 
the prescribed number of points (within the proximity) for each filter 
point (Figure 9-66).

This command is useful, for instance, when you have a set of nominal 
points on a design surface that indicates where you’d like to measure, 
and you have a surface scan of the part. The command will filter the 
clouds to those points.
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To Filter Clouds to Reference Points:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Points.

2. Select the points to use as filter points.

Figure 9-66. Filtering a cloud 
to a set of reference points. 
Here, up to 5 points were cre-
ated for each reference point.

3. Pick one or more clouds to filter.

4. At the prompt, specify the resulting group name.

5. Enter a filter proximity—the maximum distance that a result-
ing cloud point can be from a filter point. Entering 0 will cre-
ate a point only at the closest cloud point.

6. Specify the maximum number of points to create for each fil-
ter point. Entering 0 will pick all points within the prescribed 
proximity.

Filtering Clouds to a Plane

You can filter one or more clouds to a plane. After specifying a prox-
imity to the plane, SA will create a point group or cloud containing 
all cloud points within the prescribed proximity to the plane (Figure 
9-67).

This is particularly useful for creating clean cross-sections from sur-
face scan data.

To Filter Clouds to a Plane:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Plane.

2. Select the desired filter plane.

Note:  You may wish to aver-
age the resulting points after 

this operation.
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3. Select one or more clouds to filter.

Figure 9-67. Filtering a cloud 
to a plane.

4. At the prompt, enter the desired destination group name (or 
cloud name, if you choose to create a cloud).

5. Specify a filter proximity, which indicates how close a cloud 
point must be to the plane to be used. If you enter 0, all source 
cloud points will be used.

6. The Filter Clouds to Plane dialog will appear (Figure 9-68):

Figure 9-68. Options for 
filtering clouds to a plane.

 ■ Offset Direction. Determines the location of the proximity re-
gion. Both accepts points up to the prescribed filter proximity 
on both sides of the plane. positive only only accepts points on 
the positive side of the plane, and negative only only accepts 
points on the negative side of the plane.

 ■ Output Type. Determines the format of the resulting points—
should they be points or Cloud points?

7. Select the desired options, then click OK.

Filtering Clouds to Vectors by Resolving Points

Given a set of clouds and a set of vectors, SA can filter the clouds to 
the vectors. You provide a desired threshold around each vector, a 
proximity to the vector’s base, and the minimum number of required 
points, and SA will—for each vector—extract the points that meet 
the specified thresholds and average them into a single point (Figure 
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9-69).

This command is useful, for instance, when you have a set of nominal 
vectors on a design surface that indicates where you’d like to mea-
sure, and you have a surface scan of the part. The command will filter 
the clouds to those vectors.

Figure 9-69. This cloud has 
been filtered to nominal vec-
tors.

To Filter Clouds to Vectors:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Vectors-Resolve Points.

2. Pick the clouds you’d like to filter.

3. Select the vector groups you’d like to filter to.

4. The Filter Clouds to Vectors dialog will be displayed (Figure 
9-70):

Figure 9-70. The Filter 
Clouds to Vectors dialog.

 ■ Output Group Name. The name for the resulting point group.

 ■ Minimum Proximity. The minimum allowable distance from a 
point to the vector to be considered.

 ■ Maximum Proximity. The maximum allowable distance from 
a point to the vector to be considered.

 ■ Max Distance from Vector Begin. The maximum distance 

Note:  Max distance from 
Vector Begin prevents ambi-

guity when there are two or more 
coaxial vectors.
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that a cloud point can be from the base of the vector to be 
considered.

 ■ Minimum Number of Required Points. The minimum num-
ber of points required for an averaged point to be created. If 
this minimum is not met, no averaged point is created.

5. Enter the desired options, then click OK.

Extracting Center Points From Scanned Spheres

Given a raster scanned point cloud, SA can extract the centers of 
registration spheres from the scan data. You provide the command 
with the expected sphere diameter, acceptable RMS tolerance, and 
minimum number of points required, and the command will detect 
spherical data matching the proposed diameter from the scan data, 
fit spheres to them, and create their center points (Figure 9-71).

Figure 9-71. Registration 
sphere centers have been 
automatically extracted from 
this scan.

To Auto-Detect Sphere Centers from Raster Scan Data:

1. From the menu, select Construct>Points>From Cloud Points>Auto-
Detect Sphere Centers.

2. The Sphere Extraction Settings dialog appears (Figure 9-72):
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Figure 9-72. Specifying 
sphere extraction parameters.

 ■ Desired Diameter. The nominal diameter of the registration 
spheres.

 ■ Tolerance. The maximum allowable deviation for a given point 
from the desired diameter in order to be considered.

 ■ Minimum Point Count. The minimum number of points re-
quired to satisfy the tolerance to consider a sphere to be 
“found”.

 ■ Group to Contain Sphere Centers. The name for the resulting 
group to contain the sphere centers.

 ■ Create Spheres in addition to points. When enabled, SA will 
create the spheres (at the desired diameter) in addition to the 
center points.

3. Select the desired options, then click OK.

4. After calculation, SA will display the Sphere Auto-Detection 
Results dialog (Figure 9-73). This contains the RMS error, maxi-
mum error, and point count for each detected sphere.

Figure 9-73. Sphere Auto-
detection results.
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5. Click OK to accept the results, or Cancel to cancel.

Auto-Corresponding Two Groups By Proximity

Given a group of reference points and a group of roughly-aligned cor-
responding points, this command will copy the corresponding group 
and automatically rename the copied points to match the names of 
the reference points.

To Auto-Correspond Two Groups by Proximity:

1. From the menu, select Construct>Points>Auto-Correspond 2 
Groups>Proximity.

2. When prompted, select the reference group of known point 
names.

3. Select the group to copy and rename. The Autocorrespond 
Points dialog will appear (Figure 9-74):

Figure 9-74. Setting param-
eters for an auto-correspond 
operation.

 ■ Auto-correspond “same point” tolerance. Each point must 
be within this proximity to a reference point, or it will not be 
renamed.

 ■ Group to contain matched points. The name for the copied 
group with the corrected point names.

4. SA will propose new names for your review. Click Accept to 
create a copy of the source point group and assign the appro-
priate point names.

Auto-Corresponding 2 Groups by Inter-Point Distance

Given a set of reference points and a group of source points, this com-
mand copies the source group and renames the points based on the 
reference point names. This command does not require the source 
and reference groups to be roughly aligned.

To Auto-Correspond Two Groups by Inter-Point Distance:

1. From the menu, select Construct>Points>Auto-Correspond 2 
Groups>Inter-Point Distance.

2. Select the reference group.

3. Select the group to be copied. The Autocorrespond Points 
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dialog will appear (Figure 9-74).

 ■ Auto-correspond “same point” tolerance. Once “aligned”, 
each point must be within this proximity to its reference point 
to be considered a match.

 ■ Group to contain matched points. The name for the copied 
group with the corrected point names.

4. SA will propose new names for your review. Click Accept to 
create a copy of the source point group and assign the appro-
priate point names.

Averaging Points

You can create a single averaged point from a set of points.

Figure 9-75. The average of 
5 selected points.

To Average a Set of Points:

1. From the menu, select Construct>Points>Fit to Points.

2. Select the points to average, then press Enter.

3. The Construct New Point dialog appears (Figure 9-22).

4. Specify the name for the resulting point—leave the calculat-
ed coordinates alone—then click OK.

Creating Points at the End of a Line

You can construct a point at either or both ends of a line by clicking 
near the desired end of the line.

To Construct a Point at the End of a Line:

1. From the menu, select Construct>Points>End of a Line.

2. The Point Name dialog will appear (Figure 9-76).

Figure 9-76. The Point 
Name dialog.

3. Specify the name for the first created point, then click OK.

4. Click near the end of a line to create the point. When finished 
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creating points, press Enter.

Constructing a Hidden Point

If you have measurements on a hidden point bar, you can construct 
the hidden point. An A and B point are used to define the vector of 
the hidden point bar, and the hidden point is constructed along this 
vector based on the prescribed distance from the A point to the hid-
den point.

To Construct a Hidden Point:

1. From the menu, select Construct>Points>Hidden Point Bar.

2. When prompted, select the A point.

3. Select the B point.

4. The Pick Hidden Point Bar dialog will appear. Select the ap-
propriate hidden point bar, then click OK.

5. The Construct New Point dialog will appear (Figure 9-22). 
Specify the point name, leaving the coordinates alone—then 
click OK.

Creating Points at a Plane Cross Section:

This command utilizes the database order of a given set of points to 
create a new set of points at a cross section of a plane. 

To Construct Points at a Plane Cross Section:

1. From the menu, select Construct>Points>Plane Section Crossing.

2. When prompted, select the Group of Points.

3. Select the Section Plane.

Constructing Points  Evenly Spaced on a Surface:

Given a surface, this command allows you to lay out a grid of evenly 
spaced points along both the U and V directions (Figure 9-77).

Note:  This command as-
sumes you’ve already de-

fined your hidden point bar in SA. 
For details, see “Measurement”.
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Figure 9-77. Points laid out 
in ten divisons along U and V.

To Construct a Grid of Points Evenly Spaced on a Surface:

1. From the menu, select Construct>Points>Mesh Surfaces in UV.

2. When prompted, select the appropriate surface(s), then press 
Enter.

3. The Make Points From Surface dialog will appear (Figure 9-78).

Figure 9-78. The Make 
Points From Surface dialog.

4. Specify a prefix for the resulting point group.

5. If you would like each row to be in a separate group, check the 
Make each line a separate group option.

6. Specify the number of divisions along the U and V directions, 
then click OK.

Constructing Points From Vectors

This command will create a point at the origin of each selected vector 
(Figure 9-79).

Note:  The resulting point 
group name will be the pre-

fix specified + “Surface Name” + 
index.
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Figure 9-79. A point is con-
structed at the origin of each 
vector.

 To Construct Points from Vectors:

1. From the menu, select Construct>Points>From Vectors.

2. When prompted, select the appropriate vector(s), then press 
Enter.

3. The Input dialog will appear (Figure 9-80).

Figure 9-80. The Input 
dialog.

4. Specify a name for the point group containing the resulting 
points, then click OK.

Constructing a Single Point through Patch Normal Shift

This command allows you to project a single point to a defined set of 
patch points. A theoretical plane is created from the patch points and 
and the end result is a constructed point at a specified offset along its 
probing direction (Figure 9-81).
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Figure 9-81. A point con-
structed from a selected point 
and shifted 0.75” along the 
probing direction of the theo-
retical patch point plane. 

To Construct a Point by Shifting along Normal:

1. From the menu, select Construct>Points>Patch Normal Shift>Single 
Point or press Ctrl + M.

2. When prompted, select the point, then select the patch points 
you wish to use. Press Enter.

3. The Add Shifted Point dialog will appear (Figure 9-82).

Figure 9-82. The Add Shifted 
Point dialog.

4. Specify the point group and point name of the resulting point, 
as well as the target and additional offsets (if applicable). 

5.  Click OK.

Note:  The target offset of 
the selected initial point will 

populate in the dialog by default.
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Point Groups
When points are created (constructed or measured), they are placed 
into point groups, often referred to just as groups. Point groups act as 
“containers” to hold points, and are best used to organize measured 
data in a logical manner.

Figure 10-1. Point groups as 
they appear in the tree.

point Group Category

“drift 0” point Group

targets

Other point Groups

Point groups are listed under the Point Groups category in the treebar 
(see Figure 10-1). Each individual point group can be expanded to 
reveal the contained points by clicking the disclosure triangle next to 
the point group name. Click the triangle again to collapse the list of 
points.

Anything that has both a position and orientation in 
space—with the exception of instruments—is consid-
ered an object in SA. In this chapter, we’ll discuss how 
to work with objects, and what you can do with them.

Objects



330

SPATIALANALYZER USER MANUAL

A point group is an object, whereas an individual point is not. As such, 
the point group can be moved, scaled, rotated, mirrored, etc. When 
a point group is manipulated in this manner, all of the points inside 
the group are treated as a rigid body. For example, if a point group is 
scaled by a factor of 2, the space between the points inside the group 
will be doubled. In Figure 10-2, a point group has been copied, then 
translated up in the Z direction by 10 units.

Figure 10-2. A point group 
has been copied and translat-
ed in the positive Z direction.

Original Group

Copy

If a point group contains targets, and the point group is moved, then 
the targets will temporarily convert to constructed points.  You can 
revert these constructed points back to targets (and their original lo-
cations relative to the instrument) by using the Analysis>Re-Compute 
Targets From Shots command.

Points will also inherit some of the properties of their containing 
group. For example, an object color can be assigned to the point 
group, and all points will inherit the color of their containing group. 
If a point group is hidden, then all of the points inside the group are 
hidden as well.

Frames
SpatialAnalyzer allows you to create a virtually unlimited number of 
coordinate frames (referred to as frames in SA), each representing a 
different aspect of your job that is important to you.

Figure 10-3. This collection 
has two coordinate frames, 
World and Local. The Local 
frame is active (working).

While there can be many coordinate frames in a given SA job, only 
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one can be designated as the working frame. When a coordinate frame 
is designated as the working frame, it will be drawn in a bold blue 
font in the tree (see Figure 10-3 on page 330), and the Color/WCF 
Toolbar will display the name of the frame (right).

Figure 10-4. The Color/WCF 
Toolbar.

All coordinates, query results, and other values are always displayed 
relative to the active coordinate frame (Figure 10-4), unless explicitly 
specified otherwise. For example, when you view the coordinates of a 
point, you are seeing the coordinates relative to the active coordinate 
frame.

active Frameinactive Frames

 To Activate a Coordinate Frame:

Do one of the following:

 ■ Right-click a frame in the graphical view or SA tree and select 
Make Working Frame.

 ■ Click the WCF button on the Color/WCF toolbar and choose a 
new working frame from the Object Selection dialog.

 ■ Right-click a frame in the tree and select Properties. Then click 
the Make Working button.

 ■ From the menus, choose Edit>Pick Working Frame and select the 
frame to activate.

 ■ Press Alt+W (default hotkey) and choose the desired frame 
from the Object Selection dialog.
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Frame Properties

Frames, like virtually all entities in SA, have properties associated with 
them.

To View a Coordinate Frame’s Properties:

Do one of the following:

 ■ Right-click the frame in the SA tree or graphical view and 
choose Properties.

 ■ Double-click a frame in the SA tree.

 ■ Click the Object Properties icon in the Main Toolbar, then dou-
ble-click a frame in the graphical view.

 ■

Figure 10-5. The Frame 
properties dialog.

Collection. Indicates the collection in which the frame resides.

 ■ Name. The name for the coordinate frame.

 ■ Notes. The notes field allows you to add text-based notes to a 
coordinate frame, which you can reference at a later time.

 ■ Frame Axes. By clicking on the X, Y, or Z buttons, you can view 
the projected angle of the selected coordinate axis, presented 
relative to the working coordinate frame (Figure 10-6).

 ■

Figure 10-6. A frame’s prin-
ciple projected angles.

Custom Size. Enable this option to assign a custom size to the 
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coordinate frame, and enter the size in the resulting text field.

 ■ Make Working. Sets the coordinate frame active so that it be-
comes the working coordinate frame.

 ■ Transform. Opens the transformation dialog to adjust the po-
sition and orientation of the frame.

 ■ Color. Opens the color dialog so that you can assign a new col-
or to the coordinate frame.

 ■ Update. Updates SA with any changes in the object properties 
without actually closing the Frame dialog.  Note that closing 
the dialog also applies changes to SA.

 ■ Menu. Exposes object-specific menu options. This is equiva-
lent to right-clicking the object in the tree.

 ■ Close. Closes the properties dialog.

Frame Construction

SpatialAnalyzer  offers many methods for constructing Frames. To 
fully understand frame construction it is important to understand 
the components needed to construct a frame. A frame has four basic 
components: an origin point, primary axis, secondary axis and tertia-
ry axis. A frame can usually be constructed by defining an origin point 
and two of the axes.

During frame construction many commands will prompt the user to 
define the primary, secondary and tertiary axis. An axis can be de-
scribed by a point or a vector (object direction). When using a point 
to describe an axis, a vector is formed from the origin point and the 
selected point. If an object is selected its normal will be used to define 
the axis. The following examples show several combinations of points 
and vectors.

Enter
Creates a frame at the origin and orientation of the active frame. The 
transform dialog will appear allowing the user to enter the position 
and orientation values.

Plane, Line, Point (3-2-1)
A 3-2-1 frame consists of a locator point for the origin, line/vector for 
one axis and plane for the second axis (see Figure 10-7 on page 334). 
The Plane, Line, Point Transformation dialog allows control over the 
axis for the plane and line/vector. The user may also specify an alter-
nate coordinate for the locator point.

Note:  The assigned color of 
the frame is only shown 

when it is not the working frame.
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Figure 10-7. The Plane, Line, 
Point Transformation dialog.

Figure 10-8. Points used 
to define a 3-2-1 frame (left) 
and the resulting constructed 
frame (right).

point in xY plane

point defining x axis

Origin

Plane, Line, Line (Sheet Metal Corner)
Uses a plane and two lines to define a frame. A user can select the axis 
for each object selected.

Using Points and Vectors
Example using only three points. Construct>Frame>3 points>Origin, X-
axis>Point on XY plane

3 Points
Uses three point to describe the origin, primary axis and secondary 
axis.

Z-Axis
Constructs a frame with the Z-axis normal to a plane, circle or a line 
and uses the selected points for origin and X-axis.

On Instrument
This will construct a frame on the instrument base with the Z-axis be-
ing the standing axis. A frame can also be made on the “scope or end 
effector”. This will generate a frame using the probing direction as the 
vector for the Z-axis.
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Using Working Frame Orientation
Uses the current active frame orientation to define a new frame. A 
copy can be made by defining a new origin point or maintain the Z-
axis and clock the remaining axis.

3 Planes
Uses three planes to create a coordinate system. User selects X, Y and 
Z planes. The user interface allows control over priority and direction.

Mirror Cube
Often, users wish to construct a coordinate frame based on the faces 
of a mirror cube (see Figure 10-9). The Mirror Cube frame assignment 
method provides a convenient method for repeatedly and accurately 
locating a coordinate frame with two instruments (typically theodo-
lites). SpatialAnalyzer contains a powerful mirror cube frame assign-
ment tool.

Figure 10-9. The Mirror Cube 
Coordinate Frame dialog.

To accomplish a mirror cube frame assignment, point two theodolites 
at the mirror cube and collimate the instruments with the mirror fac-
es. Record a shot from each theodolite at the cube using the same 
target name, just as if you were shooting the mirror as a target. If you 
desire reversed shots, reverse the scope and take another shot, or 
take multiple shots in each face. In SpatialAnalyzer, select Construct, 
Frame, and Mirror Cube. You will be prompted to select the target for 
the mirror. Pick the common target name you used for the measure-



336

SPATIALANALYZER USER MANUAL

ments. The mirror cube frame assignment dialog will appear. At this 
point, you may press the Create Frame button to make the coordinate 
frame, or you may change the options.

Possible Options:

 ■ You may select which instrument represents the X-axis of the 
coordinate frame.

 ■ You may select or deselect specific shots from each instrument. 
When there are multiple shots, their vector directions are aver-
aged to calculate the vector displayed below the measurement 
box.

 ■ The check box for coordinate axes determines whether the 
axes of the frame are outward along the theodolite vectors or 
inward toward the theodolites.

 ■ The Axis weighting box allows you to control the distribution 
of the errors between the two axes.

 ■ Set the Cube face angle (normally 90 degrees). Press Compute 
after doing this to update!

 ■ The difference between the cube “ideal” angle and the theodo-
lite vector angle will be displayed.

 ■ Use the slider bar to control how far the frame axes are away 
from the theodolite axes. Sliding the bar to the left places more 
of the error on the “right-side” instrument.

 ■ Choose carefully when distributing the error. In some cases, it 
may be better to have no error on one axis since it is difficult to 
tell if the “error” is coming from the theodolite measurements 
or the mirror cube itself.

On Object
Constructs a frame with the Z-axis normal to the selected object.

Fit to Coordinate Components
In this method of frame assignment, we assume that we have several 
points which share a known X coordinate, several points which share 
a Y coordinate, and several points which share a known Z coordinate. 
This is often used in a factory setting where a designer has established 
a reference block with one face representing a certain XY, one plane 
representing a certain XZ plane, and one face representing a certain 
YZ plane. Initially the user will be prompted for the points of known X 
value, then Y and Z in turn. After selection of the points is completed, 
the user will see the dialog shown below. Enter the known values and 
hit OK. The frame assignment will be made.

Average of Other Frames
Creates a frame based on the average of selected frames. Usually used 
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to create an average between gravity frames.

Copy and Make Left-Handed
Makes a copy of the selected frame and prompts for the axis to re-
verse.

Spheres

Fit to Points

Constructs a best-fit sphere for the selected points. See the Geometry 
Fit section for more information.

Enter

Constructs a sphere at a position and orientation relative to the work-
ing frame. Use the Sphere Properties dialog to edit parameters.

Sphere Section

Creates a spherical section. Use the Sphere Section dialog to edit pa-
rameters.

Figure 10-10. Creating a 
spherical section.

B-Splines

Properties

The B-Spline properties will report the Curve Parameters and allow 
directional arrows to be drawn.
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Figure 10-11. The B-Spline 
curve properties dialog.

Construction

From Points

Figure 10-12. A B-Spline fit 
to a series of measured points.

Creates a B-Spline curve from selected points using either an interpo-
lated fit or cubic fit (see Figure 10-12 and Figure 10-13).

 ■

Figure 10-13. B-Spline Fit 
options.

Fit Style. A B-Spline can be fit one of two ways, Interpolation or 
Fit with control points. An interpolated fit will pass through all of 
the selected points and interpolate the curve’s shape between 
each point. Fitting with control points allows for a best fit.
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 ■ Curve Style. If closed the B-spline will end at the beginning 
point of the B-spline.

 ■ Point Ordering. The direction and path of the B-spline is deter-
mined by the order of the points. The user can select the points 
in order or use the closest neighbor approach. Points can also 
be ignored if their neighbor is within a prescribed distance.

 ■ Termination Conditions. The B-Spline creation will terminate 
if a gap of a prescribed distance is exceeded.

From Surface
Creates B-Splines from surface boundaries (Figure 10-14).

Figure 10-14. Creating B-
Splines from the boundaries of 
a surface.

Intersect Surface
Creates a B-Spline from the intersection of two surfaces (Figure 10-
15).

Figure 10-15. This B-Spline 
has been created by inter-
secting cylindrical and planar 
surfaces.



340

SPATIALANALYZER USER MANUAL

 Intersect Plane and Surface
Creates a B-Spline at the intersection of a plane and surface. Very sim-
ilar to the Intersect Surface command.

From a Collection of B-Splines
Creates one single B-Spline from the selected individual B-Splines.

Circles

Properties

 ■

Figure 10-16. The properties 
dialog for a circle.

Collection. Specifies collection name where object resides.

 ■ Name. Object name

 ■ Radius. Radius of circle

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angles represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.

 ■ Radial Normal Direction. Reverses the normal radial vector 
direction of the circle.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Reverse. Reverses the normal direction of the object.

 ■ Transform. Opens the transformation dialog.
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 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit circle for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs a circle where the normal is in the Z-axis of the working 
frame. Use the Circle Properties dialog to edit parameters.

Maximum Material Condition (from Scan 
Patch)

Creates a best-fit circle with a diameter that bounds all of the selected 
points. All of the points will either be touching the circle or inside of 
the circle.

From CAD Surfaces
Uses selected CAD surfaces to look for circular segments and creates 
circles based on the search criteria.

Figure 10-17. Creating 
circles from surface holes.

 Normal to Object, Centered at Point
Creates a circle using the selected object’s normal and is centered at 
the selected point.
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Planes

Construction

Fit to Points
Constructs a best-fit plane for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs a plane where the normal is in the Z-axis of the working 
frame. Use the Plane Properties dialog to edit parameters.

Normal to Object, Through Point
Plane created normal to a selected object and passes through a se-
lected point.

Normal to Line, Through End
A plane is created that is normal to the line and passes through a se-
lected end of line.

Mirror from Two Measured Points
The mirror plane function is used to determine the location of a mir-
ror by measuring a point both directly and through the mirror.

1. Pick the instrument.

2. Pick the point measured directly (not through mirror).

3. Pick the virtual point that is really the same point, but mea-
sured through the mirror.

SA creates a plane representing the mirror location (see Figure 10-18 
on page 343). You can make a frame on this plane if needed.
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Figure 10-18. Creating a 
plane from two measured 
points using a mirror.

If the points used in the construction have uncertainty fields 
(Analysis>Coordinate Uncertainty>Create Point Uncertainty Fields), SA will au-
tomatically compute the uncertainty of the mirror plane and add the 
results to the notes field for the constructed plane.

Establish Bounding Planes for Points
Creates two planes parallel to the selected plane and are spaced so 
that they bound the selected points.  

From Surface Faces
Creates planes from the selected surface faces.

Lines

Properties

 ■  Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ End-Point Method. Enter two point coordinates to determine 
length, position and orientation of the line.

 ■ Ray Method. Control the length or the transformation of the 
line.

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angles represent the projection of the object normal 
vector onto the coordinates planes of the active frame.
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 ■ Draw. Displays the normal vector in the graphics.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Reverse. Reverses the normal direction of the object.

 ■ Shift Ends. Enter values to shift beginning and end point along 
the vector of the line.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit line for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
This will allow you to enter the end-points of the line or designate a 
direction and a length. These values are entered using the Line Prop-
erty dialog.

2 Points
Constructs a line between two selected points. The lines direction is 
from the first to second point.

Projection, Line to Plane / Circle
After selecting either a plane or a circle as the destination, you will 
be prompted to select the line you wish to project. A new line will be 
created on the projection surface.

Between a Point and a Line
This function creates a line between a user-selected point and a line.

2 Plane Intersection
A line is created at the intersection of two planes. If the planes are 
parallel, the function reports that the line can not be created.

Center of Cylinder
Constructs a line from the cylinder end points and inherits the cylin-
der’s direction.



345

CHAPTER 10 ■ OBJECTS

Along Frame Axes
Constructs a line down each axis of the working frame.

From Instrument Shot
Creates a line from a measured point and its associated instru-
ment.  The point selected must be a measured point.

Normal to Object(s)
Creates a line normal to an object. All objects (plane, line, cylinder, 
etc) have a normal direction. The line created will represent that nor-
mal direction.

Normal to Objects, through Point
Creates a line parallel to the selected object’s normal and intersects 
to selected point.

Parallel to Line, through Point
Creates a line parallel to the selected line and pass through the se-
lected point.

Cross Product
The cross product is a function that takes two lines (vectors) and pro-
duces a line that is perpendicular to them.

From a Vector Group
Creates lines from each vector in a vector group.

Cylinders

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Transformation Method. Controls the length or the transfor-
mation of the cylinder.

 ■ End-Point Method. Enter two point coordinates to determine 
length, position and orientation of cylinder.

 ■ Diameter. Diameter of the cylinder.

 ■ Surface Normals. Reverses the surface normal direction.

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angle represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.
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 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Reverse. Reverses the normal direction of the object.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object-specific menu options. Emulates right-
clicking the object in the SATreebar.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit cylinder for the selected points. See the Geom-
etry Best-Fit section for more information.

Enter
Constructs a cylinder where the normal is in the Z-axis of the working 
frame. Use the Cylinder Properties dialog to edit parameters.

Cylinder Slice

Figure 10-19. Creating a 
cylinder slice.
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Pie Wedge

Figure 10-20. Creating a pie 
wedge.

Pipe

Figure 10-21. Creating a 
pipe.
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Tapered Pipe

Figure 10-22. Creating a 
tapered pipe.

Ellipses

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Transform. Opens the transformation dialog.

 ■ Major Axis Radius/Minor Axis Radius. The major (long) and 
minor (short) axis lengths (Figure 10-23).

 ■

Figure 10-23. The major/
minor axes of an ellipse.

Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Update. Updates SA with any changes in the object properties.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

Construction

Fit to Points
Constructs a best-fit ellipse for the selected points. See the Geometry 
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Best-Fit section for more information.

Enter
Constructs an ellipse about the working frame. Use the Ellipse prop-
erties dialog to edit parameters.

Paraboloids

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Graphical Settings. Control the length, span and facets of the 
graphical representation of the cone.

 ■ Geometry Parameters. Control length and alternative param-
eters.

Construction

Fit to Points
Constructs a best-fit paraboloid for the selected points. See the Ge-
ometry Best-Fit section for more information. 

Enter
Constructs a Paraboloid about the working frame, use the Plane prop-
erties dialog to edit parameters.

Cones

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Graphical Settings. Control the length, span and facets of the 
graphical representation of the cone.

 ■ Included Angle. The entire angle that contains the taper.

 ■ Surface Normals. Reverses the surface normal direction.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Transform. Opens the transformation dialog.
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 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit cone for the selected points.  See the Geometry 
Best-Fit section for more information.

Enter
Constructs a cone about the working frame, use the Cone properties 
dialog to edit parameters.

Surfaces

Offset Surfaces

Currently under construction...however, this will allow a user to select 
a surface to offset and enter an offset.

From a Collection of Surfaces

Merges selected surface into one surface entity.

By Dissecting Surfaces

Dissects the surface into individual surfaces. The user has the option 
to dissect any surface or pick surface faces to dissect.

Select Faces by Projecting Points

Creates separate surfaces by checking point projections. This can be 
useful for speeding analysis when trying to reduce surface faces to 
analyze.
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Figure 10-24. Creating sur-
faces by projecting points.

From Objects

Creates surfaces from supported SA Geometry. Examples are plane, 
cylinders, etc...

From Plane, Cylinder, Sphere, and Cone

Performs same functionality as above, these are just geometry spe-
cific. The above command is more universal.

Tubular Surface from a B-Spline

Creates a tubular surface that uses the B-Spline path. Users has the 
ability to enter Tubular Diameter.

From Point Groups

Functionality only available in SA Ultimate. Please see the Advanced 
Surface Fitting section.

From B-Splines

Functionality only available in SA Ultimate. Please see the Advanced 
Surface Fitting section.

From Plane and Closed B-Spline

Functionality only available in SA Ultimate. Please see the Advanced 
Surface Fitting section.

Fit from Bounding Curves and Internal Points

Functionality only available in SA Ultimate. Please see the Advanced 
Surface Fitting section.
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Fit from Nominal Face and Actual Data

Functionality only available in SA Ultimate. Please see the Advanced 
Surface Fitting section.

Polygonized Meshes

From Surfaces

Converts selected surface to a Polygonized Mesh.

From Cloud Points and from Selected Cloud Points

Generates a Polygonized Mesh from selected point clouds or points. 
By default the mesh orientation uses the current Point of View, how-
ever, the working frame can be used as well (Figure 10-25). Enter the 
grid resolution based on point cloud density. Rule of thumb, the data 
density should be four times greater than the grid resolution.

Figure 10-25. Polygonized 
mesh generation settings.
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Figure 10-26. Generating 
a polygonized mesh from a 
point cloud.

 Colorized Mesh from Point Proximity

Creates a Colorized Polygonized Mesh depicting the error between 
the selected points and the selected surface (Figure 10-27). The col-
orization options can be accessed through the Polygonized Surface 
properties.

Figure 10-27. A colorized 
graphical mesh created using 
proximity of measured points 
to a nominal surface.
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Perimeters

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Closed Perimeter. When unchecked the perimeter is opened.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Apply. Updates SA with any changes in the object properties.

 ■ Cancel. Closes dialog without saving changes.

Construction

This command will create an open or closed perimeter object from 
selected points. Its purpose is to provided a boundary for scanning 
instruments. The below example shows perimeters to capture data 
from a targetless scanner.

Figure 10-28. Perimeters 
defining the boundary of mea-
surements from a total station.
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Point Clouds
Point Clouds are unique because unlike Point Groups they do not 
give access to individual point coordinates. All cloud points are treat-
ed as a rigid body.  Point Clouds are often used for large amounts of 
data, such as data measured with a laser scanner. Point clouds require 
less memory to store than a point group. By default the display op-
tions for a point cloud are automatically set to maintain an optimal 
graphical performance. As a Point Cloud is rotated or translated in 
the graphic view, the display resolution of the cloud will reduce auto-
matically and will be restored once the movement is stopped.

From Existing Clouds

Creates a new point cloud based on selected point clouds.

From Existing Cloud Points

Creates a new point cloud based on the selection of individual cloud 
points.

Random Data

Used to generate random point cloud data.

From Existing Point Group

Converts a point group into a point cloud.

Auto Filter to Faces

Creates new point cloud based on proximity to surfaces.

Figure 10-29. A cloud cre-
ated based on proximity to a 
surface face.
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Filter settings allow for offset boundaries to be created. Thinning op-
tions are also provided to reduce data density.
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SA supports over 100 different measurement devices, from PCMM 
arms and laser trackers to scanners, laser radars, digital levels, and 
theodolites. An instrument in SA contains the basic properties of the 
instrument and defines its location in the workspace. Instruments 
appear in the treebar under the Instruments category, and each in-
strument is assigned a number (starting from zero), referred to as the 
Instrument Index Number. This number appears next to the name of the 
instrument in the treebar (Figure 11-1).

Figure 11-1. Instruments in 
the tree.

It is very important to keep in mind that instruments are not objects. In 
SA, objects are treated differently than instruments. Commands and 
functions that explicitly ask for objects will not accept an instrument. 
They are completely independent entities.

Instruments are the devices that gather accurate mea-
surement data and provide a foundation for this data’s 
position in a digital world. This chapter discusses how 
to work with instruments in general.

Instruments
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Figure 11-2. A number of 
instruments in the graphical 
view.

For spherical measurement devices (total stations, laser trackers, and 
the laser radar, for example), the position of the instrument defines 
the origin of the instrument’s measurement volume. For a PCMM arm, 
the instrument position defines the base of the kinematic chain of 
linkages leading toward the probe.

When a point is measured by an instrument, the instrument reports 
back a point in its own internal coordinate system. This point is re-
corded in the measured target’s observation details. For spherical 
measurement devices, the coordinate is represented in a spherical 
coordinate system. For a Cartesian measurement device (such as an 
arm), the coordinates are represented in XYZ coordinates.

Instrument Properties
To Access an Instrument’s Properties:

 ■ Right-click the instrument in the tree or graphical view and 
choose Properties from the context menu,

 ■ Double-click the instrument in the tree, or

 ■ Select Instrument>Properties, and double-click the instrument of 
interest.

The properties for an instrument (Figure 11-3) will vary depending on 
the class of instrument (laser tracker vs. arm vs. scanner, etc.).
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 ■

Figure 11-3. The Instrument 
Properties dialog.

Instrument Number. The index number for the instrument 
(referred to as the Instrument Index Number).

 ■ Model. The name assigned to the instrument. (By default, this 
will be the manufacturer’s name and instrument type).

 ■ TCP/IP Socket Port. The TCP/IP port that the instrument has 
been assigned. This is a random port number that is assigned 
by SA.

Sensor Control

The sensor control section allows you to adjust the graphic model 
of the instrument. For spherical devices, you can adjust the vertical, 
horizontal, and distance degrees of freedom. For an arm, you can ad-
just the rotation value for each link. Other instrument types (such as 
laser scanners) may not have any adjustment at all. After selecting the 
degree of freedom and associated value, click the Apply button to see 
the changes. Or, click the up/down arrows to increment the rotation 
value.

Scale Factor

It may be desirable to apply a scale to an instrument’s measurements 
to account for thermal expansion and contraction of a measured part. 
For example, suppose you have a nominal model that has been de-
signed for 68°F (20°C) conditions. If you are laying off nominal fea-
tures from that model on a hot day--say 95°F (35°C)--then you will 
want to scale the instrument’s measurements down from 95°F to 68°F 
so that the instrument and the nominal model are adjusted to the 
same temperature reference. One way to achieve this is to scale the 
instrument’s measurements.

Warning:  Scaling an in-
strument’s measure-
ments requires caution. 

Once an instrument’s measure-
ments have been scaled, query-
ing one measured point to an-
other will not represent the true 
measured real-world distance 
between the two points.
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When an instrument scale factor is applied, all measurements from 
the instrument will be scaled appropriately. For example, an instru-
ment observation that is normally at a radius of 100” from the instru-
ment will be 101” from the instrument at a scale factor of 1.01. Instru-
ments that are currently using a scale factor other than 1.0 will appear 
with a special yellow icon in the tree and will be listed as a scaled 
instrument, as depicted in Figure 11-4.

Figure 11-4. This laser tracker 
has a scale applied.

The scale for an instrument can be set in several different ways. It can 
be set manually (by directly entering a scale factor), set by measuring 
scale bars, or set in a command (such as Instrument>Locate (Transform to 
Part)>Measure Nominal  Points),  which allows you to vary the instrument’s 
scale as part of the best-fit procedure.

To Set an Instrument’s Scale Factor Manually:

1. In the Instrument Properties dialog, click the Set Manually but-
ton.

2. 

Figure 11-5. The scaling 
dialog.

In the Scaling dialog (Figure 11-5), select the enter Scale Man-
ually radio button and enter a scale factor, then click OK.

To Calculate a Scale Based on a Coefficient of Thermal Expansion:

Consider an example of measuring a steel part sitting in the sun, 
which has expanded in the 95°F midday heat. If we want to compare 
measurements against the nominal model for this part, which is at 
68°F, then it is important to scale the instrument’s measurements 
from 95°F (initial temperature) to 68°F (final temperature). This would 
be a situation where entering a scale for the instrument based on a 
CTE could be appropriate. The resulting scale factor will shrink the 
instrument’s measurements so that the measurements can be com-
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pared to the 68°F CAD model, effectively removing the differences 
caused by thermal expansion.

1. In the Instrument Properties dialog, click the Set Manually but-
ton.

2. Select the Calculate Scale Based on Cte radio button.

3. In the dropdown, choose the desired material for the part 
that will be measured. If the material of interest is not avail-
able, click the Edit button, which allows you to add, delete, 
and edit materials and their associated coefficients of thermal 
expansion.

4. Enter an initial and final temperature. A higher final tempera-
ture will result in a scale increase, and a lower final tempera-
ture will result in a scale decrease.

To Calculate a Scale Based on Measured Scale Bars:

Scaling based on measured scale bars should only be performed 
when the material of the scale bar matches the material of the part to 
be measured, and when the nominal scale bar temperature matches 
the nominal (modeled) CAD temperature of the part. Consider an ex-
ample of measuring a steel part sitting in the sun, which has expand-
ed in the 95°F midday heat. If a steel scale bar with a nominal length 
of 36” at 68°F is then measured in the same conditions as the part, it 
will also have expanded, and the measured scale bar points will be 
more than 36” apart. Scaling based on this measured scale bar will 
scale the instrument’s measurements down to match the nominal 
(68°F) length of 36”. Subsequent measurements from the instrument 
will now be properly compensated to the nominal 68°F temperature.

1. In the Instrument Properties dialog, click the Set from Scale 
Bars button.

2. If the instrument has measured points that belong to a de-
fined scale bar, the scale factor will be instantly calculated.

3. Review the results of the scale calculation, and click Yes to ap-
ply the scale factor to the instrument.

 ■  Measurements Active. Unchecking this box will deactivate 
all of this instrument’s measurements from target calculations. 
This might be useful, for example, if you’ve measured the same 
point with several instruments, and have found an instrument 
to be out of calibration to the point where its measurements 
are corrupting the overall coordinates of the targets. Re-check 
this box to activate the measurements again. (Note that this will 
require you to recompute targets from shots using Analysis>Re-
Compute Targets From Shots).

Note:  If the scale bar points 
have not been measured by 

the instrument in question, then 
no scale will be applied.
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Uncertainty Variables

All instruments have error in their measurements, and as a result ev-
ery measurement from an instrument has some uncertainty. Each 
class of instrument (laser tracker, PCMM arm, total station, etc.) has 
different set of uncertainty characteristics. For example, laser trackers 
have uncertainties for the horizontal and vertical encoders, as well 
as an uncertainty for the distance measurement. PCMM arms, on the 
other hand, have an angular uncertainty for each link of the arm. Ad-
ditionally, each instrument within a specific instrument class has dif-
ferent values for the uncertainties. The uncertainty values for a newly 
calibrated laser tracker in pristine condition from a manufacturer will 
be different from those of an old, dirty, poorly calibrated tracker from 
the same manufacturer.

The uncertainty variables assigned to an instrument determine what 
the resulting uncertainties of the individual measurements from that 
instrument will be. Points measured from an instrument with small 
uncertainty values will have less uncertainty than those measured 
from an instrument with large uncertainty values.

The default uncertainty values that SA applies to a given instrument 
are identical for a given class of instrument. Due to variations in instru-
ment calibration and performance, manufacturer, and measurement 
parameters, it is impossible to use a specific set of numbers for each 
instrument--the numbers can vary significantly. Instead, a set of con-
servative default values have been chosen (see Figure 11-6 on page 
363). These values, while usable, will not be truly representative of 
the instrument’s true uncertainty variables, so there is a procedure to 
determine an instrument’s values. An instrument’s true uncertainty 
variables are determined through a process using USMN. Once these 
values have been determined for a given instrument and measure-
ment situation, they can be plugged into the instrument to get truly 
accurate uncertainties for a given instrument’s measurements.

Note that all instrument uncertainty values are entered as 1 sigma 
values, regardless of the confidence interval set for the job in the User 
Options. Clicking the Edit Uncertainty Variables button will present 
you with a dialog in which you can enter specific values that apply to 
the selected instrument. The values in Figure 11-6 apply to spherical 
measurement devices such as laser trackers, total stations, and laser 
radars.
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Figure 11-6. Generic uncer-
tainty variables for a spherical 
measurement device (laser 
trackers shown here).

 ■ Theta or Horizontal Angle. The angular uncertainty for a 
spherical measurement device’s horizontal encoder, in arcsec-
onds.

 ■ Phi or Vertical Angle. The angular uncertainty for a spherical 
measurement device’s vertical encoder, in arcseconds.

 ■ Error (in job distance units). The fixed component of uncer-
tainty for a spherical measurement device’s distance measure-
ment. The instrument above has been assigned a static uncer-
tainty of 0.0003” in distance measurement.

 ■ Parts per million. Additional uncertainty (on top of the fixed 
component described above) for a spherical measurement 
device’s distance measurement that increases linearly as the 
measured distance increases. This value is entered in parts per 
million (ppm). The instrument above has been assigned a PPM 
uncertainty of 2.5 ppm. This implies that, at a measurement 
distance of 1000”, the uncertainty contributed by the PPM 
component will be 0.0025”.

The PPM and static uncertainties combine to determine the total 
distance uncertainty at a given point. At a measurement distance of 
1000”, the measurement has a total distance uncertainty of 0.0028” 
(0.0003” + 0.0025”).

For portable CMM arms—as depicted in Figure 11-7—the uncertain-
ty is entered at each link in the arm, in degrees.

Figure 11-7. Uncertainty val-
ues associated with a portable 
CMM arm.
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The theodolite uncertainty dialog is similar to that for other spherical 
measurement devices, however the distance uncertainty values do 
not apply (Figure 11-8).

Figure 11-8. Theodolite 
uncertainty values (obviously) 
have no distance component.

 Instrument Graphics (PCMM arms only)

PCMM arms have an Instrument Graphics button that appears directly 
under the Edit Uncertainty Variables button. This button calls up the 
Instrument Graphics dialog (Figure 11-9).

 ■  

Figure 11-9. The Instrument 
Graphics dialog for portable 
arms.

Restore Default Graphical Model. The kinematics for a PCMM 
arm are refined as points are measured. These kinematics only 
affect how the arm is depicted in the graphical view--not the 
accuracy of the measurement data itself. Clicking this button 
will restore the default graphical model that has been stored 
with the instrument definition.

 ■ Solve for Graphical Model Using All Measurements in Job. 
This option will consider the measurements that the arm has 
observed, and recalculate the kinematics for the arm.

 ■  Instrument Interface Response Timeout. This value deter-
mines (in seconds) how long an instrument interface will at-
tempt to connect to the instrument until it times out with an 
error, stating that the instrument cannot be found. Enter zero 

Note:  The Instrument 
Graphics options only affect 

how the PCMM arm is depicted in 
the graphical view. They have no 
effect on measured data.
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to continue checking indefinitely.

 ■ Transform. The Transform button is used to transform (move 
and rotate) the instrument. More information about transfor-
mation can be found in the Move section.

IP-Based Instruments

IP Address Basics

An IP address is an identifier for a computer or device on a TCP/IP net-
work. Networks using the TCP/IP protocol route messages based on 
the IP address of the destination. The format of an IP address (at least 
for the original, IPv4 version) is a 32-bit numeric address written as 
four numbers separated by periods. Each number can be zero to 255. 
For example, 1.160.10.240 could be an IP address. Within an isolated 
network, you can assign IP addresses at random as long as each one 
is unique.

The four sets of numbers can be thought of as a mailing ad-
dress.  State, City, Street and House number. Anyone can live in the 
same State and City and reside on the same street, however there 
can’t be duplicate house numbers. So if an instrument has an IP ad-
dress of 128.128.128.100, the computer must have a different “house 
number”, such as 128.128.128.99.

Computer and Instrument Setup

 ■

Figure 11-10. A tracker con-
nected directly to a computer 
via an ethernet cable.

Host computer and instrument have unique IP addresses.

 ■ It is typically easier to place the host computer on the same IP 
family as the instrument.

 ■ As an example the instrument IP address is 192.168.0.168

 ■ The host computer would need a unique IP address on the 
same IP family.

 ■ Change the host computer to 192.168.0.100 for example.

 ■ To test the connection use the Ping function in the SA network 
browser (Figure 11-11).
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Figure 11-11. Pinging an 
instrument to check a network 
connection.

If multiple instruments exist on the network and they belong to the 
same family, no changes are needed. If they do not belong to the 
same family the host computer must be configured to have multiple 
IP addresses. See the section below regarding Multiple IP Setup.

Changing a Static IP Address

Windows XP
1. Navigate to the Control Panel via Start>Control Panel.

2. Select to browse current connections.

3. Select the connection of interest and right-click to select 
properties (Figure 11-12).

4. 

Figure 11-12. Selecting the 
connection properties.

Select Properties. Once inside of the Properties dialog choose
and select properties.
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5. Enter in the desired static IP address and subnet mask.

Figure 11-13. Specifying IP 
address settings.

Windows Vista/Windows 7
1. Navigate to the control panel via the Start Menu

2. Select View network status and tasks to view the 
current connection.

3. Select the connection of interest.

4. 

Figure 11-14. The Windows 
7 Network Connections dialog.

Select Properties. In the Properties dialog, choose
and click the Properties button.

5. Enter the desired static IP address and subnet mask. 

Figure 11-15. The Windows 
7 IP settings dialog.
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Multiple IP Setup (Dual IP)

Cases exist where the host computer and multiple instruments are 
unable to reside in the same IP family (subnet). In this case, the host 
computer can be configured to handle multiple IP addresses.

1. Follow the above directions to set a single static IP address.

2. Once the first static IP address is set, select the Advanced but-
ton at the bottom of the dialog.

3. Click the Add button and enter the additional IP addresses 
(Figure 11-16).

Figure 11-16. Assigning dual 
(or multiple) IP addresses to a 
single port.
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Surface Grouping
Any set of surfaces may be combined into a single surface or split into 
separate surfaces. The process of combining surface faces is referred 
to as merging surfaces, and the process of separating surfaces is re-
ferred to as dissecting surfaces.

The advantage of have a merged surface is that it simplifies the tree. 
When surfaces are merged, they appear as a single surface in the tree, 
therefore there are less surface entities to wade through when mov-
ing around in the tree. This also can make selection easier, because 
selecting a single surface selects all of the faces that are part of that 
merged surface.

However, merged surfaces have some limitations. A merged surface 
cannnot have its normals corrected—so, if you need to reverse some 
surface faces, the surface must be dissected first. Also, you cannot 
create queries, relationships or other entities involving specific sub-
faces of a merged surface. If you want a relationship, for instance, to 
only compare against a single face of a surface, that face must be ex-
tracted from the merged surface so that it appears as a separate en-
tity in the tree.

One cannot definitively say whether a merged surface is better than a 

Working with CAD surfaces is a discipline in itself. As 
more and more industries move toward computer 
model-based representations and away from paper 
drawings, the ability to work with surfaces grows every 
year.

Working With 
Surfaces
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dissected surface, or vice versa. It really depends on the situation and 
what you’d like to do with the surfaces.

Merging Surfaces

The process of merging a surface involves selecting individual surfac-
es and combining them into a single surface in the tree that is treated 
as a single surface. When merging surfaces, you have the option of 
keeping the original surfaces in addition to the new merged surface, 
or deleting the original surfaces. In addition, you also have the option 
of hiding the original source surfaces as well.

To Merge Surfaces:

1. From the menu, select Construct>Surfaces>From a Collection of Sur-
faces.

2. Select all of the surfaces that you’d like to merge.

3. The Group Surfaces dialog appears (see Figure 12-1).

4. Select the desired options, then click OK. A new surface named 
Merged Surface xxx will be created.

Figure 12-1. Merging a set of 
surfaces.

 ■ Hide Original Surfaces. When selected, the original source 
surface faces will be hidden, but not deleted.

 ■ Delete Original Surfaces. When selected, the original source 
surface faces will be deleted.

 ■ Sew Faces Together. When selected, adjacent surface faces 
which lack tangency (they do not smoothly flow from one sur-
face face to another) will be stitched together in accordance 
with the sewing tolerance.

 ■ Sewing Tolerance. The maximum normal deviation from one 
surface face to the next in which those adjacent surface faces 
will be stitched together if Sew Faces together is enabled.

Dissecting Surfaces

Dissecting surfaces is the inverse operation of merging. Given a 
merged surface containing two or more surface faces, dissecting that 
surface will extract the selected faces and separate them as unique 
surfaces in the tree. Dissecting a surface leaves the original surface 

Warning:  Since sewing 
faces together can 
change the topology of a 

CAD model (usually undesirable 
in metrology), it is strongly rec-
ommended that you avoid this 
option unless you have a very 
valid reason for using it.
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intact—it will be hidden for you in the tree.

To Dissect an Entire Surface:

1. From the menu, select Construct>Surfaces>By Dissecting 
Surfaces>Entire Surface.

2. Select the surface to dissect.

To Dissect Specific Surface Faces from a Surface:

1. From the menu, select Construct>Surfaces>By Dissecting 
Surfaces>Select Faces.

2. Select the individual faces to extract. The original surface will 
remain untouched, and the extracted faces will be created as 
separate surfaces.

Duplicate Surface Faces

Occasionally, you may encounter one or more surfaces that have 
overlapping surface faces. This may be a problem in the source mod-
el, a result of how the surface was imported, or simply a result of ac-
cidentally duplicating surface faces.

Duplicate surface faces can cause confusion in analysis, so it’s best to 
clean these surfaces up before using them. Fortunately, SA has a com-
mand to detect and delete duplicate surface faces.

To Delete Duplicate Surface Faces:

1. From the menu, select Edit>Remove Duplicate Surface Faces.

2. Select the surfaces to examine.

3. Provide a coincidence tolerance. This indicates how close two 
overlapping surfaces must be to be considered duplicates.

4. If duplicate faces are found, confirm the deletion.

Surface Normal Conditioning
As explained in “SA Fundamentals”, the normal direction of surfaces is 
critical to how offset compensation is applied to your measurements. 
An incorrectly-oriented surface normal can lead to dramatically in-
correct analysis results. CAD surfaces should always have their nor-
mals facing away from the material of the part. That is, the side on 
which you approach the surface with a probe must be defined as the 
positive side of the surface.

The use of surface backside coloring (see “The Graphical View”) en-
ables you to determine if any surface normals are reversed. When-
ever you import a CAD model, you should therefore check to ensure 
that surface normals are correct, and any incorrect normals should be 
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fixed.

There are three methods for flipping surface normals: indicating 
point on positive side, reversing normals, and auto-reversing from 
viewpoint. All of these methods require a surface to be dissected into 
its individual surface faces before they are reversed.

Indicating Point on Positive Side

One method for correcting surface normals is to use a reference point 
as an indicator for whether that point should end up on the positive 
or negative side of a surface. This is similar to some metrology soft-
ware that expects an additional measured point to indicate the direc-
tion of offsets for measured geometric surfaces.

To Condition Surface Normals by Indicating Point on Positive:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 370.

2. From the menu, select Edit>Surface Normal Conditioning>Indicate 
Point on Positive (or negative) side.

3. Select the point to serve as the reference point.

4. Select the surfaces to consider.

5. At the Decision dialog, indicate whether the reference point 
should end up on the positive or negative side of the surface.

Reversing Surface Normals

The most straightforward method for reversing surface normals is to 
explicitly select the surfaces you’d like to reverse. The normal direc-
tion of each selected surface will be flipped.

To Reverse Surface Normals:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 370.

2. From the menu, select Edit>Surface Normal Conditioning>Reverse 
Surface Normals.

3. Explicitly select the surface faces you’d like to reverse.

Auto-Reversing Surface Normals

SA can use the current view orientation to automatically reverse a set 
of surface faces. This has the advantage of reversing a large number 
of surfaces at once, without requiring you to select the specific sur-
faces you’d like to fix.

With this command, you orient the view so that you can see the sur-

Note:  This method currently 
compares the reference 

point to the middle of each sur-
face face. Therefore, it is not 100% 
reliable.

Note:  You may need to per-
form this operation from 

several different viewpoints.
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faces you’d like to correct. You then select these surfaces, and the key 
is that you can also select surfaces which are already facing the prop-
er direction. SA will go through each selected surface, determine if 
it’s visible from the current viewpoint, and then reverse it if its normal 
does not generally point toward the viewpoint.

To Auto-Reverse Surface Normals from Viewpoint:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 370.

2. From the menu, select Edit>Surface Normal Conditioning>Auto Re-
verse Surface Normals from Viewpoint.

3. Orient the view so that you can see the surface faces you’d like 
to correct.

4. Select the surfaces you want the command to consider. (It’s 
OK if these surfaces are already facing the correct direction).

Note:  Occasionally, you may 
need to manually reverse a 

stray surface face.

Tip:  If there is not a large 
number of surfaces, it’s gen-

erally faster to just select all sur-
faces using rectangular selection 
or the F2 window versus trying to 
select only those surfaces that 
need to be fixed.
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Instrument Shots
It is often useful to draw instrument shots—that is, the line of sight 
from instruments to their corresponding measurements, as depicted 
in Figure 14-15. Instrument shots (also referred to as shot lines) help 
you visualize which instruments have measurements to which points, 
and also helps with visualizing the angles and distances to your shots, 
as well as the entire instrument network as a whole.

SpatialAnalyzer provides a large array of functions for 
performing measurement. The more familiar you are 
with the tools available at your disposal, the more ef-
ficient you will be when it comes to measurement.

Measurement
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Figure 13-1. Shot lines for an 
instrument network.

To Control Whether Instrument Shots are Drawn in the Graphical View:

 ■ Toggle the View>Show Instrument Shots setting.

Instrument Shot Modes

There are four modes for viewing instrument shots:

 ■ Draw only last shot of active instruments. Draws only the 
most recent shot from any active instruments.

 ■ Draw all shots. Draws every shot line from every instrument to 
every point (used in Figure 14-15).

 ■ Draw only active (enabled) shots. Any shots which have been 
disabled will not have shot lines drawn—but all others will.

 ■ Draw only inactive (disabled) shots. Any shots which are en-
abled will not have shot lines drawn—but all others will.

To Change How Instrument Shots Are Drawn:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.

3. Select the desired mode from the Mode box.

Shot Colors

In addition to changing the instrument shot mode, you can also set 
the color used for active shots, inactive shots, or the latest (Current) 
update.

To Change Instrument Shot Colors:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.

3. Click the Active Shots, Inactive Shots, or Current Update button 
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to indicate which color you’d like to modify.

4. Select a color from the dialog, then click OK.

Angle Only Shots

Instruments that do not measure distance (such as theodolites) can-
not measure a point in 3D space, therefore the shot line length can-
not be determined. A default length of 200 units is used for drawing 
these shots, although you can lengthen or shorten this value as ap-
propriate to the scale of the measurement job.

To Change the Length of Angle Only Shots:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.

3. Enter a length into the Default Length field.

Big Data Window
The Big Data Window (Figure 13-2) allows you to view various mea-
surement data as it arrives. This includes:

 ■ Target Name

 ■ Target Coordinate

 ■ Component Measurement Uncertainty

 ■ Pointing Error

 ■ Apex Angle

 ■ Group Comparison

 ■ Theodolite Data Observer information

 ■ Error Sensitivity

 ■ Distance Between Last Two Points

The window is customizable: you can turn different data elements 
on and off, resize and relocate their position in the window, change 
fonts, and control colors, borders, and other visual elements.

The window also allows you to step forward and backward through 
recent measurements to view the associated data, copy the data to 
the clipboard, or take a graphical snapshot of the window.

To View the Big Data Window:

 ■ From the menu, select View>Big Data Window.

To Enable/Disable Elements of the Big Data Window:

1. In the Big Data Window’s menu, click Customize.

2. The Customize dialog appears. Select different elements from 
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the dropdown, and check or uncheck their Visible option, 
then click Apply.

Figure 13-2. The Big Data 
window.

To Customize an Element of the Big Data Window:

1. From the big data window’s menu, click Customize.

2. In the Customize dialog, select the element from the drop-
down that you’d like to modify.

3. Choose among the below options to modify the element:

 ■ Text Font. The font used to display the textual data.

 ■ Text Color. The color of the font used to display textual data.

 ■ Draw. When enabled, draws a border around the element.

 ■ Border Color. Determines the color of the element’s border.

 ■ Fill. When enabled, fills the element’s background with the se-
lected color.

 ■ Fill Color. The color to use for the element’s background.

 ■ Highlight Color. Sets the highlight color, if used by the ele-
ment.

To Resize and Reposition Elements in the Window:

1. In the big data window’s menu, select Re-Size>Allow Sizing. This 
puts the window into a resizing mode.

2. Click and drag an element to move it. Right-click and drag an 
element to resize it horizontally and vertically.

3. When finished, again select Re-Size>Allow Sizing to disable resiz-
ing mode.

To Copy the Big Data Window Text to the Clipboard:

 ■ From the big data window’s menu, select Functions>Copy text to 
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clipboard.

To Copy the Big Data Window to the Clipboard as an Image:

 ■ From the big data window’s menu, select Functions>Copy graphics 
to clipboard.

To Move Through Your Measurement History:

 ■ Use the <Back>, <Forward>, and <Last> menu items in the big 
data window to navigate through historical measurement data.

Instruments
Before you can begin measuring with an instrument, you need to add 
one to your current job.

To Add an Instrument:

Do one of the following:

 ■ From the menus, choose Instrument>Add, or

 ■ Press Alt+I, the default keyboard shortcut, or

 ■ In the Main Toolbar, click the Add Instrument button.

Figure 13-3. The Add Instru-
ment to SA dialog.

The Add Instrument to SA dialog (Figure 13-3) will list all available in-
struments that can be used in SA. The instrument list can be filtered 
to only show the instruments that you have added in the past; each 
time an instrument is added to a job, it’s added to this filtered list.

To Switch Between the Filtered Instrument List and the Full List:

 ■ Select the My Instruments or All Instruments radio button.
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To Reset Which Instruments Appear in the Filtered List:

 ■ Navigate to the Analyzer Data\Persistence folder and 
delete the My Instruments.bin file.

Figure 13-4. The options 
available for adding an instru-
ment.

Clicking the Options button opens the Add Instrument Options dialog 
(Figure 13-4). In this dialog, you can specify an instrument stand (for 
visual representation purposes only), specify where to locate the 
newly added instrument, and specify whether to automatically run 
the instrument’s interface when the instrument is added. These set-
tings are optional conveniences and are not critical to the procedure 
of adding instruments. The settings persist and will apply to the addi-
tion of future instruments until the settings are changed.

To Specify an Instrument Stand:

 ■ Choose None, Brunson Model 233, Wooden Tripod, or Quickset from the 
Instrument Stand list.

To Specify Where a New Instrument Should Be Located:

4. Choose World Frame (to add the instrument relative to the 
World frame) or Working Frame (to add it relative to the current 
working frame).

5. Specify whether to add the instrument along the chosen 
frame’s X, Y, or Z axis.

6. Enter an Increment Value. This value specifies (in job units) 
how much further down the selected frame’s axis each subse-
quent instrument should be added.

To Specify Whether a Newly Added Instrument’s Interface Should Automatically Be Started:

 ■ Check or uncheck the Run Interface option.
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Instrument Options and Properties

When an instrument is added to SA, it is added to the graphical view 
as well as the tree. Each instrument is identified by an Instrument In-
dex Number and the name of the instrument. In a given collection, 
the Instrument Index Number begins counting from zero.

Right-clicking an instrument in the tree will expose a number of com-
mands that apply to instruments.

Instrument Properties
The instrument properties give access to several important proper-
ties. Here the user can set the scale of the instrument either using 
Scale Bars, Material CTE or a Manual entry. Instrument Properties are 
covered in SA Fundamentals | Entities | Instruments.

Instrument History
The instrument history (Figure 13-5) is a log of events that have oc-
curred to that particular instrument. Events such as when an instru-
ment was connected, instrument specific information, how the in-
strument was transformed, etc.

Figure 13-5. A tracker’s his-
tory.

Instruments and Measurements
A unique characteristic to SpatialAnalyzer is the association of points 
to their respective instrument. SA treats an instrument and its points 
as a rigid body. If an instrument is transformed (moved), the instru-
ment and its points will move. This is a key concept that is used ex-
tensively throughout SA. Objects can also be associated to an instru-
ment, so when an instrument moves the associate points and objects 
will move.

When a point is measured it is treated as a measured point. Mea-
sured points contain all of the instrument specific measurement de-
tails.  Please see the Point Properties section for more on measure-
ment details.
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The Instrument Interface
One of the most powerful aspects of SpatialAnalyzer is the modular-
ity of the instrument interfaces and how they interact with the core 
analysis platform. These interfaces are able to work independently or 
together, on a single computer or across networked computers.

Instrument interfaces communicate with SpatialAnalyzer using the 
robust TCP/IP network protocol. This affords several distinct advan-
tages. First, these connections are extremely fast and reliable. Second, 
since TCP/IP is a “network” protocol, the instrument interfaces may be 
run on either the same computer as the instance of SA, or on another 
computer accessible on the same network. Third, and perhaps most 
impressive: since it is the “Internet Protocol” (IP), the computers run-
ning the instrument interfaces could be in the same room, across the 
country, or around the world. Likewise, if activated, it is possible to re-
motely monitor a measurement job in progress using this same TCP/
IP connection over the Internet or on a local network.

Modular instrument interfaces are the basis of the data acquisition 
aspect of SpatialAnalyzer. These provide an easy-to-use and friendly 
interface for the control of instruments during a measurement job.

Establishing the instrument interfaces as separate entities in the ar-
chitecture affords several key advantages. First and foremost, this 
provides flexibility to adapt to tomorrow’s instrumentation. The num-
ber of instrument interfaces available for SpatialAnalyzer is ever-ex-
panding, much like printer drivers and other peripheral devices for 
the Windows operating system. Second, this approach enables SA 
to provide a common interface for each type or class of instrument. 
A portable CMM manufactured by Company A would has the same 
top-level interface as a portable CMM manufactured by Company B. 
This allows users to easily select the instrumentation best suited for a 
particular task. It also allows users to easily transfer the expertise they 
have gained with one instrument to another. A direct benefit of this 
capability is to improve a user’s flexibility when moving from task-to-
task and it reduces the training time for a user to become productive 
on a different instrument. Third, this allows for a more objective view 
when it comes time to replace or purchase new hardware, since re-
training is minimized by the common instrument interface in Spati-
alAnalyzer.

In all cases, the instrument interfaces perform four key functions:

 ■ They provide a common and simple user interface that can be 
used under SpatialAnalyzer control to guide a user through a 
particular measurement task.

 ■ They communicate over a TCP/IP network to convey essential 
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measurement data to SpatialAnalyzer.

 ■ They communicate via a native format to the instrument. For 
example: serial RS-232 connections for many theodolites, Net-
work protocols for many laser trackers.

 ■ They provide an efficient means to collect the raw measure-
ments, the conditions and techniques under which they were 
collected, and to perform operational checks on the instrument 
to establish that it is meeting its performance specifications.  It 
also supports simulating measurements and measurement 
tasks before the job is performed. By simulating a measure-
ment process before the job is performed, accuracy and time 
estimates can be made to help you make the best choices re-
garding optimizing the placement of the instrument(s) relative 
to the subject of the survey. 

Starting an Instrument Interface

To start an instrument interface, choose Instrument>Run Interface Module 
(or click the dropdown arrow next to the Run Instrument Interface
icon). Then select the instrument interface of choice. Once selected, 
the Connect to SpatialAnalyzer window will display (Figure 13-6). This 
window displays all network-accessible and running instances of SA 
containing instruments. The network location (computer name and 
IP address) appears in the list, in addition to the open job filename. 
Any applicable instruments not already connected to an interface will 
appear in boldface.

Figure 13-6. The list of avail-
able instruments to connect 
to.

In  this window, you’re choosing the instrument in an SA job file to 
which you’d like to send the measured data. While it is usually the file 
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open on the same computer, this is not required. Choose the instru-
ment to which you wish to connect and click OK.

The next dialog will display connection options that are specific to 
the instrument being added. In Figure 13-7, a Faro tracker is being 
added.

Figure 13-7. Connection 
options for this instrument (a 
Faro tracker).

Once accepted, the instrument interface will appear (Figure 13-8).

Figure 13-8. A simulated 
tracker interface.

See the Interfaces section for information on instrument-specific in-
terfaces.

If a single instrument is in the job file, you can click directly on the Run 
Instrument Interface icon, and the instrument’s interface will be 
connected and started up. This is equivalent to the Instrument>Run In-
terface Module and Connect command.

Running Multiple Instrument Interfaces

One of SpatialAnalyzer’s strengths is its ability to gather data simul-
taneously from multiple instruments in the same job file. This can be 
done with any combination of instruments, and users may connect 
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and disconnect instrumentation at will. The process for adding addi-
tional instruments is exactly the same as adding the first. Just follow 
the procedure outlined in earlier sections.

Measurement Simulation
SpatialAnalyzer allows for instruments and measurements to be sim-
ulated (Figure 13-9). This can aid in planning a job, analyzing instru-
ment setup uncertainty, training, etc.

Figure 13-9. Measurement 
simulation.

The “Fabricate Measurement” command will create simulated mea-
surements from the selected instruments and points.

Measurement error can be injected to simulate real world conditions. 
The error is based on the uncertainty model of the selected instru-
ment.

Locating Instruments

Instrument Locate (Transform to Part)

An instrument can be located several ways. The basic instrument lo-
cation methods can be found under Instrument>Locate or right-click 
an instrument and select Locate. Advanced methods are discussed in 
later sections and links are provided below.

Measure Nominal Points
Measure Nominal Points (Figure 13-10) is a great way to locate an 
instrument quickly. Simply select the nominal points and the instru-
ment to locate.



386

SPATIALANALYZER USER MANUAL

Figure 13-10. The Locate by 
Measuring Nominals window.

The Locate dialog will appear listing the points to measure. The user 
has the option for manual or automatic measurement. Once three 
points are measured the instrument is transformed via a Best-Fit. With 
the instrument roughly located the user can easily drive or point to 
each target. As measurements are recorded the Best-Fit is updated. A 
fit tolerance can be applied to notify user of an out of tolerance condi-
tion.

Quick Align to CAD
A quick and easy method to align to a CAD model. Simply click the 
model where the points will roughly be measured. A minimum of 
six points are needed to align to a CAD model. Red dots are used to 
guide the user where to measure. During the selection of the surface 
points the current view is saved. As measurements progress the views 
update.

Best-Fit
Locating an instrument via a Best-Fit is one of the most common loca-
tion methods. It is used heavily during instrument location to nomi-
nal control points, instrument relocation and relocation due to drift. 
The user specifies the instrument to locate, the nominal point group 
and measured point group. The below fit dialog will appear allowing 
a view of the best fit. This Best-Fit Transformation dialog is covered in 
the Best Fit Points to Points section.

Plane, Line, Point (3-2-1)
A 3-2-1 fit consist of a locator point for the origin, line/vector for one 
axis and plane for the second axis. The Plane, Line, Point Transforma-
tion dialog allows control over the axis for the plane and line/vec-
tor. The user may also specify an alternate coordinate for the locator 
point. Once the transformation is accepted the instrument will be 
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transformed with respect to the active frame.

Frame to Frame Transformation
Transform an instrument from a one frame to another. User will be 
prompted to select a source frame, a destination frame and an instru-
ment to move.

3 Planes
The 3 Plane instrument locate uses three planes to define a coordi-
nate system that is then transformed to the active frame. The user has 
control over the axis fit priority and position.

Analysis Best Fit Points to Points

Analysis>Best Fit Transformation>Points to Points is very similar to 
Instrument>Locate>Best-Fit. The main difference is that the user has the 
ability to move multiple instruments and additional objects. See Best 
Fit Points to Points for more information.

N-Point Full Fit
Finds the optimal transformation that minimizes the errors between 
the measured points and the CAD surface. This method contains 
many options for tolerance fits and other advanced fitting methods. 
See Best Fit Points to Surfaces for more information.

Locating By Minimizing Relationships
Instruments can be located by Minimizing Relationships. This is avail-
able in SA Ultimate and can found in the Minimizing Relationships 
section.

Unified Spatial Metrology Network (USMN)
USMN is a strong method for locating multiple instruments. It is usu-
ally used in a case where three or more instruments are present. This 
is available in SA Ultimate and can found in the USMN section.
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Watch Windows

Figure 13-11. A watch win-
dow on an instrument.

SpatialAnalyzer uses watch windows (Figure 13-11) to display live 
data taken from measurement devices and relationships. These watch 
windows may be used to compare the current measurement from an 
instrument to a surface, another point, the closest point, or other en-
tities.

These windows are re-sizeable to suit the user’s preferences. In addi-
tion, when a tolerance is set, these windows will indicate out of toler-
ance conditions by changing the background color of the window.

Watch windows will update when the instrument performs a Query. 
This is different than when the instrument takes a measurement. Que-
ries are sent to SpatialAnalyzer to update the watch windows and the 
graphics but are not saved as measurements. You can query an instru-
ment from its instrument interface. In addition, where applicable, you 
can set the instrument to query at a given frequency. This is the mode 
you will usually place the instrument in when using watch windows.

How to Open a Watch Window

A watch window can be opened one of two ways:

 ■ Navigate to the menu option View>Watch Window and select a 
Watch Window style, or

 ■ Right-click the point, object, relationship or instrument of in-
terest and select Add Watch Window.
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 Multiple watch windows can be opened and updated. This can be 
useful when monitoring several objects.

Watch Window Types

Point to Point
Add Point to>Point or right-click a point to add a watch window.

Point to Object
Add Point to>Object or right-click an object to add a watch window.

Add Instrument’s Point
Add Instrument’s Point or Right-Click instrument to add a watch win-
dow. Displays instrument’s current target location in active frame.

Add Closest Point

Add closest Point or Right-Click a point group to add a watch window 
Will compare the instrument’s target to the closest point.

Add Three Point Frame

Watch Two Point Axis Alignment

Watch Window Options

A watch window can be configured for size, precision, tolerance and 
more. Simply right-click the watch window to access watch window 
specific options.

Precision, Font, Text Color, Background Color 
and Highlight Color

Use these options to change the look and feel of the watch window. 
These are specific to the current watch window being changed.

Arrow Settings
Control guidance arrow components and length.

Hide/Show Row Items
Hide or show selected component.

Coordinate System Type
Display values in Cartesian, Cylindric or Polar.

Set Frame of Reference (FoR)
By default a watch window is expressed in the current active frame. 
However, it can be advantageous to display the coordinate values in 
an alternate frame. Use this option to select an alternate frame.

Default Tolerance
Use this option to apply a tolerance to the watch window.



390

SPATIALANALYZER USER MANUAL

Projection Options
Used for watch windows using an object. See the Vector Group sec-
tion for further information on projection options.

Bundle Adjustment
A bundle adjustment may be used to refine measurements acquired 
using a spherical measurement system. These include theodolites, 
laser trackers, laser scanners, etc. Basically, a bundle adjustment will 
attempt to find the instrument transformations (positions and orien-
tations) that yield the minimum combined pointing error.

Initial Guess

Since the bundle adjustment algorithms use the current locations of 
the instruments as a starting guess, it is best to “rough” position the 
instruments. To do this, either enter the instrument transformations 
manually, or use the Drag Instruments function from the Instruments 
menu. It is best to place the instruments near their final location, as 
this will speed the bundle solution. If using theodolites with level 
compensators, you will use the option to force instrument vertical 
during the bundle adjustment. If this is the case, the virtual instru-
ment models should be perfectly parallel to each other before initiat-
ing the bundle adjustment.

Scale-Bar Database

For instruments that measure angles and distances, it is not necessary 
to use scale-bars in the bundle process. They are required for theodo-
lite networks, however, because without them, the instruments will 
scale freely.

SpatialAnalyzer contains a scale-bar database. This is where you can 
enter the various scale-bars you have placed into the measurement 
area. Essentially what this database does is it associates target names 
with a scale-bar distance and uncertainty.

To modify the database, select the Scale-Bars tab from the User Op-
tions page. The next window will list all of the current scale-bars and 
their information.

To add a scale-bar, press the Add button and a new record will be 
generated. Complete the information required and press the Apply 
button. You should see the information in the list window update.

Since an accurate bundle solution for theodolites requires at least one 
scale-bar, make sure this database is populated before attempting a 
bundle. In addition, make sure the targets for the end of the scale-bar 
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have been shot and included in the list of targets to be included in the 
bundle solution.

Note, however, that you may populate the scale-bar database at any-
time before attempting to bundle adjust. It is not necessary to have 
this database in place before taking measurements.

Select Bundle Adjust from the Instruments menu. Next, select the in-
struments you wish to bundle using the dialog. The instruments that 
you select are the instruments that will be moved in order to refine 
the network solution. If you have 4 instruments, you will only have 
to bundle 3 because the first instrument may remain fixed while the 
others are adjusted relative to it. You may, however, select all of the in-
struments. This will make the solution take longer, however, because 
the entire network will be allowed to float in space. Next, the Bundle 
Adjustment dialog will appear.This dialog will allow you to configure 
the settings for the bundle, run the optimization, and view the results.

Selecting Targets to Bundle

Once the Bundle Adjustment window appears, you may select the 
targets to be included in the bundle. SpatialAnalyzer will default to 
including ALL of the targets. You may reduce the number of targets 
for computational efficiency or target accuracy reasons.

Scale-Bar Weight Factors

In the Bundle Adjustment window, you will notice a section for Scale 
Bar Weight factors. This section allows you to control the manner in 
which scale-bars are incorporated into the final solution.

You may change the state of the check-box to determine wheth-
er scale-bars are weighted based on their uncertainty. If this box is 
checked, the relative uncertainties in the Scale-Bar database will be 
used to weight those scale-bars with a higher accuracy more than 
those scale-bars with a lower accuracy (or a higher uncertainty). Basi-
cally, this check-box controls how multiplier scale-bars are compared 
to each other during the bundle solution.

In addition, you may enter a numerical weight that is applied to ALL 
scale-bars during the solution. This value defaults to 1.0, but may be 
increased or decreased at the user’s discretion. Note, however, that this 
value is independent of the state of the check-box. You may weight 
scale-bars based on uncertainty and/or apply an overall weight. This 
is because the overall weight is applied after the uncertainty weight 
is applied.
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Viewing System Errors

The Bundle Adjustment window displays both the Original shot er-
rors and the adjusted shot errors. This gives you a measure of how 
much the bundle adjustment has improved the overall system error.

A maximum, average, and RMS error is displayed. These values char-
acterize the combined pointing errors for each target that is included 
in the Bundle Adjustment. Each target has a pointing error, given in 
degrees. This is the amount that the measurements miss the best-fit 
computed target. The bundle adjustment attempts to minimize the 
combined pointing error by simultaneously adjusting both the posi-
tion and orientation of the instruments.

Therefore, if there are 30 points in the bundle, the maximum error is 
the largest pointing error for all of the points, the average is the aver-
age of that set, and the RMS is the root-mean-square of the set.

If you wish to see the errors itemized by target, click the Show Details 
button, and you will see a list of the targets and their errors. You may 
wish to select this option before beginning the bundle to inspect the 
list.

Beginning Computation

Click the Begin Computation button, and the Bundle Adjustment will 
begin. As progress is made, the graphical display will be updated, and 
all of the numerical values in the Bundle window will reflect the sys-
tem improvement.

When the algorithm has found a minimum, it will stop and issue a 
message to the user. Look at the details of the bundle to inspect the 
individual target errors as well as the scale-bar errors. If these are suit-
able, click the Accept Results button in the Bundle window, and the 
changes will be made active. The system is now bundled!

If, however, the results are not satisfactory, and you wish to start over 
where you began initially, select Cancel from the Bundle window. This 
will reset the instruments to their initial locations and re-compute the 
target locations.

Local Minima

Whenever you attempt to minimize a set of complex equations, the 
issue of local minima arises. Because you start from an initial guess 
and seek to minimize the error until you can minimize no more, you 
do not know that you are at the lowest possible minima for the entire 
solution space.

For this reason, it is possible for the bundle adjustment algorithms to 
find a solution that, while it is a minimum, is not the minimum you 
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were searching for. SpatialAnalyzer contains a full 3-D graphical mod-
el of the measurement environment to help decipher some of the lo-
cal minima. It is important, however, to start the instruments near to 
their optimal location (i.e. use a good guess) to minimize the chance 
of a local minima.

Weighting

There are several weighting factors described above. These control 
the importance of different parameters on the overall optimization 
process. There are several other weighting factors outside this dialog 
that control the process as well.

In the User Options dialog, under the Units tab, there is a button for 
Angle-Distance Weights. This button will allow you to control the rela-
tive weight of angular measurements compared to distance measure-
ments. This will only affect the bundle if you are using instruments 
that can measure distance (laser trackers for example).

UDP Broadcast
SA’s instrument interfaces have the ability to send a stream of UDP 
packets when their measurements are sent to SpatialAnalyzer. To en-
able this for trackers, for example, go to the Utilities menu and select 
UDP Data Stream (Figure 13-12). Then configure the settings:

Figure 13-12. The UDP data 
stream properties.

Now, subsequent 3D and/or 6D measurements will also be sent as 
UDP packets to either the entire subnet or a particular IP address.

SA also contains a diagnostic utility so you can view this data stream 
(Figure 13-13). Navigate file explorer to the SA install directory and 
run SpatialAnalyzer UDPMonitor.exe. Set it to the same port 
and hit Start. When measurements or updates happen, the data will 
flow into the monitor, as pictured at right.
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Figure 13-13. The UDP 
Monitor.

This output can be subsequently saved to a .CSV file.

SA Remote
SA Remote (Figure 13-14) is an iOS app that allows real-time viewing 
of 3-DOF and 6-DOF spatial data from SA and permits remote control 
of the SA Laser Tracker interface.

Figure 13-14. SA Remote.

SA Remote is available as a free app on the Apple App Store for 
iPhone® and iPod® touch devices. SA Remote will also run on an iPad®.

SA Remote will receive UDP data for display from watch windows in 
SA or the Laser Tracker interface on port 10000. If multiple sources 
of watch data are available, the app allows switching between the 
sources allowing selection of which watch source on which to focus.

SA Remote can also view/control the SA Laser Tracker interface. This 
requires entering the IP/hostname of the computer running the SA 
Laser Tracker interface into the app in the settings page. Once this is 
done, SA Remote will provide display and control over the interface 
remotely.
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Setup

To download and install SA Remote, visit the app store, find the 
SA Remote app (http://itunes.apple.com/us/app/sa-remote/
id473334282?ls=1&mt=8), and select install. Once installed, run the 
app.

The upper half of the app screen is used to display watch data while 
the lower half is used to view and control the SA Laser Tracker inter-
face. Initially, the display will likely look like Figure 13-15 since no 
watch data is available yet and the SA Laser Tracker interface IP/host-
name has not yet been entered.

Figure 13-15. SA Remote as 
it first appears on the iPhone.

Touch the small “i” info button (right) which is in the upper right cor-
ner of the screen to open the quick help screen (Figure 13-16).

Figure 13-16. The SA Re-
mote quick help screen.

The quick help screen provides a brief summary of the setup tasks for 
the app. It also displays the device IP address which can be used when 
setting up the UDP watch transmission settings in SA.

When running SA v2011.10.20 or newer, add a watch window and 
enable UDP broadcast. Specify port 10000. If SA is not running on the 
same subnet as the iOS device, you may need to choose directed UDP 
transmission entering the IP address of the device. The device IP ad-
dress is available in the quick help page mentioned above. Once cor-
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rectly configured, the top area of the app screen should start showing 
watch data as in Figure 13-17.

Figure 13-17. Watch 
Window information is now 
streaming to the device.

You can also enable UDP broadcast or directed transmission from the 
SA Laser Tracker interface.

To configure communications with the SA Laser Tracker interface, 
touch the small detail button in the upper left corner of the screen to 
bring up the settings view.  In this view (Figure 13-18), enter the IP or 
hostname of the computer running the SA Laser Tracker interface as 
well as the desired decimal precision and then tap Close.

Figure 13-18. Configuring 
the IP address.

Once the SA Remote app establishes communications with the SA 
Laser Tracker interface, the lower portion of the screen will enable 
and provide display and control of the interface as shown below.
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Figure 13-19. Tracker control 
is now enabled.

When the SA Laser Tracker interface is busy, the lower portion of the 
screen will be disabled for input, a busy animation will show, and the 
measure button will change to stop, allowing you to cancel the cur-
rent operation as shown at right.

If multiple sources of watch data are available (multiple watch win-
dows and/or instrument UDPs enabled) the label at the top of the 
screen will turn into a button indicating that you can tap it to select 
which source of watch data to view (Figure 13-20).

Figure 13-20. The button in 
the top left indicates you can 
select a different watch source.

Tapping the button will open the watch source selection view shown 
in Figure 13-21.
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Figure 13-21. Selecting the 
desired watch source.

Select the desired source of watch data and then tap CLOSE. The se-
lected source will then be displayed on the main screen.

Available Status/Commands

 ■ The COL/GRP/TGT fields show the current collection/group/
target fields from the SA Laser Tracker interface and you can 
touch them to change the values; when changed the new val-
ues will be reflected in the interface as well.

 ■ The + buttons to the right of GRP and TGT will auto-increment 
the corresponding fields (decrement is not currently support-
ed).

 ■ The status light will reflect what is shown in the interface.

 ■ The X button can be used to remove the last measurement.

 ■ The long button above the measure button shows the name 
of the current measurement profile. When touched, it cycles 
through the quick-select profiles (1 – 4) and the name updates 
to reflect the current profile.

 ■ The ADM button commands an ADM Reset.

 ■ The RH button commands a Remote Home, if one is set.

 ■ The Measure button initiates a measurement using the current 
measurement profile and changes to Stop when the interface 
is busy and can then be used to cancel the current operation.

Transformation Tracking
For 3D instruments (e.g., Trackers) transforming objects in real time 
requires at least three on-line trackers. This functionality is also called 
Trans-Track (Figure 13-22).
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Figure 13-22. Transforma-
tion tracking.

Each instrument will monitor and update a point. The movements of 
the set of points are used together to update objects in 6D. Select one 
point per instrument. The point selection order must be consistent 
with the Instrument selection order e.g., select the points in the in-
strument sequence. After defining the instruments and tracking 
points; select the objects that need to move with the point set. The 
Trans-Track interface (shown below) indicates the instruments being 
monitored and the respective fit error for the point that it is tracking. 
The time lapse value indicates the time lapse between the measure-
ments (i.e., synchronization error).

Relationships with Trans-Track

Relationships are dynamic by nature and work great with Trans-
Track. Watch windows can be displayed for relationships which will 
allow real time monitoring while moving. Figure 13-23 shows an ex-
ample of Trans-Track being used to join two cylindrical sections. A 
frame to frame relationship was used to monitor the position and ori-
entation of the moving unit with respect to its final nominal location.
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Figure 13-23. Using trans-
track to join two cylindrical 
sections of an assembly.

Transform in 6D using Instrument Updates

Trans-Track can be accomplished with a single instrument if the in-
strument supports a 6D target. Examples are the Leica T-probe/T-Mac, 
API STS and Metris iGPS. This instrument can monitor and measure in 
6D. The functionality is identical to Multiple Updates.

Laser Radar Interface
Add the Laser Radar Instrument by using or the menu item 
Instrument>Add (Figure 13-24).

Figure 13-24. Adding the 
Laser Radar to the job.

Start the instrument interface using or the menu item Instrument>Run 
Interface Module and Connect.  
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Figure 13-25. The Laser 
Radar interface.

Use the Connect button to display the Select CLR dialog. Select the 
respective instrument and press Connect (Figure 13-26).

Figure 13-26. Selecting the 
instrument to connect.

Toolbar

Figure 13-27. The toolbar in 
the laser radar interface.

 ■ Connect/Disconnect. Opens the LR Connection dialog (see 
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above).

 ■ Target Manager - Advanced. Displays the target manager 
interface (Figure 13-28).

 ■

Figure 13-28. The Advanced 
Target Manager.

Show/Hide FFT Window. Toggles the FFT window visibility 
(Figure 13-29).

 ■

Figure 13-29. The FFT  win-
dow.

Cloud Viewer. Opens the cloud viewer interface (Figure 13-
30).
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 ■

Figure 13-30. The Cloud 
Viewer.

Mirror. Displays the mirror target dialog (Figure 13-31).

 ■

Figure 13-31. The mirror 
target dialog.

Continuously Repeat Command. Sends updates by re-
peating the current measurement mode.

 ■ Video Window. Toggles the video output window (Figure 
13-32). Using Ctrl + Shift + + or Ctrl + Shift + “-” will 

increase or decrease the steering speed.
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 ■

Figure 13-32. The video 
window.

Video Focus. Displays slider for manual focusing of video 
camera.

 ■ Shutdown. Disconnect and shutdown scanner.

 ■ Dock/Undock. Docks or Undocks the instrument interface 
in SA.

Target Naming

 ■

Figure 13-33. Specifying a 
target name to measure.

Collection Name. Specify the collection name for the group 
and target to be stored. If left blank, the group and target will 
be stored in the active collection.
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 ■ Group Name. Specify group name for target to be stored.

 ■ Target Naming. Specify name for target, target name will au-
tomatically increment after each measurement.

Measure/Inspection Location

The LR interface supports three measure locations (Figure 13-34). 
When selected the user can configure the “measure” quick selects.  
When the measure operation is changed the “measure” quick selects 
will change.

 ■

Figure 13-34. Measure 
quick-selects.

Current Beam Location. Used to measure the current location 
of the beam.

 ■ Selected SA Geometry. Used when a supported geometry is 
to be measure. An example would be a perimeter or a vector 
group.

 ■ Auto Measure from SA. Used when SA sends an auto-mea-
sure request to the LR interface.

Current Beam Location, SNR and Auto-Focus Limits

This allows the user to view the IR SNR (signal to noise ratio) or the 
Red (pointing laser) focus limits (Figure 13-35). When selected the dis-
play to the right will change. When “Red” is selected the user will have 
quick access to the focus limits. F7 can be used to toggle between the 
two displays. Auto-focus can be accessed via the interface button or 
use F8.
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Figure 13-35. SNR/AF Limits.

Measure and Advanced Target Manager

To select a Measure mode for a particular quick select, press the arrow 
button the right of the desired button. A list of measure types will ap-
pear for selection (Figure 13-36).

Figure 13-36. Measurement 
modes.

To access the parameters for the measure mode, double-left click and 
the Advanced Target Manager will appear (Figure 13-37). Here a user 
can tweak a particular profile to suit the measurement task at hand.
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Figure 13-37. Specifying 
measurement details in the 
target manager.

Output

Displays information regarding the current measurement process 
(Figure 13-38).

Figure 13-38. The output 
window.

LR Operational Tests

Access the Metris LR Operational checks under the menu item Tests. 
Consult the Metris documentation for operational check procedures.

Single Point Measurements

This section will briefly cover some basic single point measurement 
types. For further information please consult Nikon Metrology.

Tooling Ball
1. Select the desired tooling ball measurement mode for select-

ed quick select. Use the drop-down arrow to pick the desired 
measurement mode. If the needed measurement does not 
exist, create a new one in the target manager .

2. Steer the laser to the tooling ball of choice. Point the laser to a 
surface near the tooling ball and press F8 to perform an auto-
focus. Once complete aim the laser to the center of the tool-
ing ball.

3. Press the measure button or F3.
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4. The point will be sent to SA, if not check the output box to 
check measurement failure details.

Surface Point
1. Select the desired surface point measurement mode for se-

lected quick select. Use the drop down arrow to pick the de-
sired measurement mode. If the needed measurement does 
not exist, create a new one in the target manager .

2. Steer the laser to the surface point of interest. Press F8 to per-
form an auto-focus.

3. Press the measure button or F3.

Scanning Measurements

This section will briefly cover some basic scanning measurement 
types. For further information please consult Nikon Metrology.

Box Scanning
Box scanning allows the scanner to perform a scan bounded by a box 
with prescribe dimensions.

1. Point the laser at the center of the area of interest.

2. Select the appropriate scan mode. Double click the measure-
ment mode to access scan parameters. Enter the scan box di-
mensions.

3. Press Measure or F3.

4. A scan will be performed inside the bounding box (Figure 13-
39).

Figure 13-39. Scanning a 
box.

Perimeter Scanning
Perimeter scanning allows the scanning region of the LR to be con-
strained by a 3D perimeter.

1. In SA, select Construct>Perimeter. Select the measured or nomi-
nal points which describe the bounding region to be scanned. 
Two types of perimeters exist in SA, open and closed. A single 
perimeter can be changed from open to closed in the perim-
eter properties dialog.
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2. In the LR Interface, change the Meas/Inspec Location to Selected 
SA Geometry (Figure 13-40).

3. 

Figure 13-40. Choosing 
Selected Sa Geometry.

In SA, select the desired perimeter. Once selected, the quick 
selects will populate with measurement modes applicable to 
perimeters.

4. Double-click the measurement mode to access scan param-
eters (Figure 13-41). Often times a user will change the output 
format, grid rotation and point spacing.

5. 

Figure 13-41. Scan param-
eters.

Press Measure or F3.

Theodolite Manager
Theodolite manager provides a solution for interfacing all modern 
digital theodolites to SpatialAnalyzer. Theodolite Manager communi-
cates through standard RS-232 serial ports to a wide variety of both 
conventional theodolites and total stations.

Figure 13-42. A job contain-
ing theodolites.

An image of an example SpatialAnalyzer job with Theodolites is 
shown in Figure 13-42. The instruments are shown with measure-
ments and a scale bar. The actual distance between the scale bar 
points is shown with a Point Comparison callout view.
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Cabling and Power Options

Fundamentally, communication to all current digital theodolites is 
done through a serial link. However, over time, different instrument 
manufacturers have selected slightly different flavors of serial com-
munication to talk to their instruments. Some units use TTL (Tran-
sistor-Transistor Logic) level signals, but otherwise essentially follow 
RS-232 protocols. Additionally, some instruments require 6 volts for 
power, others 12 volts and still others 4 volts. Because of this non-
uniformity among manufacturers some special cabling is usually re-
quired for a specific instrument.

Direct to the Instrument
This way of cabling an instrument is really most useful for applica-
tions where a single Total Station is to be used or where a   limited 
network is configured. In this case, the instruments may be plugged 
directly into the computer or to a power augmenting device supplied 
by the instrument manufacturer. Most manufacturers supply cables 
and power units for this purpose.

Using a Serial Distribution Interface (SDI)
In instances where a user wishes to use a network of theodolites ca-
bling issues for power and signals can become a major annoyance. 
The SDI unit manufactured by Brunson Instrument Company ad-
dresses these issues, by providing a simple USB device that provides 
all instruments with power and digital signals while still maintaining 
common cabling for each instrument. This is accomplished by using 
a signal conditioning device embedded in the Theodolite Junction 
Box in the last few feet of the cabling. The Theodolite Junction box 
performs three primary tasks:

 ■ It alters the signal to levels suitable for each instrument.

 ■ It provides a convenient “trigger” button remote from the in-
strument itself.

 ■ It provides a junction point to which a short, theodolite-specif-
ic cable can be attached. This cable is necessary since there is 
no standard connector for all makes and models of theodolites.

Adding a Theodolite to an SA Job

Just as with other instrumentation in SA, the first step is to add the de-
sired instrument to the SA job. This is done by selecting Instrument>Add 
from the main menu. Now you need to start the corresponding instru-
ment interface. This can be done from the Operating System Start-Bar, 
or by selecting Instrument>Run Instrument Module from the main menu. 
After selecting the appropriate instrument, you will see the initializa-
tion dialog pictured in Figure 13-43.
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Figure 13-43. The Theodolite 
manager setup buttons.

These three buttons allow you to either make a new configuration of 
instruments, recall the  last configuration, or recall a stored configura-
tion by name. The first time you run the software you must make a 
new configuration.

You will then see the main Theodolite Manager dialog (Figure 13-44).

Figure 13-44. The Theodolite 
Manager.

The following sections will describe each component of the interface 
by section.

The area appearing as a large blank region is a listing of all active in-
struments being managed by this instance of the theodolite manag-
er. It is possible to have multiple versions of theodolite manager tied 
into the same SA job at once.

Figure 13-45. The control 
buttons.

The control buttons (Figure 13-45) allow the operator to perform 
global tasks related to Theodolite Manager. In order from top to bot-
tom these buttons provide the capability to save a Theodolite Man-
ager configuration, recall a configuration, set user options for a con-
figuration, and view information about Theodolite Manager.

Figure 13-46. Buttons for 
managing the instrument list.

The buttons to the right of the instrument list are used to manage the 
instrument list (Figure 13-46). Here the user may add, delete, or dis-
play information about a specified theodolite connection.

The buttons at the bottom of the dialog are user to poll the instru-
ments connected to Theodolite Manager (Figure 13-47). The top two 
only poll specifically highlighted instruments in the instrument list. If 
none are highlighted the buttons are deactivated.
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Figure 13-47. Instrument 
polling buttons.

To add an instrument, click the Add button. A progress bar will display 
briefly while Theodolite Manager scans for available communication 
ports. The Add Instrument dialog will then appear (Figure 13-48).

Figure 13-48. The Add 
Instrument dialog.

In the Theodolite connection area of the dialog users select the de-
sired theodolite and its corresponding communications port.

The operator must then identify which SpatialAnalyzer job and which 
instrument within that job it corresponds to. By default the dialog 
limits its display to compatible and available instruments in all jobs 
on the network. If the show all devices checkbox is checked all instru-
ments and SA jobs on the local network are displayed. The operator 
must simply highlight the desired instrument.

The operator also has the opportunity to optionally enter the user 
name for the operator of this instrument. If no name is given the in-
struments will be referred to as Station1, Station2, etc.

Once all selections are made the operator may click the Connect but-
ton. At this time the instrument is initialized and an item is added to 
the instrument list.

In this case it identifies that SpatialAnalyzer Instrument 0 (SP0) is a 
Leica T2000 connected to serial port Com4. After adding a second in-
strument the display might appear something like Figure 13-49.
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Figure 13-49. This theodolite 
manager setup has two instru-
ments added.

Notice that in this case we have highlighted one of the instruments 
and the other buttons in the interface have therefore been activated. 
Multiple highlights are possible and are accomplished using the stan-
dard windows selection methods of holding down either Ctrl to add 
select, or Shift to region select multiple instruments.

To demonstrate that the instruments are now connected, move the 
instruments to a new position and click the Query All button. You 
should see all the scopes move to their actual azimuth and elevation 
in SA.

Measurement Modes

Theodolite Manager allows operators to use theodolites in one of 
three primary measurement modes. These modes have been estab-
lished based on a survey of common methods for applying theodo-
lites. Some industries or applications may exclusively use one method 
while still others will vary their selection with each task at hand.

To change Measurement modes, click the User Options button. 
The dialog in Figure 13-50 will be displayed.

Figure 13-50. The Theodolite 
Manager’s User Options.

The Target Thickness section will apply to all measurement modes. This 
is simply the target thickness (probe offset) used in SA for various 
analysis tasks such as point to surface queries.

Freeform Mode
The Freeform measurement mode is really designed for experienced 
crews who want and have the ability to enter target numbers at the 
theodolite. By far the biggest collection of these users are experienced 
operators of Leica T2000, T2002, and T3000 series theodolites. How-
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ever, this methodology applies to other instruments as well. Newer 
Leica instruments and Zeiss Eth-2’s for example, can use this method.

In freeform mode it is always necessary that the operator set the tar-
get number on the scope before recording. Recording may be accom-
plished at the instrument or the interface as desired.

Since SA uses both Target Names and Group Names the strategy em-
ployed is to arbitrarily divide the number into a group component 
and a target component. Several examples will be presented below 
to further illustrate the concept.

With the following settings (Figure 13-51):

Figure 13-51. 

the target numbers would convert to:

Target Number Group Name Target Name

1000 Group10 Tar00

2505 Group25 Tar05

2833 Group28 Tar33

With the following settings (Figure 13-52):

Figure 13-52. 

The target numbers would convert to:

Target Number Group Name Target Name

1000 Fender1 T000

2505 Fender2 T505

2833 Fender2 T833

Single Target Mode
This mode is often used when building operations need to be per-
formed or when a novice crew needs to be guided through the 
measurement process. The basic premise is that all theodolites will 
typically shoot the same target at the same time. This is particularly 
helpful for inexperienced users since sighting errors can be immedi-
ately identified and corrected.

After enabling the Single Target Mode in the user options dialog, the 
interface will appear as pictured in Figure 13-53.
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Figure 13-53. Single Target 
mode.

Note the extra section added to the bottom of the standard dialog. 
This enables users to enter alphanumeric group and target names. 
When the Prompt Scopes button is hit, the theodolites will display 
the desired target to prompt the scope operators to point at it. Any 
incrementing or decrementing of the group or target name will auto-
matically update the instrument prompts. Recording may be accom-
plished through the standard user interface or by hitting the record 
button on the theodolite or its corresponding Theodolite Junction 
Box.

Prompted List Mode
This measurement mode is designed for tasks where the desired sur-
vey points are known right from the start. These names may either 
come from a CAD file, an ASCII file or may be entered at survey time 
by the operators.

When the Prompted list interface is initiated, the user interface ap-
pears as in Figure 13-54.

Figure 13-54. Prompted list 
mode.

Alternatively, if user names were entered as the instruments were 
added, this dialog might appear as in Figure 13-55.
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Figure 13-55. User names in 
the dialog.

In this mode, each instrument has it’s own list of targets to be sur-
veyed. This list may be created on the spot using an ascii editor such 
as notepad, or by using the Build List option. Or it may be read from 
an existing file with the Read ASCII List option. Alternatively the user 
may hit the Get List From SA button and they will then be prompted 
in SA to select points. All points are identified by both group and tar-
get names with the following format (group::target).

When the Build List button is hit, the operator sees the Construct Tar-
get List dialog (Figure 13-56).

Figure 13-56. The Construct 
Target List dialog.

By typing a “group::target” name in the green field and hitting enter a 
new target is added to the list.

After several are entered our list might appear as follows (Figure 13-
57).

Figure 13-57. Targets have 
been added to the list.

Clicking OK will retain the list for this job. Clicking Save List will allow 
the operator to specify a filename so that this may be recalled later 
(always a good idea).

Returning to the main dialog, we see that the instrument list now has 
two lines. One line corresponding to each instrument station (or user).
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Figure 13-58. 

The buttons to the far right hand side in each row allow the operator 
to Record-R, Query–Q, or Skip–S a specific instrument (Figure 13-58).

The second column is the current target for a given user. When the 
dialog is first presented this column displays “No List” since a target 
list has yet to be loaded. After the target list is loaded, this column will 
display the current target for each instrument.

In Synchronous mode all instruments will be prompted to shoot a 
specific target. As each operator acquires data, they will be prompted 
to “Wait”. When the last theodolite acquires data, all scopes will be 
prompted with the next target name. In Asynchronous mode all op-
erators may proceed through the list at their own rate.

A target hot-spot box to choose the current target for that scope 
(more about that later). To the right are buttons for Record, Query, 
and Skip.

The down arrow in the second column is called the Target Hot Spot 
Control. The target hot spot pops up the target list for each instru-
ment. When you hit the hotspot you get the list at right.

This is similar to the building list except the user cannot add new tar-
gets and the left column displays target status for that particular in-
strument.

The left column presents icons to indicate state of the target (Shot, 
Skipped, UnShot). The bold item is the current target for that user. 
You can click select what target you want to shoot next, and then 
either continue from there or  (optionally) only prompt skipped or 
undone targets. When you shoot or skip the scope will proceed to 
the next target in the list. In Asynchronous mode all scopes use the 
same list but can progress through them at their own pace, skipping 
as required, and going back as required. Note that the operator will 
not normally view the list in this way, normally they would view all 
this information in the main dialog. The list is just a control to allow 
the user to move around the job freely.
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Theodolite Data Observer

Theodolite Data Observer is activated from SA’s Instrument menu. 
This dialog makes it easier to drive Theodolite systems from the 
graphic view in SA. The interface is shown in Figure 13-59.

Figure 13-59. Theodolite 
Data observer.

This interface allows the display of Measurements, Angle Vectors, 
Goal Angle, and Delta Angles. Each view of the data is applicable for 
different applications. Use the Select Instrument button to choose 
the instruments to control from this control. Select the desired Goal 
Point then Send Drive Angles and Watch Window options to setup a 
real-time graphical build mode for the currently selected instru-
ments.  Continuously Query will repeatedly record angle measure-
ments from the instruments. This mode is important for tracking the 
theodolites movements through a measurement process.

GSI V-Stars Photogrammetry Simulation
Add a GSI V-Stars Photogrammetry System  to SA by using 
Instrument>Add or the Add Instrument button (Figure 13-60).

Figure 13-60. Adding the V-
STARS system to an SA file.

Instrument Properties for Simulation

By right-clicking on the V-STARS instrument within the SA tree and 
selecting Properties, the properties are displayed (Figure 13-61).
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Figure 13-61. The properties 
of the V-Stars instrument.

Simulation
Contains all the functions and options to perform Photogrammetry 
Simulation.

Network Points
Defines the point and vector groups that will be used during the 
simulation process. Select defines the point and vector groups for 
analysis. The selection process will then show within the SA graphi-
cal view area. First the user will be prompted to select the desired 
point groups. Once all point groups have been specified, pressing the 
Enter key will cause prompting to continue for vector groups. If no 
items of a particular group are desired, simply press Enter to skip. 
Once the desired groups have been specified, the dialog will update 
to show the specified number for each group type.

Camera Parameters
The Camera Parameters dialog (Figure 13-62) provides a means of 
setting the necessary information for field of view display and de-
termining what points are within the field of view. The Incidence Angle 
parameter is used when checking whether a vector is visible within a 
camera’s field of view.
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Figure 13-62. Camera Pa-
rameters.

Camera Network
The Camera Network Configuration dialog provides a means of set-
ting the various options for each camera (Figure 13-63). 

 ■

Figure 13-63. Camera Net-
work Configuration dialog.

Load Cameras. Load a predefined camera network.

 ■ Save Cameras. Save an existing camera network.

 ■ Add Camera. Places a new camera at the current working 
frame and display the transform dialog for the newly added 
camera.

 ■ Field of View ON. Turn on field of view display for the selected 
cameras from the list.

 ■ Field of View OFF. Turn off field of view display for the selected 
cameras from the list.

 ■ Show. Cause the selected cameras to be displayed within the 
graphics view window.

 ■ Hide. Cause the selected cameras to be removed from the 
graphics view display window.

 ■ Highlight ON. Cause the selected cameras to become high-
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lighted within the graphics view display window.

 ■ Highlight OFF. Cause the selected cameras to become de-
highlighted within the graphics view display window.

 ■ Shot Rays ON. Cause the selected cameras to display shot rays 
to their visible measurements.

 ■ Shot Rays OFF. Disable shot ray display for the selected cam-
eras.

 ■ Move. Move the selected cameras about the current working 
frame.

 ■ Delete. Delete the selected cameras.

 ■ Un-Check. Un-check ALL items within the list.

 ■ Check. Check ALL items within the list.

Right clicking on the desired camera within the list will produce the 
menu options in Figure 13-64:

Figure 13-64. Menu options.

Fabricate
Executes the analysis of points/vectors within the field of view of the 
visible camera set. Once completed, the points found to be within the 
unobstructed view of the cameras will be highlighted (Figure 13-65).

Figure 13-65. Fabrication.

Bundle
Performs uncertainty analysis and update the SA graphics and point 
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data with the results. When the button has been actuated, the user 
will be prompted for a filename for the Common Photogrammetry 
File that will be created and used by V-Stars.

Once V-Stars has completed the analysis, the resulting uncertainty 
will be updated within the Common Photogrammetry File and dis-
played within SA (Figure 13-66).

Figure 13-66. Photogram-
metry uncertainties.

Camera Orientation
The X-Axis is shown in red, the Y-Axis in Green, and the Z-Axis in Blue 
(Figure 13-67).

Figure 13-67. Camera orien-
tation.

Note:  V-Stars must be run-
ning before attempting to 

bundle. V-Stars also requires at 
least one camera station to be ro-
tated 90 degrees about the lens 
axis to successfully bundle.
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There are two ways to measure with laser trackers in SA. The first is 
through the conventional laser tracker interface, which provides ac-
cess to advanced functionality and settings and allows complete con-
trol over the instrument, target definitions, and measurement modes. 
The second method is through the simpler Instrument Toolbar, which 
provides an easy-to-use, streamlined approach to laser tracker mea-
surement.

You’ll find that most tracker measurement can be carried out in the 
Instrument Toolbar, which provides accelerated workflow for com-
mon tasks such as discrete and stable point measurement and spatial 
scanning. However, when more control is needed—or when detailed 
settings or profiles need to be created or modified—the traditional 
laser tracker interface provides the ability to work at a deeper level.

We’ll first cover the laser tracker interface in detail, then cover the In-
strument Toolbar.

Laser Tracker Interface
SpatialAnalyzer’s laser tracker interface (Figure 14-1) provides the op-
erator with a great deal of control when measuring with a laser track-
er device. The interface has five main sections: the menu and toolbar, 

Note:  For information on 
starting the laser tracker in-

terface, refer to the Instruments 
chapter.

Laser trackers are prolific portable metrology instru-
ments. They have many uses for both short- and long-
range high-accuracy measurements of both discrete 
and scanned point data. This chapter discusses how to 
properly and effectively measure with laser trackers in 
SA.

Measuring With 
Laser Trackers
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target naming, measurement control, measurement profile control, 
and additional controls.

Figure 14-1. The Laser 
Tracker interface.

 At the top of the interface, an interface docking button toggles 
between docking the interface to the SA window or letting it float as 
a separate window. If the instrument interface is opened without run-
ning SA, or if the interface is run on a machine other than the machine 
running SA, this button is unavailable (as there would be no instance 
of SA on the computer to dock with). If more than one interface is run-
ning, docking an interface will replace any currently docked interface.

Interface Overview

Menus
Use the menus to get to detailed tracker settings, instrument moni-
toring utilities, compensation check routines, and other instrument-
related utilities.
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Toolbar

Figure 14-2. The tracker 
interface’s toolbar.

The toolbar (Figure 14-2) provides buttons for commonly-accessed 
areas of the instrument interface.

Status Indicators
Two colored status indicators (sometimes referred to as traffic lights) 
indicate the current status of the weather station and tracker beam.

Target Naming

Figure 14-3. Naming for 
measured targets.

Controlling target names (Figure 14-3) is an important part of the 
tracker interface.  Use this section to control how measured points are 
named and organized in the SA tree.

Measurement Control

Figure 14-4. Measurement 
buttons.

These controls (Figure 14-4) provide access to the critical measure-
ment commands required for operating a laser tracker, including tak-
ing a measurement, returning the instrument to the home position, 
and setting the active target.

Measurement Profile Control

Figure 14-5. The measure-
ment profile dropdown.

This section (Figure 14-5) allows you to quickly switch to any number 
of predefined measurement profiles. These profiles precisely control 
what’s measured, how it’s measured, and what’s done with the mea-
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surements once they come into the interface.

Additional Controls

Figure 14-6. Additional 
tracker controls.

The additional controls (Figure 14-6) give you the ability to set and 
recall remote home positions, perform ADM locks, drive the tracker 
servos via a variety of different methods, switch to the Laser Tracker 
Toolbar, and navigate an inspection in the SA Toolkit.

Collection/Instrument ID
When an instrument is added to an SA job, it is assigned an index 
number. The index (which, for a given collection, begins counting 
from zero) is used to associate measurements to instruments and also 
to differentiate one instrument from another, since multiple instru-
ments (of the same type) are frequently added to a job to enable mul-
tiple station surveys. The instrument index number is incremented by 
one as each new instrument is added to a collection. This text displays 
the connected instrument’s collection, index number, and name.

Beam Status

The Beam Status indicates both the current state of the laser tracker 
beam, as well as the distance measurement technology being used 
(IFM vs. ADM). There are four possible states:

 ■ Green. The tracker is locked onto the retroreflector, and 
the range data has been set using IFM (Interferometry) 
technology.

 ■ Green/ADM. The tracker is locked onto the retroreflector, 
and the range data has been set using ADM (Absolute 
Distance Meter) technology.

 ■ Yellow. The tracker has locked onto the retroreflector, but 
a valid distance measurement has not yet been attained. 

 ■ Red. The tracker is not currently locked onto the retrore-
flector, and valid range data is not available.

Power Lock
For instruments that support Power Lock, this functionality can be 
toggled on and off by clicking the Power Lock button (Figure 14-7).
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Figure 14-7. The Power Lock 
toggle button.

 

Target Naming

Figure 14-8. The collection, 
group, and target name for a 
measured point is specified 
here.

Each measured point in SA has a collection, group, and target name 
(Figure 14-8). This naming system is used for organizing measured 
data into logical groups. In general, before taking a set of measure-
ments the target naming section should be filled out in order to mea-
sure points into the proper collections and point groups.

Collection
Enter the destination collection name for the resulting targets or ge-
ometries, or select an existing collection from the dropdown. If this 
field is left blank, the measurements will be placed by default into the 
active collection.

Group
To place measured targets into an existing point group, either type 
in the group name or select it from the dropdown. To place measure-
ments into a new group, enter a new name into the field.

 ■ Increment/Decrement. The Increment/Decrement button
allows you to quickly increment or decrement the current 
group name by one. To increment a group, left-click this but-
ton. To decrement, right-click the button. If a group name does 
not have a numeric suffix, one will be added automatically.

 ■ Increment Checkbox. The increment checkbox speci-
fies whether a group name should be automatically increment-
ed at the completion of a measurement profile. If checked, 
then when a measurement profile completes the group name 
will automatically increment by one. Otherwise, the group 
name will not be changed at the completion of a measurement 
profile. This is perhaps most commonly used when measure-
ment profiles are iterated.

Target
Enter a name for a specific target (measured point) into the Target 
field. This target name is automatically incremented after a measure-
ment. If a target name does not have a numeric suffix, one will be 
added automatically. If the increment checkbox is checked 
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next to the Group field, then the target name will reset to 1 after the 
group name has been incremented.

 ■ Increment/Decrement. The Increment/Decrement button
quickly increments (left-click) or decrements (right-click) the 
target name by one. If incrementing and a target name does 
not have a numeric suffix, one will be added automatically.

 ■ Delete Last Point. The Delete Last Point button will delete 
the most recently measured point, if it exists.

 ■ Increment Checkbox. The increment checkbox incre-
ments the point name when enabled, and leaves the point 
name as-is when disable. It is on by default (and is automati-
cally turned back on every time you start the interface). Turn 
this off only if you intend to take multiple observations under 
the same point name.

Measurement Control

Figure 14-9. Controls for 
measurement.

Measure
Triggers the active measurement mode, which can do anything from 
take a single measured point to trigger a scan. The name of the cur-
rently active target in the interface is listed on the Measure button.

Home
The Home button sends the instrument back to its home position and 
attempts to lock on the active reflector. The instrument interface will 
wait until it is able to successfully lock onto the reflector or the op-
erator aborts the process. A successful lock on the reflector sets the 
beam status indicator to a green state.

Some trackers do not have a home position defined. In this case, this 
button will be grayed out.

Target/Reflector Quick Select
Since changing target definitions happens somewhat frequently 
when measuring with a tracker, the target/reflector quick select but-
tons allow you to assign up to four target definitions to quick-select 
buttons. Once defined, a simple left-click activates the new target, 
avoiding the need to navigate into the targets/reflectors dialog to 
activate a different target. For more on target definitions, see Targets 
and Retros below.
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To Assign a Defined Target to a Quick Select Button:

 ■ Right-click the desired button and select the named target 
from the list.

Measurement Profile Control

Figure 14-10. Measurement 
Profile control.

The Measurement Profile dropdown (Figure 14-10) allows you to select 
any of the saved profiles and set it as the active profile. After doing so, 
clicking the Measure button initiates that selected profile. There are 
also four profile quick select buttons, which allow you to easily assign 
a profile definition to each.

To Assign a Defined Measurement Profile to a Quick Select Button:

 ■ Right-click a button and select the desired profile from the list.

For more on measurement profiles, see “Measurement Profiles” on 
page 439.

Additional Controls

Remote Home
A remote iFM home can be established in the laser tracker interface. A 
remote IFM home allows you to define a new “home” position which 
is used by the tracker for seeding the IFM distance value. This new 
position will have a stored IFM distance which will be used to initialize 
the tracker’s range when locking onto this remote home position. The 
major advantage of this capability is that when working in a position 
that makes it difficult or time-consuming to access the tracker home 
position (such as when on scaffolding or far from the tracker), you 
can define a new home position. By pressing the Remote Home but-
ton, the tracker will point to the defined home position and wait for a 
retroreflector. Once a retro is acquired, the IFM distance value will be 
initialized by the stored value.

Note that when a remote home position is specfied the remote home 
button will contain the custom name of the remote home position.

To Define a New Remote Home Position:

1. Click the Set button. The Remote IFM Reset Positions dialog 
will appear (see Figure 14-11).

Warning:  When setting 
remote home positions, 
the tracker should be in 

IFM distance measurement 
mode.

Warning:  When setting a 
Remote IFM position, it is 
very important that the 

position be stable and free from 
vibration. Any movement relative 
to the tracker will increase error in 
the IFM distance measurements.
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2. 

Figure 14-11. The dialog 
used for setting remote hom-
ing positions.

Place the retroreflector into a monument or other stable point 
of reference and click the Add button. The current position 
will be measured and added to the window.

3. Click the Name or Notes fields to add a custom name to the 
remote home position, or a custom note about the position 
(see Figure 14-12).

Figure 14-12. A remote 
home position has been set.

To Set a Remote Home Position as the Active Remote Home:

1. Click the Set button. The Remote IFM Reset Positions dialog 
will appear.

2. Select the remote home position you’d like to activate.

3. Click the Set Selection Active button.

4. Click the OK button. The Remote Home button will list the new 
active remote home position.

To Change How a Remote Home Position is Measured:

1. Click the Set button. The Remote IFM Reset Positions dialog 
will appear.

2. Click the View/Edit Acquisition button.
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3. 

Figure 14-13. Changing 
the remote home acquisition 
method.

In the Remote Reset Acquisiton dialog (see Figure 14-13), 
choose the desired parameters for the remote home mea-
surement. For more details on the specific parameters see 
“Measurement Profiles” on page 439.

4. Click the Save button.

To Point to and Lock on Any Specific Remote Home Position:

1. Click the Set button. The Remote IFM Reset Positions dialog 
will appear.

2. Select the row containing the desired remote home position 
to point at and lock on.

3. Click the Lock on Selection button.

To Delete a Remote Home Position:

1. Click the Set button. The Remote IFM Reset Positions dialog 
will appear.

2. Select any row containing the remote home position to de-
lete.

3. Press the Delete key and confirm the deletion.

To Lock on the Active Remote Home Position:

1. Set the retroreflector into the nest/monument at the current-
ly active remote home position.

2. In the tracker interface, click the Remote button. The tracker 
will point to the remote home position and lock onto the re-
flector.

Find Target
The Find Target button will force the tracker to spiral outward from 
the tracker’s current pointing direction and lock onto the first reflec-
tor that it can find, using the Absolute Distance Meter (ADM) for the 
distance measurement. Once locked, the green beam status indicator 
with the “ADM” label will be displayed, indicating that range has been 
set via ADM.

Note:  Depending on manu-
facturer and proprietary 

methods, some trackers may not 
show the ADM indication after 
locking back on.
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To Lock Onto a Reflector Using ADM:

1. Point the tracker generally toward the reflector you’d like to 
lock onto. The closer the tracker is pointed to the center of the 
reflector, the faster the lock will occur.

2. Click the Find Target button and wait for the tracker to find 
and acquire the reflector.

To Adjust the Search Parameters for ADM Reset:

1. From the interface menu, select Settings>Tracker>General Set-
tings, or click the Settings button in the toolbar.

2. 

Figure 14-14. Changing the 
ADM Reset search parameters.

The General Tracker Settings dialog (Figure 14-14) will appear. 
The ADM Search Parameters section contains the applicable 
settings, which are described below.

 ■ Seed Distance. Coupled with the Radius value, the Seed Dis-
tance is used to calculate the maximum horizontal and vertical 
angles for the tracker’s spiral search. This value is typically set 
to the distance of the most recent measurement. As a general 
rule, if you have trouble locking onto a target, this value should 
be similar to the approximate distance from the tracker to the 
SMR.

 ■ Radius. The outward distance (perpendicular to the line-of-
sight) from the tracker’s starting pointing direction that will be 
searched for a reflector.

 ■ Timeout. If the tracker has not locked onto a reflector within 
this time limit (and if it is still searching), then the search will 
be aborted. This setting allows you to avoid a very long search 
operation if a large radius is used.

Drive Head/OVC
Clicking the Drive Head/OVC button opens a window giving you the 
capability to point the tracker using one of several manual methods, 
such as using the keyboard or mouse (Figure 14-15). If capable, cam-
era-equipped trackers will display a video window when this mode is 
active.
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Figure 14-15. Driving a 
tracker with the keyboard.

To Steer the Tracker to a Target:

 ■ With the Keyboard Drive/ADM dialog open, use the arrow keys 
to move the tracker beam.

Inspection Navigation
Three Inspection Navigation controls are available at the bottom of 
the tracker interface (Figure 14-16). These controls are designed to 
be used while trapping measurements, either as part of an inspec-
tion routine using the SA Toolkit or via other measurement trapping 
methods.

Figure 14-16. The Inspection 
Navigation controls.

The left and right arrows jump to the previous or next feature for trap-
ping, and the stop button stops all trapping operations.

Targets and Retros

When tracker measurements are taken, the planar and radial offsets 
are stored with the measured points. Since laser trackers aren’t aware 
of the target or tooling being used, you need to keep the interface 
informed of which tooling you’re using, so that the proper offsets can 
be assigned to measurements--and so those offsets can be account-
ed for when analyzing to surfaces or fitting geometry. The Targets/
Retros button opens the Reflectors and Targets dialog (Figure 14-
17) and provides the capability for defining new targets.

Note:  This method may vary 
depending on instrument 

manufacturer.
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Figure 14-17. The Reflectors 
and Targets dialog.

This dialog is divided into three main areas: Manufacturer Definitions, 
User Definitions, and Targets.

Manufacturer Definitions
Every laser tracker controller has a set of defined reflectors that the 
instrument supports. For example, trackers commonly support 1.5”, 
0.875”, and 0.5” SMRs, in addition to other peripheral devices. A track-
er needs to know which defined reflector is being used for several 
reasons--one of which is that it tells the tracker which nest to return 
to when homing.

The list of manufacturer definitions is populated automatically when 
you open the dialog. In certain cases, the list may need to be refreshed. 
Clicking the Reload button will poll the controller and retrieve an up-
dated list of manufacturer-defined reflectors. Note that this list may 
also include 6-DOF devices, mirrors, or other peripherals. Note that 
this list cannot be modified, and the selected reflector for the active 
target definition (see below) will be checked.

User Definitions
A user-defined reflector is essentially a manufacturer-defined reflec-
tor that has a custom measured ADM offset and/or a custom home po-
sition. ADM offset correction is applied when the difference in beam 
travel length when comparing the red laser to the ADM signal (due to 
refraction/dispersion) is significant. This is usually the case when the 
reflector has a clear windowed housing to protect the mirror, or when 
the reflective surface of the SMR is not the front face (the beam must 
travel through some material other than air before being reflected). 
ADM offsets apply a small correction to the measured distance value 
to account for the different behavior of ADM-wavelength signals.
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There are two methods to create a user-defined reflector: Add: Copy 
Selected Mfcr Reflector or Add: Measure In Nest.

 ■ Add: Copy Selected Mfcr Reflector. Creates a user-defined 
reflector using the same home position as the selected manu-
facturer reflector when the button is clicked.

 ■ Add: Measure In Nest. Creates a user-defined reflector using a 
custom home position (nest).

To Create a User-Defined Reflector with a Custom Home Position (Non-FARO trackers only):

1. Lock the beam onto your custom reflector and place it into 
the custom nest.

2. From the Targets and Retros dialog, click the Add: Measure In 
Nest button.

3. When prompted, click Yes to measure.

4. A new user-defined reflector will be added to the table.

To Create a User-Defined Reflector Using an Existing Home Position:

1. Select the manufacturer-defined reflector whose home posi-
tion you’d like to use from the Targets and Retros dialog.

2. Place your reflector in the appropriate nest, then click Add: 
Copy Selected Mfcr Reflector.

3. When prompted, click Yes to measure.

4. A new user-defined reflector will be added to the table.

To Delete a User-Defined Reflector:

1. Select the user-defined reflector.

2. Press the Delete key.

To Rename a User-Defined Reflector:

 ■ Double-click the Name field for the user-defined reflector, and 
type in a new name, then press Enter.

To Measure an ADM Offset for a Custom Reflector:

1. Select the desired user-defined reflector in the Reflectors and 
Targets dialog and home on the reflector.

2. Click the ADM Offset Check - Selected Reflector button. The 
ADM Check/Cal dialog will appear (Figure 14-18).

Note:  This option is not us-
able with FARO trackers.
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3. 

Figure 14-18. Measuring 
ADM offset.

If desired, set the measurement parameters for the ADM 
check by clicking on the View/Edit Acquisition button. These 
parameters are similar to the Discrete Point Measurement ac-
quisition settings (see below).

4. Place the SMR in several positions (at least 5) around the de-
sired measurement volume, and click the Measure Current Po-
sition button in each. The tracker will take an IFM and ADM 
measurement, recording the difference for each observation.

5. Applying a threshold (by setting the Threshold setting and 
clicking the Apply Threshold button) will highlight any obser-
vations in which the difference between the IFM and ADM 
measurements exceeds the threshold.

6. To ignore any specific measurement for the ADM offset calcu-
lation, uncheck its Use checkbox. The Home button will send 
the tracker home, and the Closure button will measure closure 
on the tracker.

7. When you feel you have taken sufficient measurements, click 
OK/Apply to apply the calculated ADM offset to the reflector, 
or Cancel to close the window and discard changes.

Targets
The targets section lists all of the defined target configurations for the 
tracker. Target configurations consist of a selected reflector and any 
combination of measurement tooling. This tooling, along with the re-
flector, determines the total offset of your measurements.

For instance, a simple 1.5” SMR is a target configuration, as is a 7/8” 
SMR. A 1.5” SMR with pin nest is also a target configuration, as is a 
6mm retro-probe or point probe. Each of these different configura-
tions has a specified planar offset and lateral, or radial, offset.

After adding a target configuration, it will appear as a row in the Tar-
gets table at the bottom of the Reflectors and Targets dialog (Figure 
14-19).
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Figure 14-19. The new tar-
get definition is in the Targets 
table.

This table has a number of columns that describe the attributes of the 
target:

 ■ Active. The checked target is currently active, and its offsets 
will be applied to any measurements.

 ■ Name. The custom name for the target configuration.

 ■ Reflector/Probe. The manufacturer- or user-defined reflector 
used by the target configuration.

 ■ Probe Radius. The radius of the spherical reflector or probe.

 ■ Extra Planar Offset. An additional offset that is applied in ad-
dition to the probe radius when planar offsets are used (such 
as fitting a plane). The total primary (planar) offset is the sum 
of the probe radius and extra planar offset. For example, when 
using a 1.5” SMR with standard pin nest, the total offset is 0.75” 
(Probe Radius) + 0.25” (Extra Planar Offset) = 1.0”.

 ■ Lateral Offset. The lateral (radial) offset to use when fitting 
circles and ellipses for features such as holes and pins. When 
using a purely spherical probe, the lateral offset is equal to the 
probe radius. For an edge nest, it’s zero--and for a pin nest, it’s 
equivalent to the shank radius.

To Define a New Target Configuration:

1. In the Reflectors and Targets dialog, select the desired manu-
facturer-defined or user-defined reflector from one of the top 
two tables, as appropriate.

2. Click the Add: From Selected Reflector button. The Add Targets 
dialog will appear (Figure 14-20).
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3. 

Figure 14-20. Adding pre-
defined targets.

From the options, pick one or more targets to define, then 
click OK. (For a definition of these options, see below).

4. One or more new target definitions will be added to the Tar-
gets table, depending on the selected items.

When defining a new target, the Add Targets dialog provides several 
shortcuts for common tooling configurations.

 ■ SMR or Probe. Adds a separate target configuration entry for 
the individual probe/reflector only.

 ■ Pin Nest. Adds a target configuration for the selected reflector 
with a pin nest (you define the shank radius and planar offset.).

 ■ Plane Nest. Adds a target configuration for the selected reflec-
tor with a plane nest (you define the planar offset).

 ■ Edge Nest. Adds a target configuration for the selected reflec-
tor with an edge nest (you define the offset).

 ■ 6mm Diameter Probe. Adds a target configuration assuming 
the use of a retro probe with a 6mm diameter probe.

 ■ 3mm Diameter Probe. Same as 6mm Diameter Probe, except 
using a 3mm probe instead of a 6mm probe.

 ■ Point Probe. Same as above, except assuming a point probe 
(no offsets).
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 ■ Probe. Allows you to enter a custom retro probe radius.

In addition to selecting the predefined options, you can also manu-
ally modify the Extra Planar Offset and Lateral Offset columns to use any 
desired numeric value. You may even see negative values. As long as 
you remember that the total planar offset it the sum of the probe ra-
dius and extra planar offset, the numbers should always make sense. 
For example, if 1.5” SMR is the selected reflector for use with a retro 
probe with a point probe, then the probe radius will be 0.75” and the 
extra planar offset will be -0.75”.

To Rename a Target Configuration:

1. Double-click the Name field for the desired target in the Tar-
gets table of the Reflectors and Targets dialog.

2. Type a new custom name, then press Enter.

To Delete a Target Configuration:

1. Select the desired target to delete in the Targets table.

2. Press the Delete key and confirm the deletion.

To Make an Editable Copy of a Target Configuration:

1. In the Targets table, select the target configuration to copy.

2. Click the Add: Copy Selected Target button.

3. A copy of the selected target configuration will be added to 
the table.

To Make a Target Configuration the Active Target:

 ■ In the Targets table, check the Active checkbox next to the target 
configuration you’d like to activate.

Measurement Profiles

Measurement profiles are defined parameters for acquiring data (tak-
ing measurements), operating on that data, and then “doing some-
thing” with that data. For example, the most common and simplest 
measurement profile is one in which clicking the Measure button 
takes a single measured point. But there are many more capabili-
ties, such as stable point or spatial scan acquisition modes, as well 
as many operations that can be performed on data (such as fitting 
geometry, creating cloud points, etc.). Measurement profiles are es-
sentially custom presets. By defining your own custom presets for dif-
ferent tasks, you can easily switch from one profile to another and 
progress through pre-defined measurement profiles without taking 
time on the shop floor to adjust settings. This is most advantageous 
when performing repeated measurements of parts. Clicking the Mea-
sure button initiates a measurement profile, and it concludes when 
the profile is completed.

Tip:  A faster way to activate a 
different target is to use the 

quick-select on the main inter-
face.



440

SPATIALANALYZER USER MANUAL

To edit or define new measurement profiles, click on the View Select-
ed Meas Profile  button. This will open the Meas Profile Parameters 
window (Figure 14-21).

Figure 14-21. The Measure-
ment Profile parameters.

If, after modifying the measurement profile parameters, you decide 
that you’d like to revert to the settings saved to the profile on disk, 
click the Refresh Popped Profile Parameters to Saved State button . At 
the top of the dialog is the name of the profile being viewed. In the 
screenshot above, it’s Single Pt. to SA. There is a Save button to save the 
current settings and overwrite the existing profile, and a Save As but-
ton to save the settings as a new profile.

 ■ Iterate this Profile X times. This setting will repeat the com-
plete profile a given number of times.

To illustrate the profile iteration setting, consider an example in which 
you wish to measure a bolt hole pattern with 24 holes. Suppose you 
set a profile to measure points spaced by 0.1” around a bolt hole, then 
fit a circle and create a point at the center of that circle. Since you’d 
want to repeat that process for the remaining 23 holes, you’d set the 
interface to iterate the profile 24 times and measure the entire bolt 
hole pattern--all requiring you to press the measure button only once.

There are two major sections in the Measurement Profile Parameters 
dialog: Acquistion and Operation. The Acquisition section defines how 
measurement data is acquired, and the Operation section defines 
what is done with that measurement data once it’s obtained. Details 
for these two sections are provided next.
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Acquisition Modes
The acquisition section, as its name implies, determines how mea-
surements are acquired by the tracker. You can measure a single point 
on command, measure points spaced by time or a distance, measure 
points on specified cross sections, and much more. The dropdown 
(Figure 14-22) allows you to specify the acquisition mode to use for 
the current measurement profile. When you select a mode, the pa-
rameters unique to that mode appear, which you can adjust as de-
sired.

Figure 14-22. Choosing an 
acquisition mode.

Each of the default primary acquisition modes is described below. For 
each measurement mode, only the parameters not already discussed 
will be covered.

Discrete Point (Fast/Standard/Precise Point on Leica trackers)

This mode acquires a single point when the Measure button is clicked. 
(For Leica trackers, Fast/Standard/Precise controls the length of time 
that samples are taken, since the sampling frequency is not configu-
rable).

 ■ Points. Specify the number of points you would like to mea-
sure. Leave the value at “0” to continue repeating measure-
ments.

 ■ Samples/Pt. The number of samples to average together in 
calculating a single discrete point. This is particularly useful 
for noisy environments, or cases in which vibration is encoun-
tered. This setting proportionately affects the time required for 
an individual measurement.

 ■ PPM Tolerance. Sets the allowable RMS error for measure-
ments based on the distance of the measurement from the in-
strument. For example, at the default value of 20 PPM, a mea-
surement 7.21m from the instrument would have an allowable 
RMS error of 7.21m × (20/1,000,000) = 144.2 microns. If after 
collecting all samples for the point this allowable RMS is smaller 
than the actual RMS, a Tolerance Exceeded dialog will appear.

 ■ Sampling Frequency. The desired rate at which to take sam-

Note:  The number of sam-
ples cannot be directly con-

figured on Leica trackers.

Note:  Sampling frequency 
on Leica trackers is constant 

and cannot be set explicitly.
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ples, in Hz. If this rate is not achievable by the instrument, the 
closest value will be used. This rate inversely affects the time 
required to take a measurement. A higher frequency will result 
in faster measurement. Note that Sampling Frequency, in com-
bination with the Samples/Pt setting, determines the duration 
of measurement. For example, a discrete point measurement 
at 50 samples/pt and 100 Hz will result in a measurement time 
of 0.5 secs.

 ■ Sample on Controller. Specifies whether the samples are ac-
quired on the tracker controller, or by the instrument interface. 
Acquiring samples on the controller will often permit a higher 
sampling frequency, but since SA does not have access to the 
individual sample data it cannot provide statistical information 
about the samples unless the controller makes it available.

 ■ Front/Back. If checked, each measurement will consist of both 
front and back face measurements.

 ■ Send Ft/Bk Points As. When measuring front face and back 
face, the individual face measurements can be sent as Separate 
Obs, in which case they become two separate observations un-
der the target, or as Single avg pt, in which the front-face and 
back-face measurements are averaged together for a single 
observation.

 ■ Auto-Outlier Rejection. If enabled, SA will perform outlier re-
jection on the samples (see auto-Outlier threshold, next).

 ■ Auto-Outlier Threshold. The sigma value outside of which 
samples should be discarded. When measurement samples are 
collected, SA performs a statistical analysis and determines the 
standard deviation of the measurements. This value, specified 
in sigmas, indicates which samples should be thrown away and 
excluded from the samples used to calculate the average point 
coordinate. For example, a value of 3 indicates that all samples 
outside of 3 sigma should be tossed away.

Stable Point (Fast/Standard/Precise Stable Point on Leica trackers)

Stable Point acquisition mode waits for the reflector to move and 
then become stable again. Once stable for a specified period of time 
(2 seconds by default), a discrete measurement is taken. This cycle is 
repeated for as many points are specified in the profile. This acquisi-
tion mode is especially useful for single-operator environments, be-
cause the measure button only needs to be clicked once for the entire 
profile. (For Leica trackers, Fast/Standard/Precise controls the length 
of time that samples are taken, since the sampling frequency is not 
configurable).

 ■ Stable Space. For stable point measurements, the diameter of 
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a sphere that the probe center must remain inside to be con-
sidered stable for purposes of triggering measurement.

 ■ Stable Time. For stable point measurements, the amount of 
time the probe center must remain inside the stable space to 
be considered stable for purposes of triggering measurement.

 ■ Measure When Beam Found. This option is no longer used.

Spatial Scan

Spatial Scan measures points spaced by a specified distance. Each 
time the reflector moves the prescribed distance from the previous 
measurement, another measurement is triggered. Be aware that 
this distance will not be perfect, as hardware sampling rate, reflec-
tor speed, computer clock speed, network latency, and other factors 
introduce lag between when the prescribed increment is detected by 
the instrument interface and when a measurement is taken.

 ■ Start Trigger. Indicates what trigger is to be used to start the 
measurement profile. After the Measure button is clicked, But-
ton/delay delays the prescribed number of seconds (in delay 
Before Measuring below) before measurement starts. Button/
stable waits for the probe to move, then become stable again 
before triggering measurement.

 ■ Delay Before Measuring. Used when Start trigger is set to But-
ton/delay, the number of seconds to delay before initiating the 
measurement profile.

 ■ Pause @ BeamBreak. If active, the measurement profile will 
be paused if the beam is broken, and resumed when the beam 
is locked again.

 ■ Stop Trigger. Indicates what event is used to signify the com-
pletion of the measurement profile. # points stops measuring 
when the specified number of points is reached. Beam break 
stops measuring when the beam is broken. Loop stops measur-
ing when the target loops back to its original measuring posi-
tion, completing a closed loop.

 ■ Increment. For spatial scanning modes, indicates the desired 
spacing between adjacent measurements.

Temporal Scan

Measurements are triggered at a specified time interval. Due to sam-
pling frequency, latency, and other factors, there will be small dis-
crepancies between actual and requested spacing.

Cross Section

Equally-spaced cross sections  can be established along the X, Y, or Z 
axis of the working frame at a specified distance. These sections trig-
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ger a measurement as the probe crosses the plane.

 ■ Sampling Increment. Indicates the spacing between adjacent 
samples.

 ■ Working Frame Axis. The axis along which the planes should 
be located.

 ■ Axis Cross Value. The position along the specified axis to lo-
cate the cross section.

 ■ Use Closest Point. Indicates whether the closest point to the 
section should be used (raw measurement), or whether a point 
directly on the cross section should be used (interpolated be-
tween the closest point on each side of the plane).

Auto-Sphere

Spatially-spaced measurements will be taken, and when data is seen 
to be spherically distributed, SA will automatically fit a sphere to that 
data.

 ■ Fit Threshold. A set of measured points must fit a sphere to 
better than this value to be considered a valid sphere.

 ■ Lock Radius. If enabled, the resulting spheres must have the 
specified radius.

 ■ Lock Rad Value. Specifies the radius to use when locking.

Geometry Trigger

Planes, cylinders, and spheres can be configured to act as measure-
ment triggers such that when a probe crosses the specified geom-
etry, a measured point is recorded.

 ■ Geometry Triggers. Defines the geometry used to trigger 
measurement in Geometry trigger acquisition. To define trig-
gers, click the None Set box.

The Make Geometry Crossing Triggers dialog will appear when defin-
ing geometry triggers for this mode (Figure 14-23). There are three 
trigger types: planes, cylinders, and spheres. The Select button allows 
you to select existing geometry from the SA file to use as triggers. The 
Cartesian, Cylindric, and Concentric buttons provide options for using 
planes spaced along a Cartesian axis, Cylindrically rotated about an 
axis, or to create concentric cylinders. When draw in Sa is selected, 
the geometry will be physically created in the SA file.

There are two sampling methods for the geometry: Closest pt. and 
interpolate. Closest Pt. uses the closest sample to the geometry as the 
resulting measured point, whereas Interpolate creates a point direct-
ly on the geometry by interpolating between the closest samples on 
each side of the geometry.
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Figure 14-23. Defining ge-
ometry triggers in the tracker 
interface.

When Group Separately (append trigger name) is selected, the mea-
surements will be placed into separate point groups based on the 
specific geometry that triggered them.

Time-Spaced Points

Repeated discrete point measurements are taken spaced by a speci-
fied time. Note that this differs from Temporal Scan in that temporal 
scan has only a single sample per point and assumes that the target is 
in motion. Time-Spaced Points has a configurable number of samples 
and assumes that the target is stationary during the sampling pro-
cess.

 ■ Time Between Points. The time to wait between successive 
discrete measurements.

High Point

Measurement samples are taken, and upon completion of the mea-
surement, only the highest point along a frame axis or the farthest 
point from a frame axis is recorded.

 ■ Working Frame Axis. The axis (x, Y, or Z) to check for a high 
point, and whether the check should be performed along that 
axis or radially from that axis.

Hidden Point

Two points are measured (A & B), and a third (hidden) C point is con-
structed automatically based on the first two.

Warning:  Offset com-
pensation is automatical-
ly applied to the high 

point, and its planar offset is set 
to zero. Points are shifted toward 
the axis when using From Axis and 
in the negative axis direction 
when using Along Axis.
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 ■ Measure Time (secs). The time to measure each point.

 ■ Bottom Pt Offset. The distance from the bottom (B) point to 
the hidden point.

 ■ Planar Offset. The desired planar offset for the resulting hid-
den point.

 ■ Radial Offset. The desired radial offset for the resulting hidden 
point.

Edge Points

Developed primarily for sheet metal work, this mode allows you to 
drag a probe along a flat surface, and when it begins to fall off the 
edge, will create a point on the edge of the surface.

 ■ Edge Plane. Defines the plane that the probe will be slid along.

Operations

Figure 14-24. Specifying the 
tracker interface’s operation.

The operation specifies (Figure 14-24) what to do with the measure-
ments once they are obtained. Here a user can decide whether to 
send the points directly to SA or perform another operation. One ex-
ample is using the “Inside Circle” operation: this will perform a circle fit 
and show the fit dialog prior to sending measurements to SA. The 
advantage of this type of operation is that real-time processing of 
measurements can take place. That is, you can fit geometry to mea-
surements and identify potential problems right at the time of mea-
surement.

The different basic operations are described below. For each opera-
tion, only the parameters not already discussed will be covered.

Send Points to SA

Measured points are sent on to SA to be created as normal measured 
points in the job file. There are no settings for this operation.

Send Updates to SA

SA is updated with the latest measured position and orientation of 
the tracker and probe, but no measurements are created in the job 
file. There are no settings for this operation.

Send Cloud Points to SA

Similar to “Send Points to SA”, except that instead of creating standard 
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measured points, SA creates cloud points. The major advantage of us-
ing this operation is seen when measuring a large number of points 
with a laser tracker (greater than ~20,000). For efficiency purposes, 
best practice when taking large volumes of data is to use cloud points, 
because the metadata associated with normal measured points con-
sumes a large quantity of RAM.

 ■ Buffer Size. The number of points to buffer in the interface be-
fore sending them over the network to SA. Only advanced us-
ers should modify this value, and only with good reason.

Poll Data

Certain trackers take a relatively long time to return a measurement 
update when asked. For applications that operate best with data sup-
plied as close to real-time as possible (such as Trans-Track), you may 
find it preferable to put the tracker into the “Poll Data” operation in-
stead of “Watch Update”, which may yield faster updates.

Make A Circle

A circle is automatically fit to the measured data.

 ■ Show Fit Dialog. When enabled, the geometry fit dialog will 
be displayed at the completion of the measurement profile.

 ■ Send Meas’d Point. When enabled, measured points will be 
sent to SA in addition to the resulting circle.

 ■ Fit Profile. The geometry fit profile to use for fitting the circle. 
Click the box to modify the profile (see the chapter on Geom-
etry Fitting). Right-click to use an existing profile.

 ■ Projection Plane. The data can be automatically projected to 
a plane prior to the circle fit. This is particularly useful when 
fitting a circle to data that may not be measured along a cylin-
der’s cross-section.  For details, see “Projection Planes” on page 
449.

Make A Plane

A plane is automatically fit to the measured data.

 ■ Patch Shift. Shifts the resulting plane an additional amount 
after compensating for probe offset.

Make A Sphere

A sphere is automatically fit to the measured data.

Make A Cylinder

A cylinder is automatically fit to the measured data.

Make A Line

A line is automatically fit to the measured data.

Note:  The Poll Data opera-
tion is only useful for certain 

(usually older) trackers. You only 
need to use it if you find normal 
update rates to be too slow for 
your application.
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Auto Proximity

Used for certain auto proximity automatic measurement modes. 
Sends data to a command in SA to be interpreted.

Single Point Circles

This operation is effective for measuring a hole with a single point. 
With a projection plane defined, place the probe into a hole and take 
a single measurement, and the resulting circle will be created based 
on the probe diameter and the degree to which the reflector sunk 
down into the hole.

 ■ Lock Radius. Forces the circle to be locked to a specified ra-
dius.

 ■ Locked Radius. The radius to use when Lock radius is enabled.

 ■ Intersection Plane. The plane defining the top surface of the 
hole can be selected from an existing plane by left-clicking this 
option, or measured as part of the operation by right-clicking 
this option. For details, see “Projection Planes” on page 449.

Patch Points

Projects all measurements to a specified plane.

3-Plane Point

Creates a point at the intersection of 3 measured planes (such as the 
corner of a box).

 ■ Plane1/Plane2/Plane3. The three planes defining the corner 
to measure. Existing planes can be used by left-clicking this op-
tion, or measured as part of the operation by right-clicking. For 
details, see “Projection Planes” on page 449.

Send Frame Updates to SA

Updates SA on the position and orientation of a frame without actu-
ally creating any frames in the SA job. Offset frames and offset points 
can be sent as well. Sending frame updates requires a 6-DOF device.

 ■ Frames To Send. You can send a raw Frame (the frame from 
the device), an Offset Frame (a frame offset from the raw frame), 
or an Offset point (the origin of an offset frame).

 ■ Offset Frame. Click this parameter to define an offset frame to 
send. For more information, see “Offset Frames” on page 449.

Send Frames to SA

Constructs frames measured from a 6-DOF device in the SA job.

 ■ Frames To Send. In addition to raw Frame, Offset Frame, and 
Offset point (described above), you can also send Both Offsets 
(offset frame and point), Both Frames (raw and offset frames), 
pt. & raw Frame (offset point and raw frame), and all (raw and 

Note:  This operation reduc-
es accuracy when burrs or 

chamfers exist on the hole edge, 
or if the hole is out of round.
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offset frames & offset point).

Projection Planes
Certain operations (such as Make a Circle & Make a plane) allow mea-
surement data to be projected to a plane prior to the operation. Pro-
jection planes handle the settings for this.

To use an existing plane as the projection plane for a measurement operation:

1. Click the box next to projection plane in the operation’s pa-
rameters.

2. Select an existing plane in the SA file.

The projection plane may also be measured as part of the operation. 

To Measure The Projection Plane As Part Of A Measurement Profile:

1. Right-click the box next to projection plane in the operation’s 
parameters. The Plane Options dialog will appear.

2. Pick the appropriate settings (see below), then click OK. The 
plane will be measured as part of the measurement opera-
tion.

 ■ Regenerate in SA. The measured fit plane will be created in 
the SA file.

 ■ Remove from Profile. If this option is checked and you click 
OK, the existing defined projection plane will be cleared.

 ■ Fit To Points. The specified number of points will be gathered 
as part of measurement to define the plane.

Offset Frames
Offset frames allow you to measure a raw frame with a 6-DOF device, 
then send an offset frame or point that is spatially offset from the raw 
frame. The offset frame maintains its relative position and orientation 
to the raw measured frame.

To measure offset frames, you must first measure and construct the 
offset frame itself. This frame will be transformed as part of the op-
eration. Then, you must also measure the raw frame, which defines 
the  delta from the reference to the offset frame. As the raw frame is 
updated and moved, the offset frame will be updated as well.

To Measure Offset Frames:

1. In the Meas Profile Parameters dialog, select a measurement 
operation supporting offset frames (Send Frame Updates to Sa 
or Send Frames to Sa).

2. Select the desired feature to send from the Frames to Send 
parameter.

3. Measure the offset frame.
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4. Click the box next to Offset Frame in the measurement opera-
tion’s parameters. The Offset Frame dialog will appear (Figure 
14-25).

5. Click the 1) Select Offset Frame From SA button and select the 
frame to become the offset frame.

6. Click the 2) Measure Reference Frame To Offset button to mea-
sure the reference frame. The target must be a 6-DOF target.

7. If creating an offset point and you’d like the offset point to 
have a defined probe radius, enter it in the 3) (Optional) Enter 
probe radius for offset point field.

Figure 14-25. Defining an 
offset frame.

8. Begin measuring 6-DOF frames, and the offset frame will be 
updated automatically.

Managing Measurement Profiles
Measurement profiles can be managed (Figure 14-26) by clicking the 
Manage Profiles button in the Laser Tracker Interface. Here you can 
add and delete measurement profiles. Measurement profiles can also 
be imported and exported, allowing them to be transferred to an-
other computer. This also serves as a great way to back up custom 
profiles.

To Delete A Custom Profile:

 ■ Click a profile to select it, then click the Delete button.

To Create A New Profile Using Existing Acquisition/Operations:

1. Click the Add button, then enter a new profile name.

2. In the appropriate dropdowns, select the acquisition and op-
eration to associate with the profile.

To Assign A Quick-Select Button To A  Profile:

 ■ Right-click a profile and select the desired button.

To Export Profiles To A File:

 ■ Click the Export button, then select the desired filename and 
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path for the .MSP file.

To Import Profiles From A File:

 ■ Click the Import button, then select the .MSP file to import.

To Restore Measurement Profiles To Their Defaults:

 ■ Click the Restore Defaults button.

Figure 14-26. Managing 
measurement profiles.

Settings

General Settings
Access to Search Parameters, Action Time Out settings and Tracker-
specific Settings can be reached by clicking the General Settings but-
ton  or by selecting Settings>Tracker>General Settings from the inter-
face menu. This opens the General Tracker Settings dialog (Figure 
14-27).

ADM Search Parameters

 ■ Seed Distance. Specifies the estimated distance to use when 
initiating an ADM search. This is generally updated automati-
cally as measurements are taken and usually does not need to 
be manually modified unless there is large range variation rela-
tive to the last measured point and an ADM search to find a 
target is not successful.

 ■ Radius. The radius from the starting pointing position (at a dis-
tance equal to the seed distance) at which to start searching. A 
larger value will initiate an ADM search over a larger cone.

 ■ Timeout. If a target has not been found after this time has 
elapsed, an ADM search will be cancelled.

Action Time Out

 ■ Get Status. After requesting the tracker’s status, if a response 
hasn’t been received after this time, the request will be can-
celled.
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 ■ Get System Info. After requesting the tracker’s system infor-
mation, if a response hasn’t been received after this time, the 
request will be cancelled.

 ■ Read Weather. If a weather information request hasn’t been 
received by this time, the request is cancelled.

 ■ Set Weather. If a weather set operation isn’t performed by this 
time, the operation is cancelled.

Figure 14-27. General 
tracker settings.

 ■ Send x Pts/Sec. Indicates the frequency at which updates 
should be automatically sent from the tracker to the SA inter-
face, even when not in a measurement.

 ■ Stable Time. Sets the stable time (how long must the probe be 
stable before starting to measure?) used for stable measure-
ment triggering (wait for move, wait for stable). This does not 
apply for Stable Point acquisition mode, which uses its own 
setting.

 ■ Stable Space. Sets the size of a sphere within which the probe 
must remain to be considered stable for stable measurement 
triggering (not used for Stable Point acquisition mode, which 
has its own setting).

 ■ Home At Startup. If disabled, the tracker will not go home 
when the interface is started.

 ■ Sim Settings. The label on this button will change depending 
on the specific instrument connected to the interface. Click it 
to access parameters specific to the connected hardware.

Note:  Some trackers may 
need to home at times, even 

if this option is disabled.
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Units
Click the Units button  to set the active units for the interface(Figure 
14-28). When data is sent from the interface to SA, it is automatically 
converted into the active job units.

Figure 14-28. The tracker 
interface’s Units dialog.

Function Keys
Function keys can be assigned for different operations in the track-
er interface (Figure 14-29). The operations that can be assigned to a 
function key include:

 ■ Measure/Resume

 ■ Watch Data

 ■ Increment Group

 ■ Change Face

 ■ Find Target

 ■ Remote Home

 ■ Home

 ■ Check Closure

 ■ Motors Off

 ■ Motors On

 ■ Decrement Group

 ■ Increment Target

 ■ Decrement Target

 ■ End Acquisition

 ■ Iterate Quick-Select Mode

 ■ Navigation Next

 ■ Navigation Previous

 ■ Navigation Stop

 ■ Remove Last Point

To modify the function keys assigned in the interface, select 

Note:  The instrument inter-
face will not see function key 

presses unless it has focus, so be 
sure to click on the interface prior 
to attempting to use a function 
key.
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Settings>Fcn Keys from the interface menu. The Function Keys dialog 
will appear (Figure 14-29).

To Change An Assigned Function Key:

 ■ Select a new operation from the dropdown for the specified 
function key, then click OK.

To Restore Default Function Key Assignments:

 ■ Click the Restore Defaults button.

Figure 14-29. Defining func-
tion keys in the interface.

User Interface Settings
The verbosity of the tracker interface when displaying certain error 
message can be controlled using the User Interface Settings dialog 
(Figure 14-30), which is accessed by selecting Settings>UI from the in-
terface menu.

Figure 14-30. The User Inter-
face settings dialog.

 ■ Quiet Mode (Turn off all error reporting, etc.). When en-
abled, error messages such as RMS tolerance violations will be 
suppressed.

 ■ Discrete Point Error Report Threshold. This setting controls 
the minimum limit for reporting an error indicating reflector 
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movement during measurement. This error is normally trig-
gered by the ppM tolerance setting in the measurement pro-
file’s acquisition mode, and is based on distance from the 
tracker. However, measurements close to the tracker may trig-
ger this warning even though the data is valid. This lower limit 
suppresses errors below the specified value.

 ■ Discrete Pt RMS Monitor/Measure Indicator. Turns on the 
RMS Monitor (see “RMS Monitor” on page 455).

 ■ No Delete Last Point Confirmation. When enabled, you will 
not be prompted to confirm deletion of points via the delete 
Last point button.

 ■ Translate (change language). The tracker interface can be 
translated using a custom language, just like the SA interface. 
For more information, (see “Language Translation” on page 
150).

RMS Monitor

The RMS Monitor (see “User Interface Settings” on page 454) is a 
window that can remain open and will display atop the SA interface 
when docked. It reports the RMS error for measurements when that 
measurement involves averaging of samples (such as discrete point 
or stable point acquisition modes).

Figure 14-31. The RMS 
monitor indicating an out of 
tolerance measurement.

Two tolerances can be set: warning (yellow) and out (red). The RMS er-
ror of the previous measurement is displayed, along with the proper 
color code, to notify you that the previous measurement may have 
been noisy. The tolerances can be set to your preferred values.

 ■ Don’t Use Out of Tol Pt. When enabled, a point with an out-of-
tolerance RMS value will not be recorded.

 ■ Show x decimal places. Limits the displayed RMS value to the 
specified number of decimal places.
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Beam Autoreset Mode

The behavior when the tracker loses a beam lock can be controlled by 
adjusting the Beam autoreset Mode. There are three modes to choose 
from:

 ■ No Action. When a beam lock is lost, the tracker will just stop 
and not attempt reset. This is generally only used with older 
legacy trackers.

 ■ Auto IFM. When a beam lock is lost, the tracker will home and 
wait to lock onto the reflector in the home position using IFM 
distance measurement (not applicable to ADM-only trackers).

 ■ Auto ADM. When a beam lock is lost, the tracker will stop head 
motion and wait for a beam lock, reacquiring using an ADM 
distance measurement.

To Change the Beam Autoreset Mode:

 ■ From the interface menu, select Settings>Tracker>Beam AutoRe-
set>..., or

 ■ Click the Set Beam Break Behavior button  in the interface to 
toggle between the three modes.

Tracker Pointing Behavior

When pointing a tracker at an existing point, the instrument can be-
have in one of two ways:

 ■ The instrument can point to the point but not attempt an ADM 
reset, or

 ■ The instrument can point and perform an ADM search to at-
tempt to lock onto a nearby target.

To Change Tracker Pointing Behavior:

 ■ From the interface menu, select Settings>Tracker>SA 
Interaction>Point Laser>Point Only or Point and Attempt Reset.

Updating Graphics While Not Measuring

The probe position, current shot line, and instrument graphics are al-
ways updated while measuring, however if you are not in the midst of 
measurement, you can choose whether or not you’d like the graphi-
cal view to automatically update when new data is received from the 
tracker.

This allows you to view updated Watch Windows without requiring 
you to be in any sort of measurement mode, for instance.

To Update Graphics While Not Measuring:

 ■ From the interface menu, enable Settings>Tracker>SA 

Tip:  This option persists pri-
marily for older legacy track-

ers. In general, it’s best to leave 
this option on unless you have a 
good reason to turn it off.
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Interaction>Update Graphics While Not Measuring. Upon doing so, SA 
will begin receiving updates from the connected tracker.

Running “Watch Update” Automatically

Older versions of SA required the tracker to be in an active measure-
ment mode (such as “Watch Update”) in order to receive updates to 
watch windows. This setting will automatically set the tracker to the 
“Watch Update” measurement profile (and initiate measurement) 
whenever a watch window is opened.

To Toggle Automatic “Watch Update” Mode:

 ■ In the interface menu, select Settings > Tracker > SA Interaction > 
Run “Watch Update” When Watch Window Opened In SA.

Measurement Requests

Certain measurement commands, such as auto-Correspond With 
proximity trigger and Measure nominal points, send measurement re-
quests to the instrument interface. When these requests are received, 
the interface needs to know how to handle the request. These settings 
are controlled in one of two windows: Single point parameter Measure-
ment requests and auto-proximity profile Measurement requests.

Single Point Parameters
For commands that request discrete measurements (such as Instru-
ment > Locate > Measure Nominal Points), the measurement settings are 
controlled by the single point parameters. These parameters are iden-
tical to those of the Discrete Point acquisition mode (see “Acquisition 
Modes” on page 441), but apply when measurements are initiated 
from SA itself.

To Access the Single Point Parameters:

 ■ In the interface menu, select Settings > Tracker > SA Interaction > 
Measurement Requests > Single Point Parameters.

Auto-Proximity Profile
For commands that use auto-proximity modes, such as Instrument > 
Automatic Measurement > Auto-Correspond With Proximity Trigger > Points, the 
measurement parameters are controlled by the auto-proximity pro-
file. These commands require some sort of temporal scanning acqui-
sition mode. The specific measurement profile used for these com-
mands can be modified.

To Change the Auto-Proximity Measurement Profile:

 ■ In the interface menu, select Settings > Tracker > SA Interaction > 
Measurement Requests > Auto-Proximity Profile.  Select the desired 
profile from the list.

Tip:  This setting is primarily 
for older legacy trackers. It is 

recommended to leave this set-
ting off and leave “Update Graph-
ics While Not Measuring” on un-
less you have a reason to do 
otherwise.

Note:  Profiles not using a 
temporal scanning acquisi-

tion mode cannot be used.
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The Weather Station

The Weather Station Status indicator (the smaller of the two colored 
lights) gives an indication as to the current status of the weather data 
coming into the interface.

Laser tracker measurements must be compensated using weather 
data to account for factors such as atmospheric index of refraction. 
Without doing so, the tracker’s measurements would not be as accu-
rate. The possible status indicators and their meanings are presented 
below:

 ■ Green. A weather station (whether internal or external) is 
connected and sending data.

 ■ Yellow. The tracker interface is set for manual input. This 
setting compensates measurements using manually en-

tered weather data. The yellow color serves as a reminder that 
this data may need to be updated by hand.

 ■ Red. The tracker’s controller does not have valid weather 
data from an internal or external weather station (whichev-
er is selected). This most likely indicates that the interface is 

not receiving weather data at all. Measurements should not be 
trusted when the weather status is red.

You can indicate whether you’d like weather data to come from the 
tracker’s internal weather station, an external weather station, or via 
manual input.

To Change the Source for Weather Data:

1. Double-click the weather station status indicator or choose 
Devices>Weather>Set Up.  A Weather Source/Settings dialog will 
appear (Figure 14-32).

2. 

Figure 14-32. Setting the 
desired weather source.

Choose the desired source, then click the Set As Active Source 
button. Edit the settings for the current selection if necessary. 
Then click OK/Apply Values to Tracker. The options are listed 
below.
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 ■ Manual Input. Manually-entered weather data (Figure 14-33)
will be sent to the tracker controller to be used for compensa-
tion. This weather data will continue to be used until updated 
manually again. When this option is selected and set as the ac-
tive source, the Edit/Confirm Settings dialog will appear to al-
low you to set the weather values:

 ■

Figure 14-33. Entering 
manual weather data.

Tracker Internal Weather Station. This setting will use the in-
ternal weather station integrated into the tracker. Typically, this 
setting is used when a weather station is either integrated into 
the tracker, or when a weather station connects directly to a 
tracker controller. This is the most common source for tracker 
weather data. When this option is selected, clicking the Edit/
Confirm Settings button will allow you to view the weather sta-
tion’s values, but you cannot change them. After selecting this 
option, click the Set As Active Source button to apply the set-
ting.

 ■ External Weather Station. This setting allows you to use a 
separate, independent weather station device for weather 
data. After selecting this option, you must first click the Set As 
Active Source button. This will bring up the External Weather 
Source dialog (Figure 14-34).

Figure 14-34. Specifying the 
external weather source.

In this dialog, pick the desired device, then click the Connect Selected 
Source button. If connected correctly, the external weather station’s 
values will be fed to the tracker controller for compensation. As with 
the Internal Weather Station setting, the Edit/Confirm Settings button 
will allow you to view (but not edit) the weather station’s values.

You can view the current weather data to monitor the change in tem-
perature, pressure, and humidity since the window was first opened. 
This provides a warning if environmental conditions have changed 
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enough to indicate potentially bad data. The Weather Values/Del-
tas dialog shows this information, and this window can be left open 
while working.

Figure 14-35. Viewing the 
initial and current weather 
data alongside the deltas.

To View Current Weather Information:

 ■ In the interface menu, select Devices > Weather > Current Values/
Deltas.

 ■ Click the Reset button to reset the initial values to the current 
observations.

Level Measurement

Different trackers have a wide variety of highly accurate levels, but all 
perform one function—to accurately read the gravity (level) direction 
at the instrument. This is often used for providing additional informa-
tion for a fit, or constraining a network of instruments during align-
ment.

When a level measurement is recorded, a coordinate frame is created 
on the instrument’s base—the “origin” of the instrument. The Z-axis of 
this frame will be aligned along the measured gravity vector.

Trackers usually position their head in several positions and average 
multiple measurements in an attempt to limit the effect of noise and 
the weight of the tracker head on the level measurement.

Settings
Several settings can be adjusted for level measurement (Figure 14-36) 
which affect how the level measurement is acquired.

To Adjust Level Measurement Settings:

 ■ From the interface menu, select Devices > Level > Set Up.

Note:  Some trackers are not 
equipped with level mea-

surement devices.

Note:  An instrument’s gravi-
ty frame will be associated 

with the instrument and will 
transform along with it.

Note:  These settings vary 
from one instrument to an-

other.
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Figure 14-36. Modifying set-
tings for level measurement.

 ■ Dwell time between. Sets the amount of time the tracker 
waits after positioning the head before taking level samples. 
This gives time for the bubble level to stabilize before measure-
ment.

 ■ Samples per measurement. The number of samples to aver-
age when measuring gravity.

 ■ Deviation Tolerance. Samples that exceed the specified toler-
ance (as a magnitude) are not included in the averaging opera-
tion.

Monitoring Level
Prior to measuring level, the instrument must be manually adjusted 
until the inclinometer is reading in-range for all azimuthal positions 
of the tracker head. The Level Monitor (Figure 14-37) permits viewing 
real-time output from the inclinometer to enable this adjustment.

 ■ Update Rate. Sets the rate at which updates are displayed in 
the interface.

 ■ Show X Decimal Places. Controls the number of decimal plac-
es displayed in the window.

 ■ Alarm. When enabled, the computer will beep and a message 
will be written to the log file when the specified angular toler-
ances are exceeded. The alarm will not sound when this win-
dow is closed.

 ■ Set Baseline. When clicked, the current values become the 
baseline or “reference” for establishing deltas for out-of-toler-
ance determination.

 ■ Display Level Values. The display is updated with raw level 
readings.

 ■ Display Deltas (Threshold). Shows angular deltas instead of 
absolute angular values. The threshold controls the limit that 
sets off the alarm.

Note:  Some instrument 
OEMs have their own win-

dows for monitoring level. SA will 
call these windows up in those 
cases.
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Figure 14-37. Monitoring a 
tracker’s inclinometer.

To Monitor The Tracker’s Level:

 ■ From the interface menu, select Devices > Level > Monitor.

To Measure Level With A Tracker:

1. Ensure the tracker is equipped with an inclinometer or other 
leveling device.

2. After setting up the instrument on a stable mount, monitor its 
level indication by selecting Devices > Level > Monitor from the 
interface menu.

3. Manually adjust the tracker (using body or tripod adjust-
ments) until the monitor consistently reads in-range for all 
azimuthal positions of the tracker head.

4. Close the level monitor and initiate measurement by select-
ing Devices > Level > Measure from the menus.

Monitoring Part Temperature

Some trackers are equipped with part temperature sensors which al-
low you to compensate for thermal expansion or monitor the part 
temperature and take action if environmental conditions might gen-
erate invalid measurements.

The Part Temperature dialog (Figure 14-38) is used for this purpose, 
and can be kept on-screen if desired.

 ■ Update Rate. Sets the rate at which updates are displayed in 
the interface.

 ■ Show X Decimal Places. Controls the number of decimal plac-
es displayed in the window.

 ■ Alarm. When enabled, the computer will beep and a message 

Warning:  Inclinometers 
are advanced bubble lev-
els—they have angular 

limits beyond which the level is 
no longer accurate. Ensure that 
the inclinometer is within range 
by monitoring the level and man-
ually leveling out the instrument 
prior to attempting to measure 
level from the interface.

Warning:  The tracker 
must be mounted to a 
stable, motionless base in 

order to acquire accurate level 
measurements.
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will be written to the log file when the specified temperature 
thresholds are exceeded. The alarm will not sound when this 
window is closed.

 ■ Set Baseline. When clicked, the current temperature reading 
become the baseline or “reference” for establishing deltas for 
out-of-tolerance determination.

 ■ Display Temperature Values. The display is updated with raw 
temperature readings.

 ■ Display Deltas. Shows the change in temperature from the 
baseline instead of the current temperature. The hi and Lo 
thresholds control the limits that set off the alarm.

Figure 14-38. Monitoring a 
part’s temperature.

Instrument Checks

The SA tracker interface has a number of check routines to verify per-
formance of the tracker. It is important to note that none of these 
checks in the interface actually modify the compensation values for 
the tracker. The instrument manufacturer knows best how to com-
pensate their own instrument, so actual modifications are performed 
in the OEM’s tracker compensation software.

Two Face
The Two Face check (Figure 14-39) gives an indication of orthogonal-
ity of the azimuth and elevation axes in the tracker. It measures dis-
crete positions from both the front and back faces, and presents the 
angular discrepancies in each measurement pair.

It is generally recommended that this check be performed with the 
instrument using IFM measurement mode to minimize distance error, 
although the primary purpose of this check is to gauge errors in the 
azimuth and elevation readings between the front and back faces. In-
strument manufacturers provide recommended passing thresholds 
for instrument operation.

Warning:  The thresholds 
are temperature values, 
not delta values.

Warning:  SA tracker in-
terface checks are purely 
to gauge performance of 

the tracker. No actual compensa-
tion is applied to the instrument 
based on the checks.
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 ■ Check Current Location. Takes a front- and back-face mea-
surement at the current reflector position.

 ■ View/Edit Acquisition. Provides control over how the mea-
sured point is acquired.

 ■ Threshold. Angular values exceeding the provided delta 
threshold will be marked as out of tolerance.

 ■ Apply Thresholds. Click this button to apply the specified 
thresholds to the data.

 ■ Warning Band. A percentage of the threshold that triggers a 
warning indication.

 ■ Home. Homes the tracker.

 ■ Remote. Sends the tracker to the defined remote home posi-
tion (if defined).

 ■ Closure. Initiates a closure check. (Checks the current position 
of the target against the home position).

 ■ OK/Log. Writes results to the log and closes the window.

Figure 14-39. The Two Face 
check.

To Perform A Two-Face Check In SA:

1. From the interface menu, select Check/Cal > Two Face.

2. Home the tracker by clicking the Home button (IFM-enabled 
trackers only).

3. Track the target out to a puck and set it down.

4. Click the Check Current Location button. The tracker will ac-
quire front and back measurements, then report the devia-
tions between the two.

5. When finished, click OK/Log to log the results.

ADM Check
An ADM check is used to measure the difference between corre-
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sponding IFM and ADM distance measurements. A new ADM offset 
can be created and applied to a given reflector.

To Initiate an ADM Check:

1. From the interface menu, select Check/Cal > ADM.

2. For more information, refer to “User Definitions” on page 434.

IFM Check
IFM checks validate IFM distance measurements using a two-station 
method or scale bar. The check geometrically eliminates error based 
on expected birdbath position to give an indication of IFM distance 
error. All measurements must be obtained in IFM distance mode.

In the two-station check, two reference points are mounted in a fixed 
location. The tracker is placed between the two points (as close to the 
line connecting them as possible), and each reference point is mea-
sured. The tracker is then moved to a new position outside of both 
reference points, and the two points are measured again. Geometri-
cally, one of these sets of measurements includes IFM error, whereas 
the other does not. The check involves determining the difference be-
tween both sets of measurements.

In the Scale Bar check, the tracker is only set up between the refer-
ence points, and the reference length of the scale bar is used as the 
baseline. The difference between the measurements and the scale 
bar length indicates IFM error.

To Perform an IFM Check:

1. From the interface menu, select Check/Cal > IFM.

2. Place the desired reflector in the home nest.

3. In the Reflectors and Targets dialog, selected the applicable 
reflector and click the IFM (Home Distance) Check - Selected 
Reflector button.

4. When the IFM (BirdBath) Check/Cal dialog appears (Figure 
14-40), click the button appropriate to the check method 
you’d like to use.

5. Measure the points as indicated by the dialog.

Figure 14-40. Performing an 
IFM check.



466

SPATIALANALYZER USER MANUAL

Drift Check
Use this check to create a database of points for monitoring drift. SA 
keeps track of the nominal points, and when remeasured the deltas 
(as well as the distance measuring mode) are displayed (Figure 14-41).

Figure 14-41. Performing a 
drift check.

 ■ Add. Adds a drift reference point to the set and measures its 
baseline position.

 ■ Measure. Measures the selected reference point.

 ■ ADM Measure. Measures the selected reference point using 
ADM distance mode.

 ■ Point At. Points at the selected reference point.

 ■ Clear. Clears the reference points from the list.

 ■ Home. Homes the tracker.

 ■ Remote. Sends the tracker to a remote home (if defined).

 ■ ADM Reset. Searches for the target using an ADM search.

 ■ ADM Drive. Use to drive the tracker head to a specific position.

 ■ View/Edit Acquisition. Modifies the parameters used for ac-
quiring the drift measurements.

 ■ OK/Log. Closes the dialog and writes the results to the log file.

To Perform a Drift Check:

1. From the interface menu, select Check/Cal > Drift.

2. Click Add to add each reference point to the list, entering a 
name and measuring the point in the process.

3. At some point in the future, reopen the dialog, select a point, 
and click Measure. The deltas and distance measurement 
modes will be displayed for inspection.

4. When finished, click OK/Log to write the results to the log file.
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Closure Check
The closure check (Figure 14-42) compares the measured home posi-
tion to the defined home position.

 ■ Recheck. Measures the reflector in the nest and compares the 
measured position to the reference position.

 ■ Log. Writes the results to the log file.

 ■ View/Edit Acquisition. Provides access to the discrete point 
parameters for measuring the point.

Figure 14-42. The Closure 
check.

To Perform a Closure Check:

1. Place the selected reflector into the home position (birdbath).

2. From the interface menu, select Check/Cal > Closure.

3. In the Closure Check dialog, click the Recheck button. The 
tracker will home on the reflector and take a measurement. 
Deviations should be very small.

Reflector Center Check
SMRs do not perfectly center the beam inside the sphere. Therefore, if 
the centering is slightly out, then taking multiple measurements while 
rotating the SMR in a nest will yield measurements that move slightly 
(runout). This test is particularly important if an SMR is dropped or 
jostled. It may appear fine, but the adhesive and reflective surfaces 
may have shifted on impact, putting the reflector out of tolerance.

Reflector center checks are carried out in the Reflector Center Check 
dialog (Figure 14-43). An initial measurement baseline point is ac-
quired, then the test is started. Measurements are taken periodically 
as the SMR is rotated in the nest (ideally no rotation occurs while a 
specific point is being measured). 

 ■ Set Baseline. Measures the initial reference point for compari-
son.

 ■ Edit Baseline Acquisition. Defines how the baseline (refer-
ence) point is acquired.

 ■ Edit Main Acquisition. Defines how the comparison points 
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are acquired.

 ■ Show X decimal places. Indicates the number of decimal plac-
es to show in the results.

 ■ Cartesian. Displays the results in Cartesian Coordinates.

 ■ Polar. Displays the results in Polar Coordinates.

 ■ Measure at X second intervals. Indicates how frequently 
measurements are taken.

 ■ Save Results. Stores the results to the log file.

 ■ View Results. Shows the results of the test.

 ■ Clear Results. Removes test results to prepare for a new test.

 ■ Start. Initiates measurement of the reflector. 

Figure 14-43. Performing a 
reflector center check.

To Perform a Reflector Center Check:

1. Place the reflector into a stable drift nest.

2. From the interface menu, select Check/Cal > Reflector Center Check.

3. In the Reflector Center Check dialog, click the Set Baseline but-
ton.

4. Click the Start button to begin measurement.

5. Between each measurement, rotate the reflector in the nest. 
The current and largest deltas relative to the baseline will be 
reported.

6. Click Stop when finished.

7. Click Save Results to log the results of the test.

Manufacturer-Specific Checks
The interface provides a convenient link to the manufacturer-provid-
ed checking and compensation routines. These compensation rou-
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tines are the only place where true modifications to the instrument’s 
compensation parameters are made.

To Access the OEM-Specific Checking & Compensation Routines:

 ■ From the interface menu, select Check/Cal > Tkr Specific (Mfcr).

Tracker Utilities

System Information
The System Information dialog (Figure 14-44) displays diagnostic 
tracker information, such as the SA tracker driver version, firmware 
and serial number, and OEM driver version information. This is pri-
marily useful when diagnosing issues with SA customer support.

Figure 14-44. The tracker’s 
vital system information.

To Display The Tracker’s System Information:

 ■ From the interface menu, select Utility > System Info.

Restarting the Laser Tracker
If you experience unexpected behavior, you can perform a warm (non 
powered-off) reboot of the tracker controller.

To Perform a Warm Reboot of the Tracker Controller:

 ■ From the interface menu, select Utility > Tracker Utilities > Restart 
Tracker.

Reinitializing the Laser Tracker
You can issue a command from the tracker interface to reinitialize a 
laser tracker. The specific tasks performed during an initialization of a 
tracker are manufacturer-specific, but in general this can help resolve 
some accuracy and tracker performance issues.

To Reinitialize the Laser Tracker:

 ■ From the interface menu, select Utility > Tracker Utilities > Reinitial-
ize Tracker.

Note:  This is not available 
on all tracker brands.
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Manufacturer-Specific Utilities
You can access manufacturer-specific utilities directly through the 
tracker interface.

To Access OEM-Specific Utilities

 ■ From the interface menu, select Utility > Tracker Utilities > Tracker 
Specific.

Tracker Status
You can view the overall status and health of the laser tracker by view-
ing the tracker’s status (Figure 14-45). This typically includes informa-
tion such as battery state of charge, ADM/IFM beam intensity, servo 
motor status, and other diagnostic functionality.

Figure 14-45. The tracker 
status dialog for an API Radian 
tracker.

To View a Tracker’s Status:

 ■ From the interface menu, select Utility > Tkr Status.

Current Position
In the Current Position dialog (Figure 14-46), you can view the current 
position of the reflector in both Cartesian Coordinates (expressed rel-
ative to the working frame in SA) or Spherical Coordinates (expressed 
in the tracker’s native frame).

Note:  The information dis-
played in the tracker status 

dialog depends on the specific 
instrument in use.
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Figure 14-46. Live data from 
the tracker.

Importing Spherical Data

Occasionally, you may have measured data from a tracker that has 
been exported to an ASCII file. If this data is in spherical format (con-
tains azimuth, elevation, and distance components), it can be im-
ported and associated with a tracker. These imported points are auto-
matically treated as measured points (although they will not have any 
measurement metadata). The import dialog is shown in Figure 14-47.

Figure 14-47. Settings for 
importing spherical data to a 
tracker.

 ■ Format. Choose the appropriate format for the source 

Note:  Currently, if source 
data is delimited by com-

mas, it will not import. The data 
must be delimited by spaces or 
other whitespace.
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data.

 ■ Distance Units. The length units for the source data.

 ■ Comment Character(s). Any lines starting with any of the 
provided characters are considered to be comments and 
are ignored.

 ■ Angle Units. The angular units for the source azimuth and 
elevation angles.

 ■ Azimuth is Counter-Clockwise. Specifies that the data 
was recorded on a tracker whose azimuth direction in-
creases as the head rotates counter-clockwise as viewed 
from above.

 ■ Azimuth is Clockwise (reversed). Specifies that the 
source data comes from a tracker whose horizontal angle 
increases as the head rotates clockwise as viewed from 
above (not common).

 ■ Vertical Angle is Zenith (0 is vertical). Indicates that the 
source spherical coordinate system has 0° pointing straight up 
(zenith referenced).

 ■ Vertical Angle is Elevation (0 is horizontal). Indicates that 
the source spherical coordinate system has 0° level with the 
horizon.

 ■ Write Resulting Cartesian Data to a Text File. Upon import, 
the points will be written out to a text file in Cartesian coordi-
nates.

 ■ Collection. The destination collection for the points.

 ■ Group. The destination group for the points.

 ■ First Target. The name for the first target. This name will be in-
cremented for following targets. If the source data already has 
point names, this field is ignored.

To Import Polar ASCII Data:

1. From the interface menu, select Utility > ASCII Import.

2. Select the source file from the browser.

3. Choose the appropriate format, units, and options for the im-
port, then click OK/Import.

Streaming Tracker Data Over The Internet

The tracker interface has the capability of streaming real-time mea-
surement data (3-DOF or 6-DOF) over the internet, using UDP (User 
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Datagram Protocol) broadcasting. Unlike TCP/IP network communi-
cations, UDP broadcasting does not require “handshaking” for data 
transmission. There is no guarantee that transmitted data is received, 
and  it can be broadcasted “into the wild” so that any network device 
can listen to the broadcast.

UDP Data Streaming opens a vast array of possibilities for harnessing 
tracker data in custom ways. For example, you can write applications 
to intercept this tracker data and perform custom analysis for hard-
ware control, or you could even write your own watch window.

There are a few limitations to keep in mind with regard to UDP Data 
Streaming:

 ■ Data flows only in one direction—from the interface. You can-
not transmit commands to the tracker interface.

 ■ Data transmission is of course subject to some finite amount of 
latency. It will not be received “real-time” in a hardware sense.

Tracker data is transmitted as an ASCII-formatted packet. The format 
of the packet is dependent on settings in the SA UDP Data Stream 
Properties dialog (Figure 14-48).

Figure 14-48. Properties for 
setting up UDP Data Stream-
ing from the tracker interface.

 ■ 3D Coordinates. Transmits 3-DOF (XYZ) data.

 ■ 6D Transformations. Transmits 6-DOF (XYZ, RXRYRZ) data.

 ■ Frame of Reference. Data can be transmitted relative to the 
instrument frame, the Working frame, or the World frame.

 ■ Instrument Time Stamp (seconds). If the instrument sup-
ports it, time stamps can be transmitted along with the data. 
This is often an approximately millisecond-accurate timestamp 
from the tracker hardware indicating when the measurement 
was taken.
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 ■ Send To. The broadcast packets can be sent to the entire Sub-
net (Broadcast) or to a Single destination. In the former case, 
data is transmitted “to the wild” for any and all devices on the 
appropriate subnet to receive. In the latter, the data stream is 
routed to a specific IP address on the network.

 ■ Computer Name or IP. Enter the IP address or computer name 
for the destination device (if broadcasting to a Single destina-
tion).

 ■ Port. Every UDP broadcast must be directed to a destination 
port. This is the port on which the receiving device must listen 
for the appropriate broadcasts.

Viewing The Upcoming Group and Target

When working with a tracker a long distance from the computer, it is 
difficult if not impossible to read the name of the next target that will 
be measured. Although this problem is addressed by the SA HUD set-
tings, you can also  open up a Group and Target dialog.

Figure 14-49. Viewing the 
upcoming group and target to 
measure.

This dialog can be resized and positioned anywhere on screen, and 
will always display the group and target of the point that is about to 
be measured.

To View the Group and Target Window:

 ■ In the tracker interface, click the button encompassing the 
Group: and Target: labels (Figure 14-50).
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Figure 14-50. The Group and 
Target button.

Instrument Toolbar
The Instrument Toolbar (Figure 14-51) is a greatly-streamlined version 
of the laser tracker interface. Once properly configured, you’ll likely 
find that the majority of your measurement work can be performed 
in this simpler interface.

Figure 14-51. The Instru-
ment Toolbar for laser trackers.

To access the Instrument Toolbar from the tracker interface, click the 
Switch to Instrument Toolbar button . To switch from the Instrument 
Toolbar back to the tracker interface, click the Switch to Instrument 
Interface button .

The different functions of the Instrument Toolbar are described be-
low.

Beam Status

A colored light (similar to the “traffic light” in the laser tracker inter-
face provides feedback on beam state and measurement status. The 
different statuses indicated by the light are as follows:

Locked. The beam is locked on the target and valid distance 
information is being received.

Measuring. The tracker is currently measuring. (A glowing in-
dicator spins in this mode).

No Valid Distance. The tracker is tracking the reflector, but a 
valid distance measurement is not available.

No Lock. The tracker does not have a lock on the reflector.

Waiting for Lock. A measurement mode has been initiated, 
but SA is waiting for a lock on the beam. (A glowing indicator spins 
in this mode).

Waiting for Move. A stable point measurement trigger is be-
ing used, and SA is waiting for the reflector to move. (A glowing 
indicator spins in this mode).

Waiting for Stable. A stable point measurement trigger is be-
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ing used, and SA is waiting for the reflector to stabilize. (A glowing 
indicator spins in this mode).

Clicking on the beam status light will initiate a reflector search to lock 
on a target. It is equivalent to the Find Target button in the laser track-
er interface.

Homing the Tracker

Click the Home button  to send the tracker to the birdbath for the 
currently-active reflector. This icon not available for trackers that have 
no home nest.

Driving the Tracker

Click the Drive Beam button  to drive the tracker head to the desired 
position. Drive operation is tracker-specific and described in “Drive 
Head/OVC” on page 432.

Toggling Motors

For instruments that support it, you can engage and disengage the 
tracker head motors by toggling the Motors button . (This icon is 
not shown for instruments that do not support motor toggling).

Tilt Compensation

Some instruments support tilt compensation. When turned on, the 
instrument automatically adjusts all measurements such that the 
standing axis of the instrument in SA is aligned with gravity. (That is, 
the instrument’s internal reference frame is always oriented to grav-
ity). For instruments that support this, the motor toggle button (see 
“Toggling Motors” on page 476) is replaced by a tilt compensator 
toggle button . Clicking this button toggles tilt compensation on 
and off.

Active Target

You can select the active target by clicking on one of the target quick-
select icons (Figure 14-52).

Figure 14-52. The target 
quick-select buttons.

The reflectors are defined in the laser tracker interface (see “Targets 
and Retros” on page 433) or can be defined directly from the tracker 
toolbar. Right-clicking any of the four quick-select buttons will allow 
you to assign a different tooling definition to the button. You can also 
select define new target from the drop-down to create a new tooling 
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definition.

Hovering the mouse cursor over a button momentarily will show a 
tooltip indicating the name of the target, and the offset (diameter if 
spherical, planar and radial if not) is displayed next to the quick-select 
buttons (Figure 14-53).

Figure 14-53. The planar and 
radial offsets are displayed, 
along with a target name 
tooltip.

Point Naming

The name of the next measured point is displayed above the target 
quick-select icons. To change the name of the next selected target, 
click this field. This will open the Instrument Interface Point Naming 
dialog, allowing you to type a new collection, group, and target name.

Measurement Modes

The Instrument Toolbar has eight buttons, each corresponding to a 
specific measurement mode (Figure 14-54).

Figure 14-54. The measure-
ment mode buttons.

The first four buttons are assigned to Single Point, Stable Point, Spa-
tial Scan, and Tooling Ball measurement modes, respectively:

 ■ Single Point. Measures a discrete point when clicked.

 ■ Stable Point. Waits for the reflector to move—then become 
stable—before measuring the point.

 ■ Spatial Scan. Initiates a spatial scan measurement. The incre-
ment can be set by right-clicking the button.

 ■ Tooling Ball. Initiates a spatial scan measurement, then fits a 
sphere to the points and creates a center point on the sphere. 
Both the spatial scan increment and the radius of the sphere fit 
can be controlled by right-clicking the button.

The last four buttons (denoted by the silhouette icons) are user-de-
fined measurement modes. You can assign any measurement mode 
you’ve created in the laser tracker interface to these buttons by right-
clicking them.

Measurement modes can be initiated with or without a beam lock. If 
started without a beam lock, SA will wait for a beam lock before start-
ing measurement. While in a measurement mode, press the button 
again to stop the measurement mode.
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To access a few additional parameters related to the first four mea-
surement modes, right-click the target button.

Alarms

The Alarm button  allows you to set a number of thresholds that will 
trigger an alarm while measuring. An alarm is intended to notify you 
that a measurement may not be trustworthy. High and low threshold 
alarms can be set for the following parameters:

 ■ Air Temperature. If the specified air temperature range is vio-
lated, the alarm will trigger.

 ■ Air Pressure. If the specified pressures are violated, the alarm 
will trigger.

 ■ Humidity. If the ambient humidity exceeds the specified 
thresholds, the alarm will trigger.

 ■ Part Temperature. If the part temperature (if the instrument is 
equipped) exceeds the specified threshold, the alarm will trig-
ger.

 ■ Level. If the specified level range is violated (if the instrument 
is equipped with an inclinometer), the alarm will trigger.

 ■ RMS. Turning on the Discrete Point RMS Monitor checkbox will 
display a warning if the Warning threshold is exceeded. The 
point will not be measured if the Out Level value is exceeded.

When an alarm is triggered, the alarm button will turn red and a blink-
ing exclamation mark will appear.

Operational Checks

Clicking the Operational Checks button will take you to the manufac-
turer’s operational checks.
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The Portable CMM Arms interface (Figure 15-1) provides unified ac-
cess to all measurement parameters associated with measurement 
using a PCMM arm. The arm interface is divided into three primary 
sections: Target and Geometry Naming, Measurement Modes, and 
Settings.

At the very top of the interface, an interface docking button tog-
gles between docking the interface to the SA window or letting it 
float as a separate window. If the instrument interface is opened with-
out running SA, this button is unavailable (as there would be no in-
stance of SA on the machine to dock with). If more than one interface 
is running, docking an interface will replace any currently docked in-
terface.

Portable arms are ideal instruments when measuring 
small volumes where high accuracy is required and 
line-of-sight measurements are difficult to achieve. This 
chapter discusses how to properly and effectively mea-
sure with portable CMM arms in SA.

Measuring With 
Arms
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Figure 15-1. The portable 
CMM arm interface.

Target & Geometry Naming

Figure 15-2. Target and 
geometry naming.

The Target & Geometry Naming section (Figure 15-2) is used to define 
how measured targets and constructed geometry will be named.

Collection

Measured targets and geometry constructed by the instrument inter-
face are sent to SA. The Collection field is where you specify the des-
tination collection for measured entities. If a collection name is not 
specified, entities are by default placed into the active collection.

Group Name

The point group name for measured targets is specified in the field 
next to the “G”. To assign measured targets to a specific group, en-
ter the name into the field. To assign measured targets to an existing 
point group, select it from the drop-down list, which shows all point 
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groups in the active collection.

To Increment the Current Group Name:

 ■ Left-click the button.

To Decrement the Current Group Name:

 ■ Right-click the button.

Target Name

Target naming is managed in the field next to the “T”. Enter the de-
sired target name in this field. After each measured target, this name 
will automatically increment by one.

To Increment the Current Target Name:

 ■ Left-click the button.

To Decrement the Current Target Name:

 ■ Right-click the button.

Geometry Name

The arm interface supports real-time geometry construction. The 
Geom field is used to name this constructed geometry. After each 
geometrical entity is constructed, this name will automatically incre-
ment.

Button Control

The SA Arm interface supports the use of button commands from 
the buttons equipped on the Portable Arm. These buttons can be as-
signed different functions in the Edit Arm Settings window. One com-
mon use of the arm buttons is to move through the different mea-
surement modes, which makes it possible to change measurement 
methods without the need to return to the computer keyboard. (The 
SA ArmPad enhances this functionality even further).

Measurement Modes

Measurement modes are extremely powerful and functional. They al-
low a user to take measurements and process data in one step. The 
arm interface supports 17 different measurement modes: Discrete 
Points, Stream Points, Patch (Projected Pt.), Pin, Hole, Slot, Line, Circle, 
Plane, Sphere, Section Cross, Frame, Batch (Guided Points), Scanner, 
Average Discrete Points, Geometry Trigger, and Cone. A special meth-
od for selecting measurement modes can be accessed as well. These 
modes are discussed below.

Discrete Points
Discrete Points mode is used to take individual measurements (Figure 
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15-3). When in this mode (signified by the appearance of the Points 
Measurement window below), the assigned Record button will take 
a measurement, and the assigned Delete Last button will delete the 
last measured point (if applicable). Point names will be incremented 
and decremented automatically.

Figure 15-3. This window 
indicates you are in discrete 
point measurement mode.

To manually increment/decrement the group or point name, left- or 
right-click the or buttons.

When finished with this mode, press the assigned Accept or Cancel 
buttons on the arm--or click the Done button--and the Points Mea-
surement window will close, returning you to the interface.

Stream Points
Stream Points mode is used to take measured data at specific spatial 
or temporal increments (as specified in the Edit Arm Settings window). 
It is extremely important to recognize that the actual measured data 
will not be spaced by the specified increments exactly--the increment 
will be limited by such factors as the hardware’s measurement update 
speed, the connection speed between the instrument and SA, the 
computer’s performance, and the speed at which the probe is moved.

Figure 15-4. Streaming 
points temporally to the 
interface.

When in this mode (signified by the appearance of Figure 15-4), press-
ing the assigned Record button will begin or continue measurement, 
and the assigned Delete Last button will pause measurement.

To manually increment/decrement the group or point name, left- or 
right-click the or buttons.

When finished with this mode, press the assigned Accept or Cancel 
button--or click the OK button--and the Stream Points Measurement 
window will close, returning you to the interface.

Note:  The title of the mea-
surement mode window will 

either say TEMPORAL or SPATIAL, 
depending on the currently se-
lected mode.
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Patch (Projected Pt.)
Patch (Projected Pt.) mode (Figure 15-5) will project measured points 
to a plane, with an optional offset (set in the Edit Arm Settings win-
dow). After starting this measurement mode, you can either select a 
plane to project to (by clicking the Select button) or you can measure 
plane points yourself by pressing the assigned Record button. Statis-
tics for the measured plane will be displayed as you measure points. 
Note that you can delete a measured point by pressing the assigned 
Delete Last button, and the plane will automatically re-fit.

Figure 15-5. Patch projected 
point measurement.

When you’ve defined the plane, press the default Accept button to 
accept it. Every subsequent measurement will be projected to the se-
lected plane (or offset plane). The projected point’s coordinates will 
be displayed in the window with each measurement. When finished, 
press the assigned Accept or Cancel button--or click the Done button-
-and you will be returned to the interface.
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Pin

Figure 15-6. Pin measure-
ment mode.

Pin mode (Figure 15-6) will project measured points on the outside of 
a cylinder to a plane, and create a circle representing the pin diame-
ter. This is useful for determining, for example, the diameter of a pin. 
When in this mode, you first define the plane to which you’d like to 
project. As in Patch (Projected Pt.) mode, you can either select a plane 
to project to (by clicking the Select button) or you can measure plane 
points yourself by pressing the assigned Record button. Statistics for 
the measured plane will be displayed as you measure points. Note 
that you can delete a measured point by pressing the assigned Delete 
Last button and the plane will automatically re-fit.

Once the plane is defined, press the assigned Accept button to accept 
it. Subsequent measurements should be taken around the outside 
of cylindrical geometry (such as a pin or shaft), and these measured 
points will be projected to the defined plane. Once 3 measurements 
have been taken, statistics for the constructed circle (radius, fit error, 
etc.) will be displayed. To accept the Pin measurement, press the as-
signed Accept button or click the Accept Pin button. To cancel geom-
etry creation, press the assigned Cancel button or click Cancel.

You can right-click this measurement mode button in order to in-
spect a pin feature that already has nominal geometry in your file. The 
inspect mode will compare your measured feature to the geometry 
selected as the reference. To inspect a pin, first right-click on the Pin 
button. When prompted, choose the circle to inspect. You’ll then be 
prompted to measure plane points. After measuring and accepting 
the plane points, you’ll be prompted to measure the pin itself. When 
complete, and after pressing the assigned Accept button, you’ll get a 
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comparison of feature characteristics (Figure 15-7).

Figure 15-7. Comparison 
results.

Hole
Hole mode (Figure 15-8) will project measured points on the inside of 
a hole to a plane, and create a circle representing the hole diameter. 
When in this mode, you first define the plane to which you’d like to 
project. As in other modes, you can either select a plane to project 
to (by clicking the Select button) or you can measure plane points 
yourself by pressing the assigned Record button. Statistics for the 
measured plane will be displayed as you measure points. Note that 
you can delete a measured point by pressing the assigned Delete Last 
button, and the plane will automatically re-fit.

Figure 15-8. Hole measure-
ment.

Once the plane is defined, press the assigned Accept button to accept 
it. Subsequent measurements should be taken around the inside of 
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cylindrical geometry (such as the inside of a hole or pipe), and these 
measured points will be projected to the defined plane. Once 3 mea-
surements have been taken, statistics for the constructed circle (radi-
us, fit error, etc.) will be displayed. To accept the Hole measurement, 
press the assigned Accept button or click the Accept Hole button. To 
cancel geometry creation, press the assigned Cancel button or click 
Cancel.

You can right-click this measurement mode button in order to inspect 
a hole feature that already has nominal geometry in your file. The in-
spect mode will compare your measured feature to the geometry se-
lected as the reference. To inspect a hole, first right-click on the Hole 
button. When prompted, choose the circle to inspect. You’ll then be 
prompted to measure plane points. After measuring and accepting 
the plane points, you’ll be prompted to measure the hole itself. When 
complete, and after pressing the assigned Accept button, you’ll get a 
comparison of feature characteristics (Figure 15-9).

Figure 15-9. Comparison 
results.

Slot
Slot mode (Figure 15-10) will project two measured inside diameters 
of a slot to a plane, and construct circles and a slot midpoint (if speci-
fied). When in this mode, you first define the plane to which you’d 
like to project. As in other modes, you can either select a plane to 
project to (by clicking the Select button) or you can measure plane 
points yourself by pressing the assigned Record button. Statistics for 
the measured plane will be displayed as you measure points. Note 
that you can delete a measured point by pressing the assigned Delete 
Last button and the plane will automatically re-fit.
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Figure 15-10. Slot measure-
ment mode.

Once the plane is defined, press the assigned Accept button to accept 
it. You should then measure the points defining the inside diameter 
of one end of the slot (Circle A). Once 3 measurements have been 
taken, statistics for the constructed circle (radius, fit error, etc.) will be 
displayed. To accept the measurement, press the assigned Accept but-
ton. Next, measure the points defining the inside diameter of the 
other end of the slot (Circle B). To accept the slot measurement, press 
the assigned Accept button again, or click the Accept Slot button. To 
cancel geometry creation, press the assigned Cancel button or click 
Cancel.

Line
Line mode (Figure 15-11) creates a best-fit line through a series of 
measured points. Once two points have been measured, statistics for 
the line and the fit will be displayed. The assigned Record button will 
take additional measurements, while the assigned Delete Last button 
will delete the previously measured point and re-fit.
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Figure 15-11. Line measure-
ment mode.

When finished measuring, press the assigned Accept button or click 
the Accept Line button. This will create a line in the SA job. To cancel 
the measurement mode, press the assigned Cancel button or click 
the Cancel button.

Circle
Circle mode (Figure 15-12) creates a best-fit circle to the measured 
points. The difference between this mode and Pin/Hole modes is that 
the measured points are not first projected to a plane. This mode 
allows you to specify whether you’re measuring an inside radius 
(hole), outside radius (pin), or face radius (no offset). Probing direc-
tion is used to define the normal direction of the resulting circle. 
After 3 points have been measured, statistics for the fit of the re-
sulting circle will be displayed. You can remove the previously-mea-
sured point from the fit by pressing the assigned Delete Last button. 

Figure 15-12. Circle mea-
surement mode.

When finished measuring points, press the assigned Accept button or 
click the Accept Circle button. To cancel geometry creation, press the 



489

CHAPTER 15 ■ MEASURING WITH ARMS

assigned Cancel button or click the Cancel button.

Plane
Plane mode (Figure 15-13) creates a best-fit plane to a series of mea-
sured points. Once 3 points are measured, the Plane Measurement 
window displays statistics for the fit and the resulting plane. The nor-
mal direction of the plane is determined by the probing vector. You 
can remove the previously-measured point from the fit by pressing 
the assigned Delete Last button.

Figure 15-13. Plane mea-
surement mode.

When finished measuring points, press and hold the assigned Accept 
button or click the Accept Plane button. To cancel geometry creation, 
press the assigned Cancel button or click the Cancel button.

You can right-click this measurement mode button in order to inspect 
a plane that already exists in your file. The inspect mode will compare 
your measured feature to the geometry selected as the reference. To 
inspect a plane, first right-click on the Plane button. When prompt-
ed, choose the plane to inspect. You’ll then be prompted to measure 
plane points. After measuring and accepting the plane points, you’ll 
get a comparison of feature characteristics (Figure 15-14).
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Figure 15-14. Comparison 
results.

Sphere
Sphere mode (Figure 15-15) creates a best-fit sphere to a series of 
measured points. Once 4 points are measured, the Sphere window 
displays statistics for the fit and the resulting sphere. You can remove 
the previously-measured point from the fit by pressing the assigned 
Delete Last button.

Figure 15-15. Sphere mea-
surement.

When finished measuring points, press the assigned Accept button or 
click the Accept Sphere button. This will create a sphere and a point 
representing the center of that sphere. To cancel geometry creation, 
press the assigned Cancel button or click Cancel.

Cross Section
Cross Section mode (Figure 15-16) will automatically trigger mea-
surements when the probe crosses a specified coordinate frame axis 
value (plane). This is useful, for example, when creating measured 
cross-sections of complex geometry. After initiating this mode, the 
Section Specification dialog will appear, in which you specify the axis 
(X, Y, or Z) and plane on that axis that you would like to use to trigger 
measurements:
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Figure 15-16. Cross section 
mode.

Once the plane is defined, click the OK button or the assigned Ac-
cept button. This will bring up the Section Measurement dialog (Fig-
ure 15-17).

Figure 15-17. The section 
measurement dialog.

When ready to begin measurement, press the assigned Record but-
ton . The arm will begin streaming data to SA (Figure 15-18). When the 
probe crosses the specified plane, a measurement will be fired. Notice 
that the result of this measurement will be an interpolated point that 
lies directly on the specified plane. (Due to limits of hardware sam-
pling frequency, network speed, computer speed, and other restric-
tions, it is highly unlikely that the instrument’s measurement will lie 
perfectly on the specified plane).

Figure 15-18. Measuring at a 
specific cross-sectional value.

To pause measurement, press the assigned Delete Last button, which 
will put the arm back into a mode in which the graphical view will be 
continuously updated with the arm’s position, but no measurements 
will be taken. When finished measuring, press the assigned Accept or 
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Cancel button, which will return you to the interface.

Frame
Frame mode (Figure 15-19) constructs a frame based on the probing 
direction (final joint position) of the arm. The origin is placed at the 
probe position, and the constructed frame’s Z-axis is along the direc-
tion of the probe.

Figure 15-19. Measuring a 
frame with the arm.

To specify a name for the constructed frame, fill in the Frame Name 
field. To measure a frame, press the assigned Record  button. When 
finished measuring, press the assigned Accept or Cancel button.

Batch (Guided Points)
Batch, or Guided Points mode, guides the user to a series of selected 
points using dynamic zooming and audio cues. When entering this 
mode, you are first prompted to select the points to guide to (usually 
nominal points). Select these points in the order in which you’d like 
to measure them, then press Enter. Next, you will be presented with 
the Measure a Batch of Points dialog (Figure 15-20).
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 ■

Figure 15-20. Settings for 
measuring a batch of points.

Group Suffix. Attaches the specified suffix to the group of 
measured points.

 ■ Target Suffix. Attaches the specified suffix to each measured 
target.

 ■ Drive Tolerance. Specifies the radius around the current point 
that is considered to be “good” or “in-tolerance”. When the 
probe is within this radius, it turns green and the tone reflects 
an in-tolerance position (see below image).

 ■ Warbler Tone ramp start zone. Specifies the radius at which 
the audio tone begins to ramp up in pitch to signify that the 
probe is approaching the desired position.

When the desired parameters are entered, click Transmit Batch to In-
strument to begin measurement. While in the actual measurement 
mode (Figure 15-21), press the assigned Record button to measure 
the point and the assigned Delete Last button to delete the previous 
point. Note that as the probe is moved closer to the desired position, 
the tone increases in pitch and the view zooms in closer to the refer-
ence point.

Figure 15-21. Measuring a 
batch of points.

When all of the batch points have been measured, this mode exits 
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automatically. You can also exit the mode prematurely by pressing 
the assigned Accept or Cancel button.

Scanner
Scanner mode activates the laser line scanner on the arm, if equipped. 
Typically, the assigned Record button starts and stops scanning, 
while pressing the assigned Accept or Cancel button will end scan-
ning mode. The specific display for this mode is dependent on the 
hardware being used to execute the scan.

Average Discrete Points
Average Discrete Points (Figure 15-22) mode creates an averaged 
point from a number of measured points. This mode is useful when 
you want to average out a series of potentially noisy measurements 
(perhaps from vibration or other issues).

When in this mode, press the assigned Record button to begin tak-
ing samples. The number of samples that are averaged to determine 
the ultimate measurement position is determined in the Edit Arm Set-
tings window.

Figure 15-22. Measuring 
averaged points.

While taking samples, the assigned Delete Last  button will pause 
sampling. Press the assigned Record button to resume. At the com-
pletion of the desired number of samples, the resulting point (and 
RMS error) will be displayed. Press the assigned Delete Last button to 
reject the point, the assigned Record  button to take another mea-
surement, and the assigned Accept button to complete the measure-
ment mode.

Geometry Trigger
Geometry Trigger mode allows you to define planar, cylindrical, or 
spherical cross sections that, when crossed by the probe, trigger mea-
surement. By default, these geometric triggers are not defined. You 
first need to define them by right-clicking on the Geometry Trigger 
button, which will take you to the Make Geometry Crossing Triggers 
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dialog (Figure 15-23). The top of this dialog (separated into Add Planes, 
Add Cylinders, and Add Spheres sections) is where the geometry trig-
gers are defined. The active geometry triggers are displayed in the list 
in the center of this dialog.

Figure 15-23. Defining 
geometry triggers.

Add Planes:
 ■ Cartesian. Creates planar triggers (Figure 15-24) along the X, 

Y, and/or Z axes:

Figure 15-24. Planar geom-
etry triggers.

After clicking this button, you are presented with the Cartesian Along 
Working Axes dialog (Figure 15-25).
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Figure 15-25. Defining the 
extent of planar geometry 
triggers.

In this dialog, check the axes along which you’d like to create planes, 
and also specify their start and stop position (in active units), as well 
as their spacing. In this example, planes will be placed along the ac-
tive Z axis, from Z=0” to Z=20”, spaced by 2” (see image above).

It is important to realize that, due to a number of limiting factors such 
as hardware sampling speed and computer speed, the sampled data 
will almost never be taken exactly on the geometry’s boundary. In the 
Cross Sampling section, choose Interpolate to have SA interpolate 
between two sampled points on each side of the geometry trigger, 
and Closest Pt. to have SA use the closest sampled point to the trig-
ger. The Interpolate option will result in a point lying directly on the 
geometry trigger (although it will not have been an actual sampled 
point), whereas Closest Pt. will be a true sampled point, but will likely 
not lie directly on the defined trigger.

You can also specify the width and height of the planes (for drawing 
purposes only) if they are going to be drawn in the graphical view.

 ■ Cylindric. Creates planar triggers that pivot about the work-
ing frame’s Z axis. Clicking this option brings up the Cylindric 
About Z in Working dialog (Figure 15-26). Here, you can define 
the start angle, stop angle, and angular spacing of the planes. 
Note that the X-axis defines the 0-degree plane for these val-
ues.
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Figure 15-26. Defining cylin-
dric geometry triggers.

It is important to realize that, due to a number of limiting factors such 
as hardware sampling speed and computer speed, the sampled data 
will almost never be taken exactly on the geometry’s boundary. In the 
Cross-Sampling section, choose Interpolate to have SA interpolate 
between two sampled points on each side of the geometry trigger, 
and Closest Pt. to have SA use the closest sampled point to the trig-
ger. The Interpolate option will result in a point lying directly on the 
geometry trigger (although it will not have been an actual sampled 
point), whereas Closest Pt. will be a true sampled point, but will likely 
not lie directly on the defined trigger.

Figure 15-27. Cylindrically 
oriented planar triggers.

You can also specify the radius (width) and length of the planes (for 
drawing purposes only) if they are going to be drawn in the graphical 
view. The settings in Figure 15-26 were used to create the trigger 
planes in Figure 15-27.

 ■ Select. Allows you to add an existing plane to the list of trig-
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gers by clicking in the treebar or the graphical view.

 ■ Cross-Sampling. This applies to triggers added via the Select 
method (see previous). It is important to realize that, due to a 
number of limiting factors such as hardware sampling speed 
and computer speed, the sampled data will almost never be 
taken exactly on the geometry’s boundary. Choose Interpolate 
to have SA interpolate between two sampled points on each 
side of the geometry trigger, and Closest Pt. to have SA use 
the closest sampled point to the trigger. The Interpolate option 
will result in a point lying directly on the geometry trigger (al-
though it will not be an actual sampled point), whereas Closest 
Pt. will be a true sampled point, but will likely not lie directly 
on the defined trigger. Note that the desired option must be 
chosen prior to selecting the plane.

 ■ Draw In SA. This option will physically create the trigger planes 
in the job upon clicking the OK button for the Make Geometry 
Crossing Triggers dialog.

Add Cylinders
This section is used to add cylindrical geometry triggers.

 ■ Select. Allows you to add an existing cylinder to the list of trig-
gers by clicking in the treebar or the graphical view.

 ■ Cross-Sampling. It is important to realize that, due to a num-
ber of limiting factors such as hardware sampling speed and 
computer speed, the sampled data will almost never be taken 
exactly on the geometry’s boundary. Choose Interpolate to 
have SA interpolate between two sampled points on each side 
of the geometry trigger, and Closest Pt. to have SA use the clos-
est sampled point to the trigger. The Interpolate option will re-
sult in a point lying directly on the geometry trigger (although 
it will not be an actual sampled point), whereas Closest Pt. will 
be a true sampled point, but will likely not lie directly on the 
defined trigger. Note that the desired option must be chosen 
prior to selecting the cylinder.

Add Spheres
This section is used to add spherical geometry triggers.

 ■ Select. Allows you to add an existing sphere to the list of trig-
gers by clicking in the treebar or the graphical view.

 ■ Cross-Sampling. It is important to realize that, due to a num-
ber of limiting factors such as hardware sampling speed and 
computer speed, the sampled data will almost never be taken 
exactly on the geometry’s boundary. Choose Interpolate to 
have SA interpolate between two sampled points on each side 
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of the geometry trigger, and Closest Pt. to have SA use the clos-
est sampled point to the trigger. The Interpolate option will re-
sult in a point lying directly on the geometry trigger (although 
it will not be an actual sampled point), whereas Closest Pt. will 
be a true sampled point, but will likely not lie directly on the 
defined trigger. Note that the desired option must be chosen 
prior to selecting the sphere.

Trigger List
The Make Geometry Crossing Triggers dialog displays a list of the cur-
rently active triggers (Figure 15-28). You can single or multi-select ac-
tive triggers, then remove them from the trigger list using the Delete 
Selected button. Or, you can delete all active triggers using the Delete 
ALL button.

 ■

Figure 15-28. A list of the 
defined geometry triggers.

Group Separately (Append Trigger Name). When this option 
is checked, measured points will be separated into point groups 
based on their respective triggers (Figure 15-29). The trigger 
name will be appended to the end of the group name as ap-
propriate. Once the geometry triggers have been defined, click 
OK to return to the interface. At this point, left-clicking the Ge-
ometry Trigger button will take you into the measurement 
mode. Pressing the assigned Record button will begin (or con-
tinue) streaming points, and only those triggered by the geom-
etry triggers will be recorded. To pause streaming, press the 
assigned Delete Last button. To exit measurement mode, press 
the assigned Accept or Cancel button.
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Figure 15-29. Separately 
grouped measurements on 
different geometry triggers.

Cone
Cone mode (Figure 15-30) creates a best-fit cone to a series of mea-
sured points. Once at least 12 points are measured, the Cone window 
displays statistics for the fit and the resulting cone. You can remove 
the previously-measured point from the fit by pressing the assigned 
Delete Last button.

Figure 15-30. Cone mea-
surement mode.

Fit parameters (Figure 15-31) can be accessed by right-clicking on the 
Cone icon.
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 ■

Figure 15-31. Fit settings for 
a cone.

Lock Angle. Allows you to specify the apex angle and lock it, so 
that the resulting cone matches the specified angle.

 ■ Measured. Indicate whether you measured the outside of the 
cone, inside of the cone, or have zero offset.

 ■ Offset. Use the current probe offset, or override it with a cus-
tom value.

 ■ Perform Guess First. When checked, as each additional point 
is measured the fitting algorithm will re-evaluate all of the 
measured points. If unchecked, the initial guess parameters 
will not necessarily be re-evaluated as additional points are 
measured. In general, leave this option checked, unless com-
putation times become unreasonable.

 ■ Angle. Define the apex angle used for the initial cone fit guess.

When finished measuring points, press the assigned Accept button 
or click the Accept Cone button. To exit the dialog, press the assigned 
Cancel button.

SA ArmPad
The SA ArmPad (Figure 15-32) is a patent-pending input method that 
takes advantage of a calibrated pad (like a mousepad) that can be 
placed on any work surface. Once calibrated, you can tap any func-
tion on the pad with a probing device, instantly performing an action 
or entering the selected measurement mode. You can then perform 
various interactive actions with SA without using the computer or 
setting down the arm/probe.
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By measuring three calibration points (A, B, & C below), SA will recog-
nize the position and orientation of the pad, as well as which pad is 
being used. (Multiple variations of ArmPads, each with different func-
tionality, are possible). As long as the pad is not moved relative to the 
instrument, its functions can be activated.

Figure 15-32. The SA Arm-
Pad.

Calibrating the ArmPad is a straightforward process. It only needs to 
be performed once for a given instrument/pad orientation. That is, as 
long as the relative position between the instrument and the pad re-
main fixed, there is no need to recalibrate. Calibration results are 
stored with the instrument interface persistence files, so if an inter-
face is shut down and restarted, the calibration is stored and recalled.

To Calibrate the ArmPad:

1. In the instrument interface (but without any measurement 
modes active), click the SA ArmPad button , or hold button 
2 on the arm for a brief moment.
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2. 

Figure 15-33. The ArmPad 
calibration dialog.

The ArmPad Calibration dialog will appear (Figure 15-33). Fol-
low the prompts and touch the probe to each calibration 
point on the pad, measuring a single point at each.

Contact NRK Support to request a free pad. Or, click the Print Pad but-
ton to bring up a PDF of the pad which you can print out yourself 
on a letter-sized sheet of paper to use. (Note that the PDF should be 
printed at full scale, ensuring Page Scaling is set to NONE.

The Cancel and Done buttons have various uses (which are intuitive) 
based on context--they are equivalent to the Cancel or Accept but-
tons on the arm itself. The Prev and Next buttons have several mean-
ings depending on context as well. For example, they switch to the 
previous or next feature when performing a GD&T Inspection, and 
they move

to the previous or next relationship when trapping measurements.

To Select a Measurement Mode Using the ArmPad:

 ■ With the arm interface running, tap the probe onto the desired 
measurment mode on the pad.   (Note: you do not need to 
press a button to select the mode).

To Change Views Using the ArmPad:

 ■ With the arm interface running, tap the probe to the Top, Front, 
Side, or Oblique boxes on the pad.

To Autoscale the View Using the ArmPad:

 ■ With the arm interface running, tap the probe to the Autoscale 
button (similar to the button) on the pad.
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To Delete the Last Measured Point Using the ArmPad:

 ■ With the arm interface running, tap the probe to the Delete 
Last Point button on the pad.

Edit Arm Settings
To access the SA Arm interface options, press the Edit Arm Settings 
button  in the bottom left-hand corner of the interface. This takes 
you to the Options dialog (Figure 15-34).

Figure 15-34. The Arm inter-
face options dialog.

Button Functions
Arm buttons 1, 2, and 3 (if available) can be set to perform a series of 
functions:

 ■ None. Disables the associated button so it performs no action.

 ■ Record/Accept. The associated button will record a point or 
begin streaming points if pressed momentarily, and accept 
a dialog, accept geometry creation, or close a measurement 
mode if held for a few seconds.

 ■ Delete Last/Mouse Toggle. The associated button will delete 
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the last point or pause streaming if pressed momentarily, and if 
held for a few seconds, will toggle the use of the arm to control 
the mouse cursor.

 ■ Delete Last/Cancel. The associated button will delete the last 
point or pause streaming if pressed momentarily, and cancel 
a dialog, cancel geometry creation, or close a measurement 
mode if held for a few seconds.

Units
Instrument interfaces have unit settings in addition to SA itself. 
Choose the active units (inches, meters, millimeters, centimeters, or 
feet) in this dropdown.

Sound Options
Clicking the Sound Options button will bring up the Sound Properties 
dialog (Figure 15-35).

Figure 15-35. The Sound 
Properties dialog.

Speech Prompting
 ■ Speech Enabled. If the SA Speech Server is running, this op-

tion will add speech prompting to the arm interface.

 ■ Test. This button can be used to verify that the speech feature 
is operating correctly.

 ■ Server Computer. The IP address of the computer running the 
speech server  (leave blank if running on the current comput-
er).

 ■ Speech Port. The network port used by the speech server (set 
in the Speech Server’s settings).

Arm Sounds
 ■ Test. Play a series of arm sounds to check the volume setting 

and verify that arm sounds are audible.

 ■ Volume (1-40). Sets the volume of the arm’s speaker (if appli-
cable).  If the arm is not equipped with an internal speaker, the 
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computer’s speaker will be used instead, and this setting will 
have no effect.

 ■ Use for Plane Sections. When enabled, the arm will sound 
when the probe crosses a plane section or geometry trigger 
that results in a measurement.

Fit/Meas Options
The Fit/Meas Options button brings up a dialog (Figure 15-36) where 
you can specify a series of options related to arm measurement and 
geometry fitting.

Figure 15-36. The Fit/Scan 
options dialog.

Start Up
 ■ Startup In Meas Mode. Check this option and choose a mea-

surement mode to have the interface automatically enter a 
specific measurement mode after being started.
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Fit Options
 ■ Lock Circle Radii to. Check this option and enter a radius to 

lock the resulting circle from a circle fit to a specific radius.

 ■ Lock Sphere Radii to. Check this option and enter a radius to 
lock the resulting sphere from a sphere fit to a specific radius.

Stream Points
 ■ Temporal. When in Stream Points mode, points will be record-

ed at the rate specified under the Arm Settings in the Query 
Rate During Measurements field. Note that due to hardware, 
network, and other limitations, the rate will not match the re-
quested rate exactly.

 ■ Spatial. When in Stream Points mode, points will be recorded 
spaced by the specified increment. Note that due to hardware, 
network, and other limitations, the spacing will not match the 
requested increment exactly.

Guided (Batch) Measurement
 ■ ‘Good’ Threshold. Set the default radius for measurements to 

be considered “good” (in the “green zone”).

 ■ Working Field Threshold. Set the default radius in which the 
mode begins zooming and emitting an audio cue.

Averaged Discrete Points
 ■ Acquire X Samples per Point. Specify the number of samples 

that will be averaged to produce the resulting measured point 
while in Average Discrete Points mode.

Line Scan (Optional Laser Line Scanner)
 ■ Send Cloud Data to SA Every X Seconds. Point cloud data 

acquired from scanners is sent to SA in batches. This option al-
lows you to control how frequently those cloud point batches 
are sent to SA.

 ■ Auto Increment Cloud Name. When selected, upon comple-
tion of a scan, the point cloud name will automatically be incre-
mented for the next set of scan data.

 ■ Thinning Factor. This setting is applied in addition to the man-
ufacturer’s thinning settings in order to determine what por-
tion of the scanned points are actually sent to SA. For example, 
if the manufacturer’s settings are set to send every 2nd point, 
and the setting here is to send every 2nd point, then SA will 
receive every 4th point.

Line Measurement
 ■ Edge Line (eg sheet metal). This option is used for measuring 
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an edge, typically of a thin plate (such as sheet metal) when in 
Line measurement mode. For this mode, you first define the 
plane of the flat surface whose edge you’d like to measure. 
Then, start measuring and slowly drag the probe tip along the 
surface until it begins to fall off the edge. This will define one 
end of the line. Repeat on the other end of the edge, and a line 
will be created. It is important to move the probe tip very slow-
ly (depending on the measurement query rate) and to ensure 
that the probe remains in contact with the surface at all times.

 ■ Probe Center. When in Line measurement mode, the line is fit 
to the probe center points.

Geometry Trigger Measurement
 ■ Set Triggers. This is equivalent to right-clicking on the Geom-

etry Trigger measurement mode button, and allows you to de-
fine geometry triggers.

Data to SA
 ■ Query Rate During Measurements. Specify the rate at which 

the instrument is polled for data while measuring. This controls, 
for example, the rate at which measurements are recorded dur-
ing the temporal Stream Points measurement mode, and the 
rate at which data is transmitted for UDP Broadcasts. Keep in 
mind that the requested data rate is limited by hardware, net-
work, and other restrictions.

 ■ Send All Points as Cloud Points. All measured points will be 
sent to SA as cloud points instead of measured targets.

 ■ Send Intermediate Points with Features. For measurement 
modes that create geometry, if checked this option will also 
send the measured points that created the geometry. By de-
fault, these points are not sent.

 ■ Send Geometries. If disabled, geometries resulting from mea-
surement modes that create geometry will not be sent to SA.

 ■ Increment Group After Measurements. When selected, the 
group name will increment upon the completion of a measure-
ment mode.

 ■ Increment Point Names By X. Each subsequent measured 
point will be incremented by the specified amount.

UDP Data Stream
The UDP Data Stream feature (Figure 15-37) enables the instrument 
interface to broadcast real-time probe position and orientation over 
the User Datagram Protocol (UDP). This allows the interface to send 
this data over a network without requiring a specific data connection 
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to be established beforehand. This means that other clients on the 
network can be set up to receive this data and, perhaps, do some-
thing useful with it.

Figure 15-37. The arm 
interface’s UDP data stream 
properties dialog.

For example, you might set up UDP data streaming to broadcast real-
time 6D probe information to a custom client application that is lis-
tening on the proper port for UDP data packets. This client applica-
tion could take this 6D information and process it, performing a useful 
task (such as using the 6D information to control a motorized pan/tilt 
head camera mount).

 ■ Data to Send. Choose whether to send 3D coordinates (X, Y, 
and Z probe position) or 6D Transformations (X, Y, Z, and prob-
ing vector). You must also choose whether to send this data 
relative to the instrument, working, or world coordinate frame.

 ■ Destination. Enter the network computer name or IP address 
to target for the UDP broadcast, or leave it blank to broadcast 
to the entire local network. You must also specify a port num-
ber to target.

To test the data being transmitted via UDP packets, use the SpatialA-
nalyzer UDP Monitor (available in the SA Install directory as Spati-
alAnalyzer UDPMonitor.exe. Set it up with the appropriate port, 
then click the Start button to view the data as it arrives over the net-
work port, as seen in Figure 15-38.

Figure 15-38. The SpatialA-
nalyzer UDP Monitor.
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Graphics in SA
 ■ Update SA Graphics When Not Measuring. When enabled, 

the depiction of the arm in the graphical view will update, even 
when a measurement mode is not active.

 ■ Query Rate for Updates. The rate at which graphical updates 
will occur when not measuring. While the interface will ask the 
instrument for this rate, the actual update rate is limited by 
hardware, network, and other restrictions.

 ■ Joint Update Threshold. If a joint encoder has not rotated by 
the angle specified in this field, the joint’s graphical view will 
not update. Larger values will result in less frequent updates.

 ■ Auto-Correct Graphic Model. Due to the kinematics involved, 
and that fact that some manufacturers do not have fixed en-
coder orientations (or they do not expose this information), 
sometimes the model of the arm in the graphical view may ap-
pear to be oriented incorrectly. When this option is enabled, 
the interface will attempt to automatically correct the kinemat-
ics of the model of the arm in the graphical view. This option 
is exclusively for graphical purposes, and has no effect on the 
accuracy of the actual measurement data coming from the in-
strument.

 ■ Reset Model. If the model continues to be incorrect, click this 
button to attempt to reset the graphical representation.

Probe
 ■ Diameter. You can override the arm’s probe diameter by enter-

ing a different value in this field (generally NOT recommend-
ed). Click the Apply button to apply the changes.

Material Thickness
 ■ Add Additional Patch Shift. Select this option to add an ad-

ditional thickness for the Patch (Projected Pt.) measurement 
mode. This can be used, for example, to account for extra ma-
terial thickness on a measured surface.

 ■ Offset. Enter the desired patch shift offset amount in this field. 
A positive offset implies that there is extra material on the mea-
sured part.

Choose Language
This button is used to load or create a translation file for the arm inter-
face. See Language Translation for more details.

Arm Calibration
This will display hardware-specific calibration routines and set-
tings. The options provided by this button are strictly controlled by 
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the instrument manufacturer.

Toggle Arm Buttons
Press this button to toggle the arm buttons on and off. Toggling the 
arm buttons off will render them inoperable until toggled back on 
again.

Blue Question Mark
This button will display the MP string commands that can be used 
to set the arm measurement modes or apply additional settings via 
Measurement Plans.

Instrument Simulation
In simulation mode, you can simulate the different measurement 
modes, as well as record points to simulate a measurement process. 
When simulating, you will come across a series of buttons in various 
parts of the interface (Figure 15-39).

Figure 15-39. The simulation 
buttons.

These buttons refer to “First button, short”, “First button, long”, “Sec-
ond button, short” and “Second button, long” and refer to simulating 
pressing the arm buttons momentarily or pressing and holding them.

Instrument Index Number
At the very bottom of the interface is the collection, instrument in-
dex number, and name of the active instrument. This index number 
(which for a given collection begins counting from zero) is used in 
several places in SA--one of which is Measurement Plans.

Instrument Toolbar
The instrument toolbar is a simpler, easier to learn and use interface 
for arm measurement than the full arm interface. It is well suited for 
performing simple point measurement and scanning tasks, for new 
users, and when performing inspection routines using the SA Tool-
kit. It does not have any of the geometry measuring routines that are 
found in the traditional arm interface.

The instrument toolbar is displayed in Figure 15-40. It is accessible 
from the main arm interface by clicking the icon. (Similarly, the
icon switches back to the standard interface).

Figure 15-40. The arm 
instrument toolbar.
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Setting the Point Name

To explicitly set the point name for the next measured point, click the 
text field above the probe diameter listing. This will call up the Instru-
ment Interface Point Naming dialog (Figure 15-41), which allows you 
to specify the collection, group, and target names. If performing an 
inspection routine, the SA toolkit will name your data for you.

Figure 15-41. Naming a 
point in the arm toolbar.

Measurement Modes

There are three measurement modes available to you in the tool-
bar: single point measurement, stream measurement, and scanning 
mode (Figure 15-42).

Figure 15-42. (Left to right) 
Single point mode, stream 
mode, and scanning mode.

Click the single point or streaming measurement mode to activate 
it. For arms that have a scanner device with a switch attached, flip 
the switch to activate scanning mode. Some instruments may require 
you to click the scanning measurement mode button.

Measuring In The Toolbar

The following buttons control measurement using the arm toolbar.

 ■ Button 1. A short press moves to the next feature in the SA 
Toolkit, whereas a long press iterates the measurement mode.

 ■ Button 2. A short press records a measurement, whereas a 
long press deletes the last measurement.

 ■ Button 3. A short press advances to the next feature in the SA 
Toolkit, whereas a long press iterates the measurement mode.

Checks/Utilities

By clicking the icon, you can access calibration, scanner, and arm 
settings (these are the same destinations as found in the traditional 
arm interface).



CH
A

PT
ER 16

513

Typically, metrology data is of limited use until it has been aligned to 
some set of reference datums, nominal data, or other measurements. 
Aligning to a coordinate system is sometimes referred to as bucking 
in, tying in, locating, or aligning. Some of the reasons this is done in-
clude the following:

 ■ Governing dimensions and measurements (acceptance crite-
ria) are typically expressed on drawings with respect to a spe-
cific datum or frame of reference. Often, evaluating features 
with respect to other datums is not permitted when evaluating 
design conformance.

 ■ When comparing as-built measurements to a nominal design, 
the data must be aligned to the nominal design—otherwise, 
the comparison cannot be performed.

 ■ Multi-station measurements (measurements taken from more 
than one position in space) must be “tied” together so that the 
data is continuous.

 ■ Digital alignment and assembly (virtual fit-up) requires that 
measured components be “virtually” assembled using some 
sort of alignment in order to check the assembly for fit and 
function.

In some situations, this involves creating a coordinate frame from the 

One of the key areas of portable metrology is align-
ment: transforming an instrument into the proper posi-
tion and orientation such that it is aligned to the de-
sired coordinate system. This chapter explores methods 
for transforming into a desired coordinate system.

Alignment & 
Transformations
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measured points. In other (less common) situations, it involves trans-
forming CAD data to the measurements. But most often, it involves 
aligning measurements to a coordinate system of interest. Since mea-
surements are rigidly fixed to the instrument that measured them,  
this typically involves transforming an instrument in space until its 
measurements end up in the desired position.

In this chapter, we will explore the tools available for performing all 
different types of alignment.

Best-Fit Transformations
Best-fit transformations are widely used in coordinate metrology 
to consistently and confidently align measurements into a coordi-
nate frame that is meaningful to a user. Measurements made with 
an instrument should be presented to users in the part coordinate 
frame—that is, aligned to the part. The best-fit transformation rou-
tine in SpatialAnalyzer is one way to do that.

A best-fit transformation solves for the difference between a group of 
points and the expected (or reference) coordinates for those points. 
The difference between the current position and orientation of the 
points and the ending position/orientation is referred to as the trans-
formation. After the solution is reached, SpatialAnalyzer shows you 
the difference and allows you to apply the transformation to your 
measurements of the points and to other objects as well. Once ap-
plied, SpatialAnalyzer is able to report those measured points and 
any new measurements in a part coordinate frame that is meaningful 
to you.

The best-fit alignment technique has many applications; for example, 
to combine sets of coordinate data or locate an instrument in the 
part coordinate system using surface features imported from a CAD 
system. Simply stated, this alignment technique helps you deter-
mine the transformation that when applied to one set of coordinates 
causes the match-up between the two sets to be ideal.

The term “best fit” is the colloquial term given to a mathematical pro-
cedure known as a Linear Least Squares fit. The transformation solved 
for and applied is determined using least-squares optimization meth-
ods. A least squares optimization seeks to minimize the square of the 
distance between corresponding points, or between points and cor-
responding surfaces.

Point to Point Best-Fit

A common need for performing a point to point best-fit is when try-
ing to locate to a known coordinate system in which discrete points 
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already exist. For instance, you have a network of control points (fi-
ducials) from a previous station measurement and you’d like to relo-
cate the instrument and remeasure these points in order to align back 
into the coordinate system. When performing this type of alignment, 
the group of points being aligned to are referred to as the reference 
group, and the points being moved are referred to as the correspond-
ing group. They may also be referred to as the nominal group and mea-
sured group, respectively, although if the term nominal group is being 
used, it does not necessarily mean that the points are true nominal 
design points (Figure 16-1).

Figure 16-1. A group of four 
points (blue), when best-fit 
to a set of reference points 
(red), will move as illustrated. 
The four blue points move 
together as a rigid body to 
try to align with the reference 
points. In this case, a rotation is 
involved.
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In order to perform a point-based best-fit transformation, the points 
involved must meet two prerequisites:

 ■ There must be at least 3 points in both the reference and cor-
responding groups that have corresponding names.

 ■ The reference and corresponding points must be in separate 
point groups.

Note that the two groups need not have exactly the same number 
of points. Any points that don’t have corresponding pairs are simply 
ignored in the command, although if they are in the moving point 
group they will be transformed along with the rest of the points in 
the group. There are three ways to perform a point-to-point best fit 
transformation:

 ■ Instrument-based best-fit. In this method, you pick an instru-
ment to align, and then select the reference and measured 
group. The transformation will be applied to the instrument, 
bringing all of the measured points along with it.

 ■ General best-fit. This is nearly identical to the first method, 
however it’s not instrument-centric, and provides a little more 
flexibility when needed. You can choose to transform anything, 
including instruments, point groups, and other objects. There 
are also a few additional options (discussed below).

 ■ Locate an instrument by measuring nominal points. This al-
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lows you to measure a set of nominal points, and let SA handle 
the point naming and alignment for you.

These three methods are described below, but to use them (well, at 
least two of them) we first need to understand the Best-Fit Transfor-
mation dialog.

The Best-Fit Transformation Dialog

The Best-Fit Transformation dialog (see Figure 16-2) is a simple in-
terface allowing a high degree of control over the fit. Here you can 
review the fit, apply tolerances, restrict degrees of freedom, edit point 
constraints, and more. Any time one or more changes is made, the 
current fit is no longer valid (indicated by a dark blue background on 
the fit button and the fit results) and needs to be re-solved. The dialog 
is divided into three main parts: the controls (top left corner), the fit 
results (top right corner), and the point list (bottom).

Figure 16-2. The Best Fit 
Transformation dialog.

Fit Results
The fit results are listed in the table in the top right corner of the dia-
log. These results will be invalid (and therefore will have a dark blue 
background) whenever the best-fit solution has either not been 
solved or a change has been made since it was last solved. The fit re-
sults table contains, on a component-by-component basis, a number 
of statistical values related to the fit that help you determine how well 
the fit performs. These values include:

 ■ Count. The number of points included in the fit for the speci-
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fied component.

 ■ Max Error. The maximum error between a pair of correspond-
ing points. This is an indicator of the “worst fit” for any pair of 
corresponding points.

 ■ RMS Error. The root-mean-square error of the fit as a whole. 
This is a good indicator of the overall error of the fit. This num-
ber is always less than or equal to the max error (although usu-
ally it’s noticably smaller than the max error).

 ■ StdDev Error. The standard deviation of the errors. A small val-
ue indicates that each pair of points had similar errors. A large 
value indicates that one or more error values differed signifi-
cantly from the group as a whole.

 ■ Max Error (all). This is the same as Max Error, except all points 
are included (even those which are deselected from the fit).

 ■ RMS Error (all). This is the same as RMS Error, except all points 
are included (even those which are deselected from the fit).

 ■ Translation. The x, y, and z instrument translation needed for 
the solution.

 ■ Rotation (Fixed YZ). The instrument rotations required for the 
solution, in Fixed XYZ form.

 ■ Rotation (Euler XYZ). The instrument rotations required for 
the solution, in Euler XYZ form.

 ■ Rotation (Angle axis). The instrument rotation required for 
the solution, in Angle axis form (first three values describe the 
rotation axis, and the last value describes the rotation angle).

 ■ Scale Factor. The scale factor applied for the fit. This will be 1.0 
unless the Scale degree of freedom is checked (allowed to float).

 ■ Matrix. This is the 4x4 transformation matrix that will be ap-
plied to the instrument.

Point List
The point list is a table that contains all points that were found to 
have matching pairs between the reference and corresponding 
groups. Immediately above this list, in the Columns section, are three 
checkboxes: Nominals, Actuals, and Weights. Checking any of these boxes 
will display the corresponding values in the table. Any column can 
be sorted in ascending or descending order by clicking the column 
header. The columns in the point list are described here:

 ■ Name. The name of the point.

 ■ Nom X. The nominal x-coordinate of the point. This is the x-
coordinate of the reference (non-moving) point.
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 ■ Nom Y. The nominal y-coordinate of the point. This is the y-
coordinate of the reference (non-moving) point.

 ■ Nom Z. The nominal z-coordinate of the point. This is the z-
coordinate of the reference (non-moving) point.

 ■ Act X. The actual x-coordinate of the point. This is the x-coordi-
nate of the measured (moving) point.

 ■ Act Y. The actual y-coordinate of the point. This is the y-coordi-
nate of the measured (moving) point.

 ■ Act Z. The actual z-coordinate of the point. This is the z-coordi-
nate of the measured (moving) point.

 ■ Wt X. The fit weight for the x-coordinate of the point.

 ■ Wt Y. The fit weight for the y-coordinate of the point.

 ■ Wt Z. The fit weight for the z-coordinate of the point.

 ■ dX. The current x-deviation between the reference and corre-
sponding point.

 ■ dY. The current y-deviation between the reference and corre-
sponding point.

 ■ dZ. The current z-deviation between the reference and corre-
sponding point.

 ■ dMag. The magnitude of the deviation between the reference 
and corresponding point.

Each point in the fit has a checkbox next to its name in the point list. 
Deselecting this checkbox will remove the point from the fit, which 
means that it will have no influence in the final solution. It is standard 
procedure to remove erroneous points from the fit so as not to cor-
rupt the overall solution. If a point is removed from the fit, it will be 
grayed out in the point list.

Best-Fit Item Dialog

Figure 16-3. The Best-Fit 
Item dialog.

Double-clicking a point in the list will bring up the Best-Fit Item dia-
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log (Figure 16-3). This dialog provides another way to remove the 
point from the fit (Use in Fit), and conveniently allows you to change 
the reference point’s coordinates, as well as the per-component fit 
weight for the point. The 1 and 0 buttons are simply shortcuts for set-
ting the corresponding fit weight value.

Fit Weights
Fit weights give you control over defining whether a certain compo-
nent of a point has any influence in the fit process. A value of zero 
indicates that the component has no influence in the fit, whereas a 
value of 1 indicates the component has full influence. Any interme-
diate value may be chosen. If a component is weighted to zero, it is 
displayed in gray in the point list. If an intermediate value is chosen, it 
is displayed in blue, and if the weight is set to 1, it is displayed in black.

One reason for reducing the weight of a specific component of a point 
is to reduce directional errors. Suppose you have a measured point 
that was performed on a floor that was flexing in the z-direction dur-
ing measurement. It is reasonable to assume that the measured point 
has significant error in the z direction when compared to the x or y 
direction, therefore reducing the weight of the z component may be 
a wise choice. Another reason is when using discrete points to control 
specific degrees of freedom, an advanced technique that, while do-
able using best-fit, is much easier to perform using relationship fits.

Controls
You’ll notice that you have a significant amount of control in the fit. 
Access to changing the fit parameters is provided via the controls in 
the upper-left hand corner of the dialog.

Degrees of Freedom
When solving a best-fit transformation, you can specify that the trans-
formation may only be permitted in certain unlocked degrees of free-
dom, relative to the working coordinate frame. You can lock any com-
bination of X/Y/Z translation, X/Y/Z rotation, and scale. Any degree of 
freedom that is checked is unlocked—unchecking a degree of free-
dom locks it. Keep in mind that these degree of freedom restrictions 
are applied with respect to the working coordinate frame, therefore 
rotations are applied about the working frame origin.

As an example, suppose you have a bolt pattern measurement on a 
flange and you’d like to fit this measured pattern to a mating, nomi-
nal pattern. In this case, you would likely align the face of the mea-
sured points to the nominal flange face using perhaps a relationship 
fit, then you might wish to use the nominal bolt pattern to spin the 
measured flange about its axis until the bolt holes are aligned (Figure 
16-4).
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Figure 16-4. Performing a 
best-fit transformation allow-
ing only rotation about the Z 
axis.

x

y

By locking all degrees of freedom except for rotation about the Z 
axis—and by placing the working frame at the center of the flange—
the fit would simply clock the measured pattern to the nominals.

You might also restrict degrees of freedom if you have a leveled in-
strument (its axis is parallel to the Z axis) and you do not want it to 
rotate about the X or Y axes.

Notice that you can also set the instrument to a specified scale value 
for the fit, which allows you to apply temperature compensation to 
the measurements in situ.

Tolerance Coloring Zones
You can apply tolerance coloring to the deviations in the point list by 
setting the tolerances in the Tolerance Coloring Zones section.

Fit Controls
A series of buttons controlling the fit is displayed below the Tolerance 
Coloring Zones section:

 ■ Re-fit button. Recalculates the best-fit transformation 
based on the current settings. A blue background on this but-
ton indicates that the current fit is not valid based on the cur-
rent settings and a re-fit is needed.

 ■ Edit Selected Items. Brings up the Best-Fit Item dialog 
(page 518) for any selected items. More than one point can be 
selected at one time in the point list. This button allows you to 
change all of their properties at once.

 ■ Quick Tips. Displays a series of tips related to the dialog.

 ■ Advanced Settings. Displays the Advanced Best-Fit Op-
tions dialog, discussed below.

 ■ Advanced View. Toggles to a simplified version of the inter-
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face, hiding less frequently-used parameters.

Advanced Settings
The Advanced Best-Fit Options dialog (Figure 16-5) provides some 
advanced, less commonly-used settings for best fit transformations.

Figure 16-5. The Advanced 
Best-Fit Options dialog.

Descriptions of these parameters follow:

 ■ Reset transform and scale before each re-fit. The transfor-
mation is solved from the same initial starting position and ori-
entation each time the fit is performed. This is the default and 
is applicable to most fitting operations.

 ■ Apply transformations successively. Each fit operation solves 
using the previous calculated transformation as a starting 
point. This allows you to apply iterative best-fit operations with 
different degree of freedom settings for each. For instance, you 
might wish to first solve the best-fit with some degrees of free-
dom locked, then solve again from that position with a differ-
ent set of locked degrees of freedom.

 ■ Reset Transformation and Scale Now. Resets the current 
transformation back to the “starting point”.

 ■ Store weight settings with points. Fit weights can be stored 
with nominal or actual points such that if the points are used in 
another best-fit operation, the weights are recalled.

 ■ Make a new group when fit is finished. Makes a copy of the 
reference (non-moving) points and puts them into a separate 
group with the specified name at the completion of the opera-
tion. If nominal coordinates were changed in the Best Fit Item 
dialog, this group will use those updated coordinates. This is 
not a common need.
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Export to CSV
The Export to CSV button will export the fit results to a comma-sepa-
rated .CSV file and import it into Excel (if installed).

Instrument-Based Best-Fit

To reiterate, an instrument-based best-fit transforms just an instru-
ment and (of course) its measurements. Only one instrument can be 
transformed. As such, it is most appropriate when locating a single 
instrument to a set of reference points, or when relocating an instru-
ment to a new station.

1. Measure a set of points into a point group. These will be the 
“measured” points.

2. Ensure that the measured point names match the corre-
sponding point names in the reference group.

3. From the menu, select Instrument>Locate (Transform to Part)>Best-
Fit.

4. If there is more than one instrument in the job file, select the 
instrument to locate (as prompted).

5. When prompted for the “nominals” group, select the refer-
ence group. This is the group containing the points that will 
not move during the transformation.

6. When asked for the “measured” group, select the group con-
taining the measured points. These points should be mea-
sured by the instrument selected in step 4.

7. Choose the desired options from the Best-Fit Transformation 
dialog and perform the fit as described, then click Apply Trans-
formation.

General Best-Fit

A general best-fit can be performed in which the calculated transfor-
mation is not simply applied to a single instrument that measured the 
corresponding points. This is useful for applying point to point best-
fit transformations when instruments are not involved, or when you’d 
like to move several instruments together as part of the fit. In the gen-
eral best-fit, you can apply transformations to instruments and other 
objects, in addition to a few more options.

To Perform a General Best-Fit Operation

1. Select Analysis>Best-Fit Transformation>Points to Points, or press 
Ctrl + B.

2. Select the reference (non-moving) group.

Note:  If your point names 
don’t correspond, use Edit> 

Rename> Points by Auto-Corresponding 
2 Groups to automatically rename 
them.
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3. Select the corresponding (moving) group.

4. In the resulting Best-Fit Transformation dialog, select the de-
sired options for the fit and solve it (see “The Best-Fit Transfor-
mation Dialog” on page 516).

5. In the Best-Fit Options dialog (Figure 16-6), select the desired 
options (described below), then click OK.

Figure 16-6. The options for 
a general best-fit.

Best-Fit Options
Toward the completion of a general best-fit operation, you are pro-
vided with a series of options that are not displayed in the single 
instrument version of the best-fit command. These options are de-
scribed below.

 ■ Move the corresponding group. Determines whether the 
transform is applied to the corresponding (moving) group. If 
unchecked, the corresponding group is not moved.

 ■ Move Objects. If you’d like to transform other objects, select 
this option. After clicking OK, you’ll be prompted to pick the 
additional objects to transform.

 ■ Move Instruments. If you’d like to transform instruments, se-
lect this option. After clicking OK, you’ll be provided the oppor-
tunity to select instruments to transform.

 ■ Adjust Instrument Scale Factor. This option is only available 
when the scale degree of freedom is unlocked during the fit. 
When checked, the scale factor calculated during the fit opera-
tion is applied to the moving instruments.

 ■ Move a copy of the working frame. When selected, the work-
ing frame will be copied, and the transform will be applied to 
the copy. This creates a frame that can be used to report the 
coordinates of the points as they were prior to the transforma-
tion.

 ■ Create alternate reference frame. When selected, a frame is 
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created that represents the inverse of the applied transforma-
tion. This allows you to transform the moving objects back to 
their position prior to the best-fit operation through the use of 
a frame to frame transformation.

Locate By Measuring Nominal Points

While locating an instrument by fitting to a set of nominal points (see 
“Instrument-Based Best-Fit” on page 522) is not a difficult task, you 
may find that using Instrument>Locate (Transform to Part)>Measure Nomi-
nal Points is preferable for typical in-process alignment in which more 
control is not needed.

Locating by measuring nominal points provides a few benefits over 
the instrument-based best-fit method:

 ■ Point naming is handled automatically, eliminating the poten-
tial for typographical errors in measured point names.

 ■ If the instrument is roughly aligned to the points already (for 
instance, it is being re-fit into the reference system after being 
bumped), it can easily be automatically pointed at the targets 
(if the instrument supports pointing). Single points or the en-
tire set of reference points can be automatically measured with 
a single button click.

 ■ The quality of the fit is displayed at the time of measurement—
therefore any blunders in measurement (resulting in errors in 
the fit) can be discovered much sooner than if the fit were be-
ing performed later in the process.

There are a few things to keep in mind when using this command:

 ■ It must be used at the time of measurement. If the measured 
points already exist, you must use one of the other two best-fit 
commands.

 ■ You have much less control over the fit. You cannot control de-
grees of freedom (with the exception of scale), weighting, or 
advanced fit operations—and you cannot remove points from 
the fit unless you delete them.

 ■ You’re presented with much less detailed information about 
the fit results.

For the first two measurements, insufficient measurements exist to 
perform the fit, so the delta deviations are not displayed. However, as 
each successive measurement is obtained, the fit is recalculated and 
the deviation values are updated. The Locate Instrument by Measur-
ing Nominals dialog is presented in Figure 16-7.
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Figure 16-7. The Locate 
Instrument by Measuring 
Nominals dialog is useful 
when performing a best-fit 
points to points transforma-
tion during the measurement 
process.

A description of the options follows:

 ■ Group to Contain Measured Points. This is the name of the 
group in which you’d like to measure the corresponding points. 
It is best to type this in before measuring any of the points, be-
cause if you change it after measuring any points, the already-
measured points will not move into the new group. The Apply 
button will update the table based on the entered group, and 
the ellipsis button allows you to select an existing group to use.

 ■ Vary Scale. When checked, scale is allowed to float during the 
fit. The initial, delta, and final scale values are listed next to this 
checkbox.

 ■ Measure Manually. When clicked, the selected target in the 
list is measured. If the target already exists, an additional ob-
servation is added.

 ■ Point At. Points the instrument at the selected target and at-
tempts to lock on. (Applies only if the instrument supports 
pointing/target acquisition).

 ■ Delete. Deletes the selected target.

 ■ Automatic Measurement - Single Point. Attempts to point 
at, acquire, and measure the selected target.

 ■ Automatic Measurement - Multiple Points. Attempts to con-
secutively point at, acquire, and measure all points in the list.

 ■ Tolerance. You can specify a tolerance in this field. Any devia-
tion magnitudes that exceed the tolerance will be highlighted 
red. Click the Apply button to apply the specified tolerance to 
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the table.

To Locate an Instrument by Measuring Nominals

1. Ensure the instrument interface is running.

2. From the menu, select Instrument>Locate (Transform to 
Part)>Measure Nominal Points.

3. If more than one instrument exists in the file, select the instru-
ment to transform, as prompted.

4. Select the nominal (reference) points.

5. The Locate Instrument by Measuring Nominals dialog is dis-
played.

6. In the Group to Contain Measured Points section, type in a name 
for the point group in which to place the measured points.

7. Measure points manually or automatically using the dialog as 
described above. Once three or more points have been mea-
sured, click the Finished -- Locate Instrument button at any 
time to accept the fit and complete the command.

Best-Fit Points to Surfaces

Performing a linear least-squares fit between a set of points and one 
or more surfaces is a common task. Often, you want to know the de-
viation of an as-manufactured part or assembly from its perfect de-
sign condition, and it is common to have the nominal design repre-
sented in a CAD package as a set of surfaces. In cases where specific 
discrete reference datums for aligning measurements to the nominal 
design are not specified (or not desired), best-fit points to surfaces is 
one method for aligning your measurements to the reference system.

Best-Fit Points to Surfaces uses optimization methods to find the 
transformation that, when applied to the instrument (and therefore 
its points), minimizes the RMS error between the measurements and 
the surfaces, taking into account your specified constraints. Typically, 
the goal is to drive all the points (compensated for probe offset) to be 
exactly on the surface. SpatialAnalyzer extends that capability by al-
lowing the operator to specify high and low tolerances for points and 
assign weights to those constraints.

Initial Condition
Like several other optimization methods, fitting points to surfaces 

Basic Operation

For a standard best-fit, just leave the options (Figure 16-8) set to the 
defaults and then the points will be brought to the surface using a 
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best-fit taking into account the target offsets of the points. Make sure 
all the surfaces you are using have their normals pointing in the right 
direction.

Figure 16-8. The Points to 
Surface Fit options.

Point Set Thinning
This option allows you to easily thin selected point sets for purposes 
of fitting to a surface. Suppose you have a scan with 10,000 points, 
but don’t want to wait a long time for the best-fit. You can specify that 
you only want to fit 400 of the points and it will evenly sample 400 
points from the selected point set.

Run Optimization
This is the default mode of operation. The optimization method per-
forms a version of the steepest-descent algorithm on the system. This 
means it assembles a matrix that is 6 (unknowns) x N (number of 
points), inverts it and determines move directions. Though quick for 
reasonable data sets, it can take a long time when using a large set of 
points depending on the amount of RAM on the computer. The stop-
ping tolerance is the amount that the objective function (RMS error) 
must repeat by in order to indicate a minima has been reached.

Run Direct Search Optimization
This optimization provides a powerful method for searching the solu-
tion space. It is also required when using the toleranced best-fitting 
options (in the advanced area) since they introduce non-linearities 
into the solution space. This method basically steps in a direction, 
evaluates the fit, then steps in another direction, etc. There is a lot of 
advanced logic built into the search, but at the core, it is a searching 
method. The advantage is that it does not have to assemble a large 
partials matrix and invert it. This means that it can effectively deal 
with huge point sets. The disadvange is that since it is trying to ex-
haustively search, it can sometimes take a long time to complete. At 
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any time during the fit, however, you can cancel the operation and 
use the current location. To use this mode, you set step sizes. They are 
set as a ratio of the position and angular perturbation values in the SA 
units options page. The step size starts at the starting value then de-
cays when it detects no improvement in any direction. Once it decays 
to the Ending step size, a minima is reached.

Recommendations
We have several recommendations for setting these options based 
on past experiences. As with many things, you may need to experi-
ment to determine the best set of options for a particular combina-
tion of points and surface geometry.

The most important recommendation is to start with a good initial 
condition. The easiest way to do this is to use Quick Align to CAD.

 ■ Reasonable point sets without toleranced fitting. Use only 
the conventional solution. It is not necessary to waste the time 
on the exhaustive search.

 ■ Huge point sets with a reasonable starting guess. Use only 
the exhaustive search with appropriate start and stop pertur-
bations.

 ■ Reasonable point sets with tolerances or unusual geom-
etry. Use both fit options.

 ■ Reasonable point sets, no tolerances, but very high accu-
racy required. Use both fit options.

Advanced Options
By pressing the Advanced button, you can open the advanced side of 
the dialog (Figure 16-9).

Figure 16-9. Advanced Best-
Fit options.

These allow you to modify the constraints of the fit to achieve more 
complex fit ups. This may be used to avoid part to part interference in 
build operations, or other processes where the interaction between 
parts is of interest.

Suppose we want to perform a standard best fit to the CAD surface, 
but we want to make sure none of the points are more than 0.030 
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below the surface. The parameters could be set as follows:

 ■ Nominal Drive. Use default settings.

 ■ Low Tolerance 0.030, and default weight values.

The result is that the optimization will drive the points to the nominal 
CAD surface but also exert extra pressure on points that fall below 
0.030 on the negative side of the surface. Because the weight for the 
tolerance is fairly high, it will push the set of points so that the offend-
ing low tolerance points lie within the -0.030 band.

Nominal Drive (Standard Surface Fitting)
To perform a standard surface fit, use this option by checking Ac-
tive.  Set the goal value to 0.0 if you wish to drive the points to the 
surface, or you may use another value to use the offset surface. You 
do not need to set the weight unless you are using other tolerances 
in the fit.

Low Tolerance
These four variables control the low tolerance value. The tolerance 
value does not have to be on the negative side of the surface. You 
could, for example, have a low tolerance of 0.25” and a high tolerance 
of 1”. The low tolerance is simply the lowest tolerance value.

 ■ Tolerance Active. This flag allows you to easily turn on and 
off the low tolerance. Turning the tolerance off is equivalent 
to settings its weight to 0.0, except that is skips the computa-
tions necessary to determine the toleranced objective function 
value.

 ■ Tolerance Value. This value is the tolerance for the point to 
surface fit of this FitPoint. If 0.0, then the point will be driven to 
the surface (after compensating for target thickness)

 ■ Static Penalty. This value is added to the objective function in 
addition to the weighted tolerance violation. Think of this as a 
static offset applied any time a point moves beyond the toler-
ance. Initially, leave this value set to 0.0 and only use it when 
needed. When you use it, set its value low so it does not un-
necessarily increase the nonlinearity of the system. Using large 
static offset penalty values will have the effect of stopping the 
optimization prematurely.

 ■ Tolerance Violation Weight. This value is multiplied by the 
amount that the point violates the low tolerance. If the low tol-
erance is –0.030 and the points projected distance is –0.040, 
the violation is 0.010 multiplied by the Weight.

High Tolerance
The parameters are identical to the Low tolerance except that they 
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apply to the high tolerance.

Edge Projection Penalty
This value is a fixed penalty added to a point’s objective function con-
tribution if the point projects to the edge of a surface.
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SA’s watch windows are live readouts of measurement data. You can 
view the coordinates of an instrument’s measurement, watch the live 
delta transformation between two objects as they are moved, watch 
the deviation of a probe from a nominal surface, and more. This en-
ables real-time assembly operations, in which you can watch a mov-
ing object’s positional error in real-time and make corrections live. It 
also permits easy tool and fixture building,  because you can watch a 
feature’s position in real-time and check it as you make adjustments 
to the tool.

A typical watch window is shown in Figure 17-1. Depending on the 
type of watch window being viewed, you may be seeing raw coor-
dinates (X/Y/Z values) or deviations (dX/dY/dZ values). Each value 
is displayed on a separate row in the window. The window may be 
resized or even maximized as necessary for easier viewing from a dis-
tance—the text will expand to fill the available window. You can open 
as many simultaneous watch windows as you’d like--they will all up-
date automatically.

By default, watch windows (like almost everything in SA) show their 
data relative to the active coordinate frame. So an X value is the value 
in the working frame’s X axis, and a dZ value is the delta along the 
working frame’s Z axis. Settings for a given type of watch window are 
saved—meaning that if you, for instance, hide the X delta in a specific 

Tip:  If possible, you can use 
SA Remote (an iOS app for 

iPod/iPad/iPhone) to view watch 
window data remotely. See the 
chapter “Measurement” for more 
information.

Viewing live measurement data is essential for tasks 
such as real-time assembly and tool-building. SA’s Watch 
Windows provide you with tools for not only viewing 
live measurement data, but also for viewing other live 
spatial relationships.

Watch Windows
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type of watch window, that value will still be hidden the next time 
you display that type of watch window.

Figure 17-1. A typical watch 
window.

Watch Window Types
There are a number of different types of watch windows that can be 
displayed in SA. They include:

 ■ Instrument’s Point. Shows the position of a live instrument’s 
probe in real-time.

 ■ Point to Point. Shows the deviation of the instrument’s probe 
from a specific point.

 ■ Point with View Zooming. Compares the instrument’s probe 
to a specific point, zooming in on the point as the deviation 
decreases.

 ■ Closest Point. Compares the instrument’s probe to the closest 
of a set of points.

 ■ Point to Objects. Compares the instrument’s compensated 
probe position to the closest of one or more objects.

 ■ Three Point Frame. A point measurement from each of three 
different instruments is used to define a coordinate frame, 
which is then viewed relative to the working frame.

 ■ Two Point Axis Alignment. Two measured points are used to 
calculate pitch and roll from a given coordinate frame.

 ■ Theodolite Observer Point to Point. Compares a point de-
rived from two or more theodolite observations to any other 
point.
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 ■ Theodolite Observer’s Point. Displays a point derived from 
two or more theodolite observations.

 ■ Theodolite Observer’s Data. Displays the data from the The-
odolite Observer.

 ■ Relationships. Any relationship can have a watch window 
added in order to view that relationship’s deviation.

Watch Instrument’s Point

This watch window displays the coordinates of the center of the in-
strument’s probe. It will update whenever updated data is received 
from the instrument.

To Display an Instrument’s Point Watch Window:

 ■ Right-click an instrument and select Add Watch Window from the 
context menu, or

 ■ From the menu, select View>Watch Window>Add Instrument’s Point.

Watch Point to Point

This watch window displays the deviation between the center of an 
instrument’s probe and the selected point. Offsets are not used in this 
comparison.

To Watch Point to Point:

 ■ From the menu, select View>Watch Window>Add Point to>Point, 
then select the point to compare, or

 ■ Right-click a point and select Add Watch Window from the context 
menu.

Watch Point to Point With View Zooming

This watch window functions the same as a point to point window, 
but automatically zooms the graphical view and plays a sound whose 
pitch is proportional to the proximity of the target to the point. Off-
sets are not used in this comparison.

To Watch Point to Point with View Zooming:

1. From the menu, select View>Watch Window>Add Point to>Point 
with View Zooming.

2. Select the point to compare.

Watch Closest Point

A closest point watch window will automatically compare an instru-
ment’s probe position to the closest of a set of points. This set of 
points can be entire group, a subset of a group, or a subset of multiple 
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groups. This watch window will automatically display the name of the 
point to which it is comparing. Offsets are not used in this compari-
son.

To Watch Closest Point:

1. From the menu, select View>Watch Window>Add Closest Point.

2. Select the point(s) to compare against.

To Watch a Point Group:

 ■ Right-click the group and select Add Watch Window from the con-
text menu.

Watch Point to Objects

This watch window displays deviation between the probe and the 
closest of a set of provided objects. It’s important to recognize that 
offsets are accounted for in this comparison—that is, probe compen-
sation is applied.

However, if the object you are comparing to is a line, SA will by default 
override target offsets to zero, since comparing the center of a probe 
to a line is far more common than comparing a compensated point 
to a line.

When multiple objects are selected, the closest object to the probe’s 
current position is compared. As the probe moves, the object com-
pared against may change.

To Watch Point to Objects:

1. From the menu, select View>Watch Window>Add Point to>Objects.

2. Select the objects to compare against.

To Watch Point to a Specific Object:

 ■ Right-click the object and select Add Watch Window from the con-
text menu.

Watch Three Point Frame

Watching a three point frame is a fairly unique operation. It involves 
watching three 3-DOF devices simultaneously, wherein the device’s 
points define a frame’s origin, X axis, and XY plane. The watch window 
then shows the transform of this frame in the working frame.

For this command to be useful, the three instruments must be aligned 
to the same coordinate system—that is, they must be located to each 
other. Otherwise, the spatial positioning of the three points won’t 
make sense.

If you have an object in which three points define a repeatable frame, 
you can use this command to easily determine the position and ori-

Warning:  When compar-
ing to a line, ensure that 
your projection options 

are correct. If you want to com-
pare the center of the probe to a 
line, offsets should be overridden 
to zero.
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entation of the object. If you then create and activate a correspond-
ing coordinate frame representing a desired end state, this watch 
window represents the deviation needed to get to the active frame.

Figure 17-2. A three point 
frame watch window.

To Watch a Three Point Frame:

1. Ensure that the interfaces for three separate 3-DOF devices 
are running.

2. From the menu, select View>Watch Window>Add Three Point Frame.

3. Select the instrument whose point will define the origin of 
the frame.

4. Select the instrument whose point defines the X axis of the 
frame.

5. Select the instrument whose point lies in the XY plane.

Watch Two Point Axis Alignment

Often, two points defining the axis of an object must be measured 
and adjusted to either match a nominal orientation, or to match a 
prescribed pitch and yaw.

This watch window allows you to measure two discrete points with 
a single instrument. The watch window then indicates the pitch (el-
evation) and yaw (azimuth) of the measured axis relative to the pre-
scribed axis (Figure 17-3).

The working coordinate frame defines the vertical direction—there-
fore its Z axis is used in the calculations.
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To Watch an Axis Using Two Point Axis Alignment:

1. Measure or construct two points along the axis that serve as 
the nominal or “goal” points.

2. From the menu, select View>Watch Window>Watch Two Point Axis 
Alignment.

3. Select the instrument to use for measurements.

4. Select the first and second points, defining the X axis (from the 
first to the second). The measured X axis is along the direction 
from the first to the second points. The Z axis is clocked along 
the working Z axis, therefore if pitch to gravity is desired, this 
axis should be along gravity.

Figure 17-3. Two Point Axis 
Alignment.

5. The Monitor Axis dialog appears.

6. Specify the group name in the text field, if desired.

7. Click Target 1 and Target 2 to measure the points and associate 
them with the ends of the axis. The pitch and yaw values will 
update.

8. To automatically measure both targets (assuming you have at 
least two targets installed and a steerable instrument), click 
the Cycle Targets button. The instrument will point, search for, 
lock on, and measure each target.

9. As repeated measurements come in, SA will automatically 
increment the group name and put each repeated measure-
ment in a separate group.

Watch Theodolite Observer Point to Point

When using the Theodolite Data Observer (see the “Measurement” 
chapter), this watch window compares the latest computed point to 
a selected point. For instance, if you have three bundled theodolites, 
and they are all focused on a common target, you can query the in-
struments with the Theodolite Data Observer to calculate the posi-
tion of the target. This watch window will compare this position to a 
specified point. Note that target offsets are not used here.

Note:  Cycle Targets will not 
work if the axis points have 

moved beyond a reasonable 
search region for the instrument.
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To Watch Theodolite Observer Point to Point:

1. Ensure that the Theodolite Data Observer is up and running, 
and that your instruments are bundled (see the “Measure-
ment” chapter).

2. From the menu, select View>Watch Window>Add Theodolite Observ-
er Point to>Point.

3. Select the point to compare against.

4. As updated data arrives from the theodolite data observer, 
the watch window will automatically update.

Watch Theodolite Observer’s Point

Similar to “Watch Theodolite Observer Point to Point” on page 536, 
except the point’s coordinates are displayed—no comparison is per-
formed to another point. Note that target offsets are not used here.

To Watch the Theodolite Observer’s Point:

 ■ From the menu, select View>Watch Window>Add Theodolite Observ-
er’s Point.

Watch Theodolite Observer’s Data

This watch window displays all data from the Theodolite Data Observ-
er, depending on the settings in the Theodolite Data Observer. For 
instance, it will display instruments and theta/phi angles from those 
instruments.

To Watch Theodolite Observer’s Data:

 ■ From the menu, select View>Watch Window>Add Theodolite Observ-
er’s Data.

Watch Window Options
Right-clicking a watch window will present a context menu contain-
ing a number of options for changing how data is represented and 
displayed. These options are discussed below.

Precision

The number of decimal places used to display watch window data 
can be controlled. Depending on the necessary accuracy and the 
user’s tolerance for quickly-changing values, the default values may 
provide too much precision (revealing noise and resulting in quickly-
changing numbers) or too little (yielding insufficient detail for the re-
quired accuracy).
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By default, SA uses the default length and angle precision set in the 
User Options. However, you can use any preferred precision. The op-
tions when changing decimal precision are as follows:

 ■ Use SA Significant Digits. When selected the watch window 
will use the software defaults. Deselect this to use custom pre-
cision settings for the watch window.

 ■ Length. The number of decimal places to use for displaying 
linear values.

 ■ Angle. The number of decimal places to use for displaying an-
gular values.

To Change a Watch Window’s Decimal Precision:

5. Right-click the watch window and select Precision from the 
context menu. The Watch Window Significant Digits dialog 
will be displayed (Figure 17-4).

Figure 17-4. Changing 
decimal precision in a watch 
window.

6. Apply your desired settings, then click OK.

Font

Watch windows can be displayed in a custom font. You can change 
the font and style. (Although you can change the font size, this set-
ting is ignored and the size of the window itself is used for determin-
ing text size).

To Change a Watch Window’s Font:

1. Right-click the watch window and select Font from the con-
text menu.

2. In the font dialog, select the desired typeface and style, then 
click OK.

Text Color

You can change the text color for the watch window on a row-by-row 
basis.

To Change Watch Window Text Color:

1. Right-click on the row in the watch window that you’d like to 
modify.
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2. From the context menu, select Text Color.

3. In the color dialog, choose a new color, then click OK.

Background Color

You have row-by-row control over the background color used in the 
watch window.

To Change Watch Window Background Color:

1. Right-click on the row in the watch window that you’d like to 
modify.

2. From the context menu, select Background Color.

3. In the color dialog, choose a new color, then click OK.

Highlight Color

If a prescribed tolerance for a watch window is exceeded, the out-of-
tolerance values will be highlighted. You can control the color used 
for this highlight.

To Change the Watch Window Highlight Color:

1. Right-click on the row in the watch window you’d like to mod-
ify.

2. From the context-menu, select Highlight.

3. In the color dialog, choose a new color, then click OK.

Arrow Settings

When a watch window is displayed that is comparing to another en-
tity, arrows are displayed in the graphical view as a way to visualize 
the deviations. You can control how these arrows are depicted using 
the options in the Watch Window Settings dialog (Figure 17-5).

Figure 17-5. Watch window 
arrow settings.

 ■ Arrows. Specifies which arrows should be displayed: X, Y, Z, 
and/or magnitude. The X/Y/Z arrows show the dX/dY/dZ val-
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ues. Magnitude shows the shortest distance between the 
watched item and the entity it’s being compared against.

 ■ Minimum Length (Static). The real-world minimum deviation 
below which an arrow does not get any shorter.

 ■ Minimum Length (Pixels). The shortest length that any arrow 
can be drawn in the graphical view.

 ■ Maximum Length (Static). The real-world maximum devia-
tion above which an arrow does not get any longer.

 ■ Maximum Length (Pixels). The longest length that any arrow 
can be drawin in the graphical view.

To Change Watch Window Arrow Display Settings:

1. Right-click the watch window and select Arrow Settings from 
the context menu.

2. Choose the desired options, then click OK.

Group Name

When viewing a watch window to closest point, by default the group 
name for the watched point is displayed in the window. You can turn 
this off, if desired.

To Toggle Display of Group Names:

 ■ Right-click a closest point watch window and toggle the Show 
Group Name context menu item.

Showing/Hiding Rows

Individual rows in a watch window can be shown or hidden. For in-
stance, if you are only interested in adjusting the XY position of a fea-
ture, you can remove the Z component from the window to prevent 
confusion and simplify the display.

To Show or Hide Rows in a Watch Window:

 ■ Right-click the desired row and select Hide Row Items from the 
context menu to hide a row, and select Show All Items to restore 
all rows.

Coordinate System

Watch windows can display data in one of three coordinate system 
types: Cartesian, Cylindrical, or Spherical. In the cylindrical/spherical 
case, the XY axes of the coordinate frame define the θ plane. In the 
spherical case, the Z axis of the coordinate frame defines the φ=0 di-
rection.
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To Change the Coordinate System for a Watch Window:

Right-click the watch window and select Cartesian, Cylindric, or Spherical 
from the context menu.

Frame of Reference

By default, watch window data is displayed with respect to the work-
ing coordinate frame. Sometimes, you may wish to display the data in 
a specific coordinate frame, regardless of the working frame (Figure 
17-6). For instance, you may have the World frame active but want to 
view a specific watch window in Local coordinates.

Figure 17-6. Changing the 
frame of reference for a watch 
window.

 ■ Use working frame. Always represents the values relative to 
the working coordinate frame. This is the default.

 ■ Use specific frame. When selected, a specific coordinate frame 
is used for data representation, regardless of the active frame.  
The selected frame can be changed using the Pick button.

To Change a Watch Window’s Frame of Reference:

1. Right-click a watch window and select Set Frame of Referece [FoR] 
from the context menu.

2. Select the desired option, then click OK.

UDP Broadcast

Watch windows can be configured to transmit their data over TCP/IP 
using the UDP Protocol (Figure 17-7). This is useful for intercepting 
watch window data with your own custom code.

Figure 17-7. UDP Settings.

Warning:  This setting 
(along with others) is 
saved for a particular 

watch window type. If you forget 
to set this back, you may view a 
watch window at a later time with 
respect to the incorrect frame.



542

SPATIALANALYZER USER MANUAL

Options for UDP transmitting are as follows:

 ■ Transmit Watch Window Text over Network. When enabled, 
data is transferred over TCP/IP.

 ■ Send To. UDP packets can be transmitted to the entire subnet, 
which is referred to as a broadcast. Or, it can be directed to a 
specific destination (Single destination).

 ■ Computer Name or IP. If transmitting to a specific destination, 
the IP address or computer name of the recipient.

 ■ Port. The port over which the data should be transmitted.

To Transmit a Watch Window’s Data over UDP:

1. Right-click a watch window and select UDP Network Transmit Set-
tings from the context menu.

2. Select the desired options, then click OK.

Tolerances

You can set tolerances for watch windows that provide deviation val-
ues. Depending on the type of watch window, this may just be a mag-
nitude tolerance (for watching objects) or individual component tol-
erances (when watching points). The Vector Tolerance dialog, which 
allows setting component tolerances, is shown in Figure 17-8.

Figure 17-8. Setting compo-
nent tolerances for a point to 
point watch window.

In this dialog, you can enable or disable individual component toler-
ances, set all high or low tolerances to a given value, or set them all to 
a symmetrical value.

To Set Tolerances on a Watch Window:

1. Right-click the watch window and select Default Tolerance from 
the context menu.

2. Set the desired options, then click OK.

Projection Options

As is the case with relationships and queries, you can control how de-
viations are depicted in a watch window. This is handled through the 
watch window’s projection options.
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The projection options for a point-based watch window are shown in 
Figure 17-9:

Figure 17-9. Projection 
options for a point to point 
watch window.

 ■ Nominal-Actual. Deviations show the delta from the “nominal” 
or reference point to the measured point. This presents the de-
viation from an inspection point of view—that is, how far is the 
measurement from nominal?

 ■ Actual-Nominal. Deviations show the delta from the mea-
sured point to the reference point. This presents the deviation 
from a build point of view—that is, how far do I need to move 
the probe to get to nominal?

Projection options for an object-based watch window are shown in 
Figure 17-10. There are four available indicator styles:

 ■   Deviations are from the measurement to the design—
that is, they reflect the “build” point of view.

 ■    Deviations are from the design to the measurement—
that is, they reflect the “inspect” point of view.

 ■     Deviations are the same as the “build” option above, but 
the arrows are drawn with their tails at the center of the probe.

 ■     Deviations are the same as the “inspect” option above, 
but the arrows are drawn with their heads at the center of the 
probe.

 ■ Ignore Edge Projections. This option is ignored.

 ■ Offset Value. The desired offset value when overriding the 
probe’s offset.

 ■ Override Target Value. When enabled, the probe’s offset is 
overridden by the provided value.

 ■ Add Extra Material Thickness. Adds virtual thickness to the 
objects being compared against. This is useful, for example, 
when you have an OML surface in your CAD model but you’re 
actually comparing to an IML, assuming a certain thickness for 
the material.
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Figure 17-10. Projection 
options for an object-based 
watch window.

 ■ Tolerance Value. This value is ignored.

To Set Projection Options for a Watch Window:

1. Right-click the window and select Projection Options from the 
context menu.

2. Enter the desired settings, then click OK.

Transparency

Watch windows can be made transparent, so that their backgrounds 
are invisible. The window border can also be made partially transpar-
ent. This allows you to see what’s going on in the graphical view while 
a watch window is being displayed.

To Make a Watch Window’s Background Transparent:

 ■ Right-click the watch window and enable the Transparent Back-
ground option.

To Make a Watch Window’s Border Partially Transparent:

1. Ensure that Transparent Background is enabled (see above).

2. Right-click the watch window and select Adjust Frame Transpar-
ency from the context menu.

3. Adjust the transparency to the desired level, then click OK.
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Google Glass App
NRK has developed an app for Google Glass that allows you to view 
watch window data in a heads-up-display directly on your Google 
Glasses (Figure 17-11).

Figure 17-11. The watch 
window on the Google Glass 
app.

Since the app is not yet available on the Google App store, the fol-
lowing provides instructions for “side-loading” the app onto a Google 
Glass device—this is not necessary when adding apps from the 
Google store.

To Install the Google Glass App:

1. Download the Android SDK ADT Bundle for Windows: http://
developer.android.com/sdk/index.html

2. Extract the downloaded .zip file anywhere on your machine 
(the resultant directory will be referred to as <SDKDir>).

3. Run the SDK Manager (<SDKDir>\SDK Manager.exe), it 
will download the latest list of available packages and might 
immediately conclude that updates are available, if so click 
the Install packages button and then exit and restart the SDK 
Manager when it is finished.

4. In the SDK Manager in the Packages menu, verify that Sort by 
api Level is selected. Under Android 4.4.2 (API 19) verify that the 
following are either installed or checked to be installed:

 ■ SDK Platform

 ■ Glass Development Kit Preview

5. Under Extras verify that the following is either installed or 
checked to be installed:

 ■ Google USB Driver

6. Click Install Packages if enabled to install/update the neces-

http://developer.android.com/sdk/index.html
http://developer.android.com/sdk/index.html
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sary components.

7. Add the SDK platform-tools directory to your system PATH: 
<SDKDir>\sdk\platform-tools

8. Verify the SDK is setup by entering the below from a com-
mand prompt:

  adb version

9. This should provide you with output similar to the below:

  Android Debug Bridge version 1.0.31

10. On the Glass device, under settings, there’s an option to en-
able USB debugging. Make sure this option is turned on to 
allow communications with the computer.

11. Plug the Glass into your computer’s USB port.

12. The Glass device may prompt you to allow this computer to 
debug, if so, allow it.

13. From a command prompt, enter the following:

  adb wait-for-device

This command will wait until communications with the device are 
available. If it just sits there and never returns you back to the com-
mand prompt, then something is not working. If it returns quickly 
with no output, then the installation is correct. It will eventually time 
out if a connection cannot be established.

14. From a command prompt, enter the following (this assumes 
the .apk file is in the current directory). Replace the example 
.apk filename below with the actual filename:

  adb install SAWatch-YYYY.MM.DD.apk

To Run the Google Glass Watch Window App:

1. Wake up the Glass device (tap the side or angle your head up 
30 degs) so that the main screen is displayed with the time 
and “ok glass”.

2. Either say “ok glass” and then say “watch measurements” or 
tap to get a command menu and then tap to select “watch 
measurements”.

3. Configure SA with a watch window that has UDP broadcast 
enabled to port 10000 and you should see the data displayed 
in the Glass app.

4. If there are multiple watch windows open, you can switch be-
tween them by swiping left and right.

5. To exit the app, either swipe down, or tap then tap again to 



547

CHAPTER 17 ■ WATCH WINDOWS

select Stop.

Note that the app is setup as a Glass “immersion” and it is configured 
to force the screen to stay on while its running. Because of this, you’ll 
want to exit the app when done to preserve battery life.

Uninstalling the Google Glass App:

1. You can remove the app from your Glass device by entering 
the following from a command prompt:

  adb uninstall com.kinematics.sawatch

Troubleshooting

ADB unable to communicate with device, “adb wait-for-device” hangs:

It is possible the USB driver .inf file does not have the correct entries 
for your specific Glass device. Editing the .inf file and then updat-
ing the driver in device manager (and specifying the edited .inf file) 
may fix this.

1. Open Device Manager (right-click My Computer and select 
Manage > Device Manager and find the entry for the Glass de-
vice—it may be under “Other” with a yellow icon indicating 
a problem.

2. Right-click the Glass device and choose Properties > Details. Se-
lect Hardware IDs. You’ll see something similar to Figure 17-12.

Figure 17-12. The Glass 
device in the Hardware IDs 
dropdown.

3. Open the android_winusb.inf file in notepad (this file can 
be found in <SDKDir>\sdk\extras\google\usb_driver.

4. In this file, there will be two sections, Google.NTx86 and 
Google.NTamd64 which must both contain entries match-
ing the hardware IDs shown in the above screenshot. In these 
sections add entries like the below based on the info shown 
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in the device properties window. You can leave other, existing 
entries alone:

[Google.NTx86] 
;  Google Glass 
%SingleAdbInterface%=USB_Install, USB/VID_18D1&PID_9001&REV_0216&MI_01 
%CompositeAdbInterface%=USB_Install, USB\PID_18D1&PID_9001&MI_01 
 
[Google.NTamd64] 
; Google Glass 
%SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_9001&REV_0216&MI_01 
%CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_9001&MI_01

5. Save the edited file and close Notepad; then go back to de-
vice manager, right-click the device and pick the option to 
update hardware drivers; when asked, browse the local com-
puter and find the edited .inf file.

6. Retry the adb wait-for-device command in the install 
section.

App Install Error, “INSTALL_FAILED_OLDER_SDK”

This suggests the Glass device on which you’re trying to install the 
app has an older SW version than what was used when building the 
app. To fix this, update the Glass SW; see the below link for more info:

https://support.google.com/glass/answer/3226482?hl=en

Glass turns off after about a minute and can no longer be used

• Software update XE17 introduced a problem with the on-head de-
tection feature.

1. Try turning off this feature in settings.

https://support.google.com/glass/answer/3226482?hl=en
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Under development.

Measurement 
Uncertainty
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Geometry Fitting
Fitting geometry to measured points is a fundamental and critical as-
pect of almost any metrology analysis task. SA’s Geometry Fit Inter-
face has the capability to fit the following geometric shapes to any set 
of measured points or cloud points:

 ■ Planes

 ■ Circles

 ■ Spheres

 ■ Cylinders

 ■ Lines

 ■ Paraboloids

 ■ Slots

 ■ Cones

 ■ Ellipses

Fitting geometry in SA is completely interactive. You can see and in-
teract with the results of your fit settings in real-time as you mod-
ify them. You can interact with the graphical view, re-select points, 
change geometry types, and reverse offset and geometry directions, 
all while watching your geometry update in the graphical view.

Note:  When fitting slots, 
there are a few rules to fol-

low. If measuring 5 points, obtain 
3 in the middle (2 one side, 1 on 
the other other), and one on each 
end. If measuring 6 points, mea-
sure an extra point in the middle. 
For more than 6 points, distribute 
your points evenly around the 
slot.

This chapter covers a myriad of analysis operations that 
can be performed in SA, from Geometry Fit to fitting 
surfaces to measurements.

Analysis
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Geometry can be fit to any number of measured points, constructed 
points, or cloud points--and it’s fast. For example, you can fit a sphere 
to 640,000 cloud points in about 12 seconds. Unlike some metrology 
software, when you select large numbers of points the geometry is fit 
to all selected points rather than a subsample.

You can easily construct interactive vector groups while tweaking 
settings to visually see how they affect the fit. Easily create cardinal 
points, offset points, or graphs of fit deviations with a single button 
click.

Another powerful feature is the ability to project points to a plane be-
fore fitting the geometry. This allows you to measure several off-plane 
features and project them to the same planar surface.

The dialog (Figure 20-1) is also designed with potential repeated use 
in mind. It enables you to fit multiple geometric features without forc-
ing you to re-select the menu command. This permits you to fit a lot 
of geometry to measured data quickly. When satisfied with your fit, 
simply click the Next button and you’re set to select points for the 
next fit.

Figure 20-1. The Geometry 
Fit interface.

To Open the Geometry Fit Dialog:

 ■ From the menus, select Construct>Geometry by Fitting, or

 ■ Press the default keyboard shortcut of Ctrl+G, or

 ■ To fit geometry to an entire point group, right-click the point 
group in the tree and select Fit Geometry.
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About Planar Offset Methods

Planar offset methods determine what is considered the “positive” side 
of resulting geometry. The positive side of planar geometry (planes, 
circles, and ellipses) is the side toward which the normal faces, and in 
metrology it is typically thought of as the “outside” of the part or the 
side of the surface that was measured (Figure 20-2).

Figure 20-2. Geometry has a 
positive and negative side.

When fitting geometry to points, there are three offset methods that 
can be used to determine the positive side of geometry: Probing Di-
rection, Working Origin Positive, and Right-Hand Rule.

Probing Direction
This is the direction from which the point was measured (Figure 20-3). 
For a line-of-sight instrument such as a laser tracker, total station, or 
laser radar, probing direction is the line-of-sight itself, as depicted by 
the red arrows below.

Figure 20-3. Probing direc-
tions.

For non-line-of-sight devices, the probe direction is the vector of the 
device on which the probe is attached, as depicted by the red arrow 
in Figure 20-4.

Figure 20-4. Probing direc-
tion for a portable arm.

For the purposes of determining the positive side of geometry, the 
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overall probing direction is the average direction of the probing di-
rections for all measured points in the fit (Figure 20-5). Put another 
way, it is simply the average of all of the individual probing directions. 
The figure at right depicts the average probing direction for the plane 
fit from the laser tracker depicted earlier.

Figure 20-5. Average prob-
ing direction.

When probing direction is selected as the planar offset method, the 
positive side of the resulting geometry points generally in the oppo-
site direction as the average probing direction. Put another way, the 
average probing direction points in the same direction as the nega-
tive direction of the geometry. For line-of-sight instruments, the re-
sult is that the positive side of the geometry points back toward the 
instrument, which is usually the desired result. This can be seen in the 
previous figure: The thin green arrow depicting the positive side of 
the plane points back generally in the opposite direction as the aver-
age probing direction.

The advantage of this method is that for most situations, it describes 
the resulting geometry correctly--that is, the “outside” of the geom-
etry is the side from which the measurement was approached.

Working Origin Positive
With this method, the geometry is defined such that the origin of the 
working frame lies on the positive side of the resulting geometry, as 
depicted in Figure 20-6.

Figure 20-6. Working origin 
positive.

This is often used as the planar offset method in situations in which 
probing directions do not exist (for example, when using constructed 
or imported points).

Right-Hand Rule
This method allows you to define the direction of the resulting geom-
etry through selection order--it uses the traditional “Right-Hand Rule” 

Note:  Constructed points 
do not have probing direc-

tions. If no measured points are 
included in a fit, SA will fall back to 
using the Working Origin Positive 
method (described below). If at 
least one measured point is in-
cluded in the fit, then the probing 
direction is used.
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standard. If you curl the fingers of your right hand in the direction 
from the first selected point, to the second, then to the third, your 
thumb will define the positive direction. When using this method, 
the first three points in the fit should be individually clicked to define 
the selection order--then the remaining points can be selected as a 
whole using the marquee selection tool.

Figure 20-7. Defining offset 
direction using the right-hand 
rule.

In Figure 20-7, point M4 was selected first, followed by M3, then M5. 
M6 was selected after the first three points. Because of the orienta-
tion of the first three sequentially selected points, the resulting ge-
ometry points up in this image, as dictated by the Right-Hand Rule.

About Measured Side Settings

In order to properly offset geometry, SA must know on which side a 
feature was measured. For planar geometry (planes, circles, and el-
lipses), the planar offset direction has one of three options: Above 
Plane, Probe Center, or Below Plane.

The radial analogs to these settings, used in geometry such as circles, 
ellipses, spheres, and cylinders, are Inside, Probe Center, and Outside.

Above Plane
With this setting, the line-of-sight to the target (or the probing direc-
tion) points in the direction in which offsets should be applied. This 
is by far the most common measurement situation.  In Figure 20-8, 
the tracker measured several points on the floor. Since the resulting 
plane representing the floor should be offset away from the tracker, 
the Above Plane setting is used. In other words, the SMRs were lo-
cated between the instrument and the measured feature.

Figure 20-8. Offsetting along 
the probing direction using 
Above Plane.
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Probe Center
This setting is used when it is preferred to ignore offsets and instead 
fit geometry along probe centers. This is not as common a setting. In 
Figure 20-9, the Probe Center setting is active. Notice that the plane 
lies along the centers of the measured points--no offset is applied.

Figure 20-9. No offsets are 
applied when the Probe Cen-
ter method is used.

The radial version of Probe Center is equivalent--it implies that no off-
set is applied in the radial (inward or outward) direction.

Below Plane
This setting is used when the desired offset direction is in the oppo-
site direction as the probing direction. With this setting, the geometry 
is shifted back toward the instrument (Figure 20-10).

Figure 20-10. Below Plane 
applies offsets opposite the 
probing direction.

This is most commonly encountered with line-of-sight instruments in 
measurement situations where obtaining a proper line-of-sight to a 
surface is not obtainable, perhaps due to lack of space or the inability 
to move an instrument.  As a result, the measured surface faces away 
from the instrument, and the probe is placed on the edge of the fea-
ture to obtain the measurement. This is often referred to as a backside 
measurement.

Inside
This is a radial setting for geometry such as circles, spheres, cylinders, 
and paraboloids. Inside (Figure 20-11) implies that the probe was 
placed on the inside of the geometry, and therefore the geometry 
should be shifted outward from the probe centers. The following fig-
ure depicts a sphere with the Measured Side set to inside:
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Figure 20-11. Measured 
side is set to inside, since the 
measurements were taken on 
the inside of this sphere.

Outside
This is a radial setting for geometry such as circles, spheres, cylinders, 
and paraboloids. Outside implies that the probe was placed on the 
outside of the geometry, and therefore the geometry should be shift-
ed inward from the probe centers. Figure 20-12 depicts a sphere with 
the Measured Side set to Outside:

Figure 20-12. Measured side 
is set to Outside, since the 
measurements were taken on 
the outside of this sphere.

The Fit Interface

The Geometry Fit Interface for a circle is pictured in Figure 20-13 (the 
available options change slightly depending on the selected geom-
etry).
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Figure 20-13. The Geometry 
Fit Interface

The options common to most geometry types will be discussed be-
low, followed by geometry-specific options.

Common Settings
 ■ Geometry Type Selector. Allows you to select the type of ge-

ometry to fit. This dropdown can be changed at any time to 
switch to a different geometry type.

 ■ Point Selection Buttons. Choose from either Points or Clouds. 
Click the button, then select the points to include in the fit. The 
number of selected points will be displayed below these but-
tons--choose as many points as desired.

 ■ Planar Offset Direction. Determines the planar offset meth-
od of the resulting planar geometry, using one of three pos-
sible methods: Probing Direction, Working Origin Positive, and 
Right-Hand Rule. This setting is used for plane, circle, and el-
lipse fits.

 ■ Reverse. Reverses the current offset direction. If the selected 
planar offset method does not offset in the correct direction, 
click this checkbox to reverse it.

 ■ Measured Side Settings. These settings allow you to specify 
on which side of the feature the specified geometry was mea-
sured. For planar geometry (planes, circles, and ellipses), there 
are planar settings of Above Plane, Probe Center, and Below 
Plane. For solid geometry, there are radial settings of Inside, 
Probe Center, and Outside.

Warning:  Reversing the 
offset direction does two 
things: it reverses the 

positive direction of the geome-
try (so that the normal faces the 
opposite direction), and it chang-
es the direction in which the ge-
ometry is offset from the points.
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 ■ Override. Checking this checkbox allows you to enter a value 
to override the selected probe radii and therefore use a differ-
ent offset value (not applicable to the Probe Center option).

 ■ Reverse Object Normal Vector. Flips the normal direction of 
the resulting geometry, without changing other characteristics 
(such as position or radius).

 ■ Refit Geometry. Click this button to update the fit. If this but-
ton has a blue background, it indicates that the fit is not cur-
rently valid and needs to be recalculated.

 ■ Auto Refit. When checked, changing fit parameters will cause 
the fit to automatically recalculate.

 ■ Project to Plane. When checked, you can select a plane to 
project points to prior to performing the fit.

 ■ Fit Summary. The maximum absolute error and RMS error of 
the fit is displayed in this section.

 ■ Fit Tolerance. The current user-specified tolerance for the fit. 
To enter a new tolerance, type a new number into the field and 
then click Apply.

 ■ View Point List. Opens the Point List for the fit (see below).

 ■ Graph. Displays the Geometry Fit Graph for the fit (see below).

 ■ Fit Details. Displays a detailed, geometry-specific summary of 
the fit. For example, it shows absolute and signed errors, calcu-
lated radii or sphere centers, and other important information.

 ■ Name. Use this field to specify the name for the resulting ge-
ometry. The geometry will be placed into the active collection.

 ■ Make Vector Group. If checked, a vector group will be created 
that represents a comparison between the points and the re-
sulting geometry from the fit. This is an excellent way to visual-
ize errors in the fit.

 ■ Properties. The Properties button opens the properties from 
the vector group representing the fit. This button is only dis-
played when Make Vector Group is checked.

 ■ Cardinal Pts. When clicked, creates cardinal points (centroid, 
axis points, etc.) for the geometry.

 ■ Offset Points. When clicked, creates points offset toward the 
geometry by an amount equal to the probe radius.

 ■ Chart. When clicked, creates a histogram and run chart depict-
ing point errors for the fit.

Warning:  Changing 
some parameters, such 
as removing a point from 

the fit, will not cause an automat-
ic recalculation, even if auto refit 
is checked.  In these cases, the Re-
fit Geometry  button will have a 
blue background, indicating that 
the current fit is invalid.

Note:  The vector group is 
updated dynamically. 

Changing fit parameters will 
update the vector group in 
real-time.

Warning:  Cardinal 
points, offset points, and 
charts are not dynam-

ic. Once created they are not 
updated if fit parameters are 
changed.
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Geometry-Specific Settings
 ■ Lock Radius (Circles, Spheres, & Cylinders). Allows you to 

specify a radius for the resulting geometry. SA will orient the 
specified geometry to minimize errors in the fit.

 ■ Lock Focal Length (Paraboloids). Allows you to specify a fo-
cal length for a paraboloid. SA will orient the paraboloid to 
minimize errors in the fit.

 ■ Lock Included Angle (Cones). Allows you to specify the apex 
angle for a cone. SA will orient the cone to minimize errors in 
the fit.

 ■ Standard [Geometry]/Max Inscribed/Min Circumscribed 
(Cylinders, Circles, and Slots). Specifies a different type of fit 
for cylinders, circles, or slots. Standard performs a traditional 
fit by minimizing errors. Max inscribed finds the largest geom-
etry that fits inside the specified points, whereas Min Circum-
scribed finds the smallest geometry that fits around the speci-
fied points.

 ■ Round/Square (Slots). Used to specify whether a slot should 
be round or square.

 ■ Guess Before Each Fit/Use Last Fit As Guess/Use Object As 
Guess (Cylinders, Paraboloids, Cones). Specifies how the ini-
tial condition for a fit is determined. Due to the nature of these 
fit types, the initial condition for the fit can have an effect on 
the resulting generated geometry. For example, if there is not 
great axial or radial coverage of a cylinder, it is possible for the 
cylinder fit algorithms to get “confused”. This option helps the 
fit algorithms find the proper solution. Guess Before Each Fit asks 
the algorithm to take a guess as to the initial size and orien-
tation of the geometry before it progresses through the fit to 
find the ideal solution, and is the default setting. Use Last Fit As 
Guess uses the current geometry fit result’s size and orientation 
as the initial condition for the next fit recalculation. Use Object As 
Guess allows you to pick existing geometry of the same type to 
specify the starting condition geometry for the fit algorithm. In 
this way, you can provide a “hint” as to the resulting orientation 
of the geometry. If you find that your cylinder, paraboloid, or 
cone fits are not what you expect, try using this setting to help 
the algorithm with an initial guess.

 ■ Lock Focus Location (Paraboloids). Prevents the current fo-
cus location from changing if a fit recalculation occurs.

 ■ Lock Vertex Location (Paraboloids). Prevents the current ver-
tex location from changing if a fit recalculation occurs.
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Point List

The Geometry Fit Point Listing dialog (Figure 20-14) allows you to 
view individual points and their errors in a geometry fit.

The table contains all points selected for the fit, in addition to their in-
dividual deviation from the best-fit geometry.  For circles and ellipses, 
planar and radial component error is displayed as well. To sort the list 
by a specific attribute (point name, magnitude error, radial error, etc.) 
click the associated column header. Click it again to sort the list in the 
opposite direction.

Any point can be excluded from the fit by unchecking its checkbox, 
and any excluded point can be included again by re-checking the 
checkbox. Unchecked (excluded) points appear with other excluded 
points in the list, so it is easy to find all excluded points.

Figure 20-14. The Geometry 
Fit Point List.

Points that lie outside the specified tolerance in the main dialog are 
colored red. Points in the intermediate tolerance zones are yellow 
and blue, and points inside the first tolerance zone have a white back-
ground.

To Toggle Between Absolute Error and Signed Error:

 ■ Check or uncheck the Abs Value checkbox.

To Remove Selected Points From the Fit:

1. Select one or more points in the list.

2. Do one of the following:

 ■ Click the Check or Uncheck button to include or exclude points 
from the fit, or
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 ■ Right-click any of the selected points and choose Check or Un-
check from the context menu.

To Toggle the Included/Excluded State for the Selected Points in the Fit:

1. Select one or more points in the list.

2. Right-click any of the selected points and choose Toggle.

To Permanently Remove Selected Points From the Fit:

1. Select one or more points to remove.

2. Right-click any of the selected points and choose Remove From 
List.

To Exclude Points Beyond the Specified Error Tolerance:

 ■ Click the Ignore > Tol button.

To Delete Selected Points from the SA Job:

1. Select one or more points to delete.

2. Right-click any of the selected points and choose Delete From 
SA Job.

To Change Limits or Colors for the Tolerance Zone Coloring:

 ■ Click the ellipses button next to the zone color swatches.

Tolerance Zone Coloring
The Tolerance Zone Coloring dialog (Figure 20-15) allows you to 
change the specified limits and coloring for three tolerance zones.

Figure 20-15. The Tolerance 
Zone Coloring dialog.

These zones allow you to characterize errors with three coloring 
zones. This is often useful for users who have a 1, 2, and 3-sigma toler-
ance. Each zone is bounded by limits. The first coloring zone starts at 
greater than Limit 1 and ends at Limit 2. The second zone starts at 
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greater than Limit 2 and ends at Limit 3. The last zone starts at greater 
than Limit 3.

In the figure at left, points with errors >0.005” and <=0.01” are colored 
yellow; points with errors >0.01” and <=0.015” are colored blue, and 
points with errors >0.015” are colored red. For users who only need 
one coloring zone, simply pay attention to the red zone and ignore 
the other two, or set all three zones to the same value.

The tolerance specified in the main Geometry Fit Interface is applied 
as the Limit 3 value.

The Quick-Set Limits section allows you to set a tolerance for Limit 1 
or Limit 3, and then set the remaining limit values based on 1, 2, and 
3-sigma values. Click Restore Defaults to return the values to their de-
fault limits.

Geometry Fit Graph
The Geometry Fit Graph (Figure 20-16) allows you to view an interac-
tive graph of the errors for all points in the fit. It is an excellent way to 
visually find outliers.

Figure 20-16. The Geometry 
Fit Graph makes detection of 
outliers easy.

Any point (outliers in particular) can be removed from the fit by way 
of the graph, and you can also find the point name and error for every 
point.

To Remove an Outlier from the Fit Using the Graph:

 ■ Left-click the point on the graph and choose Ignore Point.
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To View a Point’s Name and Error:

 ■ Left-click a point in the graph. The point name and error will 
appear at the top of the context menu.

In addition to a run chart of the data, you can also view a statistical 
histogram of the data (Figure 20-17).

Figure 20-17. Viewing fit 
data in histogram form can 
also point to outliers or incon-
sistencies in data.

The histogram also includes the Lower Control Limit (LCL), average, 
and Upper Control Limit (UCL) at 2 sigma. As seen above, the histo-
gram can also be used to detect an outlier, in this case located far 
outside the UCL.

By removing the outlier from the fit, the histogram reveals a more 
natural bell-shaped curve (Figure 20-18), as real-world data would 
typically indicate.

Figure 20-18. The outlier has 
been removed from the histo-
gram, revealing a more natural 
Gaussian distribution of data.

Both the histogram and the run chart can be easily copied to the clip-
board for pasting into a report or graphics program.

To Copy a Chart to the Clipboard:

 ■ Display the desired chart, then right-click the chart and select 
Copy to Clipboard.
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Queries
The Query menu contains numerous methods for comparing points 
and objects. A bulk of your analysis needs can be found under this 
menu item. All query commands automatically account for target off-
set unless otherwise noted.

The output of most query commands is either a Query Results dialog 
(Figure 20-19) or a vector group. The result dialog will contain query 
specific results and can be used to create a relationship by selecting 
Create Relationship.

Figure 20-19. The Query 
Results dialog.

A vector group is a graphical depiction of the magnitude between 
points and objects (Figure 20-20). It is often displayed with arrows 
(whiskers) showing the deviation from the object to the point. Please 
refer to the Vector Group section for further details.

Figure 20-20. A vector group 
depicting error magnitude 
and direction.

Query Basics

When a point is compared to an object it is projected to the object 
using a local normal and then the difference is calculated (Figure 20-
21). The below example is the result of a point to object query. The dx, 
dy and dz values represent the difference between the point and its 
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projected point in working coordinates. dMag represents the magni-
tude. Conventionally magnitude does not carry a sign but since ob-
jects have a positive and negative side the magnitude sign can be 
used to determine which side of the object the point lies. Also, the 
objects positive side is used for determining target offset direction. 
The target offset is simply subtracted from the calculated distance.

Figure 20-21. The anatomy 
of a query.

Query Point To Object
Displays the deviation of a point to an object. Results displayed in 
Working Coordinates.

Object (Ignore Offsets)
Displays the deviation of a point to an object without compensating 
for target offset. Results displayed in Working Coordinates.

Point
Displays deviation between two points in Working Coordinates.

Circle (ignore offsets)
Displays the deviation of a point to a circle without compensating for 
target offset.

Query Points To Single Point
Creates a vector group contain deviation between selected points 
and single point.

Points
Points to points query results in a distance map between each combi-
nation of points (Figure 20-22).
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Figure 20-22. An Inter-Point 
Distance query finds distances 
between all combinations of a 
set of points.

Curves/Objects
Generates a vector group with deviations from the selected points 
and the closest object (if more than one object is selected).

Circle (Radial and Planar)
Generates two vector groups, one for radial deviation and one for pla-
nar deviation.

Query Group to > Multiple Groups > Organize By Groups
Use this command to instantly compare several groups back to a ref-
erence group. This command will create multiple vector groups: One 
comparing the reference group to group A, another comparing the 
reference group to group B, and so on. This is useful for comparing 
drift checks or doing repeatability studies, enabling you to view de-
viations of multiple measured groups over time.

Multiple Groups > Organize By Points (Gage R&R)
Similar to the “Organize by Groups” command described above, ex-
cept the vector groups contain the same point as seen over time. This 
is particularly useful for viewing the variation of a specific point over 
time (Figure 20-23).
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Figure 20-23. A multiple-
group query organized by 
points.

Query Point Clouds to Objects
Generates vector group containing deviation of individual points in a 
point cloud to object(s).

Query Line to Line Angle
Computes angle and mutual perpendicular between two lines.

Plane Angle
Computes angle and mutual perpendicular between line and the 
normal vector of the plane.

Query Plane to Plane
Computes angle and mutual perpendicular between the two plane 
normals.

Query Frame to Frame
Computes position and rotational difference between two frames ex-
pressed in the working coordinates.

Query Object to Object Direction
Computes angle and mutual perpendicular between the two object 
normals.

Query Sensitivity Cloud to Sensitivity Cloud
Using the SpatialAnalyzer coordinate uncertainty computation capa-
bilities, you can create a cloud of points around a measured point. 
These points represent the “cloud of uncertainty” of the coordinate. 
If you have clouds created for at least two points, you can determine 
the uncertainty of the line between them. The results are presented 
in Figure 20-24.
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Figure 20-24. Querying one 
sensitivity cloud to another.

Query Auxiliary Data
Generates a vector group using auxiliary data (Figure 20-25). This al-
lows the user to view and chart auxiliary data as you would with 3D 
data.

Figure 20-25. The Auxiliary 
Data Vector Group dialog.
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Best Fit Points to Surfaces

Vector Groups
A vector group is a graphical depiction of the magnitude between 
points and objects. It is often displayed with arrows (whiskers) show-
ing the deviation from the object to the point (Figure 20-26).

Figure 20-26. A vector 
group.

By Clicking Surfaces
Creates a vector group from clicking on surface face.

From Existing Vectors
Creates a new vector group from selection of individual vectors.

From Existing Vector Groups
Creates a new vector group from selection of existing vector groups.

Scale Existing Vector Groups
Creates a new vector group scaled about the selected frame.  User 
may select a scale factor for each component of the vectors (Figure 
20-27).
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Figure 20-27. The Scale Vec-
tor Groups dialog.

Copy Vector Groups Excluding Obscured Vectors
Creates new vector group only coping visible vectors. Vectors blocked 
from current point of view are not copied.

Area Profile Check From Point Measurement Probing Directions
Creates a vector group representing the probing direction stored for 
each selected point.

Projection Options
The projection options dialog (Figure 20-28) can be seen in several 
places in SA but is mainly used in Query Points to Objects and re-
lationships. The projection options allow the user to control vector 
group direction, add material offsets, create offset point groups, and 
change probe offset compensation.
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Figure 20-28. The Query 
Point To Surface Options 
dialog.

Offset Probe

Figure 20-29. The Offset 
Probe vector group options.

These two options (Figure 20-29) create vector groups depicting de-
viation of the surface from the probe (left) and of the probe from the 
surface (right, the default option). Both of these options create vec-
tors with the exact same magnitude but exactly opposite in direction. 
The left option therefore depicts a typical “build” perspective (how far 
do I need to go to get to nominal?), whereas the right option depicts 
a typical “inspect” perspective (how far am I from nominal?).

Offset Surface

Figure 20-30. The Offset 
Surface vector group options.

These options (Figure 20-30) create vector groups with the head or 
tail on the center of the target and all offsets applied at the object. 
This is sometimes used with thin parts to prevent the vector from dis-
appearing behind the nominal surfaces.
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Make Point Group

Figure 20-31. Projection op-
tions for making point groups.

These options (Figure 20-31) create point groups instead of vectors. 
The first option applies any offset at the probe center. Unless addi-
tional material thickness is added, this represents the probe’s contact 
point on the surface. The second option applies all offsets at the sur-
face, and the third option creates projected points on the object to 
which the query is being performed.

Ignore Edge Projections
The Ignore edge projections option is used when you would like to ignore 
points whose projections onto objects lie on a surface edge (Figure 
20-32).

 

Figure 20-32. Two points 
which are edge projections.

Probe Offsets
The geometry offset allows the user to use the point specific offset 
or override the offset (Figure 20-33). The “Use the target’s values” will 
display the offset of the selected points.

Figure 20-33. Probe offset 
options.

Vector Group Properties
The vector group properties allow the user to view vector group sta-
tistics as well as change the graphical appearance (Figure 20-34).  
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Figure 20-34. The properties 
of a Vector Group.

Display Settings
 ■ Label Vectors With Values. Display each vector’s magnitude 

(Figure 20-35).

Figure 20-35. A set of vec-
tors that have been labeled 
with values.

 ■ Vector Magnification. Magnifies the graphical length of the 
vector. Improves viewing when deviation is small.

 ■ Line Width. Increase the graphical width of the vector for im-
proved viewing.

 ■ Show Out of Tol Only. Only displays vectors that are out of 
tolerance.

 ■ Draw As. Draws the vectors as arrows, blotches, tubes, or 
blotches with arrows (Figure 20-36).
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Figure 20-36. Different 
methods for depicting error.

 ■ Color Bar Appearance. Displays color bar and options for col-
or bar display (Figure 20-37).

Figure 20-37. A vector group 
color bar.

Edit Colorization
 ■ Tolerance. Set the High and Low Tolerance as needed. Use 

Auto-Range Limits to set the High and Low Saturation Limits.

 ■ Color Ranging Method. Pick from five preset color ranges.
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Figure 20-38. Vector group 
colorization options.

Report
The Report button will generate a report showing each vectors begin, 
end and delta coordinates (Figure 20-39). It also displays magnitude 
with the respective colorization. This report can be printed or export-
ed from this dialog. This report can also be generated in other formats 
such as Quick and Composite reports.  

Each column can be sort ascending or descending when name value 
is double left-clicked.

Figure 20-39. Viewing a vec-
tor group report.

Chart
The chart button will generate one of three predefined charts (Figure 
20-40).



579

CHAPTER 20 ■ ANALYSIS

Figure 20-40. Chart Type.

The user can select the inputs for the chart type (Figure 20-41):

Figure 20-41. Axis settings 
for the charts.

Once the chart is generated (Figure 20-42) it is saved in the SA Treebar.

Figure 20-42. The resulting 
generated chart.
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Chart Options

Figure 20-43. The options 
for a moving range chart.
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Relationships
Relationships can be used for automatically updating dynamic 
changes between objects, make creating vector groups for analysis 
faster, provide a quick overview of the status of build operations and 
enable you to optimize your measurement directly against design 
constraints.  

Relationships can also be used as a fitting tool.  By optimizing rela-
tionships a user can transform points and objects to an optimal posi-
tion.  Please see the Minimizing Relationships section as it is a feature 
of SA Ultimate.

Relationship Types

Relationships can cover a combination of point, points and object 
comparisons.

Point to Point
Reports deviation between two points.

Point to Object
Reports deviation between a point and object.

Points to Objects
Report deviation between multiple points and multiple objects.

Point Clouds to Objects
Reports deviation between point clouds and multiple objects.

Groups to Objects
Report deviation between multiple groups and multiple objects.

Frame to Frame
Reports a delta transform between two frames expressed in the work-
ing frame.

Group to Group
Report deviation between points in two point groups.

Object to Object Direction
Reports the angle and mutual perpendicular between two object 
normals.

Geometry Comparison
Functionality includes comparing measured points to nominal ob-
ject, comparing object to object or fitting measured points.  See the 
Geometry Relationships section below for more information.
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Relationship Properties
Most relationships have properties that can effect how a relationship 
is used for fitting and reporting. Here the user can control tolerances, 
projection properties, etc. (Figure 20-44).

Figure 20-44. The Vector 
Tolerance dialog.

Report Options control how the deviations will be reported (Figure 
20-45).

Figure 20-45. Relationship 
report options.

The summary contains a snapshot of the relationship (Figure 20-
46). The complete options will display all the individual deviations.

Figure 20-46. Relationship 
summary.

Fit settings
The Relationship Fit settings are covered under the Minimizing Rela-
tionships section.
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Auto Update Vector Group
This option allows a dynamic vector group to be created. Any time 
the relationship updates the vector group will update as well.

Geometry Relationship Overview

Geometry Relationships allow for dynamic fitting and comparison of 
geometry. Three relationship types allow the user to “Fit and Compare 
to Nominal”, “Fit Only” and “Compare Only”. Relationships are dynamic 
in nature and update when associated data moves. So as points are 
measured, moved, updated, etc…the relationship will re-compute, 
updating geometry and comparisons.

Geometry Relationship Properties
The Relationship Properties consist of the geometry specific fit op-
tions. Right-click the relationship and select properties, the respec-
tive fit options will appear (Figure 20-47).

Figure 20-47. Geometry rela-
tionship properties.

Report Options
The report options for the relationship will allow the user to set many 
parameters (Figure 20-48). The interface will allow the user to choose 
which components of the fit or comparison to report. In addition, tol-
erance and relationship optimization settings can be accessed.
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Figure 20-48. Geometry rela-
tionship report options.

Each component has the ability to be used in a relationship minimiza-
tion, allowing a user to fine tune a relationship fit based on geometry 
components (Figure 20-49). The user has the ability to minimize based 
on delta and/or the amount out of tolerance. This allows the fit to 
drive the delta to zero and/or bring the amount out of tolerance to 
zero.

Figure 20-49. Adjusting ge-
ometry relationship criteria.

Fit and Compare to Nominal
Specify a nominal geometry and points as inputs and the respective 
geometry will be fit and compared. For example, specify a nominal 
circle and measured points. A measured circle will be fit and com-
pared to the nominal (Figure 20-50). Adding a callout for the relation-
ship will yield the comparison.
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Figure 20-50. A Fit and Com-
pare to Nominal geometry 
relationship.

Fit Only
Specify points for fit and choose geometry type to fit. New geometry 
will be created (Figure 20-51).

Figure 20-51. A Fit Only 
geometry relationship.

 Compare Only
Select two geometries of the same type to compare (Figure 20-52).
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Figure 20-52. A Compare 
Only geometry relationship.

Minimizing Relationships

See section Minimizing Relationships.
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Uncertainty Analysis

Coordinate Uncertainty

SpatialAnalyzer provides powerful coordinate sensitivity analysis 
functions. Essentially, uncertainty is determined by injecting normal-
ly distributed, random error into the measurement system and evalu-
ating the effect of the error on the coordinate data. The amount and 
type of error that is inserted is based on the precision of the measur-
ing device.

Uncertainty Analysis and Visualization

SpatialAnalyzer is able to compute and report measurement uncer-
tainty estimates for each of the instruments it interfaces to. Looking 
through a long list of computed uncertainty estimates often provides 
little insight into the specific effects that it might be having on the 
measurement job. To enable users to make tangible use of the un-
certainty estimates, SpatialAnalyzer can generate a cloud of points 
(around a target) that represents the target’s region of uncertainty. 
The point cloud is called a sensitivity cloud.

Creating Point Uncertainty Fields

Uncertainty fields can be created for selected points (Figure 20-53). 
The uncertainty is calculated by using the respective instrument un-
certainty model and the number of samples entered.

Figure 20-53. Uncertainty 
fields for several measure-
ments.

The uncertainty values can be accessed via the point properties or a 
report. The uncertainty cloud display properties can be changed un-
der the User Options.
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Figure 20-54. Uncertainties 
as listed in the Target Informa-
tion dialog.

Deleting Uncertainty Fields

Use Delete selected Point Uncertainty Fields to delete individual point un-
certainties or use Delete All Point Uncertainty Fields to delete all calculated 
point uncertainties for the SA job.

Thinning Point Uncertainty Fields

Reduced the amount of samples for selected points.
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GD&T Inspection
This feature of SA supports the engineer’s ability to read and imple-
ment GD&T design from CAD drawings. The GD&T design gives the 
measurements relativity, and once those points are known, the data 
can be arranged. SA allows the technician to encode CAD with anno-
tations indicating curvature, diameter or true position. In SA, you go 
measure then validate the code’s pass or failure. The feature checks 
assign and validate measurements, and you can also generate re-
ports.   Another feature is that in addition to process flow, manual 
creation is allowed with imported CAD files that need to be anno-
tated.  So it is not only compatible with GD&T notations, a user can 
create them on files when necessary, making it easier to implement 
GD&T.

With SA, engineers and mechanical technicians can more easily im-
plement and integrate GD&T into their daily work, using the tools it 
provides, as well as work on their own customized annotations. GD&T 
has been around for the past 36 years, and it will continue to change 
the industry and the way that measurement is conveyed.

Import CAD with GD&T annotations

To  the  import a CAD model with annotations use File>Import>Direct 
CAD Access. See Direct CAD Access for supported formats.

In the Direct CAD Access Settings dialog (Figure 20-55), check the An-
notations option.
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Figure 20-55. Direct CAD 
Access import settings.

Once imported, the annotations will appear graphically and in the 
tree under Annotations (Figure 20-56).

Figure 20-56. Annota-
tions have been successfully 
imported.
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 Creating GD&T annotations

If a CAD file with GD&T annotations is unavailable GD&T annotations 
can be created/modified inside of SA using the GD&T menu, or the 
GD&T Toolbar can be used.

When creating a Datum or Feature check from the tool bar, the user 
will be asked to select the respective surface faces. The annotation 
editor will be appear allowing the annotation parameters to be en-
tered.

GD&T Datum Annotation Properties

 ■

Figure 20-57. Annotation 
properties.

Name. Datum name used for graphical annotation.

 ■ Measurement Profile Name. Sets the measurement mode 
for the selected instrument when the Datums is created for in-
spection.

 ■ CAD Feature. Prompts user to select CAD faces for the respec-
tive feature.

 ■ View. Changes orientation of annotation.

 ■ Text Height. Defines the height of the annotation text. Ex-
pressed in job units.

 ■ Text Rotation. Defines rotation in the current view.
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GD&T Feature Check Annotation Properties

 ■

Figure 20-58. Properties for 
a True Position check.

Type. Feature check type.

 ■ Name. The name of the check used to describe the annotation 
in the SATreebar and Reporting.

 ■ Measurement Profile Name. Sets the measurement mode 
for the selected instrument when the Datums is created for in-
spection.

 ■ CAD Feature. Prompts user to select CAD faces for the respec-
tive feature.

 ■ View. Changes orientation of annotation.

 ■ Text Height. Defines the height of the annotation text. Ex-
pressed in job units.

 ■ Text Rotation. Defines rotation in the current view.

 ■ Text Above and Text Below. Adds additional text above and 
below the annotation.

 ■ Number of Primary, Secondary and Tertiary Datums. Enter 
the respective Primary, Secondary and Tertiary Datums if ap-
plicable.

 ■ Material Modifiers. Defines the material modifier for the se-
lected datum. Choose from Maximum Material Condition, 
Least Material Condition and Regardless of feature size.
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 ■ Zone. Applicable tolerance zone

 ■ Tolerance. Tolerance value for the feature check.

 ■ Material Modifiers. Defines the material modifier for the fea-
ture check selected datum. Choose from Maximum Material 
Condition, Least Material Condition and Regardless of feature 
size.

 ■ Has Projected Zone. If checked, the projected zone will be 
used.

 ■ Projected Zone Value. Value used when Projected zone is be-
ing used.

Figure 20-59 illustrates how the settings in the property grid relate to 
the annotation graphic:

Figure 20-59. Anatomy of a 
GD&T annotation.

Graphical Placement of Annotations

With the annotation editor open the graphical annotation can be 
moved and placed in a position that is easy for the user to read. The 
annotation leader line is defined when the first surface face is selected 
under the CAD Features parameter. To move the annotation simply 
select the annotation in the graphics by left-clicking the annotation. 
While holding the left mouse button the annotation can be moved 
in the plane of the selected view. The view can be change under the 
View parameter in the annotation editor. Controls at the bottom of 
the annotation editor help in fine tuning the position and orientation 
of the annotation.

 ■ Rotates the annotation box 90 degrees counter clockwise.

 ■ Rotates the annotation box 90 degrees clockwise.

 ■ Mirrors the annotation box.

 ■ Straightens the leader line normal to the selected surface 
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face.

While moving the annotation, Alt can be combined with the left 
mouse button to move the annotation along the leader line.

Quick Annotation Creation
The GD&T tool bar (Figure 20-60) has several methods that aid in cre-
ating annotations quickly. In the tool bar the user can predefine view, 
tolerance, and datums. So once the surface faces are chosen the an-
notation properties are populated.

Figure 20-60. The GD&T an-
notations dialog.

Inspecting a GD&T Feature

To inspect a feature simply right-click and select make feature check 
(Figure 20-61). The annotation will be decoded and the appropriate 
datum and feature checks will be created.

Figure 20-61. 

Now measurements need to be associated to the datums and feature 
checks. There are two ways to associate data, manually associate or 
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trap measurements.

To associate data right click the respective datum or feature check 
and select Associate Data (Figure 20-62).  The user will prompted to se-
lect the points.

Figure 20-62. Associating 
data.

Trapping measurements allows any measurement coming from an 
instrument to be associated to that datum or feature check.  Right-
click Trap Measurments from an instrument to start trapping and Stop Trap-
ping Measurements to stop the association (Figure 20-63).

Figure 20-63. Choosing to 
trap measurements.

To clear point associations right-click and select Clear Point/Cloud Associa-
tions.

Reporting

Once all measurements are associated the inspection is complete. 
Use the report bar to view each feature check result (Figure 20-64). To 
create a complete report, right-click the feature check category and 
select “Composite Quick Report”.
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Figure 20-64. An evaluated 
GD&T check in the Report Bar.

Alignment to Part
When performing a GD&T inspection the graphical alignment to the 
part is usually not important. During the evaluation of the feature 
check the data must be aligned to the respective datums. Therefore, 
the alignment will always be changing. For a “feel good”, the data can 
be aligned to any of the datums. Right-click the datum category and 
select “align”.  Here the user can select the datums for alignment (Fig-
ure 20-65). This is for visual purposes only, it will not be used during 
the evaluation of the features. 

Figure 20-65. Aligning to 
GD&T datums.

Guided Inspection

A inspection plan can be created for GD&T. The user can specific 
nominal points and preset views. This will guide the measurement 
technician through the GD&T inspection. To create a Guide Inspec-
tion right-click the Collection, Datum or Feature Check and select 
Inspection>Design. The design dialog will appear. Orient the view as de-
sired and double left click where the user should measure.  A red dot 
will appear marking the area for the user to measure. Press the next 
button in the bottom right hand corner to advance to the next datum 
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or feature. Continue the process until complete (Figure 20-66) .

Figure 20-66. Designing a 
GD&T inspection routine.

When a user is ready to inspect, they right-click the Collection, Datum 
or Feature Check and select Inspection>Inspect. The guided dialog will 
appear (Figure 20-67), prompting the user through the inspection. If 
nominal points are present a red dot will appear. As the user mea-
sures the red dot will advance to the next measurement area. Once 
the nominals for one datum or feature are complete the inspection 
will advance.

Figure 20-67. The inspection 
window.

Feature Inspection Auto Filter

If the measurements are roughly aligned to the part, the Feature In-
spection Auto Filter can be used to automatically associate measure-
ments to datums and feature checks based on proximity to respec-
tive surface faces (Figure 20-68). To perform an Auto Filter inspection, 
simply make the desired feature checks and use the menu command 
GD&T>Feature Inspection Auto Filter. The user will be prompted to select 
either points, point groups or point clouds. This command is extreme-
ly beneficial when working with point clouds. The below interface al-
lows the user to choose surface proximity and thinning options. The 
auto filter will filter the points and clouds to the proximity of the re-
spective surfaces faces and automatically associate to the datum or 
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feature check.

Figure 20-68. Prior to a fea-
ture inspection auto-filter.

Figure 20-69. Auto-filter 
settings.
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Figure 20-70. After the 
feature inspection auto-filter 
command.

GD&T References and Resources

 ■ ASME Y14.5M-1994. http://catalog.asme.org/Codes/Print-
Book/Y145M_1994_Dimensioning.cfm

 ■ Tec-Ease. http://www.tec-ease.com/gdt-tips.htm
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Minimizing Relationships
In most applications one of the goals is to orient measured points to 
critical part features. SpatialAnalyzer is able to help you accomplish 
that task by letting an optimization routine use relationships to drive 
a fitting process. The net effect is the distances defined between ob-
jects in each relationship are minimized. You can use this functionality 
to produce a best-fit between the points and the critical features. So 
by creating relationships between the measured points and the part’s 
critical features you can find orientations that yield the best perform-
ing part. Since SA’s relationships can be made between any object 
types you’re able to define a comprehensive set of part features and 
then optimize their orientation.

Figure 20-71. Relationships 
set up in the tree.

Move Objects by Minimizing Relationships

This is a great way to transform objects and instruments into a co-
ordinate system (Figure 20-72). This is often used when traditional 
alignment methods are not applicable. The relationship minimization 
gives full control over each individual relationship by using weighting 
and fit constraints. The user also has control over the translation and 
rotation degrees of freedom during the minimization. This can allow 
a minimization to translate and/or rotate about user defined axis.

Run Optimization  
This is the default mode of operation. The optimization method per-
forms a version of the steepest-descent algorithm on the system. This 
means it assembles a matrix that is 6 (unknowns) x N (number of 
points), inverts it and determines move directions. Though quick for 
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reasonable data sets, it can take a long time when using a large set of 
points depending on the amount of RAM on the computer. The stop-
ping tolerance is the amount that the objective function (RMS error) 
must repeat by in order to indicate a minima has been reached.

Figure 20-72. The Minimize 
Relationships dialog.

Run Direct Search Optimization
This optimization provides a powerful method for searching the solu-
tion space. It is also required when using the toleranced best-fitting 
options (in the advanced area) since they introduce non-linearities 
into the solution space. This method basically steps in a direction, 
evaluates the fit, then steps in another direction, etc. There is a lot of 
advanced logic built into the search, but at the core, it is a searching 
method. The advantage is that it does not have to assemble a large 
partials matrix and invert it. This means that it can effectively deal 
with huge point sets. The disadvantage is that since it is trying to ex-
haustively search, it can sometimes take a long time to complete. At 
any time during the fit, however, you can cancel the operation and 
use the current location. To use this mode, you set step sizes. They are 
set as a ratio of the position and angular perturbation values in the SA 
units options page. The step size starts at the starting value then de-
cays when it detects no improvement in any direction. Once it decays 
to the Ending step size, a minimum is reached.
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Relationship Fit Settings

Figure 20-73. Relationship 
settings.

Fit Weight
Allows more emphasis to placed on the selected relationship. Often 
times weighting can be tweaked to bring a part in tolerance.

Fit Constraints
A fit region can be described that will represent a “dead” region where 
the solution can satisfy a zeroed out condition.  For example a high 
limit can be set at +0.1 and low at 0. This will define a region from 0 to 
+0.1. When the solution reaches this region, it will stop.

Sub Sample Options
Sub sampling is useful for large data sets (Figure 20-74). Often all of 
the data is not required for the fit.

Figure 20-74. Subsampling 
options.

Outlier Rejection
Outlier rejection is a great way of removing stray data for the fitting 
solution. Stray points can often impose difficulties for the optimiza-
tion.
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Figure 20-75. Outlier rejec-
tion options.
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USMN

Figure 20-76. Part of a large 
USMN network.

Many organizations have standards requiring that measurements in-
clude not only measured values, but also a statement of the measure-
ment’s uncertainty. For instance, the International Organization for 
Standardization (ISO) “Global Product Specification” requires that part 
measurements have both measured values and uncertainties, and 
the National Institute of Standards and Technology (NIST) specifies 
that “a measurement result is complete only when accompanied by a 
quantitative statement of its uncertainty.” In addition, others recom-
mend that measurement systems provide uncertainty statements in 
order to be considered “accredited”.

A lot of effort has been expended in the metrology industry to quan-
tify the accuracies of different measurement systems, along with the 
uncertainties of those measurements. While these laboratory specifi-
cations generally remove other variables from the process and pro-
vide a fairly accurate “apples-to-apples” comparison of one measure-
ment system to the next,   they rarely reflect the achieved values in 
real-world measurement conditions.

In addition, measurement uncertainty statements typically assume a 
spherical uncertainty and do not address the geometric nature of a 
measurement in determining its accuracy.

One might have a reasonable estimate of the uncertainty of a mea-
surement in a sterile lab environment--but what is really needed is 
an estimate of the uncertainty of a real-world measurement. Without 
this uncertainty, it is somewhat reckless to state that a measurement 
does or does not conform to a tolerance. For instance, if a measure-
ment has an uncertainty of +/-0.015”, and the measurement is re-
quired to be 8.125” +/-0.005”, then is a measurement of 8.127” truly 
in-tolerance? In this case, there is a fairly significant chance that the 
actual value is 8.131” (or worse) and is therefore out-of-tolerance. If it 
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were known to a high degree of confidence that the uncertainty of 
the measurement were instead +/- 0.0025”, then one could say with 
high confidence that the measurement is in-tolerance.

There are a number of effects experienced in real-world measure-
ment that are either excluded or not provided in typical instrument 
specifications but which have true impact on real measurement. This 
may be by choice (for marketing reasons) or out of necessity (e.g. the 
inability to quantify errors due to poor operator technique). Some of 
these effects include:

 ■ Measurements are often combined into a network of interre-
lated measurement systems whose combined characteristics 
are dramatically different than the individual source measure-
ments.

 ■ Individual instrument characteristics dictate dramatically differ-
ent uncertainties for a given measurement depending on the 
relative orientation of the instrument and measurement.  (For 
instance, measurements reasonably close to a laser tracker are 
inherently more accurate than measurements in the distance).

 ■ Poor operator technique may have adverse effects on accura-
cies and uncertainties.

 ■ Temperature gradients, fluctuations, wind, and other environ-
mental conditions increase uncertainty.

Based on these factors (and others), it is clear that knowing the uncer-
tainty of a real-world measurement is very valuable.

What is USMN?

USMN (Unified Spatial Metrology Network) is an advanced tool for 
combining common measurements for two or more instruments into 
a single instrument network. It has several major benefits over other 
analysis tools, such as a best-fit:

 ■ It provides a means for calculating a “weighted bundle”: the 
most likely position and orientation for all instruments and tar-
gets in a measurement network.

 ■ It provides the capability of calculating realistic uncertainties 
for measurements in a measurement network.

 ■ It can be used to evaluate the real-world uncertainties of in-
struments on an individual basis.

Let’s consider each of these benefits in order to get a true grasp on 
the benefits of USMN.
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Weighted Bundle

All instruments have different characteristics. Perhaps the simplest 
example is the comparison of a laser tracker and a total station--both 
spherical measurement devices (they each measure a distance, azi-
muth angle, and elevation angle).

Figure 20-77 depicts the uncertainty cloud for a laser tracker. Laser 
trackers have accurate distance measurements, but the angular mea-
surements are not nearly as accurate. Notice how the uncertainty 
clouds inherit a flat “pancake” shape--there is less uncertainty in dis-
tance than angle, so the uncertainty cloud tends to be thin (along the 
line of sight) and wide (perpendicular to the line of sight).

Figure 20-77. A tracker mea-
surement’s uncertainty cloud.

Notice also that as measurements get further away from the tracker, 
the uncertainty becomes larger, manifested as larger uncertainty 
clouds.  (Compare the nearby measurement in the lower-right com-
pared to the more distant measurement in the upper-left).

On the other hand, a total station’s azimuth/elevation angle measure-
ments are very accurate compared to its distance measurements. 
Notice how the uncertainty clouds are elongated and cigar-shaped: 
there are high uncertainties along the line-of-sight, but low uncer-
tainties perpendicular to the line-of-sight (Figure 20-78).
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Figure 20-78. The uncer-
tainty cloud for measurements 
from a total station.

Viewed side-by-side (Figure 20-79), the differing characteristics of 
each instrument result in drastically different measurement uncer-
tainties (in size, shape, and density):

Figure 20-79. Comparing 
the shapes of the two uncer-
tainty clouds.

The uncertainty characteristics of a portable CMM arm are even more 
complex (Figure 20-80), depending on the behavior of the encoder in 
each joint and the configuration of the arm when the measurement is 
taken.
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Figure 20-80. The uncertain-
ty cloud shapes for a portable 
arm.

Now, consider the situation in which a long part is to be measured. 
Due to its shape, this part might require multiple instrument stations 
along its length. In order to tie all of the measurements into a single 
coordinate system, a number of common points are measured be-
tween adjacent sets of instruments, and then these points are best-fit 
together to determine the overall instrument network. For some cas-
es, this method is a perfectly valid approach, and in fact, this is the 
approach taken by other metrology software packages for tying a 
network of instruments together. In particular, fairly small instrument 
networks with low uncertainty requirements can use this approach 
without problems.

However, using best-fit introduces error stack-up, very similar to the 
idea of tolerance stack-up in engineering drawings. This error stack-
up can be significant. Figure 20-81 depicts an instrument network us-
ing a best-fit compared to the true instrument positions (ghosted). A 
slight error for the first set of common points (between Instruments A 
& B) will move the position and orientation of Instrument B out of its 
true position. By fitting Instrument C to Instrument B, not only does 
Instrument C inherit the error from the first set of common points 
(which has now been “leveraged” by its distance from those common 
points), but now errors in the common points between Instruments B 
& C cause even more error to stack up. The end result is a network that 
could potentially be quite different from reality.
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Figure 20-81. Positional 
errors resulting from leap-
frogging an instrument along 
a length.

When more accuracy is desired--or when the measurement network 
is elongated, large scale, fairly 2-dimensional, or C-shaped (non-
closed, meaning the first instrument is not tied back to the last), then 
best-fitting is usually inadequate. Some examples of real-world mea-
surements that get significant benefit from USMN include particle ac-
celerator measurements (very large and mostly 2-dimensional), large 
linear measurements with high accuracy requirements (such as the 
catapult rail on an aircraft carrier), and large “open” networks (such as 
measurement of two sides of a building).

Instead of using a best-fit, USMN takes an intelligent weighted bun-
dle approach. USMN examines each common measurement and con-
siders the characteristics of the instruments that measured them and 
their positions in space.  Components of instrument observations 
which are considered to have low uncertainty are assigned a higher 
weight than components that are considered to have higher uncer-
tainty. If a total station and laser tracker measure a common point 
from different angles, then the angular measurement from the total 
station will be assigned more weight than that of the tracker, and the 
distance measurement from the laser tracker will be assigned more 
weight than that of the total station.

Once these weights are assigned, the instrument transforms are ad-
justed to calculate their most likely positions based on all available in-
formation. The net result is an instrument network that is significantly 
closer to reality than the best-fit network described above.

In summary, USMN considers each instrument’s uncertainty variables 
and perturbs instrument positions in order to get minimal measure-
ment closures on the common points. This is similar to a traditional 
bundle process, except the optimization process uses the estimates 
of the instrument uncertainties and the range of each observation to 
weight the individual contributions for each measurement.

Network Measurement Uncertainties
Instrument measurements (observations) can have uncertainties cal-
culated that indicate the uncertainty of a given measurement rela-
tive to the instrument. But when instruments are networked togeth-
er, this simple uncertainty no longer applies, because the common 
point position in a networked measurement is really determined by 
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a combination of instruments that measured the common point.  In 
fact, in the real world the computed common point in the real world 
never lies on top of any of the component observations (because the 
world is not perfect--unfortunately!). This highlights the second ma-
jor advantage to USMN: the ability to calculate “net uncertainties” for 
common points.

Figure 20-82. The USMN 
composite point. (Note: The 
error between the total station 
and laser tracker measure-
ments are exaggerated for 
clarity).

Refer to Figure 20-82. A total station and laser tracker have measured 
a common target in a nest. Due to noise, operator error, and a number 
of other factors reminding us that the world is not perfect, each in-
strument “sees” the target in a slightly different position in space. As a 
result, the measured points end up in slightly different positions.

Not only can USMN calculate the most likely position of the real target 
based on instrument characteristics (referred to as a USMN Compos-
ite Point), but it can also calculate the uncertainty of that composite 
point. In Figure 20-82, the composite point is closer to the total sta-
tion’s line-of-sight position (due to lower angular uncertainties of the 
total station), but is also much closer to the laser tracker’s distance 
measurement (due to less uncertainty in the laser tracker’s distance 
measurement). The uncertainty of the composite point itself has less 
uncertainty than either of the instrument observations, because 
much of the total station’s uncertainty along the line of sight is ren-
dered extremely unlikely based on the laser tracker’s measurement.

Figure 20-83. Accessing the 
uncertainty variables for an 
instrument.

“Real-World” Instrument Uncertainties
As mentioned earlier, instrument uncertainty values as published by 
the manufacturer are a good way to compare different measurement 
systems, but they are a poor way to predict real-world measurement 
uncertainty. A number of factors, such as the calibration/performance 
of an individual instrument, the technique of the operator, and the 
measurement environment have significant effects on uncertainty.

Each instrument in SA has associated with it Instrument Uncertainty 
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Variables (Figure 20-84). These can be found in the Instrument Prop-
erties window. Uncertainty variables are used to model an individual 
instrument’s uncertainty characteristics.

Figure 20-84. Uncertainty 
variables for a tracker.

If you look at the uncertainty variables for a laser tracker or total sta-
tion, four values are provided (see image). These values together dic-
tate the uncertainties for the horizontal angle, vertical angle, and dis-
tance components for an instrument. They are used in concert with a 
measurement’s relative position from the instrument to determine 
the uncertainty of the individual measurement.

By default, the values assigned to uncertainty variables are experi-
mentally determined, conservative values for a given class of instru-
ment. In other words, they generally give a result that is “in the ball-
park”, but are probably a bit worse (higher uncertainty) than can truly 
be achieved with the instrument. This is done to a) err on the safe 
side, b) avoid conflict with instrument manufacturers, and c) avoid 
the need to continually update data as instruments evolve, which 
could be a time-consuming task.

In order to get the most realistic uncertainties for measurements and 
USMN, it is necessary to use uncertainty variable values that closely 
match the individual instrument, operator, and measurement envi-
ronment characteristics. But how is this done? Manufacturers don’t 
(and can’t possibly) publish these values, and they differ from one 
instrument to the next and (to a lesser extent) from one operator/
measurement situation to the next.

USMN itself can be used to determine the most accurate values for 
these variables. This is done by setting up a set of monuments, and 
then moving an instrument around through the workspace, measur-
ing each of those monuments in turn.

Consider a situation in which an instrument, its operator, and the en-
vironment is perfect (and therefore would have zero uncertainty). A 
perfect instrument, after having measured all monuments from dif-
ferent positions, would see a given monument in the exact same lo-
cation in space. When fit together (using a traditional best-fit), there 
would be zero error. The observations would lie on top of each other 
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perfectly. USMN would see this “perfection” and would report uncer-
tainty variables of zero (no error).

Of course, in reality this never happens. In the real world, an instru-
ment can measure a monument two different times and “see” it in 
a slightly different place. By analyzing the error between measure-
ments of a common point from the same instrument, in different po-
sitions, USMN can perform a complex calculation and determine the 
real-world uncertainty variables for a given measurement situation.

Observations and Point Group Requirements for USMN

When setting up a network for analysis with USMN, there are several 
organizational requirements for instruments, measurements, point 
groups, and point names. These are relatively simple in construction 
as they follow the process commonly used to locate an instrument 
(Figure 20-85).

Figure 20-85. Organizational 
setup for a USMN.

The requirements for USMN analysis are as follows:

 ■ As with any measurement network, common targets must be 
measured by more than one instrument to form a network.

 ■ Individual point names must be common between groups 
as USMN will associate measurements from different instru-
ments based on point names. For example, MeasStation1::P1, 
MeasStation2::P1, … MeasStationN::P1 will be combined to 
compute the composite point P1.

Note:  A group name does 
not need to include a specif-

ic reference to the instrument 
that made measurements to the 
points contained within it.   The 
designation of S1, S2…SN used 
above is to illustrate a convenient 
means of organizing the data for 
USMN analysis.
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 ■ Points without measurements are ignored, unless the point 
group is included as a ‘Nominal Group.’

 ■ A specific point in a given point group should have observa-
tions from only one instrument.

 ■ An instrument can make more than one measurement to a 
specific point. As an example, an instrument can have a front 
and back sight to a point or an instrument might have N front 
sight measurements to a point.

 ■ Observations that are marked as ‘ignored’ are not included in 
the USMN network. The measurement details dialog for a point 
provides an interface to determine whether or not an observa-
tion is ignored.

Consider an example tree for a job ready for a USMN network as seen 
at right.

 ■ Points 1 and 2 (in the Station1 group) have no common mea-
surements with other instruments.

 ■ Points 4, 5, 6, and 7 are shared with Station2.

 ■ Point 9 is shared by Station2 and Station3.

 ■ Point 10 is shared by Station2, Station3, and Station4.

 ■ Points 11-13 are shared by Station3 and Station4.

The points which are measured by more than one instrument station 
will affect the network solution.

The primary output from USMN is a Composite Point Group. This 
group contains the optimal point coordinates (the most likely posi-
tion of the points) after solving the network. Inputs to USMN include 
both the instruments and their measurements. For a measurement to 
affect the calculation, it must have been measured from multiple in-
strument stations. The observations from different stations are made 
into different point groups, but should have the same target name.

USMN Dialog

The primary purpose of the USMN dialog is to help you optimize the 
network confidently and get the best Composite Point Group pos-
sible from the instrument stations and measurements. The window is 
composed of 7 main parts (Figure 20-86).



614

SPATIALANALYZER USER MANUAL

Figure 20-86. The USMN 
dialog.

   1. Instrument Section
This section lists the instruments whose measurements are includ-
ed in the USMN network solution. Instruments can have different 
weights applied. So, for example, if one instrument is known to not 
perform as well as others, its weight might be decreased from the 
default value of 1.

Each instrument has a checkbox indicating whether that instrument 
is allowed to move during the calculation. A USMN bundle (or any 
bundle, or that matter) is a relative solution. That is, the solution can 
be reached relative to any instrument. As a result, all instruments may 
be checked (meaning all instruments will be perturbed to find the 
solution) or one may be unchecked (so that the solution is reached 
by perturbing all instruments EXCEPT the unchecked instrument). 
In both cases, the same end result is reached for the network itself, 
although the networks will end up in different places in space (and 
the uncertanties will be relative to different baselines). Regardless, 
allowing all instruments to move will typically take longer to solve. 
Although the network solution is the same, the calculated uncertain-
ties for the USMN Composite points will be different, because they 
are relative to different baselines. However, the relative uncertainties 
(differences between uncertainties) between each pair of points will 
remain the same.

More than one instrument may be fixed (unchecked) during a solu-
tion, although this is typically only done in rare cases and is generally 
not recommended, as the end result is a solution that is not an ideal 
spatial representation of an instrument network.
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An individual instrument in this list may be double-clicked to access 
specific instrument properties. For example, you can adjust an instru-
ment’s degrees of freedom or change its weight.

2. Measurement Section
This section shows measurement-specific information and has a 
number of columns which are described below:

 ■ Weight. Each measurement can have a weight applied. If a 
point is considered less important or perhaps more erroneous, 
its weight can be reduced.

 ■ Point. Each point measured by an instrument in the USMN net-
work is listed.

 ■ Max Err. The maximum error is listed for each point that has 
been measured by more than one instrument. This depicts 
the maximum error between any individual measurement of a 
point and its optimal value.

 ■ Ranking. Displayed as a percentage, this indicates the per-
centage of the expected 3-sigma envelope consumed by the 
maximum measurement residual. This is an efficient method 
of determining which points may have measurement outliers. 
A point with a ranking of 100% has observations which are 
consuming the entire 3-sigma envelope. Points with smaller 
rankings are more tightly clustered around the optimal value. 
Lower rankings indicate better measurements.

 ■ Ux/Uy/Uz/Umag. The component and magnitude uncertain-
ties (in the active coordinate frame) for the optimal point. 
These values only appear after an uncertainty field analysis has 
been performed.

 ■ Meas. A list of the instruments that have observations for a 
given point.  For instance, point 6 shows 0 _ _ 3, which indi-
cates that instruments 0 and 3 each have a measurement for 
that point.

Further detail for a point can be obtained by double-clicking the 
point in the list.

3. Solve Section
This section contains the parameters and controls for actually calcu-
lating the USMN solution. They are summarized below:

 ■ Auto Solve. This button performs a “Best-Fit then Solve” (see 
below), trims outliers at 100% (see below), then performs a 
“Solve” (see below). This automated process is recommended 
for well-understood networks and in applications where the 
process has to be automated. It is not recommended when first 
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optimizing an unfamiliar network of measurements. Anytime 
outliers are eliminated from the network, the causes and de-
tails should be characterized and documented.

 ■ Do This Automatically. When the USMN dialog is displayed, 
an Auto Solve is automatically performed once.

 ■ Best-Fit Only. Performs a best-fit of the networked points. This 
is equivalent to performing a traditional best fit. Performing 
a best-fit prior to initiating the USMN solve drastically speeds 
up the calculation, because it provides for a much better initial 
starting point for the calculation.

 ■ Best-Fit then Solve. Performs a Best-Fit (see above) and Solve 
(see below) in one step.

 ■ Solve. Initiates a USMN calculation from the instrument’s cur-
rent positions.

 ■ Instrument Settings. Allows you to modify properties for all 
instruments at one time.

 ■ Trim Outliers. Removes points or observations exceeding a 
specified Ranking threshold from the USMN solution. Recall 
that ranking is an indicator of the quality of a point. Points 
above the ranking threshold can either be weighted to zero 
or removed from USMN entirely. Therefore, this is an effective 
means for preventing poor measurements from tainting the 
USMN solution.

 ■ Exclude Measurements. Any measurements that should not 
be included in the USMN calculation can be excluded with this 
button.

4. Uncertainty Field Analysis Section
USMN does not by default calculate the uncertainties of the resulting 
optimal (USMN Composite) points, because this calculation can take 
a fair amount of time. As a result, you must initiate this calculation 
yourself.

Uncertainty field analysis works by using the instrument uncertainty 
characteristics to slightly perturb measurements following a realistic 
Gaussian distribution. Each iteration of perturbed measurements is 
then treated as a separate USMN network. Each iteration is solved in 
turn, which allows for statistical generation of optimal point uncer-
tainties.

 ■ Samples. Specify the number of perturbations, or iterations, to 
perform. Higher numbers take proportionately longer to solve, 
but have more accurate uncertainty values. It has been statisti-
cally determined that 300 or more samples will provide results 
within 5% of the “statistically true” value, so 300 is considered 
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the default. About 10,000-15,000 samples are required to get a 
result within 1% of the statistically true value.

 ■ Time Limit. When checked, the uncertainty field analysis will 
time out at this limit, regardless of the number of samples re-
quested. In this case, the number of completed iterations will 
be used.

 ■ Begin. Initiates the Uncertainty Field Analysis.

5. Reporting Section
This section provides different methods for reporting results.

6. Apply Results Section
This section controls how the calculated results are applied to the job 
file.

 ■ Create Composite Group. When checked, creates the optimal 
(USMN Composite) point group.

 ■ Create Point Uncertainty Fields. When checked, applies un-
certainty fields (calculated via the Uncertainty Field Analysis) 
to the USMN composite points. These fields represent the re-
sulting uncertainty of the network points.

 ■ Apply instrument and point group transforms in SA. If 
unchecked, no instruments or points in SA will be physically 
moved in the file.

 ■ De-Activate measurements weighted to zero. If checked, 
any measurements that have been weighted to zero in the 
Measurement Section will be deactivated in SA.

7. Summary
This section lists a general summary of the USMN calculation, includ-
ing values such as Overall RMS, average point error, uncertainty aver-
age, and other statistical information. It also provides access to infor-
mation about scale bars included in the USMN calculation.

The point list is automatically organized in the interface. Points with 
the highest ranking are listed first. A high ranking indicates a point 
with a higher chance of problems. Points with lower ranking suggest 
the target solution is better.

An auto-solve function automates the solution and outlier trimming 
process. USMN runs with default options without displaying the main 
interface dialog. The results are then applied to the instruments in the 
metrology application automatically.
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Basic USMN Solution Process

The following describes the steps for a basic USMN solution process, 
without calculating uncertainty fields for the USMN composite group.

1. Ensure that the job file matches the requirements in Observa-
tions and Point Group Requirements for USMN.

2. Select Analysis>Coordinate Uncertainty>Unified Spatial Metrology Net-
work.

3. When prompted, select the instruments to include in the 
USMN network, then press Enter.

4. The USMN dialog will be presented (see USMN Dialog).

5. Ensure that the instrument settings are correct (moving/non-
moving, weights, DOF constraints, etc).

6. Click Best-Fit then Solve.

7. Examine the max error and ranking values.

8. If desired, click the Trim Outliers button and trim any measure-
ments beyond your desired ranking.

9. Click the Solve button and observe the results.

10. Verify that Create composite group is checked.

11. Click the Apply button. The instruments/point groups will be 
located, and a USMN Composite point group will be created 
representing the ideal position of each meausurement.

For a more in-depth example on basic USMN, see the tutorial Basic 
USMN.
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Advanced Surface Fitting
From Point Groups (Interpolate)

Creates a interpolated surface by fitting b-splines to each selected 
group (Figure 20-87) and then lofting the b-spline to create a surface 
(Figure 20-88).

Figure 20-87. Fitting B-
Splines to a series of points.

Figure 20-88. A surface 
has now been fit from the 
B-Splines.

From B-Splines (Approximate)
Similar to the above command, this time each b-spline is an approxi-
mate fit. The user has control of the control points, degree of curve 
and the skinning tolerance.

Note:  Points in the selected 
point groups must be in or-

der or the b-spline will be created 
incorrectly.
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Figure 20-89. Defining the 
number of intermediate con-
trol points.

Figure 20-90. Specifying the 
degree of intermediate curves.

Figure 20-91. The skinning 
tolerance indicates how far the 
surface may deviate from the 
B-Splines.

From Plane and Closed B-Spline
Projects selected closed B-spline to selected plane and creates a sur-
face from the projection (Figure 20-92).

Figure 20-92. A closed B-
Spline has been projected to 
a plane.

Fit From Bounding Curves and internal points
Use for B-splines that bound a group of points (Figure 20-93) to create 
a surface (Figure 20-94).
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Figure 20-93. Four bounding 
B-Splines around a surface.

Figure 20-94. The resulting 
surface.

 Fit From Nominal Face and Actual Data
A surface will be created by fitting the selected surface face to the 
selected data (Figure 20-95).
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Figure 20-95. Fitting a sur-
face face to selected data.
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Frame Wizard
The Frame Wizard (Construct>Frame>Frame Wizard) is used to create a 
coordinate frame based on different combinations of entities, which 
can then be optionally offset in the new frame’s X, Y, and Z directions.

Figure 20-96. The Frame 
Wizard dialog.

The Frame Wizard dialog (Figure 20-96) allows you to interact with 
the graphical view while changing the settings for the frame. Once 
enough parameters have been defined to construct a coordinate 
frame, you see the frame in the view and it changes as you modify the 
settings.

The following describes the specific settings for this command:

 ■ Primary Axis. The axis to use as the primary axis for the coor-
dinate frame. Since this axis is primary, it is perfectly parallel to 
the vector constructed by its defining entities. The primary axis 
and secondary axis must make sense--for example, you cannot 
define the +Z axis as primary and the -Z axis as secondary.

 ■ Secondary Axis. The axis to use as the secondary axis for the 
coordinate frame. The plane defined by the primary and sec-
ondary axes will be parallel to the vector constructed by the 
secondary axis’s defining entities.

 ■ Origin. A single point in space that (assuming no offset) de-
fines the origin of the coordinate frame.

 ■ Enter Values in Frame. Click this button to define a new XYZ 
coordinate. The coordinate frame will be shifted such that the 
originally defined origin point ends up at the supplied coordi-
nates.

 ■ Name. The name for the resulting coordinate frame (in the ac-
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tive collection). To change a name, type it in, then click the Ap-
ply button.

 ■ Set Working Frame. If checked, the new coordinate frame will 
be set as the active coordinate frame.

Figure 20-97. A frame 
defined by an origin at point 
Origin, a primary axis (+Z) by a 
cylinder, and a secondary axis 
(+X) by the origin and a point 
named Clocking. No offsets 
have been applied.

Figure 20-98. The same 
frame which has been shifted 
using Enter Values in Frame so 
that the origin ends up at (5, 
5, 5).

The primary and secondary axes can be defined by an object, 2 points, 
or an origin and point:

 ■ Object. The object’s internal normal direction defines the direc-
tion of interest. For example, if a plane is selected, the normal 
to the plane is used. Note that some objects (such as spheres) 
do not define a direction and  therefore cannot be used with 
this option.

 ■ 2 Points. The vector from the first point to the second defines 
the direction of interest.
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 ■ Origin & Pt. The vector from the defined origin to the selected 
point defines the direction of interest.

The origin can be defined by either an object or a point:

 ■ Select Point. A single point will define the position of the ori-
gin. Point offsets are not applied.

 ■ Select Object. An object’s internal origin defines the origin of 
the frame. For example, if a sphere is selected, the center of the 
sphere is used.

To Create a Frame with the Frame Wizard:

1. Select the appropriate primary and secondary axes to define.

2. Click the appropriate buttons to define entities for the pri-
mary axis, secondary axis, and origin. These entities can be 
defined in any order.

3. If desired, enter coordinates to shift the frame using the Enter 
Values in Frame button.

4. Type a desired name for the frame and click Apply.

5. When finished, click the Accept button.
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Pipe Relationships
In some industries, such as nuclear energy and shipbuilding, a com-
mon need is to align mating sections of pipe in order to calculate and 
lay off cut planes so that the pipes can be adjoined with a high-qual-
ity weld. In general, the goal is for these adjacent pipe sections to be 
as coaxial as possible and to share enough material overlap such that 
a valid cut plane can be calculated that enables a quality weld joint.

Consider the example of replacing a steam generator that has reached 
the end of its service life at a nuclear power plant. A nuclear steam 
generator typically has a number of nozzles or pipe openings—one 
variant design has a “hot leg” pipe for hot water, a “cold leg” pipe for 
cold water, and a pipe for steam (Figure 21-1).

Relationships are extremely powerful tools that have a 
number of uses: Dynamic inspection, alignment, virtual 
fit-up, real-time assembly, and optimization can all be 
driven by SA’s relationships. Relationships provide op-
timization results that far surpass traditional methods, 
and without a complicated setup process.

Relationships
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Figure 21-1. A typical steam 
generator, with hot and cold 
legs (bottom) and a steam leg 
(top).

These piping interfaces are critical to the safety and performance of 
the nuclear power plant, and since they provide a direct barrier be-
tween the radioactive and non-radioactive sides of the plant, they 
must be aligned and cut with optimal precision.

Figure 21-2. The steam gen-
erator after virtual assembly.

Since a nuclear reactor must be shut down in order to replace the 
steam generator—and since downtime at a nuclear power plant is 
enormously costly—anything that minimizes this downtime is ex-
tremely beneficial. Historically, cut planes were calculated manually 
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and refined with the steam generator in its final alignment. However, 
this proved to be a time-intensive and therefore expensive process. 
Instead, the steam generator can be digitally assembled (Figure 21-2) 
and resulting pipe cuts can be calculated before the steam generator 
is in its final location (Figure 21-3). As a result, the pipes can be cut 
prior to installation—pipe relationships play a critical role in this pro-
cess.

Figure 21-3. A cut plane cal-
culated by a pipe relationship.

Using Pipe Relationships

The general process of using a pipe relationship is as follows:

1. Define the pipe relationship between mating pipe/fittings.

2. Align the pipes using traditional relationships, pipe relation-
ships, or a combination.

3. If the pipe relationship can find a valid cut plane, the pro-
posed cut can be made. A frame can also be constructed on 
this cut for layoff purposes.

4. After physically cutting one end of the pipe, the actual cut 
plane can be fed into the solution, re-solving for a tweaked 
cut plane on the other end.

5. This tweaked cut plane can then be used to cut the mating 
piece.

Defining Pipe Relationships

Pipe Relationships can be defined between two objects that have po-
sitional and directional information. Typically, this means lines, cyl-
inders, or planes. The particular type of object does not matter—as 
long as the object properly describes the pipe’s position and orienta-
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tion. When a pipe relationship is created, a tube representing the al-
lowable cut region and ID/OD appears in the graphical view, and the 
Pipe to Pipe Relationship dialog is displayed (Figure 21-4).

Figure 21-4. The Pipe to 
Pipe Relationship dialog.

The first step is to define the properties of each pipe segment (Figure 
21-5):

Figure 21-5. Properties of 
a pipe segment in a pipe 
relationship.

 ■ Inner. The inside diameter of the pipe.

 ■ Outer. The outside diameter of the pipe.

 ■ Begin. The start of the permissible cut region, as a distance 
along the pipe axis from its origin. This value should typically 
be less than the End value.

 ■ End. The end of the permissible cut region, as a distance along 
the pipe axis from its origin. This value should typically be 
greater than the Begin value.

A pipe relationship will supply several forcing functions to an optimi-
zation:

 ■ It will try to make the pipe segments coaxial.
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 ■ It will try to make the pipe ends parallel.

 ■ It will try to overlap the cut regions evenly.

After defining the characteristics of the pipe segments, the weighting 
factors for the relationship may be modified, if desired. Typically, the 
default values (Figure 21-6) are sufficient:

 ■

Figure 21-6. Weighting Fac-
tors for a pipe relationship.

Overall Weight. The weight of the pipe relationship as a whole, 
which determines the influence of the pipe relationship in the 
overall optimization scheme.

 ■ Axis Offset. The importance of minimizing the mutual per-
pendicular midpoint between the two pipe segments (i.e. how 
“coaxial” the two pipe segments are). Larger values attempt to 
bring the segments closer together.

 ■ Axis Alignment. The importance of minimizing the angle be-
tween the two pipe segments. Larger values will force the pipe 
segments to be more parallel.

 ■ Center Pull. The importance of overlapping the center of each 
pipe segment’s cut region (along the axis direction). Larger val-
ues assign more importance.

 ■ Weight. The importance of having sufficient material for the 
weld. A value of zero implies that the solution does not care if 
there is sufficient material for the weld.

 ■ Static Offset. A value that controls “how bad” the solution gets 
when there is insufficient material for the weld. Higher values 
assign a larger penalty to having insufficient material, effec-
tively ensuring that material requirement is more crucial in the 
eyes of the solution.

 ■ Constrain Cut to Region at OD. If checked, ensures that the 
cut angle at the outer diameter does not cause the cut plane 
to exceed the defined region. If unchecked, this restriction is 
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ignored.

 ■ Constrain Cut so ID/OD overlap. If enabled, the inner diame-
ter/outer diameter values for the pipes are used to ensure that 
there is sufficient material based on the angle of alignment.

To Solve a Pipe Relationship:

1. First take a moment to think about the assembly. If there is 
more than one pipe segment that will be assembled (that is, 
if there will be more than one independently moving object 
in the optimization), then each moving object (pipe segment) 
should be placed into its own collection. This includes the ob-
jects defining the pipe endpoint, the pipe surface/cylinder, 
and anything else you want to rigidly move with that pipe 
segment. In this situation, you must use Relationships > Move Col-
lections by Minimizing Relationships in step 7 below.

2. Create a primitive SA object with directionality (circles, lines, 
cylinders, or planes—but circles are preferred) to represent 
the end of each pipe opening in the assembly. Each object’s 
normal direction must face the mating pipe segment as de-
picted in Figure 21-7.

Figure 21-7. The circles de-
fining each pipe opening have 
their normals pointing toward 
the mating pipe segment.

3. From the menu, select Relationships > Pipe Fitting.

4. Select the object (i.e. circle) describing the first pipe segment, 
then the second.

5. In the Pipe to Pipe Relationship dialog (Figure 21-4), click the 
Edit button for each pipe segment and define the ID, OD, and 
begin/end values for the allowable cut region (Figure 21-5).

Warning:  If the ID and 
OD values of mating pipe 
segments match, a valid 

cut plane will typically not be 
found unless you uncheck the 
Constrain Cut so id/Od Overlap 
option.
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6. If any pipe ends are already cut, create a frame representing 
that pipe end (usually Construct > Frame > On an Object is appro-
priate) and then click the Force CUT to Frame button (Figure 
21-8).

7. Create any other conventional relationships governing the 
alignment, if applicable.

8. Solve the relationship using Relationships > Move Objects by Mini-
mizing Relationships or > Move Collections by Minimizing Relationships, 
as applicable. Enable/disable and adjust the weights on all re-
lationships as desired.

Working With the Cut

If the pipe relationship can find a valid cut plane, it will display a 
dashed plane indicating the location and orientation of the cut plane 
(Figure 21-3).

Typically, the next step is to create a frame on the cut, which can then 
be laid off on the real pipe for cutting. This involves making the pro-
posed cut, then constructing a frame on the cut plane. The XY plane 
of this frame now defines the perfect cut location on the pipe. Watch 
windows can be used to lay this cut off on the real pipe.

In some applications, it may be desirable to simply calculate the cuts 
and lay them all off at once, as described above. This would be a faster 
but less stringent approach. A more rigorous approach would involve 
laying off the cuts on one segment, performing the cuts on the actual 
pipe, then measuring the actual cut plane.

Once the actual cut plane is measured, a coordinate frame can be 
constructed that represents the location of the as-built cut. This as-
built cut location can then be fed back into the pipe relationship, and 
the as-built cut can be used to tweak the alignment once more. After 
the alignment is further tweaked, a new tweaked cut plane can be 
laid off on the other pipe segment.

This process can be iterated, as desired, for each pair of pipe seg-
ments.

To Lay Off Cut Planes:

1. Once the relationship has been solved (see “To Solve a Pipe 
Relationship:” on page 632), double-click the pipe relation-
ship in the tree. In the Cut section, ensure that “Valid Cut Avail-
able” is indicated.

2. Click the Edit button in the Cut section for one of the pipe seg-
ments. In the Pipe Cut Properties dialog, click the Make Pro-
posed Cut button (Figure 21-8).

Tip:  In general, pipe relation-
ships are best solved by click-

ing the Direct Search Optimization 
button instead of the Run Optimi-
zation button.
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3. With the cut applied, click the Create Frame on CUT button 
to create a coordinate frame whose XY plane defines the cut 
plane (Figure 21-9).

4. 

Figure 21-8. The Pipe Cut 
Properties dialog.

Use a Watch Window to lay the cut plane onto the actual pipe.

Figure 21-9. A cut frame 
constructed on the cut plane.

The above steps can be repeated for the other pipe segment, if de-
sired. However, if applying cuts sequentially, the process contains a 
few more steps.

Applying Cuts Sequentially

1. After cutting the first pipe segment, measure the actual cut 
and construct a frame on the resulting cut plane. Ensure that 
this data is aligned appropriately in the SA file.
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2. Double-click the pipe relationship, and click the Edit button 
for the appropriate pipe cut.

3. Click the Force CUT to Frame button, and select the appropri-
ate frame. This will force the cut to sit on the provided frame.

4. Re-solve the optimization. Based on the as-built cut location, 
you should see the solution get tweaked to account for the 
changes.

5. Based on the results, make the cut on the other pipe segment 
using the steps in “To Lay Off Cut Planes:” on page 633.
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Callouts
Callouts offer a quick and easy way to annotate the graphical view 
in SpatialAnalyzer. Callouts can be created for a number of objects, 
points, vector groups, and other items (Figure 22-1).

Figure 22-1. Geometry 
relationship callouts in the 
graphical view.

If you cannot communicate your results with your cus-
tomer, then all of your measurement and analysis work 
is pointless. Fortunately, SA provides you with many 
different tools and capabilities for reporting your mea-
surement results.

Reporting
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Creating a Callout

To create a callout simply press the button. This will create and ac-
tivate a callout view in the tree. Double-Clicking a callout will activate 
or deactivate a callout (Figure 22-2).

Figure 22-2. An activated 
callout as it appears in the tree.

Callout Annotations

Text
Allows user to enter text.

Point Coordinates
Annotates selected point coordinates (Figure 22-3).

Figure 22-3. A point coordi-
nate callout.

Right-Click the callout to access properties (Figure 22-4).
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Figure 22-4. Point callout 
properties.

Point Comparison
Compares the two selected points (Figure 22-5). Their deltas are com-
puted by subtracting the first selected from the second selected. 
Right-Click the callout to access properties (Figure 22-6).

Figure 22-5. A point com-
parison callout.
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Figure 22-6. Properties for a 
point comparison callout.

Point Labels
Creates annotations for selected points. User can pick items to in-
clude (Figure 22-7).

Figure 22-7. Point label 
callout properties.

Group Comparison
Compares the two selected groups. Their deltas are computed by 
subtracting the first selected from the second selected. Right-Click 
the callout to access properties.

Vectors
Annotates selected vector properties and tolerance (Figure 22-8). 
Right-Click the callout to access properties (Figure 22-9).
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Figure 22-8. A vector callout.

Figure 22-9. Vector callout 
properties.

Relationship
Annotates selected relationship report (Figure 22-10). Right-Click the 
callout to access properties.

Figure 22-10. A relationship 
callout.

Object
Annotates selected object properties (Figure 22-11). Right-Click the 
callout to access properties.

Figure 22-11. An object 
callout.
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Callout View Properties

Figure 22-12. Callout view 
properties.

Viewpoint
Allows a user to save and lock the current view of the callout. When 
the callout is activated the saved view will be restored.

Recall Working Frame
Allows the current frame to be recalled when the callout is activated.

Visible Layers
Allows for layers to be used when a callout is activated.

Annotation Display Properties
Access to leader/border thickness and font control.



643

CHAPTER 22 ■ REPORTING

SA Reports
The SA Report allows a user to “drag and drop” items from the tree 
into the Spatial Analyzer Report Designer Editor where items can be 
arranged, formatted and edited to convey the user intent. If values/
information change in the tree, the SA report will reflect that change.

The Report Designer

The Report Designer is the canvas on which the user will create their 
report. The Report Designer supports standard functionality such as 
click and drag, re-sizing and Left/Right Clicking with context menus. 
The Report Designer also contains a toolbar (Figure 22-13) with useful 
reporting tools and options.

Report Toolbar

Figure 22-13. The Report 
Designer toolbar.

 ■ Print Current Report. Displays print dialog for the current 
SA Report.

 ■ Save As PDF. Allows the current SA Report to be saved as 
a PDF document.

 ■ Global Reporting Options/Page Setup. Displays SA Re-
port options such as Page Layout, Default Fonts and other op-
tions.

 ■ Report Refresh. Refreshes the SA Report with the current 
values from the tree.

 ■ Document Zoom In. Increases the scale of the report.

 ■ Document Zoom Out. Decreases the scale of the report.

 ■ Document Zoom 100%. Restores the report scale back to 
100%.

 ■ Export to Excel. Exports the current SA Report to Micro-
soft Excel.

 ■ Auto Adjust Report Whitespace. Removes excess vertical 
spaces between report items.

 ■ Lock Report. When clicked the SA Report becomes static 
and will no longer receive updates from the tree.

 ■ Help. Displays useful information regarding how to navi-
gate and interact with the Report Designer.

Report Header
The contents of the report header can be formatted to include a logo 
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image and a company byline (Figure 22-14). To include this informa-
tion navigate to Edit>User Options. For more information on global re-
port options please refer to the Reporting Tab section.

Figure 22-14. A report 
header in the Report Designer.

Page Layout
The report can be formatted in either Portrait or Landscape orienta-
tion. Use the page Global Reporting Options/Page Setup button 
to format the current report.

Creating an SA Report

An SA Report can be created several ways--as the result of a:

 ■ Quick Report

 ■ Composite Report

 ■ Report Template

To create a blank SA Report, use the menu item Reports>Add SA Report.

Figure 22-15. An SA report 
as it appears in the tree.

To open/edit an existing SA Report, expand the SA Reports category 
in the tree and right-click and select View. You can also double-click 
the respective SA Report to view it (Figure 22-15).

Warning:  Before creating 
a report, it is important to 
select the appropriate 

page layout. The layout can be 
changed during report design, 
however it could change the lay-
out of some existing items.
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Adding Items to the Dynamic Report

Simply click on an item in the tree and drag into the report window. 
Once inside the report, items can moved by dragging them.

Adding Snapshots to the Report

Use the Camera Button to take a snapshot of the SA graphic win-
dow. The snapshot will be placed into the tree under the Pictures cat-
egory.

The picture can be placed into the report by dragging, as with other 
items (Figure 22-16).

Figure 22-16. Dragging a 
picture into a report.

Once the picture is in the report it can be re-sized by dragging a cor-
ner of the image.

Adding Text to Report

Click any open space and start typing to add text. Or paste text from 
clipboard into any open space (Figure 22-17).
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Figure 22-17. A report an-
notated with some text.

Report Fields

Fields are text boxes that accept input via the keyboard or can be set 
by a Measurement Plan. There are two types of fields: Input fields and 
Output fields.

 ■ Input Fields. Fields intended for input from the user. They dis-
play a yellow background (red until filled in, if a required field).

 ■ Output Fields. Fields intended to display output. These fields 
have gray backgrounds.

To add a field to a report, right-click on the canvas and select Add New 
Field.

To add an input field, choose the Input radio button. If it is a required 
field, check the Required option. A required field will have a red back-
ground until it is filled in, and any attempts to print the report or send 
it to PDF will display a warning dialog.

To add an output field, choose the Output radio button. The value dis-
played in output fields can be set from a specific value, or from a tag 
(see below).

Tags
Every field (both input and output fields) can be assigned a tag. There 
are two types of tags: system tags and user-defined tags.

 ■ System tags include << Date/Time >> and << Filename 
>> and automatically populate the field with the current date/
time or filename (additional system tags will be added in the 
future). System tags can only be assigned to output fields. To 
create a system tag, select one of the system tags from the 
dropdown list in the Tag field.

 ■ User-defined tags are tags that you have created yourself (such 
as “MyTag” that allow you to reference the field from measure-



647

CHAPTER 22 ■ REPORTING

ment plans so that a script can fill out the field automatically. To 
create a user-defined tag, just type a unique tag name into the 
Tag field. You can also assign an existing tag to a field in order 
to populate multiple fields with the same value.

Field Value
A field value is used to populate the field. Field values are always 
displayed in the field itself, and are changed when a script or a user 
modifies the field.

Tables

To add a table to a report, right-click the canvas and select Add New 
Table. Specify a name for the table, and the desired number of rows 
and columns.

Tables can be resized by dragging their corners, or the left/right/bot-
tom sides. Interior cells can be resized by dragging any internal hori-
zontal or vertical line. Drag the interior of any cell to move the entire 
table.

To modify the number of rows or columns in a table, right-click the 
table and select Table Properties.

To insert or delete rows or columns or to change the alignment of a 
cell, right-click a cell and then choose Cell Options.

Add an input or output field to a cell by right-clicking a cell and se-
lecting Cell Options.

Modifying Items in the report

Items in the report can be modified by right-clicking the report item 
and selecting Report Options. Depending on the item, a context sensi-
tive menu will appear. All items have the following common options: 
Report Options, Remove from Report, Bring to Front, Send to Back, and Properties.

Events
SA Events provide detailed information for major events that occur in 
SA. These events can be viewed in the Report Bar or be added to any 
Report (Figure 22-18). Events are created automatically when certain 
functions are performed and are stored in the tree.

SA Events are generated for:

 ■ Best-Fit Transformations

 ■ Best-Fit Geometry

 ■ Move Objects by Minimizing Relationships
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 ■ Unified Spatial Metrology Networks (USMN)

 ■ Quick Align to CAD

 ■ Queries

 ■ CAD Imports

and more to come!

 

Figure 22-18. A best fit 
transformation event in the 
tree.

Object Report Options
Items in the tree have report options that can be accessed and config-
ured per the users needs. You can access by right-clicking the object 
and selecting Report Options (Figure 22-19).

Figure 22-19. Report op-
tions.
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Quick Report
A Quick Report is a fast and easy way to create an SA Report of a single 
object or multiple objects when using Composite Quick Report.

Creating a Quick Report

To create a Quick Report of a single item, right-click the item of in-
terest in the tree and select Generate Quick Report. An SA Report of the 
object will be created and saved in the tree.

Creating a Composite Quick Report

A Composite Quick Report is a fast way to create an SA Report of sev-
eral items. A Composite Report can be created by right-clicking a cat-
egory in the tree and selecting Composite Quick Report or from the menu 
Reports>Composite Report - All Collections.

To exclude or include an item from a Composite Quick Report, simply 
right-click the respective item in the tree and select Include in Composite 
Quick Report.

Report Bar
The Report Bar can serve as quick reporting tool allowing the user to 
view items quickly and also store the views in a tabular format (Figure 
22-20). The report bar can also combine the report tabs into a com-
posite report.

Figure 22-20. A vector group 
in the Report Bar.

Report Bar Toolbar

 ■ Capture Current View. Creates a picture item in the tree of 
the current graphical view. The picture will display in the report 
bar under the current tab.

 ■ Clipboard Help. Displays help information regarding meth-
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ods of copying Report Bar data to the clipboard.

 ■ Object Properties. Displays the current tab object proper-
ties.

 ■ Current Object Report Options. Displays the report op-
tions for the current tab.

 ■ Include Current Object in Composite Report. Sets the 
current object to be used in a Composite Report.

 ■ Quick Report. Generates a Quick Report from the current 
tab.

 ■ Generate Quick Report from Tab Order. Generates a 
Quick Report from all Report Bar tabs.

 ■ New Report Tab. Creates a new tab in the Report Bar.

 ■ Close All Tabs except Current. Closes all Report Bar tabs 
except for the currently selected tab.

 ■ Refresh Report. Refreshes the Report Bar with current in-
formation.

Displaying the Report Bar

To display the Report Bar use the menu option Report>Report Bar Visible.

Using the Report Bar

The Report Bar is a great way to view object properties and values 
quickly. Multiple items can be added to the Report Bar for continu-
ous reviewing. Once finished, the Report Bar can be cleared or sent 
directly to an SA Report for final output.

Adding an Item
To add an item in the Report Bar simply select an item in the tree by 
single-clicking the item. Once selected it will display in the Report 
Bar. The currently selected item in the tree will always display in the 
current Report Bar Tab (Figure 22-21).
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Figure 22-21. The item cur-
rently selected in the tree is 
displayed in the Report Bar.

Adding multiple items to the Report Bar requires multiple tabs. Add a 
new tab by using the icon. The new tab will appear with the cur-
rently selected tree item. Select the next item from the tree to view.

Removing an Item
To remove a Report Bar item, click the “X” icon in the bottom right-
hand corner of the Report Bar (Figure 22-22). All tabs, except the cur-
rent tab, can be cleared by using the icon.

Figure 22-22. Removing a 
Report Bar item.

Generating a Report
If needed, an SA Report can be generated from one or all of the Re-
port Bar tabs. Use to generate a report of the current tab or to 
generate a report from al Report Bar tabs.

Report Templates
SA Report Templates offer a repeatable method for creating reports 
of items from the tree. Once created they can be used repeatedly.

Creating an SA Report Template

Select Reports>Add New SA Report Template from the menu and a report 
template will be created in the tree (Figure 22-23).
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Figure 22-23. The SA Report 
Template dialog.

Inside the SA Report Template the inputs and outputs are controlled 
in the Report Instructions box (Figure 22-24). Simply use the Add or Re-
move buttons to control items availability in the report.

Figure 22-24. The Report 
Instructions box.

The Output Selection defines the output format and location of the re-
port when it is generated (Figure 22-25). Choose from embedded lo-
cations or external locations.
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Figure 22-25. The Output 
Selection box.

Generating the Report

Once the Report Template is designed and saved, a report can be 
generated. Simply right-click the respective SA Report Template and 
choose Generate (Figure 22-26). The report will be created and saved in 
the prescribed output format.

Figure 22-26. Generating a 
report from a template.
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Dimensions provide a method to annotate the graphical view with 
both linear and angular dimensions between any combination of 
points and objects (Figure 23-1). They are dynamic entities: Both the 
numeric values and the leader lines update as the points and objects 
move.

Figure 23-1. Dimensions 
between hole centers.

Types of Dimensions
There are several different types of dimensions that you can create:

 ■ Point to Point. Shows the linear distance between two points.

The ability to depict as-built distances and angles pro-
vides a great way to communicate measurement results 
visually. Dimensioning is a flexible tool that is designed 
for displaying these measurements in the graphical 
view, with flexible options to provide you a great deal 
of control.

Dimensioning
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 ■ Point to Object. Shows the linear distance between a point 
and any object.

 ■ Object to Object. Shows the linear distance or angle between 
any two objects.

 ■ Diameter/Radius. Shows the diameter or radius of a circle or 
cylinder.

Working With Dimensions
To Create a Dimension:

Do one of the following:

 ■ From the Query>Make Dimension menu, select the desired dimen-
sion type. Select the appropriate points or objects to dimen-
sion. A new dimension will appear in the graphical view.

 ■ When the Query Results dialog is displayed as the result of an 
appropriate query, check the Create Dimension checkbox (Figure 
23-2):

Figure 23-2. The Create 
dimension checkbox in the 
Query Results dialog.

Common Properties

All dimensions in a collection have a set of common properties which 
can be adjusted for all dimensions in the collection at once. These in-
clude the text size for the dimension, and the dimension orientation.

Dimensions can be oriented based on their leader lines, or can be set 
to always face the screen:

 ■ Screen. The dimension always faces the screen.

 ■ Along. The dimension is oriented along the leader line.

 ■ Leave Unchanged. The dimension orientations are left un-
changed.

To Change Settings for All Dimensions in a Collection at Once:

 ■ Right-click the dimensions category in the tree
and select Set Common Properties to open the Common Dimen-
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sion Properties dialog.

To Change the Size of All Dimensions in a Collection:

 ■ In the Common Dimension Properties dialog, enter a new value 
in the Text Size field, then click OK.

To Change the Display Orientation of All Dimensions in a  Collection:

 ■ In the Common Dimension Properties dialog, select the Screen, 
along, or Leave Unchanged option.

To Change a Single Dimension’s Properties:

 ■ Double-click the dimension in the tree, or

 ■ Right-click the dimension in the tree or graphical view and se-
lect Properties.

Dimension Properties

Point to Point Dimensions

These dimension types depict the distance between two points (Fig-
ure 23-3).

Figure 23-3. The properties 
of a Point to Point dimension.

Each point has an offset setting:

 ■ No Offset. Dimension from the target or point’s center.

 ■ Add Target Offset. Adds the target’s offset to the dimension. 
This simulates an inside caliper (as if you’d measured the inside 
of a box).

 ■ Subtract Target Offset. Subtracts the target’s offset from the 
dimension. This simulates an outside caliper (as if you’d mea-
sured the outside of a box).

You can also control the display orientation for the dimension, as de-
scribed in “Common Properties” on page 656.
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Point to Object Dimensions

Figure 23-4. Properties of a 
Point to Object dimension.

The point end of this dimension is the same as described in “Point to 
Point Dimensions” on page 657. There is an additional option to Use 
radial Offset Component. If enabled, the radial component of the 
measurement offset will be used for compensation instead of the pla-
nar comonent. This is useful, for instance, when you are measuring 
the distance from the closest point in a hole to a surface edge plane 
and are acquiring the hole measurement with a pin nest. On the other 
end of the dimension, the object can have one of four settings:

 ■ Origin. Distance to the object’s internal origin (Figure 23-5). 
For instance, the center of a circle or plane.

 ■

Figure 23-5. Origin.

Axis. Distance to the object’s projected (extended) axis (Figure 
23-6).

 ■

Figure 23-6. Axis.

Plane. Distance to the plane of the object, if applicable (Figure 
23-7).
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 ■

Figure 23-7. Plane.

Surface. Show the distance to the closest point on the object’s 
surface/line/curve (Figure 23-8).

Figure 23-8. Surface.

You can control the display orientation of the dimension as described 
in “Common Properties” on page 656.

Object to Object Dimensions

In addition to dimension linear distances between objects, object to 
object dimensions enable angular dimensioning as well (Figure 23-9).

Figure 23-9. Object to Ob-
ject Dimension properties.

The dimension can be tied to one of three features of each object:

 ■ Origin. The distance from the object’s internal origin. This fea-



660

SPATIALANALYZER USER MANUAL

ture setting for the dimension does not allow angular dimen-
sioning, therefore the Angular option becomes grayed out.

 ■ Z Axis. The distance to the object’s projected Z axis (if Linear is 
selected), or the angle to the object’s internal Z axis (if Angular 
is selected).

 ■ XY Plane. The distance to the object’s XY plane (if Linear is se-
lected), or the angle to the object’s XY plane (if Angular is se-
lected).

Two settings particular to angular dimensioning dictate where the 
angular dimension appears:

 ■ Dimension Radius. The distance of the angular dimension 
from the mutual intersection of the two objects.

 ■ Angular Location. This button cycles through the four quad-
rant representations of the given angle, as illustrated in Figure 
23-10 through Figure 23-13.

Figure 23-10. Angular quad-
rant 1.

Figure 23-11. Angular quad-
rant 2.

Figure 23-12. Angular quad-
rant 3.

Note:  The internal Z axis of 
an object is typically the ob-

ject’s normal (for planes, circles, 
etc.) the Z axis (for frames) or the 
line direction (for lines).
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Figure 23-13. Angular 
quadrant 4.

You can control the display orientation of the dimension as described 
in “Common Properties” on page 656.

Diameter / Radius Dimensions

Figure 23-14. A diametrical 
dimension.

Diameter/Radius dimensions are ideal when the diameter or radius of 
a circle, cylinder, or sphere needs to be dimensioned (Figure 23-14).

The diameter/radius dimensions are shown in Figure 23-15:

Figure 23-15. Properties of a 
Diameter/Radius dimension.

 ■ Diameter/Radius. Specify whether you’d like to dimension the 
object’s diameter or radius.

 ■ Display Angle. Specifies the angle around the circle to which 
the dimension is oriented.

You can control the display orientation of the dimension as described 
in “Common Properties” on page 656.
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SpatialAnalyzer’s GD&T Inspection tools provide engineers with the 
ability to perform standardized inspections in accordance with the 
guidelines of the ASME or ISO standards. It provides the tools to al-
low the technician to import fully annotated CAD models and utilize 
the annotations and tolerances provided, or build their own annota-
tions from CAD models, SA geometry, or even directly from measured 
points that define geometry. It also provides the ability for a designer 
to build an inspection process that walks an operator through the 
process of measuring the datums and features of interest following 
predefined measurement location indicators. Once points are as-
signed to a feature check it is immediately validated with a pass or 
fail result. The check can then be added directly to dynamic reports.

SA makes every effort to be true to the ASME standard in the 
GD&T evaluation process. All calculations are based on the ASME 
Y14.5M-1994 guidelines but provide users a wide range of flexibility 
dependent upon their needs.  Introduced in the 2012.12.06 version 
are GD&T pre-check validations which ensure full compatibility with 
the desired standard. The supported standards include:

 ■ ASME (1994)

 ■ ASME (2009)

 ■ ISO (1983)

Geometric dimensioning and tolerancing, more com-
monly known as GD&T, is a system for defining and 
implementing engineering tolerances for part and as-
sembly geometry. In this chapter, we will discuss how 
SA supports the engineer’s ability to read and commu-
nicate GD&T design from CAD drawings. 

GD&T
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 ■ ISO (2004)

You may select the standard you wish to use by navigating to the 
Analysis tab in the User Options dialog. Select GD&T Options and then 
choose one of the options listed in Figure 24-1.

Figure 24-1. GD&T Options 
dialog.

Choosing a pre-check evaluation does not affect the numeric results 
but rather allows the user to validate the check in advance to ensure 
that the check is in accordance with the specific standard. As a result 
some checks will fail due to a noncompliance with a particular stan-
dard that would pass without pre-checks in place. However, this al-
lows the user to be fully-compliant with the desired version of either 
the ASME or ISO standard.

Importing CAD with GD&T Annotations
To import a CAD model with annotations select File > Import > Direct CAD 
Access. If you would like to change your import preferences, navigate 
to File > Import > Direct CAD Access Settings. 

In the Direct CAD Access Settings dialog, check the annotations op-
tion. Once imported, the annotations will appear graphically and in 
the tree in the Annotations category (Figure 24-2) .
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Figure 24-2. Imported CAD 
Annotations.

Creating GD&T Annotations
In many cases the GD&T annotations will be imported with the CAD 
model. However, SA provides the ability to add GD&T annotations to 
a CAD model that does not have them and provides the tools nec-
essary to conduct a GD&T analysis on constructed SA geometry and 
also points within SA that define geometry. To build your own anno-
tations in SA use the GD&T tab in the SA toolkit (Figure 24-3).

Creation Options

The GD&T Annotation tab is located within the SA Toolkit. If it is not 
visible, select View > Show Toolkit Bar from the menu. This toolbar is the 
starting point for building annotations and setting up GD&T evalua-
tions when not importing annotations with a CAD model. With a logi-
cal workflow starting from the top and working toward the bottom, 
the toolbar begins with the Creation Options section.

View
This sets the orientation of the text for the annotation to be added.  
The view orientations available are drawn from the Preset Views  list 
which can be accessed and edited by going to View > View Control > 
Preset Views. The view selected, as well as the text size, can be edited 
within the annotation properties once the annotation is created.
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Figure 24-3. GD&T tab in 
Toolkit.

Feature Type
The Feature Type defines and limits the type of objects to which an 
annotation may be added. You can choose from Cad Faces, Sa Objects 
or Sa Objects (fit to points). In all cases the GD&T annotations must be 
added to the nominal (design)  features. If these nominal features do 
not exist in your job they must be created. 

 ■ When you select Cad Faces, the annotation will be added to 
and include the specific selected CAD faces you chose from 
a particular model regardless of whether or not a model has 
been dissected into individual faces.

 ■ Selecting Sa Objects allows selection of any primitive SA geom-
etry type as the nominal feature.

 ■ Sa Objects (fit to points) allows you to add an annotation direct-
ly to measured points. When you select this option you will be 
limited in your choices to building Datums, Form, and Orienta-
tion Checks. When adding annotations you will be prompted 
to define the geometry type you wish to fit to the points. This 
nominal geometry is then created for you from the points se-
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lected and the type of feature check used.

Datum Annotations

Once the Creation Options are set, Datums and Datum targets can be 
added to the model by simply clicking on a CAD face, SA object or 
selecting points. The datum letter is incremented automatically. To 
place a specific datum letter on a model, hold down the letter you 
wish to add on the keyboard when you click the datum button. You 
can then click on a CAD face or SA object and that particular letter will 
be used. Datum targets are added with the datum name and a nu-
meric indicator in the same way that datums are added. Simply click 
on the datum target button and on the point on the datum surface 
that you wish to add the target. That click point will then be used to 
anchor the leader line for the annotation. Once a datum/target is se-
lected, the GD&T Datum dialog will appear (Figure 24-4).

Figure 24-4. GD&T Datum  
dialog.

The GD&T Datum annotation properties dialog allows you to edit the 
following settings:

 ■ Datum Name (Identifier). The datum letter used as an identi-
fier in the annotation (currently support single and double let-
ter annotations).

 ■ Inspection. Measurementprofilename sets the measurement 
mode for the selected instrument when the Datum is created 
for inspection through the guided inspection feature.

 ■ Feature Type. Provides a selection prompt and resulting selec-
tion list of the SA features for reference in the check. You must 
select either CAD faces or SA objects. The selected SA objects 
define the annotation placement and the features used during 
datum alignment. The selected CAD faces define the annota-
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tion placement and the features used during datum alignment. 
Where applicable, SA Offset Objects provides directional refer-
ence information or alignment restrictions for surface datums.

 ■ Placement. This will define the text size and orientation in the 
job. The View defines the saved orientation of annotation text. 
The Text Height defines the height of the annotation text. This 
is expressed in job units. The Text Rotation defines the rotation 
in the current view.

 ■ Cylinder Mode. Allows for selection between hole and pin cyl-
inder evaluations. It is used to properly define probing offsets.

 ■ CAD Feature. Provides a radio button which forces the select-
ed feature to be interpreted as a general surface.

GD&T Feature Check Annotation Properties

 ■

Figure 24-5. Properties for a 
True Position check.

Type. Feature check type.

 ■ Name. The name of the check used to describe the annotation 
in the tree as well as reporting.

 ■ Measurement Profile Name. Sets the measurement mode for 
the selected instrument when the Datum is created for inspec-
tion.

 ■ CAD Feature. Prompts user to select CAD faces for the respec-
tive feature.
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 ■ View. Changes orientation of annotation.

 ■ Text Height. Defines the height of the annotation text. Ex-
pressed in job units.

 ■ Text Rotation. Defines rotation in the current view.

 ■ Text Above and Text Below. Adds additional text above and 
below the annotation.

 ■ Number of Primary, Secondary and Tertiary Datums. Enter 
the respective Primary, Secondary and Tertiary Datums if ap-
plicable.

 ■ Zone. Applicable tolerance zone

 ■ Tolerance. Tolerance value for the feature check.

 ■ Material Modifiers. Defines the material modifier for the fea-
ture check’s selected datum. Choose from Maximum Material 
Condition, Least Material Condition or regardless of Feature Size.

 ■ Has Projected Zone. If checked, the projected zone will be 
used.

 ■ Projected Zone Value. Value used when projected zone is be-
ing used.

 ■ Tolerance Lower Tier. Tolerance used in Lower Tier evaluation.

 ■ Outer Tolerance Lower Tier. This designates the amount of 
the tolerance outside the surface of the part for the lower tier 
check. It allows for asymmetrical tolerance zones to be set. For 
symmetric tolerances this value should be set to one-half the 
total tolerance.

 ■ Material Modifier Lower Tier. Optional material modifier des-
ignation for the lower tier tolerance.

GD&T Dimension Tolerances

To add dimensional annotations you must have first set the desired 
View and Feature Type followed by the Tolerance type, whether that 
be Limit (which provides the option to enter the low value limit and 
high value limit) or Nominal +/- (which provides the option to enter 
the nominal value and the low and high deviation values from that 
nominal). These settings are saved with the annotation and used in 
the evaluation. The tolerance definition can then be edited in the an-
notation properties later dialog if needed. Figure 24-6 illustrates how 
the settings in the property grid relate to the annotation graphic:
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Figure 24-6. Anatomy of a 
GD&T annotation.

Graphical Placement of Annotations

With the annotation editor open the graphical annotation can be 
moved and placed in a position that is easy for the user to read. The 
annotation leader line is defined when the first surface face is selected 
under the CAD Features parameter. To move the annotation simply 
select the annotation in the graphics by left-clicking the annotation. 
While holding the left mouse button the annotation can be moved 
in the plane of the selected view. The view can be change under the 
View parameter in the annotation editor. Controls at the bottom of 
the annotation editor help in fine tuning the position and orientation 
of the annotation.

 ■ Rotates the annotation box 90 degrees counter clockwise.

 ■ Rotates the annotation box 90 degrees clockwise.

 ■ Mirrors the annotation box.

 ■ Straightens the leader line normal to the selected surface 
face.

While moving the annotation, Alt can be combined with the left 
mouse button to move the annotation along the leader line.

GD&T Entities
If you look in the TreeBar in SA you will find that all imported and con-
structed annotations are contained within an Annotations category. 
Often it is useful to contain all the design CAD and Annotations with-
in a single collection. You can then create a new collection for a par-
ticular inspection. To inspect a feature simply right-click on the Anno-
tations category and select Make Feature Checks.  The annotation will 
be decoded and two additional categories will be built: Feature Checks 
and Datums. Feature Checks and Datums are much like relationships 
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in that they maintain the association between measured points and 
the features specified in the annotation. (For more information on as-
sociating points to with datums and feature checks refer to the GD&T 
Workflow section). 

Figure 24-7. GD&T Entities in 
the Treebar.

Datums and Feature Checks

The Datums dialog (Figure 24-8) as well as the Feature Checks dialog 
(Figure 24-9) have identical settings with a few minor exceptions:

Figure 24-8. Datum proper-
ties dialog.
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Figure 24-9. Feature Check 
properties dialog.

 ■ Indirect Measurements (Datums only). At times, it can be-
come necessary to measure a feature indirectly. Meaning for 
example, that you measure the table top to represent the back 
surface of a part clamped to the table. Normally the probing 
direction of a surface defines the way in which we handle prob-
ing offsets, however in this case, you are both measuring off 
the true surface and from the opposite direction. To account 
for this we have an option in the Feature Check properties di-
alog that allows you to specify that the measurements were 
taken indirectly. 

 ■ View. Provides controls for the views saved in the GD&T In-
spection Design, Inspection Inspect workflow process (see sec-
tion on workflow). The views saved from the Inspection Design 
interface are saved here and can be recalled or edited by going 
directly to this section in the specific datum or feature check.

 ■ Cloud Thinning. Controls the extent of thinning performed on 
point clouds associated with this check during evaluation and 
defaults to the global settings.

 ■ Datum Alignment (Feature Checks only). When doing a 
GD&T inspection, alignment is performed relative to the speci-
fied datums for each individual check. The current instrument 
alignment is not used for analysis unless specified. To do so, dis-
able datum alignment for a particular feature check by going 
to this feature in the feature check properties dialog. When you 
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do so, the datum annotation will be crossed out in the evalua-
tion (Figure 24-10).

Figure 24-10. Disabled 
datum alignment.

 ■ Nominal Points. Provides control of the selected nominal 
points used in the GD&T Inspection Inspect routine. These 
points are used to lay out the bulls eyes on the part used by 
the inspector as a guild to measure the part in the correct lo-
cation. Nominal points can be added to the job through the 
Inspection Design interface or can be selected manually for a 
particular feature through this dialog. The highlight button can 
be used to graphically identify the nominal points.

 ■ Measurement Trapping & Advancing. This parameter is used 
to control the number of points captured from a live instru-
ment during trapping. When the specified number of points 
are associated with the feature trapping is stopped automati-
cally (refer to GD&T Workflow section).

 ■ Cylinder Evaluation Methods. (Figure 24-11) The way in 
which cylinders are fit to the data depends on the number of 
measurements. A full cylinder fit is only attempted if you have 
10 or more measurements of the feature. This is essential to un-
derstanding how the data is used in the check. 

                

Figure 24-11. Cylinder Evalu-
ation Method section.

Cylinder Evaluation Methods

 ■ Choose for me (Automatic). This is the default used when cre-
ating datums and checks with cylindrical features.  In this mode, 
the evaluation method is determined automatically based on 
the number of measurements. When set to this option the fol-
lowing designations will be made: if one point is associated, 
trans-axis Center pos. Meas. will be chosen; if two points are as-
sociated, then Center and Surface axis Meas. will be selected; if 
three to nine points are associated, then Center & diam at nom. 
direction will be selected; and if ten or more points are associ-
ated then Full Cylinder eval will be chosen.
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 ■ Full Cylinder Evaluation. This method does a cylinder fit 
from the provided measurements. The points are assumed to 
be measurements of the cylinder walls (pin or hole), and the 
length of the cylinder is determined by the extent of the mea-
surements along the cylinder axis. In this case the measure-
ments are used to determine the central axis and radius/diam-
eter of the cylindrical feature.

 ■ Trans-Axis Center Position Measurement. This method takes 
either a single point or averages a set of points and compares 
the resulting point to the nominal cylinder axis while using the 
nominal direction and radius for the evaluation. An example of 
this type of check is resting a probe tip of a larger diameter on 
a hole.

 ■ Center and Surface Axis Measurement. This method assumes 
that multiple measurements of the cylinder axis were taken at 
varying depths. A line is fit to the measurements and that line 
determines the center and direction of the cylinder while the 
nominal cylinder is used for the radius. For example, using a 
probe resting on a hole with and without a spacer could be 
used to define a cylinder center axis. 

 ■ Center & Diameter at Nominal Direction. This method proj-
ects the associated measurements to the end cap of the nomi-
nal cylinder.  The results of the projection are then used to fit 
a circle.  The circle then determines the center point and the 
diameter while the nominal cylinder is used for the direction. 
This is an excellent choice in situations where you have very 
little coverage of the cylinder on either side of a cross section 
plane to define the cylinder axis.

GD&T Alignment
When performing a GD&T inspection, alignment is performed relative 
to the specified datums for each individual check. The current instru-
ment alignment is not used for analysis unless specifically specified 
for the specific feature check within its properties dialog (refer to the 
feature check properties section for more details). 

To get an idea of the alignment used by the GD&T evaluation with 
specific datums, right-click on the Datum Category and select “Align”.  
You will be prompted to specify the datum scheme, picking primary, 
secondary and tertiary where applicable. This will then move the in-
struments and points associated with the datums to the correct ori-
entation based on this datum scheme. Because each feature check 
is evaluated based upon its own datums it will be necessary to in-
clude or exclude only the datums you wish to use in the alignment to 
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simulate the alignment for the particular check. This alignment tool 
is for visual purposes only, it will not be exactly duplicated during the 
evaluation of the features.

To accelerate and the calculation process and to ensure that an ideal 
alignment solution is found for a particular check it is highly recom-
mended that an initial instrument alignment, using one of SA’s other 
alignment tools such as Quick Align to CAD or Relationship Fitting, 
is performed first prior to performing the check, particularly if using 
surface datums.

Surface Alignment

When using datums that reference complex (non-planar / cylindrical) 
surface features some additional requirements are involved:

 ■ The data should be pre-aligned to the part using other non-
GD&T techniques before attempting GD&T analysis, such as 
Quick Align to CAD or relationship fitting.

 ■ It is necessary to specify an offset plane or line with the datum 
annotation which will be used to constrain the degrees of free-
dom for that datum during alignment.

This offset geometry is what will “maintain contact” during alignment 
to subsequent datums and/or the main tolerance feature and so it 
needs to be chosen in such a way that it represents the control the 
datum is intended to exert over the solution.

Normally GD&T evaluation begins with an initial alignment step inter-
nally and also uses an iterative solution. When surface datums are in-
volved both are disabled. This was necessary to ensure stable results 
with surface datums and since the data is required to be close before 
starting they aren’t needed anyway.

GD&T Evaluation
The GD&T Analysis within SA follows the ASME standard evaluation. 
Therefore you will find that the results of a geometry fit or relation-
ship fit which are based on an RMS fit will not return exactly the same 
results. Take the example of a flatness check. When we build a Geom-
etry relationship fit to the points we report the flatness. This value 
is based on comparing the point deviations to the best fit plane. In 
GD&T, however, flatness is evaluated as two parallel planes bounding 
the data. These planes are then free to rotate in space to find the clos-
est position they can reach to each other while still containing all the 
measured points between them. This process will almost always re-
turn a slightly better result than an RMS fit because of this additional 
degree of freedom.
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Decimal Precision

It is important to understand that the displayed decimal precision im-
ported with an annotation or set in the Users Options does not limit 
the underlying GD&T Analysis. So, for example, if you have the deci-
mal precision set to 2 digits and have a flatness check with a tolerance 
of 0.02, the check can still fail if the measured deviation is 0.02001. 
This makes sense considering that the standard is based upon hard 
limits. The measurement is compared directly to the specified toler-
ance value and any deviation outside the limit signifies nonconfor-
mance to those limits. If you can’t get the pin in the hole then it fails.

Evaluation Zone/Length

The evaluation zone/length is set by the extents of the measure-
ments associated with the feature check. Therefore if you have a tol-
erance specification for a particular length part but can only measure 
a portion of that part. It may be necessary to adjust the tolerance to 
account for the shortened evaluation zone.

Cylinder Coverage

When measuring cylindrical features and using the “full eval” mode, it 
is important to provide enough measurements so that the intended 
cylinder orientation can be determined from the measurements.

Consider the following cylinder with 8 measurements in Figure 24-12. 
It is possible to interpret the cylinder in 3 different basic orientations.

Figure 24-12. Possible 
cylinder fit orientations with 
only eight points defining a 
cylinder location.

To avoid this problem, cover the cylinder more completely with mea-
surements so that it is clear which of those 3 orientations is intended. 
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One question which may arise is why the nominal feature is not suf-
ficient to lock in the correct orientation. When SpatialAnalyzer evalu-
ates a GD&T check it first performs an initial alignment on the data 
representing the datums. This initial fit is done without knowledge of 
the nominal orientation because data is often far out of alignment ini-
tially as is common with portable metrology. Once a fit is performed 
the fit cylinder is compared with the nominal cylinder. Using the 
above as an example, if the wrong cylinder fit result was chosen (not 
having the nominal information) then the alignment would attempt 
to rotate the data incorrectly. Providing more complete measurement 
coverage avoids this problem.

GD&T User Options

There are several important global evaluation settings to select from 
found in the GD&T Options within the Users Options Dialog (Figure 
24-13): 

Figure 24-13. GD&T Options 
dialog within the User Options 
dialog.

 ■ High Point Utilization for Feature Alignment. If checked, 
three high points which also enclose the center of gravity of 
the points are used while if unchecked, the best-fit geometry is 
used (Least Squares).
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 ■ Distance Between Checks Used. You can choose between us-
ing the Centroid or the Min/Max when reporting the distance 
between checks.

 ■ Check Pre-Evaluation Validator. SA follows the ASME 
Y14.5M-1994 standard when performing GD&T analysis, how-
ever, GD&T pre-check validations can be used to ensure full 
compatibility with the desired standard. The supported stan-
dards currently supported are: ASME (1994); ASME (2009); ISO 
(1983); ISO (2004).

Choosing to use a pre-check evaluation does not affect the numeric 
results but rather allows the user to validate the check in advance to 
ensure that the check is in accordance with the specific standard. As 
a result some checks will fail do to a noncompliance with a particular 
standard that would pass without pre-checks in place. However, this 
allows the user to be fully compliant with the desired version of either 
the ASME or ISO standard.  To use a Pre-Evaluation Check simply se-
lect the desired standard in the users options prior to evaluating the 
feature check.

 ■ Feature Creation Check Boxes. Both the calculated points 
and geometry used for the evaluation can be obtained for 
some feature checks by turning on these check boxes in the 
Users Options. This can be a very helpful diagnostic tool, how-
ever, it creates a lot of new points and geometry. Figure 24-14 
shows the resulting geometry created by enabling the Feature 
Creation check boxes on a Composite True Position check. 

Figure 24-14. Resulting 
geometry from enabling the 
Feature Creation check boxes 
on a Composite True Position 
check.

 ■ Cross-Section Criteria. In order for a group of measurements 
to be considered a cross section, they must be within the de-
fault 1mm of each other in the cross section direction. In other 
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words if you fit a plane to the data none of the points would be 
greater than .5mm from the plane. In order to take measure-
ments in this format a geometry trigger measurement mode 
would be easiest. This cross section criteria can be adjusted by 
selecting GD&T Options under the Analysis tab in the User Op-
tions dialog.  The number of cross sections used in the analysis 
is reported in the summary table of the check.  

GD&T Workflow
SA provides the option for a GD&T inspection designer to layout ex-
actly how and where to measure a part. It also provides a rehearse 
function that allows the designer to walk through the script in simu-
lation to check the workflow. Once complete, the resulting script can 
then graphically walk a measurement technician, with little to no me-
trology knowledge, through the measurement process.  This guided 
inspection is broken into 3 pieces: Design, Rehearse and Inspect.

Guided Inspection - Design

To build a guided GD&T Inspection an inspection designer should be-
gin with a fully annotated model. This annotated model can either be 
imported from a CAD package or built within SA. SA objects should 
be converted to bounded surfaces before beginning the inspection 
design to allow nominal guild points to be placed on the nominal 
features. The design process should be conducted as follows:

1. Begin by right-clicking on the annotations in the tree and 
building feature checks. The majority of the inspection design 
including view orientations and nominal points are saved 
with the datums and feature checks.

2. Right-clicking in the tree and select Inspection > Design. There 
are three location where you can find this option. You can 
right-click on the collection containing the GD&T datums and 
feature checks to work through the design of all datum and 
feature checks at once, or you select the datums or feature 
checks only if you only want to work on designing the portion 
of the GD&T inspection.

3. Once started the GD&T inspection designer walks through 
designing the inspection for each GD&T feature in order just 
as a user would measure them. For each feature the following 
designations can be made:

 ■ Save View for Inspection. If checked the current view will be 
saved with the datum or feature check and the view will be set 
to this view when the Inspection > Rehearse or Inspection > Inspect 
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routines are run.

 ■ Create Nominal Points. Nominal point measurement loca-
tions can be layed out on the model by graphically clicking on 
the model in the graphic view. The click selection order will be 
duplicated in the guided inspection. These point locations are 
saved as a point group and are saved with the Group Name and 
Point Name specified in the dialog. If you wish to remove the 
associated point locations you can use the “Clear NomPts” but-
ton at the bottom of the dialog.

 ■ Measurement Profile Name. The measurement profile for the 
instrument being used for the inspection can be set through 
the inspection designer as well. When the inspector is prompt-
ed to measure this feature the measurement profile specified 
here will be sent to the active instrument.

 ■ Enable Inspection Automatic Measurement. When enabled 
this option will automatically begin the specified measure-
ment mode on the active instrument.

 ■ Inspection Design - Item # of #. This set of toggle buttons 
provides a convenient way of progression the included inspec-
tion features. The total number of features included in the item 
list depend on the selection method, whether you selected to 
design only the datums, feature checks, or included the entire 
inspection in the design by selecting Inspection > Design for the 
entire collection. The settings for each inspection feature are 
saved automatically when you exit the current feature.

Guided Inspection - Rehearse

Once a guided GD&T inspection has been built the designer can then 
use the Inspection>Rehearse routine to simulate the measurement 
process. This option allows the designer to walk through the inspec-
tion process in simulation using mouse clicks for measurements to 
simulate the complete GD&T inspection routine built through the 
Inspection>Design process.

1. To begin the inspection right-click on either the collection, the 
datums or the feature check categories and select Inspection 
> Rehearse depending on the number of features you wish to 
include in the rehearsal. When you do so the following dialog 
will be displayed with the following options (Figure 24-15):
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Figure 24-15. Inspection > 
Rehearse dialog.

 ■ Group Name/Point Name. Specifies the group and target 
names for the click points (simulated measurements) to be 
saved.

 ■ Random Noise Magnitude. This entry allows you to add ran-
dom noise to the data measurements to simulate a more realis-
tic result. The recorded point location will be randomly gener-
ated within the specified radius of the point click point on the 
surface.

 ■ Skip Measured Features. When checked this option allows 
the feature progression buttons to skip features that already 
have measurements associated and progress to features that 
do not. This is helpful when all but a few skipped features have 
been measured and you want to automatically progress to 
those particular features.

 ■ Number of Nominal Points. These progress buttons provide 
the number of design measurements expected for the features 
and allows the user to skip through the measurement points 
to record measurements for only the points desired. It also al-
lows you to backtrack and add additional measurements at a 
particular guide location.

 ■ Inspection Design - Item # of #. This set of toggle buttons 
provides a convenient way of progression the included inspec-
tion features. The total number of features included in the item 
list depend on the selection method, whether you selected to 
design only the datums, feature checks, or included the entire 
inspection in the design by selection Inspection>Design for 
the entire collection. The settings for each inspection feature 
are saved automatically when you exit the current feature.

2. Simply click on the surface where the bulls eyes is displayed 
to simulate a measurement of that location. The bulls eyes will 
automatically increment through the saved measurement lo-
cations. When all measurements are taken for a feature the 
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dialog will automatically increment to the next feature in the 
list just as the inspection was designed.

Guided Inspection - Inspect

Once a guided GD&T inspection has been built through the 
Inspection>Design process, a measurement technician can then 
right-click on the collection and select Inspection>Inspect to conduct 
the inspection of a part. The guided inspection will walk the operator 
through the inspection laid out by the designer and allow them to 
measure the part as specified. As measurements are taken they will 
be associated with the appropriate feature is the tree and an analysis 
will be carried out automatically. For an operator it can be as easy as 
measuring the point on the part designated by the bulls-eyes laid out 
on the nominal CAD part. The process flow is as follows:

1. To begin the inspection right-click on either the collection, 
the datums or the feature check categories and select Inspec-
tion> Inspect depending on the number of features you wish 
to include in the inspection. When you do so the inspection 
will begin and the following will occur:  the view will be set 
to the saved view for the feature; the measurement profile 
will be set on the instrument specified; or the first inspection 
point will be displayed on the nominal part.

2. A dialog box (Figure 24-16) will be displayed with the follow-
ing options and active trapping will begin for that feature:

Figure 24-16. Inspection > 
Inspect dialog.

 ■ Skip Measured Features. When checked, this option allows 
the feature progression buttons to skip features that already 
have measurements associated and progress to features that 
do not. This is helpful when all but a few skipped features have 
been measured and you want to automatically progress to 
those particular features.

 ■ Highlight Cylinder Features. This check box triggers an ad-
ditional cylinder to be graphically drawn on the CAD model to 
clearly depict which cylindrical surface to measure in addition 
to highlighting the specific CAD faces.

 ■ # of # Nominal Points. These progress buttons are displayed 
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only when saved measurement locations are included in the 
inspection. They provide the number of design measurements 
expected for the features and allows the user to skip through 
the measurement points to record measurements for only the 
points desired. It also allows you to backtrack and add addi-
tional measurements at a particular guide location.

 ■ Inspecting # of # Features. This set of toggle buttons provides 
a convenient way of progression the included inspection fea-
tures. The total number of features included in the item list de-
pend on the selection method, whether you selected to design 
only the datums, feature checks, or included the entire inspec-
tion in the design by selection inspection>design for the entire 
collection. The settings for each inspection feature are saved 
automatically when you exit the current feature.

3. Simply measure the actual part where indicated by the bulls 
eye is displayed on the nominal part within SA. The bulls eyes 
will automatically increment through the saved measure-
ment locations. When no nominal measurement locations 
are save with the feature it is assumed that the measurement 
technician will measure the appropriate number of on the 
designated surfaces.

4. When all measurements are taken for a feature the dialog will 
automatically increment to the next feature in the list just as 
the inspection was designed. If nominal measurement loca-
tions were not included in the inspection design then the fea-
ture should be incremented manually when sufficient mea-
surements are take.

Direct Data Association and Trapping

In addition to classical Design and Inspection routines intended to 
separate the GD&T inspection design phase from the inspection or 
operation phase, SA provides a number of tools available to more ad-
vanced GD&T users performing the inspection of a part.

Trapping Measurements from a Live Instrument
Measurements can be captured or “Trapped” directly from a live in-
strument while measuring without either building or utilizing the 
guided inspection process. For an advanced user, directly measuring 
points on a part and having those measurements automatically asso-
ciated to a particular feature can be the fast way to conduct an analy-
sis. Trapping can be started for any datum or feature check in either 
of two ways:

Trapping through the Instrument

1. Connect to your instrument.
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2. Right-click on the particular Datum or Feature Check you wish 
to trap.

3. When finished measuring, right-click on the feature a second 
time and select Stop Trapping Measurements.

Trapping through the Inspection Tab in the Toolkit

1. Connect to your instrument.

2. Double-click on the particular Datum or Feature Check you 
wish to trap measurements to in the Inspection tab. 

3. When finished measuring, press the stop button (INSERT 
ICON) or press the progress button (INSERT ICON) to move to 
the next or previous item in the Inspection tab list. 

Either of these operations will begin trapping to the feature. If you 
have more than one instrument you will be prompted to choose 
which instrument you wish to trap measurements from. While trap-
ping is active the feature will become highlighted in both the Inspec-
tion tab and in the tree as well as being displayed with the point count 
in the Heads Up Display and will remain highlighted until trapping is 
stopped.

Directly Associating Data with a Feature
As soon as Annotations are available, Feature Checks and Datums can 
be built and data can be associated with those features. A user could 
potentially measure all the features on the part independently of the 
GD&T analysis process and then come back after the fact and associ-
ate the appropriate measurements with the corresponding Datums 
and Feature Checks. To associate data with a datum or a feature check 
just right-click on the feature in the tree and select Associate Points or 
Associate Clouds. This will clear the list of currently associated points 
and or point clouds associated with the feature, if any are currently 
associated, and associate the selected points or clouds with the fea-
ture. Once features have associated data they can be evaluated all at 
once by right-clicking on the feature checks and selecting Evaluate 
all Checks. 

Feature Inspection Auto Filter
If you have measured your part independently of any type of Guided 
Inspection or Measurement Trapping and you have pre-aligned to a 
CAD model it is quite simple to perform a GD&T analysis using the an-
notations contained in the model.  To do so simply do the following:

1. Navigate to GD&T > Feature Inspection Auto Filter.  This filter goes 
through all the measurements in the job within a specified 
distance from the part, whether they are individual points, 
point groups, or even point clouds, filters them into individual 
groups associated with the CAD surface, and assigns them to 
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the appropriate feature check or datum in one operation. 

2. Once this is done then navigate to GD&T > Evaluate all Feature 
Checks to complete the GD&T analysis.

This is a particularly useful approach to GD&T analysis when using a 
scanner. If you initially locate a scanner and then fully scan the part 
you are evaluating you can then filter the scan data to the CAD Faces 
associate the individual scans to the appropriate Features and in two 
clicks of a mouse button go from a single unfiltered cloud to a com-
pleted GD&T analysis ready for reporting.

Figure 24-17. Evaluated 
feature checks.

GD&T Reporting
Once feature checks have been evaluated the number of points used 
and the PASS/FAIL status is displayed in the tree. The report bar will 
provide the complete results of the analysis. Datum point associa-
tions, locations, and offsets can also be viewed as you select individu-
al datums. Feature checks display only a single line pass or fail results 
just as displayed in the graphic view by default but more detailed 
information can be obtained by turning on additional reporting fea-
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tures by right-clicking on the feature of interest and selecting report-
ing Options (Figure 24-18).

Figure 24-18. Full Feature 
Check reporting options in the 
Report Bar.

These feature checks can easily be added to a report through a drag 
and drop process or a composite report can be generated for all the 
feature checks at once by right-clicking on the Feature Check catego-
ry and selecting Composite Quick Report > Generate this will automatically 
generate a report containing a snapshot of the part in the saved view 
used for the measurement and the resulting success or failure of the 
check. By right-clicking on the check you can select to add either a 
summary table, showing more detail on the overall residuals, or a De-
tails view displaying the point coordinates and offsets for each point 
used in the analysis.
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About Measurement Plans
Measurement Plans (MPs) is the name given to the scripting capabil-
ity built into SpatialAnalyzer. MPs are similar to macros in that they 
can repeat a series of steps for you—but the similarities end there. 
MPs actually have significantly more capability—scripts make calcu-
lations, branch to different behavior based on decisions, gather user 
input, read and write to files, and execute custom code. In that sense, 
scripts share more traits with a programming language than a macro.

However, true programming languages have a complex syntax, often 
take many years to master, and have a high learning curve. MPs are 
designed to share as much capability as possible with programming 
languages while still dramatically lowering the learning curve com-
pared to learning a programming language.

Scripts can vary from simple utilities constructed in just a few minutes 
to comprehensive inspection plans that provide go/no-go automa-
tion and drive other machinery such as robots or CNC machines.

MPs are available for editing and executing on SA Ultimate or higher. 
They cannot be created, edited, nor executed on SA Professional.

SpatialAnalyzer contains a powerful scripting envi-
ronment that gives you the ability to automate tasks 
ranging from measurement, to analysis, and reporting. 
Scripts can introduce efficiencies into your metrology 
processes that cannot be overstated.

Measurement 
Plans
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Running a Measurement Plan
Scripts can be created in two formats:

 ■ Embedded. An embedded MP is stored in the SA job file and 
listed in the tree (Figure 25-1).

 ■ External. An external MP is stored as a separate .MP file on the 
file system. It is completely independent of any job file.

Both embedded and external scripts have essentially the same func-
tionality and behavior (although there are some advanced reasons 
why you might choose one over the other).

Figure 25-1. An embedded 
MP.

If you would like some example scripts to view or run, they are in-
cluded with the SA install in the Samples/Scripts folder.

To Run an External MP:

1. From the SA menu, select Scripts > Run Measurement Plan.

2. Navigate to the .mp file and select it.

3. The script will load into the MP Bar (Figure 25-2). If the auto-
run Mps option is enabled (see “To Enable/Disable Auto-Run-
ning of Scripts:” on page 689), the script will begin executing 
immediately. If this option is disabled, you must click the run 
button in the MP Bar to run the script.

Figure 25-2. A script ready to 
run in the MP Bar.

To Run an Embedded MP:

1. In the tree, locate the script in the Measurement Plans cat-
egory (see Figure 25-1) and double-click it, or right-click it and 
select Run from the context menu.

2. The script will load into the MP Bar (Figure 25-2). If the auto-
run Mps option is enabled (see “To Enable/Disable Auto-Run-
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ning of Scripts:” on page 689), the script will begin executing 
immediately. If this option is disabled, you must click the run 
button in the MP Bar to run the script.

To Run a Script from the MP Editor:

1. Load the script into the editor.

2. Do one of the following:

 ■ Click the run button at the top of the editor,

 ■ From the editor’s menu, select File > Run, or

 ■ Press Ctrl + R.

3. The script will load into the MP Bar (Figure 25-2). If the auto-
run Mps option is enabled (see “To Enable/Disable Auto-Run-
ning of Scripts:” below), the script will begin executing imme-
diately. If this option is disabled, you must click the run button

in the MP Bar to run the script.

To Enable/Disable Auto-Running of Scripts:

1. Click the User Options icon or press Ctrl+U (default key-
board shortcut.

2. Navigate to the Automation tab. Toggle the auto-run Mps (ap-
plies for double-click in tree and Scripts>>run Measurement 
plan) option.

Quick MPs
You can assign Measurement Plan scripts to the menus (Figure 25-3), 
so that any script can be executed by selecting it specifically from the 
SA menu (or from a toolbar, if you’ve customized the SA user inter-
face). You can assign up to 30 scripts to Quick MP slots for easy execu-
tion.

This immediate execution of Quick MPs is excellent for listing a library 
of commonly-used scripts or for testing a script during development.

Warning:  Making chang-
es to Quick MP slots 
modifies your User Inter-

face Profile. Changes must be 
saved to your UI profile in order to 
retain the settings the next time 
SA is run.
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Figure 25-3. Scripts have 
been assign to Quick MP slots 
1, 2, and 3.

To Assign a Script to a Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. In the QuickMP Assignments dialog, click the Add button.

3. In the Quick MP Assignment window, specify the parameters 
for the script:

 ■ ID. Which of the 30 slots (from one through 30) should be used 
for the script.

 ■ Display Name. The name for the script that you’d like to use in 
menus or toolbars.

 ■ Location. Select embedded Mp if the script is embedded, or ex-
ternal Mp File if the script is an external file.

 ■ Collection/Name/File. If the script is embedded, specify the 
collection containing the script and the name of the script it-
self as it appears in the tree. If the script is external, the path to 
the script file to run.

4. Click OK to accept the settings, then OK again to close the 
QuickMP Assignments window.

5. Save the changes to the UI profile as specified in “Custom UI 
Profiles” on page 144.

If you now select Scripts > Quick MP, you should see your script listed.

To Edit a Script’s Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. In the QuickMP Assignments dialog, select the Quick MP to 
modify and click the Edit button.

3. Specify the desired settings as indicated in “To Assign a Script 
to a Quick MP Slot:” on page 690.

4. Click OK to accept the settings, then OK again to close the 
QuickMP Assignments window.

 zTip: In most cases, you should use 
external scripts with Quick MPs.
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5. Save the changes to the UI profile as specified in “Custom UI 
Profiles” on page 144.

To Remove a Script from a Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. Select the Quick MP script to delete, then click the Delete but-
ton.

3. Save the changes to the UI profile as specified “Custom UI Pro-
files” on page 144.

To Run a Script from a Quick MP Slot:

1. In the menus, select Scripts > Quick MP.

2. Choose the script you’d like to execute.

3. The script will execute immediately, even if the auto-run Mps 
option is disabled (see “To Run an External MP:” on page 688)

To Assign a Script to Any Menu or Toolbar:

1. Assign the script as a Quick MP as described in “To Assign a 
Script to a Quick MP Slot:” on page 690.

2. Assign the Quick MP slot’s menu item to a toolbar or menu as 
described in “Customizing Toolbars & Menus” on page 145.

Working With Measurement Plans
Measurement Plan Scripts are not text-based. Instead, SA uses a 
graphical editor for writing scripts, which is not as basic as a macro 
recorder but also not as complicated as a text-based scripting envi-
ronment.

As described in “Running a Measurement Plan” on page 688, you 
can create your script as an embedded script or as an external script. 
There are advantages and disadvantages to each.

Embedded Measurement Plans:

 ■ Are stored as part of the SA file, therefore are easier to find and 
bundle with a script.

 ■ Are easier to execute and edit, since you can access them di-
rectly from the tree.

 ■ May not work if you need to create a new SA file or load an SA 
file as part of the script, since such actions will clear the embed-
ded scripts from the tree.

 ■ Make version maintenance, reuse, and distribution of scripts 
more difficult, since you need to export the script to a separate 
file in order to use it with other SA files.

Tip:  In general, we recom-
mend using external script 

files unless your script is fairly 
short and simple.

Warning:  You cannot use 
embedded scripts that 
have more than one 

script (such as a script with a sub-
routine) with an “Open SA File” or 
“New SA File” command. An ex-
ternal script is necessary in such a 
scenario.
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External Measurement Plans:

 ■ Are stored as a separate .mp file, therefore you must navigate 
to the file to execute it.

 ■ Are able to work with any scripting commands—creating a 
new SA file or loading an existing file does not create problems.

 ■ Are much better suited to script maintenance, reuse, version-
ing, and distribution.

You can start writing an embedded script or start writing a script in 
an external file. Likewise, you can export an embedded script to an 
external file or import an external script file as an embedded script.

To Start a New Embedded Measurement Plan Script:

1. In the menus, select Scripts > Embedded Measurement Plans > Create 
New.

2. Specify a name for the new script. This is how the embedded 
script will be named in the tree.

3. The MP Editor will appear, ready for input.

To Start a New Measurement Plan Script in an External File:

1. In the menus, select Scripts > Create/Edit Measurement Plan.

2. The MP Editor will appear, ready for input.

To Import an External Script File as an Embedded Script:

1. Select Scripts > Embedded Measurement Plans > Embed existing .MP 
file.

2. Navigate to the script file to embed and select it.

To Export an Embedded Script to an External File:

1. Right-click the script in the tree and select Export from the con-
text menu.

2. Specify a file name for the new external file, then click Save.

To Edit an Existing External Script File:

1. From the menu, select Scripts > Create/Edit Measurement Plan...

2. The MP Editor will appear.

3. Do one of the following:

 ■ In the editor’s menu, select File > Load, or

 ■ Press Ctrl + L.

4. Select the desired file.

To Edit an Existing Embedded Script:

1. Right-click the script in the SA tree and select Edit from the 
context menu.
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To Start a New Script in an Existing Editor Window:

 ■ From the editor’s menu, select File > New, or

 ■ Press Ctrl + N.

To Save Your Script:

 ■ From the editor’s menu, select File > Save or File > Save As..., as 
applicable, or

 ■ Press Ctrl + S (Save) or Ctrl + Shift + S (Save As...).

Protecting Scripts

Once you have finalized a script, you will often want to protect it from 
accidental (or intentional) modification. You can password-protect a 
script so that it cannot be modified. Once protected, the script will 
no longer load into the editor. However, protecting a script does not 
prevent it from being executed, or from viewing the commands used 
to create the script.

To Password-Protect a Script:

1. Load the script into the editor.

2. From the editor’s menu, select Protect > Set Password.

3. In the Set Password dialog, enter the desired password twice, 
then press OK.

4. Save the script.

To Open A Protected Script:

1. Load the script into the editor as usual.

2. When prompted, enter the password for the script.

To Remove Protection from a Script:

1. Load the script into the editor. You will need the password for 
this operation.

2. From the menu, select Protect > Remove Password.

3. Confirm the operation.

Generating SDK Code

The MP Editor has the capability of automatically generating the SDK 
code needed to repeat a script’s functionality in both the C++ and 
Visual Basic languages. This code can then be copied, pasted into an 
SDK project, and (with limited changes) be executed directly in com-
piled code. For more on the SDK, refer to the next chapter (SA SDK).

To Generate SDK Code for a Script:

1. Load the desired script into the editor.
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2. From the editor’s menu, select SDK > View SDK Code.

3. In the SDK Code Viewer dialog, select the desired language, 
Visual C++ or Visual Basic.

4. The code will automatically be copied to the Windows clip-
board and can be pasted directly into any text editor or Inte-
grated Development Environment.

The MP Editor
If you will be writing Measurement Plans, you’ll be doing it in the MP 
Editor (Figure 25-4). Some companies even have employees whose 
primary (or only) job responsibility is to write Measurement Plans—
these people may spend most of their working hours in this editor!

Figure 25-4. The MP Editor.

Command List

Varables/Connections View

Step List

For those used to the legacy MP Editor in SA 2014.04.15 and earlier, 
this new editor has an enormous number of improvements. The most 
notable are:

 ■ Command list and script are now integrated into one window. 
More screen real estate is devoted to your script.

 ■ Multiple commands can be displayed at once for easy refer-
ence.

 ■ Every command is a collapsable tree item, allowing easy ex-
pand/collapse behavior. This is particularly useful for “keeping 
track” of commands that you haven’t finished editing.

 ■ Commands can be rearranged through easy drag and drop.

 ■ Commands can be locked to prevent changes once they’re fi-
nalized.

 ■ Changing entry methods (such as switching from “Enter Meth-
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od” to “Reference” is dramatically faster than before with quick-
select buttons.

 ■ Most references can be selected directly in the step editor (in-
stead of the large table that was displayed in older versions), 
causing less disorientation.

 ■ Long comments can be seen completely, whereas they would 
be obscured in the old editor.

 ■ A variable list shows any defined variables and their types for 
reference.

 ■ A debug mode allows you to get “MP Watcher” functionality 
directly in the editor. You can see argument values directly in 
the editor as the script executes.

 ■ Current variable values are displayed while in debug mode.

 ■ A Connections viewer allows you to easily view commands that 
reference or are referenced by the current command, and jump 
to those steps quickly.

 ■ Lots of keyboard shortcuts for loading, saving, running, ex-
panding and collapsing, selecting, etc. are available—making 
for a fast workflow.

 ■ Automatic expansion and collapse of applicable commands 
(an option) makes for quick selection of references.

 ■ An “expert mode” suppresses warning messages about dele-
tion of commands.

 ■ Configurable alternating row colors for less eyestrain.

 ■ Automatic refresh of subroutine arguments.

 ■ Faster setting of breakpoints/comments.

 ■ More obvious indentation.

 ■ For new commands, if a step reference becomes invalid, it will 
switch to -1, forcing a command to fail instead of jumping to 
the start of the script. This makes it easier to find incomplete 
arguments in a command.

Overview

The MP Editor provides a graphical interface for writing scripts. It car-
ries a few traits from a traditional IDE (Integrated Development Envi-
ronment) that experienced programmers might recognize. But most 
importantly, it is not a text editor. Scripts are written in a point-and-
click, drag-and-drop fashion instead of writing text-based commands. 
This makes the learning curve more acceptable for most users.

There are three main sections in the editor (Figure 25-4):

 ■ Command List. This is a hierarchical tree showing every com-
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mand that could possibly be added to a script, organized by 
type.

 ■ Variables/Connections View. This view shows either a list of 
the variables, variable types, and (if debugging) variable values 
defined in the current script, or shows the connections for the 
currently selected command. (For now, think of connections as 
the commands that relate to the selected command in some 
way).

 ■ Step List. The majority of the window is devoted to the Step 
List, which displays the individual steps of the script itself and 
allows for editing of the script’s arguments.

A Measurement Plan is a procedural script that executes one line at 
a time. Normally, the script executes in a linear fashion, proceeding 
from one command to the next. However, there are commands that 
cause execution to jump to another location in the script. There are 
also commands that branch to different parts of the script (or to dif-
ferent scripts altogether) based on some value.

Everything in Measurement Plan scripting is zero-based. That is, all 
counting begins with zero, whereas in the regular world we typically 
start counting from one. The first step in a script is step zero, the first 
argument in a command is argument zero, the first item in a list (ar-
ray) is item zero, and so on. If you have any programming experience, 
you will be used to this convention.

About Commands

When a command is first added to a script, it will be in expanded form 
so that it can easily be modified (Figure 25-5).

Figure 25-5. A newly-added 
command, in expanded form.

Commands can also be collapsed to one line at any time to save space 
or simplify your view (Figure 25-6).

Figure 25-6. A collapsed 
command.

To understand the command’s parameters, let’s look at this command 
in more detail. Each item in the command’s detail view is numbered 
in Figure 25-7 and discussed below.

Figure 25-7. A command’s 
parameters.
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1. Step Number
Every command in a script has a specific step number, used to order 
and identify steps in the script. Step numbers start from zero, so the 
first step in a script is step zero. You can rearrange single steps or en-
tire groups of steps.

2. Command Name
The name of the command is listed at the top of the entry. This is a 
read-only field that allows you to view the name of the command be-
ing examined. The name of the command in Figure 25-7 is Integer 
Math Operation.

3. Comment
Each step can have a user-defined comment (Add 3+5 in this case). 
This comment is simply a single line into which you can type anything 
you’d like. Comments are typically used to provide “human-readable” 
text to accompany the commands, so that someone reading a script 
(often times, that’s you!) can understand the intent of the command.

Comments can only be one line in length. When you collapse a com-
mand, the comment appears to the right of the command name. 
When expanded, the comment appears below the command name 
in a field that can be edited.

A few tips regarding comments:

 ■ Keep them brief. Long comments clutter up the screen, take 
time to enter, and take longer to read.

 ■ Comment Only When Necessary. New script writers have 
a tendency to add a comment to every line. Don’t. Only add 
comments if you feel like they’re needed.

 ■ Don’t be redundant. If the command itself is clear, there’s no 
need to add a comment. For instance, in Figure 25-7, it’s clear 
that we’re adding 3+5, so the comment is redundant.

 ■ The above three rules are not set in stone. If you feel like 
a comment is needed, add one. For example, it may be clear 
what a command is doing when you’re looking at its details, 
but when it’s collapsed, you can’t see what it’s doing. So it may 
be acceptable to add a comment in that case. Use your own 
discretion.

4. Arguments
Every command added to a script has zero or more arguments. Argu-
ments are the vehicle by which you can communicate with a com-
mand, and by which a command can communicate with you as the 
script’s author. There are two types of arguments:

 ■ Input Arguments. These are values that can be supplied to a 
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command as input. They help the command determine what 
it is supposed to do. Most input arguments are required, but 
some are optional.

 ■ Return Arguments. Return arguments are used to return in-
formation or results back from a command after it executes.

In Figure 25-7, the command has three input arguments: zero 
through two (A0 through A2). It has one return argument: A3 (notice 
the grayed-out “Result only” fields).

In this example, we want to perform a math operation on two inte-
gers (whole numbers). We obviously need to provide both of those 
numbers, in addition to the math operation that we want to perform. 
Those are the input arguments.

Once the command completes, we need a place to store the result of 
the operation so that we can refer to it later. The result of the addition 
in this case is stored in A3.

5. Data Type
Every argument has a data type (this will not be new for those with 
programming experience). A data type indicates the type of informa-
tion that an argument is expecting. You must feed an argument data 
of a compatible data type—otherwise, SA will prevent the operation 
or the script will fail at runtime. For instance, you cannot provide a let-
ter to an argument expecting a number. After all, what is the numeric 
value of that letter?

There are just four primary data types:

 ■ Integer. Whole numbers, such as 10, 10000, 0, and -502. These 
values are represented exactly, but there is a limit to the range 
of this number. In general, you need not worry about this limit 
for scripting applications.

 ■ Double. Decimal numbers, such as 3.1415926535, 2.781, 0.0, 
or -1.125. These numbers are in general not represented exact-
ly, so expect numerical errors to creep into your calculations. 
These errors are typically well beyond the precision of portable 
metrology work, so they’re not usually a worry, but you should 
take care when trying to compare one double value to another. 
You may expect them to be the same but they may actually 
be very slightly different. Double values also have limits on the 
range of values they can represent, but in general you need not 
worry about this limit for scripting applications.

 ■ Boolean. A value that represents one of two possible values, 
such as true/false, on/off, left/right, or yes/no.

 ■ String. A sequence of one or more alphanumeric characters, 
such as a sentence or prompt.
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There are many more data types in scripts in addition to these four, 
but virtually all other data types in scripts are derivations of these four 
main types. For example, there is a Collection Name data type, but 
it is really a string. This means that any argument that expects a Col-
lection Name can also be fed a string, and vice versa.

6. Description
Every argument has a description field. This is more of a human-read-
able description of what the argument is for.

7. Entry Method
A dropdown which appears when clicking in this column allows you 
to specify how you want to supply the information for the argument. 
For example, do you want to type it in, or feed it from some other 
command?

There are many entry methods. The most common are covered here:

 ■ Enter Value. The argument’s value is typed directly into the 
command—known as hard coding the value.

 ■ Reference. The value is fed into the argument from some other 
command. For example, the result of a math operation might 
be fed into another command for further processing.

 ■ Variable. The value for the argument is retrieved from a vari-
able by specifying the variable’s name. The variable must be of 
a compatible data type for the given argument.

 ■ Pick. The value is selected from a limited dropdown list of val-
ues.

 ■ Dialog. The value is specified graphically in a dialog.

8. Argument Value
The argument’s value is specified in this field.

 ■ Hard coded values appear as typed.

 ■ References appear as a combination of step number and argu-
ment number. For instance, Ref {S3 A4} indicates that you 
are feeding the value stored in step 3, argument 4 into the cur-
rent argument.

 ■ Variables are specified by entering the variable name.

9. Entry Method Quick-Select
A series of buttons for the most common entry methods are listed to 
the right of the argument value. By clicking these buttons, you can 
immediately change the entry method for the argument and directly 
enter the value. Users familiar with SA’s legacy script editor will find 
this new method of argument entry dramatically faster than the old 
method, while also requiring less clicking.

Note:  Some data types are 
simply more descriptive 

names for other data types. These 
are called proxy data types. Col-
lection Name is an example of a 
proxy data type.
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Only buttons applicable to a given argument are displayed, although 
often times there are more entry methods than buttons. (In other 
words, only the most common entry methods have buttons).

Entering Commands

Before you add a command to a script, you must find it in the Com-
mand List first. When you are just starting out, you will probably find 
commands by browsing the list. However, once you have more ex-
perience under your belt, you will begin memorizing key phrases 
of common commands and find them by simply typing a phrase to 
search for in the Search field above the Command List. 

To Add a Command to a Script:

1. Select the step after which you’d like the new command to 
be added. (If no step is selected, the new command will be 
added to the end of the script).

2. Find the desired command in the command list, or search for 
it by typing into the Search field. Use the + and - buttons to 
expand or collapse categories in the command list.

3. Double-click the desired command, or select it and press En-
ter.

To Delete a Command from a Script:

1. Select one or more commands by clicking on their command 
name. (Standard Windows contiguous and non-contiguous 
selection is supported).

2. Press the Delete key.

Editing Commands

Once you have commands in your script, various editing operations 
can be performed.

To Select a Single Command:

 ■ Click in the row containing the command’s name, or

 ■ Use the up/down arrow keys on the keyboard while the step 
list has focus.

To Select Several Contiguous Commands:

1. Click the row containing the first command’s name.

2. Hold down Shift and click the row containing the last com-
mand’s name.

To Select Several Non-Contiguous Commands:

1. Click the row containing the first command’s name.

Note:  If you cannot find a 
button for the appropriate 

entry method, look for it in the en-
try method dropdown (7).
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2. Hold down Ctrl and click additional rows containing subse-
quent command’s names.

All clicked commands will now be selected.

To Select All Commands:

 ■ Use contiguous selection above, or

 ■ Choose Edit > Select All from the editor’s menu, or

 ■ Press Ctrl + A.

To Clear Your Selection:

 ■ Click away from any commands in the step list, or

 ■ Choose Edit > Deselect All from the editor’s menu, or

 ■ Press Ctrl + Shift + A.

To Rearrange Commands:

 ■ To move a single command, drag it by clicking on its command 
name and drop it anywhere on the command you’d like the 
command to follow.

 ■ To drop a command BEFORE another command, hold down 
the Shift key while dropping.

 ■ To rearrange multiple steps, select them (standard Windows 
contiguous and non-contiguous selection is supported), then 
drag and drop them onto the step after which you’d like the 
group of steps to appear. Hold down Shift when dropping to 
place the group of steps before the command.

To Expand or Collapse Commands:

1. Select one or more commands (standard Windows contigu-
ous and non-contiguous selection is supported).

2. Do one of the following:

 ■ Click the or  button,

 ■ Double-click the row containing the command name, or

 ■ Press the right arrow (expand) or left arrow (collapse) keys on 
the keyboard.

To Copy Commands:

1. Select one or more commands.

2. Do one of the following:

 ■ From the editor’s menu, select Edit > Copy, or

 ■ Press Ctrl + C.

To Paste Commands:

1. First copy one or more commands as described above.

2. Select the command after which you’d like to paste.

Note:  Cut is not currently 
supported.
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3. Do one of the following:

 ■ From the editor’s menu, select Edit > Paste, or

 ■ Press Ctrl + V.

Resizing Columns

Although it may not be obvious, the MP Editor has a number of resiz-
able columns. You can adjust these to better fit the column’s contents, 
or if you have made the editor window large.

To Resize Columns:

1. Expand any command so that its arguments are visible.

2. Place the cursor just to the left of the Description, Entry Meth-
od, Value, or Entry Method Quick-Select Button columns. The 
cursor will change to indicate that you can drag left and right.

3. Drag the column to the desired width.

Hard Coding Argument Values

hard coding involves manually entering values into an argument. This 
is done when the value for an argument is known at development 
time and is not expected to change.

To Hard Code an Argument Value:

1. Ensure the entry method dropdown for the desired argument 
is set to enter Value, or click the button.

2. Enter the value into the argument’s value field, as specified 
below (the most common cases are described):

 ■ Simple Data types. Doubles, strings, integers, and other sim-
ple data types can be entered by typing the values directly into 
the field.

 ■ Boolean types. For arguments of type Boolean, you can ei-
ther type TRUE or FALSE (case insensitive) or, as a shortcut, 
type a nonzero value to represent TRUE and 0 to represent 
false. (It will automatically convert this value to TRUE or FALSE 
when you press Enter.

 ■ Collection Object Names. If you’re entering the name of an ob-
ject, type the collection name, followed by two colons, followed 
by the object name. For example, Measured::AxisLine. If 
you leave off the collection name and simply type AxisLine, 
the command will try to find the object named AxisLine in 
whichever collection is active at the time the command is ex-
ecuted.

 ■ Point Names. To specify a point name, type the collection, 
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group name, and point name separated by a pair of colons. 
For instance, Measured::Tie-Ins::1. You can leave off the 
collection name to indicate that you want to find the group 
and target in the active collection at the time the command is 
executed. For example, Tie-Ins::1 will look for point 1 in a 
Tie-Ins group for the active collection.

 ■ Reference Lists. Some commands, such as Concatenate 
Strings, expect reference lists, which are simply lists of items. 
To enter these, click the entry field, which will open the List Edi-
tor (Figure 25-8). Use this to add, rearrange, or remove items 
from the list.

Figure 25-8. The String List 
Editor.

Referencing Arguments

The true power of scripting comes not from a script that repeats a 
sequence of steps exactly as before, but in making decisions and be-
having differently based on parameters that may be different from 
the last time the script was executed.

The most common way of supporting this “non-hard coded” behavior 
in scripts is through the use of references. A reference is essentially a 
link or a connection to another value in your script. It is a way to feed 
a value from some other command in your script into the current ar-
gument.

For example, one step may multiply two values together. You can 
then feed the result of that calculation into an input argument in an-
other command to further operate on it.

To Reference an Argument:

1. Ensure the entry method dropdown for the desired argument 
is set to reference, or click the button.

The editor will highlight yellow all arguments that are of a compatible 
type for the given argument. If an argument is already being refer-
enced, it will be highlighted blue. If the auto expand/Collapse Steps 
option is enabled in the MP Editor options, any commands contain-
ing compatible arguments will be automatically expanded to show 

Tip:  If multiple arguments 
from different commands are 

going to refer to the same value, 
it is generally best for all of them 
to reference the same argument. 
Doing so ensures that future 
changes only require changing 
one argument.

Note:  An argument cannot 
reference itself. Such circular 

references do not make sense.
Warning:  Do not at-
tempt to reference an ar-
gument that will not con-

tain a value at the time the 
command is executed. This re-
sults in undefined (and generally 
incorrect) behaivor.
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them. These commands will collapse again when the reference is se-
lected.

2. Click on the highlighted argument to reference, or Esc to can-
cel.

Using Variables

Most if not all programming languages support the concept of vari-
ables. Variables allow you to define a name that is associated with a 
value. This allows you to refer to that value by name. The advantage 
of this is that while a script is running, you may change or overwrite 
the value of that variable, but anywhere you refer to it by name, you’ll 
always retrieve its current value. In many scripting situations, this can 
lead to dramatically simpler scripts.

Variables must be of the appropriate data type to store a given value. 
For instance, an integer variable can store a whole number, but it can-
not store a double. Likewise, a point name variable can store a point 
name, but it cannot store a vector.

You can define a variable by using the Set [____] Variable com-
mands. (There is a different command for each variable type). These 
commands create a variable with the specified name that stores the 
specified value. You can then refer to that value by its variable name.

To overwrite or change the value stored under a variable, simply use 
another Set [_____] Variable command using the same vari-
able name.

To Enter a Variable Argument:

1. Ensure that the entry method dropdown for the desired argu-
ment is set to Variable, or click the button.

2. Type the name of the variable into the argument’s value field.

The value of the variable will be retrieved at the time the command is 
executed and used as the argument’s value.

Variables View
In the bottom-left-hand side of the MP Editor is a dropdown that al-
lows you to select the Variables view (Figure 25-9).



705

CHAPTER 25 ■ MEASUREMENT PLANS

Figure 25-9. A list of the 
defined variables.

The Variables view allows you to see all of the defined variables in 
the current script, as well as their data type. Additionally, while de-
bugging, the value of the variable at the current point of execution is 
displayed in the Value column.

In addition to debugging uses, having a list of defined variables avail-
able allows you to easily reference the name when typing a variable 
in by hand.

Connections View

Occasionally, you may wish to see or jump to commands which are 
somehow related to the currently selected step. For example, if you 
delete a command, it would be nice to see which commands refer-
ence that step. After all, by deleting that step, any commands that 
reference it will need to be corrected.

As another example, you may have a command that jumps to a given 
step. If you want to insert a new command before that step and have 
the command jump to it instead, you will need to adjust the step 
reference. These types of situations are where the Connections View 
comes in handy.

Commenting Out Commands

Sometimes, you may wish to “comment out” commands. Comment-
ing out commands will temporarily disable them—they remain in 
your script, but the script will skip them during execution. As a re-
sult, you can easily remove a portion of your script and then restore it 
into the script with a simple click. This is extremely useful while test-
ing your script—you may wish to try something without a section of 
commands, or you may wish to remove a block of your script simply 
to shorten the length of time it takes for a script to execute. Deleting 
these commands instead would not be a great approach, since add-
ing them back in would require a lot of work.

Although commented commands are not executed, they are still a 
part of your script—references to those commands remain. If other 

Note:  For simplicity, vari-
ables defined in other scripts 

are not displayed. Variables de-
fined in subroutines are not visi-
ble to a calling script, so listing  a 
subroutine’s variables would be 
pointless. While editing a subrou-
tine, the editor doesn’t know 
which script is considered its par-
ent, so a parent script’s variables 
are not displayed either.
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commands reference a commented command, they will most likely 
fail at runtime, because the commented command is not executed, 
so its values may not be calculated.

Steps which have been commented out will have a speech bubble 
icon next to them (Figure 25-10).

Figure 25-10. Steps 0 
through 3 are commented 
out.

To Comment Out Commands:

1. Select the commands you’d like to comment out.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected step numbers until a small comment bubble icon ap-
pears , (Figure 25-10), or

 ■ Right-click the selection and select Comment Line (REM) from the 
context menu.

To Uncomment Commands:

1. Select the commands to uncomment.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected step numbers until all icons are cleared, or

 ■ Right-click the selection and deselect Comment Line (REM) in the 
context menu.

To Clear All Comments:

 ■ Right-click any step and select Clear All Comments from the con-
text menu.

Setting Breakpoints

When testing, you often want to run a script at “full speed”, then have 
the script pause at a certain point so that you can slowly step through 
a certain area of your script. For example, if there is a tight loop at the 
start of a script that executes thousands of times, it would be exhaust-
ing to step through the loop manually one line at a time. Instead, what 
is needed is a way to run the loop at full speed, then pause afterward.

Breakpoints enable this capability. Any line can be set as a breakpoint, 
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and you can set as many breakpoints in your script as you’d like (Fig-
ure 25-11). When set as a breakpoint, an executing script will pause 
prior to executing the line on which the breakpoint is set. You can 
then choose to step forward one line at a time, or continue running 
“at full speed”.

Figure 25-11. Steps 5 and 12 
have been set as breakpoints.

To Set Breakpoints:

1. Select the commands you’d like to set as breakpoints.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected steps until a breakpoint icon appears (Figure 25-11), 
or

 ■ Right-click one of the selected steps and choose Breakpoint (BRK) 
from the context menu.

To Clear Breakpoints:

1. Select the steps whose breakpoints you’d like to clear.

2. Do one of the following:

 ■ Right-click one of the selected steps and uncheck Breakpoint 
(BRK) in the context menu, or

 ■ Click in the right half of the gray column to the left of one of the 
selected steps until no icon is displayed.

To Clear All Breakpoints:

 ■ Right-click any command and select Clear All Breakpoints from 
the context menu.

Locking Commands

When you are satisfied one or more command’s parameters, you can 
lock those commands to prevent accidental modification. Locking a 
command provides a number of advantages:

 ■ They cannot be reordered in the script, so you cannot acciden-
tally move them around.

 ■ They cannot be deleted.
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 ■ Changes cannot be made to their arguments.

To Lock or Unlock Commands:

1. Select the commands you’d like to lock/unlock.

2. Do one of the following:

 ■ Right-click one of the selected commands and toggle the Lock 
entry in the context menu, or

 ■ Click in the left half of the gray column to the left of one of the 
selected steps until the lock icon appears (to lock) or disap-
pears (to unlock).

To Unlock All Commands:

 ■ Right-click any command and select Clear All Locks from the con-
text menu.

Entering Comments

When a command is expanded, a line directly beneath the command’s 
name says << Click to Enter Step Comment >>. In this field, 
you can type any comment to help document your script. Simply click 
in the field and start typing.

When you collapse a command, its comment will be placed next to 
the command name.

Indenting Commands

You can indent commands to help set them off as being part of a loop 
or branch of code, similar to how programmers indent their code to 
improve readability of the source code.

To Indent Commands:

1. Select the commands you’ d like to indent.

2. Press Tab. The command will shift over by one tab space.

To Remove Indention:

3. Select the commands you’d like to unindent.

4. Press Shift + Tab.

Setting Command Colors

You can change the background color of one or more commands in 
the editor to help differentiate a section of your script.

To Change Command Colors:

1. Select the commands you’d like to change.

2. Right-click one of the selected commands and choose Set 

Note:  Multi-line comments 
are not currently supported.
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Background Color from the context menu.

3. Choose a new color, then click OK. To reset the color back to its 
default, choose white.

Writing Your First Script
Let’s go through the process of writing a short simple script just to see 
how it’s done. This script will ask for a number between 1 and 10, and 
it will count up to that number starting from 1. For instance, if the user 
enters 2, our script will display 1, 2, then exit.

1. Start a new script in the editor.

We first need to ask the user for the number to count to. We’ll do this 
using the Ask for Integer command, which allows the user to 
enter a whole number and returns the value entered.

2. In the search field above the command list, type Ask For I.

The search field will filter the available commands down—the Ask 
For Integer command should be the only one remaining.

3. Double-click the command in the command list, or select it 
and press Enter. It will get added as the first line in our script.

4. In the Question to Ask argument, click in the box and type 
Please Enter a number from 1 to 10, then press En-
ter.

5. In the Enforce Min/Max Values? argument, click in the box and 
type 1, then press Enter. The value becomes TRUE. This al-
lows us to ensure that the user can only supply a value within 
a given range.

6. Set the Min Value to 1 and the Max Value to 10.

7. In the search field/command list, find the command Exit 
Measurement Plan (again, starting to type this name in the 
search field is the fastest way to find the command). Add it to 
the script (it will appear at the end).

8. Back in the Ask for Integer command, set the Step to jump 
to if Canceled argument to 1. If the user clicks the cancel but-
ton, the script will jump to the Exit Measurement Plan 
command in step 1 and exit.

9. Make sure a line in step 0 is selected, then add the command 
Create Counter. In the Counter Value argument, set the val-
ue to 1. This will be the initial value of our counter.

10. Next, add an Integer Comparison command. This will al-
low us to check the current counter value against the value 

Tip:  For any boolean argu-
ment, you can type 0 to rep-

resent FALSE or any nonzero 
number to represent TRUE. The 
value will be converted automati-
cally when you hit Enter.
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the user entered so we can determine when to stop counting.

11. Click below the command name where it says << Click to 
Enter Step Comment >>. Type Keep Counting? or a 
similar comment.

12. In the Integer A argument, click the reference quick-select but-
ton , then click the yellow box in Step 1, argument 0. The 
argument should now say Ref {S1 A0}.

We have now set this argument to reference the current counter’s 
value in step 1, argument 0. This will feed the current counter value 
into this argument at runtime.

13. In the Comparison Type argument, click the box and select <= 
from the dropdown list.

14. For Integer B, again click the reference button and select 
step 0, argument 7.

Essentially, this command is now comparing the “current” counter val-
ue against the number that the user entered. If the current counter is 
less than or equal to the supplied number, the command will jump to 
the Step if TRUE step. Otherwise, the command will jump to the Step 
if FALSE step. However, we don’t yet have these steps written, so we 
can’t yet fill them in.

Let’s consider what happens if the current counter is less than or 
equal to the supplied value. In this case, we want to display the cur-
rent counter value.

15. After the Integer Comparison command, add a Notify 
User Integer command. Click the command name to se-
lect it and press Tab to indent the line over once (we’re now 
inside the body of a loop).

Your script should now appear as depicted in Figure 25-12.

Figure 25-12. Our first script, 
so far.



711

CHAPTER 25 ■ MEASUREMENT PLANS

16. In the Reported Value argument, click the reference button
and select step 1, argument 0 (the counter value). This will dis-
play the current counter value to the user at runtime.

We need to increment the counter, or else we’ll be stuck in an infinite 
loop.

17. Add an Increment Counter command after the Notify 
User Integer command. Click the reference button and 
select the counter in step 1, argument 0. Press Tab to indent 
the command name.

When this command is reached, the current counter value will auto-
matically be incremented by one. 

Almost done. Now that we’ve incremented the counter, we need to 
jump back to our test—the comparison—to see if we should contin-
ue the loop.

18. Add a Jump to Step command. In the Step ID argument, en-
ter 2 to jump back to the Integer Comparison command.

The last thing we need to do is fix the step references in the Integer 
Comparison command.

19. In the Integer Comparison command, set the Step if TRUE 
value to 3. This will enter the body of the loop if we’re still 
counting.

20. Set the Step if FALSE value to 6. When we’re done counting and 
the counter becomes greater than the entered value, we’ll 
exit the script.

21. Select all commands by pressing Ctrl + A. Then press the 
left arrow key to collapse all commands at once.

Let’s lock the commands so we don’t accidentally change them.

22. Ensure all commands are still selected, then click the left 
side of the column to the left of the step numbers. A pad-
lock should appear on every line, indicating the lines are now 
“read-only” (Figure 25-13).

Figure 25-13. All steps are 
now locked.

That’s it! Our script is done. Let’s test it.
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23. Click the run button in the editor. If auto-run is disabled 
(see “To Enable/Disable Auto-Running of Scripts:” on page 
689), click the same button in the MP Bar.

Did your script run as you expected? If not, try to find any errors and 
correct them.

Debugging
A large portion of the time spent writing a script is often spent on 
debugging—that is, finding any bugs and errors in the script and cor-
recting them so that the script runs flawlessly in an execution envi-
ronment.

There are several ways to test and evaluate your script’s behavior.

Stepping Through a Script

One of the most obvious but still useful techniques for testing a script 
is to simply step through its evaluation one line at a time. This gives 
you the opportunity to view the effect of each command as it’s ex-
ecuted—typically, scripts execute too quickly to observe what’s hap-
pening.

When a script is loaded into the MP Bar, you can step forward one line 
at a time by clicking the Next Step button.

In the MP Editor, you can enable debugging mode by clicking the 
Debug button . When you do this, the Next Step button will ap-
pear in the editor window, allowing you to step through the script.

Debug Mode

The MP Editor has a debug mode that you can enable. Debug mode 
(Figure 25-14) provides several benefits for testing:

 ■ You can step through a script one line at a time.

 ■ Each command’s arguments will display their runtime values, 
so that as you step through the script you can see the actual 
runtime values stored with each argument.

 ■ The Variables view shows the current value of each variable as 
you step through the script.
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Figure 25-14. Debug mode 
shows variable values (left col-
umn) and current argument 
values.

These three items provide most of the tools you need to discover er-
rors in your script.

Debug mode only works with a single script. This means that if a sub-
routine is called, you will not see any changes in the MP Editor win-
dow until the subroutine returns and execution continues in the cur-
rent script. To view values in parent scripts and subroutines as a script 
executes, use the MP Watcher.

To Enable Debug Mode:

1. In the editor, click the Debug button . In debug mode, all 
arguments will become read-only and they will display their 
current values.

2. Run the script or step through it using the controls at the top 
of the window.

MP Watcher

The MP Watcher is very similar to debug mode in the editor. It is a sep-
arate window that allows you to view the current values of all com-
mand arguments as a script is executing. However, the MP Watcher 
adds each line to a list as it is executed. This means that unlike debug 
mode in the editor, if a script calls a subroutine, the subroutine’s val-
ues can be seen while that subroutine is executing. Moreover, in a 
loop each iteration through the loop will add additional lines to the 
list, whereas in debug mode the previous iteration is “overwritten” 
with the current iteration’s values.

The MP Watcher is shown in Figure 25-15. It will only show com-
mands that are executed starting from the time that the window was 
opened. In other words, it is possible to run partway through a script, 
then open the MP Watcher. Only commands from that point on will 
be displayed.

Scripts will run noticeably slower with the MP Watcher open, so make 

Note:  Scripts will run notica-
bly slower in debug mode. 

This is typically fine, since you’re 
testing—but it is something to be 
aware of.
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sure that this window is not open when execution speed is impor-
tant. (Typically, this is fine, since the window is only used during the 
testing phase of script development).

To Print the Contents of the MP Watcher Window:

 ■ Click the Print button.

To Export the Contents of the MP Watcher to an Excel Spreadsheet:

 ■ Click the Excel Export button.

To Export the Contents of the MP Watcher to a PDF File:

 ■ Click the PDF Export button.

To Clear the Contents of the MP Watcher Window:

 ■ Click the Clear button.

To Search for Content in the MP Watcher Window:

 ■ Click the Search button. You can search for text in the title, the 
comment field, for a specific value, or search among a specific 
command.

To Limit the Number of Steps Displayed in the MP Watcher:

 ■ Click the Options button. Set the Max displayed Steps option, 
then click OK.

Figure 25-15. The MP 
Watcher in mid-execution.
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SA SDK
The SpatialAnalyzer SDK provides a means by which to write custom 
applications that utilize Measurement Plan functionality within Visual 
C++, VB.NET, or other development environments that support Ac-
tiveX controls. Once the SDK engine has been added to the develop-
ment environment, Measurement Plan steps can be executed from 
within the programming language.

The advantages of the SDK over Measurement Plans include the fol-
lowing:

 ■ Since the code is written in a full-featured programming lan-
guage (such as Visual C++ or VB.NET), it offers the full flexibility 
and power of those programming languages.

 ■ Complex math operations and data manipulation is often easi-
er than when written in MPs.

 ■ There is no need to write routines to transfer data back and 
forth between MPs and custom external applications--all data 
is handled within the SDK application itself.

 ■ SDK code is compiled and can be distributed as a true applica-
tion.

 ■ SDK code is more difficult to reverse engineer than MPs, so pro-

The ability to automate measurement, analysis, and 
reporting tasks in SA can prove to save an enormous 
amount of money, time, and effort. Automation through 
Measurement Plans or the SA SDK can introduce ef-
ficiencies in your metrology processes unmatched by 
anything else.

SA SDK
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prietary processes can be kept more secure.

The disadvantages of the SDK when compared to MPs include the 
following:

 ■ It is more difficult to understand for a user not familiar with 
programming. Creating automated routines is less intuitive.

 ■ It requires at least basic knowledge of a real programming lan-
guage and development environment.

SDK Engine

Whenever a client application that you have developed is executing, 
the SpatialAnalyzer SDK engine will automatically start and appear 
minimized on the Taskbar. Figure 26-1 shows the engine in its maxi-
mized state:

Figure 26-1. The window 
displayed when the SDK En-
gine is running.

Automatic Code Generation

SpatialAnalyzer supports the automatic generation of SA SDK code 
for Visual Basic and Visual C++ languages through the MP Editor. This 
is an excellent way to prototype SDK applications, or convert MPs into 
full SA SDK applications. To access this sample code, set up an MP 
with your desired arguments. Then, press the SDK Code Generation 
button in the MP Editor (Figure 26-2).

Figure 26-2. The SDK Code 
Generation button.

The necessary code will be displayed in a window and automatically 
copied to the Windows clipboard (Figure 26-3).
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Figure 26-3. The SDK Code 
Viewer.

You can then paste this code into your SDK application.

Setting Up an SDK Project

VB.NET
1. Create a new Visual Basic Windows Forms Application project 

within Visual Studio (Figure 26-4). Select File>New Project.  

Figure 26-4. Creating a new 
VB.NET project.

2. Type a name for your application, then press OK.

3. Select Project>Add Reference...  
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Figure 26-5. Adding the Spa-
tialAnalyzerSDK COM object.

4. In the Add Reference dialog, select the COM tab, then scroll 
down in the list and choose SpatialAnalyzerSDK.  Click OK (Figure 
26-5).

5. Double-click the form in your project. You should be present-
ed with the code for the Form1_Load method of your form (Fig-
ure 26-6).  

Figure 26-6. The default 
form.

6. Replace this class code with the following:

Public Class Form1
’Declare an object for the SA SDK Interface

Private NRKSdk As SpatialAnalyzerSDK.SpatialAnalyzerSDK
‘Declare an enumerated type that defines the various return codes from the SA 
‘SDK Interface.
 
Enum MPStatus
 SDKERROR = -1
 UNDONE = 0
 INPROGRESS = 1
 DONESUCCESS = 2
 DONEFATALERROR = 3
 DONEMINORERROR = 4
 CURRENTTASK = 5
End Enum

‘Allocate the SDK Interface object
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.
EventArgs)
Handles MyBase.Load
 NRKSdk = New SpatialAnalyzerSDK.SpatialAnalyzerSDK
End Sub

End Class
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7. Ensure SA is running, then compile and run the application.

Visual C++
1. Create a new Visual C++ MFC project within Visual Studio (Fig-

ure 26-7).  Select File>New Project...

 

Figure 26-7. Creating a new 
MFC C++ project.

2. Type a name and location for your project, then click OK.

3. For purposes of illustration, let’s assume a dialog application 
is created (Figure 26-8). Note that the Dialog based radio button 
is selected:

Figure 26-8. The MFC Ap-
plication Wizard.

4. In the next dialog, ensure that Automation is selected (Figure 
26-9).  
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Figure 26-9. Ensuring that 
the Automation checkbox is 
selected.

5. Now add the SDK to the application. From the Solution Explor-
er, right-click the application in the tree and select Add>Class 
(Figure 26-10).

Figure 26-10. Adding a new 
class.

6. Select MFC Class From TypeLib, then click Add (Figure 26-11). 

Figure 26-11. Adding an 
MFC class.

7. Select SpatialAnalyzerSDK<1.0> from the Available type libraries 
drop-down. Then click the >> button to add ISpatialAna-
lyzerSDK to the Generated Classes section. Click Finish. 

8. CSpatialAnalyzerSDK.h will automatically be added to 
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your project and contains all of the available SDK declarations.

Sending Commands to SA

Establishing a Connection
The SDK consists of a set of function calls that allow the specification 
and execution of MP Steps. Before executing any commands in SA, 
your SDK code must first connect to SpatialAnalyzer. You can connect 
to SA using one of two methods: Connect (deprecated) and ConnectEx. 
The deprecated Connect() method returns a simple boolean YES or NO 
answer, indicating whether the connection was successful:

‘Connect to SA. If unable to connect, display a failure message.
If Not(NRKSdk.Connect(“localhost”)) Then 
 MsgBox(“Failed to connect with automation server!”) 
End If

The ConnectEx() method allows you to pass a long integer variable (by 
reference) and obtain a status code from the command which indi-
cates whether a connection was successful or not, and why:

‘Connect to SA. If unable to connect, display a failure message.
Dim statusCode As Long
NRKSdk.ConnectEx(“localhost”, statusCode)
If (statusCode)
 Msgbox(“Connection error, code: “ & statusCode)
End If

‘Possible values for statusCode include:
‘CONNECTED = 0,
‘CONNECTION IN USE = -1     An  SDK Client is already connected to SA
‘INVALID_LICENSE   = -2     Invalid SA SDK license
‘COULD_NOT_CONNECT = -3     Failed to connect to specified host
‘SDK_SOCKET_ERROR  = -4     Other Socket error

Executing an MP Step
Once you’ve successfully connected, you can now execute any MP 
command by adhering to the following process:

Declaring the Command
The first step in executing a command is to tell the SDK which MP 
command you want to execute by using the setStep() method:

‘Tell SA which MP step we’re defining.
NRKSdk.setStep(“Construct a Point in Working Coordinates”)

This example would tell SA that you are in the process of defining 
the Construct a Point in Working Coordinates command. Note that the 
string provided as an argument to the setStep() method must match 
the name of the MP command exactly.

Setting the Arguments
Once you’ve declared the command, you need to provide input argu-
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ments using the argument setting methods such as setVectorArg() and 
setPointNameArg():

‘Set the “Working Coordinates” argument of the command.
NRKSdk.SetVectorArg(“Working Coordinates”, 10.1234, 20.2345, 30.5678)

‘Set the Point Name argument of the command.
‘We want to put this point in the active collection, in the TestGrp point 
‘group, and name it “TestPt”.
NRKSdk.SetPointNameArg(“Point Name”, “”, “TestGrp”, “TestPt”)

When doing this, the first string provided to the methods is from the 
Description field of the MP command. This string must match what is 
seen in the MP, in English. The remaining arguments to the method 
depend on the type of argument.

Executing the Command
Now that the MP command is fully defined, you need to tell SA to ex-
ecute the step. This is performed using the executeStep() method:

‘Create a boolean variable to hold the result of the execution.
Dim bSendStatus As Boolean

‘Execute the step, and assign the result to our boolean variable.
bSendStatus = NRKSdk.ExecuteStep()

Checking the Result of a Command
If the SDK fails to execute the command (for example, because you 
have not properly defined the arguments), then bSendStatus (above) 
will be False. If the command succeeds, the value will be True and you 
can further obtain the MP step result using the getMPStepResult() meth-
od. That is, you can determine whether the MP step passed, partially 
failed, or completely failed:
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‘Only do this if the MP command executed properly.
If (bSendStatus) Then
 ‘Declare a long integer to hold the result code.
 Dim result As Long
 ‘Get the MP step result, and assign it to result.
 NRKSdk.GetMPStepResult(result)

 ‘Check the result of the MP command.
 Select Case result
  Case MPStatus.DONESUCCESS
   Msgbox(“Success!”)
  Case MPStatus.DONEMINORERROR
   Msgbox(“Partial Success!”)
  Case MPStatus.DONEFATALERROR
   Msgbox(“Failure!”)
  Case MPStatus.SDKERROR
   Msgbox(“There was an SDK Error!”)

   ‘Create an object to hold the error message
   Dim msgArray As Object

   ‘Display the text returned from execution attempt to 
                         ‘user...
   If (NRKSdk.GetMPStepMessages(msgArray)) Then
    ‘Declare a variable to hold the array index.
    Dim i

    ‘Declare a string to hold the message
    Dim msg As String = “”

    ‘Loop through the array to assemble the
                                 ‘message.
    For idx = LBound(msgArray) To      
                                        UBound(msgArray)
         msg += msgArray(idx) + Chr(10) + 
                                         Chr(13)
    Next

    ‘Now display the message.
    MsgBox(msg)
   End If
  Case MPStatus.UNDONE
    msgbox(“Command hasn’t been executed!”)
  Case MPStatus.INPROGRESS
    msgbox(“The command is currently being executed...”)
  Case MPStatus.CURRENTTASK
    msgbox(“The step is the current task.”)
 End Select
End If

Getting Return Arguments
If an MP contains a “Result Only” argument, then the result argument 
can be retrieved by a calling the appropriate argument get methods, 
such as getVectorArg() and getPointNameArg(). For example, if the MP step 
successfully executes and a vector result argument is returned, the 
following code could be used to retrieve the result:
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If (bSendStatus) Then
 ‘Declare a long int to hold the return code.
 Dim result As Long
 NRKSdk.GetMPStepResult(result)
 If (result = MPStatus.DONESUCCESS) Then
   ‘Get the return values and store in variables.
   Dim xVal, yVal, zVal As Double
   NRKSdk.GetVectorArg(“Vector Representation”, xVal, yVal, zVal)
 End If
End If
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SA Machine
SA Machine contains all of the features of SA Ultimate + Native CAD, 
but also allows interfacing with robots and CNC machines. This per-
mits calibration and compensation of robots and large volume CNC 
machines to high degrees of accuracy. It also enables robotic script-
ing, teach pendant behavior, and linear or joint space robotic control.

 Usually, robots are delivered by the manufacturer with default kine-
matic models that are accurate to on the order of about 1/2 - 1/4”. 
This depends on the manufacturer, product, calibration level, and 
other factors. Many manufacturers offer calibration packages that 
might improve this accuracy to perhaps 0.1”. CNC machines (espe-
cially large-volume machines) can also encounter the same sorts of 
issues (although they are usually more accurate). Regardless, this de-
fault accuracy is nowhere near what’s necessary for precision applica-
tions. There are several reasons for this. One might be that the manu-
facturer’s kinematic model is not quite right or doesn’t incorporate 
things like the stiffness of the linkages or the weights of tools on the 
machine very well (if at all).  

SA’s Robot and Machine calibration functions have a few purposes. 
The first benefit is that they can be used to calculate a significantly 
more accurate kinematic model than is provided by the manufacturer 

Note:  While SA Ultimate al-
lows robot calibration, only 

SA Machine can connect with ro-
bots to enable true real-time com-
pensation and control.

SpatialAnalyzer has the unique ability to integrate por-
table metrology measurements for the calculation of 
true metrology-compensated robot and CNC machine 
calibrations. 

Machine 
Calibration
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by default. The following discussion will refer to robots, but it applies 
equally well to CNC machines.  

To calculate a new kinematic model, a robot is commanded to go to 
a set of poses throughout the desired volume of use and whose posi-
tions in the robot controller’s coordinates are known. For each pose, 
measurements are taken on the robot’s end effector to determine the 
actual position of the tool compared to where it was “asked” to go. 
These measurements can be taken with a single measurement from a 
6-DOF measurement device, or they can be taken by measuring 3 tar-
gets with a 3-DOF measurement device. (Any measurement method 
that results in 6-DOF information can be used, including photogram-
metry).

Once a set of commanded positions and measured “actual” positions 
are determined, this data is run through a series of kinematic algo-
rithms to determine an accurate kinematic model for the specific ro-
bot (machine) of interest. Using this kinematic model, any position 
that you’d like to send the robot to is first backed through this kine-
matic model to give the controller a new set of positions. In other 
words, based on the calculated kinematic model, SA Machine tells the 
controller where the robot ought to go (based on its kinematics) to 
end up where you want it to be. This results in a drastically improved 
result, (to accuracies of about 0.010”, for example). Although this is a 
big improvement, it can be taken a step further.  

Now that the robot has gone where we think it should go, the end-ef-
fector can be measured again, which tells us where the robot actually 
went compared to where we expected it to be. We can then iterate 
through the kinematic model to give a small correction to the robot, 
getting it even closer to the desired target. We have demonstrated ac-
curacies to about 0.001”-0.002” using this method, which is quite ac-
curate for a robot. Given the accuracy of the encoders on the robot’s 
servos, this can’t be beat without more accurate hardware encoders. 
This process is a great way to position tools and other items with very 
high accuracy/repeatability.

Robots in SA

Adding a Robot to SA
There are two ways to add a robot to SA.

 ■ To load an existing SA Robot use Analysis>SA Machine - Robots and 
Machines>Add Machine>Load .SAMachine File (kinematics and graphics).

 ■ To create a new Robot use Analysis>SA Machine - Robots and 
Machines>Add Machine> Add Serial Robot>Using Kinematic Definition 
File.

Once a robot is added to the tree it is displayed under the Robots and 
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Machines category.

Robot Category
This category contains the specific Robot or Machine with the respec-
tive components and calibrations (Figure 27-1).

Figure 27-1. The properties 
of a Kuka KR 5 robot.

 ■ Show. Show/Hide all components

 ■ Show Link Frames. Show/Hide Link Frames

 ■ Properties. Displays properties

 ■ Teach Pendant. Displays teach pendant dialog in which user 
can control robot via several different methods.

 ■ Edit Machine to World Transform. Displays machine base 
transform dialog allowing for the machine to be transformed 
with respect to the current frame.

 ■ Command Controller Motion. Sends move commands to ma-
chine based on controller kinematics or SA kinematics.

 ■ Simulate Motion. Simulates move commands to machine 
based on SA kinematics.

 ■ Delete. Delete machine from SA TreeBar.

 ■ Make Frame at last end-effector update. Creates a SA coordi-
nate frame at the last end-effector position.

 ■ Add Graphical Entity. Adds a new component.

 ■ Save to File. Saves current machine to .SAMachine file.

Components
The Components sub-category contains each link of the robot with 
its respective graphical representations (Figure 27-2).
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Figure 27-2. The properties 
of the robot’s waist joint.

 ■ Properties. Displays the Manipulator Segment Properties - 
Denavit-Hartenberg Dialog. Here the Segment Transform and 
Joint Variables can be modified.

 ■ Set Kinematic Control Frame. Select the Link Frame for the 
component.

 ■ Delete. Deletes the selected component.

 ■ Add CAD to Component. Select surfaces to attach to compo-
nent at current location.

 ■ Make Frame at current location. Creates a SA coordinate 
frame at the current component location.

Calibrations

Figure 27-3. A calibration in 
the tree.

 ■ Calibration Interface. Displays the Calibration Interface for 
the respective calibration set.

 ■ Trap Measurements from an Instrument. Allows incoming 
measurements to be paired with current joint sets.

 ■ Stop Trapping Measurements. Stops the trapping of incom-
ing measurements.

 ■ Delete Calibration. Deletes selected calibration.
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 ■ Import Joint Poses and match to measurements. Imports 
Joint Poses and pairs with selected measurements. Often used 
when a live interface to a Robot is unavailable.

 ■ Export Joint Poses. Exports the Joint Poses from the selected 
calibration set.

Controlling a Robot from SA

There are several ways to control a Robot from SA. The following sec-
tions will cover the various methods.

SA Teach Pendant
The SA Teach Pendant (Figure 27-4) allows for Robot control from SA 
instead of the physical teach pendant. The SA Teach Pendant allows 
for individual actuator inputs, Cartesian moves and graphical input.

Figure 27-4. The Teach Pen-
dant dialog.

 ■ Actuator Movement. Select the actuator to move and either 
enter the value or use the slider to increase/decrease the value. 
Select the Drive button to apply the movement to the Robot 
Controller.

 ■ Cartesian Movement. Here the TCP can be moved in Carte-
sian space about either the Tool, Base or World frame. Simply 
slide the respective sliders and then click the Drive button to 
apply the movement to the Robot Controller.
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 ■ Graphical Movement. Allows the user to graphically move the 
Robot and then apply the movement to Robot Controller by 
clicking the Drive button.

 ■ Command Machine. The Drive button sends over the speci-
fied movement in either Joint space or Cartesian space.

 ■ Auto Drive. Automatically sends movement to the Robot Con-
troller when values change.

Move to Frame
The Move to Frame commands (Figure 27-5) allow robot movements 
to be calculated from the selection of Coordinate Frames in SA. When 
used, the user will be prompted to select a frame. From here, the ro-
bot will be moved to the selected position either in controller kine-
matics or SA Kinematics.

Figure 27-5. The Move to 
Frame commands.

Measurement Plan
The SA Measurement Plan scripting language also includes several 
commands for controlling Robots. As the above section describes 
Move to Frame, similar commands are available in MP. MP is a great 
tool for automating data acquisition and robot movement.

 ■ Move Robot/Machine to Frame

 ■ Move Robot/Machine to Named Destination

 ■ Set Robot/Machine Parameter

 ■ Compute Robot/Machine Adjusted Goal Frame

Collecting Calibration Measurements

Collecting data for a Robot calibration only takes a few steps. Two sce-
narios exist: Collecting joint sets from a live robot or importing joint 
sets.
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To Collect Measurements from a Live Robot

1. Ensure that SA and the Robot are connected via the SA Robot 
Driver.

2. Add a new calibration by right-clicking Calibrations and se-
lect Add Calibration.

3. Right-click the newly added calibration and select Trap Mea-
surements from an Instrument.

4. Now the calibration set is ready to receive measurements and 
joint sets. As a measurement is received a corresponding joint 
set is recorded. Simply move the Robot to various poses and 
record measurements (Figure 27-6).

Figure 27-6. Pose data for a 
calibration set.

To Import Measurements and Robot Poses

1. Ensure the proper Robot poses are formatted in a .txt or 
.csv file:

<name>,<j1>,<j2>,etc.

2. Collect measurements for each pose and ensure the point 
names match the respective pose names.

3. Add a new calibration by right-clicking Calibrations and se-
lecting Add Calibration.

4. Right-click the newly-added calibration and select Import Joint 
Poses and match to measurements. You will be prompted to 
select the points and pose file.

Calibration Interface

The calibration interface is used to compute the new kinematic mod-
el for the robot based on the recorded poses and measurements (Fig-
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ure 27-7).  

Figure 27-7. The Machine 
Calibration dialog.

 ■ Components. Displays the current components for the current 
Machine. Right-click a component to access properties.

 ■ Pose Name and Errors. Displays each pose and correspond-
ing positional and rotational errors. Uncheck a pose to remove 
from solution.

 ■ Measured Point in Tool Coordinates. Used to define the mea-
sured target in the TCP frame when using single point measure-
ments. Not needed when using a 6 degree of freedom target.

 ■ Rough-fit tool tips to measurements. Performs a best-fit of 
the tool tip locations to the measurements to ensure a good 
initial condition for the optimization.

 ■ Settings. Displays the tool orientation weighting factor.

 ■ Generate Report. Generates a final report to Excel with solu-
tion results and kinematic properties.

 ■ Degrees of Freedom. Degrees of freedom for the base, link-
ages and tool of Robot.

 ■ Run Calibration. Executes the optimization.

 ■ Solution. Displays current position and orientation errors and 
RMS values.
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Best Practice for Running a Calibration
1. With measurements and poses captured, open the calibration 

interface by right-clicking the calibration set of interest and 
choosing Calibration Interface.

2. Ensure a good initial starting condition by pressing Rough-fit 
tool tips to measurements. The overall errors will reduce great-
ly as the measurements and tool tip positions are best-fit to 
one another.

3. The initial Degrees of Freedom (DOF) are to allow the base 
and tool to move freely while maintaining the nominal kine-
matics (Figure 27-8). The tool DOF should only be set to 6 DOF 
when 6 DOF measurements are present. Press Run Calibration 
to start the optimization.

Figure 27-8. The Degrees of 
Freedom box.

4. Now, if desired, allow the Robot kinematics to vary by choos-
ing Partial or Full (Figure 27-9). Press Run Calibration to start the 
optimization.

Figure 27-9. Choosing a 
partial robot DOF solution.

5. At any time, make sure to validate any potential outliers and 
remove by un-checking the pose and re-running the optimi-
zation by pressing Run Calibration.

6. Once satisfied with optimization, generate a report for exter-
nal sources and/or apply the new calibration to SA by press-
ing Apply.

7. This calibration will now be used when moving the robot with 
SA Kinematics.

Figure 27-10. The Move to 
Frame option.

Kuka Robot Deployment
Below are the necessary components to operate SA and SA Robot 
Driver with Kuka Robots.



738

SPATIALANALYZER USER MANUAL

XML Channel configuration and Data format files (C:\KRC\Roboter\INIT)
 ■ RAC.xml

 ■ RAC+.xml

 ■ XmlApiConfig.xml (set tcp/ip address and port of remote ac-
cess computer – secondary fixed ip on remote computer)

KRL Client Communication  (C:\KRC\Roboter\KRC\R1\Program)
 ■ SAKRL.dat

 ■ SAKRL.src

KRL Client motion programs (called by SAKRL.SRC   C:\KRC\Roboter\KRC\R1\Pro-
gram)

 ■ MoveToFrame.SRC and .DAT

 ■ MoveToJointSet.SRC and .DAT

 ■ HitEStop.SRC

VxWorks Communication Configuration (C:\Windows)
 ■ vxWin.ini (robot controller VxWorks tcp/ip address modified 

under e={……})

Server application and data format files on remote computer
 ■ SARobotDriver.exe

 ■ EKX Server.exe

 ■ RACData.xml

 ■ Global Data  (c:\KRC\Roboter\KRC\R1\System)

 ■ $config.dat

SA Robot Driver – Kuka Controller Requirements
 ■ KR C2 Controller

 ■ Kuka System Software

 ■ KSS v.5.5

 ■ Kuka Ethernet KRL XML

 ■ v. 1.2

 ■ 3COM Ethernet Card Option

Denavit-Hartenberg Notation1

The first step in calibrating a manipulator is to understand its nominal 
kinematic parameters, and the controller’s ability to accept new, cali-
brated values for these parameters. This section will describe how to 

1 For a more detailed description of Denavit-Hartenberg nota-
tion see Craig, J. J., 1989, Introduction to Robotics: Mechanisms and 
Control, Addison Wesley, New York.
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represent a robot’s kinematics. Most manipulators are serial devices, 
meaning they are composed of a series of links and joints connected 
in an open chain.  Denavit-Hartenberg  notation is a standard means 
for specifying the kinematics of a manipulator. See the example table 
below, then a brief description of the meaning of the parameters.

Figure 27-11. A robot and 
its Denavit-Hartenberg (D&H) 
table.

Link α a d θ Type

1 0.0 0.0 0.0 0 Revolute

2 -90.0 0.0 0.0 0 Revolute

3 0 8.0 -4.8 0 Revolute

4 -90.0 0.0 8.0 0 Revolute

5 -90.0 0.0 0.0 0 Revolute

6 -90.0 0.0 0.0 0 Revolute

Links are rigid members; joints allow relative motion between the 
links. The chain starts at the base, or ground link, and ends at the 
working tool. Except for the tool link and the base, each individual 
link in the chain begins and ends with a joint. The tool may be a grip-
per, paint sprayer, welding tip, electro-magnet or any of a wide vari-
ety of devices. Common manipulators use only revolute (turning) or 
a prismatic (sliding) joints to connect links. More complicated forms 
of joints can always be modeled as a combination of these simple 
elements. The function of a link is merely to fix the relationship be-
tween the joints at either end of the link. As long as the two joints are 
held at the same relative position and orientation with respect to one 
another, the link serves only as a rigid connector. The actual physical 
shape of the link can be changed  without altering the kinematic rela-
tionship between the two interconnected joints.

A kinematic description of the manipulator is generated by SpatialAn-
alyzer  using the standard Denavit-Hartenberg  notation. This remark-
ably simple representation uses only two values to describe each link, 
and two additional values to describe the joint connection between 
adjacent links. Links are described in terms of their length (a) and the 
twist they maintain between adjacent joints (α), as explained below.
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 ■ Twist Angle (α). The angle between the first and second joint 
axes on a link. This angle is measured in a right-hand sense 
when viewed directly along the common normal.

 ■ Link Length (a). The distance between the two joint axes of a 
link. This distance must be measured along a line that is normal 
(i.e. perpendicular) to both joint axes. This line is referred to as 
the common normal between the joint axes.  If the joint axes 
intersect (a common arrangement in industrial manipulators), 
the link will have zero length. The joint connection between 
adjacent links is described in terms of the offset (d) and the 
joint angle (θ), as explained below.

 ■ Offset (d). The distance between the common normal of one 
link and the common normal of the next, measured along the 
axis of the joint connecting the two links.

 ■ Joint Angle (θ).  The angle between the common normal of 
one link and the common normal of the next, measured about 
the axis of the joint connecting the two links.

The four parameters α, a, d, and θ, when taken for each link and joint 
in the chain, provide a complete kinematic description of the manip-
ulator. When taken together with a description of the physical shape 
of each link and limits on joint motion, an accurate simulation of ro-
bot motion and operating workspace can be developed.

In addition, there is usually a Joint Offset value computed during the 
calibration. This value represents the difference between the “kine-
matic zero” of a joint, and the mechanical zero based on how the en-
coder was set in the joint mechanism.

For a more detailed description of Denavit-Hartenberg notation see:

Craig, J. J., 1989, Introduction to Robotics: Mechanisms and Control, 
Addison Wesley, New York
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Connection Configurations
Instruments can be categorized by the connection type used to inter-
act with the computer. These fall into several basic categories:

 ■ Serial Devices. Serial devices (such as RS-232) require a func-
tional serial port on the user’s computer and the use of a serial 
cable. USB to serial adapters are available should your com-
puter not have a serial port (We have had success with DIGI 
Edgeport adapters, which although are more expensive, have 
been quite reliable). Refer to the individual following sections 
for more specific configurations.

 ■ Bluetooth devices. Bluetooth devices require a Bluetooth re-
ceiver on the user’s computer. If your computer does not have 
a built-in Bluetooth connection, a relatively inexpensive mod-
ule, such as a Rocketfish™ Micro Bluetooth Adapter, can be pur-
chased from most office supply stores.

 ■ Universal Serial Bus (USB). USB connected devices typically 
require the installation of a USB driver for the instrument. The 
latest drivers for supported instruments can be found on NRK’s 
FTP site at: ftp://ftp.kinematics.com/pub/SA/Install/Driver 
Downloads/.

These instrument Quick-Start guides are designed to 
supplement the manufacturer’s instrument device 
manuals by providing straightforward, easy to follow 
steps to quickly get instruments up and running in Spa-
tialAnalyzer. You may wish to reference them when set-
ting up your instrument with SA for the first time.

Instrument 
Quick-Starts
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 ■ Network-connected devices (TCP/IP). The majority of instru-
ments used in SpatialAnalyzer are network-connected devices. 
This connection type provides extremely fast and reliable con-
nections either directly to the host computer or over a network.

Laser Trackers

API Radian

Hardware Setup
Set up the unit following the manufacturer’s directions. API Radian 
trackers are networked TCP/IP connected devices and should be con-
nected either to a network or directly to a computer with an Ethernet 
crossover cable.

Connect the temperature probe and ensure that it is well clear of any 
external heat sources (such as the heat fan on the back of the power 
supply). Ensure that the instrument is powered on and that an SMR is 
in the home position. 

Software Setup
Each version of SA is built with the most current version of the API 
software development kit (SDK). This driver set provides the tools to 
interface with the instrument. Check the Readme file to see which 
SDK version is being used. No additional software installation is nec-
essary. 

Set the IP address on your computer to be compatible with the ad-
dress set on the tracker. The default Radian IP address is: 192.168.0.168 
with the subnet mask 255.255.255.0. 

Starting the Interface
1. Select Instrument>Add and choose API Radian from the Add In-

strument to SA dialog (Figure 28-1).
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Figure 28-1. Adding a Ra-
dian tracker.

2. Run Interface Module without connecting (Instrument>Run In-
terface Mode) and choose api device interface (not Laser Track-
ers). 

3. Within the Connect to SpatialAnalyzer dialog, se-
lect the instrument station (computer name, job name, 
Collection::Instrument Name: Serial Number) you wish to 
connect your instrument to from the network list. 

4. In the API_DI Connection dialog, enter the tracker’s IP address 
(if different than the default) and use the Ping button to test 
the connection if needed. Once satisfied, click OK. The next 
time you connect this instrument to the instrument, you can 
just select run interface and Connect. This will utilize the last 
saved settings and automatically connect the instrument. 

Intelliprobe 360
Please refer to the current API Intelliprobe 360 user’s manual for setup 
and calibration instructions. A version is available on our webpage: 
http://www.kinematics.com/ftp/SA/Install/Driver%20Downloads/
Laser%20Trackers/API/Radian/. 

1. Ensure the I-360 has been fully unpacked, configured to com-
municate with the controller, and calibrated within API’s soft-
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ware.

2. Set the reflector in SA to the appropriate I-360.

3. Place a 1.5”  inch reflector in the nest.

4. Run a virtual level measurement (Check/Cal> Virtual Level). This 
will align the instrument with gravity, allowing the I-360 pen-
dulum measurements to be correctly interpreted.

5. Specific measurement profiles have been added for the I-360 
and must be used to take data from the device (Figure 28-2).

Figure 28-2. I-360 Measure-
ment profiles.

API T2+

The parameter file, [tkr serial#].prm contains the kinematic cor-
rection info, home location, etc. for the tracker.  For example, if your 
tracker serial number is 3827, the file name will be 3827.prm.  This 
file must be located successfully by the tracker initialization for the 
tracker to run. By default the parameter file should be located in C:\
Analyzer Data\Persistence. To change this location, just press 
the Browse button in the tracker connection dialog, as pictured in Fig-
ure 28-3.

Figure 28-3. The legacy API 
Connection window.

The parameter file is edited when an API calibration is run. Ensure that 
the file attributes are NOT set to read only.

You must have a working serial port for the connection to the tracker. 
Use the lowest available serial port number for the tracker connec-
tion.

Note:  Conducting the Virtu-
al Level measurement will 

transform subsequent tracker 
data. If you have taken measure-
ments from this instrument sta-
tion previously, a new instrument 
station must be added.
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API T3

The parameter file is stored on the controller for the API T3 tracker. 
Like the API T2+, you will see a default location for a parameter file. 
In the case of the T3, this is only the location where a back-up copy 
of the parameter file will be written from the controller. To change 
this location, just press the Browse button in the tracker connection 
dialog.
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Faro

This guide applies to the setup of the SMX 4000, 4500, Faro X, Xi, Ion 
and the Vantage. 

Hardware Setup
Set up the unit following the manufacturer’s directions. Faro trackers 
are networked TCP/IP connected devices and should be connected 
either to a network or directly to a computer with an Ethernet cross-
over cable.

Connect the temperature probe and ensure that it is well clear of any 
external heat sources (such as the heat fan on the back of the power 
supply). Ensure that the instrument is powered on and that an SMR is 
in the home position. 

The Faro Vantage requires SA version 2012.09.14 or later and a mini-
mum of JRE version 4.0.2 or later. 

Software Setup
Set your computer’s Local Network Connection to be compatible with 
that of the Faro tracker. Faro trackers are shipped with a standard IP 
address of 128.128.128.100. 

Download the latest java drive from: http://www.kinematics.
com/ftp/SA/Install/Driver Downloads/Laser Trackers/
Faro/.  Extract the files to the C:\ drive. This should create a directory 
structure with the Faro Java files contained in C:\FaroJRE.

If you plan to use the video (overview) camera, you must get ‘Faro 
Tracker v.4.0.2 (or later) Camera files.zip’ (search the SA readme for 
“java” to ensure correct version for your install) from ftp://ftp.kinemat-
ics.com/pub/SA/Install/Driver%20Downloads/Laser%20Trackers/
Faro/ . Unzip the file and follow the instructions contained in ReadMe 
Faro Camera.txt. Note that cameras are wireless. If your camera 
has the default IP address, you can set your PC’s wireless connection’s 
address to 129.129.0.1. 

Starting the Interface
1. Select Instrument > Add and choose the appropriate Faro track-

er from the Add Instrument to SA dialog  (Figure 28-4).
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Figure 28-4. Adding a Faro 
tracker

2. Run Interface Module without connecting (Instrument > Run In-
terface Mode) and choose Laser trackers. This will bring up the 
Faro Connection dialog (Figure 28-5). Within it you will see all 
the available instruments on the network.

Figure 28-5. The Faro Con-
nection dialog

3. Select the instrument station (computer name, job name, 
Collection::Instrument Name: Serial Number) you wish to 
connect your instrument to from the network list.

4. Enter the tracker’s IP address (if different than the default) and 
use the Ping button to test the connection if needed. Once 
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satisfied, click OK. The next time you connect this instrument 
to the instrument, you can just select run interface and Con-
nect. This will utilize the last saved settings and automatically 
connect the instrument. 

5. To use the camera, click the ADM Drive button in the SA in-
terface.  The tracker pad will pop showing the drive options. 
Select Camera drive to use the Faro camera interface.

The interface is now connected and ready for use. Please refer to the 
Measurements chapter of the manual for more details on the tracker 
interface and instrument settings options.  
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Leica EmScon

Prerequisites
 ■ Newer emScon controllers require a Leica dongle. Ensure that 

the dongle is installed on the controller’s parallel port.

 ■ All emScon controllers are shipped with 192.168.0.1 as the IP 
address. To learn more about configuring IP addresses, see the 
IP Address Basics section.

Compensation
The Leica emScon trackers and accessories can be compensat-
ed per Leica through emScon (Figure 28-6). EmScon can be ac-
cessed via the shortcut on the desktop or use the following address 
http://192.168.0.1:8099/emscon/default.aspx. If your tracker address 
is not the standard 192.168.0.01, change that component of the ad-
dress in your browser.

 ■

Figure 28-6. The main Em-
Scon window.

Compensation Password: Expert (Full and Intermediate, ADM, 
Reflector Definition, Camera Compensation, etc.)

 ■ Server Settings Password: Administrator (TCP/IP address, Time/
Date, etc.)

Starting the Interface
1. Select Instrument > Add and choose the respective Leica em-

Scon Tracker from the Add Instrument to SA dialog. 
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2.  

Figure 28-7. Adding an 
emScon tracker.

Now  run the instrument interface module under Instrument > 
Run Interface Module and choose Laser Trackers.

3. Enter the tracker’s IP address and use the Ping button to test 
the connection if needed. Once satisfied, press OK. The next 
time the interface is started, you can simply click the Run In-
terface and Connect icon. This will use the last saved set-
tings and automatically connect the instrument.

4. 

Figure 28-8. The Leica em-
Scon connection window.

The interface is now connected and ready for use. Please refer 
to the Laser Tracker section for details on the laser tracker in-
terface.

EmScon Settings
To access the emScon settings, use Settings > Tracker > General Settings or 
press the button. Then press the tracker specific button at the bot-
tom. This will expose the emScon-specific options (Figure 28-9). These 
options are the same ones that exist in emScon. This dialog gives you 
access without having to enter emScon.
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Figure 28-9. EmScon-specif-
ic tracker settings.

ADM Parameters
Parameters for recapturing the beam in ADM.

Sensor Configuration
Choose which peripheral devices are being used. Overview camera, 
Nivel Level and Weather Station.

Laser Temperature Range
Select the temperature range in which the tracker will be operating.

Beam Break Behavior
 ■ Go to Safe Position. The head will point directly up toward the 

overview camera when the beam is broken.

 ■ Hold Last Position. The beam will sit still when the beam is 
broken. This is needed for ADM beam break reset mode to 
work. If not, each time the beam is broken the tracker will re-
turn to its safe position.

Trigger
 ■ Select the type of trigger, if applicable, for triggering measure-

ments.

T-Probe
 ■ Allows for the programming of buttons and the option to mea-

sure without a tip.

Home Exit Direction
 ■ Choose which direction for the tracker head to unwrap when 
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leaving the birdbath.

PowerLock/ATR settings
Ability to turn on/off PowerLock and Spiral Search.

Tracker Status
To view the tracker status (Figure 28-10) go to Utility>Tracker Status.

Figure 28-10. The Leica 
Tracker Status dialog.

T-Probe
If you get a ‘usage conflict’ error when trying to use the T-Probe, run 
the emScon BUI. In it, there is a setting for stylus usage:

 ■ Stylus required

 ■ Stylus not required

 ■ Compensated shank

For standard T-Probe usage, you MUST select ‘stylus required’.
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Leica AT401

Prerequisites
The Leica AT401 connects via a wired Ethernet connection or a wire-
less connection. In either case, the IP configuration must be correct 
before the PC and instrument can communicate. The default Leica 
AT401 IP address is 192.168.0.1. To learn more about configuring IP 
address see the IP Address Basics section.

Compensation
The Leica AT401 compensation is performed in the Leica Tracker Pilot 
application. This is supplied by Leica and should be performed before 
running the instrument in SA.

Figure 28-11. Running a 
compensation routine in 
TrackerPilot.

Starting the Interface
1. Select Instrument>Add and choose the Leica emScon AT401 

from the Instrument List (see Figure 28-12 on page 754).
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2. 

Figure 28-12. Adding an 
AT401 tracker.

Now run the instrument interface module under Instrument > 
Run Interface Module and choose Laser Trackers.

3. Enter the tracker’s IP address and use the Ping button to test 
the connection if needed (Figure 28-13). Once satisfied, click 
OK.  The next time the interface is started, you can simply click 
the Run Interface and Connect icon. This will use the last 
saved settings and automatically connect the instrument.

4. 

Figure 28-13. The Leica 
AT401 Connection dialog.

The interface is now connected and ready for use. Please refer 
to the “Measuring With Laser Trackers” chapter for details on 
the laser tracker interface.

AT401 Settings
To access the AT401’s settings, use Settings > Tracker > General Settings or 
press the button. Then press the Tracker Specific button at the 
bottom. This will expose the AT401’s specific options (Figure 28-14).

Note:  If the Initialize Tracker 
option is chosen, be sure a 

reflector is in the tracker’s view 
and at a distance of 1.5 meters or 
greater.
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Figure 28-14. The Leica 
AT401 tracker settings.

The AT401 utilizes a programmable remote (Figure 28-15).

Figure 28-15. Setting the 
programmable buttons for the 
AT401.

Battery Status
To view the battery status go to Utility > Tracker Status (Figure 28-16).

Figure 28-16. The AT401 bat-
tery status dialog.

Leica Automation Interface

Hardware Setup
Before starting the AIC driver, it’s necessary to ensure that all hard-
ware connections are complete:

 ■ The AT-901 tracker controllers should be connected to the AIC 
hardware.

 ■ The auxiliary device (T-Mac, T-Probe, external trigger, etc.) 
should be connected to the AIC hardware.

 ■ The AIC hardware should be directly connected to the com-
puter on which the interface will be run.

Starting the AIC Driver Manually
1. First, add up to four Leica AT-901 trackers to the SA job.
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2. From the appropriate SA folder in the Windows Start Menu, 
navigate to Interfaces and select Leica Automation Interface 
(Figure 28-17).

3. 

Figure 28-17. Starting the 
Leica Automation Interface.

In the Connect dialog, select the tracker you’d like to connect 
to (Figure 28-18).

4. 

Figure 28-18. Connecting to 
a tracker.

The Leica AIC Driver interface will appear, automatically con-
nect to the AIC, and immediately be ready to use. Note that 
the AIC Driver will detect the current AI Controller’s connec-
tion to hardware at the Multiplexer--it is the T-Scan in this case 
(Figure 28-19).
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Figure 28-19. The AIC Driver 
window.

Using the Interface
Each tracker in use requires an assigned IP address and collection/in-
dex, which indicates which instrument in the SA file is associated with 
the corresponding hardware. Use the radio button to switch between 
different trackers.

All settings appropriate to the current device will be automatically 
set. Measurement parameters can be set via Measurement Plans.

 ■ The Record Position button is used to teach positions for au-
tomatically locking on the T-Scan via an MP command.  The 
Collection::Group::Target name is used for the storage of the 
auto-lock position in SA.

 ■ The Release Motors button will release the motors on the active 
tracker so that it can be pointed by hand.

 ■ The Find Reflector button will initiate a search for a reflector in 
order to lock onto the selected device. The distance field next 
to this button is used to provide the controller with an idea on 
how far to search for the reflector based on its distance from 
the tracker.

Note:  If we’d had a T-Mac 
connected, the MUX (multi-

plexer) would show T-Mac and 
the Device would be Trigger 
Probe.
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Running the AIC Driver In Automation Mode
The Program I/O button is used to program the digital I/O signals for 
Automation Mode. In this mode, the AIC Interface expects to receive 
signals from the robot, and will send signals to the robot, for hand-
shaking. The Program I/O button allows communication between the 
AIC interface and the device with which it is working--typically a ro-
bot. You can define the meaning for up to 6 input channels coming in 
from the robot, and up to 3 channels going out to the robot (Figure 
28-20).

Figure 28-20. Programming 
the I/O.

A series of Instrument Operational Check Measurement Plan 
command strings are available for interacting with the AIC in automa-
tion mode. Refer to the “MP Command Reference” document for de-
tails.
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Portable Arms

API Axxis Arm (6 DOF)

1. Download the Baces3D Install zip from ftp://ftp.kinematics.
com/pub/SA/Install/Driver%20Downloads/PCMM%20Arms/
API/Axxis/.

2. Unzip the file to your hard drive, and follow the instructions in 
the Baces3D USB Installation PDF file.

Running the Arm
1. Select the API Axxis 6DOF arm (Figure 28-21).

2. 

Figure 28-21. Adding an 
Axxis 6-DOF arm.

With the new instrument added, run the arm interface mod-
ule.

3. You  will  be  asked  to  choose  a  communication  meth-
od  and  a  parameter  file (Figure 28-22).  This  parameter  file 
should be supplied with the arm.

4. 

Figure 28-22. The Axxis Con-
nection Settings dialog.

Once connection is established the arm must be initialized. 
Simply exercise the arm until all encoders have a green status 
(Figure 28-23).

Note:  You must have the 
proper calibration file for the 

arm (manufacturer-supplied). The 
file name will contain the arm se-
rial number and will end with 
...Arm.tab. You will be prompt-
ed to browse for the path to this 
file when the interface starts.
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5. 

Figure 28-23. Exercising the 
encoders on the arm.

The SA arm interface will now appear. At this point you are 
ready to perform a point probe calibration. To access the point 
probe calibration, simply right-click on the Baces3D icon in 
the system tray (Figure 28-24).

6. 

Figure 28-24. The Baces3D 
icon.

Follow the Baces3D calibration dialog (Figure 28-25).

7. 

Figure 28-25. The Baces3D 
calibration dialog.

With a satisfactory calibration the arm is ready to measure. 
Simply use the buttons on the arm to trigger measurements, 
change measurements, etc. The button configuration is avail-
able through the arm User Options. For example, a short press 
of the blue button will toggle through the measurement 
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modes. A long press of the blue button will activate a mea-
surement mode.

Figure 28-26. Button set-
tings for the arm.
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API Axxis Scanner Arm (7 DOF)

Prerequisites
1. Download PluginSpatialAnalyzerXXXX.zip from ftp://

ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/
Scanners/Kreon%20Scanner%20Plugin/.

2. Unzip the file to your hard drive, and run Setup.exe. The 
installer will guide you through the process of installing the 
scanner and the HASP dongle driver.

Network Settings for Running the Scanner
 ■ The scanner’s ip address is set to 192.168.244.43 and 

255.255.255.0 (subnet mask).

 ■ Your PC’s network card MUST have the following address: 
192.168.244.x, where x is any number between 1 and 255, ex-
cept for 43. 255.255.255.0 (subnet mask).

 ■ The above MUST be the ONLY address set on your network 
card.

 ■ Your network card MUST be configured for ‘Speed & Duplex’ = 
‘10Mbps/Full Duplex’

 ■ You can find this setting in (e.g. for Windows XP) in Device 
Manager: Control Panel>System>Hardware>Device Manager.   Select 
Network adapter (the one you are configuring), and go to the 
Advanced tab.

 ■ If you are unable to make this setting change, you will need to 
consult IT, or someone who can make the change.

Running the Instrument in SA
1. Add an instrument using the menu item Instrument>Add Instru-

ment or use the icon.

2. Select the API Axxis 7DOF arm (Figure 28-27).

Note:  You must have the 
proper calibration file for the 

arm (manufacturer-supplied). The 
file name will contain the arm se-
rial number and will end with 
...Arm.tab. You will be prompted 
to browse for the path to this file 
when the interface starts.

Note:  You must plug in the 
USB license key for the scan-

ner before use.

Note:  You must have the 
proper calibration file for the 

scanner.  The Kreon install will 
prompt you for the file. It will be 
named [scanner serial number].
cal.

Note:  The consequence of 
the above requirements is of 

course that you will be unable to 
run any other device which uses 
network communications on the 
computer configured as required, 
UNLESS the computer has more 
than one network card.
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3. 

Figure 28-27. Adding a 
7-DOF Axxis arm.

With the new instrument added run the arm interface mod-
ule. Simply click the icon.

4. You will be asked to choose a communication method and 
a parameter file. This parameter file should be supplied with 
the arm. Be sure to select the scanner parameter file (Figure 
28-28). 

5. 

Figure 28-28. The Axxis con-
nection settings dialog.

Once the connection is established the arm must be initial-
ized. Simply exercise the arm until all encoders have a green 
status (Figure 28-29).  

6. 

Figure 28-29. Exercising the 
encoders on the arm.

The SA arm interface will now appear. At this point you are 
ready to perform a point probe and scanner calibration. To ac-
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cess the calibration routine press the calibration button in 
the arm interface. Perform a scanner calibration and accept 
the results (Figure 28-30).

7. 

Figure 28-30. Calibrating the 
arm.

If hard probing will be used in conjunction with the scanner 
be sure to have a valid 6-DOF calibration as the 7-DOF calibra-
tion is dependent on the results of the 6-DOF calibration. To 
define the 7-DOF hard probe press the options button in 
the arm interface. Now press the Cal/Set button to access the 
calibration dialog.

8. Follow the instructions for defining the point probe (Figure 
28-31).  

9. 

Figure 28-31. Calibrating the 
touch probe.

With a satisfactory calibration the arm is ready to measure. 
Simply use the buttons on the arm to trigger measurements, 
change measurements, etc.
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Perceptron Contour Scanner (ScanWorks v4)

The Perceptron interface requires that you install and run Perceptron’s 
ScanWorks application. Make certain the scanner is connected to the 
arm, and the power to the scanner is on. Run ScanWorks. ScanWorks 
version 4.4a.082 is shown in Figure 28-32.

Figure 28-32. 

Note the Output data to TCP/IP setting is checked. This MUST be checked 
in order for the interface to receive data. In older versions of Scan-
Works, you must go to the Setup menu, and select User Options. 
There, you must check Output data to TCP/IP, and select Inches as the 
units. In ScanWorks v. 4.4 and later, the SA interface sets the units in 
ScanWorks automatically.

1. Minimize ScanWorks to preserve screen space. In the SA Inter-
face, select to start the scanner measure mode. As with any 
measure mode, this is normally done by pressing the Record/
Accept button for a short duration to iterate through the mea-
sure modes (buttons will appear pressed as you iterate 
through.)  Or you can press the Delete Last/Cancel button to 
iterate back the other way through the measure modes. Then, 
a long button press on the Record/Accept button will start 
the selected measure mode. The scanner laser line will turn 
on, and the Scanner Measurement dialog will appear (Figure 
28-33).
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2. 

Figure 28-33. 

If the ScanWorks window is visible, you’ll notice most controls 
are greyed out in ScanWorks, denoting that control has been 
taken by the SA CMM Arm interface (Figure 28-34).

3. 

Figure 28-34. Grayed-out 
controls in the ScanWorks 
interface.

You’ll also notice that ScanWorks will pop a scanner distance 
indicator bar (see Figure 28-35 on page 767) to help deter-
mine whether you are a good distance from the surface to be 
scanned:
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4. 

Figure 28-35. Scanner dis-
tance guide.

You’ll also hear a variable frequency beep giving an audible 
scanner-to-part distance indication. Both these features can 
be toggled in the ScanWorks Setup menu under User Options. 
When you reach a good starting position, simply press and 
release the scan start/stop button on the arm (this is deter-
mined by ScanWorks. For example, on a 7-DOF arm with a 
trigger style handle, the start scan button will be the center, 
or trigger, button.).

5. During the scan, Scanner Measurement dialog will indicate 
that a scan has started (Figure 28-36), and will display prog-
ress indicating number of cloud data points and Cloud Name 
being sent to SA.

6. 

Figure 28-36. Scanning 
progress is displayed in the 
Scanner Measurement win-
dow.

End a scan by again pressing and releasing the arm scan but-
ton. When this happens, the Scanner Measurement dialog 
will indicate the scan stop, and will send and report any left 
over buffered cloud points.

7. Perform as many scans as are desired in this way. To end the 
Scanner Measurement Mode, you must press the ‘end scan 
session’ button on the arm. Like the start/stop scan button, 
this is determined by ScanWorks.  For example, on a 7-DOF 
arm with a trigger-style handle, the end scan session button 
will be either of the outside buttons on the trigger handle. 
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Note that if you try to simply close the Scanner Measurement 
dialog with the “X” button, it will not close, and the dialog will 
instruct you to end the scan session from the arm (Figure 28-
37).

8. 

Figure 28-37. The scan ses-
sion must be closed via the 
arm button.

Once you do press the appropriate arm button to end the 
ScanWorks scan session, the Scanner Measurement will re-
port that the ScanWorks connection is closing, and will close 
once ScanWorks is disconnected. If the ScanWorks window is 
visible, you’ll notice that its controls are re-enabled, indicating 
that scanner control has been passed back to it.

Scanner Settings
You can edit the scan data handling and naming in the Arm Settings 
dialog. Press  to edit arm settings. Note that if you still have the 
Perceptron scanner connected, you will briefly see an error message 
from CimCore (Figure 28-38).

Figure 28-38. Error message.

This is expected, since the CimCore Validate Probe function is called, 
and CimCore has no knowledge of the Contour Scanner as a valid 
probe definition. Indeed, this error will be generated any time a mea-
surement other than scanning is attempted while the scanner is con-
nected to the arm. The arm Options dialog will appear (Figure 28-39).
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Figure 28-39. Arm options.

Press the Fit/Scan Options button to show the Fit/Scan Options dialog 
(Figure 28-40).
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Figure 28-40. The Fit/Scan 
options.

Under Line Scan (Optional Laser Line Scanner), you can control the inter-
val at which scan clouds are sent to SA (Perceptron Contour can ac-
quire up to ~23,000 Pts/sec), by editing the field labeled Send Cloud 
Data to SA Every ___ Seconds. The Cloud Name is taken from the current 
Group Name in the main dialog. If Auto Increment Cloud Name is checked, 
then the name will automatically increment after each cloud data 
packet is sent to SA. The Scanner Measurement dialog is modeless, 
meaning the Group Name (and therefore Cloud Name) in the main 
dialog can be edited any time, even during a scan session. The scan-
ner measurement progress shown earlier in this section was per-
formed with the settings as shown here. To apply settings, simply 
press OK.

Scanner Calibration
The ScanWorks User Guide includes detailed instructions for calibrat-
ing the scanner to the arm. Read the instructions through before at-
tempting to calibrate the scanner. If you need to change computers, 
but will be using the same scanner and arm, you can transfer the ex-
isting calibration to the new computer. The calibration file is stored in 
the ScanWorks install on the application PC. For example, if you used 
the default location for the ScanWorks install, the calibration file will 
be stored in C:\Program Files\Perceptron\ScanWorks\Cim-
Core\data\.
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The name of the file is xform_[scanner serial number].dat 
where [scanner serial number] will match the number printed directly 
on the scanner. Simply copy this file to the same location in the Scan-
Works install folder on the new PC, and you are ready to run using the 
existing scanner calibration.
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Perceptron Contour Scanner (ScanWorks v5)

Running the Perceptron Scanner requires Scanworks (version 5.21.116 
or later) to be installed and running (Figure 28-41). Please refer to 
Scanworks documentation for details and settings. The Scanworks in-
terface is controlled by a console application. The console can be set 
to start on system startup or manually started when needed.

Figure 28-41. Starting Scan-
works.

The below options in the console (Figure 28-42) must be set accord-
ingly to allow SA to communicate with the arm and scanner. If set-
tings are not set correctly communication errors will occur.

Figure 28-42. ScanWorks 
Console.

Once the console options have been set, now operation of the scan-
ner can begin. Open SA and add your instrument. Start the instru-
ment interface. Best practice is to have the console running before 
you start the instrument interface but it is not required. The console 
must be running before the scanning operation is started.

In the instrument interface there are several settings that can affect 
the outputs of the contour scanner. These settings can be optimized 
to best fit your application and the capacity of your computer.
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Figure 28-43. Setting the 
Laser Line Scan options.

Once Line Scan settings are configured (Figure 28-43), simply press
to start scanning.

You will see a status window notifying the connection between SA 
and Scanworks (Figure 28-44).

Figure 28-44. The connec-
tion is established.

You will notice the below toolbar display when connected to the 
scanner (Figure 28-45). This will allow access to settings such as scan 
rate, scan density and exposure settings.

Figure 28-45. The Scan-
Works toolbar.

Now press the Red button to start collecting data. The status window 
will show data being sent to SA (Figure 28-46).

Figure 28-46. Data collec-
tion.

To stop data collection, press the Red Button again. To exit the scan-
ning operation press one of the White Buttons and SA will disconnect 
from Scanworks.

Troubleshooting
If the error in Figure 28-47 occurs try the following:
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1. 

Figure 28-47. ScanWorks 
communication error.

Check to be sure sensor is attached and all connections are 
correct.

2. Go to the Scanworks Console and close Scanworks (Figure 28-
48).

3. 

Figure 28-48. Shutting down 
ScanWorks.

Now restart Scanworks and try the scanning operation again 
(Figure 28-49).

Figure 28-49. Restarting 
ScanWorks.
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Romer/Cimcore Arms

Before adding and running a Cimcore arm in SA, the appropriate in-
strument driver must be installed. Locate and install the latest WinRDS 
driver from the SA Driver Download area: ftp://ftp.kinematics.com/
pub/SA/Install/Driver%20Downloads/PCMM%20Arms/Cimcore/

Once downloaded, with the instrument disconnected, install the in-
strument driver as instructed. Once installed, reboot the PC.   Now 
connect the arm and turn the power on. If the arm uses a USB connec-
tion, follow the below steps. If not, proceed to Running the Cimcore 
Arm in SpatialAnalyzer below.

When connecting via USB for the first time Windows will display the 
dialog in Figure 28-50.

Figure 28-50. The Hardware 
Update wizard.

Select Yes, this time only and press Next. Follow the prompts until the 
Hardware Update is complete.

If this dialog did not appear and the drivers have not been associated 
to the hardware, right click on “My Computer” and select “Proper-
ties”.  Under the properties dialog select the “Hardware” tab and then 
select “Device Manager”.

Under “Device Manager” (Figure 28-51) locate the Cimcore USB Arm, 
then right click and select “Update Drivers”.  This will display the “Hard-
ware Update Wizard” as discussed above. Follow the same directions 
as above.   

Note:  If you are not running 
the latest version of SA, 

please check the readme.txt file 
for the corresponding driver ver-
sion.
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Figure 28-51. Device Man-
ager.

Now that drivers are installed and the hardware is updated, test the 
connection by running WinRDS.  Start>Programs>Cimcore>WinRDS>Cimc
ore Arm Utilities.

If the connection is working correctly, WinRDS will initialize the arm. 
Move the arm to until the below dialog is satisfied. Now that the con-
nection has been tested close WinRDS.

Figure 28-52. Exercising the 
encoders on the arm.

Running the Cimcore Arm in SpatialAnalyzer
Connecting the arm for the first time in SA requires one extra step than 
usual. First add the desired Cimcore Arm by selecting Instrument>Add. 
Then select Instrument>Run Interface Module.  Select the Portable CMM 
interface (Figure 28-53).
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Figure 28-53. Starting the 
interface.

Select the instrument (Figure 28-54).

Figure 28-54. Connecting to 
the instrument.

Once selected, a prompt will display asking for communication meth-
od (Figure 28-55). This step will persist the next time the interface is 
connected.

Figure 28-55. Choosing the 
communication method.

The next time connection is required, simply use the icon to run 
and connect the interface module. The arm interface will display once 
connection is complete.
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Romer MultiGage

Prerequisites
Before adding and running a Romer Multi-Gage in SA, the RDS drivers 
must first be installed.

Download the RDS InstallerV3.1.1.exe (or later) from ftp://ftp.
kinematics.com/pub/SA/Install/Driver%20Downloads/PCMM%20
Arms/Hexagon/ or install from the Instrument Drivers Combined In-
staller at http://kinematics.com/products/spatialanalyzer/spatialana-
lyzer-downloads.html

1. Run the RDS Installer and follow the prompts. Once installed, 
plug in the arm via the USB cable and verify Windows has 
properly recognized the device and installed the drivers prop-
erly.

2. RDS will always be active in the system tray (Figure 28-56) and 
is a great tool for checking arm status and connectivity (Fig-
ure 28-57).

Figure 28-56. RDS in the 
System Tray.

Figure 28-57. The RDS 
status.

Running the MultiGage
1. Add a MultiGage to SA via Instrument>Add or using the icon. 

Select the Romer MultiGage and click Add Instrument (Figure 
28-58).
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2. 

Figure 28-58. Selecting the 
instrument to add.

Run the instrument interface via Instrument>Run Interface Mod-
ule and Connect or using the icon.  

Troubleshooting
If arm connection problems occur, be sure to use the RDS application 
in the system tray for current status (Figure 28-59).  

Figure 28-59. The RDS status 
displaying an error.

If further information or settings are needed access the RDS Control 
Panel by right clicking the RDS icon in the system tray and select RDS 
Control Panel.



780

SPATIALANALYZER USER MANUAL

Romer Absolute

Prerequisites
Before adding and running a Romer Absolute Arm in SA, the RDS driv-
ers must first be installed.

Download the RDS InstallerV3.1.1.exe (or later) from ftp://ftp.
kinematics.com/pub/SA/Install/Driver%20Downloads/PCMM%20
Arms/Hexagon/ or install from the Instrument Drivers combined in-
staller at http://kinematics.com/products/spatialanalyzer/spatialana-
lyzer-downloads.html

1. Run the RDS Installer and follow the prompts. Once installed, 
plug in the arm via the USB cable and verify Windows has 
properly recognized the device and installed the drivers prop-
erly.

2. RDS will always be active in the system tray (Figure 28-60) and 
is a great tool for checking arm status and connectivity (Fig-
ure 28-61).

Figure 28-60. RDS in the 
System Tray.

Figure 28-61. The RDS status 
window.

3. If the arm is an Absolute Arm 7DOF SI (integrated scanner) 
you will need to ensure the computer’s IP address is config-
ured correctly to communicate with the Scanner IP address 
of 192.168.167.200.   Make sure the computer IP address is 
192.168.167.XXX with the last digits being between 0-255 
but not 200.  Example, 192.168.167.100 for the computer. For 
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more information on changing IP addresses please consult 
the IP Address Basics section.

Running the Absolute Arm
1. Add an AbsoluteArm to SA via Instrument>Add or using the

icon (Figure 28-62). Select the respective Absolute Arm and 
click Add Instrument.

2. 

Figure 28-62. Adding the 
Absolute arm to SA.

Run the instrument interface via Instrument>Run Interface Mod-
ule and Connect or using the icon.  

Scanning with the Absolute Arm (SI)
Scanning with a Absolute Arm 7-DOF SI is as simple as sliding a switch. 
Slide the switch on the back of the grip to the ON (upper) position 
and the scanner will be activated. There is no need to use the icon 
as it will notify you to slide the switch to the ON position. The inter-
face in Figure 28-63 will appear when the scanner is successfully con-
nected.

Figure 28-63. The RDS Scan-
ning interface.

Troubleshooting
If arm connection problems occur, be sure to use the RDS application 

Note:  If the probe is re-
moved and the RDS Scan-

ning window will not appear, ver-
ify the Ethernet connection and 
the IP address configuration.

Note:  When using the scanner 
make sure the probe is removed. 
The scanner will not connect 

with the probe attached.
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in the system tray for current status.  

Figure 28-64. The RDS Status 
window displaying an error.

If further information or settings are needed access the RDS Control 
Panel by right clicking the RDS icon in the system tray and select RDS 
Control Panel. 
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Romer Absolute (SE) with Perceptron ScanWorks v5 Shark

Figure 28-65. The Romer 
Absolute arm with Perceptron 
ScanWorks v5 Shark.

Requirements
 ■ A version of SA newer than SA 2011.10.20 is required.

 ■ RDS v3.2 is required and must be installed.

 ■ ScanWorks v5.50.19 or later is required. Refer to the ScanWorks 
documentation for installation instructions. If running on a 64-
bit operating system, be sure to use the 64-bit version of Scan-
Works.

Installing RDS v3.2
1. Obtain the installer for RDS v3.2 from ftp://ftp.kinematics.

com/pub/SA/Install/Driver%20Downloads/PCMM%20Arms/
Hexagon/ or use the combined instrument drivers installer 
found at ftp://ftp.kinematics.com/pub/SA/Install/SA%20In-
strument%20Mfg%20Drivers.exe.

2. Double-click the executable file to begin the installer, and fol-
low the on-screen instructions.
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Setting Up the Scanner
1. Ensure that the correct versions of RDS and ScanWorks are in-

stalled on the computer as indicated above.

2. Verify that all connections have been made and that the scan-
ner controller (and its sensor power switch) are powered off.

3. On the Absolute arm’s handle, ensure the scanner switch is in 
the Off position.

4. Start ScanWorks Console (Figure 28-66), and set it up as de-
picted in the following image. While these settings are not all 
required, if settings differ you may experience communica-
tion problems.

5. 

Figure 28-66. ScanWorks 
console.

Open the RDS Control Panel (Figure 28-67) and go to the 
Probe tab. If there are any entries of type Scanner in the list, 
delete them by selecting them and pressing Delete. (This is 
required if you ever change from one scanner to another).

6. 

Figure 28-67. ScanWorks 
Control Panel.

If the computer is on a network with a DHCP server, the scan-
ner controller will get an IP address from the server, and you 
can leave your network settings as they are. If not, set the 
computer’s IP address to 192.168.19.xx, where xx is any 

Note:  If your scanner con-
troller has been set to any IP 

address other than the default, 
you may need to use a different IP 
address. Contact Perceptron or 
Hexagon Metrology for details.
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number other than 13.

7. Power on the scanner controller. On the Absolute arm’s han-
dle, turn the scanner switch to the On position.

8. RDS should automatically detect and identify the scanner. If 
not, you will be presented with a dialog asking you to select 
the probe type (Figure 28-68). Choose External scanner, then 
click OK.

9. 

Figure 28-68. Selecting the 
probe type.

Calibrate the scanner in accordance with the manufacturer’s 
guidance.

10. In SA, add the appropriate Absolute SE arm, and start up the 
instrument interface (Figure 28-69).

11. 

Figure 28-69. Adding the 
appropriate arm.

Any time the scan switch on the Absolute arm’s handle is in 
the On position, pressing the trigger button will initiate scan-
ning. Press the side button to stop scanning. When finished 
scanning, move the scanner selector switch on the Absolute 
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arm’s handle to the Off position.

12. To change to a probe tip, turn off the Perceptron control-
ler Sensor Power switch, remove the scanner, and attach the 
probe. To change back to the scanner, remove the probe, at-
tach the scanner, and turn scanner controller’s Sensor Power 
switch back on. The current active probe is displayed on the 
SA Arm Interface main window.
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Romer Absolute (SE) with Hexagon CMS Scanner

Figure 28-70. Romer Abso-
lute arm with Hexagon CMS 
Scanner.

Requirements
 ■ A version of SA newer than SA 2011.10.20 is required.

 ■ RDS v3.2 is required and must be installed.

Installing RDS v3.2
1. Obtain the installer for RDS v3.2 from ftp://ftp.kinematics.

com/pub/SA/Install/Driver%20Downloads/PCMM%20Arms/
Hexagon/ or use the combined instrument drivers installer 
found at ftp://ftp.kinematics.com/pub/SA/Install/SA%20In-
strument%20Mfg%20Drivers.exe.

2. Double-click the executable file to begin the installer, and fol-
low the on-screen instructions.

Setting Up the Scanner
1. Ensure that the correct versions of RDS is installed on the 

computer as indicated above.

2. Verify that all connections have been made and that the scan-
ner controller is powered off.

3. On the Absolute arm’s handle, ensure the scanner switch is in 
the Off position.
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4. Open the RDS Control Panel (Figure 28-71) and go to the 
Probe tab. If there are any entries of type Scanner in the list, 
delete them by selecting them and pressing Delete. (This is 
required if you ever change from one scanner to another).

5. 

Figure 28-71. The RDS Con-
trol Panel.

Set the computer’s IP address to 192.168.150.xx, where xx 
is any number other than 100.

6. Power on the scanner controller. On the Absolute arm’s han-
dle, turn the scanner switch to the On position.

7. RDS should automatically detect and identify the scanner. If 
not, you will be presented with a dialog asking you to select 
the probe type (Figure 28-72). Choose CMS, then click OK.

8. 

Figure 28-72. Selecting the 
probe type.

In the RDS Control Panel, click the Calibrate button and cali-
brate the scanner in accordance with the manufacturer’s 
guidance.

9. Once calibration is complete, return to SA. Add the appropri-
ate Absolute SE arm (Figure 28-73), and start up the instru-
ment interface, as depicted below.

Note:  If your scanner con-
troller has been set to any IP 

address other than the default, 
you may need to use a different IP 
address. Contact Hexagon Me-
trology for details.

Note:  During calibration, 
the trigger button on the 

Absolute arm’s handle toggles 
scanning, and the side button 
confirms the scan for each of the 
15 calibration scans.
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10. 

Figure 28-73. Adding the 
appropriate arm.

Any time the scan switch on the Absolute arm’s handle is in 
the On position, press and hold the trigger button to scan. 
When finished scanning, move the scanner selector switch on 
the Absolute arm’s handle to the Off position.
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Total Stations

Leica TCRP, TDRA, and TS-Series

Establishing Bluetooth Connection on PC
Use the Bluetooth wizard installed on the PC to create a new connec-
tion (Figure 28-74). Be sure the Leica 1203+ is powered on.

Figure 28-74. The Bluetooth 
Settings window.

The Bluetooth wizard will search for the device (Figure 28-75).

Figure 28-75. Adding the 
new connection.

The Bluetooth manager will complete the connection and display the 
COM number being used. Remember this number as it is needed in-
side of SA to establish connection.   If prompted for a password just 
use “0000”.

Figure 28-76. This instru-
ment is set up on COM4.

Now the Leica 1203+ is a recognizable connection for Bluetooth. Each 
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time the Leica 1203+ is powered the user must enter the Bluetooth 
manager and activate the connection (Figure 28-77).

Figure 28-77. Activating the 
connection.

Starting the Interface
1. Select Instrument>Add and choose the Leica Total Station 

(TDRA6000, TS3X, T120x) from the Instrument List.  

2. Now run the instrument interface module under Instrument>Run 
Interface Module and choose Theodolite Manager.

3. Select New Setup and then Add (Figure 28-78).

4. 

Figure 28-78. Creating a 
new setup.

Select the instrument type and the COM Port. Then select the 
instrument in the available SpatialAnalyzer list and click Con-
nect.
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Figure 28-79. Connecting to 
the instrument.

The Interface

Figure 28-80. The total sta-
tion interface.

Toolbar
 ■ Laser beam on

 ■ Laser beam off

 ■ Reverses the face of the instrument

 ■ Displays rotation dialog for manual entry of rotation values

 ■ Displays the user options

 ■ Shuts down the instrument

 ■ Opens the reflector database

Group and Target
Defines the Group name and target name for the measured point. If 
the measured point is recorded from the instrument it will do one of 
two things:
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 ■ If in Freeform Mode it will decode the instrument target based 
on the parameters in the Theodolite Manager Options (Figure 
28-81). For example, if the Target name is 32 on the instrument, 
when recorded in SA it will be Group3::2 per the below settings.

 ■

Figure 28-81. Freeform 
mode.

If the Theodolite Manger options are set to Single Target Mode, 
the prescribed point name in the SA interface will be used.

Messages
The message dialog will notify the user if a measurement or process 
encounters an issue. The message will clear automatically or right-
click the message.

Figure 28-82. An error mes-
sage.

Query and Record
Query will send updates only to SA. If you wanted to update a watch 
window, you use Query. Record will send a measured point to SA 
(Figure 28-83). See above section regarding point naming if recorded 
from the instrument.

Figure 28-83. Query vs. 
Record.

Acquire
Acquire will use the Leica ATR functionality to lock onto a tar-
get. This is especially useful for Prisms and Tape targets.  Point the in-
strument close to the target and press acquire. ATR will find the best 
center for the target.
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Tracking
With the instrument locked onto a prism, tracking can be used. Select 
the desired options and press Track (Figure 28-84). 

Figure 28-84. Tracking.

Track only will do exactly what it says, it will only track the prism and 
not send updates or measurements. Send updates is like query, but 
used for sending updates to SA while tracking. Measure will send 
measurements to SA while tracking.

Auto Measure SA Geometry

Figure 28-85. Auto-Measure 
settings.

User Options
The user options (Figure 28-86) can be accessed by using or by 
Instrument>Options.

 ■

Figure 28-86. The instru-
ment options.

Tilt Compensator. Turns the tilt compensator on and off. If on, 
the instrument must be level in order to measure.

Laser Pointer
 ■ Point at with laser pointer. When the SA command “point at” 

is executed the laser will turn on.

 ■ Activate Laser After Tracking Loss. When the tracking stops 
because the line of sight as been broken the laser beam will 
turn on.

Targeting Properties
 ■ Change Reflector. Choose the desired reflector type.   For 
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prism, the user has the option of adding Planar and Radial off-
sets in addition to the Prism Constant. For prism and tape tar-
gets, the ATR can be used if desired when a point is recorded.

 ■ Front/Back (Reverse Face). When checked, a back sight mea-
surement will be taken with each front sight measurement

 ■ Send Front/Back as Separate Observations. When a front/
back sight measurement is taken, if checked, they will be stored 
as separate observations.

Perimeter Scanning
1. Measure points defining the area to scan (Figure 28-87).  

2. 

Figure 28-87. Perimeter 
points.

Construct a perimeter from the measured point in SA under 
Construct>Perimeter (Figure 28-88).

3. 

Figure 28-88. Defined pe-
rimeters.

Two types of perimeters exist in SA, open and closed (Figure 
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28-89). A single perimeter can be changed from open to 
closed in the perimeter properties dialog.

4. 

Figure 28-89. Marking a 
perimeter as closed.

Set the scan properties for the appropriate perimeter. If the 
perimeter is closed the scan will be bounded by the perime-
ter. If it is open, the scan lines will be perpendicular to the pe-
rimeter.

Figure 28-90. Auto Measure 
SA Geometry settings.

Figure 28-91. Auto Scan 
properties.

The user can specify the distance between scan lines and points per 
scan line (Figure 28-91). In addition the user can also specify line 
length for open perimeters. The orientation of the lines to the perim-
eter can be controlled by the Grid Rotation field.

To measure a Perimeter, first select Active in the user interface (Figure 
28-92) and then select a perimeter from the Treeview in SA. Once the 
perimeter is selected, select the measure button.
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Figure 28-92. Selecting ac-
tive in the interface.

The scan will start (Figure 28-93) and lines will be constructed (if op-
tion was checked).  Points will be spaced per user setting. A point will 
always be measured at the beginning and end of each line.

Figure 28-93. Scanning.

To stop a scan, press the Cancel button in the progress dialog.

Auto Measure
The Leica 1203+ can also be used in the SA command Auto Mea-
sure. This command will drive the instrument to points in a group and 
allow a measurement to be recorded.

To perform the Auto Measure, select Instrument>Automatic 
Measurement>Auto Measure.

Select the group to measure and the dialog in Figure 28-94 will ap-
pear.

Figure 28-94. The Auto 
Measure dialog.

This will allow for a single point to be measured or an entire pass be 
performed. Choose Entire Pass and the instrument will drive to the 



798

SPATIALANALYZER USER MANUAL

first point.

Sight the target and press Record (F3) in the instrument interface. 
Once the measurement is recorded the instrument will drive to the 
next point.

Figure 28-95. Completion of 
the Auto Measure procedure.
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Sokkia Net1

SpatialAnalyzer interfaces with the Sokkia Net1 using the Theodo-
lite Manager via a Bluetooth or RS232C (Serial Port) connection. This 
quick start guide will cover required Sokkia Net1 settings along with 
step by step instruction for using the Sokkia Net1 in SA.

Connections
Before attempting to connect to SA, first choose your preferred con-
nection on the Net1.

1. Enter the configuration menu (Figure 28-96).

2. 

Figure 28-96. The configura-
tion menu.

Select Communications (Figure 28-97).

3. 

Figure 28-97. Selecting 
Comms.

Set the communication mode (Figure 28-98).

4. 

Figure 28-98. Choosing the 
Comm mode.

RS232C Settings (Figure 28-99).
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5. 

Figure 28-99. The correct 
RS232 settings for connection.

Bluetooth Settings (Figure 28-100).

Figure 28-100. The proper 
Bluetooth settings.

 Establishing Bluetooth Connection on PC
1. Use Bluetooth wizard installed on PC to create a new connec-

tion (Figure 28-101). Be sure the Sokkia Net1 power is on.

2. 

Figure 28-101. Creating a 
new connection.

The Bluetooth wizard will search for the device (Figure 28-
102).
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3. 

Figure 28-102. The Add New 
Connection Wizard.

The Bluetooth manager will complete the connection and 
display the COM number being used (Figure 28-103). Remem-
ber this number as it is needed inside of SA to establish con-
nection.

4. 

Figure 28-103. The assigned 
COM port.

Now the Sokkia Net1 is a recognizable connection for Blue-
tooth. Each time the Sokkia Net1 is powered the user must 
enter the Bluetooth manager and activate the connection 
(Figure 28-104).

5. 

Figure 28-104. The connec-
tion has been established.

Add the Sokkia Net1--select the Sokkia Net1 and pick instru-
ment options (Figure 28-105).
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6. 

Figure 28-105. Adding the 
total station to the job.

Run the Theodolite Manager and select New Setup, then Add 
(Figure 28-106).

7. 

Figure 28-106. Creating a 
New Setup.

Select the instrument type and the Comm Port. This port was 
displayed in the Bluetooth manager during the creation of 
the connection. Then select the instrument in the available 
Spatial Analyzer list. Once connected the Sokkia Net1 inter-
face will display (Figure 28-107).



803

CHAPTER 28 ■ INSTRUMENT QUICK-STARTS

Figure 28-107. The Sokkia 
interface.

The following topics will be covered:

 ■ Selecting a Reflector

 ■ Single Point Measurement

 ■ Perimeter Scanning

 ■ Target Tracking

 ■ Auto Measure Points

Selecting Target Reflector
1. Select the options button in the interface (Figure 28-108).

2. 

Figure 28-108. The options 
button.

Select the Change Reflector button (Figure 28-109).

3. 

Figure 28-109. The Sokkia 
options window.

Select desired reflector type (Figure 28-110) .
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Figure 28-110. Selecting the 
desired reflector.

Single Point Measurement
1. Specify Group and Target Name.

2. Sight Target.

3. Select Query or Record (F3) in the interface. Query will force 
the instrument to calculate a measurement. Record (F3) will 
send the measurement to SA (Figure 28-111).

Figure 28-111. Recording a 
measurement.

Perimeter Scanning
1. Measure points defining the area to scan (Figure 28-112).  

2. 

Figure 28-112. Measure-
ments of the area to scan.

Construct a perimeter from the measured point in SA under 
Construct>Perimeter (Figure 28-113).
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3. 

Figure 28-113. The defined 
perimeters.

Two types of perimeters exist in SA, open and closed. A single 
perimeter can be changed from open to closed in the perim-
eter properties dialog (Figure 28-114).

4. 

Figure 28-114. The Perim-
eter Properties window.

Set the scan properties for the appropriate perimeter. If the 
perimeter is closed the scan will be bounded by the perime-
ter. If it is open, the scan lines will be perpendicular to the pe-
rimeter.

5. 

Figure 28-115. Auto Scan 
properties.

The user can specify the distance between scan lines and 
points per scan line (Figure 28-115). In addition the user can 
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also specify line length for open perimeters. The orientation 
of the lines to the perimeter can be controlled by the Grid Ro-
tation field.

To measure a Perimeter, first select Active in the user interface (Figure 
28-116) and then select a perimeter from the Treeview in SA. Once 
the perimeter is selected, select the measure button.

Figure 28-116. The Active 
setting.

The scan will start and lines will be constructed (if option was 
checked).  Points will be spaced per user setting. A point will always 
be measured at the beginning and end of each line.

To stop a scan, press the cancel button in the progress dialog.

 Target Tracking
The Sokkia Net1 is capable of tracking a prism target.

Figure 28-117. The track set-
ting to track a prism target.

Simply select track and start moving the prism (Figure 28-117). The 
Net1 will track the prism. If the record option is check, measurements 
will be sent to SA while the prism is being moved.

 Auto Measure
The Sokkia Net1 can also be used in the SA command Auto Mea-
sure. This command will drive the instrument to points in a group and 
allow a measurement to be recorded.

To perform the Auto Measure, select Instrument>Automatic 
Measurement>Auto Measure.

Select the group to measure and the dialog in Figure 28-118 will ap-
pear.
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Figure 28-118. Auto Mea-
sure mode.

This will allow for a single point to be measured or an entire pass be 
performed. Choose Entire Pass and the instrument will drive to the 
first point.

Sight the target and press Record (F3) in the instrument interface. 
Once the measurement is recorded the instrument will drive to the 
next point.

Figure 28-119. A completed 
auto measurement.
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Leica Nova MS50

This guide may be used for initial configuration, connection and basic 
operation of the Leica Nova MS50 Total Station within SA. For more 
details on instrument operation and configuration, please contact 
Leica directly. 

Hardware Setup
Set up the unit following the manufacturer’s directions. Leica total 
stations may be connected either with a USB cable, wireless network 
adapter or  Bluetooth connection. Ensure that you have the necessary 
cables, router or a Bluetooth adapter.  Be sure the power is turned on 
and the battery is charged.

Software Setup
It is recommended that initial connection and testing be performed 
using a cable connection to your computer. To connect directly to the 
PC, you will need to install the instrument drivers. The current drivers 
SA supports can be downloaded from http://www.kinematics.com/
ftp/SA/Install/Driver%20Downloads/TotalStations_Theodolites/Lei-
ca/Leica%20Nova%20MS50%20Drivers/.

To use the live remote video function available on this instrument, 
you will also need to install the VLC player application which can be 
downloaded from http://www.videolan.org/vlc/. Once installed, a 
Video button will appear on the Camera Interface dialog. 

Direct Cable Connection
On the scope select Instrument > Connections > All Other Connections. Set 
the GeoCom connection to USB (to obtain the current IP address and 
port, press Cntrl..). Connect the USB cable and continue to the section 
Running the Instrument.

Wireless Connection
A connection can be established to the Nova by adding the device to 
a preexisting network or by building an Ad-hoc connection with your 
PC. For more detailed instructions, refer to the document “Connecting 
a Nova total station with a PC using a WLAN” on our download page. 
For a quick synopsis on a Windows 7 machine, follow these steps:

Building an Ad-hoc Connection on a Win7 PC

6. Turn on the wireless adapter on your PC and go to Control Panel 
> Network and Sharing Center.

7. Select Setup a new connection or network > Set up a wireless ad hoc 
(computer to computer) network.

8. When prompted, enter a network name (e.g. “Ad-hoc MS50) 
and a security type, if desired (no authentication, WEP and 
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WPA-2 are supported).

9. Select Save this network then Next to create the network.

10. Set the IP address to be compatible with the scope.

Setting the IP Address in the Adapter Properties

1. Turn on the wireless adapter on your PC and go to Control Panel 
> Network and Sharing Center.

2. Select Manage wireless networks > Adapter properties for the net-
work you wish to connect to and for editing the properties of 
your ad-hoc network.

3. In the Wireless Network Connection Properties dialog, select 
Internet Protocol Version 4 (TCP/IPv4).

4. Select Properties and enter the IP address rather than obtain-
ing one automatically. This address determines the comput-
er’s IP address on the network. 

Configuring the MS50 Network Connection

1. Open the Windows CE control panel by selecting User > Tools & 
Utilities > View ASCII files and close the viewer. 

2. Click on WLAN Settings in the taskbar and select the network 
you wish to connect to from the network list and click Con-
nect. In some cases, you may need to set the IP address manu-
ally by doing following:

 ■ Select Start > Settings > Network and Dial-Up Connections OWL221A1.

 ■ Select Enable, and then Properties.

 ■ Choose Specify an IP address, and enter the IP address for the 
total station on the network. The first three numbers of the IP 
address need to match the first three numbers entered for the 
PC. The last number must be unique from the PC.

3. Return to the Windows CE desktop, click on WLAN settings in 
the taskbar. In the Wireless Information tab, select the ad-hoc 
network that you created and select Connect. 

4. Continue to the section Running the Instrument. 

Connecting to Bluetooth

1. On the scope, select Instrument > Connections > All Other Connec 
tions.

2. Set the GeoCom connection to TS Bluetooth 1.

3. On your PC, go to your Bluetooth adapter and select Add a 
Device. 

4. Select the device from the available Bluetooth connections 
and select next.



810

SPATIALANALYZER USER MANUAL

5. When prompted, enter the pairing code: 0000. Once con-
nected, a COM port number will be assigned and can be ac-
cessed through the properties of the device.

6. Continue on to the section Running the Instrument.

Configuring the Scope for Optimal Use with SA

1. Navigate to Users > System Settings > Regional Settings. 

2. Check that the Hz angle display is set to north anti-clockwise 
and the V angle display is set to Zenith angle. This will ensure 
that the angles displayed on the scope match those of the 
recorded points in SA.

Starting the Interface
1. Select Instrument > Add and choose the Leica Nova MS50 Total 

Station from the Add Instrument to SA dialog (Figure 28-120).

Figure 28-120. Adding the 
Leica Nova MS50 Total Station 
to a job.

2. Now run the instrument interface module under Instrument > 
Run Interface Module and choose Theodolite Manager.

3. Select New Setup and then Add (Figure 28-121).
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Figure 28-121. The Theodo-
lite Manager dialog.

4. Select the instrument type and the COM Port. Set the COM 
Port to TCP if you are connecting with either a cable or wire-
less; or enter the port number for Bluetooth. Then select the 
instrument in the available SpatialAnalyzer list and click Con-
nect (Figure 28-122).

Figure 28-122. Adding a 
new setup.

v

5. Select the instrument in the available SpatialAnalyzer list and 
click Connect. 

Operations Specific to the MS50
Auto Measure SA Geometry

In addtion to scanning a predefined region by laying points out on a 
grid using auto measure, the MS50 can quickly scan an a perimeter 
and generate a point cloud within SA. 

1. In the auto Measure Sa Geometry section of the instrument in-
terface, ensure that the Revert  button is not depressed. 
This button changes between scanning modes (Figure 28-

Note:  If connecting with a 
cable or wireless, enter the 

instrument’s IP address in the 
Server Address box. 
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123).

Figure 28-123. Auto mea-
sure SA Geometry section of 
MS50 Interface.

2. Click Settings to change the parameters of the scan. The den-
sity of the scan is defined by the vertical and horizontal angu-
lar increment set in decimal degrees. Once satisfied with the 
settings click OK (Figure 28-124).

Figure 28-124. Auto 
measure SA geometry profile 
parameters.

3. Change the auto Measure Sa Geometry to active by selecting 
the radio button. When you do so, a note will be shown at 
the bottom of the interface that states: “awaiting Sa perimeter 
Selection.” 

4. Click on the desired perimeter by clicking on double-clicking 
on it in the tree. When selected, the perimeter Collection::name 
will be displayed. 

5. To begin the scan, click Measure. An example of this type of 
perimeter scan is pictured in Figure 28-125.
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Figure 28-125. Perimeter 
scan using the Auto Measure 
SA Geometry measurement 
mode.

v

Importing Nova Scan Files into SA

If you choose to scan  while not connected to a computer, you may 
import these files into SA at a later time. The Nova Scans are saved as 
*.SDB files on the SD Card or the internal memory. To do so, follow 
these steps:

1. Add an instrument to your SA job file to which you wish to 
import the scan data. Data will be imported into SA relative to 
this instrument.

2. Either connect to the live instrument using a cable or connect 
using the simulation mode. 

3. Locate and move the *.SDB files to your local machine. If you 
are connected using the cable, you can use Windows Mobile 
Device Center to navigate to the SD card directly.

4. In Theodolite Manager, select your instrument and click Im-
port.

5. Select the *.SDB data type, navigate to your data, and click 
Import.

Performing a Point to Point Auto Measure Scan

1. In the Auto Measure SA Geometry section of the instrument in-
terface, ensure that the Revert  button is depressed. This 
button changed between scanning modes. 

2. Click the Settings button to change the parameters of the scan 
based on the line and point spacing in the Auto Scan Proper-
ties dialog (Figure 28-126).
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Figure 28-126. Auto Scan 
Properties dialog.

3. Change the Auto Measure SA Geometry to active by selecting 
the radio button. When you do so, a note will be shown at 
the bottom of the interface that states: “awaiting Sa perimeter 
Selection.” 

4. Click on the desired perimeter by clicking on double-clicking 
on it in the tree. When selected, the perimeter Collection::name 
will be displayed. 

5. To begin the scan, click Measure. An example of this type of 
perimeter scan is pictured in Figure 28-127.

Figure 28-127. A point to 
point auto measure scan. 
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Photogrammetry

Aicon Move Inspect

This quick-start guide can be used for initial configuration, connec-
tion and basic operation of the AICON Move Inspect Photogramme-
try system within SA. For more details on instrument operation and 
configuration, please contact AICON directly.

Hardware Setup
Set up the AICON MoveInspect system following the Manufacturer’s 
directions. This will depend on the camera configuration and system 
type. Ensure you have the appropriate camera mounts, tripods, and 
cabling to power the unit.

Communication with SA is done through TCP/IP Ethernet connection 
so an appropriate network connection is necessary.

Software Setup
SA does not interface with the cameras directly but rather with the 
host application AICON MoveInspect. Therefore, MoveInspect must 
be installed, calibrated, and running on the local machine prior to any 
attempt to connect to SA.

Please contact AICON directly to obtain the correct version of MoveIn-
spect for your camera system and install it following the manufactur-
er recommendations. 

http://aicon3d.com

You can verify SA’s current version compatibility by looking in the SA 
readme file available under the Help menu within SA.
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Creaform HandyProbe

Starting the Interface
1. Start the Creaform HPS application.

2. Once started, ensure that C-Track is connected and calibrated 
per OEM guidelines (Figure 28-128).

3. 

Figure 28-128. The HPS 
dialog.

 Select Instrument > Add and choose the Creaform Handy Probe 
from the Instrument List.

4. Run the Creaform HandyProbe interface from the start menu’s 
Interfaces menu.

5. The Creaform HandyProbe dialog box will open. Select your 
device, and the interface will start up (Figure 28-129).  

Figure 28-129. The 
HandyProbe interface.

Measuring with the Handy Probe

Button Functionality
 ■ Center Button. A single press measures a single point. Holding 

the button will stream multiple points.

 ■ Check Button (left). Increment the group name.

 ■ “X” Button (right). Delete last measured point.

Watch Window
Using watch windows with the Handy Probe is very easy.   Simply 
check the “Stream Watch Updates” option and open the watch win-
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dow of choice (Figure 28-130).

Figure 28-130. The 
HandyProbe in use with a 
watch window.
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GSI V-STARS

Starting the Interface
1. Select Instrument > Add and choose the GSI V-Stars Photogram-

metry System from the Instrument List (Figure 28-131).

2.  

Figure 28-131. Adding a V-
STARS camera system to SA.

Run GSI V-stars 4.7.A16 or later.

3. Start the instrument interface using Instrument > Run Interface 
Module and Connect or .  

Interface Overview

Figure 28-132. The V-STARS 
interface.

Data is sent to SA in 2 possible ways.   If VSTARS is in M-Mode, then 
selected data is sent any time VSTARS is triggered.  This can be done 
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with the ‘Trigger’ shown (Figure 28-132), or in VSTARS.  The Continuous 
Trigger option in VSTARS will result in the selected data type being 
sent to VSTARS upon each trigger event.  If VSTARS is in S-Mode, the 
Data >> SA button shown above results in an immediate project im-
port from VSTARS, and selected data is sent to SA.

Note the Inc checkbox (1).  This is the Auto-Increment Group (or Cloud) 
name option.  When checked, the group or cloud name will automati-
cally increment after each data send to SA.

Select Data to Send To SA (2). These work as follows:

 ■ Camera. If VSTARS is in M-Mode, the camera transforms are 
sent to SA, and all the M-Mode camera positions are shown in 
SA.

 ■ Probe. If VSTARS is in M-Mode, then the most recent PROBE 
point is sent to SA once a trigger event occurs. Generally, the 
‘Inc’ will be unchecked in this case. If VSTARS is in S-Mode, the 
project is imported immediately, and the most recent PROBE 
point is sent to SA.

 ■ Targets. If VSTARS is in M-Mode, then all selected point types 
(see 3 below) are sent to SA once a trigger event occurs. Gener-
ally, the Inc checkbox will be checked in this case. If VSTARS is in 
S-Mode, the project is imported immediately, and all selected 
points are sent to SA.

 ■ Cloud (ProSpot). If VSTARS is in M-Mode, then all selected 
point types (see 3 below) are sent to SA in the form of a point 
cloud once a trigger event occurs. Generally, the Inc checkbox 
will be checked in this case. Note that the cloud sent will carry 
then name shown in the ‘Group/Cloud’ edit box. If VSTARS is in 
S-Mode, the project is imported immediately, and all selected 
point types are sent to SA in the form of a cloud.

The Set Labels buttons (3) are used to set the VSTARS data types (la-
bels) which will be sent when measuring either ‘Targets’ or ‘Cloud 
(ProSpot)’.   The Targets data selection defaults to “CODE”, and the 
Cloud (ProSpot) data selection defaults to “_S”.  The selections denote 
strings.  When any of the selected strings are found in the VSTARS la-
bel of a point, that point will be sent to SA in the selected data form 
(‘Targets’ means points, and ‘Cloud (ProSpot)’ means a point cloud).

Figure 28-133 shows the Set Target Labels to Use dialog.  The dialog 
is the same for ‘Cloud (ProSpot)’.  All types are selected here for read-
ability (un-selected labels are subdued).
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Figure 28-133. c
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Metronor

Prerequisites
Metronor Server must be installed and running before SpatialAna-
lyzer will connect to the instrument.

Starting the Interface
1. Start Metronor Server (Figure 28-134).

2. Run Metronor Server and perform setup and field checks per 
OEM guidelines.

Figure 28-134. Metronor 
Server.

Figure 28-135. The startup 
process.
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3. 

Figure 28-136. Adding the 
Metronor to SA.

Select Instrument > Add and choose the Metronor Portable 
Measurement System from the Instrument List (Figure 28-
136).

4. Run the Metronor interface from the Start > Programs > SpatialA-
nalyzer 20##.##.## > Interfaces menu.

5. The Spatial Analyzer Metronor Logon dialog box will open 
and will ask what device you want to connect to (Figure 28-
137).  Select the instrument and type the server name (which 
will be either the computer name or the computer’s IP ad-
dress).  Accept the default Server Port.

6. 

Figure 28-137. The logon 
dialog.

This will start the Metronor Interface.
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Vicon Tracker

Prerequisites
Vicon Tracker must be installed and running before SpatialAnalyzer 
will connect to the instrument. SpatialAnalyzer and Vicon Tracker 
must be installed on the same computer.

Starting the Interface
1. Ensure Vicon Tracker is running and instrument is operating 

correctly per OEM guidelines.

2. Select Instrument > Add and choose the Vicon Tracker from the 
Instrument List.

3. Run the instrument interface using Instrument > Run Interface 
Module and Connect or

Instrument Interface Overview

Figure 28-138. The Vicon 
interface.

Press Set Objects to populate the drop down combo box with all ob-
jects currently in view of the cameras in Vicon Tracker. For this, you 
must be sure all defined objects are in the view of the cameras.  Here, 
an Object called ‘L-Frame’ is selected in the drop down.

Press Send Markers to send the sphere centers of all the Vicon markers 
in the selected object. This is for co-locating with other instruments 
in SA.

Press Edit Selected to add an offset frame/probe to the selected ob-
ject (Figure 28-139).
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Figure 28-139. Defining an 
offset.

Just follow the steps in the dialog to create an offset frame or probe 
for the selected object.

1. Create a frame in SA on the object (or e.g. a probe which you 
have rigidly attached to the object) by measuring with an in-
strument, or creating by some other means.

2. Click 1) Select Offset Frame From SA. You’ll be prompted to se-
lect the frame you have created, and the Name field will be 
populated with the name of the frame from SA.

3. Click 2) Measure Reference Frame to Offset to take a fresh 
6-DOF measurement of the object you’ve selected. You’ll see 
a suggested name appear.

4. In the 3) Enter name for this new Offset Object/Probe field, type in 
a name if you’d like to use your own name. 

5. In the 4) (Optional) field, enter the probe radius for the offset 
probe.

6. Press OK to add this new offset frame/probe definition to the 
drop down combo box.

When your new offset object is selected, the offset frame will be sent 
to SA whenever you have “6D” Data Type selected, or the origin of 
the offset frame will be sent if you have “3D” Data Type selected. The 
probe radius will be added to all data sent from your offset object 
definition.
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Scanners

Faro LS/Focus3D

Prerequisites
Before adding and running a Faro LS/Focus 3D Scanner in SA, the ap-
propriate drivers must first be installed.

Download the drivers from ftp://ftp.kinematics.com/pub/SA/In-
stall/Driver%20Downloads/Scanners/Faro%20LS%20Photon%20
Scanner/  or install from the Instrument Drivers combined installer 
at http://kinematics.com/products/spatialanalyzer/spatialanalyzer-
downloads.html

1. Unzip the dll’s into the current SA install folder.

2. Place the .bat files in the current SA install folder.

3. Run Unregister iQpen.bat

4. Run Register iQOpen.bat

Running the Faro Scanner
1. Add a Faro Scanner LS to SA via Instrument>Add or using the

icon (Figure 28-140). Select the Faro Scanner and press Add 
Instrument.

2. 

Figure 28-140. Adding a 
Faro scanner to the job.

Run the instrument interface module under Instrument>Run In-
terface Module and Connect.

3. The Faro Scanner LS Interface will now appear and be ready 
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for use (Figure 28-141).

Figure 28-141. The Faro 
scanner interface.
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Surphaser

Prerequisites
Before adding and running a Surphaser Scanner in SA, the appropri-
ate drivers must first be installed.

Download the operating system-specific Surphaser drivers from ftp://
ftp.kinematics.com/pub/SA/Install/Driver%20Downloads/Scanners/
Surphaser/.  

1. Unzip the drivers into a known location. Example: C:\
DrvWinUsb

2. Plug in the Surphaser USB cable to the PC. Windows should 
recognize the USB device and automatically locate the drivers 
and install them. If this is performed correctly, the Surphaser 
scanner will be presented in your Device list (Figure 28-142).

Figure 28-142. The Device 
list.

Running the Surphaser
1. Add a Surphaser to SA via Instrument>Add or using the icon. 

Select the Surphaser Scanner and press Add Instrument (Fig-
ure 28-143).
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2. 

Figure 28-143. Adding the 
Surphaser to SA.

Run the instrument interface module under Instrument>Run In-
terface Module and choose Surphaser. Select the parameter file 
provided for the respective instrument and a log file (Figure 
28-144).

3. 

Figure 28-144. The Surphas-
er Connection dialog.

The Surphaser Interface will now appear and be ready for use 
(Figure 28-145).
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Figure 28-145. The main 
Surphaser interface.



830

SPATIALANALYZER USER MANUAL

Leica ScanStation P20

This guide may be used for initial configuration, connection and basic 
operation of the Leica ScanStation P20 within SA. For more details 
on instrument operation and configuration, please contact Leica di-
rectly. 

Hardware Setup
Setup the unit following the manufacturer’s directions. The ScanSta-
tion requires an Ethernet connection to the machine running Spati-
alAnalyzer 2014.02.04 or later. Be sure the Leica device power is on 
and that the batteries are charged.

Software Setup
You must have a FW license to activate the api data access tog-
gle on the P20. You can toggle this on the scanner in Status>System 
Information>Options. The setting api data access must be activated (it is 
deactivated by default). Contact your Leica Geosystems representa-
tive for more information.

Starting the Interface
1. Select Instrument>Add and choose the Leica Geosystems 

ScanStation P20 from the Add Instrument to SA dialog (Figure 
28-146).

Figure 28-146. Adding the 
Leica ScanStation P20 to a job.

2. Now run the instrument interface module and connect using 
the running man icon .
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3. Select Run Scanner (Figure 28-147).

Figure 28-147. The run scan-
ner dialog. 

4. When the P20 Scanner Control dialog appears, select the in-
strument’s serial number and click Connect Scanner. The scan-
ner uses a DHCP connection so an IP address identification is 
not necessary. Then enter the project name, which specifies 
the directory to save the scan data and click Init Project (Figure 
28-148). 

Figure 28-148. P20 Scanner 
control dialog. 

Export Settings
The Export Settings tab (see Figure 28-149) in the P20 Scanner Control 
dialog defines the scan filter definitions and the scan transfer location 
on the local machine. The aSCii export path defines the location on 
the local machine where scan files will be transferred. 

The advanced settings are master controls for filter options not typi-
cally changed for scans unless needed for a particular application.
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 ■ remove intensity Overload pixels. This option is checked by de-
fault and removes any pixels that have an overload intensity 
such as pixels taken from a mirror or reflector. The location of 
the pixels are typically incorrect. 

 ■ remove Mixed pixels. This option is checked by default. It re-
moves pixels that have a mix of return intensities indicating 
that the target is not reliable, typically occurring on edges of 
surfaces. 

 ■ remove Low Quality pixels. This option is unchecked by default 
but allows you to receive pixels with a low quality return.

 ■ area Filter. This is considered Leica’s “Intelligent Area Filter”. 
It will smooth out the data based upon the relative position 
of adjacent points in the scan. The degree that this is done is 
based upon the slider setting. To turn it off, slide the Area Filter 
slider to Min.

Figure 28-149. Export Set-
tings tab. 

Scanner Control
The Scanner Control tab defines the scan and controls (start/stop/
pause/resume) (Figure 28-150).
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Figure 28-150. Scanner 
Control tab. 

 ■ Scan resolution. This setting defines the density of the cloud. 
You can chose from 7 preset scan resolution settings defined 
as the distance between adjacent scan points at the distance 
specified. This represents the angular spacing of individual 
points. The points will be closer together at a closer distance 
and wider at a great distance based on this angular setting. The 
default setting when connecting to SA is the lowest resolution.

 ■ Scan Quality. This setting defines accuracy for a particular point. 
Higher accuracy results in an increase in the overall measure-
ment time. See chart below (Figure 28-151):

Figure 28-151. Scan time 
and resolution chart.

 ■ h Center. Defines the horizontal angle clockwise about the 
scanner start location to the center of the scan.

 ■ h delta. Defines the horizontal angular width of the scan about 
H center.

 ■ V Center: Defines the Vertical angle about the scanner start lo-
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cation to center of the scan.

 ■ V delta. Defines the vertical angular width of the scan about V 
center.

Figure 28-152. Scanning 
orientation. 

Scanner Data
The Scanner Data tab provides a view of scan data on the instrument 
as well as transfer options (see Figure 28-153).

 ■ Refresh Tree. This button updates the tree list on the interface 
with the latest scan data available from the instrument.

 ■ Tree View. This section contains a static list of all the scans avail-
able from the instrument at the time the tree was last updated. 
To ensure you have the latest scan information, click Refresh 
Tree.

 ■ SA Cloud Data. This information is sent with the scan and used 
to define it in the SA job once the transfer is complete.

 ■ Right Panel. The right hand panel of this tab displays informa-



835

CHAPTER 28 ■ INSTRUMENT QUICK-STARTS

tion on the selected scan as well as a preview of that scan. The 
colors in the preview are based upon point return intensity.

Figure 28-153. Scanner data 
tab.
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Laser Projectors

LPT

Setup the projector following the manufacturer’s directions. The LPT 
functions as a separate computer with a separate IP address and must 
be connected through a network connection using an Ethernet cable. 
Ensure that the unit is powered on. 

1. Make sure the projector and the PC have compatible IP ad-
dresses. This can be done by attaching a monitor, keyboard, 
and mouse to the projector and verifying the Projector’s IP 
address.

2. Open Windows Explorer on the PC. In the Address field, type the 
computer name of the projector.  For example, \\LPT10587.

3. You will see a dialog box entitled Connect to LPT10587 (for 
example).   Enter your username and password. The default 
username and password are both Admin.

4. Once you are logged onto the projector, Windows Explorer 
will show the hard drives on the projector.

5. Run RayTracer Operator on the PC.   (RayTracer Operator can be 
run on the projector but it is recommended to run it on the 
PC.)

6. On the RayTracer Operator Login screen, type Admin for the 
User ID, and Admin for the password.

7. You should have a database set up on the PC already, but if 
not, contact LPT for assistance. (To get started, you can run 
RayTracer Administrator to create a new database or to incor-
porate tools and parts created ‘offline’ (see “Using SA to Create 
Offline Tools and Parts” on page 838). Or, just copy a data-
base from the projector to the PC, and use RayTracer Adminis-
trator to set it active.)

8. Be sure the database you wish to use is indicated in the Ray-
Tracer Operator login, and press OK.

9. Once Operator is running, check the ‘Laser Name’ list in the 
application’s main window. Ensure that the projector you are 
connecting to is in the list, and that it is checked. If not, you 
must check it and ‘take ownership’ of the projector. Other-
wise, commands will appear to succeed, but none will be car-
ried out.

Running the Projector
1. Select Instrument>Add... and choose the LPT Laser Projector 
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from the Instrument List (Figure 28-154).

2. 

Figure 28-154. Adding an 
LPT to the SA job.

Select Instrument>Run Interface Module. Select LPT Laser Projector 
from the list.

3. In this dialog (Figure 28-155) two options appear: you can con-
nect to a computer running RayTracer Operator or work Offline. 
Be sure to select Connect to Operator, and indicate the name of 
the computer running Operator. (The ‘This Computer’ button 
will fill in your pc’s name in case you are running Operator on 
the PC as recommended.)

4. 

Figure 28-155. The Connect 
to SpatialAnalyzer dialog.

The progress report at the bottom of the interface window 



838

SPATIALANALYZER USER MANUAL

will indicate actions as they take place.

Using SA to Create Offline Tools and Parts
1. Run SA and add an LPT projector. Then run the LPT Laser Pro-

jector Interface, and select Work Offline in the interface’s Con-
nect to SA dialog (see “Running the Projector” on page 836).

2. The interface will then run in OFFLine Mode. You will select the 
path for the ‘Offline Tool’ and ‘Offline Part’ xml files in the in-
terface. You can create as many tools and parts as you wish. It 
is highly recommended that tool and part ‘sets’ be created. In 
other words, for any set of parts, create a corresponding tool 
which represents the projector’s location while projecting 
those parts. These tool and part sets can be organized in fold-
ers.

To Create a tool

 ■ Set the path and file name for the tool in the ‘Offline Tool’ area 
of the interface. In SA, select Instrument>Laser Projector>Alignment. 
You’ll be prompted to select the instrument (projector) and the 
Group (set of alignment points). The points will be written to 
the file indicated by the path in   the ‘Offline Tool’ area of the 
interface.

To Create a Part

1. Set the path and file name for the part in the ‘Add to Offline 
Part’ area of the interface. If you are creating a part from any-
thing other than points, be sure to set the Ply Filter in the in-
terface (see section below for use of the Ply Filter). In SA, se-
lect Instrument>Laser Projector>Project Objects. You’ll be prompted 
to select the instrument (projector), and the Objects to proj-
ect (geometric entities, points, etc.). You will be prompted 
for a Ply Name for the object in the Part file. The objects will 
be written to the ply in the file indicated by the path in  the 
‘Add to Offline Part’ area of the interface, and codes to ensure 
uniqueness in the part file will be added to the ply name. You 
can continue to add objects (plies) to the same part file, and/
or create new part files as desired.

2. Once desired set(s) of tools and parts have been created, use 
RayTracer Administrator to add these sets to a projector data-
base.

3. During the creation of tools, you may wish to start up the pro-
jector (described below) and ensure the validity of the tool by 
actually aligning the projector to the tool. Then the parts cor-
responding to that tool location can be projected to ensure 
their validity. All this is described below.
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Projecting within SA

Alignment
There are several possible ways to perform this action:

1. If you have been working with a projector in SA, and you are 
continuing work on a file, the projector’s location/orientation 
will be persisted by SA and the interface. If this is the case, hit 
the ‘Auto Align’ button in the ‘Align’ section of the interface. 
Operator will pop to the forefront, and an Auto-alignment 
will take place. Operator’s view area will go green upon a suc-
cessful alignment. NOTE: For the following methods, be sure 
to use the ‘Toggle FOV’ (field of view), and ‘Toggle +’ (center 
cross) buttons in the interface to aid in the initial location of 
the projector.

2. If you are starting a new job, you can create alignment points 
(a tool) in SA, and align the projector to that tool. In the in-
terface, be sure that ‘Add to Projector Part’ is selected in the 
‘Projections from SA’ area (in ‘Online’ mode, if ‘Add to Offline 
Part’ is selected, Tools will be created in the last used offline 
tool.) Create a group of points in SA which you wish to use as 
the alignment tool. In the SA Instrument menu, select Laser 
Projector >> Alignment. You’ll be prompted to select the in-
strument (projector), and the Group (set of alignment points). 
Once the group is selected, you will be prompted for the Tool 
Name. A tool by this name, containing the points from the 
selected Group, will be added to Operator’s database. You will 
see the tool name and point appear in Operator if it is vis-
ible. Finally, the interface will instruct you to manually align 
the projector in Operator.... just maximize operator, and hit 
the ‘Manual Alignment’ button. Guide the projector to each 
indicated point, and left click when near the point. After 4 
such points are Accepted, Operator will take over and finish 
the alignment. (If the alignment fails, Operator will give you 
an oportunity to override the alignment and continue, but 
you should check for the source of the failure - it is generally 
an rms error exceeded in the alignment calculation.) Once 
you have performed this manual alignment procedure, you 
should be able to Auto-align (as described above) so long as 
the projector is not moved, and the Tool in Operator is not 
changed.

3. If you have previously created Tools offline (as described 
above), you can use LPT RayTracer Administrator to add the 
tool(s) to your database, and they can then be used by select-
ing them from the ‘Tool:’ list in Operator. As always, a one time 
manual alignment will have to be performed in Operator, and 
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then Auto-align from the interface can be used until the pro-
jector is moved, or the Tool is changed.

Projecting
1. For projecting within the current Part, simply use the ‘Next’, 

‘Current’, and ‘Previous’ buttons in the interface to toggle 
through plies. The ‘Pause’ and ‘Resume’ buttons also apply to 
the current Part.

2. Use LPT RayTracer Administrator to add any offline parts you 
have created (as described above) to the current database.

3. To add a part to the current database, and project it imme-
diately:  Be sure the projector has a valid alignment (Opera-
tor’s view screen is green.)  Be sure ‘Add to Projector Part’ is 
selected in the interface.   Edit the name of the part if de-
sired.  (As with offline parts, you are free to continue to add 
projection objects (plies) to the part as many times as you 
wish.)   If you are creating a part from anything other than 
points, be sure to set the Ply Filter in the interface (see sec-
tion below for use of the Ply Filter).   In SA, go to the ‘Instru-
ment’ menu, and select Laser Projector>Project Objects.  You’ll be 
prompted to select the instrument (projector), and the Ob-
jects to project (geometric entities, points, etc.).     If this is a 
new part, the part will be added to the current Database.  The 
selected projection object(s) (i.e. the ply) will be added to the 
part and projected immediately.  The ply name in the part will 
be “CommandedProjection_X”, where X is a code to ensure 
uniqueness.

Using the Ply Filter
In the interface’s ‘Projections from SA’ area is a ‘Ply Filter’ button. The 
button shows information about the current active filter option.

Filter Options Are:

 ■ None. Just project everything as is

 ■ Minimum Angle. Starting with the first point, look at all con-
secutive sets of 3 points in the ply, e.g. 1, 2, and 3.  Make vec-
tors 1to2 and 2to3.  If the angle between 1to2 and 2to3 is less 
than the selected minimum angle, point 2 is eliminated, and 
the evaluation continues.

 ■ Number of Points. Numerically spaced points are eliminated 
until the desired maximum number of points is reached.

 ■ Minimum Distance. Starting with the first point, look at all 
consecutive sets of 2 points in the ply, e.g. 1 and 2.  If the dis-
tance between 1 and 2 is less than the selected minimum dis-
tance, point 2 is eliminated, and the evaluation continues.
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The ply filter is applied to any entity which comprises a continuous 
projection along some curve.  (Anything except points.)

The current active filter (indicated on the filter button) is applied to 
all plies coming into the interface, whether they are to be projected 
immediately, added to the current database part, or added to an of-
fline part. 
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Assembly Guidance Laser Projector

Hardware Setup
Setup the unit following the manufacturer’s directions with an unre-
stricted view of the work area.

Software Setup
You can download and install the latest drivers from http://www.kine-
matics.com/ftp/SA/Install/Driver%20Downloads/Projectors/Assem-
blyGuidance%20LaserProjector/ . You will need the following files:

 ■ LASERGUIDESDK_3_03_13.exe or later

 ■ Register LaserGuide dll.bat
 ■ Unregister LaserGuide dll.bat

Installation

1. Run the file LASERGUIDESDK_3_03_13.exe or later on your 
machine. This will walk you through the installation process 
of the LaserGuideSDK used by SA to communicate with the 
device.

2. An install directory will be created under C:\Program Files 
(x86)\AGS\LaserGuideSDK as well as a shortcut link on the 
desktop to the test application for the AG projector.

3. Restart your computer.

4. Move the Register LaserGuide dll.bat into the SA install 
folder typically located here: C:\Program Files (x86)\New River 
Kinematics\SpatialAnalyzer 2013.12.10.

5. Double click “register LaserGuide dll” to run the file from this 
directory. If you have previously registered from a different di-
rectory you will need to run the Unregister LaserGuilde 
dll.bat utility first.

Figure 28-156. Windows 
registration.

Network Configuration
Be sure to create a fixed IP address on your computer that will be 
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compatible with the IP address of your projector(s). The default ad-
dress should be stamped on the front of your projector. For example, 
if your projector’s IP address is 10.1.1.1, then you need to change your 
computer’s IP address to 10.1.1.X; where X is between 1 and 255. 

Starting the Interface
1. Select Instrument>Add and choose the Assembly Guidance La-

ser Projector. 

Figure 28-157. Adding an 
Assembly Guidance Projector 
to SA.

2. Now  run the instrument interface module under Instrument>Run 
Interface Module and Connect.

3. Enter the projector’s IP address and click the Connect  
button on the AG LaserGuide (see Figure 28-158) dialog. For 
more detailed connection information, you click on the Show 
Projector Window (see Figure 28-158) button to bring up the 
Assembly Guidance Contol Utilities. 
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Figure 28-158. AG Laser-
Guide dialog. 

Figure 28-159. Projector 
window.

Aligning the Projector
There are two methods of aligning the projector in SA.: automatic and 
manual. To perform an auto alignment, use the browse button in the 
AG LaserGuide dialog (see Figure 28-158) to find a preexisting regis-
tration file to use. Click the Auto Align button, and the projector will 
auto measure the alignment points and the transformation from the 
measured points to the current point locations will be used to align 
the projector within SA. 

To Perform a Manual Alignment

1. Measure six reflector positions with a separate instrument 
within the field of view of the projector. Located in the Aim 
section of the instrument interface is the Toggle FOV and + 
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button. This can be used to display the projector region and 
also to import a set of known location points. 

2. Select Instrument>Laser Projector>Alignment.

3. Select the instrument to align and then the measured point 
group for alignment.

4. Browse to a location to save a Registration data file in .txt for-
mat.

5. Use the manual alignment utility pictured in (Figure 28-160) 
to point the laser at each registration point in order by name. 
To do so, click and hold while dragging the mouse. This drives 
the laser pointer relative to the cross hairs in the dialog and, 
in turn, drives the projector beam to the reflector point. Once 
aimed correctly, right-click to scan the target.

Figure 28-160. Steer Beam 
for Target dialog.

6. After each of the individual target locations have been identi-
fied in this fashion, these points will automatically measured 
and the alignment will be performed. 

Point and Object Projection
The Assembly Guidance Interface provides the tools to project points 
as well as objects in SA. To project an object it must be added to a 
part file. These part files are then used to build the laser path defini-
tion for the projector. A single part may contain several patterns and 
additional patterns can be added to an existing part file. 
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Projecting Part Files

1. In order to project patterns from a previously created part file, 
simply browse to the file using the Pattern (Part) File button  

 in the interface.

2. Click Current to project the part shown in the selection path. 
You can utilize the Pause and Resume buttons to control pro-
jection of the current part file and the patterns it contains. 

3. Select Next and Previous to toggle through part files in the 
same folder as the current part shown in the Part File Edit box.

Building/Editing Part Files and Projecting Objects

1. In the From SA section of the interface , select Add to Part or 
Make New Part.

2. Select Instrument>Laser Projector>Project Objects. You will then be 
prompted to select the instrument (if you have more than one 
in the job). 

3. Now select the objects you wish to project. Doing so will cre-
ate a file using the name of the first object selected for projec-
tion if you have Make New Part selected. If you chose Add to 
Part, it will add the selected objects to the current part file.

Tip:  Objects cannot be re-
moved from a part file 

through SA.
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Working With Frames
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will explore working with dif-
ferent coordinate frames, and see how the working coordinate 
frame affects the values reported in SpatialAnalyzer.

 ■ Areas Covered. Creating points and geometry, geometry 
fitting, frame construction/activation, transformations, and 
point/object queries.

 ■ Time to Complete. Approximately 30 minutes.

Creating Entities to Work With

For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

1. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2. Let’s create a few points to work with in the workspace. To do 
this, go to Construct>Point(s)>Enter or press Ctrl+P.

3. In the Add Points to Model dialog (Figure 29-1), let’s place 

The following tutorials are designed to guide you 
through various topics in SA and get you up and run-
ning as quickly as possible. After completing a tutorial, 
you should feel more comfortable with using the cov-
ered areas of the software in real-world use.

Tutorials
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the points into a collection called nominal and a point group 
called nominalpoints. We’ll give the first point a name of 1. 
Give the point an X coordinate of 15, a Y coordinate of 10, 
and a Z coordinate of 7.  We’re entering these coordinates as 
Cartesian (XYZ) coordinates, so we’ll leave that setting at the 
default:  

Figure 29-1. Adding a point.

4. Click the Add Point button, then click Done. In the graphical 
view, you should see a point created at the specified coordi-
nate. If you don’t see it, autoscale the view by clicking the Au-
toscale button , pressing Alt+A, or choosing View> Zoom> 
Autoscale.

5. In the tree view, you should see that the nominal collection 
now exists. Since it did not exist when you created the point, 
SA created this collection for you.

6. In the tree, (if necessary) click the disclosure triangle next to 
nominal to expand the list of items in the Nominal collection. 
Note that there is an item in the list named point Groups. SA 
sorts items in the tree based on their category. Expand the 
point Groups category, and you’ll see that SA created the nom-
inalpoints point group, because it did not already exist.

7. Expand the nominalpoints point group to show all points con-
tained within the point group, then click the triangle next to 
the single point to show the coordinate of the point named 
1. You should see the coordinates that you just entered (Fig-
ure 29-2).

Figure 29-2. The newly-
added point.

8. The default collection in your SA file is currently ac-

Note:  Depending on how 
your copy of SA is set up, 

your active collection may not be 
named A.
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tive, because it is depicted in bold blue font in the tree. 
Let’s activate our new nominal collection. Right-click on the 
nominal text in the tree and, from the context menu, choose 
Make Active Default Collection. Now, any geometry that you create 
will be placed into the active nominal collection.

9. Now let’s create another point. SA saves a history of the 
most recently used commands so that you don’t have to 
select them from the menu again if you’re repeating a sin-
gle command several times. To use this history, hold down 
Ctrl+Shift+Tab. In the upper-left corner of the graphical 
view, a menu should appear showing your recent commands 
since you started SA, with the most recent command at the 
top (Figure 29-3).

Figure 29-3. The list of 
recent commands.

10. Choose the Construct>Point(s)>Enter item from the list. Notice 
that SA remembers the last collection and point group that 
was used for this command. Enter 2 for the point name, and 
give it a coordinate of (20, 20, 20). Click the Add Point button.

11. After clicking the button, notice that SA automatically incre-
ments the point name by one. This behavior is found com-
monly in different parts of SA, and is intended to save time 
from typing, since incrementing names by one is so com-
mon. Change the coordinates to (5,5,5) and click the Add Point 
button again to create the third point, then click the Done 
button to close the dialog.

12. Now let’s create a plane to work with. From the menu, select 
Construct>Plane(s)>Enter. The Plane dialog will appear (see Fig-
ure 29-4 on page 850), allowing you to specify properties for 
the newly created plane.

13. Leave the plane’s name at the default of Plane, and click the 
Transform button. Locate the plane at (35, 0, 0) and assign it an 
Rx value of 90°. Click the Update button.

14. If necessary, autoscale or zoom out so you can see the newly-
created plane relative to the points.

15. With the plane in view, set the Rx value back to 0°, and change 

Note:  The Autoscale key-
board shortcut of Alt+A will 

only work if the graphical view 
has the focus, by clicking once on 
it.
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Ry to 90°. Again, hit the Update button to see the plane change 
orientation. Now, click the increment arrows next to the Ry 
field and notice how the plane is rotating around the active 
coordinate frame’s Y axis. We’ll set the Ry value to 160°. Click 
the Update button, then click the “X” in the corner of the Plane 
Position dialog to close the window.

Figure 29-4. The Plane Posi-
tion dialog.

16. In SA (as in mathematics), planes extend infinitely in two di-
mensions. So, the boundaries that are depicted in the graphi-
cal view are purely to give you an idea of the location and 
orientation of the plane--the actual plane is not bounded. No-
tice also that planes have an arrow drawn along their normal 
to indicate the direction of the plane. All geometry and sur-
faces have normal directions, which define the positive side of 
the geometry. All measurements with offsets in SA are always 
compensated relative to this positive side:  

Figure 29-5. The positive 
side of a plane is indicated 
with an arrow.

17. The plane’s normal direction can be reversed to face the op-
posite direction. In the Plane dialog, click the Reverse button.  

Figure 29-6. Selecting the 
option to draw a plane’s nor-
mal vector.

 

Notice how the arrow flips to face the opposite direction. Turn 
off the plane’s arrow so that it’s no longer drawn in the graph-
ical view by deselecting the Draw checkbox in the Plane dialog 
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(Figure 29-6). Close the dialog by clicking the Close button or 
the “X” in the corner of the window.

18. Finally, let’s create a circle to work with. This time, rather than 
creating a circle and specifying its position and orientation, 
let’s fit a circle to the three points that we created earlier. 
Orient your view so that you can see all three points. From 
the menus, choose Construct>Circle(s)>Fit to Points or press 
Ctrl+Alt+C. You will be prompted for the points that will 
define the circle fit. Hold down the Shift key, and click-drag 
to define a rectangle around the three points. In the bottom-
left corner of the SA window, you should see a message say-
ing “Picked 3 Points”. If you look in the treebar, the selected 
points will highlight bold and blue,  and they will change to 
a highlight color in the graphical view. Press Enter to accept 
the selection.

19. You will be presented with the Circle Fit dialog (Figure 29-7), 
which allows you to define the parameters and results of the 
fit operation. Above the box with the red background, you’ll 
see your points (1-3) listed in a box, along with the resulting 
error of those points from the resulting circle. Since three 
points perfectly define a circle, our resulting circle will end up 
passing through all three points exactly. Notice that the Planar 
and Radial errors are zero, and the error magnitudes are also 
zero:

Figure 29-7. The Circle Fit 
dialog.

20. In the bottom-left corner of the Circle Fit dialog, ensure that 
only the Make Cardinal Points and Make Geometry options are se-
lected, then click the OK button. SA will ask you for the name 
of the group in which you’d like to place the cardinal points. 
Enter nominalpoints and click OK.

21. The Circle dialog will appear. Give the circle a name of My-
Circle. Notice the Draw checkbox again. Select it to see that 
circles have a normal direction as well, and notice that two 
points have been created from our circle fit: one on the circle’s 
center, and another along the normal of the circle. These are 
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the Cardinal Points. Turn the Draw checkbox back off, and click 
the Close button.

In the next section, we’ll create some coordinate frames using a few 
different methods.

Creating Frames

Coordinate frames are crucial to many functions in SpatialAnalyzer 
and metrology in general. They define the locations and directions 
that are important to you or the features that you’re measuring. SA 
has a number of powerful ways to create coordinate frames to meet 
all of the needs you might encounter on a day-to-day basis.

1. In the graphical view, note that the World frame is currently 
the working frame. The working frame is rendered with col-
ored arrows representing each of the axis directions: red for X, 
green for Y, and blue for Z. In the tree, you will also notice that 
the working coordinate frame is rendered in a bold blue font.

2. Let’s create a new coordinate system, offset it from the cur-
rent World frame, and change its orientation. From the menu, 
choose Construct>Frame>Enter. Give the frame the name Offset 
Frame. This command creates a new coordinate frame with 
the same position and orientation as the working coordinate 
frame. We want to move our new frame. Click the Transform 
button to bring up the Frame Position dialog (Figure 29-8). 
Offset the frame by 10 units in X, Y, and Z, and also rotate the 
frame by +45° about the Z axis. Click the Update button to see 
the new frame move to the new position:

Figure 29-8. Creating a new 
frame.

3. Close the Frame Position and Frame dialogs, and verify for 
yourself visually that the new frame’s origin is located at (10, 
10, 10) in the active (World) frame’s coordinate system. Verify 
also that your constructed frame is rotated 45° about the ac-
tive coordinate frame’s Z-axis. Notice that SA uses the right-
hand rule. If the thumb of your right hand is pointed along 
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the axis of rotation, then curling your thumbs from one of the 
remaining axes to the other will define the sense of positive 
rotation. Our newly-created frame is drawn as a set of 3 or-
thogonal lines. The thicker colored arrows are only drawn on 
the coordinate frame that is currently active.

4. Let’s activate our newly-created coordinate frame. Click on 
the A::World button in the WCF Toolbar (your button may look 
slightly different depending on the name of your default col-
lection):  

Figure 29-9. The WCF 
Toolbar.

5. From the Object Selection dialog, double-click the Offset 
Frame frame. The button’s title will immediately change to re-
flect the new working frame, and the new frame will be ren-
dered as active.

6. Now let’s construct a frame on our circle. Objects can have 
frames constructed on them. The specific behavior is depen-
dent on the type of object, but for a circle, the frame will be built 
with its origin on the center of the circle and its Z-axis along 
the circle’s normal. From the menu, select Construct>Frame>On 
an Object. When prompted for the object, double-click the My-
Circle circle. Name our new frame Frame On Circle and close 
the Frame dialog.

7. Finally,  let’s create a coordinate frame whose origin is at one 
of our circle points, whose X-axis points directly to the second, 
and whose Z axis clocks along the point defining the circle’s 
normal. From the menu, choose Construct>Frame>3 Points>Origin, 
X axis>Point on XZ Plane. For the origin point, double-click the 
point in the tree named nominal::nominalpoints::1. Note that 
SA uses a convention to denote the “complete location” of an 
entity. For objects, it includes the collection, followed by two 
colons, then the object name. For points, it includes the col-
lection, followedby two colons, followed by the group name, 
followed by two more colons, and finally followed by the 
point name.

8. Let’s pick the Point along X axis by clicking on it visually in the 
graphical view. We want to pick the nominal::nominalpoints::2 
point, but how do we know which is which? From the menu, 
choose View>Show Point Labels (or press Alt+L). This will toggle 
on and off the display of labels for the points. Ensure that the 
Point along X axis prompt is still displayed, and in the graphi-
cal view, double-click the point labeled 2.

9. When prompted for the Point along XZ plane, double-click 
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the point on normal point. In the Frame dialog, give the frame 
a name of Clocked Frame and close the dialog.

Activating Frames

When analysis values are reported by SpatialAnalyzer, they are almost 
always reported in the working coordinate frame, unless otherwise 
specified. For example, when you query two points to determine the 
distance between them, you will be presented with the magnitude of 
the distance (in the current units), which will remain the same regard-
less of the working frame. However, you’ll also get delta values along 
each active frame axis (dX, dY, dZ). In some cases, you can explicitly 
specify the frame to report results in, regardless of which frame is cur-
rently active.

1. With the Offset Frame frame still active, right-click on the 
nominalpoints point group and choose Expand All Entries from 
the context menu. You should now be able to view the X/Y/Z 
coordinates for all of the point group’s points (Figure 29-10).

Figure 29-10. Viewing the 
point coordinates.

2. In the tree, right-click on Clocked Frame and choose Make Work-
ing Frame from the context menu. Notice that the point coor-
dinates change immediately to reflect the new coordinate 
frame’s position and orientation.

3. Let’s look at the point coordinates further. Point 1 is located at 
(0, 0, 0) because we used it to define the origin of our working 
frame. Point 2 has Y and Z coordinates of 0 because the X axis 
points directly to it. Finally, the point On normal point has a 
Y coordinate of zero, since we defined the frame so that the 
point lies in the frame’s XZ plane.

4. Next, activate the Frame on Circle frame. The Center point is at 
the origin, and the point on normal point is along the Z axis. 
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In the tree, right-click on MyCircle and choose properties from 
the menu. In the Circle dialog, click the Transform button. 
Notice that the circle has position and orientation values of 
zero, since the active frame was created on the circle. (In other 
words, the frame was created at the circle’s internal object ori-
gin). Close both dialogs.

5. Now we’ll measure a few distances. From the menu, choose 
Query>Point to>Point (or press Ctrl+D). When prompted, dou-
ble-click the Center point for the 1st point and point on nor-
mal for the second. In the Query Results dialog, the two points 
have dX and dY values of zero (since they both lie along the Z 
axis of the active frame). If you were paying close attention (or 
have a photographic memory), you’ll notice that the distance 
between the two points is the same as the circle radius.

6. This time, activate the Offset Frame frame and follow the in-
structions in the previous step to compare the two points 
again. This time, notice that the two points have nonzero dX, 
dY, and dZ values, since they do not lie along the direction of 
any of the active frame’s axes.

7. Let’s determine the distance of one of our points from our 
plane. From the menu, choose Query>Point to>Object. Double-
click point on normal for the point, and plane as the plane. 
The Query Results dialog will display the distance of the point 
from the plane along the active frame’s X, Y, and Z axes.

Conclusion

In this tutorial, we saw ways to create different geometric entities 
such as points, circles, and planes. We also explored a few methods 
of frame construction, and saw how results reported from commands 
can be influenced by the working coordinate frame.
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Construct and Modify Objects
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to construct 
and modify objects.

 ■ Areas Covered. Construct simple geometry, move an object, 
change object color and rename.

 ■ Time to Complete. Approximately 10 minutes.

Creating and Modifying a Sphere

In this tutorial we want to become familiar with the basic object op-
erations in SpatialAnalyzer.

1. Let’s construct a sphere by using Construct>Spheres>Enter. The 
Sphere properties dialog will appear (Figure 29-11). Change 
the name to MySphere, then close the dialog.

Figure 29-11. Constructing 
a sphere.

2. The newly-created sphere will display in the graphical view 
and the tree (Figure 29-12).
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Figure 29-12. The newly-
constructed sphere.

3. Now let’s change the shading from wireframe to solid. Go to 
the toolbar and click the solid render icon . The sphere will 
now appear shaded.

4. Change the color of the sphere to green. Double-click My-
Sphere in the tree. The sphere properties box will appear. Se-
lect the color button and choose a green color from the color 
palette, then press OK.

Figure 29-13. Moving the 
sphere.

5. Let’s move the sphere to 30 inches in X and 50 inches in Y. 
Right-click MySphere and select Move. Enter in the values for X 
and Y and press Update (Figure 29-13).

6. Now copy the sphere and move it to 50 inches in Z. Right-click 
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MySphere and select Copy. Enter 50 for the Z position.

7. Now rename the sphere to MySecondSphere. Right-click My-
Sphere1 and select Properties. Change the name to MySecond-
Sphere in the name field (Figure 29-14).

8. Now change the color to blue. This time change the active 
color to blue using the color icon . Once blue is selected 
use the color objects icon and single-click the sphere in the 
graphical view.

Figure 29-14. Setting the 
name of the sphere.

Conclusion

After completing this tutorial you should feel comfortable with cre-
ating, moving, and editing objects. Remember that most properties 
can be accessed by right-clicking an object in the tree or the graphi-
cal view.



859

CHAPTER 29 ■ TUTORIALS

View Control
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover basic view control 
functions.

 ■ Areas Covered. Hiding and Showing of objects, background 
color, panning, zooming and rotating.

 ■ Time to Complete. Approximately 15 minutes.

Changing Render Settings

Here we will change the render mode for the SA graphics from wire-
frame to solid.

1. Open Query Points to Surface.xit from the Samples 
directory under Help>Open Sample SA Files. When a file is opened, 
surfaces are by default rendered in wireframe mode in order 
to open the file as quickly as possible.

2. The Render settings can be changed with the render mode 
icons . Try each of the Render settings. Now render 
the model solid by using the Solid icon  (Figure 29-15).  

Figure 29-15. Rendering in 
solid-shaded mode.

Change Background Color

Let’s change the background color from a gradient to a solid color.

3. Access the background color options by using the Back-
ground button on the main toolbar.

4. In the Background dialog (Figure 29-16), select the Solid color 
radio button. Now select a solid color by clicking the current 
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solid color swatch. The color palette will display--choose a 
green color and press OK. Exit the background color dialog by 
pressing OK. After your eyes adjust...go back and change the 
background color to white by using the shortcut for white.

Figure 29-16. Changing the 
background color.

Hide and Show

Let’s experiment with the ways to hide and show points, objects, and 
other SA entities.

1. Hide the vector group called Boat error_Vectors_Blotches. Ex-
pand the Vector Group category in the tree. Now right-click 
Boat error_Vectors_Blotches and uncheck Show. The object 
name will be greyed out in the tree (Figure 29-17). To show a 
hidden item, simply select Show again.  
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Figure 29-17. Hiding the 
vector group in the tree.

2. Now let’s hide a few of the points. Choose View>Hide Points 
from the menu. Single-click a few points in the graphical view 
and press Enter. Now hide a single point in the Surface point 
group. Expand the Surface point group, right-click on a point 
and uncheck Show. Just like the above step for hiding the Vec-
tor Group, the point will be greyed out and the check box 
beside Show will be removed. Now hide all of the points by 
right-clicking the Point Groups category in the tree and select-
ing Hide All. Now all of the point groups in the collection are 
hidden (Figure 29-18).

Figure 29-18. Hiding the 
entire point group.

3. Now let’s hide the CAD model surface by using the menu item 
View>Object Visibility>Hide Objects. Select the surface by pressing 
F2 and checking the surface category. Press OK to exit the F2 
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selection dialog and press Enter to complete the command.

4. Hide the remaining items in the hydro collection by right-
clicking hydro and selecting Hide All.

5. Now to show an object you can simply reverse any of the 
above steps. Let’s show everything by right-clicking hydro 
and selecting Show All.

Zoom, Pan and Rotate

Now that we can change colors, render, and hide/show objects, let’s 
learn how to manipulate the graphical view. See the Graphical View 
section for more information regarding Zoom, Pan and Rotate.

Zoom
1. Zoom in on the graphical view by rolling the scroll wheel for-

ward on your mouse.

2. Zoom out by using the Page Down key.

3. Zoom back in by holding down Ctrl and left-click dragging 
the mouse.

4. Zoom back out by using menu item View>Zoom>Out.

5. Now let’s put all visible objects back in the view by using Au-
toscale .

Pan
1. Use the arrow keys on the keyboard to pan the view up, down, 

left and right.

2. Now pan the view by holding down the Shift key while 
pressing the left mouse button and dragging the mouse.

Rotating
1. Now let’s rotate the graphical view. Press and hold the right 

mouse button and drag the mouse. You will quickly notice 
that the view pivots about a particular point in space.

2. Let’s change the rotation center by selecting the View Rota-
tion Center button from the toolbar. Select one of the 
points at the corner of the model. Now rotate and you will see 
how the view pivots about the selected point.

Preset Views
Preset views are available which allow for quick orientation of the 
graphical view.

1. Press the drop down beside the icon and select Top. This 
will orient the view with respect to the World frame. 
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2. Saved presets can also be used. Now select the vector view 
preset view from the list.

Conclusion

We have now covered many ways to render objects, change back-
ground colors, show/hide objects and manipulate the graphics.
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Basic Point Analysis
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to perform ba-
sic point analysis.

 ■ Areas Covered. Query Point to Point, Query Point to Object 
and Query Points to Objects.

 ■ Time to Complete. Approximately 20 minutes.

Creating Entities to Work With

For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

1. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2. Create a set of random points by using Ctrl+Alt+Z or Constru
ct>Point(s)>Layout>Random Points. Use the default settings.

3. Now create a plane by using Construct>Plane(s)>Enter and ac-
cept the default settings.

Calculating Point to Point Distance

Calculating the distance between two points is a very common analy-
sis operation and provides a good starting point for learning basic 
analysis in SA.

1. Using the points we created above, let’s determine the dis-
tance between two points. Use Query>Point to>Point or Ctrl+D 
and select two points by single-clicking in the graphical view.

2. The distance between the two points will be reported in the 
Query Results dialog (Figure 29-19). The delta values for each 
component are expressed in the active coordinate frame. The 
point to point distance is calculated from the centers of the 
selected points. Any target offset, if present, will be ignored.

Figure 29-19. The query 
results dialog.
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3. A record of the point to point query is stored in the SA tree 
in the form of an Event. This event can be viewed using the 
report bar or an SA report (Figure 29-20).

Figure 29-20. The query as 
an SA Event.

Calculating Point to Object Distance

Another common analysis operation is calculating the distance be-
tween a point and an object, which is reported as the closest distance 
between that point and the object. Let’s calculate the distance be-
tween one of the random points and the plane we created earlier.

1. Select Query>Point to>Object from the menu. Select one of the 
random points and then the plane. The resulting distance be-
tween the point and the plane is displayed (Figure 29-21). No-
tice that the dx and dy values are zero. Since we’re comparing 
a point to a plane, and the plane’s normal is along the Z axis, 
there is no delta-x or delta-y component. (Said another way, 
the closest point on the plane to the selected point is directly 
below that selected point).  

Figure 29-21. Querying a 
point to an object.
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2. Like the Point to Point query, the results are stored in the tree 
as an event (Figure 29-22).

Figure 29-22. The Point to 
Object query as an event.

Calculating Multiple Points to Object Distances

During analysis operations it is often desireable to calculate the dis-
tance between multiple points and objects. To do this, a Points to Ob-
jects query can be performed. The output of this query is a vector 
group which gives a numerical and graphical representation of the 
point to object deviations.

1. Go to Query>Points to>Objects and select all of the random 
points. Then, select the plane when prompted for the ob-
jects. The Query Point to Surface Options dialog will appear 
(Figure 29-23). Here you can choose which direction the Vec-
tor should point and access general options. By default the 
vector (whisker) will point from the object to the point. Let’s 
also create a point group with points that are offset toward 
the object by the target radius. (Think of these as the “contact 
points”, or the points where the measurement tooling would 
have been touching the object being measured). Press OK.  
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Figure 29-23. The options 
for querying points to objects.

2. A Vector Group will be created and the properties dialog will 
appear (Figure 29-24).  

Figure 29-24. The vector 
group properties dialog.

3. To change the appearance of the vectors, click the Display 
Settings button. Here you can change the magnification, size, 
and style of the vector. Change the magnification, vector style 
and blotch size to match Figure 29-25.  
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Figure 29-25. The Vector 
Group Display Options dialog.

4. Now change the colorization of the vectors and apply a tol-
erance for colorization. There are four different colorization 
methods (Figure 29-26). Choose Toleranced (Go/No-Go).  

Figure 29-26. Colorization 
options.

Now the vector group reflects the display and colorization changes 
(Figure 29-27).
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Figure 29-27. The result.



870

SPATIALANALYZER USER MANUAL

Best Fit Points to Points
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will explore the “best fit points 
to points” commands, a commonly-used functionality for relo-
cating to an established coordinate system and aligning ob-
jects.

 ■ Areas Covered. Renaming points using a name pattern, re-
naming points by auto-corresponding using inter-point dis-
tances, locating instruments using best-fit, fit weighting, and 
tolerance coloring zones.

 ■ Time to Complete. Approximately 20 minutes.

Point Names Are Important

In this tutorial, we have a set of nominal points (fiducials), and we’ve 
measured those nominal points with a laser tracker. Our task here is to 
locate the instrument by fitting the measured points to the nominals.

1. We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files.  Choose the 
Best Fit Points to Points.xit file. This file contains a 
laser tracker which has measured a series of 7 points, each of 
which has a corresponding nominal point.

2. Our measured points currently match the names of the nomi-
nals, but in real life, you won’t ordinarily be so lucky. Let’s give 
random names to our measured points to simulate what you 
might encounter after a real survey. From the menu, choose 
Edit>Rename>Points Using a Name Pattern.

3. When prompted for the points, press F2. Check the Sta-
tion1 point group to select all points in the group, then click 
OK.  Press Enter to accept the point selection.

4. For the Name Pattern field, enter %d. Enter a starting value of 
5, and click OK (Figure 29-28). The measured targets will be 
assigned names from 5 to 11. Notice that the measured target 
names do not match the nominal point names.

Figure 29-28. Renaming us-
ing a pattern.
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5. Let’s locate our instrument to the nominal points. In the tree, 
right-click the tracker and choose Locate. From the Locate In-
strument dialog, choose Best Fit and click OK (Figure 29-29).  

Figure 29-29. Locating using 
Best Fit.

6. You will be prompted to select the Nominals Group. Click one 
of the nominal points in the graphical view. Then click one 
of the instrument’s points when prompted for the Measured 
Group. Nothing happens! The fit is not occurring because best 
fitting points requires that each nominal and corresponding 
measured point must have the same name.

7. You could rename each point manually, but there is a better 
way. We want to rename our measured points to match our 
nominal names. From the menus, choose Edit>Rename>Points 
by Auto-Corresponding 2 groups>Inter-Point Distance. Think of this 
command as performing a best fit “under the hood”, then re-
naming the points based on their proximity to the reference 
points. When prompted for the reference group, pick the 
nominals group.  For the group to be renamed, pick the Sta-
tion1 group.

8. The default value of 0.1” (2.54 mm) works fine for our inter-
point distance match tolerance. We know that each of our 
measured points should be within 0.1” (2.54 mm) of our nom-
inals after a best-fit it performed, so all of the points within 
this threshold will be renamed. (Note that this function would 
probably not work if the nominal points were symmetrical. 
In that case, SA wouldn’t know how to orient the measured 
points, and the resulting points may not be named correctly).

9. You will be presented with the proposed name changes. Click 
Accept to make the changes. The Station1 point names now 
match the nominals point names. We’re now set to do a points 
to points best fit.
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Fitting the Points

1. We saw how to use best fit from the instrument’s Locate 
menu. Let’s look at how to do it from the main menu. Choose 
Instrument>Locate (Transform to Part)>Best Fit.   As before, pick 
nominals for the nominal group and Station1 for the mea-
sured group. The Best-Fit Transformation dialog will appear 
(Figure 29-30). At the top of this window, we’re allowing 6 de-
grees of freedom for the fit: X, Y, Z, Rx, Ry, and Rz, which is what 
we want in this case. Notice the table at the bottom, which is 
currently displaying the nominal coordinates and resulting 
deltas. Click the Actuals checkbox to display the coordinates of 
the measured points. Notice that the fit hasn’t yet been per-
formed, and as a result the deltas are quite large. That’s why 
the Re-fit button (with the two chasing arrows) and the fit re-
sults are highlighted blue.

Figure 29-30. The Best-Fit 
Transformation dialog.

2. Click the Re-fit button to calculate the fit. Immediately, the 
results of the fit are displayed (Figure 29-31).
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Figure 29-31. The fit results.

3. Notice that each field is color-coded based on the Toler-
ance Coloring Zones in the dialog.  Deltas between 0.0000-
0.0200” are not colored, deltas from 0.0200-0.0400” are yel-
low, 0.0400-0.0600” are blue, and 0.0600” and greater are 
red. Looking at the results of the fit, point M3 has a very 
large dX value relative to the other points. This is highlight-
ed by the red coloring. Click the “dX” column header twice 
to sort the values, with the highest value in the top row. 
 
It looks like our M3 point has a significantly higher dX error 
than the other points, so that point is suspect. Let’s temporar-
ily remove it from the fit to see how the solution is affected. 
Uncheck the checkbox in the Name column for point M3. Since 
this changes the fit, you again need to click the Re-fit button.

4. Immediately, the errors drop dramatically, which backs up our 
theory that the M3 point is not good. Let’s give our tolerance 
warning indicators smaller values, for good measure. Click the 
ellipsis button in the Tolerance Coloring Zones section of the 
dialog. In the Tolerance Zone Coloring dialog (Figure 29-32), 
set the values to 0.005”, 0.010”, and 0.020” respectively.
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Figure 29-32. The Tolerance 
Zone Coloring dialog.

5. After the change, none of the rows are highlighted, so we 
know that all errors are within 0.005”. In fact, we can easily see 
that the largest error is just under 0.002”.

6. Now take a look at each of the individual components. The larg-
est dX error is 0.0006”, which we deem to be acceptable. The 
largest dZ error is 0.0004”, which is also acceptable. But notice 
that two of the dY errors are -0.0011” and 0.0016”.  These are 
at least double the largest errors of any of the other compo-
nents. Suppose that we believe that the Y values  from those 
two points might be unreliable. The best-fit dialog allows us 
to weight these individual components to zero, so that they 
do not affect the fit. Let’s do that now, starting with the point 
with the larger error.

7. Check the Weights checkbox so that we can see the individual 
component weights being applied. Double-click the M2 row. 
In the Best-Fit Item dialog (Figure 29-33), click the 0 button 
under the Y component to set its component weight to zero 
and click the OK button.

Figure 29-33. The Best-Fit 
Item dialog.

8. Click the Re-fit button.  (Note that it’s usually best to make 
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small changes and re-fit, so you can gradually see how the 
changes affect the solution). Now that the new solution is cal-
culated, the new largest dY is under 0.001”, so we may con-
sider this to be acceptable.

9. Click the Apply Transformation button. The instrument imme-
diately snaps to the nominals (Figure 29-34). We’ve now per-
formed a fairly complicated fitting operation with ease. We’ve 
removed a point from the fit operation, and weighted an in-
dividual component from another point to zero to exclude it 
from the fit. As a result, we brought our errors from over 0.030” 
to under 0.001”. Since most of the points and components are 
still in the fit, we can still be confident that the fit is good.

Figure 29-34. After the best 
fit.

Reviewing the Fit

1. Let’s review the results of our fit. When the fit was completed, 
an event was created in the tree called Best Fit transformation. 
Turn on the Report Bar by selecting Reports>Report Bar Visible 
from the menus (if necessary), and click the event in the tree 
to select it.

2. In the Report Bar, notice that you can view all of the results 
from the fit, including the points and components that were 
excluded from the fit or assigned special weights.
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Best Fit Geometry from Points
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will explore how to best fit ge-
ometry to points.

 ■ Areas Covered. Geometry Fitting.

 ■ Time to Complete. Approximately 15 minutes.

A significant portion of metrology analysis involves fitting geometry 
to measured points. SA’s interactive Geometry Fit Interface is able to 
fit a wide variety of geometric shapes to any set of measured, con-
structed, or cloud points. In this tutorial, you will learn how to best fit 
data to four of the most commonly created shapes: circles, cylinders, 
lines and planes.

1. To begin, open the tutorial file in SA included with your instal-
lation. Choose Help>Open Sample SA Files and select Geometry 
Fit.xit.

If you expand the items in the tree bar on the left, you will see that 
this file contains two separate instruments. The laser tracker mea-
sured points in the point groups Circle and Plane. The portable 
arm measured the points in the point group named Cylinder. These 
instruments were located to an established coordinate system using 
a best fit points to points transformation. This transformation was 
performed for visual purposes only and will not be demonstrated in 
this tutorial.

Best Fit a Plane to Points

There are several ways to fit geometry in SA. One is by selecting 
Construct>Geometry by Fitting (Ctrl+G), which is the general form of 
the command. If you already know the type of geometry you wish to 
create, a slightly faster method is to use Construct>[Geometry Type]>Fit 
to Points. This method will automatically select the proper geometry 
type for you. The keyboard shortcuts for geometry fitting are useful 
and easy to remember: Ctrl+Alt+[Letter], where [Letter] is 
typically the first letter in the geometry name (P for plane, C for circle, 
etc). If either of these methods are used, you must explicitly select the 
points to use in the fit. The simplest option is to right-click on the ap-
propriate point group and select Fit Geometry from the context menu. 
If you’ve measured features into different point groups (as you should 
in SA), this will fit the geometry to the entire point group, which is 
almost certainly what you want.



877

CHAPTER 29 ■ TUTORIALS

2. Right-click the Plane point group and select Fit Geometry from 
the context menu.

3. The Geometry Fit Interface will appear. Here you can control 
the fit tolerance, points used in the calculation, output param-
eters, and everything else related to the fit. Select the Plane 
option from the dropdown (Figure 29-35).

Figure 29-35. The Geometry 
Fit Interface.

Fit Tolerance

4. Click on the Point List button. This will display the Geometry 
Fit Point Listing dialog (Figure 29-36) which shows you the fit 
error for individual points and permits the application of Tol-
erance Coloring Zones.

Tolerance Coloring Zones can be defined with values of your choos-
ing and help you gauge how well the plane fits the selected data. You 
may change the tolerance zones as well as their colors by selecting 
the ellipses icon . In this example, one point lies outside of the 
0.015” tolerance zone. Four points are highlighted yellow because 
their error lies in the Limit 1 tolerance zone. All other points that are 
not highlighted are considered completely in-tolerance.
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Figure 29-36. A geometry 
fit’s point listing.

5. Let’s uncheck the out-of-tolerance point highlighted in pink 
to remove it from the fit. Once unchecked, the fit will need to 
be recomputed. Press the recompute button , which will 
have a dark blue background indicating the currently dis-
played fit data is not reflective of the current settings. Evaluat-
ing the new fit results, all points are now considered in toler-
ance. Close out the point listing dialog box.

Controlling Probe Offset

By selecting which probe you are using while collecting data, you will 
allow for SA to automatically calculate the offset when fitting geom-
etry. For this particular plane, a 1.5” SMR was used and as a result SA 
has already shifted the plane 0.75” to compensate for the probe ra-
dius (Figure 29-37).

Figure 29-37. The plane is 
automatically offset from the 
measured points.

6. Click the Fit Details button. Among the statistics about the fit 
and the resulting geometry, the dialog also indicates that all 
points have offsets of 0.75”. Close this window.

7. Check the Override checkbox (which overrides the target off-
sets to 0.0” by default) and notice how the plane now rests 
approximately on the measured points.
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Figure 29-38. Overriding the 
offset to 0.0”.

8. Uncheck the Override checkbox to again use the measured 
probe offset of 0.75”. 

In certain less common measurement situations (such as indirect 
measurement or when using a backing bar), you may wish to reverse 
the geometry offset direction or the direction of the resulting geom-
etry. The reverse checkbox in the Planar Offset Direction box and the 
reverse Object normal Vector checkbox are intended to be used for 
this purpose.

Creating Entities

It is sometimes desired to create probe compensated points—that is, 
points which represent the point of contact of the probe on the mea-
sured feature (instead of points representing the center of the probe). 
This can easily be accomplished by selecting the Offset Pts button. 

Exercise

Now that you have discovered how simple it is to interact with the 
geometry fit interface when constructing a best fit plane to points, it’s 
time to try an exercise utilizing three other geometric shapes with the 
remaining data on your own.

 ■ Best fit a circle to its measured points.

 ■ Best fit a cylinder to its measured points.

 ■ Best fit a line to the cardinal points constructed from both the 
circle and cylinder.

If you need help or would like to check your work, follow the steps 
below.

Best Fit a Circle To Its Measured Points

1. All points for the circle fit were measured in the same point 
group. Right-click on the group in the tree and select Fit Ge-
ometry.

2. Click the Point List button. Several points are highlighted pink 
(Figure 29-39). Uncheck the point with the highest magni-
tude and recompute. Several points are still highlighted pink 
so uncheck the point with the highest magnitude once again 
and recompute. All points are now in tolerance (Figure 29-40).
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Figure 29-39. The point list 
for the circle, showing many 
out of tolerance points.

Figure 29-40. The fit 
improves dramatically after 
removing a few stray points.

3. Since the final step requires us to best-fit a line using cardinal 
points, click the Cardinal Pts button. The point group Fitted 
CircleCardinal Points has been created. 

4. Click OK to accept.

Best Fit a Cylinder To Its Measured Points

1. All points for the cylinder fit were measured in the same point 
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group, so right-click on the group and select Fit Geometry.

2. Since the tolerance box lets us know that 0 of 16 points are 
out-of-tolerance (assuming the defined tolerance is accept-
able to us), we do not need to look at the point list.

3. Click the Cardinal Pts button to create the point group Fitted 
CylinderCardinal Points. 

4. Click OK to accept.

Best Fit a Line To The Cardinal Points Constructed from both the circle and cylinder.

1. The cardinal points constructed from the circle and cylinder are 
located in separate point groups, so choose Construct>Lines>Fit 
to Points or use the keyboard shortcut Ctrl+Alt+L. This will 
bring up the Geometry Fit Interface.

2. Select all points in both cardinal points groups by using either 
the F2 command or graphically clicking on the points them-
selves.

3. Of the five points, one is out-of-tolerance. Uncheck the point 
with the largest amount of error from the Point List dialog and 
recompute. 

4. Click OK to accept.

Conclusion

This tutorial has covered the basics of geometry creation and how to 
create a best fit plane. The interface we covered is generic for all the 
geometry fits which makes fitting geometries extremely simple.
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Creating Callouts
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to create callout 
views with graphical annotations.

 ■ Areas Covered. Creating a Callout View, Creating Callout An-
notations and Locking the view.

 ■ Time to Complete. Approximately 10 minutes.

Creating A Callout View

1. In SA, start by opening the Blower Shroud.xit file from 
the Samples directory under Help>Open Sample SA Files.

2. Before we create a callout view, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3. Now create a callout view by clicking the Callout icon . Call-
out 1 view will be created in the tree and will be active (Figure 
29-41).

Figure 29-41. The newly-
added callout view.

Creating Callout Annotations

1. Let’s create a callout annotation in the graphical view. Start by 
clicking the arrow by the icon. A series of annotation types 
will appear. Let’s start with a simple Point Comparison. Select 
Point Comparison from the drop down and select two points to 
compare. An annotation will appear and you can now place 
the annotation accordingly by left-clicking and dragging (Fig-
ure 29-42).
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Figure 29-42. The point 
comparison callout.

2. Now let’s create some annotations for a few of the vectors in 
the vector group. Start by clicking the arrow by the icon 
and select Vectors. When prompted select the vectors of inter-
est. The Vector Callouts dialog will appear with view options 
(Figure 29-43). This dialog will allow you to select display op-
tions for the callouts. Once satisfied, press OK (keep callouts). 
Feel free to place the annotations accordingly by left-clicking 
and dragging (Figure 29-44).    

Figure 29-43. The Vector 
Callouts dialog.
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Figure 29-44. Vector callouts 
have been added.

Locking the Callout view

1. Right-click on Callout 1 in the tree and select Properties (Figure 
29-45).

Figure 29-45. The Callout 
Page properties.

2. Select Lock in the Viewpoint section. When the viewpoint is 
locked, the view will be recalled when the callout is activated.

3. Double-click Callout 1 in the tree. This will deactivate the call-
out.

4. Rotate and zoom the view to be different than the callout.

5. Now double-click Callout 1 in the tree. This will activate the 
callout. Notice how the view returns to the locked position.
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Inspection with GD&T
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to perform a 
GD&T inspection with nominal CAD and native GD&T annota-
tions.

 ■ Areas Covered. Importing CAD with GD&T annotations, cre-
ating Datums and Feature Checks, Associating/Trapping mea-
surements and Reporting.

 ■ Time to Complete. Approximately 15 minutes.

Importing CAD with GD&T annotations

The first step for this tutorial is to import the nominal CAD model with 
GD&T annotations. If your CAD models do not contain GD&T annota-
tions, please refer to the tutorial on creating GD&T annotations.

1. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2. Import the native CAD model with GD&T annotations by se-
lecting File>Import>Direct CAD Access or use the Auto Import
button on the main toolbar.

3. Choose Sample CAD.CATPart from the Samples file folder 
in the SpatialAnalyzer install directory.

4. When the Direct CAD Access Settings dialog appears (Figure 
29-46), make sure the Annotations option is selected and press 
OK.  

Note:  This tutorial requires 
SA Ultimate or greater.
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Figure 29-46. The Direct 
CAD Access settings.

5. Once imported, you will find the Annotations category is cre-
ated with the imported annotations (Figure 29-47).

Figure 29-47. Imported an-
notations.
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Figure 29-48. Annotations in 
the graphical view.

Creating GD&T Datums and Feature Checks

For this tutorial we will inspect only one of the GD&T Features. Right-
click Geometrical tolerance.1 in the tree and choose Make Feature Check. 
You will notice two new categories are created, GD&T Datums and Fea-
ture Checks. These two new categories act as bins for the respective 
measurements.  

Inspecting GD&T Datums and Feature Checks

1. The next step is to associate measured points to the respec-
tive GD&T Datum or Feature Check. For this tutorial we will 
assume that an instrument is present. So let’s add an instru-
ment and run the interface. See the Instruments section for 
information regarding adding and running an instrument. For 
this example we will use a Faro Arm.

2. Now that the instrument is added and running, simply right-
click the collection containing the GD&T Datums and Feature 
Checks and select Inspection>Inspect. In this case we will right-
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click collection a (Figure 29-49).

Figure 29-49. Selecting 
Inspect.

3. A dialog will display prompting what feature to measure. As 
points are measured, they are immediately associated to the 
GD&T Datum or Feature Check. Since an instrument is prob-
ably not available during this tutorial just use your imagina-
tion.

4. Once measurements are complete for a feature, press the 
next button  to advance to the next feature and continue 
measuring. Once all measurements are made the inspection 
is complete.

5. Since we did not take any actual measurements, lets open 
GD&T with Arm.xit from the Samples directory under 
Help>Open Sample SA Files.

6. In the GD&T with arm.xit file, all the GD&T Datums and 
Feature Checks have points associated.

Reporting the Results

1. To see the results of the Feature Checks evaluation, simply se-
lect the Feature Check of interest and the results will display 
in the Report Bar. If the report bar is not visible, turn it on us-
ing Reports>Report Bar Visible.
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Figure 29-50. Feature check 
results for a surface profile 
check.

2. To report all results, right-click the Feature Checks category in 
the tree and select Composite Quick Report>Generate. All of the 
Feature Check results will be compiled into one report (Figure 
29-51).

Figure 29-51. A composite 
quick report with GD&T fea-
ture check results.

Conclusion

In this tutorial, we covered how to import CAD with GD&T annota-
tions and how to create, measure and report feature checks.
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Reporting With SA Reports
 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to create a re-
port using the SA Report designer.

 ■ Areas Covered. Creating an SA Report, dragging out items, 
changing report options.

 ■ Time to Complete. Approximately 15 minutes.

Creating an SA Report

In this tutorial, our goal is to create a report comparing measured data 
to CAD. We will use a sample file and create the report from that data.

1. In SA, start by opening the Query Points to Surface.
xit file from the Samples directory under Help> Open Sample 
SA Files. 

2. Before we start the report, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3. Create an SA report by selecting Report>Add SA Report. The SA 
Report editor will appear, and the report is automatically 
stored in the tree under the SA Reports category (Figure 29-
52).    

Figure 29-52. The newly-
added report.

Figure 29-53. The Report 
Designer.

4. Let’s add an item to the SA Report. Click and drag the Boat 
error_Vectors_Blotches vector group into the report (Figure 

Note:  This file contains data 
that was measured with a 

portable CMM arm.  The measure-
ments were compared to the 
nominal model using Query> 
Points to> Objects.
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29-54).

Figure 29-54. Adding a vec-
tor group to the report.

5. Now let’s change the reporting options for the vector group 
so that only the vector magnitude will be displayed. Right-
click anywhere on the vector group table and select Report Op-
tions.

6. Uncheck the Point A, Point B and Delta components and press 
OK.  The SA Report will update and reflect your changes.

7. Let’s add an image of the current graphics view to the report. 
Orient the SA graphics as you’d like, and press the Picture icon

in the toolbar. The picture will be stored in the tree, as pic-
tured in Figure 29-55.

Figure 29-55. The screen-
shot has been added to the 
tree.

8. Click the photo, drag it over a table in the SA Report, and re-
lease the mouse button. Immediately, the report will relocate 
your tables so that they do not overlap. This is a feature that is 
on by default, but if you do not want this behavior, select the 
Global Reporting Options button .  In the Report Designer 
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Settings dialog, uncheck Auto Vertical Overlap Adjust. Now, the re-
port will not automatically ensure that items do not overlap 
(Figure 29-56).

Figure 29-56. Ensuring that 
report items don’t overlap.

9. The photo will have the same aspect ratio (width to height 
ratio) as the graphical view when it was taken. If you need to 
resize the image, hold down Ctrl and drag over the image, 
or grab a corner of the image to resize it as necessary. Drag 
the tables around to rearrange the report as you’d like (Figure 
29-57).  

Figure 29-57. Arranging ele-
ments of the report.

10. The report is automatically saved into the tree. If you’d like, 
you can print the report, send it to a PDF, or export to Excel.
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Creating Relationships
 ■ Skill Level. Intermediate.

 ■ Description.  In this tutorial, we will explore the advantages of 
relationships, and look at how to create them.

 ■ Areas Covered. Points to Objects Relationships, Groups to Ob-
jects Relationships, Relationship Reports.

 ■ Time to Complete. Approximately 20 minutes.

Building the Relationships

Relationships are an extremely powerful concept that enable real-
time examination of the positions and/or orientations between en-
tities in SA. Using relationships, you can get dynamically updated 
comparisons between measured and nominal points, points and ge-
ometry, coordinate frames, and other entities. There are two sides to 
relationships: the reporting side, and the relationship minimization 
side. Relationship minimization is available in SA Ultimate and higher, 
and will be explored in a different tutorial.

1. We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files. Choose the 
Relationships.xit file.

2. This file contains a sample CAD model of a hydroplane, along 
with a series of measured points along different surfaces of 
the model (Figure 29-58). Since this sample file already has 
constructed relationships, let’s delete them to create them 
from scratch. In the tree, right-click on the relationships cat-
egory and choose Delete All from the menu. Confirm the dele-
tion.
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Figure 29-58. The measured 
points have not yet been 
aligned to the model.

3. Currently, our measured points are not aligned to the model. 
That’s OK--for the purposes of this demo, we’ll ignore that fact. 
We now want to compare our measured points to the CAD 
surface, and see how our measured part deviates from nomi-
nal. We’ll use a series of Groups to Objects relationships to ex-
tract this information. In the menu, select Relationships>Groups 
to Objects. For the relationship name, enter Canopy.

4. The Query Point to Surface Options dialog will appear (Fig-
ure 29-59). This dialog allows you to specify how you want 
the relationship to compare the measured points to the sur-
face. The set of buttons at the top of this dialog allow you to 
specify how the resulting deviations will be depicted in the 
view. All four options give the same numeric result--they just 
control how the resulting deviation vectors are displayed, and 
the sense (positive or negative) of the deviation. We want to 
know the deviation from the CAD to the offset point (probe 
contact point). Leave all of the other options at their defaults 
and press Enter.
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Figure 29-59. Query Point to 
Surface options.

5. When prompted for the groups, double-click the Canopy point 
group, then press Enter.

6. When prompted for the objects, double-click the hYdrOdeCK 
surface, then press Enter to complete the command.

7. Notice that the Canopy relationship has been added to the 
tree.  If you expand the relationship, you’ll see the absolute 
max error, RMS error, max signed error, and minimum signed 
error for the comparison of all of the points in the selected 
group to the selected surface.

8. Let’s open up the Relationship Report so we can see this re-
lationship’s values update in real-time. Double-click the re-
lationships category. The Relationships Report dialog shows 
the desired relationship parameters for a given collection in 
real-time.

9. By default, only the relationship summary is displayed. Let’s 
turn on more details. Right-click the Canopy relationship and 
choose Report Options from the menu.  In the Report Options 
dialog (Figure 29-60), select the Single Line format:
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Figure 29-60. Report Op-
tions for the relationship.

10. Click OK to accept the change. In the Relationship Report win-
dow, you can now see the deltas and resulting deviations for 
each point, as well as a summary for the relationship.

11. Let’s move the instrument up in Z. Since measurements are 
“tied to” instruments, the resulting measured points will move 
up in Z as well. Expand the instruments category and right-
click on the instrument. Choose Properties from the context 
menu. In the Instrument Properties dialog, click the Transform 
button. Click on the up arrow for the Z value to move the in-
strument up in Z, and watch as the Relationship Report up-
dates all of the calculations. After moving the instrument up 
a little bit in Z, close the dialog and click OK in the Instrument 
Properties dialog. Notice now that our measured points are 
now well above the CAD surface.

12. Close the Relationship Report window by clicking the Done 
button. Let’s create another relationship for the measurements 
of the sides of the Hydroplane. Choose Relationships>Groups to 
Objects and give the relationship the name Sides.  Leave the 
projection options at the defaults and click OK.

13. This time, let’s assign the point group to the relationship AF-
TER we’ve created it. This illustrates the idea that you can set 
up relationships in a nominal file prior to measuring anything, 
then assign measured points later. (You can even automati-
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cally assign them AS you measure by “Trapping Measure-
ments”). Just press Enter to continue through the Groups 
prompt. As before, when prompted for the Objects, pick the 
hYdrOdeCK surface and press Enter to finish the command. 
Here, you’ve set the relationship up so that only the surface 
has been assigned--the groups involved in the relationship 
are not yet specified.

14. Expand the Sides relationship. Note that the tree indicates 
that there are No Points Specified. Let’s fix that. Right-click on 
the collection, and in the context menu, choose Associate 
Data>Points>Groups. Double-click the top group and press En-
ter.

15. Let’s check to make sure that we’ve assigned the right objects 
to our relationship.  Right-click the Sides relationship in the 
tree and choose Highlight Entities. The hYdrOdeCK surface will 
highlight, as well as the top point group. We just made a mis-
take! We accidentally selected the top group instead of the 
Sides  group! No problem, we’ll fix it. From the menu, select 
View>Clear All Highlights to remove the highlighting. Right-click 
the collection, and repeat step 14, only this time, select the 
Sides group.

16. The collection should now be set up correctly. Go ahead and 
set up a Groups to Objects relationship between the top 
group and the hYdrOdeCK surface as well, and name it top.

17. Notice the horizontal plane named tabletop plane. This part 
was surveyed on a flat tabletop, so it would be impossible to 
measure the bottom surface of the object. Instead, we cre-
ated a nominal plane representing the top of the table, and 
measured a few points around the edges of the part to estab-
lish the table surface. Let’s build a relationship between the 
plane points and the tabletop plane plane, which we’ll use in 
a later tutorial (Minimizing Relationships) to fit our measured 
data to the CAD model.

18. From the menu, select Relationships>Points to Objects. Give the 
relationship a name of tabletop, and accept the default pro-
jection options. When asked for the points, double-click the 
6 green points around the edge of the model (the ones in the 
plane group). We could have done this using a Groups to Ob-
jects relationship, but we wanted you to see a different way to 
create a relationship. Press Enter to accept the points.

19. When prompted for the objects, double-click the horizontal 
tabletop plane plane. Press Enter to complete the command.

20. We also measured a scribe line passing through our part 
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which indicates the part’s centerline. We measured this line 
by placing the probe directly over the scribe line and measur-
ing the points. Repeat steps 18 and 19 one final time to create 
a relationship between the Centerline points and the CL plane 
plane. Give the relationship a name of Centerline.  However, 
this time, in the projection options, override the target offset 
value to zero (Figure 29-61). Since we measured a centerline 
and want to compare it to a plane defining the centerline of 
the part, we do not want to account for a probe offset.  In oth-
er words, we want to compare the center of the probe to the 
plane directly, as seen at right.

Figure 29-61. Overriding 
target offsets to zero.

21. We’ve now set up 5 relationships that show the real-time 
deviation between selected features and the corresponding 
measured points. As the instrument that measured the points 
is moved around, the relationships immediately recalculate 
and update the deviation values. This real-time re-calculation 
is very useful, particularly with instrument alignment and re-
al-time building/part mating processes.

Conclusion

In the next tutorial, Minimizing Relationships, we’ll explore the power 
of Relationship Minimization and discover how it can be used to per-
form a variety of complex alignments with constraints.
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Minimizing Relationships
 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will explore relationship mini-
mization, an extremely useful capability used for alignment, 
assembly, and a host of other applications. We’ll use relation-
ships to locate our measurements relative to a CAD part, using 
a series of different situations.

 ■ Areas Covered. Moving objects by minimizing relationships, 
local minima, Standard vs. Direct Search optimization, and re-
lationship weighting.

 ■ Time to Complete. Approximately 25 minutes.

Relationship Minimization

One of the great advantages of relationships is their ability to define 
constraints and alignment parameters. In traditional metrology soft-
ware, degree-of-freedom constraints for alignments are usually ex-
plicitly specified. For example, if a pin is constraining an assembly, 
one might explicitly lock a degree of freedom along the radial direc-
tions of the pin, so that the pin only allows travel along its length.

Relationships, by their very nature, automatically take care of con-
straints when they are created. Different geometric setups will result 
in different constraints. For example, if a relationship is set up be-
tween a set of points and a plane, the plane will by its very nature 
constrain distance from the plane, but will allow the points to rotate 
in the plane’s surface. As a result, a plane introduces a positional con-
straint along its normal, and rotational constraints in the plane of the 
plane. The ability to set up these constraints “naturally”, without ex-
plicitly defining further constraint parameters, is one of the signifi-
cant advantages of relationships over other alignment methods.

1. We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files. Choose the 
Relationships.xit file.

2. In this file, five relationships have been set up for you. Three 
of these relationships are between the CAD model and the 
measurements of specific features of interest. The last two (ta-
bletop and Centerline) relate measurements to a table surface 
and center plane, respectively. To see how these relationships 
were created, see the Creating Relationships tutorial. Notice 
also how the measurements have not yet been aligned to the 
CAD model. That’s one of the tasks we’ll be accomplishing in 
this tutorial.

Note:  This tutorial requires 
SA Ultimate or greater.
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3. Let’s align our measured data to the CAD model. From the 
menus, choose Relationships>Move Objects by Minimizing Relation-
ships. In this case, we only want to move the instrument (and 
by association the targets measured by that instrument). So, 
when prompted for the Objects to Move, just press Enter. 
When prompted for the Instruments to Move, double-click 
the instrument and press Enter. The Minimize Relationships 
dialog will appear (Figure 29-62).

Figure 29-62. The Minimize 
Relationships dialog.

4. The process of relationship minimization finds the optimum 
position of the specified moving objects and instruments that 
results in the smallest RMS error. Let’s first take a look at how 
our measured points fit to the CAD model, without including 
our tabletop or centerline in the solution. Uncheck the Cen-
terline and tabletop relationships to exclude them from the 
minimization process (Figure 29-63), then click the Run Opti-
mization button. This is the “standard” method of minimizing 
relationships.

Figure 29-63. Excluding the 
Centerline and Tabletop rela-
tionships from the solution.

5. The instrument’s position and orientation will be adjusted 
to arrive at a minimum error, which represents the ideal fit. 
Note that as the solution progresses, the RMS Objective value 
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decreases toward zero (Figure 29-64).

Figure 29-64. The objective 
progresses toward zero as the 
relationship solves.

6. The resulting absolute maximum and RMS errors are also 
displayed for each individual relationship in the Minimize 
Relationships window. The results look good, but we didn’t 
get a good idea of what was going on. Let’s move the instru-
ment back up in Z. Click the Move Manually button, and in the 
Transform dialog, type 5 into the Z value and press Enter. 
Close the Transform dialog. Let’s also choose an option so we 
can actually see the intermediate positions as the relationship 
is being solved. In the Minimize Relationships dialog, check 
the Show Steps checkbox (Figure 29-65).

Figure 29-65. Turning on the 
Show Steps option.

7. Move the Minimize Relationships window to the side of the 
screen so that you can see the graphical view, then again click 
the Run Optimization button. Watch as SA solves the equa-
tions to minimize the error.

Local Minima

Under the hood, relationships are projecting measured points to the 
CAD surfaces and calculating the resulting deviations.  If the mea-
sured points are too far from the CAD surfaces, or if the points are 
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flipped from their true orientation, then depending on the geometry 
of the setup and the surfaces, it is possible for the solution to reach a 
local minimum, and stop prematurely.

1. Again, click the Move Manually button. In the Transform dia-
log, enter 180 for Ry and -10 for Z. Notice that the measured 
data is now flipped upside-down relative to the CAD model. 
Close the Transform dialog, and again click the Run Optimiza-
tion button.

2. The relationship solves and stops. Click the Apply Transforma-
tion button, and take a look at the graphical view. Clearly our 
points are flipped upside-down relative to the CAD model, 
and we have a large RMS error. What’s going on here? What’s 
happening is that the solution is getting caught in a local min-
imum. When minimizing relationships, you always want your 
measured points to have a “clean approach” to the geometry 
that you’re relating to. This means that there shouldn’t be any 
large rotations required that cause the relative orientation be-
tween the CAD and the measured data to “flip”. Depending on 
the geometry of the setup, the solution could get caught up 
in the wrong minimum, as seen here.

3. Let’s fix our local minimum problem so we can ensure that 
the relationship solves to the correct position. Click the Views 
button to go to the Side View (Figure 29-66).

Figure 29-66. Selecting the 
predefined Side view.

4. From the menu, select Instrument>Drag Graphically. Hold down 
the right mouse button to rotate the instrument approxi-
mately 180 degrees (Figure 29-67).

Figure 29-67. The instru-
ment has been rotated about 
180 degrees out.
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5. Again, choose Relationships>Move Objects by Minimizing Relation-
ships. As before, don’t move any objects, but move the instru-
ment. Ensure that the Centerline and tabletop relationships 
are still deselected. Click the Run Optimization button. You’ll 
notice that, after a few seconds, the solution comes to an 
abrupt and premature end--the points remain in their origi-
nal positions. Because the initial condition for the solution is 
so far from the CAD model, a local minimum is being encoun-
tered.

6. Instead, click the Run Direct Search Optimization button. Di-
rect Search Optimization is a more “brute-force” method of 
finding a minimum.  It involves exploring the solution space 
more thoroughly to find a more optimized orientation, then 
moving to that intermediate position and checking again. 
This method is slower, and requires more time to solve (some-
times, significantly more time). Depending on the setup, it 
can also end up with a “flipped” result. However, it is less like-
ly to get caught in a local minimum. After a few seconds of 
calculating--once the Objective value is under about 0.8”--click 
the Cancel button.

7. Notice that, rather than returning to the original position and 
orientation, the instrument and points stopped in their cur-
rent position. This is a helpful behavior, because we can now 
switch to the traditional optimization method to close up the 
fit the rest of the way. Click the Run Optimization button, and 
the solution should be reached relatively quickly. When fin-
ished, click the Apply Transformation button. If you notice that 
your solution has solved to the incorrect orientation, move 
and rotate the instrument for a better starting condition and 
try again.

8. What is the lesson from all of this? The fact is, you’ll avoid all 
of these issues with reaching local minima if you start with a 
good initial condition. As long as you manually orient the in-
strument so that the points have a relatively clean approach 
to the surface, and as long as they aren’t too far away from 
the surface, the solution can be approached with no trouble. 
Many people will do a rough orientation using Quick Align, then 
fit with more data using relationships. In a situation like that, 
you won’t encounter problems with local minima.

Incorporating the Tabletop and Centerline

1. Suppose that we now wish to incorporate the measurements 
of the tabletop to our fit. If we assume that the bottom sur-
face is flat, and that the tabletop is flat, then our measured 
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tabletop points represent the bottom surface of the CAD part. 
Press Ctrl+Tab to reselect the last command, which should 
be the Move Objects by Minimizing Relationships command. As be-
fore, pick to move just the instrument.

2. This time, ensure that the tabletop relationship is also select-
ed, then click Run Optimization again. Our RMS error has in-
creased from 0.0013” to 0.0022”, but we’ve now allowed our 
measurements of the tabletop to influence the solution. Since 
the tabletop plane plane is facing directly along the Z axis, the 
relationship is only affecting the final solution’s Rx, Ry, and Z 
results. X, Y, and Rz are not affected due to the geometry of 
the plane. (Rotating about Z or translating along X or Y will 
not affect the distance of the plane points from the tabletop 
plane plane. Click the Apply Transformation button to accept 
the results.

3. Click the Views button in the toolbar to select the top view, 
then zoom in on the CAD model and measured points. In the 
tree, right-click the point Groups category header and choose 
Hide All from the context menu. Then, right-click the Centerline 
point group and choose Show from the menu (Figure 29-68).

Figure 29-68. Showing the 
Centerline point group.

4. We haven’t yet incorporated our Centerline relationship into 
the solution. Let’s say, for sake of this tutorial, that it is very im-
portant to us that the measured centerline points are aligned 
well to the centerline plane. We still want the measured points 
of the CAD surface to influence our fit, but we consider the 
centerline measurements to be much more important. We 
can weight the Centerline relationship to have a much stron-
ger influence in the overall solution.

5. Press Ctrl+Shift+TAB and choose the Relationships>Move 
Objects by Minimizing Relationships command from the list, and 
specify to move just the instrument. In the Minimize Relation-
ships dialog, ensure that all five relationships are checked so 
that we incorporate them all into the minimization process.
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6. Single-click the row with the Centerline relationship so that 
it is selected. Then, single-click the Weight column. Give the 
Centerline relationship a weight of 100 (Figure 29-69). This is 
equivalent to saying that we consider errors from the points 
in the Centerline relationship to be 100 times more important 
than errors from the points in the other relationships.

Figure 29-69. Setting the 
weight of the Centerline rela-
tionship to 100.

7. Click the Run Optimization button.  It may be difficult to see, 
but the solution has been adjusted to try to minimize the cen-
terline errors with more effort than the other relationships, 
due to the higher weight assigned to the Centerline relation-
ship. Notice that the RMS errors have jumped way up. As you 
can see, the points measured on the centerline were not mea-
sured carefully. Uncheck the Centerline relationship to again 
remove it from the minimization process.

8. This time, let’s give the tabletop relationship a little less weight, 
since it’s not a direct measurement of the bottom surface of 
the part. Give it a weight of 0.5, and click the Run Optimization 
button. Now, the tabletop is still incorporated into the solu-
tion, but it is not considered to be as important.

Conclusion

We’ve seen here that it is important to give relationships a good 
“initial condition” to ensure that relationship minimization does not 
get caught up in a local minimum. We’ve also seen how relationship 
weighting can be used to assign more or less influence to different 
measured features when minimizing.
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Geometry Relationships
 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will cover how to create geom-
etry relationships for reporting.

 ■ Areas Covered. Creating Fit only, Compare only and Fit and 
Compare Relationships.

 ■ Time to Complete. Approximately 20 minutes.

Fit and Compare Relationship

1. In SA, start by opening the Geometry Relationship.xit 
file from the Samples directory under Help>Open Sample SA Files.

2. We will first make a relationship that will take measured points, 
fit geometry to those points, and compare this geometry back 
to the nominal geometry. Navigate to Relationships>Geometry 
Comparison>Fit and Compare to Nominal.   Select the nominal ge-
ometry and then select the points from the Measured points 
point group that are above the red circle. Accept the default 
name for the relationship.

3. Double-click the Fit Circle - Big hole relationship in the tree to 
expose the Geometry Relationship Report Options. Here you 
can control tolerance, fit constraint and geometry fit settings 
(Figure 29-70).

Figure 29-70. The Geometry 
Relationship Report options.

4. Let’s change the Fit Settings so that circle is offset correctly. By 
default it was treated as an outside measured circle when in 
fact it was an inside measured circle (Figure 29-71).
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Figure 29-71. Setting the 
circle fit options to offset 
outward.

5. Let’s set a tolerance for the X and Y components of 0.001”. 
Double-click the X column in the properties dialog. The Cri-
teria Properties dialog will appear. Set the tolerance for both 
high and low tolerances (Figure 29-72).  

Figure 29-72. Modifying the 
high and low tolerances for 
the X attribute.

6. Now uncheck the Z and MagXYZ rows. Press OK to accept and 
close the dialog.

7. Right-click Fit Circle - Big hole and select Add Callout (Figure 29-
73).
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Figure 29-73. Adding the re-
lationship callout to the circle.

8. The best part about a Geometry Relationship is its ability to 
dynamically update--if the points change, the geometry and 
reported values will update accordingly. Select Instrument>Drag 
Graphically and move the instrument around in the graphical 
view. Notice how the geometry and callout update automati-
cally (Figure 29-74). Press ESC to cancel and restore the instru-
ment position.  

Figure 29-74. The callout 
automatically updates as the 
situation changes.

Fit Only Relationship

1. Fit Only relationships are similar to Fit and Compare to nomi-
nal. Select Relationships>Geometry Comparison>Fit only and select 
the group of points that are rectangular in shape. You will be 
prompted to select a geometry to fit to the selected points-
-select plane. Accept the default name.

2. Right-click Fit plane and select Add Callout. Fit only relationships 
utilize the same Geometry Relationship Report Options as Fit 
and Compare to Nominal, although with different reported 
items (Figure 29-75 and Figure 29-76).



909

CHAPTER 29 ■ TUTORIALS

Figure 29-75. A fit-only 
relationship.

Figure 29-76. Geometry 
Relationship report options for 
fit-only relationships.

 

Compare Only Relationships

1. Now let’s compare two circles.  Select Relationships>Geometry 
Comparison>Compare Only and select the nominal::Small hole 
and Measurements::Small hole Measured items from the tree 
and accept the default name.

2. Right-click Circle: Small hole Measured - Small hole and select 
Add Callout.

3. Compare only relationships utilize the same Geometry Rela-
tionship Options as well (Figure 29-77 and Figure 29-78).
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Figure 29-77. Compare-only 
relationships.

Figure 29-78. Geometry 
Relationship report options for 
compare-only relationships.

 Conclusion

Geometry Relationships provide a quick and powerful method for 
creating and comparing geometry dynamically.
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Figure 29-79. Various geom-
etry relationships in a job.
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Designing a GD&T Inspection
 ■ Skill Level. Beginner

 ■ Description. In this tutorial, we will cover how to design a 
GD&T inspection routine for repeated use.

 ■ Areas Covered. Importing CAD with GD&T annotations, creat-
ing Datums and Feature Checks and assigning nominal points 
and views.

 ■ Time to Complete. Approximately 15 minutes.

Importing CAD with GD&T annotations

The first step for this tutorial is to import the nominal CAD model with 
GD&T annotations. If your CAD models do not contain GD&T annota-
tions, please refer to the tutorial on creating GD&T annotations.

1. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2. Import the native CAD model with GD&T annotations by se-
lecting File>Import>Direct CAD Access or use Auto Import from 
the main toolbar.

3. Choose Sample CAD.CATPart from the Samples file folder 
in the SpatialAnalyzer install directory. See Direct CAD Access 
for supported formats.

4. When the Direct CAD Access Settings dialog appears, make 
sure the Annotations option is selected and press OK (Figure 29-
80).

Note:  This tutorial requires 
SA Ultimate.
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Figure 29-80. Ensuring that 
the Annotations option is 
selected in the Direct CAD Ac-
cess import settings.

5. Once imported, you will find that the annotations group is 
created with the imported annotations.  

Creating GD&T Datums and Feature Checks

For this tutorial we will inspect only one of the GD&T Features.

1. Right-click Geometrical tolerance.1 in the tree and choose Make 
Feature Check. You will notice two new categories are created, 
Gd&t datums and Feature Checks. These two new categories 
act as bins for the respective measurements.

Designing the Inspection Routine

Now that the feature checks have been made, the inspection routine 
can be designed which will set views and nominal points for each 
GD&T Datum and Feature Check.

1. To design an inspection, simply right-click collection a and 
select Inspect>Design. A dialog will appear which contains op-
tions for the design of each GD&T Datum or Feature Check 
(Figure 29-81).
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Figure 29-81. Options for 
designing an inspection.

2. The design dialog will guide you through the design of each 
GD&T Datum or Feature Check. So for datum a, orient the 
view how you would like the user to see Datum A during in-
spection. Now let’s put some nominal inspection points on 
the surface by clicking the areas for inspection on Datum A. 
Use the minimize button to minimize the dialog so more of 
the graphical view is available (Figure 29-82).

Figure 29-82. The options 
are now minimized.

3. Now that Datum A is designed, proceed to the next GD&T Da-
tum or Feature Check by clicking to advance. Do the same 
for the remaining GD&T Datums and Feature Checks. Once 
complete, close the dialog using .

Rehearsing a Designed Routine

Now that the inspection routine is designed, it can be rehearsed to 
check the work flow, nominal points and views.

1. To start Rehearse mode, right-click collection a and select 
Inspect>Rehearse. A dialog will appear with options regard-
ing the rehearsal (Figure 29-83). During this rehearsal mode, 
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the mouse acts as an instrument. So with each mouse click, a 
measurement is simulated with some random error.

Figure 29-83. Rehearsing the 
inspection.

2. Now that the rehearse mode is started, let’s click the dot for 
Datum A. With each click a measurement is simulated and the 
guiding dot will advance. Continue clicking the dots for Da-
tum A. Once all the dots for Datum A are clicked, the inspec-
tion will advance to the next GD&T Datum or Feature Check.

3. Do the same as above for the remaining GD&T Datums and 
Feature Checks. Once complete, close the dialog using .

Conclusion

We have just designed a routine that can be used to guide a user 
through an inspection process. A user can now simply right-click the 
collection of interest and select Inspect.
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CMM Arm Inspection
 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will cover a basic part inspec-
tion without CAD while using a Portable CMM Arm.

 ■ Areas Covered. Add and Run an Instrument, Watch Windows, 
Collecting Measurements, Fitting Geometry and SA Reporting.

 ■ Time to Complete. Approximately 30 minutes.

General Part to Inspect

For this exercise we will use a generic part in which we would like to 
determine the size of the large and small bore and the angle between 
the top face and side face (Figure 29-84).

Figure 29-84. The part we’ll 
be inspecting.

Adding and running the instrument interface

1. Start by adding the instrument. For this tutorial we will use an 
8 ft Faro Quantum (7 dof ) arm. Use the menu item 
Instrument>Add or the Add Instrument icon . Navigate the 
instrument list, select FARO Arm USB 8ft & Quantum (7 dof), and 
then click Add Instrument at the bottom of the dialog (Figure 
29-85).
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Figure 29-85. Adding the 
arm to the job.

2. With the instrument added, let’s run the instrument interface. 
Simply use Instrument>Run Interface Module and Connect or use the 
Run Instrument Interface icon .

3. Once connected the instrument interface will appear. Now 
we are ready to measure!

Establishing Control Points

A good rule of thumb is to always establish a set of control points that 
can be used as a reference. These control points can be used to check 
drift and relocate the instrument.

1. Lay out three or more control points to measure. For our case 
we will measure four holes on the table by placing the probe 
in the hole.

2. Let’s set the group and target name in the instrument inter-
face so the group is called Control and the target name is C1.

3. Activate the discrete measurement mode by pressing .

4. Measure each of the four control points by placing the probe 
in the hole and pressing the green button on the arm. The 
target name in the instrument interface will automatically in-
crement after each measurement.

5. Now check the measurements to for repeatability. Right-click 
the Control point group and select Add Watch Window. Move the 
probe to each measured point and note the deviation (Figure 
29-86). The deviations should be extremely low--if not, the 
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control points should be re-measured.

Figure 29-86. The closest 
point watch window.

6. Once measured, your graphical view should look similar to 
Figure 29-87.

Figure 29-87. Measured con-
trol points.

Measuring the Bores

Let’s start by measuring the Large and Small Bores. We will take a se-
ries of points in each bore and then fit cylinders to each set.

1. Set the group name to Large Bore and the target name to 1.

2. Activate the discrete measurement mode by pressing .

3. Measure points inside of the large bore by pressing the green 
button to trigger the measurement. Once complete, close the 
discrete measurement dialog.

4. Change the group name to Small Bore and the target name 
to 1.

5. Activate the discrete measurement mode by pressing .
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6. Measure points inside of the small bore by pressing the green 
button to trigger the measurement. Once complete, close the 
discrete measurement dialog.

7. Your SA job should look like Figure 29-88.

Figure 29-88. The large 
and small bores have been 
measured.

Measuring the Top and Side Face

1. Set the group name to top Face and the target name to 1.

2. Activate the Stream Points Mode by pressing .

3. Place the probe on the Top Face and press the green button 
to start the scan. Move the probe over the surface. When fin-
ished, press the red button to stop. Close the Stream Points 
dialog.

4. Set the group name to Side Face and the target name to 1.

5. For the Side Face we will use the Plane mode. Activate this 
mode by pressing .

6. Take several points on the Side Face. After three points are 
measured, the plane fit results will appear. Once you are satis-
fied with the plane measurements, press Accept Plane.

7. Your SA job should look like Figure 29-89.
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Figure 29-89. After the plane 
fit.

Fitting Geometry to the measurements

Now that the data is collected, let’s begin the analysis. We will start by 
fitting cylinders to the bores.

1. Fit a cylinder to the Large Bore point group by using 
Construct>Cylinder>Fit to Points. Refer to the Best Fit Geometry 
from Points tutorial or Geometry Fitting section for more 
information regarding Geometry Fitting. Name the cylinder 
Large Bore.

2. Repeat the above for the Small Bore point group.

3. Now fit a plane to the top Face point group using 
Construct>Plane>Fit to Points. Name the cylinder top Face.

4. Your SA job should look like Figure 29-90.

Figure 29-90. After the 
cylinder fits.
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Reporting the results

With the geometry created we can now report the findings. For the 
report we will use SA Reporting.

1. Create an SA Report by selecting Reports>Add SA Report.

2. Orient the graphics to a view that would look good in the re-
port.

3. Press to take a screenshot. This image will now be added to 
the tree. Click and drag the Photo into the SA report. Place the 
image so that it is centered at the top of the report.

4. Now drag the Large Bore cylinder onto the report. Right-click 
the cylinder and choose Report Options.  Uncheck Show Normal 
Vector and Show Projected Angles on Working Frame. Repeat this for 
the Small Bore cylinder.

5. So far your report should look like Figure 29-91.

Figure 29-91. A screenshot 
and both cylinders have been 
added to the report.

6. Now determine the angle between the Top Face and Side 
Face. Use Query>Plane>to Plane: Angle between normals. Select the 
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two measured planes. Once completed the results will display 
and an SA Event will be created.

7. Drag the SA Event into the SA Report.

8. We have now reported our findings. The report will be saved 
in the tree. If desired, the report can be printed or converted 
into PDF format using the following icons: 

9. The final report will look like Figure 29-92.

Figure 29-92. The final 
report.
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Laser Tracker Inspection
 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will cover basic inspection of 
simple geometries and look at their relationships

 ■ Areas Covered. Add and Run an Instrument, Watch Windows, 
Collecting Measurements, Fitting Geometry and Dynamic Re-
porting.

 ■ Time to Complete. Approximately 30 minutes.

General Part to Inspect

For this exercise we will perform a basic inspection of a desk and of-
fice. (Try to find one if you don’t have one!) The office floor, walls and 
desk will serve as the measurement artifacts. We will calculate the an-
gle between the walls and the floor and the height of the desk from 
the floor.

Adding and running the instrument interface

1. Start by adding the instrument. For this tutorial we will use a 
Faro Laser Tracker. Use the menu item Instrument>Add or click 
the Add Instrument icon . Navigate the instrument list, se-
lect the FARO Laser Tracker, and then select Add Instrument at 
the bottom of the dialog (Figure 29-93).

  

Figure 29-93. Adding the 
tracker.

2. With the instrument added, let’s run the instrument interface. 
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Simply use Instrument>Run Interface Module and Connect or use the 
Run Instrument Interface icon . Once connected the instru-
ment interface will appear. Now we are ready to mea-
sure!

Establishing Control Points

A good rule of thumb is to always establish a set of control points that 
can be used as a reference. These control points can be used to check 
drift and relocate the instrument.

1. Layout three or more control points in the room.  For our case, 
we secured four SMR nests in various locations in the room.

2. Set the group and target name in the instrument interface so 
the Group is called Control and the Target name is 1.

3. Make sure the correct targeting is selected in the Tracker in-
terface. For our case we are using a 1.5” SMR. To change the 
active target, press and select the respective target (Figure 
29-94).

Figure 29-94. Selecting the 
proper target.

4. To acquire the points, select the Stable Pt. to SA measurement 
profile. By default, Quick Select 2 is set to Stable Pt. to SA.

5. Open the measurement profile parameters . Once opened, 
change the Points value to the number of control points you 
plan to measure (Figure 29-95). In our case we are measuring 
only four points.  When finished press the Save button at the 
top.
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Figure 29-95. Specifying the 
number of points to measure 
in the profile.

6. Measure each of the control points, start the measurement 
mode by pressing the Measure button or F3. The measure dia-
log will prompt you when to move the target and when the 
target should be stable. The target name in the instrument in-
terface will automatically increment after each measurement.

7. Now check the measurements for repeatability. Right-click 
the Control point group and select Add Watch Window. Now 
move the SMR to each nest and note the deviation. The devia-
tions should be extremely low (Figure 29-96). If not, the con-
trol points should be re-measured.

Figure 29-96. The watch 
window.
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 Measuring the Room

Now that a control network is established, let’s move onto measur-
ing the features of the room. We will use measurement modes that 
will create geometry as we measure. This improves the work flow and 
reduces the amount of post analysis. However, feel free to take mea-
surements and then construct the geometry afterwards. Consult the 
Best Fit Geometry from Points tutorial or Geometry Fitting section for 
more information regarding Geometry Fitting.

1. First start by measuring the floor. Measure enough points to 
establish a good plane for the floor. In our case, we measured 
five points. Select the Stable Pt. Plane measurement profile. 
Open the measurement profile parameters, change the num-
ber of points to five, and select the Show Fit Dialog and Send Mea-
sured Points options (Figure 29-97). This way we can review the 
fit and capture the points that created the plane.

Figure 29-97. Changing the 
measurement profile.

2. Set the Group name to Floor and the Target to 1.

3. Measure the floor by starting the measurement mode. The 
stable point acquisition mode will guide you as to when to 
move and will inform you when measuring.  Once the five 
points are measured, the Plane Fit dialog will appear (Figure 
29-98). Review the results and when satisfied press OK.
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Figure 29-98. The Best Fit 
dialog.

4. The plane will be created and automatically offset the correct 
amount and direction. Your SA job should look similar to Fig-
ure 29-99. 

Figure 29-99. After the plane 
is created.

5. A good rule of thumb is to check instrument/part drift as of-
ten as possible. So at this point let’s check to see if we have 
any drift. For these next steps we want the instrument to 
have drifted so we can practice relocating. So to simulate this, 
slightly bump or move the instrument.
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6. Check the Control group by right-clicking the Control point 
group and selecting Add Watch Window. Now move the SMR to 
several of the SMR nests and note the deviation. It should be 
rather large since you bumped the instrument.

7. Now that we have established the need to relocate the instru-
ment, right-click the instrument in the tree and choose Jump 
Instrument to new location. You will be prompted to choose a lo-
cation method, select No Thanks and press OK. A new instru-
ment has been added to the tree and the existing instrument 
has been hidden.

8. Set the Group to Station2 and the Target to 1. Now measure 
the control points using the same method as before.

9. With the control points measured, right-click the second in-
strument in the tree and select Locate. In this dialog select Best-
Fit. You will be prompted to pick the nominal group and the 
measured group. Select the Control point group and the Sta-
tion2 point group, respectively.

10. The best-fit interface will appear (Figure 29-100). Press to 
perform the best-fit computation. Once satisfied with the re-
sult, press Apply Transformation. The new instrument will now 
be located with respect to the first instrument.

Figure 29-100. The plane fit 
dialog.

11. Proceed to measure two walls of the room, naming them 
Wall1 and Wall2. Follow steps 1-3. When finished, your job 
should look similar to Figure 29-101.



929

CHAPTER 29 ■ TUTORIALS

Figure 29-101. All three 
walls are now measured.

12. With the walls and floor measured, let’s scan the top of a desk. 
Select the Spatial Scan measurement profile from the drop-
down. Open the parameters and set the Spatial Increment to 
6 inches. Set the Group name to desktop and the Target to 
1. With the SMR on the surface of the desk, start the mea-
surement mode. By default the measurement mode will stop 
when the beam is broken.

13. Your SA job should look similar to Figure 29-102.

Figure 29-102. After the 
spatial scan.
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Analyzing the data

With the data collected, we can now perform a few basic analysis 
functions. Let’s determine the angle between the walls, the walls and 
floor and the maximum and minimum distance from the floor to the 
top of the desk.

1. To calculate the angle between Wall1 and Wall2, use 
Query>Plane>to Plane: Angle between normals. Select the two mea-
sured planes. Once completed the results will display and an 
SA Event will be created.

2. Now do the same for each wall to the floor using the same 
query command as above.

3. To calculate the maximum and minimum distances from the 
floor to the top of the desk, use Query>Points to>Objects. When 
prompted, select the desktop points and then select the 
Floor_1 plane for the object. A vector group will be generated 
which will later be used in the SA Report.

Reporting the results

With the analysis complete, we can report the results using the SA 
Reporting functionality.

1. Create an SA Report by using Reports>Add SA Report.

2. Orient the graphics so that a screenshot can be taken and 
added to the report.

3. Press to take a screenshot image. This image will now be 
added to the tree. Click and drag the Photo onto the report. 
Place the image so that it is centered at the top of the report.

4. Now drag the three SA Events that were created for the Plane 
to Plane angle query. Click and drag each one onto the SA 
Report.

5. Now drag the vector group onto the SA report. Right-click the 
Vector Group table in the report and select Report Options. Un-
check all the components so that only magnitude is reported.

6. We have now reported our findings. The report will be saved 
in the tree. If desired, the report can be printed or converted 
into PDF format. Use the following icons:

7. Once complete the report should look similar to Figure 29-
103.
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Figure 29-103. The final 
report.
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Basic USMN
 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will cover the basic process for 
performing a USMN network.

 ■ Areas Covered. Unified Spatial Metrology Network.

 ■ Time to Complete. Approximately 15 minutes.

USMN Sample File

1. We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files.   Choose 
the USMN.xit file. This file contains four instruments with 
common measurements (Figure 29-104). The goal is to bring 
all of these instruments into one common network and cre-
ate a point group that represent the network as a whole. Tra-
ditional methods use a best-fit approach, but unfortunately 
error stack-up affects the instrument positions greatly. USMN 
uses instrument uncertainty and advanced optimization al-
gorithms to simultaneously solve for all instrument positions, 
ultimately removing the error stack up and increasing the 
accuracy of the instrument network. When more than two 
instrument locations are present, it is recommended to use 
USMN.

Figure 29-104. Prior to the 
USMN bundle.

2. To start the USMN process, navigate to Analysis>Coordinate 
Uncertainty>Unified Spatial Metrology Network. You will be prompt-
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ed to select the instruments for the USMN network. Select 
the four instruments in the job. The USMN interface will be 
displayed (Figure 29-105), and you will have the controls and 
tools to create and analyze the measurement network. The 
next few steps will walk through this process.

Figure 29-105. The USMN 
dialog.

3. Press the Best-Fit then Solve button. The instrument stations 
will be located to one another first by a best-fit. Their posi-
tions will then be optimized using an uncertainty model for 
each instrument.

4. Now note the Max Error and Ranking of each point (Figure 29-
106). The ranking is an indication of the uncertainty of the 
point error in the network. Typically, points over 100% rank-
ing are removed from the solution.

Figure 29-106. Point details, 
including Max Error and Rank-
ing.

5. Press the Trim Outliers button to remove points that exceed a 
specified ranking (Figure 29-107). In our case, we will remove 
any points over 100%.
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Figure 29-107. Trimming 
outliers.

6. Now press the Solve button to resolve the network for the re-
maining points. Now note the Max error and Ranking values 
(Figure 29-109). The rule of thumb is to only trim outliers one 
time, so we will leave point 10 with its new ranking of 110%.

Figure 29-108. New ranking 
values after outliers have been 
trimmed.

7. Once the outliers have been trimmed, compute the uncer-
tainties of the network by pressing the Begin button under 
the Uncertainty Field Analysis section. Once completed the un-
certainties can now be reviewed (Figure 29-109).
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Figure 29-109. Calculating 
composite point uncertainties.

8. Now apply the results of the USMN. Each of the four instru-
ments should now be aligned (Figure 29-110).

Figure 29-110. After the 
USMN bundle.

9.  A USMN Composite point group will be created. This point 
group will represent the optimized locations of the common 
points and represents the instrument network as a whole. Fig-
ure 29-111 is a close up look at a composite point versus the 
measured points.
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Figure 29-111. The posi-
tion of the USMN composite 
point relative to the measured 
points.

Conclusion

We have learned how to bring multiple instruments into one network 
easily and with more accuracy than best-fit methods alone. For more 
information on USMN, see the USMN section.
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Running Multiple Laser Trackers
 ■ Skill Level. Advanced

 ■ Description. In this tutorial, we will cover how to run two laser 
trackers simultaneously.

 ■ Areas Covered. Adding Instruments, Running Instrument In-
terfaces, IP Addresses, Watch Windows

 ■ Time to Complete. Approximately 30 minutes.

Configuration Requirements

When running multiple instruments simultaneously, network con-
figuration must be considered. For this exercise we will use two laser 
trackers which have different IP addresses. We will configure the PC 
with dual IP address to accommodate. Please refer to the IP Address 
Basics section for more information on setting multiple IP Addresses. 
For this example we used one PC with a network router connecting 
the two instruments to the PC.

Adding the Instruments

1. Select Instrument>Add or the Add Instrument icon . Navigate 
the instrument list and select your Laser Tracker type,   then 
select Add Instrument at the bottom of the dialog.

2. Repeat the above step and add a second Laser Tracker.

3. Now run the instrument interface by selecting Instrument>Run 
Interface Module and select Laser Tracker. The SA Network Brows-
er will appear (Figure 29-112). Select the first laser tracker un-
der your SA file name and press OK. Depending on your laser 
tracker type, you might be prompted to enter the respective 
IP address. If prompted, enter now. Now the instrument inter-
face is up and running for the first instrument.
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Figure 29-112. Selecting 
the appropriate instrument to 
connect to.

4. Repeat the above step for the second laser tracker (Figure 29-
113).

Figure 29-113. Starting a 
second interface.

Common Network

With both instruments running, we will need to bring the instruments 
into a common coordinate system.

1. With the first tracker, measure a set of common points that 
can be seen from both instruments, and name the group ac-
cordingly.

2. Repeat this process for the second instrument.
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3. Now best-fit the second laser tracker to the first laser track-
er. Right-click the second laser tracker in the tree and select 
Locate. Choose Best-Fit and choose the first tracker’s control 
points as the Nominal Group and the second tracker’s control 
points as the Measured group.  Accept the best-fit and now 
the two laser trackers are located to one another (Figure 29-
114).

Figure 29-114. Fitting the 
two instruments together.

Working with both instruments simultaneously

To demonstrate working with multiple instruments simultaneously, 
let’s measure a plane and then watch the deviation of the plane with 
both laser trackers.

1. Measure points on the floor with one of the laser trackers.

2. Create a plane from the measured points.

3. Now add a watch window using View>Watch Window>Add Point 
to>Objects. Select the first laser tracker and then select the 
plane. Accept the default projection options.
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Figure 29-115. Watching 
two entities simultaneously.

4. Repeat step 3 for the second laser tracker (Figure 29-115).

5. Now we are monitoring the deviation with one single object 
using two instruments.



CH
A

PT
ER 30

941

What Is OPC?
OPC is an acronym that originally stood for “OLE for Process Control”, 
but has since been renamed to “Open Platform Communications”. It 
is a standard originally developed in 1996 to enable communication 
of real-time factory data between various hardware devices and soft-
ware applications from different manufacturers.

OPC as a communication standard enables various devices in a man-
ufacturing environment to communicate among themselves—for 
instance, allowing real-time measurement data to be monitored by 
other hardware, or to track part progress through an assembly line in 
a real-time database.

SA & OPC
The OPC DA (Data Access) server functionality is available in SA Ulti-
mate (64-bit only). SA’s implementation is based on version 2.05 of 
the OPC DA specification. Any client that complies with this specifica-
tion can communicate with SA’s server—that is, that client has the 
ability to read from and write to SA’s OPC server.

SA supports the OPC standard, enabling a wide-variety 
of possibilities for real-time communication between it-
self and other applications or process control hardware. 
This chapter discusses the capabilities and use of this 
interface.

The OPC 
Interface
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Prerequisites
In order to activate and use the OPC DA server in SA, the following 
prerequisites must be satisfied:

 ■ The OPC Core Components Redistributable (x64) 3.0 package 
must be installed on the system,

 ■ 64-bit SA Ultimate must be installed,

 ■ SA’s OPC server must be registered and enabled, and

 ■ The OPC server DCOM and network settings must be config-
ured for remote client access.

The OPC Foundation (http://www.opcfoundation.org) provides a 
compliance test client for the data access 2.05 specifications to all of 
its members. A sample client which can be used to try out new SA 
functionality can be downloaded for free from one of the following 
websites:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

Configuring the OPC Server

Step 1: Creating a DCOM User

Windows 7 Home Premium

1. Login to Windows 7 under an administrator account.

2. Under the Windows Control Panel > User Accounts, select 
Manage another account. Then click Create a new account.

3. Add a new administrative user OPCUser, password nrkopc.

Windows 7 Professional
1. Under the Windows Control Panel, select Administrative Tools, 

then select Computer Management.

2. Expand the Local Users and Groups item in the tree.

3. Right-click Users and select New User... from the context menu.

4. Enter OPCUser for the User Name and nrkopc for the pass-
word. Enter a description as well (Figure 30-1).

5. Click Create, then Close.

 zTip: It is recommended that you 
create a system restore point prior to 
changing the system configuration.

 XNote: For Windows 7 Home Premium, 
this must be an administrator account.

http://www.opcfoundation.org
http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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6. Add the new user to the Distributed COM Users group 
(Figure 30-2).

Step 2: Disable Windows Firewall

1. Under Windows Control Panel, select Windows Firewall.

2. From the sidebar, select Turn Windows Firewall On or Off.

3. Select the turn off Windows Firewall (not recommended) op-
tion.

Figure 30-1. Setting up an 
OPC user account.

Figure 30-2. Making the 
new user a member of the 
Distributed COM Users 
group.

Step 3: Adjust User Account Control Settings

1. As administrator, type uac in the start menu.

2. Set the UAC to never notify, then click OK.
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3. Restart the computer.

Step 4: Install SA

1. Log into the OPCUser account.

2. Install SA as usual.

3. If SA automatically starts at the end of the install, close it.

Step 5: Install OPC Core Components

1. Run the OPC Server Utility (C:\Program Files (x86)\New 
River Kinematics\SpatialAnalyzer <version>\
x64\OpcServerUtility.exe).

2. If the core components are missing on your system, the utility 
will notify you—continue with the following. Otherwise, skip 
to step 6.

3. To install the missing components, you download the OPC 
Core Components Redistributable (x64) package from the 
OPC Foundation website (https://opcfoundation.org/).

4. After installing the core components, restart your computer.

Step 6: Register the NRK OPC DA Server

1. Login to the OPCUser account.

2. Ensure SA is not running, then run the OPC Server Utility (see 
Step 5, item 1).

3. Click the Register SA OPC Server button.

Step 7: Enable the OPC Server in the SA Configuration

1. Run SA Ultimate (x64) or greater.

2. In SA’s User Options dialog, select the Machine Configuration 
tab.

3. Turn on the enable OpC Server option. The server will now run 
in the future whenever SA is running.

Step 8: Test the Server with a Local Client

1. Install a client onto the machine. For instance:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

2. Start the client application.

https://opcfoundation.org/
http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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3. Verify that the NRK OPC DA Server is presented in the list of 
local v2 data acess servers.

4. Connect to the SA OPC server and browse its tags.

5. Add items to the client’s group and verify that data is updat-
ing as appropriate.

6. Once proper local operation is verified, close the local OPC cli-
ent and SA Ultimate before continuing on.

Step 9: Configuring System-wide DCOM Settings

1. Ensure you’re logged in as OPCUser.

2. Run the OPC Server Utility (step 5, item 1).

3. Click the View DCOM Configuration button.

4. Right-click on My Computer and select Properties from the 
context menu.

5. In the Default Properties tab, ensure that the enable distributed 
COM on this computer option is enabled. The Default Authenti-
cation Level should be set to Connect, and the Default Imperson-
ation Level should be set to identify (Figure 30-3).

Figure 30-3. Setting the 
computer’s default compo-
nent services properties.

6. Select the COM Security tab. Click the Edit Default... button in 
the Access Permissions group.

7. In the Access Permission dialog, add permission for Every-
one and the ANONYMOUS LOGON users, then click OK.

8. Click the Edit Limits... button in the Access Permissions group.

 XNote: At least one tag (NRK SA Ver-
sion) is always available in the OPC 
server’s address space. If you add an 
instrument to your job file, SA automati-
cally adds the instrument’s coordinates 
to the address space.

 XNote: Both of these are required for 
OPC functionality.
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9. In the Access Permission dialog, add permission for Every-
one and the ANONYMOUS LOGON users, then click OK.

10. Click the Edit Default... button in the Launch and Activation Per-
missions group.

11. In the Launch and Activation Permission dialog, add permis-
sion for Everyone and the ANONYMOUS LOGON users, then 
click OK.

12. Click OK again to close the My Computer Properties dialog.

Step 10: Configure the OPC Server’s Specific DCOM Settings

1. In the Component Services window, open the properties of 
the NRK SA OPC DA Server (Figure 30-4).

Figure 30-4. Opening the 
properties for the NRK SA OPC 
DA Server component.

 

2. In the General tab, set the Authentication Level to default.

3. Verify that the Security tab’s Launch and Activation Permissions 
are set as indicated in Figure 30-5 (no launch is allowed).

Figure 30-5. Settings for the 
Security tab.

4. Verify that the Security tab’s Access Permissions are set as indi-
cated in Figure 30-6.

 XNote: Do not adjust system-wide 
COM security Launch and Activation 
permissions limits (the Edit Limits... 
button).

 XNote: The OPC clients are not allowed 
to launch SA. For this purpose the Local 
Path parameter is not configured and 
the Location tab’s parameters are not set.
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Figure 30-6. The Security 
tab’s Access Permissions.

5. In the Endpoints tab, verify that DCOM Protocols and Endpoints 
are set to defaults (the default is TCP/IP).

6. Set the Identity to interactive User to allow displaying of the SA 
GUI elements on the server side.

Refer to the following section to configure the client side.

Configuring the OPC Client

Step 1: Create an OPC User Account & Install Components

1. Follow the instructions described in  “Step 1: Creating a DCOM 
User” on page 942.

2. Follow the instructions described in “Step 5: Install OPC Core 
Components” on page 944.

Step 2: Configure System-Wide DCOM Settings

1. Ensure you’re logged in as OPCUser.

2. Run the OPC Server Utility (step 5, item 1).

3. Click the View DCOM Configuration button.

4. Right-click on My Computer and select Properties from the 
context menu.
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5. In the Default Properties tab, ensure that the enable distributed 
COM on this computer option is enabled. The Default Authenti-
cation Level should be set to Connect, and the Default Imperson-
ation Level should be set to identify (Figure 30-3).

6. Select the COM Security tab. Click the Edit Limits... button in the 
Access Permissions group.

7. In the Access Permission dialog, add permission for Every-
one and the ANONYMOUS LOGON users, then click OK.

8. Click the Edit Limits... button in the Launch and Activation Per-
missions group.

9. In the Launch and Activation Permission dialog, add permis-
sions for Everyone, Distributed COM Users, and ANONY-
MOUS LOGON, then click OK.

Step 3: Test the OPC Server Connection

1. Restart the computer.

2. Install a client onto the machine. For instance:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

3. Start the client application.

4. Browse the remote OPC server to verify that data is being re-
ceived.

Using SA’s OPC Server
Once the server is up and running, the server’s identifications (class 
ID, description, and program ID) are displayed in the client (Figure 30-
7).

Figure 30-7. The SA OPC DA 
server identifications.

The following parameters are available to the OPC server:

 ■ Active coordinate values for each live instrument as a 3-entry 
array of doubles (XYZ).

 ■ Active coordinate values for each live instrument as separate 
values (X, Y, and Z).

 ■ The current SA version.

 ■ The full name of each instrument.

http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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The tag name for each coordinate includes the collection and instru-
ment ID for the associated instrument—for example, A::0.x (Figure 
30-8).

Figure 30-8. Tags for single-
coordinate items in the OPC 
server.

Point coordinates are presented with A::0.xyz tag names in the array 
format (Figure 30-9):

Figure 30-9. A coordinate as 
an array.

MP Support

Measurement Plan commands have been added to support interfac-
ing with SA’s OPC server—both setting and retrieving values from the 
server’s address space. These commands include:

 ■ Set OPC DA Tag Value Double

 ■ Get OPC DA Tag Value Double

 ■ Set OPC DA Tag Value Integer

 ■ Get OPC DA Tag Value Integer

These commands are detailed in the MP Command Reference. The 
“set” commands will create a double or integer in the server’s address 
space under the specified tag name. This value can be retrieved from 
the address space using the corresponding “get” command, or can be 
updated (overwritten) by specifying another “set” command.
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The following page is a list of default keyboard short-
cuts that ship with SpatialAnalyzer. To become a more 
efficient user of SA, it is recommended that you try to 
become familiar with as many of these shortcuts as 
possible.

Keyboard 
Shortcuts



Action Shortcut

Rotate (Orbit)   (Drag)

Zoom In/Out

Pg Up/Pg Dn

 Scroll Up/Down

Ctrl +  + Drag Up/Down

Pan
   

Shift +  (Drag)

Recenter View  (Click to Center)

Zoom to Selection  + Drag Rectangle

Autoscale Alt+A

Clipping Planes Alt+X

Previous View Ctrl + Alt + 

Next View Ctrl + Alt + 

Graphical View

Action Shortcut

Fit Geometry Ctrl + G

Fit Line Ctrl + Alt + L

Fit Circle Ctrl + Alt + C

Fit Plane Ctrl + Alt + P

Fit Cylinder Ctrl + Alt + Y

Fit Sphere Ctrl + Alt + S

Geometry Fit
Action Shortcut

Add Instrument Alt + I

Point at a Point  (Double-click on point)

Instruments

Action Shortcut

Point to Point Ctrl + D

Group to Group Ctrl + W

Queries

Action Shortcut

Best Fit Points to Points Ctrl + B

USMN Alt + U

Analysis

Action Shortcut

Construct Points Ctrl + P

Layout Random Points Ctrl + Alt + Z

Patch Normal Shift Ctrl + M

Construct Line 2 Points Ctrl + L

Geometry Construction

Action Shortcut

Repeat Command Ctrl + Tab

Command History Ctrl + Shift + Tab

Graphical Selection Mode F3 (During Selection)

List Selection F2

Undo to Restore Point Ctrl + Z

Create Restore Point Alt + Space

Pick Working Frame Alt + W

User Options Ctrl + U

General

Action Shortcut

Open File Ctrl + O

Save File Ctrl + S

File

Action Shortcut

Show Point Labels Alt + L

Hover Ctrl + H

Cloud Display Control Ctrl + T

Refresh F5

View

Action Shortcut

Object Properties Alt + Q

Copy then Transform Ctrl + C

Delete Objects Delete

Delete Points Alt + D

Add User Note Ctrl + N

Edit

KEYBOARD SHORTCUTS
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Linear Least Squares Adjustment
Least squares is a procedure for adjusting observations containing 
random errors. It was developed in the latter part of the eighteenth 
century by Karl Gauss. It was not used much until computers became 
commonplace because of the lengthy calculations required. Spati-
alAnalyzer uses it in many routines (transformations, best-fit lines-
planes-circles etc), to provide the best and most consistent answer 
for fitting problems.

For a group of equally weighted observations (or measurements in 
our case), the basic condition that is enforced in least squares adjust-
ments is that the sum of the squares of the residuals is minimized. 
Residual is another term for the difference between a measured value 
and its most probable (or “correct”) value. For 3D coordinate metrol-
ogy, one example of a residual would be the difference between the 
true X-coordinate for a point and the actual X-coordinate measure-
ment.

The method of least squares is a criterion for fitting a specified model 
to observed data. In this case, the specified model is the reference set 

Although not at all essential to get benefit out of the 
software, this section provides background knowledge 
on some of the math behind SpatialAnalyzer.

Math Reference
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of points (or expected values), and the observed data are typically 
your measurements of the reference set of points. Let’s use a common 
use of the least squares adjustment as an example. The least squares 
line routine is a commonly used method for computing the best-fit 
line from a series of measurements of a linear function. The distance 
your car travels when you’re driving at a particular speed is an ex-
ample of a linear function. In this example, you are trying to drive 
your car at a constant speed and measure how far you have gone and 
the time it took you to get there. While driving, it is likely that a little 
error is going to creep into the process—you’re not going to be able 
to . That error is generally referred to as random error. Least squares 
adjustment techniques are really good at dealing with this type of 
error and are able to produce a reasonable and consistent answer in 
spite of it. An example is shown in the figures. The time is plotted on 
the X-axis and the distance on the Y-axis.

The points are the paired measurements made of time verses the dis-
tance traveled, which is linear in this case because you were trying to 
maintain a constant speed. To find what is considered the “best line” 
through the data the least squares line routine is used. In this case, 
the residual that gets minimized is the difference (squared) from a 
measured point to the line that best describes the distance you trav-
eled verses the time it took. The least squares line routine will find 
a line, such that the sum of the distances (squared) from the data 
points to the line is the minimized. The figure shows a line that best 
fits those points; it was solved for with the best-fit line routine in Spa-
tialAnalyzer.

The slope of the best-fit line is actually the average speed that you 
traveled on your trip. This line is the most consistent way of determin-
ing where you probably where at any point in time during your trip.

The least square line adjustment was able to use this set of measure-
ments even through each point had some error, and it produced a 
high-quality and reliable answer. This ability of dealing with measure-
ments that have at least some component of random error and still 
being able to produce consistent and representative answers is why 
the technique is used in SpatialAnalyzer.

Basics of Spatial Transformations
Homogeneous transformations—transforms for short—can be used 
to represent the position and orientation of one coordinate frame 
(system) with respect to another coordinate frame. A general trans-
formation matrix can be conveniently represented as a four by four 
matrix; however, only twelve of the sixteen numbers are typically 
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used in this application1. This representation is unique—i.e., there 
is only one transformation matrix that unambiguously describes a 
particular relative position and orientation. The problem with repre-
senting all transforms as a matrix is that this representation is over-
constrained. We know, for example, that a rigid object in space has 
only six degrees-of-freedom—three positional and three rotational. 
You simply don’t need all twelve numbers in the 4x4 matrix to rep-
resent the relative position and orientation. Let’s look at other more 
compact representations.

First of all, we need to define which coordinate frame is described 
relative to the other. Let’s assume we have frames A and B, and that 
we wish to describe frame B relative to A (Figure B-1).

Figure B-1. Two coordinate 
frames in space.

x

z

y

x

z
y

A B

Position is easy—we simply describe the x, y, and z components of 
the origin of B. Note these terms are the distances along the x, y, and 
z axes of frame A. Also note the position of A relative to B would not, 
in general, be the negative of these values. (This would only be the 
case if the corresponding axes for the two frames were all parallel). 
Rotation is not as easy as position. To describe rotations, certain stan-
dard conventions have been adopted. These are by no means the 
only possible methods. The following sections will discuss different 
viewpoints that are commonly used to discuss transforms, then we 
will discuss simple unit rotations, and go on to develop compound 
rotation methods.

The old viewpoint debate: Are we describing or transforming?

This section only becomes necessary because of the language that 
individuals use to discuss transforms. This is one of the most common 
sources of errors in dealing with spatial transformations. Transforms 
can be used in two different ways:

 ■ As a descriptor. This is the way we will always talk about trans-
forms in SpatialAnalyzer. This is the description of one frame 

1 The four-by-four matrix is typically used because it is symmet-
ric. Numerical routines can generally be made more efficient when 
the numerical pieces are symmetric.
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relative to another. For example, frame B relative to frame A.

 ■ As a transform operator. In this case we ask the question: 
what operations we do to frame A to rotate and translate it to 
the position and orientation of B? In some cases, it’s natural to 
think about transforms in this way. For example, if you want to 
describe the position of a box as it moves, it’s natural to think 
about the rotations and translations that it is subjected to over 
time.

The final result is a little counter-intuitive—but essentially, it doesn’t 
matter which view point you use—they both produce the exact same 
results. You just need to be aware of the fact that despite the language 
used, the math is the same. Many people incorrectly interpret one as 
the inverse of the other.

Unit Rotation Matrices

Before we can discuss compound rotations, we need to develop the 
building blocks of unit rotations. These are simply rotations that oc-
cur about any given principal coordinate axis (X, Y, or Z). They are as 
follows:

Rx(θ) =




1 0 0
0 cos θ − sin θ
0 sin θ cos θ


 Ry(θ) =




cos θ 0 sin θ
0 1 0

− sin θ 0 cos θ


 Rz(θ) =




cos θ − sin θ 0
sin θ cos θ 0

0 0 1




Or, for the particular example of an X rotation of 30°, a Y rotation of 
60°, and a Z rotation of 90°:

Rx(30◦) =




1 0 0
0 0.866 −0.500
0 0.500 0.866


 Ry(60◦) =




0.500 0 0.866
0 1 0

−0.866 0 0.500


 Rz(90◦) =




0 −1 0
1 0 0
0 0 1




Compound Rotations

Using the building blocks of the above unit rotations, we can now 
proceed to develop more complex compound rotations. As we stated 
earlier, a rotation matrix is unique. However, the descriptive methods 
we often use to describe a rotation are not. The same physical orien-
tation can be described in an infinite number of ways. We’ll explore 
the most common below.

Fixed Angle XYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the X-axis of A (XA), then about the Y-axis of A 
(YA), then about the Z-axis of A (ZA). We can express this as:

Rxyz(30◦, 60◦, 90◦) = Rz(90◦)Ry(60◦)Rx(30◦) =




0.000 −0.866 0.500
0.500 0.433 0.750
−0.866 0.250 0.433
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Fixed Angle ZYX
In this case, we again start with frame A and B coincident. We then ro-
tate frame B about the Z-axis of A (ZA), then about the Y-axis of A (YA), 
then about the X-axis of A (XA). We can express this as:

Rzyx(90◦, 60◦, 30◦) = Rx(30◦)Ry(60◦)Rz(90◦) =




0.000 −0.500 0.866
0.866 −0.433 −0.250
0.500 0.750 0.433




Euler Angle XYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the X-axis of B (XB), then about the Y-axis of B 
(YB), then about the Z-axis of B (ZB). Note that the axes of frame B ro-
tate during the operations. We can express this as:

Rx′y′z′(30◦, 60◦, 90◦) = Rx(30◦)Ry(60◦)Rz(90◦) =




0.000 −0.500 0.866
0.866 −0.433 −0.250
0.500 0.750 0.433




Euler Angle ZYX
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the Z-axis of B (ZB), then about the Y-axis of B 
(YB), then about the X-axis of B (XB). Note that the axes of frame B ro-
tate during the operations. We can express this as:

Rz′y′x′(90◦, 60◦, 30◦) = Rz(90◦)Ry(60◦)Rx(30◦) =




0.000 −0.866 0.500
0.500 0.433 0.750
−0.866 0.250 0.433




Euler Angle ZYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the Z-axis of B (ZB), then about the Y-axis of B 
(YB), then again about the Z-axis of B (ZB). Note that the axes of frame 
B rotate during the operations. We can express this as:

Rz′y′z′(90◦, 60◦, 90◦) = Rz(90◦)Ry(60◦)Rz(90◦) =



−1 0 0
0 −0.500 0.866
0 0.866 0.500




Equivalent Angle Axis
This representation is a little different from the others given in that 
it does not result from the combination of unit rotations. This con-
vention stems from the fact that for any given rotation there exists a 
unique axis of rotation and magnitude of rotation. If we rotate about 
a unit vector K and amount θ we find that the following matrix results:

R(K, θ) =




KxKxvθ + cos θ KxKyvθ − Kz sin θ KxKzvθ + Ky sin θ
KxKyvθ + Kz sin θ KyKyvθ + cos θ KyKzvθ − Kx sin θ
KxKzvθ − Ky sin θ KzKyvθ + Kx sin θ KzKzvθ + cos θ




where vθ = (1 − cos θ) and Kx, Ky, Kz are the components of unit vector 
K. Through an inverse analysis we can extract the (K, θ) for any rota-
tion matrix.
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Quaternions (also known as Euler Parameters)
A Quaternion is simply another way of expressing the information 
that is inherent in the equivalent angle-axis representation. Namely,

ε1 = Kx sin

(
θ

2

)
ε2 = Ky sin

(
θ

2

)
ε3 = Kz sin

(
θ

2

)
ε4 = cos

(
θ

2

)
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SOFTWARE LICENSE AGREEMENT OF NEW RIVER KINEMATICS, INC. 
(“MANUFACTURER”) 

NOTICE-- READ BEFORE INSTALLING THIS PACKAGE

CAREFULLY READ THE TERMS AND CONDITIONS OF THIS AGREEMENT 
BEFORE INSTALLING THIS PACKAGE. INSTALLING THIS PACKAGE IN-
DICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. 
IF YOU DO NOT AGREE WITH THE TERMS AND CONDITIONS OF THIS 
AGREEMENT, PROMPTLY RETURN THIS PACKAGE TO THE PLACE OF 
PURCHASE FOR REFUND IN THE AMOUNT YOU PAID.

THIS AGREEMENT, entered into by and between NEW RIVER KINEMAT-
ICS, INC. (‘’Licensor’’), a Virginia corporation having principal offices 
at 436 McLaws Circle,  Williamsburg, Virginia 23185, and the under-
signed customer (‘’Licensee’’) determines, the rights and licenses 
granted to Licensee in the Licensed Software (hereinafter defined) 
supplied by the Licensor.

Definitions
As used in this agreement, the following definitions, not in alphabeti-
cal order, apply:

 ■ Activated Software. Software for which Licensee has paid ap-
plicable license fees and charges and for which Licensor has 
delivered a Security Device.

 ■ Effective Date. Date of execution of this Agreement by Licens-
ee or in the absence of any other ascertainable date or, at the 
option of Licensor, means the date of installation of the Soft-
ware by Licensee.

 ■ Licensed Software or Software. Licensor’s software, selected 
by Licensee, in executable code only, as licensed under this 
Agreement.

 ■ Licensed Documentation. means all the documentation, in 
printed or electronic form, that is delivered from Licensor to 
Licensee and related to the Licensed Software.

End User License 
Agreement
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 ■ Licensed Product. Licensed Software and the Licensed Doc-
umentation, collectively, including the Security Device when 
provided by Licensor with Activated Software.

 ■ Maintenance Fees. Fees payable for Software Maintenance of 
Activated Software. 

 ■ Security Device. Device issued by Licensor and licensed to 
Licensee to enable Licensee’s Use of Activated Software to 
achieve functionality for which Licensee has paid Licensor ap-
plicable license fees and charges.

 ■ Software Maintenance. Corrections, revisions, patches, ser-
vice packs, updates, and subsequent releases of the Licensed 
Product made available by Licensor from time to time.

 ■ Unactivated Software. Software for which no license fees and 
charges have been paid by Licensee and for which no Secu-
rity Device has been issued, thus limiting authorized use of the 
Software to Viewer Mode.

 ■ Use. Licensee’s right to install, use, access, run, or otherwise 
read the Software into and out of memory in strict accor-
dance with the Licensed Documentation and all the terms of 
this license granted from Licensor to Licensee pursuant to this 
Agreement.

 ■ Viewer Mode. Use of Software only for purposes of evaluating 
the Software or viewing a file or other work product not cre-
ated by the Unactivated Software.

License Grant
Subject to the payment of the license fees and charges to Licensor, 
Licensor grants to Licensee a limited, nonexclusive and nontransfer-
able license for Use of the Licensed Product during the Agreement’s 
term defined in Section 4. Licensee agrees that it has no right, power 
or authority to make any modifications to or unauthorized copies of 
the Licensed Product.

At Licensor’s request upon the expiration or other termination of Li-
censee’s authorized Use of the Software, Licensee will return to Licen-
sor all Licensed Documentation, including the Security Device.
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License Fees, Charges and Taxes
Licensee shall pay Licensor’s license fees and charges for the Licensed 
Product in effect at the time of Licensee’s acceptance of this Agree-
ment.  No license fees and charges apply when the Licensed Software 
is Unactivated Software.

The license fees and charges, taxes and other applicable charges are 
due and payable upon installation of the Activated Software unless 
separate arrangements for deferred payment are made with Licensor 
prior to installation.

Term
Unless otherwise terminated or cancelled as provided by this Agree-
ment, the term of Licensee’s Use of Activated Software shall com-
mence upon first Use of the Software and shall continue for five (5) 
years from the most recent version of Activated Software delivered to 
Licensee.  Licensee acknowledges that if Licensee at any time fails to 
extend the term of Software Maintenance by payment of applicable 
Maintenance Fees, no versions of Activated Software will be obtained 
following the expiration of the latest period for which Software Main-
tenance has been purchased.  Notwithstanding the foregoing, Licen-
sor will have the right prior to the end of any term for which Software 
Maintenance has been purchased to notify Licensee that Licensor will 
not provide Software Maintenance after that term, and in that event, 
the term of Licensee’s Use of Activated Software will extend five years 
from the date of the latest version of Activated Software delivered 
to Licensee prior to expiration of the then term of Software Mainte-
nance.

Unless otherwise terminated or cancelled, the Term of Licensee’s Use 
of Unactivated Software is five (5) years from the date of first Use of 
Unactivated Software.

Protection of Licensed Product
Licensee acknowledges and agrees that the Licensed Product and 
all permitted copies are Licensor’s exclusive property and a valuable 
trade secret of Licensor. Licensee will not disclose or make available 
to third parties the Licensed Product or any portion or any informa-
tion from Licensor marked ‘’confidential’’ without Licensor’s prior 
written approval. Licensor reserves title to, ownership of, and all pro-
prietary rights to the Licensed Product, as well as any related work 
product and major or minor releases of the Software, if any. Licensee 
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shall promptly and in good faith take all action reasonably necessary, 
advisable, or requested by Licensor to assure compliance with this 
Section 5 by all employees and agents of Licensee.

Upon reasonable notice during the Agreement’s term and within six 
(6) months after termination or expiration of the Agreement, Licen-
sor may arrange for the inspection and review of Licensee’s computer 
systems to assure compliance with all terms and provisions of this 
Agreement during Licensee’s normal business hours and in such a 
manner as not to interfere unreasonably with Licensee’s operations. 
In the event such audit discloses that the number of permitted cop-
ies has been exceeded, Licensee shall promptly pay to Licensor the 
appropriate license fees and charges for the additional computers or 
users.

Prohibited Uses
Licensee shall not:

 ■ At any one time, use, share, or use concurrently more than 
one installation or copy of the Software on any one computer, 
including but not limited to a workstation, terminal, or other 
digital electronic device, except that Unactivated Software is 
not subject to such restrictions;

 ■ Modify, translate, reverse engineer, decompile, disassemble, 
reduce the Software to a humanly perceivable form, or create 
derivative works based upon the Licensed Product, or cause or 
permit another to do so;

 ■ Remove any proprietary notices, labels, copyright marks, or 
trademarks on the Licensed Product;

 ■ Modify, adapt, rent, lease, commercially host, sublicense, redis-
tribute, or lend the Software;

 ■ Copy or attempt to copy the Software for any purpose whatso-
ever, except as expressly permitted by the terms of this Agree-
ment.

 ■ Attempt to access or use Activated Software, except by means 
of the Security Device licensed by Licensor to Licensee.

 ■ Attempt to alter, modify, reprogram or otherwise tamper with 
any Security Device issued by Licensor, regardless of whether 
the Security Device has been licensed to Licensee.
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Support Services and Updates
For Activated Software Licensor will provide Licensee with all Soft-
ware Maintenance  made available by Licensor for the Software dur-
ing the period of time for which Licensee has purchased and paid 
for Software Maintenance.  Initially, Licensor will provide Licensee 
Software Maintenance through the expiration date of the Security 
Device first provided by Licensor to enable functionality of the Ac-
tivated Software.  Subject to the provisions of Section 4, Licensee’s 
right to receive Software Maintenance can be extended for succeed-
ing periods of time upon payment of then applicable Maintenance 
Fees. If Licensee allows Software Maintenance to lapse, Licensor may, 
but need not, reinstate and continue Software Maintenance upon Li-
censee’s payment of any and all Maintenance Fees for the period or 
periods of time during which Software Maintenance lapsed, plus a re-
instatement fee of 25% of such previously unpaid Maintenance Fees.

As part of Software Maintenance purchased by Licensee, Licensor 
shall provide support services to attempt to correct any error, mal-
function or defect in the Activated Software’s functionality or provide 
an alternative process, provided that Licensee gives Licensor prompt 
notice of the problem and sufficient information to either diagnose 
or recreate such problems. Licensee acknowledges that the Licensed 
Software is complex and may not be error free and that all errors, if 
any, may not be correctable or avoidable.

Warranty
Licensor warrants that, for a period of sixty (60) days after delivery the 
Licensed Product to Licensee:

 ■ Under normal Use and service, the media on which the Li-
censed Software is delivered (if so delivered otherwise than 
electronically) shall be free from defects in material and work-
manship, and

 ■ The Licensed Product will meet Licensor’s then current pub-
lished specifications for the Software.

If If the Licensed Product fails to meet the media warranty of Para-
graph 9(a)(1) and Licensee gives Licensor written notice thereof dur-
ing the applicable warranty period, Licensor shall replace such media. 
If the Licensed Product fails to meet the warranty of Paragraph 9(a)(2) 
and Licensee gives Licensor written notice thereof during the appli-
cable warranty period, Licensor’s sole obligation shall be to provide 
technical services to attempt to correct the failure, provided that Li-
censee gives Licensor detailed information regarding the failure and 
Licensor is able to duplicate or view the same. Licensee acknowledg-
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es that the Licensed Product is complex, may not be error free, and 
that all errors, if any, may not be correctable or avoidable.

EXCEPT AND TO THE EXTENT EXPRESSLY PROVIDED IN PARAGRAPH 
9 AND IN LIEU OF ALL OTHER WARRANTIES, THERE ARE NO WARRAN-
TIES, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY 
WARRANTIES OF MERCHANTABILITY, INFORMATIONAL CONTENT, 
FITNESS FOR A PARTICULAR PURPOSE OR SYSTEM INTEGRATION, OR 
NON-INFRINGEMENT OF THIRD PARTY RIGHTS RELATING TO THE LI-
CENSED PRODUCT. Some jurisdictions do not permit the exclusion of 
implied warranties or limitations on applicable statutory rights of the 
consumer, and, as such, some portion of the above limitation may not 
apply to Licensee. In such jurisdictions, Licensor’s liability is limited to 
the greatest extent permitted by law.

Licensee shall be solely responsible for the selection, Use, efficiency, 
and suitability of the Licensed Product and Licensor shall have no li-
ability thereof.

The warranty provision of this Paragraph 9 do not apply if the Soft-
ware has been subject to modification by other than Licensor or on 
Licensor’s instruction, has not been installed, operated, repaired, or 
maintained in accordance with instructions supplied by Licensor, is 
subject to accident or abuse, or is used in ultra hazardous activities.

Licensor warrants that the Software is date compliant. The duration 
of this warranty and remedies available to the Licensee for breach of 
this warranty shall be limited to repair or replacement of the Software 
where such non-compliance is discovered and made known to Licen-
sor in writing within ninety (90) days after acceptance. Nothing in this 
warranty shall be construed to limit any rights or remedies Licensee 
may otherwise have under this Agreement with respect to other de-
fects.

Despite any other provision hereof to the contrary, Licensor’s liability 
of any kind shall never exceed the amount of the license fees, charges 
and taxes described in Section 3, and the Licensor’s liability expressly 
excludes incidental or consequential damages to Licensee, including 
lost profits, even if Licensor is on notice of, and has express knowl-
edge of, the potential loss or damage.

Despite any other provision hereof to the contrary “UNACTIVATED 
SOFTWARE”, AS HEREIN DEFINED, IS SUBJECT TO NO WARRANTY, 
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY WAR-
RANTIES OF MERCHANTABILITY, INFORMATIONAL CONTENT, FITNESS 
FOR A PARTICULAR PURPOSE OR SYSTEM INTEGRATION, OR NON-
INFRINGEMENT OF THIRD PARTY RIGHTS RELATING TO THE LICENSED 
PRODUCT.
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Negation of Proprietary Rights Indemnity

THERE IS NO WARRANTY AGAINST INTERFERENCE WITH LICENSEE’S 
QUIET ENJOYMENT OF THE LICENSED PRODUCT OR AGAINST IN-
FRINGEMENT, AND LICENSOR HAS NO LIABILITY TO LICENSEE FOR THE 
INFRINGEMENT OF PROPRIETARY RIGHTS BY THE LICENSED PRODUCT 
OR ANY PORTION THEREOF.

Termination/Cancellation
Licensor has the right to terminate or cancel this Agreement in accor-
dance with other provisions of this Agreement and also if:

 ■ Licensee fails to pay Licensor any license fee or charges when 
due; or

 ■ Licensee is in default of any other provision hereof and such 
default has not been cured within ten (10) days after Licensor 
learns of the default and gives Licensee written notice thereof; 
or

 ■ Licensee becomes insolvent or seeks protection, voluntarily or 
involuntarily, under any bankruptcy law; or

 ■ Licensee attempts to assign or sublicense its rights under this 
license.

In the event of any termination or cancellation, Licensor may:

 ■ Declare all amounts owed hereunder to Licensor to be imme-
diately due and payable;

 ■ Require that Licensee cease any further use of the Licensed 
Product or any portion thereof and immediately destroy, erase 
from any temporary RAM and permanent memory, and return 
to Licensor all copies of the Licensed Product, including the 
Security Device; Upon Licensor’s request, an authorized repre-
sentative of Licensee shall provide a written certification that 
warrants compliance with this requirement.

 ■ Cease performance of all of Licensor’s obligations hereunder 
without liability to Licensee; and

 ■ Electronically render the Software of no further Use by Licens-
ee. 

UPON ANY TERMINATION, EXPIRATION, OR CANCELLATION OF THIS 
AGREEMENT, DUE TO BREACH OR OTHERWISE, LICENSOR SHALL IN 
ALL EVENTS HAVE ALL RIGHTS, POWER AND AUTHORITY TO EXERCISE 
ELECTRONIC SELF-HELP AND TO EXERCISE ALL RIGHTS, REMEDIES 
AND RECOURSE TO WHICH IT MAY BE ENTITLED, WHICH SELF-HELP 
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SHALL INCLUDE WITHOUT LIMITATION, ALL ELECTRONIC MEANS 
AVAILABLE TO LICENSOR.

Limitation of Liability
IN NO EVENT SHALL LICENSOR BE LIABLE TO LICENSEE FOR ANY INDI-
RECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY 
KIND, REGARDLESS OF THE FORM OF THE ACTION, ARISING OUT OF 
OR RELATED TO THIS LICENSE AGREEMENT OR THE PERFORMANCE OR 
BREACH THEREOF, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POS-
SIBILITY THEREOF. LICENSOR’S LIABILITY TO LICENSEE HEREUNDER, IF 
ANY, SHALL IN NO EVENT EXCEED THE TOTAL OF THE LICENSE FEES 
PAID TO LICENSOR HEREUNDER BY LICENSEE.  IN NO EVENT SHALL 
LICENSOR BE LIABLE TO LICENSEE FOR ANY DAMAGES RESULTING 
FROM OR RELATED TO ANY FAILURE OF THE SOFTWARE PRODUCTS, 
INCLUDING, BUT NOT LIMITED TO, LOST DATA TIME, PROFITS, DELIV-
ERY DELAY OR LICENSOR’S PERFORMANCE OF SERVICES UNDER THIS 
LICENSE AGREEMENT. SOME JURISDICTIONS DO NOT ALLOW THE 
LIMITATION OF LIABILITY FOR PERSONAL INJURY, OR OF INCIDENTAL 
OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION MAY NOT APPLI-
CABLE TO LICENSEE. Some jurisdictions do not permit the exclusion 
of limitation of liability for consequential or incidental damages, and, 
as such, some portion of the above limitation may not apply to Li-
censee. In such jurisdictions, Licensor’s liability is limited to the great-
est extent permitted by law.

General
Any claim arising out of or related to this Agreement must be brought 
no later than one (1) year after it has accrued.

This Agreement is the sole agreement between the parties relating to 
the subject matter and supersedes all prior understandings, writings, 
proposals, representations, or communications, written or oral, of ei-
ther party. Only a writing executed by the authorized representatives 
of both parties may amend this Agreement.

No Assignability. This Agreement and the licenses granted hereunder 
cannot be transferred or assigned by Licensee without the prior writ-
ten consent of Licensor.  Any attempted assignment or sublicense by 
Licensee.

Severability and Survivability. If any part of this Agreement is held in-
valid or unenforceable, that portion will be construed consistent with 
applicable law as nearly as possible to reflect the original intention 
of the parties and all other portions of this Agreement remain in full 
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force and effect. In the event of any expiration, termination or can-
cellation of this Agreement, provisions that are intended to continue 
and survive shall do so.

This Agreement is binding upon the Licensor’s and Licensee’s succes-
sors and assigns.

Failure of either party to enforce any provision of this Agreement will 
not be deemed a waiver of the provision or the right to enforce that 
provision.

Licensee shall not export or re-export, or allow the export or re-ex-
port of the Software or any copy, portion or direct product of the fore-
going, in violation of any export laws, restrictions, national security 
controls or regulations of the United States or any other applicable 
foreign agency or authority. By accepting this license Agreement, Li-
censee represents and warrants that it is not located in, under control 
of, or a national or resident in a United States embargoed country, 
or on the United States Treasury Department’s list of Specially Desig-
nated Nationals or the United States Commerce Denied Person’s List 
or Entity List.

This Agreement shall be interpreted in accordance with the substan-
tive laws of the Commonwealth of Virginia.  In an action arising out 
of or relating to this Agreement or the Licensed Product, both par-
ties consent to the nonexclusive jurisdiction of the federal and state 
courts located in the City of Roanoke, Virginia.  The prevailing party 
of any dispute shall recover its reasonable attorneys’ fees and costs 
incurred in litigating, arbitrating, or otherwise settling or resolving 
such dispute.

During the Agreement’s term, Licensee agrees to regularly back-up 
its Licensed Computer on a separate medium. Licensee acknowledg-
es that any failure to do so may significantly decrease its ability to 
mitigate any harm or damage arising from any problem or error in the 
Licensed Products or the provision of services under the Agreement.

NOTWITHSTANDING ANYTHING TO THE CONTRARY CONTAINED IN 
THIS AGREEMENT, IT IS SPECIFICALLY ACKNOWLEDGED AND AGREED 
THAT NO REPRESENTATION, WARRANTY OR OTHER ASSURANCE IS 
MADE, DIRECTLY OR INDIRECTLY, THAT (I) ALL OR ANY PORTION OF 
THE LICENSED PRODUCT COMPLIES WITH ANY FEDERAL, STATE OR 
LOCAL LAWS, RULES, REGULATIONS OR ORDINANCES, AS THE SAME 
MAY BE CHANGED FROM TIME TO TIME, OR (II) LICENSEE’S USE OF THE 
LICENSED PRODUCT WILL RESULT IN LICENSEE’S COMPLIANCE WITH 
ANY FEDERAL, STATE OR LOCAL LAWS, RULES, REGULATIONS, OR OR-
DINANCES, AS THE SAME MAY BE CHANGED FROM TIME TO TIME.

The Software is a ‘’commercial item,’’ as defined at 48 C.F.R. § 2.101, 
consisting of ‘’commercial computer software’’ and/or ‘’commercial 
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computer software documentation,’’ as defined in 48 C.F.R. § 12.212 or 
48 C.F.R. § 227.7202, as applicable. Any use, modification, reproduc-
tion, release, performance, display, disclosure or distribution of the 
Software by the United States government, its agencies or instrumen-
talities shall be governed solely by the terms of this Agreement and 
shall be prohibited except to the extent expressly permitted herein.

Licensee’s Acceptance
Licensee will be deemed to accept the terms of this Agreement and 
agree to perform obligations of Licensee under this Agreement upon 
installation of the Software or Use of the Software or by any other 
means, electronic or otherwise, prescribed by Licensor and accepted 
by Licensee.
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