
User Manual



ii

SPATIALANALYZER USER MANUAL



User Manual

2021.06.09



iv

SPATIALANALYZER USER MANUAL

Hexagon Metrology, inc. 

06/09/2021. Hexagon Metrology, inc.  All 
rights reserved. Copyright ©1994-2021.

Your rights to the software are governed by 
the accompanying software license agree-
ment. The owner or authorized user of a 
valid copy of SpatialAnalyzer software may 
reproduce this publication for the purpose of 
learning to use such software. No part of this 
publication may be reproduced or transmit-
ted for commercial purposes, such as selling 
copies of this publication or for providing 
paid-for support services.

Every effort has been made to ensure that the 
information in this manual is accurate. Hexa-
gon Metrology is not responsible for printing 
or clerical errors.

Because Hexagon Metrology frequently 
releases new versions and updates to its ap-
plications and Internet sites, images shown in 
this book may be slightly different from what 
you see on your screen.

Hexagon Metrology, inc.  
436 McLaws Circle 
Williamsburg, VA 23185 
+1 (757) 565-1500 
www.kinematics.com

SpatialAnalyzer and New River Kinematics are 
trademarks of Hexagon Metrology, inc. , regis-
tered in the U.S.

Windows is a registered trademark of Micro-
soft Corporation.

iPhone and iPod are registered trademarks of 
Apple Inc.

OpenGL is a registered trademark of Silicon 
Graphics, Inc.

Other company and product names men-
tioned herein are trademarks of their re-
spective companies. Mention of third-party 
products is for informational purposes only 
and constitutes neither an endorsement nor 
a recommendation. Hexagon Metrology as-
sumes no responsibility with regard to the 
performance or use of these products.

SPATIALANALYZER USER MANUAL

http://www.kinematics.com


v

TABLE OF CONTENTS
Chapter 1: WELCOME ................................................................................................................... 1

About This Manual ...................................................................................................................................................................... 2
Conventions ................................................................................................................................................................................ 2
SA Packages ................................................................................................................................................................................ 5

SA Professional .................................................................................................................................................................................. 5

Chapter 2: GETTING STARTED ..................................................................................................... 5
SA Ultimate ....................................................................................................................................................................................... 6
SA Machine ........................................................................................................................................................................................ 7
Feature Summary .............................................................................................................................................................................. 8

System Requirements ................................................................................................................................................................. 9
Minimum Requirements .................................................................................................................................................................... 9
Recommendations for Optimal Performance ..................................................................................................................................... 9
Supported Auxiliary Input Devices ................................................................................................................................................... 10
Check My Computer ......................................................................................................................................................................... 10

Installation ............................................................................................................................................................................... 11
Installing SA .................................................................................................................................................................................... 11
Installer Command-Line Options ..................................................................................................................................................... 11
Instrument Drivers ........................................................................................................................................................................... 12

Licensing .................................................................................................................................................................................. 14
USB Licensing .................................................................................................................................................................................. 14
Cloud Licenses ................................................................................................................................................................................. 15

Certification .............................................................................................................................................................................. 19
How to Get Help ........................................................................................................................................................................ 19

SA Community Webpages ................................................................................................................................................................ 19
Documentation................................................................................................................................................................................ 20
Customer Support............................................................................................................................................................................ 20
Context-Sensitive Help .................................................................................................................................................................... 20
Tutorials & Sample Files ................................................................................................................................................................... 21

Navigating this Users Manual ................................................................................................................................................... 21
An overview of fundamental concepts and guiding principles ......................................................................................................... 21
Getting into the details of operation ................................................................................................................................................ 22
The core of measurement - Points and feature measurement .......................................................................................................... 22
Working with Instruments ............................................................................................................................................................... 23
How to effectively move and align measurements for analysis ........................................................................................................ 24
Live view and build it functionality .................................................................................................................................................. 24
Analysis, inspection refined alignment operations .......................................................................................................................... 24
Measurement Uncertainty and Unified Spatial Metrology Networks ............................................................................................... 25
Scripting and Automation ............................................................................................................................................................... 25
Specialized functionality ................................................................................................................................................................. 25
References ....................................................................................................................................................................................... 25



vi

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Chapter 3: SA FUNDAMENTALS ................................................................................................ 27

Architecture .............................................................................................................................................................................. 27
Host SpatialAnalyzer Session ........................................................................................................................................................... 28
Instrument Interface ....................................................................................................................................................................... 28
Instruments ..................................................................................................................................................................................... 29

Selection Filtering ..................................................................................................................................................................... 31
Double Colon Format ................................................................................................................................................................ 32
The Wire Model ......................................................................................................................................................................... 33
The Alignment Process .............................................................................................................................................................. 34
Feature Measurement ............................................................................................................................................................... 35
Offset Compensation ................................................................................................................................................................ 35

Probe Offsets ................................................................................................................................................................................... 36
Surface Normal Direction ................................................................................................................................................................. 37

Comparing Measurements to Points and Objects ...................................................................................................................... 39
Measured Points vs. Cloud Points .............................................................................................................................................. 40
Unbounded Geometry .............................................................................................................................................................. 41
The Working Frame ................................................................................................................................................................... 42
The Default Collection ............................................................................................................................................................... 42
Traceability ............................................................................................................................................................................... 42

Chapter 4: EXPLORING THE USER INTERFACE ......................................................................... 45
SA Ribbon Menus ...................................................................................................................................................................... 47

SA TreeBar ....................................................................................................................................................................................... 53

Report Bar ................................................................................................................................................................................ 56
Status Bar ................................................................................................................................................................................. 56
MP Bar ...................................................................................................................................................................................... 57
Classic Toolbars ......................................................................................................................................................................... 57

Main Toolbar .................................................................................................................................................................................... 58
Graphical Control Toolbar ................................................................................................................................................................. 59
Color/WCF Toolbar ........................................................................................................................................................................... 60
Instrument Docking Bar ................................................................................................................................................................... 61

SA Toolkit .................................................................................................................................................................................. 61
UI Themes ................................................................................................................................................................................. 62
Custom UI Profiles ..................................................................................................................................................................... 62

Customizing Toolbars & Menus ........................................................................................................................................................ 64
Keyboard Shortcuts ......................................................................................................................................................................... 66
Options ............................................................................................................................................................................................ 67

Language Translation ................................................................................................................................................................ 68
Character Sets .................................................................................................................................................................................. 70
Creating a Translation ...................................................................................................................................................................... 70
Merging Language Files .................................................................................................................................................................. 72



vii

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Using .CSV Files For Translation ........................................................................................................................................................ 72

Chapter 5: THE GRAPHICAL VIEW ............................................................................................. 75
Navigating the Graphical View .................................................................................................................................................. 75

Zoom ............................................................................................................................................................................................... 75
Autoscale ......................................................................................................................................................................................... 76
Pan .................................................................................................................................................................................................. 76
Rotate .............................................................................................................................................................................................. 76
Center In View.................................................................................................................................................................................. 77
Adjust View Components ................................................................................................................................................................. 77
Jumping to Previous/Next Views ..................................................................................................................................................... 78
Set Viewpoint From Frame ............................................................................................................................................................... 78
Set Viewpoint From Instrument Updates ......................................................................................................................................... 78
Set Viewpoint From Object .............................................................................................................................................................. 80
Set Viewpoint From Surface Point .................................................................................................................................................... 80
View Clipping .................................................................................................................................................................................. 80

Multiple Graphical Views .......................................................................................................................................................... 82
Heads-Up Display ..................................................................................................................................................................... 82

User Options Controls ...................................................................................................................................................................... 83

Saved Viewpoints ...................................................................................................................................................................... 85
Rendering Modes ...................................................................................................................................................................... 86
Surface Backsides ..................................................................................................................................................................... 88
Background/Highlight Color ..................................................................................................................................................... 89
Hardware Acceleration .............................................................................................................................................................. 90
Surface Rendering Options ....................................................................................................................................................... 91
Labels ....................................................................................................................................................................................... 93
The Hover Window .................................................................................................................................................................... 94
Object-Specific Rendering Modes ............................................................................................................................................. 96
Visibility .................................................................................................................................................................................... 97
Miscellaneous Settings & Commands ....................................................................................................................................... 98

View Animation Steps...................................................................................................................................................................... 98
Arrowhead Sizes .............................................................................................................................................................................. 98
Scale Indicator ................................................................................................................................................................................. 99
Shadow Plane .................................................................................................................................................................................. 99
Connection Indicator ..................................................................................................................................................................... 100
Uncertainty Fields .......................................................................................................................................................................... 101
Highlighting .................................................................................................................................................................................. 102
View Refresh .................................................................................................................................................................................. 103
Copying the Graphical View to the Clipboard ................................................................................................................................. 103
Creating a Movie Capture of the Screen ......................................................................................................................................... 103
Controlling Target Icon Size ............................................................................................................................................................ 104



viii

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Chapter 6: WORKING IN SA ......................................................................................................107

Selection ................................................................................................................................................................................. 107
Graphical Selection ........................................................................................................................................................................ 108
Treebar Selection ........................................................................................................................................................................... 111
F2 Selection ................................................................................................................................................................................... 111
Selection By Color .......................................................................................................................................................................... 114

Context Menus ........................................................................................................................................................................ 115
Organizing Your Job ................................................................................................................................................................ 116

Folders ........................................................................................................................................................................................... 117
Collections ..................................................................................................................................................................................... 118
Relocating Items to Another Collection.......................................................................................................................................... 119
Rearranging Points ........................................................................................................................................................................ 120
Naming & Renaming Items ........................................................................................................................................................... 123
Deleting Items ............................................................................................................................................................................... 127

Configuring SpatialAnalyzer ................................................................................................................................................... 130
Job File Settings............................................................................................................................................................................. 130
Machine Settings ........................................................................................................................................................................... 135
Security ......................................................................................................................................................................................... 137

System Diagnostics ................................................................................................................................................................. 139
Memory Monitor ........................................................................................................................................................................... 139
Check Job Data Consistency ........................................................................................................................................................... 140
Regenerate References .................................................................................................................................................................. 140

Repeating Commands ............................................................................................................................................................. 140
Working With Items ................................................................................................................................................................ 141

Moving Objects .............................................................................................................................................................................. 142
Mirroring Objects ........................................................................................................................................................................... 154
Scaling Objects .............................................................................................................................................................................. 155
Finding Items In The Tree ............................................................................................................................................................... 156

Network Browser .................................................................................................................................................................... 156
Remote Monitoring ................................................................................................................................................................ 157
Working With The Clipboard ................................................................................................................................................... 159
Working Frame and Locked Objects ........................................................................................................................................ 159

About the World Frame.................................................................................................................................................................. 160
 Locked Items ................................................................................................................................................................................. 161

Object Color ............................................................................................................................................................................ 161
Accessing Item Properties ....................................................................................................................................................... 163
The Calculator ......................................................................................................................................................................... 164
User Notes .............................................................................................................................................................................. 164

Adding Notes to Items ................................................................................................................................................................... 164

Item History ............................................................................................................................................................................ 164



ix

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Print Setup .............................................................................................................................................................................. 165
Command-Line Arguments ..................................................................................................................................................... 166

Launching SA with Command-Line Arguments ............................................................................................................................. 166
Example Command-Line Arguments ............................................................................................................................................. 167

Multiple Instances and Exiting SA ........................................................................................................................................... 167
Chapter 7: WORKING WITH FILES ...........................................................................................169

SA Files ................................................................................................................................................................................... 169
Creating New Files ......................................................................................................................................................................... 169
Opening Files ................................................................................................................................................................................. 170
Saving Files .................................................................................................................................................................................... 170
Save As .......................................................................................................................................................................................... 171
Backing Up Files ............................................................................................................................................................................ 171
Restore Points ................................................................................................................................................................................ 173
Password-Protecting SA Files ......................................................................................................................................................... 173

File Import .............................................................................................................................................................................. 174
Auto Import ................................................................................................................................................................................... 174
Importing SpatialAnalyzer Job Files ............................................................................................................................................... 174
Direct CAD Access ........................................................................................................................................................................... 175
Importing Standard CAD Formats .................................................................................................................................................. 181
Importing Predefined ASCII Formatted Files .................................................................................................................................. 182
Importing ASCII Formatted Points With Offsets ............................................................................................................................. 184
Importing XML Files ...................................................................................................................................................................... 184
Cloud Files: Standard Formats ........................................................................................................................................................ 186
Custom Formats ............................................................................................................................................................................. 187
Embedding Files ............................................................................................................................................................................ 187
Importing Images .......................................................................................................................................................................... 188

File Export ............................................................................................................................................................................... 188
Exporting ASCII Formatted Points .................................................................................................................................................. 188
Exporting Point Clouds .................................................................................................................................................................. 190
Exporting Vector Groups ................................................................................................................................................................ 191
Exporting Geometry ...................................................................................................................................................................... 191
Exporting Object Frames ............................................................................................................................................................... 191
Exporting to CAD Formats .............................................................................................................................................................. 192
Exporting Window Placements ...................................................................................................................................................... 193

Templates ............................................................................................................................................................................... 193
The Default Template ..................................................................................................................................................................... 194

Screen & Graphics Capture ...................................................................................................................................................... 195
Chapter 8: POINTS ....................................................................................................................197

About Points ........................................................................................................................................................................... 197
Point Groups .................................................................................................................................................................................. 197
Constructed Points ......................................................................................................................................................................... 198



x

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Measured Points ............................................................................................................................................................................ 198

Point Characteristics ............................................................................................................................................................... 199
Point Tolerance .............................................................................................................................................................................. 200
Notes ............................................................................................................................................................................................. 201
Targeting Offsets ........................................................................................................................................................................... 201
Accessing A Point’s Group Menu From the Graphical View ............................................................................................................. 203

Measurements ........................................................................................................................................................................ 203
How SA Computes a Measured Point’s Location ............................................................................................................................. 203
About Target Observations ............................................................................................................................................................. 204
About Target Offsets ...................................................................................................................................................................... 206
Characteristics Unique to Measured Points .................................................................................................................................... 206

Hidden Point Measurements ................................................................................................................................................... 211
The Hidden-Point Bar Database ..................................................................................................................................................... 211
Gravity Frame ................................................................................................................................................................................ 212
2 Point Hidden-Point Bar ............................................................................................................................................................... 213
N Point Bars or Fixtures .................................................................................................................................................................. 214

Setting Properties for Multiple Points ..................................................................................................................................... 216
Working With Point Lists ......................................................................................................................................................... 217
Point Sets ................................................................................................................................................................................ 219

Point Sets ...................................................................................................................................................................................... 219

Constructing Points ................................................................................................................................................................. 221
Entering Point Coordinates ............................................................................................................................................................ 221
Constructing a Point at the Center of a Line ................................................................................................................................... 221
Constructing  Points at the Center of Spheres and Circles ............................................................................................................... 222
Constructing Points at the Center of a Cylinder .............................................................................................................................. 222
Projecting to the Closest Point on Objects ...................................................................................................................................... 223
Projecting Points Parallel to a Working Coordinate Frame Axis ...................................................................................................... 224
Projecting Points Radially from a Working Coordinate Frame Axis ................................................................................................. 224
Projecting Points Spherically from a Working Coordinate Frame Origin ......................................................................................... 225
Projecting Points to a Curve ........................................................................................................................................................... 226
Creating Points at a 3-Plane Intersection ....................................................................................................................................... 227
Creating Points at the Intersection of a Plane and Circle ................................................................................................................ 227
Constructing Points at the Intersection of a Line and Plane ........................................................................................................... 228
Constructing a Point at the Intersection of 2 Lines ......................................................................................................................... 229
Constructing Points at the Intersection of a Line and Circle ............................................................................................................ 229
Constructing Points at the Intersection of a Line and Cylinder ....................................................................................................... 230
Constructing Points at the Intersection of a Line and Sphere ......................................................................................................... 230
Constructing Points at the Intersection of 2 B-Splines ................................................................................................................... 231
Constructing Points at the Intersection of a B-Spline and Surfaces ................................................................................................ 232
Constructing Points at the Intersection of Principle Object Axes and Surfaces ............................................................................... 233
Shifting Points In a Direction ......................................................................................................................................................... 233



xi

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Shifting Points In Cylindric Coordinates .......................................................................................................................................... 234
Laying Out Points on a Grid By Count ............................................................................................................................................. 235
Laying Out Points on a Grid By Distance ......................................................................................................................................... 236
Laying Out Points On a Circle ......................................................................................................................................................... 237
Generating Random Points ............................................................................................................................................................ 238
Laying Out Points On A Surface By Clicking .................................................................................................................................... 239
Laying Out Points On An Object Vertex By Clicking ......................................................................................................................... 239
Laying Out Points On An Object’s Vertices ...................................................................................................................................... 240
Laying Out Points Evenly On Curves ............................................................................................................................................... 240
Laying Out Points On Curves With Prescribed Spacing ................................................................................................................... 241
Laying Out Points On Curves by Clicking ........................................................................................................................................ 241
Laying Out Points on Curves Max Chordal Deviation ...................................................................................................................... 242
Laying Out Points On Lines ............................................................................................................................................................ 242
Laying Out Points At The Center of Surface Holes ........................................................................................................................... 243
Laying Out Points In The View By Clicking ...................................................................................................................................... 245
Copying Existing Points .................................................................................................................................................................. 245
Moving Existing Points Into A New Group ...................................................................................................................................... 245
Creating a Subset of Points With Greatest Spacing ......................................................................................................................... 246
Auto-Corresponding Two Groups By Proximity ............................................................................................................................... 247
Auto-Corresponding 2 Groups by Inter-Point Distance ................................................................................................................... 248
Averaging Points ............................................................................................................................................................................ 248
Creating Points at the End of a Line ............................................................................................................................................... 249
Creating Points at a Plane Cross Section: ........................................................................................................................................ 249
Constructing Points  Evenly Spaced on a Surface: .......................................................................................................................... 249
Constructing Points From Vectors .................................................................................................................................................. 250
Constructing a Single Point through Patch Normal Shift ................................................................................................................ 251
Scale Points ................................................................................................................................................................................... 252
Copy Groups Excluding Obscured Points ......................................................................................................................................... 253
Auto Filter to Faces ........................................................................................................................................................................ 253
From Surface Faces ........................................................................................................................................................................ 254
Closet points between 2 Surfaces .................................................................................................................................................. 254

Chapter 9: POINT CLOUDS .......................................................................................................255
Point Clouds ............................................................................................................................................................................ 255

Point Cloud Formats ...................................................................................................................................................................... 255

Point Cloud Visualization  ........................................................................................................................................................ 256
Real-time Data Display .................................................................................................................................................................. 256
Working with Raw Point Cloud Data .............................................................................................................................................. 257
Voxel Cloud Display  ....................................................................................................................................................................... 265
Using Voxel Colors for Deviation and Analysis ................................................................................................................................ 269

Clipping Planes  ...................................................................................................................................................................... 272
Cross Section Clouds  ............................................................................................................................................................... 274



xii

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Cloud Filtering and Sub-Sampling .......................................................................................................................................... 277

Auto Filter Point Status .................................................................................................................................................................. 279

Point Cloud Construction Options ........................................................................................................................................... 279
Create Empty Scan Stripe Cloud ..................................................................................................................................................... 279
From Existing Clouds ..................................................................................................................................................................... 280
From Existing Clouds Uniform Spacing .......................................................................................................................................... 280
From Existing Cloud Points ............................................................................................................................................................ 280
Random Data ................................................................................................................................................................................. 280
From Existing Point Group ............................................................................................................................................................. 280
Auto Filter to Faces ........................................................................................................................................................................ 280
Auto Filter to Vectors ..................................................................................................................................................................... 281
Auto Filter to Lines ......................................................................................................................................................................... 282
Auto Filter to circular Arc B-Splines ................................................................................................................................................ 282
On Object’s Vertices ........................................................................................................................................................................ 282
Auto Filter to Cross -Sections ......................................................................................................................................................... 282
From Frame Set ............................................................................................................................................................................. 282

Building Points from  Point Clouds .......................................................................................................................................... 282
Converting Clouds to Points ........................................................................................................................................................... 283
Filtering Clouds to Points ............................................................................................................................................................... 284
Filtering Clouds to a Plane ............................................................................................................................................................. 285
Filtering Clouds to Vectors by Resolving Points .............................................................................................................................. 286
Extracting Center Points From Scanned Spheres ............................................................................................................................ 287

Cloud Based Alignment/Registration Tools ............................................................................................................................. 290
Aligning Clouds to CAD / Mesh / Clouds ......................................................................................................................................... 290
Point Extraction and Best-Fit ......................................................................................................................................................... 292
Cloud to Object Relationship Optimization .................................................................................................................................... 293
 Refit Scan Passes ........................................................................................................................................................................... 293

Query Point Cloud to Point Cloud ............................................................................................................................................ 294
Feature Extraction from Point Clouds ...................................................................................................................................... 294

Auto Filter to Nominal Geometry >3D Extraction .......................................................................................................................... 294
Auto Filter to Nominal Geometry >2D Geometry .......................................................................................................................... 301
Extract Geometry from Clouds ....................................................................................................................................................... 302

 Meshing Point Clouds ............................................................................................................................................................ 305
Scan Stripe Mesh Operations ......................................................................................................................................................... 305
Scan Stripe Mesh Editing ............................................................................................................................................................... 310

Chapter 10: FRAMES .................................................................................................................313
6D Locations and Measurements  ........................................................................................................................................... 313

Frames ........................................................................................................................................................................................... 313
Frame Properties ........................................................................................................................................................................... 315
Frame Construction ....................................................................................................................................................................... 317
Frame Sets ..................................................................................................................................................................................... 321



xiii

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Chapter 11: GEOMETRY ............................................................................................................325

Locations and Measurement ................................................................................................................................................... 325
Point Group ................................................................................................................................................................................... 325
Point Clouds and Meshes ............................................................................................................................................................... 326
Frames and Coordinate Systems .................................................................................................................................................... 327

Objects vs. Geometry Relationships ........................................................................................................................................ 327
Lines ....................................................................................................................................................................................... 327

Properties ...................................................................................................................................................................................... 327
Construction .................................................................................................................................................................................. 328

Circles ..................................................................................................................................................................................... 330
Properties ...................................................................................................................................................................................... 330
Construction .................................................................................................................................................................................. 331

Planes ..................................................................................................................................................................................... 331
Construction .................................................................................................................................................................................. 332

Slots ........................................................................................................................................................................................ 333
Properties ...................................................................................................................................................................................... 333
Construction .................................................................................................................................................................................. 334

Ellipses .................................................................................................................................................................................... 335
Properties ...................................................................................................................................................................................... 335
Construction .................................................................................................................................................................................. 335

Cylinders ................................................................................................................................................................................. 335
Properties ...................................................................................................................................................................................... 336
Construction .................................................................................................................................................................................. 337

Spheres ................................................................................................................................................................................... 337
Properties ...................................................................................................................................................................................... 337
Construction .................................................................................................................................................................................. 338

Cones ...................................................................................................................................................................................... 338
Properties ...................................................................................................................................................................................... 339
Construction .................................................................................................................................................................................. 339

Paraboloids ............................................................................................................................................................................. 340
Properties ...................................................................................................................................................................................... 340
Construction .................................................................................................................................................................................. 340

Toruses .................................................................................................................................................................................... 340
Properties ...................................................................................................................................................................................... 341
Construction .................................................................................................................................................................................. 341

Perimeters .............................................................................................................................................................................. 341
Properties ...................................................................................................................................................................................... 342
Construction .................................................................................................................................................................................. 342

Graphical Entities .................................................................................................................................................................... 343
Sphere Section............................................................................................................................................................................... 344



xiv

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Chapter 12: WORKING WITH SURFACES .................................................................................347

Surface Grouping .................................................................................................................................................................... 347
Constructing a Merged Surface ...................................................................................................................................................... 348
Dissecting Surfaces ........................................................................................................................................................................ 348
Show Selected Faces Command ..................................................................................................................................................... 349
Duplicate Surface Faces ................................................................................................................................................................. 350

Surface Normal Conditioning .................................................................................................................................................. 350
Indicating Point on Positive Side .................................................................................................................................................... 350
Reversing Surface Normals ............................................................................................................................................................ 351
Auto-Reversing Surface Normals ................................................................................................................................................... 351

Surface Construction Options .................................................................................................................................................. 352
From a Collection of Surfaces ......................................................................................................................................................... 352
By Dissecting Surfaces ................................................................................................................................................................... 352
Select Faces by Projecting Points ................................................................................................................................................... 352
From Objects ................................................................................................................................................................................. 352
From Plane, Cylinder, Sphere, and Cone ......................................................................................................................................... 352
Tubular Surface from a B-Spline .................................................................................................................................................... 352
Advanced Surface Fitting ............................................................................................................................................................... 353

B-Splines ................................................................................................................................................................................ 353
Properties ...................................................................................................................................................................................... 353
B-Spline Construction .................................................................................................................................................................... 354

Polygonized Meshes ............................................................................................................................................................... 359
From Surfaces ................................................................................................................................................................................ 359
From Cloud Points and from Selected Cloud Points ........................................................................................................................ 359
 Colorized Mesh from Point Proximity ............................................................................................................................................ 360

Chapter 13: INSTRUMENTS ......................................................................................................361
Instrument Properties ............................................................................................................................................................. 362

Sensor Control ............................................................................................................................................................................... 363
Scale Factor ................................................................................................................................................................................... 364
Uncertainty Variables .................................................................................................................................................................... 366
Instrument Graphics (PCMM arms only) ........................................................................................................................................ 366
Instrument Communication Controls ............................................................................................................................................. 367

Instrument Shots .................................................................................................................................................................... 368
Instrument Shot Modes ................................................................................................................................................................. 369
Shot Colors .................................................................................................................................................................................... 369
Angle Only Shots ........................................................................................................................................................................... 370
Instruments and Measurements .................................................................................................................................................... 370

Using Instruments .................................................................................................................................................................. 371
Instrument Options and Properties ................................................................................................................................................ 372

The Instrument Interface ........................................................................................................................................................ 373
Starting an Instrument Interface ................................................................................................................................................... 375



xv

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Running Multiple Instrument Interfaces ........................................................................................................................................ 376

Connection Configurations ...................................................................................................................................................... 377
IP-Based Instruments ............................................................................................................................................................. 377

IP Address Basics ........................................................................................................................................................................... 377
Computer and Instrument Setup ................................................................................................................................................... 378
Changing a Static IP Address .......................................................................................................................................................... 379
Multiple IP Setup (Dual IP) ............................................................................................................................................................ 379

Measurement Simulation ....................................................................................................................................................... 380
Laser  Tracker Simulation ............................................................................................................................................................... 380
Portable CMM Arm Simulation ...................................................................................................................................................... 383
Simulation with Other Instrument Types ....................................................................................................................................... 384
Measurement Fabrication .............................................................................................................................................................. 384

Taking Measurements ............................................................................................................................................................. 384
Auto Measure ................................................................................................................................................................................ 385
Guided Points ................................................................................................................................................................................ 387
Proximity Triggered Points ............................................................................................................................................................. 388
Synchronized Measurement .......................................................................................................................................................... 391
Crib Sheets and Measurement Templates ...................................................................................................................................... 392

Monitoring.............................................................................................................................................................................. 393
Watch Windows and Transformation Tracking ................................................................................................................................ 393

Tools ....................................................................................................................................................................................... 394
Scale Bars ...................................................................................................................................................................................... 394
Perimeter....................................................................................................................................................................................... 394
Target Detection ............................................................................................................................................................................ 394

Chapter 14: ALIGNMENT & TRANSFORMATIONS ..................................................................397
Review of Available Alignment Options .................................................................................................................................. 398

Measured Point to Reference Alignments ...................................................................................................................................... 398
Feature and Reference Point Alignments ....................................................................................................................................... 399
Surface Alignments ....................................................................................................................................................................... 399
Point Cloud/Mesh to Reference Alignments ................................................................................................................................... 399
Frame and Feature Based Alignments ........................................................................................................................................... 399
Advanced Optimizations ................................................................................................................................................................ 400
Network Alignments ..................................................................................................................................................................... 400

Measured Points to Reference Alignments .............................................................................................................................. 401
Best-Fit Transformations ................................................................................................................................................................ 401
Point to Point Best-Fit .................................................................................................................................................................... 401
Locate By Measuring Nominal Points ............................................................................................................................................. 411
Drift Check ..................................................................................................................................................................................... 413

Feature and Reference Point Alignments ................................................................................................................................ 416
Nominal Geometry Relationships .................................................................................................................................................. 416
Reference Point System (RPS) Alignment ...................................................................................................................................... 416



xvi

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Surface Alignments ................................................................................................................................................................ 420

Quick Align to CAD ......................................................................................................................................................................... 420
Best-Fit Points to Surfaces ............................................................................................................................................................. 422

Network Alignments ............................................................................................................................................................... 426
Bundle Adjust ................................................................................................................................................................................ 426
Unified Spatial Metrology Network(USMN)  .................................................................................................................................. 429

Job Pre-Planning and Instrument Placement ......................................................................................................................... 429
How to Pre-Plan instrument placements ....................................................................................................................................... 429

Chapter 15: WATCH WINDOWS ................................................................................................433
How to Add a Watch Window ......................................................................................................................................................... 434

Watch Window Types .............................................................................................................................................................. 434
Watch Instrument’s Point............................................................................................................................................................... 435
Watch Point to Point ...................................................................................................................................................................... 435
Watch Point to Point With View Zooming ....................................................................................................................................... 436
Watch Closest Point ....................................................................................................................................................................... 436
Watch Point to Objects ................................................................................................................................................................... 436
Watch Three Point Frame ............................................................................................................................................................... 437
Watch Two Point Axis Alignment ................................................................................................................................................... 438
Watch Theodolite Observer Point to Point ...................................................................................................................................... 439
Watch Theodolite Observer’s Point ................................................................................................................................................. 440
Watch Theodolite Observer’s Data .................................................................................................................................................. 440

Watch Window Options .......................................................................................................................................................... 441
Data Representation ...................................................................................................................................................................... 441
Item Visibility................................................................................................................................................................................. 445
Background Window ..................................................................................................................................................................... 446
Text Controls .................................................................................................................................................................................. 446
Arrow Settings ............................................................................................................................................................................... 447
Graphical Guide ............................................................................................................................................................................. 448
UDP Broadcast ............................................................................................................................................................................... 449

Transformation Tracking ......................................................................................................................................................... 450
Relationships with Trans-Track ....................................................................................................................................................... 450
Transform in 6D using Instrument Updates .................................................................................................................................... 451

Big Data Window .................................................................................................................................................................... 451
UDP Broadcast ........................................................................................................................................................................ 453
SA Remote .............................................................................................................................................................................. 454

Setup ............................................................................................................................................................................................. 455
Available Status/Commands .......................................................................................................................................................... 458

Google Glass App .................................................................................................................................................................... 458
Troubleshooting ............................................................................................................................................................................ 461

Chapter 16: ANALYSIS ..............................................................................................................463
Geometry Fitting .................................................................................................................................................................... 463



xvii

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
About Planar Offset Methods ......................................................................................................................................................... 465
About Measured Side Settings ....................................................................................................................................................... 467
The Fit Interface ............................................................................................................................................................................. 469
Point List ....................................................................................................................................................................................... 473

Queries ................................................................................................................................................................................... 477
Query Basics .................................................................................................................................................................................. 478
Cloud to Cloud Query ..................................................................................................................................................................... 481

Vector Groups ......................................................................................................................................................................... 483
Vector Group Properties ................................................................................................................................................................. 483

Vector Construction Options ................................................................................................................................................... 494
 Advanced Surface Fitting ....................................................................................................................................................... 498
Frame Wizard .......................................................................................................................................................................... 502

Chapter 17: RELATIONSHIPS ...................................................................................................505
What is a Relationship  ........................................................................................................................................................... 505
Definition of Relationship Types .............................................................................................................................................. 506

Points Based Relationships ............................................................................................................................................................ 506
Object Orientation Relationships ................................................................................................................................................... 506
Special Function Relationships ...................................................................................................................................................... 507
Geometry Relationships ................................................................................................................................................................ 508
Dynamic Geometry  ....................................................................................................................................................................... 510

General Relationship Properties & Controls ............................................................................................................................. 512
Visual Controls ............................................................................................................................................................................... 512
File Management Tools .................................................................................................................................................................. 513
Projection and Fit Controls ............................................................................................................................................................. 513
Reporting Options and Controls ..................................................................................................................................................... 516
Combined Relationship Reports .................................................................................................................................................... 518
Recomputation .............................................................................................................................................................................. 519
Measurement Associations ............................................................................................................................................................ 519
Measurement Trapping and Trapping Controls ............................................................................................................................... 520

Properties & Controls - Special Function Relationships ........................................................................................................... 520
Group to Nominal Group ................................................................................................................................................................ 520
Points/Groups to Surface Faces ...................................................................................................................................................... 522
Vector Group to Vector Group Relationships ................................................................................................................................... 522

Relationships with built in Alignments ................................................................................................................................... 526
Properties & Controls - Geometry Relationships ..................................................................................................................... 527
Minimizing Relationships ....................................................................................................................................................... 535

Move Objects by Minimizing Relationships .................................................................................................................................... 536
Relationship Fit Settings ................................................................................................................................................................ 539

Sequential Alignment ............................................................................................................................................................. 540
Pipe Relationships .................................................................................................................................................................. 542



xviii

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Using Pipe Relationships ............................................................................................................................................................... 544
Defining Pipe Relationships ........................................................................................................................................................... 544
Working With the Cut .................................................................................................................................................................... 548

Chapter 18: FEATURE INSPECTION .........................................................................................551
Why Feature Based Inspection ................................................................................................................................................ 551

Why GR-Features verses GD&T ....................................................................................................................................................... 552

Building GR-Features .............................................................................................................................................................. 552
Nominals ....................................................................................................................................................................................... 553
New Feature Controls ..................................................................................................................................................................... 553
Building New Features ................................................................................................................................................................... 556
Extract Geometry  .......................................................................................................................................................................... 559
Relationships ................................................................................................................................................................................. 559
Relationship tab of the Toolkit ....................................................................................................................................................... 561

Feature Inspection .................................................................................................................................................................. 563
Instrument Alignment ................................................................................................................................................................... 563
Measurement Trapping  ................................................................................................................................................................. 564
Sweep and Sweep & Move  ............................................................................................................................................................ 567
Helpful Tools for Inspection ........................................................................................................................................................... 568

SA Toolkit  ............................................................................................................................................................................... 572
Analysis Tab ............................................................................................................................................................................ 573

Visualization .................................................................................................................................................................................. 573
Construction .................................................................................................................................................................................. 574
Fitting ............................................................................................................................................................................................ 575
Uncertainty ................................................................................................................................................................................... 575
Scaling ........................................................................................................................................................................................... 576

Reporting Tab ......................................................................................................................................................................... 576
Reports .......................................................................................................................................................................................... 576
Dimensions .................................................................................................................................................................................... 577
Callouts.......................................................................................................................................................................................... 578

Chapter 19: GD&T .....................................................................................................................579
Importing CAD with GD&T Annotations .................................................................................................................................. 580
Creating GD&T Annotations .................................................................................................................................................... 580

Creation Options ............................................................................................................................................................................ 581

GD&T Entities .......................................................................................................................................................................... 588
GD&T Annotation Properties.......................................................................................................................................................... 589

GD&T Alignment ..................................................................................................................................................................... 601
Pattern Datums ............................................................................................................................................................................. 603
Surface Alignment ......................................................................................................................................................................... 604
Disabling Datum Alignment .......................................................................................................................................................... 605
Simultaneous Evaluations ............................................................................................................................................................. 605

GD&T Evaluation ..................................................................................................................................................................... 606



xix

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
GD&T User Options ........................................................................................................................................................................ 606
GD&T Evaluations verses RMS fits .................................................................................................................................................. 609
Decimal Precision .......................................................................................................................................................................... 609
Evaluation Zone/Length ................................................................................................................................................................ 610
Cylinder Evaluation & Coverage ..................................................................................................................................................... 610
Slots and Open Slots ...................................................................................................................................................................... 611
Point Cloud Thinning Controls ........................................................................................................................................................ 612

Feature Check Specifics ........................................................................................................................................................... 614
Form Checks .................................................................................................................................................................................. 614
Orientation Checks ......................................................................................................................................................................... 618
Location Checks ............................................................................................................................................................................. 619

GD&T Workflow ...................................................................................................................................................................... 627
Guided Inspection.......................................................................................................................................................................... 628
Inspection Bar Trapping and Direct Association ............................................................................................................................. 632
Show Only Active Feature Check or Datum..................................................................................................................................... 633
Remeasure Failed Checks Only ....................................................................................................................................................... 634
Feature Inspection Auto Filter ........................................................................................................................................................ 634

GD&T Reporting ...................................................................................................................................................................... 637
Reporting Options ......................................................................................................................................................................... 637
Adding Checks to a Report ............................................................................................................................................................. 642

Chapter 20: REPORTING ...........................................................................................................645
Building New Reports ............................................................................................................................................................. 645
Report Bar .............................................................................................................................................................................. 646

Displaying the Report Bar .............................................................................................................................................................. 646
Building Reports Using the Report Bar .......................................................................................................................................... 647

Generating Reports ................................................................................................................................................................. 648
Quick Reports ................................................................................................................................................................................ 648
SA Report Builder Utility ................................................................................................................................................................ 649

Reporting User Settings  ......................................................................................................................................................... 650
SA Reports .............................................................................................................................................................................. 652

Creating an SA Report .................................................................................................................................................................... 652
The Report Designer ...................................................................................................................................................................... 653
Export Options ............................................................................................................................................................................... 655
Adding Elements to the body of a Report ...................................................................................................................................... 657
Report Fields ................................................................................................................................................................................. 657
Tables ............................................................................................................................................................................................ 662
Modifying Items in the report ........................................................................................................................................................ 663

Report Templates .................................................................................................................................................................... 664
Object Report Options............................................................................................................................................................. 666

Events ............................................................................................................................................................................................ 667
Queries .......................................................................................................................................................................................... 667



xx

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Dimensions ............................................................................................................................................................................. 668

Types of Dimensions ...................................................................................................................................................................... 668
Working With Dimensions ............................................................................................................................................................. 669
Properties Common to all Dimensions ........................................................................................................................................... 670
Type Specific Dimension Properties ............................................................................................................................................... 673
Point to Point Dimensions.............................................................................................................................................................. 673
Point to Object Dimensions ............................................................................................................................................................ 675
Object to Object Dimensions .......................................................................................................................................................... 678
Diameter / Radius Dimensions ....................................................................................................................................................... 679

Callout Views and Callouts ...................................................................................................................................................... 681
Creating a Callout View .................................................................................................................................................................. 681
Callout View Properties .................................................................................................................................................................. 683
The Layer Manager ........................................................................................................................................................................ 685
Types of Callouts ............................................................................................................................................................................ 687

Charting .................................................................................................................................................................................. 692
Available Charts ............................................................................................................................................................................. 692
Chart Plot Region Controls: ............................................................................................................................................................ 694
Chart Statistical Results ................................................................................................................................................................. 695

 Photos .................................................................................................................................................................................... 697
Chapter 21: MEASUREMENT UNCERTAINTY ..........................................................................699

What is Measurement Uncertainty? ........................................................................................................................................ 699
Measurement Uncertainty and Visualization in SA ........................................................................................................................ 700
Basic Uncertainty Computation Process for a Tracker/Total Station: ............................................................................................... 708
 Basic Uncertainty Computation Process for a PCMM Arm .............................................................................................................. 710
Uncertainty for Points with Multiple Observations ........................................................................................................................ 711

Measurement Analysis with Uncertainty Fields ...................................................................................................................... 712
Point to Point Distance Uncertainty ............................................................................................................................................... 712
Geometry Fit Uncertainty .............................................................................................................................................................. 713
How to Perform a Geometry fit with Uncertainty:  ........................................................................................................................ 716

Chapter 22: UNIFIED SPATIAL METROLOGY NETWORK .......................................................721
What is USMN ......................................................................................................................................................................... 721

What is USMN? .............................................................................................................................................................................. 721
Weighted Bundle ........................................................................................................................................................................... 722

Using USMN ............................................................................................................................................................................ 726
Observations and Point Group Requirements for USMN ................................................................................................................. 726
USMN Dialog ................................................................................................................................................................................. 729
Basic USMN Solution Process ......................................................................................................................................................... 742

Chapter 23: MEASUREMENT PLANS .......................................................................................745
About Measurement Plans ...................................................................................................................................................... 745
Running a Measurement Plan ................................................................................................................................................. 746



xxi

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Quick MPs ............................................................................................................................................................................... 747
Working With Measurement Plans .......................................................................................................................................... 749

Protecting Scripts .......................................................................................................................................................................... 751
Generating SDK Code ..................................................................................................................................................................... 751

The MP Editor ......................................................................................................................................................................... 752
Overview ....................................................................................................................................................................................... 753
About Commands .......................................................................................................................................................................... 754
Entering Commands ...................................................................................................................................................................... 758
Editing Commands ........................................................................................................................................................................ 758
Resizing Columns........................................................................................................................................................................... 760
Hard Coding Argument Values ....................................................................................................................................................... 760
Referencing Arguments ................................................................................................................................................................. 761
Using Variables .............................................................................................................................................................................. 762
Connections View .......................................................................................................................................................................... 763
MP Find and Replace ..................................................................................................................................................................... 764
Commenting Out Commands ........................................................................................................................................................ 766
Setting Breakpoints ....................................................................................................................................................................... 767
Locking Commands ....................................................................................................................................................................... 768
Entering Comments ....................................................................................................................................................................... 769
Indenting Commands .................................................................................................................................................................... 769
Setting Command Colors ............................................................................................................................................................... 769
Grouping Commands ..................................................................................................................................................................... 770
Working with Subroutines ............................................................................................................................................................. 771

Writing Your First Script .......................................................................................................................................................... 772
Debugging .............................................................................................................................................................................. 775

Stepping Through a Script ............................................................................................................................................................. 775
Debug Mode .................................................................................................................................................................................. 776
MP Watcher ................................................................................................................................................................................... 776

Chapter 24: SA SDK ...................................................................................................................779
SA SDK .................................................................................................................................................................................... 779

SDK Engine .................................................................................................................................................................................... 780
Automatic Code Generation ........................................................................................................................................................... 780
Setting Up an SDK Project .............................................................................................................................................................. 781
Sending Commands to SA .............................................................................................................................................................. 785

Chapter 25: THE OPC INTERFACE ............................................................................................789
What Is OPC? ........................................................................................................................................................................... 789
SA & OPC ................................................................................................................................................................................. 789
Prerequisites ........................................................................................................................................................................... 790
Configuring the OPC Server ..................................................................................................................................................... 790

Step 1: Creating a DCOM User ........................................................................................................................................................ 790
Step 2: Disable Windows Firewall .................................................................................................................................................. 791



xxii

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS
Step 3: Adjust User Account Control Settings ................................................................................................................................. 791
Step 4: Install SA ............................................................................................................................................................................ 792
Step 5: Install OPC Core Components ............................................................................................................................................. 792
Step 6: Register the NRK OPC DA Server ......................................................................................................................................... 792
Step 7: Enable the OPC Server in the SA Configuration .................................................................................................................. 792
Step 8: Test the Server with a Local Client ...................................................................................................................................... 792
Step 9: Configuring System-wide DCOM Settings .......................................................................................................................... 793
Step 10: Configure the OPC Server’s Specific DCOM Settings .......................................................................................................... 794

Configuring the OPC Client ...................................................................................................................................................... 795
Step 1: Create an OPC User Account & Install Components ............................................................................................................. 795
Step 2: Configure System-Wide DCOM Settings ............................................................................................................................. 795
Step 3: Test the OPC Server Connection .......................................................................................................................................... 796

Using SA’s OPC Server .............................................................................................................................................................. 796
MP Support ................................................................................................................................................................................... 797

Chapter 26: MACHINE CALIBRATION ......................................................................................799
SA Machine ............................................................................................................................................................................. 799

Robots in SA .................................................................................................................................................................................. 800
Controlling a Robot from SA .......................................................................................................................................................... 803
Collecting Calibration Measurements ............................................................................................................................................ 804
Calibration Interface ...................................................................................................................................................................... 805

Denavit-Hartenberg Notation ................................................................................................................................................. 808
Chapter 27: TUTORIALS............................................................................................................811

Tutorial Index: ......................................................................................................................................................................... 811
Installation and Configuration ................................................................................................................................................ 812

Installing Spatial Analyzer (SA)...................................................................................................................................................... 812

Basic Operations ..................................................................................................................................................................... 814
Navigating the Graphical View ....................................................................................................................................................... 814
Navigating the Graphical View Tutorial .......................................................................................................................................... 814
Point  Properties and Data Management ....................................................................................................................................... 819
Coordinate Systems In SA .............................................................................................................................................................. 826
Working With Frames Tutorial ........................................................................................................................................................ 828

Connecting an Instrument ...................................................................................................................................................... 838
Basic Tracker Operation Using the Instrument Toolbar ................................................................................................................... 838
Measure Nominal Points ................................................................................................................................................................ 847
Drift Check Verification and Re-Alignment .................................................................................................................................... 851
Using Best-Fit to Align Point Measurements .................................................................................................................................. 857
Quick Align to CAD ......................................................................................................................................................................... 864

Feature Inspection .................................................................................................................................................................. 869
Creating Features from Existing Points ........................................................................................................................................... 869
Fitting Geometry from Points ........................................................................................................................................................ 876
Geometry Relationships ................................................................................................................................................................ 881



xxiii

CHAPTER 2 ■ THE WORKSPACE

TABLE OF CONTENTS
Contoured Surface Alignment and Evaluation with Relationships ................................................................................................. 887
Cloud Based Part Inspection with an Arm ...................................................................................................................................... 893
Inspection with GD&T .................................................................................................................................................................... 899

Analysis and Reporting  .......................................................................................................................................................... 905
Basic Point Analysis ....................................................................................................................................................................... 905
Creating Callouts ........................................................................................................................................................................... 911
Reporting With SA Reports ............................................................................................................................................................ 915

appendix a: KEYBOARD SHORTCUTS ......................................................................................919
appendix B: MATH REFERENCE ................................................................................................921

Linear Least Squares Adjustment ............................................................................................................................................ 921
Basics of Spatial Transformations ............................................................................................................................................ 922

The old viewpoint debate: Are we describing or transforming? ..................................................................................................... 923
Unit Rotation Matrices ................................................................................................................................................................... 924
Compound Rotations ..................................................................................................................................................................... 924

Notes on Decimal Precision and Rounding .............................................................................................................................. 926



xxiv

SPATIALANALYZER USER MANUAL

TABLE OF CONTENTS

This Page Intentionally Left Blank.



1

SA is used in many high-profile applications throughout a wide array 
of industries, from manufacturing to science and research. Some of 
these industries include:

 ■ Aerospace (aircraft and spacecraft)

 ■ Shipbuilding

 ■ Particle Accelerators

 ■ Nuclear Energy

 ■ Automotive

 ■ Heavy Equipment

 ■ Machining

You are about to embark on learning how to adeptly use the most 
powerful portable metrology software ever created. We think this 
learning period will prove to be remarkably short. Most users are able 
to confidently acquire and analyze data after only one day. In fact, it’s 
quite possible that you can start using SpatialAnalyzer simply by per-
forming a few trial and error “test drives”. The software is robust, and 
in general, it will politely inform you if you try something impossible.

We suggest that you may ultimately save time and grief by taking 
the time to read through this manual. Don’t be too particular about 
memorizing anything—after all, this document is available from 

CH
A

PT
ER

Congratulations on your purchase of SpatialAnalyz-
er, the world’s leading portable metrology software 
platform.  SpatialAnalyzer is a traceable, graphical 
metrology software package that can simultaneously 
communicate to virtually any number and type of di-
mensional measurement systems and perform com-
plex analysis tasks with ease.

1Welcome
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within SpatialAnalyzer. We hope you will obtain an understanding of 
the philosophy behind SpatialAnalyzer by reading this manual. If you 
are unable to read the manual, it also serves as an excellent reference 
when you have questions.

Above all else, the goal of our work has been to develop a software 
package where users of all levels of expertise may actually enjoy tak-
ing and analyzing measurements and may have confidence in the 
numbers they report.

About This Manual
New River Kinematics (NRK) regularly updates this manual to incor-
porate the most recent updates and changes to SA. However, due to 
the fact that this manual is currently under development, and due to 
the rapid pace of NRK’s software development, you may encounter 
out-of-date material. NRK is aware of this and is working to bring con-
tent up-to-date.

SpatialAnalyzer comes in several packages. In cases where it may be 
ambiguous, we try to make it clear if a capability is not available in a 
specific SA package.

If you have any comments or suggestions for this manual, or if you 
notice any errata, please report them to support@kinematics.com.

Conventions
A standard set of conventions have been established to help ensure 
that this document is easy to read. The established standards are de-
scribed here:

The titles of windows and dialogs will appear like this: Best Fit Trans-
formation.

Menu choices appear like this: Construct>Points>Enter.

Checkboxes, dropdowns, and other control choices appear like this: 
Show Scale indicator in View.

Button titles appear like this: Apply.

Keyboard combinations appear like this: Ctrl+D.

Named fields or boxes that subdivide areas of the user interface will 
appear like this: Degrees of Freedom.

Filenames appear like this: License10734.met.

Text that you should type in will appear like this: Nominal.

New terms will look like this: relationship Minimization.

Note:  An important note 
that accompanies the text 

appears in a box like this.

Warning:  A warning 
box, like this, will 
appear anytime there 

is information considered to 
be of a critical nature for 
either data integrity or 
measurement data accuracy. 
Failure to heed warnings 
could potentially lead to loss 
of data or incorrect results.

Tip:  Tips or recommenda-
tions that include best 

practices or time-saving 
techniques will appear in a 
box like this.

mailto:support%40kinematics.com?subject=Support%20Question
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Hyperlinks or links to other locations in this document look like this: 
support@kinematics.com.

WARNING: UNITED STATES COPYRIGHT LAW PROTECTS THIS MANUAL, 
ASSOCIATED SOFTWARE, ALGORITHMS, AND VISUAL CONTENT.

A Closer Look
Additional information that is not critical, but may be of interest to curious readers, is 
printed in an box like this.
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SA Packages
SA is available in three forms: SA Professional, SA Ultimate, and SA 
Machine. The details of the functionality provided in each of these 
packages is provided below.

SA Professional

SA Professional is the professional measurement, alignment, inspec-
tion, analysis, and reporting software for all portable metrology in-
struments. In addition to all essential measurement needs, it includes 
Native CAD import, several key inspection features, geometry inspec-
tion, and measurement automation.

MEASUREMENT
SA Professional offers 100% traceability from measurement to report-
ing. All measurement data is stored alongside time stamps, instru-
ment information, weather data, and other measurement parame-
ters. Log files track user actions, fit results, and more, allowing you to 
see the entire history of the job file.

ALIGNMENT
An essential part of the measurement process is the alignment of 

You are about to start your journey toward learning 
the world’s most powerful portable metrology soft-
ware package. But you can’t take the first step until 
the software’s installed!

Getting Started
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measurements to a known coordinate system. SA Professional in-
cludes a variety of alignment methods ranging from traditional 3-2-1 
alignments to more advanced surface fits.

BUILD
The Relationship functionality offers an easy way to calculate and ob-
serve part deviation. Relationships are dynamic in nature and update 
automatically if part alignment or data changes.

EVALUATION & ANALY-
SIS

A user-friendly interface permits both graphical and numerical de-
piction of measurement uncertainty, enhancing your perspective of 
measurement quality.

REPORTING
SA Professional offers quick, user-friendly reporting functionality. 
Quick Reports are ideal for on-location reporting, report templates 
are perfect for repetitive work, and the Report Designer allows you to 
drag and drop items to develop custom reports using tables, charts, 
and graphics.

GD&T INSPECTION
GD&T allows you to import CAD with GD&T annotations, create an-
notations manually, and inspect to GD&T standards with real-time 
reporting.

GEOMETRY INSPEC-
TION

Geometry inspection enables you to define design-based inspection 
routines from a CAD model or primitive geometry.

NATIVE CAD
Native CAD provides import support for such major applications as 
CATIA V4, V5, Pro/Engineer, SolidWorks, Unigraphics, and other CAD 
formats.

SA Ultimate

SA Ultimate is the premier measurement, optimization, analysis, re-
porting, and automation software suite for all portable instruments. It 
includes everything contained in SA Professional, plus the following 
features:

REAL-TIME ALIGN-
MENT

Transformation Tracking allows you to track moving parts in real-time 
so that you can monitor a part’s position as it is guided into place.
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ADVANCED FIT OPTI-
MIZATION

Relationship minimization provides the power necessary for ad-
vanced alignments and can help bring an out-of-tolerance part back 
within tolerance. You can also define fit envelopes to satisfy multiple 
constraints/requirements.

COMPLEX INSTRU-
MENT NETWORKS

USMN is an extremely powerful feature that leverages the uncertainty 
characteristics of different instruments to provide a much more accu-
rate instrument network than that of traditional alignment methods. 
It is used by many metrology groups to solve large-scale networks 
such as accelerator rings, full submarine surveys, and large machinery 
analysis.

AUTOMATION
The Measurement Plan and SA SDK functions can add a significant 
layer of automation to your processes.

Generating simple to complex scripts can greatly improve workflow 
and productivity, reducing analysis time from days to minutes while 
eliminating errors and saving significant resources.

PIPE FITTING
The Pipe Fitting function is used in large piping applications when 
precision cuts must be determined.

Precision measurements and optimization greatly improve accuracy, 
ultimately reducing the cost of rework.

DATABASE OUTPUT
Database output is an additional reporting feature that gives you the 
ability to transfer SA data to databases and track projects/data long-
term.

SA Machine

SA Machine with Native CAD contains all features of SA Ultimate, but 
also allows users to interface with robots and CNC machines. This 
permits calibration and real-time compensation of robots and large-
volume CNC machines to high degrees of accuracy. It also enables 
robotic scripting, teach pendant behavior, and linear or joint space 
robotic control.



8

SPATIALANALYZER USER MANUAL

Feature Summary

Features SA Professional SA Ultimate SA Machine

Measurement:

Traceability

Simultaneous Instrument Interfacing

Over 120 Supported Instruments

Alignment:

Best Fit

Feature Based

Points to Surfaces

Standard Instrument Network Bundle

Relationship Fitting

Advanced Network Optimization (USMN)

Inspection:

Geometric Dimensioning & Tolerancing

Geometry Inspection

Build:

Relationships

Watch Windows

Transformation Tracking & Guiding

Evaluation & Analysis:

Queries

Spatial Transformations

Robust Fit Algorithms (NIST & PTB Certi-
fied)

Measurement Uncertainty Analysis

Relationship Optimization (independent-
ly moving objects)

Reverse Engineering

CAD Interface:

Standard CAD Exchange (IGES, STEP, etc.)

Native CAD Access (CATIA, ProE, NX, etc.)

Automation:

Automatic Measurement

Measurement Plan Scripting

Software Development Kit (SDK)

SA Reporting:

Standard Output (Excel, Word, PDF, Text)

Graphical Callout Annotations
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Features SA Professional SA Ultimate SA Machine

Quick Reports

Drag & Drop Reporting

Database Output (ODBC)

Pipe Fitting:

Pipe Cut Optimization

Robotics:

Kinematic Modeling

Kinematic Calibration

Direct Motion Control

Graphical Simulation

System Requirements
SpatialAnalyzer is capable of running on most modern computing 
platforms, both 32 and 64-bit.

Minimum Requirements

Microsoft  Windows 7 or later

4 GB RAM

500 MB free disk space for installation (more for your data files)

1024 x 768 screen resolution

Microsoft .NET 4.0 Runtime (if using the Laser Radar Interface)

Recommendations for Optimal Performance

The system outlined below will provide a good base platform for us-
ing the most advanced features of SA. With this equipment measure-
ment data may be gathered with high data rates (1 kHz sampling 
rates) into complex models containing numerous CAD surfaces.

3 GHz or faster Dual-Core 64-bit processor

Windows 10™  (64-bit)

32 GB system RAM (64-bit systems)

1920x1080 or higher screen resolution

Hardware-accelerated graphics card supporting OpenGL®

100 GB of free hard disk space
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Supported Auxiliary Input Devices

3DConnexion®  SpaceNavigator™  (USB)

3DConnexion®  SpaceExplorer™  (USB)

3DConnexion®  SpacePilot™  (USB)

3DConnexion®  SpacePilot™  PRO (USB)

Check My Computer

SA provides a utility named Check My Computer that detects certain 
system configuration issues that may result in errors or problems 
while running SA. While this tool does not detect all issues—and while 
some checks may fail even though you never experience problems in 
SA—this is a useful diagnostic tool to use when you do encounter a 
problem. This tool does the following:

 ■ Checks for certain problematic software known to interfere 
with certain aspects of SA operation.

 ■ Verifies that a default printer is installed.

 ■ Checks for TCP/IP availability (a network interface).

 ■ Checks firewall settings.

 ■ Ensures that your computer’s network interface provides sup-
port for UDP broadcasting.

 ■ Ensures that your computer’s network interface provides sup-
port for socket communication and that it is not blocked.

 ■ Checks your User Account Control settings (Windows 7 and 
later) to ensure they’re not set too high.

 ■ Provides convenient access to system information and network 
configuration settings.

If you encounter an issue running SA, it is recommended to run this 
utility to check for problems and to contact support if necessary to 
find a resolution.

To Run the Check My Computer Utility

 ■ From SA, Select Help>Check My Computer, or

 ■ From the Windows Start menu, in the SA install folder, select 
the Check My Computer entry.

 ■ In the Main toolbar, click the SA Network icon.
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Installation

Installing SA

The SA Installer will guide you through installing the following:

 ■ SpatialAnalyzer™ Application

 ■ Documentation (this document)

 ■ Hardware lock driver

The installer is included with your provided USB flash drive and is also 
available for download at www.kinematics.com/download.

To Install SpatialAnalyzer:

1. Double-click SpatialAnalyzer 2021.XX.XX-Install-
er.exe.

2. Choose a destination folder (the default folder is usually pref-
erable), then click Next.

3. Leave both components (hardware driver & SA application) 
checked unless you have a specific reason to deselect a com-
ponent. (For instance, if you are an OEM running a software 
lock, you would not need to install the Sentinel Hardware 
Driver).  Click Next.

4. Choose additional install options.  The Check My Computer 
utility will check your system for some common configuration 
issues that often cause problems with instrument communi-
cation in SA.  When done selecting options, click Install.

SA is continuously updated with improvements and new features, 
and new beta releases are posted frequently. If your maintenance 
supports upgrading, you are encouraged to download the latest ver-
sion and explore the newest functionality.

Installer Command-Line Options

The SA Installer supports several command-line options. These are 
typically most useful for IT departments that wish to do a silent or 
automated install. The most command-line options can be combined 
and are as follows:

 ■ /?. Lists the command line options.

 ■ /S. Performs a silent install (this must be a CAPTIAL S). The in-
staller will operate in the background with no user interven-
tion.

 ■ /CREATESHORTCUT. Creates a desktop shortcut when run in 
silent mode.

Note:  Updated SA ver-
sions may require a new 

version of the hardware lock 
driver, so it is best to leave that 
option checked.  Older drivers 
will be updated, if necessary.

http://www.kinematics.com/download
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 ■ /TEMPUNITS=[Celsius, Fahrenheit]. Sets the default temper-
ature units for the install. If omitted, Fahrenheit will be used as a 
default, unless SA was installed previously, in which the temper-
ature units will not change. Ex. usage: /TEMPUNITS=Celsius.

 ■ /LENGTHUNITS=[Inches, Feet, Millimeters, Centimeters, 
Meters]. Sets the default length units for the install. If omitted, 
inches will be used as a default, unless SA was installed previ-
ously, in which the length units will not change. Ex. usage: /
LENGTHUNITS=Millimeters.

To Install SA with Command-Line Options:

 ■ At the command line, follow the executable name with the 
options. For instance, the following installs SpatialAnalyzer si-
lently in the background while also creating a desktop shortcut 
and setting the length units to millimeters: SpatialAnalyz-
er 2014.XX.XX-Installer.exe /S /CREATESHORTCUT 
/LENGTHUNITS=Millimeters

To Check for SA Updates:

 ■ Select Help>Check for SA Updates,

 ■ Choose Help>SpatialAnalyzer License Management>View Maintenance 
Support and Subscription Status, then click the Check for Updates button, 
or

 ■ Navigate to http://www.kinematics.com/products/spatialana-
lyzer/download-software.html.

Instrument Drivers

Most portable measurement devices (instruments) require a driver 
to be installed in order to properly communicate with SpatialAnalyz-
er.  When configuring a new instrument, it is always best to follow the 
instrument manufacturer’s recommended installation procedure and 
to install their software components/drivers as provided by the hard-
ware manufacturer.  However, the minimum drivers required for com-
municating with SA for most supported instruments are provided in 
a single bundled instrument driver installer provided by NRK.  This in-
staller is included with the provided USB flash drive and is also avail-
able for download at www.kinematics.com/download.

You can also locate drivers for your instrument on NRK’s FTP site at 
ftp://ftp.kinematics.com/pub/SA/Install/Driver Downloads/.

To Install Instrument Drivers using the Bundled Instrument Driver Installer:

1. Double-click SA Instrument Mfg Drivers.exe.

2. Select the desired instrument drivers to install and click Next.

3. You will be guided through the installation for the selected 

http://www.kinematics.com/products/spatialanalyzer/download-software.html
http://www.kinematics.com/products/spatialanalyzer/download-software.html
http://www.kinematics.com/download
ftp://ftp.kinematics.com/pub/SA/Install/Driver Downloads/
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instruments.  Note that the installers are usually provided by 
the hardware manufacturers, and each one is different.  Con-
tact NRK if you have problems while installing.
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Licensing
SpatialAnalyzer now offers both USB and Cloud Licensing. To deter-
mine which one is right for you please consult with your local sales 
representative.

USB Licensing

With this option SpatialAnalyzer is licensed via a USB hardware lock. 
A hardware lock driver (Sentinel), used to read the USB key, must be 
in- stalled before using SpatialAnalyzer. This driver is provided as part 
of the software install.

Meta-key File Installa-
tion

USB Licensing uses Meta files (extension .met) to upgrade or extend 
a licenses Maintenance. A new USB License will have no need for a 
Meta file since the key contains the initial Meta file. When software 
licensing is extended, or renewed, a user will receive a Meta file.  All 
the user must do is double click the Meta files(s) when received and 
they will auto extract into the correct directory.  Should an issue occur 
or you need to retrieve the file, it can be manually placed / found at: 
C: Analyzer Data\License.

Meta-keys have filenames like “License12345.met”, where the 
5-digit number must matches the serial number on the key.

License files can also be sent with the *.mez extension. This is a zip 
file that can contain more than 1 license. SA automatically recognizes 
both *.met and *.mez extensions so all you must do to install either 
format is double click on the file.

To install an SA Meta-key File:

1. Double-click the .*mez or *.met file you received from 
NRK and SA will automatically install it.

2. Ensure that the hardware lock with the matching serial num-
ber is installed in the USB port.

3. Run SpatialAnalyzer.

4. Choose the Help>SpatialAnalyzer License Management>View Current 
License Information menu option to verify your license.

Viewing Your License 
Information

Occasionally it may be necessary to examine the details of your Spa-
tialAnalyzer license, such as the serial number, user and company, 
upgrade date, and available software components. You can view the 
details of the current license in use at any time.

Note:  If a hardware lock is 
moved to a different com-

puter, the meta-key file must 
be transferred with it by copy-
ing the file into the new com-
puter’s Analyzer Data\Li-
cense folder. Failure to do this 
will result in the hardware lock 
reverting to its original license 
settings.
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To View the Current License Information

1. From the SA menu, select Help>SpatialAnalyzer License 
Management>View Current License Information.

2. A window will be displayed showing your license details, and 
this text will be automatically copied to the Windows clip-
board.

A Closer Look
When SA starts up, it first looks for a hardware lock.  It retrieves the license information and 
serial number from the hardware lock, then checks your Analyzer Data\License 
folder to see if there is a meta-key file matching the hardware key’s serial number.  If found, 
it uses the meta-key file to update the license information from the lock.

Cloud Licenses

Cloud licenses provide a number of advantages over USB Dongles. 
They can easily be activated and deactivated on-line providing an 
easy way to share a single license with colleges in different facilities 
and they are not as prone to being lost or damaged. Cloud licenses 
use a license code consisting of a string of numbers and letters that 
can be used to activate SA on a particular machine. 

On-line Cloud License 
Installation

To install a cloud license simply open SA. If no license is available you 
will see the following activation as an option on screen (Figure 2-1):

Figure 2-1. Cloud License 
Activation

1. Select Activate and enter the Cloud License number you were 
provided along with your User Details (Figure 2-2).  Be sure to 
enter the code exactly (it is case sensitive). It can be helpful to 
copy and paste the string directly out of an email or text file. 
The activation can only be performed with an active internet 
connection.



16

SPATIALANALYZER USER MANUAL

Figure 2-2. Entering Cloud 
License Information

To check on the status of your license or to de-activate the license on 
a particular computer go to Help> SpatialAnalyzer License Management> 
Cloud License Management.

Offline Activation/De-
activation:

Many customer will not have direct internet access. License activa-
tion and de-activation can be still be accomplished by transferring 
a license certificate to a computer with access. To do so follow these 
steps: 

1. Attempt activation (as described above) and you will see the 
following message(Figure 2-3):

Figure 2-3. No Internet Con-
nection

2. Press YES to activate your license offline. This will bring up the 
following Cloud License Offline Activation Dialog with your 
current license information(Figure 2-4): 
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Figure 2-4. Offline Certifi-
cate Generation

3. Select the *Entire* Certificate and copy it to a *.txt file or word 
document that can be saved and transferred to another com-
puter.  Then take this file to another computer with internet 
access. 

4. Browse to our Cloud License Activation Site here: 

 http://kinematics.com/spatialanalyzer/cloud.php
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Figure 2-5. Cloud license 
offline registration site

5. Paste the Activation Certificate into the site and press Acti-
vate. This will generate a license Certificate that can then be 
transferred back to the offline computer.

6. Once this License Certificate is entered into the Offline Cloud 
Activation Dialog the cloud license should be successfully ac-
tivate for that machine (Figure 2-6):

Figure 2-6. License Activa-
tion Successful. 

The deactivation process is the same. You will need to go to Help>Spatial 
Analyzer License Management> Cloud License Management and select Deacti-
vate (Figure 2-7):
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Figure 2-7. Deactivate 
Process

The same code generation will process will then follow and the de-
activation can de done with the use of an activation certificate online 
as well. 

Checking License 
Status

You may also wish to view your maintenance subscription informa-
tion, which will indicate the date software maintenance will expire.

To View Your Maintenance Subscription Information:

 ■ From the menu, select Help > SpatialAnalyzer License Management > 
View Maintenance and Support Subscription Status.

To Request Renewal for Your Maintenance and Support Subscription:

 ■ Select Help > SpatialAnalyzer License Management > Request Mainte-
nance and Support Renewal, or

 ■ Choose Help > SpatialAnalyzer License Management > View Mainte-
nance and Support Subscription Status, then click the Request Upgrade/
Renewal button.

Certification
SpatialAnalyzer has been certified by the National Institute of Stan-
dards and Technology (NIST), the Physikalisch-Technische Bunde-
sanstalt (PTB), and the National Physical Laboratory (NPL).

How to Get Help

SA Community Webpages

The SA Community webpage provides an index of key word search-
able help articles, many of which are also linked to helpful YouTube 
videos. Its a great interactive place to start looking for basic informa-
tion on SA and how to get started using it. It can be accessed using 
this URL:

https://kinematics.force.com/SA/s/
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Documentation

If you need help, the definitive source of information is the SA User 
Manual (this document). This document is in PDF format and is fully 
searchable.

To Access the SpatialAnalyzer User Manual:

Do one of the following:

Click the User Manual icon in the Main Toolbar,

Select Help>User Manual, or

In the Windows Start Menu, navigate to the SA install folder, then the 
Documentation subfolder, and select the SpatialAnalyzer User 
Manual link.

Every SA Release has a complete Readme file documenting every 
change to the software, organized by software version. This is often 
a useful source of information, particularly with determining instru-
ment driver compatibility with a given SA version.

To View the SA Readme File:

 ■ Select Help>View the SA Read Me File, or

 ■ From the Windows Start Menu, navigate to the SA install folder, 
then the Documentation subfolder, and select the Release 
Notes link.

Customer Support

If you need help setting up or using SpatialAnalyzer, there are several 
ways that you can reach customer support:

 ■ E-mail. support@kinematics.com

 ■ Telephone. Dial +1 (757) 565-1500 and choose the support 
option (option 1). Be aware that this will transfer you directly to 
a voice mailbox, but your call will be returned promptly.

 ■ Web. Navigate to www.kinematics.com and choose the sup-
port link, or from within SA, select Help>Visit NRK Website!

Regardless of how you contact us, we try to respond to all support 
requests in less than 24 hours.

Context-Sensitive Help

SA has a context-sensitive help system wherein you can click on menu 
items, interface components, or select dialogs in order to be directed 
to that topic in this User Manual.

Tip:  We recommend 
against contacting 

support personnel directly via 
their e-mail address or phone 
number.  Doing so may result 
in a delayed support re-
sponse, as the support 
individual may be out of the 
office or otherwise unreach-
able.

mailto:support%40kinematics.com?subject=Customer%20Support%20Question
http://www.kinematics.com
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To Initiate Context-Sensitive Help:

1. In SA, press Shift + F1. The mouse cursor icon will change
to indicate that you are now in context-sensitive help 

mode.

2. Click on a menu item, toolbar item, or interface item to be 
directed to the topic in the user manual.

Some dialogs have a question mark in their upper-right corner. Click 
this question mark to be directed to the appropriate topic in the doc-
umentation.

Tutorials & Sample Files

SA comes with a variety of sample files to demonstrate some of the 
key features of SA. Most of these sample files are used in the Tutorials 
chapter toward the end of this manual.

To Open a Sample File:

From the menu, select Help>Open Sample SA Files.

Navigating this Users Manual
This users manual is quite large and detailed and it can be difficult to 
know where to start.  The following is a grouping of  chapter headings 
and a brief synopsis of what is contained within each group. The idea 
is to help you know where to go in order to find the information that 
you need. 

An overview of fundamental concepts and guiding principles

SA Fundamentals
This chapter contains a select of fundamental principles that are con-
sidered central to the operation of the software.  These include sub-
jects such as: 

 ■ The architecture of how instruments are connected

 ■ The basic definition of an object

 ■ How measurements are linked to instruments 

 ■ How and when measurements are compensated

 ■ Understanding the working frame
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Getting into the details of operation

Exploring the User 
Interface

This chapter provides a review of the basic tool bars and how they are 
used to manage the data contained in a measurement job.

The Graphical View
As a graphical software, the ability to effectively manage and work 
with  points, objects and surfaces in 3D space is essential. This chapter 
provides the tools to work effectively and report features contained 
in the graphical view. 

Working in SA
The majority of basic operations can be found in this chapter. Its a 
catch all for general operation.

Working With Files
A big part of measurement is managing job files. This section includes 
important subjects such as:

 ■ Creating new files

 ■ Import and export operations

 ■ Backups and restore points

 ■ CAD formats 

The core of measurement - Points and feature measurement

Points
Points are the basis from which virtually all analysis is performed in 
portable metrology. This chapter goes into depth on how points are 
architected from observations, how their properties are managed,  
and various ways to build points and use them for comparison. 

Objects
While points are the key to measurement those measurements need 
to be used for analysis of features such as geometric objects. The ba-
sic geometry types, their inherent properties and construction is re-
viewed in this chapter (see  Analysis for geometry fitting).

Working with Surfaces
Analysis is typically either a comparison of points to a regular geo-
metric shape or a CAD model or surface. This chapter provides some 
fundamental concepts necessary for working with CAD models and 
surfaces. 
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Working with Instruments

Instruments
An instrument model and the measurements associated with it are 
saved within an SA Job. The functions essential to managing these 
instruments are included in this chapter and include:

 ■ Instrument properties

 ■ Scaling an instrument 

 ■ Instrument uncertainties

This chapter also provides an overview of how to connect to a live 
instrument

 ■ Adding Instruments

 ■ Overview of Instrument interfaces 

 ■ Connection methods

 ■ Managing IP based instruments

 ■ Measurement simulation

Measuring with Laser 
Trackers

Details on the laser tracker interface and its operation. Quick-Start in-
formation for specific trackers can be found at the end of this chapter.

Measuring with Arms
Details on the PCMM arm interface and its operation. Quick-Start in-
formation for specific arms can be found at the end of this chapter.

Measuring with Total 
Stations

Details on the Theodolite Manager and both theodolite and total sta-
tion interfaces and their operation. Quick-Start information for spe-
cific theodolites and total stations can be found at the end of this 
chapter.

Measuring with Pho-
togrammetry

Details on photogrammetry interfaces and their operation. Quick-
Start information for specific photogrammetry devices can be found 
at the end of this chapter.

Measuring with the 
Laser Radar

Details on the Laser Radar interface and its operation.
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Measuring with Room 
Scanners

Details on the room scanner interfaces and their operation. Quick-
Start information for specific room scanners can be found at the end 
of this chapter.

Measuring Operating 
Laser Projectors

Details on the Laser Projector interfaces and their operation. Quick-
Start information for specific photogrammetry devices can be found 
at the end of this chapter.

How to effectively move and align measurements for analysis

Alignment and trans-
formations

This chapter provides a list of possible alignment options and the 
steps to conduct these alignments. 

Live view and build it functionality

Watch Windows
Watch windows provide the ability to get a live feedback on a point 
or objects position relative to any other point or object in a job. This 
chapter discusses how.

Analysis, inspection refined alignment operations

Analysis
The fundamentals of geometry fitting, point offset compensation, 
and error visualization are presented here. 

Relationships
Relationships are dynamic links between points and objects. They 
can be used to build dynamic geometry, continually updating vector 
groups and for the most advanced of alignment operations. 

Toolkit Inspection
Geometry Relationships are very powerful tools and have become 
the centerpiece for dynamic inspection. The SA Toolkit provides both 
quick access to important menu features and a streamlined process 
flow. 

GD&T
Standardized inspection is a separate analysis process intended to be 
true to the ASME or ISO standard of your choice. 
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Dimensions & Callouts
Dimensions and callouts provide the tools you will need to annotate 
the graphics both for operator feedback and reporting.

Reporting
This chapter is dedicated to report creation and editing.

Measurement Uncertainty and Unified Spatial Metrology Networks

Measurement Uncer-
tainty

Review of uncertainty analysis

USMN
Advanced uncertainty based network alignments.

Scripting and Automation

Measurement Plan
SA provides a powerful scripting environment called Measurement 
Plan for easy automation of just about any task that can be performed.

SA SDK
SDK provides a means by which to write custom applications that 
utilize Measurement Plan functionality within Visual C++, VB.NET, or 
other development environments that support ActiveX controls. 

Specialized functionality

The OPC Interface
OPC is a communication standard that enables various devices in a 
manufacturing environment to communicate among themselves. SA 
Ultimate provides OPC data server functionality. 

Machine Calibration
SpatialAnalyzer has the unique ability to integrate portable metrolo-
gy measurements for the calculation of true metrology-compensated 
robot and CNC machine calibrations. 

References

Tutorials
This chapter contains an assortment of tutorials covering SA’s basic 
functionality.

Keyboard Shortcuts
A printable page of useful keyboard shortcuts.
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Math References
A selection of useful references for basic calculation processes carried 
out within SA.

End Users License 
Agreement

The SA license agreement.
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Architecture
SA has been designed from the ground up with a very decentral-
ized concept of operation. That is, the software’s various parts do not 
necessarily need to be running on the same computer. Because of 
its network architecture, SA is able to communicate with its various 
instrument interfaces via the TCP/IP network protocol, which permits 
a number of interesting capabilities. In addition, instruments them-
selves can communicate to SA through a wide array of protocols/
interfaces, including TCP/IP, Serial RS-232, Bluetooth, and USB. Each 
method requires that the settings be configured to allow proper com-
munication between SA and the instrument(s).

Figure 3-1. The components 
involved in measuring with an instru-
ment in SA. From left to right: the Host 
(SpatialAnalyzer itself), the Interface, 
and the Instrument.

There are three main components to an SA configuration: The host 

It is important to have a good understanding of SA’s “modus operandi”. 
Having a good fundamental understanding of how SA operates will 
prove to be extremely useful and will make you a more effective user 
of the software. In this section, we’ll describe some of the fundamental 
principles surrounding SA and its use.

SA Fundamentals
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SpatialAnalyzer session, the instrument interface, and the instrument 
(see Figure 3-1).

Host SpatialAnalyzer Session

The host SpatialAnalyzer session is an instance of SA running on a 
computer that will be the destination for measured data. While it is 
usually the same computer as the one running the instrument inter-
face (see Figure 3-2), it can be any computer that is connected via 
TCP/IP on the local network to the computer running the instrument 
interface (see Figure 3-3).

Figure 3-2. A host SA session and 
an instrument interface running on the 
same computer.

The flexibility provided by the separation of host, interface, and in-
strument means that you can run multiple instruments and interfaces 
all in the same SA job.

Figure 3-3. A host SA session and 
an instrument interface running on dif-
ferent computers.

Instrument Interface

The instrument interface is the application that directly connects with 
an instrument, “speaks the instrument’s language”, and directs mea-
sured data to the host SA session. When starting the instrument in-
terface, you must choose which SA session will be the destination for 
measured data--if multiple computers on a network are all running 
SA, any one of them could have measured data sent to it. If not on the 
same computer, the host SA session should be located on the same 
network as the instrument interface. You must also define how the 
interface should connect with the instrument. (For example, which 
COM port, or using which IP address?)

There are two primary requirements in order to start up an instru-
ment interface:
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 ■ In order for a host SA session to be a destination for measured 
data, you must add the appropriate instrument to the job file 
on the SA host, and it must be discoverable on the network.

 ■ In order to connect to the instrument, the interface must be 
able to communicate with it: Either directly via an interface 
such as USB or Bluetooth, or via a network using TCP/IP.

A single instrument interface can connect to only one SA host session 
and only one instrument at a time. However, any one computer may 
run multiple instrument interfaces (connected to different instru-
ments) at the same time.

The instrument interface is the mediator between the SA host and 
the instrument. The interface sends commands to the instrument to 
control its behavior, and the instrument sends data and state infor-
mation back to the interface. The interface then grooms this data as 
necessary and sends it on to the SA host.

Instruments

Each instrument must be able to communicate with its respective in-
strument interface, and therefore must be set up correctly to talk to 
the computer running the interface. This is handled in a number of 
ways depending on the method that the instrument uses to connect 
to the computer. Detailed information on the proper setup for instru-
ments using each communication protocol is found in the Instrument 
Interfaces section.

The following graphics illustrate just a few of the many possible ways 
to connect instruments with SpatialAnalyzer.

Figure 3-4. A single computer con-
nected directly to an instrument via TCP/
IP. This is the most common setup.

In Figure 3-4, since the instrument is connected directly to the host 
computer via a network cable and the TCP/IP protocol, no other com-
munication hardware is required. The interface runs on the same 
computer as the host SA session. This is the most common way to 
connect in SA.
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Figure 3-5. Two computers con-
nected directly to the host computer: One 
via USB, the other via TCP/IP.

In Figure 3-5, one instrument is connected via USB, and the other 
through TCP/IP. The instruments are connected directly to the same 
computer on which the instrument interfaces and the host SA session 
are running. Only one instrument might be running at a time, or two 
instrument interfaces might be running simultaneously in a single 
session of SA.

Figure 3-6. Multiple instruments 
and computers on a local network con-
nected via TCP/IP and an ethernet switch. 
The interfaces may be running on a 
different computer than the host.

With this configuration (Figure 3-6), a connection to the internet is 
not used. Instead, one or more instruments and one or more comput-
ers are connected to a local network through a network hub or switch 
(and the TCP/IP protocol). One SA host computer may be running in-
strument interfaces for all instruments, or the interfaces may be run 
on separate networked computers. Or, three instances of SA might be 
running on three different computers to control the three different 
instruments.

While the configuration in Figure 3-7 is rare, it is technically possible. 
In this case, an instrument is connected via TCP/IP over the internet to 
an instrument interface, perhaps on the other side of the world. The 
interface then connects to the SA host via the local network. As long 
as you can ping the desired instrument from the computer running 
the instrument interface, you can connect to it.
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As you can see, the networked architecture of SA lends immense flex-
ibility to the way that you measure and operate on data. With this set-
up, it is possible for an operator in a metrology office to control a laser 
radar hanging from a gantry crane in a facility on the other side of the 
world. Or, one workstation might be set up to receive measurement 
data, and three operators with laptops might measure data with their 
own instruments and send it to the receiving workstation.

Figure 3-7. Networked configura-
tion. Instrument and interface connected 
via TCP/IP over the internet, and the host 
SA session is connected to the interface 
via a local network.

While there are many different configurations and possibilities, most 
users end up with one of the first three configurations illustrated 
above.

Selection Filtering
In any SA file, there are four main types of entities. Three of them have 
a represented position in space (that is —they have a position and, 
with the exception of points, an orientation), and the fourth encom-
passes everything else. These entity types are described below:

 ■ Points. This includes measured points (recorded by an instru-
ment) and constructed points (created via any other method).

 ■ Instruments. This includes only measurement instruments.

 ■ Objects. Anything that has a position and orientation in space 
that is not a point or instrument is an object. This includes 
entities such as lines, point groups, vector groups, cylinders, 
spheres, planes, surfaces, and point clouds.

 ■ Other. Anything that is not a point, object, or instrument. For 
example, relationships, Measurement Plans, scale bars, charts, 
and vector groups.

Knowing these four entity types is important, because most com-
mands in SA are filtered for the proper entity type. For instance, the 
Edit>Delete Objects command only allows selection of objects—at-
tempting to select a point will choose its parent point group instead 
(because a point is not an object, but a point group is).
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Double Colon Format
When referring to an entity in your SA file, it is important to know 
where it is organized in your job file. For instance, in what collection  
is a specific surface located?

You will notice a specific syntax used in SA in various dialogs to de-
scribe the organizational location of an item in SA. A specific point is 
referred to by listing its containing collection, enclosing point group, 
and target name separated by pairs of colons, which act as separators:

Measured::Tie-Ins::3

This is an unambiguous reference to the point named 3 in the point 
group named Tie-Ins, which is inside the collection named Mea-
sured.

Objects and other entities have a similar syntax, but only the collec-
tion and entity name are used:

Nominal::Centerline

This name refers to an object named Centerline inside the Nomi-
nal collection.

Instruments are referred to by their instrument index number. An in-
strument index number is a unique number that is assigned to each 
instrument in a given collection. The first instrument added to a col-
lection becomes instrument index number 0, the second is 1, and 
so on. When an instrument is moved from one collection to another, 
its index number changes. If the fourth instrument in collection A is 
moved to collection B, and there are already 2 instruments in collec-
tion B, the instrument will change from index number 3 in the old 
collection to index number 2 in the new collection.

The syntax for instruments is similar to that for objects, except instead 
of using an object name, the instrument index number is used in-
stead:

ThisCollection::1

This name refers to the second instrument in the ThisCollection 
collection. Sometimes, you will also see this syntax with the instru-
ment name at the end, such as

ThisCollection::1 - Zeiss ETh 2 Theodolite

The double colon syntax is used in several places in SA—for example, 
when displaying full point names or instrument names in the graphi-
cal view, when viewing an instrument interface, or when working in 
Measurement Plan scripts.
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The Wire Model
One of the most important things to keep in mind when working in 
SA is that measurements are linked and tied directly to the instru-
ment that measured them. If you move an instrument (using 
Instrument>Drag Instruments Graphically) from one area of the SA work-

space (Figure 3-8) to another, you will find that all of the 

Figure 3-8. An instrument has 
measured the surface of this part. Prior to 
alignment, the measured points are not 
yet located to the CAD surfaces.

targets that 
were measured by that instrument also move along with it. You can 
think of each of the measured points as having a straight piece of wire 
between the instrument and the measurement—the instrument and 
its measurements move together as a rigid body.

Figure 3-9. After alignment, the 
points are aligned to the CAD surface. 
Here, the instrument was moved. The 
points just “came along for the ride”.

This behavior has a number of important benefits, and if you stop to 
think about it, the behavior most accurately reflects reality. When a 
measurement is recorded, the instrument provides to SA the position 
of the probe relative to the instrument’s reference system. For spheri-
cal measurement devices such as total stations, laser trackers, and la-
ser radars, this consists of a horizontal and vertical angle and a dis-
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tance component. These three values indicate where the point is 
located relative to the instrument’s reference--usually its optical cen-
ter. The only thing the instrument knows about the measurement is 
the location of that measurement relative to itself—it (typically) 
knows nothing about where the measurement is located in the real 
world.

The link between the position of the instrument and the position of 
the measurement (relative to the instrument) should really never be 
broken, because if the two were to become disassociated relative to 
each other, then the value of the measurement is lost. That is, its posi-
tion (and therefore the measurement) becomes meaningless to us. 
Therefore, it makes sense that SA maintains and keeps track of this 
relationship.

The Alignment Process
Tied to the association between the instrument and its measurements 
is the idea of alignment. Alignment is really the process of positioning 
the digital instrument in the SA file until it ends up in the same cor-
responding position as the instrument in the real world. For example, 
Figure 3-8 shows an instrument and its measurements prior to align-
ment, and Figure 3-9 shows that same instrument after alignment. In 
both cases, the only thing that was moved was the instrument—the 
measurements merely moved as a result of being rigidly tied to the 
instrument. Put another way, the measurements “came along for the 
ride”.

As long as a reference system is measured to properly perform an 
alignment at some later time, alignment is not required to be per-
formed as one of the first steps in the measurement process. If align-
ment to CAD surfaces or other instruments is not required, then there 
is no need to perform any alignment at all.

You can measure features on a part, measure a reference system, 
move the instrument, measure more features and the reference sys-
tem, and then measure again from a third perspective, all without 
once performing an alignment. Only when the analysis is performed 
are the instruments required to be aligned (so that you can extract 
meaningful information from the data). As a result, you can measure 
everything on the shop floor and perform the alignment at your desk 
at the end of the day.

For precise point based alignment options refer to “Review of Avail-
able Alignment Options” on page 398, and when working with point 
clouds refer to “Cloud Based Alignment/Registration Tools” on page 
290.

Note:  If you are performing 
a build operation or need 

on-the-spot comparison of mea-
surements to CAD or to your refer-
ence system, then the alignment 
must be performed at that time.
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Feature Measurement
One important general rule to follow in SA is that each feature should 
be measured into its own point group when possible (see Figure 
3-10). One intended meaning for the term feature in this case is a 
specific portion of a measured part. For instance, measurements on 
the inside of a hole should go into one group, measurements of the 
top surface of the part should go into another, and measurements of 
the side of the part should go into a third. When measuring features 
that represent geometric shapes such as planes, circles, cylinders or 
cones, consider using the SA toolkit (see “Why Feature Based Inspec-
tion” on page 825).

But another intended meaning of feature in this context is to refer 
to any set of related points. So, for instance, all points in a drift check 
should be measured into their own point group, and the reference 
points (fiducials) should be measured into another.

Figure 3-10. Proper feature-based 
organization of point groups. Measure-
ments for each individual feature on this 
part are organized into separate point 
groups.

SA is designed around the assumption that features are measured 
into their own individual point groups. If you follow this rule, you will 
find that working in SA becomes much easier and more intuitive. The 
only time when this rule does not apply is when measuring with the-
odolites. Since theodolite measurement requires at least two obser-
vations to calculate a target position, each observation of a given tar-
get should be measured under the same point.

Offset Compensation
When storing measurements, SA always records the point represent-
ing the center of the probe (SMR, ruby tip, etc). Unless non-contact or 
zero-offset measurement is being performed (such as measurement 
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with a laser radar, scanner, point probe, or photogrammetry), the re-
corded point will not represent the point where the probe touched 
the measured surface, but instead will be at its center (see Figure 
3-11). (For zero-offset measurement, the recorded point is at the 
point of contact). What this means, of course, is that the distance be-
tween the measured point and the measured surface is not zero, but 
is instead equal to the probe radius (also known as the planar offset).

In order to properly compensate for probe offsets, two values must be 
known: the probe offset, and the surface direction. These two proper-
ties are discussed in the following sections.

Figure 3-11. The recorded point for 
any measurement is always at the probe 
center.

Recorded PointProbe

Probe Offsets

When a measurement is recorded, SA stores not only the probe cen-
ter point, but also the corresponding offsets. There are actually two 
offsets used: a planar offset and a radial offset. The planar offset is an 
offset perpendicular (or normal) to the resulting geometry, whereas 
the radial offset is an offset in the plane of the geometry.

The planar offset is used to offset the measured point toward a sur-
face, line, or curve. The radial offset is used to offset measurements in-
ward or outward when measuring or fitting circles and ellipses using 
tooling that introduces a radial offset, such as a pin nest (see Figure 
3-12).
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Figure 3-12. The radial offset is 
used for shifting measurements inward 
or outward when using a pin nest.

Radial O�set

Hole Edges
Probe O�set

Pin Nest O�set

If just a spherical probe is used (such as a ruby tip or an SMR), the ra-
dial offset is ignored (it is never used). If additional target tooling is 
used—such as the pin nest in Figure 3-12, the offsets attributable to 
the additional tooling are included in the point’s offset. For instance, 
the pin nest pictured introduces 0.25” of additional planar offset and 
0.125” of radial offset on top of the SMR’s 0.75” planar offset. This 
yields a total planar offset of 1.0” and a total radial offset of 0.125”.

Whenever a measured point is compared to an object such as a CAD 
surface, line, or curve, probe offset compensation is automatically ap-
plied, and the reported deviation is actually the deviation between 
the point of contact and the corresponding closest point on the ob-
ject of interest. Likewise, whenever geometry is created from mea-
sured points, the resulting geometry is automatically offset from the 
measured points, and the resulting geometry represents the surface 
actually measured.

Obviously, in order for SA to compensate for offsets correctly, the cor-
rect offsets must be stored with the measured points. Offsets should 
be set in the appropriate instrument interface whenever target tool-
ing is changed, and as a result measured points should have the cor-
rect offsets as they are measured. However, if you forget to set the 
proper offsets when measuring, you can always correct them after 
the fact by changing the offsets on measured points. (More informa-
tion on this can be found in the Measurement section).

Surface Normal Direction

In addition to having the proper stored offsets, one additional factor 
is required to be correct in order to perform a properly compensated 
analysis: it is critical that the direction of the surface normals being 
used in any comparison are facing the proper direction. Consider the 
example in Figure 3-13, in which four measurements were taken with 
an SMR at four positions on a measured surface (the blue dashed sur-
face in the illustration). Note that, for clarity, the as-built error in the 
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measured surface is greatly exaggerated here.

Figure 3-13. Proper offset com-
pensation is applied when the surface 
normal faces the side to be measured.

Surface
Normal

Nominal Surface

Measured Surface

Suppose we wish to compare our measurements to the nominal CAD 
part in order to determine whether the as-built part is “high” or “low” 
of the ideal design. When comparing the measured point to the nom-
inal surface, SA first calculates the deviation from the nominal surface 
to the recorded point (the purple vector), and then adds the probe 
offset in the direction opposite to the surface normal (the red vector 
in the illustration). The resulting vector (green) indicates the devia-
tion between the measured surface and the nominal surface. In this 
example, the first three measurements are low of nominal, and the 
last measurement is high of nominal.

To visualize how an incorrect surface normal direction can result in 
incorrect results, suppose that the surface normal in Figure 3-13 is 
accidentally reversed and is now facing the wrong direction (Figure 
3-14), with all else being the same. The deviation from the nominal 
surface to the measured point stays the same (purple vector). Again, 
SA adds the probe offset in the direction opposite to the surface nor-
mal, but since the surface normal is facing the wrong direction, the 
offset compensation is performed in the wrong direction. As a result 
(green vectors), the reported deviation is off by exactly the probe di-
ameter—a very large error!

Figure 3-14. Offset compensation 
applied when a surface’s normal is facing 
the wrong direction. This will result in 
incorrect results!

Surface
Normal

Nominal Surface

Measured Surface

This behavior leads to a golden rule in SA—one that is referred to in 
various places in the SA dialogs. The rule is that in order for deviations 
to be reported properly, all surface normals must face the side being 
measured. Put another way, the surface normal direction for the sur-
faces being compared should point to the side from which you’re ap-
proaching the part with the probe (the other direction should point 
into the part’s “material”).

There is one simple way to ensure that you comply with this rule: 

Warning:  If surface nor-
mals are facing the wrong 
direction, the calculated 

deviation will typically be in error 
by exactly the probe diameter.

Warning:  If stored target 
offsets are incorrect, the 
calculated deviation (or 

the location of geometry result-
ing from a geometry fit) will be 
incorrect.



39

CHAPTER 3 ■ SA FUNDAMENTALS

When working with surfaces, you want to ensure that the normals all 
point toward the “outside” of the object—that is, they should point 
away from the material of the part. If you imagine that your CAD part 
is submerged in the ocean, the surface normals should point to the 
side where the water is touching the surface. Upon importing CAD to 
be used in analysis, one of your first steps should be to ensure that the 
surface normal directions are all correct, and to correct any normals 
that point inward.

For information on identifying surfaces whose normals are facing the 
wrong direction, see the Surface Backsides section in “The Graphical 
View”.

Comparing Measurements to Points and Objects
The fact that SA automatically compensates for probe offsets results 
in a few rules that should be kept in mind when performing compari-
sons between measured points, objects, and surfaces:

 ■ When comparisons between points are performed, the com-
parison is always between centers. Point to point deltas and 
best-fits, for example, always compare center to center. This 
leads to a corollary that if two separate points are to represent 
the same point in space (such as for a reference monument), 
their centers should be coincident. This might seem obvious, 
but if the same point is measured twice with probes that have 
different offsets, a physical target adapter is required to make 
one of the offsets match the other.

 ■ When comparisons between points and objects or surfaces 
are performed, the comparison automatically compensates for 
probe offset.

There are a few cases where you will want to override this behavior 
and ignore offsets, however.

Figure 3-15. Comparing a mea-
sured point with 3/4” offset to a line.

dMag=0.75”

0.75”

For example, suppose a measured point with a 3/4” offset lies directly 
on a line. This would appear in SA as indicated at left in Figure 3-15. A 
normal comparison between the point and the line will indicate a de-
viation of 0.75” as depicted at right, because offset compensation is 
being applied. That is, you are 0.75” from touching the line. Typically, 
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however, in this situation you want to compare the center of the 
probe to the axis. For instance, perhaps you’ve set the probe in a hole 
to take a measurement, and you want to compare the measurement 
to the nominal hole center. In that case, you’ll want to ignore the off-
set so that this situation would indicate a deviation of zero. There are 
several ways to do this in SA, including overriding target offsets to 
zero or using commands that specifically ignore offsets.

Measured Points vs. Cloud Points
It is important to understand the distinction between measured 
points and cloud points, and to know when it is more appropriate to 
use one instead of the other when taking measurements. Both points 
and clouds are discussed in more detail in later chapters—however 
in this section we will discuss the broad differences between the two 
entities.

Measured points carry with them a relatively large amount of over-
head. They are not simply an XYZ coordinate with a name, but ac-
tually store quite a bit of information. As described in “Traceability” 
on page 42, measured points store metadata in addition to the 
measurement itself and its offsets. Weather parameters (temperature, 
pressure, and humidity), RMS data, measurement mode informa-
tion, timestamps, and other information are all stored with a point 
for traceability and documentation purposes. While this information 
is useful and great to have, it also means that a measured point puts 
a relatively large strain on the data processing and computing capa-
bilities of the machine. Storing and handling that wealth of data can 
become relatively stressful on a computer’s resources if there is a very 
large number of points.

Cloud points, on the other hand, are designed for very large quanti-
ties of measurements and are optimized to be much more lightweight 
from a computer resources perspective. Cloud points only store an 
XYZ value. They have no metadata and no individual names or offsets, 
and therefore use the smallest possible computer resources. Instead, 
the point cloud itself (which is the container for the cloud points) 
stores the offsets for the measurements. Although cloud points (col-
lectively known as a cloud) are typically created from scanning devic-
es, they can be created by discrete measurements from instruments 
like laser trackers and portable arms as well.

So the question to answer is: when should a measurement be taken as 
a regular measured point, and when should it be recorded as a cloud 
point? The general rule of thumb is that if you are performing any 
type of surface scanning consisting of a large (>10,000) number of 
points, you should use point clouds. Note that nothing in this rule of 

Note:  All points in a cloud 
should be measured with 

the same offset. If you change 
probes and the offset changes, 
put those points into a different 
cloud.

Tip:  For best performance, 
measure into a cloud when-

ever recording a large number of 
points (>10,000).
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thumb refers to the type of instrument being used. That is—whether 
or not you are using an actual scanner is of no consequence. If you are 
“scrubbing” a surface with an SMR and scanning with a laser tracker, 
for instance, that is considered scanning and point clouds should be 
used.

Unbounded Geometry
There are several primitive geometry types in SA that are unbounded. 
This means that the geometry extends infinitely without bound. For 
an example of this, refer to Figure 3-16.

Although a plane in SA is depicted in the graphical view with a bound-
ary (blue line), this is only so that the plane is visible in the graphical 
view. From an analysis perspective, the plane extends infinitely in two 
dimensions, just as it might be defined in an academic math class. 
Keep in mind that any time you compare a point to unbounded prim-
itive geometry, the geometry will behave as if it extends infinitely 
along its unbounded edges. The following primitive geometry types 
are unbounded:

 ■

Figure 3-16. A plane in SA has a 
graphical depiction (blue lines) so that 
it can be seen, but from an analysis 
perspective it extends infinitely in two 
dimensions. When compared to a point 
beyond its graphical depiction, a plane is 
extended infinitely. The closest point to 
this measurement on the depicted plane 
is shown as a red dot above.

x

y

z

Planes

 ■ Lines

 ■ Cylinders (lengthwise)

 ■ Paraboloids

 ■ Cones

If you would like the geometry to be bounded for analysis purposes, 
it must be converted to a surface (see “Working With Surfaces” on 
page 347).
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The Working Frame
SA has a concept known as the working frame. The working frame is 
a coordinate frame through which all data is represented or mapped. 
Put another way, it is the active coordinate frame. Any coordinate 
frame can be made the working frame, and when a frame is working, 
all data (point coordinates, delta values, rotations) is represented in 
SA with respect to that frame unless specified otherwise. 

It is important to recognize that changing a coordinate frame does 
not physically move anything in space—it merely results in a change 
in the reference system used to represent that same position and ori-
entation. This allows you to take measurements in any arbitrary de-
fault coordinate system and represent them in a system that better 
describes the data. For more information on Frames refer to “Frames” 
on page 313.

A Closer Look
You can assign a frame of reference to a watch window in order to see deviations represented in a given frame regardless 
of the working frame. You can also specify a reporting frame for an object in order to view that object’s properties on a 
report with respect to a specific coordinate frame. (Those values will still be represented outside of reports with respect to 
the working coordinate frame. That is, if you assign a reporting frame to a point group, the coordinates will be represented 

in the active coordinate frame unless viewing them in a report).

The Default Collection
Collections are organizational elements used to contain entities in 
a hierarchy in SA. Just as there is always exactly one working frame, 
there is always exactly one default collection. The default collection 
(colloquially referred to as the working collection) is the organization-
al container inside which all newly created entities are placed, unless 
specified otherwise. For example, if a circle is created as the result of a 
geometry fitting operation, that circle will be placed into the default 
collection.

Traceability
One of the unique features of SA is its traceability. Traceability refers 
to maintaining an unbroken chain of comparisons relating measure-
ments back to a defined standard (Figure 3-17). National measure-
ment institutes such as the National Institute of Standards and Tech-
nology (NIST-USA), the National Physical Laboratory (NPL-UK), and 
the Physikalisch-Technische Bundesanstalt (PTB-Germany) all main-
tain national standards for weights and measures for their respective 
countries. Properly calibrated measurement instruments are evalu-
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ated and certified to this standard, which establishes the first link in 
this chain.

The chain is continued through measurement in SA. Each measured 
point in SA contains an array of metadata that describes auxiliary in-
formation about the measurement, such as the instrument (and serial 
number) that measured it, the time and date it was measured, who 
measured it, weather factors such as temperature/pressure/humid-
ity, and more (see Figure 3-17). This information all helps maintain a 
complete record of the data.

In addition, actions performed in a given job file are logged, and enti-
ties themselves have historical logs that indicate how they have been 
modified throughout their existence. Entities even maintain informa-
tion about how they were created in the first place. All of this infor-
mation helps provide a complete picture of traceability for your mea-
surements. If a specific instrument begins to show anomalies, you can 
look at any previous measurements, perhaps from weeks or months 
earlier, and identify which instrument measured it. This might give 
you cause to question those measurements as well—but without this 
traceability metadata, such a correlation may not have been possible.

NIST further maintains that “Traceability of measurement requires the 
establishment of an unbroken chain of comparisons to stated refer-
ences, each with a stated uncertainty”.1 Measurement uncertainty 
information can also be calculated for any measurement in SA, pro-
viding compliance with this policy but also providing a number of 
additional benefits as well (such as USMN—(see “Unified Spatial Me-
trology Network” on page 721).

Figure 3-17. Some of the traceabil-
ity metadata stored with a laser tracker 
measurement.

1 NIST Policy on Metrological Traceability.
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The SpatialAnalyzer software is fundamentally a three-dimensional 
rendered view of a measurement job, which is displayed in a  Graphi-
cal View window. Around the sides of this window are a set of essen-
tial tools. The treebar is a list the points and objects in the measure-
ment job and a report Bar displays a detailed summary of information 
on the selected item in the job. Finally, across the top is set of Ribbon 
menus or a combination of classic menu bars. 

SpatialAnalyzer provides a user-friendly interface to access all of your 
measurement data. There are often several ways  to perform a given 
task, enabling you to choose a preferred method of interacting with the 
application.

Exploring The 
User Interface
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Figure 4-1. Core Components of 
the SA Application.

 ■ Graphical View. A three-dimensional rendered view of the 
current job. 

 ■ Treebar. A hierarchical view of all entities in the open job. For 
brevity this will typically be referred to simply as the tree.

 ■ Report Bar. Displays important information about the select-
ed item and a convenient way to generate reports.

 ■ SA Ribbon Menu. The ribbon menu or the classic set of menus 
provide access to all of the tools SA offers for analysis and con-
struction purposes. 

Each component comes in a separate window which can be docked 
to  the edge of the screen or to the edge of another window. The com-
ponents can be closed independently to allow you to maximize your 
screen space and to enable you to customize the user interface for 
the specific task at hand.

A series of addition controls can also be added as needed for applica-
tions such as controlling an instrument or running a measurement 
script. At any point if you wish to display an additional toolbar you 
can right-click on any of the toolbar headers and enable additional 
toolbars (see Figure 4-2). 
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Figure 4-2. Right-Click Menu 
allowing access to additional or  hidden 
toolbars accessed from any toolbar 
header.

SA Ribbon Menus
SA can be displayed in either of two modes. It can be shown with the 
classic SA Toolbars (see “Classic Toolbars” on page 57) or with the 
SA Ribbon Menu. To enable or disable the ribbon menu use the check 

box on the Display tab of the User Options . Enabling the ribbon 
display will require you to restart SA but will persist from that point 
on (see Figure 4-3). 
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Figure 4-3. SA Ribbon Menu.

The SA Ribbon Menu is a full replacement for the Main Toolbar, Graphical 
Control Toolbar, Color/WCF toolbar and SA Toolkit.

Ribbon Bar Customization
The biggest advantage of the ribbon menu is its ability to be custom-
ized to fit a user’s needs. It can be streamlined for a user or even for a 
specific task. 

To access the customization dialog. First press the File Menu button 
that takes you to the back Stage ( Figure 4-5). Then Select Options. 
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Figure 4-4. File Menu

The  “Customize Ribbon” option has been added to a resizable Cus-
tomize Options dialog. It presents the ribbon bar structure in a tree 
format and allows to search and locate needed command, add new 
tabs/group/buttons, define own MP-based command, control button 
size and icon, rearrange tabs, hide/unhide tabs/group/buttons,  im-
port/export ribbon bar custom configuration to XML file, customize 
keyboard shortcuts, and etc. ( Figure 4-5).

Figure 4-5. Customize Ribbon 
Dialog. 

 ■ Search Ribbon Bar. The “Search Ribbon Bar” operation allows 
to find a command location on SA Ribbon Bar. User needs to 
enter a keyword and press “Search” button. The found entries 
are expanded and highlighted in the tree. Additionally, there 
are two buttons “+” (Expand All”) and “-“ (Collapse All) may help 
to control the ribbon tree presentation to locate needed item.

 ■ Ribbon Bar Node Visibility. To hide/unhide ribbon bar node 
(tab, group, button, or menu entry), user needs to check/un-
check a corresponding node in the ribbon tree and save the 
changes. A “Select All” button allows quickly check all nodes in 
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a tree. If saved, it will make all nodes in the Ribbon Bar visible. 
The visibility of all default and custom tabs, groups, and but-
tons can be controlled.

 ■ Add New Tab. User can add a new tab to the SA Ribbon Bar. 
Once added, new tab is considered as a Custom Tab.

 ■ Add New Group. User can add new group to any current tab. 
Once added, new group is considered as a Custom Group. User 
needs to select a tab in the tree and press “New Group” button. 
The application automatically adds new groups after the last 
default group of the tab.

 ■ Add New Button. User can add a New Button to a Custom 
Group only. Once added, a new button is considered a Custom 
Button. 

New Button Options

User needs to select a custom group in a tree and press “New Button” 
button. The application automatically adds a new button to a custom 
group and popup “Ribbon Bar Custom Button Settings” dialog where 
user can define the custom button properties and operation Figure 
4-6.



51

CHAPTER 4 ■ EXPLORING THE USER INTERFACE

Figure 4-6. Custom Button 
Controls.

 ■  Button Location. The button location is defined by Tab and 
Group set. The dialog presents the current button’s location. 
User can change the button location by picking new tab or 
group from the combo boxes. The Tab combo box lists all rib-
bon pages that have at least one custom group. The Group 
combo box lists all custom groups of the selected page.

 ■ Button Name. User can define or edit button’s name. Small 
buttons have a single line name. Large buttons may have a 
name presented as two lines.  

 ■ Ribbon Command Based Custom Button. User can select 
and assign a command from default ribbon Tabs. Once select-
ed, the application automatically sets all known information 
to a new custom button including button name, command id, 
screen tips, default icon and button size.  User can modify any 
of these properties through Ribbon Bar Custom Button Set-
tings dialog.

 ■ MP Script Based Custom Button. A custom button can launch 
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a pre-defined MP script. The Ribbon Bar Custom Button Set-
tings dialog allows user to define MP script location (embed-
ded or external file)

 ■ Button Size and Icon. Custom button’s size can be configured 
as large with 32x32 bmp icon or small with 16x16 bmp icon. 
Please note that currently single button launches a single com-
mand. No drop-down menu items for a button are supported. 
When configuring a custom tab, please keep in mind the but-
ton’s size and the space they take. 

For example, the small buttons configuration has the following ad-
vantages: 

 ■ Allow long button name (self-explanatory)

 ■ Three small buttons can create a column on the ribbon tab. 
In the same space only two large buttons can be created. By 
default, the application uses a default button icon. However, 
user can specify location of custom *.bmp file to use instead of 
default.

 ■ Button Screen Tip. User can define screen tips for button op-
eration.

Editing a Custom Ribbon Configuration

 ■ Remove Custom Node. User can remove any created custom 
node (Tab/Group/Button). 

 ■ Edit Custom Node. User can edit any custom Node. Editing of 
custom Tab or Group means renaming. For Custom Button, the 
application automatically opens “Ribbon Bar Custom Button 
Settings” dialog to allow user to change any button’s property.

 ■ Apply. When updating an existing configuration the apply 
button should be used in order to ensure the current settings 
are saved for export.

 ■ Import and Export from XML File. The SA Ribbon Custom 
Configuration can be imported/ exported from XML file.

 ■ Reset to Defaults. The Reset to Defaults operation restore the 
original SA Ribbon Bar configuration. It removes all custom 
nodes, makes all default nodes visible, and restore the original 
order of tabs.
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SA TreeBar

Database Tab

Figure 4-7. The database tab.

The Database tab of the tree displays a hierarchical view of all entities 
in the current job (see Figure 4-7). It’s called the Database tab because 
it reveals all of the entities in SA’s underlying measurement database. 
This provides quick access to items of interest and enables simple but 
effective organization and management of properties. The tree con-
tains items such as instruments, point groups, reports,  embedded 
files, and geometric objects (lines, planes, etc). Headings or parent 
items within the tree can be expanded by clicking on the button to 
expose child data (on some machines, this appears as an icon). Click-
ing the button will collapse these items again. Right-clicking on an 
entry will display a context menu of commands that relate to the se-
lected item.

The hierarchical tree displays a number of different entities depend-
ing on what is present in the current job file:

SA job organizational levels

SA’s database structure and naming is composed of 2 levels: Collec-
tion and item. Some special items like point groups also have subcat-
egory within them (points) which are exposed in the tree. While oth-
ers like point clouds or vectors also include a large number of entries 
(cloud points or vectors) that are not directly accessible from the tree.

Folders. Like folders in Windows Explorer, you can sort collections 
into folders to organize the SA file. 

Collections. An organized collection of entities (objects, instru-
ments, reports, etc) that can be managed as a set in the tree. Collec-
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tions can be moved into a folder or stand alone in the tree.

Point Groups. A series of points (measured or constructed) that are 
conveniently treated as a single object. Each group resides within a 
single collection. 

Additional important Item types:

Frames. Coordinate frames. The World frame is the base coordi-
nate frame for the job file and cannot be moved or edited. A single 
job file may have many frames within it any of which can be desig-
nated as the Working frame for the job. The xyz position of any object 
in the job is reported with respect to the Working frame coordinate 
position. 

Instruments. Measurement instruments—laser trackers, portable 
CMMs, etc.

Additional Items/Objects in the tree:

In SA the term “Object” is used for items that are drawn in the SA 
graphics such as:

Planes. Planar geometry that, while drawn with a finite size in the 
graphical view, extends infinitely in two dimensions.

Circles. Circular geometry.

Cylinders. Cylindrical geometry.

Spheres. Spherical geometry.

B-Splines. Curves that have a mathematical definition and a de-
fined direction along the curve.

Surfaces. Surfaces are parametrically defined and have a complete 
mathematical definition for every point on the surface. They are exact 
representations of a given surface.

Vector Groups. Vector groups represent the deviation between 
two entities as one or more vectors.

Point Clouds. Groups of points typically gathered from non-con-
tact measurement devices (such as a laser line scanner or coherent 
laser radar).

The term Item is used more generally and applies to additional datab-
se items that are in the tree but not part of the 3D world of the SA 
graphics view. These include things like:

Pictures. Imported images or graphical view screenshots that can 
be dragged into SA Reports.

SA Reports. One of several types of reports that can be created in 
SA.

Callouts. Callout views enable you to add captions, labels, and call-
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outs in the graphical view.

Charts. A number of different statistical charts can be created as a 
result of various operations in SA.

Events. Easily-reportable records of significant events (such as fit-
ting geometry, minimizing relationships, or importing a CAD file) that 
have taken place in the file.

Relationships in SA

SA uses the concept of a relationship as a entity that defines the con-
nection between two or more objects. It can either be used for re-
porting or computing dynamic changes in the job. For example a vec-
tor group can be built to define the distance between points and an 
object. If this vector group is build by a relationship it will dynamically 
update if the position of the points and/or object are moved. 

Relationships. Dynamic (continuously updated) comparisons be-
tween entities.

Embedded Files

It can be helpful to use the SA job file as a resource to store additional 
reference materials. This can include scripts and reference files such 
as:

Measurement Plans. Scripted programs that can automate mea-
surement, analysis, and reporting operations.

Embedded Files. Any file can be embedded into an SA file for quick 
access or to conveniently link a file with the SA job.

Graphical Entities. Geometric shapes (such as boxes and pyramids) 
that act as purely visual elements and cannot participate in any analy-
sis.

All of the above items (with the exception of Folders and Collections) 
are actually categories of items. The tree organizes items in a collec-
tion by their category--the individual items of that category are listed 
under the category. For instance, in the Instruments category, there 
might be three actual instruments.

Explorer Tab
The Explorer tab displays the file and directory structure of the local 
computer. This is a convenient way of navigating the disk to find files 
to import into the current SA job.
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Report Bar

Figure 4-8. The Report Bar show-
ing properties for a coordinate frame.

The Report Bar (Figure 4-8) displays the detailed properties of the cur-
rently selected item in the tree. It can also serve as a report generator 
by allowing multiple tabs of information to be compiled into a single 
report. For details on the report bar and reporting, refer to the Re-
porting chapter.

To Toggle Display of the Report Bar:

 ■ Right-click in the menus, toolbars, or status bar area of the in-
terface and select Report Bar from the context menu, or

 ■ From the menus, select Reports>Report Bar Visible.

Status Bar
The Status Bar (Figure 4-9) is a small bar at the bottom of the interface 
that has a number of minor, auxiliary displays. The left side of the bar 
will display any minor, low-importance messages that may arise dur-
ing the course of your work (for example, when copying data to the 
clipboard from the Report Bar).

Figure 4-9. The Status Bar.

To the right of this message area is the SA version. In Figure 4-9, the SA 
version is a date followed by a build number: 2020.07.20_67800. 

Next to the version number are a set of status displays:

 ■ The current active color used if a new object is created.

 ■ The working frame in the job file, which cans as a button allow-
ing you to edit the working frame.

 ■ Current job unit settings

 ■ The three slots to the right of the units display indicate wheth-
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er Caps Lock, Num Lock, or Scroll Lock are active on the 
keyboard (respectively). 

 ■ Two small processor icons on the right side of the status bar 
light up when SA is in a multi-threaded operation.

MP Bar

Figure 4-10. The MP Bar with an 
MP loaded.

The MP Bar (Figure 4-10) is normally only visible when a scripted Mea-
surement Plan has been loaded for execution. The main window lists 
each command of the MP, as well as a pointer indicating the com-
mand which will be executed next, and the status (success, partial 
success, or failure) of each step. The MP Bar has a button to start exe-
cuting the current MP , execute the next step in the MP , and 
terminate/close the current MP . The tabs at the bottom of the 
MP Bar display the primary MP and any MP subroutines currently ex-
ecuting.

Classic Toolbars
Toolbars provide icons for quick access to frequently-used function-
ality and are organized into related groups. There are three factory-
default toolbars that ship with SpatialAnalyzer: the Main Toolbar, Graphical 
Control Toolbar and the Color/WCF Toolbar.

To Hide an Interface Component:

 ■ Click the icon in the corner of the window, or

 ■ Right-click on the menu bar, toolbar, or a window title bar and 
uncheck the component you wish to hide. Check it to show it 
again.

Interface components can be set to auto-hide, so that they collapse 
into a tab at the edge of the screen when not active.  This provides for 
more space to work in other interface windows.
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To Set an Interface Component to Auto-Hide:

Click the icon. When the mouse is moved away from the window, it 
will collapse into a tab (after a short delay). Roll over the tab and click 
the icon to disable the auto-hide behavior.

Figure 4-11. Docking the MP Bar to 
the bottom of the tree.

You can rearrange the positioning of the different user interface com-
ponents using docking. Interface components can be undocked, 
docked to the edge of the application screen, or docked along the 
edge of another interface component.

To Undock an Interface Component:

 ■ Click and drag the title bar for the component away from its 
current position.

To Dock an Interface Component to the Edge of the Screen or Another Component:

 ■ Click and drag the title bar for the component. As you drag, a 
series of boxes representing locations to dock the window will 
appear. Drag over an icon to dock to a specific position (see 
Figure 4-11).

You can customize the user interface, and then save this customiza-
tion to a User Interface Profile.  For more information, see “Custom UI 
Profiles” on page 62.

Main Toolbar

Figure 4-12. The Main Toolbar.

User Manual. Opens the manual (this document) for SpatialAna-
lyzer.

Warning:  User Interface 
Profiles cannot be used 
with the Ribbon Menu.
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New. Starts a new job file.

Open. Opens a saved job file.

Auto Import. Imports a file automatically based on its file type.

Save. Saves the current job file.

User Options. Opens the user options dialog.

Object Properties. Displays the properties of an object after click-
ing the object in the graphical view.

Add Instrument. Adds an instrument to the current job.

Run Instrument Interface. Starts an instrument’s interface.

SA Network. Opens the SA Network Browser.

Rendering Settings. Switches between Wireframe, Hidden 
Line Removed, Solid+Edges, and Solid rendering modes.

Views. Selects, edits, and saves preset views.

Background. Changes the background and highlight colors.

Callout View. Adds callout views to the active collection.

Capture Graphics Picture. Captures the current graphics view as 
an image for use in reports or other documents.

Graphical Control Toolbar

Figure 4-13. The Graphical Control 
Toolbar

Autoscale. Automatically scales the graphical view to fit all visible 
entities.

View Rotation Center. Defines a pivot point for view rotations 
when enabled. Click to enable the mode and select a rotation point. 
Click again to change the rotation point, and double click to exit the 
mode. 

 Instrument View. Provides a means to easily enable the instrument 
view option also available through the instrument’s right-click menu.   
Single click to enable or turn off the mode and double click while ac-
tive to access the settings dialog see “Set Viewpoint From Instrument 
Updates” on page 78). 

  Clipping Plane Mode. This button provides a convenient way to 
both define and check the status of the cloud default clipping plane 
for the job file. Left-Click to build a plane feature and set that plane 
feature as the jobs default clipping plane, setting you to measure it. 
Right-click to select an existing plane. Once set, right-click again to 
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directly access the clipping plane’s offset definitions see “Clipping 
Planes” on page 272).

Graphical Selection Mode. Changes the method for graphically se-
lecting items with the mouse. Single click to toggle between rectan-
gular and polygon selection modes. Double click to open the proper-
ties dialog. 

 Left Mouse Button Overrides. Provides options to control the 
function of the Left mouse button for computers or tablets with only 
1 button. Choose between Left, Right, and middle mouse button op-
eration. R-click (one-shot) provides a single right-button press follow-
ing button selection followed by normal left button operation. 

F2 - Select from a List. Opens the F2 selection dialog.

Enter - End Multiple Selection. Equivalent to pressing the Enter 
key. Ends multiple-select mode.

Color/WCF Toolbar

Figure 4-14. The Color/WCF 
Toolbar.

Color Objects. Changes the color of selected objects in the graph-
ical view.

Working Color.  Changes the working color.

Working Frame. Displays the current working frame 
and allows you to pick a new one.

User Interface Profiles. Used to define and activate custom user 
interface profiles. For more information, see “Custom UI Profiles” on 
page 62.

Toolbars can be rearranged by dragging on their toolbar grips(see 
Figure 4-15). You can completely undock a toolbar from the menus, 
or simply rearrange them. To dock a toolbar back into its original loca-
tion, drag the grip to slide the toolbar back into place.

Figure 4-15. Rearranging a 
toolbar by grabbing its grip.

You can create your own custom toolbars. For more information, see 
“Custom UI Profiles” on page 62.
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Instrument Docking Bar

Figure 4-16. The tracker interface 
inside the Instrument Docking Bar.

 The Instrument Docking Bar (Figure 4-16) is a window that houses 
the currently docked instrument interface. It enables the instrument 
interface, which is actually a separate application from SA, to be 
docked onto one edge of the SpatialAnalyzer interface.

SA Toolkit
The SA Toolkit (Figure 4-17) contains five tabs that provide conve-
nient access to a number of useful SA tools. These tabs include GD&T, 
Relationships, Inspection, Analysis, and Reporting.

 ■

Figure 4-17. The SA Toolkit.

GD&T. Tools for creating GD&T checks from CAD surfaces, 
primitive objects, or directly from points.

 ■ Relationships. Tools for quickly creating various types of rela-
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tionships.

 ■ Inspection. Provides access to a list of inspection-ready items 
with buttons for advancing through the inspection.

 ■ Analysis. One-click access to many analysis tools.

 ■ Reporting. Buttons for creating reports, dimensions, and call-
outs.

UI Themes
A number of standard user interface themes are available to change 
the look of the SA interface. Three of the 14 interface styles are pic-
tured below:

Figure 4-18. Top to bottom: MS 
Office XP, MS Office 2007 (black), and 
MS Office 2003 themes.

To Change the Look of the SA Interface:

 ■ In the View>User Interface Features>UI Theme menu, choose a 
theme from the list. The interface will update immediately.

Custom UI Profiles
Custom User Interface Profiles can be used to customize the Classic 
SA menus. They are not compatible with the ribbon bar and setting 
a custom user interface profile will prevent switching to the ribbon 
display. 

Using Custom User Interface Profiles

A large portion of the SA user interface can be customized. With user 
interface customization you can:

 ■ Add, rearrange, delete, and rename menu items,

 ■ Create custom toolbars and menus,

 ■ Save menu and toolbar docking locations,

 ■ Create custom keyboard shortcuts, and

 ■ Create custom icons.

This allows you to modify an interface to display only the commands 
you use while hiding unused features and leaving more room to work.

User interface settings are saved as profiles, with an .saprofile ex-

Note:  The user interface 
theme is saved as a machine 

setting.



63

CHAPTER 4 ■ EXPLORING THE USER INTERFACE

tension in the Analyzer Data\Templates directory. Once saved, 
they can later be recalled, or easily transferred to another computer 
by copying the file into the same directory on another machine. The 
selected profile becomes the default used when SA starts, and is 
saved as a machine setting.

Figure 4-19. The User Interface 
Profiles dialog.

To Create a Custom User Interface Profile:

1. Do one of the following:

 ■ Click the User Interface Customization button in the Color/WCF 
Toolbar, or

 ■ Select View>User Interface Customization.

2. Click the Customize Current Profile button (Figure 4-19). This places 
you into Customize mode, which allows you to edit the prop-
erties of toolbar and menu items instead of performing their 
equivalent operations. (For details on customization, read the 
following sections). Customize mode ends when you return 
to the User Interface Profiles dialog.

3. When finished customizing the profile, click the Save Current Pro-
file button. Enter a profile name, and click OK.

To Delete a Custom User Interface Profile:

1. Do one of the following:

 ■ Click the User Interface Customization button in the Color/WCF 
Toolbar, or

 ■ Select View>User Interface Customization.

2. Select the profile in the list that you’d like to delete (Figure 
4-19).

3. Click the Delete button. The profile will be deleted from the list 
and from the Analyzer Data\Templates directory.

To Reset to the Factory Default User Interface Profile:

 ■ In the User Interface Profiles dialog (Figure 4-19), choose <Fac-
tory Defaults> from the list, or

Warning:  User Interface 
profiles are not forward-
compatible. Once a pro-

file file is saved, it cannot be 
opened by a previous version of 
SA.
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 ■ From the menus, choose View>User Interface Features>Reset GUI 
Toolbar Layout.

Customizing Toolbars & Menus

The Toolbars tab (Figure 4-20) allows you to show and hide toolbars, 
as well as create your own. Custom toolbars are treated just like  stan-
dard toolbars and act identically. Checked toolbars are displayed, 
while unchecked toolbars are hidden. The following assumes you are 
in customize mode (see “To Create a Custom User Interface Profile:” 
on page 63).

Figure 4-20. The Toolbars tab of 
the Customize dialog.

To Create a Custom Toolbar:

1. In the Toolbars tab, click the Create button.

2. Give the toolbar a unique, descriptive name.

3. The new toolbar will appear in the list, and an empty toolbar 
will appear in the user interface (Figure 4-21).

Figure 4-21. A new custom 
toolbar named MyToolbar has been 
added. Notice the empty toolbar below 
the main toolbar.

While in Customize mode (see “To Create a Custom User Interface Pro-
file:” on page 63), you can modify toolbars as well as menu items. 
You can drag items to create new menus, drag them into current 
menus, or drag them into toolbars.
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To Move an Item:

 ■ Drag a menu, menu item, or toolbar button to the desired posi-
tion. Drag it back to reverse the process.

To Add a Separator Between Items in a Custom Toolbar or Menu:

 ■ Right-click an item and choose Begin a Group. The separator will 
be placed before the selected item.

Figure 4-22. A group separator 
has been added after the Scripts menu.

To Delete an Item from a Custom Toolbar or Menu:

 ■ Drag the item into an “empty” area of the screen (not over any 
menu or toolbar). The mouse cursor will change to , signify-
ing that the item will be deleted, or

 ■ Right-click the item and choose Delete.

To Add a New Item to a Custom Toolbar or Menu:

 ■ From the Commands tab, choose a menu category from the 
list at left. Then drag a command from the list at right to the 
toolbar or menu.

The appearance of items in a toolbar or menu can be changed. You 
can view an item as an icon only, text only, or both. You can even 
modify the icon for an item.

To Change the Appearance of a Toolbar Item:

 ■ Right-click the item and select from either Default Style, Text Only 
(Always), Text Only (In Menus), or Image and Text.

 ■ Default Style. This will display the icon if one is available. Oth-
erwise, it will display text.

 ■ Text Only (Always). This will display the item as text, regard-
less of whether it is on a toolbar or in a menu.

 ■ Text Only (In Menus). This will display the item as an icon 
when in a toolbar (if an icon is available), and as text when in a 
menu.

 ■ Image and Text. This will display both the icon (if available) 
and the text for the item, regardless of whether it is in a menu 
or a custom toolbar.

Figure 4-23. Two icons displayed 
with the image and text option.

To Change the Text Associated with an Item:

 ■ In Customize mode, right-click the item and click in the Name 
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text field. Enter a new name for the item. Note that this will only 
be displayed if the current appearance setting displays text.

 To Reset an Item to its Default Appearance:

 ■ Right-click the item and choose Reset.

To Change a Toolbar Icon’s Appearance:

 ■ In Customize mode, right-click the item and choose Edit But-
ton Image. This will open a simple editor to allow you to modify 
the icon, as depicted in Figure 4-24:

Figure 4-24. The Button Editor.

To Reset a Button’s Image Back to Defaults:

 ■ In Customize mode, right-click the item and choose Reset Button 
Image.

To Copy or Paste a Button Image:

 ■ In Customize mode, right-click the item and choose Copy Button 
Image or Paste Button Image.

To Assign a Supplied Image to an Icon:

 ■ In Customize mode, right-click the item and choose Change But-
ton Image, then choose an image from the list.

Keyboard Shortcuts

You can create custom keyboard shortcuts for virtually every com-
mand available to you in SA. Keyboard shortcuts are defined in the 
Keyboard tab of the Customization window. These keyboard shortcuts 
are saved as part of the custom user interface profile.

Note:  If a command does 
not come with a default 

icon, a custom icon cannot be 
added.
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To Define a Keyboard Shortcut for a Command:

1. In the Keyboard tab (Figure 4-25), choose the desired catego-
ry and command from the list.

2. 

Figure 4-25. Assigning custom 
keyboard shortcuts.

Click in the Press new shortcut key field, then enter the de-
sired shortcut.

3. If the shortcut is currently assigned to another command, it 
will appear in the Shortcut currently used by: field as a warning.

4. Click the Assign button to assign the new shortcut.

To Remove a Keyboard Shortcut:

 ■ Select the Category and Command from the Keyboard tab, then 
choose the shortcut from the Current keys: box and click Remove.

To Reset Keyboard Shortcuts to the Defaults:

 ■ In the Keyboard tab, click the Reset All button.

Options

The Customize dialog provides several additional options for control-
ling the display and behavior of the interface (Figure 4-26).

 ■ Always Show Full Menus. If disabled, menu items which are 
used rarely are not displayed. As a result, only an abbreviated 
menu is displayed. Click the down-arrow in the menu listing to 
view all commands for that menu.

 ■ Show Full Menus After Short Delay. If selected, the abbrevi-
ated menu will be displayed for a moment, followed by the full 
menu. (Disabled if always Show Full Menus is selected).

 ■ Animate Menu When Expanding. Animates the menu as it ex-
pands from the abbreviated menu to the full menu. (Disabled if 
always Show Full Menus is selected).

 ■ Highlight Rarely Used Menu Items. Menu items which are 
not used often will be highlighted.

Tip:  You can assign a key-
board shortcut to a main 

menu item by placing an amper-
sand before the letter that you’d 
like to become the shortcut—for 
example, &GD&&T. This will allow 
you to open the GD&T menu by 
typing Alt+G. To place a single 
ampersand in a menu item, the 
name field must have two con-
secutive ampersands (to distin-
guish it from the keyboard short-
cut assignment), as illustrated in 
this example.
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 ■ Display Menus With Shadows. Renders a shadow around 
menus.

 ■ Large Icons in Toolbars. When selected, large icons will be 
rendered in the toolbars. This is useful for very high resolution 
displays (or poor resolution eyeballs!)

 ■ Large Icons in Menus. When selected, icons displayed along 
menu items will be drawn in large size.

 ■ Show Screen Tips on Toolbars. When selected, displays 
tooltip information for toolbar icons.

 ■ Show Screen Tips on Menus. When selected, displays tooltip 
information for menu items.

 ■ Show Shortcut Keys in Screen Tips. When selected, displays 
the assigned shortcut key for a toolbar item as part of its tooltip 
information.

 ■ Menu Animations. Controls the transition used to display 
menus as they expand.

Figure 4-26. Changing UI options 
in the Options tab.

To Reset the Historical Usage Information for Menus and Toolbars:

 ■ Click the Reset menu and toolbar usage data button.

Language Translation
SpatialAnalyzer comes with seven stock languages:

 ■ English

 ■ Chinese

 ■ French

 ■ German

 ■ Italian

 ■ Portuguese
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 ■ Russian

 ■ Spanish

If you would like to add an additional language, SA has a language 
translation tool that can be used to translate menu items, dialogs, and 
other user interface elements. Language translation files are stored 
as .lan files which can be transferred to different computers and 
loaded into the interface. Several SA resellers also offer ready-made 
language translation files to customers.

Figure 4-27. The Language Set-
tings dialog.

The language translation interface (Figure 4-27) works by storing 
translations from English to a specified language. If a certain phrase 
has not been translated, it will remain in the default English language.

To Make A Stock Language Translation Active:

1. Select File>Language Translation.

2. From the Language Translation dialog, select the desired lan-
guage, then click the Close button. If the window indicates that 
a custom translation is active, it must be deactivated first be-
fore choosing a stock language.

The active stock language will also apply to instrument interfaces un-
less a specific language has been loaded into that interface.

You cannot modify a stock language—it is read-only. However, you 
can create a new translation based off of a stock language, as de-
scribed below.

All custom translation is performed in the Language Settings dialog. 
To access this dialog, click the User Options icon,  and in the Display 
tab, click the Custom Language File button.

To Create a New Language Translation:

1. In the Language Settings dialog, click the New button.

2. In the dropdown, choose Empty Language File to create a new 
language file, or Language File based on to create a custom lan-

Note:  Language settings are 
saved with custom user pro-

files. If you attempt to create a 
new language translation file 
while a custom user profile is ac-
tive, the user interface will be re-
turned to the default.

Note:  After changing the ac-
tive language, you may need 

to restart any running instrument 
interfaces for the new language 
to take effect.
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guage file based on one of the stock languages.

3. Assign a filename for the translation file and click OK.

SA will build a database of phrases to translate and present the NRK 
Language Translation Interface. If the translation is based off of a 
stock language file, you will find that many of the phrases are already 
translated.

To Load an Existing Language Translation File:

 ■ In the Language Settings dialog, click the Browse button, and select 
a language translation file. The translations will immediately be 
applied to the user interface.

To Remove All Translations and Return to the Default Language of English:

 ■ Click the Clear (no translation active) button.

To Edit the Active Translation File:

 ■ Click the Edit Translation File button.

Character Sets

Certain languages (Asian languages in particular) do not use a tra-
ditional Latin character set (standard). To account for this, they may 
require an expanded character set in order to be displayed properly.

To Modify the Character Set Used for Dialogs:

 ■ Click the Standard or Expanded character set (Chinese, Japanese) buttons.

To Modify the Font Type and Size Used for Dialogs:

 ■ Enter a new font name or size into the dialogs.

Creating a Translation

The language translation interface (Figure 4-28) allows any phrase 
that is used in SA to be selected and translated. Once a translation 
has been added for a particular phrase, it will appear translated in the 
interface. The top list contains phrases that have not been translated. 
The bottom list contains phrases that have been translated, and lists 
both the original English and the translated phrase.

To Assign a Name for the Language:

 ■ Type a language name in to the Language Name field, then click 
Apply.

To Search for an Untranslated Phrase:

1. In the top search field, type in a phrase. As you type, the first 
matching item will be highlighted.

2. To find the next result, click the Next Missing Phrase button again.

Note:  The search field al-
lows you to enter phrases 

with wildcard characters (*,?  
and []). For example, to search for 
the phrases “Password Protection” 
and “Projection”, enter 
Pro?ection in the search field.
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To Save the Current State of the Language File and Apply Changes:

 ■ Click the Save button.

Figure 4-28. The Language 
Translation Interface.

To Apply a Translation to a Phrase:

1. Select the phrase from the top list of untranslated phrases.

2. Click the Add button.

3. In the Translation Entry window, enter the translated phrase. 
To automatically assign an ALT keyboard shortcut to a menu 
item, precede the desired letter with an ampersand. To enter 
an ampersand in the phrase, use two consecutive amper-
sands (&&).

4. When finished, click OK. The translated phrase will appear in 
the list at the bottom, and the phrase will disappear from the 
top list of untranslated phrases.

To Edit or Delete a Translated Phrase:

 ■ Select the phrase in the bottom list of translated phrases and 
click Edit or Delete.
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To Search for an Original Phrase (English):

1. Enter the search text in the lower-left search field. As you type, 
the first matching phrase will be highlighted. Wildcard char-
acters (*,? and []) may be used in this search field.

2. To find the next matching phrase, click the Next English Phrase 
button.

To Search for a Translated Phrase (Translated Language):

1. Enter the search text in the lower-right search field. As you 
type, the first matching phrase will be highlighted. Wildcard 
characters (*,? and []) may be used in this search field.

2. To find the next matching phrase, click the Next Foreign Phrase 
button.

To Clear Untranslated Phrases From The Dialog:

 ■ Click the Clear button. All untranslated phrases will be removed 
from the list.

Merging Language Files

Multiple language files can be merged into a single language file. 
Consider translating an instrument interface, which is performed in 
the instrument interface itself. This translation is saved into a sepa-
rate translation file. You can merge an instrument interface transla-
tion file into the SA translation file so that a separate translation does 
not need to be applied to the instrument interface. (This is how the 
stock language files work).

To Merge Language Files:

1. From the NRK Language Translation Interface dialog, click the 
Import button.

2. In the file filter dropdown, change the file type to Language 
File (*.lan).

3. Select the desired language file to merge, then click Open.

4. Confirm the merge procedure. The translated phrases from 
the language file will be merged into the current file.

Using .CSV Files For Translation

Once translations have been applied, converting one language to 
another is made easier with the ability to use .CSV files. Translated 
phrases (those appearing in the bottom list) may be exported to a 
two-column .CSV format, which allows you to simply change a trans-
lation to another language using a spreadsheet program such as Ex-
cel. This way, you can avoid having to click the Edit button for each 
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translated phrase.

To Export Translated Phrases to .CSV Format

1. Ensure the desired phrases to translate already have some 
sort of translation applied to them (so that they appear in the 
bottom list).

2. Click the Export button, and choose a file name for the .CSV 
file.

To Edit an Exported .CSV Translation File

1. In a program capable of working with the CSV format (such as 
Microsoft Excel or Notepad), open the .CSV file.

2. Leave the first column (English Phrases) alone, but change the sec-
ond column (Translated phrases) to the desired language.

3. Save the .CSV file without changing its format.

To Import a .CSV Translation File

1. In the Language Translation Interface, click the Import button.

2. Choose the file to import and click OK. The new phrases will 
load into the translated phrases section of the window.

Figure 4-29. SA with a German 
language translation active.
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The graphical view is drawn as a parallel projection—that is, lines of 
perspective do not converge in the distance but are instead paral-
lel. This is done for a very good reason: there is no “vanishing point”, 
therefore objects appear the same size regardless of their distance 
from the viewpoint. From a practical perspective, this allows you to vi-
sually estimate size and position differences among objects without 
worrying about  whether their distance from the viewpoint is affect-
ing their apparent size.

Navigating the Graphical View
The graphical view provides a graphics-accelerated, three-dimen-
sional rendered view of everything in your job. It allows you to in-
spect, select, and operate on objects graphically. In order to take ad-
vantage of this realistic view of your data, it’s important to be able to 
navigate the view with ease.

Zoom

To Zoom In and Out:

 ■ Hold down Ctrl and click-drag the mouse up or down, or

 ■ Scroll the mouse wheel up/down, or

The graphical view is arguably the most important single display in all 
of SpatialAnalyzer. It allows for graphical selection, provides visual feed-
back, and allows you to visualize your measurements and data.

The Graphical 
View
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 ■ Press the PgUp/PgDn key, or

 ■ From the menus, choose View>View Control>Zoom>In [Out], or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 77).

To Zoom Into a Region of the View:

Hold down the left mouse button, drag the mouse to define a rect-
angle, and release the mouse button. The view will zoom into the de-
fined region.

Autoscale

Autoscale will zoom and center the view so that all visible objects are 
displayed in the graphical view at once.

To Autoscale the View:

 ■ In the main toolbar, click the Autoscale button, or

 ■ In the menu, select View>View Control>Zoom>Autoscale, or

 ■ Press Alt+A, the default keyboard shortcut.

Pan

To Pan the View:

 ■ Hold down the middle mouse button. 

 ■ Hold down the Shift key and drag the mouse in the graphical 
view, or

 ■ Use the keyboard arrow keys (Up, Down, Left, and Right), or

 ■ Select View>View Control>Pan>Up/Down/Left/Right, or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 77).

To Center the View on a Point:

 ■ Middle-click anywhere in the graphical view.

Rotate

To Rotate the View (Freeform):

 ■ Hold down the right mouse button and drag, or

 ■ Use the controls in the Adjust View Components window (see 
“Adjust View Components” on page 77).

The viewpoint can be rotated about an axis perpendicular to the 
screen (this is referred to as spinning the view).

To Spin the View:

 ■ Hold down the Ctrl key and right-click-drag the mouse.
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To Set a Specific Point as the Rotation Pivot Point:

1. On the Main Toolbar, click the View Rotation Center button.

2. Click a point to set the pivot point.

Normally, SA chooses the entity closest to the center of the graphical 
view to become the pivot point for rotation. However, if desired you 
can select a specific point to serve as the rotation pivot point.

To Reverse the View Rotation Sense:

By default, SA uses the Front of Sphere view rotation mode. When ro-
tating in this mode, the rotation center is considered to be at the cen-
ter of a sphere, while the cursor is “stuck to” the front of the sphere 
and spinning it. This rotation sense can be reversed to Back of Sphere 
mode in the User options Machine Configuration tab. Change the Front of 
Sphere Mode setting.

Center In View

If you have an item in the tree and are having trouble finding it in the 
graphical view, you can easily center the view on an object, point, 
instrument. (Does not apply to point groups, point clouds, vector 
groups, annotations, datums, feature checks, or dimensions).

To Center the View on an Item:

 ■ Right-click the item in the tree or graphical view and select Cen-
ter In View from the context menu.

Adjust View Components

If desired, you can control the viewpoint (zoom, rotation, and pan-
ning) through the Point of View dialog. To open the Point of View dia-
log, choose View>View Control>Adjust View Components.

Figure 5-1. The Point of View 
dialog has controls for zoom, rotation, 
and panning, as well as transformation 
dialog increment fields.

Each of these buttons works similar to the manual view operations, 
except that the rotation buttons rotate about axes that are horizontal, 
vertical, or perpendicular to the screen.

This dialog also contains fields for controlling how much an object’s 
position or orientation changes when an up/down arrow is clicked in 

Tip:  Centering the view on a 
point is an easy way to make 

that point the center of rotation.
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a transformation dialog.

 ■ Position. Controls the increment applied to positional values.

 ■ Rotation (deg). Controls the angular increment applied to an-
gular values.

Jumping to Previous/Next Views

It is often useful to jump back and forth among various recent views. 
As you navigate throughout the graphical view, if you remain at a 
given viewpoint for at least one second, SA will store the viewpoint. 
You can then quickly navigate back and forth between previous and 
next views.

These views are not saved with the SA file. If you manually change 
views while at an earlier view in the list, later views are removed from 
the list.

To Navigate Among Previous Views:

 ■ To jump to a previous view, press Ctrl+Alt+← or select 
View>Viewpoint Control>Go to Prev View from the menus.

 ■ To jump to the next view, press Ctrl+Alt+→ or select 
View>Viewpoint Control>Go to Next View from the menus.

Set Viewpoint From Frame

The viewpoint can be set from any existing frame using the View>View 
Control>Set Viewpoint From Frame command. The resulting view will look 
down the +Z axis.

To Set a Viewpoint From a Frame:

1. Select View>View Control>Set Viewpoint From Frame.

2. At the prompt, select the frame you’d like to use for orienting 
the view.

Set Viewpoint From Instrument Updates

The viewpoint can be updated dynamically based upon the current 
probe position and orientation (for instruments that provide 6-DOF 
information such as portable CMM arms). This enables the capability 
to “fly around” a part using an instrument, or to update the viewpoint 
while measuring such that the probe is always visible in the graphics. 
Several configuration options are available (see Figure 5-2).

Note:  The smoothness of 
the transition between 

views is controlled in the User 
Options>Display tab with the 
View animation Steps option.
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Figure 5-2. View from Instrument 
Updates Configuration page

 ■ Update View. This check box enables and disables graphical 
updates based on the probe position. The graphics will be re-
centered when the probe has reached 75% (selectable per-
centage) of the way to the edge of the screen. 

 ■ Clip Behind Probe. This check box enables graphical clipping 
(use of a clipping plane) behind the probe position. This pro-
vides visibility even when objects are blocking the view.

 ■ Automatic Zoom When Trapping. This option adds zooming 
to the graphic control. This is linked to feature trapping such 
that the view zoom depth is set to fit the nominal feature and 
the current probe position. 

 ■ Enable Directional Cloud Points. With this option enabled 
the directional flag for cloud points will be set such that cloud 
points are only viewed from their probing direction. For more 
information see “Directional View Control” on page 260.

 ■ Angle Rest Threshold. This defines how often the view is up-
dated and is the key control when using a 6D probe. The cur-
rent orientation of the probing vector is compared with the last 
saved position and when the angle is greater than the speci-
fied value the graphics will update orientation. Otherwise they 
will remain fixed. 

 ■ Animation Steps. The transition from one view orientation to 
another can be disorienting without some degree of anima-
tion. But too much slow performance. Start low and raise this 
threshold until you find an optimum for your application. 

To Set the Viewpoint Based on Instrument Updates:

1. Select View>View Control>Set Viewpoint From Instrument Updates. Or 
use the menu icon  in the Graphical Control Toolbar 

2. At the prompt (if more than one instrument is available), se-
lect the instrument to use for establishing the viewpoint.

Note:  For some instruments, 
you may need to put the in-

strument interface into a mode 
that sends updates to see an up-
date in the view.
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Set Viewpoint From Object

Any object’s orientation can be used as the basis for a viewpoint. The 
resulting view will look down the -Z axis of the object.

To Set a Viewpoint From an Object:

1. From the menu, select View>View Control>Set Viewpoint From Ob-
ject.

2. At the prompt, select the object to use for establishing the 
viewpoint.

Set Viewpoint From Surface Point

You can also set the viewpoint to look at a surface along its normal.

To Set a Viewpoint From a Surface Point:

1. From the menus, select View>View Control>Set Viewpoint From Sur-
face Point.

2. At the prompt, click on the surface where you’d like to look.

View Clipping

Circumstances might arise in which you want to clip portions of the 
graphical view. Two major examples include:

 ■

Figure 5-3. Viewing a model, 
measurements, and a vector group with 
an active clipping region.

Removing data (such as point cloud data) outside of a region in 
order to simplify the view. This may be done for reporting rea-
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sons (to obtain a clear screenshot for a report) or just to be able 
to more easily work in the view. For example, if you have point 
cloud scans of the inside and outside of a building, you might 
clip away the near “wall” so that you can view the data on the 
inside of the building without also seeing the wall data.

 ■ Displaying a “section cut”. You might do this to “cut away” por-
tions of your CAD or data in order to display only a region of 
interest, as in Figure 5-3.

A clipping region is defined by a box that can be moved or have any 
of its sides scaled along a coordinate direction. The orientation of the 
region (its rotation in space) can be defined by any object, and each 
of the six faces of the box can have clipping enabled or disabled.

To Set A Clipping Region:

1. From the menus, select View>View Control>Clipping Planes or 
press Alt-X.

2. In the Clipping Entities dialog, click the Add button.

3. Select any object to define the initial position and orientation 
of the clipping box.

4. Mouse over the center of a face (it will turn black) and click it 
to toggle that face’s clipping plane.

5. Mouse over the center of any edge (an icon will appear) and 
drag to move the clipping region along that edge’s direction.

6. Mouse over the end of any edge (an icon will appear) and 
drag to grow or shrink the region along that edge’s direction.

7. When you’re happy with your region, click the Close button, or 
leave the dialog open if desired.

To Assign Numeric Boundaries to a Clipping Region:

1. Create the clipping region as described above in “To Set A 
Clipping Region:” on page 81.

2. In the Clipping Entities dialog, double-click on a clipping re-
gion or select it and click the Edit button.

3. In the resulting Clipping Volume Properties dialog, check the 
regions you’d like to be active, and enter desired values for 
each clipping plane.

To Delete a Clipping Region:

 ■ In the Clipping Entities dialog, select the clipping region to de-
lete, then click the Delete button.

You can define as many clipping regions as you’d like. Any of them 
can be activated or deactivated.

Note:  Clipping regions are 
tied to the object used to de-

fine the position and orientation 
of the clipping cube. If the object 
moves or rotates, the clipping 
planes will move or rotate along 
with it.
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To Activate or Deactivate a Clipping Region:

 ■ In the Clipping Entities dialog, check (to activate) or uncheck 
(to deactivate) the clipping region’s checkbox.

Multiple Graphical Views
Multiple graphical views (see Figure 5-4) can be displayed by select-
ing View>New Graphical View Window. This allows you to simultaneously 
view and interact with your job from multiple perspectives.

Figure 5-4. An auxiliary view 
has been opened to view and interact 
with this door panel from a different 
perspective.

Auxiliary graphical views can be rotated, positioned, and rendered in-
dependent of the primary graphical view, and they also support se-
lection.  Hold the Ctrl key while changing the render mode, auto-
scaling, or creating a snapshot of the screen to have the setting apply 
across all open graphical view windows.

You can add as many auxiliary views as you’d like, although more than 
two auxiliary views begins to become unmanageable without mul-
tiple computer displays.

Heads-Up Display
The graphical view has a Heads-Up Display (HUD) that can display a 
variety of measurement information (see Figure 5-5), including:

 ■ Feature Name (if trapping measurements to a feature)

 ■ Last computed Feature RMS (for geometry relationships only)

 ■ Current Point Number (if trapping to a feature with a prescribed 
number of measurements)

 ■ Point coordinates

 ■ Point name (when not trapping)
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 ■ RMS error (if the RMS error of a sampled measurement exceeds 
the warning threshold)

Figure 5-5. The Heads-Up Display.

User Options Controls

To modify or enable the Heads-Up Display you can access the User 
Option controls as follows:

1. From the SA Toolbar, click the User Options icon.

2. In the Display tab, click the Heads Up Display Settings button (Figure 
5-6).

Figure 5-6. The Heads Up 
Display Options dialog.

 ■ In the HUD options dialog, enable or disable the Show hUd 
when a point is measured or trapping is activated checkbox.

Font  Size and Color:
The Font, Font Color, and text transparency can also be set as needed.

 ■ In the HUD options dialog, click the Font button, then choose a 
new font from the dialog.
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 ■ In the HUD options dialog, click the color and choose a new 
color.

 ■ In the HUD options dialog, set the Translucency (0 to 1) field to a val-
ue between 0 (fully transparent) and one (fully opaque).

Display Duration 
In the HUD options dialog, set the Dwell Time before removal option (in sec-
onds) to control how long the text is displayed graphically after a 
measurement is taken.

The Beam Status indicator, displayed as a colored rectangle around 
the graphic view, reflects the beam status of the live instrument in 
the job file. Its used to supliment the toolbar status indicator light for 
greater visibility when measuring away from the computer. The Beam 
Status Indicator is available only in Toolbar Mode with a single live 
tracker in the job file.  

XYZ
By default the XYZ position of each newly measured point will be dis-
played along with the new point name. 

An RMS warning threshold can also be set to display for this point 
through the alarm button in the tracker interface (Figure 5-7).

Figure 5-7. Default HUD display 
showing a newly measured point’s 
name, XYZ potion, and RMS error

 

GR- Feature Trapping
When Trapping is initiated for a relationship, or GD&T datum or fea-
ture check, the name of the active feature will be displayed in the 
HUD along with the number of measurements associated with it in 
brackets [#]. 

The rMS selection in the HUD options dialog is used to control the 
display of the current RMS of the active Relationship and will be dis-
played below the feature point count. Note that the individual point 
RMS warning is displayed on the right hand side of the graphics and 
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is set within the instrument toolbar controls. 

Saved Viewpoints
You can save custom viewpoints in order to quickly return to a preset 
view orientation.

To Save a Custom Viewpoint:

1. Orient the view to the desired position.

2. Click the Views icon in the Main Toolbar, or select View>View 
Control>Set Viewpoint.

3. In the View List dialog, click Add Current, as depicted in Figure 
5-8.

4. 

Figure 5-8. The View List dialog.

In the Preset View dialog, type a name for your custom view 
(Figure 5-9).

5. 

Figure 5-9. Entering the name for 
a custom view.

If you would like the view to restore the current zoom set-
tings, select restore Zoom Settings.

6. To view position and orientation information about the view, 
click the Show Details button.

7. Click OK. Your custom view will now be available in the View 
List:
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Figure 5-10. The custom view has 
been added to the view list.

To Restore a Custom Viewpoint:

 ■ Click the down-arrow next to the Views icon and pick the view 
from the list, or

 ■ In the View List dialog, double-click the desired view or select 
it and choose OK.

To Edit a Custom Viewpoint:

 ■ In the View List dialog, select the view and choose Edit.

To Delete a Custom Viewpoint:

 ■ In the View List dialog, select the view to delete and click Delete.

To Delete All Viewpoints:

 ■ In the View List dialog, click Delete All.

To Restore the Default Viewpoints:

In the View List dialog, click Reset to Defaults.

By default, saved view directions are based on the orientation of the 
world coordinate frame. For example, if a view is saved looking along 
the world frame’s Z-axis, then when the view is restored, it will again 
be looking along the Z-axis of the world frame, regardless of the ac-
tive frame. However, you can choose to restore saved view directions 
relative to the working frame instead. By doing so, restoring the view 
described above would look along the Z-axis of the active frame.

To Restore a Viewpoint Based on the Working Frame:

 ■ In the User Options>Display tab, check the View relative to Working 
Frame option.

Rendering Modes
SA provides four rendering modes for viewing geometry: Wireframe, 
Hidden Line Removed, Solid+Edges, and Solid. The rendering modes 
are selected from the Main Toolbar.

 ■ Wireframe. Geometry is displayed as edges only, and hid-
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den edges are visible, as depicted in Figure 5-11.

 ■

Figure 5-11. Wireframe rendering 
mode.

Hidden Line Removed. Geometry is displayed as edges 
only, but hidden edges are not displayed, as depicted in 
Figure 5-12. 

Here

Figure 5-12. Hidden Line Re-
moved rendering mode.

 is the same view with silhouettes turned on:

 ■

Figure 5-13. Silhouettes have 
been drawn in this hidden line view.

Solid+Edges. Solid surfaces are rendered in addition to 
edges, as shown in Figure 5-14.

 ■

Figure 5-14. Solid+Edges render-
ing mode.

Solid. Solid surfaces are rendered without edges, as depict-
ed in Figure 5-15.

Note:  By default, silhouette 
edges are not rendered in 

Hidden Line Removed mode.  To 
draw silhouettes, in the User 
Options>Display tab, check draw Sil-
houettes in hidden Line removed 
Mode.

Note:  Because of the neces-
sary computation time, each 

time the view is rotated, you need 
to click the Hidden Line Removed icon 
to redraw silhouettes if you want 
to see them. the draw Silhouettes 
in hidden Line removed Mode set-
ting is saved with the SA file.

Note:  When a file is first 
opened, the rendering 

method always defaults to wire-
frame mode. This prevents a po-
tentially lengthy rendering pro-
cess from starting immediately 
after a file is loaded.
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Figure 5-15. Solid rendered mode.

Surface Backsides
Every surface in SA (in addition to other entities, such as planes) has a 
positive and a negative side (see Figure 5-16). In order to properly ac-
count for a probe’s target offsets, it is important that all comparisons 
be performed against the positive side of a surface. In order for you to 
determine the positive side, SA renders the negative side of surfaces 
in a special, user-definable color (a light gray by default).

Figure 5-16. The same surface as 
viewed from the front (left) and back 
(right) with highlight Surface 
Back-sides enabled.

Although the default gray is usually sufficient, you can choose a cus-
tom color to denote surface backsides. It is best to choose an unusual 
color which is not one of the typical working colors.

If desired, you can disable surface backside highlighting so that both 
the front and back  side of surfaces appear in the same color.

To Disable Surface Back-Side Highlighting:

 ■ In the User Options>Display tab, uncheck the highlight Surface Back-
sides option.

To Change the Color of Surface Back-sides:

1. Ensure the highlight Surface Back-sides option is selected.

2. Click the Color button, then choose a new color.

Note:  The highlight Surface 
Back-sides setting is saved as 

a machine setting.
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Background/Highlight Color

Figure 5-17. The Background 
dialog.

The background of the graphical view can be set to a solid color or a 
gradient, and you can also adjust the highlight color used in SA.

To Adjust Background Color Settings:

 ■ Click the Background icon in the Main Toolbar.

To Change the Background Color to a Solid Color:

 ■ Click the Solid radio button, then click the color swatch to 
change the color.

 ■ Click the Black button to change the background color to black.

 ■ Click the White button to change the background color to white.

To Change the Background Color to a Gradient:

 ■ Click the Gradient radio button, then choose a start and end 
color. Specify whether you’d like a horizontal or vertical gradi-
ent.

The highlight color is used when an object is selected or when it is 
explicitly highlighted using the Highlight command.

To Change the Highlight Color:

 ■ Under the Highlight Color section, click the color swatch and choose 
a new color, or

 ■ Click the Auto Set button, which will automatically select a high-
light color that has high contrast when compared to the cur-
rent background color.

Tip:  For fastest rendering, set 
your background to a solid 

color. Solid backgrounds redraw 
faster than gradient backgrounds.
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To Restore the Factory Default Background/Highlight Colors:

 ■ Click the Restore Defaults button.

Hardware Acceleration
If your graphics card supports it, SpatialAnalyzer provides OpenGL™ 
hardware acceleration for the graphical view. This option is enabled 
by default, and provides a significant performance increase—partic-
ularly with complex models and large amounts of geometry.

To Enable or Disable Hardware Acceleration:

1. Open the User Options dialog by clicking the icon.

2. On the Display tab, click the Performance Options button.

3. Check or uncheck the Use hardware accelerated rendering if 
available option (Figure 5-18).

Figure 5-18. Enabling hard-
ware acceleration for faster graphics 
performance.

After changing the hardware acceleration option, it is necessary to 
exit SA and restart for the new setting to take effect.

SA has a built-in Frames-per-second (FPS) monitor that you can use 
to determine whether hardware acceleration is improving rendering 
performance in your job (see Figure 5-19). The FPS monitor displays a 
running average of the rendered frame rate. The progress bar under 
the frame rate shows how “full” the measurement buffer has become. 

Note:  Some graphics cards 
may cause visual artifacts 

with hardware-accelerated ren-
dering enabled. If you see these 
artifacts, first ensure that you 
have the latest drivers for your 
graphics card. If the artifacts per-
sist, disable hardware accelera-
tion.
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For the most accurate value, continue rotating the view until this buf-
fer is nearly full.

To Test the Effectiveness of Hardware Acceleration on Your Machine:

1. Open the User Options dialog by clicking the icon.

2. On the Display tab, click the Performance Options button.

3. Select the display Frames-per-Second (FpS) Monitor option.

Figure 5-19. The Frames-per-sec-
ond (FPS) monitor indicates how quickly 
the graphical view is being redrawn.

Surface Rendering Options
CAD surfaces (sometimes referred to as B-Reps or NURBS—Non-ra-
tional Uniform B-Splines) are mathematically defined and therefore 
have an “exact” representation. However, curved surfaces must be 
converted into a series of approximated flat faces in order to be ren-
dered in the graphical view. The quality of this approximation is de-
termined by the Surface Rendering Options (see Figure 5-20).

Figure 5-20. The Surface Render-
ing Options dialog.

If you find that your curves and surfaces are not being represented 
accurately enough for your liking, or if you see “tearing” in your CAD 
surfaces, you can modify the surface rendering options.

 To Change the Surface Rendering Options:

 ■ In the User Options>Display tab, click the Surface Rendering Options 
button. Choose the desired settings, then click OK.

The adjustable options that affect surface rendering are as follows:

Note:  You will not see a 
framerate that exceeds the 

refresh rate of your display--typi-
cally around 60 fps.

Note:  Surface rendering op-
tions only affect the depic-

tion of the CAD in the graphical 
view.   In calculations, the exact 
surface is always used.
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 ■ Max Trimmed Edge Angle. Specifies the maximum length of 
edge segments for trimmed edges. A lower value gives a high-
er quality representation. Use a value of 0 to default to a low-
quality setting.

Figure 5-21. Max trimmed edge 
angle: 65 (left) and 15 (right).

Note that this setting also applies to spline curves:

 ■

Figure 5-22. Max trimmed edge 
angle: 125 (left) and 5 (right).

Max Facet Chordal Deviation. Specifies the maximum allow-
able distance between a rendered edge and the surface with 
which it is associated. Use a value of 0 to default to a low-qual-
ity setting.

Figure 5-23. Max facet chordal 
deviation of 0.000 (left) and 0.001 
(right).

When laying out points on an object’s vertices, this setting affects 
how many points are constructed.

 ■ Max Facet Edge Length. Specifies the maximum allowable 
length of each edge segment.

 ■ Max Facet Aspect Ratio. Specifies the maximum aspect ratio 
(length vs. width) of each rendered facet.

 ■ Force Re-render of all surfaces. Checking this option will force 
SA to recalculate surfaces using the latest settings in the win-
dow. If unchecked, and surfaces have already been rendered, 
then the settings will not take effect until the file is reopened.
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Labels

Figure 5-24. Point and object 
labels are visible in this view.

Labels can be turned on in the graphical view for displaying names of 
points, objects, and instruments (see Figure 5-24). This is often useful 
for visually distinguishing different objects, but can become over-
whelming in complicated files—so you can toggle label visibility.

You can specify the font with which to display labels, as well as the 
text size.

To Change the Font Used for Labels:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Font Settings... button in the Labels box.

3. Select the desired font, style, size, and color (the other options 
will not apply).

Labels can be controlled individually for points (which also displays 
instrument labels) or objects.

To Toggle the Display of Labels:

 ■ Points and Instruments. Toggle View>Show Point Labels or press 
Alt+L (default keyboard shortcut).

 ■ Objects. Toggle View>Show Object Labels.

Point labels can display just the target name (such as STAR_EAST_5 
in Figure 5-24) or can display the entire collection, group, and target 
name (such as Controls::Network::STAR_EAST_5).

To Toggle the Display of Full Point Names:

1. Click the User Options icon in the toolbar.

2. In the Display tab, check or uncheck the Use Full names check-
box.

Tip:  Displaying a large num-
ber of labels simultaneously 

in the graphical view can signifi-
cantly slow down display perfor-
mance. Hide items not in use or 
turn labels off to speed up display 
speed.
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To Display Instrument Labels Without Point Labels:

1. Click the User Options icon in the toolbar.

2. In the Display tab, uncheck the display Labels checkbox.

3. Ensure that View>Show Point Labels is turned on.

When point labels are enabled, by default they are displayed even 
when the corresponding point is hidden behind a surface. To avoid 
confusion, you can set the graphical view to hide labels for points that 
are not visible from the current point of view.

Figure 5-25. Hide obstructed la-
bels disabled (left) and enabled (right).

To Hide Labels for Hidden (Obstructed) Points:

 ■ Select View>Hide Obstructed Labels.

When point labels are displayed, by default SA will label the axes of 
coordinate frames as X, Y, and Z. This can be disabled.

To Disable Labeling of Frame Axes:

1. Click the User Options icon in the toolbar.

2. In the Display tab, uncheck the draw Labels checkbox in the Co-
ordinate Frames box.

The Hover Window
If you are looking at an item in the graphical view, finding that item’s 
name—or where it is located in the tree—can be a difficult task, par-
ticularly if the file is complicated and has lots of objects. The Hover 
window is a floating dialog, so it can be left up and “floating” over the 
graphical view. When you hover over an item in the graphical view, 
the Hover window will indicate the collection, name, type,  and loca-
tion of the item in the tree, the coordinates of a point (in Cartesian, 
Cylindrical, or Spherical coordinates, the deltas for a vector, or the 
number of measurements associated with an instrument.

Note:  Hiding obstructed la-
bels is computationally in-

tensive and can slow down the 
graphical view considerably. For a 
more efficient method, simply 
hide the points.
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To Toggle Display of the Hover Window:

Do one of the following:

 ■ From the menu, select View>Hover (nearest point), or

 ■ Press Ctrl+H (the default keyboard shortcut), or

 ■ From the Toolkit’s Analysis tab, click the Hover Window

Figure 5-26. The Hover window 
showing the name and coordinates of 
a point.

The Hover window has a filter that you can apply to indicate what can 
be “hovered”.

 ■ Auto. No filter is applied—SA will provide information for 
points, objects, vectors, or instruments—whatever you roll 
over.

 ■ Points. Information will only be displayed when the cursor is 
rolled over a point.

 ■ Objects. Information will only be displayed when the cursor is 
rolled over an object.

 ■ Vectors. Information will only be displayed when the cursor is 
rolled over a vector.

 ■ Instruments. Information will only be displayed when the cur-
sor is rolled over an instrument.

To Set the Hover Window Filter:

 ■ With the Hover window displayed, choose either the auto, 
points, Objects, Vectors, or instruments option.

To Find an Item in the Tree:

1. Activate the Hover window and ensure that the Show in tree 
option is selected.

2. Hover the mouse cursor of the item of interest. The tree will 
be expanded and auto-scrolled to reveal the item, and it will 
be selected.

3. To keep the selection active and the tree expanded, turn off 
the hover window while hovering over an item by pressing 
Ctrl+H.

To Change the Coordinate System for Viewing Point Coordinates:

 ■ In the Hover window, choose the Cartesian, Cylindric, or Spheri-
cal option.
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Object-Specific Rendering Modes
It is often useful to make a specific object or instrument in the graphi-
cal view partially transparent (translucent) or to render it differently 
than other objects. For example, if a measured part has an area of 
insufficient material, its corresponding vector group will point into 
the CAD model. As a result, this vector will be nearly invisible when 
the CAD is rendered in Solid, Solid+Edges, or Hidden Line Removed 
mode. As another example, depending on viewing angle, sometimes 
the instrument’s graphical representation, a surface, or the active co-
ordinate frame will obstruct the work area that you’re most interest-
ed in (see Figure 5-27). A third case might involve a surface that you 
want to see through. While there is always the option of hiding the 
obstructing items, often times it is desirable to keep them visible. In 
such circumstances, translucency allows you to avoid hiding the ob-
jects, but still be able to see through them to the work area.

Figure 5-27. Viewing the work 
area through a translucent instrument.

To Toggle Instrument Translucency:

 ■ Select View>Translucent Instruments.

To Toggle Frame Translucency:

 ■ Select View>Translucent Working Frame.

Surfaces and primitive objects can be set to a specific level of trans-
lucency or can be independently set to render in solid or wireframe 
mode.

To Set the Rendering Mode of an Individual Surface or Primitive Object:

1. Right-click the object in the tree or graphical view.

2. Select Translucency.

3. Select a desired rendering mode. If translucent is selected, 
choose an opacity level with the slider.

To Set the Rendering Mode of Multiple Surfaces or Primitive Objects:

1. Select View>Object Visibility>Translucency>Individual Objects or >All 
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Objects as desired.

2. If >Individual Objects was selected, select the objects of interest 
and press Enter.

3. Select a desired rendering mode. If translucent is selected, 
choose an opacity level with the slider.

Visibility

Figure 5-28. The frame named 
Frame1 in this collection is hidden.

All of the items listed above can be shown or hidden. Hiding an item 
will remove it from the graphical view, and (unless it is a folder or col-
lection) will dim the item’s name in the tree to gray (see Figure 5-29).

Hiding items not in use has a number of benefits, chief of which are:

 ■ The graphical view becomes less cluttered, and it’s easier to 
work with the items of interest.

 ■ If many items are being displayed at once, hiding those not in 
use will speed up the graphics considerably.

 ■ Graphical selection becomes easier, because there are less 
items to pick incorrectly.

To Toggle An Individual Item’s Visibility:

 ■ Right-click the item in the tree or graphical view and toggle the 
Show option.

To Hide or Show All Items In a Container or Category:

 ■ Right-click the container (collection or folder) or category in 
the tree and select Hide All or Show All.

To Hide or Show Individual Points:

 ■ Right-click the point in the tree or graphical view and toggle 
the Show setting to toggle visibility of individual points, or

Select View>Show Points or >Hide Points, then select the points to show 
or hide.

To Hide or Show Multiple Objects:

 ■ Select View>Object Visibility>Hide Objects or >Show Objects.

To Show All Objects:

 ■ Select View>Object Visibility>Display All.

You can also filter the graphical view to display items only from a spe-
cific source. This source can be either SA itself, or an imported CAD 
file. This allows you to immediately hide objects imported from one 
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or more CAD files, or to immediately hide native SA objects.

To Filter The View By CAD Source:

1. Select View>Object Visibility>Filter By CAD Source.

2. In the Show Selected Sources dialog, select the sources you’d 
like to show, then click OK.

3. The filter will apply until you change it again.

Miscellaneous Settings & Commands

View Animation Steps

Sometimes, switching from one saved viewpoint to another can be 
disorienting. If you find that switching from one saved view to an-
other is too jarring, you can increase the number of animation steps 
as the view transitions from one saved viewpoint to another. This has 
the effect of smoothing out (and slowing down) the transition.

To Change the Number of View Animation Steps:

1. Click the User Options icon in the toolbar.

2. In the Display tab, change the View animation steps value. The 
value is the number of frames used to animate from one view 
to the other.

Arrowhead Sizes

You can change the size of arrowheads on vectors with the Line arrow 
size factor setting (see Figure 5-29).

Figure 5-29. Line arrow size 
factors of 0.01 (left), 0.05 (middle), and 
0.1 (right).

To Change the Size of Arrowheads on Vectors:

1. Click the User Options icon in the toolbar.

2. In the Display tab, change the Line arrow size factor setting to a 
different value. A small change goes a long way!

Note:  Vector arrowheads 
also get larger as the vector 

gets longer.
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Scale Indicator

Figure 5-30. The scale indicator. 
These points are approximately 100 
inches apart.

To get a better grasp on the scale of the current zoom setting, you can 
display a scale indicator—somewhat like a distance legend on a 
map—that indicates the size of distances in the graphical view (Fig-
ure 5-30). The scale indicator automatically updates and adjusts itself 
as you zoom in and out in the view.

To Display the Scale Indicator:

1. Click the User Options icon in the toolbar.

2. In the Display tab, check the Show Scale indicator in View check-
box.

Shadow Plane

A shadow plane provides a more advanced way to establish relative 
size and orientation in a 3D space. The grid of the shadow plane will 
adjust dynamically to display the extents of the visible objects in the 
job. It is always oriented parallel to the XY plane of the working frame, 
but will shift vertically to the lowest (-Z) extent of the lowest object. 
This provides a ground level grid in the 3D world of the job file (Figure 
5-31).

Figure 5-31. Shadow Plane

The properties of a shadow plane control the grid scale and color. The 
grid can be set to either dynamically adjust to always display a fixed 
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number of squares or can be set to a fixed grid size, using job units.  
The length and width of each square in the grid is defined by the “ac-
tual Grid Size” value. 

Figure 5-32. Shadow Plane 
Viewed from Above and Below

To help interpret up from down, the shadow plane is colored in solid 
mode from viewed from above and shown only in wire frame mode 
when viewed from below (see Figure 5-32).

A new job will add a shadow plane automatically, although this can 
be turned off in the User Options > Display tab. It behaves like any other 
object in the tree in that it can be moved between collections and has 
properties, but only one can exist at any time in a job file. If it has been 
deleted it can be re-added to the job using View> Show Shadow Plane.

Connection Indicator

If you have more than one instrument in your job file, it may begin to 
get confusing as to which instrument is currently connected to the in-
strument interface (that is, which instrument in the SA file is currently 
live). The connection indicator (Figure 5-33) is designed to highlight 
the connected instrument and prevent the confusion.

Figure 5-33. The connection 
indicator.

You can control whether the indicator is displayed, and if so, how 
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large it is drawn.

To Adjust the Connection Indicator:

1. Click the User Options icon in the toolbar.

2. In the Display tab, enable or disable the Connection indicator 
checkbox.

3. To change the size of the indicator, change the Radius value.

Uncertainty Fields

As discussed in “Measurement Uncertainty”, uncertainty fields allow 
you to visualize the uncertainty of a measurement as a cloud of points 
(Figure 5-34). Uncertainty clouds provide a reference for determining 
relative uncertainty magnitude, shape, and distribution when com-
paring measurements.

Figure 5-34. Viewing uncertainty 
fields for a set of measurements.

You can choose to display these uncertainty fields in the graphical 
view, or to hide them.

To Toggle Display of Uncertainty Fields:

 ■ From the menu, select View>Show Uncertainty Fields.

Uncertainty fields are rendered in the graphical view at a certain mag-
nification level so that they can be easily seen.

To Change the Size of Uncertainty Fields:

1. Click the User Options icon in the toolbar.

2. In the Analysis tab, change the Cloud Magnification value to the de-
sired amount.

By default, uncertainty clouds are drawn as individual dots on the 
screen, each representing a sample of the overall uncertainty cloud. 
For ease of viewing, you may prefer to draw the cloud with lines in-
stead of dots (Figure 5-35).

To Draw Uncertainty Clouds as Lines:

1. Click the User Options icon in the toolbar.
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2. In the Analysis tab, enable the draw using lines option.

Figure 5-35. Uncertainty clouds 
drawn as dots (left) and lines (right).

Highlighting

As a job file grows to hold more objects and measurements, it may 
become somewhat difficult to distinguish objects in the graphical 
view. While hiding items not of concern is probably the most com-
mon solution to this, often times it is faster to simply select an ob-
ject by name in the tree and highlight it. Highlighting an item does 
two things: it changes the item in the graphical view to the current 
highlight color, and it also colors the item in the tree a bold blue. Do-
ing this enables you to pinpoint the selected object while keeping 
all objects of interest visible. In addition to individually highlighting 
objects, you can also highlight points, collections, instruments, and 
folders. (Highlighting a collection or folder highlights everything in-
side that collection or folder).

There are also cases in which simply hiding items does not provide 
sufficient information. For instance, you can right-click a relationship 
and ask it to highlight its associated points or objects in order to iden-
tify which entities are associated with that relationship. This is infor-
mation that cannot be revealed by simply hiding objects.

To Highlight a Point, Object, Instrument, Collection, or Folder:

 ■ Right-click the item in the tree or graphical view and select 
Highlight.

To Highlight the Points or Objects Associated With a Relationship:

 ■ Right-click the relationship in the tree and select Highlight Enti-
ties.

To Clear Highlights:

 ■ Right-click the item(s) in the tree or graphical view and un-
check the Highlight setting, or

 ■ Select View>Clear all Highlights to clear all highlighted items.
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View Refresh

Rarely, you might occasionally find the need to manually refresh the 
view. If you are uncertain that the view updated after performing an 
action, you can refresh the view to ensure that you’re looking at the 
latest rendering of the graphical view.

To Refresh the Graphical View:

 ■ Select View>Refresh from the menu, or

 ■ Press F5, the default keyboard shortcut.

Copying the Graphical View to the Clipboard

You can quickly and conveniently copy just the current graphical 
view to the clipboard for pasting in other applications (such as into 
an Excel or Word document).

To Copy the Graphical View to the Clipboard:

 ■ From the menus, select Edit>Copy graphics to clipboard.

Creating a Movie Capture of the Screen

SA comes with a tool for capturing video of the screen (or certain win-
dows) to a video file. This may be useful for sharing your work with 
others or communicating an important feature to a customer.

To Create a Movie Capture of the Screen:

1. From the menus, select View>Create AVI Movie>New File.

2. When prompted, specify a filename for the resulting video.

3. The Image Capture Options dialog appears (Figure 5-36).

4. 

Figure 5-36. Options for an video 
capture.

Select the desired settings, then click Create AVI File.

Capture Modes



104

SPATIALANALYZER USER MANUAL

 ■ Entire Screen. The entire screen will be captured.

 ■ SA Window. Only the boundary of the SA window will be cap-
tured.

 ■ SA Graphics Window. Only the graphical view will be cap-
tured.

Output Size (pixels)

Controls the resolution of the resulting video file.

Capture Method

 ■ Continuous. Captures frames with a specified delay between 
frames.

 ■ Triggered: Capture when mouse wheel used. Captures a 
frame only when the mouse wheel is used.

 ■ Triggered: Capture everytime the graphics window re-
draws. Captures a new frame whenever the graphical view is 
redrawn.

Frame Rate

 ■ Playback Rate (frames per second). Indicates the playback 
rate of the video—the number of video frames displayed per 
second.

5. If applicable, choose the appropriate video compression set-
tings.

6. Start recording by selecting View>Create AVI Movie>Start Record-
ing or press Alt+1.

To Pause or Resume Video Recording:

 ■ To pause, select View>Create AVI Movie>Stop Recording or press 
Alt+2.

 ■ To resume, select View>Create AVI Movie>Start Recording or press 
Alt+1.

To Finish Recording:

1. First stop recording using the View>Create AVI Movie>Stop Record-
ing command or press Alt+2.

2. Select View>Create AVI Movie>Close File.

Controlling Target Icon Size

You can control the size of constructed and measured points (targets) 
as displayed in the graphical view. Targets can be drawn at a fixed 
size—which does not change regardless of zoom level—or a varied 
size, in which the points get larger as you zoom in. The former avoids 
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clutter when multiple points are spaced closely together, whereas the 
latter gives a visual indication of scale on the current view.

Figure 5-37. Targets displayed 
at 5 pixel size (top) and 15 pixel size 
(bottom).

To Use a Fixed Target Size:

1. Click the User Options icon in the toolbar.

2. In the Targets area of the Display tab, ensure that Fix size in view us 
checked, and enter the desired pixel size for the targets.

To Use a Variable Target Size:

1. Click the User Options icon in the toolbar.

2. In the Targets area of the Display tab, ensure that Fix size in view is 
unchecked. Set the icon radius to the desired size, in job units.
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Selection

Figure 6-1. A selection prompt 
displayed in the graphical view.

SA generally follows the action-Object selection paradigm when it 
comes to issuing menu commands. This implies that you first choose 
a command or operation, and then select the items to which the op-
eration should be applied. Depending on the operation, multiple se-
lection steps may be required. When an object is selected, it will 
change to the selected highlight color and its listing in the tree will 
become bold blue.

You can select entities visually in the graphical view. When an opera-
tion requires a user to make a selection, a selection prompt will ap-

This chapter will help you to learn the ins and outs of working in SA on 
a day-to-day basis, which will speed up your workflow and allow you to 
complete your work as quickly as possible.

Working In SA
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pear as in Figure 6-1.

The entities that you will be prompted to select will depend on the 
selected command (one of the benefits of the Action-Object para-
digm). SA will filter entity types for you, so that if you are prompted 
to select points, you will only be allowed to select points—not instru-
ments or objects.

To Abort a Command and Exit the Selection Mode:

 ■ Press the Esc key. The selection prompt will disappear and the 
command will be cancelled.

In many commands, the prompt permits you to select more than one 
item—usually as many items as desired. You can continue to select 
items using the selection methods below until satisfied, at which time 
you must indicate to the prompt that you are finished selecting items.

To Complete Selection:

 ■ Press the Enter key.

There are several ways to make selections in SA:

 ■ Graphically. Pick items directly in the graphical view.

 ■ Treebar Selection. Pick items using the tree.

 ■ F2 Selection. Pick items from a filtered list.

 ■ Wildcard Selection. Pick items based on naming criteria using 
wildcards.

 ■ By Color. Pick items based on their color.

 ■ By Type. Pick items based on their type.

Each of these selection methods is discussed in more detail in the fol-
lowing sections.

Graphical Selection

One way to graphically select items is to simply click them in the 
graphical view.

To Graphically Select Items One at a Time:

 ■ With a prompt displayed, single-click the item in the graphical 
view. The item’s selection state will be toggled—once selected, 
clicking an item again will remove it from the selection.

You can also graphically select multiple items at one time. To do this, 
SA provides graphical selection modes.

Graphical Selection Modes
There are two graphical selection modes in SA: rectangle and poly-
gon.
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Figure 6-2. Selecting a set of 
points using a rectangular selection 
marquee.

Rectangle mode allows you to draw a rectangle around the entities of 
interest, as illustrated in Figure 6-2. Everything inside the rectangle is 
either selected (or deselected), whereas the selection states of items 
outside of the rectangle remain unchanged.

To Select Multiple Items Using Rectangular Selection:

1. Ensure you are in rectangle graphical selection mode (see 
“Graphical Selection Options” on page 110).

2. While pressing the Shift key, click and hold the mouse but-
ton to define one corner of the rectangle.

3. Drag to the opposite corner of the rectangle, then release the 
mouse button.

Polygon selection mode allows you to draw a polygon of any shape to 
define the selection, as depicted in Figure 6-3.

Figure 6-3. Points are being 
selected through the use of a polygon 
selection marquee.

Items inside the polygon are either selected (or deselected), whereas 
items outside of the polygon are not affected.

Tip:  If you’ve started to de-
fine a selection in the wrong 

place, drag the mouse back over 
the starting corner of the rectan-
gle. When the cursor changes 
back to an arrow, release the 
mouse button. You will remain in 
the selection mode but nothing 
will be selected.

Note:  If you release the Shift 
key prior to releasing the 

mouse button, you will define an 
autoscale region, not an entity se-
lection.

Note:  To remove selected 
items from the selection, 

hold down both the Shift and 
Alt keys.
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 To Select Multiple Entities Using Polygon Selection:

1. Ensure you are in polygon graphical selection mode (see 
“Graphical Selection Options” on page 110).

2. While pressing the Shift key, single-click to define each ver-
tex of the polygon.

3. For the last vertex, locate the mouse cursor where you’d like 
the vertex to be and release the Shift key.

To Change the Selection Mode During a Selection:

 ■ Press the F3 key.

Graphical Selection Options 
The Graphical Selection Mode dialog (Figure 6-4) provides a number 
of options to allow you to control graphical selection. You can pick 
the selection mode as well as define whether entities inside, outside, 
or crossing the selection boundary should be selected.

To Open the Graphical Selection Mode Dialog:

 ■ Choose View>Graphical Selection Mode, or

 ■ Select the Graphical Selection Mode icon from the Main 
Toolbar.

To Change Graphical Selection Modes:

 ■ Choose the rectangle or polygon radio button.

Figure 6-4. The Graphical Selec-
tion Mode dialog allows you to define 
the behavior of the selection marquee.

Note:  To remove entities 
from the selection, hold 

down Shift, then hold down 
Alt and make your selection. 
When finished defining the poly-
gon, release the Shift key, but 
keep the Alt key depressed.

Note:  The graphical selec-
tion mode options will per-

sist until SA is closed.
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To Select Whether Entities Inside or Outside the Selection Region Should Be Selected:

 ■ Choose the Select items inSide shape or Select items OUtSide 
shape radio button.

To Define Whether Entities Crossing a Selection Region are Selected:

 ■ Check or uncheck the Objects must be entirely in or out check-
box.

Treebar Selection

Any item can also be selected in the tree. Selecting items in the tree 
provides an advantage over the graphical view in cases where there 
are many entities overlapping, when the item is not visible, does not 
have a representation in space, or when the geometry of the view 
makes it difficult to determine which items are actually selected.

To Select Items in the Tree:

 ■ With a prompt displayed, double-click the item in the tree. 
Double-click the entity again to toggle its selection state.

F2 Selection

The F2 selection window (Figure 6-5) provides significant advantages 
for selection in cases where multiple items need to be selected. F2 
selection filters out entity types that don’t apply to the current selec-
tion and lists the remaining items in a hierarchical view similar to the 
treebar.

Figure 6-5. The F2 Selection 
dialog.

There are three variants of the F2 selection window: there is a window 
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specific to point selection mode, object selection mode, and instru-
ment selection mode. Each is slightly different and has options par-
ticular to the specific mode.

To Use the F2 Selection Window:

1. During selection (while the prompt is displayed), do one of 
the following:

 ■ Press F2,

 ■ Click the F2 - Select from a list icon in the toolbar, or

 ■ From the menu, select View>Point Selection Tree-View.

2. Select the desired items, then click the OK button.

3. Continue selecting items using other methods (if desired), 
then confirm your selection by pressing the Enter key.

To Expand or Collapse the Entire Tree of Items (Point/Object Selection Modes):

 ■ Click the Expand or Collapse button.

To Select All Items in a Folder or Collection:

 ■ Check the box next to the folder or collection name.

To Select an Entire Category or an Entire Point Group (Point/Object Selection Mode):

 ■ Check the box next to the category/point group (for example, 
Spheres, Point Groups, or Frames).

To Select All But a Few Items in a Category or Point Group (Object/Point Selection Modes):

 ■ Check the box next to the category type, then uncheck indi-
vidual items within that category.

To Select Contiguous Rows of Items (Object/Point Selection Modes):

1. Check the box next to the first item in the list.

2. Hold down Shift and check the box next to the last item in 
the list.

To Select All Items in the List:

 ■ Click the All button.

To Deselect All Items in the List:

 ■ Click the None button.

Wildcard Selection
Wildcard selection is a powerful way to select items by name from the 
F2 window. To use it, click the By name using wildcards button, which opens 
the dialog in Figure 6-6.
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Figure 6-6. The Wildcard Selection 
dialog.

This dialog may appear slightly different depending on whether the 
current command allows you to select points or objects. In this dia-
log, asterisks (*) represent a set of contiguous characters, and ques-
tion marks (?) represent a single character. You can also use [] to select 
a specific character. 

This dialog allows you to enter selection criteria based on collection, 
object, and point names. In each criteria field, enter a search string. 
Any entities that match all of the entered criteria will be selected.

Examples (all based on point selection):

To Select: Enter the following into the fields:

Collection Group Target

All points in all collections * * *

All points in all collections containing 
“Survey”

SURVEY * *

All points in the Survey collection from 
point groups whose names contain 
“Instrument”, followed by any string, fol-
lowed by “Measured”

SURVEY INSTRUMENT*MEASURED *

Selects all points in all collections with a 
“*” at the end of the name 

* * *[*]

To select everything except the items selected by the search criteria, 
check the Inverse Selection Mode option. After completing a wild-
card selection, the items are selected (signified by the checked check-
box next to their entry in the list) but the F2 dialog remains open so 
that you can modify your selection or add to it. You can even add the 
result of another wildcard selection to your currently selected items.

To Select Based on Wildcards:

1. At a selection prompt, open the F2 Selection Window.

2. Click the By Name Using Wildcards button.

3. Type in your criteria, then click OK.

4. Modify the selection as needed, or perform another wildcard 
selection.

5. Click OK to select the items.

Warning:  Wildcard selec-
tion automatically adds 
an asterisk (*) at the be-

ginning and end of your search 
text. This may result in selection 
of more items than desired.

Note:  The wildcard selec-
tion criteria, like all names in 

SpatialAnalyzer, are not case sen-
sitive.
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Selection By Object Type
The F2 selection window enables you to select items by their type 
(see Figure 6-7). Although this is not particularly useful when select-
ing items in a single collection (because those items are already orga-
nized by type and can be easily selected by clicking one checkbox), if 
you have multiple collections of items that you want to select by type, 
this can save you some time.

To Select Objects By Type:

1. In an object selection mode, call up the F2 selection dialog.

2. Click on the By Object Type button.

3. In the Select Object Types dialog, select the object types you’d 
like to select, then click the OK button.

Figure 6-7. Selecting all point 
groups by their object type.

Selection By Color

It may be desirable to use object color to characterize different enti-
ties in the job file. For instance, you may decide to color all nominal 
objects yellow, and all as-built or measured objects blue. If you fol-
low this colorization scheme, then you can easily select all nominal or 
measured objects using selection by color.

There are two ways to select objects by color. You can select graphi-
cally by color, or you can F2-select by color. Both color selection 
modes apply to object selection only, because only objects can be 
assigned a color. When selecting graphically by color, you choose a 
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single item whose color defines the color to select. SA will then auto-
matically also select all objects that match that color. F2 selection by 
color allows you to directly pick a color (not an object) and SA selects 
all objects of that color.

To Graphically Select Objects By Color

1. While in object selection mode, press the F3 key or click on 
the Graphical Selection Mode icon.

2. In the Graphical Selection Mode dialog, click the Select Objects by 
Color (Applies Once) button.

3. Click on an object whose color defines the color you’d like to 
select.

To F2 Select Objects By Color

1. With a selection prompt displayed, press the F2 key or click 
the list selection icon.

2. In the resulting Object Selection dialog, click the By Color but-
ton.

3. In the Select Color dialog, check one of the colors in the list. 
(Only the colors in use in the file will be displayed).

4. Click OK. You will be notified how many objects matched the 
color criteria, and they will be added to your selection.

Context Menus
Context menus play an important part in the SpatialAnalyzer work-
flow. They allow you to select commands directly related to an item 
by selecting that item instead of looking for a command in a menu. In 
some cases, commands are available in context menus and nowhere 
else. To access a context menu, simply right-click an item or object. 
If it has a context menu, it will be displayed adjacent to the mouse 
cursor.

Context menus are frequently used in the graphical view. Right-click-
ing an entity in the graphical view reveals its context menu, allow-
ing quick access to commands related to that entity (see Figure 6-8). 
There are several commands that appear in the graphical view con-
text menus that are not found anywhere else.
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Figure 6-8. The context menu for 
this tire contains a command to reveal 
the surface in the tree.

Right-clicking an entity in the SA tree will also present a context menu 
and is one of the most common actions performed in the tree (Figure 
6-9).

Figure 6-9. The context menu in 
the tree.

Organizing Your Job
In a typical measurement job, you’ll be working with many different 
types of objects in a file: instruments, coordinate frames, measured 
points, geometry, CAD data, reports, and more. Without a way to or-
ganize this data, it would be easy to quickly get lost amongst the va-
riety of entities in the file. Fortunately, SA provides a flexible way to 
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organize this data so that it can be accessed conveniently and with-
out confusion. The primary player in all of this organization is the tree, 
in which the items in your job are displayed in a hierarchical fashion.

Folders and Collections are two primary constructs that enable this or-
ganizational capability.

Folders

Figure 6-10. Multiple folders and 
collections in a hierarchy in the tree.

Folders allow you to sort and arrange your job information in the tree 
in a way that makes the most sense based on the way you work (Fig-
ure 6-10). You can create nested folders and move collections from 
one folder to another. You can expand and collapse a folder hierarchy, 
hide folders, rename and move folders, and change their order in the 
tree. Folders can only contain other folders or collections. You cannot 
put an instrument, point group, coordinate frame, or any other entity 
directly inside of a folder.

To Create a New Folder:

 ■ Right-click an empty area of the tree or on any folder and 
choose New Folder.

To Create a New Sub-Folder:

 ■ Right-click the folder you’d like to be the parent of the new 
sub-folder, and choose New Sub-Folder.

To Delete a Folder:

 ■ Right-click a folder in the tree and choose Delete. All items with-
in the selected folder will be deleted.

To Delete Multiple Folders by Name:

1. From the menu, select Edit>Delete>Delete Folders By Wildcard...

2. Type a wildcard search criteria (*,? and []) are allowable 
wildcard characters) into the Search Criteria field.

3. Click the OK button and confirm the deletion action.

To Rename a Folder:

 ■ Right-click the folder and choose Rename.

To Expand or Collapse an Entire Folder Hierarchy:

 ■ Right-click the folder and choose Expand All or Collapse All.

To Change the Order of Folders in the Treebar:

 ■ Right-click a folder and choose Change Order In List>Move Up (Move 
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Down).

Collections

A collection refers to a group of objects, measured data, reports, and 
other entities that can be managed as a group from the tree, and as 
depicted with an open box icon . This “collection” of objects serves 
to group related data in a logical manner, making measurement and 
analysis more intuitive.

A job may have any number of collections. However, only one of these 
collections may be the active collection at any one time. When a col-
lection is active, it is considered to be the default collection. Any new-
ly-created entities (e.g., Points, Instruments, Planes, Lines, Reports, 
Relationships, etc) are created in the active collection unless a differ-
ent collection is explicitly specified. The active collection is depicted 
in the tree by a bold blue font. Notice in Figure 6-10 that any folders 
enclosing the active collection are also highlighted with a bold blue 
font so that you can find the active collection if the folder hierarchy is 
collapsed.

To Create a New Collection:

 ■ Right-click an empty area of the tree, any collection, or any 
folder and choose New Collection, or

 ■ Measure a point or object into a collection that does not al-
ready exist (see Measurement).

To Rename a Collection:

 ■ Right-click the collection in the tree and choose Rename.

To Delete a Collection:

 ■ Right-click a collection in the tree and choose Delete.

To Delete Multiple Collections:

 ■ Right-click a collection in the tree and choose Delete Multiple Col-
lections, or

 ■ Right-click an empty area of the tree and choose Select Collec-
tions to Delete.

To Delete Multiple Collections By Name:

1. From the menu, select Edit>Delete>Delete Collections By Wildcard...

2. Type a wildcard search criteria (*,? and []) are allowable 
wildcard characters) into the Search Criteria field.

3. Click the OK button and confirm the deletion action.

To Copy a Collection:

 ■ Right-click a collection and choose Copy.

Note:  If you measure 
points  (through an instru-

ment interface) into a collection 
that does not already exist, the 
collection will be created auto-
matically for you.
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To Change the Order of Collections in the Treebar:

 ■ Right-click the collection and choose Change Order In List>Move Up 
(Move Down).

To Make a Collection Active:

 ■ Right-click the collection and choose Make active default collection.

To Move a Collection to a Folder:

1. Right-click the collection and choose Move Collection to Folder.

2. Choose the destination folder from the resulting dialog.

When objects are created inside of a collection (either explicitly or as 
the result of an operation), SA automatically organizes those objects 
by their type inside what is referred to as a category. A category is 
simply a container that holds all like items in a given collection. For in-
stance, all point groups in a given collection are placed into the Point 
Groups category, and all instruments in a collection are placed into 
the Instruments category. This behavior makes it easy to keep your 
file’s elements organized by type.

Relocating Items to Another Collection

A common use for collections is to organize nominal and measured 
data separately. Another use is for organizing multiple states of mea-
sured data (for instance, measuring an assembly at various stages in 
the production process). You may occasionally come across the need 
to move items from one collection to another.

To Relocate an Item to Another Collection:

1. Right-click the item in the tree or graphical view and select 
Move to Another Collection from the context menu.

2. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The item will be moved 
into the destination collection.

To Relocate Multiple Objects to Another Collection:

1. From the menu, select Edit>Relocate Objects to another Collection.

2. Select the objects you’d like to relocate.

3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The objects will be moved 
into the destination collection.

To Relocate Multiple Instruments to Another Collection:

1. From the menu, select Edit>Relocate Instruments to another Collec-
tion.

2. Select the instruments you’d like to relocate.

Note:  To move a collection 
out of all folders, choose the 

Root folder as the destination.

Note:  A common mistake 
for new users is to try to dou-

ble-click a category in the tree to 
select it. You must expand the cat-
egory to reveal the actual items 
inside it.
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3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The instruments will be 
moved into the destination collection.

To Relocate Multiple MPs to Another Collection:

1. From the menu, select Edit>Relocate MPs to another Collection.

2. Select the scripts you’d like to relocate.

3. In the Select Collection dialog, double-click the destination 
collection (or select it and click OK). The MPs will be moved 
into the destination collection.

Rearranging Points

At some point while working in a file, you will likely want to rearrange 
your points by moving them from one point group to another. There 
are several ways to do this.

To Relocate Points into a Separate Group:

1. From the menu, select Construct>Points>From Existing Points>Move.

2. Select the points to relocate.

3. In the dialog, enter a name for a new group into which to 
place the points. This group must not already exist.

4. The points will be removed from the current group and placed 
into the new group. The point names will be prepended with 
the source group name.

To Relocate a Single Point into a Different Group:

Renaming a point and giving the point a different collection or group 
will move it into that collection/group. If the collection or group does 
not already exist, it will be created for you.

1. Right-click the point to relocate and choose Rename from the 
context menu.

2. In the Rename Point dialog, enter a new collection or group 
name, then click OK.

The Group Manager
You can rearrange points in an intuitive way using the Group Man-
ager. The Group Manager is a Windows Explorer-like dialog that al-
lows you to drag and drop points from one group to another, and also 
provides the capability for renaming, group creation/deletion, search 
and replace, sorting, and more.

To Call Up The Group Manager:

 ■ From the menu, select Edit>Group Manager...

The Group Manager is shown in Figure 6-11.
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Figure 6-11. The Group Manager.

On the left side of the group manager is a list of all groups in your job, 
organized by collection. At right is a list of the points in the selected 
group, as well as their coordinates.

To Create a New Group:

1. Right-click anywhere on the left side of the Group Manager 
and select New from the context menu.

2. Type a new group name, then click OK.

To Delete a Group:

 ■ Right-click a group on the left side of the Group Manager and 
select Delete from the context menu.

To Rename a Group:

1. Right-click a group on the left side of the Group Manager and 
select Rename from the context menu.

2. Enter a new name for the group, then click OK.

To Relocate Points to a Different Group:

1. Select the points to relocate from the right side of the win-
dow. You can only select points from one group at a time, al-
though multi-selection is allowed.

2. Do one of the following:

 ■ Drag the selected points to the destination group, or

 ■ Right-click the selection and select Cut from the context menu, 
then right-click the destination group and select Paste from the 
context menu.

To Copy Points To Another Group:

1. Select the points to copy on the right side of the window. You 
can only select points from one group at a time, although 
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multi-selection is allowed.

2. Do one of the following:

 ■ Right-click the selection and choose Copy from the context 
menu, then right-click the destination group and select Paste 
from the context menu, or

 ■ Right-click the selection and choose Copy selections into a New 
Group from the context menu. Type a new group name, then 
click OK.

To Create New Points:

1. Select the group to contain the new points on the left side of 
the Group Manager.

2. Right-click the right side of the window and select New from 
the context menu.

3. Enter the Cartesian coordinates for the point, then click OK.

4. Enter the name for the new point, then click OK.

To Delete Points:

 ■ Select one or more points, then right-click the selection and 
choose Delete from the context menu.

To Sort Points by Name or Coordinate Value:

 ■ In the Group Manager, click a column header to sort by that 
value. Click again to sort in the reverse direction.

To Find Points:

1. Right-click a point or selection (select points to search 
amongst first, if desired) and select Find... from the context 
menu.

2. Type a search string, and choose either the Selection option to 
search the selection, or the Group option to search the entire 
group.

3. Click the OK button. The list of points will be filtered to show 
only the matching points. (Click the group name to reset the 
list).

To Perform Search and Replace in Point Names:

1. Select points (if desired), then right click the selection and 
choose Replace... from the context menu.

2. In the Replace dialog, enter text to search for, and the text to 
replace it with. Choose Selection, Group, or All to indicate whether 
you want to search among the selection, entire group, or all 
points.

3. Click the OK button. All matching text substrings are replaced.
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To Access Point Properties:

 ■ Double-click a point in the Group Manager, or

 ■ Right-click a point and select Properties from the context menu.

To Access Group Properties:

 ■ Right-click a group and select Properties from the context menu.

Naming & Renaming Items

If you create objects in SA without properly naming them—that is, 
by using the default names provided by SA—you will soon find that 
your job file becomes completely unmanageable. In all but the sim-
plest of measurement files, there are enough entities created that you 
can quickly lose track of what each entity represents. Therefore, best 
practice is to clearly name all items in your file when you create them. 
Doing so makes the file easier to work with, keeps it organized, and 
also allows you (or another person) to look at the file perhaps years 
later and still understand the data inside it.

Choosing a name is entirely up to you, although there are a few rules 
that should be followed.

 ■ Names are not case-sensitive. A group named TEST is not dis-
tinguishable from a group named test.

 ■ Spaces are allowed, but depending on the letters surrounding 
the space, it is often difficult to determine if a name contains 
a space at all (or perhaps multiple spaces). If you’re worried 
about potential confusion, avoid the use of spaces.

 ■ Multiple points in the same point group cannot have the same 
name. They must be unique.

 ■ Multiple objects may have the same name in a given collec-
tion, however this is not recommended if you expect to use 
scripting (Measurement Plans), as this leads to potential am-
biguity within your script as to which object you are referring.

 ■ Avoid long consecutive sequences of numeric digits at the 
end of a point or group name. Keep them to less than 20 dig-
its. (Otherwise, incrementing and decrementing of point and 
group names will not function correctly).

To Rename a Group of Points:

Do one of the following:

1. Do one of the following:

 ■ From the menu, select Edit>Rename>Group of Points, or

 ■ Right-click a group in the tree and select Rename from the con-
text menu.

2. At the prompt, enter a new name for the group, then click OK.
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To Rename a Point:

1. Right-click a point and select Rename from the context menu, 
or select Edit>Rename>Single Point.

2. At the prompt, enter a new Collection/Group/Target name (as 
desired), then click OK.

To Rename Objects:

 ■ Right-click the object and select Rename from the context menu. 
(If this menu item is not available, choose the Properties menu 
item and the name will be found in that dialog).

Renaming Using Unique Names

Figure 6-12. Automatically 
removing duplicate names.

Occasionally, you will be presented with a file in which several objects 
have the same name. This is sometimes the case when importing an 
external CAD file, for instance. You can easily automatically rename a 
series of objects, ensuring that they all have unique names (Figure 
6-12). SA will rename the objects by appending the type of object 
with a unique number and using that for the new name.

To Rename Objects Using Unique Names:

1. From the menu, select Edit>Rename>Objects by Assigning Unique 
Names.

2. At the prompt, select the objects to rename.

SA will rename each of the objects in turn, ensuring that the names 
are unique.

Renaming Using A Name Pattern
You can rename points and objects using a name pattern. Suppose 
you wish to rename a set of objects and call them Obj1, Obj2, Obj3, 
etc. This would use a name pattern that looks like this: Obj%d. When 
renaming using a name pattern, you can specify any prefix or suffix 
for the name, then add the wildcard %d to the search field. The %d 
characters will be replaced by an actual number when the command 
is performed. By default, the first number is 1, but you can specify 
your own starting value.

To Rename Objects Using a Name Pattern:

1. From the menu, select Edit>Rename>Objects Using a Name Pattern.

2. Select the objects you’d like to rename.

3. In the Pattern for Rename dialog (Figure 6-13), specify the 
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pattern and a starting value, then click OK.

Figure 6-13. Renaming a group of 
objects using a name pattern.

To Rename Points Using a Name Pattern:

1. From the menu, select Edit>Rename>Points Using a Name Pattern.

2. Select the points to rename.

3. In the Pattern for Rename dialog (Figure 6-13), specify the 
pattern and a starting value, then click OK.

Renaming By Proximity
Renaming by auto-corresponding to points uses a group of points as 
a name reference. A different group of points is then renamed based 
on the reference group’s names.

You can rename points by proximity to a set of reference points. This 
is extremely useful for quickly renaming points in preparation for a 
Point to Point Best-Fit operation. When renaming by proximity, SA will 
search for a point in a reference group that is closest to a point in the 
group to rename. As long as the reference point is within the speci-
fied threshold, the point to rename will be assigned the same name 
as the reference point (see Figure 6-14). Note that the reference group 
and group to rename need not have the same number of points. 

Figure 6-14. Before renaming 
points by proximity (left) and after 
(right).

The renaming operation is controlled by a proximity distance Match 
tolerance. This is the furthest that a reference point can be located 
relative to the point to rename to be considered a match. If more than 
1 point is within the tolerance specified the points will be renamed 
and incremented numerically using the reference name as a base (for 
example TB1, TB1-1, TB1-2, etc). 

Probably the most common use for this is when remeasuring a set of 
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tie-in points after an instrument has drifted (moved) beyond the de-
sired threshold. After remeasuring the tie-in points, since the instru-
ment has only slightly changed position, they will be relatively close 
to the nominal tie-ins. In this case, you need not be concerned with 
the proper naming of the points. Simply measure them, and SA will 
take care of automatically renaming them for you.

To Automatically Rename Points by Proximity:

1. From the menu, select Edit>Rename>Points by Auto-Corresponding 
2 Groups>Proximity.

2. At the prompt, select the reference group—you may need to 
select it from the tree. This is the group containing the proper 
point names that you’d like to assign to the other group.

3. At the second prompt, select the group to be renamed—you 
may need to select it from the tree.

4. In the Input dialog, specify the Proximity Distance Match Tolerance.

5. If any matches are found within the specified threshold, you 
will be presented with the Residuals dialog. This dialog lists 
the original point names, and their proposed new names. 
Click the Save to File button to save this list to a text file, or the 
Accept button to accept the proposed new names.

Renaming By Inter-Point Distance

Figure 6-15. A set of points before 
renaming by inter-point distance (left) 
and after (right).

You will often want two sets of points to have matching correspond-
ing point names. Suppose you have a set of nominal reference points 
in your SA file that you’d like to use for tie-ins. Assuming your instru-
ment hasn’t yet been located to the nominal points (as it typically will 
not be), the measured points will not be close to the reference points. 
In order for a Point to Point Best-Fit operation to successfully execute, 
corresponding point names must match up. If you forget to name the 
points correctly as you measure them, the fit will not succeed. While 
you could manually rename each individual point, this command 
performs that process automatically (Figure 6-15), and is a big time-
saver in this situation. The command is governed by an inter-point dis-
tance match tolerance. This tolerance is the maximum allowable differ-
ence between the spacing of any proposed pair of renamed points 
and the corresponding spacing of that same pair of points in the ref-

Note:  If (due to the thresh-
old) matches are found for 

some points but not others, 
points that did not have matches 
will have Orig. prepended to the 
point name. This is to ensure 
uniqueness—another point that 
did have a match may have been 
renamed to the unmatched 
point’s name.

Note:  If the threshold is very 
large, SA will only use the 

closest reference point to each 
measured point.
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erence group. If the difference exceeds this value, the set is not con-
sidered a match.

Note that the reference group and group to rename need not have 
the same number of points. Any points that don’t match will be ig-
nored.
To Rename Points By Inter-Point Distance:

1. From the menu, select Edit>Rename>Points by Auto-Corresponding 
2 Groups>Inter-Point Distance.

2. At the prompt, select the reference group containing the de-
sired point names.

3. Then, select the group containing the points to rename.

4. In the Input dialog, enter the desired Inter-point distance match toler-
ance.

5. If any matches are found within the specified threshold, you 
will be presented with the Residuals dialog. This dialog lists 
the original point names, and their proposed new names. 
Click the Save to File button to save this list to a text file, or the 
Accept button to accept the proposed new names.

Deleting Items

To keep your job file clean, you should delete any items that you no 
longer need. If you are certain that a measurement was erroneous, for 
instance, it is best to delete it on the spot and remeasure. This mini-
mizes clutter in the job file and helps make the file more understand-
able. There are numerous ways to delete items in SA. For a generic 
delete function choose Edit>Delete>Delete Database Items. This will allow 
you to choose items both from the tree and from within the graphics. 

For a filtered List of items to delete select from the following:

To Delete Objects:

Objects within SA include primary level graphical entities such as ge-
ometry, surfaces or point groups.

1. From the menu, select Edit>Delete>Delete Objects, or press the 
Delete key. You can also use the F2 key to bring up a list.

2. Select the objects to delete.

To Delete an object directly within the graphics you can also:

1. Right-click the item in the tree or graphical view.

2. From the context menu, select Delete.

To Delete Points:

Points are not considered Objects because the are included within a 

Note:  If (due to the thresh-
old) matches are found for 

some points but not others, 
points that did not have matches 
will have Orig. prepended to the 
point name. This is to ensure 
uniqueness—another point that 
did have a match may have been 
renamed to the unmatched 
point’s name.

Note:  If the threshold is very 
large, SA will only use the 

closest reference point to each 
measured point.
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Point Group. For that reason they require a special selection method:

1. From the menu, select Edit>Delete Points, or press Alt+D.

2. Select the points to delete by holding shift and rectangle se-
lecting in the graphics. You can also use the F2 key to bring up 
a list of points to select from.

Points can also be deleted within proximity to a reference group. To 
do so select Edit>Delete Points>Corresponding to Reference Group by Proxim-
ity. This utility will allow you to select a set of reference points and de-
tect points within a specified proximity to those points. This is a great 
way to remove duplicate points.

To Delete Cloud Points:

Individual cloud points must also be selected separately. 

1. From the menu, select Edit>Delete Cloud Points>Selected Points  or 
press Crt+Alt+D.

2. Select the cloud points to delete by holding shift and rectan-
gle selecting in the graphics or using one of the other graphi-
cal selection tools. 

Sometimes you may wish to delete cloud points based on their ra-
dial distance from a set of points. For instance, once you’ve scanned a 
set of registration spheres and extracted the sphere centers, you may 
wish to delete the scan data of the spheres themselves (so they do 
not interfere with other analysis).

To Delete Cloud Points by Their Radial Distance From Reference Points:

1. From the menu, select Edit>Delete Cloud Points>By Radial Distance 
from Points.

2. Select the point cloud(s) of interest.

3. When prompted, pick the points to use as the reference points.

4. Specify a radial distance.

5. At the prompt, specify whether the cloud points inside or out-
side of the radius should be deleted.

To Delete Vectors:

Vectors, much like cloud points, must be selected separately from 
within a vector group. To do so:

1. From the menu, select Edit>Delete Vectors.

2. Select the vectors to delete by holding shift and rectangle 
selecting in the graphics or using one of the other graphical 
selection tools (the vector end points is used for selection).
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To Delete Vectors and Point Pairs:

In many cases the deviation vectors can be used to effectively identify 
bad measurements. When a relationship is displaying Auto-vectors 
the vectors are directly tied to the points that generate them and can 
be used for this purpose. 

To delete points using vectors:

1. From the menu, select Edit>Delete Vectors>Auto Vector/Point Pairs.

2. Select the vectors to delete by holding shift and rectangle se-
lecting in the graphics or using one of the other graphical se-
lection tools (the vector end points is used for selection). This 
will remove both the vector and the corresponding point.

To delete cloud points using vectors:

1. From the menu, select Edit>Delete Vectors>Auto Vector/Cloud Point 
Pairs.

2. Select the vectors to delete by holding shift and rectangle 
selecting in the graphics or using one of the other graphical 
selection tools (the vector end points is used for selection). 
This will remove both the vector and the corresponding cloud 
point.

To Delete Objects From a Specific CAD Source

SA keeps track of the source of objects—whether they were created 
natively in SA or imported from CAD files. As a result, you can delete 
objects that were imported from a specific CAD file.

1. From the menu, select Edit>Delete>Delete CAD Objects By Source.

2. In the Delete Objects by CAD Source dialog, select the source 
CAD file, then click OK.

To Delete Pictures:

1. From the menu, select Edit>Delete>Delete Pictures.

2. Select the pictures to delete.

To Delete Relationships:

1. From the menu, select Edit>Delete>Delete Relationships.

2. Select the pictures to delete.

To Delete Using Layer Manger:

“The Layer Manager” on page 685.
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Configuring SpatialAnalyzer
There are a wide variety of settings in SpatialAnalyzer that provide 
significant control over the application’s configuration. These set-
tings can be stored in one of several different ways, depending on 
the scope of the setting:

 ■ Factory Defaults. Factory default settings are stored as part of 
SA itself. These are the settings that apply when no other set-
tings override them.

 ■ Job Files. These are settings that are stored as part of the job 
file because it makes the most sense for them to be a property 
of a specific job file. Opening up a job file will restore its job file 
settings, regardless of the computer on which file is opened.

 ■ User Interface Profile. These are settings that are stored as 
part of a customized user interface profile.

 ■ Machine Settings. These settings are stored in the Windows 
Registry and apply at the computer level. Machine settings 
apply on a given computer, regardless of the current job file. 
(Although a user interface profile is stored in a profile file, the 
active profile is stored as a machine setting).

 ■ Persistence Files. Persistence files contain configuration in-
formation and can easily be transferred from one computer to 
another.

Job File Settings

A number of the more general job file settings are described below—
however be aware that this list is not all-inclusive.

Units
Anywhere a number with units is displayed in SA, it is presented in the 
active unit system, unless indicated otherwise. A job file can be set 
to one of the different length and angular units. Temperature units 
can be set to either Fahrenheit or Celsius. The active job’s length units 
are displayed in the status bar (Figure 6-16). Angular units are always 
presented in decimal degrees, but can be specified to present data in 
±180° format or 0-360° format.

Figure 6-16. The active length 
units are displayed in the SA Status Bar.

To Change the Job File Units

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Units tab.
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3. Select the desired length or temperature units.

To Change the Representation of Angles

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Units tab.

3. Select the appropriate setting in the Angle Representation box.

To Set the Default Job File Units (No Template File In Use)

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Machine Configuration tab.

3. Click the No Template Default Options button.

4. In the New File Defaults dialog, select the preferred units.

Fractional Unit Display
Fractional unit display options are also available for feet and inch dis-
play settings (Figure 6-17). 

Figure 6-17. Fractional Display 
Settings

This setting is for display purposes and only impacts a selection of 
numeric indicators: 

 ■ Dimension. Both the graphical display of dimensions and their 
reported values will include the fractional unit designation 
when set. 

 ■ Callouts. Vector callouts are converted to display in fractions. 

 ■ Vectors. Vector Labels will be converted to display in fractions
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 ■ Watch Windows. The Distance component in a watch window 
will display in fractions. 

US Survey Feet
In addition to a standard (or “international”) foot, SA also supports the 
US Survey Foot as a unit type (1 US Survey Foot = 1200/3937 meters 
where as 1 standard foot = .3048 meters). This can be helpful when 
working with job files saved in State Plane Coordinates and other sur-
vey applications. 

Decimal Precision
Internally, calculations in SA are performed (and numbers are stored) 
with a high degree of decimal precision. However, when numeric re-
sults are displayed in the user interface, they are typically rounded to 
a preferred decimal precision in order to simplify the display. You can 
control the number of decimal places used when displaying different 
categories of values. Specifically, you can independently control deci-
mal precision for length, angle, scale, unit vector, and weight values.

You can change the decimal precision for a given file at any time with-
out incurring any additional internal numerical error.

To Change the Decimal Precision

1. Click the User Options icon in the Main toolbar.

2. In the Decimal Digits for Display box of the Display tab, change the Length, 
Angle, Scale, Unit Vector, and Weight decimal precision as desired.

To Set the Default Job File Decimal Precision (No Template File In Use)

1. Click the User Options icon in the Main toolbar.

2. Click to activate the Machine Configuration tab.

3. Click the No Template Default Options button.

4. In the New File Defaults dialog, enter the preferred display 
decimal precision.

A Closer Look
Having a different decimal precision for different types of numbers is useful, since different types of numbers are 
expressed in different units.  For example, three digits of decimal precision for an angle (eg. 0.001°) is only accurate to 
3.6 arcseconds--not enough for some applications. However, three digits of decimal precision in length when working in 
millimeters is too much precision for most applications (1 micron).

Reporting Tolerances
Reporting tolerances specify the threshold at which pointing errors 
or uncertainties are flagged in reports.

Angle-Distance Weights
Angle-distance optimization weighting values provide you with con-
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trol over the weight of angular measurements compared to distance 
measurements for bundle adjustments and point calculation. You 
can weight distance and angular measurement components equally, 
or you can completely disregard distance or angular measurement 
components.

To Edit the Angle-Distance Weights

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, click the Edit Angle-
Distance Weights button.

3. In the resulting Optimization Weighting Values dialog, drag 
the slider to the left to apply more weight to angular compo-
nents, or to the right to apply more weight to distance com-
ponents. You can optionally type relative weights for each 
into the two text fields.

Optimization Parameters
You have control over a number of parameters involved in certain cal-
culations. These are found in the Optimization Parameters section of the Units 
tab in the User Options.

Convergence Tolerance

Optimizations are involved in many different aspects of SpatialAna-
lyzer’s computations. While these optimizations usually have a sin-
gle “best” answer in theory, in reality often they can only be found 
through iterative analysis. As a result, finding the “correct” answer 
would theoretically take an infinite amount of time.

Consider a best fit optimization: once the computer finds what it 
perceives as the solution that best fits a series of measurements to a 
CAD surface, it will stop. However, if you were to increase the internal 
decimal precision and “jiggle” the points around with even more fine 
movements and rotations, it could find a better solution than the so-
lution initially proposed.

Continuously increasing the decimal precision and making finer ad-
justments becomes unwieldy after a short time, and it would most 
certainly try your patience. While a best fit showing 1x10-12 inches of 
RMS error is better than a best fit showing 1x10-11 inches of error, we 
don’t particularly care, because the difference is much less than the 
accuracy of the measurement in the first place. The additional com-
putation required to reach the better solution is just not worth our 
time.

As a result, SA follows a set of rules that tell it when an optimization 
is “good enough”. When SA notices that the difference between two 
iterations in a solution is smaller than these thresholds, the solution 
terminates, because the result is considered to be “good enough”. The 
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default values provided for the convergence tolerances have been 
found to work well for a wide array of measurement devices and geo-
metric optimizations.

To Edit the Convergence Tolerance Settings

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, specify new length 
and angular convergence tolerance values.

 ■ Length (object fits). When the RMS error of a fit (such as a ge-
ometry fit, surface fit, or relationship fit) does not change by 
more than this value, the optimization process terminates. Us-
ing a smaller value here will theoretically give a better solution, 
but will increase the computation time required for the fit.

 ■ Angular (bundle adj). When the RMS pointing error in a bun-
dle adjustment does not change by more than this value from 
one iteration to the next, the bundle adjustment process ter-
minates. Using a smaller value here will theoretically give a bet-
ter solution, but will increase the computation time required 
for the fit.

Perturbations/Damping

For many of the numeric optimizations within SA, the partials matrix 
is computed using numerical differentiation. A value is changed by a 
delta (referred to as a perturbation), and the result is computed. The 
deltas used to offset the values in an optimization are set here. At each 
step, one portion of the partials matrix is populated. If these values 
are too small, you can experience sensitivity problems. The perturba-
tion may be so small that the change in the objective is negligible 
and therefore the optimization proceeds without accurate direction. 
If the values are too large, it is possible to miss nuances in the solution 
space by moving over the ideal solutions.

To Adjust the Perturbation/Damping Values

1. Click the User Options icon in the Main toolbar.

2. In the Optimization Parameters box of the Units tab, specify new length 
and angular perturbation values, or specify a new damping 
factor.

 ■ Length Perturbation. The length perturbation is the amount 
of perturbation along the X, Y, and Z axes. In the case of a best-
fit transformation, for example, the X value is adjusted by the 
length perturbation. The objective function is recomputed, 
and this process is repeated with adjustments to the Y and Z 
values.

 ■ Angular Perturbation. After perturbing X, Y, and Z, the Rx val-
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ue is perturbed by the angular perturbation, then Ry, then Rz. 
At each step, one portion of the partials matrix is populated. 
If these values are too small, you can experience sensitivity 
problems. The perturbation may be so small that the change in 
the objective is negligible and therefore the optimization pro-
ceeds without accurate direction. If the values are too large, it 
is possible to miss nuances in the solution space by moving 
over the ideal solutions.

 ■ Damping. Once the partials matrix is computed for a given 
step in an optimization, the matrix is inverted, and multiplied 
by the residual errors. This results in a vector describing how 
to move the input variables to minimize the objective is the 
system were truly linear. Since the systems we deal with in co-
ordinate metrology are usually non-linear, the delta vector will 
most likely not move to the optimal solution. For this reason, 
we scale the vector by the damping factor to retard its effect. 
After making the move, the partial determination process re-
peats until an acceptable solution is reached.

Machine Settings

Although most parameters associated with work in SA are stored as 
part of the job file, many are instead stored on the computer. These 
settings are those that are more appropriate to be consistent on a 
given computer and do not necessarily have anything to do with a 
given SA file. For instance, the setting defining the file system loca-
tion for SA backup files is a setting more appropriate to the computer 
instead of the SA file—regardless of which SA file is opened, it should 
always be saved to a certain backup folder.

SpatialAnalyzer Directories
SA uses a folder structure for storing certain files, such as measure-
ment backups, templates, and instrument interface settings. You can 
control where this folder structure is located. By default, the folder 
structure is placed into the root of the C:\ drive and consists of the 
following:

 ■ C:\Analyzer Data\. The base of the SA folder structure.

 ■ C:\Analyzer Data\Reports\. The location for generated re-
ports.

 ■ C:\Analyzer Data\Templates\. The location for the default 
template file, as well as any other template files or custom user 
interface configuration files.

 ■ C:\Analyzer Data\Scripts\. This folder can be used to store 
Measurement Plan Scripts, although scripts can be located 
anywhere on the file system.
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 ■ C:\Analyzer Data\Persistence\. This folder contains instru-
ment interface settings files, configuration files, parameter 
files, and other configuration information.

 ■ C:\Analyzer Data\Backup\. All automatic backup files are 
saved to this folder. Measurement backups are saved to a sub-
directory of this directory named Measurements.

To Change the Location of SA’s Entire Folder Structure

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab, click the Select Root Directory to contain 
“Analyzer Data” and its subdirectories button.

3. Choose a new folder.

The individual folder locations and names can also be changed di-
rectly from this dialog.

To Change the Location of an Individual SA Directory

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab’s SpatialAnalyzer Directories box, select 
the desired directory.

3. Click the Pick new Directory for Selected Entry button.

4. Select the desired folder from the folder browser.

Parallel Processing
Many operations in SA are multi-threaded, such as USMN calculations, 
surface queries and projection, and point cloud filtering. However, in 
order to reap the substantial performance benefit of multi-threading, 
SA’s parallel processing must be enabled (and your computer must 
support multi-threading).

To Enable Parallel Processing

1. Click the User Options icon in the Main toolbar.

2. In the Machine Configuration tab, check the Use multiple processors 
if available option.

Fault Handling
Should you ever experience a crash or other serious runtime error 
while using SA, you can configure SA to automatically collect informa-
tion on this error and send it on to New River Kinematics for analysis. 
(This is similar to the Windows error reporting functionality). You can 
also choose to send a large diagnostic file, which is a more complete 
record and picture of SA’s state at the time of the error.

To Enable Fault Handling

1. Click the User Options icon in the Main toolbar.

Note:  When a multi-thread-
ed operation is underway, 

the two gears on the right side of 
the SA status bar will light up.
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2. In the Fault Handling section of the Machine Configuration tab, enable 
the Collect diagnostic info from faults option.

3. To also send large diagnostic files, select the enable large diag-
nostic file option.

Security

You can place security restrictions on SA in order to restrict the access 
of different classes of users to SA’s functionality. For example, you can 
prevent a user or class of users from saving a job file, measuring, de-
leting objects, moving objects, or using Measurement Plans.

To enable security restrictions, you first must create at least two secu-
rity classes: One that provides administrator privileges, and another 
to provide restricted access. A security class defines the rights and 
privileges a group of people belonging to that class will have. The dif-
ferent rights that can be restricted are listed here:

 ■ Edit Security Options. Members can edit security settings 
(normally this privilege is only granted to an administrator 
class).

 ■ Save Jobs. Members can save files.

 ■ Print Jobs. Members can print reports.

 ■ Measure. Members can take measurements.

 ■ Delete Objects. Members can delete objects.

 ■ Delete Points. Members can delete individual points.

 ■ Delete Collections. Members can delete entire collections.

 ■ Import Files. Members can import files into the current job file.

 ■ Move Objects. Members can move (transform) objects.

 ■ Copy Objects. Members can make copies of objects.

 ■ Edit Points. Members can change point and target properties.

 ■ Use MP. Members can run Measurement Plan scripts.

 ■ Instrument Properties. Members can modify instrument 
properties.

 ■ Bundle Adjust. Members can perform bundle adjustments.

To Create a Security Class

1. Click the User Options icon in the Main toolbar.

2. In the Security Classes section of the Security tab, click the New but-
ton.

3. Give the class a name, and deselect the privileges you’d like to 
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restrict. Then click OK.

To Remove a Security Class

 ■ In the Security Classes section of the Security tab, select the class you’d 
like to delete and click the Remove button.

To Edit a Security Class

1. In the Security Classes section of the Security tab, select the class 
you’d like to edit and click the Edit button.

2. Change the name of the class and/or the associated privileg-
es, then click OK.

Once two or more classes have been created, you need to create 
users. These users need not refer to unique people (although they 
can)—that is, multiple people can use the same user name.

To Create Users

1. In the Users section of the Security tab, click the New button.

2. Enter a name for the user, then type and confirm a password 
for the user.

To Remove Users

 ■ In the Users section of the Security tab, select the user you’d like to 
delete, then click the Remove button.

To Edit Users

1. In the Users section of the Security tab, select the user you’d like to 
edit, then click the Edit button.

2. Modify the username and/or the password for the user, then 
click OK.

The last step, once classes and users have been created, is to assign 
users to a class. A single user can belong to one or more classes. When 
a user belongs to more than one class, the user receives the combined 
privileges of all classes to which he belongs.

To Assign Classes To a User

1. In the Users section of the Security tab, select the user you’d like to 
assign to a security class.

2. Next to the Belongs to classes box, click the Add button.

3. Select a class to add to the user, then click OK.

To Remove a Class From a User

1. In the Users section of the Security tab, select the user to modify.

2. In the Belongs to classes box, select the class to remove from 
the user.

3. Click the Remove button.
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Once your users, security classes, and privileges have been set up, you 
must enable security restrictions in SA, or else no change in behavior 
will occur.

To Enable Security

1. Click the User Options icon in the Main toolbar.

2. In the Security tab, ensure that all classes and users are set up 
correctly. Also verify that at least one user has full access to 
the edit Security Options privilege, and that the user’s user-
name and password is known.

3. Uncheck the always auto-login with full access checkbox.

4. Restart SA. A username and password will be required to start 
the application.

With the always auto-login with full access option disabled, you can 
also use the Login Now button to log in as a different user without re-
starting SA. This is useful for conveniently testing the privileges of dif-
ferent security classes.

To Disable Security

1. Login to SA using a username that has access to the edit Secu-
rity Options privilege (typically the “administrator”).

2. Click the User Options icon in the Main toolbar.

3. In the Security tab, enable the always auto-login with full access 
option.

System Diagnostics
SA provides a number of system tools and utilities to monitor config-
uration and diagnose potential issues with your system or file setup. 
These tools are listed below.

Memory Monitor

Large files (particularly those containing dense scan data or complex 
CAD files) can easily consume the available RAM on your system. To 
monitor your available/used RAM, SA provides a convenient memory 
monitor utility, which displays SA’s memory usage, total system mem-
ory usage, total RAM, and operating system information.

To View the Memory Monitor

 ■ From the menu, select Help>Diagnostics>Memory Monitor.
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Check Job Data Consistency

You can verify the integrity and consistency of any SA file. This tool 
will examine an SA file and verify that there are no corrupt internal 
references.

To Verify the Integrity of an SA File

1. Open the SA file.

2. Select Help>Diagnostics>Advanced>Check Job Data Consistency.

3. A dialog will be displayed indicating whether any errors were 
found, and a log of the findings will be saved to the Analyz-
er Data\Reports\_SAJobFileConsistencyReport.
txt file.

Regenerate References

If any issues are found with the Check Job Data Consistency tool, you 
can attempt to repair them by regenerating references. This will walk 
through the measurements and ensure that each measured point has 
the proper references to its targets.

To Re-Generate Target References

1. Open the SA file.

2. From the menu, select Help>Diagnostics>Advanced>Re-Generate 
Measurement to Target References.

Repeating Commands
Occasionally, the need comes up to repeat a command, perhaps sev-
eral times. While you could search through the menus to find the de-
sired command and select it again, such an approach is not efficient. 
Instead, you can use a keyboard shortcut to repeat the last executed 
command.

To Repeat the Last Executed Command:

 ■ Press Ctrl+Tab, or select Scripts>Repeat Command.

In other cases, you may need to repeat a series of non-consecutive 
commands several times. In such a situation, the Repeat Command 
menu option will not help you, since it only executes the most recent 
command. Instead, you can ask SA to display a command history of 
the most recently executed commands (Figure 6-18), with the most 
recent at the top.

Note:  Regenerating refer-
ences is not normally neces-

sary. It should only be performed 
if a job file consistency check indi-
cates errors.
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Figure 6-18. The command 
history.

To Select a Recent Command From the Command History:

 ■ Press Ctrl+Shift+Tab or select Scripts>Command History, then 
select the desired command from the resulting list.

Working With Items
Many items in an SA job have some sort of representation in space. 
In a few cases in which the items are containers (collections, folders, 
point groups, and categories), the position and orientation of an item 
is not clearly defined, but still exists. For example, a collection can be 
moved and rotated (that is—a relative movement can be applied to 
it), but you would have a difficult time determining where that col-
lection is specifically located in space. The list below indicates the de-
fined positions and orientations of the various items in SA that have a 
representation in space:

 ■ Folders. The specific position and orientation is undefined.

 ■ Collections. The specific position and orientation is undefined.

 ■ Coordinate Frames. The position is defined by its origin, and 
its orientation is defined by its axes. The primary direction of a 
coordinate frame is its Z axis.

 ■ Point Groups. The specific position and orientation is unde-
fined.

 ■ Lines. The position is defined by its “begin” point. The line itself 
describes its Z direction.

 ■ Instruments. The position is determined by the base, optical 
center, or other defined origin of the instrument. The stand-
ing axis of an instrument is its Z axis, and typically the X axis 
is defined by the “front” of the instrument (although this is not 
always the case).
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 ■ B-Splines. The specific position and orientation is undefined.

 ■ Planes. The position is defined by its centroid. The Z axis is de-
fined by its normal, and its X axis is typically defined by the first 
defined point in the plane.

 ■ Circles. The position is defined by its center. The Z axis is de-
fined by its normal, but the X and Y axes are undefined.

 ■ Ellipses. The position is defined by its center and the Z axis is 
defined by its normal. The X axis is defined by its major axis, 
and the Y axis is defined by its minor axis.

 ■ Cylinders. The position is defined by the center of its “begin” 
end. The Z axis is defined by its axis. The X and Y axes are un-
defined.

 ■ Spheres. The position is defined by its center, and the X axis 
passes through its poles. The Y and Z axes are undefined.

 ■ Cones. The position is defined by its apex, and the Z axis is de-
fined by its axis. The X and Y axes are undefined.

 ■ Paraboloids. The position is defined by its focal point, and the 
Z axis by its axis. The X and Y axes are undefined.

 ■ Polygonized Surfaces, Surfaces, Vector Groups, Point 
Clouds, and Perimeters. The specific positions and orienta-
tions are undefined.

 ■ Graphical Entities. Each has a defined position and orienta-
tion, but graphical entities are only for graphical purposes and 
are not useful in analysis.

If you’re wondering why this is important, it’s because many different 
operations in SA that require you to define a position or orientation 
allow you select most of the items above to describe that position or 
orientation. For instance, if in the process of constructing a new coor-
dinate frame you’re prompted to specify the X direction for the frame, 
selecting a circle is a valid selection for that prompt—SA will use the 
normal direction of the circle to define the X direction.

All of the objects listed above have a number of common character-
istics, discussed below.

Moving Objects

While there are many commands to automatically apply transforma-
tions to objects based on special alignments and fits, all of the items 
mentioned in “Working With Items” above can be moved manually 
through any of several methods. These methods are described below.



143

CHAPTER 6 ■ WORKING IN SA

Entering a Transform

Figure 6-19. The Move Objects 
dialog.

The Move Objects dialog (Figure 6-19) provides the ability to apply a 
relative movement to an object by typing in values, expressed in the 
active coordinate frame. In this dialog, you can explicitly type in the 
positional and rotational deltas—these values are initially zero be-
cause they are relative movements from a starting position. Positional 
deltas can be entered in Cartesian (xyz), Cylindrical (rθz), or Spherical 
(rθϕ) values. Rotational deltas can be entered in Fixed notation, euler 
notation, equivalent angle axis notation, or as euler parameters.

To Move One or More Objects by Typing In Values:

1. Right-click an object in the tree or graphical view and select 
Move. Or, to move multiple objects simultaneously, select 
Edit>Move Objects>Enter Transformation and select the objects you 
wish to move.

2. In the Move Objects dialog, select the proper format in which 
to enter the values from the dropdowns in the Position and Ori-
entation boxes. Usually, Cartesian XYZ and Fixed XYZ is the intended 
format.

3. Type in the appropriate values, then press Enter or click the 
Update button.

To Reset an Object Back To Its Original Position:

 ■ Click the Reset button, or

 ■ Manually type zeroes into all numeric fields, then press Enter.

Transforms can be copied from one dialog and pasted in another. This 
allows you to manually transform an object in the Move Objects dia-
log, then apply that same transform to another object.

To Copy and Paste Transforms Between Instruments:

1. In the Move Objects dialog, ensure the transform you want to 
copy is entered.

2. Click the Copy button.

3. Call up the Move Objects dialog for the destination object (see 
“To Move One or More Objects by Typing In Values:” above).
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4. Click Paste.

If you are performing an analysis of your own, you can copy and paste 
raw 4×4 transform matrices between objects, and also export trans-
forms to a comma-delimited .CSV file.

To Copy and Paste Transform Matrices Between Objects:

1. In the Move Objects dialog, click the View Matrix button.

2. In the Transformation Matrix dialog, click the Copy button to 
copy the current matrix to the clipboard, or click Export .csv to 
send it to a comma-delimited file.

3. Call up the Transformation Matrix dialog for the destination 
object.

4. Check the allow editing checkbox, which enables manual ed-
iting of an object’s 4×4 transform matrix.

5. Click the Paste button, or choose Import .csv to import the matrix 
from a comma-delimited file.

To Edit An Object’s Transformation Matrix Directly:

1. In the Move Objects dialog, click the View Matrix button.

2. Enable the allow editing checkbox.

3. Type the desired values into the 4×4 matrix.

Graphical Dragging
You may wish to move objects by dragging them graphically in the 
view. This is a great way to visually position objects in an approximate 
way without being concerned with exact transformation values.

To Drag Objects Graphically:

1. From the menus, select Edit>Move Objects>Drag Graphically.

2. At the prompt, select the objects you wish to move, then 
press Enter.

3. Use the left mouse button to move the object, and the right 
mouse button to rotate it about an axis perpendicular to the 
view orientation. When finished, press Enter.

Frame to Frame Transformations
Frame to frame transformations make note of the transformation re-
quired to go from one coordinate frame (the source frame) to another 
(the destination frame), and then applies that transformation to se-
lected objects (Figure 6-20).

Tip:  To rotate the object 
about different axes, use 

saved viewpoints to switch to dif-
ferent views without cancelling 
out of the command.
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Figure 6-20. An object prior to 
(top) and after (bottom) a frame to 
frame transformation.

An interesting characteristic about coordinate frames is that they 
store complete information on position and orientation. As a result, 
they can be used to keep a record of an object’s position. As an exten-
sion to that idea, two different coordinate frames store a positional 
and rotational delta (a transformation). Frame to frame transforma-
tions take advantage of this fact. If you plan on applying a transfor-
mation to an object, you can store the object’s initial position by cre-
ating a coordinate frame at its location (the Construct>Frames>On an 
Object command is very handy for this). If, after moving the object, you 
change your mind and would like to put it back to its original posi-
tion, you can create a frame on the object’s current position, then use 
a frame to frame transformation to move the object back to it’s origi-
nal location.

To Apply a Frame to Frame Transformation:

1. From the menu, select Edit>Move Objects>Frame to Frame Transfor-
mation.

2. At the prompt, select the source frame. This is the coordinate 
frame that the transformation will be calculated from.

3. Select the destination frame. This is the coordinate frame that 
the transformation will be calculated to.

4. Now that the positional and rotational deltas have been cal-
culated, select the objects to which you’d like to apply the 
transform. You may choose the source or destination frame, 
if desired.



146

SPATIALANALYZER USER MANUAL

5. Confirm or reject the transformation at the prompt.

Point to Point Delta Translations

Figure 6-21. A circle is being 
moved to a nominal position through 
the use of a point to point transla-
tion. In this example, Measured 
Center is the source point, and 
Nominal Center is the destina-
tion point.

Often, you will want to apply a pure translation (movement in XYZ 
but no rotation) to one or more objects. Point to point delta transfor-
mations use a source point and a destination point to calculate a po-
sitional delta to apply to one or more objects (Figure 6-21). A point to 
point delta transformation is the 3 degree of freedom analog to a 
frame to frame transformation (which involves movement in 6 de-
grees of freedom). Just as frames can record an object’s position and 
orientation in space, points can record an object’s position in space. 
As such, point to point translations are reversible and can be used to 
“undo” a translation applied to an object—simply reverse the source 
and destination points.

To Move Objects Using a Point to Point Translation:

1. Select Edit>Move Objects>Translate by Point to Point Delta.

2. At the prompt, select the first (source) point.

3. Select the second (destination) point.

4. Choose the objects to translate.

Translating Using Instrument Updates
Updates from a 3 degree-of-freedom device such as a laser tracker 
can be used to translate one or more objects. Note that this is a pure 
translation--no rotations are applied.

When the command is initiated, the initial target position is recorded. 
As the target moves from this initial position, the translation is ap-
plied to the selected objects.

To Translate Objects Using Instrument Updates:

1. Select Edit>Move Objects>Translate Using Instrument Updates.
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2. At the prompt, select the instruments (if more than one exists 
in the file) and the objects you’d like to move. These objects 
will move together as a rigid body.

3. The Translate Objects - by Instrument dialog will appear (see 
Figure 6-22).

Figure 6-22. Translating objects 
using an instrument’s 3 degree-of-
freedom updates.

4. When measurement updates are received from the instru-
ment, the objects will be translated.

5. When finished, you can either click Cancel: Restore Original Position, 
which will put the objects back in their original location, or 
click OK: Leave Objects in Current Position, which will accept the trans-
formation and apply it to the objects.

Transforming in 6D Using Instrument Updates 
Updates from a 6 degree-of-freedom device (such as a T-Probe, por-
table arm, T-Mac, or STS) can be used to transform one or more ob-
jects. The positional and rotational delta experienced by the device is 
applied to the objects involved in the transformation.

When the command is initiated, the position and orientation of the 
device is recorded. As the device moves and rotates from this initial 
position, the transformation is applied to the selected objects.

To Transform Objects in 6 Degrees of Freedom Using an Instrument’s Updates:

1. Select Edit>Move Objects>Transform in 6D Using Instrument Updates.

2. At the prompt, select the instruments (if more than one exists 
in the file) and the objects you’d like to transform. These ob-
jects will move and rotate together as a rigid body.

3. The Transform (6D) Objects - by Instrument dialog will appear 
(Figure 6-23).
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Figure 6-23. Transforming objects 
using an instrument’s 6 degree-of-
freedom updates.

4. When 6-DOF measurement updates are received from the in-
strument, the object position and orientation will be updated 
automatically.

5. When finished, you can either click Cancel: Leave Objects in Current Po-
sition to accept the transformation, or Cancel: Restore Original Position 
to move the objects back to their original position.

Transforming in 6D Using Multiple Instrument Updates (also 
know as Trans-Track)

SA has the capability of synchronizing three degree-of-freedom mea-
surements from 3 or more instruments and combining them to cal-
culate a six degree-of-freedom transformation. This is commonly re-
ferred to as trans-track. For Trans-Track to function correctly, three or 
more instruments must first be tied to a common coordinate system. 
This can be achieved using any accepted technique, such as USMN, 
bundling, or best-fit. Once the instruments are tied together, each in-
strument must measure a single point, which becomes the reference 
point for that instrument.

The Trans-Track operation is then started, and the instruments are si-
multaneously polled for updates. A real-time transformation is then 
calculated, and that transformation is applied to any objects of choice.

To Transform in 6D Using Multiple Instrument Updates:

1. Ensure that you have three or more instruments tied togeth-
er to the same reference system (usually a set of common 
points), and that their interfaces are all running in SA.

2. Affix three targets to the moving object, with one instrument 
watching each target--these will be your reference points.

3. Measure a single reference point from each of the instru-
ments.

4. From the menus, select Edit>Move Objects>Transform in 6D Using 
Multiple Instrument Updates.

Tip:  Spread reference points 
apart as far as possible to 

minimize angular errors in Trans-
Track.

Tip:  The accuracy of the 
Trans-Track operation is limit-

ed to the accuracy of the net-
work, so try to tie instruments to-
gether as accurately as possible.
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5. When prompted, select the instruments that will be part of 
the operation. You must be explicit about the order in which 
you pick the instruments.

6. Now select the earlier-measured reference points that corre-
spond with the instruments. The points must be selected in 
the same order as the instruments. (That is, select the first in-
strument’s reference point first, then the second instrument’s 
point, etc.)

7. When prompted, select the object or objects to which you’d 
like the transformation applied.

8. The Transform Using Multiple Instrument Updates dialog will 
appear (see Figure 6-24).

9. Click the Query Instruments button, and SA will begin polling the 
instruments and calculating the transformation. The dialog 
will list the fit error between the live set of points and the ref-
erence set. The time lapse among the measurements is also 
displayed.

10. When finished, press Done: Leave Objects in Current Position to accept 
the transformation, or Cancel: Restore Original Position to undo any 
movement.

The Trans-Track dialog also has a few settings that can be modified 
(see Figure 6-24):

 ■ Point Best-Fit Error Tolerance. If a point’s best fit error to the 
corresponding reference point exceeds this threshold, the 
point will be highlighted as a warning.

 ■ Time Lapse Tolerance (sec.). If the time difference between 
the first point and another point exceeds this threshold, the 
point will be highlighted as a warning, indicating that the mea-
surement sync was not acceptable. This can be ignored when-
ever the targets are stationary.

 ■ Delay after update (sec.). The time delay between one set of 
measurements and the next.

Tip:  Be careful to place tar-
gets such that they will be 

visible throughout the range of 
motion of the moving object.

Tip:  Measurements cannot 
be perfectly synced, there-

fore slower movement will result 
in more accurate real-time trans-
formations due to a smaller time 
delay among the instrument 
measurements. Allowing the tar-
gets to become stationary for a 
moment will remove sync-based 
error from the transformation.
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Figure 6-24. Performing a 
Trans-Track operation with three laser 
trackers.

Figure 6-25. Trans-Track settings.

Transforming in 6D Using a Batch of Points from an Instrument
Some instrument systems, such as photogrammetry systems, are 
capable of tracking several points simultaneously. SA is capable of 
watching this batch of points and updating the transformation of 
one or more objects as the updates arrive. Since this command only 
involves one instrument, alignment among multiple instruments is 
not required as it is with Transform in 6D Using Multiple Instrument Updates.

To Transform Objects in 6D Using a Batch of Points From An Instrument:

1. From the menus, select Edit>Move Objects>Transform in 6D Using a 
Batch of Points from an Instrument.

2. Select the object(s) that you would like to transform.

3. The Trans-Track a Point Set dialog appears (Figure 6-25).

4. Before moving anything, measure a set of points. This will be 
used as the reference for the initial position.
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Figure 6-26. The Trans-Track 
a Point Set dialog appears.

5. As each set of measurements are taken, the position of the 
selected objects will be updated, and the fit error will be re-
ported in the dialog.

6. When finished, click Done: Leave Objects in Current Position to accept 
the transformation, or Cancel: Restore Object Positions to cancel the 
command and put all objects back into their original posi-
tions.

Guiding Objects in 6D Using Point Measurements
If you would like to apply 6 degree-of-freedom transformations to 
one or more objects, but only have a 3 degree-of-freedom device 
available, then you can measure a set of reference points to serve as 
the controls for a 6 degree-of-freedom transformation.

The process involves measuring a set of reference points affixed to 
the moving object, and creating a corresponding set of “goal” points 
which represent these reference points transformed to the desired fi-
nal location. You then repeatedly measure the reference points on the 
moving object, and SA will update the position of the moving objects 
and also display a watch window indicating the required motion to 
transform from the current position to the final position (Figure 6-27).
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Figure 6-27. Guiding objects 
using point measurements.

The controls for guiding in 6D are shown in Figure 6-27.

Figure 6-28. The Translate 
Objects using Instrument 
Point Measurements dialog.

 ■ Measurement Group. Defines the name of the point group 
containing the measured points. If you change this, you must 
click the Apply button.

 ■ Cycle All Points. When clicked, this button cycles through all 
reference points, points at their last measured position, search-
es, locks, and measures each point (applies to steerable, tar-
geted instruments only).

 ■ Measure Selected Point. Measures a point and associates it 
with the selected point in the table.

 ■ 3D Translate in Real-Time. Select a point in the table, then 
click this button. SA will track the target as this point and trans-
late the moving objects. This is useful for getting real-time 
feedback on movement, without considering rotational in-
formation. Once you dial in the position, you can switch back 
to full 6 degree-of-freedom measurement of your reference 
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points by toggling this mode back off.

 ■ Watch. Click this button to open a watch window showing the 
transformation, in the active frame, required to get from the 
current position to the goal position.

To Guide Objects in 6D Using Point Measurements:

1. Locate into a coordinate system as necessary.

2. Measure a set of reference points on the moving object. Three 
are required at a bare minimum, more are better.

3. Create a set of corresponding goal points in the destination 
position. This is usually accomplished by copying the refer-
ence group and applying an appropriate transformation to 
the copy.

4. From the menu, select Edit>Move Objects>Guide Objects in 6D using 
Point Measurements.

5. At the prompt, select the destination (goal) group.

6. Select the reference group on the moving object.

7. Select any additional objects you’d like to transform.

8. When the dialog appears, select the appropriate point in the 
table and click Measure Selected Point to measure it. Or, ensure tar-
gets exist at each reference location and click Cycle All Points to 
measure them all automatically.

9. Using the reported transform, apply the desired movement to 
the moving objects, then repeat the measurement.

10. When satisfied with the final position, click Done: Leave Objects in 
Current Position to accept the transformation.

Copying Objects
Objects can be copied. The copy is always placed into the active col-
lection. If the collection containing the copied object is the active col-
lection, the object will be renamed as necessary to maintain unique-
ness. There are two main methods for copying an object: Copying 
and then applying a transform (which can be unity to leave the object 
unmoved), or copying and then applying a point to point translation. 
Keep in mind that since point groups are objects, copying a point 
group will duplicate that group of points. However, since the copied 
points were not actual measured points (after all, they are copies) 
they will be depicted as constructed points.

It is probably most common for copies to be made without applying 
any transformation so that the copy is in the same position as the 
original.

Tip:  Just as with a best fit or 
trans-track operation, spread 

your reference points out to im-
prove your baseline and reduce 
angular errors in the solution.

Note:  When using “Cycle All 
Points”, movements must be 

small enough relative to the pre-
viously measured position to en-
sure that the instrument can still 
find the targets.
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Copy, Then Transform
This method first creates a copy of one or more objects, then permits 
you to optionally type in a transformation to move the copies.

To Copy then Transform:

1. Right-click an object in the tree or graphical view and select 
Copy; or, to copy multiple objects, select Edit>Copy Objects>Copy 
Then Transform or press Ctrl+C.

2. If copying multiple objects, select the objects.

3. The Copy Objects dialog will appear, which is identical to the 
Move Objects dialog. Enter the desired transformation to ap-
ply, or leave the values zeroed out to leave the copy in place.

Copy, Then Translate Point to Point
If you’d just like to translate the copies only, you can create a copy and 
apply a point to point translation to them. This is the copy-based ver-
sion of moving objects using a point to point translation.

To Copy Using Translation Only:

1. In the menus, select Edit>Copy Objects>Translate by Point to Point 
Delta.

2. At the prompt, select the first (source) point.

3. Select the second (destination) point.

4. Specify the objects you’d like to copy, then press Enter.

Mirroring Objects

Objects can be mirrored (reflected) about any of a frame’s three 
planes (XY, XZ, or YZ). This is most often used with symmetric parts. 
For example, if certain nominal features of an aircraft model are only 
available on the left side, it will need to be mirrored to the right side 
when it comes time to work on the right side of the aircraft.

You can either create a mirrored copy of selected objects (creates a 
duplicate, then reflects the duplicate), or you can mirror the objects 
directly without creating any copies. Mirrored copies are placed into 
the active collection and are renamed as necessary to ensure unique-
ness. An object moved via a mirroring operation will not be renamed 
at all. Always use care when mirroring—depending on the object be-
ing reflected and the plane being mirrored about, the object’s normal 
may flip directions.

To Mirror One or More Objects:

1. Select Edit>Mirror Objects>Move (to mirror the source objects) or 
>Copy (to mirror copies of the source objects).
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2. Select the frame about which to mirror.

3. Select the objects to mirror, then press Enter.

4. In the Select Mirror Plane dialog, choose the plane about 
which to mirror, then click the Mirror button.

Scaling Objects

Any object may be scaled by an arbitrary amount. This yields an ob-
ject that has grown or shrunk by the corresponding scale factor rela-
tive to the active coordinate frame. Since the scaling is applied rela-
tive to the active coordinate frame, scaling generally also results in 
object translation (except for a point on the origin of the active frame).

Two different methods can be used for scaling:

 ■ Calculate Scale Based on CTE. With this option, you select a 
material and an initial and final temperature, and SA calculates 
the scale factor automatically using the linear thermal expan-
sion equation. The material entered should be the material of 
the objects being scaled. For example, if you are scaling mea-
surements of a steel plate, steel should be used for the material.

 ■ Enter Scale Manually. You can enter your own scale factor. As 
an example, a scale factor of 2.0 will double the size of the ob-
ject.

To Scale One or More Objects:

1. From the menus, choose Edit>Scale Objects.

2. 

Figure 6-29. The Scaling dialog.

At the prompt, select the objects to scale, then press Enter. 
The Scaling dialog will be displayed (see Figure 6-29).

3. Choose the scaling method (either Calculate Scale Based on 
Cte or enter Scale Manually).

Warning:  The most com-
mon situation in which 
an object is scaled is 

when you have point groups or 
other data that is not associated 
with an instrument and you want 
to apply a temperature compen-
sation to it. Other than this situa-
tion, it is not common and is usu-
ally more appropriate to apply a 
scale factor to an instrument.

Note:  The list of materials in 
the CTE Editor is stored in 

the SA file. If you’d like a modifica-
tion to appear in all files, save your 
SA file as a default template.
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4. If scaling manually, enter the desired scale factor. If scaling us-
ing CTE, choose the appropriate material and initial/final tem-
perature. Then click OK.

If the default list of materials is not sufficient for your needs, you may 
wish to enter your own material with a custom coefficient of thermal 
expansion.

To Enter a Custom Material and CTE:

1. In the Scaling dialog, click the Edit button.

2.  In the CTE Editor, use the Add, Edit, and Remove buttons to mod-
ify the list of materials, then click Done.

Finding Items In The Tree

While working in the graphical view (particularly if the job file is com-
plex and has many entities), you may need to find an item in the tree. 
Searching for the item through the tree is cumbersome in complex 
files, so SA provides the ability to find any item in the tree.

To Find an Item In the Tree:

 ■ In the graphical view, right-click the item and select Show In Tree 
from the context menu. SA will expand, autoscroll, and select 
the item in the tree for you.

Network Browser
SA is a very network-capable application. You may be viewing an SA 
instance running on another computer on your network, or you may 
be connecting an instrument interface to another computer on the 
network. The SA Network Browser allows you to view the network 
and perform a few network-related diagnostic operations.

To Access the SA Network Browser:

 ■ Click the SA Network icon in the Main Toolbar.

The SA Network Browser dialog (Figure 6-30) displays at the root level 
all computers running SA that are visibile on the network, along with 
their IP address. In Figure 6-30, there are four computers running SA 
on the network.
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Figure 6-30. This SA Network 
Browser lists a number of instances 
of SA running on four different comput-
ers.

Below the computer name will be listed all open SA files on each com-
puter, and below that all unconnected instruments or other connec-
tions that can be made. In Figure 6-30, the computer named T-SCAN 
has two possible connections: A connection to the Remote Monitor 
and the Remote Window Viewer.

To Refresh the Network Browser List:

 ■ Click the Refresh button.

To Run the Check My Computer Tool:

 ■ Click the Check My Computer button.

To View the IP Settings of Your Computer:

 ■ Click the IP Config button.

To Ping an IP Address:

 ■ Type an IP address into the text field, then click the Ping button.

Remote Monitoring
SA provides the capability to pull an open SA file from any computer  
reachable on the network and work with it. You can also remotely 
view the SA application, graphical view, or HUD windows from an-
other computer (if applicable).

For privacy and security reasons, both of these remote viewing ca-
pabilities require the computer being monitored to have its remote 
Viewable option set.



158

SPATIALANALYZER USER MANUAL

To Make a Computer Viewable Via Remote Monitoring:

1. Visit the User Options by clicking the User Options icon on 
the toolbar.

2. Navigate to the Machine Configuration tab and check the remote 
Viewable option.

Figure 6-31. The remote 
Viewable option.

To Work With the Current File From Another Network Computer:

1. From the menu, select File>Remote Monitor another SpatialAna-
lyzer.

2. When the Remote Monitor Options dialog appears, double-
click any SA file’s Remote Monitor option. Or, select the Use 
manual entry of ip (or computer) and port option and manually 
enter the IP address or computer name and port number to 
connect to, then click OK.

The file will be pulled from the other computer and opened. A time-
stamp will appear in the corner of the graphical view to indicate the 
time when the file was pulled (Figure 6-32).

Figure 6-32. Remotely monitoring 
another instance of SA on the network.

To View an Active Window From a Remote Instance of SA:

1. From the menu, select File>Remote Window Viewer.

2. In the resulting Remote Window Monitor Options dialog, dou-
ble-click the Remote Window Viewer entry that you’d like to 

Note:  Computers with the 
remote Viewable option 

turned off will not be visible in 
this list.

Note:  When remote moni-
toring, SA essentially saves 

the file from the remote computer 
and loads it on the local comput-
er. No link is maintained between 
the two files after that point.
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connect to, or select the Use manual entry of ip (or computer) 
and port option and enter an IP address/computer name and 
port number, then click OK.

3. When the Select Remote Window dialog appears, select the 
desired option, then click OK. A separate window will appear, 
which will periodically get updated. You are now watching 
the other computer’s SA instance, live.

Working With The Clipboard
The Windows clipboard is the fastest way for transferring data within 
or among applications. It is far better than manually typing data into 
a different program, and it faster and “cleaner” then exporting data to 
a file and re-importing in the other application.

You can copy the graphical view to the clipboard as an image for past-
ing into any program that supports standard image formats.

To Copy the Graphical View to the Clipboard:

 ■ From the menu, select Edit>Copy graphics to clipboard.

If you’ve copied point data from another source—perhaps an Excel 
file or Notepad text file, you can paste it directly into SA.

To Paste Points From the Clipboard:

1. In the source application (Notepad, Excel, etc.), select the data 
and copy it to the clipboard.

2. From the SA menu, select Edit>Paste Points from Clipboard.

3. Select the appropriate ASCII import options (see the chap-
ter on File Import for detailed information on these options), 
then click Import.

Working Frame and Locked Objects
All data within SpatialAnalyzer is represented relative to the active 
(working) coordinate frame, unless you have specified a specified a 
reporting frame for a particular object. When you examine a point’s 
coordinates, for instance, you are seeing those coordinates relative to 
the working frame. When moving an object, you are entering posi-
tional and rotational deltas with respect to the working frame. When 
performing a best-fit and restricting rotation about the X or Y axis, 
the X and Y axes are defined by the working frame. As a result, staying 
mindful of the active frame while working in SA is very important.

You can create as many coordinate frames in your job file as you want 
or need. You can also freely switch from one active frame to another 
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at any time. This allows you to view deltas, specify rotational values, or 
look at coordinates with respect to any frame of reference.

To Change the Working Frame:

Do one of the following:

 ■ Click the Working Frame button , then se-
lect the new desired working frame from the list, or

 ■ Right-click any coordinate frame you’d like to activate and se-
lect Make Working Frame, or from the menu, select Edit>Pick Work-
ing Frame, and select the new frame.

 ■ Press Alt+W (the default keyboard shortcut), and select the 
new frame.

For more information on frames and frame properties see “Frames” on 
page 313.

About the World Frame

The WORLD is a unique frame that exists in every SA file and defines 
the base coordinate system for the job file. Either deleting or moving 
this World frame can result in both confusion and unforeseen prob-
lems. For that reason its properties are locked by default and are not 
directly accessible. In addition, efforts to move or rename this frame 
will result in a new World frame being build for you automatically. 

If for some reason the World frame must be edited or renamed an 
option exists on the Display tab of the Users Options to either disable 
this function or adjust the name of the locked frame (Figure 11-9).

frame. 
Figure 6-33. Set Locked Frame 
Name Control in the User Options.

Warning:  Moving the 
World frame can be dan-
gerous if you are not care-

ful. Modifying this frame requires 
care and is generally not neces-
sary.
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 Locked Items

In addition to the World frame, many other object types can be locked 
such that their position within the job cannot be edited. Locked only 
means entity cannot be spatially moved – all other existing opera-
tions allowed. These include:

 ■ Imported Surfaces - which are locked automatically

 ■ Instruments can be locked.

 ■ SA objects not yet associated with instruments can be locked.

The item lock status can be edited using the command Item Proper-
ties> Control Item Lock Status (or under the edit menu).  

Object Color
Objects can be given any color, or painted, which you can use for any 
purpose. You can use the color of an object for organizational pur-
poses, to assign special meaning to an object, or simply to make it 
look good. It’s up to you to decide.

SA uses the concept of a working color. Every time a new object is cre-
ated, it is given a color. The color that is assigned is the current—or 
working—color. Think of the working color as an open can of paint—
each object you create is painted, and the working color is used for 
that painting job.

By default, the working color is set to automatically increment. That 
is, when an object is created and assigned a color, the next color in 
a list of 13 random colors is automatically made the working color. 
The result of this is that repeated object creation results in objects of 
different colors so that they are more clearly distinguishable in the 
graphical view.
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Figure 6-34. Toggling the auto-
matically increment color option 
in the Working Color dialog.

Successive creation of multiple objects in different colors may be a 
behavior that you like—or, depending on what you’re doing, it may 
not. For instance, you may wish to create a number of nominal objects 
all of the same color, using the assigned color as a cue that the objects 
are in their nominal configuration. In this situation, the automatically 
incrementing working color is not desirable. You can disable working 
color auto-increment so that the current color remains the working 
color until you explicitly change it.

To Set the Working Color:

1. Do one of the following:

 ■ In the Color/WCF toolbar, click the color swatch button , 
which dispays the working color, or

 ■ From the menu, select Edit>Change Working Color.

2. Select a new working color, then click OK. The next object cre-
ated will be assigned the working color.

To Turn Working Color Auto-Increment On or Off:

1. In the Color/WCF toolbar, click the color swatch button .

2. In the Working Color dialog (Figure 6-34), toggle the auto-
matically increment color option.

To Change the Color of One or More Objects:

1. Choose the desired working color as described above in “To 
Set the Working Color:” on page 162.

2. From the toolbar, click the Color Objects button , or select 
Edit>Set Objects to Working Color.

3. Select the objects to paint.

Note:  Selecting Edit>Change 
Working Color does not allow 

selection from a list of existing 
working colors. On the other 
hand, selecting the toolbar but-
ton does.
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You can also change the color of an object directly through its prop-
erties.

To Change the Color of an Object Through Its Properties:

1. Right-click the object in the tree or graphical view and select 
Properties from the context menu.

Figure 6-35. Changing the color of 
a circle through its properties dialog.

2. In the dialog (Figure 6-35), click the Color button. Select a new 
color, then click OK.

Accessing Item Properties
Nearly every item in your job has properties associated with it. Some 
properties are general—such as the name of the item and any notes 
associated with it—and other properties are more specific and de-
pend on the object type. These more specific properties are discussed 
in detail later.

To Access the Properties of an Item:

Do one of the following:

 ■ Right-click the item in the tree or graphical view and select 
Properties from the context menu, or

 ■ From the toolbar, click the Object Properties button , then 
select the object to examine (applies to objects only), or

 ■ From the menu, select Edit>Object Properties, then select the ob-
ject to examine (applies to objects only), or

 ■ Press Alt+Q (default keyboard shortcut), then select the object 
to examine (applies to objects only).



164

SPATIALANALYZER USER MANUAL

The Calculator
Since you may find the need to perform a quick calculation fairly fre-
quently in SA, a shortcut is provided for calling up the Windows cal-
culator utility.

To Start the Windows Calculator Utility:

 ■ From the menu, select Edit>Calculator.

User Notes
Occasionally you may be interested in recording some field notes. 
You can add user notes to an SA job for later reference or for adding 
to a report. A user note will be added to the tree under the Events
category, and can optionally be added to the job’s log file as well.

To Add a User Note:

1. From the menu, select Edit>Add User Note, or press Ctrl+N (de-
fault keyboard shortcut).

2. In the Enter User Note field, type a summary and details for 
the note.

3. If you’d like the note to also be logged in the job’s log file, se-
lect the Log File option.

4. Click OK.

Adding Notes to Items

You can also add notes and associate them with specific items. For in-
stance, if you’re measuring a cylindrical tank to check for deformation 
when it’s filled, you might want to add a note that a best-fit cylinder 
was created when the tank was filled, and add the quantity of fluid in 
the tank for later analysis.

To Add a Note to an Item:

1. Right-click the item in the tree or graphical view and select 
Properties from the context menu.

2. In the Notes field, enter the desired note, then close the dialog.

Item History
Many different items in your job have a history associated with them. 
An item’s history shows significant events related to the item’s cre-
ation or manipulation. For instance, all item histories indicate when 
the item was added to the job,. A circle’s history may indicate the de-

Note:  Some items, such as 
polygonized surfaces, sur-

faces, and relationships, do not 
have associated notes.
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tails of the geometry fit used to create that circle.

To View an Item’s Historical Log:

 ■ Right-click the item in the tree or graphical view and select His-
tory from the context menu.

To Expand or Collapse all Entries in an Item’s History:

 ■ In the item’s history dialog, click the + or - button.

To Change the Chronological Order in Which an Item’s History is Displaye:

 ■ In the item’s history dialog, choose the ascending or descend-
ing option.

To Copy an Item’s History to the Clipboard:

 ■ In the item’s history dialog, select the entries to copy (or select 
none to copy them all), then click the Copy to Clipboard button.

To Export an Item’s History to a Text File:

 ■ In the item’s history dialog, click the Export Entire Log as Text File but-
ton. Choose a filename, then click Save.

To Search an Item’s Historical Log:

 ■ In the item’s history dialog, click the Search button. In the result-
ing Search dialog, type a string to search for, then click Find Next.

To Trim an Item’s Historical Log:

 ■ In the item’s history dialog, click the Trim Log button. Confirm the 
action, then specify the number of log entries to keep and click 
the OK button.

Print Setup
Default printing options can be setup through the Print Setup dialog 
(Figure 6-36).

Figure 6-36. The Print Setup 
dialog.

This standard dialog’s options depend on the selected printer but de-
fine how output from printed reports is handled by the printer. For 
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more information, refer to your printer’s documentation.

To Modify Print Settings:

1. From the menu, select File>Print Setup...

2. Choose the desired settings, then click OK.

Command-Line Arguments
SpatialAnalyzer has a series of command-line arguments that allow 
you to automate some tasks when launching the program:

Argument Description

/? Displays a help window showing all of the available 
command-line arguments.

{FILENAME.XIT} Automatically opens the specified SA job file upon launch. 
Replace {filename.xit} with the path to the desired file.

/MP {FILENAME.MP} Runs the specified Measurement Plan file upon launch. 
Replace {filename.mp} with the path to the desired mea-

surement plan file.

/MPE {COLLECTION}::{MP NAME} Runs the specified embedded Measurement Plan upon 
launch. Replace {COLLECTION} with the collection name, 

and {MP Name} with the name of the embedded MP in the 
SA tree.

/QUICK {INSTRUMENT NAME} Launches SA, starts a new file, adds the entered instrument 
name, and starts its interface. Replace {Instrument Name} 
with the name of the instrument (as specified in the Add 

Instrument to SA dialog).

-MINIMIZE Starts SA in a minimized window state.

Combinations of these arguments may be executed at the same time. 
Quotes are required around the elements (filenames, instrument 
names, and object names) if they contain spaces.

Launching SA with Command-Line Arguments

Command-line arguments were traditionally used when running a 
program from the DOS (command prompt) window. Now that graph-
ical operating systems like Windows have become standard, com-
mand-line arguments are usually entered by use of a shortcut icon. 
Regardless, they can still be executed from the Windows command 
prompt.

To Use Command-Line Arguments from the Windows Command Prompt:

1. In the windows search box, type cmd and press Enter.

2. In the resulting window, navigate to the SpatialAnalyzer in-
stall directory by typing cd {PATH}, where {PATH} is the 
path to the SA install directory. For example, cd C:\Pro-
gram Files\New River Kinematics\SpatialAnalyz-
er 2019.11.21.  Press Enter.

3. Type “Spatial Analyzer” {ARGUMENTS}, where {ARGU-
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MENTS} includes one or more of the arguments listed above. 
Press Enter.

4. SA should launch, using the parameters that you specified in 
the arguments.

To Use Command-Line Arguments via a Shortcut Icon:

1. Create a shortcut for the SpatialAnalyzer program (C:\Pro-
gram Files (x86)\New River Kinematics\SpatialAnalyzer 
2019.11.21_62452\x64\Spatial Analyzer64.exe). 

2. Right-click on the icon and choose Properties.

3. In the Properties dialog, locate the Target field, add a space at 
the end of the text in this field, then add the arguments as 
specified above. When finished, click the OK button 

4. Double-click the icon to start SA with the specified param-
eters. 

Example Command-Line Arguments

To: Command

Start SA With A File “Spatial Analyzer” “C:\MyFolder\My Tem-
plate File.xit”

“Spatial Analyzer” FileInThisFolder.xit

View the Command-Line Argument Help “Spatial Analyzer” /?

Start an External MP in a Specified File “Spatial Analyzer” /MP C:\MyScripts\
MyMP.mp MyFile.xit

Start an Embedded MP in a Specified File “Spatial Analyzer” /MPE 
Nominal::MyEmbeddedMP MyFile.xit

Add/Startup a Leica Tracker in a New File “Spatial Analyzer” /QUICK “Leica emScon 
Absolute Tracker (AT901 Series)”

Add/Startup an API AXXIS Arm in a Specified 
File

“Spatial Analyzer” /QUICK “AXXIS 6-200 
Arm (3.2m 6 dof)” myFile.xit

Multiple Instances and Exiting SA
SA does not have a “tabbed” interface. If you would like to have mul-
tiple copies of SA open on a single computer, simply open the appli-
cation again. 

To Exit SA:

 ■ From the menu, select File>Exit, click the “X” in the top-right cor-
ner of the application window, or double-click the application 
icon in the top-left corner of the window.
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SA Files

Creating New Files

Creating a “new” file in SA does not necessarily mean that you’re work-
ing with a blank slate, as you would be in some applications. Even a 
completely new file has at the very least a collection, a coordinate 
frame, and myriads of settings for anything from colors and units to 
decimal precision.

When a new file is created without the existence of a default tem-
plate, SA opens a factory default file—that is, a file that has default 
settings hardcoded by NRK.

To Create A New File:

 ■ From the menu, select File>New, or click the icon on the tool-
bar. If you currently have an SA file open, you will be asked if 
you would like to save it.

If you have an existing file open, you can restore it to the factory de-
fault settings (colors, decimal precision settings, etc).

To Revert a File’s Settings to the Factory Default:

 ■ With the file open, select File>Restore Default Settings. The set-

While working in SA you will likely be working with many types of 
files—SA job (.XIT) files, CAD files containing nominal designs, and text 
files containing point coordinates, for example. This chapter explains 
how to work with external files in SpatialAnalyzer.

Working With 
Files
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tings will return to the defaults. You will of course need to save 
the file to store the changes.

Opening Files

The Open File command permits opening native SpatialAnalyzer files. 
These are commonly referred to as job files and come in one of two 
formats:

 ■ xit. This is a standard 32-bit .xit file. It can be opened by both 
32- and 64-bit versions of SA, but cannot have extremely large 
data sets. It is limited to storing data that will fit in a 32-bit soft-
ware environment.

 ■ xit64. This is a 64-bit SA file. It can only be opened in the 64-bit 
version of SA, but is able to store very large data sets (such as 
extremely dense scan sets).

SpatialAnalyzer job files are backward compatible—you can open an 
.xit or .xit64 file saved in an older version of SA in a newer ver-
sion. However, the reverse is not true—attempts to open a job file 
saved in a newer version of SA into an older version will fail.

To Open an Existing File:

 ■ From the menu, select File>Open, or

 ■ Click the icon on the toolbar, or

 ■ Press the default keyboard shortcut of Ctrl+O, or

 ■ Double-click an SA file in Windows Explorer.

To Open a Recent File:

 ■ From the menu, select File>[Filename] toward the bottom of the 
file menu.

Saving Files

You can save a SpatialAnalyzer job file in one of two formats, as de-
scribed in “Opening Files” on page 170. Any current job file can be 
saved in either format, however it’s important to keep a few things in 
mind:

 ■ If you want to be able to open the file in either the 32-bit or 
64-bit version of SA, you must save the file in the 32-bit (.xit) 
format.

 ■ If the file contains a very large dataset, and you want to pre-
serve the integrity of the data, it must be saved in the 64-bit 
(.xit64) format and cannot be opened in the 32-bit version 
of SA.

 ■ A very large file can be saved in the 32-bit (.xit) format if 
you’d like, however there will likely be loss of data. You will be 

Note:  If you double-click a 
file in Windows Explorer, it 

will be opened in the most recent 
version of SA that has been 
opened.
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warned if this occurs.

File Checksums
To protect against data integrity issues, SA can perform a checksum 
of your SA file immediately after a save operation. This essentially ver-
ifies that the file on disk matches the currently opened file, assuring 
that the save was successful.

To Verify File Checksums After Saving:

1. In the User Options dialog, navigate to the Machine Configuration 
tab.

2. Enable the Verify File Checksums after Saving option.

To Save an SA file:

1. From the menu, select File>Save, click the icon on the tool-
bar, or use the default keyboard shortcut (Ctrl+S).

2. In the Save As dialog, select the desired format from the Save as 
type: dropdown, then click Save.

The first time you save a file, you will be prompted to choose a name 
and format. Subsequent saves will simply save the file and not prompt 
you for a file name or format.

Save As

If you choose to save the current file under a different filename or 
format, you can select the Save As command at any time. This permits 
you to specify a new filename or format, even if you’ve already saved 
the current file.

To Save the File With a New Name or Format:

1. From the menu, select File>Save As.

2. In the Save As dialog, specify a new filename and format, then 
click Save.

Backing Up Files

SA can be configured to capture periodic, automatic backups of your 
working file which requires no user intervention. However, you can 
also automatically save a backup copy of your current file. This back-
up will be saved to the current backup folder and the filename will be 
appended with a timestamp.

To Force A Backup File To Be Saved:

 ■ From the menu, select File>Backup Now. After a short delay, the 
file will be saved to the backup folder.
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Automatic Backups
Losing measurement data or your job progress can be a critical and 
expensive problem. To mitigate this risk, you can set your machine to 
make automatic SA file backups while SA is running. There are two 
types of backups that can be made:

 ■ Job File Backups. These backup files save the same informa-
tion as a standard job file. (In fact, job file backups are simply 
regular SA files that are saved automatically for you).

 ■ Measurement Backups. These backups only store instru-
ments and measurements.

So why are there two types? The main reason is to save space. You 
might be working in a file with a very large complex nominal CAD file. 
There is simply no reason why all of this information should be saved 
in a backup, because the CAD surfaces are typically not modified. As 
a result, they mostly just waste hard disk space. Measurement back-
ups, on the other hand, only store instrument and measurement data 
which is much more critical and significantly smaller in file size. As a 
result, frequent measurement backups can be made without wasting 
hard drive space or causing performance delays, whereas frequent 
job file backups would cause a much bigger hit to performance and 
available drive space. Measurement backups are also regular SA files, 
and can easily be re-merged into the SA file containing the nominal 
CAD data using the File>Import command.

Sometimes, you might open a file, make a few changes, and acciden-
tally overwrite your original file, which could be disastrous without a 
backup. To help prevent this type of mistake, you can optionally ask 
SA to create a file backup automatically upon opening the file, so you 
have a pristine, untouched backup in place.

You can also ask SA to automatically create Measurement Plan back-
up files while making changes in the MP Editor. If the specified time 
has elapsed and changes have occurred to your MP, SA will store a 
backup of your script to the Backups folder.

To Enable Automatic Backups:

1. Click the User Options icon in the Main toolbar.

2. In the Automatic Backups section of the Machine Configuration tab, click 
the enabled checkbox for the appropriate backup type.

3. Select a time interval at which enabled backups should occur.

4. If desired, enable the automatically Create on File Open option 
to store a backup upon opening a file.

or

 ■ To quickly toggle automatic backups without changing other 
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backup settings, toggle the Edit>Automatic File Backup setting in 
the menus (this does not apply to MP Backups).

To Restore a Job File Backup

 ■ Select Edit>Undo to Restore Point from the menus. Select a desired 
restore point from the list, or

 ■ Select File>Open and select the desired file in your backup fold-
er.

To Restore a Measurement Backup

 ■ Select File>Open and select the desired file in your backup fold-
er.

To Restore a Measurement Plan Backup

 ■ In the MP Editor, select File>Open and select the desired .MP file 
in the backup folder.

Restore Points

Restore points can be thought of as “quicksaves”. At any time, you can 
create a quick backup of your current files by creating a restore point. 
You can then revert back to the restore point to continue from that 
point. They are not a complete alternative to an undo system (which 
is not available in SA) as they require you to consciously create a re-
store point. However, they are very useful as quicksaves of your work-
ing job file.

To Create a Restore Point:

Do one of the following:

 ■ From the menu, select Edit>Create Restore Point, or

 ■ Press Alt+Space (the default keyboard shortcut).

To Undo to a Restore Point:

Do one of the following:

 ■ From the menu, select Edit>Undo to Restore Point, or

 ■ Press Ctrl+Z (the default keyboard shortcut).

Password-Protecting SA Files

For safety purposes, you may choose to password-protect your SA file 
to prevent accidental or malicious modification. This involves assign-
ing a password to the current job file, then saving it. When the file is 
opened in the future, it requires a password to access the data.

To Password-Protect a Job File:

1. From the menu, select File>Password Protection>Set Password.

2. In the Set Password dialog, enter your password into both 

Warning:  The password 
protection scheme is not 
intended to be a secure 

method of data storage. Pass-
word protection can be circum-
vented by a hacker relatively eas-
ily. If you need high security, you 
should use a tool designed for 
secure data storage.
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fields.

3. When prompted, confirm that you wish to apply a password 
to the file.

4. Save the file. It will now require a password to open.

To Remove a Password From a Job File:

1. From the menu, select File>Password Protection>Remove Password.

2. At the prompt, confirm that you would like to remove the 
password.

3. Save the file. A password will no longer be required to open it.

File Import
SA supports a wide variety of common file formats, making data shar-
ing easy. You can work with various CAD formats, text-based point 
formats, custom formats and embedded formats. The act of import-
ing a file will always merge it into the existing job file.

When a file is imported, the data is transformed by aligning the work-
ing frame or active coordinate system of the imported file to the 
working frame of the current file.

Auto Import

You can let SA choose the proper import method for a file based on its 
file extension. You do this using the Auto Import (by file extension) com-
mand. Be aware that this depends on the file extension to match the 
format of the file. If there is a mismatch, the import will fail.

To Auto-Import a File by Type:

1. Do one of the following:

 ■ From the menu, select File>Auto Import (by file extension), or

 ■ In the toolbar, click the Auto Import icon, or

 ■ Drag the file from Windows Explorer into the graphical view, or

 ■ In the tree, switch to the Explorer tab, find the file to import, then 
double-click it.

2. The appropriate file import command will be triggered.

Importing SpatialAnalyzer Job Files

It is often desirable to merge another SA job (.xit file) into the current 
SA file. This is particularly useful when portions of measurement have 
been accomplished on various computers and files. You can choose 
which collections should be imported.
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To Import Another SA File Into the Current Job Using the Menus:

1. Choose File>Import>SpatialAnalyzer Job File (.xit). Choose the file 
to import.

2. From the SA File Import Filter dialog, check the collections 
you’d like to import.

3. Click Import Selected Collections.

Direct CAD Access

The Direct CAD Access import option allows a user to import native CAD 
files directly into SpatialAnalyzer. The following is a list of supported 
formats:

Format Extensions Version Polygonized 
Surfaces Surfaces Annotations

ACIS .SAT, .SAB Up to 2020 N/A

AutoCAD - 2D .dwg, .dxf Up to 2019 N/A

AutoCAD - 3D .dwg, .dxf Up to 2019 N/A

Autodesk 3DS .3DS Any N/A N/A

Autodesk DWF .DWF, .DWFX Any N/A N/A

Autodesk Inventor .IPT, .IAM Up to 2021

CATIA V4 .MODEL, .SESSION, .DLV, .EXP Up to 4.2.5

CATIA V5 .CATPRODUCT, .CATPART, 
.CATSHAPE, .CGR Up to  V5-R2020

CATIA V6 / 3DExperience .3DXML Up to  V5-6 R2019 (R29) N/A

COLLADA .DAE Any N/A N/A

Creo - Pro/E .ASM, .NEU, .PRT, .XAS, .XPR Pro/Engineer 19.0 to Creo 
7.0

GL Transmission Format .GLTF, .GLB Version 2.0 only N/A N/A

I-deas .MF1, .ARC, .UNV, .PKG Up to 13.x (NX 5), NX 
I-deas 6

IFC .IFC, .IFCZIP IFC2x Editions 2, 3 & 4 N/A N/A

IGES .IGS, .IGES 5.1, 5.2, 5.3 N/A

FBX FBX ASCII: from 7100 to 7400. 
Binary: all. N/A N/A

JT .JT Up to v10.3

NX - Unigraphics .PRT Unigraphics v11.0 to NX 
12.0, and NX 1899

Parasolid .X_T, .X_B, .XMT, .XMT_TXT Up to v32.0 N/A

PDF .PDF All Versions

Note:  If any imported col-
lections have the same 

name as existing collections, they 
will be automatically renamed.
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Format Extensions Version Polygonized 
Surfaces Surfaces Annotations

PRC .PRC All Versions

Revit .RVT, .RFA 2015 to 2020 (64-bit only)

Rhino3D .3DM v4, v5, v6 N/A

Solid Edge .ASM, .PAR, .PWD, .PSM V19-20, ST10, 2020

SolidWorks .SLDASM, .SLDPRT From 97 up to 2020  
*

STEP .STP, .STEP AP 203 E1/E2, 
AP 214, AP 242

STEP/XML STPX, STPXZ Any

Stereo Lithography 
(STL) .STL All Versions N/A N/A

U3D .U3D ECMA-363  
(1st, 2nd, 3rd Editions) N/A N/A

VDA-FS .VDA v1.0 and v2.0 N/A

VRML .WRL, .VRML v1.0 and v2.0 N/A N/A

Wavefront OBJ .OBJ Any N/A N/A

Supported:

Unavailable in this CAD Format: N/A

Not currently offered in SA:

* Our SolidWorks PMI reader is limited. 

To Natively Import a CAD File:

1. From the menu, select File>Import>Direct CAD Access.

2. Select the file you’d like to import.

3. In the Direct CAD Access dialog (if you’ve chosen to show this 
dialog), choose the desired import options.

4. If the Selective import option is checked in the Direct CAD Ac-
cess dialog, the Choose CAD Features dialog will be shown 
(Figure 7-1). Choose the desired features to import, then click 
OK. For more on this dialog, see “Selective CAD Import” on 
page 177.
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Figure 7-1. The selective CAD 
import dialog.

Selective CAD Import
The Choose CAD Features dialog (Figure 7-1) is only displayed when 
the Selective import (Choose which Components to import) option in 
the Direct CAD Access Settings dialog is enabled (see “Direct CAD Ac-
cess Settings” on page 177). It lists all components of the CAD model 
or assembly in a tree-like view on the left, and a legend at right indi-
cates the type and quantity of all of the entities to be imported. In this 
dialog you can choose to deselect entities from the source CAD file 
that you do not wish to import. This provides several benefits:

 ■ It saves you the effort of having to clean up the CAD file of un-
wanted items after import.

 ■ It makes the import process shorter.

 ■ It allows you to circumvent portions of a CAD file that may be 
causing import errors.

Direct CAD Access Settings
The Direct CAD Access Settings control a number of options related 
to import via Direct CAD Access.

To Open the Direct CAD Access Settings:

 ■ From the menu, select File>Import>Direct CAD Access Settings, or

 ■ From the User Options Machine Configuration tab, click the Direct 
CAD Access Settings button.

The options for this dialog are explained below.
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Entity Types to Import:

Figure 7-2. The Direct CAD 
Access Settings dialog, section 1.

 ■ Entity Types to Import. These checkboxes give you control 
over which types of entities to import. Any unchecked entities 
will not be imported (Figure 7-2).

 ■ Group Name. All points from the CAD file will be imported into 
a group with this name.

Import Filters:

Figure 7-3. The Direct CAD 
Access Settings dialog, section 2.

 ■ Import Construction Geometry. For CAD formats that sup-
port it, unchecking this box will exclude construction geom-
etry from the import (Figure 7-3).

 ■ Import Hidden Entities. For CAD formats that support it, un-
checking this box will exclude hidden entities from the import.

 ■ Import all surfaces as Mesh Graphical Entities. When 
checked, surfaces from the CAD file are imported as Mesh 
Graphical Entities instead of true surfaces. Mesh Graphical En-
tities are useful for visualizing surfaces and have a significantly 
lower requirement for computing resources than surfaces, but 
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you cannot analyze against them.

 ■ Do not import fillets. Usually, CAD surfaces contain minor 
features that may not be important to a metrology inspection. 
Fillets or modeled weld beads are one example of this. To keep 
your imported model as efficient as possible, check this op-
tion to exclude fillets from the import (if the file type supports 
marking the features as such).

 ■ Do not import Dittos (repeated items). Some file formats 
support “dittos”, which are efficient memory copies of surfac-
es that are repeated over and over in a CAD file. For instance, 
hardware such as bolts, nuts, and screws are often modeled as 
dittos to save memory in the CAD application. These are fea-
tures that are rarely inspected by metrology—check this op-
tion to exclude them from the import.

 ■ Ditto Threshold. Some formats support multiple levels of dit-
tos (dittos of dittos, for instance). If necessary, you can modify 
this number to indicate the threshold below which dittos are 
not imported. Higher numbers import less dittos.

 ■ Selective Import (Choose which Components to Import). 
When enabled, the Choose CAD Features dialog is displayed to 
allow you to more finely control which entities are imported 
from the CAD file (see “Selective CAD Import” on page 177).

 ■ Surface Compatibility Mode. When enabled, this function at-
tempts to adapts each surface (brep) in the imported CAD to 
improve compatibility. Try enabling this when running into im-
port problems with specific CAD files.

 ■ Explode Surfaces. When enabled, individual surfaces will be 
created for each face in the imported model. Individual face 
colors will be set as the object colors, preserving more of the 
color information from the model during import. Use this func-
tion with caution when importing large models because abun-
dant surfaces can slow down tree operations.
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Other Settings:

Figure 7-4. The Direct CAD 
Access Settings dialog, section 3.

 ■ Center View on Imported Objects. When enabled, the graph-
ical view will be centered on the imported objects after import 
(Figure 7-4).

 ■ Import Into Folders Matching CAD File Hierarchy. When 
enabled, if the source CAD format supports a hierarchy, that 
hierarchy will be preserved in the SA tree using a hierarchy of 
folders and collections.

 ■ Remove Empty Folders. Importing a CAD file into fold-
ers maching the CAD file hierarchy (see previous option) can 
sometimes result in empty folders in the tree. Enabling this op-
tion removes these empty folders after the import operation.

 ■ Lock Imported Items. When enabled imported items that can 
be locked will have this status set automatically. 

 ■ Prompt if One or More Components Are Missing. Several 
CAD formats support the idea of a product or assembly file, 
which is a master file that has several supporting component 
CAD files. When importing these master files, this option will 
warn you if any subcomponent CAD files that are part of the 
master assembly are not found.

 ■ Do Not Show This Dialog Each Time. When enabled, the Di-
rect CAD Access Settings dialog will not display on import, but 
will use the previous settings. If you want to access the settings 
again, follow the steps in “To Create A New File:” on page 169.

 ■ Surface Normals Mode. This setting has two possible options: 
Mode 1 or Mode 2. Some CAD formats or CAD packages do not 
consistently define or store the direction of surface normals. 
Incorrectly oriented CAD surface normals will cause incorrect 

Tip:  Importing while match-
ing CAD hierarchy can result 

in a somewhat cumbersome, 
cluttered SA job file. Use this op-
tion sparingly, and only when 
needed.
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analysis in SA. While surface normals can always be corrected 
manually, if you find that one mode is importing surfaces in the 
wrong direction, trying Mode 2 might solve the problem.

Importing Standard CAD Formats

SA can import several standard CAD formats using an additional sec-
ond import utility called the  “classic” importer. These formats include:

 ■ STEP. Import via File>Import>Standard CAD Formats>STEP.

 ■ IGES. Import via File>Import>Standard CAD Formats>IGES.

 ■ VDA. Import via File>Import>Standard CAD Formats>VDA.

 ■ SAT. Import via File>Import>Standard CAD Formats>SAT.

In addition to providing additional import formats, you can also use 
this classic import method if you encounter problems attempting to 
import using Direct CAD Access. During the CAD import you can se-
lect from a variety of import options (Figure 7-5):

Figure 7-5. The Classic CAD 
Import Options dialog.

 ■ Import into Group. Points from the CAD file will be imported 
into a group with the specified name.

 ■ Use Point Color Information if available (1 group per col-
or).  Upon importing points from the CAD file, this option will 
set the group color to match the current point color from the 
source file, if that color exists. Each point will be organized into 
a group by its color.

 ■ Lines/Circles/Curves/Planes/Surfaces/Coordinate Frames. 
Choose which types of entities to import.

 ■ Ignore ‘No Shows’. When selected, items hidden or on a “no 
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show” layer in the file (if supported) will not be imported.

 ■ Surface Normals Mode. Equivalent to the same option in the 
Direct CAD Access Settings dialog (see “Direct CAD Access Set-
tings” on page 177).

To Import a Standard CAD Format Using the Classic Importer:

1. Choose File>Import>Classic CAD Importers>(Format).

2. Select the file to import from the dialog, and click OK.

3. Choose the desired CAD import options, then click OK.

4. A summary of the file information will be displayed. To save it 
to file, click Save to File. Otherwise, click Accept.

5. If the current file’s units do not match the source units, you 
will be prompted whether you’d like to convert the units. Click 
Yes or No.

Importing Predefined ASCII Formatted Files

ASCII text files are common in coordinate metrology. They provide a 
standard, human-readable format that many software packages can 
easily import. SpatialAnalyzer supports many formats of ASCII data. 
Figure 7-1 shows an example of a file in “Point Name, X, Y, Z” format.

Figure 7-6. A text file containing 
point data in Pointname, X, 
Y, Z format.

When a file is selected, you will be presented with several options to 
define how SA will import the file (Figure 7-7):

Note:  If units between files 
differ, the units are convert-

ed (if you choose). The CAD data is 
not physically scaled at all.
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 ■

Figure 7-7. The ASCII Import 
dialog.

Select ASCII Import Format. Choose the format of the ASCII 
file. SA will automatically delimit using commas, tabs, or spaces 
(depending on how the ASCII file is set up). The format types 
can be filtered in the selection view based upon type, name , 
and number of fields represented by the ASCII line. 

 ■ File Units. Define the units used in the ASCII file.

 ■ Collection Name. Specifies the collection to which the data 
will be imported. This applies to all formats that do not contain 
a collection designation as part of the format. 

 ■ Point Group Name. Specify the name to import the points 
into (only applicable if not specified already by the format).

 ■ Ensure new group. Select this option to ensure that points are 
placed into a new point group if the specified group already 
exists.

 ■ Ensure unique names. Verifies that imported point names are 
unique.  If there is a naming conflict, the offending point will 
have an asterisk appended.

 ■ Make Point Cloud. Select this option to import points as a 
point cloud instead of a point group.

 ■ Comment character(s). Any lines that start with the specified 
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characters are treated as comment lines and are ignored.

To Import an ASCII-Formatted File:

1. Select File>Import>ASCII: Predefined Formats.

2. Choose the file to import.

3. In the ASCII Import dialog, specify the desired options, then 
click Import.

4. The file will be imported, and you will receive a summary of 
lines imported and ignored.

Importing ASCII Formatted Points With Offsets

There are two additional ASCII formats for importing points with off-
sets, depending on the format of your source data.

To Import Points With Offsets:

 ■ From the menu, select File>Import>ASCII: Points with 
Offsets><Format>.

<Name><X><Y><Z><Offset>

This option is used when the source file is in the format 
<Name><X><Y><Z><Offset>.

2 Files: <Name><X><Y><Z> + <Name><Offset>

This option is used when there are two source files: One in the format 
<Name><X><Y><Z> and the other in the format <Name><Offset>.

Importing XML Files

XML files containing nominal points and coordinates can be import-
ed into an SA file. At a later time, measured point data can be merged 
back into the XML file, which will associate the actual coordinates 
with the nominal coordinates. The nominal points will be imported 
into a group matching the name of the XML file.

XML Format: Nominal Points
The format of the XML file should have the standard XML format, such 
as the introductory tag:

<?xml version=”1.0” encoding=”UTF-8” ?>

Following this, an enclosing group may contain one or more <POINT> 
elements, containing a NAME attribute and a child <NOMINAL> ele-
ment which itself contains X, Y, and Z attributes. For example:

<?xml version=”1.0” encoding=”UTF-8” ?> 
  <left> 
    <POINT NAME=”Center1”> 
      <NOMINAL X=”1.000” Y=”4.000” Z=”7.000” /> 
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    </POINT> 
    <POINT NAME=”Center2”> 
      <NOMINAL X=”3.000” Y=”6.000” Z=”9.000” /> 
    </POINT> 
  </left>

XML Format: Nominal and Measured Points
Once measured data has been obtained, the measured point names 
are matched up with the nominal names in the XML file, and an <AC-
TUAL> element is added as a child of each matching <POINT> ele-
ment. This <ACTUAL> element contains X, Y, and Z attributes holding 
the measured coordinates. The above XML file might look like the fol-
lowing after merging measured data:

<?xml version=”1.0” encoding=”UTF-8” ?> 
  <left> 
    <POINT NAME=”Center1”> 
      <NOMINAL X=”1.000” Y=”4.000” Z=”7.000” /> 
      <ACTUAL X=”1.002” Y=”3.996” Z=”7.003” /> 
    </POINT> 
    <POINT NAME=”Center2”> 
      <NOMINAL X=”3.000” Y=”6.000” Z=”9.000” /> 
      <ACTUAL X=”3.007” Y=”6.005” Z=”8.998” /> 
    </POINT> 
  </left>

To Import an XML File:

1. From the menu, select File>Import>XML, then select the desired 
XML file.

2. In the XML import dialog, the structure of the points to im-
port will be listed (Figure 7-8). Click the Import Points button.

Figure 7-8. The XML import dialog 
for the above example file.

To Merge Measurements to an XML File:

1. From the menu, select File>Import>XML, then select the desired 
XML file.

2. In the XML import dialog (Figure 7-8), click the Merge Measure-
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ments and Save button.

3. From the Object Selection dialog, select the point group you’d 
like to merge.

Cloud Files: Standard Formats

Point Cloud data including color and intensity information can be im-
ported in the following standard formats: 

 ■ E57. Which is a ASTM standard format in a compressed form.

 ■ PTX. Is an ASCII point cloud format used by several instrument 
manufacturers. This format can be used to import point cloud 
data, intensity and RGB information. 

Using PTX for Point Cloud Import
PTX is a handy format because it provides a means to import cloud 
data with Intensity and RGB color for each cloud point. Any ascii file 
can be modified and saved as a *.ptx file for this purpose as long as 
you understand the format. 

The header includes the transform for an instrument within a job file 
with respect to the working frame. 

 ■ number of columns (for unstructured data enter 1)

 ■ number of rows (number of points to import)

 ■ st1 st2 st3 ; scanner registered position

 ■ sx1 sx2 sx3 ; scanner registered axis ‘X’

 ■ sy1 sy2 sy3 ; scanner registered axis ‘Y’

 ■ sz1 sz2 sz3 ; scanner registered axis ‘Z’

 ■ r11 r12 r13 0 ; transformation matrix

 ■ r21 r22 r23 0 ; this is a simple rotation and translation 4x4 ma-
trix

 ■ r31 r32 r33 0 ; just apply to each point to get the transformed 
coordinate

 ■ tr1 tr2 tr3 1 ; use double-precision variables

Therefore you header for un-transformed data would look like this: 

0,0,0; 1,0,0; 0,1,0; 0,0,1;1,0,0,0; 0,1,0,0; 0,0,1,0; 0,0,0,1

Each row below the header would then include the XYZ location of 
the cloud point, intensity in a range from 0 -1 and 3 color integer 
values (RGB in a range from 0 - 255).  An example cloud point entry 
would look like this:

4.147541 12.075727 1.136227 0.486915 76 74 91
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Custom Formats

Many custom file formats can be imported, including the following:

 ■ xyz, ijk Files (IJK). Files in IJK format (containing both position 
and probe orientation data).

 ■ Digital Network Level Measurements. Measurements from a 
digital level. This is an ASCII file expected to be of the format 
<group>, <target>, <elevation>.

 ■ VSTARS .xyz Files. .xyz files from VSTARS.

 ■ VSTARS Cameras. Camera files from VSTARS in the outstar.txt 
format.

 ■ DMIS Files.

 ■ Polyworks Files. .POL, .PIF, .PF, and .DPI formats are all sup-
ported.

 ■ IMETRIC Files.

 ■ Leica GSI8/GSI16 Files. Files from Leica total stations in GSI8 
or GSI16 format.

 ■ Leica SDB File. Imports a point cloud to the selected instru-
ment. *Note - Any additional transformations performed with-
in the Leica Job file cannot automatically be applied. 

 ■ Steinbichler AC Files. This imports data from a Steinbichler 
scanner (such as the T-Scan) originating in .AC format. Note 
that, depending on the scanning mode selected (Surface or 
Feature), T-Scan Collect can automatically post-process the 
data creating a mesh. When exported, the mesh or the point 
cloud will have the same format *.ac, and SA only supports 
*.ac format if it’s a point cloud.  “Surface” will create a mesh and 
“Features” a point cloud. 

 ■ Wavefront Objects Files. This imports data in Wavefront Tech-
nologies’ Objects file (.obj).

 ■ Leica ADF format. Files in Leica’s .adf format.

 ■ 1-D Data (DataMyte).

To Import a Custom File Format:

 ■ From the menu, select File>Import>Custom Formats>...

Embedding Files

You can import any file from the file system and embed it in the SA 
job file. The embedded file is placed into the active collection. This is 
convenient for transporting relevant files with the job file. Of course, 
when doing so the SA job file grows accordingly to store the file. At 
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any time, this file can be exported back to the file system.

To Embed a File:

1. Activate the collection into which you’d like to embed the file.

2. From the menu, select File>Import>File as Embedded File.

3. At the prompt, select the file to embed. The file will appear 
under the Embedded Files category of the tree.

Importing Images

You can import any common image format into the SA job. In the tree, 
embedded images appear under the Pictures category in the active col-
lection. Importing images is particularly useful because these images 
can be used in reports. For example, you might have a few JPEG im-
ages of a measured part taken with a digital camera that you’d like to 
include in your report. Importing these images into the SA file gives 
you the ability to use them in a report.

To Import an Image Into an SA File:

1. Ensure the collection into which you’d like to import the im-
age is active.

2. From the menu, select File>Import>Image.

3. At the prompt, select the image file to import. In the tree, the 
image will appear in the Pictures category of the active collec-
tion.

File Export
There are many ways to export your data from SA. Points, Point 
Clouds, Vector groups and many CAD formats are supported under 
the File>Export menu option.

Exporting ASCII Formatted Points

Points are easily exported from SA to an external ASCII text file. Using 
this method, the points are always exported in the working coordi-
nate frame. There are many export options to give you fine control 
over the export format and data (Figure 7-9). These options are sum-
marized below:

 ■ Target Name. The name of each exported target can be one 
of four options: Collection Group target, Group target, target, or 
none. These options indicate which parts of the point/target 
name are included. For example, exporting using Collection 
Group target exports in the format CollectionName Group-
Name TargetName x y z.



189

CHAPTER 7 ■ WORKING WITH FILES

 ■ Coordinate System. Point coordinates can be exported in Car-
tesian, Cylindric, or Spherical coordinates.

 ■ Tolerance. If selected, point tolerances will be exported for 
each point (if available).

 ■ Coordinate uncertainties. If selected, coordinate uncertain-
ties for each point will be exported (if available).

 ■ Time Stamps. If selected, the point’s time stamp will be ex-
ported.

 ■ Target Offsets. If selected, the planar and radial offset of each 
point will be exported.

 ■ Target Comments. If selected, any comments stored with the 
point will be exported.

 ■ Measurement Details. If selected, measurement details (such 
as RMS error, measurement mode, and sampling method) will 
be exported, if available.

 ■ Separator. Data can be delimited by spaces or commas in the 
exported format.

 ■ Decimal Precision. Numerical values can be exported using 
fixed decimal precision (you specify the number of digits) or 
using full precision scientific notation.

 ■ Include SA Version and Frame Comments. If selected, the SA 
version and working coordinate frame name will be listed at 
the beginning of the file, preceded by // to denote that the 
line is a comment.

 ■ Include Axis Comments. If selected, information about the 
exported coordinate system will be listed at the beginning of 
the file, preceded by // to denote that the line is a comment.
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Figure 7-9. The options for export-
ing ASCII points.

To Export Selected Points:

1. From the menu, select File>Export>Points (ASCII File).

2. When prompted, select the desired points to export, then 
press Enter.

3. In the Save As dialog, specify the name for the exported file, 
then click Save.

4. When the ASCII Export dialog appears, choose the desired op-
tions, then click OK. For convenience, the resulting exported 
file will be opened in Notepad.

To Export an Entire Point Group:

1. In the tree, right-click the desired point group to export, then 
select Export to ASCII File from the context menu.

2. In the  Save As dialog, specify the name for the exported file, 
then click Save.

3. When the ASCII Export dialog appears, choose the desired op-
tions, then click OK. For convenience, the resulting exported 
file will be opened in Notepad.

Exporting Point Clouds

You can export point clouds to an external ASCII file. You can specify 
whether each point is assigned a label in the exported file.

To Export One or More Point Clouds to an ASCII File:

1. From the menu, select File>Export>Point Clouds.
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2. Select one or more clouds to export.

3. In the Save As dialog, specify the filename to export, then 
click Save.

4. When prompted, indicate whether you would like each cloud 
point to have a label in the exported file.

To Export a Single Point Cloud to an ASCII File:

1. Right-click any point cloud in the tree and select Export to ASCII 
File.

2. In the Save As dialog, specify the filename to export, then 
click Save.

3. When prompted, indicate whether you would like each cloud 
point to have a label in the exported file.

Exporting Vector Groups

Vector groups can be exported to an ASCII file. The file is exported in 
the following format:

 ■ Name, X, Y, Z, dX, dY, dZ, Signed Magnitude
To Export a Vector Group to an ASCII File:

1. From the menu, select File>Export>Vector Group.

2. At the prompt, select the vector group to export.

3. In the save dialog, specify the name for the ASCII file to ex-
port. For convenience, the exported file will be opened for 
you in Notepad.

Exporting Geometry

The fundamental characteristics of any geometry type (either con-
structed or as part of Geometry Relationship) can be export to a *.csv 
file for easy access in Excel. Each parameter is included in a separate 
column. 

1. From the menu, select File>Export>Geometry. 

2. Select the objects or geometry relationships you would like to 
export (objects included in a relationship are listed under the 
relationship category). 

3. In the Save As dialog, specify the filename to export, then 
click Save.

Exporting Object Frames

The coordinate frames for any objects that have representable frames 
(such as coordinate frames, circles, and spheres) can be exported in 
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any of the following formats:

 ■ XYZ Fixed Angles. FrameName, X, Y, Z, Rx, Ry, 
Rz, [Timestamp]

 ■ XYZ Euler Angles. FrameName, X, Y, Z, Rx, Ry, 
Rz, [Timestamp]

 ■ ZYX Euler Angles. FrameName, X, Y, Z, Rx, Ry, 
Rz, [Timestamp]

 ■ ZYZ Euler Angles. FrameName, X, Y, Z, Rx, Ry, 
Rz, [Timestamp]

 ■ ZXZ Euler Angles. FrameName, X, Y, Z, Rx, Ry, 
Rz, [Timestamp]

 ■ Frame Name, Transformation Matrix (4x4). Frame-
Name, r0c0, r0c1, r0c2, r0c3, r1c0...[Timestamp]

 ■ Transformation Matrix (4x4). r0c0, r0c1, r0c2, 
r0c3, r1c0...[Timestamp]

The Fixed angle and Euler Angle options exports the name of the ob-
jects and their positions and orientations in space. The Transforma-
tion Matrix options export the 16 elements of their transformation 
matrix in addition to the other selections.

To Export Object Frames:

1. From the menu, select File>Export>Frames (and objects’ frames).

2. Select all of the objects defining the frames you’d like to ex-
port.

3. In the Frame Export Settings dialog, select the desired format 
for the exported file, then click OK.

4. In the Save As dialog, specify the name for the exported file. 
Notice that this file is automatically exported as a .CSV file. For 
convenience, the file is automatically opened after successful 
export.

Exporting to CAD Formats

SA jobs can be exported to several different formats, with support for 
points, geometry and surfaces. Only the entity types supported by 
the selected file format will be exported. The supported formats are:

 ■ STEP. You can export the entire SA file or specific objects.

 ■ IGES. You can export the entire SA file or specific objects.

 ■ VDA. You can export the entire SA file or specific objects.

 ■ SAT.
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 ■ DXF.

 ■ Metric Vision Instrument Compensation Data Format.

 ■ Imageware Cloud File.

 ■ Surface Wireframe Curve File(s) (.crv). Writes a wireframe 
representation of the selected surfaces to a text file containing 
comma-separated values.

 ■ Polyworks POL File.

 ■ STL. Files can be exported in either ASCII or binary format.

To Export an SA File to a CAD Format:

1. From the menu, select File>Export>[Format]. If supported, spec-
ify whether the entire model or specific objects should be ex-
ported.

2. If applicable, select the objects you’d like to export.

3. When prompted, specify the name of the file to export.

Exporting Window Placements

When automating SA using Measurement Plans or the SDK, it is 
sometimes desirable to preserve the placement and size of SA win-
dows and dialogs. Consider an example in which a number of client 
computers running at a specified screen resolution will be using a 
series of automation routines. In order to ensure that these measure-
ment computers have all of the windows and dialogs in the exact 
same place as the “development computer”, you can export window 
placements on the development computer, then have the automa-
tion routine import these placements on the client computers using 
the Import SA Windows Placement MP command. This will ensure that the 
client computers position and size the windows exactly the same as 
the development computers.

To Export Window Placements:

1. From the menu, select File>Export>Window Placements.

2. Specify a name for the exported file. The file will be exported 
as a .POS file.

Templates
When you create a new file or start up SpatialAnalyzer, it opens in a 
“factory default” configuration. However, you might wish to specify 
your own read-only configurations for one or more files that are used 
as starting points for your work. Or, you may wish to create a con-
figuration that is used as the default starting point for your job when 
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starting up SA or creating a new default file. For instance, you likely 
have a preferred set of default units, decimal precision settings, col-
ors, and other settings you wish to use. Setting these manually each 
time you start a new job would be tedious.

To satisfy this need, SA employs templates. A template is not very dif-
ferent from a regular job file. In fact, it is a job file. The only difference 
is that it is marked as read-only and is typically stored in a standard 
folder on disk (C:\Analyzer Data\Templates), although this is 
not a requirement.

To Create a New Template File:

1. Configure a job file as desired.

2. From the menu, select File>Save As Read-Only Template.

3. In the dialog, specify the name and location for the template 
file. It will be set as read-only.

To Open an Existing Template File:

1. From the menu, select File>Open Template File.

2. From the dialog, choose the file to open.

The Default Template

Instead of having templates as starting points for a specific job, you 
may also have a preferred default starting configuration for all files. 
SpatialAnalyzer provides the capability to define a default template. 
A default template is a template that is automatically loaded in the 
following situations:

 ■ SpatialAnalyzer is started from the Windows start menu or a 
desktop shortcut.

 ■ File>New is selected from the menu, or the New File icon is 
selected in the toolbar.

Default templates help you avoid repeating the same job file prepa-
ration steps by allowing you to define a starting point for all of your 
job files. They also provide a convenient method for standardizing file 
setup and settings across an organization. If a default template does 
not exist, SA will use factory default settings.

To Create a Default Template

1. Configure an SA file with the settings for your template. Re-
member to set all settings that are saved with an SA file (such 
as the active units and decimal precision settings) as desired.

2. From the menu, choose File>Save As Read-Only Template.

3. In the save dialog, ensure you are in the Analyzer Data\
Templates folder (SA will take you there by default), then 

Note:  Template files are typ-
ically stored in C:\Analyz-

er Data\Templates, although 
this is not mandatory.
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save the template as default.xit. When you start SA or a 
new file, this file will automatically be restored.

To Remove a Default Template

1. Navigate to SA’s Analyzer Data\Templates folder in Win-
dows Explorer.

2. Delete the default.xit file. Without this file, the factory de-
fault settings will be used.

Screen & Graphics Capture
At any time, you can capture either the entire screen or the graphical 
view for printing or output to a standard image file (BMP, JPG, PNG, 
GIF, or TIFF).

To Print or Capture the Screen or Graphical View:

1. From the menu, select File>Capture Screen[Capture Graphics]>To 
Printer[To File (BMP/JPG/PNG/GIF/TIFF)] as appropriate.

2. If capturing to printer, choose the printing options and con-
firm. If capturing to file, select the filename and type, then 
click Save.

3. The Capture Graphics > To File (BMP/JPG/PNG/GIF/TIFF) command al-
lows you to specify a render scale. A value of 1.0 uses the ac-
tual pixel count of the graphical view for the resulting image. 
A value of 3.0 will create an image three times the resolution 
of the graphical view.
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About Points
A point is defined as a specific location in three-dimensional space, 
and may be represented in Cartesian (X/Y/Z), Spherical (r/θ/Φ), or Cy-
lindrical (r/θ/Z) coordinates (depending on the application). With a 
few exceptions coordinates are reported to the user in the working 
coordinate frame.

Points can be created by many methods. For example, they can be 
created from a point construction command or can be the result of 
measurement with a portable metrology device. They may be im-
ported from a CAD file, extracted from sphere scans, or the result of a 
fit to existing data.

Point Groups

In SA, all points must exist inside of a point group. A point group is a 
container for a set of points that are related in some way. The point 
group itself is considered an object, whereas its contained points are 
not objects. All points inside of a point group are treated as a rigid 
body. That is, when you move or rotate a point group, all of the en-
closed point groups move or rotate together, as if rigidly connected.

The point group is the organizational element that is used to organize 

Points are the most fundamental aspect of any measurement. They are 
the basis from which virtually all analysis is performed in portable me-
trology—therefore having a good understanding of how they work in 
SpatialAnalyzer is crucial.

Points
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your point data by feature. All measurements of a specific hole should 
typically be placed into their own point group. All measurements of 
reference (tie-in) points should typically be placed into their own 
group. Likewise, measurements of a complex surface should typically 
be placed into their own group as well. As mentioned earlier in this 
manual, organizing your point data in this manner will make analysis 
and reporting easier later on.

Since point groups are objects and points themselves are not, only 
point groups have a color. All points inside that group inherit the col-
or of their point group.

There are two types of points that you will see in SA: Constructed 
points and Measured points (also referred to as targets). Both of these 
types of points may appear in the same point group.

Constructed Points

A constructed point is a point that is not associated with any instru-
ment observations or measurements. There are many ways to create 
constructed points. They may have been created manually by enter-
ing coordinates, by intersecting a line with a plane, or may be the re-
sult of importing data from an ASCII file. A constructed point may also 
result from deleting a target’s individual measurement observations.

Figure 8-1. A constructed point as 
seen in the graphical view.

A constructed point is represented in the graphical view and the SA 
tree by a 3-D “plus” symbol, as pictured in Figure 8-1 and Figure 8-2.

Figure 8-2. A constructed point in 
the tree named MyPoint sits inside 
the MyPointGroup group.

Expanding the triangle next to any point will display its coordinates in 
the working frame.

Measured Points

A measured point (also referred to as a target) is a point which has been 
determined from one or more direct instrument observations. For 
traceability purposes, targets they maintain a record about who and 
what measured them, when and how they were measured, weather 
data, sampling statistics, raw measurement data from the instrument, 
and any other pertinent metadata. Because they are tied to instru-
ment measurements, measured points cannot be created through 
typical point construction or analysis methods--they must be mea-
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sured. (There is, however, a way to create targets through measure-
ment simulation).

Measured points are represented in the graphical view by a 3-D plus 
symbol with a diamond around it (Figure 8-3).

Figure 8-3. A measured point as it 
appears in the graphical view.

In the tree, targets are represented by a crosshair icon (Figure 8-4).

Figure 8-4. A measured target 
named MyTarget as it appears in 
the tree.

Expanding the triangle next to any point will display its coordinates in 
the working frame.

Point Characteristics
There are a number of characteristics common to both constructed 
and measured points. The Point (Target) Information dialog, shown 
in Figure 8-5, contains the properties of an individual point. In this 
particular figure, a constructed point’s properties are shown.

Figure 8-5. The Point Infor-
mation dialog for a constructed 
point.

To Display the Properties for a Point:

 ■ Double-click a point in the graphical view or tree, or

 ■ Right-click a point in the graphical view or tree and select Prop-
erties.
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At the top of the Point Information dialog, the collection, group, and 
target name are listed. Below that are the coordinates of the point in 
the working coordinate frame.

To Edit the Coordinates of a Point:

1. Click the Edit Values button. The Edit Point Coordinates dialog 
will appear as shown in Figure 8-6.

2. 

Figure 8-6. The Edit Point 
Coordinates dialog.

Type in the new values and click OK.

If you attempt to edit the coordinates of a measured point (some-
thing you typically should not do), you will receive a warning and the 
measured point will turn into a constructed point. The original mea-
surement data is still preserved with the point, but the measurements 
become deactivated and they need to be reactivated (and the target 
recomputed) to restore the measured point.

Point Tolerance

Each point can be assigned a tolerance (Figure 8-7). Tolerances that 
have been assigned to a point will be used for watch windows and 
other comparisons where applicable. A point tolerance must be as-
sociated with a specific coordinate frame (because it may be asym-
metrical). Tolerances can be applied on any combination of axes, and 
in any combination of sides (high or low).

Figure 8-7. The Point Toler-
ance dialog allows you to specify the 
tolerance for a point.

To Add a Tolerance to a Point:

1. In the Point (Target) Information dialog, click the Tolerance 
button, or right-click the point in the tree or view and choose 
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Tolerance.

2. In the resulting Point Tolerance dialog, click the Add button, 
as shown in  Figure 8-7.

3. To pick the applicable coordinate frame from a list, click the 
Pick Frame button and choose the frame from the resulting 
dialog. To specify that the tolerance will apply to the current 
working frame, click the Use Active Frame button.

4. To assign the numeric tolerance value, click the Tolerance but-
ton, which will open the Vector Tolerance dialog (Figure 8-8).

5. 

Figure 8-8. The Vector Tolerance 
dialog.

Check the tolerances that you want to apply, and enter the 
numeric values. The Enable All and Disable All buttons are 
shortcuts to check and uncheck all tolerances. If a value is en-
tered into the Set Values field, then clicking the Set All High, Set 
All +/-, or Set All Low buttons apply the value to all of the high 
tolerances, all of the high and low tolerances, or all of the low 
tolerances, respectively.

6. Click OK to apply the tolerance.

Notes

The Notes field in the Point (Target) Information dialog can be used to 
enter descriptive notes about an individual point.

Targeting Offsets

Each point can be assigned a planar and radial target offset. Enter the 
values in these fields to change them for a single point. These offsets 
will be automatically compensated for when comparing the point to 
surfaces and other geometry. By default, constructed points have off-
set values of zero.

Planar Offset
The planar offset is the most commonly-used offset. It is used in al-
most all situations. To provide examples, the planar offset is used 
when compensating in the planar direction for a pin nest (Figure 8-9), 
when comparing to a cylinder or best-fitting a cylinder to measured 
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points, or when comparing a set of measured points to a surface.

Radial Offset
The radial offset is only used in one situation: when using tooling in-
tended to measure circular and elliptical holes that has a radial offset 
associated with it—that is, when using a pin nest. In Figure 8-9, the 
radius of the pin nest’s shank determines how far outward or inward 
the circle radius or ellipse axis must be offset.

Figure 8-9. Measuring a surface 
hole with a laser tracker’s SMR and Pin 
Nest.

Radial Offset
Planar Offset

Material

Spherical probes (such as SMRs and balls) have the same planar and 
radial offset, although technically the radial offset is not used.

The following are some sample measurement instrument/tooling 
combinations, and the proper planar and radial offsets associated 
with each:

Measurement Tooling Planar Offset Radial Offset

PCMM arm with 6 mm probe 3 mm (0.1181”) 3 mm (0.1181”)

PCMM arm with 3 mm probe 1.5 mm (0.0591”) 1.5 mm (0.0591”)

PCMM arm with Point Probe 0 0

Tracker with 1.5” (38.1 mm) SMR 0.75” (19.05 mm) 0.75” (19.05 mm)

Tracker with 1.5” SMR and Flat Nest1 1.0” (25.4 mm) N/A (0)

Tracker with 1.5” SMR and Pin Nest 1.0” (25.4 mm) 0.125” (3.175 mm)

Tracker with 1.5” SMR and Edge Nest 1.0” (25.4 mm) 0

Laser Radar (non-contact measurement) 0 0

1 When a flat nest is used, a feature such as a hole cannot be 
measured because there is no tooling feature to properly locate the 
SMR radially. As a result, there is no valid radial offset for this tooling 
combination.
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Accessing A Point’s Group Menu From the Graphical View

Sometimes, you want to select a point and access the properties of 
its enclosing point group. For instance, to change the color of a point 
you would need to access its parent point group. The graphical view’s 
context menu allows you to do just that.

To Access a Point’s Enclosing Group Menu:

 ■ In the graphical view, right-click a point and select Group Menu 
from the context menu. The enclosing group’s context menu 
will be displayed.

Measurements
Measured points carry a number of additional properties that are im-
portant to understand.

How SA Computes a Measured Point’s Location

Determining the location of a measured point at first seems trivial. 
However, it gets significantly more complex when you realize that 
some instruments (such as theodolites) are angle-only measurement 
devices, and do not measure a target’s position in space. With the-
odolites, at least two measurements of a target need to be recorded 
from different points in space to triangulate the location of the point.

Another complication is that one or more instruments may measure 
a single target several times. We will discuss these situations, but let’s 
first look at how SA computes a measured point’s location in a simple 
case, when an instrument provides a point position in space.

When measurements are recorded, SA always records the raw mea-
surement data that came from the instrument. For theodolites, this 
means a horizontal angle (azimuth) and vertical angle (elevation). For  
other line-of-sight devices, it means azimuth, elevation, and distance, 
and for non-spherical measurement devices (such as portable arms) 
the coordinates are provided from the instrument in Cartesian space.

The instrument always provides the location of the measurement 
relative to its own internal reference system—typically at the opti-
cal center or at the base of an instrument. Since each instrument 
has a three-dimensional position and orientation in the job file, SA 
takes these raw measurements and calculates their coordinates in job 
space based on the position of the instrument. When an instrument 
moves, the position of all of its measurements are recalculated.

At any time, you can move a point group containing measured 
points. When you do so, you will break the connection between the 
measured points and their instrument, and the measured points will 
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instantly turn into constructed points to show that you are no longer 
looking at actual measurements. You haven’t lost the original mea-
surement data, however. You can recalculate these measured points 
and turn them back into measurements.

To Recalculate Measured Points:

 ■ From the menu, select Analysis>Re-Compute Targets From Shots. This 
will snap all measurements back into place relative to the in-
strument and convert them back into measured points.

About Target Observations

An observation is a single reported measurement from an instru-
ment. A target, by definition, must have one or more instrument ob-
servations. While the coordinates for a constructed point are easy to 
understand and unambiguous, the coordinates for a target take more 
explanation. It is fairly common, particularly with theodolite measure-
ments, for a given target to have multiple observations that together 
define the coordinate of the point. Consider, for instance, the case 
where three theodolites have measured a common point (see Figure 
8-10 on page 205). Since each measurement has finite error (due 
to encoder error, operator differences, alignment, and other factors), 
the observations will not coincide in space. Put another way, each in-
strument will “see” a slightly different location when measuring the 
same point in space. (The error in Figure 8-10 is greatly exaggerated 
for clarity).

It would be easy to simply take an average of each observation to 
determine the computed target location, but that is not an optimal 
technique, because it assumes that each observation has equal error. 
Instead, SA uses a more accurate technique of computing the coordi-
nate for the target based on an optimization. In Figure 8-10, the com-
puted target location is closer to the leftmost instrument’s observa-
tion, due primarily to the fact that it is closest to the measured point 
and therefore should have the least measurement error.

A view of this situation from above (see Figure 8-11 on page 205) 
makes it even clearer: The closest instrument is most accurate, and 
gets the most influence in calculating the target location. The net re-
sult of this optimization technique is that the computed target loca-
tion’s coordinates are more accurate than they would be if the aver-
age of the observations were used instead.

In the case of a single instrument measuring a point multiple times, 
the end result is that the target coordinate is almost exactly an aver-
age of the individual observations, as the distance to the target is ap-
proximately constant for all observations.
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Figure 8-10. A measured target as 
computed by observations from three 
instruments (exaggerated for clarity).

Figure 8-11. The instrument 
closest to the target has the greatest 
accuracy and therefore gets the largest 
influence in target computation.
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About Target Offsets

Regardless of the type of instrument used, when a measurement is 
performed in SA, the point that is recorded is the center of the probe 
(or the surface intersection point for non-contact measurements). For 
example:

 ■ Laser tracker measurements record the center of the SMR.

 ■ PCMM arm measurements record the center of the probe tip.

 ■ Laser radar measurements record the returned point of con-
tact with the object’s surface.

Figure 8-12. The center of the 
probe is the recorded point, and the 
offset is its radius.

Recorded Point

Offset Value

In order to properly compare measured points to geometry or con-
struct geometry from measured points, SA must always know the pla-
nar and radial offset for the measurement tooling that is currently in 
use. In normal use, an instrument interface has an offset assigned 
based on the current probe and tooling being used, and this offset is 
automatically applied to points as they are measured. For example, 
suppose a pin nest and SMR are being used to measure the inside 
diameter of a hole with a laser tracker. If SA is set up to construct a 
circle as a result of the measurement, then once the circle is fit to the 
measured probe centers, it will be offset normal to the circle by the 
planar offset amount, and its radius will be increased by the radial 
offset value. These offsets will align the constructed circle with the 
true location of the edge of the hole, regardless of the measurement 
tooling or probe used for the measurements.

In addition to the target’s offsets, for traceability purposes each in-
dividual measurement observation has a radial and planar offset as 
well.

Characteristics Unique to Measured Points

There are a few characteristics that are unique to measured points 
that you will not see on constructed points (Figure 8-13).
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Figure 8-13. The Target 
Information dialog looks like the 
Point Information dialog for 
constructed points, but has a few subtle 
(but important) differences.

Uncertainty
There is an Uncertainty box with a Compute button inside. This is used for 
computing the uncertainty of the measured point and is discussed in 
more detail in the chapter on Measurement Uncertainty.

Measurement Details    
To view the detailed measurement information that comprises a tar-
get, click on the Measurement Details button. (Note that the button 
will display the number of active observations that are being used to 
calculate the target position).

Figure 8-14. Two observations 
comprise this measured target, and 
both are active.

In this example (Figure 8-14), there are two active instrument obser-
vations that are being used to calculate the target coordinates. The 
checkboxes at the top of this dialog control which items are visible in 
the table.

 ■ Time. Toggles whether or not the timestamp (date and time) 
for the measurement is displayed.

 ■ Information. Toggles whether measurement details (such as 

Warning:  Deactivated 
observations are not 
used when calculating 

the target coordinate.
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instrument serial number, mode, weather information, etc.) are 
displayed.

 ■ User. Toggles whether the username is displayed.

 ■ Target Offset. Toggles whether the stored offsets for each ob-
servation are displayed.

 ■ Pointing Error. Displays the instrument’s angular and linear 
pointing errors. (Pointing error is the angular error between the 
observation and the computed target location).

Next to these checkboxes, the dialog displays the RMS value of the 
combined angular pointing errors.

To Activate or Deactivate an Observation:

 ■ Check or uncheck the observation in the Instrument column.

To Activate or Deactivate All Observations on a Target:

 ■ Right-click the point in the tree or graphical view and select 
Activate All Measurements or Disable All Measurements as applicable.

To Activate All Measurements to All Targets:

 ■ From the menu, select Analysis>Activate All Measurements.

To Permanently Delete an Observation:

 ■ Select the row in the table and click the Delete button.

An Apex Angle is the angle between two measurement rays, or lines of 
sight, from measurement devices (see Figure 8-15). Ideal measure-
ments with the least amount of error and uncertainty are obtained 
with apex angles of 90 degrees. As the apex angles increase or de-
crease from this value, the measurements have more uncertainty and 
are less reliable. SA can calculate and display the worst apex angle 
from a series of observations comprising a target.
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Figure 8-15. The apex angle 
between two lines of sight to a common 
target.

Apex Angle

To Determine the Worst Apex Angle Comprising a Target:

 ■ Click the Apex Angles button. SA will determine the two obser-
vations that form the worst apex angle, list the angle, and also 
list the two observations that form this angle.

To Point an Instrument’s Graphical Model at its Observation:

 ■ Select the observation of interest and click the Point At w/ 
Graphics button. The instrument’s head will point at the mea-
surement in the graphical view.

Observation Details
You can view the details for an individual instrument observation.

To View the Details for a Single Observation:

 ■ Double-click or right-click the observation, or

 ■ Select the desired row and click the Properties button.

The details for an observation are displayed in the Polar Measure-
ment dialog (see Figure 8-16 on page 210).
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Figure 8-16. A single observa-
tion’s details. This shows a laser tracker’s 
observation information.

The top section displays all of the metadata associated with the ob-
servation.

 ■ Use In Calculation. Toggling this option is equivalent to ac-
tivating/deactivating an observation in the Measurement De-
tails dialog.

 ■ Draw Me. Turn this option off to prevent SA from drawing the 
instrument shot (ray) for the observation.

 ■ Theta/Phi/Z (X/Y/Z). Read-only values showing the raw data 
from the instrument, expressed in the instrument’s coordinate 
frame.

 ■ Advanced Options (theodolites only). Mark observations as 
normal, collimation shots, or mirror cube shots (see below).

Each observation can store a planar and radial offset. These offsets 
are normally recorded when the measurement is taken. However, you 
can change them by filling in the Planar and Radial offset values to as-
sign custom offsets to a specific observation.

The Advanced Options button allows you to specify whether the ob-
servation is a normal Shot, a Collimation Shot (you must specify the 
instrument you’re collimating to), or a Mirror Cube Shot (you must 
specify which mirror face was measured). These settings are used to 
help constrain bundle adjustments (see Figure 8-17 on page 211).
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Figure 8-17. Advanced shot op-
tions for a spherical measurement.

Targeting Offsets
Individual observations can have their own stored planar and radial 
offsets. Constructed points do not have to deal with this, as they do 
not have any observations.

A button labeled Apply offsets to all measurements (see Figure 8-13 
on page 207) is visible below the planar and radial offset fields for 
measured points (you will not see it for constructed points). Clicking 
this button will apply the specified planar and radial offsets to all indi-
vidual observations for the target.

Hidden Point Measurements
It is often necessary to be able to take measurements and compute 
point location is in places that cannot be directly reached or mea-
sured. Hidden-Point Bar definitions provide a means to do that.  Hid-
den points can be computed in two ways:

 ■ Using a hidden pt. to Sa measurement profile with a laser track-
er  (refer to the Instruments Manual).

 ■ Using the Hidden-Point Bar Database saved within the SA Users Op-
tions. These options are described in the following sections. 

The Hidden-Point Bar Database

Hidden-Point Bar definitions are saved with the Users Options.  Bars can 
be defined in either of three ways: 

 ■ Gravity Frame. A gravity frame is a single point offset point. 
Added to support survey applications it can be used to com-
pute the location of a point shifted a predefined distance along 
the Z axis of a reference frame. 

 ■ 2 Point Bars. Define the distance of a third point (C) based 
upon the vector between the two measured or selected points 
and the entered distance from one of those points (A or B) .
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 ■ N-Point Bars or Fixtures. With 3 or more points defined, a 3D 
position can be computed anywhere in space relative to the 
measured or selected points. N-Point Fixtures are defined by 
selecting a set of points and also selecting a measurement lo-
cation to return when those points are measured.  

Automatic Hidden Point Computation

The most effective way to use hidden point bars or fixtures is to use 
a naming convention to designate points as part of a defined hidden 
point bar or fixture. To do so follow this naming convention: 

point name $ (Bar index) _ (point index)

 ■ Point Name. The point name for the computed point should 
also be used for all the measurements of the reference points 
used to built it. 

 ■ Bar Index. The Hidden Point Bars defined in the user options 
are not named but instead use an integer index. By specifying 
“MyPoint$0_0” you are specifying a point named “MyPoint” 
and telling SA to use the “0” index bar. 

 ■ Point Index. Its important to specify a measured point as A or 
B for a 2 point bar to be computed correctly. Also the specific 
index of the points within an N Point Bar need to be defined. 
The final piece of the naming convention is the point index. 
So “MyPoint$0_1” tells SA to use the 0 index bar and that this 
point represents the “1” index point. 

Figure 8-18. Hidden Point Nam-
ing Convention in use.

If this naming convention is followed hidden point locations can be 
updated/recomputed at any point by using the menu command 
Analysis>Re-Compute Hidden Points. This can be quite helpful if hidden 
points are computed from multiple instrument plants and their rela-
tive positions are changed do to an alignment. 

Gravity Frame

A Gravity Frame hidden-point definition was added to facilitate survey 
applications and pin nest measurements. A single point can be used 
to compute a point shifted along an axis with respect to a specified 
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frame. This allows a single point to be all that is needed for this Hid-
den-Point Bar measurement. 

Figure 8-19. Gravity Bar Proper-
ties Dialog.

Gravity Frame measurements are compensated along the Z-axis of 
the specified Reference Frame by the specified Offset or by the offset 
value entered in the measurement string. 

Measurement examples are as follows:

 ■ lf you measure a point  “<PtName>$<Bar index>” the hidden 
point will be computed using the default bar offset

 ■ If you measure a point “<PtName>!<Z-Axis Offset>$<Bar in-
dex> the hidden point will be compensated by the entered 
value “!<Z-Axis Offset>”.

Note that you can also use the Gravity Bar Name directly instead of 
the Bar index.

2 Point Hidden-Point Bar

With a 2 point bar(Figure 8-20), an A and B point are used to define 
the vector of the hidden point bar, and the hidden point (C) is con-
structed along this vector at a prescribed distances from either the A 
or B points.
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Figure 8-20. 2 Point Hidden Point 
Bar Definition

To Construct a Hidden Point:

1. From the menu, select Construct>Points>Hidden Point Bar.

2. When prompted, select the A point.

3. Select the B point.

4. The Pick Hidden Point Bar dialog will appear. Select the ap-
propriate hidden point bar, then click OK.

5. The Construct New Point dialog will appear (Figure 8-29). 
Specify the point name, leaving the coordinates alone—then 
click OK.

To Measure a Hidden Point:

1. In the instrument name control type the <point name> $<Bar 
Index_0 for the point A (eg. “Point1$1_0”), and measure a 
point

2. Check that the name incremented correctly: <point name> 
$<Bar Index_1 for point B (eg. “Point1$1_1”), and measure a 
point. 

That’s it...Measure 2 points and it will compute the hidden point for 
you (eg. “Point1”)

N Point Bars or Fixtures

Hidden points can also be computed from an array of point locations. 
Having 3 or more input points makes it possible to compute a hidden 
point location anywhere in 3D space with respect to the reference 
points (Figure 8-21). 
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Figure 8-21. N Point Hidden Point 
Fixture

To build a Hidden- Point Fixture do the following: 

1. First build a nominal bar. Use Construct>Points>Enter and build 
the measurable points defining the fixture in their exact 
nominal XYZ locations relative to the working frame, and also 
build the nominal design target point relative to these fixture 
points.

2. Open the Use Options and press the Add N Point Frame  but-
ton to build a new Fixture definition.

3. In the Hidden-Point Fixture dialog press the Add Points but-
ton and select the constructed (measurable) points.

4. In the Fixture hidden Measurement point section use the Pick 
button and choose the constructed Target point. In this case 
where  a point probe is to be used, simply press OK and be 
done. However, if you are using fixture with a spherical probe 
tip be sure to also add the correct offsets so that they are au-
tomatically applied to the computed point.

To use new fixture definition, measured the fixture points using the 
hidden point name convention described in the next section. When 
measuring an N Point Hidden Point Bar the points are fit to the nomi-
nal definition. Therefore, as soon as 3 points are measured a comput-
ed point is built. The accuracy of the computed point increases with 
each additional measurement as error is distributed equally through 
a best fit process.
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Setting Properties for Multiple Points
Some situations arise in which you’d like to change the properties of 
multiple points at once. For instance, if you accidentally measure a 
large number of points with the wrong target offsets set in the instru-
ment interface, you will need to correct these offsets in order for SA 
to properly apply probe compensation.

You can apply new tolerances or offsets to multiple points using the 
Set Properties for Multiple Points dialog (Figure 8-22).

Figure 8-22. The Set Proper-
ties for Multiple Points dialog.

To Change Offsets or Tolerances For Multiple Points:

 ■ From the menu, choose Edit>Set Properties for multiple points and 
select the points to modify. This will call up the Set Properties 
for Multiple Points dialog.

To Change Offsets or Tolerances For An Entire Group:

 ■ Right-click a point group and select Set Point Properties from the 
context menu. This will call up the Set Properties for Multiple 
Points dialog.

This dialog has two regions. The top region is for changing the stored 
target offsets, and the bottom region is for changing the point toler-
ances.

 ■ Set Target Offsets. Check this option to change the planar and 
radial offsets of the measured points to the values entered into 
the Planar and Radial fields.

 ■ Set Measurement Offsets Also. This applies the entered off-
sets to the individual observations within a target as well. Very 
rarely would you not want to select this option.

 ■ Set Tolerances. When checked, the tolerances specified via 
the Tolerance Settings button will be applied to the points.

Note:  The tolerance settings 
dialog is the same as de-

scribed in “Point Tolerance” on 
page 200.
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Working With Point Lists
It is often useful to view a list of points and point coordinates in tabu-
lar format, so that you can easily compare against nominals or quickly 
modify a set of points at once (similar to working in Excel). SA’s point 
lists provide this functionality (Figure 8-23).

Figure 8-23. A point list.

To View a Point List:

Do one of the following:

 ■ From the menu, select View>Point Lists for Groups, then select the 
group(s) to view, or

 ■ Right-click a group and select View Point List from the context 
menu (to view a single group).

The list has several buttons at the top:

 ■ Refresh. Refreshes the list to ensure it’s showing the latest in-
formation.

 ■ Copy to Clipboard. Copies the selected rows (or all rows if 
nothing is selected) to the clipboard.

 ■ Export to Text File. Exports the selected rows (or all rows if 
nothing is selected) to a text file.

 ■ Display. Display provides a list of additional point properties 
that can be displayed including tolerances, weights, offsets, 
etc. 

 ■ Coordinate System. Click this button to switch among Carte-
sian, Cylindrical, and Spherical coordinates.

 ■ Edit. Opens up a new window allowing you to modify the point 
information (see below).

Instead of just viewing the information, a point list can be used for 
modifying point names, coordinates or properties. This is particularly 
useful because you can change multiple values at once. For instance, 
you can quickly change the x-coordinate of multiple points in one 
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action.

To Edit a Point List:

Do one of the following:

 ■ With the point list already displayed (see “To View a Point List:” 
on page 217), click the Edit button, or

 ■ Right-click a point group and select Edit Point List from the con-
text menu to edit that group of points.

The Edit Point List dialog is displayed in Figure 8-24.

Figure 8-24. The Edit Point 
List dialog.

To Change a Point’s Name, Coordinate, or Notes:

 ■ Double-click the field you’d like to modify, enter a new value, 
then press Enter.

To Modify Multiple Values At Once:

1. Select multiple fields using Shift+Click (standard Win-
dows range selection) or Ctrl+Click (standard Windows 
non-contiguous selection).

2. Double-click one of the selected fields, type a new value, and 
press Enter. All fields will be updated with the new value.

The dialog provides a few additional buttons at the top.

 ■ Apply Changes. Modifications are not actually applied to the 
points until you click this button.

 ■ Coordinate System. Choose to switch the display between 
Cartesian, Cylindrical, or Spherical coordinates.

 ■ Cancel. If you cancel, no changes will be applied the points.
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Point Sets

Point Sets

Point Sets provide a merged point format that allows many individual 
points to be saved as part of a single object. Using Point Sets provides 
the advantage of keeping the tree manageable and allowing many 
more points to be measured in a single job file at faster rates (Figure 
8-25) than are available with traditional points. Unlike a point cloud, 
each point within a point cloud retains critical information including: 
Point name and (when available) instrument measurement time.

Figure 8-25. Point Set Properties 
dialog include a full set of measurement 
details

Measuring with Point Sets
Point Sets can only be recorded as part of a Scan but are available 
from any measurement device that can scan points. Single Discrete 
measurements will still always be recorded as individual points. 

This method of data capture is an option that must also be turned on 
through the right-click instrument menu by selecting Enable Point Set 
Scan Mode (Figure 8-26): 

 ■ Auto Detect Point Set Scan Mode. When set individual point 
measurements will be recorded as individual points but scans 
will be recorded in Point Sets. 
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 ■ Enable Point Set Mode. This open enables data recording 
within a point set for newly recorded points.

 ■ Disable Point Set Scan Mode. This option turns off any Point 
Set data acquisition. 

Figure 8-26. Enable Point Set 
Mode must be active to record measure-
ments in Point Sets

Individual Point Selection from a Set
Double left clicking on a single point in the graphics provides the 
ability to select a single point from within the point set. Doing so pro-
vides direct access to the position and time stamp recorded with that 
particular measurement. 

Time stamps are recorded as a fundamental property of a point set, 
when available from the instrument, and reflect the instrument’s own 
controller time. This controller time is quite accurate and reflect s the 
time from the beginning of the scan. 

Figure 8-27. Individual Point 
Selection from within a Point Set



221

CHAPTER 8 ■ POINTS

Constructing Points
There are many different ways to create points in SA. You can explic-
itly create a point at a specified coordinate or create points through 
an array of geometric analysis functions.

Entering Point Coordinates

The most basic way to create a point is to explicitly enter a point by 
specifying its collection, group, target, and coordinate system. This 
will create a single constructed point in your job.

To Enter a Point:

1. From the menu, select Construct>Points>Enter, or press Ctrl+P 
(default keyboard shortcut). The Add Points to Model dialog 
will appear (Figure 8-28).

Figure 8-28. Constructing a point 
by entering its coordinates.

2. Enter a collection, group, and point name (or select one from 
the dropdown of existing collections or groups).

3. Specify the desired coordinate type (Cartesian, Cylindric, or 
Spheric).

4. Enter the desired coordinate values, then click the Add Point 
button to create the point and continue adding more, or click 
Done to create the point and close the dialog.

Constructing a Point at the Center of a Line

Creating a point at the center of a line constructs a point halfway be-
tween its endpoints.

To Create a Point at the Center of a Line:

1. From the menu, select Construct>Points>Center>Line.

2. Select the desired line.

3. The Construct New Point dialog will appear (Figure 8-29).
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Figure 8-29. The Construct 
New Point dialog.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.

Constructing  Points at the Center of Spheres and Circles

You can construct points at the center of multiple circles or multiple 
spheres with a single command.

To Construct Points at the Center of Circles or Spheres:

1. From the menu, select Construct>Points>Center>Circles or 
>Spheres. The Point Name dialog will appear (Figure 8-30).

Figure 8-30. The Point Name 
dialog.

2. Enter a collection, group, and point name for the first point to 
construct. (Leave the Collection field blank to put the points into 
the active collection). Click OK.

3. Select one or more circles or spheres. Each center point will 
be created, and successive point names will be incremented.

4. When finished creating centers, press Esc or Enter.

Constructing Points at the Center of a Cylinder

When creating points at the center of cylinders, SA will actually create 
three points: one point at each end on the cylinder’s axis (called EndA 
and EndB), and a third point halfway between the endpoints (called 
Center).
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To Create Points at the Center of Cylinders:

1. From the menu, select Construct>Points>Center>Cylinder.

2. Select the cylinder. The points will be placed into the active 
collection, into a group with a name matching that of the cyl-
inder.

Projecting to the Closest Point on Objects

Projecting points to the closest point on an object is equivalent to 
creating points on the object where that object’s surface normals in-
tersect with the original points.

With this command, you can select multiple objects and SA will find 
the closest point among all selected candidate objects. You can also 
select multiple points, and SA will find the closest point for each of 
the candidate points.

You can also offset points away from the surface. This is particularly 
useful when you have nominal points on a surface that you’d like to 
back away from the surface by the probe radius (so that those points 
can serve as proximity triggers for measurement).

To Project Points to the Closest Points on an Object:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Closest Point.

2. Select one or more objects to project to.

3. Select one or more points to project. The Point Naming dialog 
will appear (Figure 8-31).

Figure 8-31. The Point Nam-
ing dialog.

4. Enter or select the desired group to contain the projected 
points. In the Add Prefix or Add Suffix field, enter a prefix or suffix 
that you’d like to attach to the point names, then click OK.

5. The Probe Offset dialog will appear. Enter a distance to offset 
the projected points back away from the object’s surface. A 
positive value shifts along the positive direction of the surface 
normal.
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Projecting Points Parallel to a Working Coordinate Frame Axis

You can project points along a working coordinate frame axis until it 
intersects with one or more surfaces (Figure 8-32). (If there is no inter-
section, no projected point will be created).

Figure 8-32. Projecting a grid of 
points along the working X axis to a 
surface.

To Project Points Along the Working Coordinate Frame Axis:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Frame Axis>Parallel to WCF Axis.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. When the Select Axis dialog appears, choose the axis to proj-
ect along.

5. The Point Naming dialog will appear (Figure 8-31). Enter or 
select the desired group to contain the projected points. In 
the Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

Projecting Points Radially from a Working Coordinate Frame Axis

You can also project points radially from a coordinate frame axis. 
Here, one of the axes of the working coordinate frame serves as the 
axis of a cylindrical coordinate system, and the points are projected 
out radially from that axis until they intersect with one or more sur-
faces (Figure 8-33).
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Figure 8-33. Projecting radially 
from a coordinate frame axis.

To Project Radially from a Working Coordinate Frame Axis:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Axes>Radial from WCF Axis.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. When the Select Axis dialog appears, choose the axis from 
which to project radially.

5. The Point Naming dialog will appear (Figure 8-31). Enter or 
select the desired group to contain the projected points. In 
the Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

Projecting Points Spherically from a Working Coordinate Frame Origin

Points can be projecting spherically outward from the origin of the 
working coordinate frame (Figure 8-34).
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Figure 8-34. Projecting points 
spherically from the working coordinate 
frame origin.

To Project Points Spherically From the Working Coordinate Frame Origin:

1. From the menu, select Construct>Points>Project Points 
to>Objects>Relative to Coordinate Frame Axis>Spherical From WCF Ori-
gin.

2. When prompted, pick the surfaces to project to.

3. Select the points you’d like to project.

4. The Point Naming dialog will appear (Figure 8-31). Enter or 
select the desired group to contain the projected points. In 
the Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

Projecting Points to a Curve

You can project points directly to any arbitrary curve or curves (Figure 
8-35). The projected points can lie directly on the curves or can be 
backed off the curve by a specified amount. Each point will be pro-
jected to the closest curve among all candidates.

To Project Points to a Curve:

1. From the menu, select Construct>Points>Project Points to>Curves.

2. At the prompt, select the curves to project to.

3. Select the points to project.

4. The Point Naming dialog will appear (Figure 8-31). Enter or 
select the desired group to contain the projected points. In 
the Add Prefix or Add Suffix field, enter a prefix or suffix that you’d 
like to attach to the point names, then click OK.

5. At the Probe Offset dialog, enter a distance to offset the pro-
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jected points back away from the curve. This value must be 
positive, and always shifts away from the curve.

Figure 8-35. Projecting points to 
a curve.

Creating Points at a 3-Plane Intersection

A point can be created at the intersection of 3 planes. This of course 
requires that no two planes may be parallel.

To Create a Point at the Intersection of 3 Planes:

1. From the menu, select Construct>Points>Intersection>3 Planes.

2. Select the three planes successively.

3. The Construct New Point dialog (see Figure 8-29 on page 
222) will appear. Leave the coordinates as-is (they are calcu-
lated for you), and specify the desired collection, group, and 
point name (or select an existing collection or group from the 
dropdown).

4. Click OK to create the point.

Creating Points at the Intersection of a Plane and Circle

Intersecting a plane and a circle will actually create two points as seen 
in Figure 8-36. It should be noted that the plane and circle cannot be 
parallel or coplanar.

To Create Points at the Intersection of a Plane and Circle:

1. From the menu, select Construct>Points>Intersection>Plane and 
Circle.

2. Select the plane, then the circle. Two new points will be cre-
ated in the active collection’s Intersections group named 
Plane-Circle1 and Plane-Circle2.
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Figure 8-36. Intersecting a plane 
with a circle.

Constructing Points at the Intersection of a Line and Plane

You can intersect a line with a plane to create a point at the intersec-
tion (Figure 8-37).

Figure 8-37. A line and plane in-
tersection creating a point, even though 
their depictions do not intersect.

There are a few things to keep in mind:

 ■ The line and plane need not physically intersect, since planes 
and lines are treated as infinite in size.

 ■ If the line lies in the plane, or the line is parallel to and not in the 
plane, no points will be created.

To Create a Point at the Intersection of a Line and Plane:

1. From the menu, select Construct>Points>Intersection>Line and 
Plane.

2. Select the line, then the plane.

3. The Construct New Point dialog (Figure 8-29) appears.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.
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Constructing a Point at the Intersection of 2 Lines

You can create a point at the intersection of two lines (Figure 8-38). 
Or, if the lines do not intersect, a point will be created at their mutual 
perpendicular midpoint. (The mutual perpendicular midpoint is half-
way between the closest points between the two lines). If the lines 
are parallel, no point will be created.

Figure 8-38. A point constructed 
at the mutual perpendicular midpoint 
between two lines. In this case, these 
two lines do not intersect.

To Create a Point at the Intersection of Two Lines:

1. From the menu, select Construct>Points>Intersection>2 Lines (mu-
tual perpendicular midpoint).

2. Select the first line, then the second.

3. The Construct New Point dialog (Figure 8-29) appears.

4. Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown).

5. Click the OK button.

Constructing Points at the Intersection of a Line and Circle

Points can be created at the intersection of a line and a circle (Figure 
8-39). The line is first projected to the plane on the circle and then the 
intersection points are created.

Figure 8-39. A line and circle 
intersection creating two points.

To Create Points at the Intersection of a Line and Circle:

1. From the menu, select Construct>Points>Intersection>Line and 
Circle.

2. Select the line, then the circle. Two new points will be created 
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in the active collection’s Intersections group.

Constructing Points at the Intersection of a Line and Cylinder

You can create a point at each intersection of a line and cylinder. The 
cylinder and line need not physically intersect, since cylinders and 
lines are treated as infinite in length (Figure 8-40). However, the line 
must pass within the cylinder’s radius.

Figure 8-40. A point at each 
intersection of the line and cylinder are 
created, even though their depictions 
do not intersect. Note the length of the 
cylinder does not need to be increased, 
since cylinders are infinite in size.

To Create a Point at the Intersection of a Line and Cylinder:

1. From the menu, select Construct>Points>Intersection>Line and Cyl-
inder.

2. Select the line, then the cylinder. A naming dialog appears 
(Figure 8-42). 

3. Specify the desired collection, group, and point names (or se-
lect an existing collection and group from the dropdown).

4. Click OK to create the point.

Constructing Points at the Intersection of a Line and Sphere

You can create a point at each intersection between a line and a 
sphere.
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Figure 8-41. A point is con-
structed at each intersection of the line 
and sphere.

To Create a Point at the Intersection of a Line and Sphere:

1. From the menu, select Construct>Points>Intersection>Line and 
Sphere.

2. Select the line, then the sphere.

3. A naming dialog appears (Figure 8-42).

4. Specify the desired collection, group, and point names (or se-
lect an existing collection and group from the dropdown).

5. Click OK to create the point.

Figure 8-42. The naming dialog 
for line intersections with cylinders and 
spheres.

Constructing Points at the Intersection of 2 B-Splines

Points can be constructed from the intersections of two B-Splines. A 
point will be created at the midpoint of the closest location between 
the two B-splines if they do not intersect (Figure 8-43).

To Create a Point at the Intersection of 2 B-Splines:

1. From the menu, select Construct>Points>Intersection>2 B-Splines.

2. Select the first B-spline, then the second.

3. The Construct New Point dialog (Figure 8-29) will appear. 
Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown.
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4. Click OK to create the point.

Figure 8-43. The pink and green 
B-splines create a point where they 
physically intersect, whereas the green 
and purple B-splines create a midpoint 
between their closest locations since 
they do not intersect.

Constructing Points at the Intersection of a B-Spline and Surfaces

You can create a point at the intersection of a B-Spline and a surface 
(Figure 8-44). The command follows the B-Spline from its tail toward 
its head and creates a point when the spline first pierces the surface.

You can select multiple surfaces with this command, but still only one 
intersection point will be created.

Figure 8-44. Intersecting a B-
Spline with a surface to create a point.

To Create a Point at the Intersection of a B-Spline and Surfaces:

1. From the menu, select Construct>Points>Intersection>B-Spline and 
Surfaces.

2. Select the B-Spline.

3. Select one or more surfaces to test.

Note:  If the B-Spline inter-
sects multiple times or inter-

sects multiple selected surfaces, 
only one point is created. Which 
point is created is not generally 
clear.
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4. When prompted, enter an approximation tolerance. Gener-
ally, the default value is fine.

5. The Construct New Point dialog (Figure 8-29) will appear. 
Leave the coordinates as-is (they are calculated for you), and 
specify the desired collection, group, and point name (or se-
lect an existing collection or group from the dropdown.

6. Click OK to create the point.

Constructing Points at the Intersection of Principle Object Axes and Surfaces

A point can be constructed at the intersection of an object’s axis and 
a surface (Figure 8-45). The definition of the axis depends on the type 
of object, but the axis must intersect at a point on the surface and not 
through a hole in the surface.

Figure 8-45. A point created at 
the intersection of a plane’s axis and a 
surface.

To Construct a Point at the Intersection of an Object Axis and Surface:

1. From the menu, select Construct>Points>Intersection>Principle Ob-
ject Axes and Surfaces.

2. Choose the axis object, followed by the surface. 

3. Enter the destination point group name. You also have the 
option of entering a suffix for the points (which will have the 
same name as your object).

4. Click OK.

Shifting Points In a Direction

You can use a selected object to define a direction in which to shift a 
point or selection of points by a specified distance (Figure 8-46). If a 
frame is selected as the object, you will be prompted to choose along 
which axis to shift the points.
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Figure 8-46. Green points were 
copied from the original points (red) 
and shifted along the circle’s surface 
normal.

To Shift Points in a Direction: 

1. From the menu, select Construct>Points>Shift Points>In a Direction.

2. Select the object defining the shift direction, then select the 
points you would like to shift.

3. The Shift Points in Direction dialog will appear (Figure 8-47). 
Enter the shift distance and the point group destination.

Figure 8-47. Shifting points along 
a direction.

4. Click Make Points to create the shifted points.

Shifting Points In Cylindric Coordinates

Points may be shifted cylindrically. Any object that contains direc-
tional  information may be selected to define the axis of the cylinder 
about which the points are shifted (Figure 8-48).

Figure 8-48. The cylinder is the 
object defining the cylindrical coordi-
nate system and the blue points were 
copied from the original points (green) 
and shifted 5.0” along the planar and 
radial directions.

To Shift Points in Cylindric Coordinates: 

1. From the menu, select Construct>Points>Shift Points>In Cylindric 
Coordinates.

2. Select the object defining the cylindric coordinate system, 
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followed by the points to be shifted.

3. The Shift Points in Cylindric Coordinates dialog will appear 
(Figure 8-49). Enter the radial and planar shifts and the point 
group destination.

Figure 8-49. Specifying the radial 
and planar shift.

4. Click Make Points to create the shifted points.

Laying Out Points on a Grid By Count

A grid of points can be laid out with respect to the XY plane of the 
working coordinate frame. Using this command, you specify the 
range of the grid and the number of points desired along each axis, 
and SA determines the spacing for you automatically.

Figure 8-50. 10x10x1 Grid layout 
of 100 points.

To Lay Out Points on a Grid by Count:

1. Activate the frame you’d like to use to define the grid orienta-
tion.

2. From the menu, select Construct>Points>Layout>Grid by Count.

3. The Make a Grid of Points dialog will appear (Figure 8-51). In 
the Min and Max fields, specify the limits along the coordinate 
directions for the three-dimensional grid. In the Count fields, 
specify the number of rows of points along each direction. 
You can also enter a destination collection, group, and target 
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prefix for the resulting points. 

4. Click Create Points to construct the grid.

Figure 8-51. Entering the X, Y, and 
Z range of the grid, and the number of 
rows of points along each axis direction.

Laying Out Points on a Grid By Distance

A grid of points can be laid out with respect to the XY plane of the 
working frame. Using this command, you specify the range of the grid 
and the distance between points, and SA determines the number of 
points for you automatically.

To Lay Out Points on a Grid by Distance:

1. Activate the grid you’d like to use to define the grid orienta-
tion.

2. From the menu, select Construct>Points>Layout>Grid by Distance. 
The Make a Grid of Points dialog will be displayed (Figure 
8-52).

Figure 8-52. Defining parameters 
to create a grid by spacing.

3. Specify the range of the grid in all three component direc-
tions, as well as the desired spacing between points along 
each direction. You can also enter a destination collection, 
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group, and target prefix for the resulting points.

4. Click Create Points to construct the grid.

Laying Out Points On a Circle

It is often useful—particularly when laying out nominal bolt hole pat-
terns—to lay out points on a circle. A circular point layout can be con-
structed in the XY plane of the working frame (Figure 8-53).

Figure 8-53. Laying out 16 
evenly-spaced points on a circle.

The Layout Points on Circle dialog is shown in Figure 8-54. A number 
of options are available when laying out points, which are discussed 
below:

Figure 8-54. The Layout 
Points on Circle dialog.

 ■ Radius. The radius of the circle defining the points.

 ■ Starting angle. The angle in the working frame’s XY plane, 
from the X axis, at which to lay out the first point.

 ■ Number of points on circle. The number of points to create 
on the circle.

There are two methods for laying out points on the circle:

 ■ Evenly space points around entire circle. The points will be 
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constructed evenly around the entire circle.

 ■ Space points by. You can specify the angle between points. 
If (based on the specified spacing and the number of points) 
more than 360° of the circle is specified, the points will con-
tinue to be laid out around the circle.

You can also control the naming of the resulting points using the Group 
and First Point fields, and whether a center point is created with the Cre-
ate center point option.

To Construct a Layout of Points on a Circle:

1. From the menu, select Construct>Points>Layout>Circle.

2. The Layout Points on Circle dialog will appear (Figure 8-54).

3. Fill in the desired parameters, then click OK to create the 
points.

Generating Random Points

Occasionally, you may come across the need to generate random 
points. (This tends to be more common in training and testing than  
actual production environments).

When generating random points (Figure 8-55), you can specify the 
number of points and the range of the points along each of the three 
axis directions. The points will be randomly created inside this de-
fined box.

Figure 8-55. 100 randomly-
generated points.

To Construct a Random Layout of Points:

1. From the menu, select Construct>Points>Layout>Random Points or 
use the default keyboard shortcut Ctrl+Alt+Z.

2. The Random Point Generator dialog will appear (Figure 8-56). 
Specify the number and range of point coordinates as well as 
the desired group name.
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Figure 8-56. The Random 
Point Generator dialog.

3. Click OK to create the points.

Laying Out Points On A Surface By Clicking

You can click anywhere on a surface to create a point on that surface 
(Figure 8-57). 

Figure 8-57. Laying out points on 
a surface.

To Lay Out Points on a Surface:

1. From the menu, select Construct>Points>Layout>On Surface By 
Clicking.

2. Place the cursor anywhere on the surface and click to create 
a point at that location. If the cursor is not over a surface, a 
point will not be created.

Laying Out Points On An Object Vertex By Clicking

Points can be constructed on an object’s vertices simply by clicking 
near the vertex (Figure 8-58).

Figure 8-58. Several points have 
been laid off on this cylinder’s vertices.

To Lay Out Points on Object Vertices by Clicking:

1. From the menu, select Construct>Points>Layout>On Object Vertex 
by Clicking.

Note:  The first click on a sur-
face will incur a small delay 

as the software performs some 
calculations. Remaining clicks on 
the surface will be much faster.

Note:  The points will always 
be created on the surface, 

regardless of render settings.
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2. At the prompt, enter a desired group and starting point name.

3. Click the object near the desired vertices.

4. Press Enter when finished.

Laying Out Points On An Object’s Vertices

You can construct points on all vertices of one or more objects at 
once (Figure 8-59).

Figure 8-59. Points laid out on a 
cylinder’s vertices.

To Lay Out Points on an Object’s Vertices:

1. From the menu, select Construct>Points>Layout>On Object’s Verti-
ces.

2. Select the objects on which you’d like to create vertex points.

3. Enter a name for the destination group, then click OK.

Laying Out Points Evenly On Curves

You can construct any number of evenly-spaced points on one or 
more B-Spline curves (Figure 8-60).

Figure 8-60. 10 points spaced 
evenly on a B-Spline.

To Lay Out Evenly-Spaced Points on a Curve:

1. From the menu, select Construct>Points>Layout>On Curves>n 
Spaced Points.

2. Select one or more B-splines.

Tip:  Increasing surface ren-
dering detail will create more 

vertices for a given surface.
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3. Type a name for the destination group, then click OK.

4. At the prompt, enter the number of points to create on each 
curve, then click OK.

Laying Out Points On Curves With Prescribed Spacing

SA can construct points on one or more curves spaced by a prescribed 
distance (Figure 8-61). This is not a straight-line distance, but a dis-
tance along the curve (as if you’d laid a measuring tape of the pre-
scribed length along the curve). When creating the points, SA places 
the first point exactly on the starting end of the curve.

Figure 8-61. Points on a B-spline 
spaced exactly 2” from each other along 
the curve.

To Create Points Spaced on a Curve by a Prescribed Distance:

1. From the menu, select Construct>Points>Layout>On Curves>Spaced 
at Distance.

2. Select one or more B-splines.

3. Type a name for the destination group, then click OK.

4. Enter the specified distance between points, then click OK.

Laying Out Points On Curves by Clicking

This command allows you to click anywhere on one or more curves 
and create a point at that position on the curve (Figure 8-62).

Figure 8-62. Several points cre-
ated by clicking on a B-Spline.

To Create Points on a Curve by Clicking:

1. From the menu, select Construct>Points>Layout>On Curves>By 
Clicking.

2. Enter a destination group name for the constructed points, 
then click OK.

3. Type a starting point name, then click OK.



242

SPATIALANALYZER USER MANUAL

4. Select one or more curves to consider.

5. Click at the desired locations. SA will create the point on the 
closest point of the closest curve.

Laying Out Points on Curves Max Chordal Deviation

Builds points on a curve at higher densities where the curve is at a 
tighter radius. This can be controlled in a couple of ways. It will ask 
you to select:  

 ■ Maximum Chordal Deviation. Which defines the greatest 
distance the mid point of a line between any two points on 
a curve can deviate from that curve without adding an addi-
tional point. 

 ■ Maximum Trim Edge Angle. Which sets an additional thresh-
old such that if the angle between any two chordal lines is 
greater than the threshold a new points is built. 

 ■ Maximum Chord Length. Allows you to set a maximum spac-
ing between points along the curve. This can be helpful in en-
suring a minimum point spacing along straight sections.

Figure 8-63. Depiction of the 
available controls provided by the Max 
Chrodal Deviation tool

All the points built with this command will be constructed perfectly 
on the mathematical definition of the curve. * Note* that the graphi-
cal depiction of a curve also uses a similar approximation and if the 
graphical display is not equal to or higher than the construction toler-
ance the points may not appear to be on the curve even when they 
are (to control the graphical display go to the User Options>Display tab, 
Surface Rendering Options). 

Laying Out Points On Lines

As with a curve, you can lay points out on a line by specifying the 
number of points (in which they’re evenly spread along the line) or by 
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specifying the spacing (Figure 8-64).

Figure 8-64. A line with 10 
evenly-spaced points.

To Lay Out Points on a Line:

1. From the menu, select Construct>Points>Layout>On Lines.

2. Select one or more lines.

3. The Layout Points on Lines dialog will appear (Figure 8-65).

Figure 8-65. The Layout 
Points on Lines dialog.

 ■ n Spaced Points. SA will create the specified number of points 
spaced evenly along each of the selected lines.

 ■ Spaced at Distance. SA will create points on each line starting 
from the tail of the line, using the prescribed spacing.

 ■ Group. The name for the resulting point group.

4. Choose the desired options, then click OK.

Laying Out Points At The Center of Surface Holes

It is often useful to create points at the center of holes on a surface. 
You can click on a single surface containing surface holes, and SA will 
create points at the center of the holes based on prescribed minimum 
and maximum diameter thresholds (Figure 8-66).

If a surface is dissected and you therefore select just a single surface 
face with holes, the points will be created along that face. If a surface 
is merged and you select a closed shell, points will be created on each 
end of the hole (if it is a thru hole).
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Figure 8-66. These points have 
been constructed at the center of 
surface holes.

SA considers any surface opening that has a circular arc for an edge 
as a surface hole.

To Construct Points at the Center of Surface Holes:

1. From the menu, select Construct>Points>Layout>At Center of Sur-
face Holes.

2. Select one or more surfaces with holes.

3. The Points from Surface Holes dialog will appear (Figure 8-67).

Figure 8-67. The Points from 
Surface Holes dialog.

 ■ Output Group. The name for the destination group.

 ■ Min Dia. The minimum diameter hole for point construction. 
Holes smaller than this diameter will not have center points 
constructed.

 ■ Max Dia. The maximum diameter hole for point construction. 
Holes larger than this diameter will not have center points con-
structed.

 ■ Check Tolerance. This describes the accuracy of the diameter 
check. Smaller values may take incrementally longer, but will 
more accurately check the diameter of the hole. Typically, you 
need not adjust this value unless you encounter unexpected 
behavior.

4. Select the desired options, then click OK.
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Laying Out Points In The View By Clicking

Primarily intended for training and testing purposes, SA enables you 
to construct points by clicking anywhere in the graphical view. These 
points will be created on a plane perpendicular to the viewing direc-
tion (Figure 8-68).

Figure 8-68. Random points laid 
out in the view.

To Construct Points in the Graphical View by Randomly Clicking:

1. From the menu, select Construct>Points>Layout>In View By Click-
ing.

2. Enter a name for the destination point group.

3. Specify a name for the starting point (subsequent point 
names will be incremented.

4. Click anywhere in the graphical view to create each point. 
Press Enter when finished.

Copying Existing Points

Any set or subset of existing points can be easily copied. The copies 
are placed into a new point group.

To Copy Points from Existing Points:

1. From the menu, select Construct>Points>From Existing Points>Copy.

2. Select the points that you want to copy.

3. When prompted, type a destination group name, then click 
OK.

Moving Existing Points Into A New Group

You can quickly and easily relocate a set of points into a new group 
(Figure 8-69). The points may start in the same group or separate 
groups, but they will always end up in the same group. The points are 
relocated (not copied), which means that measurements remain as 
measured points after the command is executed. After the command, 

Note:  Any copied measure-
ments become constructed 

points.

Note:  This command does 
not physically move points, 

as the name might imply.
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the point names will carry a prefix indicating their source group.

Figure 8-69. Relocating points 
into a new group.

To Move Existing Points to a New Point Group:

1. From the menu, select Construct>Points>From Existing Points>Move.

2. Select the points you want to move.

3. At the prompt, enter a name for the destination group, then 
click OK.

Creating a Subset of Points With Greatest Spacing

It is not uncommon to be confronted with point data that is more 
dense than is necessary for a certain operation (Figure 8-70).

Figure 8-70. An overly-dense 
point group.

SA can sample an existing point group and create a new group of 
points at a lower spatial density than the source group (Figure 8-71). 
You can specify the desired number of points, and SA will choose a 
subset of points spread out to match that number.

The original points are untouched. Any subsampled points are a copy 
of the originals.
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Figure 8-71. A subset of the 
original point group.

To Create a Subset of Points with Greatest Spacing:

1. From the menu, select Construct>Points>From Existing 
Points>Subset with Greatest Spacing.

2. Specify the number of points to create.

3. Enter a name for the destination point group.

Auto-Corresponding Two Groups By Proximity

Given a group of reference points and a group of roughly-aligned cor-
responding points, this command will copy the corresponding group 
and automatically rename the copied points to match the names of 
the reference points.

To Auto-Correspond Two Groups by Proximity:

1. From the menu, select Construct>Points>Auto-Correspond 2 
Groups>Proximity.

2. When prompted, select the reference group of known point 
names.

3. Select the group to copy and rename. The Autocorrespond 
Points dialog will appear (Figure 8-72):

Figure 8-72. Setting parameters 
for an auto-correspond operation.

 ■ Auto-correspond “same point” tolerance. Each point must 
be within this proximity to a reference point, or it will not be 
renamed.
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 ■ Group to contain matched points. The name for the copied 
group with the corrected point names.

4. SA will propose new names for your review. Click Accept to 
create a copy of the source point group and assign the appro-
priate point names.

Auto-Corresponding 2 Groups by Inter-Point Distance

Given a set of reference points and a group of source points, this com-
mand copies the source group and renames the points based on the 
reference point names. This command does not require the source 
and reference groups to be roughly aligned.

To Auto-Correspond Two Groups by Inter-Point Distance:

1. From the menu, select Construct>Points>Auto-Correspond 2 
Groups>Inter-Point Distance.

2. Select the reference group.

3. Select the group to be copied. The Autocorrespond Points 
dialog will appear (Figure 8-72).

 ■ Auto-correspond “same point” tolerance. Once “aligned”, 
each point must be within this proximity to its reference point 
to be considered a match.

 ■ Group to contain matched points. The name for the copied 
group with the corrected point names.

4. SA will propose new names for your review. Click Accept to 
create a copy of the source point group and assign the appro-
priate point names.

Averaging Points

You can create a single averaged point from a set of points.

Figure 8-73. The average of 5 
selected points.

To Average a Set of Points:

1. From the menu, select Construct>Points>Fit to Points.

2. Select the points to average, then press Enter.

3. The Construct New Point dialog appears (Figure 8-29).

4. Specify the name for the resulting point—leave the calculat-
ed coordinates alone—then click OK.
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Creating Points at the End of a Line

You can construct a point at either or both ends of a line by clicking 
near the desired end of the line.

To Construct a Point at the End of a Line:

1. From the menu, select Construct>Points>End of a Line.

2. The Point Name dialog will appear (Figure 8-74).

Figure 8-74. The Point Name 
dialog.

3. Specify the name for the first created point, then click OK.

4. Click near the end of a line to create the point. When finished 
creating points, press Enter.

Creating Points at a Plane Cross Section:

This command utilizes the database order of a given set of points to 
create a new set of points at a cross section of a plane. 

To Construct Points at a Plane Cross Section:

1. From the menu, select Construct>Points>Plane Section Crossing.

2. When prompted, select the Group of Points.

3. Select the Section Plane.

Constructing Points  Evenly Spaced on a Surface:

Given a surface, this command allows you to lay out a grid of evenly 
spaced points along both the U and V directions (Figure 8-75).
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Figure 8-75. Points laid out in ten 
divisons along U and V.

To Construct a Grid of Points Evenly Spaced on a Surface:

1. From the menu, select Construct>Points>Mesh Surfaces in UV.

2. When prompted, select the appropriate surface(s), then press 
Enter.

3. The Make Points From Surface dialog will appear (Figure 8-76).

Figure 8-76. The Make Points 
From Surface dialog.

4. Specify a prefix for the resulting point group.

5. If you would like each row to be in a separate group, check the 
Make each line a separate group option.

6. Specify the number of divisions along the U and V directions, 
then click OK.

Constructing Points From Vectors

This command will create a point at the origin of each selected vector 
(Figure 8-77).

Note:  The resulting point 
group name will be the pre-

fix specified + “Surface Name” + 
index.
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Figure 8-77. A point is construct-
ed at the origin of each vector.

 To Construct Points from Vectors:

1. From the menu, select Construct>Points>From Vectors.

2. When prompted, select the appropriate vector(s), then press 
Enter.

3. The Input dialog will appear (Figure 8-78).

Figure 8-78. The Input dialog.

4. Specify a name for the point group containing the resulting 
points, then click OK.

Constructing a Single Point through Patch Normal Shift

This command allows you to project a single point to a defined set 
of patch points. A theoretical plane is created from the patch points 
and the end result is a constructed point at a specified offset along its 
probing direction (Figure 8-79).



252

SPATIALANALYZER USER MANUAL

Figure 8-79. A point constructed 
from a selected point and shifted 0.75” 
along the probing direction of the 
theoretical patch point plane. 

To Construct a Point by Shifting along Normal:

1. From the menu, select Construct>Points>Patch Normal Shift>Single 
Point or press Ctrl + M.

2. When prompted, select the point, then select the patch points 
you wish to use. Press Enter.

3. The Add Shifted Point dialog will appear (Figure 8-80).

Figure 8-80. The Add Shifted 
Point dialog.

4. Specify the point group and point name of the resulting point, 
as well as the target and additional offsets (if applicable). 

5.  Click OK.

Scale Points

This command build a copy of the selected points scaled relative to 
the working frame.

Note:  The target offset of 
the selected initial point will 

populate in the dialog by default.



253

CHAPTER 8 ■ POINTS

Copy Groups Excluding Obscured Points

This command builds a new point group from the selected group in-
cluding only points directly visible from the instruments base frame.  
It excludes points on the far side of surfaces. 

Auto Filter to Faces

Creates a new set of points, groups, or clouds based on the proximity 
of points to a selection of surfaces. 

A selection of useful controls are available which include:

Figure 8-81. Auto Filter to Surface 
Faces Dialog.

 ■ Surface Offset. The necessary proximity to the surface 

 ■ Edge Offset. The required distance from a surface edge, which 
allows removal of points too close to an edge.

 ■ Surface Offset Direction. Which can be set to both above and 
below the surface or in only a single direction.

 ■ Output Limits. This control ensures that no more than the 
specified number of points are included per face.

 ■ Output Grouping. This selection determines if a single point 
cloud is built or if a cloud per surface face is returned. 

 ■ Cloud Thinning Options. A list of cloud thinning controls are 
also available including randomized thinning, Nth point thin-
ning, and min/max limits. 

When combined with the user of cloud based geometry relationships 
this command makes it very easy to extract features from a cloud us-
ing the available CAD to filter the cloud. For more information on ge-
ometry relationships refer to “Properties & Controls - Geometry Rela-
tionships” on page 527.
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A variation on this same command can be found under GD&T>Feature 
Inspection Auto Filter. This command displays the same dialog and selec-
tion of controls but does the following:

1. Detects which surface faces have both annotations attached 
and valid features checks built. 

2. It filters the data using the specified criteria to those faces

3. Associates the newly built points with the corresponding fea-
ture checks. 

From Surface Faces

This command currently builds a single point at the proximal extent 
of the cylinder it defines. Much like Construct>Cirles>From Surface Faces.

Closet points between 2 Surfaces

This command compares the provided surfaces and builds 2 points 
on the surfaces at the closest point locations on those surfaces, dis-
playing the minimum distance between them. 
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Point Clouds
Point Clouds are unique from Points and Point Groups because they 
are optimized for data storage and minimum memory usage. All 
cloud points are treated as a rigid body so point offsets and meta data 
are only recorded on the cloud level not with the individual points.  
Point Clouds are therefore ideal for large amounts of data, such as 
data measured with a laser room scanner or arm scanner, but can also 
be used to reduce the size of scanned measurements from a laser 
tracker with offsets. 

Point Cloud Formats

Standard Clouds 
The standard point cloud format is the simplest and most generic for-
mat of point clouds. Each cloud point consists of nothing more than 
and XYZ position and an index. The cloud contains targeting offsets 
(applied to all included cloud points) and visual controls. 

Scan Stripe Clouds 
Scan Stripe Clouds were added to provide a missing piece of informa-
tion necessary for meshing. In this format a transform representing 
the instrument probing direction is saved per scan stripe. Scan Stripe 

Point Clouds are a collection of compressed point lo-
cations in a format that is optimized for working with 
large amounts of data. This chapter addressed the fun-
damental principles necessary for effectively working 
with Point Cloud data with in SA and the differences 
between cloud points and regular points. 

Point Clouds
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Clouds therefore contain slightly more information but are otherwise 
the same as Standard Clouds. For this reason Scan Stripe Clouds can 
be converted to Standard Clouds but Standard Clouds cannot be con-
verted to Scan Stripe Clouds. 

Cross Section Clouds 
Cross Section Clouds were added as a convenient way to process a 
cloud or group of clouds in cross sections. It provides access to a set of 
filtering controls and the cloud visualization tools for cross sections. 

Point Cloud Visualization 
One of the more challenging aspects of working with point cloud 
data is finding the best way to visualize the information. When active-
ly measuring (in Real-Time) it may be better to have one view format 
and a different one when processing data. 

Real-time Data Display

There are 3 primary ways to visualize cloud data as it is being mea-
sured and these default settings can be controlled from the Users Op-
tions on the display tab (Figure 9-1).

1. Points Display. The raw point as measured can be shown using 
this as the default. This method is also important to use in 
order to see color or intensity values saved with points (see 
“Point Cloud Formats” on page 255).

2. Voxel Display. A more efficient method of display that shows a 
single point per volume of a specified size (see “Voxel Cloud 
Display” on page 265). 

3. Mesh Display.  This option does not show the measured points 
but uses a mesh to display the data (see “Real-Time Meshing” 
on page 306). 
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Figure 9-1. Default display 
settings available in the Users 
Options.

Working with Raw Point Cloud Data

Display Control
The number of cloud points displayed graphically can be controlled 
using the Cloud Display Control (View>Cloud Display Control Ctr+T). This 
utility provides the ability to adjust a global thinning factor which re-
duces the overall  number of cloud points displayed as well as a cloud 
point size control. 

As a Point Cloud is rotated or translated in the graphic view, the dis-
play resolution of the cloud will reduce automatically and will be re-
stored once the movement is stopped. Control over the extent of this 
additional thinning is also provided as part of the Cloud Display Con-
trol (Figure 9-2). 
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Figure 9-2. Cloud Display 
Control Dialog

 ■ Thin. The visual thinning factor applied. If set to the 8, for ex-
ample, only 1 point in 8 will be displayed. 

 ■ Size. The number of pixels used to display a point cloud point.

 ■ Rotational Thinning. This section controls the additional thin-
ning during graphical moves and rotations. Either or both of 
these rotation limits can be applied: 

 ■ Percent. If set, Rotational Thinning is controlled by a percent-
age value from 0-100 where 100 is no additional thinning. 

 ■ Limit. If set, Rotational Thinning is controlled by an upper limit 
of the number of cloud points displayed. In other words no 
more than the Limit number of points will be displayed graphi-
cally. 

 ■ AutoZoom Enable. Enables/Disables a zoomable display in 
which a limit can be set for how many cloud points are dis-
played graphically within the viewing window. As you zoom in 
more points will appear until the cloud is displayed at full reso-
lution, while zooming out reduces the total visible in a single 
area in favor of holding the max display value.

 ■ Point Selection. This option is used to help select points that 
are closest to the viewpoint when selecting points from a cloud 
with multiple layers.

Dynamic Cloud Thinning
When a live instrument is connected to in the job the total number of 
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cloud points visible at one time is limited to 200,000 points. This pre-
vents potential loss of data due to slow downs resulting for graphic 
display issues. Cloud thinning can be regulated below this threshold 
but can not be increased beyond the threshold until the instrument 
is disconnected. 

Auxiliary Cloud Thinning Factor
In addition to the global cloud thinning controls each individual cloud 
can have its own thinning factor set independently through its prop-
erties.  This control decreases the total number of points displayed at 
any time. This allows clouds of very different densities to be equalized 
for display purposes. 

Cloud Bounding Box
In order to more readily visualize the extents of a cloud a bounding 
box can be displayed by checking the option in the cloud properties 
dialog. This option provides the minimum volume box that contains 
all the points in the cloud. This box can be quite helpful in visualizing 
a cloud when you have less points displayed or in detecting outliers 
in a cloud (Figure 9-3). 

 ■ Axis Aligned Box. This option defines a box that is oriented 
with the World coordinate system in job file. Its the default be-
cause it and requires little initial computation. 

 ■ Minimum Orientation Box. This box defines the minimum 
volume necessary to contain the data. 

Figure 9-3. Example Bound-
ing Box control found through 
the Thinning Settings button 
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Figure 9-4. Cloud Properties 
Dialog

 

Directional View Control
Scan stripe clouds have an additional directional display control that 
can be enabled or disabled. This mode allow view of cloud points only 
when aligned within 60 degree of the probing direction. This hides 
cloud points measured on the backside of a part making view of front 
side coverage much easier. 

This mode can be enabled for an individual point cloud through its 
Right-click menu. It can also be set for all clouds, or a selection of 
clouds, through the Scan Stripe Cloud category right-click menu. 

When enabled the cloud will have a (Direction) identification ap-
pended to the cloud name (Figure 9-5).
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Figure 9-5. Directional cloud 
display controls through the 
Scan Stripe Clouds category  
R-click menu.

Color (Intensity) Mode
Both RGB or Intensity can be saved as part of a point cloud. When 
this information is available, it can be used to colorize each individual 
cloud point while in the standard cloud display mode. This color in-
formation will replace the standard cloud color and can be enable 
or disabled through the use of the Color (Intensity) Mode check box in 
the cloud properties menu (Figure 9-4). Only certain instruments and 
import formats (such as E57 or PTX) currently include RGB color or 
Intensity information. 

Cloud Point display can also be edited based upon the cloud point 
color and intensity information. This is done by right-clicking on the 
cloud and selecting RBG Filtering. This will open a filter control dialog 
that will allow you to limit the displayed cloud points based upon a 
max and min thresholds that can be applied to Red, Green and Blue 
independently (Figure 9-6).
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Figure 9-6. RGB Filter 
controls used to control cloud 
display based on saved cloud 
point parameters.

 

The check boxes next to the individual color components can be used 
to temporarily isolate the graphical display of the colors for the vis-
ible cloud points. This can be helpful for an instrument like the Leica 
ATS600 that saves the incidence (broadening) value in the Red color 
scheme while using Blue and Green to identify intensity. By uncheck-
ing the Blue and Green components the points will be displayed only 
using the red component making it easier to determine the ideal 
threshold to set in order to isolate the display of the desired cloud 
points. 

Display of the select color or combination of colors will be updated 
when the Apply Filter buttons are pressed. 

The individual controls function as follows:

 ■ High/Low Threshold. These check boxes and numerical val-
ues define the filter threshold that will be applied to the cloud 
points. These values should be between 0 and 255. 

 ■ Incrementally Apply Filter. The selected settings are applied 
to the cloud as it is currently displayed without any consider-
ation for hidden points. 

 ■ Reset and Apply Filter. The selected settings are applied to 
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the entire cloud regardless of its current display status. 

 ■ Reset All Cloud Points Visible. This option will reset all the 
cloud points such that they are visible regardless of color. 

 ■ Save Filter As Default. This option applies the current filter 
settings as a Default filter available to all clouds. 

 ■ Delete Current Filter. Removed the current filter from the list 
of available filters.

 ■ Clear All Filters. This option removed all the saved filters such 
that only the default filter will remain. 

 ■ Apply to selected. This button operates as a batch function al-
lowing the selected settings in the current cloud to be applied 
to a selection of other point clouds. 

 ■ Save Filter. This option allows you to apply the current filter 
settings to the currently selected Filter. Remember that at any 
time new filters can be created by typing a name into the Filter 
Name field and saving the current settings.

A simple example of how to use this filter is as follows. Assume you 
have scanned a black and white target and you want to use this filter 
to identify the center point of the target (Figure 9-7):

Figure 9-7. Scanned black 
and white location target

4. Right-click on the cloud in the graphics (or in the tree) and 
select RBG Filtering. 

5. Check the Grey Scale check box and the Low threshold check 
box below it. 

6. Enter a mid range value (45 worked here) to separate the dark 
or lower return points and hide them by pressing the Reset and 
Apply Filter button. When you do the dark points will be hid-
den (see Figure 9-8). The threshold can be adjusted and the 
display of the cloud points edited as desired to extract clean 
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lines on the target.

Once isolated each triangle can easily be selected graphically and the 
center point constructed. 

Figure 9-8. Scanned Target 
with the specified filter set-
tings applied.  

The Color Intensity Histogram was added to help in selecting the correct 
color values to use in the filtering process. It also has a Quality and 
intensity mode which is more intuitive for new uses than editing the 
green or gray scale values depending on the instrument (Figure 9-9). 

Figure 9-9. RGB Histogram

The Quality (Red) - Intensity (Green) Display Mode check box can be used to 
switch the controls for direct RGB selection to either Quality or Inten-
sity only. The slider can then be used to position the cut off threshold 
logically based upon the frequency distribution of the data. 

Adjusting Contrast

The contrast in the image can also be adjusted to the extents of the 
selected data range. This can be very helpful when trying to read text 
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or identify visual cues from the intensity data. To do so, check the Re-
set Grey Scale Contrast To Match Selected Range check box at  the bottom of 
the histogram available in Grey Scale mode(Figure 9-10). 

Figure 9-10. The Reset Grey 
Scale Contrast option can be 
found when in Grey Scale 
mode. 

The benefits of this mode can be seen here when trying to detect 
chalk markings on a part (Figure 9-11).

Figure 9-11. Scaled Contrast

Using rGB Filtering with Leica atS600 in Spatialanalyzer - https://youtu.
be/m11ufArEkJU

Voxel Cloud Display 

Voxelization (enabling the voxel processing) provides an alternative 
to using the Cloud Display Control to help visualize large point cloud 
files by providing a 3D grid or volume based sub-sampling option.  It 
also provides an alternative to vectors for displaying cloud to object 
deviations or other Surface Analysis displays (see Figure 9-12). 



266

SPATIALANALYZER USER MANUAL

Figure 9-12. Voxel display 
of deviations from a scan of a 
propeller.

How it works is you specify a grid size or volume and then only the 
point closest to the average for a specified volume, which we call a  
“voxel”, is displayed. Displaying a cloud in this way creates a roughly 
uniform density display of cloud data cross the entire scan region, 
and the size of the voxel point (displayed as a screen oriented disc 
or blotch) can be adjusted as a percentage of the volume used in its 
computation.

Enabling Voxel Display for an Existing Cloud
The Voxel cloud display can be enabled either through a cloud’s prop-
erties (Figure 9-4) or as an alternative vector display option from with-
in a Cloud to Objects relationship (Figure 9-13). 

Figure 9-13. Voxel Cloud Set-
tings available through both 
the relationship and cloud 
properties dialogs.

The Voxel Setting dialog provides the ability to adjust the display as 
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needed with the following controls:

 ■ Voxel Size. This entry field defines the length of a single side 
of the 3d volume used to identify each voxel.  Much like defin-
ing a grid for what data to keep, this control defines the data 
density. The Auto Detect button provides a convenient way to 
compute an estimated best size to balance detail and screen 
performance.

 ■ Minimum Point Count Per Voxel. This value defines the min-
imum number of cloud points required in a volume in order 
to compute a voxel. If there are fewer cloud points than the 
specifed number the voxel will be ignored. This provides a 
means to ignore outlier points. 

Traditional vectors reports consider cloud point deviations no differ-
ent than points. You can sub-sample and you can ignore edge projec-
tions but its still just considering the points directly. Voxels are differ-
ent. They are volume oriented. In each voxel volume the cloud points 
are processed and only the single cloud point closest to the average in 
that volume is considered. This dramatically down samples the cloud 
statistics and distributes the analysis much more equally across the 
part. In addition there is some built in outlier rejection. If a considered 
volume only has 1 or 2 points it, it will be ignored, which is ideal for ig-
noring noise from a scanner. This is an adjustable threshold (Min Point 
Count Per Voxel) that defaults to 3.  If you set this value to 6 for example 
there has to be 6 points in that volume or no voxel will be built in the 
zone. The advantage in this method is that it is not just smoothing by 
a distance but instead it preserves the actual scanned data. If there is 
a blemish in the part then removing outliers by a distance threshold 
may hide those bad places on the part. Voxels will not. 

If you change the Min Point Count Per Voxel to 1 and turn the op-
tion to ignore edge projections off you should see the Total and Valid 
point counts are equal (see Figure 9-14). 

Figure 9-14. Voxel Cloud 
Deviation Report displayed 
for a Point Cloud to Object 
Relationship
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This statistic is basically telling you how many voxel volume’s were 
processed and ignored.  The Voxel Size defines the volume considered 
so with larger point clouds you will want a larger volume. For quick 
graphics displays it seems that  keeping the total displayed number 
of voxels to roughly 200K is a good rule of thumb for a reasonable 
laptop. The Auto Detect button tries to do that for you but is generally 
a little conservative.

Voxel Display Settings 
The Voxel Display Settings are used to control the color and size of the 
blotch used to display the voxel. 

Figure 9-15. Voxel cloud set-
tings dialog

 ■ Enable Fast Rendering. This check box provides a method to 
disable blotch display and show voxels as regular cloud points 
only. 

 ■ Voxel Rendering Diameter. Voxels are displayed as blotches 
or round discs oriented toward the screen, unless Fast Render 
mode is enabled. The size of these blotches is controlled as a 
percentage of the Voxel Size. This value can be adjusted to fill 
gaps or more clearly separate individual voxels. For a smooth 
colored display a slightly larger value is best such as 125%. 

 ■ Voxel Render Border. The depth and 3D nature of a voxel dis-
play is dependent upon a black border around the voxel. The 
thickness of this border can be adjusted if the voxels overlap 
greatly and the color is overly black. 
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Using Voxel Colors for Deviation and Analysis

Surface Analysis Mode
Each voxel point can be colorized to display different information us-
ing the following settings:

 ■ None. Displays using the cloud color. This color is set when the 
voxel display is enabled so if the cloud color is changed after 
voxel display is set then the voxels will need to be recomputed 
for the color to change. 

 ■ Relationship. In this mode, each voxel is colorized based upon 
the distance information in the relationship. A single cloud to 
object relationship needs to be defined using this cloud for this 
mode to be available. A single relationship can only control the 
colorization of a single cloud, and if a second relationship is 
added this mode will no longer be available. 

 ■ Normals. Displays the XYZ direction vector for the voxel in RGB 
color based upon the working frame. 

 ■ Curvature. This setting will colorize the voxels based upon the 
depth or extent of the data within each voxel. Changes in the 
depth distribution of the voxel relative to a fit plane for that 
same data can help identify transition zones.  

 ■ Deviation RMS, Max, Avg. Provide a way to display the voxel 
colorization based upon each voxel’s statistics such as: RMS, 
Max and Average values independently.  The extents for each 
voxel can then be compared to the surrounding voxels.

 ■ Pseudo Surface. This option was added to help visualize the 
cloud data in 3D. Each voxel point is oriented based upon a 
plane fit using the surrounding voxel points and colorized us-
ing surface lighting (Figure 9-16). 

 ■ Cloud Comparison Deviation. This mode is only available in 
a cloud generated from a cloud to cloud query. In this case the  
voxel colors display the deviation results (see “Cloud to Cloud 
Query” on page 481). 

The voxel processing takes place following the scan data arriving in 
SA so you will see a scan pass line appear first and then be converted 
to a surface voxel as you scan.
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Figure 9-16. Pseudo Surface 
voxel display 

Basic Cloud display Controls & part Comparions in Spatialanalyzer - 
https://youtu.be/IzTV3lK4rVg 

Simple Surface Deviation Display Process
To visualize the deviations between a cloud and a CAD model using 
Voxels follow these steps: 

1. Import the CAD Model, scan the part and align to it. Then dis-
connect from the instrument. 

2. Build a Cloud to Objects relationship between the cloud and 
the CAD model.

3. Open the Relationship properties and enable the Voxel Cloud 
Display.  Select Voxelized Cloud Settings to adjust coloring or 
tolerance settings (Figure 9-13). 

Figure 9-17. Voxel Settings 
for Surface Deviation Display
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4. To add callouts displaying voxel deviation at particular loca-
tions, right click on the relationship and select Add Voxel Call-
out (Figure 9-18).   

Figure 9-18. Adding Voxel 
Callouts

Voxel callouts can be added through the right-click properties of a 
Cloud to Objects relationship or through the standard Callout drop 
down list.  When  you add a voxel callout you select a zone of voxels 
depending on how closely you are zoom in or out. The callout will 
by default identify the highest and or lowest voxel value for that re-
gion assuming all the voxel deviations are the same sign. If your se-
lection bridges a zone where there are positive and negative values 
in that selection the callout will also display both the high and low 
values(Figure 9-19). The leader line will attach to the specific voxel 
being reported if selected directly or include a region based upon the 
zoom extent at the time the callout was added. 
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Figure 9-19. Voxel Callout 
including multiple voxels over 
a span bridging zero

Clipping Planes 
Clipping planes can be extremely useful in removing unwanted data 
from a scan. For example, in many cases a part is set upon a flat sur-
face and then scanned and the splash measurements of the flat sur-
face are included with the measurements of the part. Clipping planes 
provide a way to easily removed measurements of the flat surface 
leaving only the measurements of interest.  

Clipping planes can be set globally but are defined through a point 
cloud’s properties and must be edited there as well. These clipping 
planes can be edited at ay time to be used in 2 ways: 

 ■ Defined in advance. If a clipping plane is defined for a cloud 
prior to scanning the data obscured by the clipping plane will 
be deleted automatically.

 ■ Defined after scanning. If a clipping plane is defined after the 
scan has been conducted then the hidden data is only hidden 
and not removed until the Delete Hidden Points command is used. 

To define a clipping plane do the following: 
1. Open the clouds properties dialog

2. Press the Configure Clipping Planes button

3. Press Add and select an object.

Each object in the Clipping Entities dialog (Figure 9-20) defines the 
base frame for a particular clipping volume. By default the XY plane of 
this object’s base frame defines the clipping plane used. Therefore if 
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you choose a plane directly it will be used as expected. However, you 
can choose any object as the reference object to define this plane. 

Figure 9-20. Clipping Plane

Each Clipping Entity defines a coordinate system which defines not 
only a clipping plane but a full clipping cube or volume.  Any of the 6 
different clipping planes or sides of a cubic volume can  be enabled 
and used as clipping plane to fully enclose a specific region of data. 
Therefore, up to 6 clipping planes per object can be used and as many 
objects as you want can be added all of which can refine the clipped 
volume. With multiple clipping entities defined just about any spe-
cific volume can be partitioned to either eliminate or isolate cloud 
points from the cloud (Figure 9-21). 

Figure 9-21. Clipping Entities 
and controls

The clipping volume box can be directly controlled graphically. By 
placing the mouse over an edge or corner the an arrow will appear 
graphically allowing you to drag that bounder to either increase or 
decrease its length. Particular clipping faces of this box can be turned 
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on or off by hovering over them until the side illuminates and then 
clicking. For more explicit control these controls can be accessed 
through the edit button (Figure 9-22). 

Figure 9-22. Edit Clipping 
Volume Controls

To define a clipping plane for multiple clouds
1.  Go to View> View Control> Clipping Planes (Alt + x)

2. Define a global visual clipping plane as desired

3. Press the Set as Cloud Default button

Clipping planes are cloud specific and set through the properties of 
each cloud independently. However, by setting up a clipping plane 
through the view control and applying it as a Cloud Default you are 
setting up each new cloud that is built to inherit this clipping plane 
definition when it is build.  This allows you to easily set a single plane 
as the default clipping plane for a job and then measure as many 
clouds as you would like. Each newly built cloud will then have this 
defined clipping plane. In order to then turn off this feature just go 
back to the global control again and reset the cloud default for the 
job. 

Cross Section Clouds 
Cross Section Clouds provide an additional method to visualize the 
data subdivided in segments at a distance across a part. This can be 
very helpful in understanding trends in deviation along the length of 
a part and can help to simplify the display regionally. 

Cross Sections Clouds in Spatialanalyzer - https://youtu.be/JbawRLRH-
pGE
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Figure 9-23. Cross Sections

Cross sections can be built from the menu command Construct>Point 
Clouds>Auto-Filter to Cross-Sections. 

Cross Section Configuration
The Build Cloud Cross Sections dialog provides the necessary con-
trols to define the filtered cloud sections. As inputs, it requires a Cross 
Section Reference Object which defines the direction axis for the cloud 
processing. This can be any object that defines a direction and will 
use the Z axis of that reference object. When using Planar Sections, this 
reference object defines the direction the normal vector of the filter 
planes will lie, and for Cylindrical Sections it defines the central axis for 
the coaxial cylinders.  When the direction object is a b-spline, planes 
will be added normal to the spline at the specified distance along its 
curve, using the spline direction at that point. 
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Figure 9-24. Build Cross Sec-
tions Dialog

The following parameters can be set: 

 ■ Start Distance. Defines the distance from the origin of the ref-
erence object to the first cross section

 ■ Section Spacing. The distance between the cross sections

 ■ Proximity Threshold. Defines how close data must be to the 
cross section to be included in the resulting cloud

 ■ Maximum Section Count. Defines the total number of cross 
sections from the start location. 

 ■ Limit Planar Cross Section Radius. When enabled this option 
restricts point selection to a radial proximity to the axis of the 
reference object. 

 ■ Project Proximate Points to Reference Plane. This check box 
provides an option to project selected points onto the cross 
section plane to ensure perfectly planar results. 

 ■ Cloud Thinning Settings. This button provides access to the 
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additional cloud thinning controls (see “Cloud Filtering and 
Sub-Sampling” on page 277).

Cross Section Cloud Properties
In addition to the standard cloud properties dialog, Cross Section 
Clouds provide a section display control panel. 

Figure 9-25. Cross Section 
Cloud Properties Dialog

This cross section panel provides display control  for each of the indi-
vidual cross sections, allowing you to turn on and off individual sec-
tions as desired. 

 ■ Double click on any individual section to display only that one 
section.

 ■ Highlight a selection of sections using either CTRL-click or 
SHFT-click, then R-click to select.

Cloud Filtering and Sub-Sampling
Many functions within SA provide access to an additional layer of 
thinning either as part of the association or evaluation process. This 
thinning of the input cloud can greatly increase processing speeds by 
reducing the size of the resulting cloud. The standard cloud thinning 
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controls include the following options (Figure 9-26): 

Figure 9-26. Cloud Thinning

 ■ No Thinning (Use All Points). Selecting None will disable in-
put cloud thinning. 

 ■ Random Thin. A random selection of points will be taken from 
the point input cloud until the Desired Count is reached. This 
method ensures an unbiased selection of cloud points for use.  
A random selection will pick different points each time it is run 
but ensures the same number of cloud points are returned. 

 ■ Every N-th Point. Provides either of two filter methods. If the 
Maximum Point Count is set to 0 it provides a simple decimation 
strategy where it will return 1 cloud point for every Skip Inter-
val. When used together with a Max Point Count, the Skip Interval is 
effectively expanded to equal the Input count divided by the 
Max Point Count, ensuring no more than the Max Point Count will be 
returned.   

 ■ Use Spatial Filtering. This filtering mode uses a moving filter 
window to walk through the data evaluating points within the 
specified 3D volume or Voxel Size. It attempts to return the most 
representable cloud point from the available data within that 
region by retaining the point closest to the average. The Mini-
mum Points Per Voxel control provides a means to exclude regions 
of low density as part of the sub-sampling process. This can be 



279

CHAPTER 9 ■ POINT CLOUDS

helpful in excluding outliers.  

Auto Filter Point Status

A Scan Strip Cloud contains the scan-line probing information used 
to build fine meshes. Unfortunately, many auto filter operations pro-
duce standard clouds that don’t contain this information as a result of 
the sub-sampling process. 

The auto Filter points Status section in the cloud properties window 
(Figure 9-4) provides a solution to this problem. When an auto filter 
operation is performed, the cloud points detected as part of the filter 
are saved in the original scan stripe cloud (Figure 9-27). 

Figure 9-27. Auto Filter Point 
Status Controls

This provides a means to highlight the marked cloud points and build 
a new point cloud using that data for either meshing or reverse engi-
neering purposes. 

Point Cloud Construction Options

Create Empty Scan Stripe Cloud

Building an empty scan stripe cloud allows an operator to configure 
the cloud prior to measuring. For example a clipping plane can be set 
up in advance as well as the meshing options defined as needed prior 
to the scan.

Note:  Auto Filtering using 
Spatial or Voxel thinning 

methods will not be saved or acti-
vate the Auto Filter Points Status 
window.  
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From Existing Clouds

Creates a new point cloud using a copy of the cloud points contained 
within the selected clouds and providing a full selection of sub sam-
pling options. 

From Existing Clouds Uniform Spacing

This command builds a new cloud from the selected clouds with a 
reduced number of cloud points. It returns an approximately uniform 
distribution of cloud points keeping only the closest cloud points at 
the desired point distance specified (see “Cloud Filtering and Sub-
Sampling” on page 277).  

From Existing Cloud Points

Creates a new point cloud copying the selected set of individual 
cloud points.

Random Data

Builds a randomly generated point cloud using the desired number 
of points within the specified X,Y, Z limits. 

From Existing Point Group

Converts a point group into a point cloud.

Auto Filter to Faces

New point clouds can be build from other clouds based upon 
the proximity of cloud points to a selection of surface faces using: 
Construct>Point Clouds>Auto Filter to Faces (Figure 9-28). Choose a prox-
imity threshold or “Surface Offset” in either the positive or negative 
direction or both. You can also limit the selection to points a certain 
distance away from the edge of the selected surface faces using the 
“Edge Offset” control. 
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Figure 9-28. A cloud cre-
ated based on proximity to a 
surface face.

 A variation on this command can also be found for feature inspection 
and automatic cloud association:

1. To filter clouds only to the surfaces faces used by a GD&T 
Datum or Feature Check a similar command can be found 
through Construct>Points>Auto Filter to Faces and GD&T>Feature 
Inspection Auto Filter. For more information refer to “Feature In-
spection Auto Filter” on page 634

2. To filter clouds only to the surfaces faces referenced  by Geom-
etry Relationships a similar command can be found through 
Relationships > Geometry Comparison > Autofilter to Nominal Geometry.  
This function is described in the following section.

Auto Filter to Vectors

New point clouds can be build from other clouds based upon the 
proximity of cloud points to a selection of vectors or vector groups us-
ing Construct>Point Clouds>Auto Filter to Vectors. This option provides the 
ability to define a cylindrical zone about a vector with a predefined 
radial proximity and distance from the vector origin and build new 
clouds for each vector that fit these requirements(Figure 9-29).

Figure 9-29. Auto Filter to 
Vectors Dialog Controls
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Auto Filter to Lines

New point clouds can be build from other clouds based upon the 
proximity of cloud points to a selection of lines. Controls are the same 
as are provided for filtering to Vectors.

Auto Filter to circular Arc B-Splines

New point clouds can be build from other clouds based upon the 
proximity of cloud points to a selection of B-splines. Cloud points be-
yond a plane constructed normal to the spline at either end will be 
ignored. 

On Object’s Vertices

This function operates the same as the construct points command 
but returns a single cloud with the object vertex points included as 
cloud points. 

Auto Filter to Cross -Sections

This option builds a cross-section cloud ((see “Query Point Cloud to 
Point Cloud” on page 294).

From Frame Set

This function builds a single cloud with cloud points built from the 
origins of the frames in the selected Frame Set. It will ask for a starting 
and ending frame and build the origins for the frames in that range. 

Building Points from  Point Clouds
You can convert cloud points gathered from a scan into normal con-
structed points as needed. These newly-constructed points will re-
tain the offsets saved with the cloud and will appear as constructed 
points. This can be helpful for a number of other functions that re-
quire regular points as inputs. 

Note:  Creating more than 
about 20,000 constructed 

points will result in increasingly 
sluggish interaction with the soft-
ware. When dealing with very 
large datasets, use cloud points.
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Figure 9-30. Points con-
structed from cloud points.

To Convert Cloud Points Into Constructed Points:

1. From the menu, select Construct>Points>From Cloud Points>Pick 
Cloud Points.

2. Select the points to convert.

3. The Make Points from Clouds dialog will appear (Figure 9-31).

Figure 9-31. The Make Points 
from Clouds dialog.

4. Specify the group name, an optional target prefix and start-
ing number, and an offset for the resulting points. If desired, 
select the Get a point every xxx option to subsample the cloud. 

5. Click OK. If subsampling, confirm the dialog.

Converting Clouds to Points

Similar to converting cloud points to points, you can convert an entire 
cloud to points. The procedure is almost identical to creating points 
from cloud points.

To Create Points from Clouds:

1. From the menu, select Construct>Points>From Cloud Points>Pick 
Clouds.

2. Select the points to convert.

3. The Make Points from Clouds dialog will appear.

Note:  If the cloud is being 
thinned, only the thinned 

subset will be selected.
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4. Specify the group name, an optional target prefix and start-
ing number, and an offset for the resulting points. If desired, 
select the Get a point every xxx option to subsample the cloud. 

5. Click OK. If subsampling, confirm the dialog.

Filtering Clouds to Points

Given a set of clouds and a set of points, SA can filter the clouds to 
the points. You provide a desired proximity and maximum number 
of points, and choose the existing points to serve as filter points. SA 
will create a new point group containing a subsampled set of up to 
the prescribed number of points (within the proximity) for each filter 
point (Figure 9-32).

This command is useful, for instance, when you have a set of nominal 
points on a design surface that indicates where you’d like to measure, 
and you have a surface scan of the part. The command will filter the 
clouds to those points.

To Filter Clouds to Reference Points:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Points.

2. Select the points to use as filter points.

Figure 9-32. Filtering a cloud 
to a set of reference points. 
Here, up to 5 points were cre-
ated for each reference point.

3. Pick one or more clouds to filter.

4. At the prompt, specify the resulting group name.

5. Enter a filter proximity—the maximum distance that a result-
ing cloud point can be from a filter point. Entering 0 will cre-
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ate a point only at the closest cloud point.

6. Specify the maximum number of points to create for each fil-
ter point. Entering 0 will pick all points within the prescribed 
proximity.

Filtering Clouds to a Plane

You can filter one or more clouds to single a plane. After specifying 
a proximity to the plane, SA will create a point group or cloud con-
taining all cloud points within the prescribed proximity to the plane 
(Figure 9-33).

To Filter Clouds to a Plane:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Plane.

2. Select the desired filter plane.

3. Select one or more clouds to filter.

Figure 9-33. Filtering a cloud 
to a plane.

4. At the prompt, enter the desired destination group name (or 
cloud name, if you choose to create a cloud).

5. Specify a filter proximity, which indicates how close a cloud 
point must be to the plane to be used. If you enter 0, all source 
cloud points will be used.

6. The Filter Clouds to Plane dialog will appear (Figure 9-34):

Figure 9-34. Options for 
filtering clouds to a plane.

Note:  You may wish to aver-
age the resulting points after 

this operation.
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 ■ Offset Direction. Determines the location of the proximity re-
gion. Both accepts points up to the prescribed filter proximity 
on both sides of the plane. positive only only accepts points on 
the positive side of the plane, and negative only only accepts 
points on the negative side of the plane.

 ■ Output Type. Determines the format of the resulting points—
should they be points or Cloud points?

7. Select the desired options, then click OK.

Filtering Clouds to Vectors by Resolving Points

Given a set of clouds and a set of vectors, SA can filter the clouds to 
the vectors. You provide a desired threshold around each vector, a 
proximity to the vector’s base, and the minimum number of required 
points, and SA will—for each vector—extract the points that meet 
the specified thresholds and average them into a single point (Figure 
9-35).

This command is useful, for instance, when you have a set of nominal 
vectors on a design surface that indicates where you’d like to mea-
sure, and you have a surface scan of the part. The command will filter 
the clouds to those vectors.

Figure 9-35. This cloud has 
been filtered to nominal vec-
tors.

To Filter Clouds to Vectors:

1. From the menu, select Construct>Points>From Cloud Points>Filter 
Clouds to Vectors-Resolve Points.

2. Pick the clouds you’d like to filter.

3. Select the vector groups you’d like to filter to.

4. The Filter Clouds to Vectors dialog will be displayed (Figure 
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9-36):

Figure 9-36. The Filter 
Clouds to Vectors dialog.

 ■ Output Group Name. The name for the resulting point group.

 ■ Minimum Proximity. The minimum allowable distance from a 
point to the vector to be considered.

 ■ Maximum Proximity. The maximum allowable distance from 
a point to the vector to be considered.

 ■ Max Distance from Vector Begin. The maximum distance 
that a cloud point can be from the base of the vector to be 
considered.

 ■ Minimum Number of Required Points. The minimum num-
ber of points required for an averaged point to be created. If 
this minimum is not met, no averaged point is created.

5. Enter the desired options, then click OK.

Extracting Center Points From Scanned Spheres

SA can search a point cloud and detect registration spheres within 
the cloud, and build the center points for those detected spheres. To 
do so, from the Clouds & Surfaces tab select Build from Clouds>Points  
>Auto-Detect Sphere Centers.

Provide the command with the expected sphere diameter, accept-
able RMS tolerance, and minimum number of points required, and 
the command will detect spherical data matching the proposed di-
ameter from the scan data, fit spheres to them, and create their center 
points (Figure 9-37).

Note:  Max distance from 
Vector Begin prevents ambi-

guity when there are two or more 
coaxial vectors.
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Figure 9-37. Registration 
sphere centers have been 
automatically extracted from 
this scan.

Create point from cloud sphere extraction now includes an option to 
perform a “Final Fit” option which implements aStM e3125-17 fitting 
algorithms. The point cloud data is filtered so that only a central cone 
opening angle of 120° is used to compute the sphere and its center 
point (Figure 9-38). 

Figure 9-38. ASTM E3125-
17 offers an outlier rejection 
strategy that uses the instru-
ments line of sight. 

Note that the input cloud must be associated with an instrument to 
establish the line of sight vector used for cloud segmentation as per 
this standard which then applies a conical outlier rejection strategy to 
further refine the fit results.
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To Auto-Detect Sphere Centers from Raster Scan Data:

1. From the menu, select Construct>Points>From Cloud Points>Auto-
Detect Sphere Centers.

2. The Sphere Extraction Settings dialog appears (Figure 9-39):

Figure 9-39. Specifying 
sphere extraction parameters.

 ■ Sphere Diameter. The nominal or expected diameter of the 
registration spheres to detect from the cloud.

 ■ Search Tolerance. The maximum allowable deviation for a giv-
en point from the desired diameter in order to be considered.

 ■ Minimum Point Count. The minimum number of cloud points 
required to satisfy the tolerance to consider a sphere to be 
“found”.

 ■ Final Fit Parameters. When enabled this option employs the 
ASTM E3125-17 method for cloud point rejection using the in-
strument’s line of sight and the LOS Cone Angle specified.

 ■ Group to Contain Sphere Centers. The name for the resulting 
group to contain the sphere center points found.

 ■ Create Spheres in addition to points. When enabled, SA will 
create the spheres (at the desired diameter) in addition to the 
center points.

3. Select the desired options, then click OK.

4. After calculation, SA will display the Sphere Auto-Detection 
Results dialog (Figure 9-40). This contains the RMS error, maxi-
mum error, and point count for each detected sphere.
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Figure 9-40. Sphere Auto-
detection results.

5. Click OK to accept the results, or Cancel to cancel.

Cloud Based Alignment/Registration Tools
SA provides a selection of cloud to cloud, cloud to mesh, and cloud 
to CAD alignment tools that can be used to align clouds and meshes 
as needed within your job file. The following options include cloud/
mesh specific alignment tools. At any time points can be built from 
cloud points for use in other alignment tools (see “Building Points 
from  Point Clouds” on page 282). 

Aligning Clouds to CAD / Mesh / Clouds

Align Cloud to CAD and Align Cloud to Mesh
An “intelligent” Cloud to CAD or Cloud to Mesh alignment tool is avail-
able directly through the cloud’s right-click properties. It provides a 
convenient way to align a cloud and associated instrument to a CAD 
model. This function first prompts for the operator to select the CAD 
surfaces to consider and then performs the alignment reporting the 
fit results and transform. 

This function is designed to be quick and easy to use. It is intended 
for clouds with nearly full coverage of the CAD and that have already 
had any splash data or outliers removed. It performs an initial align-
ment based upon the perimeter of the scan and then refines that 
alignment. If the alignment is canceled it can be run a second time 
using a finer detail mesh of the CAD model which will take longer but 
typically returns better results. 
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Figure 9-41. Align to CAD

Video demonstration available here- https://youtu.be/IzTV3lK4rVg

Align N Points to Objects
In many cases a simple one click alignment solution is not adap-
tive enough and a better starting condition is needed.  For this pur-
pose we have the align n points to Objects command (also available 
through the right-click menu).  This alignment tool provides the abil-
ity to choose starting points for the alignment which are used for a 
best fit prior to the final optimization.  

While any combination of feature types can be aligned to each other, 
cloud or mesh to clouds, meshes and CAD models its typically best 
to build a mesh for the alignment rather than directly aligning cloud 
points to cloud points because the mesh provides greater flexibility in 
the alignment and less variability in results. 

To use the Align N Points to Objects command do the following:

1. Right-click on the object you want to align (either Point Cloud  
or Mesh) and select align n points to Objects, choosing Cloud, 
Mesh or CAD as needed.  Both a properties dialog and a sec-
ond graphical window will open to help you select corre-
sponding points on both the moving feature and the feature 
to align to.  

2. Select the Control Points button and then click directly on 
the stationary feature within SA to identify location points (at 
least 3 Points). 
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3. Select the  Rough Align Points button and then click within 
the second graphics window on the moving feature to iden-
tify the corresponding points (Figure 9-42). You can delete the 
last selected  point location with the delete key.

Figure 9-42. Align N Points 
To Objects

4. When satisfied with the selected points press the Perform 
Alignment button and verify the alignment. You can do so 
both graphically and by checking the resulting RMS. At any 
time the applied alignment can be edited until you exit the 
dialog.  

Quick Align Clouds to CAD
Based upon the Quick Align to CAD function, this equivalent com-
mand first prompts for selection of alignment points located on the 
CAD model and then prompts the operator to select the correspond-
ing cloud points from the cloud.  These cloud points are then fit to the 
CAD model at the designated locations.  

Point Extraction and Best-Fit

When using registration targets the best way to align those common 
targets together between scans is to extract the alignment points 
and then Best-Fit those points together. To do so try the following: 

1. Extracting Center Points From Scanned Spheres from each 
cloud ensuring that the corresponding point groups have 
the same point names (see “Extracting Center Points From 
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Scanned Spheres” on page 287).

2. Select Analysis> Best-Fit Transformation> Points to Points (Ctr+B). For 
more details on the Best-Fit alignment refer to the alignments 
chapter (see “Best-Fit Transformations” on page 401). 

Cloud to Object Relationship Optimization

Cloud to Object Relationships are very powerful tools. They allow 
you to define subsampling options as needed and provide a dynamic 
query that can be used to dial in an alignment to highest accuracy. 
The same degree of control is provided for cloud points in relation-
ship fitting as is available for use with points. For more details refer 
to the Relationships chapter (see “Minimizing Relationships” on page 
535). 

 Refit Scan Passes

In addition to aligning separate clouds to each other a lower level 
adjustment can be made to align separate scan passes. To do so, 
right-click on the cloud of interest and select Refit Scan Passes. This will 
build a new, adjusted point cloud aligned to the specified tolerance.  
The alignment transform and statistics are recorded within the new 
cloud’s History.

Each time a scan is started and stopped a new scan pass is recorded. 
These passes can then be aligned to each other using the features 
measured within the scan and adjusting the relative transforms of 
subsequent scans passes to the first. 

This can be helpful in two ways. In cases where an instrument made 
a significant shift in position, such as shifting to the far side of a part  
but is still measuring into the same point cloud, this tool can help 
align the passes to each other. This could correct for a slight instru-
ment calibration error in a particular joint for example. This is very 
helpful in smoothing a resulting mesh.

Second, if you combine two or more point clouds into a single cloud 
using a construction command these scans will be marked as sepa-
rate passes within the resulting cloud. The re-fit scan passes can then 
be used to refine the alignment of these separate cloud passes within 
the cloud with respect to each other.  
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Query Point Cloud to Point Cloud
The distance between two point clouds can be evaluated directly us-
ing a Cloud to Cloud Query. Rather than generating a vector group 
(which is not optimized for so much data) this operation build a new 
point cloud which is colorized to display the deviations (Figure 9-43).

Select two point clouds. The first is the reference cloud and the sec-
ond is the measured object cloud which will be projected onto the 
reference. The Max Distance determines the furthest distance points 
will be considered, limiting the size of the query.

Each point is projected in the direction of the local normal of the 
cloud on a local plane. In other words, the “distance” is not the closest 
distance to a point of the target cloud, but the closest distance to a 
local plane of the target cloud.

Figure 9-43. Example Point 
CLoud to Point Cloud Query

Feature Extraction from Point Clouds

Auto Filter to Nominal Geometry >3D Extraction

The nominal geometry within a Compare to Nominal Geometry Rela-
tionships can be used to perform feature extraction based upon 
proximity. This can be done per feature or by using the command 
Relationships>Geometry Comparison >Autofilter to Nominal Geometry>3D Geom-
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etry or by using the toolkit button  which will also bring up the 
following control (Figure 9-44).

Figure 9-44. Nominal Geom-
etry Auto Filter

This function an be used in either of two ways: 

1. It provides a means to select a list relationships you would 
like to detect and a list of point clouds to filter from. It then 
will search through each relationship and all the clouds and 
populate all of them with the results at one time. 

2. It can be used “Live” as part of the Nominal Geometry Rela-
tionship build process. With the dialog open and the “Live” 
and “Auto Detect” check boxes checked. Any newly built com-
pare to nominal geometry relationship will be automatically 
analyzed and features extracted as part of the build process.  

The Nominal Geometry Auto Filter dialog offers the following options:

Relationship and Point Clouds Selection.  

 ■ Add Relationships. Provides the ability to select a set of pre-
defind Geometry Relationships 



296

SPATIALANALYZER USER MANUAL

 ■ Remove Relationships. Allows the user to remove the cur-
rently seleted relationship from the list to consider. 

 ■ Add Input Clouds. Provides the ability to select a set of point 
clouds to use for the filter process. 

 ■ Remove Input Clouds. Allows the user to remove the current-
ly seleted point cloud from the list to consider. 

 ■ Auto Detect. This check box comes into play when building 
geometry from CAD using the Live Auto-filter function. 

Cloud Thinning Controls 

 ■ Count Based - Cloud Thinning Options. This selection mode 
and control provides access to standard cloud thinning con-
trols including Nth point decimation and limit selection. 

 ■ Spatial Based - Voxel Size. This thinning options provides a 
more advanced volume processing approache to thinning. The 
Spatial Filtering size designation defines the size of the  volume 
to be processed to return a single point, and the Minimum 
points designation provides a means to exclude outliers and 
ignore volumes without a sufficent point count.

Auto Filter Proximity Settings
This filter process takes the selected point clouds and detects from 
those clouds the cloud points that fall within a specified proximity to 
the nominal feature. This filter process falls into two categories: 2D 
and 3D objects and the controls for each are separately designed. 

For 3D objects such as Planes, Cylinders, Cones and Spheres there are 
two basic parameters to consider (Figure 9-45): 

Figure 9-45. Nominal Ge-
ometry Auto Filter Proximity 
Settings for 3D features

 ■ Surface Inclusion Proximity (A). This parameter defines how 
close the cloud points must be to the surface of a feature in 
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order to be included for that feature. This can be limited to only 
one side of the nominal feature if desired. This needs to be set 
large enough to account for any error in the measurements but 
not so big as to pick up data from other features. 

 ■ Edge Exclusion Proximity (B). Cloud points too close to the 
edge of a feature often include bad points. For this reason we 
provide a means to exclude those points based upon a preset 
distance from that edge. 

2D features such as cirlces require an additional parameter because 
they are both detecting the measured plane used for projection and 
the filter points. Therefore there are three parameters to consider 
(Figure 9-46):

Figure 9-46. Nominal Ge-
ometry Auto Filter Proximity 
Settings for 2D features

 ■ Planar Inclusion Proximity (A). This parameter defines the 
distance from the planar surface or how deeply into a hole the 
filter will look.  

 ■ Planar Exclusion Proximity (B). The filter is looking to gather 
points from the inner wall of the measured cylindrical surfaces 
not the measured plane points. To exclude these, this param-
eter allows you to set the extent of data ignored relative to the 
nominal planar surface. This can be compared to the Edge Ex-
clusion Proximity (B) setting for 3D features. 

 ■ Radial Inclusion Proximity (C). Much like the Surface Inclu-
sion Proximity using for 3D Objects, this parameter provides 
a setting to define the extent of data included relative to the 
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inner wall of the hole. This parameter can be set fairly large 
unless there are other holes or features close by. The numeric 
value entered defines the distance from the wall of the hole or, 
when the “On Axis Only” option is enabled, relative to the hole 
center axis. 

These values defines either the total bidirectional  distance, when the 
Both option is checked or a singe direction value when either the Posi-
tive only or Negative only options are set. 

Using Surface Faces for Edge Detection
When working with composite structures such as  plane with holes 
in it or a partial sphere or cylindrical cutout filtering to the nominal 
feature doesn’t provide enough information to accurately detect the 
correct points. In these cases the CAD Faces can be save with the 
nominal feature to more precisely restrict the filter. 

As an example consider a rounded corner on a CAD part. If you build 
the nominal cylinder from this face the filter  process will include all 
the points within a proximity to that cylinder. The problem with this is 
that the CAD is only a partial cylinder and this will throw off the result-
ing fit as shown here in Figure 9-47. 

Figure 9-47. Partial cylin-
der proximity filter problem. 
Showing the need to save 
CAD face information. 

To properly filter to this face we have added the ability to record the 
faces used to build the geometry with the nominal cylinder selection. 
This can either be done through a right-click option added to the 
toolkit or directly through the relationship properties. 

When a face is saved with the nominal geometry you will see it high-
light with the geometry when it is highlighted as shown here in Fig-
ure 9-48.



299

CHAPTER 9 ■ POINT CLOUDS

Figure 9-48. CAD face saved 
with the nominal cylinder.

Using the CAD faces with the proximity filter allows you to ignore dat 
a beyond their extents an better isolate the data as shown here in 
Figure 9-49.

Figure 9-49. Properly filtered 
data using the associated CAD 
faces and resulting vectors.

3D Extraction with Points
The same feature extraction process can be used to detect points 
within the specified proximity. The points are first queried to the sur-
faces to correctly compensate for point offsets and then the same fil-
ter process is used. 

Feature Specific Filtering
Each GR-Feature has its own auto-filter proximity settings built 
in when it is created. These initial settings are pulled from the User 
Options>Display Tab, GR Proximity Filter and saved with the feature. They 
can be accessed at any time through the Right-click Inspection>Configure 
Cloud Trapping Filter option.  This will open a unique feature type specific 
set of controls (Figure 9-50). 
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Figure 9-50. Feature Specific 
Proximity settings for a plane.

 ■ Enable Cloud Trap Filter. This option allows trapping to be fil-
tered based upon proximity to the nominal geometry.

 ■ Enable Real-Time Updates. When enabled the geometry is fit 
dynamically to the cloud data as it is gathered. This can be very 
helpful in some cases and can cause slow downs depending 
on the data acquisition rate. With this option off, geometry is fit 
when trapping is completed.

 ■ Only Save Last Scanned Cloud Data. With this flag set, all 
previously acquired cloud data is cleared as input into the ge-
ometry relationship. With flag off, whenever you are trapping 
cloud data to a relationship, the most recently scanned cloud 
is appended to the list of any previously acquired cloud data 
such that any previously acquired cloud data is saved. 

 ■ Use Associated CAD Faces. When filtering, consider the CAD 
faces as well as the nominal geometry. This will impact edge 
proximity.

 ■ Cloud Thinning Settings. This is the standard cloud thinning 
settings used in many places within SA. It allows you to sub 
sample the cloud used in the fit operation.

 ■ Apply. The Apply button can be used to trigger a re-sampling 
of the cloud data from the source cloud. And the Apply to selected  
option can be used to apply settings to a selection of features 
at once.
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In order to maintain data integrity the source cloud is saved with a 
GR-Feature but not edited by it. Instead, a sub sample of the source 
cloud is made as a copy and linked as well so that it can be used for 
the purpose of fitting and outlier rejection. This allows you to more 
unwanted outlier cloud points with edition the source cloud (Figure 
9-51). 

Figure 9-51. Example GR-
Cylinder showing both a 
Source Cloud and the associ-
ated cloud used for he fit. 

These settings are applied directly from within a particular relation-
ship using Associate Data> Proximity Filtered Cloud or through trapping 
into the feature with a live instrument. 

Auto Filter to Nominal Geometry >2D Geometry

2D Geometry extraction is a specialized subset of the Compare to 
Nominal Geometry function used for holes (circles and slots). It can be 
used to perform feature extraction from a point clouds based upon 
proximity to nominal geometry, where only a surface scan is available, 
such as with sheet metal. This command can be accessed  through 
Relationships > Geometry Comparison > Autofilter to Nominal Geometry>2D Ge-
ometry or through the toolkit. 

This alternative Filter to Nominal function uses the same dialog as the 
3D Geometry extraction tool with the addition of a tolerance and two 
processing buttons (Figure 9-52):

Figure 9-52. 2D Extraction 
specific buttons

The 2D Geometry extraction process is performed in 2 steps:

1. The Auto Filter Button should first be use to extract mini clouds 
in close proximity to nominal geometry in order to isolate and 
identify the cloud points of interest (use the settings button to 
set filtering and extraction depth to built the mini clouds). 

2. The Extract button can then be used to build the extracted circle 
points and associate them automatically with the generated re-
lationship. 
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Figure 9-53. 2D Extraction 
process in action

The extraction process will delete the referenced mini-cloud built 
from the auto-filter process and automatically associate the extracted 
points to the relationship as long as a circle fit can be achieved within 
the specified tolerance. If it cannot identify geometry, it will not re-
move the filtered cloud so that a manual inspection is possible. For 
additional information on the tolerance settings see “Extraction Tol-
erance” on page 304. The auto Set option when enabled will adjust 
the tolerance based on the maximum radius over all active nominals.

All filter settings are disabled in 2D Geometry extraction mode ex-
cept for the depth control (A) which is still used to determine how far 
above or below the nominal hole plane data is collected. 

Auto Filter to Nominal Geometry>Lines
Filtering clouds to lines only considers a radial deviation and is there-
fore handled separately. The controls for this function include the 
proximity to the line (Radial Cutoff) and the distance from the ends 
of the line, distance from the origin (Lower Cutoff) and distance from 
the end of the line  (Upper Cutoff). Subsampling options are also 
available . 

Figure 9-54. Auto Filter to 
Lines

Extract Geometry from Clouds

SA can be used to extract features from a point cloud without CAD or 
any nominal references of any kind. This is done by detecting geom-
etry within proximity to a seed point (or click-point). This command 
can be  accessed through Relationships > Geometry Comparison > Extract 
Geometry from Cloud.



303

CHAPTER 9 ■ POINT CLOUDS

Figure 9-55. Extract Geom-
etry from Clouds Dialog

Feature Selection and Cloud interaction
To use this extraction dialog, simply open the dialog so that it is vis-
ible, select the geometry button of interest, and then click on a cloud 
point to define the start of the search region. 

 ■ Extract Plane. Click on the cloud in a planar region. SA will 
then grow a plane from that starting point including cloud 
data as long as it remains within the specified tolerance.

 ■ Extract Single Circle from Plane (Left-Click). Click on the 
cloud in a planar region. SA will then fit a plane to that data set 
and search within proximity to that click point for a single circle 
or hole in the planar region selected.

 ■ Extract Multiple Circles from Plane (Right-Click). Click on 
the cloud in a planar region. SA will then fit a plane to that data 
set and search throughout the plane for circles or holes that are 
within the specified tolerance.

 ■ Extract Circle from Cylinder (Alt+Left-Click). Click on the 
cloud in a cylindrical region. SA will then fit a cylinder to that 
data set and build a circle at the end of the fit cylinder closest 
to the click point.

 ■ Extract Single Slot from Plane (Left-Click). Click on the cloud 
in a planar region. SA will then fit a plane to that data set and 
search within proximity to that click point for a single slot.

 ■ Extract Multiple Slots from Plane (Right-Click). Click on the 
cloud in a planar region. SA will then fit a plane to that data set 
and search throughout the plane for slots that are within the 



304

SPATIALANALYZER USER MANUAL

specified tolerance.

 ■ Cylinder. Click on the cloud in a cylindrical region. SA will then 
grow a cylinder from that starting point including cloud data 
as long as it remains within the specified tolerance. 

 ■ Sphere. Click on the cloud in a Spherical region. SA will then 
grow a sphere from that starting point including cloud data as 
long as it remains within the specified tolerance.

Extraction Tolerance
A single tolerance parameter is presented. 

Relative to the seed point, the “ExtractPlane” function tries to grow a 
plane (or other geometry) and as it grows, it filters out points that are 
not within this plane tolerance. If data is fairly planar then there is a 
good chance that the correct set of planar cloud points will be har-
vested with a tight tolerance. However, if you pick a seed point in a 
region with adjacent points that are not clearly planar then the plane 
may start off in a bad orientation. Larger tolerances will increase the 
likelihood of getting the correct orientation but include more outlier 
points in the fit. Therefore an optimal balance must be found. 

Acceptance criteria for a “good” circle (currently hard coded values in-
cluded here only as a reference) :

 ■ RMS <= 0.1 * radius

 ■ MAX Pt Dev<= 4 * tolerance

 ■ Number of points >= 10

 ■ Radius / (max cloud dimension) < 4

 ■ Tolerance <= 0.1 * Radius (not used when filtering to nominal 
geometry)

Selected Points Only (check box)
When enabled, this option will prompt the user to select the subset 
of the cloud to consider after selecting the starting point. This can 
be very helpful for detecting individual features and accelerating the 
search process by reducing the amount of data to consider.

Normal Direction and Reference
Without a nominal reference, geometry has no directional reference. 
Predefining a reference object allows all the resulting objects to be 
correctly oriented. This is important if additional point measurements 
are going to be taken and the correct offsets need to be accounted 
for. Object direction can also be reversed individually by selecting the 
newly built object in the Extract Geometry from Cloud dialog, or in 
the fit settings of the resulting geometry relationship.
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 Meshing Point Clouds
A mesh is an approximated surfaces built from triangles (or poly-
gons). These surfaces can be either imported or built directly from 
cloud data and they can be used for a wide range of purpose includ-
ing simplified reference surfaces that can be used as a proxy for a sur-
face’s true curvature. The vertice points used to define the triangles 
provide the only accurate position information which the connecting 
lines are used for visualization purposes. 

There are a couple of different mesh formats: 

Polygonized Surfaces 
Polygonized Surfaces are primarily imported CAD models of a very 
low resolution, although some legacy construction and editing can  
be done most meshing tools now use the Scan Strip Mesh.

Graphical Entities 
Graphical entities can be edited but includ aditional visual elements. 
For example a Colorized Graphical Mesh is generated from the proximity 
of points or point clouds to a surface the resulting feature in the tree 
is a Graphical Entity. This is use for visual representation only. 

Scan Stripe Mesh 
Scan Stripe Meshes are SA’s primary tool for working with and editing 
mesh representations of cloud data. They can be built from a specific 
Scan Stripe Cloud, much like auto-vectors built from a relationship. 
The probing transforms embedded within Scan Stripe Cloud can be 
used to provide the direction vectors necessary to make Real-time 
meshing possible. It also provides the ability to build finely detailed 
meshes from cloud data. 

 ■ Real-Time Mesh. Built as measurements are taken. 

 ■ Coarse Mesh. Provides a quick visualization tool a mesh of 
roughly a uniform grid density.

 ■ Fine Mesh. Provides a detailed surface approximation for the 
scan data and is optimized for triangle density and distribution. 

Scan Stripe Mesh Operations

Scan Strip Meshes
Scan Stripe Meshes display a graphical rendering of cloud data in ei-
ther of two formats: 

 ■ Real-Time Course Mesh. Which is built as you scan or is gener-
ated directly from a cloud and is a course and minimally pro-
cessed mesh for visualization 
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 ■ Fine Mesh. This mesh must be built from course mesh and 
uses the specified meshing parameters defined in the mesh 
properties to built a finalized or detailed mesh.

Real-Time Meshing
A real-time mesh can be enabled during scanning. This can be quite 
useful as an easy to see coverage indicator. 

In order to enable the Real-Time Mesh go to the User Options and on 
the display tab select Clouds & Mesh (Figure 9-56). Within this default 
control is an option to enabled the Mesh display. Doing so will cause 
newly acquired clouds to hidden and a mesh displayed in their place.  
The resolution of this mesh can be set to match your job’s resolution.  

Figure 9-56. Coarse Mesh 
Controls within the cloud 
Properties

Defaults can be set using the predefined Fast or Standard options. Or 
your settings can be customized with the following controls:

 ■ Hole Size. Defines the expected hole size. Setting too large a 
value with could cause holes to be filled. 

 ■ Stripe Max Deviation. The maximum strip distance to be con-
nected when building a mesh. 

 ■ Stripe Max Point Spacing. The maximum distance within a 
scan line to bridge within the mesh. 

 ■ Grid Size. Defines the average triangle edge length to use in 
the meshing process. 

 ■ Grid Max Angle. This setting works as a rejection threshold 
beyond which data with too steep a probing vector will be ei-
ther rejected or marked as suspect.

 ■ Grid Max Ratio.

 ■ Throttle Time (sec). This timer controls the amount of data 
processed prior to sending it to SA. 

At any time you can also right-click on a scan stripe cloud and gener-



307

CHAPTER 9 ■ POINT CLOUDS

ate a finalized. 

General Mesh
Both course and fine general meshes can be built from any point 
cloud or combination of point clouds. It requires a instrument asso-
ciation but does not require a scan stripe cloud as an input. To built 
a general mesh either right-click on a cloud directly or use the com-
mand Construct>Mesh from Point Clouds. This will open the mesh settings 
dialog (Figure 9-57).

Figure 9-57. Generic Mesh 
Construction Dialog

General Meshes only offer 2 parameters: 

 ■ Maximum Triangle Size. This value defined the resolution of 
the resulting mesh by defining the size of the triangles used. 
The small the max triangle size, the finer the mesh.

 ■ Smallest Hole Diameter. This value controls the size of the 
gaps within a mesh that are bridge or covered. With this val-
ue very small the mesh will have lots of holes. But with a large 
value, holes that are actually there within the mesh could be 
covered over in the meshing process.

 ■ Finalize. The finalize check box is used to build a finalized 
mesh. This takes much longer and produces a much more opti-
mized mesh when the mesh is generated. 

 ■ Use Scan Direction For Point Normals. This option allows the 
normals saved in a Scan Stripe Cloud to be used to help ori-
ent the normals of mesh segments. However, when combing 
clouds, or meshing scans performed with many passes from 
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different directions, this may not be helpful.  The positive side 
of the mesh needs to be oriented correctly for correct probe 
compensation. 

Figure 9-58. Fine Mesh Gen-
eration

The Reverse Mesh Normals button can be used to reverse the normal of a 
mesh for accurate probe offset compensation. However, it should be 
noted that breaks in the mesh can cause local segment reversals. The 
Extended Parameter Mesh is much more resistant to these because it 
uses the scan line probing vectors.  

Extended Parameter Mesh
The Extended Parameter Mesh is unique it two ways. It uses the scan 
strip probing directions in its computation and it provides the user 
full control over all the input parameters. For difficult meshing data 
sets this provides greater user control(Figure 9-59). 

The controls presented are presented in the order that they are used 
in the mesh refinement. 
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Figure 9-59. Mesh Parameter 
Controls

Initial Meshing Filters:

Scan Pass Processing 

 ■ Critical Tilt Angle. Allowable tilt threshold. This excludes 
points recorded at a sharp angle to the instrument.

 ■ Critical Span Angle. Allowable span angle.

Big Triangles Filter

 ■ Max Triangle Edge Length. The maximum size allowed for tri-
angles within the mesh. Triangles greater than this size will be 
removed.

Stitch Overlapping meshes filter

 ■ Max Surface Separation Distance. Required overlap neces-
sary for scans to be stitched together as a single layer.

Filter Mesh by Deviation Error

 ■ First Pass Deviation Tolerance. Tolerance set for the first pass 
processing of the mesh.

 ■ Second Pass Deviation Tolerance. Tolerance set for the sec-
ond pass processing of the mesh.
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Remesh Refine Existing Mesh Options

 ■ Remesh Deviation Tolerance. Final tolerance set for the mesh. 

 ■ Min Triangle Edge Length. Removes triangles smaller than 
the specified threshold

 ■ Max Number of Triangles. Total number of triangles allowed.

  Options Mask 

Set of optional check boxes for greater smoothing options. 

 ■ Free borders may be moved and refined. Choose to allow 
borders to be free to move.

 ■ Free borders may be move, refined, if some points of the 
cloud are outside free borders. Choose to allow borders to 
move if there is data outside of the border. 

 ■ Allow vertices to move while smoothing. This option creates 
a smoother mesh but could hide real imperfections in the data 
or surface.

  Reorganization Mask. 

Set of options for optimized triangle layout.

 ■ Optimize fitting to sharp edges and small radii.  This option 
produces greater resolution along edges. 

 ■ Disable smoothing operation at end of process. This option 
can be used to bypass the final smoothing process.

  Final point exclusion

 ■ Cloud Point Exclusion Threshold. Final exclusion threshold. 

Saving and Applying Mesh Parameters

Scan Stripe Mesh parameters can be saved using the Manage Default 
Settings option. Currently only a single set of saved settings can be 
recorded at one time in addition to the system default settings and 
these settings are saved only within the current job file. To save set-
tings for use in other jobs you can set up a template file with the 
saved settings. 

Scan Stripe Mesh Editing

Stitch Mesh
Two meshes can be combined using the right-click menu command 
Stitch Mesh. This command allows you to select a second mesh and 
blend them together within an overlap tolerance as a single result, 
building a new mesh. 
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Mesh Dissection
A mesh can be composed of a continuous set of linked polygons or a 
group of distinct segments. This group of segments can be split apart 
and recombined much like the faces of a CAD model. 

Use Mesh by Dissecting to create additional entries in the tree for each 
distinct mesh segment, and Mesh from Collection of Meshes to build a sin-
gle mesh for a selection of segments. This is different from Stitching in 
that the mesh segments are unaltered. 

Hole Filling
Holes can be filled within a mesh using the command Clouds & 

Surfaces>Build from Clouds>Mesh>Edit Scan Strip Mesh . This option 
searches the mesh relative to a click point and fills holes that fit the 
selected criteria. 

Limited Filling Options. 

Limited filling is the safest approach. It sets restrictions on the extents 
of the filling that can be performed .

 ■ Wall Thickness. This parameter can be used to fill horseshoe 
shaped holes in an edge. It allows you to specify the size of gap 
to bridge (a value of -1 disables this bridging).

 ■ Max Triangle Length. The length of triangles used to bridge 
a hole can be restricted to a specific length (a value of -1 re-
moves any limits). 

 ■ Tension. Tension determines the curvature of the mesh that is  
used to span a hole, allowing you to follow the natural contour 
of the part within a hole rather than filling it with a flat cap. Ten-
sion is defined numerically. 

 ■ Values <0  reverse the curvature in the middle of hole

 ■ A value of 0 does not add any curvature

 ■ Values >0 add curvature.  By default, curve fitting should use a 
value near 1.  

To use this function set the values you would like to apply, press the 
Fill Individual Holes button, and then click on the mesh next to the hole 
you wish to fill.

The option to Fill All Holes in Selected  Mesh can also be used to fill any holes 
that fit the filling criteria. 

Hole filling is an art and can produce unexpected results. The Undo All 
Fills For Last Selected Mesh button can be used when a fill operation does 
not go as expected. 
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Unconditional Filling

This option will fill unconditionally even if the shape is not smooth. 
This option can produce sharp edges and intersections because some 
of the filters are disabled but provides an alternative when Limited Fill-
ing is not providing the desired results. 

hole Filling a Mesh in Spatialanalyzer - 

https://youtu.be/7kfCxv8qOBc
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6D Locations and Measurements 

Frames

SpatialAnalyzer allows you to create a virtually unlimited number of 
coordinate frames (referred to as frames in SA), each representing a 
different aspect of your job that is important to you.

Figure 10-1. This collection 
has two coordinate frames, 
World and Local. The Local 
frame is active (working).

While there can be many coordinate frames in a given SA job, only 
one can be designated as the working frame. When a coordinate frame 
is designated as the working frame, it will be drawn in a bold blue 
font in the tree (Figure 10-2), and the Color/WCF Toolbar will display 
the name of the frame (right).

Spatial Analyzer provides a lot of flexibility when it 
comes to defining a base coordinate for a job file. 
Frames in SA refer to both coordinates systems and any 
defined 6D location in space or measurement.  “Frames” 
may also be called: Reference Systems, Coordinate Ref-
erence Systems, Coordinate Reference Frames, Frame 
of References, or 6D locations.

Frames
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Figure 10-2. The Color/WCF 
Toolbar.

All coordinates, query results, and other values are always displayed 
relative to the active coordinate frame (Figure 10-3), unless explicitly 
specified otherwise. For example, when you view the coordinates of a 
point, you are seeing the coordinates relative to the active coordinate 
frame.

Figure 10-3. Working Frame

 To Activate a Coordinate Frame:

Do one of the following:

 ■ Right-click a frame in the graphical view or SA tree and select 
Make Working Frame.

 ■ Click the WCF button on the Color/WCF toolbar and choose a 
new working frame from the Object Selection dialog.

 ■ Right-click a frame in the tree and select Properties. Then click 
the Make Working button.

 ■ From the menus, choose Edit>Pick Working Frame and select the 
frame to activate.

 ■ Press Alt+W (default hotkey) and choose the desired frame 
from the Object Selection dialog.
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Frame Properties

Frames, like virtually all entities in SA, have properties associated with 
them.

To View a Coordinate Frame’s Properties:

Do one of the following:

 ■ Right-click the frame in the SA tree or graphical view and 
choose Properties.

 ■ Double-click a frame in the SA tree.

 ■ Click the Object Properties icon in the Main Toolbar, then dou-
ble-click a frame in the graphical view (Figure 10-4).

 ■

Figure 10-4. The Frame 
properties dialog.

Collection. Indicates the collection in which the frame resides.

 ■ Name. The name for the coordinate frame.

 ■ Notes. The notes field allows you to add text-based notes to a 
coordinate frame, which you can reference at a later time.

 ■ Frame Axes. By clicking on the X, Y, or Z buttons, you can view 
the projected angles for the selected coordinate axis, present-
ed relative to the working coordinate frame (Figure 10-5).

Projected Angles can be reported for most any object, but unlike 

Figure 10-5. A frame’s prin-
ciple projected angles.
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frames, these default Projected Angles are reported for the Z axis of 
that object only. Projected angles represent the 2D component of the 
vector or line as projected onto the respective planes of the reporting 
frame (Figure 10-5). 

Figure 10-6. Visualizing Pro-
jected Angles for a line or axis     

 ■ Custom Size. Enable this option to assign a custom size to the 
coordinate frame, and enter the size in the resulting text field.

 ■ Make Working. Sets the coordinate frame active so that it be-
comes the working coordinate frame.

 ■ Transform. Opens the transformation dialog to adjust the po-
sition and orientation of the frame.

 ■ Color. Opens the color dialog so that you can assign a new col-
or to the coordinate frame.

 ■ Update. Updates SA with any changes in the object properties 
without actually closing the Frame dialog.  Note that closing 
the dialog also applies changes to SA.

 ■ Menu. Exposes object-specific menu options. This is equiva-
lent to right-clicking the object in the tree.

 ■ Close. Closes the properties dialog.

Note:  The assigned color of 
the frame is only shown 

when it is not the working frame.
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Frame Construction

SpatialAnalyzer  offers many methods for constructing Frames. To 
fully understand frame construction it is important to understand 
the components needed to construct a frame. A frame has four basic 
components: an origin point, primary axis, secondary axis and ter-
tiary axis. A frame can usually be constructed by defining an origin 
point and two of the axes, and the third axis becomes fully defined as 
a result. The simplest and more useful tool for this application is Frame 
Wizard (see section below).

During frame construction many commands will prompt the user to 
define the primary, secondary and tertiary axis. An axis can be de-
scribed by a point or a vector (object direction). When using a point 
to describe an axis, a vector is formed from the origin point and the 
selected point. If an object is selected its normal will be used to de-
fine the axis. The following methods provide several combinations of 
ways in which points and vectors can be defined and use to build a 
frame.

Frame Wizard
Frame Wizard was added to provide a one-stop solution to most 
frame construction needs.  It allows you to interactively define a Pri-
mary and secondary axis to define orientation, and an origin (Figure 
10-7).

Figure 10-7. Example Frame 
Wizard definition.

The selection of these axes and the objects that define them can be 
done in any order. As soon as the frame is fully defined in space it will 
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appear in the graphics. Changes to the objects selection will auto-
matically update the frame in the graphics, providing a preview of 
the final frame. 

Enter
Creates a frame at the origin and orientation of the active frame. The 
transform dialog will appear allowing the user to enter the position 
and orientation values.

Plane, Line, Point (3-2-1)
A 3-2-1 frame consists of a locator point for the origin, line/vector for 
one axis and plane for the second axis (Figure 10-8). The Plane, Line, 
Point Transformation dialog allows control over the axis for the plane 
and line/vector. The user may also specify an alternate coordinate for 
the locator point.

Figure 10-8. The Plane, Line, 
Point Transformation dialog.

Figure 10-9. Points used 
to define a 3-2-1 frame (left) 
and the resulting constructed 
frame (right).

point in xY plane

point defining x axis

Origin

Plane, Line, Line (Sheet Metal Corner)
Uses a plane and two lines to define a frame. A user can select the axis 
for each object selected.

Using Points and Vectors
Example using only three points. Construct>Frame>3 points>Origin, X-
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axis>Point on XY plane

3 Points
Uses three point to describe the origin, primary axis and secondary 
axis.

Z-Axis
Constructs a frame with the Z-axis normal to a plane, circle or a line 
and uses the selected points for origin and X-axis.

On Instrument
This will construct a frame on the instrument base with the Z-axis be-
ing the standing axis. A frame can also be made on the “scope or end 
effector”. This will generate a frame using the probing direction as the 
vector for the Z-axis.

Using Working Frame Orientation
Uses the current active frame orientation to define a new frame. A 
copy can be made by defining a new origin point or maintain the Z-
axis and clock the remaining axis.

3 Planes
Uses three planes to create a coordinate system. User selects X, Y and 
Z planes. The user interface allows control over priority and direction.

Mirror Cube
Often, users wish to construct a coordinate frame based on the faces 
of a mirror cube (see Figure 10-10). The Mirror Cube frame assign-
ment method provides a convenient method for repeatedly and ac-
curately locating a coordinate frame with two instruments (typically 
theodolites). SpatialAnalyzer contains a powerful mirror cube frame 
assignment tool.
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Figure 10-10. The Mir-
ror Cube Coordinate Frame 
dialog.

To accomplish a mirror cube frame assignment, point two theodolites 
at the mirror cube and collimate the instruments with the mirror fac-
es. Record a shot from each theodolite at the cube using the same 
target name, just as if you were shooting the mirror as a target. If you 
desire reversed shots, reverse the scope and take another shot, or 
take multiple shots in each face. In SpatialAnalyzer, select Construct, 
Frame, and Mirror Cube. You will be prompted to select the target for 
the mirror. Pick the common target name you used for the measure-
ments. The mirror cube frame assignment dialog will appear. At this 
point, you may press the Create Frame button to make the coordinate 
frame, or you may change the options.

Possible Options:

 ■ You may select which instrument represents the X-axis of the 
coordinate frame.

 ■ You may select or deselect specific shots from each instrument. 
When there are multiple shots, their vector directions are aver-
aged to calculate the vector displayed below the measurement 
box.

 ■ The check box for coordinate axes determines whether the 
axes of the frame are outward along the theodolite vectors or 
inward toward the theodolites.

 ■ The Axis weighting box allows you to control the distribution 
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of the errors between the two axes.

 ■ Set the Cube face angle (normally 90 degrees). Press Compute af-
ter doing this to update!

 ■ The difference between the cube “ideal” angle and the theodo-
lite vector angle will be displayed.

 ■ Use the slider bar to control how far the frame axes are away 
from the theodolite axes. Sliding the bar to the left places more 
of the error on the “right-side” instrument.

 ■ Choose carefully when distributing the error. In some cases, it 
may be better to have no error on one axis since it is difficult to 
tell if the “error” is coming from the theodolite measurements 
or the mirror cube itself.

On Object
Constructs a frame with the Z-axis normal to the selected object.

Fit to Coordinate Components
In this method of frame assignment, we assume that we have several 
points which share a known X coordinate, several points which share 
a Y coordinate, and several points which share a known Z coordinate. 
This is often used in a factory setting where a designer has established 
a reference block with one face representing a certain XY, one plane 
representing a certain XZ plane, and one face representing a certain 
YZ plane. Initially the user will be prompted for the points of known X 
value, then Y and Z in turn. After selection of the points is completed, 
the user will see the dialog shown below. Enter the known values and 
hit OK. The frame assignment will be made.

Average of Other Frames
Creates a frame based on the average of selected frames. Usually used 
to create an average between gravity frames.

Copy and Make Left-Handed
Makes a copy of the selected frame and prompts for the axis to re-
verse.

Frame Sets

Frame Sets provide a merged frame format that allows many individ-
ual frames to be saved as part of a single object, much in the same 
way point clouds record the point information. Using Frame Sets pro-
vides the advantage of keeping the tree manageable and allowing 
many more frames to be measured in a single job file at faster rates 
(Figure 10-11). 
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Figure 10-11. Frame Set 
Properties dialog

Measuring with Frame Sets
Frame Sets can only be recorded as part of a 6D Scan, but is available 
for any measurement device that can record measurements as frames. 
Single Discrete measurements will still create individual frames. 

This method of data capture is an option that must also be turned 
on through the right-click Frame Category menu by selecting Enable 
Frame Set Scan Mode as shown here (Figure 10-12): 

Figure 10-12. Enable Frame 
Set Mode must be enabled to 
record Frames in Frame Sets

Individual Frame Selection
Double left clicking on a single frame in the graphics provides the 
ability to select a single frame from within the frame set. Doing so 
provides direct access to the transform and time stamp recorded with 
that particular frame measurement. 
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Time stamps are also recorded as a fundamental property of a frame 
set, when available from the instrument, and reflect the instrument’s 
own controller time. This controller time is quite accurate and reflect 
s the time from the beginning of the scan. 

Figure 10-13. Individual 
Frame Selection from within a 
Frame Set

By pressing Copy the transform is saved   and using  Construct>Frames>Enter 
then provides the ability to use Paste in the frame transform to easily  
construct an exact duplicate of any individual frame in the frame set. 

Full Ascii Predefined format Frame support is also available in both 
import and export for frame sets.
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Locations and Measurement
For more detail on points and point measurements refer to the Chap-
ter on “Points” on page 197.

Point Group

When points are created (constructed or measured), they are placed 
into point groups, often referred to just as groups. Point groups act as 
“containers” to hold points, and are best used to organize measured 
data in a logical manner.

Figure 11-1. Point groups as they 
appear in the tree.

point Group Category

“drift 0” point Group

targets

Other point Groups

Point groups are listed under the Point Groups category in the treebar 

Anything that has both a position and orientation in space—with the 
exception of instruments—is considered an object in SA. In this chapter, 
we’ll discuss how to work with objects, and what you can do with them.

Geometry
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(see Figure 11-1). Each individual point group can be expanded to 
reveal the contained points by clicking the disclosure triangle next to 
the point group name. Click the triangle again to collapse the list of 
points.

A point group is an object, whereas an individual point is not. As such, 
the point group can be moved, scaled, rotated, mirrored, etc. When 
a point group is manipulated in this manner, all of the points inside 
the group are treated as a rigid body. For example, if a point group is 
scaled by a factor of 2, the space between the points inside the group 
will be doubled. In Figure 11-2, a point group has been copied, then 
translated up in the Z direction by 10 units.

Figure 11-2. A point group has 
been copied and translated in the posi-
tive Z direction.

Original Group

Copy

If a point group contains targets, and the point group is moved, then 
the targets will temporarily convert to constructed points.  You can 
revert these constructed points back to targets (and their original lo-
cations relative to the instrument) by using the Analysis>Re-Compute 
Targets From Shots command.

Points will also inherit some of the properties of their containing 
group. For example, an object color can be assigned to the point 
group, and all points will inherit the color of their containing group. 
If a point group is hidden, then all of the points inside the group are 
hidden as well.

Point Clouds and Meshes

Refer to the chapter on “Point Clouds” on page 255. Cloud points are 
the most efficient way to store large data sets that contain millions of 
measurements.
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Frames and Coordinate Systems

SpatialAnalyzer allows you to create a virtually unlimited number of 
coordinate frames (referred to as “frames” in SA), each representing a 
different aspect of your job that is important to you. It also allows you 
to actively measure 6D postions as frames.

Refer to the chapter on “This Page Intentionally Left Blank.” on page 
324. 

Objects vs. Geometry Relationships
Spatial Analyzer provides the capability to build both static and 
dynamic points and geometry. For example, a cylinder can be con-
structed from a print at a defined location with a preset length and 
diameter, or dynamically update as measurements are taken. In order 
for geometry to dynamically update a relationship is used to connect 
the list of points measured with the object that is fit to those points. 
However, the object that is build is the same in each case and will be 
described here. For more information on Geometry Relationships and 
dynamic features refer to “Geometry Relationships” on page 508.  

Lines

Properties

 ■  Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ End-Point Method. Enter two point coordinates to determine 
length, position and orientation of the line.

 ■ Ray Method. Control the length or the transformation of the 
line.

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angles represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Reverse. Reverses the normal direction of the object.

 ■ Shift Ends. Enter values to shift beginning and end point along 
the vector of the line.

 ■ Color. Opens color dialog and allows the object color to be 
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changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit line for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
This will allow you to enter the end-points of the line or designate a 
direction and a length. These values are entered using the Line Prop-
erty dialog.

2 Points
Constructs a line between two selected points. The lines direction is 
from the first to second point.

Mutual Perpendicular
This function will ask for selection of two lines. It will then find the 
closest point to the intersection between those lines and build a line 
that passes from one line, through this point, to the other. 

Projection, Line to Plane / Circle
After selecting either a plane or a circle as the destination, you will 
be prompted to select the line you wish to project. A new line will be 
created on the projection XY plane of the selected object.

Between a Point and a Line
This function creates a line between a user-selected point and a line.

2 Plane Intersection
A line is created at the intersection of two planes. If the planes are 
parallel, the function reports that the line can not be created.

Center of Cylinder
Constructs a line from the cylinder end points and inherits the cylin-
der’s direction.

Center of Slot(s)
Builds a line defining the axis of the slot. Its extents will define the 
center points of each radii defining the ends of a rounded slot or con-
nect to the center of each straight end section of a square slot.
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Along Frame Axes
Constructs a line down each axis of the working frame.

From Instrument Shot
Creates a line from a measured point and its associated instru-
ment.  The point selected must be a measured point.

Normal to Object(s)
Creates a line normal to an object. All objects (plane, line, cylinder, 
etc) have a normal direction. The line created will represent that nor-
mal direction.

Normal to Objects, through Point
Creates a line parallel to the selected object’s normal and intersects 
to selected point.

Parallel to Line, through Point
Creates a line parallel to the selected line and pass through the se-
lected point.

Cross Product
The cross product is a function that takes two lines (vectors) and pro-
duces a line that is perpendicular to them. Imagine selecting two 
lines that define the Z and X axes of a frame, this function will built 
the Y axis line. 

Bisection of 2 lines
Builds a line defining the average or mid line between the two se-
lected lines. 

From a Vector Group
Creates lines from each vector in a vector group.

From 2 Groups (name matched)
Much like a group to group query, this function will build a set of lines 
(rather than vectors) linking the points in each group with common 
names. 

From CAD Surfaces
This function, like construct circle from CAD surfaces, finds a set of 
holes in a selected surface within a specified size rage. It then builds 
the hole axes as individual lines. 

From CAD Faces
Allows user selection of individual CAD faces. When a cylindrical CAD 
face is selected, it will build the center axis of the cylinder defined by 
that surface face. 
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Circles

Properties

 ■

Figure 11-3. The properties dialog 
for a circle.

Collection. Specifies collection name where object resides.

 ■ Name. Object name

 ■ Radius. Radius of circle

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angles represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.

 ■ Radial Normal Direction. Reverses the normal radial vector 
direction of the circle.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Reverse. Reverses the normal direction of the object.

 ■ Transform. Opens the transformation dialog.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.
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Construction

Fit to Points
Constructs a best-fit circle for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs a circle where the normal is in the Z-axis of the working 
frame. Use the Circle Properties dialog to edit parameters.

Maximum Material Condition (from Scan 
Patch)

Creates a best-fit circle with a diameter that bounds all of the selected 
points. All of the points will either be touching the circle or inside of 
the circle.

From CAD Surfaces
Uses selected CAD surfaces to look for circular segments and creates 
circles based on the search criteria.

Figure 11-4. Creating circles from 
surface holes.

 Normal to Object, Centered at Point
Creates a circle using the selected object’s normal and is centered at 
the selected point.

Planes
The position of a plane is reported differently than other objects. We 
report the position and orientation of a plane using ABCD notation.  
Because the origin and rotation of a plane in space  is not clearly de-
fined,  ABCD is used as a simplified expression of a full transform.  ABC 
is the unit direction vector for the plane and D is the distance from 
the reporting frame origin to the closest point on the reported plane 
(Figure 11-5).
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Figure 11-5. ABCD Definition

Construction

Fit to Points
Constructs a best-fit plane for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs a plane where the normal is in the Z-axis of the working 
frame. Use the Plane Properties dialog to edit parameters.

Normal to Object, Through Point
Plane created normal to a selected object and passes through a se-
lected point.

Normal to Line, Through End
A plane is created that is normal to the line and passes through a se-
lected end of line.

Mirror from Two Measured Points
The mirror plane function is used to determine the location of a mir-
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ror by measuring a point both directly and through the mirror.

1. Pick the instrument.

2. Pick the point measured directly (not through mirror).

3. Pick the virtual point that is really the same point, but mea-
sured through the mirror.

SA creates a plane representing the mirror location (see Figure 11-6 
on page 333). You can make a frame on this plane if needed.

Figure 11-6. Creating a plane 
from two measured points using a 
mirror.

If the points used in the construction have uncertainty fields 
(Analysis>Coordinate Uncertainty>Create Point Uncertainty Fields), SA will au-
tomatically compute the uncertainty of the mirror plane and add the 
results to the notes field for the constructed plane.

Establish Bounding Planes for Points
Creates two planes parallel to the selected plane and are spaced so 
that they bound the selected points.  

From Surface Faces
Creates planes from the selected surface faces.

Slots

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.
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 ■ Length. Controls the full length or the slot from end to end, in 
both square and rounded slots (not circle center points). 

 ■ Width. Defines the distance across perpendicular to the length.

 ■ Round or Squre. Round slots are defined as two half circles 
connected with two tangent lines, where as a square slot is 
rectangular. A slot can be defined in either form and draw in 
either from.   

 ■ Projected Angles. Displays the Principle Projected Angles dia-
log. These angle represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Reverse. Reverses the normal direction of the object.

 ■ Transform. Opens the transformation dialog.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object-specific menu options. Emulates right-
clicking the object in the SATreebar.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit cylinder for the selected points. See the Geom-
etry Best-Fit section for more information.

Enter
Constructs a cylinder where the normal is in the Z-axis of the working 
frame. Use the Cylinder Properties dialog to edit parameters.

From Surface Faces
Constructs a slot by searching the surrounding faces of a click point 
on a CAD model. The inner cylindrical or planer faces should be se-
lected for this process. 
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Ellipses

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Transform. Opens the transformation dialog.

 ■ Major Axis Radius/Minor Axis Radius. The major (long) and 
minor (short) axis lengths (Figure 11-7).

 ■

Figure 11-7. The major/minor 
axes of an ellipse.

Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Update. Updates SA with any changes in the object properties.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

Construction

Fit to Points
Constructs a best-fit ellipse for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs an ellipse about the working frame. Use the Ellipse prop-
erties dialog to edit parameters.

Cylinders
Cylinders can be displayed either using a full cylinder representation 
or using a cylinder slice, displaying measurement coverage. This cov-
erage display is an option controlled from the User Options, display 
tab, Geometry control. When enabled the Theta Extents are set when 
the cylinder is fit to points. The length of a cylinder is always displayed 
based upon the extent of the measurements. 
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Figure 11-8. Cylinder cover-
age display is optional for measured 
cylinders.

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Transformation Method. Controls the length or the transfor-
mation of the cylinder.

 ■ End-Point Method. Enter two point coordinates to determine 
length, position and orientation of cylinder.

 ■ Diameter. Diameter of the cylinder.

 ■ Surface Normals. Reverses the surface normal direction.

 ■ Theta Start in degrees. The starting rotation of the cylinder 
display when displaying measurement coverage.

 ■ Theta Span in degrees. The span of display of the cylinder 
slice when displaying coverage. 

 ■ Enable Theta Extent Mode. This check box option enables 
coverage display to be enabled or disabled for a particular cyl-
inder.

 ■ Top End Cap. When enabled the upper end cap of the cylinder 
will be displayed.

 ■ Bottom End Cap. When enabled the lower end cap of the cyl-
inder will be displayed, the origin end.

 ■ Projected angles. Displays the Principle Projected Angles dia-
log. These angle represent the projection of the object normal 
vector onto the coordinates planes of the active frame.

 ■ Draw. Displays the normal vector in the graphics.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Reverse. Reverses the normal direction of the object.
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 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object-specific menu options. Emulates right-
clicking the object in the SATreebar.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit cylinder for the selected points. See the Geom-
etry Best-Fit section for more information.

Enter
Constructs a cylinder where the normal is in the Z-axis of the working 
frame. Use the Cylinder Properties dialog to edit parameters.

From Surface Faces
Constructs a cylinder from a click point on a CAD model. The inner 
cylindrical should be selected for this process. 

Along Line(s)
Constructs a cylinder from a selection of lines. The orientation and 
length of the of the newly constructed cylinders will match that of 
the selected line and a prompt will allow manual entry of the cylinder 
diameter(s). 

Spheres

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Graphical Settings. Control the length, span and facets of the 
graphical representation of the Sphere.

 ■ Radius. This value controls the radius (diameter) of a sphere.

 ■ Surface Normals. Reverses the surface normal direction.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Transform. Opens the transformation dialog.
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 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit sphere for the selected points. See the Geometry 
Fit section for more information.

Enter
Constructs a sphere at a position and orientation relative to the work-
ing frame. Use the Sphere Properties dialog to edit parameters.

From Surface Faces
Constructs a sphere from a click point on a CAD model. The spherical 
face should be selected for this process. 

Cones
Cones can be displayed either using a full cone representation or us-
ing a cone slice, displaying measurement coverage. The length of a 
measured cone is displayed based upon the extent of the measure-
ments. 

Figure 11-9. Cone coverage 
display which uses the cut length to 
limit the length display to the measured 
extents of the cone.
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Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Length. Length of the cone measured from the apex.

 ■ Cut Length from Apex. Hidden segment of the cone used to 
reduce graphical display to the measured segment of the cone.

 ■ Number of Height. Number of graphical segments drawn 
along the length of the cone.

 ■  Theta Start in degrees. Angle at which the graphical display 
begins

 ■ Theta Span in degrees. The span of the graphical display.

 ■ Number of Theta. Number of segments drawn around a cone.

 ■ Included Angle. The entire angle that contains the taper.

 ■ Surface Normals. Reverses the surface normal direction.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Transform. Opens the transformation dialog.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Update. Updates SA with any changes in the object properties.

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

 ■ Close. Closes the object properties dialog.

Construction

Fit to Points
Constructs a best-fit cone for the selected points.  See the Geometry 
Best-Fit section for more information.

Enter
Constructs a cone about the working frame, use the Cone properties 
dialog to edit parameters.

From Surface Faces
Constructs a Cone from a click point on a CAD model. The conical face 
should be selected for this process. 
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Paraboloids

Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Graphical Settings. Control the length, span and facets of the 
graphical representation of the cone.

 ■ Geometry Parameters. Control length and alternative param-
eters.

Construction

Fit to Points
Constructs a best-fit paraboloid for the selected points. See the Ge-
ometry Best-Fit section for more information. 

Enter
Constructs a Paraboloid about the working frame, use the Plane prop-
erties dialog to edit parameters.

Toruses
Toruses are defined as a circular section revolved about an axis to 
form a donut shape. These objects can come in hand in modeling 
pipe runs and other circular sections. 

Figure 11-10. Example Toruses fit 
to points and cloud points
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Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Major Radius. The radius of the rotation of the torus

 ■ Minor Radius. The radius of each circular cross section of the 
torus. 

 ■ Number of Major Segments. Number of graphical segments 
drawn perpendicular to the major radius of rotation. 

 ■ Number of Minor Segments. Number of graphical segments 
drawn about the axis of rotation 

 ■ Theta Start. Graphical starting point about the object’s base 
frame.

 ■ Theta Span. The degree of rotation of the graphical represen-
tation. 

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc...

 ■ Transform. Opens the transformation dialog.

 ■ Color. Opens color dialog and allows the object color to be 
changed. 

 ■ Menu. Exposes object specific menu options. Emulates right-
clicking the object in the tree.

Construction

Fit to Points
Constructs a best-fit torus for the selected points. See the Geometry 
Best-Fit section for more information.

Enter
Constructs an torus about the working frame. Use the torus proper-
ties dialog to edit parameters.

Perimeters
Perimeters appear graphically much like a series of connected lines 
that define a 3D volume. Perimeters are used with scanning devices 
to define a region of interest for measurement purposes.
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Properties

 ■ Collection. Specifies collection name where object resides.

 ■ Name. Object name.

 ■ Closed Perimeter. When unchecked the perimeter is opened.

 ■ Notes. Contains information entered by user or information re-
garding construction method, fit, etc.

 ■ Color. Opens color dialog and allows the object color to be 
changed.

 ■ Apply. Updates SA with any changes in the object properties.

 ■ Cancel. Closes dialog without saving changes.

Construction

Manual Point Selection
This command will create an open or closed perimeter object from 
selected points. Its purpose is to provided a boundary for scanning 
instruments. The below example shows perimeters to capture data 
from a targetless scanner.

Figure 11-11. Perimeters defin-
ing the boundary of measurements 
from a total station.

From CAD Faces
This option will build a bounding perimeter for each and every sur-
face face selected. This makes it quite easy to identify specific CAD 
faces to be measured.

Bounding Surface from Instrument Viewpoint
When a scan of an entire model is needed, this option delivers. It uses 
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the base frame of the selected instrument as the viewpoint, allows a 
selection of a selection of surfaces and builds a bounding perimeters 
that is grown 10% larger than the model to ensure complete surface 
coverage from the instruments perspective.

Graphical Entities
SA offers the ability to build a selection of graphical objects that are 
primarily used for display purposes. Once built these are listed in the 
tree under the Graphical Entities category. These include:

Cylindrical objects such as:

Cylinder Slice

Figure 11-12. Creating a cylinder 
slice.

Pie Wedge

Figure 11-13. Creating a pie 
wedge.
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Pipe

Figure 11-14. Creating a pipe.

Boxes

Tapered Pipe

Figure 11-15. Creating a tapered 
pipe.

Sphere Section

Creates a spherical section. Use the Sphere Section dialog to edit pa-
rameters.
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Figure 11-16. Creating a spheri-
cal section.

Ellipsoid
Ellipsoids can be constructed and displayed with a set length in X, Y, 
and Z and the transform edited.

Boxes 
Box display options include:

 ■ Box. A box has a length width and height as well as a position 
transform. 

 ■ Tapered Box. A tapered box offers a front and back face length 
and width control as well as a height and transform. 

 ■ Rounded Box. A rounded box offers an Length, and two width 
parameters that control the radius of the ends. A depth and 
transform is also available. 

 ■ Arched Box. An arched box has 1 rounded end and offers 
length, width and depth controls along with a transform. 

 ■ Rounded Plate. Defines a box with 4 rounded corners of a 
given radius.

Pyramid
A pyramid offers Length, Width, Height and Transform controls. 
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Surface Grouping
Surfaces in SA are entities that exist in the SA tree bar and can be se-
lected and colored individually. Each surface may be composed of 
many surface faces. These individual faces can only be selected or 
handled independently from the entire surface in certain modes or 
with particular commands. In general when querying points to a sur-
face for example, the points are compared to the closest face includ-
ed in the selected surface.  

Therefore surface grouping is a process of tree management and ease 
of access. 

Any set of surface faces or set of surfaces may be combined into a 
single surface or split into separate surfaces. The process of combin-
ing surface faces is referred to as merging surfaces, and the process of 
separating surfaces is referred to as dissecting surfaces.

The advantage of have a merged surface is that it simplifies the tree. 
When surfaces are merged, they appear as a single surface in the tree, 
therefore there are less surface entities to wade through when mov-
ing around in the tree. This also can make selection easier, because 
selecting a single surface selects all of the faces that are part of that 
merged surface.

Working with CAD surfaces is a discipline in itself. As more and more in-
dustries move toward computer model-based representations and away 
from paper drawings, the ability to work with surfaces grows every year.

Working With 
Surfaces
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However, merged surfaces have some limitations. A merged surface 
cannot have its normals corrected—so, if you need to reverse some 
surface faces, the surface must be dissected first.

Constructing a Merged Surface

The process of merging a surface involves selecting individual surfac-
es and combining them into a single surface in the tree that is treated 
as a single surface. When merging surfaces, you have the option of 
keeping the original surfaces in addition to the new merged surface, 
or deleting the original surfaces. In addition, you also have the option 
of hiding the original source surfaces as well.

To Merge Surfaces:

1. From the menu, select Construct>Surfaces>From a Collection of Sur-
faces.

2. Select all of the surfaces that you’d like to merge.

3. The Group Surfaces dialog appears (see Figure 12-1).

4. Select the desired options, then click OK. A new surface named 
Merged Surface xxx will be created.

Figure 12-1. Merging a set of 
surfaces.

 ■ Hide Original Surfaces. When selected, the original source 
surface faces will be hidden, but not deleted.

 ■ Delete Original Surfaces. When selected, the original source 
surface faces will be deleted.

 ■ Sew Faces Together. When selected, adjacent surface faces 
which lack tangency (they do not smoothly flow from one sur-
face face to another) will be stitched together in accordance 
with the sewing tolerance.

 ■ Sewing Tolerance. The maximum normal deviation from one 
surface face to the next in which those adjacent surface faces 
will be stitched together if Sew Faces together is enabled.

Dissecting Surfaces

Dissecting surfaces is the inverse operation of merging. Given a 
merged surface containing two or more surface faces, dissecting that 
surface will extract the selected faces and separate them as unique 

Warning:  Since sewing 
faces together can 
change the topology of a 

CAD model (usually undesirable 
in metrology), it is strongly rec-
ommended that you avoid this 
option unless you have a very 
valid reason for using it.
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surfaces in the tree. Dissecting a surface leaves the original surface 
intact—it will be hidden for you in the tree.

To Dissect an Entire Surface:

1. From the menu, select Construct>Surfaces>By Dissecting 
Surfaces>Entire Surface.

2. Select the surface to dissect.

To Dissect Specific Surface Faces from a Surface:

1. From the menu, select Construct>Surfaces>By Dissecting 
Surfaces>Select Faces.

2. Select the individual faces to extract. The original surface will 
remain untouched, and the extracted faces will be created as 
separate surfaces.

Show Selected Faces Command

In the right-click menu of the Surfaces category in each collection is 
an option to Show Selected Faces. This option provides a shortcut to ac-
cessing  only the surface faces of interest from a larger CAD model. 
When selected it will: 

1. Prompt the user to select CAD Faces graphically from any of 
the visible surfaces, and press enter when done.

2. When selection is complete a new surface will be created us-
ing a copy of the selected CAD faces in the working collection  
and hide all the other surfaces. 

Figure 12-2. Show Selected Faces
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Duplicate Surface Faces

Occasionally, you may encounter one or more surfaces that have 
overlapping surface faces. This may be a problem in the source mod-
el, a result of how the surface was imported, or simply a result of ac-
cidentally duplicating surface faces.

Duplicate surface faces can cause confusion in analysis, so it’s best to 
clean these surfaces up before using them. Fortunately, SA has a com-
mand to detect and delete duplicate surface faces.

To Delete Duplicate Surface Faces:

1. From the menu, select Edit>Remove Duplicate Surface Faces.

2. Select the surfaces to examine.

3. Provide a coincidence tolerance. This indicates how close two 
overlapping surfaces must be to be considered duplicates.

4. If duplicate faces are found, confirm the deletion.

Surface Normal Conditioning
As explained in “SA Fundamentals”, the normal direction of surfaces is 
critical to how offset compensation is applied to your measurements. 
An incorrectly-oriented surface normal can lead to dramatically in-
correct analysis results. CAD surfaces should always have their nor-
mals facing away from the material of the part. That is, the side on 
which you approach the surface with a probe must be defined as the 
positive side of the surface.

The use of surface backside coloring (see “The Graphical View”) en-
ables you to determine if any surface normals are reversed. When-
ever you import a CAD model, you should therefore check to ensure 
that surface normals are correct, and any incorrect normals should be 
fixed.

There are three methods for flipping surface normals: indicating 
point on positive side, reversing normals, and auto-reversing from 
viewpoint. All of these methods require a surface to be dissected into 
its individual surface faces before they are reversed.

Indicating Point on Positive Side

One method for correcting surface normals is to use a reference point 
as an indicator for whether that point should end up on the positive 
or negative side of a surface. This is similar to some metrology soft-
ware that expects an additional measured point to indicate the direc-
tion of offsets for measured geometric surfaces.
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To Condition Surface Normals by Indicating Point on Positive:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 348.

2. From the menu, select Edit>Surface Normal Conditioning>Indicate 
Point on Positive (or negative) side.

3. Select the point to serve as the reference point.

4. Select the surfaces to consider.

5. At the Decision dialog, indicate whether the reference point 
should end up on the positive or negative side of the surface.

Reversing Surface Normals

The most straightforward method for reversing surface normals is to 
explicitly select the surfaces you’d like to reverse. The normal direc-
tion of each selected surface will be flipped.

To Reverse Surface Normals:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 348.

2. From the menu, select Edit>Surface Normal Conditioning>Reverse 
Surface Normals.

3. Explicitly select the surface faces you’d like to reverse.

Auto-Reversing Surface Normals

SA can use the current view orientation to automatically reverse a set 
of surface faces. This has the advantage of reversing a large number 
of surfaces at once, without requiring you to select the specific sur-
faces you’d like to fix.

With this command, you orient the view so that you can see the sur-
faces you’d like to correct. You then select these surfaces, and the key 
is that you can also select surfaces which are already facing the prop-
er direction. SA will go through each selected surface, determine if 
it’s visible from the current viewpoint, and then reverse it if its normal 
does not generally point toward the viewpoint.

To Auto-Reverse Surface Normals from Viewpoint:

1. Dissect the surface as described in “Dissecting Surfaces” on 
page 348.

2. From the menu, select Edit>Surface Normal Conditioning>Auto Re-
verse Surface Normals from Viewpoint.

3. Orient the view so that you can see the surface faces you’d like 
to correct.

Note:  This method currently 
compares the reference 

point to the middle of each sur-
face face. Therefore, it is not 100% 
reliable.

Note:  You may need to per-
form this operation from 

several different viewpoints.

Note:  Occasionally, you may 
need to manually reverse a 

stray surface face.
Tip:  If there is not a large 
number of surfaces, it’s gen-

erally faster to just select all sur-
faces using rectangular selection 
or the F2 window versus trying to 
select only those surfaces that 
need to be fixed.
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4. Select the surfaces you want the command to consider. (It’s 
OK if these surfaces are already facing the correct direction).

Surface Construction Options

From a Collection of Surfaces

Merges selected surface into one surface entity.

By Dissecting Surfaces

Dissects the surface into individual surfaces. The user has the option 
to dissect any surface or pick surface faces to dissect.

Select Faces by Projecting Points

Creates separate surfaces by checking point projections. This can be 
useful for speeding analysis when trying to reduce surface faces to 
analyze.

Figure 12-3. Creating surfaces by 
projecting points.

From Objects

Creates surfaces from supported SA Geometry. Examples are plane, 
cylinders, etc...

From Plane, Cylinder, Sphere, and Cone

Performs same functionality as above, these are just geometry spe-
cific. The above command is more universal.

Tubular Surface from a B-Spline

Creates a tubular surface that uses the B-Spline path. Users has the 
ability to enter Tubular Diameter.
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Advanced Surface Fitting

There are several more advanced surface construction tools that are 
available and discussed in more detail in the Analysis Chapter. Please 
refer to “Advanced Surface Fitting” on page 498.

 ■ From Point Groups. This option builds a surface using sequen-
tial point groups.  

 ■ From B-Splines. This option builds a surface from sequential 
B-splines.

 ■ From Plane and Closed B-Spline. This function builds a 
bounded surface from a plane and a closed B-spline. 

 ■ Fit from Bounding Curves and Internal Points. This option 
builds a surface from a curve and measurements.

 ■ Fit from Nominal Face and Actual Data. This function de-
forms an existing surface to fit measurements. 

Meshing Options are also available. While not a true surface, a mesh 
provides a means to create a triangulated representation of a true 
surface in a light weight format “Meshing Point Clouds” on page 305. 

B-Splines

Properties

A B-Splines, which can  be referred to as a curve interchangeably, de-
fines a polynomial trajectory through space.  It visually expresses a 
polynomial curve of a given degree and is built from a series of  “con-
trol points” and the minimal smooth bends between them. Curve 
properties provide basic spline definition parameters and allow di-
rectional arrows to be drawn.
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Figure 12-4. The B-Spline curve 
properties dialog.

B-Spline Construction

From Points

Figure 12-5. A B-Spline fit to a 
series of measured points.

Creates a B-Spline curve from selected points using either an interpo-
lated fit or cubic fit (see Figure 12-6 and Figure 12-7).
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Figure 12-6. B-Spline Fit options.

Fit Style. A B-Spline can be fit to points exactly with a specified number 
of control points and degree of curvature.  

 ■ Interpolation. An interpolated curve will fit each selected point 
exactly and find the best solution to get from one to the next 
in order to minimize the degree of curvature. 

 ■ Fit with.  Fitting with a specified number of Control Points and 
Degree of Curve allows a user to define the complexity of the 
curve. The points will be fit as best they can within these con-
straints.

 ■ Curve Style. An Open curve starts at the first point and ends at 
the last. Closed B-splines will end at the beginning point of the 
B-spline. 

Point Ordering. The direction and path of the B-spline is determined by 
the ordering of the points. The user can select the point ordering as 
follow:

 ■ Use Selection Order. The curve will fit the selected points in 
the order selected by the user. **Note that when F2 selection is 
used the database (tree) order will be applied. 

 ■ Use Closest Neighbors (First selection is starting point). 
This option starts with the selected point and fits the points 
based upon sequential proximity. 

 ■ Use Closest Neighbors Searching in direction of curve. This  
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option looks for the closest neighbor following the direction of 
the curve as it is built. This may ignore a closer point to priori-
tize a point closer to the direction of the curve. 

Figure 12-7. Fit results when ap-
plying different Point Ordering options: 
1. Use Selection Order (Green); 2. User 
Closest Neighbor (Red); 3. Searching in 
direction of curve (Blue).

 ■ Ignore Points within. This option allows points in very close 
proximity to be ignored, reducing the complexity of the result-
ing curve.

 ■ Termination Conditions. When enabled, the B-Spline creation 
will terminate if a gap of a prescribed distance is exceeded.

Tesselation Options. B-Splines are always mathematically perfect but, 
due to rendering limitation, must be drawn graphically as intercon-
nected line segments. This additional control allows particular splines 
to be drawn at higher or lower resolution. 

From Surface
Creates B-Splines from surface boundaries (Figure 12-8).
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Figure 12-8. Creating B-Splines 
from the boundaries of a surface.

From Circles
This command directly converts a circle or collection of circles into 
closed b-splines.

From a Collection of B-Splines
Creates one single B-Spline from the selected individual B-Splines.

From Cloud Cross Section
This command is designed to provide a means to build a fit b-spline 
to a cross section. To do so, it uses a seed (click-point) to define a start 
ing search point. It expects this point to define the end of the cross 
section to build. It then asks for a proximity tolerance used to define 
how large a gap in the cloud data to span and then the number of 
control points to use in the fit. With a larger number of control points 
you will get a closer fit to each of the cloud points, and with a smaller 
number you will get a smoother curve. 

The fit solution will then search through the cloud data in the select-
ed cross section until a gap is reached that is bigger than the proxim-
ity tolerance. Cross Sections that are intended to bridge holes in the 
part for example will need to be built by running the fit command a 
second time and selecting a starting point at the far side of the hole 
to complete the curve (Figure 12-9).
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Figure 12-9. Building additional 
b-splines from cross section clouds

 

To facilitate  building subsequent b-splines the newly constructed b-
spline will be highlighted and an option provided to Accept or Retry 
provided. 

Intersect Surface
Creates a B-Spline from the intersection of two surfaces (Figure 12-
10). This function builds a series of splines defining the direct contact 
curves of each and every surface face within the selected surfaces.  

Figure 12-10. This B-Spline has 
been created by intersecting cylindrical 
and planar surfaces.

 Intersect Plane and Surface
Creates a B-Spline at the intersection of a plane and surface. This func-
tions creates the same spline that would be created from intersecting 
surfaces built from the geometries but allows for unbounded geom-
etry to always intersect.

Intersect Cone and Cylinder
Creates a B-Spline at the intersection of the surfaces of a cone and 
cylinder. This functions creates the same spline that would be created 
from intersecting surfaces built from the geometries but allows for 
unbounded geometry to always intersect. 
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Intersect 2 Cones
Creates a B-Spline at the intersection of 2 cones. This functions cre-
ates the same spline that would be created from intersecting surfaces 
built from the geometries but allows for unbounded geometry to al-
ways intersect.

Polygonized Meshes

From Surfaces

Converts selected surface to a Polygonized Mesh.

From Cloud Points and from Selected Cloud Points

Generates a Polygonized Mesh from selected point clouds or points. 
By default the mesh orientation uses the current Point of View, how-
ever, the working frame can be used as well (Figure 12-11). Enter the 
grid resolution based on point cloud density. Rule of thumb, the data 
density should be four times greater than the grid resolution.

Figure 12-11. Polygonized mesh 
generation settings.
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Figure 12-12. Generating a 
polygonized mesh from a point cloud.

 Colorized Mesh from Point Proximity

Creates a Colorized Polygonized Mesh depicting the error between 
the selected points and the selected surface (Figure 12-13). The col-
orization options can be accessed through the Polygonized Surface 
properties.

Figure 12-13. A colorized graphi-
cal mesh created using proximity of 
measured points to a nominal surface.
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Spatial Analyzer (SA) supports a wide range of measurement devices, 
from PCMM arms and laser trackers to scanners, laser radars, projec-
tors, digital levels, and theodolites. An instrument model in SA con-
tains the basic properties of the instrument and defines its location 
in the workspace. It is the foundation for measurements from a live 
instrument in a single plant, and a new model is added each time the 
live instrument is moved in the real world.

To add an instrument model to SA select Instrument>Add. You will then 
connect your live instrument to this model when taking measure-
ments.

Instruments appear in the treebar under the Instruments category, 
and each instrument is assigned a number (starting from zero), re-
ferred to as the Instrument Index Number. This number appears next to the 
name of the instrument in the treebar (Figure 13-1).

Instruments are the devices that gather accurate measurement data and 
provide a foundation for this data’s position in a digital world. This chap-
ter discusses how to work with instruments in general.

Instruments



362

SPATIALANALYZER USER MANUAL

Figure 13-1. Instruments in the 
tree.

It is very important to keep in mind that instruments are not objects. In 
SA, objects are treated differently than instruments. Commands and 
functions that explicitly ask for objects will not accept an instrument. 
They are completely independent entities.

Figure 13-2. A number of instru-
ments in the graphical view.

For spherical measurement devices (total stations, laser trackers, and 
the laser radar, for example), the position of the instrument defines 
the origin of the instrument’s measurement volume. For a PCMM arm, 
the instrument position defines the base of the kinematic chain of 
linkages leading toward the probe.

When a point is measured by an instrument, the instrument reports 
back a point in its own internal coordinate system. This point is re-
corded in the measured target’s observation details. For spherical 
measurement devices, the coordinate is represented in a spherical 
coordinate system. For a Cartesian measurement device (such as an 
arm), the coordinates are represented in XYZ coordinates.

Instrument Properties
To Access an Instrument’s Properties:

 ■ Right-click the instrument in the tree or graphical view and 
choose Properties from the context menu,

 ■ Double-click the instrument in the tree, or
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 ■ Select Instrument>Properties, and double-click the instrument of 
interest.

The properties for an instrument (Figure 13-3) will vary depending on 
the class of instrument (laser tracker vs. arm vs. scanner, etc.).

 ■

Figure 13-3. The Instrument 
Properties dialog.

Instrument Number. The index number for the instrument 
(referred to as the Instrument Index Number).

 ■ Model. The name assigned to the instrument. (By default, this 
will be the manufacturer’s name and instrument type).

 ■ TCP/IP Socket Port. The TCP/IP port that the instrument has 
been assigned. This is a random port number that is assigned 
by SA.

Sensor Control

The sensor control section allows you to adjust the graphic model 
of the instrument. For spherical devices, you can adjust the vertical, 
horizontal, and distance degrees of freedom. For an arm, you can ad-
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just the rotation value for each link. Other instrument types (such as 
laser scanners) may not have any adjustment at all. After selecting the 
degree of freedom and associated value, click the Apply button to see 
the changes. Or, click the up/down arrows to increment the rotation 
value.

Scale Factor

It may be desirable to apply a scale to an instrument’s measurements 
to account for thermal expansion and contraction of a measured part. 
For example, suppose you have a nominal model that has been de-
signed for 68°F (20°C) conditions. If you are laying off nominal fea-
tures from that model on a hot day--say 95°F (35°C)--then you will 
want to scale the instrument’s measurements down from 95°F to 68°F 
so that the instrument and the nominal model are adjusted to the 
same temperature reference. One way to achieve this is to scale the 
instrument’s measurements.

When an instrument scale factor is applied, all measurements from 
the instrument will be scaled appropriately. For example, an instru-
ment observation that is normally at a radius of 100” from the instru-
ment will be 101” from the instrument at a scale factor of 1.01. Instru-
ments that are currently using a scale factor other than 1.0 will appear 
with a special yellow icon in the tree and will be listed as a scaled 
instrument, as depicted in Figure 13-4.

Figure 13-4. This laser tracker has 
a scale applied.

The scale for an instrument can be set in several different ways. It can 
be set manually (by directly entering a scale factor), set by measuring 
scale bars, or set in a command (such as Instrument>Locate (Transform to 
Part)>Measure Nominal  Points),  which allows you to vary the instrument’s 
scale as part of the best-fit procedure.

To Set an Instrument’s Scale Factor Manually:

1. In the Instrument Properties dialog, click the Set Manually but-
ton.

Warning:  Scaling an in-
strument’s measure-
ments requires caution. 

Once an instrument’s measure-
ments have been scaled, query-
ing one measured point to anoth-
er will not represent the true 
measured real-world distance be-
tween the two points.
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2. 

Figure 13-5. The scaling dialog.

In the Scaling dialog (Figure 13-5), select the enter Scale Man-
ually radio button and enter a scale factor, then click OK.

To Calculate a Scale Based on a Coefficient of Thermal Expansion:

Consider an example of measuring a steel part sitting in the sun, 
which has expanded in the 95°F midday heat. If we want to compare 
measurements against the nominal model for this part, which is at 
68°F, then it is important to scale the instrument’s measurements 
from 95°F (initial temperature) to 68°F (final temperature). This would 
be a situation where entering a scale for the instrument based on a 
CTE could be appropriate. The resulting scale factor will shrink the 
instrument’s measurements so that the measurements can be com-
pared to the 68°F CAD model, effectively removing the differences 
caused by thermal expansion.

1. In the Instrument Properties dialog, click the Set Manually but-
ton.

2. Select the Calculate Scale Based on Cte radio button.

3. In the dropdown, choose the desired material for the part 
that will be measured. If the material of interest is not avail-
able, click the Edit button, which allows you to add, delete, and 
edit materials and their associated coefficients of thermal ex-
pansion.

4. Enter an initial and final temperature. A higher final tempera-
ture will result in a scale increase, and a lower final tempera-
ture will result in a scale decrease.

To Calculate a Scale Based on Measured Scale Bars:

Scaling based on measured scale bars should only be performed 
when the material of the scale bar matches the material of the part to 
be measured, and when the nominal scale bar temperature matches 
the nominal (modeled) CAD temperature of the part. Consider an ex-
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ample of measuring a steel part sitting in the sun, which has expand-
ed in the 95°F midday heat. If a steel scale bar with a nominal length 
of 36” at 68°F is then measured in the same conditions as the part, it 
will also have expanded, and the measured scale bar points will be 
more than 36” apart. Scaling based on this measured scale bar will 
scale the instrument’s measurements down to match the nominal 
(68°F) length of 36”. Subsequent measurements from the instrument 
will now be properly compensated to the nominal 68°F temperature.

1. In the Instrument Properties dialog, click the Set from Scale Bars 
button.

2. If the instrument has measured points that belong to a de-
fined scale bar, the scale factor will be instantly calculated.

3. Review the results of the scale calculation, and click Yes to ap-
ply the scale factor to the instrument.

 ■  Measurements Active. Unchecking this box will deactivate 
all of this instrument’s measurements from target calculations. 
This might be useful, for example, if you’ve measured the same 
point with several instruments, and have found an instrument 
to be out of calibration to the point where its measurements 
are corrupting the overall coordinates of the targets. Re-check 
this box to activate the measurements again. (Note that this will 
require you to recompute targets from shots using Analysis>Re-
Compute Targets From Shots).

Uncertainty Variables

All instruments have error in their measurements, and as a result ev-
ery measurement from an instrument has some uncertainty. Each 
class of instrument (laser tracker, PCMM arm, total station, etc.) has 
different set of uncertainty characteristics. For example, laser trackers 
have uncertainties for the horizontal and vertical encoders, as well 
as an uncertainty for the distance measurement. PCMM arms, on the 
other hand, have an angular uncertainty for each link of the arm. Ad-
ditionally, each instrument within a specific instrument class has dif-
ferent values for the uncertainties. The uncertainty values for a newly 
calibrated laser tracker in pristine condition from a manufacturer will 
be different from those of an old, dirty, poorly calibrated tracker from 
the same manufacturer.

For more information on uncertainty and uncertainty parameters re-
fer to the chapter: “Measurement Uncertainty” on page 699.

Instrument Graphics (PCMM arms only)

PCMM arms have an Instrument Graphics button that appears directly 
under the Edit Uncertainty Variables button. This button calls up the Instru-

Note:  If the scale bar points 
have not been measured by 

the instrument in question, then 
no scale will be applied.



367

CHAPTER 13 ■ INSTRUMENTS

ment Graphics dialog (Figure 13-6).

 ■  

Figure 13-6. The Instrument 
Graphics dialog for portable arms.

Restore Default Graphical Model. The kinematics for a PCMM 
arm are refined as points are measured. These kinematics only 
affect how the arm is depicted in the graphical view--not the 
accuracy of the measurement data itself. Clicking this button 
will restore the default graphical model that has been stored 
with the instrument definition.

 ■ Solve for Graphical Model Using All Measurements in Job. 
This option will consider the measurements that the arm has 
observed, and recalculate the kinematics for the arm.

 ■  Instrument Interface Response Timeout. This value deter-
mines (in seconds) how long an instrument interface will at-
tempt to connect to the instrument until it times out with an 
error, stating that the instrument cannot be found. Enter zero 
to continue checking indefinitely.

 ■ Transform. The Transform button is used to transform (move 
and rotate) the instrument. More information about transfor-
mation can be found in the Move section.

Instrument Communication Controls

Several instrument communication controls have been added to al-
low users to tailor performance based upon their computer perfor-
mance and instrument requirements. These include:

 ■ Instrument Interface Response Timeout. This value is used 
to define how long SA waits for a response from an instrument 
in seconds. If no response is received after the specified du-
ration a break in communication will be assumed to have oc-
curred such as might be caused by a firewall turning on or a 

Note:  The Instrument 
Graphics options only affect 

how the PCMM arm is depicted in 
the graphical view. They have no 
effect on measured data.
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cable getting unplugged. Aso, some data transmitted to an in-
strument may be such that the function sending it will wait for 
a response before exiting the function.  This value establishes 
the amount of time the function will wait before it exits on a 
“timeout” condition. 

 ■ Packet Warning Threshold. Measurements from an instru-
ment are stored in packets and processed by SA as fast as 
possible. However, when recording large amounts of data at 
a fast rate a backlog can occur and a user notification can be 
useful. This warning threshold defines a minimum threshold 
below which no warning dialogs will be shown.  This a dy-
namic threshold which determines, based upon the number 
of packets processed and the time required to process them, 
how many packets could be expected to be processed over an 
interval of 5 seconds.  

 ■ Packet Bundle Interval. This interval is used to control the 
minimum update rate of the graphics and user interface while 
measuring.  The instrument socket thread will present data for 
the incoming “PendingPacket” buffer as fast as the instrument 
will send them.  The data is only processed upon receiving a 
notification from the instrument socket thread that there is 
data available.  The time interval between these notifications 
will not be less that this time interval.

 ■ Filter Instrument Update Packets. This check box controls 
whether graphical updates from an instrument are stored and 
processed or filtered out and ignored to accelerate data pro-
cessing speeds. If the filter is asserted, only the last instance 
of an update packet will be processed even if there are several 
packets of this sort in the packet bundle being processed.

Instrument Shots
It is often useful to draw instrument shots—that is, the line of sight 
from instruments to their corresponding measurements, as depicted 
in Figure 13-7. Instrument shots (also referred to as shot lines) help 
you visualize which instruments have measurements to which points, 
and also helps with visualizing the angles and distances to your shots, 
as well as the entire instrument network as a whole.
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Figure 13-7. Shot lines for an 
instrument network.

To Control Whether Instrument Shots are Drawn in the Graphical View:

 ■ Toggle the View>Show Instrument Shots setting.

Instrument Shot Modes

There are four modes for viewing instrument shots:

 ■ Draw only last shot of active instruments. Draws only the 
most recent shot from any active instruments.

 ■ Draw all shots. Draws every shot line from every instrument to 
every point (used in Figure 13-7).

 ■ Draw only active (enabled) shots. Any shots which have been 
disabled will not have shot lines drawn—but all others will.

 ■ Draw only inactive (disabled) shots. Any shots which are en-
abled will not have shot lines drawn—but all others will.

To Change How Instrument Shots Are Drawn:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.

3. Select the desired mode from the Mode box.

Shot Colors

In addition to changing the instrument shot mode, you can also set 
the color used for active shots, inactive shots, or the latest (Current) 
update.

To Change Instrument Shot Colors:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.



370

SPATIALANALYZER USER MANUAL

3. Click the Active Shots, Inactive Shots, or Current Update button to indi-
cate which color you’d like to modify.

4. Select a color from the dialog, then click OK.

Angle Only Shots

Instruments that do not measure distance (such as theodolites) can-
not measure a point in 3D space, therefore the shot line length can-
not be determined. A default length of 200 units is used for drawing 
these shots, although you can lengthen or shorten this value as ap-
propriate to the scale of the measurement job.

To Change the Length of Angle Only Shots:

1. Click the User Options icon in the toolbar.

2. In the Display tab, click the Shot Graphics Options button.

3. Enter a length into the Default Length field.

Instruments and Measurements

A unique characteristic to SpatialAnalyzer is the association of points 
to their respective instrument. SA treats an instrument and its points 
as a rigid body. If an instrument is transformed (moved), the instru-
ment and its points will move with it. This is a key concept that is used 
extensively throughout SA. When a point is measured the observa-
tion is built and the link is created. For more details refer to “Measured 
Points” on page 198.  

Objects can also be associated to an instrument. In some cases, such 
as with point clouds and frames, objects are directly handled like 
measured points and the link between them and the instrument can 
be rebuilt if things are moved. This is done using Analysis>Reset Associ-
ated Object Transforms. 

Geometry fit to measure points, all measured from a single instru-
ment station, is also automatically associated with that instrument so 
that when an instrument moves the associate points and objects will 
move as well.

Finally additional objects can be linked to an instrument manually us-
ing Instrument>Object Associations.

XYZ Reference Frame
A special instrument called a XYZ Reference Frame instrument exists for 
the specific purpose of linking things together with in a job file. It 
is tool to link other objects together for monitoring applications. It’s 
position will update automatically to match a specified frame in a job 
file and any associated objects will also move with it. This provides a 
means to take a series of 6D measurements, updating a frame’s po-
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sition and see the resulting associated objects move dynamically to 
match.

Using Instruments
Before you can begin measuring with an instrument, you need to add 
one to your current job.

To Add an Instrument:

Do one of the following:

 ■ From the menus, choose Instrument>Add, or

 ■ Press Alt+I, the default keyboard shortcut, or

 ■ In the Main Toolbar, click the Add Instrument button.

Figure 13-8. The Add Instrument 
to SA dialog.

The Add Instrument to SA dialog (Figure 13-2) will list all available in-
struments that can be used in SA. The instrument list can be filtered 
to only show the instruments that you have added in the past; each 
time an instrument is added to a job, it’s added to this filtered list.

To Switch Between the Filtered Instrument List and the Full List:

 ■ Select the My Instruments or All Instruments radio button.

To Reset Which Instruments Appear in the Filtered List:

 ■ Navigate to the Analyzer Data\Persistence folder and 
delete the My Instruments.bin file.
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Figure 13-9. The options available 
for adding an instrument.

Clicking the Options button opens the Add Instrument Options dialog 
(Figure 13-3). In this dialog, you can specify an instrument stand (for 
visual representation purposes only), specify where to locate the 
newly added instrument, and specify whether to automatically run 
the instrument’s interface when the instrument is added. These set-
tings are optional conveniences and are not critical to the procedure 
of adding instruments. The settings persist and will apply to the addi-
tion of future instruments until the settings are changed.

To Specify an Instrument Stand:

 ■ Choose None, Brunson Model 233, Wooden Tripod, or Quickset from the 
Instrument Stand list.

To Specify Where a New Instrument Should Be Located:

4. Choose World Frame (to add the instrument relative to the 
World frame) or Working Frame (to add it relative to the current 
working frame).

5. Specify whether to add the instrument along the chosen 
frame’s X, Y, or Z axis.

6. Enter an Increment Value. This value specifies (in job units) 
how much further down the selected frame’s axis each subse-
quent instrument should be added.

To Specify Whether a Newly Added Instrument’s Interface Should Automatically Be Started:

 ■ Check or uncheck the Run Interface option.

Instrument Options and Properties

When an instrument is added to SA, it is added to the graphical view 
as well as the tree. Each instrument is identified by an Instrument In-
dex Number and the name of the instrument. In a given collection, 
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the Instrument Index Number begins counting from zero.

Right-clicking an instrument in the tree will expose a number of com-
mands that apply to instruments.

Instrument Properties
The instrument properties give access to several important proper-
ties. Here the user can set the scale of the instrument either using 
Scale Bars, Material CTE or a Manual entry. Instrument Properties are 
covered in SA Fundamentals | Entities | Instruments.

Instrument History
The instrument history (Figure 13-4) is a log of events that have oc-
curred to that particular instrument. Events such as when an instru-
ment was connected, instrument specific information, how the in-
strument was transformed, etc.

Figure 13-10. A tracker’s history.

The Instrument Interface
One of the most powerful aspects of SpatialAnalyzer is the modular-
ity of the instrument interfaces and how they interact with the core 
analysis platform. These interfaces are able to work independently or 
together, on a single computer or across networked computers.

Instrument interfaces communicate with SpatialAnalyzer using the 
robust TCP/IP network protocol. This affords several distinct advan-
tages. First, these connections are extremely fast and reliable. Second, 
since TCP/IP is a “network” protocol, the instrument interfaces may be 
run on either the same computer as the instance of SA, or on another 
computer accessible on the same network. Third, and perhaps most 
impressive: since it is the “Internet Protocol” (IP), the computers run-
ning the instrument interfaces could be in the same room, across the 
country, or around the world. Likewise, if activated, it is possible to re-
motely monitor a measurement job in progress using this same TCP/
IP connection over the Internet or on a local network.
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Modular instrument interfaces are the basis of the data acquisition 
aspect of SpatialAnalyzer. These provide an easy-to-use and friendly 
interface for the control of instruments during a measurement job.

Establishing the instrument interfaces as separate entities in the ar-
chitecture affords several key advantages. First and foremost, this 
provides flexibility to adapt to tomorrow’s instrumentation. The num-
ber of instrument interfaces available for SpatialAnalyzer is ever-ex-
panding, much like printer drivers and other peripheral devices for 
the Windows operating system. Second, this approach enables SA 
to provide a common interface for each type or class of instrument. 
A portable CMM manufactured by Company A would has the same 
top-level interface as a portable CMM manufactured by Company B. 
This allows users to easily select the instrumentation best suited for a 
particular task. It also allows users to easily transfer the expertise they 
have gained with one instrument to another. A direct benefit of this 
capability is to improve a user’s flexibility when moving from task-to-
task and it reduces the training time for a user to become productive 
on a different instrument. Third, this allows for a more objective view 
when it comes time to replace or purchase new hardware, since re-
training is minimized by the common instrument interface in Spati-
alAnalyzer.

In all cases, the instrument interfaces perform four key functions:

 ■ They provide a common and simple user interface that can be 
used under SpatialAnalyzer control to guide a user through a 
particular measurement task.

 ■ They communicate over a TCP/IP network to convey essential 
measurement data to SpatialAnalyzer.

 ■ They communicate via a native format to the instrument. For 
example: serial RS-232 connections for many theodolites, Net-
work protocols for many laser trackers.

 ■ They provide an efficient means to collect the raw measure-
ments, the conditions and techniques under which they were 
collected, and to perform operational checks on the instrument 
to establish that it is meeting its performance specifications.  It 
also supports simulating measurements and measurement 
tasks before the job is performed. By simulating a measure-
ment process before the job is performed, accuracy and time 
estimates can be made to help you make the best choices re-
garding optimizing the placement of the instrument(s) relative 
to the subject of the survey. 
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Starting an Instrument Interface

To start an instrument interface, choose Instrument>Run Interface Module 
(or click the dropdown arrow next to the Run Instrument Interface
icon). Then select the instrument interface of choice. Once selected, 
the Connect to SpatialAnalyzer window will display (Figure 13-5). This 
window displays all network-accessible and running instances of SA 
containing instruments. The network location (computer name and 
IP address) appears in the list, in addition to the open job filename. 
Any applicable instruments not already connected to an interface will 
appear in boldface.

Figure 13-11. The list of available 
instruments to connect to.

In  this window, you’re choosing the instrument in an SA job file to 
which you’d like to send the measured data. While it is usually the file 
open on the same computer, this is not required. Choose the instru-
ment to which you wish to connect and click OK.

The next dialog will display connection options that are specific to 
the instrument being added. In Figure 13-12, a Faro tracker is being 
added.
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Figure 13-12. Connection options 
for this instrument (a Faro tracker).

Once accepted, the instrument interface will appear (Figure 13-13).

Figure 13-13. A simulated tracker 
interface.

See the Interface section for information on instrument-specific inter-
faces.

If a single instrument is in the job file, you can click directly on the Run 
Instrument Interface icon, and the instrument’s interface will be 
connected and started up. This is equivalent to the Instrument>Run In-
terface Module and Connect command.

Running Multiple Instrument Interfaces

One of SpatialAnalyzer’s strengths is its ability to gather data simul-
taneously from multiple instruments in the same job file. This can be 
done with any combination of instruments, and users may connect 
and disconnect instrumentation at will. The process for adding addi-
tional instruments is exactly the same as adding the first. Just follow 
the procedure outlined in earlier sections.



377

CHAPTER 13 ■ INSTRUMENTS

Connection Configurations
Instruments can be categorized by the connection type used to inter-
act with the computer. These fall into several basic categories:

 ■ Serial Devices. Serial devices (such as RS-232) require a func-
tional serial port on the user’s computer and the use of a serial 
cable. USB to serial adapters are available should your com-
puter not have a serial port (We have had success with DIGI 
Edgeport adapters, which although are more expensive, have 
been quite reliable). Refer to the individual following sections 
for more specific configurations.

 ■ Bluetooth devices. Bluetooth devices require a Bluetooth re-
ceiver on the user’s computer. If your computer does not have 
a built-in Bluetooth connection, a relatively inexpensive mod-
ule, such as a Rocketfish™ Micro Bluetooth Adapter, can be pur-
chased from most office supply stores.

 ■ Universal Serial Bus (USB). USB connected devices typically 
require the installation of a USB driver for the instrument. The 
latest drivers for supported instruments can be found on NRK’s 
FTP site at: ftp://ftp.kinematics.com/pub/SA/Install/Driver 
Downloads/.

 ■ Network-connected devices (TCP/IP). The majority of instru-
ments used in SpatialAnalyzer are network-connected devices. 
This connection type provides extremely fast and reliable con-
nections either directly to the host computer or over a network.

IP-Based Instruments

IP Address Basics

An IP address is an identifier for a computer or device on a TCP/IP net-
work. Networks using the TCP/IP protocol route messages based on 
the IP address of the destination. The format of an IP address (at least 
for the original, IPv4 version) is a 32-bit numeric address written as 
four numbers separated by periods. Each number can be zero to 255. 
For example, 1.160.10.240 could be an IP address. Within an isolated 
network, you can assign IP addresses at random as long as each one 
is unique.

The four sets of numbers can be thought of as a mailing ad-
dress.  State, City, Street and House number. Anyone can live in the 
same State and City and reside on the same street, however there 
can’t be duplicate house numbers. So if an instrument has an IP ad-
dress of 128.128.128.100, the computer must have a different “house 
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number”, such as 128.128.128.99. The subnet mask determines which 
numbers are used as part of the address and which are part of the 
house number. SA expects a subnet a mask of 255.255.255.0. This 
blocks the first 3 numbers out as part of the address and only leaves 
the last number to identify the house (or device).  

Computer and Instrument Setup

 ■

Figure 13-14. A tracker con-
nected directly to a computer via an 
ethernet cable.

Host computer and instrument have unique IP addresses.

 ■ It is typically easier to place the host computer on the same IP 
family as the instrument.

 ■ As an example the instrument IP address is 192.168.0.168

 ■ The host computer would need a unique IP address on the 
same IP family.

 ■ Change the host computer to 192.168.0.100 for example.

 ■ To test the connection use the Ping function in the SA network 
browser (Figure 13-15).

Figure 13-15. Pinging an instru-
ment to check a network connection.

If multiple instruments exist on the network and they belong to the 
same family, no changes are needed. If they do not belong to the 
same family the host computer must be configured to have multiple 
IP addresses. See the section below regarding Multiple IP Setup.
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Changing a Static IP Address

Windows 7
1. Navigate to the control panel via the Start Menu

2. Select View network status and tasks to view the 
current connection.

3. Select the connection of interest.

4. 

Figure 13-16. The Windows 7 
Network Connections dialog.

Select Properties. In the Properties dialog, choose
and click the Properties button.

5. Enter the desired static IP address and subnet mask. 

Figure 13-17. The Windows 7 IP 
settings dialog.

Multiple IP Setup (Dual IP)

Cases exist where the host computer and multiple instruments are 
unable to reside in the same IP family (subnet). In this case, the host 
computer can be configured to handle multiple IP addresses.

1. Follow the above directions to set a single static IP address.

2. Once the first static IP address is set, select the Advanced button 
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at the bottom of the dialog.

3. Click the Add button and enter the additional IP addresses (Fig-
ure 13-18).

Figure 13-18. Assigning dual (or 
multiple) IP addresses to a single port.

Measurement Simulation
SpatialAnalyzer allows for particular instruments to be started and 
run in a simulation mode. This can be quite helpful in planning a job, 
analyzing setup uncertainty, or simply for training purposes. 

To start an instrument in simulation do the following:

Laser  Tracker Simulation

All Laser Trackers models (except the Leica AT960, “Leica AT960 Simu-
lator” on page 383) can be run in a generic simulation mode. To start 
a laser tracker interface in simulation do the following: 

1. Add an instrument model using the instrument add button

 or by going to Instrument> Add, if an instrument station 
does not yet exist in your job file. If you have your tracker 
set to connect automatically this will have to be turned off 
through the options button in the add instrument dialog (Fig-
ure 13-19).  
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Figure 13-19. Automatic Connec-
tion Option in the Add instrument menu 
must be turned off to run in simulation

2. Next, start the instrument interface by going to Instrument>Run 
Interface Module >Laser Trackers (or API Device Interface) . Or by using 
the drop down icon next to the running man (Figure 13-20). 

Figure 13-20. Run Interface 
Module

3. Select your instrument model from the network list by click-
ing on the name in the list and press OK.
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Figure 13-21. Select the instru-
ment model to connect to and press OK 
to continue

Do not select “Run Without Hardware” for simulation. Run Without Hardware 
is a special mode that allows you connect and edit the tracker’s persis-
tence file directly, as if you are connected to your actual instrument. 
This allows you to edit tooling and measurement profiles for later use, 
but will not allow measurement simulation. 

4. In the Connection dialog uncheck the “Connect to Tracker” check 
box (Figure 13-22).  

Figure 13-22. Connect to Tracker 
Check Box in the connection dialog

Once the simulated interface opens you can take measurements, 
point at targets and interact with the measurement profiles and tool-
ing definitions. However, only a default set of each will be available. 
Specific Instrument settings are also not available through Simula-
tion. 
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Leica AT960 Simulator
Leica offers a laser tracker simulator utility for the AT960. This tool is 
accessed by adding a AT960 to a job file and connecting to the in-
strument in Simulation. When you do so an additional tracker control 
dialog will open along with the full AT960 interface (Figure 13-23). 

Figure 13-23. AT960 Simulator 
Control

This simulator provides the ability to simulate the tracker directly. You 
can change beam status, tooling, point the instrument, and simulate 
error messages in order to observe the resulting response of our SA 
Laser Tracker interface. 

Portable CMM Arm Simulation

Start a generic Portable CMM Arm interface in simulation mode using 
the same method as described for the SA Laser Tracker interface (Add 
instrument, Run Instrument Model>Portable CMM Arms, Select your instru-
ment model, and uncheck the “Connect to Arm” Check box).

When simulation starts an arm button simulation dialog will also 
open allowing measurements to be triggered by a simulated arm 
button press (Figure 13-24). 

Figure 13-24. Arm Button 
Simulation Dialog
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Arm simulation is more limited than that available for trackers be-
cause there are so many links in the kinematic model of an arm. For 
example the option to Point At a point is not available because there 
are so many ways to move the arm to get to that point. However, 
there is a Simulate Motion option in the instruments right-click menu 
that will allow you to manually place an instruments probe or enter a 
transform.  

Scanning is also possible in simulation for arms. A simulated scan will 
build a series of parallel scan path  on a plane using a user defined 
width, line spacing and rate. 

Simulation with Other Instrument Types

Total Stations, Laser Radar and some photogrammetry systems also 
offer simulation tools, while still others offer a direct data import 
function. Typically an option is provided to start in simulation if an 
attempt to connect is not successful. Refer to the instrument specific 
quick starts for additional information. 

Measurement Fabrication

Imported points can be linked to an instrument station as mea-
surements by using the “Fabricate Measurement” command 
(Analysis>Measurement Simulation>Fabricate Measurements). This  will create 
a simulated observations of the points from the selected instrument, 
and can be done without starting an instrument in Simulation mode.

Measurement error can be injected to simulate real world conditions. 
The error is based on the uncertainty model of the selected instru-
ment (Figure 13-25).

Figure 13-25. Measurement 
simulation.

 

Taking Measurements
In addition to the standard measurement capabilities of each instru-
ment interface (see chapters on specific devices) SA has a number of 
measurement operations that are initiated from within the SA appli-
cation and can be very helpful in automation applications. 
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Auto Measure

Auto Measure provides an automated means to tell a motorized instru-
ment to measure a set of targets on its own. This can be done once or 
repeatedly. To perform the Auto Measure, select Instrument>Automatic 
Measurement>Auto Measure. Select the group of points to measure and

 the Auto Measure dialog in will appear (Figure 13-26).

Figure 13-26. Auto Measure 
Dialog.

The Auto Measure Dialog is organized into 4 sections as follows:

Orient
An instrument must be aligned to the reference points in order to 
perform an automatic measurement, which is based upon a point 
at, find, and measure process.  It will be told to point at the nominal 
points in order to find the actual points to measure. Unless already 
aligned, it can be helpful to mark at least 3 of the points as Anchor 
Points. This is done by right-clicking on the row of the point of interest 
and changing the Status on that point in the Measurement section 
to define it as an anchor point. The Measure Anchor Pts. and Locate 
Instrument buttons can then be used. 

Measure
The measure process is initiated and configured from the measure-
ment section of the dialog. 

 ■ Single Point. By pressing this button a single measurement 
will be taken at the current reflector/target location and com-
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pared to the currently selected target in the Measurement Sec-
tion. This can be helpful in measuring anchor points as well. 

 ■ Entire Pass. Pressing the Entire Pass button will trigger a full 
set of measurements of each of the points included in the Mea-
surement Section. 

 ■ Next Pass. This function will clear the prior measurement re-
sults and reset focus to the first point in the list. 

 ■ Multi-Pass. This function allows all the points to be measured 
repeatedly for a specified number of passes and allow for a 
time delay to be added before each measurement or between 
passes (Figure 13-27). 

Figure 13-27. Auto Measure 
Multi-Pass dialog and controls.

 ■ Stop. Stop controls are available in both the Orient and Mea-
sure sections in order to exit a measurement process when de-
sired. 

Options
A selection of options are available for the auto measure process. 
These options can be defined as default by using the Right-click op-
tion on the Apply button. These include: 

 ■ Auto Increment Group. The option increments the point 
group each time a pass is complete such that passes are saved 
separately rather than additional observations on the same 
points.

 ■ Halt on Failed Target. When marked the auto measure pro-
cess stops when a target fails. 

 ■ Halt on Tolerance Error. When marked the auto measure pro-
cess stops when a point is out of tolerance.

 ■ Mark Failed Targets. This option marks targets as failed and 
will not attempt to re-measure them in subsequent passes. 

 ■ Append All Passes to File. Record points to a specified .csv 
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formatted ascii file. 

 ■ Group for data. Name of the point group used to record the 
observations. 

 ■ Tolerance. Tolerance used for each point. 

 ■ Watch Window. Open a watch window displaying point to 
point deviations between the nominal and measured points. 

 ■ Create Event. Saves the currently displayed measurement 
window as an event.

Measurement
The measurement section of the dialog displays the current status 
of the last pass through the nominal points. This includes both the 
nominal, actual, and delta statics in a tabular form just as it will appear 
in an event or ascii export. 

The active point (row) is highlighted and the highlighted point will 
also be the target the instrument measures if a single point measure-
ment is taken. Points can also be marked as anchor points (see “Ori-
ent” on page 385) and Ignore such that they are not measured in sub-
sequent passes. 

Instrument>Automatic Measurement>Auto Measure (streamlined) provides a 
much simplified control dialog without a full measurement section 
display. 

Guided Points

Measure Batch of Points provides a tool to guide a user to measure within 
a specified proximity to a set of nominal points selected in a user de-
fined order. It provides control over an audible and visual proximity 
indicator and will zoom the view as you get closer the active point. 
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Figure 13-28. Measure Batch of 
Points graphical guide tools

Measure Batch of Vectors was added with a Laser Radar in mind and drives 
the device to the intersection point between a nominal vector and 
the measured surface to record a point. 

Proximity Triggered Points

It is often necessary to measure points on a part at precise locations. 
Proximity Triggers is a special utility for this purpose. It places an in-
strument in a continuous scan mode and captures a measurement 
when a probe reaches a specified proximity to a nominal point or 
vector (Instrument>Automatic Measurement>Auto-Correspond with proximity 
trigger>).  

Proximity Triggers asks for a reference point group and lay out a set  of 
bull’s-eyes on those points to identify the nominals that have not yet 
been measured. The points can then be measured in any order and 
the Measure each point only once check box can be used to determine if 
only a single measurement is capture or if multiple observations are 
recorded as the probe gets closer and closer to the nominal within 
the tolerance zone.  Additional options include:

 ■ Group to contain measurements. This is the name used for 
the measurements recorded during the proximity trigger op-
eration. 

 ■ Make Vectors while Measuring. This option allows you to 
built point to nominal point vectors as part of the measure-
ment process. 

 ■ Project result to nominal vector. This option ensures that 
only differences in vertical displacement are displayed by the 
vectors, not the displacement of the measured point within 
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the tolerance zone.

 ■ Point Distance Threshold. Defines the maximum distance 
from the nominal point at which a point will be triggered. And 
with vector measurements, defines the length of the cylindri-
cal trigger zone.   

 ■ Vector Axis Threshold. The maximum distance from the vec-
tor axis a point will be triggered (applies to vectors only). This 
value determines the diameter of a cylindrical trigger zone.

You can use vectors to trigger your measurements rather than the 
points. Doing so allows you to trigger measurements when you get 
within a proximity to the vector axis, eliminating any issues with get-
ting close enough to the points you want to measure. The proximity 
trigger zone for vectors is defined as cylindrical zone with a length 
equal to the point distance threshold and the width equal to the Vec-
tor axis threshold. This fine control of both the width and height of 
the trigger allows the user to precisely trigger points even in tight 
regions or slots between adjacent CAD surfaces (Figure 13-29).

Figure 13-29. Cylindrical Trigger 
Region

Once the routine starts. You can simply run a probe over the part and 
it will automatically trigger measurements for specific locations every 
time you get within the trigger distance threshold, ticking off points 
locations as you go keeping track for you of what points have been 
measured and which still need to be taken. Once the majority of the 
points have been measured you can bring up a Graphical Guide win-
dow that will help you navigate precisely to the remaining locations, 
finishing a precise grid measurement of a part.
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Figure 13-30. Proximity Mea-
sured Points in progress

Proximity Measurements with a Scanner
Proximity triggers can also be used with a line scanner. Both Portable 
CMM arm scanners and tracker-linked scanners (such as the Leica T-
scan or LAS) can be used with proximity triggers. 

There is a separate option in each instrument’s interface properties to 
enable this function with a scanner. An example of the setting in the 
CMM arm properties is show here (Figure 13-31): 

Figure 13-31. The Proximity 
Settings found in the properties of a 
CMM arm.

With the Use Scanner for Auto-Proximity Measurements option enabled an 
operator can start the proximity triggers process and begin to scan. 
The cloud points will only be record when they are within the toler-
ance zone on a part.  
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Proximity Measurements with a Shank Probe
Shank Probe measurement can also be acquired using proximity trig-
gers. This provides a very effective method to measure edge points 
quickly by sliding the shank along the part. This is currently only sup-
ported with the T-probe. See “6D Shank Measurements” on page 104. 

Synchronized Measurement

It can be helpful to be able to measure from more than one instru-
ment with the press of a single button. There are a number of ways 
within SA to perform this task. 

Master  - Slave
This function allows you to select a single instrument as the Master 
and a second as the Slave. Once started in this mode, a measurement 
taken from the master instrument will trigger a corresponding mea-
surement from the Slave. The point measurements and the lag time 
(in seconds) will be displayed with each measurement. 

An optional Best-Fit alignment can also be performed as part of this 
utility by checking the Locate one of the instruments check box. When you 
press the Done button, after measurements have been taken, this will 
close the synchronized measurement utility and automatically open 
a Best-Fit dialog allowing alignment of the selected instrument.  

Polling
Polling provides even more options for synchronized measurement 
applications. It allows multiple instruments to be selected at one time 
and opens a master control dialog to trigger measurements. 
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Figure 13-32. Synchronized 
Measurement Polling control dialog

 ■ Single Point (Measure Now). When the Measure Now button is 
pressed it will trigger a point from all of the selected instru-
ments and record those points in the specified point groups. 

 ■ Stream of Points (Begin). The Stream of Points Begin button will 
start a continuous measurement from all of the instruments. A 
time delay can be added between measurements to space the 
points using the Delay between measurements (sec) option.  

Measurement requests from SA are handled separately from mea-
surements triggered directly in the instrument interface. For exam-
ple, discrete tracker measurements use a specific measurement pro-
file that can be found under Settings>Tracker>SA Interaction>Measurement 
Requests>Single Point Parameters. 

Crib Sheets and Measurement Templates

SA provides a wide spectrum of tools for measurement template 
construction. The simplest for of the is a Crib Sheet which provides a 
means of recording target names and the measurement profiles use 
to measure them along with notes for an operator. 
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More advanced measurement templating is available both in Geom-
etry Relationship Inspection (see “Feature Inspection” on page 563) 
and in GD&T Inspect (see “GD&T Workflow” on page 627). Full Mea-
surement plan integration is also available through SA Ultimate.

Crib Sheets
Crib Sheets provide a simple means to automatically set the Collec-
tion, Group, and Target name, as well as the Measurement Mode, for 
an operator as part of a standard task (Figure 13-33). 

Figure 13-33. Crib Sheet Dialog

Each entry in the Crib Sheet can be considered a command to the 
instrument and will set both the Collection, Group and Target as well 
Meas measurement mode and any user notes. Therefore, an instru-
ment selection is required.

Crib sheets are set up to record new entries when the Learn Mode 
option is enabled, and the Add New Item button provides a means to 
manually add an entry.

Crib sheets can be run from the properties dialog using the Measure 
button once an instrument has been selected. The Item selection in 
the list can be used to run steps in any order you wish and completed 
items will be marked with a check mark. 

Monitoring

Watch Windows and Transformation Tracking

Watch windows are discussed in their own chapter “Watch Windows” 
on page 433.
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Tools

Scale Bars

Adding a Scale Bar
After measuring the necessary points, the user should create a scale 
bar.  For instruments that measure angles and distances, it is not nec-
essary to use scale-bars in the bundle process but they are required 
for theodolite networks.  Without them, the instruments will scale 
freely. To do this you will need to utilize two points that have a known 
distance from each other.  They can be two points designated only 
for the scale or common points, but either way they need to be re-
corded from the theodolite before the scale bar is created.  Once you 
have the actual distance select Construct > Scale Bar > Pick 2 Points.  At 
this point, select the two points that you just measured the distance 
between.  The window below will appear (Figure 13-34).  Select edit 
to change the length to the actual measured amount.  After hitting OK 
the new length should populate.  You should also notice that a scale 
bar is now listed in the tree bar.

Figure 13-34. Scale-Bar Type List

Spatialanalyzer: instrument Scaling Using Scale Bar and Cte - https://
www.youtube.com/watch?v=XOG5du8oOR0

Perimeter

Perimeters appear graphically much like a series of connected lines 
that define a 3D volume. Perimeters are used with scanning devices 
to define a region of interest for measurement purposes. For more 
information refer to “Perimeters” on page 341.

Target Detection

Survey targets locations can be extracted from clouds using the em-
bedded intensity information. To use these commands,  graphically 
select cloud points containing the target you wish to extract.

 ■ Survey Points from Triangles. This command can be used to 
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extract the center point from two intersecting triangles. 

 ■ Survey Points from Circles. This command can be used to ex-
tract the center of scan circle targets. 

Figure 13-35. Example Triangle 
and Circular Intensity Targets

Scan target detection in Spatialanalyzer - https://youtu.be/BSBPYRHY-
fm0
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Typically, metrology data is of limited use until it has been aligned to 
some set of reference datums, nominal data, or other measurements. 
Aligning to a coordinate system is sometimes referred to as bucking 
in, tying in, locating, or aligning. Some of the reasons this is done in-
clude the following:

 ■ Governing dimensions and measurements (acceptance crite-
ria) are typically expressed on drawings with respect to a spe-
cific datum or frame of reference. Often, evaluating features 
with respect to other datums is not permitted when evaluating 
design conformance.

 ■ When comparing as-built measurements to a nominal design, 
the data must be aligned to the nominal design—otherwise, 
the comparison cannot be performed.

 ■ Multi-station measurements (measurements taken from more 
than one position in space) must be “tied” together so that the 
data is continuous.

 ■ Digital alignment and assembly (virtual fit-up) requires that 
measured components be “virtually” assembled using some 
sort of alignment in order to check the assembly for fit and 
function.

In some situations, this involves creating a coordinate frame from the 

One of the key areas of portable metrology is alignment: transforming 
an instrument or set of points into the proper position and orientation 
such that it is aligned to the desired coordinate system. This chapter ex-
plores methods for transforming into a desired coordinate system.

Alignment & 
Transformations



398

SPATIALANALYZER USER MANUAL

measured points. In other (less common) situations, it involves trans-
forming CAD data to the measurements. But most often, it involves 
aligning measurements to a coordinate system of interest. Since mea-
surements are rigidly fixed to the instrument that measured them,  
this typically involves transforming an instrument in space until its 
measurements end up in the desired position.

In this chapter, we will explore the tools available for performing all 
different types of alignment.

Review of Available Alignment Options
Alignments should be made on an instrument basis whenever possi-
ble. Because instruments, their measurements and associated objects 
move as a unit this is the most effective method. 

An instrument can be located several ways. The basic instrument lo-
cation methods can be found under Instrument>Locate or right-click 
an instrument and select Locate. Advanced methods are discussed in 
later sections and links are provided below.

Measured Point to Reference Alignments

Best-Fit
Locating an instrument via a Best-Fit is one of the most common loca-
tion methods. It is used heavily during instrument location to nomi-
nal control points, instrument relocation and relocation due to drift. 
The user specifies the instrument to locate, the nominal point group 
and measured point group. The below fit dialog will appear allowing 
a view of the best fit. This Best-Fit Transformation dialog is covered 
in the Best Fit Points to Points section. For more details see “Point to 
Point Best-Fit” on page 401.

Analysis Best Fit Points to Points
Analysis>Best Fit Transformation>Points to Points is very similar to  a ba-
sic  best fit, the main difference being that the user has the ability 
to move multiple instruments and additional objects with the com-
puted transform (see “Point to Point Best-Fit” on page 401)

Measure Nominal Points
Measure Nominal Points is a great way to locate an instrument quick-
ly. It functions like a guided best fit. Simply select the nominal points 
and the instrument to locate.

The Locate dialog will listing the points to measure and the user has 
the option for manual or automatic measurement. Once three points 
are measured the instrument is transformed via a Best-Fit. With the 
instrument roughly located the user can easily drive or point to each 
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target. As measurements are recorded the Best-Fit is updated. For 
more details see “Locate By Measuring Nominal Points” on page 411.

Feature and Reference Point Alignments

Nominal Geometry Relationships
Many geometry relationships are point reducible such as the center 
of a circle or a sphere. This option allows you to choose a selection of 
geometry relationships and best fit their center points (see “Nominal 
Geometry Relationships” on page 416). 

Reference Point System (RPS) Alignment
Added and popularized in the automotive industry this alignment 
option provides a means to use a set of point reducible features as 
well as surface points to achieve an Alignment. It provides individual 
point control over weighting and component influences (see “Refer-
ence Point System (RPS) Alignment” on page 416).

Surface Alignments

Quick Align to CAD
A quick and easy method to align to a CAD model. Simply click the 
model where the points will roughly be measured. A minimum of 
six points are needed to align to a CAD model. Red dots are used to 
guide the user where to measure. During the selection of the surface 
points the current view is saved. As measurements progress the views 
update (see “Quick Align to CAD” on page 420).

N-Point Full Fit
Much like a relationship optimization this function finds the optimal 
transformation that minimizes the errors between the measured 
points and the CAD surface. This method contains many options for 
tolerance fits and other advanced fitting methods (see “N-Point Full 
Fit” on page 399).

Point Cloud/Mesh to Reference Alignments

A selection of Cloud to Cloud, Cloud to Mesh, Cloud to CAD, Mesh 
to mesh and Mesh to CAD alignment options are available. These 
alignments are discussed in detail in the chapter on point clouds (see 
“Cloud Based Alignment/Registration Tools” on page 290).

Frame and Feature Based Alignments

Frame to Frame Transformation
Transform an instrument from a one frame to another. User will be 
prompted to select a source frame, a destination frame and an instru-
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ment to move.

Plane, Line, Point (3-2-1)
A 3-2-1 fit consist of a locator point for the origin, line/vector for one 
axis and plane for the second axis. The Plane, Line, Point Transforma-
tion dialog allows control over the axis for the plane and line/vec-
tor. The user may also specify an alternate coordinate for the locator 
point. Once the transformation is accepted the instrument will be 
transformed with respect to the active frame.

3 Planes
The 3 Plane instrument locate uses three planes to define a coordi-
nate system that is then transformed to the active frame. The user has 
control over the axis fit priority and position.

Frame Wizard 
Frame Wizard provides a flexible way to select points or objects to 
define the origin and axis directions of a new frame.  Once that frame 
is built and you accept it, the transformation from the current frame 
location to the active frame is performed.

Advanced Optimizations

Locating By Minimizing Relationships
Instruments can be located by Minimizing Relationships. This is an 
advanced option to help equalize any misalignment by using mul-
tiple relationships at once all with custom weighting and constraint 
options. Its only fully available in SA Ultimate and more details can 
found in the Relationships Chapter (see “Minimizing Relationships” 
on page 535).

Sequential Alignment
A Sequential Alignment allows you to align with different relation-
ships in a predefined sequence, applying specific degrees of freedom 
to each relationship and then running the alignment process much 
like a script (see “Sequential Alignment” on page 540).

Network Alignments

Bundle 
Designed with theodolites in mind. This network alignment performs 
a weighted bundle based upon common measurements targets and 
the resulting position (see “Bundle Adjust” on page 426). 

Unified Spatial Metrology Network (USMN)
USMN is a strong method for locating multiple instruments. It is usu-
ally used in a case where three or more instruments are present. This 
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is available in SA Ultimate and can found in the USMN Chapter (see 
“What is USMN” on page 721).

Measured Points to Reference Alignments

Best-Fit Transformations

Best-fit transformations are widely used in coordinate metrology 
to consistently and confidently align measurements into a coordi-
nate frame that is meaningful to a user. Measurements made with 
an instrument should be presented to users in the part coordinate 
frame—that is, aligned to the part. The best-fit transformation rou-
tine in SpatialAnalyzer is one way to do that.

A best-fit transformation solves for the difference between a group of 
points and the expected (or reference) coordinates for those points. 
The difference between the current position and orientation of the 
points and the ending position/orientation is referred to as the trans-
formation. After the solution is reached, SpatialAnalyzer shows you 
the difference and allows you to apply the transformation to your 
measurements of the points and to other objects as well. Once ap-
plied, SpatialAnalyzer is able to report those measured points and 
any new measurements in a part coordinate frame that is meaningful 
to you.

The best-fit alignment technique has many applications; for example, 
to combine sets of coordinate data or locate an instrument in the 
part coordinate system using surface features imported from a CAD 
system. Simply stated, this alignment technique helps you deter-
mine the transformation that when applied to one set of coordinates 
causes the match-up between the two sets to be ideal.

The term “best fit” is the colloquial term given to a mathematical pro-
cedure known as a Linear Least Squares fit. The transformation solved 
for and applied is determined using least-squares optimization meth-
ods. A least squares optimization seeks to minimize the square of the 
distance between corresponding points, or between points and cor-
responding surfaces.

Point to Point Best-Fit

A common need for performing a point to point best-fit is when try-
ing to locate to a known coordinate system in which discrete points 
already exist. For instance, you have a network of control points (fi-
ducials) from a previous station measurement and you’d like to relo-
cate the instrument and remeasure these points in order to align back 
into the coordinate system. When performing this type of alignment, 
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the group of points being aligned to are referred to as the reference 
group, and the points being moved are referred to as the correspond-
ing group. They may also be referred to as the nominal group and mea-
sured group, respectively, although if the term nominal group is being 
used, it does not necessarily mean that the points are true nominal 
design points (Figure 14-1).

Figure 14-1. A group of four 
points (blue), when best-fit to a set 
of reference points (red), will move as 
illustrated. The four blue points move 
together as a rigid body to try to align 
with the reference points. In this case, a 
rotation is involved.
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In order to perform a point-based best-fit transformation, the points 
involved must meet two prerequisites:

 ■ There must be at least 3 points in both the reference and cor-
responding groups that have corresponding names.

 ■ The reference and corresponding points must be in separate 
point groups.

Note that the two groups need not have exactly the same number 
of points. Any points that don’t have corresponding pairs are simply 
ignored in the command, although if they are in the moving point 
group they will be transformed along with the rest of the points in 
the group. There are three ways to perform a point-to-point best fit 
transformation:

 ■ Instrument-based best-fit. In this method, you pick an instru-
ment to align, and then select the reference and measured 
group. The transformation will be applied to the instrument, 
bringing all of the measured points along with it.

 ■ General best-fit. This is nearly identical to the first method, 
however it’s not instrument-centric, and provides a little more 
flexibility when needed. You can choose to transform anything, 
including instruments, point groups, and other objects. There 
are also a few additional options (discussed below).

 ■ Locate an instrument by measuring nominal points. This al-
lows you to measure a set of nominal points, and let SA handle 
the point naming and alignment for you.

These three methods are described below, but to use them (well, at 
least two of them) we first need to understand the Best-Fit Transfor-
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mation dialog.

The Best-Fit Transformation Dialog
The Best-Fit Transformation dialog (see Figure 14-2) is a simple in-
terface allowing a high degree of control over the fit. Here you can 
review the fit, apply tolerances, restrict degrees of freedom, edit point 
constraints, and more. Any time one or more changes is made, the 
current fit is no longer valid (indicated by a dark blue background on 
the fit button and the fit results) and needs to be re-solved. The dialog 
is divided into three main parts: the controls (top left corner), the fit 
results (top right corner), and the point list (bottom).

Figure 14-2. The Best Fit 
Transformation dialog.

Fit Results
The fit results are listed in the table in the top right corner of the dia-
log. These results will be invalid (and therefore will have a dark blue 
background) whenever the best-fit solution has either not been 
solved or a change has been made since it was last solved. The fit re-
sults table contains, on a component-by-component basis, a number 
of statistical values related to the fit that help you determine how well 
the fit performs. These values include:

 ■ Count. The number of points included in the fit for the speci-
fied component.

 ■ Max Error. The maximum error between a pair of correspond-
ing points. This is an indicator of the “worst fit” for any pair of 
corresponding points.

 ■ RMS Error. The root-mean-square error of the fit as a whole. 
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This is a good indicator of the overall error of the fit. This num-
ber is always less than or equal to the max error (although usu-
ally it’s noticably smaller than the max error).

 ■ StdDev Error. The standard deviation of the errors. A small val-
ue indicates that each pair of points had similar errors. A large 
value indicates that one or more error values differed signifi-
cantly from the group as a whole.

 ■ Max Error (all). This is the same as Max Error, except all points 
are included (even those which are deselected from the fit).

 ■ RMS Error (all). This is the same as RMS Error, except all points 
are included (even those which are deselected from the fit).

 ■ Translation. The x, y, and z instrument translation needed for 
the solution.

 ■ Rotation (Fixed YZ). The instrument rotations required for the 
solution, in Fixed XYZ form.

 ■ Rotation (Euler XYZ). The instrument rotations required for 
the solution, in Euler XYZ form.

 ■ Rotation (Angle axis). The instrument rotation required for 
the solution, in Angle axis form (first three values describe the 
rotation axis, and the last value describes the rotation angle).

 ■ Scale Factor. The scale factor applied for the fit. This will be 1.0 
unless the Scale degree of freedom is checked (allowed to float).

 ■ Matrix. This is the 4x4 transformation matrix that will be ap-
plied to the instrument.

Point List
The point list is a table that contains all points that were found to have 
matching pairs between the reference and corresponding groups. Im-
mediately above this list, in the Columns section, are three checkboxes: 
Nominals, Actuals, and Weights. Checking any of these boxes will display 
the corresponding values in the table. Any column can be sorted in 
ascending or descending order by clicking the column header. The 
columns in the point list are described here:

 ■ Name. The name of the point.

 ■ Nom X. The nominal x-coordinate of the point. This is the x-
coordinate of the reference (non-moving) point.

 ■ Nom Y. The nominal y-coordinate of the point. This is the y-
coordinate of the reference (non-moving) point.

 ■ Nom Z. The nominal z-coordinate of the point. This is the z-
coordinate of the reference (non-moving) point.

 ■ Act X. The actual x-coordinate of the point. This is the x-coordi-
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nate of the measured (moving) point.

 ■ Act Y. The actual y-coordinate of the point. This is the y-coordi-
nate of the measured (moving) point.

 ■ Act Z. The actual z-coordinate of the point. This is the z-coordi-
nate of the measured (moving) point.

 ■ Wt X. The fit weight for the x-coordinate of the point.

 ■ Wt Y. The fit weight for the y-coordinate of the point.

 ■ Wt Z. The fit weight for the z-coordinate of the point.

 ■ dX. The current x-deviation between the reference and corre-
sponding point.

 ■ dY. The current y-deviation between the reference and corre-
sponding point.

 ■ dZ. The current z-deviation between the reference and corre-
sponding point.

 ■ dMag. The magnitude of the deviation between the reference 
and corresponding point.

Each point in the fit has a checkbox next to its name in the point list. 
Deselecting this checkbox will remove the point from the fit, which 
means that it will have no influence in the final solution. It is standard 
procedure to remove erroneous points from the fit so as not to cor-
rupt the overall solution. If a point is removed from the fit, it will be 
grayed out in the point list.

Best-Fit Item Dialog

Figure 14-3. The Best-Fit Item 
dialog.

Double-clicking a point in the list will bring up the Best-Fit Item dia-
log (Figure 14-3). This dialog provides another way to remove the 
point from the fit (Use in Fit), and conveniently allows you to change 
the reference point’s coordinates, as well as the per-component fit 
weight for the point. The 1 and 0 buttons are simply shortcuts for set-
ting the corresponding fit weight value.



406

SPATIALANALYZER USER MANUAL

Fit Weights
Fit weights give you control over defining whether a certain compo-
nent of a point has any influence in the fit process. A value of zero 
indicates that the component has no influence in the fit, whereas a 
value of 1 indicates the component has full influence. Any interme-
diate value may be chosen. If a component is weighted to zero, it is 
displayed in gray in the point list. If an intermediate value is chosen, it 
is displayed in blue, and if the weight is set to 1, it is displayed in black.

One reason for reducing the weight of a specific component of a point 
is to reduce directional errors. Suppose you have a measured point 
that was performed on a floor that was flexing in the z-direction dur-
ing measurement. It is reasonable to assume that the measured point 
has significant error in the z direction when compared to the x or y 
direction, therefore reducing the weight of the z component may be 
a wise choice. Another reason is when using discrete points to control 
specific degrees of freedom, an advanced technique that, while do-
able using best-fit, is much easier to perform using relationship fits.

Controls
You’ll notice that you have a significant amount of control in the fit. 
Access to changing the fit parameters is provided via the controls in 
the upper-left hand corner of the dialog.

Degrees of Freedom
When solving a best-fit transformation, you can specify that the trans-
formation may only be permitted in certain unlocked degrees of free-
dom, relative to the working coordinate frame. You can lock any com-
bination of X/Y/Z translation, X/Y/Z rotation, and scale. Any degree of 
freedom that is checked is unlocked—unchecking a degree of free-
dom locks it. Keep in mind that these degree of freedom restrictions 
are applied with respect to the working coordinate frame, therefore 
rotations are applied about the working frame origin.

As an example, suppose you have a bolt pattern measurement on a 
flange and you’d like to fit this measured pattern to a mating, nomi-
nal pattern. In this case, you would likely align the face of the mea-
sured points to the nominal flange face using perhaps a relationship 
fit, then you might wish to use the nominal bolt pattern to spin the 
measured flange about its axis until the bolt holes are aligned (Figure 
14-4).
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Figure 14-4. Performing a best-fit 
transformation allowing only rotation 
about the Z axis.

x

y

By locking all degrees of freedom except for rotation about the Z 
axis—and by placing the working frame at the center of the flange—
the fit would simply clock the measured pattern to the nominals.

You might also restrict degrees of freedom if you have a leveled in-
strument (its axis is parallel to the Z axis) and you do not want it to 
rotate about the X or Y axes.

Notice that you can also set the instrument to a specified scale value 
for the fit, which allows you to apply temperature compensation to 
the measurements in situ.

Tolerance Coloring Zones
You can apply tolerance coloring to the deviations in the point list by 
setting the tolerances in the Tolerance Coloring Zones section.

Fit Controls
A series of buttons controlling the fit is displayed below the Tolerance 
Coloring Zones section:

 ■ Re-fit button. Recalculates the best-fit transformation 
based on the current settings. A blue background on this but-
ton indicates that the current fit is not valid based on the cur-
rent settings and a re-fit is needed.

 ■ Edit Selected Items. Brings up the Best-Fit Item dialog 
(page 405) for any selected items. More than one point can be 
selected at one time in the point list. This button allows you to 
change all of their properties at once.

 ■ Quick Tips. Displays a series of tips related to the dialog.

 ■ Advanced Settings. Displays the Advanced Best-Fit Op-
tions dialog, discussed below.

 ■ Advanced View. Toggles to a simplified version of the inter-
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face, hiding less frequently-used parameters.

Advanced Settings
The Advanced Best-Fit Options dialog (Figure 14-5) provides some 
advanced, less commonly-used settings for best fit transformations.

Figure 14-5. The Advanced 
Best-Fit Options dialog.

Descriptions of these parameters follow:

 ■ Reset transform and scale before each re-fit. The transfor-
mation is solved from the same initial starting position and ori-
entation each time the fit is performed. This is the default and 
is applicable to most fitting operations.

 ■ Apply transformations successively. Each fit operation solves 
using the previous calculated transformation as a starting 
point. This allows you to apply iterative best-fit operations with 
different degree of freedom settings for each. For instance, you 
might wish to first solve the best-fit with some degrees of free-
dom locked, then solve again from that position with a differ-
ent set of locked degrees of freedom.

 ■ Reset Transformation and Scale Now. Resets the current 
transformation back to the “starting point”.

 ■ Store weight settings with points. Fit weights can be stored 
with nominal or actual points such that if the points are used in 
another best-fit operation, the weights are recalled.

 ■ Make a new group when fit is finished. Makes a copy of the 
reference (non-moving) points and puts them into a separate 
group with the specified name at the completion of the opera-
tion. If nominal coordinates were changed in the Best Fit Item 
dialog, this group will use those updated coordinates. This is 
not a common need.
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Export to CSV
The Export to CSV button will export the fit results to a comma-separated 
.CSV file and import it into Excel (if installed).

Instrument-Based Best-Fit
To reiterate, an instrument-based best-fit transforms just an instru-
ment and (of course) its measurements. Only one instrument can be 
transformed. As such, it is most appropriate when locating a single 
instrument to a set of reference points, or when relocating an instru-
ment to a new station.

1. Measure a set of points into a point group. These will be the 
“measured” points.

2. Ensure that the measured point names match the corre-
sponding point names in the reference group.

3. From the menu, select Instrument>Locate (Transform to Part)>Best-
Fit.

4. If there is more than one instrument in the job file, select the 
instrument to locate (as prompted).

5. When prompted for the “nominals” group, select the refer-
ence group. This is the group containing the points that will 
not move during the transformation.

6. When asked for the “measured” group, select the group con-
taining the measured points. These points should be mea-
sured by the instrument selected in step 4.

7. Choose the desired options from the Best-Fit Transformation 
dialog and perform the fit as described, then click Apply Transfor-
mation.

General Best-Fit
A general best-fit can be performed in which the calculated transfor-
mation is not simply applied to a single instrument that measured the 
corresponding points. This is useful for applying point to point best-
fit transformations when instruments are not involved, or when you’d 
like to move several instruments together as part of the fit. In the gen-
eral best-fit, you can apply transformations to instruments and other 
objects, in addition to a few more options.

To Perform a General Best-Fit Operation

1. Select Analysis>Best-Fit Transformation>Points to Points, or press 
Ctrl + B.

2. Select the reference (non-moving) group.

3. Select the corresponding (moving) group.

Note:  If your point names 
don’t correspond, use Edit> 

Rename> Points by Auto-Corresponding 
2 Groups to automatically rename 
them.
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4. In the resulting Best-Fit Transformation dialog, select the de-
sired options for the fit and solve it (see “The Best-Fit Transfor-
mation Dialog” on page 403).

5. In the Best-Fit Options dialog (Figure 14-6), select the desired 
options (described below), then click OK.

Figure 14-6. The options for a 
general best-fit.

Best-Fit Options
Toward the completion of a general best-fit operation, you are pro-
vided with a series of options that are not displayed in the single 
instrument version of the best-fit command. These options are de-
scribed below.

 ■ Move the corresponding group. Determines whether the 
transform is applied to the corresponding (moving) group. If 
unchecked, the corresponding group is not moved.

 ■ Move Objects. If you’d like to transform other objects, select 
this option. After clicking OK, you’ll be prompted to pick the ad-
ditional objects to transform.

 ■ Move Instruments. If you’d like to transform instruments, se-
lect this option. After clicking OK, you’ll be provided the oppor-
tunity to select instruments to transform.

 ■ Adjust Instrument Scale Factor. This option is only available 
when the scale degree of freedom is unlocked during the fit. 
When checked, the scale factor calculated during the fit opera-
tion is applied to the moving instruments.

 ■ Move a copy of the working frame. When selected, the work-
ing frame will be copied, and the transform will be applied to 
the copy. This creates a frame that can be used to report the 
coordinates of the points as they were prior to the transforma-
tion.

 ■ Create alternate reference frame. When selected, a frame is 
created that represents the inverse of the applied transforma-
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tion. This allows you to transform the moving objects back to 
their position prior to the best-fit operation through the use of 
a frame to frame transformation.

Locate By Measuring Nominal Points

While locating an instrument by fitting to a set of nominal points (see 
“Instrument-Based Best-Fit” on page 409) is not a difficult task, you 
may find that using Instrument>Locate (Transform to Part)>Measure Nomi-
nal Points is preferable for typical in-process alignment in which more 
control is not needed.

Locating by measuring nominal points provides a few benefits over 
the instrument-based best-fit method:

 ■ Point naming is handled automatically, eliminating the poten-
tial for typographical errors in measured point names.

 ■ If the instrument is roughly aligned to the points already (for 
instance, it is being re-fit into the reference system after being 
bumped), it can easily be automatically pointed at the targets 
(if the instrument supports pointing). Single points or the en-
tire set of reference points can be automatically measured with 
a single button click.

 ■ The quality of the fit is displayed at the time of measurement—
therefore any blunders in measurement (resulting in errors in 
the fit) can be discovered much sooner than if the fit were be-
ing performed later in the process.

There are a few things to keep in mind when using this command:

 ■ It must be used at the time of measurement. If the measured 
points already exist, you must use one of the other two best-fit 
commands.

 ■ You have much less control over the fit. You cannot control de-
grees of freedom (with the exception of scale), weighting, or 
advanced fit operations—and you cannot remove points from 
the fit unless you delete them.

 ■ You’re presented with much less detailed information about 
the fit results.

For the first two measurements, insufficient measurements exist to 
perform the fit, so the delta deviations are not displayed. However, as 
each successive measurement is obtained, the fit is recalculated and 
the deviation values are updated. The Locate Instrument by Measur-
ing Nominals dialog is presented in Figure 14-7.
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Figure 14-7. The Locate 
Instrument by Measuring 
Nominals dialog is useful when 
performing a best-fit points to points 
transformation during the measure-
ment process.

A description of the options follows:

 ■ Group to Contain Measured Points. This is the name of the 
group in which you’d like to measure the corresponding points. 
It is best to type this in before measuring any of the points, be-
cause if you change it after measuring any points, the already-
measured points will not move into the new group. The Apply 
button will update the table based on the entered group, and 
the ellipsis button allows you to select an existing group to use.

 ■ Vary Scale. When checked, scale is allowed to float during the 
fit. The initial, delta, and final scale values are listed next to this 
checkbox.

 ■ Hold Level (Rx Ry off). This option can be if you do not want 
the locate operation to tilt the instrument. It restricts the de-
grees of freedom at are used in the alignment and was added 
for use with gravity compensated instruments in mind. 

 ■ Closest Point. With this option enabled you still have to mea-
sure the first 3 points in order, but after that, you can measure 
the point in any order and SA will detect which point you mea-
sured automatically.  

 ■ Measure Manually. When clicked, the selected target in the 
list is measured. If the target already exists, an additional ob-
servation is added.
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 ■ Point At. Points the instrument at the selected target and at-
tempts to lock on. (Applies only if the instrument supports 
pointing/target acquisition).

 ■ Delete. Deletes the selected target.

 ■ Automatic Measurement - Single Point. Attempts to point 
at, acquire, and measure the selected target.

 ■ Automatic Measurement - Multiple Points. Attempts to con-
secutively point at, acquire, and measure all points in the list.

 ■ Tolerance. You can specify a tolerance in this field. Any devia-
tion magnitudes that exceed the tolerance will be highlighted 
red. Click the Apply button to apply the specified tolerance to 
the table.

To Locate an Instrument by Measuring Nominals

1. Ensure the instrument interface is running.

2. From the menu, select Instrument>Locate (Transform to 
Part)>Measure Nominal Points.

3. If more than one instrument exists in the file, select the instru-
ment to transform, as prompted.

4. Select the nominal (reference) points.

5. The Locate Instrument by Measuring Nominals dialog is dis-
played.

6. In the Group to Contain Measured Points section, type in a name for the 
point group in which to place the measured points.

7. Measure points manually or automatically using the dialog as 
described above. Once three or more points have been mea-
sured, click the Finished -- Locate Instrument button at any time to 
accept the fit and complete the command.

Drift Check

Drift Check is an option easily accessed by directly right-clicking on 
the instrument in the graphics you want to check. It can also be found 
it under the menu command Instrument>Drift Check. 

The Drift Check dialog may appear familiar. The group name control 
and measurement controls are the same as those used in the Measure 
Nominal Points alignment option, and in many ways it’s the same opera-
tion. It allows you to select a set of points and measure them in a fast 
and efficient manner. 

However, the advantage of Drift Check is that it provides both a re-
port of the current deviations and a preview of the RMS and Max de-
viation you would see if you were to re-fit, aligning using a Best-Fit to 
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the nominal points. This is quite helpful because the deviations can 
be compared, and an informed decision can be made as far as how to 
proceed (Figure 14-8).

Figure 14-8. The Drift Check dia-
log which provides a streamlined means 
of re-measing a set of points and either 
jumping station or recording the event.

Drift Check results can be applied in either of 3 ways: 

1. Best-Fit (Add New Instrument: Transform).  Pressing this button will 
automatically add a new instrument model to the job file, dis-
connect the interface from the original model, reconnect it to 
the new model and perform a best-fit using the points mea-
sured in the drift check to align the new instrument station.

2.  Best-Fit Scaled (Add New Instrument: Transform and Scale). Pressing 
this button will also automatically add a new instrument mod-
el to the job file, disconnect the interface from the original 
model, reconnect it to the new model and perform a best-fit 
using the points measured in the drift check to align the new 
instrument station. However, it will allow scale to float as part 
of the best-fit and the new station will be scaled accordingly. 

3. Finish -- Drift Acceptable. Pressing this button will record an event 
in the tree as a record but will not have any effect on the exist-
ing instrument station.  

How to Perform a Drift Check Step by Step
1. Right-click on your live instrument model in the job file and 

select Drift Check.

2. Select a Point Group to measure as a reference.  This should ei-
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ther be an imported reference group or set of prior measured 
reference points. ***See Key Points.

3. Measure each point in the list by selecting and manually mea-
suring it (you can use Point At to find which point is which). 
If you have a set of targets already in place you can also use 
the Automatic Measurement option to measure all the points 
automatically.

4. Compare the drift results to the expected results if you were 
to relocate. Choose to Add a New Instrument and Transform 
if this difference is significantly greater than you would ex-
pect with your instrument under your conditions. ***See Key 
Points

Key points: On how and When to transform

 ■ Drift Checks should be performed frequently, and on regular 
intervals. The frequency will need to increase the tighter the 
tolerances. Minor shifts in the instrument placement can add 
up and drift checks are the best way to make sure either: that 
things are still in a good condition, or to identify that you’re 
instrument needs to be re-aligned. The sooner you realize an 
instrument was bumped the sooner this can be fixed. 

 ■ Get to know your instrument and  your working environment 
to establish an expected threshold for a drift check. Drift checks 
should be quick an painless but in real life there will always be 
error. If you have an idea of how accurate your instrument is 
under your expected working conditions, it can become sec-
ond nature to accept and continue or add a new instrument 
and re-align.

 ■ You may not want to align to your reference group. It is very 
important to not create an error stackup situation. If you align 
one station to the next in sequence, errors can accumulate. You 
always want to align to your original nominal point set, but 
when these are imported from a CAD model the errors may be 
pretty big to start. 

To prevent error stack up with imported nominal points , do the follow:

1. When you start the job you can measure the CAD points and 
align, noting the significant errors in alignment.

2. When you perform drift checks you will want to select the first 
measured point group so that the errors displayed in the Drift 
Check are 100% linked to the station placement.

3. Then when the instrument needs to be re-aligned you will 
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want to again align to the original CAD points to prevent 
any error stackup. The Add New Instrument and Align option 
within the Drift Check dialog should only be used when the 
original measured group is the defining point group for the 
nominals within the job file. 

Feature and Reference Point Alignments

Nominal Geometry Relationships

The function Analysis>Best Fit Transformation>Nominal Geometry Relation-
ships, also available through the instruments right-click menu pro-
vides an easy way to locate using geometry relationships that are 
point reducible using a best fit. Point reducible relationships include: 

 ■ Point to Point

 ■ Average Point

 ■ Circles

 ■ Slots

 ■ Ellipses

 ■ Spheres

This alignment tool provides an option to choose a selection of point 
reducible geometry relationships and perform a best fit using the 
centers of those features. The only requirements are that you have 
at least 3 point reducible relationships with nominals defined. Each 
feature will be listed as an entry in the Best Fit dialog and all the same 
controls are available (see “The Best-Fit Transformation Dialog” on 
page 403).

Spatialanalyzer: how to align an instrument Using a nominal Geometry 
relationship - https://www.youtube.com/watch?v=Wz0HcpIvN10

Reference Point System (RPS) Alignment

Much like a Best Fit, Reference Point System (RPS) alignments require 
a nominal and measured set of points for alignment. RPS is unique 
in that it provides the means to use a set of point reducible features 
(such as circle centers) as well as surface points to achieve an align-
ment. It then expects the input points to be used to constrain a single 
axis or set of axes for the alignment.  This alignment can be found 
under Analysis>Best Fit Transformation> RPS Alignment.

Features can be added to the alignment list in either of two ways: 
they can be built directly through this dialog which will prompt for 
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CAD selection or they can be selected from a list of existing compare 
to nominal geometry relationships or point to point relationships and 
added to the alignment list.

Figure 14-9. Basic RPS Alignment 
Dialog

Actions 

A full list of available functions for adding and removing features from 
the RPS alignment is listed under the Actions menu (Figure 14-9). The 
primary functions are also available through the icon buttons, and 
include the following:

 ■ Add Feature. This command initiates the addition of a feature 
to the inspection list. By selecting Point, Projection Plane, Cir-
cle, Slot, or Sphere, a built from CAD prompt will be initiated. It 
also provides access to selecting from Existing Features. 

 ■ Delete Feature. Removes the selected feature from the RPS 
list. This does not delete the feature from the tree. 

 ■ Clear All Features. Removes all features from the RPS list of 
features. 

 ■ Run Fit. Performs a fit computation, populating the summary 
table.

 ■ Apply Alignment. Transforms the Active instrument. If no 
instrument is marked as Active it will prompt for objects and 
then instruments to move. This then provides the opportunity 
to align multiple instruments at once.  

 ■ Undo Alignment. Returns the instrument and objects moved 
to their starting location. 

Features List

Each point reducible feature included in the RPS alignment is listed in 
the Features List as well as check marks for the dX, dY, and dZ compo-
nents to include in the computation. What makes RPS unique is that 
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it provides the ability to specify individually if a feature will contrib-
ute to the alignment in individual XY or Z components of the work-
ing frame. So if you specify a surface point and only use the Z axis 
then the measured point will influence the alignment only along that 
Z axis and will not influence the alignment along either X or Y.  An 
example alignment then could include a set of 3 surface points to 
define a Z axis (or a top planar direction) and a set of two holes each 
constraining X and Y to lock the position of a part in space. 

Additional information about each feature can be found by hovering 
over it, including projection plane assignment and additional toler-
ance information. 

Projection Planes

Projection planes are not required but are recommended for fea-
tures where the depth within a hole feature is not contained. A circle 
measured free-hand within the hole will have some degree of misori-
entation which will influence the fit and the resulting nominal com-
parison. However, projection planes are not part of RPS alignment. 
Surface points are expected to constrain a planar surface along an 
axis. When a projection plane is defined all features defined afterward 
that can take a projection plane as an input with include it. 

View Menu

The display of the Summary and Advanced sections of the dialog can 
be controlled through the view menu. Each or both can be hidden if 
desired to save graphic space. 

Summary Section

Figure 14-10. RPS Summary 
Section

Features that are out of tolerance will be identified in the dialog and 
marked in red in response to the numerically value entered in the tol-
erance field in the summary section (Figure 14-10). Relationships will 
additional tolerances set on them directly and who’s additional toler-
ances are out of specification will be marked in Blue. When the RPS 
alignment computation is performed the Max, RMS, and Average will 
be displayed and reflect the individual component values.

The alignment Status , Tolerance and feature count are included in 
the second column of the Summary section.   The Tolerance field con-
trols the colorization of the relationships within the feature list. 
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Advanced Section

Figure 14-11. RPS Advanced 
Section

The Advanced section (Figure 14-11) provides a set of more advanced 
controls not necessary for most fits. These include the ability to add 
scale to the fit which in turn will scale the moving instrument to pro-
duce the best possible solution. It also provides a set of weight con-
trols which will expose additional fields to adjust weights within the 
feature list. 

Surface Normal Considerations

Building a surface point through the RPS dialog will result in a point 
to point relationship being built in the tree. This relationship will in-
clude the nominal point, the measured point, and the surface normal 
from the selected surface. Its important to realize, however, that the 
alignment is still a point to point alignment. If surface points are built 
from curved surfaces it is very important to measure the actual point 
very closet to the design location or some cosine error can result due 
to the change in curvature of the surface. 

Performing a Basic RPS Alignment

Much like a best fit operation an RPS alignment is intended to pro-
vide a means to align point to their nominal locations. The only differ-
ence is that these points are the center locations of features or surface 
points and they are only used to adjust the fit along a single axis or set 
of axes. A basic fit to the NRK Demo part may go like this:

1. Add an RPS alignment using  Analysis>Best Fit Transformation> 
RPS Alignment and import the CAD model into your job.

2. Build a set of surface points on the top of the CAD model to 
define the Z axis (these should be built from planar surfaces 
normal to the Z axis of the working frame but do not need to 
be co-planar).  

3. Define a projection plane using the projection plane icon

4. Add 2 circles by first selecting the circle button and then click-
ing on the inner cylindrical surface of the CAD model to de-
fine nominal geometry relationships 

5. Double check that the surface point feature only have the dZ 
component checked and the circles have both the dX and dY 
components check but not the dZ component.

6. Add an instrument, connect and measure these features. 

7. Press the Run Alignment Icon and check that everything is 
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within the specified tolerance (set within the Summary Sec-
tion). 

8. Press the Apply Alignment Button to locate the instrument. 

Surface Alignments

Quick Align to CAD

Quick Align to CAD is intended to be a quick and easy method to 
align to a CAD model and can be initiated either through Analysis>Best 
Fit Transformation> Quick Align to CAD or through the instruments right-
click menu. The quick align dialog provides two functions: alignment 
designation and measurement guidance. 

When the quick align dialog opens, it first expects you to specify 
points on the CAD model where you wish to measure and use for the 
fit.  A minimum of six points are needed to align to a CAD model and 
these should be defined such as to fully constrain it in space. Starting 
with a 3-2-1 type laying is usually most effective. 

Point selection can be performed simply by clicking on the CAD 
model where you wish the measurements to be taken.  These points 
should be laid out in the order, as you wish to measure them, and the 
view should be oriented such that it is clear where the points should 
be taken (both the view orientation and zoom depth is saved with 
each point).  Red dots (bull’s-eyes) are used to guide the user where 
to measure (Figure 14-12). The Backspace key can be used to remove 
unwanted points if you select an incorrect location, and the Enter key 
will end the selection process. 
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Figure 14-12. Point Placement 
for a 3-2-1 type Quick Align to CAD

  

As soon as Enter is pressed the inspection process begins. The user will 
guided point by point through the list of inspection points . Measure-
ments can be added in either of two way. Any measurements taken 
by an instrument while the quick align process is active will be used 
for the alignment. Alternatively, the Pick Measurement button can be 
used to select pre-existing measurements either from the graphics or 
from within the tree to used for the alignment. 

Figure 14-13. Quick Align Mea-
surement Guidance
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Alignment computation options... Analysis>Best Fit Transformation> 

 ■ Quick Align to CAD. The quick align process performs a series 
of alignment operations. When the first point is measured the 
instrument is translated such that these points align. With the 
second measurement the instrument is also rotated to fit. With 
3 or more measurements the instrument’s points and nominal 
points are best fit together to show a reasonable graphical rep-
resentation of the alignment. Once complete a final optimiza-
tion process is performed where the measured points are then 
aligned directly to the CAD model looking to minimize the RMS 
error between the measured points and the surfaces.

 ■ Quick Align (Faces Only). This alternative menu item is very 
much the same as a standard Quick Align to CAD, the only dif-
ference is that it is more restrictive. Where a Quick Align to CAD 
performs a final points to surface alignment, this option forces 
point deviations to fit to the specific surface faces used for the 
nominal designation. With small surface faces or larger errors 
in the measurements this option provides the means to ensure 
that the points are pulling the alignment toward the correct 
surface face  even if the optimal RMS is reduced. 

Best-Fit Points to Surfaces

Performing a linear least-squares fit between a set of points and one 
or more surfaces is a common task. Often, you want to know the de-
viation of an as-manufactured part or assembly from its perfect de-
sign condition, and it is common to have the nominal design repre-
sented in a CAD package as a set of surfaces. In cases where specific 
discrete reference datums for aligning measurements to the nominal 
design are not specified (or not desired), best-fit points to surfaces is 
one method for aligning your measurements to the reference system.

Best-Fit Points to Surfaces uses optimization methods to find the 
transformation that, when applied to the instrument (and therefore 
its points), minimizes the RMS error between the measurements and 
the surfaces, taking into account your specified constraints. Typically, 
the goal is to drive all the points (compensated for probe offset) to be 
exactly on the surface. SpatialAnalyzer extends that capability by al-
lowing the operator to specify high and low tolerances for points and 
assign weights to those constraints.

Initial Condition
Like several other optimization methods, fitting points to surfaces 
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Basic Operation
For a standard best-fit, just leave the options (Figure 14-14) set to the 
defaults and then the points will be brought to the surface using a 
best-fit taking into account the target offsets of the points. Make sure 
all the surfaces you are using have their normals pointing in the right 
direction.

Figure 14-14. The Points to 
Surface Fit options.

Point Set Thinning
This option allows you to easily thin selected point sets for purposes 
of fitting to a surface. Suppose you have a scan with 10,000 points, 
but don’t want to wait a long time for the best-fit. You can specify that 
you only want to fit 400 of the points and it will evenly sample 400 
points from the selected point set.

Run Optimization
This is the default mode of operation. The optimization method per-
forms a version of the steepest-descent algorithm on the system. This 
means it assembles a matrix that is 6 (unknowns) x N (number of 
points), inverts it and determines move directions. Though quick for 
reasonable data sets, it can take a long time when using a large set of 
points depending on the amount of RAM on the computer. The stop-
ping tolerance is the amount that the objective function (RMS error) 
must repeat by in order to indicate a minima has been reached.

Run Direct Search Optimization
This optimization provides a powerful method for searching the solu-
tion space. It is also required when using the toleranced best-fitting 
options (in the advanced area) since they introduce non-linearities 
into the solution space. This method basically steps in a direction, 
evaluates the fit, then steps in another direction, etc. There is a lot of 
advanced logic built into the search, but at the core, it is a searching 
method. The advantage is that it does not have to assemble a large 
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partials matrix and invert it. This means that it can effectively deal 
with huge point sets. The disadvange is that since it is trying to ex-
haustively search, it can sometimes take a long time to complete. At 
any time during the fit, however, you can cancel the operation and 
use the current location. To use this mode, you set step sizes. They are 
set as a ratio of the position and angular perturbation values in the SA 
units options page. The step size starts at the starting value then de-
cays when it detects no improvement in any direction. Once it decays 
to the Ending step size, a minima is reached.

Recommendations
We have several recommendations for setting these options based 
on past experiences. As with many things, you may need to experi-
ment to determine the best set of options for a particular combina-
tion of points and surface geometry.

The most important recommendation is to start with a good initial 
condition. The easiest way to do this is to use Quick Align to CAD.

 ■ Reasonable point sets without toleranced fitting. Use only 
the conventional solution. It is not necessary to waste the time 
on the exhaustive search.

 ■ Huge point sets with a reasonable starting guess. Use only 
the exhaustive search with appropriate start and stop pertur-
bations.

 ■ Reasonable point sets with tolerances or unusual geom-
etry. Use both fit options.

 ■ Reasonable point sets, no tolerances, but very high accu-
racy required. Use both fit options.

Advanced Options
By pressing the Advanced button, you can open the advanced side of 
the dialog (Figure 14-15).

Figure 14-15. Advanced Best-Fit 
options.

These allow you to modify the constraints of the fit to achieve more 
complex fit ups. This may be used to avoid part to part interference in 
build operations, or other processes where the interaction between 
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parts is of interest.

Suppose we want to perform a standard best fit to the CAD surface, 
but we want to make sure none of the points are more than 0.030 
below the surface. The parameters could be set as follows:

 ■ Nominal Drive. Use default settings.

 ■ Low Tolerance 0.030, and default weight values.

The result is that the optimization will drive the points to the nominal 
CAD surface but also exert extra pressure on points that fall below 
0.030 on the negative side of the surface. Because the weight for the 
tolerance is fairly high, it will push the set of points so that the offend-
ing low tolerance points lie within the -0.030 band.

Nominal Drive (Standard Surface Fitting)
To perform a standard surface fit, use this option by checking Ac-
tive.  Set the goal value to 0.0 if you wish to drive the points to the 
surface, or you may use another value to use the offset surface. You 
do not need to set the weight unless you are using other tolerances 
in the fit.

Low Tolerance
These four variables control the low tolerance value. The tolerance 
value does not have to be on the negative side of the surface. You 
could, for example, have a low tolerance of 0.25” and a high tolerance 
of 1”. The low tolerance is simply the lowest tolerance value.

 ■ Tolerance Active. This flag allows you to easily turn on and 
off the low tolerance. Turning the tolerance off is equivalent 
to settings its weight to 0.0, except that is skips the computa-
tions necessary to determine the toleranced objective function 
value.

 ■ Tolerance Value. This value is the tolerance for the point to 
surface fit of this FitPoint. If 0.0, then the point will be driven to 
the surface (after compensating for target thickness)

 ■ Static Penalty. This value is added to the objective function in 
addition to the weighted tolerance violation. Think of this as a 
static offset applied any time a point moves beyond the toler-
ance. Initially, leave this value set to 0.0 and only use it when 
needed. When you use it, set its value low so it does not un-
necessarily increase the nonlinearity of the system. Using large 
static offset penalty values will have the effect of stopping the 
optimization prematurely.

 ■ Tolerance Violation Weight. This value is multiplied by the 
amount that the point violates the low tolerance. If the low tol-
erance is –0.030 and the points projected distance is –0.040, 
the violation is 0.010 multiplied by the Weight.
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High Tolerance
The parameters are identical to the Low tolerance except that they 
apply to the high tolerance.

Edge Projection Penalty
This value is a fixed penalty added to a point’s objective function con-
tribution if the point projects to the edge of a surface.

Network Alignments

Bundle Adjust

A bundle adjustment may be used to refine measurements acquired 
using a spherical measurement system. These include theodolites, 
laser trackers, laser scanners, etc. Basically, a bundle adjustment will 
attempt to find the instrument transformations (positions and orien-
tations) that yield the minimum combined pointing error.

Initial Guess
Since the bundle adjustment algorithms use the current locations of 
the instruments as a starting guess, it is best to “rough” position the 
instruments. To do this, either enter the instrument transformations 
manually, or use the Drag Instruments function from the Instruments 
menu. It is best to place the instruments near their final location, as 
this will speed the bundle solution. If using theodolites with level 
compensators, you will use the option to force instrument vertical 
during the bundle adjustment. If this is the case, the virtual instru-
ment models should be perfectly parallel to each other before initiat-
ing the bundle adjustment.

Scale-Bar Database
For instruments that measure angles and distances, it is not necessary 
to use scale-bars in the bundle process. They are required for theodo-
lite networks, however, because without them, the instruments will 
scale freely.

SpatialAnalyzer contains a scale-bar database. This is where you can 
enter the various scale-bars you have placed into the measurement 
area. Essentially what this database does is it associates target names 
with a scale-bar distance and uncertainty.

To modify the database, select the Scale-Bars tab from the User Op-
tions page. The next window will list all of the current scale-bars and 
their information.

To add a scale-bar, press the Add button and a new record will be gen-
erated. Complete the information required and press the Apply button. 
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You should see the information in the list window update.

Since an accurate bundle solution for theodolites requires at least one 
scale-bar, make sure this database is populated before attempting a 
bundle. In addition, make sure the targets for the end of the scale-bar 
have been shot and included in the list of targets to be included in the 
bundle solution.

Note, however, that you may populate the scale-bar database at any-
time before attempting to bundle adjust. It is not necessary to have 
this database in place before taking measurements.

Select Bundle Adjust from the Instruments menu. Next, select the in-
struments you wish to bundle using the dialog. The instruments that 
you select are the instruments that will be moved in order to refine 
the network solution. If you have 4 instruments, you will only have 
to bundle 3 because the first instrument may remain fixed while the 
others are adjusted relative to it. You may, however, select all of the in-
struments. This will make the solution take longer, however, because 
the entire network will be allowed to float in space. Next, the Bundle 
Adjustment dialog will appear. This dialog will allow you to configure 
the settings for the bundle, run the optimization, and view the results.

Selecting Targets to Bundle
Once the Bundle Adjustment window appears, you may select the 
targets to be included in the bundle. SpatialAnalyzer will default to 
including ALL of the targets. You may reduce the number of targets 
for computational efficiency or target accuracy reasons.

Scale-Bar Weight Factors
In the Bundle Adjustment window, you will notice a section for Scale 
Bar Weight factors. This section allows you to control the manner in 
which scale-bars are incorporated into the final solution.

You may change the state of the check-box to determine wheth-
er scale-bars are weighted based on their uncertainty. If this box is 
checked, the relative uncertainties in the Scale-Bar database will be 
used to weight those scale-bars with a higher accuracy more than 
those scale-bars with a lower accuracy (or a higher uncertainty). Basi-
cally, this check-box controls how multiplier scale-bars are compared 
to each other during the bundle solution.

In addition, you may enter a numerical weight that is applied to ALL 
scale-bars during the solution. This value defaults to 1.0, but may be 
increased or decreased at the user’s discretion. Note, however, that this 
value is independent of the state of the check-box. You may weight 
scale-bars based on uncertainty and/or apply an overall weight. This 
is because the overall weight is applied after the uncertainty weight 
is applied.
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Viewing System Errors
The Bundle Adjustment window displays both the Original shot er-
rors and the adjusted shot errors. This gives you a measure of how 
much the bundle adjustment has improved the overall system error.

A maximum, average, and RMS error is displayed. These values char-
acterize the combined pointing errors for each target that is included 
in the Bundle Adjustment. Each target has a pointing error, given in 
degrees. This is the amount that the measurements miss the best-fit 
computed target. The bundle adjustment attempts to minimize the 
combined pointing error by simultaneously adjusting both the posi-
tion and orientation of the instruments.

Therefore, if there are 30 points in the bundle, the maximum error is 
the largest pointing error for all of the points, the average is the aver-
age of that set, and the RMS is the root-mean-square of the set.

If you wish to see the errors itemized by target, click the Show Details 
button, and you will see a list of the targets and their errors. You may 
wish to select this option before beginning the bundle to inspect the 
list.

Beginning Computation
Click the Begin Computation button, and the Bundle Adjustment will be-
gin. As progress is made, the graphical display will be updated, and all 
of the numerical values in the Bundle window will reflect the system 
improvement.

When the algorithm has found a minimum, it will stop and issue a 
message to the user. Look at the details of the bundle to inspect the 
individual target errors as well as the scale-bar errors. If these are 
suitable, click the Accept Results button in the Bundle window, and the 
changes will be made active. The system is now bundled!

If, however, the results are not satisfactory, and you wish to start over 
where you began initially, select Cancel from the Bundle window. This 
will reset the instruments to their initial locations and re-compute the 
target locations.

Local Minima
Whenever you attempt to minimize a set of complex equations, the 
issue of local minima arises. Because you start from an initial guess 
and seek to minimize the error until you can minimize no more, you 
do not know that you are at the lowest possible minima for the entire 
solution space.

For this reason, it is possible for the bundle adjustment algorithms to 
find a solution that, while it is a minimum, is not the minimum you 
were searching for. SpatialAnalyzer contains a full 3-D graphical mod-
el of the measurement environment to help decipher some of the lo-
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cal minima. It is important, however, to start the instruments near to 
their optimal location (i.e. use a good guess) to minimize the chance 
of a local minima.

Weighting
There are several weighting factors described above. These control 
the importance of different parameters on the overall optimization 
process. There are several other weighting factors outside this dialog 
that control the process as well.

In the User Options dialog, under the Units tab, there is a button for 
Angle-Distance Weights. This button will allow you to control the rela-
tive weight of angular measurements compared to distance measure-
ments. This will only affect the bundle if you are using instruments 
that can measure distance (laser trackers for example).

Unified Spatial Metrology Network(USMN) 

Our most advanced network alignment has its own chapter (see “Uni-
fied Spatial Metrology Network” on page 721).

Job Pre-Planning and Instrument Placement

How to Pre-Plan instrument placements

Measurement projects often need to be performed within a tight 
timeline while working in a crowded environment.  For those applica-
tions it can be very helpful to pre-plan both how many instrument 
plants or station moves are necessary and where to place the instru-
ments in order to maximize the number of targets that can be shot 
from each location. 

The first step is to set up a nominal reference file.

1. Set up a job file with the nominal points you need to measure

2. Import CAD defining the structures in the building that need 
to be considered

3. Add any additional obstacles by building planes or cylinder 
defining those obstacles and then converting them too into 
surfaces (surfaces are better than basic geometry because 
they are bounded and define a specific surface area).

Add Instrument Stations to the file. 

Method #1.
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For many years SA has offered a function Construct>Points>Copy Groups 
Excluding Obscured Points this function allows you to select a point group 
measured by an instrument and build a new group that is composed 
of the points that are visible from that station. To use this method, you 
would:

1. Add an instrument to the job and position it in a candidate 
position

2. Use the Copy Groups Excluding Obscured Points function to see if all 
the points are visible from that location. 

3. Move the instrument if needed and repeat.

Method #2 (available in 209.11.21 or later) 

There is now an option within the instruments Right-Click menu to 
Show Obscured Shots. This option simplifies the process quite a bit. Using 
this method, the workflow would be much simpler:

1. Add an instrument in the job and position it in a candidate 
position

2. R-Click on the instrument and enable Show Obscured Shots, se-
lecting the groups to consider. Shot lines will be drawn graph-
ically from the instrument to the hidden points showing 
where the interference is, making it easy to adjust accordingly

3. Use R-Click on the instrument and Drag Instrument Graphically to 
re-position the instrument in a more favorable location. The 
shot lines will update dynamically as you move the instru-
ment making it easy to identify an optimal location. 
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Figure 14-16. Show Obscured 
Shots option in use displaying the 3 
points not visible from the instrument.

4. To record the instrument position and available targets use 
Construct Frame >On Instrument Base, and use the Copy Groups Exclud-
ing Obscured Points command described above. 
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SA’s watch windows are live readouts of measurement data. You can 
view the coordinates of an instrument’s measurement, watch the live 
delta transformation between two objects as they are moved, watch 
the deviation of a probe from a nominal surface, and more. This en-
ables real-time assembly operations, in which you can watch a mov-
ing object’s positional error in real-time and make corrections live. It 
also permits easy tool and fixture building,  because you can watch a 
feature’s position in real-time and check it as you make adjustments 
to the tool.

A typical watch window is shown in Figure 15-1. Depending on the 
type of watch window being viewed, you may be seeing raw coor-
dinates (X/Y/Z values) or deviations (dX/dY/dZ values). Each value 
is displayed on a separate row in the window. The window may be 
resized or even maximized as necessary for easier viewing from a dis-
tance—the text will expand to fill the available window. You can open 
as many simultaneous watch windows as you’d like--they will all up-
date automatically.

Tip:  If possible, you can use 
SA Remote (an iOS app for 

iPod/iPad/iPhone) to view watch 
window data remotely. See the 
chapter “Measurement” for more 
information.

Viewing live measurement data is essential for tasks such as real-time 
assembly and tool-building. SA’s Watch Windows provide a wide selec-
tion of digital readouts (DRO’s) that can be configured to fit those needs.

Watch Windows
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Figure 15-1. A typical watch 
window.

By default, watch windows (like almost everything in SA) show their 
data relative to the active coordinate frame. So an X value is the value 
in the working frame’s X axis, and a dZ value is the delta along the 
working frame’s Z axis. Settings for a given type of watch window are 
saved—meaning that if you, for instance, hide the X delta in a specific 
type of watch window, that value will still be hidden the next time 
you display that type of watch window.

How to Add a Watch Window

Watch windows are all about viewing the live readings of an instru-
ment. So the first step is to connect your instrument and configure it 
to send updates to SA. Most instruments will always be sending posi-
tion updates but some may need to be told to send updates. 

With a live instrument you can add a watch window in either of 2 
ways: 

1. For more applications simply right-click on the instrument, 
point or object you wish to monitor and select Add Watch Win-
dow from the menu.

2. Watch windows are also available through the menus. Navi-
gate to View> Watch Window and select the watch window type 
you would like to add.

Watch Window Types
There are a number of different types of watch windows that can be 
displayed in SA. They include:

 ■ Instrument’s Point. Shows the position of a live instrument’s 
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probe in real-time.

 ■ Point to Point. Shows the deviation of the instrument’s probe 
from a specific point.

 ■ Point with View Zooming. Compares the instrument’s probe 
to a specific point, zooming in on the point as the deviation 
decreases.

 ■ Closest Point. Compares the instrument’s probe to the closest 
of a set of points.

 ■ Point to Objects. Compares the instrument’s compensated 
probe position to the closest of one or more objects.

 ■ Three Point Frame. A point measurement from each of three 
different instruments is used to define a coordinate frame, 
which is then viewed relative to the working frame.

 ■ Two Point Axis Alignment. Two measured points are used to 
calculate pitch and roll from a given coordinate frame.

 ■ Theodolite Observer Point to Point. Compares a point de-
rived from two or more theodolite observations to any other 
point.

 ■ Theodolite Observer’s Point. Displays a point derived from 
two or more theodolite observations.

 ■ Theodolite Observer’s Data. Displays the data from the The-
odolite Observer.

 ■ Relationships. Any relationship can have a watch window 
added in order to view that relationship’s deviation.

Watch Instrument’s Point

This watch window displays the coordinates of the center of the in-
strument’s probe. It will update whenever updated data is received 
from the instrument.

To Display an Instrument’s Point Watch Window:

 ■ Right-click an instrument and select Add Watch Window from the 
context menu, or

 ■ From the menu, select View>Watch Window>Add Instrument’s Point.

Watch Point to Point

This watch window displays the deviation between the center of an 
instrument’s probe and the selected point. Offsets are not used in this 
comparison.
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To Watch Point to Point:

 ■ From the menu, select View>Watch Window>Add Point to>Point, 
then select the point to compare, or

 ■ Right-click a point and select Add Watch Window from the context 
menu.

Watch Point to Point With View Zooming

This watch window functions the same as a point to point window, 
but automatically zooms the graphical view and plays a sound whose 
pitch is proportional to the proximity of the target to the point. Off-
sets are not used in this comparison.

To Watch Point to Point with View Zooming:

3. From the menu, select View>Watch Window>Add Point to>Point 
with View Zooming.

4. Select the point to compare.

Watch Closest Point

A closest point watch window will automatically compare an instru-
ment’s probe position to the closest of a set of points. This set of points 
can be an entire group or a selection of points from a single group, 
or multiple groups. This watch window will automatically switch be-
tween points, displaying the name of the point to which it is compar-
ing. Offsets are not used in point to point comparisons.

To Watch Closest Point:

1. From the menu, select View>Watch Window>Add Closest Point.

2. Select the point(s) to compare against.

To Watch a Point Group:

 ■ Right-click the group and select Add Watch Window from the con-
text menu.

Watch Point to Objects

A Watch Point to Objects watch window will display deviations between 
an instrument’s probe position and either a single object or the clos-
est of a set of objects. It can easily be added to any individual object 
by simply right-clicking on the object in the graphics and selecting 
Add Watch Window. 

Like a query, a watch window will automatically account for probe 
offsets in its distance comparisons, and probe compensations are ap-
plied based upon the Projection Options set in the windows proper-
ties (see “Watch Window Options” on page 441).
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Object Type Differences
Watch Objects - Lines:

If the object you are comparing to is a line, SA will by default override 
target offsets to zero, since comparing the center of a probe to a line 
is far more common than comparing a compensated point to a line.

Watch Objects - Frames:

Adding a watch window to a Frame provides an added benefit if you 
have a 6D probe in that it will open a 6D watch window. This will 
report the relative distance and change in orientation of the instru-
ments probe with respect to the selected frame. 

Watching Multiple Objects at Once:

When multiple objects are selected, the closest object to the probe’s 
current position is compared. As the probe moves, the object com-
pared against may change, but the Collection and Object name of 
the object being compared to will be displayed in the Watch Window 
(Figure 15-2).

Figure 15-2. Point to Objects 
Watch Window

To Watch Point to Objects:

1. From the menu, select View>Watch Window>Add Point to>Objects.

2. Select the objects to compare against.

To Watch Point to a Specific Object:

 ■ Right-click the object and select Add Watch Window from the con-
text menu.

Watch Three Point Frame

Watching a three point frame is a fairly unique operation. It involves 
watching three 3-DOF devices simultaneously, wherein the device’s 
points define a frame’s origin, X axis, and XY plane. The watch window 
then shows the transform of this frame in the working frame.

For this command to be useful, the three instruments must be aligned 
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to the same coordinate system—that is, they must be located to each 
other. Otherwise, the spatial positioning of the three points won’t 
make sense.

If you have an object in which three points define a repeatable frame, 
you can use this command to easily determine the position and ori-
entation of the object. If you then create and activate a correspond-
ing coordinate frame representing a desired end state, this watch 
window represents the deviation needed to get to the active frame.

Figure 15-3. A three point frame 
watch window.

To Watch a Three Point Frame:

1. Ensure that the interfaces for three separate 3-DOF devices 
are running.

2. From the menu, select View>Watch Window>Add Three Point Frame.

3. Select the instrument whose point will define the origin of 
the frame.

4. Select the instrument whose point defines the X axis of the 
frame.

5. Select the instrument whose point lies in the XY plane.

Watch Two Point Axis Alignment

Often, two points defining the axis of an object must be measured 
and adjusted to either match a nominal orientation, or to match a 
prescribed pitch and yaw.

This watch window allows you to measure two discrete points with 
a single instrument. The watch window then indicates the pitch (el-
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evation) and yaw (azimuth) of the measured axis relative to the pre-
scribed axis (Figure 15-4).

The working coordinate frame defines the vertical direction—there-
fore its Z axis is used in the calculations.

To Watch an Axis Using Two Point Axis Alignment:

1. Measure or construct two points along the axis that serve as 
the nominal or “goal” points.

2. From the menu, select View>Watch Window>Watch Two Point Axis 
Alignment.

3. Select the instrument to use for measurements.

4. Select the first and second points, defining the X axis (from the 
first to the second). The measured X axis is along the direction 
from the first to the second points. The Z axis is clocked along 
the working Z axis, therefore if pitch to gravity is desired, this 
axis should be along gravity.

Figure 15-4. Two Point Axis 
Alignment.

5. The Monitor Axis dialog appears.

6. Specify the group name in the text field, if desired.

7. Click Target 1 and Target 2 to measure the points and associate 
them with the ends of the axis. The pitch and yaw values will 
update.

8. To automatically measure both targets (assuming you have at 
least two targets installed and a steerable instrument), click 
the Cycle Targets button. The instrument will point, search for, 
lock on, and measure each target.

9. As repeated measurements come in, SA will automatically 
increment the group name and put each repeated measure-
ment in a separate group.

Watch Theodolite Observer Point to Point

When using the Theodolite Data Observer (see the “Measurement” 
chapter), this watch window compares the latest computed point to 
a selected point. For instance, if you have three bundled theodolites, 

Note:  Cycle Targets will not 
work if the axis points have 

moved beyond a reasonable 
search region for the instrument.
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and they are all focused on a common target, you can query the in-
struments with the Theodolite Data Observer to calculate the posi-
tion of the target. This watch window will compare this position to a 
specified point. Note that target offsets are not used here.

Figure 15-5. Theodolite Data 
Observer and available display options.

To Watch Theodolite Observer Point to Point:

1. Ensure that the Theodolite Data Observer is up and running, 
and that your instruments are bundled (see the “Measure-
ment” chapter).

2. From the menu, select View>Watch Window>Add Theodolite Observ-
er Point to>Point.

3. Select the point to compare against.

4. As updated data arrives from the theodolite data observer, 
the watch window will automatically update.

Watch Theodolite Observer’s Point

Similar to “Watch Theodolite Observer Point to Point” on page 439, 
except the point’s coordinates are displayed—no comparison is per-
formed to another point. Note that target offsets are not used here.

To Watch the Theodolite Observer’s Point:

 ■ From the menu, select View>Watch Window>Add Theodolite Observ-
er’s Point.

Watch Theodolite Observer’s Data

This watch window displays all data from the Theodolite Data Observ-
er, depending on the settings in the Theodolite Data Observer. For 
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instance, it will display instruments and theta/phi angles from those 
instruments.

To Watch Theodolite Observer’s Data:

 ■ From the menu, select View>Watch Window>Add Theodolite Observ-
er’s Data.

Watch Window Options
Right-clicking a watch window will present a context menu contain-
ing a number of options for changing how data is represented and 
displayed. These options are discussed below.

Figure 15-6. Example Watch 
Window properties dialog used for 
configuration

Data Representation

Coordinate System
Watch windows can display data in one of three coordinate system 
types: Cartesian, Cylindrical, or Spherical. In the cylindrical/spherical 
case, the XY axes of the coordinate frame define the θ plane. In the 
spherical case, the Z axis of the coordinate frame defines the φ=0 di-
rection. Values will therefore be displayed in either of 3 ways relative 
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to the current reporting frame:

 ■ X Y Z coordinates in the default cartesian system

 ■ R (radius or distance from the axis), T (theta or rotation about 
the axis), Z (height from the origin) in cylindrical coordinates

 ■ R (radius or distance from the origin), T (theta or horizontal ro-
tation), P (Phi or vertical rotation) in spherical coordinates.

Angular Display Mode
Angular rotation values can be reported in several display modes 
when full frame to frame transformation information is displayed.

Precision
The number of decimal places used to display watch window data 
can be controlled. Depending on the necessary accuracy and the 
user’s tolerance for quickly-changing values, the default values may 
provide too much precision (revealing noise and resulting in quickly-
changing numbers) or too little (yielding insufficient detail for the re-
quired accuracy).

By default, SA uses the default length and angle precision set in the 
User Options. However, you can use any preferred precision. The op-
tions when changing decimal precision are as follows:

 ■ Use SA Significant Digits. When selected the watch window 
will use the software defaults. Deselect this to use custom pre-
cision settings for the watch window.

 ■ Length. The number of decimal places to use for displaying 
linear values.

 ■ Angle. The number of decimal places to use for displaying an-
gular values.

To Change a Watch Window’s Decimal Precision:

5. Right-click the watch window and select Precision from the 
context menu. The Watch Window Significant Digits dialog 
will be displayed (Figure 15-7).

Figure 15-7. Changing decimal 
precision in a watch window.

6. Apply your desired settings, then click OK.

Projection Options
As is the case with relationships and queries, you can control how de-
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viations are depicted in a watch window. This is handled through the 
watch window’s projection options.

The projection options for a point-based watch window are shown in 
Figure 15-8:

Figure 15-8. Projection options 
for a point to point watch window.

 ■ Nominal-Actual. Deviations show the delta from the “nominal” 
or reference point to the measured point. This presents the de-
viation from an inspection point of view—that is, how far is the 
measurement from nominal?

 ■ Actual-Nominal. Deviations show the delta from the mea-
sured point to the reference point. This presents the deviation 
from a build point of view—that is, how far do I need to move 
the probe to get to nominal?

Projection options for an object-based watch window are shown in 
Figure 15-9. There are four available indicator styles:

 ■   Deviations are from the measurement to the design—
that is, they reflect the “build” point of view.

 ■    Deviations are from the design to the measurement—
that is, they reflect the “inspect” point of view.

 ■     Deviations are the same as the “build” option above, but 
the arrows are drawn with their tails at the center of the probe.

 ■     Deviations are the same as the “inspect” option above, 
but the arrows are drawn with their heads at the center of the 
probe.

 ■ Ignore Edge Projections. This option is ignored.

 ■ Offset Value. The desired offset value when overriding the 
probe’s offset.

 ■ Override Target Value. When enabled, the probe’s offset is 
overridden by the provided value.

 ■ Add Extra Material Thickness. Adds virtual thickness to the 
objects being compared against. This is useful, for example, 
when you have an OML surface in your CAD model but you’re 
actually comparing to an IML, assuming a certain thickness for 
the material.



444

SPATIALANALYZER USER MANUAL

Figure 15-9. Projection options 
for an object-based watch window.

 ■ Tolerance Value. This value is ignored.

To Set Projection Options for a Watch Window:

1. Right-click the window and select Projection Options from the 
context menu.

2. Enter the desired settings, then click OK.

Frame of Reference
By default, watch window data is displayed with respect to the work-
ing coordinate frame. Sometimes, you may wish to display the data in 
a specific coordinate frame, regardless of the working frame (Figure 
15-10). For instance, you may have the World frame active but want 
to view a specific watch window in Local coordinates.

Figure 15-10. Changing the 
frame of reference for a watch window.

 ■ Use working frame. Always represents the values relative to 
the working coordinate frame. This is the default.

 ■ Use specific frame. When selected, a specific coordinate frame 
is used for data representation, regardless of the active frame.  

Warning:  This setting 
(along with others) is 
saved for a particular 

watch window type. If you forget 
to set this back, you may view a 
watch window at a later time with 
respect to the incorrect frame.
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The selected frame can be changed using the Pick button.

To Change a Watch Window’s Frame of Reference:

1. Right-click a watch window and select Set Frame of Referece [FoR] 
from the context menu.

2. Select the desired option, then click OK.

Tolerances
You can set tolerances for watch windows that provide deviation val-
ues. Depending on the type of watch window, this may just be a mag-
nitude tolerance (for watching objects) or individual component tol-
erances (when watching points). The Vector Tolerance dialog, which 
allows setting component tolerances, is shown in Figure 15-11.

Figure 15-11. Setting component 
tolerances for a point to point watch 
window.

In this dialog, you can enable or disable individual component toler-
ances, set all high or low tolerances to a given value, or set them all to 
a symmetrical value.

To Set Tolerances on a Watch Window:

1. Right-click the watch window and select Default Tolerance from 
the context menu.

2. Set the desired options, then click OK.

Item Visibility

Showing/Hiding Rows
Individual rows in a watch window can be shown or hidden. For in-
stance, if you are only interested in adjusting the XY position of a fea-
ture, you can remove the Z component from the window to prevent 
confusion and simplify the display.

Row entry visibility is controlled using the provided set of check box-
es. Only the checked options will be displayed when the watch win-
dow properties dialog is closed. 
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Background Window

Background Color
The Background color button provides the ability to set the color of 
the watch window in Solid Color display mode such that it can be set 
to any color needed to help in visualization. 

Transparency
Watch windows can be made transparent, so that their backgrounds 
are invisible. The window border can also be made partially transpar-
ent. This allows you to see what’s going on in the graphical view while 
a watch window is being displayed across the entire screen.

To enable background transparency select the radio button in the 
properties dialog and use the transparency Level control to adjust the 
window border transparency. 

Text Controls

Font
Watch windows can be displayed in a custom font. You can change 
the font and style. (Although you can change the font size, this set-
ting is ignored and the size of the window itself is used for determin-
ing text size).

To Change a Watch Window’s Font:

1. Right-click the watch window and select Font from the con-
text menu.

2. In the font dialog, select the desired typeface and style, then 
click OK.

Text Color
You can change the text color for the watch window on a row-by-row 
basis.

To Change Watch Window Text Color:

1. Right-click on the row in the watch window that you’d like to 
modify.

2. From the context menu, select Text Color.

3. In the color dialog, choose a new color, then click OK.

Highlight Color
If a prescribed tolerance for a watch window is exceeded, the out-of-
tolerance values will be highlighted. You can control the color used 
for this highlight.
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To Change the Watch Window Highlight Color:

1. Right-click on the row in the watch window you’d like to mod-
ify.

2. From the context-menu, select Highlight.

3. In the color dialog, choose a new color, then click OK.

Arrow Settings

When a watch window is displayed that is comparing to another en-
tity, arrows are displayed in the graphical view as a way to visualize 
the deviations. You can control how these arrows are depicted using 
the options in the Watch Window Settings dialog (Figure 15-12).

Figure 15-12. Watch window 
arrow settings.

 ■ Arrows. Specifies which arrows should be displayed: X, Y, Z, 
and/or magnitude. The X/Y/Z arrows show the dX/dY/dZ val-
ues. Magnitude shows the shortest distance between the 
watched item and the entity it’s being compared against.

 ■ Minimum Length (Static). The real-world minimum deviation 
below which an arrow does not get any shorter.

 ■ Minimum Length (Pixels). The shortest length that any arrow 
can be drawn in the graphical view.

 ■ Maximum Length (Static). The real-world maximum devia-
tion above which an arrow does not get any longer.

 ■ Maximum Length (Pixels). The longest length that any arrow 
can be drawin in the graphical view.

To Change Watch Window Arrow Display Settings:

1. Right-click the watch window and select Arrow Settings from 
the context menu.

2. Choose the desired options, then click OK.
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Graphical Guide

The Graphical Guide (Drive to Center Guide), originally available 
through the proximity triggers utility, provides a visual indication of 
the probe’s position with respect to a target in 2D. It is designed to 
make it easier for an operator to tell if they are centered on a target 
before taking a measurement, and does this by zooming in as you ap-
proach the target location(Figure 15-13). 

Figure 15-13. Graphical Guide 
Display available for many watch win-
dows and used to clearly find a location 
with high precision.

The Graphical Guide is available with Instrument’s point, Closest Point  and 
Point to Objects watch windows.

Watch window tolerances are not to be confused with the graphical 
guide proximity tolerance – they are independently set.  A Right-click 
on the graphical guide window will provide the user an option to 
change the proximity tolerance. This is a 2D proximity tolerance set 
within plane of the view. 

If you set a specific reference frame for the corresponding watch win-
dow, then that will be used to set the view orientation.  If you set the 
reference frame to working frame, then the view will follow that of 
the main display. When in tolerance the background of the graphical 
view will turn green (Figure 15-14).
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Figure 15-14. In Tolerance display 
using the Graphical Guide utility.

UDP Broadcast

Watch windows can be configured to transmit their data over TCP/IP 
using the UDP Protocol (Figure 15-15). This is useful for intercepting 
watch window data with your own custom code.

Figure 15-15. UDP Settings.

Options for UDP transmitting are as follows:

 ■ Transmit Watch Window Text over Network. When enabled, 
data is transferred over TCP/IP.

 ■ Send To. UDP packets can be transmitted to the entire subnet, 
which is referred to as a broadcast. Or, it can be directed to a 
specific destination (Single destination).

 ■ Computer Name or IP. If transmitting to a specific destination, 
the IP address or computer name of the recipient.

 ■ Port. The port over which the data should be transmitted.

To Transmit a Watch Window’s Data over UDP:

1. Right-click a watch window and select UDP Network Transmit Set-
tings from the context menu.
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2. Select the desired options, then click OK.

Transformation Tracking
For 3D instruments (e.g., Trackers) transforming objects in real time 
requires at least three on-line trackers. This functionality is also called 
Trans-Track (Figure 15-19).

Figure 15-16. Transformation 
tracking.

Each instrument will monitor and update a point. The movements of 
the set of points are used together to update objects in 6D. Select one 
point per instrument. The point selection order must be consistent 
with the Instrument selection order e.g., select the points in the in-
strument sequence. After defining the instruments and tracking 
points; select the objects that need to move with the point set. The 
Trans-Track interface (shown below) indicates the instruments being 
monitored and the respective fit error for the point that it is tracking. 
The time lapse value indicates the time lapse between the measure-
ments (i.e., synchronization error).

Relationships with Trans-Track

Relationships are dynamic by nature and work great with Trans-
Track. Watch windows can be displayed for relationships which will 
allow real time monitoring while moving. Figure 15-17 shows an ex-
ample of Trans-Track being used to join two cylindrical sections. A 
frame to frame relationship was used to monitor the position and ori-
entation of the moving unit with respect to its final nominal location.
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Figure 15-17. Using trans-track 
to join two cylindrical sections of an 
assembly.

Transform in 6D using Instrument Updates

Trans-Track can be accomplished with a single instrument if the in-
strument supports a 6D target. Examples are the Leica T-probe/T-Mac, 
API STS and Metris iGPS. This instrument can monitor and measure in 
6D. The functionality is identical to Multiple Updates.

Big Data Window
The Big Data Window (Figure 15-18) allows you to view various mea-
surement data as it arrives. This includes:

 ■ Target Name

 ■ Target Coordinate

 ■ Component Measurement Uncertainty

 ■ Pointing Error

 ■ Apex Angle

 ■ Group Comparison

 ■ Theodolite Data Observer information

 ■ Error Sensitivity

 ■ Distance Between Last Two Points

The window is customizable: you can turn different data elements on 
and off, resize and relocate their position in the window, change fonts, 
and control colors, borders, and other visual elements.

The window also allows you to step forward and backward through 
recent measurements to view the associated data, copy the data to 
the clipboard, or take a graphical snapshot of the window.
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To View the Big Data Window:

 ■ From the menu, select View>Big Data Window.

To Enable/Disable Elements of the Big Data Window:

1. In the Big Data Window’s menu, click Customize.

2. The Customize dialog appears. Select different elements from 
the dropdown, and check or uncheck their Visible option, 
then click Apply.

Figure 15-18. The Big Data 
window.

To Customize an Element of the Big Data Window:

1. From the big data window’s menu, click Customize.

2. In the Customize dialog, select the element from the drop-
down that you’d like to modify.

3. Choose among the below options to modify the element:

 ■ Text Font. The font used to display the textual data.

 ■ Text Color. The color of the font used to display textual data.

 ■ Draw. When enabled, draws a border around the element.

 ■ Border Color. Determines the color of the element’s border.

 ■ Fill. When enabled, fills the element’s background with the se-
lected color.

 ■ Fill Color. The color to use for the element’s background.

 ■ Highlight Color. Sets the highlight color, if used by the ele-
ment.

To Resize and Reposition Elements in the Window:

1. In the big data window’s menu, select Re-Size>Allow Sizing. This 
puts the window into a resizing mode.

2. Click and drag an element to move it. Right-click and drag an 
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element to resize it horizontally and vertically.

3. When finished, again select Re-Size>Allow Sizing to disable resiz-
ing mode.

To Copy the Big Data Window Text to the Clipboard:

 ■ From the big data window’s menu, select Functions>Copy text to 
clipboard.

To Copy the Big Data Window to the Clipboard as an Image:

 ■ From the big data window’s menu, select Functions>Copy graphics 
to clipboard.

To Move Through Your Measurement History:

 ■ Use the <Back>, <Forward>, and <Last> menu items in the big 
data window to navigate through historical measurement data

UDP Broadcast
SA’s instrument interfaces have the ability to send a stream of UDP 
packets when their measurements are sent to SpatialAnalyzer. To en-
able this for trackers, for example, go to the Utilities menu and select 
UDP Data Stream (Figure 15-19). Then configure the settings:

Figure 15-19. The UDP data 
stream properties.

Now, subsequent 3D and/or 6D measurements will also be sent as 
UDP packets to either the entire subnet or a particular IP address.

SA also contains a diagnostic utility so you can view this data stream 
(). Navigate file explorer to the SA install directory and run Spati-
alAnalyzer UDPMonitor.exe. Set it to the same port and hit Start. 
When measurements or updates happen, the data will flow into the 
monitor, as pictured at right.
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Figure 15-20. The UDP Monitor.

This output can be subsequently saved to a .CSV file.

SA Remote
SA Remote (Figure 15-21) is an iOS app that allows real-time viewing 
of 3-DOF and 6-DOF spatial data from SA and permits remote control 
of the SA Laser Tracker interface.

Figure 15-21. SA Remote App.

SA Remote is available as a free app on the Apple App Store for iPhone® 
and iPod® touch devices. SA Remote will also run on an iPad®.

SA Remote will receive UDP data for display from watch windows in 
SA or the Laser Tracker interface on port 10000. If multiple sources 
of watch data are available, the app allows switching between the 
sources allowing selection of which watch source on which to focus.

SA Remote can also view/control the SA Laser Tracker interface. This 
requires entering the IP/hostname of the computer running the SA 
Laser Tracker interface into the app in the settings page. Once this is 
done, SA Remote will provide display and control over the interface 
remotely.
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Setup

To download and install SA Remote, visit the app store, find the 
SA Remote app (http://itunes.apple.com/us/app/sa-remote/
id473334282?ls=1&mt=8), and select install. Once installed, run the 
app.

The upper half of the app screen is used to display watch data while 
the lower half is used to view and control the SA Laser Tracker inter-
face. Initially, the display will likely look like Figure 15-22 since no 
watch data is available yet and the SA Laser Tracker interface IP/host-
name has not yet been entered.

Figure 15-22. SA Remote as it 
first appears on the iPhone.

Touch the small “i” info button (right) which is in the upper right cor-
ner of the screen to open the quick help screen (Figure 15-23).

Figure 15-23. The SA Remote 
quick help screen.

The quick help screen provides a brief summary of the setup tasks for 
the app. It also displays the device IP address which can be used when 
setting up the UDP watch transmission settings in SA.

When running SA v2011.10.20 or newer, add a watch window and 
enable UDP broadcast. Specify port 10000. If SA is not running on the 
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same subnet as the iOS device, you may need to choose directed UDP 
transmission entering the IP address of the device. The device IP ad-
dress is available in the quick help page mentioned above. Once cor-
rectly configured, the top area of the app screen should start showing 
watch data as in Figure 15-24.

Figure 15-24. Watch Window 
information is now streaming to the 
device.

You can also enable UDP broadcast or directed transmission from the 
SA Laser Tracker interface.

To configure communications with the SA Laser Tracker interface, 
touch the small detail button in the upper left corner of the screen to 
bring up the settings view.  In this view (Figure 15-25), enter the IP or 
hostname of the computer running the SA Laser Tracker interface as 
well as the desired decimal precision and then tap Close.

Figure 15-25. Configuring the IP 
address.

Once the SA Remote app establishes communications with the SA 
Laser Tracker interface, the lower portion of the screen will enable 
and provide display and control of the interface as shown below.
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Figure 15-26. Tracker control is 
now enabled.

When the SA Laser Tracker interface is busy, the lower portion of the 
screen will be disabled for input, a busy animation will show, and the 
measure button will change to stop, allowing you to cancel the cur-
rent operation as shown at right.

If multiple sources of watch data are available (multiple watch win-
dows and/or instrument UDPs enabled) the label at the top of the 
screen will turn into a button indicating that you can tap it to select 
which source of watch data to view (Figure 15-27).

Figure 15-27. The button in the 
top left indicates you can select a differ-
ent watch source.

Tapping the button will open the watch source selection view shown 
in Figure 15-28.
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Figure 15-28. Selecting the 
desired watch source.

Select the desired source of watch data and then tap CLOSE. The se-
lected source will then be displayed on the main screen.

Available Status/Commands

 ■ The COL/GRP/TGT fields show the current collection/group/
target fields from the SA Laser Tracker interface and you can 
touch them to change the values; when changed the new val-
ues will be reflected in the interface as well.

 ■ The + buttons to the right of GRP and TGT will auto-increment 
the corresponding fields (decrement is not currently support-
ed).

 ■ The status light will reflect what is shown in the interface.

 ■ The X button can be used to remove the last measurement.

 ■ The long button above the measure button shows the name 
of the current measurement profile. When touched, it cycles 
through the quick-select profiles (1 – 4) and the name updates 
to reflect the current profile.

 ■ The ADM button commands an ADM Reset.

 ■ The RH button commands a Remote Home, if one is set.

 ■ The Measure button initiates a measurement using the current 
measurement profile and changes to Stop when the interface 
is busy and can then be used to cancel the current operation.

Google Glass App
NRK has developed an app for Google Glass that allows you to view 
watch window data in a heads-up-display directly on your Google 
Glasses (Figure 15-29).
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Figure 15-29. The watch window 
on the Google Glass app.

Since the app is not yet available on the Google App store, the fol-
lowing provides instructions for “side-loading” the app onto a Google 
Glass device—this is not necessary when adding apps from the 
Google store.

To Install the Google Glass App:

1. Download the Android SDK ADT Bundle for Windows: http://
developer.android.com/sdk/index.html

2. Extract the downloaded .zip file anywhere on your machine 
(the resultant directory will be referred to as <SDKDir>).

3. Run the SDK Manager (<SDKDir>\SDK Manager.exe), it 
will download the latest list of available packages and might 
immediately conclude that updates are available, if so click 
the Install packages button and then exit and restart the SDK 
Manager when it is finished.

4. In the SDK Manager in the Packages menu, verify that Sort by 
api Level is selected. Under Android 4.4.2 (API 19) verify that the fol-
lowing are either installed or checked to be installed:

 ■ SDK Platform

 ■ Glass Development Kit Preview

5. Under Extras verify that the following is either installed or 
checked to be installed:

 ■ Google USB Driver

6. Click Install Packages if enabled to install/update the necessary 
components.

7. Add the SDK platform-tools directory to your system PATH: 
<SDKDir>\sdk\platform-tools

8. Verify the SDK is setup by entering the below from a com-

http://developer.android.com/sdk/index.html
http://developer.android.com/sdk/index.html
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mand prompt:

  adb version

9. This should provide you with output similar to the below:

  Android Debug Bridge version 1.0.31

10. On the Glass device, under settings, there’s an option to en-
able USB debugging. Make sure this option is turned on to 
allow communications with the computer.

11. Plug the Glass into your computer’s USB port.

12. The Glass device may prompt you to allow this computer to 
debug, if so, allow it.

13. From a command prompt, enter the following:

  adb wait-for-device

This command will wait until communications with the device are 
available. If it just sits there and never returns you back to the com-
mand prompt, then something is not working. If it returns quickly 
with no output, then the installation is correct. It will eventually time 
out if a connection cannot be established.

14. From a command prompt, enter the following (this assumes 
the .apk file is in the current directory). Replace the example 
.apk filename below with the actual filename:

  adb install SAWatch-YYYY.MM.DD.apk

To Run the Google Glass Watch Window App:

1. Wake up the Glass device (tap the side or angle your head up 
30 degs) so that the main screen is displayed with the time 
and “ok glass”.

2. Either say “ok glass” and then say “watch measurements” or 
tap to get a command menu and then tap to select “watch 
measurements”.

3. Configure SA with a watch window that has UDP broadcast 
enabled to port 10000 and you should see the data displayed 
in the Glass app.

4. If there are multiple watch windows open, you can switch be-
tween them by swiping left and right.

5. To exit the app, either swipe down, or tap then tap again to 
select Stop.

Note that the app is setup as a Glass “immersion” and it is configured 
to force the screen to stay on while its running. Because of this, you’ll 
want to exit the app when done to preserve battery life.
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Uninstalling the Google Glass App:

1. You can remove the app from your Glass device by entering 
the following from a command prompt:

  adb uninstall com.kinematics.sawatch

Troubleshooting

ADB unable to communicate with device, “adb wait-for-device” hangs:

It is possible the USB driver .inf file does not have the correct entries 
for your specific Glass device. Editing the .inf file and then updat-
ing the driver in device manager (and specifying the edited .inf file) 
may fix this.

1. Open Device Manager (right-click My Computer and select 
Manage > Device Manager and find the entry for the Glass de-
vice—it may be under “Other” with a yellow icon indicating 
a problem.

2. Right-click the Glass device and choose Properties > Details. Se-
lect Hardware IDs. You’ll see something similar to Figure 15-30.

Figure 15-30. The Glass device in 
the Hardware IDs dropdown.

3. Open the android_winusb.inf file in notepad (this file can 
be found in <SDKDir>\sdk\extras\google\usb_driver.

4. In this file, there will be two sections, Google.NTx86 and 
Google.NTamd64 which must both contain entries match-
ing the hardware IDs shown in the above screenshot. In these 
sections add entries like the below based on the info shown 
in the device properties window. You can leave other, existing 
entries alone:

[Google.NTx86] 
;  Google Glass 
%SingleAdbInterface%=USB_Install, USB/VID_18D1&PID_9001&REV_0216&MI_01 
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%CompositeAdbInterface%=USB_Install, USB\PID_18D1&PID_9001&MI_01 
 
[Google.NTamd64] 
; Google Glass 
%SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_9001&REV_0216&MI_01 
%CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_9001&MI_01

5. Save the edited file and close Notepad; then go back to de-
vice manager, right-click the device and pick the option to 
update hardware drivers; when asked, browse the local com-
puter and find the edited .inf file.

6. Retry the adb wait-for-device command in the install 
section.

App Install Error, “INSTALL_FAILED_OLDER_SDK”

This suggests the Glass device on which you’re trying to install the 
app has an older SW version than what was used when building the 
app. To fix this, update the Glass SW; see the below link for more info:

https://support.google.com/glass/answer/3226482?hl=en

Glass turns off after about a minute and can no longer be used

• Software update XE17 introduced a problem with the on-head de-
tection feature.

1. Try turning off this feature in settings.

https://support.google.com/glass/answer/3226482?hl=en
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Geometry Fitting
Fitting geometry to measured points is a fundamental and critical as-
pect of almost any metrology analysis task. SA’s Geometry Fit Inter-
face has the capability to fit the following geometric shapes to any set 
of measured points or cloud points:

 ■ Planes

 ■ Circles

 ■ Spheres

 ■ Cylinders

 ■ Lines

 ■ Paraboloids

 ■ Slots

 ■ Cones

 ■ Ellipses

Fitting geometry in SA is completely interactive. You can see and in-
teract with the results of your fit settings in real-time as you mod-
ify them. You can interact with the graphical view, re-select points, 
change geometry types, and reverse offset and geometry directions, 
all while watching your geometry update in the graphical view.

Note:  When fitting slots, 
there are a few rules to fol-

low. If measuring 5 points, obtain 
3 in the middle (2 one side, 1 on 
the other other), and one on each 
end. If measuring 6 points, mea-
sure an extra point in the middle. 
For more than 6 points, distribute 
your points evenly around the 
slot.

This chapter covers a myriad of analysis operations that can be per-
formed in SA, from Geometry Fit to fitting surfaces to measurements.

Analysis
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Geometry can be fit to any number of measured points, constructed 
points, or cloud points--and it’s fast. For example, you can fit a sphere 
to 640,000 cloud points in about 12 seconds. Unlike some metrology 
software, when you select large numbers of points the geometry is fit 
to all selected points rather than a subsample.

You can easily construct interactive vector groups while tweaking 
settings to visually see how they affect the fit. Easily create cardinal 
points, offset points, or graphs of fit deviations with a single button 
click.

Another powerful feature is the ability to project points to a plane be-
fore fitting the geometry. This allows you to measure several off-plane 
features and project them to the same planar surface.

The dialog (Figure 16-1) is also designed with potential repeated use 
in mind. It enables you to fit multiple geometric features without forc-
ing you to re-select the menu command. This permits you to fit a lot 
of geometry to measured data quickly. When satisfied with your fit, 
simply click the Next button and you’re set to select points for the next 
fit.

Figure 16-1. The Geometry Fit 
interface.

To Open the Geometry Fit Dialog:

 ■ From the menus, select Construct>Geometry by Fitting, or
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 ■ Press the default keyboard shortcut of Ctrl+G, or

 ■ To fit geometry to an entire point group, right-click the point 
group in the tree and select Fit Geometry.

About Planar Offset Methods

Planar offset methods determine what is considered the “positive” side 
of resulting geometry. The positive side of planar geometry (planes, 
circles, and ellipses) is the side toward which the normal faces, and in 
metrology it is typically thought of as the “outside” of the part or the 
side of the surface that was measured (Figure 16-2).

Figure 16-2. Geometry has a posi-
tive and negative side.

When fitting geometry to points, there are three offset methods that 
can be used to determine the positive side of geometry: Probing Di-
rection, Working Origin Positive, and Right-Hand Rule.

Probing Direction
This is the direction from which the point was measured (Figure 16-3). 
For a line-of-sight instrument such as a laser tracker, total station, or 
laser radar, probing direction is the line-of-sight itself, as depicted by 
the red arrows below.

Figure 16-3. Probing directions.

For non-line-of-sight devices, the probe direction is the vector of the 
device on which the probe is attached, as depicted by the red arrow 
in Figure 16-4.
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Figure 16-4. Probing direction for 
a portable arm.

For the purposes of determining the positive side of geometry, the 
overall probing direction is the average direction of the probing di-
rections for all measured points in the fit (Figure 16-5). Put another 
way, it is simply the average of all of the individual probing directions. 
The figure at right depicts the average probing direction for the plane 
fit from the laser tracker depicted earlier.

Figure 16-5. Average probing 
direction.

When probing direction is selected as the planar offset method, the 
positive side of the resulting geometry points generally in the oppo-
site direction as the average probing direction. Put another way, the 
average probing direction points in the same direction as the nega-
tive direction of the geometry. For line-of-sight instruments, the re-
sult is that the positive side of the geometry points back toward the 
instrument, which is usually the desired result. This can be seen in the 
previous figure: The thin green arrow depicting the positive side of 
the plane points back generally in the opposite direction as the aver-
age probing direction.

The advantage of this method is that for most situations, it describes 
the resulting geometry correctly--that is, the “outside” of the geom-
etry is the side from which the measurement was approached.

Working Origin Positive
With this method, the geometry is defined such that the origin of the 
working frame lies on the positive side of the resulting geometry, as 
depicted in Figure 16-6.

Note:  Constructed points 
do not have probing direc-

tions. If no measured points are 
included in a fit, SA will fall back to 
using the Working Origin Positive 
method (described below). If at 
least one measured point is in-
cluded in the fit, then the probing 
direction is used.
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Figure 16-6. Working origin 
positive.

This is often used as the planar offset method in situations in which 
probing directions do not exist (for example, when using constructed 
or imported points).

Right-Hand Rule
This method allows you to define the direction of the resulting geom-
etry through selection order--it uses the traditional “Right-Hand Rule” 
standard. If you curl the fingers of your right hand in the direction 
from the first selected point, to the second, then to the third, your 
thumb will define the positive direction. When using this method, 
the first three points in the fit should be individually clicked to define 
the selection order--then the remaining points can be selected as a 
whole using the marquee selection tool.

Figure 16-7. Defining offset direc-
tion using the right-hand rule.

In Figure 16-7, point M4 was selected first, followed by M3, then M5. 
M6 was selected after the first three points. Because of the orienta-
tion of the first three sequentially selected points, the resulting ge-
ometry points up in this image, as dictated by the Right-Hand Rule.

About Measured Side Settings

In order to properly offset geometry, SA must know on which side a 
feature was measured. For planar geometry (planes, circles, and el-
lipses), the planar offset direction has one of three options: Above 
Plane, Probe Center, or Below Plane.

The radial analogs to these settings, used in geometry such as circles, 
ellipses, spheres, and cylinders, are Inside, Probe Center, and Outside.

Above Plane
With this setting, the line-of-sight to the target (or the probing direc-
tion) points in the direction in which offsets should be applied. This 
is by far the most common measurement situation.  In Figure 16-8, 
the tracker measured several points on the floor. Since the resulting 
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plane representing the floor should be offset away from the tracker, 
the Above Plane setting is used. In other words, the SMRs were lo-
cated between the instrument and the measured feature.

Figure 16-8. Offsetting along the 
probing direction using Above Plane.

Probe Center
This setting is used when it is preferred to ignore offsets and instead 
fit geometry along probe centers. This is not as common a setting. In 
Figure 16-9, the Probe Center setting is active. Notice that the plane 
lies along the centers of the measured points--no offset is applied.

Figure 16-9. No offsets are ap-
plied when the Probe Center method 
is used.

The radial version of Probe Center is equivalent--it implies that no off-
set is applied in the radial (inward or outward) direction.

Below Plane
This setting is used when the desired offset direction is in the oppo-
site direction as the probing direction. With this setting, the geometry 
is shifted back toward the instrument (Figure 16-10).

Figure 16-10. Below Plane 
applies offsets opposite the probing 
direction.

This is most commonly encountered with line-of-sight instruments in 
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measurement situations where obtaining a proper line-of-sight to a 
surface is not obtainable, perhaps due to lack of space or the inability 
to move an instrument.  As a result, the measured surface faces away 
from the instrument, and the probe is placed on the edge of the fea-
ture to obtain the measurement. This is often referred to as a backside 
measurement.

Inside
This is a radial setting for geometry such as circles, spheres, cylinders, 
and paraboloids. Inside (Figure 16-11) implies that the probe was 
placed on the inside of the geometry, and therefore the geometry 
should be shifted outward from the probe centers. The following fig-
ure depicts a sphere with the Measured Side set to inside:

Figure 16-11. Measured side is 
set to inside, since the measurements 
were taken on the inside of this sphere.

Outside
This is a radial setting for geometry such as circles, spheres, cylinders, 
and paraboloids. Outside implies that the probe was placed on the 
outside of the geometry, and therefore the geometry should be shift-
ed inward from the probe centers. Figure 16-12 depicts a sphere with 
the Measured Side set to Outside:

Figure 16-12. Measured side is 
set to Outside, since the measure-
ments were taken on the outside of this 
sphere.

The Fit Interface

The Geometry Fit Interface for a circle is pictured in Figure 16-13 (the 
available options change slightly depending on the selected geom-
etry).
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Figure 16-13. The Geometry Fit 
Interface

The options common to most geometry types will be discussed be-
low, followed by geometry-specific options.

Common Settings
 ■ Geometry Type Selector. Allows you to select the type of ge-

ometry to fit. This dropdown can be changed at any time to 
switch to a different geometry type.

 ■ Point Selection Buttons. Choose from either Points or Clouds. 
Click the button, then select the points to include in the fit. The 
number of selected points will be displayed below these but-
tons--choose as many points as desired.

 ■ Planar Offset Direction. Determines the planar offset meth-
od of the resulting planar geometry, using one of three pos-
sible methods: Probing Direction, Working Origin Positive, and 
Right-Hand Rule. This setting is used for plane, circle, and el-
lipse fits.

 ■ Reverse. Reverses the current offset direction. If the selected 
planar offset method does not offset in the correct direction, 
click this checkbox to reverse it.

 ■ Measured Side Settings. These settings allow you to specify 
on which side of the feature the specified geometry was mea-
sured. For planar geometry (planes, circles, and ellipses), there 
are planar settings of Above Plane, Probe Center, and Below 
Plane. For solid geometry, there are radial settings of Inside, 
Probe Center, and Outside.

Warning:  Reversing the 
offset direction does two 
things: it reverses the 

positive direction of the geome-
try (so that the normal faces the 
opposite direction), and it chang-
es the direction in which the ge-
ometry is offset from the points.
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 ■ Override. Checking this checkbox allows you to enter a value 
to override the selected probe radii and therefore use a differ-
ent offset value (not applicable to the Probe Center option).

 ■ Reverse Object Normal Vector. Flips the normal direction of 
the resulting geometry, without changing other characteristics 
(such as position or radius).

 ■ Refit Geometry. Click this button to update the fit. If this but-
ton has a blue background, it indicates that the fit is not cur-
rently valid and needs to be recalculated.

 ■ Auto Refit. When checked, changing fit parameters will cause 
the fit to automatically recalculate.

 ■ Project to Plane. When checked, you can select a plane to 
project points to prior to performing the fit.

 ■ Fit Summary. The maximum absolute error and RMS error of 
the fit is displayed in this section.

 ■ Fit Tolerance. The current user-specified tolerance for the fit. 
To enter a new tolerance, type a new number into the field and 
then click Apply.

 ■ View Point List. Opens the Point List for the fit (see below).

 ■ Graph. Displays the Geometry Fit Graph for the fit (see below).

 ■ Fit Details. Displays a detailed, geometry-specific summary of 
the fit. For example, it shows absolute and signed errors, calcu-
lated radii or sphere centers, and other important information.

 ■ Name. Use this field to specify the name for the resulting ge-
ometry. The geometry will be placed into the active collection.

 ■ Make Vector Group. If checked, a vector group will be created 
that represents a comparison between the points and the re-
sulting geometry from the fit. This is an excellent way to visual-
ize errors in the fit.

 ■ Properties. The Properties button opens the properties from 
the vector group representing the fit. This button is only dis-
played when Make Vector Group is checked.

 ■ Cardinal Pts. When clicked, creates cardinal points (centroid, 
axis points, etc.) for the geometry.

 ■ Offset Points. When clicked, creates points offset toward the 
geometry by an amount equal to the probe radius.

 ■ Chart. When clicked, creates a histogram and run chart depict-
ing point errors for the fit.

Warning:  Changing 
some parameters, such 
as removing a point from 

the fit, will not cause an automat-
ic recalculation, even if auto refit 
is checked.  In these cases, the Re-
fit Geometry  button will have a 
blue background, indicating that 
the current fit is invalid.

Note:  The vector group is 
updated dynamically. 

Changing fit parameters will 
update the vector group in 
real-time.

Warning:  Cardinal 
points, offset points, and 
charts are not dynam-

ic. Once created they are not 
updated if fit parameters are 
changed.
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Geometry-Specific Settings
 ■ Lock Radius (Circles, Spheres, & Cylinders). Allows you to 

specify a radius for the resulting geometry. SA will orient the 
specified geometry to minimize errors in the fit.

 ■ Lock Focal Length (Paraboloids). Allows you to specify a fo-
cal length for a paraboloid. SA will orient the paraboloid to 
minimize errors in the fit.

 ■ Lock Included Angle (Cones). Allows you to specify the apex 
angle for a cone. SA will orient the cone to minimize errors in 
the fit.

 ■ Standard [Geometry]/Max Inscribed/Min Circumscribed 
(Cylinders, Circles, and Slots). Specifies a different type of fit 
for cylinders, circles, or slots. Standard performs a traditional 
fit by minimizing errors. Max inscribed finds the largest geom-
etry that fits inside the specified points, whereas Min Circum-
scribed finds the smallest geometry that fits around the speci-
fied points.

 ■ Round/Square (Slots). Used to specify whether a slot should 
be round or square.

 ■ Guess Before Each Fit/Use Last Fit As Guess/Use Object As 
Guess (Cylinders, Paraboloids, Cones). Specifies how the ini-
tial condition for a fit is determined. Due to the nature of these 
fit types, the initial condition for the fit can have an effect on 
the resulting generated geometry. For example, if there is not 
great axial or radial coverage of a cylinder, it is possible for the 
cylinder fit algorithms to get “confused”. This option helps the 
fit algorithms find the proper solution. Guess Before Each Fit asks 
the algorithm to take a guess as to the initial size and orien-
tation of the geometry before it progresses through the fit to 
find the ideal solution, and is the default setting. Use Last Fit As 
Guess uses the current geometry fit result’s size and orientation 
as the initial condition for the next fit recalculation. Use Object As 
Guess allows you to pick existing geometry of the same type to 
specify the starting condition geometry for the fit algorithm. In 
this way, you can provide a “hint” as to the resulting orientation 
of the geometry. If you find that your cylinder, paraboloid, or 
cone fits are not what you expect, try using this setting to help 
the algorithm with an initial guess.

 ■ Lock Focus Location (Paraboloids). Prevents the current fo-
cus location from changing if a fit recalculation occurs.

 ■ Lock Vertex Location (Paraboloids). Prevents the current ver-
tex location from changing if a fit recalculation occurs.
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Point List

The Geometry Fit Point Listing dialog (Figure 16-14) allows you to 
view individual points and their errors in a geometry fit.

The table contains all points selected for the fit, in addition to their in-
dividual deviation from the best-fit geometry.  For circles and ellipses, 
planar and radial component error is displayed as well. To sort the list 
by a specific attribute (point name, magnitude error, radial error, etc.) 
click the associated column header. Click it again to sort the list in the 
opposite direction.

Any point can be excluded from the fit by unchecking its checkbox, 
and any excluded point can be included again by re-checking the 
checkbox. Unchecked (excluded) points appear with other excluded 
points in the list, so it is easy to find all excluded points.

Figure 16-14. The Geometry Fit 
Point List.

Points that lie outside the specified tolerance in the main dialog are 
colored red. Points in the intermediate tolerance zones are yellow 
and blue, and points inside the first tolerance zone have a white back-
ground.

To Toggle Between Absolute Error and Signed Error:

 ■ Check or uncheck the Abs Value checkbox.

To Remove Selected Points From the Fit:

1. Select one or more points in the list.

2. Do one of the following:

 ■ Click the Check or Uncheck button to include or exclude points 
from the fit, or
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 ■ Right-click any of the selected points and choose Check or Un-
check from the context menu.

To Toggle the Included/Excluded State for the Selected Points in the Fit:

1. Select one or more points in the list.

2. Right-click any of the selected points and choose Toggle.

To Permanently Remove Selected Points From the Fit:

1. Select one or more points to remove.

2. Right-click any of the selected points and choose Remove From 
List.

To Exclude Points Beyond the Specified Error Tolerance:

 ■ Click the Ignore > Tol button.

To Delete Selected Points from the SA Job:

1. Select one or more points to delete.

2. Right-click any of the selected points and choose Delete From 
SA Job.

To Change Limits or Colors for the Tolerance Zone Coloring:

 ■ Click the ellipses button next to the zone color swatches.

Tolerance Zone Coloring
The Tolerance Zone Coloring dialog (Figure 16-15) allows you to 
change the specified limits and coloring for three tolerance zones.

Figure 16-15. The Tolerance Zone 
Coloring dialog.

These zones allow you to characterize errors with three coloring 
zones. This is often useful for users who have a 1, 2, and 3-sigma toler-
ance. Each zone is bounded by limits. The first coloring zone starts at 
greater than Limit 1 and ends at Limit 2. The second zone starts at greater 
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than Limit 2 and ends at Limit 3. The last zone starts at greater than Limit 3.

In the figure at left, points with errors >0.005” and <=0.01” are colored 
yellow; points with errors >0.01” and <=0.015” are colored blue, and 
points with errors >0.015” are colored red. For users who only need 
one coloring zone, simply pay attention to the red zone and ignore 
the other two, or set all three zones to the same value.

The tolerance specified in the main Geometry Fit Interface is applied 
as the Limit 3 value.

The Quick-Set Limits section allows you to set a tolerance for Limit 1 or 
Limit 3, and then set the remaining limit values based on 1, 2, and 
3-sigma values. Click Restore Defaults to return the values to their default 
limits.

Geometry Fit Graph
The Geometry Fit Graph (Figure 16-16) allows you to view an interac-
tive graph of the errors for all points in the fit. It is an excellent way to 
visually find outliers.

Figure 16-16. The Geometry Fit 
Graph makes detection of outliers easy.

Any point (outliers in particular) can be removed from the fit by way 
of the graph, and you can also find the point name and error for every 
point.

To Remove an Outlier from the Fit Using the Graph:

 ■ Left-click the point on the graph and choose Ignore Point.

To View a Point’s Name and Error:

 ■ Left-click a point in the graph. The point name and error will 
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appear at the top of the context menu.

In addition to a run chart of the data, you can also view a statistical 
histogram of the data (Figure 16-17).

Figure 16-17. Viewing fit data in 
histogram form can also point to outli-
ers or inconsistencies in data.

The histogram also includes the Lower Control Limit (LCL), average, 
and Upper Control Limit (UCL) at 2 sigma. As seen above, the histo-
gram can also be used to detect an outlier, in this case located far 
outside the UCL.

By removing the outlier from the fit, the histogram reveals a more 
natural bell-shaped curve (Figure 16-18), as real-world data would 
typically indicate.

Figure 16-18. The outlier has 
been removed from the histogram, 
revealing a more natural Gaussian 
distribution of data.

Both the histogram and the run chart can be easily copied to the clip-
board for pasting into a report or graphics program.

To Copy a Chart to the Clipboard:

 ■ Display the desired chart, then right-click the chart and select 
Copy to Clipboard.
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Queries
A Query, much like building a dimension, is used to determine the dis-
tance or angle between objects or a set of points. It is intended to be a 
one time operation that returns many values for analysis. It is typically 
returned as a vector group containing both a distance and direction 
to indicate the magnitude of displacement between the selected ob-
jects. Queries are not dynamic, and will not update as the position of 
objects are changed, providing a means to record relative distances 
at any time during a project. For dynamic queries, you can also enable 
Auto-vectors as part of a relationship (see “General Relationship Proper-
ties & Controls” on page 512).  

The Queries  section of the Reporting Tab contains numerous methods 
for comparing points and objects. A bulk of your analysis needs can 
be found under this menu item. All query commands automatically 
account for target offset unless otherwise noted.

The output of most query commands is either a Query Results dialog 
(Figure 16-19) or a vector group. The result dialog will contain query 
specific results and can be used to create a relationship by selecting 
Create Relationship.

Figure 16-19. The Query Results 
dialog.

A vector group is a graphical depiction of the magnitude between 
points and objects (Figure 16-20). It is often displayed with arrows 
(whiskers) showing the deviation from the object to the point. 
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Figure 16-20. A vector group de-
picting error magnitude and direction.

Query Basics

When a point is compared to an object it is projected to the object 
using a local normal and then the difference is calculated (Figure 16-
21). The below example is the result of a point to object query. The dx, 
dy and dz values represent the difference between the point and its 
projected point in working coordinates. dMag represents the magni-
tude. Conventionally magnitude does not carry a sign but since ob-
jects have a positive and negative side the magnitude sign can be 
used to determine which side of the object the point lies. Also, the 
objects positive side is used for determining target offset direction. 
The target offset is simply subtracted from the calculated distance.

Figure 16-21. The anatomy of a 
query.

Query Point To Object
Displays the deviation of a point to an object. Results displayed in 
Working Coordinates.
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Object (Ignore Offsets)
Displays the deviation of a point to an object without compensating 
for target offset. Results displayed in Working Coordinates.

Point
Displays deviation between two points in Working Coordinates.

Circle (ignore offsets)
Displays the deviation of a point to a circle without compensating for 
target offset.

Query Points To Single Point
Creates a vector group contain deviation between selected points 
and single point.

Points
Points to points query results in a distance map between each combi-
nation of points (Figure 16-22).

Figure 16-22. An Inter-Point 
Distance query finds distances between 
all combinations of a set of points.

Curves/Objects
Generates a vector group with deviations from the selected points 
and the closest object (if more than one object is selected).

Circle (Radial and Planar)
Generates two vector groups, one for radial deviation and one for pla-
nar deviation.

Query Group to > Multiple Groups > Organize By Groups
Use this command to instantly compare several groups back to a ref-
erence group. This command will create multiple vector groups: One 
comparing the reference group to group A, another comparing the 
reference group to group B, and so on. This is useful for comparing 
drift checks or doing repeatability studies, enabling you to view de-
viations of multiple measured groups over time.
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Multiple Groups > Organize By Points (Gage R&R)
Similar to the “Organize by Groups” command described above, ex-
cept the vector groups contain the same point as seen over time. This 
is particularly useful for viewing the variation of a specific point over 
time (Figure 16-23).

Figure 16-23. A multiple-group 
query organized by points.

Query Point Clouds to Objects
Generates vector group containing deviation of individual points in a 
point cloud to object(s).

Query Line to Line Angle
Computes angle and mutual perpendicular between two lines.

Plane Angle
Computes angle and mutual perpendicular between line and the 
normal vector of the plane.

Query Plane to Plane
Computes angle and mutual perpendicular between the two plane 
normals.

Query Frame to Frame
Computes position and rotational difference between two frames ex-
pressed in the working coordinates.

Query Object to Object Direction
Computes angle and mutual perpendicular between the two object 
normals.

Query Sensitivity Cloud to Sensitivity Cloud
Using the SpatialAnalyzer coordinate uncertainty computation capa-
bilities, you can create a cloud of points around a measured point. 
These points represent the “cloud of uncertainty” of the coordinate. 
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If you have clouds created for at least two points, you can determine 
the uncertainty of the line between them. The results are presented 
in Figure 16-24.

Figure 16-24. Querying one 
sensitivity cloud to another.

Query Auxiliary Data
Generates a vector group using auxiliary data (Figure 16-25). This al-
lows the user to view and chart auxiliary data as you would with 3D 
data.

Figure 16-25. The Auxiliary Data 
Vector Group dialog.

Cloud to Cloud Query

Cloud to cloud query is unique in that it generates a colorized cloud 
from the relative distances between cloud points. The cloud coloriza-
tion and voxel callouts can then be used to determine the precise 
distances between the clouds  at particular locations. This analysis 
approach is designed for larger data sets than cannot typically be 
analyzed using vector groups, because of performance and graphic 
limitations. 

This command calculates a color map to show the deviations be-
tween two point clouds.

1. The first selected object is the reference object.

2. The second selected object is the measured object that will 
be projected on the reference. This cloud will be copied and 
colorized according to the deviations.

Each point is projected in the direction of the local normal of the 
cloud on a local plane. In other words, the “distance” is not the closest 
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distance to a point of the target cloud, but the closest distance to a 
local plane of the target cloud (Figure 16-26). 

Figure 16-26. Example of how a 
distance value is computed in a cloud to 
cloud query using a local plane. 

Each point to plane distance value is saved in the properties of the 
cloud point and can be displayed using the voxel colorization con-
trols when the Surface analysis Mode is set to Cloud Comparison Deviations 
(Figure 16-27). 

Figure 16-27. Voxel cloud display 
settings used to show the cloud to cloud 
query colorization.
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Vector Groups
A vector group is a graphical depiction of the magnitude between 
points and objects. It is often displayed with arrows (whiskers) show-
ing the deviation and directoin from the object to the point (Figure 
16-28). It can also be magnified to more clearly display relative devia-
tions in very small numbers.

Figure 16-28. A vector group.

Vector groups are build in the following ways... 

 ■ By using Query. This the most common method and creates a 
vector group that represents a snapshot of the deviations be-
tween points and objects. 

 ■ Auto-Vectors created with a relationship. Relationships can 
update a vector group so that rather than being a single mea-
surement event the vector group is always update to display 
the current deviations. 

 ■ By construction. At any time a snapshot of an autovector can 
be captured or there are additional construction commands to 
build or combine vector groups together. 

Vector Group Properties

Projection Options
The projection options dialog (Figure 16-29) can be seen in several 
places in SA but is mainly used in Query Points to Objects and re-
lationships. The projection options allow the user to control vector 
group direction, add material offsets, create offset point groups, and 
change probe offset compensation.
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Figure 16-29. The Query Point To 
Surface Options dialog.

Offset Probe

Figure 16-30. The Offset Probe 
vector group options.

These two options (Figure 16-30) create vector groups depicting de-
viation of the surface from the probe (left) and of the probe from the 
surface (right, the default option). Both of these options create vec-
tors with the exact same magnitude but exactly opposite in direction. 
The left option therefore depicts a typical “build” perspective (how far 
do I need to go to get to nominal?), whereas the right option depicts 
a typical “inspect” perspective (how far am I from nominal?).

Offset Surface

Figure 16-31. The Offset Surface 
vector group options.

These options (Figure 16-31) create vector groups with the head or 
tail on the center of the target and all offsets applied at the object. 
This is sometimes used with thin parts to prevent the vector from dis-
appearing behind the nominal surfaces.
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Make Point Group

Figure 16-32. Projection options 
for making point groups.

These options (Figure 16-32) create point groups instead of vectors. 
The first option applies any offset at the probe center. Unless addi-
tional material thickness is added, this represents the probe’s contact 
point on the surface. The second option applies all offsets at the sur-
face, and the third option creates projected points on the object to 
which the query is being performed.

Ignore Edge Projections
The Ignore edge projections option is used when you would like to ignore 
points whose projections onto objects lie on a surface edge (Figure 
16-33).

 

Figure 16-33. Two points which 
are edge projections.

Probe Offsets
The geometry offset allows the user to use the point specific offset 
or override the offset (Figure 16-34). The “Use the target’s values” will 
display the offset of the selected points.

Figure 16-34. Probe offset 
options.

Vector Group Properties
The vector group properties allow the user to view vector group sta-
tistics as well as change the graphical appearance (Figure 16-35).  
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Figure 16-35. The properties of a 
Vector Group.

  Components Included in Vector

The X, Y, Z check boxes  provide the ability for the deviations to be 
reported in 2D or along a single axis as needed and can be turned on 
or off in any combination. These component controls are relative to 
the working frame unless a reporting frame for the vector group has 
been set. 

  Statistics for Mag (XYZ)

The properties dialog also reports summary of the statistics for the 
vector group. It reports the following values: 

 ■ Max. The largest vector deviation 

 ■ Avg. The average deviation for the entire vector group

 ■ Min.  The smallest vector deviation or largest negative devia-
tion in the group. 

 ■ Vector Count. The total number of vectors in the group

 ■ StdDev from Zero. Reports the standard deviation relative to 
zero rather than to the average. 
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 ■ StdDev from Avg. Reports the standard deviation from the av-
erage.  

 ■ RMS. The square root of the average of the deviations. 

Display Settings
 ■ Label Vectors With Values. Display each vector’s magnitude 

(Figure 16-36).

Figure 16-36. A set of vectors 
that have been labeled with values.

 ■ Vector Magnification. Magnifies the graphical length of the 
vector. Improves viewing when deviation is small.

 ■ Line Width. Increase the graphical width of the vector for im-
proved viewing.

 ■ Show Out of Tol Only. Only displays vectors that are out of 
tolerance.

 ■ Draw As. Draws the vectors as arrows, blotches, tubes, or 
blotches with arrows (Figure 16-37).

Figure 16-37. Different methods 
for depicting error.

Color Bar
 ■ Show in View. Displays the color bar for the vector group (Fig-

ure 16-38).



488

SPATIALANALYZER USER MANUAL

Figure 16-38. A vector group 
color bar.

 ■ Redern in 2D. Converts the Color Bar display to thin 2D version 
(Figure 16-39).

Figure 16-39. 2D Color bar



489

CHAPTER 16 ■ ANALYSIS

 ■ Show Percentages. Adds additional labels indicating that per-
centage of points in each segment of the color bar

 ■ Show Fractions. Adds additional labels indicating the fraction 
of the total number of points in each segment of the color bar.

Edit Colorization
The Colorization button provides access to the Color Profile selection 
dialog.  Individual profiels can be set to more clearly display the de-
viation results relative to predefined tolerances and limits. 

     

Figure 16-40. Vector group Color 
Profile selection dialog.

Color Profiles currently offered include the following: 

 ■ Single Color. Which sets the vectors in that group all to one 
color. 

 ■ Continuous. Which provides a continuous transition of colors 
set between the High and low limits.

 ■ Tolerance (Continuous). Which displays a continual transition 
in color between the extent of the tolerance zone and the high/
low limits, but all data within tolerance have a single color.

 ■  Tolerance (Go / No-Go). This profile only displays 3 colors 
defined by the tolerance range, where data above tolerance, 
within tolerance, and below tolernce each are designated sin-
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gle color. 

 ■ Tolerance (Go / No-Go With Warning). This profile is the same 
as Tolerance (Go / No-Go) with the addition of 2 warning colors 
which indicate if values are close to being out of tolerance. 

 ■ Discrete Colors. This mode offers an option to devide devia-
tions within a selectable number of discrete color bins. 

Figure 16-41. Color Profile 
Properties

The Color Profile Properties button proivde access to customization 
options for used by the different color profiles (Figure 16-41). 

 ■ Base Colors. The base colors are used to determined the basic 
colorization used for the color bars, including High, Mid, and 
Low color selections. 

 ■ Sigma Selection Rule. In addition to setting the colorization 
based upon the limits of the data or a custom value a user may 
choose to set the color distribution at a proportion of the data 
extent. This can be helpful in ignoring outliers. 

Discrete Color selection and Color Distribution Mode options are only 
used for the Discrete Color Profile. 

 ■ Discrete Colors. A selection can be made between the num-
ber of different colors to be used (4, 8, 12) and if a special color 
display option to help with color blindness should be applied. 
Both a gray scale option and a set of colors designed for people 
with deuteranopia type color blindness is available.  

 ■ Color Distribution Mode. The discrete colors can be distrib-
uted either evently within the extents of the dat by selecting 
the Continuous option or symmetrically by distance about a 
Middle Value within fixed distances or Interval Values. 
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Figure 16-42. Color Profiles

The Color Profile selection will reveal a different number of controls 
depending on the number of colors displayed. These controls define 
the placement of the colors available in the profile. These controls  in-
clude the following:

 ■ High/Low Limit. The upper/lower extent of the defined color 
displayed. 

 ■ Hight/Low Tolerance. The upper/low extent of the tolerance 
zone.

 ■ High/Low Warning. The value which defines the begining of 
the warning zone, which will extend to the Hight/lower Toler-
ance value.

The High and Low limits can be set based upon several parameters:

 ■ Max / Min Error. This setting will adjust the color display such 
that the maximum and minimum values in the data define the 
extent of the color. 

 ■ +/- 3 Sigma. In noisy data sets outliers can cause all the colors 
to be compressed. When 3 Sigma is used the extent of the col-
orization is defined by 3 Sigma or 99% of the data. 

 ■ Custom. A custom value can also be entered. 

Currently the only Color Profile that provides full control over every 
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possible setting is the Toleranced (Go / No-Go With Warning). If the 
limits of the color are set to a custom value or 3 Sigma then the data 
values could extend beyond the defined colorization. In that case we 
add darker color above or below the defined region. 

Figure 16-43. Tolerance (Go /No-
Go With Warning) with custom limits

Report
The Report button will generate a report showing each vectors begin, 
end and delta coordinates (Figure 16-44). It also displays magnitude 
with the respective colorization. This report can be printed or export-
ed from this dialog. This report can also be generated in other formats 
such as Quick and Composite reports.  

Each column can be sort ascending or descending when name value 
is double left-clicked.
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Figure 16-44. Viewing a vector 
group report.

Chart
The chart button will generate one of three predefined charts (Figure 
16-45).

Figure 16-45. Chart Type.

The user can select the inputs for the chart type (Figure 16-46):

Figure 16-46. Axis settings for 
the charts.

Once the chart is generated (Figure 16-47) it is saved in the SA Treebar.
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Figure 16-47. The resulting 
generated chart.

Chart Options
For more information on Statistical Process Control (SPC) and chart-
ing options refer to  “Charting” on page 692.

Vector Construction Options
By Clicking Surfaces

Creates a vector group from clicking on surface face. These vectors 
are of a fixed magnitude but will use the surface normal direction.

From Existing Vectors
Creates a new vector group from selection of individual vectors.

From Existing Vector Groups
Creates a new vector group from selection of existing vector groups.

Scale Existing Vector Groups
Creates a new vector group scaled about the selected frame.  User 
may select a scale factor for each component of the vectors (Figure 
16-48).
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Figure 16-48. The Scale Vector 
Groups dialog.

Copy Vector Groups Excluding Obscured Vectors
Creates new vector group only coping visible vectors. Vectors blocked 
from current point of view are not copied.

Area Profile Check 
Area Profile check builds a new vector group to display the relative 
difference between the evaluated vector group(s) and the reference 
vectors with a specified area (Construct>Vector Group>Area Profile Check).

The Area Profile check has several inputs:

 ■ Reference Vectors.  This can be a grid of vectors across the 
model which designate the centroid of an evaluation region. 
These reference vectors are used to define each evaluation re-
gion and they also define the base magnitude for comparison 
within each region.

 ■ Vector Group(s). The vector group or groups to be evaluated.

 ■ Radius to check. Defines the distance from the reference vec-
tor used for each evaluation in selecting surrounding vectors 
to evaluate.

 ■ Area Tolerance.  The tolerance to use for the evaluation (which 
will be applied bi-laterally) and is used for vector colorization 
(go/no go).

Reference Vectors can be simply sub-sampled or built yourself. The 
spacing of these reference vectors define the evaluation coverage. 
With more gaps, regions will be missed, however, with more overlap 
you end up with redundant data and a slower evaluation (Figure 16-
49). 
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Figure 16-49. Reference Vector 
Distribution and Evaluation Overlap

As an example, if you wish to evaluate the area profile at 0.005” in ev-
ery 5” segment using the following Reference Vectors (Figure 16-50): 

Figure 16-50. Reference Vectors

This Area Profile Check would produce the following result (Figure 
16-51):

Figure 16-51. Area profile Vector 
Group Results

The evaluation process is as follows:

1. For each reference vector a list of vectors is created that fall 
within the evaluation radius.

2. For each vector in the list a new vector is created with the 
same position and orientation. The magnitude of this new 
vector is equal to vector magnitude minus the reference vec-
tor magnitude. 
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3. The color (Red/blue out of tolerance, or Green in tolerance) is 
set based upon your specified tolerance.    

The resulting vector group shows the difference between the refer-
ence vector magnitude and the returned vector for each evaluated 
region and can be useful in evaluating the relative change in magni-
tude within a region.  

From Point Measurement Probing Directions
Creates a vector group representing the probing direction stored for 
each selected point.

From Polygonized Surface Normals
Creates a vector group with a vector normal to each face of the 
polygonized surface. 
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 Advanced Surface Fitting
From Point Groups (Interpolate)

Creates a interpolated surface by fitting b-splines to each selected 
group (Figure 16-52) and then lofting the b-spline to create a surface 
(Figure 16-53).

Figure 16-52. Fitting B-Splines to 
a series of points.

Figure 16-53. A surface has now 
been fit from the B-Splines.

From B-Splines (Approximate)
Similar to the above command, this time each b-spline is an approxi-
mate fit. The user has control of the control points, degree of curve 
and the skinning tolerance.

Note:  Points in the selected 
point groups must be in or-

der or the b-spline will be created 
incorrectly.
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Figure 16-54. Defining the num-
ber of intermediate control points.

Figure 16-55. Specifying the 
degree of intermediate curves.

Figure 16-56. The skinning toler-
ance indicates how far the surface may 
deviate from the B-Splines.

From Plane and Closed B-Spline
Projects selected closed B-spline to selected plane and creates a sur-
face from the projection (Figure 16-57).

Figure 16-57. A closed B-Spline 
has been projected to a plane.

Fit From Bounding Curves and internal points
Use for B-splines that bound a group of points (Figure 16-58) to create 
a surface (Figure 16-59).
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Figure 16-58. Four bounding 
B-Splines around a surface.

Figure 16-59. The resulting 
surface.

 Fit From Nominal Face and Actual Data
A surface will be created by fitting the selected surface face to the 
selected data (Figure 16-60).
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Figure 16-60. Fitting a surface 
face to selected data.
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Frame Wizard
The Frame Wizard (Construct>Frame>Frame Wizard) is used to create a 
coordinate frame based on different combinations of entities, which 
can then be optionally offset in the new frame’s X, Y, and Z directions.

Figure 16-61. The Frame Wizard 
dialog.

The Frame Wizard dialog (Figure 16-61) allows you to interact with 
the graphical view while changing the settings for the frame. Once 
enough parameters have been defined to construct a coordinate 
frame, you see the frame in the view and it changes as you modify the 
settings.

The following describes the specific settings for this command:

 ■ Primary Axis. The axis to use as the primary axis for the coor-
dinate frame. Since this axis is primary, it is perfectly parallel to 
the vector constructed by its defining entities. The primary axis 
and secondary axis must make sense--for example, you cannot 
define the +Z axis as primary and the -Z axis as secondary.

 ■ Secondary Axis. The axis to use as the secondary axis for the 
coordinate frame. The plane defined by the primary and sec-
ondary axes will be parallel to the vector constructed by the 
secondary axis’s defining entities.

 ■ Origin. A single point in space that (assuming no offset) de-
fines the origin of the coordinate frame.

 ■ Enter Values in Frame. Click this button to define a new XYZ 
coordinate. The coordinate frame will be shifted such that the 
originally defined origin point ends up at the supplied coordi-
nates.

 ■ Name. The name for the resulting coordinate frame (in the ac-
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tive collection). To change a name, type it in, then click the Apply 
button.

 ■ Set Working Frame. If checked, the new coordinate frame will 
be set as the active coordinate frame.

Figure 16-62. A frame defined by 
an origin at point Origin, a primary axis 
(+Z) by a cylinder, and a secondary axis 
(+X) by the origin and a point named 
Clocking. No offsets have been applied.

Figure 16-63. The same frame 
which has been shifted using Enter 
Values in Frame so that the origin ends 
up at (5, 5, 5).

The primary and secondary axes can be defined by an object, 2 points, 
or an origin and point:

 ■ Object. The object’s internal normal direction defines the direc-
tion of interest. For example, if a plane is selected, the normal 
to the plane is used. Note that some objects (such as spheres) 
do not define a direction and  therefore cannot be used with 
this option.

 ■ 2 Points. The vector from the first point to the second defines 
the direction of interest.
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 ■ Origin & Pt. The vector from the defined origin to the selected 
point defines the direction of interest. An option is also avail-
able to select an object. When this is done the selected Object’s 
origin point is treated as the point definition. 

The origin can be defined by either an object or a point:

 ■ Select Point. A single point will define the position of the ori-
gin. Point offsets are not applied.

 ■ Select Object. An object’s internal origin defines the origin of 
the frame. For example, if a sphere is selected, the center of the 
sphere is used.

Working with CAD Models Directly
In addition to the object and point select options a right-click on an 
Object, 2 Points or Origin & Pt. button opens up a list of options to 
directly extract and build those objects or points by selecting surface 
faces on the CAD model directly. 

To Create a Frame with the Frame Wizard:

1. Select the appropriate primary and secondary axes to define.

2. Click the appropriate buttons to define entities for the pri-
mary axis, secondary axis, and origin. These entities can be 
defined in any order.

3. If desired, enter coordinates to shift the frame using the Enter 
Values in Frame button.

4. Type a desired name for the frame and click Apply.

5. When finished, click the Accept button.
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What is a Relationship 
Relationships are not physical objects in themselves but a defined 
link between objects. In the simplest case a relationship calculates 
the distance between two related entities and re-calculates this dis-
tance whenever either of the related items are moved.  This linking 
process is quite efficient and can be expanded to include many points 
and many objects simultaneously.  By building a relationship you can 
use this dynamic link in many powerful ways. 

 ■ Reporting. Relationships can be used for automatically up-
dating dynamic changes between objects. Relationships can 
therefore be used directly to report deviations.

 ■ Build Operations.  Relationships can be used to update dis-
plays or watch windows to guide users to specific location for 
part alignment.

 ■ Dynamic Geometry Fitting.  Geometry Relationships are a 
special type of relationship that updates the properties of an 
object based upon the measurements. The relationship links 
the measurements to the resulting geometry making it dy-
namic.

 ■ Alignment.  Multiple Relationships can be used simultaneous-

Relationships are extremely powerful tools that have a number of uses: 
Dynamic inspection, alignment, virtual fit-up, real-time assembly, and 
optimization can all be driven by SA’s relationships. Relationships pro-
vide optimization results that far surpass traditional methods, and with-
out a complicated setup process.

Relationships
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ly and weighted independently for sophisticated alignment 
operations 

Definition of Relationship Types

Points Based Relationships

The simplest relationship types are points based relationships. These 
relationships continually evaluate the distance between the associat-
ed points and objects and are used primarily for reporting and align-
ment purposes.  

Point to Point
Reports deviation between two specific points.

Point to Object
Reports deviation between a specific point and object.

Points to Objects
Reports deviation between one or more points and the closest se-
lected object from a list of one or more objects.

Groups to Objects
Reports deviation between multiple groups and multiple objects.

Point Clouds to Objects
Reports deviation between the points contained within one or more 
clouds and the closest object from a list of multiple objects.

Group to Group
Reports deviation between points of the same name in two point 
groups. Along with the Group to Nominal Group relationship it can 
be used for alignment through the right-click option Exectute Align-
ment. Doing so triggers a best fit using the two associated groups, 
aligning the second group to the first. 

Object Orientation Relationships

Object orientation relationships were added to monitor differences in 
the 6D orientation of one object relative to another object.  

Object to Object Direction
Reports the angle and mutual perpendicular distance between two 
objects.

Frame to Frame
Reports a delta transform between two frames expressed in the work-
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ing coordinates.

Special Function Relationships

Group to Nominal Group
This relationship type functions like a Group to Group relationship 
but with added inspection guidance.  It provides: 

 ■ Visual guidance with bull’s-eyes identifying the unmeasured 
points

 ■ Automatic renaming functionality by proximity

 ■ Closest Point Watch window function

 ■ Along with the Group to Group relationship it can be used for 
alignment through the right-click option Exectute Alignment. Do-
ing so triggers a best fit using the two associated groups, align-
ing the measured group to the nominal. 

For more details refer to “Group to Nominal Group” on page 520.

Points to Points 
This relationship type functions like a Group to Group relationship in 
that it provides a comparison between commonly named points. Its 
unique in that it gives the user the flexibility to select points from a 
combination of groups both as reference and as actual. All possible 
comparisons will be made between points in the reference list and 
those within the actual list by point name, regardless of collection 
and group designation. 

Vector Group to Vector Group
Built with Sim and Gap applications in mind, this relationship requires  
a Points to Surface Face relationship and a corresponding vector 
group representing the far side of a gap. It then computes a delta 
vector group defining the current gap statistics and can be used for 
alignment. 

For more details refer to”Vector Group to Vector Group Relationships” 
on page 522.

Points/Groups to Surface Faces
Points to Surface Faces and Groups to Surface Faces function just like 
Points/Groups to Objects relationship but are tied directly to CAD sur-
face faces, providing greater control in comparisons. 

Clouds to Surface Faces
Clouds to Surface Faces functions just like Clouds to Objects relation-
ship but are tied directly to CAD surface faces, providing greater con-
trol in comparisons. 
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Point Cloud to Swatch
The Point Cloud to Swatch relationship can be thought of as a surface 
point analysis tool. It is an even more specialized cloud to surface face 
relationship that also takes a reference point on that surface as an in-
put. It then builds a mini cloud using only cloud points within a prox-
imity to the reference point and a surface normal vector from a large 
point cloud. The resulting computed point uses the average distance 
values in the cloud swatch to compute the  point offset. 

Pipe Fitting
Pipe relationships are designed specifically for pipe alignment and 
cut calculations (see “Pipe Relationships” on page 542).

MP Execution
This MP serves only a single purpose which is to provide a means to 
identify and run an MP as part of a inspection.

Geometry Relationships

Geometry relationships build dynamic geometry. They continually 
update the position, orientation and size of an SA object based upon 
the associated points or objects. They also report deviations between 
measured and nominal geometry. 

Geometry Comparison
This relationship type can be subdivided into 3 types: 

 ■ Fit and Compare to Nominal.  This type provides a full fit and 
compare function between the measured points and the se-
lected nominal geometry. 

 ■ Fit Only. Without a nominal assignment, Fit Only relationships 
build dynamic geometry but do not provide a comparison to 
a nominal feature (These relationships can easily be expanded 
to Fit and Compare to Nominal relationships with a nominal 
designation). 

 ■ Compare Only. These relationships only calculate and com-
pare the differences between objects of the same type. They 
do not perform geometry fit functions. 

Average Point
These relationships are the points equivalent of a geometry relation-
ship. The average point relationship calculates a points position based 
upon the associated input points and compares it to a nominal point.   

Select Nominal Frame... Frame Wizard
This relationship is the frames equivalent of a geometry relation-
ship. Like a Frame to Frame relationship it compares the position and 
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orientation of two frames, but the relationships “measured” frame is 
built upon the associated points and features using the Frame Wizard 
selection utility(see “Frame Wizard” on page 502). 

This frame can therefore be built upon other geometry relationships 
which in tern make it a dynamically updating frame. For this reason, 
geometry extracted from CAD is built as a placeholder geometry rela-
tionships that is then added to the tree, ready to be measured. This is 
a difference from the construction tool which builds a frame from the 
nominal features extracted from the CAD model. 

Frame Wizard relationships can also be used for alignment when a 
nominal frame is assigned. Using the Execute Alignment option in the 
right-click menu will perform a frame to frame alignment, aligning 
the measured frame to the nominal frame.  

A special CAD only option has been added to the Toolkit that is re-
stricted to building geometry from a CAD model but has the added 
benefit of building the nominal frame as well as adding the measured 
features. This is perfect for defining a frame to frame or 3-2-1 type 
alignment to a job file that is dynamic and repeatable. 

Auto Detect Feature
An Auto Detect feature is a placeholder that can be used to built a 
Geometry  Relationship of the correct geometry type automatically 
based upon an RMS fit threshold to the associated points. It is intend-
ed to be used with Feature Trapping but can also be used with direct 
association. 

Figure 17-1. Smart Feature Fit to 
Points as seen in the Ribbon Menu.

How it works

When trapping stops (by progressing to the next feature in the list) 
an attempt will be made to  resolve the correct geometry type. This is 
done through a sequential series of fits to the data set comparing the 
results to the acceptance tolerance. 

The search sequence is: Line, circle, slot, plane, cylinder, sphere, cone.

Once an acceptable fit is found (a fit with an RMS below the specified 
tolerance) the search stops and the geometry is built. This can also 
be triggered through a right-click menu Resolve Smart Feature Geometry. 

Projection Plane Control

When enable, the active projection plane is set automatically as part 
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of the Smart Feature resolve process. The idea being that each time 
plane is resolved it is set as the new projection plane. This works well 
when measuring lines/circles/slots on a sequence of different planes. 

Note that a plane 90 degrees to the original will resolve as a line not a 
plane. So moving from one projection plane to another will work best 
if the planes are not perfectly orthogonal to the last.

This Auto Reset Projection Plane operation is optional and can be turned 
off in the configuration.

Detect Nominal from CAD

A search for the nominal feature is also included in the smart feature 
resolve process. This means that if you align to CAD first you can mea-
sure features as desired and record both the nominal and measured 
feature from the CAD as you go.

Dynamic Geometry 

Dynamic Geometry are a type of Geometry Relations that uses other 
objects or features for its computation. Like Comparison Only rela-
tionships they do not provide an option to select points but only 
evaluate the selected features for the computation. 

General Computations
Dynamic Point

 ■ Mid-point of perpendicular to Two lines. Use to establish the 
intersection point between two imperfect lines.

Dynamic Line

 ■ Cylinder Axis

 ■ Cone Axis

 ■ Bisect Two Lines. Use to create a line at the center of two refer-
ence lines.

 ■ Slot Center line along length

Dynamic Plane

 ■ Bisect Two Planes. Use to create a line at the center of two 
reference lines.

 ■ Offset Plane. Used to hold a specific distance and orientation 
relative to a reference plane.

Dynamic Circle

 ■ From Multiple Circles. Used to build a circle through a set of 
reference circles such as a bolt hole pattern. 
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Intersections
These relationships compute and update a feature based upon the 
intersection of other geometries. The following intersection geom-
etries are currently available:

Dynamic Points

 ■ Intersection of a Line and Plane

 ■ Intersection of a Cylinder (axis) and Plane

 ■ Intersection of a Cone (axis) and Plane

 ■ Intersection of Three Planes

Dynamic Line

 ■ Intersection of Two Planes

Dynamic Plane

 ■ Intersection of Two Cones (combinations)*

 ■ Intersection of Cone and Cylinder (combination)*

Dynamic Circle

 ■ Intersection of Cylinder and Plane (combinations)*

 ■ Intersection of Cone and Plane (combinations)*

 ■ Intersection of Sphere and Plane

 ■ Intersection of two Cones (Best-FIt Plane)*

 ■ Intersection of Cylinder and Cone (Best-Fit Plane)*

Dynamic Ellipse

 ■ Intersection of Cylinder and Planes

 ■ Intersection of Cone and Planes

Most intersections have a clear mathematical solution such as the in-
tersection of a line and a plane. However others require more expla-
nation and are marked with “*”.

 Cone/cone and cone/cylinder intersections can be computed as a plane, 
ellipse or circle depending on the customers needs. These are com-
puted as follows:

1. An exact analytical solution for 16 points spaced at uniform 
angular rotation about the axis of the first cone are developed 
for the intersection between the cone/cone or cone/cylinder.

2. These 16 points are used as input for determining a best-fit 
plane (approximate unless axes are coincident).

3. Ellipse is analytically constructed for the intersection of the 
first (only) cone with the best-fit plane.
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4. Circle is constructed from ellipse by setting circle center to 
ellipse center and the radius = sqrt(major*minor) [constant 
area]

5. Circle normal is set to best-fit plane normal, first cone axis, or 
second cone (cylinder) axis.

Its important to realize that, as cone/cone or cone/cylinder axes devi-
ate further from coincident, the approximate solution degrades and 
as cone/plane or cylinder/plane deviate from perpendicularity, the 
solutions for circles created by intersection degrades. Therefore these 
intersections are intended primarily for situations where the axes are 
constrained such as measurements of shafts.  

General Relationship Properties & Controls
Relationships function like dynamic queries. They calculate the spa-
tial deviations of the associated points from the associated objects. 
Any time either a new point is added or the associated objects are 
moved, the relationships are recomputed. This ensures that the cor-
rect deviation statistics are always displayed. 

Relationships provide many controls and the number of controls in-
crease with complexity. This section provides an overview of the gen-
enaral property controls available for most relationships. 

Visual Controls

Highlight Entities
Highlights all the associated points and/or objects. This button func-
tions as a toggle to turn on and off highlighting. 

Add Watch Window
Adds a watch window to the relationship. The watch window type 
will depend on the specific relationship type but typically displays the 
Max deviation and RMS for the relationship ((Figure 17-2). 

Figure 17-2. Relationship Watch 
WIndow
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Add Callout
This command does either of two things. If a callout view is active, it 
adds a callout for the relationship to the active callout view. On the 
other hand if no callout view is active it builds a new callout view and 
adds a callout. 

Create Associated Inspection Callout
This builds a new callout view and it adds the relationship callout to it. 
It also activates the callout view when trapping is initiated. 

Disable Associated Inspection Callout
This disables the link between the relationship and the inspection 
callout such that it is no longer indicated when trapping begins.

File Management Tools

Delete
This command deletes the relationship.

Copy
This command copies the relationship to the active collection. It will 
prompt the user to either keep the object/point associations or clear 
them. 

Move to Another Collection
This command allows the relationship to be relocated to another col-
lection within the job file. 

Rename
The command provides a method to rename the relationship. 

Projection and Fit Controls

Properties
Some relationships provide a condensed set of primary controls in 
the Properties menu while others are controlled directly though the 
right-click menu for the relationship. 

Projection Properties
Relationships have the same projection properties as a query. They 
provide the same probe compensation options with the added ben-
efit of allowing changes to these settings at any time (Figure 17-3). 
These options include display and probe offset controls including:

 ■ Indicator Style. Which defines the direction of the vector and 
the associated end point locations.

 ■ Ignore edge projections. When enabled this check box causes 
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point projections to be ignored from the relationship compu-
tation. 

 ■ Offset Value. When the Override  Target Value check box is 
checked the point offsets will be ignored and the entered value 
will be used in place. 

 ■ Add Extra Material Thickness. When enabled this check box 
will added the entered additional material thickness to the off-
set compensation. 

Figure 17-3. Relationship Projec-
tion Options

 

Fit Weight
This command controls the weight assigned to the relationship as 
part of an alignment operation (see “Minimizing Relationships” on 
page 535). 

Tolerance Controls
Tolerances can be set for any relationship and apply to all the indi-
vidual point deviations for both alignment and reporting purposes   
(Figure 17-4). 
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Figure 17-4. The Vector Tolerance 
dialog.

Individual tolerances can also be applied directly to nominal points 
and these point tolerances will be picked up and used within a Group 
to Group ( and Group to Nominal Group) or point to point relation-
ship. These individual tolerances will then be reported for the rela-
tionship report unless the override option is checked within the rela-
tionship properties dialog (Figure 17-8). Point to Object relationships 
will not use point tolerances as it is assumed that tolerances on mea-
sured points should not apply to a surface analysis.

Fit  Constraints
When a fit constraint is added to a relationship it defines a “dead” re-
gion where the relationship has no influence.  For example, a high 
limit can be set at +0.1 and low at 0. This will define a region from 0 to 
+0.1. When the solution reaches this region, the relationship will stop 
influencing the solution and the fit will only continue to optimize if 
other relationships are involved (see “Minimizing Relationships” on 
page 535).

Sub Sampling Options 
Relationships provide sub-sampling controls to increase processing 
speed for large data sets. These include two categories: 

 ■ Fit using every i-th point 

Using the Fit using every i-th point control provides the ability to dis-
play a reduced number of vectors that continues to increase in num-
ber as the data set increases in size. When i=1, all the point deviations 
are used for display and calculation. As i increases so does the num-
ber of skipped points. 

 ■ Fit using no more than n points

Using the Fit using no more than n points control provides the ability 
to place a hard limit on the number of points used in the relationship 
for display and reporting purposes. 

Outlier Rejection
This command provides a the ability to set a threshold beyond which 
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points are ignore (see “Minimizing Relationships” on page 535).  

Auto Update Vector Group
This option the use to create a dynamic vector group. Any time the 
relationship updates the vector group will update as well using the 
associated points and objects.

Make Vector Group (static)
This option allows the user to capture the current condition of an 
Auto Vector by copying it as a separate vector group. 

Reporting Options and Controls

Include in Composite Quick Report
This option is determines if a relationship is included or excluded au-
tomatically in quick report.  

Generate Quick Report
This command generates a quick report for the selected relationship 
only. 

Add to Active SA Report
This command adds the relationship to the active report. 

Reporting Options
Report Options control how the deviations will be reported and the 
format of the resulting relationship tables in a report (Figure 17-5). 
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Figure 17-5. Relationship Report-
ing Options.

Controls within the Reporting Options include:

 ■ Coordinate System

Report tables can display points in either of 3 formats:  Cartesian 
(XYZ), Cylindrical (RTZ) or Spherical (RTP) coordinates. The reported 
values are presented relative to the working frame unless specified in 
the reporting frame control. 

 ■ Tables

Relationships default to displaying both a summary table and a single 
line details table.  When enabled the  “Table per Object” option subdi-
vides the details table into multiple details tables, one for each object 
associated in the relationship.  

The summary contains a snapshot of the relationship (Figure 17-
6). The complete options will display all the individual deviations.
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Figure 17-6. Relationship Sum-
mary Table.

 ■ Components

Each of the components of the details table can be turned on and 
off with these check box controls. The display of tolerances can be 
turned on and off, along with the tolerance color column. 

 ■ Naming and Ordering

Points can either be displayed using their individual names of the 
full Collection::Group::Target format to help identfy points in the tree 
with similar names.  The point are displayed in the order in which they 
appear in the tree by default. An option was added to sort the order 
in which they appear by their names. 

Custom Headers can also be added. If a new heading is added they 
will replace the default Point A and Point B headings in the detail ta-
ble. 

 ■ Record Format

Several formatting options are available for the details table includ-
ing single line and 2 multi-line formats. 

 ■ Default Settings

The report settings can be applied to other relationships by either 
setting this relationships configuration as default or by applying the 
setting explicitly to other relationships. 

Reporting Frame
By default relationships are reported relative to the working frame. In 
order to report relative to a different frame one must be specified and 
this option provides the control to do so. 

Combined Relationship Reports

Relationships Report
Accessed either through the Report menu or through the right-click 
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category. This Relationship report is designed to report details on all 
relationships except Geometry Relationships. It includes a summary 
table with basic statistics on each of the relationships in the selected 
collection and the details table for each of those relationships that 
has this details table enabled in its Report Options (Figure 17-7). 

Figure 17-7. Relationship Report

Recomputation

Relationship Dormant Status
Relationships update continually with the job file. With a large num-
ber of relationships in the job this re-computation process can take 
valuable time. For this reason a flag was added to allow individual re-
lationships to be temporarily set as “dormant”. When marked as such 
the relationship will be marked with a snowflake icon   to indicate 
that the status is “frozen” and will not be refreshed until the dormant 
status is turned off. Be sure to turn off and refresh all the relationships 
before reporting results. 

An additional menu option Analysis>Re-Compute Relationships was added 
to aid in this process. 

Measurement Associations

Associate Data
This control allows new data to be associated with a relationship. De-
pending on the type it provides options to pick points and/or objects  
and replacing the current list of objects with the new selection. 

Clear Point Associations
This option clears the relationships associations. 
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Delete Point Associations
This option deletes the points associated with the relationship as part 
of clearing the relationship. 

Measurement Trapping and Trapping Controls

For greater detail on trapping (see “Why Feature Based Inspection” on 
page 825).

Trap Measurements from an Instrument
This  indicates trapping of measurements from a live instrument. 
When trapping is set any measurement obtained from the selected 
instrument will automatically be associated with the instrument. 

Stop Trapping Measurements
This commands stops trapping 

Trap Selections
Trap selection acts like trapping from an instrument but allows the  
operator to graphically select points to be added to the relationship.  
It is a great way to add additional points without having to reassoci-
ate all the points at once. 

Configure Instrument
Instrument configuration provides options to control instrument set-
tings when trapping is indicated. 

Lock Out Trapping
Excludes the relationship from the list of relationships within the in-
spection tab of the toolkit (see “Feature Inspection” on page 832).

Change order in List
This changes the order of the select relationship within the relation-
ship category in the active collection. The order in inspection tab mir-
rors the order of the relationships in the tree so being able to control 
its position in the list is important .

Properties & Controls - Special Function Relationships

Group to Nominal Group

This relationship type functions like a group to group relationship but  
with added inspection guidance. 
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Key Features: 
This relationship assumes that the 1st group associated is the nomi-
nal or design group and uses this group for guidance in measuring 
the corresponding group. 

Trapping Controls:
When trapping is started for a Group to Nominal Group relationship 
bull’s-eyes are drawn on each of the points in the nominal group to 
guide the operator to measure those points on the part. Additional 
user guidance can be turned on and off within the properties dialog 
(Figure 17-8).

Figure 17-8. Group to Nominal 
Group Properties Dialog.

 ■ Update a vector group with relationship

This function turns on an auto-vector group that provides a direct vi-
sual indication of the distance between the points in each group. 

 ■ User closest point to match new measurements

With this function enabled the point name control in the instrument 
interface is automatically set to a default “g2ngrTrap-p#”.  As each 
point is measured it is automatically compared to the points in the 
nominal group and takes on the same name as the closest point. An 
initial alignment is helpful in ensuring the correct name is assigned.
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 ■ Display closest point watch window

This option turns on a watch window that displays the distance be-
tween the probes current position and the closest point in the nomi-
nal group that has not yet been measured, and will update  with each 
measurement. 

Points/Groups to Surface Faces

Points to Surface Faces and Groups to Surface Faces relationships 
function just like Points or Groups to Objects relationship but are tied 
directly to CAD.  By using these relationships individual CAD faces can 
be referenced directly where as before those faces had to be sepa-
rated out as unique objects in the tree for reference.

CAD faces will also highlight during trapping for clarity (Figure 17-9).

Figure 17-9. Points to Surface 
Face relationship.

Vector Group to Vector Group Relationships

Built with Shim and Gap applications in mind, as well as comparisons 
between sequential measurements, this Vector Group to Vector Group Rela-
tionship (VG to VG Relationship) computes a delta vector group defin-
ing the difference between two reference vector groups. 

A VG to VG relationship offers the following property controls (Figure 
17-10):
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Figure 17-10. Properties Control 
for a Vector Group to Vector Group 
Relationship

Proximity Settings define a cylindrical proximity zone that is used to 
control which vectors in the second group are used for comparison 
with the first. 

 ■ Maximum Radial Offset. Maximum distance from the origin 
point of the reference vector to consider in comparisons.

 ■ Minimum Axial Offset. Minimum distance from the axis of the 
reference vector to consider in comparisons. 

 ■ Maximum Axial Offset. Maximum distance from the axis of 
the reference vector to consider in comparisons. 

Nominal Relative Polarity Between Vector Groups optional selection 
is used to control the mathematical comparison of the vector groups.

 ■ Opposing Direction. Used for shim and Gap applications 
where measurements have been taken from two opposing 
surfaces

 ■ Same Direction. Used for sequential surface measurement 
where the same surfaces is measured a second time and the 
relative change in deviation is desired.

Gap Optimization evaluation Settings are used to both control the fit 
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setting used in a relationship optimization and the default tolerances 
passed to the resulting vector group for reporting purposes.

 ■ Minimum (Gap and Weight). The Gap value is an absolute val-
ue used to define the minimum gap threshold and low vector 
tolerance while the Fit Weight is the maximum fit weight on the 
lower or negative side of the optimization.

 ■ Maximum (Gap and Weight). The Gap value is an absolute 
value used to define the Maximum gap threshold and high 
vector tolerance while the Fit Weight is the maximum fit weight 
on the upper or positive side of the optimization.

 ■ Nominal (Gap and Weight). The Gap value is an absolute val-
ue used to define the optimum or nominal gap threshold. The 
Fit Weight is the minimum fit weight used in an optimization.

 ■ Gradient Steepness Factor. This value is used to control the 
rate of transition in Fit Weight applied when within the min or 
max thresholds but not at the nominal. 

The Gradient Steepness Factor defines the how a relationship will influ-
ence the fit as it enters the desired gap threshold. Unlike a fixed con-
straint which is either on or off, the gradient control provides a means 
to control the transition rate of the fit weight as it moves from the 
max or min weight toward the nominal weight (see Figure 17-11). 
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Figure 17-11. Comparison of two 
example Gradient Steepness Factors

If the tolerance is very narrow, then the gradient steepness value must 
be set quite large (~500), providing a sharp drop off in influence. If the 
gap tolerance is larger then the gradient steepness can be set smaller 
(~50) which produces a slower transition. For more information on 
relationship fitting see “Minimizing Relationships” on page 535.

Basic shim and Gap application would go as follows:  

preliminary Setup:
1. Start with two nominal surfaces that are expected to mate to-

gether in some fashion.

2. Declare one of these surfaces to be the primary and define a 
Points to Surface Face Relationship to which points can be added to 
characterize the as-built surface relative to the nominal CAD 
surface. Use this relationship for a best-fit if desired and en-
able auto-vectors.

3. Declare the second of the two mating surfaces to be the sec-
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ondary by defining a second points to surface relationship to 
characterize the second as-built surface. The collected points 
need to correspond to those points collected for the primary 
surface. Use this relationship for a best-fit if desired (if using a 
second instrument station) and enable auto-vectors.

Configuring the VG to VG Relationship
1. Create a “Vector Group to Vector Group” relationship and se-

lect the primary Points to Surface Face relationship auto-vectors 
as the primary input and then select the secondary Points to 
Surface Face relationship auto-vectors as the secondary input.

2. Open the properties for the VG to VG Relationship and set the 
proximity parameters as desired (Figure 17-10). The vectors in 
the first vector group will be used for reference and the closes 
(radial) corresponding vector will be found from the corre-
sponding vector group. Also ensure that the Opposing Direction 
radio button is selected. Same Direction should be used when 
comparing points on the same surface.

Fitting with a VG to VG Relationship
VG to VG Relationships can be used in an optimization.  

1. Set the properties for the “Vector Group to Vector Group” such 
that the nominal, minimum, and maximum gap values are set 
appropriately. 

2. Enter an appropriate Gradient Steepness Factor. 

3. Run the relationship fit by selecting relationship>Move Ob-
jects by Minimizing relationships

Relationships with built in Alignments
Several relationships have built in alignment that can be performed 
at any time by using the Execute Alignment right-click option. If only a 
single instrument is associated with the measured group no addition-
al prompting is necessary. However, if more than one instrument has 
measured points in the group an additional prompt will be displayed 
asking for which instruments to move. 

Relationships with built in alignments include the following: 

Best-Fit Applications
Group to group relationships build a link between the commonly 
named points in the two groups. This provides the necessary infor-
mation to perform a best fit operation with the associated groups. 

 ■ Group to Nominal Group. Choosing Execute Alignment will bring 
up a best-fit dialog and allow you to align the measured group 
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to the nominal group. 

 ■ Group to Group. A basic group to group relationship will also 
an align option and will align Group 2 to Group 1.

 Frame to Frame Applications
Frame to Frame relationships also provide a defined alignment which, 
when executed will place one frame on top of the other. 

 ■ Frame Wizard. Frame wizard builds a frame from the associ-
ated points and or geometry. Choosing Execute Alignment will 
place the measured frame on the nominal frame. 

 ■ Frame to Frame. A basic frame to frame relationship can also 
be used for alignment. If you only have a single instrument in 
the job it will transform that instrument from the correspond-
ing frame to the reference frame. With more than 1 instrument 
in the job it will prompt for selection of what instrument to 
move.  

Properties & Controls - Geometry Relationships
Geometry Relationships (GR-relationships) allow for dynamic fitting 
and comparison of geometry. Unlike standard geometry construc-
tion operations, GR-relationships will update the size and position of 
the geometry as measurements are either added or removed from 
the relationship and any comparison with a nominal geometry is also 
automatically updated. 

GR Properties and Report Options
The Geometry Relationship Properties dialog provides control over 
all the individual controls for the relationship. Right-click the relation-
ship and select properties, the respective properties dialog will ap-
pear (Figure 17-12).
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Figure 17-12. Geometry relation-
ship properties.

Report Options
The report options for the relationship allow the user to set many pa-
rameters or specific Criteria (Figure 17-13). 

Figure 17-13. Geometry relation-
ship report options.

The interface will allow the user to choose which criteria to report, us-
ing the check box selection. In addition, tolerance and relationship 
optimization settings can be accessed for each individual criteria by 
selecting the desired row and pressing the Edit button.
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Figure 17-14. Adjusting geom-
etry relationship criteria.

Each criteria has the ability to be used in a relationship minimization, 
allowing a user to fine tune a relationship fit based on geometry com-
ponents (Figure 17-14). The user has the ability to minimize based on 
delta and/or the amount out of tolerance. This allows the fit to drive 
the delta to zero and/or bring the amount out of tolerance to zero.

In addition to the critieria selection there are a set of check boxes con-
trolling report table parameters including: 

 ■ Show High and Low Tolerance in Report

 ■ Show Point List Details In Report

 ■ Show Units in Report Title

Geometry Uncertainty Computation
Geometry Relationships offer the ability to compute uncertainty us-
ing the uncertainty of the points included in the relationship. In order 
to compute uncertainty perform the following steps:

1. Ensure that all of the points included in the GR feature have 
uncertainty fields computed. This can be done by using the 
function Analysis > Coordinate Uncertainty > Create Point Uncertainty 
Fields.

2. In the relationship properties check the Uncertainty check 
box and then press Compute. This will ask you for the number 
of samples to use and generate the uncertainty event, as well 
as adding the uncertainty statistics to the related GR Criteria
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Figure 17-15. Compute Uncer-
tainty Button

For more information on the geometry uncertainty computation pro-
cess (see “Geometry Fit Uncertainty” on page 713). 

Once uncertainty has been computed for a relationship the relation-
ship is put into a Dormant status. This is done so that the uncertainty 
values are not removed as part of the normal recomputation process 
of a relationship. At any time the dormant status can be removed 
through the right-click option Set/Clear Relationship Dormant Status.  

Geometry Fit Settings:
The Geometry Fit Setting will depend on the type of relationship. 
These types include: 

1. Points and Point Group based relationships which provide 
greater control over individual point selection

2. Cloud based relationships which provide additional subsam-
plint options

3. Intersection relationships which used objects as inputs. 

Points based Fit / Fit and Compare relationships are performing a 
standard geometry fit operation using the associated points and up-
dating that fit when  ever the list of points changes. The geometry 
Fit controls are the same as those offered for construction operations 
and include the following(Figure 17-16): 

Figure 17-16. Points Based 
Relationship fit settings

Fit Settings - Provide basic geometry fit controls such as offset compen-
sation, diameter override, Max Inscribed/Min Circumscribed, etc. 

Point List - Shows a list of the associated points in the relationship and 
includes tolerances and point rejection controls. 

Graph - Displays a graph of individual point deviations from the fit ge-
ometry an offers the ability to remove points graphically. 

Cardinal Points - Cardinal or Design points are described separately be-
low. 
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Projection Plane - 2D GR-Relationships offer the option to turn on a pro-
jection plane. Checking the Project to Plane check box will cause the 
user to be prompted to select the desired projection plane. Projec-
tion planes can also be assigned automatically when a relationship is 
built through designation in the toolkit. 

Desired Measurement Count - The desired number of points can be des-
ignated for a relationship. This is used for inspection and will cause 
trapping to stop once the desired number of points has been reached 
during measurement. 

Intersection Geometry don’t offer any fit settings through the proper-
ties dialog other than cardinal point selection. The geometry selec-
tion process can be triggered through the relationship’s right-click 
menu under associate data. 

Working with Cloud Data
Geometry Relationships can also take point clouds as inputs. When 
a point cloud is associated with a geometry relationship the Point List 
button is replaced with a subsampling control (Figure 17-17): 

Figure 17-17. Point Cloud Based 
Relationship Fit Settings

 

By default geometry relationships take a random sample using a uni-
form distribution from the cloud data and only use 200 points. This 
can be seen when the AVN vectors are enabled. This allows for quick 
and efficient fitting.

Proximity filters can be defined for a Compare to Nominal relation-
ship.  The defaults for newly created relationships can be accessed 
directly through the User Options>Display>Default Options>FR Proximity Fil-
ter. But each relationship has its own settings which can be accessed 
through the feature’s right-click menu using Inspection>Configure Cloud 
Trapping Filter (Figure 17-18). 
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Figure 17-18. GR-Feature Proxim-
ity Filter settings for a circle.

These Proximity settings come into use in either of two way: 

1. When you use the option in a features right-click menu: Associ-
ate Data> Proximity Filtered Clouds. You will be prompted to select 
a cloud and a new cloud will be built from the reference after 
applying the filter and associated with the feature.

2. Trapping while scanning. When actively trapping to a feature 
these proximity settings can be used. This limits the data ac-
quired while scanning such that you only acquire points with-
in the defined proximity to the nominal feature.

Proximity filtering is a great way to associate relevant cloud points 
with a particular feature and can easily be used in combination with 
a job level feature extraction (see “Feature Extraction from Point 
Clouds” on page 294).   

Outlier Rejection
Outlier reject for GR-Features using points are available as follows:

 ■ Point List. The point list can be used for outlier rejection by 
setting a tolerance and using the Ignore >Tol button to ignoring 
points beyond a threshold. The list headers can also be used to 
sort the data and selections of points can be excluded manu-
ally using Shift or Control Click selection.

 ■ Graph. The deviation graph also provides direct access to in-
cluded points and their relative deviation. Multi-select allows 
for quick removal of groups of points, all of which are set to 
“ignored” in the point list.

Outlier rejection for cloud based GR-Features are as follows:
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 ■ Graph. The Point List is not available for cloud based relation-
ships. Rather than keeping track of individual cloud points a 
reference cloud is used to build an analysis cloud. The graph 
provides a means to remove points from this analysis cloud. 
The graph functions differently as well in that it provides a his-
togram display of the data and selection can be made of the 
data to keep with respect to sigma fit markers.

Figure 17-19. Cloud Point Fit 
Graph used for outlier rejection.

 ■ Proximity filter. In addition to simple geometry extraction the 
proximity filter can be used to edit the cloud points included in 
the fit by adjusting the filter settings and pressing apply. This 
will effectively delete the existing filter cloud and re-extract 
from the original input cloud using the new settings. 

Cardinal Points
Cardinal Points can be turned on for any geometry. These points can 
be used as the input for other GR-Relationships to build dynamic ge-
ometry. For example, if you wish to build a line along the axis of a 
cylinder you can turn on the cardinal points for the cylinder and use 
those points to build line. As the cylinder updates the cardinal points 
will update and so will the position and length of the line. 

Different numbers of cardinal points exist for different geometry 
types and the choice to turn on and off particular points and to con-
trol their naming is given when you turn them on (Figure 17-20).
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Figure 17-20. Cardinal Point 
Name Control.

Automatic Vector Groups. 
GR-Relationships offer a selection of Auto-Vectors to help visualize 
Point deviations and deviations between features. These include: 

Fit Geometry to Points (AVF) - These vectors show the individual deviations 
between the measured points and the fit geometry. It helps visually 
display the quality of the fit.  

Nominal Geometry to Points (AVN) - This Auto Vector type displays the de-
viations between the measured feature and the nominal feature. It 
can be shown as either: 

1. Nominal to Fit Cardinal Points - The deviation of the cardinal points 
of the fit geometry from the axis or surface of the nominal ge-
ometry. This provides a minimal number of vectors to clearly 
illustrate the relative misalignment of the features. For planes  
the vertex points are used rather than the cardinal points. 

2. Input Points - The deviations of the measured points as directly 
compared with the nominal feature as if it were the fit feature. 
This shows both deviations in form and location. 

3. Nominal Cardinal Points To Fit - (Cylinders Only) This option more 
closely reflects the results of a GD&T inspection in that it dis-
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plays the deviations extrapolated beyond the fit cylinder to 
the extents of the nominal cylinder. 

Set as Default and Apply to Selected
The default state of just about any setting can defined for a geometry 
relationship and applied to other relationships of the same geometry 
type. 

Geometry Relationship Summary Table
By right-clicking on the Relationship category in the tree an option 
called  Create Geometry Relationship Summary Table is available. This option 
prompts a user to select from a list of the geometry relationships in 
the job. It then builds a custom report containing the reporting cri-
teria for each of the selected geometry relationships in a single table 
format. 

Figure 17-21. Example Custom  
Geometry Relationship Table

Minimizing Relationships
In most metrology applications the first step in analysis is to orient 
measured points to critical design features. This then provides the 
ability to perform an evaluation of the measured features. SpatialA-
nalyzer is able to help you accomplish that task by letting an optimi-
zation routine use relationships to drive a fitting process. This is a far 
more powerful process than a simple best fit because it dynamically 
establishes the best possible fit to potentially complex and curvy 
parts. The net effect is the distances defined between objects in each 
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relationship are minimized. 

By creating relationships between the measured points and the part’s 
critical features you can use these dynamic features to find orienta-
tions that yield the best performing part. Since SA’s relationships can 
be made between any object types you’re able to define a compre-
hensive set of part features and then optimize their orientation.

Figure 17-22. Relationships set 
up in the tree.

Move Objects by Minimizing Relationships

Relationship Minimization is a powerful way to transform objects and 
instruments into alignment with design features (Figure 17-23). It is 
often used when traditional alignment methods are not applicable 
and a more advanced method is needed. The relationship minimiza-
tion dialog provides full control over each individual relationship,and 
direct access to its weighting and fit constraints. 

The Minimize Relationships dialog should be considered in 3 sections  
from top down:

1. Weight and Degree of Freedom Controls across the top, which 
establish the overall fit conditions.

2. The list of individual relationships, which also provide direct 
access to the relationships fit settings.

3. User Controls.

Relationship optimizations are extremely powerful tools that are only 
fully available with a SA Ultimate license. A relationship fit can be per-
formed with a single relationship using a Pro license but in order to 
use multiple relationships at one time to balance the fit and optimize 
based on tolerance weighting the Ultimate license is required. 
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Figure 17-23. The Minimize 
Relationships dialog.

Normalize Weighting
The Nomalize Weighting control provides a means to equalize the influence 
of relationships on the fit. By default each relationship is weighted the 
same. This means that if you have one relationship with 10 points and 
another with 100 points the relationship with only a 10 points is given 
more power (10x) in the fit.

Weights can be normalized based upon the following options:

 ■ Equation Count. A point to surface relationship is a singe vec-
tor or equation, where as a point to point relationship applies 
in X,Y, and Z and is in effect 3 equations. You can normalize 
the weighting between relationships such that the number of 
equations (which is typically the number of points) are equal-
ized. 

 ■ Tolerance. Tolerances can also be used to equalize the weight-
ing between relationships. This allows you to adjust the fit pro-
viding greater weight to features with tighter tolerances. 



538

SPATIALANALYZER USER MANUAL

FIlters
This control can be very helpful in large job files by allowing you to 
hide relationships not included in the fit. Additionally, the individual 
criteria in any geometry relationship, frame to frame or average point 
relationship can be included in a relationship optimization. However 
these settings are hidden by default. 

Relationship List
The relationship list within the Minimize Relationships dialog pro-
vides direct access to the individual relationship’s settings (Figure 17-
24).

Figure 17-24. Right-click access 
to the properties of a selected relation-
ship.

Run Optimization  
This is the default mode of operation. The optimization method per-
forms a version of the steepest-descent algorithm on the system. This 
means it assembles a matrix that is 6 (unknowns) x N (number of 
points), inverts it and determines move directions. Though quick for 
reasonable data sets, it can take a long time when using a large set of 
points depending on the amount of RAM on the computer. The stop-
ping tolerance is the amount that the objective function (RMS error) 
must repeat by in order to indicate a minima has been reached.

Run Direct Search Optimization
This optimization provides a powerful method for searching the solu-
tion space. It is also required when using the toleranced best-fitting 
options (in the advanced area) since they introduce non-linearities 
into the solution space. This method basically steps in a direction, 
evaluates the fit, then steps in another direction, etc. There is a lot of 
advanced logic built into the search, but at the core, it is a searching 
method. The advantage is that it does not have to assemble a large 
partials matrix and invert it. This means that it can effectively deal 
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with huge point sets. The disadvantage is that since it is trying to ex-
haustively search, it can sometimes take a long time to complete. At 
any time during the fit, however, you can cancel the operation and 
use the current location. To use this mode, you set step sizes. They are 
set as a ratio of the position and angular perturbation values in the SA 
units options page. The step size starts at the starting value then de-
cays when it detects no improvement in any direction. Once it decays 
to the Ending step size, a minimum is reached.

Apply Transform and Continue
The optimization is performed with degrees of freedom defined rela-
tive to the working frame. Rotations are applied with respect to this 
reference frame. There are cases where one it would be helpful to per-
form an initial optimization and then an subsequent optimization us-
ing a different set of degrees of freedom defined  by a different frame. 
The Apply Transform and Continue button provides the ability to do 
this.  

Relationship Fit Settings

Figure 17-25. Relationship 
settings.

Fit Weight
Allows more emphasis to placed on the selected relationship. Often 
times weighting can be tweaked to bring a part in tolerance.
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Fit Constraints
A fit region can be described that will represent a “dead” region where 
the solution can satisfy a zeroed out condition.  For example a high 
limit can be set at +0.1 and low at 0. This will define a region from 0 to 
+0.1. When the solution reaches this region, it will stop.

Sub Sample Options
Sub sampling is useful for large data sets (Figure 17-26). Often all of 
the data is not required for the fit.

Figure 17-26. Subsampling 
options.

Outlier Rejection
Outlier rejection is a great way of removing stray data for the fitting 
solution. Stray points can often impose difficulties for the optimiza-
tion.

Figure 17-27. Outlier rejection 
options.

Sequential Alignment
The Sequential Alignment available under Analysis> Best-Fit Transforma-
tion> Sequential Alignment is designed to provide a streamlined means 
to apply one relationship optimization after another in a specific se-
quence. Individual degrees of freedom can be set with each relation-
ship or group of relationships and are then used when that particular 
relations is optimized (see Figure 17-28). This functions much like us-
ing the Apply and Continue button in the Move Objects by Minimizing rela-
tionships option. 

In addition, the reporting frame for that relationship can also be used 
to define different reference frames for the applied degree’s of free-
dom. 

This tool is ideal for GD&T style alignments, providing a way to align to 
curvy surfaces in a sequential way with defined degrees of freedom. 



541

CHAPTER 17 ■ RELATIONSHIPS

Figure 17-28. Sequential Align-
ment dialog

To perform an alignment do the following: 

1. Press the Select Existing Relationships button and select the 
relationships you wish to use in the optimization process. 

2. Press the Select Objects and Instruments to Move button and 
choose what you wish to move. Typically instrument selection 
is all that is required. Measured points and associated geom-
etry will be moved with the instrument automatically. 

3. Order the relationships in the relationship dialog in the order 
you wish to apply them and select the degrees of freedom 
you wish to influence through the relationship. 

The Sequential Alignment process will used the Working Frame to de-
fined the degrees of freedom so a relevant frame should be built and 
set as working. If you wish to align using degrees of freedom refer-
enced by a different frame you can set a Reporting Frame in the relation-
ship right-click properties. 

4. Once content that the alignment process has been defined 
correctly press the Run (Re-Run) the Alignment Fit button to 
compute a fit. This will compute the resulting Error RMS.

5. Finally when the numbers look good you can apply the fit by 
selecting the Apply Alignment Fit button. This will apply the 
alignment which can then be viewed in the graphics. You can 
also use the Undo Applied Alignment button to put the in-
strument back in its starting location. 



542

SPATIALANALYZER USER MANUAL

Sequential alignments, along with RPS alignments are saved in the 
tree and can be re-opened and recomputed at any time. 

Pipe Relationships
In some industries, such as nuclear energy and shipbuilding, a com-
mon need is to align mating sections of pipe in order to calculate and 
lay off cut planes so that the pipes can be adjoined with a high-qual-
ity weld. In general, the goal is for these adjacent pipe sections to be 
as coaxial as possible and to share enough material overlap such that 
a valid cut plane can be calculated that enables a quality weld joint.

Consider the example of replacing a steam generator that has reached 
the end of its service life at a nuclear power plant. A nuclear steam 
generator typically has a number of nozzles or pipe openings—one 
variant design has a “hot leg” pipe for hot water, a “cold leg” pipe for 
cold water, and a pipe for steam (Figure 17-29).

Figure 17-29. A typical steam 
generator, with hot and cold legs (bot-
tom) and a steam leg (top).

These piping interfaces are critical to the safety and performance of 
the nuclear power plant, and since they provide a direct barrier be-
tween the radioactive and non-radioactive sides of the plant, they 
must be aligned and cut with optimal precision.
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Figure 17-30. The steam genera-
tor after virtual assembly.

Since a nuclear reactor must be shut down in order to replace the 
steam generator—and since downtime at a nuclear power plant is 
enormously costly—anything that minimizes this downtime is ex-
tremely beneficial. Historically, cut planes were calculated manually 
and refined with the steam generator in its final alignment. However, 
this proved to be a time-intensive and therefore expensive process. 
Instead, the steam generator can be digitally assembled (Figure 17-
30) and resulting pipe cuts can be calculated before the steam gen-
erator is in its final location (Figure 17-31). As a result, the pipes can be 
cut prior to installation—pipe relationships play a critical role in this 
process.
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Figure 17-31. A cut plane calcu-
lated by a pipe relationship.

Using Pipe Relationships

The general process of using a pipe relationship is as follows:

6. Define the pipe relationship between mating pipe/fittings.

7. Align the pipes using traditional relationships, pipe relation-
ships, or a combination.

8. If the pipe relationship can find a valid cut plane, the pro-
posed cut can be made. A frame can also be constructed on 
this cut for layoff purposes.

9. After physically cutting one end of the pipe, the actual cut 
plane can be fed into the solution, re-solving for a tweaked 
cut plane on the other end.

10. This tweaked cut plane can then be used to cut the mating 
piece.

Defining Pipe Relationships

Pipe Relationships can be defined between two objects that have po-
sitional and directional information. Typically, this means lines, cyl-
inders, or planes. The particular type of object does not matter—as 
long as the object properly describes the pipe’s position and orienta-
tion. When a pipe relationship is created, a tube representing the al-
lowable cut region and ID/OD appears in the graphical view, and the 
Pipe to Pipe Relationship dialog is displayed (Figure 17-32).
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Figure 17-32. The Pipe to 
Pipe Relationship dialog.

The first step is to define the properties of each pipe segment (Figure 
17-33):

Figure 17-33. Properties of a pipe 
segment in a pipe relationship.

 ■ Inner. The inside diameter of the pipe.

 ■ Outer. The outside diameter of the pipe.

 ■ Begin. The start of the permissible cut region, as a distance 
along the pipe axis from its origin. This value should typically 
be less than the End value.

 ■ End. The end of the permissible cut region, as a distance along 
the pipe axis from its origin. This value should typically be 
greater than the Begin value.

A pipe relationship will supply several forcing functions to an optimi-
zation:

 ■ It will try to make the pipe segments coaxial.

 ■ It will try to make the pipe ends parallel.

 ■ It will try to overlap the cut regions evenly.

After defining the characteristics of the pipe segments, the weighting 



546

SPATIALANALYZER USER MANUAL

factors for the relationship may be modified, if desired. Typically, the 
default values (Figure 17-34) are sufficient:

 ■

Figure 17-34. Weighting Factors 
for a pipe relationship.

Overall Weight. The weight of the pipe relationship as a whole, 
which determines the influence of the pipe relationship in the 
overall optimization scheme.

 ■ Axis Offset. The importance of minimizing the mutual per-
pendicular midpoint between the two pipe segments (i.e. how 
“coaxial” the two pipe segments are). Larger values attempt to 
bring the segments closer together.

 ■ Axis Alignment. The importance of minimizing the angle be-
tween the two pipe segments. Larger values will force the pipe 
segments to be more parallel.

 ■ Center Pull. The importance of overlapping the center of each 
pipe segment’s cut region (along the axis direction). Larger val-
ues assign more importance.

 ■ Weight. The importance of having sufficient material for the 
weld. A value of zero implies that the solution does not care if 
there is sufficient material for the weld.

 ■ Static Offset. A value that controls “how bad” the solution gets 
when there is insufficient material for the weld. Higher values 
assign a larger penalty to having insufficient material, effec-
tively ensuring that material requirement is more crucial in the 
eyes of the solution.

 ■ Constrain Cut to Region at OD. If checked, ensures that the 
cut angle at the outer diameter does not cause the cut plane 
to exceed the defined region. If unchecked, this restriction is 
ignored.

 ■ Constrain Cut so ID/OD overlap. If enabled, the inner diame-
ter/outer diameter values for the pipes are used to ensure that 
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there is sufficient material based on the angle of alignment.

To Solve a Pipe Relationship:

1. First take a moment to think about the assembly. If there is 
more than one pipe segment that will be assembled (that is, 
if there will be more than one independently moving object 
in the optimization), then each moving object (pipe segment) 
should be placed into its own collection. This includes the ob-
jects defining the pipe endpoint, the pipe surface/cylinder, 
and anything else you want to rigidly move with that pipe 
segment. In this situation, you must use Relationships > Move Col-
lections by Minimizing Relationships in step 7 below.

2. Create a primitive SA object with directionality (circles, lines, 
cylinders, or planes—but circles are preferred) to represent 
the end of each pipe opening in the assembly. Each object’s 
normal direction must face the mating pipe segment as de-
picted in Figure 17-35.

Figure 17-35. The circles defining 
each pipe opening have their normals 
pointing toward the mating pipe 
segment.

3. From the menu, select Relationships > Pipe Fitting.

4. Select the object (i.e. circle) describing the first pipe segment, 
then the second.

5. In the Pipe to Pipe Relationship dialog (Figure 17-32), click the 
Edit button for each pipe segment and define the ID, OD, and 
begin/end values for the allowable cut region (Figure 17-33).

6. If any pipe ends are already cut, create a frame representing 
that pipe end (usually Construct > Frame > On an Object is appro-
priate) and then click the Force CUT to Frame button (Figure 17-36).

Warning:  If the ID and 
OD values of mating pipe 
segments match, a valid 

cut plane will typically not be 
found unless you uncheck the 
Constrain Cut so id/Od Overlap 
option.
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7. Create any other conventional relationships governing the 
alignment, if applicable.

8. Solve the relationship using Relationships > Move Objects by Mini-
mizing Relationships or > Move Collections by Minimizing Relationships, 
as applicable. Enable/disable and adjust the weights on all re-
lationships as desired.

Working With the Cut

If the pipe relationship can find a valid cut plane, it will display a 
dashed plane indicating the location and orientation of the cut plane 
(Figure 17-31).

Typically, the next step is to create a frame on the cut, which can then 
be laid off on the real pipe for cutting. This involves making the pro-
posed cut, then constructing a frame on the cut plane. The XY plane 
of this frame now defines the perfect cut location on the pipe. Watch 
windows can be used to lay this cut off on the real pipe.

In some applications, it may be desirable to simply calculate the cuts 
and lay them all off at once, as described above. This would be a faster 
but less stringent approach. A more rigorous approach would involve 
laying off the cuts on one segment, performing the cuts on the actual 
pipe, then measuring the actual cut plane.

Once the actual cut plane is measured, a coordinate frame can be 
constructed that represents the location of the as-built cut. This as-
built cut location can then be fed back into the pipe relationship, and 
the as-built cut can be used to tweak the alignment once more. After 
the alignment is further tweaked, a new tweaked cut plane can be 
laid off on the other pipe segment.

This process can be iterated, as desired, for each pair of pipe seg-
ments.

To Lay Off Cut Planes:

1. Once the relationship has been solved (see “To Solve a Pipe 
Relationship:” on page 547), double-click the pipe relation-
ship in the tree. In the Cut section, ensure that “Valid Cut Avail-
able” is indicated.

2. Click the Edit button in the Cut section for one of the pipe seg-
ments. In the Pipe Cut Properties dialog, click the Make Proposed 
Cut button (Figure 17-36).

3. With the cut applied, click the Create Frame on CUT button to cre-
ate a coordinate frame whose XY plane defines the cut plane 
(Figure 17-37).

Tip:  In general, pipe relation-
ships are best solved by click-

ing the Direct Search Optimization but-
ton instead of the Run Optimization 
button.



549

CHAPTER 17 ■ RELATIONSHIPS

4. 

Figure 17-36. The Pipe Cut 
Properties dialog.

Use a Watch Window to lay the cut plane onto the actual pipe.

Figure 17-37. A cut frame 
constructed on the cut plane.

The above steps can be repeated for the other pipe segment, if de-
sired. However, if applying cuts sequentially, the process contains a 
few more steps.

Applying Cuts Sequentially

1. After cutting the first pipe segment, measure the actual cut 
and construct a frame on the resulting cut plane. Ensure that 
this data is aligned appropriately in the SA file.

2. Double-click the pipe relationship, and click the Edit button for 
the appropriate pipe cut.

3. Click the Force CUT to Frame button, and select the appropriate 
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frame. This will force the cut to sit on the provided frame.

4. Re-solve the optimization. Based on the as-built cut location, 
you should see the solution get tweaked to account for the 
changes.

5. Based on the results, make the cut on the other pipe segment 
using the steps in “To Lay Off Cut Planes:” on page 548.
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Why Feature Based Inspection
Spatial Analyzer is a points based software. Each point is traceable 
back to the instrument that measured it and that link is fundamental 
to geometry fitting and instrument alignment. SA has always made 
it easy to measure points and fit geometry to those points, analyzing 
the deviations and reporting the statistics. However, part inspection is 
all about streamlined comparisons between nominal and measured 
geometry, reporting measured locations within specified tolerances 
and effectively reporting those results. 

SA uses Geometry Relationships to effectively link nominal and mea-
sured geometry position and location information, and dynamically 
update and report on these comparisons. These features can be built 
in advance or after measurements are made and, once built, provide 
a template for future measurements 

For more details on Geometry Relationships configurations refer to 
“General Relationship Properties & Controls” on page 512. 

GR features also provide an ideal path to working with point cloud 
data. For more details on point cloud operations refer to “Point 
Clouds” on page 255.

SA provides a streamlined set of tools which can be 
used for fast and effective feature inspection, include 
built in reporting and template creation. This process 
uses Geometry Relationships (GR) and/or GD&T Fea-
ture checks for standardized inspection. This chapter 
provides an overview of this capability. 

Feature 
Inspection
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Why GR-Features verses GD&T

Geometry can also be inspected using our ASME and ISO compli-
ant Standardized GD&T inspection process. The datums and feature 
checks will also appear as stand along inspection features that also 
will updated dynamically. 

The primary reason these evaluation processes are separate in SA are: 

1. GD&T feature checks use the built in datum references to per-
form an internal alignment and then evaluate with respect to 
that alignment. GR features display deviations using the cur-
rent job alignment which provide greater visual feedback.

2. GD&T feature use either ASME or ISO inspection processes 
that are designed to establish if a part is within specification. 
This means that it optimizes fits using bounding thresholds 
in its mathematical evaluation. GR features use an RMS fit to 
help identify measurement error.  

Although these are separate approaches,  both GR-feature inspection 
and GD&T can be used in tandem. More information on GD&T fea-
tures and inspection can be found in the chapter on  “GD&T” on page 
579. But the GD&T Datums and Feature Checks will appear as part of 
the inspection process which can be conducted through the Inspec-
tion bar just like GR features.

Building GR-Features
Geometry Relationships (GR-Features) are built either through the Re-
lationships tab of toolkit menu (and Relationship menu) or by using the 
Features page on the Ribbon Bar. The Ribbon Bar is the most advanced 
tool for this purpose and will be discussed here (Figure 25-1). 

Figure 25-1. Features Page  of 
the ribbon bar

While GR-Features) are fully configurable after they are built, there are 
a number of tools that can be used in the Features page to configure 
features so that you get the desired settings applied when they the 
GR-Features are built. 



553

CHAPTER 25 ■ FEATURE INSPECTION

Nominals

The Build Nominals section of the Feature tab provides an easy way 
to convert existing nominal geometry into GR-features and extract 
or detect nominals from fit features with a proximity to the nominals. 

Select Nominal Geometries
This function takes the specified geometry and converts them into 
geometry relationships such that they can be used for trapping and 
direct comparison with a measured feature.

Detect Nominals 
Used to quick gather nominal features based on proximity. 

 ■ Detect CAD Nominals by Proximity. This function looks at a 
CAD model, extracts the nominal features from it and associ-
ates them with the measured features.

 ■ Detect SA Object Nominals by Proximity. This function looks 
for existing objects and both sets them as the nominal object 
for the geometry relationship and renames the measured fea-
ture using the nominal names.

The Detect Nominal options for both CAD and SA Objects only con-
sider the visually displayed features. If you hide parts of the CAD 
model or SA Objects they will not be considered for association. This 
provides the user the ability to control which objects are detected. 

Build 2D Nominals from B-Splines
2D Compare to Nominal geometry relationships such as lines and 
circles can be build directly from B-splines with this tool. Selection of 
a spline provides a nominal reference for the new GR-Feature.

New Feature Controls

Feature Name Field
A Name field allows you to enter a specific name for a relationship prior 
to building it. This speeds construction by allowing you to name fea-
tures in advance. If this field is left blank, then the default geometry 
type name will be used.

Defining Projection Planes
The projection plane setting (Figure 25-2) options provide simple on/
off control in order to switch from 3D to 2D projected geometry. The 
projection plan can be set as follows:

 ■ None. Does not use a projection plane for the feature.

 ■ Selected Plane. You choose a specific plane which will be used 
as a projection plane. When this option is checked you will be 
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prompted to choose the desired planar feature. The name of 
the select plane will then be shown.

 ■ Plane for Each Feature. When selected, each additional fea-
ture added to the inspection routine will also have a projection 
plane feature added, so that you first measure the projection 
plane, then the feature to project to it. 

Figure 25-2. Projection Plane 
and feature name controls

Basic Settings
A selection of basic settings can be applied to newly built features as 
part of the Basic Settings tool. This function allows you to define:

 ■ Desired Measurement Count. The specified measurement 
count will be applied to the created feature. 

 ■ Auto Vectors. This option allows you to build Fit vectors (AVF) 
by default

 ■ Cardinal Points. Enabling this option will allow Cardinal points 
can be built by default.

CAD Nominal
the CAD Nominal button provides a toggle to choose between nom-
inal selection options when a feature is built (Figure 25-3). This se-
lection then directly influences the operation of the feature buttons 
when a new feature is defined:

Figure 25-3. Nominal selec-
tion and CAD interaction 
controls.

 ■ Build without Nominal. This setting is to be used without 
CAD and builds a basic fit only feature without pre-assigning 
a nominal feature. 

 ■ Extract Nominal from CAD. With this option selected you will 
be prompted to select the nominal feature by clicking on the 
desired surface face. The newly built nominal feature will be 
assigned to the new feature. 

 ■ Save CAD Faces with Nominal. It can be helpful to save the 
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selected CAD faces when building nominal features from CAD. 
When you do so, these faces will highlight along with the high-
lighted relationship and they can then be used during auto fil-
ter operations. 

Repeat for Inspection Check Box
A Repeat for Inspection check box is also available in the New Feature 
Controls section. When enabled, advancing forward in the Inspection 
tab or completing a feature with a measurement count limit will au-
tomatically create a new feature with the same properties as the last 
created feature. 

This is particularly useful if you have to measure a large number of 
similar features, such as 100 holes. Simply enable the Repeat option, 
and then define the first hole. As you advance past the first hole a new 
circle features will be created for you automatically. 

Data Association
In many cases a feature may be built after data has already been ac-
quired. The Data Association toggle button provides an option to be 
directly prompted to select a certain data type as features are built. 
The available options are shown below (Figure 25-4):

Figure 25-4. Data Associa-
tion option 

 ■ Placeholder - No Data. This is the default setting and is used 
when data has not yet become available to build a placeholder 
relationship which is ready to be measured. 

 ■ Individual Points. With this option selected you will be 
prompted to select points when a new feature is built.

 ■ Point Groups. With this option selected you will be prompted 
to select point groups for association with the newly created 
feature. 

 ■ Clouds. This option allows selection of entire clouds for use in 
a feature. 

 ■ Proximity Filtered Clouds. This option is only available with 
features that have a nominal pre-defined (or defined as part 
of the newly built feature). It will prompt you to select a cloud 
that is then filtered by proximity to the nominal feature, creat-
ing a new sub-cloud that is associated with the relationship.
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Building New Features

Figure 25-5. New Features

Point
Creates a GR-Point feature that dynamically builds a point from the 
average of all associated points. The points can be projected to a 
plane before averaging. 

The following additional Intersection Points can also be created:

 ■ Line and Plane Intersection. Computes a point from the in-
tersection of a line and a plane. 

 ■ Cone and Plane Intersection. Computes a point from the in-
tersection of a cone’s central axis and a plane.

 ■ Cylinder and Plane Intersection. Computes a point from the 
intersection of a cylinder’s axis and a plane.

 ■ Three Plane Intersection. Computes the intersection point 
from 3 roughly orthogonal planes.

 ■ Mid-point of perpendicular to two lines. Builds a point at 
the center of a line constructed perpendicular to two selected 
lines. Also called a mutually perpendicular line, this defines the 
closest point to two lines that nearly cross each other.

Line
Creates a GR-Line feature that dynamically builds a line from the as-
sociated points. 

The following additional Intersection and axis Lines can also be cre-
ated:

 ■ Cone Axis. Computes and builds the axis line of a selected 
cone.

 ■ Cylinder Axis. Computes and builds the axis line of a selected 
cylinder.

 ■ Two Plane Intersection. Computes the intersection line be-
tween two planes. 

 ■ Bisect Two Lines. Builds the bisection line or average line de-
fined by two selected lines.

 ■ Slot Centerline Along Length. Computes and builds the the 
central axis of a slot.
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Plane
Creates a GR-Plane feature that dynamically builds a plane from the 
associated points. 

 ■ Prepare to Projection Plane Fit. This option both builds a GR-
Plane feature and sets the measured plane from it as the active 
projection plane as part of the build process. 

The following additional Intersection planes can also be created, “Dy-
namic Geometry” on page 510 provides greater detail on the con-
struction methods:

 ■ Bisect Two Planes. Computes and builds a plane that is the 
bisection or average of the two selected planes.

 ■ Two Cone Intersection Options. Computes and builds a plane 
from the intersection of two cones. 

 ■ Cone and Cylinder Intersection Options. Computes and 
builds a plane from the intersection of a cone and a cylinder. 

Circle
Creates a GR-Plane feature that dynamically builds a plane from the 
associated points.

Single point circles allow you to lay a probe in a hole (assuming the 
hole diameter is smaller than the probe diameter) and create a circle 
with a single measurement, based on how far the probe sinks into the 
hole. 

To create a single point circle geometry relationship, create a circle re-
lationship as usual, and enable a projection plane. If the relationship 
has exactly one point, a single point circle will be created automati-
cally. If you continue measuring additional points, a regular circle re-
lationship will be created instead. Note that the measured point must 
be on the positive side of the projection plane.

The following additional Intersection circles can also be created, “Dy-
namic Geometry” on page 510 provides greater detail on the con-
struction methods:

 ■ Sphere and Plane Intersection. Computes and builds a circle 
from the intersection of a sphere and a crossing plane.

 ■ Cylinder and Plane Intersection. Builds a circle from the 
intersection of a cylinder and a plane based on the selected 
method. 

 ■ Two Cone Intersection. Builds a circle from the intersection of 
two cones.

 ■ Cone and Cylinder Intersection. Builds a circle based on the 
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intersection of a cone and a cylinder

 ■ Cone and Plane Intersection. Builds a circle based upon the 
intersection of a cone and a plane. 

Slot
Creates a GR-Slot feature that dynamically builds a slot from the asso-
ciated points. Selection between square and rounded ends are avail-
able from within the slot fit settings.

Ellipse
Creates an GR-Ellipse feature that dynamically builds an Ellipse from 
the associated points. Feature extraction from CAD is not available for 
this feature type. 

The following additional Intersection ellipses can also be created, 
“Dynamic Geometry” on page 510 provides greater detail on the 
construction methods:

 ■ Cylinder and Plane intersection. Computes and builds an el-
lipse at the intersection of a cylinder and a plane.

 ■ Cone and Plane Intersection. Computes and builds an ellipse 
from the intersection of a cone and a plane. 

Sphere
Creates an GR-Sphere feature that dynamically builds an Sphere from 
the associated points. 

Cylinder
Creates an GR-Cylinder feature that dynamically builds an Cylinder 
from the associated points. 

Cone
Creates an GR-Cone feature that dynamically builds an Cone from the 
associated points. 

Paraboloid
Creates an GR-Paraboloid feature that dynamically builds an Parabo-
loid from the associated points. Feature extraction from CAD is not 
available for this feature type.

Frame
Creates an GR-Frame feature that dynamically builds an Frame from 
the associated objects.

The Frame Wizard relationship provides the same controls as the 
classsic frame wizard utility. It still provides object and point selection 
to define a frame but it continually monitors those objects so that if 
any of the input features change so does the computed frame. In ad-
dition it provides a dynamic comparison to a nominal from in with a 
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similar look and feel to other Geometry Relationships.

Extract Geometry 

In addition to direct data association there are several direct extract 
and proximity filter options available (Figure 25-6).

Figure 25-6. Extract GEome-
try Section of the Features Tab

Auto Filter to Nominal
These functions provide a means to gather data within proximity to 
the nominal features and associate that data with the relationship.

 ■ Auto Filter to Nominal 3D. Used to detect either point or 
cloud data within proximity to geometry (see “Auto Filter to 
Nominal Geometry >3D Extraction” on page 294).

 ■ Auto Filter to Nominal 2D. Used to detect holes in surface 
scan data (see “Auto Filter to Nominal Geometry >2D Geom-
etry” on page 301).

 ■ Auto Filter to Nominal Line. Used to detect cloud points with-
in a specified proximity to a line. 

Extract Geometry From Cloud
This function is uses to extract geometry from a point cloud with-
out any nominal reference. It uses a click point as a starting point to 
search through the cloud and identify features. 

For more information on feature extraction and auto filter functions 
refer to “Extract Geometry from Clouds” on page 302.

Relationships

The Relationships section of the Features tab provides buttons to 
build relations of types other than geometry relationships (Figure 25-
7). These include the following:

Figure 25-7. Relationships 
Section of the Features Tab.

Points
 ■ Point to Point. Creates a point to point relationship used to 
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link two specific points together.

 ■ Point to Object. Creates a point to Object relationship used to 
defined the placement of a single point relative to an object.

 ■ Points to Objects. Creates a Points to Objects relationship 
used to compare a set of selected points to a set of objects. 

 ■ Points to CAD Faces. Creates a Points to Objects relationship 
where the specific faces of a selected CAD model are used for 
the comparison.

 ■ Groups to Objects. Creates a Groups to Objects relationship 
used like a points to objects relationship but without the need 
for selection of individual points. All the points in the selected 
groups will be used. 

 ■ Groups to CAD Faces. Creates a Groups to Objects relation-
ship where the points in the selected point groups are com-
pared to a set of selected surfaces faces from a CAD model.

 ■ Group to Group. Creates a group to group relationship used 
to compare the commonly named points within the two se-
lected groups.

 ■ Group to Nominal Group. A Group to Nominal Group rela-
tionship functions like a group to group relationship but with 
some added features for inspection. When trapping begins a 
set of bull’s-eyes are displayed on the points contained within 
the nominal group. When a point is measured, it will automati-
cally be renamed to the closest nominal point. And the bull’s-
eye removed.

 Clouds
 ■ Cloud to Objects. Creates a clouds to objects relationship used 

to compare the cloud points from the selected point clouds to 
the selected objects.

 ■ Clouds to CAD Faces. Creates a clouds to objects relationship 
used to compare to a selection of CAD faces.

Special 
 ■ Frame to Frame. Creates a simple frame to frame relationship 

used to compare two selected frames.

 ■ Object to Object Angle. Creates an objects to objects direc-
tion relationship used to compare the angle between the Z-
axes of the selected objects.

 ■ Pipe Fitting. Creates a pipe relationship used to compute a 
cut plane, for more information refer to “Pipe Relationships” on 
page 542.
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 ■ MP Execution Node. Used to incorporate an embedded MP 
into an inspection process such that iteration through the fea-
ture list will trigger the MP execution.

Relationship tab of the Toolkit

Functionally the Relationship tab of the Tookit works much like the 
Features page of the ribbon but with a slightly different organiza-
tion. The data association options are not available but the projection 
plane and name controls are (Figure 25-8). 

Figure 25-8. Projection Plane 
and feature name controls

The Geometry section (Figure 25-8) provides access to relation-
ships available through the Relationships>Geometry Comparison>Fit Only 
menu, while the Compare to Nominal section provides access to the 
Relationships>Geometry Comparison>Fit and Compare menu. These relation-
ships are functionally the same. The only difference is that the Compare 
to Nominal section prompts for nominal selection as part of the build 
process. Nominal features can be assigned or edited at any time. 

Figure 25-9. Geometry and 
Compare to Nominal Sections 
of the Relationship tab of the 
Toolkit

The Other section of the Relationship tab (Figure 25-6) provides but-
tons to build relations of types other than geometry relationships. 
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Figure 25-10. Other section of 
the Relationship tab.

The Utilities section of the Relationship tab provides quick links to 
a selection of very useful tools needed for data association. Theses 
include:

Figure 25-11. Utilities section 
of the Relationship tab.

Detect Nominals 
Used to quick gather nominal features based on proximity. 

 ■ Detect Nominals by Proximity. This function looks at a CAD 
model, extracts the nominal features from that CAD model and 
associates them with the measured features.

 ■ Detect SA Object Nominal Geometry by Proximity. This 
function looks for existing objects and both sets them as the 
nominal object for the geometry relationship and renames the 
measured feature using the nominal names. 

Select Nominal Geometries
This function takes the specified geometry and converts them into 
geometry relationships such that they can be used for trapping and 
direct comparison with a measured feature.

Auto Filter to Nominal
These functions provide a means to gather data within proximity to 
the nominal features and associate that data with the relationship.

 ■ Auto Filter to Nominal 3D. Used to detect either point or 
cloud data within proximity to geometry (see “Auto Filter to 
Nominal Geometry >3D Extraction” on page 294).

 ■ Auto Filter to Nominal 2D. Used to detect holes in surface 
scan data (see “Auto Filter to Nominal Geometry >2D Geom-
etry” on page 301).

 ■ Auto Filter to Nominal Line. Used to detect cloud points with-
in a specified proximity to a line. 

Extract Geometry From Cloud
This function is uses to extract geometry from a point cloud with-
out any nominal reference. It uses a click point as a starting point to 
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search through the cloud and identify features. 

For more information on feature extraction and auto filter functions 
refer to “Auto Filter to Nominal Geometry>Lines” on page 302.

Feature Inspection
Feature Inspection is most effective through the use of either the In-
spection Bar menu or Inspection tab of the Toolkit. These inspection pan-
els provide a focused view of the features to measure in the tree and 
provide easy navigation controls for effective workflow, without hav-
ing to navigate the full tree. 

To access the Inspection Bar menu from within the Ribbon Menu, navi-
gate to the Home page and press the Inspection Bar button in the 
inspection Controls section (Figure 25-12). 

Figure 25-12. Inspection 
Controls and Inspection Bar 
access button from the Home 
Page.

The inspection bar works directly with the Inspection Section of the 
Home page on the Ribbon which allows it to not need as many con-
trol button as are shown in the Inspection tab of the toolkit. 

Instrument Alignment

Convenient access to various alignment options are available at the 
top of the Inspection tab (Figure 25-13) of the toolkit.

Figure 25-13. Instrument 
Alignment section of the 
Inspection tab.  

Repeat last
Executes the last repeatable alignment used in the job file. Repeat-
able alignments include: 

 ■ Measure Nominal Points

 ■ Quick Align to CAD

 ■ Frame Wizard

 ■ Nominal Geometry Relationships

This Repeat Last function can only be used after an alignment has al-
ready been performed. Therefore it is intended as a benefit to those 
looking to either align a second instrument to the same features or as 
a way to build a template file that can be used again and again.
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New
The New alignment button provides that same list of alignment func-
tions available by right-clicking on the instrument and selecting Lo-
cate from the menu. This button is only accessible if a live instrument 
is connected within the job file. If you wish to set up an alignment for 
repeated use as a template file you will need to first connect to the 
instrument in simulation and perform the alignment. This alignment 
will then be available for use with the Repeat Last function.  

Measurement Trapping 

The Measurement Trapping page (Figure 25-14) provides a convenient 
list of all trappable features in the job file. This list can be rearranged 
and edited as needed to provide a list of features to inspect. Trap-
pable features include: 

 ■ Geometry Relationships or GR Features

 ■ Standard Relationships

 ■ GD&T Datums

 ■ GD&T Feature Checks

Trapping simply means direct data association. When you are actively 
trapping to a particular feature it will be marked as active . This indi-
cates that each measurement taken is automatically associated with 
that active feature 

There are currently two separate inspection toolbars that can be dis-
played (Figure 25-14). 

The inspection page of the Toolkit provides more controls for thing 
such as Instrument Alignment, Feature properties and Sweep func-
tions. Where as the stand alone inspection bar provides a larger list 
area and a cleaner look and was added to work with the ribbon menu 
and its built in tools. 
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Figure 25-14. Measure-
ment Trapping section of the 
Inspection tab.

The navigation controls provide a means to navigate through a list of 
features:

Figure 25-15. Inspection 
Trapping Controls

 The Next button advances trapping. Ctr+Right click provides a 
means to move a feature down in the measurement task list.

 The Stop button halts feature trapping.

 The Previous button moves trapping up to the prior feature in 
the list. Ctr+Right click provides a means to move a feature up a slot 
in the measurement task list.

In addition to directly trapping measurements taken from and instru-
ment relationships provide the ability to trap select points already in 
the job file simply by clicking on those points. To start Trap Selection 
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right-click on the relationship in either the tree or the inspection tab 
and select Trap Selections.

Simultaneous Trapping
Multiple features can be selected at one time when scanning and 
used as scanning targets. This is process is initiated with a Right-click  
on the next button in the Inspection Bar (Figure 25-16).

Figure 25-16. Simultaneous 
Trapping function in  action

Simultaneous trapping is very helpful when trying to obtain data on 
specific features. It pre-filters the incoming scan data while measur-
ing such that data is only recorded within the proximity limits set for 
each feature (see “Working with Cloud Data” on page 531). Once 
trapping is stopped, the cloud is divided and automatically associ-
ated with each feature.

Inspection Status Icons
The status of features in the toolkit can vary depending of if toleranc-
es are set or if measurements have been made of particular features. 
To more clearly identify the status of these features different icons 
are used in both the tree and in the Inspection Tab of the Toolkit. This 
includes 4 states: 

3. Unmeasured

4. Measured

5. Tolerance set - Pass

6. Tolerance set - Fail (or mixed status)

Figure 25-17. Status Icons 
showing that status of a circle

The status icons are displayed slightly differently in the tree and the 
Task bar (Figure 25-17). In the tree the icon is condensed by placing 
the check mark  on top of the feature icon. In the task bar these are 
separated out to make it easier to see that status. 
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Measurement Trapping and Navigation
To begin trapping to any individual feature in the inspection tab you 
can double-click on it. As long as there is at least 1 live instrument 
trapping will begin. 

At the top of the Measurement Trapping section are a set of naviga-
tion buttons. When actively trapping to a particular feature, these 
buttons provide a convenient means to move to the next or previous 
feature in the list or stop trapping.  

Reordering Features in the Inspection Tab
By right-clicking in the navigation buttons at the top of the Measure-
ment section you can change the order in the list of the currently se-
lected feature. Moving that item either forward or backward in the 
list. The inspection task list is a direct reflection of the tree. By chang-
ing the order of the features in the inspection task list you are also re-
order the entries in the tree within their respective category. Likewise 
by reordering the entries in the tree you will also change the order of 
the entries in the inspection list. 

Lock/Unlock Trapping
The availability or display of any feature in the Inspection tab can be 
controlled on an individual or feature type basis. To exclude or include 
features in the inspection tab right-click on that feature in the tree 
and turn on or off Lock Out Trapping. Likewise, by right-clicking on 
the Relationship, Datum, or Feature Check categories you can select 
Lock/Unlock Trapping and control the display of multiple features 
from that category at one time. 

Sweep and Sweep & Move 

Figure 25-18. Sweep and 
Sweep & Move sections of the 
Inspection tab.

Sweep
The sweep controls (Figure 25-18) are composed of two button icons 
and two radio buttons. This provides a 4 way control. 

 ■ Sweep/Clear Assoc. -  clears the actively selected feature
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 ■ Sweep All/Clear Assoc. - clears all the features 

 ■ Sweep/Delete Points - deletes the points from the actively se-
lect feature

 ■ Sweep All/Delete Points - deletes the points from all features

Sweep & Move
Sweep & Move was added to allow collection management and eas-
ier repeat measurement of common features in separate collections. 
This function only works with relationships not GD&T features. When 
you press the Sweep & Move Icon you will see the following dialog: 

By utilizing the Sweep & Move feature, a user may choose to either 
copy or move relationships from the active collection to a destination 
collection. By selecting COpY, a duplicate set of the relationships will 
be built in the new collection, constructed point associations will be 
maintained while clearing measured points from these new relation-
ships. By choosing MOVe, relationships will be moved into a destina-
tion collection, leaving the measured points and constructed geom-
etry only in the original collection.

Properties Button
A properties button is also available next to the sweep section. This 
button provides direct access to the properties dialog of the selected 
feature in the inspection tab. 

Helpful Tools for Inspection

Measurement Counts
Measurement Counts are a property of any feature within the inspec-
tion tab. They are used to set the desired number of measurements 
for a feature. When trapping to that feature you can measure until the 
desired count is reached and then the trapping will be automatically 
iterated to the next feature in the inspection list.  
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Figure 25-19. Desired Mea-
surement Counts.

Measurement Counts are off by default (when 0), but global default 
controls (Figure 25-19) can be set for all features within the User Op-
tion> Analysis Tab or within the properties of each Feature individually. 

Associated Inspection Callouts
Callout views can be directly linked to relationships for use in inspec-
tion. Once linked when you start trapping to that particular relation-
ship the associated callout view is activated. This opens up some very 
powerful scripting tools. Activating a callout can:

 ■ Set the viewpoint and render mode 

 ■ Set the working frame

 ■ Set the visibility layer (such that only objects of interest are 
shown)

 ■ And display any individual callouts you wish to display. 

To associate a callout with a relationship you can do either of the fol-
lowing: 

1. Right-click on the relationship in either the tree or the inspec-
tion task list and choose Create Associated Inspection Callout. This 
will build a new Callout View with the particular relationships 
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callout added to it.  Edit the properties of the new Callout as 
desired.

2.  Go to and existing callout and use Add Relationship. Each rela-
tionship added to callout will then be linked to that callout 
view. 

Show Only Selected Relationship
Within the right-click relationship category is an option to show only 
the selected relationship. This option hides all relationships in the graph-
ics except for the one currently selected in either the tree or with trap-
ping focus in the inspection bar. When used with trapping this can 
make the inspection process much clearer. 

Enable Trapping Auto Vectors
Within the relationship category is an option to turn on/off trapping 
auto vectors (Figure 25-20). This function automatically turns on an 
auto vector group for the for the feature that is actively being trapped 
to. It builds a vector group called “Trap Vectors: [Relationship Name]”. 

Figure 25-20. Enable Trap-
ping Auto Vectors displays 
vector deviations for the cur-
rently feature.

 ■ Trapping vectors display the point to Measured Object (AVF) 
vectors for geometry relationships or the point to object vec-
tors. 

 ■ When the toolkit is advance to the next feature in the inspec-
tion tab this vector group is automatically replaced by a new 
one representing the current feature. When trapping stops the 
vector group is then deleted. 

 ■ Should an auto vector group already exist for a particular re-
lationship in the tree it is updated and then hidden when you 
move to the next feature.   

Set/Clear Relationship Domant Status
There are times such as when performing a relationship optimiza-
tion process or working in large job file when it would be helpful to 
postpone the recomputing process inherent in a relationship. This 
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dormant satus is used for that purpose. Any relationship marked as 
dormant will stop updating until its status is changed. 

Configure Instrument
By right-clicking on a relationship in the Inspection tab (or in the tree-
bar), a user can configure the instrument settings prior to measure-
ment. By configuring these settings ahead of time, the measurement 
profile and reflector/tooling will automatically update without user 
interaction while iterating through the task list (Figure 25-21).

Figure 25-21. Configure 
Instrument Dialog.

The Loop and iterate control is helpful for scanning around a hole with 
a pin nets. It recognizes that a loop is closed and iterates to the next 
feature for you automatically when measurement counts can’t be 
used. 

Toolkit/Toolbar Keyboard Shortcuts
Keyboard shortcuts and T-Probe/4-button remote functions have 
been added for the SA Toolkit and Instrument Toolbars:

 ■  F6 (‘A’ button). Toggle measurement in the instrument toolbar.

 ■  F7 (‘B’ button). Go to the next feature in the toolkit.

 ■  Ctrl + F7. Go to the previous feature in the toolkit.

 ■  F8 (‘C’ button). Remove last point in the toolbar.

 ■  Ctrl + F8. Stop trapping in the toolkit.

 ■  F9 (‘D’ button). Iterate the measurement mode in the toolbar.

 ■  F10. Iterate the active target in the toolbar.

 ■  F12. Find the reflector (target search) in the toolbar
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SA Toolkit 
The SA Toolkit (Figure 25-22) contains five tabs that provide conve-
nient access to a subset of the most powerful tools in SA. These tabs 
include GD&T, Relationships, Inspection, Analysis, and Reporting.

GD&T. 
What was formerly known as the GD&T bar has been brought on as a 
tab in the Toolkit bar.  This tab is an ideal tool for building GD&T An-
notations. For more information on the GD&T Tab and its use see the 
GD&T Chapter.

Relationships. 
The relationships tab enables one-click definition of features (defined 
by CAD or using primitive geometry) primed for easy inspection us-
ing geometry relationships, with or without projection planes. Other 
relationships can be easily defined as well.

Inspection. 
The inspection tab presents all trappable features from all collec-
tions—relationships, datums, and feature checks—in a single list. This 
allows you to easily advance through an inspection routine, trapping 
measurements for each feature, and instantly providing inspection 
results against nominal data. 

Analysis. 
Some of the more commonly-used analysis tools, such as the frame 
wizard and geometry fitting, are presented together in the analysis 
tab.

Reporting. 
Functionality for creating reports, making dimensions, and creating/
annotating callout views is gathered together in the reporting tab. 
To display the Toolkit bar, right-click on the menu/toolbar/status bar 
area of the SA interface and select Toolkit.
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Figure 25-22. SA Toolkit

Tutorials On Using the Toolkit for Inspection
For instructions on using the toolkit refer to the Tutorials section of 
this manual. 

Analysis Tab

The Analysis tab consists of a set of direct shortcuts to powerful and 
commonly-used features also available through SA’s main menus. A 
brief synopsis of the function of each button is provided here.  

Figure 25-23. Visualization 
section of the Analysis tab.

Visualization

The Visualization section of the Analysis tab (Figure 25-23) provides a 
set of useful graphical controls and object identification tools. 

Cloud Thinning
This button brings up the Cloud Display control dialog. It allows you 
to limit the number of cloud points rendered on-screen, and control 
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the size of the rendered cloud point, in pixels.

Clipping Planes
This button brings up the Clipping Planes control dialog. It allows you 
to define, edit and turn on and off the display of clipping planes for 
visualization.

Auxiliary View
This button opens an Auxiliary View dialog. Auxiliary graphical views 
can be rotated, positioned, and rendered independent of the primary 
graphical view, and they also support selection.

Hover Window
This button opens the Hover window which will indicate the collec-
tion, name, type, and location of the item in the tree, the coordinates 
of a point (in Cartesian, Cylindrical, or Spherical coordinates, the del-
tas for a vector, or the number of measurements associated with an 
instrument.

Figure 25-24. Construction 
section of the Analysis tab.

Construction

The Construction section of the Analysis tab (Figure 25-24) provides a 
set of usefult construction tools.

Frame Wizard
The Frame Wizard is used to create a coordinate frame based on differ-
ent combinations of points or features. It allows control of axis com-
ponents and origin placement based upon these features. For more 
information see the second on Frame Wizard in the Analysis Chapter. 

Objects from CAD
This button provides direct access to a collection of geometry extrac-
tion tools. It allows you to pick a geometry type and then graphically 
select faces on a CAD model, building the nominal geometry from 
the selected face.

Circle Center Points
This button triggers the Construct>Points>Center>Circles function.

Colorized Graphical Mesh
This button triggers the Construct>Colorized Graphical Mesh>From Proximity 
Points command. It will prompt for selection of points and surfaces 
and build a colorized mesh from the point proximity. Right-click to 
build a mesh using point clouds. 
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Figure 25-25. Fitting section of 
the Analysis tab.

Fitting

The Fitting section of the Analysis tab (Figure 25-25) provides access 
to a selection of powerful alignment tools. 

Geometry Fit
This button will open the Construct>Geometry by Fitting dialog.

Best-Fit Transform
This button will open the Analysis>Best Fit Transformation>Points to Points 
function. 

Relationship Fitting
This button triggers the Relationships>Move Objects by Minimizing Relation-
ships function. 

Quick Align to CAD
This button triggers the Analysis>Best Fit Transformation>Points to Surfaces/
Objects>Quick Align to CAD function. 

Figure 25-26. Uncertainty sec-
tion of the Analysis tab.

Uncertainty

The Uncertainty section of the Analysis tab (Figure 25-26) provides a 
set of powerful analysis tools that take advantage of the uncertainty 
information contained within measured points.

USMN
This button triggers the Analysis>Coordinate Uncertainty>Unified Spatial Me-
trology Network function.

Simulate Measurements
When you wish to link constructed points with an instrument station 
and treat them as measurements you can use this button which trig-
gers the Analysis>Measurement Simulation>Fabricate Measurements func-
tion.

Make Uncertainty Fields
This button calls the Analysis>Coordinate Uncertainty>Create Point Uncer-
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tainty Fields function.

Geometry Fit Uncertainties
When you wish to determine the uncertainty in fitting a particular 
type of geometry to a selected set of points you can use this button 
which triggers the Analysis>Coordinate Uncertainty>Fit Geometry Using Un-
certainty Fields function. 

Figure 25-27. Scaling section 
of the Analysis tab.

Scaling

The scaling section of the Analysis tab (Figure 25-27) provides a set 
of controls to help with scaling points and controlling scale of instru-
ments and their measurements. 

Temperature Compensation
This button triggers the Analysis>Temperature Compensation command 
which prompts to choose a reference frame and then the point groups 
to scale, allowing for scaling of constructed or imported points.

Scale Bar Measurement

Make Scale Bar
This button triggers the Construct>Scale-Bar>Pick 2 Points command. 

Reporting Tab

Figure 25-28. Reports section 
of the reporting tab.

Reports

The reports section of the Analysis tab (Figure 25-28) provides access 
to the SA reports in the job file.

Add New SA Report
This button builds a new SA Report.

Pick Report
This drop down menu provides access to a list of all the SA reports 
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in the Job file. It provides a quick way to open the desired report by 
clicking on it in the list. 

Figure 25-29. Dimensions sec-
tion of the Reporting tab.

Dimensions

The Dimensions section of the Reporting tab (Figure 25-29) provides 
a set of quick format buttons for adding dimensions. Dimensions are 
defined as one of 4 different dimension types: 

 ■ Point to Point

 ■ Point to Object

 ■ Object to Object

 ■ Diameter/radius

The individual icons provide not only the ability to add these dimen-
sions to an SA job file as you would be able to do through the Analysis 
menu, but they provide additional pre-formating options depending 
on the selected icon. 
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Figure 25-30. Callouts section 
of the Reporting tab.

Callouts

The Callouts section of the Reporting tab (Figure 25-30) provides ac-
cess to both the callout views in the job and the individual callouts 
that can be placed in any callout view.

Views 

 Selection List
This drop down menu provides access to a list of all the callout views 
in the Job file. It provides a quick way to activate the desired callout 
view by clicking on it in the list. 

 Add New Callout View
This button adds a new callout view to the job file in the active collec-
tion and prompts for a name. 

 Close Callout Views
This button deactivates all the active callout views.

 Callout Options
This button provides access to the active callout view’s right-click 
menu options. 

Callouts
This section provides a set of buttons to build callouts within the ac-
tive callout view of various types. 



CH
A

PT
ER 26

579

SpatialAnalyzer’s GD&T Inspection tools provide engineers with the 
ability to perform standardized inspections in accordance with the 
guidelines of the ASME or ISO standards. It provides the tools to al-
low the technician to import fully annotated CAD models and utilize 
the annotations and tolerances provided, or build their own annota-
tions from CAD models, SA geometry, or even directly from measured 
points that define geometry. It also provides the ability for a designer 
to build an inspection process that walks an operator through the 
process of measuring the datums and features of interest following 
predefined measurement location indicators. Once points are as-
signed to a feature check it is immediately validated with a pass or 
fail result. The check can then be added directly to dynamic reports.

SA’s GD&T evaluation process can be customized to ensure compli-
ance with one of the following supported standards:

 ■ ASME (1994)

 ■ ASME (2009)

 ■ ISO (1983)

 ■ ISO (2004)

 ■ ISO (2012)

You may select the standard you wish to use by navigating to the 
Analysis tab in the User Options dialog. Select GD&T Options and then 

Geometric dimensioning and tolerancing, more commonly known as 
GD&T, is a system for defining and implementing engineering tolerances 
for part and assembly geometry. In this chapter, we will discuss how SA 
supports the engineer’s ability to read and communicate GD&T design 
from CAD drawings. 

GD&T
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choose one of the options listed. For more details see “GD&T Evalua-
tion” on page 606. 

Importing CAD with GD&T Annotations
To import a CAD model with annotations select File > Import > Direct CAD 
Access. If you would like to change your import preferences, navigate 
to File > Import > Direct CAD Access Settings. 

In the Direct CAD Access Settings dialog, check the annotations op-
tion. Once imported, the annotations will appear graphically and in 
the tree in the Annotations category (Figure 26-1) .

Figure 26-1. Imported CAD An-
notations.

Annotations will be imported into the current active collection along 
with the CAD surfaces. An additional collection will be added contain-
ing the imported CAD Views and will be labeled “CADViews:” followed 
by the name of the imported CAD file. This collection will include the 
view orientation frames associated with the annotations as well as a 
set of Callout views. These callout views include the imported orien-
tation of the model and the fill Annotation display as well as one for 
each group of commonly oriented annotations. 

Creating GD&T Annotations
SA provides the ability to add GD&T annotations to a CAD model 
and provides the tools necessary to conduct a GD&T analysis on con-
structed SA geometry. To build your own annotations in SA use the 
GD&T tab in the SA toolkit (Figure 26-2), and for a basic case just fol-
low these steps:
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Defining Datums:
1. Choose between CAD Faces or SA Objects 

2. Click the Datum letter button to start selection

3. Click in the graphics on the desired CAD face or SA Object to 
both define the attachment point for your datum and desig-
nate the feature as a datum. 

Defining Checks
1. Choose between CAD Faces or SA Objects

2. Enter the Tolerance and Datums to include in the check (using 
the order of priority)

3. Click on the check button to define the check type

4. Click in the graphics on the desired face or object to define 
the features to inspect. 

Notes on Selection
Here are a set of helpful hints and things to keep in mind when build-
ing annotations using the GD&T Toolkit tab:

1. The GD&T Toolkit tab is intended to be a quick means to build 
annotations in the graphics. For greater control or to edit the 
annotations simply open the annotation properties. 

2. After an annotation has been created it will contain all the fea-
tures associated and tolerance information. When the proper-
ties dialog is open the associated features will be highlighted 
and the annotation can be positioned as necessary. 

3. The Feature Type selected greatly impacts the construction of 
GD&T annotations. 

Creation Options

The GD&T Annotation tab is located within the SA Toolkit. If it is not 
visible, select View > Show Toolkit Bar from the menu. This toolbar is the 
starting point for building annotations and setting up GD&T evalua-
tions when not importing annotations with a CAD model. With a logi-
cal workflow starting from the top and working toward the bottom, 
the toolbar begins with the Creation Options section (Figure 26-2).
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Figure 26-2. GD&T Creation Op-
tions Section.

View
This sets the orientation of the text for the annotation to be added.  
Selecting Current View  sets the annotations to the current screen ori-
entation and allows them to rotate to always face the user. The view 
orientations available are drawn from the Preset Views  list which can 
be accessed and edited by going to View > View Control > Preset Views. 
The view selected, as well as the text size, can be edited within the 
annotation properties once the annotation is created.

Feature Type
The Feature Type settings within the Creation Options section defines 
and limits the type of objects to which an annotation may be added. 
You can choose from Cad Faces, Sa Objects or Sa Objects (fit to points). 
In all cases the GD&T annotations must be added to the nominal (de-
sign)  features. If these nominal features do not exist in your job they 
must be created because they define the baseline for the evaluation.  
Only the Sa Objects (fit to points) option allows you to select measure-
ments.

 ■ When you select Cad Faces, the annotation will be added to 
and include the specific selected CAD faces you chose from 

Tip:  In all cases GD&T Anno-
tations must be added to the 

nominal (design) feature. If they 
don’t exist they must be created.
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a particular model regardless of whether or not a model has 
been dissected into individual faces.

 ■ Selecting Sa Objects allows selection of any primitive SA geom-
etry type as the nominal feature.

 ■ Sa Objects (fit to points) is a special case which allows you to add 
an annotation directly to measured points. When you select 
this option you will be limited in your choices to building Da-
tums, Form, and Orientation Checks. When adding annotations 
you will be prompted to define the geometry type you wish to 
fit to the points. Doing so will perform the following actions: 

1. Datums & Form Checks. The selected feature type will be built 
fit to the selected points, an annotation will be added to this 
feature, and the check will be evaluated based on the speci-
fied tolerance. 

2. Orientation Checks. Form checks require the nominal feature 
to be built at a nominal angle to the specified datum. There-
fore, the feature fit to the selection points will not be RMS 
fit but will be align to the points while holding this nominal 
angle. Once built, an annotation will be added to the features 
and it will be evaluated using the specified tolerance.  

 ■ Selecting Gr Objects is another special case which allows selec-
tion of Compare to Nominal Geometry Relationships directly. 
This creates a bridge between a standard inspection and a true 
GD&T inspection by doing the following:

1. The nominal SA Object defined within the GR-feature will be 
automatically assigned as the reference object for the GD&T 
Annotation. 

2. The associated points from the selected GR-Feature, used to 
build the measured feature, will be used by the resulting fea-
ture checks.  

Datums
The two buttons in the datum section are intended for the quick ad-
dition of datums to a part. Press the Datum letter button and then click 
on the part to define the tie-in point for the leader line used by the 
annotation and to select the associated CAD faces. The Datum letters 
increments automatically to the next available letter. To enter a let-
ter that is not in sequence, hold the letter you wish to use down on 
the keyboard when you press the datum button. It will then add this 
selected letter when you click on the part. Datum letter utilization is 
controlled by the selected GD&T Standard. ASME does not allow the 
use of the letters I, O, and Q, so they are excluded in the sequence 
(Figure 26-3).
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Figure 26-3. Datums Section of 
the Toolkit

 ■ Double or great datum letter designations such as AA or AC can 
be created and are recognized in SA. However, they cannot be 
built through the toolkit. You can build them using only one 
letter “A” for example and then open the annotation properties 
and change the name after building the annotation. Another 
alternative is to use  GD&T> Make Annotation for GD&T Datum to build 
a blank datum annotation, add the Name designation desired 
and then associate the feature object.

Datum Targets
Datum Targets can also be added to a predefined datum feature. They 
are added by first clicking on the datum target button in the toolkit 
and then on the datum feature at the location you would like to iden-
tify as the target location. Targets acquire the name of the datum and 
increment numerically. Datum targets are tied to a surface face or ob-
ject. However, for greater positioning accuracy, the end of the leader 
line can be linked directly to points with known coordinates. 

Feature Checks
Like Datums, Feature checks are added simply by selecting the check 
type button and then the associated features. The only major differ-
ence is that special attention needs to be given to the Tolerance and 
Datums assignment text boxes. These settings need to be entered 
prior to adding the check for them to be applied (Figure 26-4). 

Figure 26-4. Feature Check Sec-
tion of the Toolkit
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 can be added by first setting the selection mode clicking on the CAD 
face, object, or selecting points in the same was as datums are added. 
However, it is important to first specify the associated datum(s) and 
tolerance(s) used by the check.  In addition to specifying any indi-
vidual datums used in the check such as ABC you can also use  “ -“  to 
indicate compound datums such as A-B and use @L or @M to specify 
the minium and maximum material conditions respectively. The com-
posite true position check shown Figure 26-5. 

 ■ Tolerance. 0.02@M, 0.01@M

 ■ Datums. AE@MB, A

Figure 26-5. Composite True 
Position check. 

Double letter datum entry in the Feature Check reference is currently 
not supported through the toolkit. To add Feature Checks that refer-
ence double letter datums go to GD&T >> Make Annotation for GD&T Fea-
ture Check and build a bank Feature check. Within its properties more 
complex datum structures including double letter datums can be 
added (such as AB-AC).

GD&T Dimension Tolerances
Dimension tolerances provide both a means of checking simple di-
mensional aspects of a part and also provide the base of reference for 
other checks that use a material modifier. 

To add dimensional annotations you must have first set the Tolerance 
type, whether that be Limit (which provides the option to enter the 
low limit and high limit values explicitly) or Nominal +/- (which provides 
the option to enter the nominal value and the low and high deviation 
values from that nominal). These settings are saved with the annota-
tion and used in the evaluation. The tolerance definition can then be 
edited in the annotation properties later dialog if needed. 

Figure 26-6. Dimension Section 
of the Toolkit

Tip:    To add Feature Checks 
that reference double letter 

datums go to GD&T >> Make Annota-
tion for GD&T Feature Check to build a 
Feature check.
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Adjusting Size and Placement of Annotations
The placement and size of any annotation can be edited at any time. 
However, imported annotations will be converted when you do so. 
It should be noted that changing the properties of any annotation 
including placement and scale will convert the annotation from the 
CAD format to the NRK format annotations. This may change the look 
and number of leader lines of these annotations to some degree. 

The size and position of an annotation is saved in the annotation 
properties. While the properties of an annotation is open the graphi-
cally placement can be edited by dragging the annotation to a new 
location in the graphics window. There is also a numeric control with-
in the properties dialog to adjust the size of the annotation text. 

Global Adjustments

Global adjustments to annotation placement and text size can be 
made by using the utilities available through the Annotation Right-
click Menu. these functions will convert Cad imported annotations to 
nrK annotations which will graphically change to some degree. 

 ■ Set Text Scale. This option will allow you set the text scale for 
all annotations in the job file at one time. 

 ■ Drag Annotations. This Graphically Drag Annotations dialog 
allows you to edit the position and orientation of any selected 
annotation. Set the view, text rotate, and text size you want 
and then select an annotation to apply those settings. 

Figure 26-7. Drag Annotions 
Placement Control uesd to position 
multiple annotations at one time.

annotation Layout tools in Spatialanalyzer - 

https://youtu.be/-ToXGkd1hyQ
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Using the Drag Annotations Tool.

Annotations can either use the “Current View” which dynamically ro-
tates to face the screen at all times or can be constrained such that 
the annotation text is placed on a plane. 

The hardest part of position an annotation in 3D space is controlling 
the depth. Your annotation may appear perfect but, when rotated 90 
degrees, be far from the part because of this view plane issue. To ad-
dress this the Placement Reference Object selection was added. This al-
lows you to constrain the placement of an annotation to a plane and 
position it while remaining in Current View (screen oriented) display. 

This is done as follows: 

1. Select an object defining a direction, such as the World frame.  

2. Select a reference plane such as XY-plane. 

3. Position any annotations you would like in the graphics. Do-
ing so will constrain the leader lines for the selected annota-
tions to be parallel to the reference plane. 

Alternatively, annotations can be directly constrained to a view plane 
by selecting a specific view. Doing so will lock the annotation text 
to a plane defined by the viewing direction and the annotation an-
chor point. This method works very well when combined with callout 
views. 

GD&T Dimensional Annotations

Dimensional tolerances have greater constraints placed on them and 
only allow 2D placement with respect to the selected features. Right-
clicking on a dimension annotation and selecting Adjust Leader Lines 
will bring up the following dialog (Figure 26-8). 

 

Figure 26-8. Dimension place-
ment controls use for diameter, radial 
and distance between checks.

 ■ Display Offset. (Ctr + Mouse Wheel) shifts the annotation in 
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and out from the reference features along the display plane. 

 ■ Display Angle. (Alt + Mouse Wheel) rotates the annotation 
about the selected feature

 ■ Elevation Angle. (Ctr + Alt + Mouse Wheel) tilts the angle of 
the display plane.

 ■ Annotation Tag Line. Provides an option to display a line from 
the center of the dimension to the annotation text much like a 
standard annotation. 

 ■ Reverse Feature Direction. Flips the display plane from one 
end of a feature to the other.

 ■ Annotation Text Settings.  Annotation text can be graphically 
dragged into positioned and the radio selection boxes can be 
used to change the orientation of the tex.

GD&T Entities
If you look in the TreeBar in SA you will find that all imported and con-
structed annotations are contained within an Annotations category. Of-
ten it is useful to contain all the design CAD and Annotations within 
a single collection. You can then create a new collection for a particu-
lar inspection. To inspect a feature simply right-click on the Annota-
tions category and select Make Feature Checks.  The annotation will 
be decoded and two additional categories will be built: Feature Checks 
and Datums. Feature Checks and Datums are much like relationships 
in that they maintain the association between measured points and 
the features specified in the annotation. (For more information on as-
sociating points to with datums and feature checks refer to the GD&T 
Workflow section). 

Figure 26-9. GD&T Entities in the 
Treebar.
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GD&T Annotation Properties

Annotation in SA are used to define both the graphical placement, 
object associations and tolerance information used to define datums 
and checks. All GD&T Annotations will contain a subset of the follow-
ing options regardless of the type of Datum or Check they represent.  

Figure 26-10. Example Annota-
tions Properties Dialog.

The GD&T Datum annotation properties dialog allows you to edit the 
following settings:

(Identifier)
This section is used to describe the datum or  check. 

 ■ Type. This field identifies the type of check represented by the 
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annotation. 

 ■ Name. The datum letter used as an identifier in the annotation 
(currently support single and double letter annotations and 
will automatically exclude I,O,Q for ASME).

Inspection
These controls are used with the Inspection>Inspect process de-
scribed in the Workflow Section (see “GD&T Workflow” on page 627).

 ■ MeasurementProfileName. Controls the measurement mode 
set when inspection is initiated for this check. 

 ■ MeasurementToolName. Controls the tooling set when in-
spection is initiated for this check. 

Features
The Feature Type section provides a list of the associated objects for 
the annotation. It also allows you to re-select the associated features 
and define additional reference objects as needed. You must select 
either CAD faces or SA objects.

 ■ SA Object. The selected SA objects define both the annotation 
placement and the features evaluated as part of the check.

 ■ CAD Feature. The selected CAD faces define the annotation 
placement and the features evaluated as part of the check.

 ■ GRs. The selected GR-Features (Geometry Relationships) used 
to define the annotation placement and the features evaluated 
as part of the check. The Nominal geometry from the selected 
GR-feature will be used.

 ■ SA Offset Object. SA Offset Objects provides directional refer-
ence information or alignment restrictions for surface datums.

 ■ Auto Detect CAD Faces. Profile checks can have this option 
enabled which allows all measured faces to be evaluated un-
der the specified tolerance. This provides a convenient means 
to apply a global tolerance to a part.

 ■ Is Slot. This check box designates this feature as a slot which 
triggers a separate evaluation process. 

Placement
These controls provide the ability to redefine the text size, placement 
and orientation in the job. 

 ■ View. The View defines the saved orientation of annotation 
text. 

 ■ Height. The Text Height defines the height of the annotation 
text. This is expressed in job units. 

Tip:  The point where the an-
notation leader line connects 

to the associated objects can be 
adjusted here.  It used the first 
click point in the selection pro-
cess.
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 ■ Text Rotation. The Text Rotation defines the rotation in the 
current view.

With the annotation editor open the graphical annotation can be 
moved and placed in a position that is easy for the user to read. The 
annotation leader line is defined using a click-point on the first surface 
face or SA Object selected when that feature is assigned in the anno-
tation. To move the annotation simply select the annotation in the 
graphics by left-clicking the annotation. While holding the left mouse 
button the annotation can be moved in the plane of the screen.  Us-
ing orthogonal views can help to precicely locate annotations in 3D. 
The view can be change under the View parameter in the annotation 
editor. Controls at the bottom of the annotation editor help in fine 
tuning the position and orientation of the annotation.

 ■ Rotates the annotation box 90 degrees counter clockwise.

 ■ Rotates the annotation box 90 degrees clockwise.

 ■ Mirrors the annotation box.

 ■ Straightens the leader line normal to the selected surface 
face.

Extra Text
 ■ TextAbove. Allows a user to display text just above the refer-

ence frame for a check. 

 ■ TextBelow. Allows a user to display text just below the refer-
ence frame for a check. 

Certain Alt + Number entries can be used to add symbols to this text 
line. A brief list of these symbols includes the following:

 ■ Alt + 0176. Will produce the degree symbol °

 ■ Alt + 0177. Will produce the plus & minus symbol ± 

 ■ Alt + 0226. Will produce the diameter symbol Ø

Cylinder
When a datum/check is added to a cylindrical feature the following 
additional controls will be provided. 

 ■ Cylinder Mode. Allows for selection between hole and pin cyl-
inder evaluations. It is used to properly define probing offsets. 

 ■ Axial Extent Mode. Provides control of the way full cylinder 
evaluations are performed (see “Cylinder Evaluation Methods.” 
on page 598). 

 ■ Auto Full Cyl Eval.  It also provides control of the way full cylin-
der evaluations are performed (see “Cylinder Evaluation Meth-
ods.” on page 598). 
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Initial Alignments
When working with offset objects and surface datums or pattern fea-
tures it can be important to provide a good starting alignment for the 
evaluation to ensure the best solution is found. 

 ■ Custom Initial Alignment. This field provides the ability to ref-
erence a defined alignmnet in the tree (RPS or Sequent Align-
ment) that is used prior to the full GD&T evaluation. 

CAD Feature 
 ■ Force Surface Feature. Provides a radio button which forces 

the selected feature to be interpreted as a general surface.

Datums
Datum designations for a check are established  in this section, which 
consists of two parts: a summary section and the individual datum 
selections (Figure 26-11).

The summary section defines how many datums are referenced as 
primary, secondary and tertiary and outlines the construction of the 
lower tier with the user of check boxes. 

The following details section allows you to edit each datum designa-
tion and call out any Matieral Modifiers used with those Datums. 
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Figure 26-11. Datum Designa-
tions

Tolerance
 ■ Zone. Applicable tolerance zone. See “Feature Check Specifics” 

on page 614 for more information on Zone options.

 ■ Tolerance. Tolerance value for the feature check.

 ■ Material Modifiers. Defines the material modifier for the fea-
ture check’s selected datum. Choose from Maximum Material 
Condition, Least Material Condition or regardless of Feature Size.

 ■ Has Projected Zone. If checked, the projected zone will be 
used.

 ■ Projected Zone Value. Value used when projected zone is be-
ing used.

 ■ Tolerance Lower Tier. Tolerance used in Lower Tier evaluation.

 ■ Outer Tolerance Lower Tier. This designates the amount of 
the tolerance outside the surface of the part for the lower tier 
check. It allows for asymmetrical tolerance zones to be set. For 
symmetric tolerances this value should be set to one-half the 
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total tolerance. Starting in the 2016.09.01 version Unilateral an-
notations are displayed graphically (Figure 26-12). 

Figure 26-12. Unilateral Symbols

 ■ Material Modifier Lower Tier. Optional material modifier des-
ignation for the lower tier tolerance.

Datums and Feature Checks
The Datums dialog as well as the Feature Checks dialog (Figure 26-13) 
have identical settings with a few minor exceptions:
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Figure 26-13. Datum and Feature 
Check properties dialogs.

 ■ Name. Displays the name of the Datum/Check. 

 ■ # Associated Measurements. This displays the number of 
points associated with the check. 

Point Controls
Under the Datum/Check name are a set of check boxes which define 
the way in which offset measurements are applied and allow for alter-
native probe offset controls. 

 ■ Measured Indirectly. At times, it can become necessary to 
measure a feature indirectly. Meaning for example, that you 
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measure the table top to represent the bottom surface of a 
part clamped to the table. Normally the probing direction de-
fines the way in which we handle probing offsets. However in 
this case, you are measuring a mating surface, changing the 
offset direction. To account for this, we have an option in the 
Feature Check properties dialog that allows you to specify that 
the measurements were taken indirectly. 

 ■ Use Probing Direction. Probing direction is either the line of 
sight of the instrument (for a tracker as an example) or the di-
rection vector recorded with a point taken by a 6D probe. Using 
this information typically ensures proper probe compensation.

 ■ Reverse Probing Direction. There are times when a reflector 
is visible on the far side of a part but the measurement was 
taken in the opposite direction of the line of sight. This option 
allows probe compensation to be manually set in the opposite 
direction from normal use. 

 ■ Ignore Edge Projection. Surface Profile checks are allows a 
little flexibility based upon the extent of the surrounding sur-
faces. This check box forces any points off the measured sur-
face to be ignored. 

View Controls
A saved view can be recorded with each feature check and displayed 
when it is either activated for measurement or evaluated for reporting 
purposes. Saving a preset view with a check ensures that a comfort-
able viewing angle is obtained whenever measurement is in prog-
ress. The GD&T Inspection >Design, Inspection>Inspect workflow process 
provides a convenient way to predefine views for a series of checks. 
The views from the Inspection Design interface are saved automati-
cally and can be recalled or edited by going directly to this section in 
the specific datum or feature check.

 ■ Set. Defines the current view perspective and zoom depth and 
saves it with the check. 

 ■ Clear. Removes the currently saved View. 

 ■ Switch To.  Resets the graphics to the saved view.

In addition to the saved view orientations an option has been built 
into the right-click menu of the feature check category to enable Show 
Only Active Feature Check. When enabled, this option changes the visibil-
ity of the annotations such that only the annotations directly linked 
to the selected check are displayed. This included the selected check, 
the datums it references and any addition annotations that share the 
same feature associations.
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Datum Alignment
A GD&T alignment performs a direct fit to the datums as an initial 
alignment, the measurements of the features to be checked are then 
divided up and the final evaluation process is conducted. These op-
tions provide tools to troubleshoot each aspect of the evaluation pro-
cess.

 ■ Enable Datum Alignment. Un-check for manual alignment. 
This performs a GD&T evaluation of the check in the current 
job alignment without using the GD&T control frame datums 
to align.  When disabled this is no long a standard GD&T evalu-
ation and the datums with be marked out in the report. How-
ever this option can be helpful in troubleshooting your results.

 ■ Disable Initial Datum Alignment. This option provides the 
ability to skip the normal datum alignment process prior to 
point and feature processing. When pre-aligned this option 
can help ensure that the correct points are associated with the 
correct features in a pattern. However, it requires the points to 
be closely aligned to the part in order to evaluate correctly.

 ■ Enable Custom initial Alignment. When a custom initial align-
ment is specified in the annotation properties this check box 
allows it to be applied as the first step in the evaluation pro-
cess, providing the GD&T evaluate a better initial alignment.

Cloud Thinning 
Controls the extent of thinning performed on point clouds associated 
with this check during evaluation. 

 ■ Use Global Defaults. With this default option enabled, the 
check will use the system thinning controls defined in the Fea-
ture Check Cloud Thinning settings on the Analysis tab of the Users 
Options. 

 ■ Settings. This button opens a dialog allowing you to specifi-
cally define the thinning used in that check, independent of 
the global settings. 

Datum Alignment 
 ■ Enable Datum Alignment.  When unchecked, the feature 

check will be evaluated in its current position and the datum 
alignment will not be performed. This is primarily for diagnos-
tic purposes only (see “Disabling Datum Alignment” on page 
605).

Nominal Pts
Nominal Points provide control of the selected nominal points used 
in the GD&T Inspection>Inspect routine. These points are used to lay 
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out the bulls-eyes on the part used by the inspector as a guild to mea-
sure the part in the correct location. Nominal points can be added to 
the job through the Inspection Design interface or can be selected 
manually for a particular feature through this dialog. The highlight 
button can be used to graphically identify the nominal points.

 ■ Select. Allows you to re-establish which points are associated 
as nominals for the check.

 ■ Toggle Highlight. Allows highlighting to be toggled on and 
off for those associated points. 

Measurement Trapping & Advancing
 ■ Desired Measurement Count.  This parameter is used to con-

trol the number of points captured from a live instrument dur-
ing trapping. When the specified number of points are associ-
ated with the feature trapping is stopped automatically (refer 
to GD&T Workflow section).

Cylinder Evaluation Methods. 
Cylinder can be evaluated either in 2D as circle center point locations 
or in 3D as an axis comparison along a length. Settings in this section 
control the way that the specific feature is evaluated (Figure 26-14). 

                

Figure 26-14. Cylinder Evaluation 
Method section.

The position of measured cylindrical holes or pins can be established 
in either of 4 ways depending on the users needs.  These methods are 
as follows: 

2D Projected Evaluation Methods:
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Figure 26-15. 2D Evaluation 
Methods

 ■ Trans-Axis Center Position Measurement. (Single Point 
Method) This method takes either a single point or averages a 
set of points and compares the resulting point to the nominal 
cylinder axis while using the nominal direction and radius for 
the evaluation. An example of this type of check is resting a 
probe tip of a larger diameter on a hole.

 ■ Center & Diameter at Nominal Direction. (Circle Center 
Method)  This method projects the associated measurements 
to the end cap of the nominal cylinder.  The results of the pro-
jection are then used to fit a circle.  The circle then determines 
the center point and the diameter while the nominal cylinder 
is used for the direction. This is an excellent choice in situations 
where you have very little coverage of the cylinder on either 
side of a cross section plane to define the cylinder axis.

3D Axis Evaluation Methods:

Figure 26-16. 3D Evaluation 
Methods

 ■ Center and Surface Axis Measurement.  (Axis Measurement 
Method) This method assumes that multiple measurements of 
the cylinder axis were taken at varying depths. A line is fit to the 
measurements and that line determines the center and direc-
tion of the cylinder while the nominal cylinder is used for the 
radius. For example, using a probe resting on a hole with and 
without a spacer could be used to define a cylinder center axis. 

Warning:   The Single 
Point Method should not 
be used for Primary or 

Secondary Datums because they 
do not control angular degrees of 
freedom. They are always orient-
ed by the nominal cylinder axis 
and this can lead to incorrect da-
tum alignments.
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 ■ Full Cylinder Evaluation. (Full Cylinder Fit Method) This meth-
od does a cylinder fit from the provided measurements. The 
points are assumed to be measurements of the cylinder walls 
(pin or hole), and the length of the cylinder is determined by 
the extent of the measurements along the cylinder axis. In this 
case the measurements are used to determine the central axis 
and radius/diameter of the cylindrical feature.

 ■ extrapolate axial extents. This option provides the ability to ex-
trapolate the GD&T evaluation beyond the extents of the mea-
sured cylinder to the full extent of the nominal cylinder. This 
option is more true to the letter of the standard but the ex-
trapolation can lead to false part rejection, particularly if there 
is sparse data coverage along the length of the pin or hole. 

 ■ exclude from auto eval. This option allows prevents the Full Cyl-
inder Evaluate mode from being used. This option is helpful 
when measuring with a limited number points and expecting 
a 2D result. With this option off and you measure 10 points for 
example we will do a full cylinder fit which can produced an 
unexpected result. 

 ■ Choose for me (Automatic). This is the default used when cre-
ating datums and checks with cylindrical features.  In this mode, 
the evaluation method is determined automatically based on 
the number of measurements. When set to this option the fol-
lowing designations will be made: if one point is associated, 
trans-axis Center pos. Meas. will be chosen; if two points are as-
sociated, then Center and Surface axis Meas. will be selected; if 
three to nine points are associated, then Center & diam at nom. 
direction will be selected; and if ten or more points are associ-
ated then Full Cylinder eval will be chosen.

 ■ Enable Pin Nest Detect & Comp. With greater than 3 measure-
ments (use to define a planar direction) pin nest compensation 
can be used. The planar offset is applied in the direction of the 
plane defined by these measurements and then the radial off-
set is applied laterally based upon the cylinder type designa-
tion, either pin or hole. 

 ■ Enable Actual Diameter Override. This option allows the user 
to manually stipulate a diameter for a check. It was added to 
allow quick evaluation of other checks such as True Position 
checks that have a material modifier where only a single point 
was taken (and therefore the actual diameter is unknown). 

Circles, Ellipses and Slots
While annotations can be added directly to features other than cylin-
ders (circles, ellipses or slots), these are 2D only evaluations and offer 
only a limited selection of fit controls as shown here (Figure 26-17). 
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Figure 26-17. Circle, Ellipse and 
slot evaluation options

Selecting between inside and outside probe compensation is the 
only tool that is need to control the fit of these entities. 

GD&T Alignment
When performing a GD&T inspection, alignment is performed relative 
to the specified datums for each individual check. This is often not the 
current instrument alignment in the job file. This can be a surprise to 
folks new to GD&T, but is required in order to correctly evaluate each 
check.  You can see this is true by evaluating the GD&T checks with 
the instrument not aligned to the part at all and verifying they still 
report the correct results.  

Figure 26-18. Results Evaluated 
without correct alignment.

The current instrument alignment is not used for analysis unless spe-
cifically specified with in its properties dialog (see Figure 26-20 on 
page 605). 

Note that diameter checks and other checks that use the nominal fea-
tures for reference will not evaluate correctly if you are not at least 
close in alignment with the nominal features. Therefore, an initial 
alignment is necessary prior to performing a final evaluation. 

 Tools
To get an idea of the alignment used by the GD&T evaluation with 
specific datums, right-click on the Datum Category and select “Align”.  

Warning:  An initial align-
ment is needed for some 
evaluations that use a 

nominal direction reference so al-
ways pre-align prior to perform-
ing your GD&T evaluation.
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You will be prompted to specify the datum scheme, picking primary, 
secondary and tertiary where applicable. This will then move the in-
struments and points associated with the datums to the correct ori-
entation based on this datum scheme. Because each feature check 
is evaluated based upon its own datums it will be necessary to in-
clude or exclude only the datums you wish to use in the alignment to 
simulate the alignment for the particular check. This alignment tool 
is primarily for visualization and troubleshooting purposes. It will not 
exactly duplicate the evaluation in all cases. For this reason results 
should be compared the transform values reported in the feature 
check summary table. 

Figure 26-19. Datum Align Tool

Datum selection can be set in either of two way in the GD&T Datum 
Alignment dialog (Figure 26-19): 

1. The middle section lists each feature check. If you wish to 
set the datum scheme to a match that of a particular feature 
check then the specific check can be clicked on in this list. Do-
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ing so will set the datum selection accordingly. 

Using the evaluate Selected Feature Check and apply transform (if 
possible) check box does just that. It uses the selected check and ap-
plies the resulting transform resulting returned from evaluating that 
particular check. If the solution is fully constrained, this will zero out 
the fit transform for this particular check. This can be very helpful in 
troubleshooting or when comparing to the results returned by a re-
lationship. 

2. The final or “Manual” section allows a datum scheme to be 
set that is not currently available in the job file or differs from 
one of the existing datum schemes. You can select and desig-
nate any particular datum as primary/secondary or tertiary as 
needed. 

To accelerate and the calculation process and to ensure that an ideal 
alignment solution is found for a particular check it is highly recom-
mended that an initial instrument alignment, using one of SA’s other 
alignment tools such as Quick Align to CAD or Relationship Fitting, 
is performed first prior to performing the check, particularly if using 
surface datums.

Summary Fit Transform and Alignment
The actual transform used for the check evaluation is reported in the 
Summary table for each feature check (see “Reporting Options” on 
page 637). You can directly use this information to align exactly to 
the reported position. To do so follow these steps: 

1. Copy the Transform directly out of the report bar table using 
Shift + Drag Select to copy the transform to the clipboard. You 
may want to increase the decimal precision shown when you 
do this. 

2. Set the World frame as the working frame and copy it. 

3. In the copied frames transform properties press paste to enter 
the transform.

4. Use Instrument>Locate (Transform to Part)>Frame to Frame Transfor-
mation selecting the World frame as the Source Frame and the 
new frame as the Destination Frame.    

Pattern Datums

Multi-feature datum configurations are supported such that a pattern 
of holes can be used for alignment. However, all input feature must 
be cylinders (or cylindrically faces). Slots and circles are current not 
allowed as part of a pattern datum, but cylinder evaluation methods 
do apply such that 2D cylinder evaluations can be made if circles are 
desired. 
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Surface Alignment

When using datums that reference surfaces that are of a complex or 
non geometric shape (non-planar nor cylindrical) some additional re-
quirements are involved in order to clarify which degrees of freedom 
each datum is intended to control. There are two approached that 
can be used to do so: using offset objects or providing a custom initial 
alignment. 

Using Offset Objects
 ■ The data should be pre-aligned to the part using other non-

GD&T techniques before attempting GD&T analysis, such as 
Quick Align to CAD or relationship fitting.

 ■ It is necessary to specify an SA Offset Object within the datum an-
notation which will be used to determine the degrees of free-
dom to constrain for that datum during alignment.

This offset geometry is what will “maintain contact” during alignment 
to subsequent datums and/or the main tolerance feature and so it 
needs to be chosen in such a way that it represents the control the 
datum is intended to exert over the solution. For example, a slightly 
curved plate designated as a datum can be treated as either a pla-
nar surface or a cylindrical surface. The offset object selection clarifies 
this. 

GD&T evaluation begins with an initial alignment step performed in-
ternally and also use an iterative solution. When surface datums are 
involved both are disabled. This was necessary to ensure stable re-
sults with surface datums and since the data is required to be close 
before starting they aren’t needed anyway.

Custom Initial Alignment. 
An alternative to using offset objects is to provide a full reference 
alignment. Custom Initial Alignments provide the ability to reference 
a defined alignment in the tree (either RPS or  a Sequential Alignment) 
that is used to align the features for evaluation. To define a Custom 
Initial Alignment the following steps must be performed:

1. An RPS or Sequential Alignment must be developed in the 
tree. 

2. This alignment must be referenced from within the Annota-
tion properties.

3. The Enable Custom Initial Alignment option must be checked to in-
dicate that this particular check is to use that option.

When enabled this custom initial alignment will be executed as part 
of the evaluate of the check.
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Disabling Datum Alignment

When doing a GD&T inspection, alignment is performed relative to 
the specified datums for each individual check. The current instru-
ment alignment is not used for analysis unless specified.  However, 
there is an option in the Feature Check propties menu to disable da-
tum alignment. When checked,  the feature check will be evaluated in 
its current position and the datum annotation will be crossed out in 
the evaluation (see Figure 26-20).

Figure 26-20. Disabled datum 
alignment.

This can be a very helpful tool in understanding why a check is fail-
ing because it allows you to separate the datum alignment from the 
feature evaluation process. 

Simultaneous Evaluations

Position and Profile checks using a common Datum Reference Frame 
(DRF) can be evaluated simultaneously if so desired. This evaluation 
mothod is a specified method within the ASME standard and can be  
more true to real life in that it more directly replicates part assem-
bly limitations. However, it is more restrictive which can leader to a 
greater number of failed checks and may not be desirable in all ap-
plications. 

To use a simultaneous evaluation, right-click on one of the feature 
check in the list, select Inspection> Simultaneous Evaluation. The Initial 
transform from this selected check will then be applied (which could 
be a Custom Initial Alignment) and then all of the checks that refer-
ence the same DRF will be evaluated simultaneously as a unit. 

Once evaluated the check results will then be locked such that each 
check result can be independently viewed without forcing a recom-
putation. They will also be marked as such in the Datum and Toler-
ance Summary Table (Figure 26-21). 

Figure 26-21. Simultaneous 
Evaluation results noted in the Datum 
and Tolerance Summary Table.

In order to reevaluate these checks the results will need to be cleared 
by right-clicking on the Feature Check Category in the tree and se-
lecting Clear All Check Results.
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GD&T Evaluation
As feature checks are measured, the number of points associated 
with them are shown in the tree. The evaluation process, however, is 
iterative and manually triggered for efficiency purposes.

To evaluate a particular check you can view it in the report bar. As 
long as the report bar is up you can click on a check it directly in the 
tree and it will re-evaluate to ensure the status is current. Alternative-
ly, an Evaluate all Checks  option is available in the right-click menu of 
the feature checks category. Once evaluated, a PASS/FAIL status with 
then also be displayed in the tree.  You can also Go to GD&T>Evaluate All 
Feature Checks to evaluate all the checks in the job file. 

GD&T User Options

There are several important global evaluation settings to select from 
found in the GD&T Options within the Users Options Dialog on the 
Analysis Tab (Figure 26-22): 
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Figure 26-22. GD&T Options 
dialog within the User Options dialog.

 ■ High Point Utilization for Feature Alignment. If checked, 
three high points which also enclose the center of gravity of 
the points are used while if unchecked, the best-fit geometry is 
used (Least Squares).

Full Cylinder Evaluation Defaults
 ■ Full Cylinder Evaluation Defaults. These options control the 

default fit settings passed to the annotations and define the 
way in which cylinder/Pin measurements are evaluated (see 
“Cylinder Evaluation Methods.” on page 598). The default set-
tings are applied to annotations when they are built or import-
ed but can be edited within the annotation properties directly.

Distance Between Checks Use
 ■ Distance Between Checks Used. You can choose between us-

ing the Centroid or the Min/Max when reporting the distance 
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between checks.

Evaluation Method
 ■ Eval Method. By default the Eval Method is set to “none”. This 

means that no additional version specific verifications are per-
formed beyond the standard GD&T verification common to 
both ASME and ISO inspections. By selecting a particular stan-
dard, additional verifications are added to ensure compliance 
with the particular selected version of GD&T: ASME (1994); 
ASME (2009); ISO (1983); ISO (2004); ISO (2012).

Choosing a specific standard will ensure that the numeric results 
presented are true to the selected version of the standard, and any 
deviation from that standard will result in an error. For example, by 
selecting ASME 1994 an additional check is applied for invalid datum 
identifiers (letters not permitted in ASME 1994). For more specifics on 
the additional validation checks applied for a particular standard ver-
sion, please contact support@kinematics.com. 

Debugging Tools
 ■ Feature Creation Check Boxes. Both the calculated points 

and geometry used for the evaluation can be obtained for 
some feature checks by turning on these check boxes in the 
Users Options. This can be a very helpful diagnostic tool, how-
ever, it creates a lot of new points and geometry. Figure 26-23 
shows the resulting geometry created by enabling the Feature 
Creation check boxes on a Composite True Position check. 

Figure 26-23. Resulting geom-
etry from enabling the Feature Creation 
check boxes on a Composite True 
Position check.

Cross Section Criteria
 ■ Cross-Section Criteria. In order for a group of measurements 

to be considered a cross section, they must be within the de-
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fault 1mm of each other in the cross section direction. In other 
words if you fit a plane to the data none of the points would be 
greater than .5mm from the plane. In order to take measure-
ments in this format a geometry trigger measurement mode 
would be easiest. This cross section criteria can be adjusted by 
selecting GD&T Options under the Analysis tab in the User Options 
dialog.  The number of cross sections used in the analysis is re-
ported in the summary table of the check.  

Datum Combination Tolerances
 ■ Datum Combination Tolerances. These tolerances are used 

to determine how nominal features are to be handled. It ac-
countes for slight variations in a nominal model and allows for 
grouping of nearly perfect objects as needed within these cat-
egories. 

Automatic Feature Detection From CAD Face Selection
 ■ Enable Automatic Feature Detection. This option can be 

used to enable or disable automatic face detection. When en-
abled, SA will search adjacent faces on the CAD model and in-
clude them in the selection. This allows all 4 faces defining the 
walls of a hole to be selected with a single click, as an example. 

GD&T Evaluations verses RMS fits

The GD&T Analysis within SA follows the ASME standard evaluation. 
Therefore you will find that the results of a geometry fit or relation-
ship fit which are based on an RMS fit will not return exactly the same 
results. Take the example of a flatness check. When we build a geom-
etry relationship fit to the points we report the flatness. This value 
is based on comparing the point deviations to the best fit plane. In 
GD&T, however, flatness is evaluated as the separation between two 
parallel planes bounding the data. These planes are then free to ro-
tate in space to find the closest position they can reach to each other 
while still containing all the measured points between them. This 
process will almost always return a slightly better result than an RMS 
fit because of this additional degree of freedom. But it is also much 
more influenced by outliers in the data.

Decimal Precision

It is important to understand that the displayed decimal precision im-
ported with an annotation or set in the Users Options does not limit 
the underlying GD&T analysis. So, for example, if you have the deci-
mal precision set to 2 digits and have a flatness check with a tolerance 
of 0.02, the check can still fail if the measured deviation is 0.02001. 
This makes sense considering that the standard is based upon hard 



610

SPATIALANALYZER USER MANUAL

limits. The measurement is compared directly to the specified toler-
ance value and any deviation outside the limit signifies nonconfor-
mance to those limits. If you can’t get the pin in the hole then it fails.

Evaluation Zone/Length

The evaluation zone/length is set by the extents of the measurements 
associated with the feature check. Therefore, if you have a tolerance 
specification for a particular length part but can only measure a por-
tion of that part. It may be necessary to adjust the tolerance to ac-
count for the shortened evaluation zone.

Cylinder Evaluation & Coverage

Cylinders can be evaluated either in 2D or 3D depending on the set-
tings defined in the users Datum or Feature Check properties dialog.  
By default the number of points will be used to determine this meth-
od. For more details on these settings see “Cylinder Evaluation Meth-
ods.” on page 598.

When measuring cylindrical features and using the “full eval” mode, it 
is important to provide enough measurements so that the intended 
cylinder orientation can be determined from the measurements.

Consider the following cylinder with 8 measurements in Figure 26-24. 
It is possible to interpret the cylinder in 3 different basic orientations.

Figure 26-24. Possible cylinder 
fit orientations with only eight points 
defining a cylinder location.

To avoid this problem, cover the cylinder more completely with mea-
surements so that it is clear which of those 3 orientations is intended. 
One question which may arise is why the nominal feature is not suf-
ficient to lock in the correct orientation. When SpatialAnalyzer evalu-
ates a GD&T check it first performs an initial alignment on the data 
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representing the datums. This initial fit is done without knowledge of 
the nominal orientation because data is often far out of alignment ini-
tially as is common with portable metrology. Once a fit is performed 
the fit cylinder is compared with the nominal cylinder. Using the 
above as an example, if the wrong cylinder fit result was chosen (not 
having the nominal information) then the alignment would attempt 
to rotate the data incorrectly. Providing more complete measurement 
coverage avoids this problem.

Slots and Open Slots

SA Supports the use of rounded slots, square slots, and open slots (or 
mid-planes) in the evaluation process. In order to use slots to define 
datums and checks they need to be manually identified in the anno-
tation in order to be recognized in the evaluation process. 

Figure 26-25. Slot Designation

Marking a check as a slot triggers SA to search the surrounding sur-
face faces for a representative slot feature. Only a single associated 
CAD face is necessary and additional face selections will only slow the 
search process.  

Standard Slots (Round/Square)
Like other holes, slots can be evaluated in position. Material Modifiers 
can be applied in both length and width. To use a modifier on a slot, a 
Width check must always be added.  To verify the position of a slot in 
both Length and Width with modifiers, add both supporting checks 
and mark the Position check with using a Cylindrical Tolerance Zone 
in the annotation properties. The MMC (or other) condition will be 
defined by the most restrictive of the two checks. distance Between 
checks are not applicable to slots. 

Slots are 3D entities. For this reason it maybe useful to either measure 
a slot with a pin nest or some alternative depth control.  

Open Slots & Width Datums
In addition to a closed slot features, SA can also evaluate the position 
of a mid-planes or open slots. These open slots must be designated 
as a slot in the annotation properties using the is Slot check box. In 
addition, their is a requirement that 2 and only 2 parallel planar fea-
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tures are associated with the check. When an open slot is defined you 
will see the midplane displayed graphically when the check is high-
lighted (Figure 26-26).  

Figure 26-26. Mid Plane Evalua-
tion of a slot.

In  order to evaluate a slot with a material modifier a Width check 
must also be added to the same features. Width checks are a special 
case and are not the same as a Distance Between check. In order to 
define a Width check through the SA Toolkit a new right-click option 
has been added to the Distance Between check button. 

Figure 26-27. Right-click Option 
to add a Width Check

Point Cloud Thinning Controls

Point Cloud measurement adds an additional level of complexity to 
GD&T evaluations. A desire to use all available data often needs to 
be weighted against obtaining a quick and accurate solution. SA pro-
vides a selection of cloud thinning and subsampling options to help 
with this task.  The global Feature Check Cloud Thinning control is available 
on the Analysis Tab in the User Options (Figure 26-28). 
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A description of the individual settings is available in the chapter on 
point clouds (see “Cloud Filtering and Sub-Sampling” on page 277). 

Figure 26-28. Cloud Thinning 
Controls

In many cases a single check may need to be sub-sampled to a differ-
ent extent than other checks in the job. An example of this would be 
a planar region with multiple holes. The plane could be over sampled 
extensively in capturing data to define the hole positions. Equalizing 
the data coverage in all the features would in this case speed the pro-
cessing time. 

The individual check thinning controls are in the right-click Feature 
Check Properties (see Figure 26-13). The total number of points in-
cluded in the check and the number used are both reported as part 
of the evaluation results in the tree for clarity: 

Figure 26-29. Cloud thinning and 
point usage reported in the tree.
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 The Details Table of the report will only report the points used for the 
evaluation (see “Details Table” on page 640). 

Feature Check Specifics
This section has been offered to help explain SA operations, as a sup-
plement to directly using the standard, not as a replacement for it. The 
hope is that it will provide some insights into how checks of different 
types are evaluated in SA. A simplified summary of the intended use 
of each check is provided as well as an example evaluation process. 
For additional information or clarification always check with the stan-
dard and if there are discrepancies contact support@kinematics.com.   

Cross-Section Checks
A number of Feature Checks require measurements to be made in 
cross sections to be correctly evaluated. These checks are marked 
with an asterisk symbol (*) and include the following checks:

 ■ Circularity

 ■ Straightness

 ■ Profile of a Line

 ■ Circular Runout

 ■ Concentricity

Keep in mind that if measurements are not within  a 1mm band within 
cross sections they will be considered part of a second cross section. 
This can have a signification impact on the evaluation process (see 
“Feature Check Specifics” on page 614).

Form Checks

Circularity*
Circularity is evaluated in cross sections along the normal vector of 
the nominal feature (circle or cylinder). The tolerance establishes the 
maximum distance allowable between two concentric circles con-
taining the measurements of that part at the cross section location 
(Figure 26-30).

evaluation process within Sa:

1. Cross sections are established along the normal vector of the 
nominal feature and the data is divided into groups based 
upon their position along this vector.

2. A plane is fit to the first point in each cross section group (us-
ing the actual feature direction vector) and then the points 
are projected onto that plane.

Warning:  This section 
has been added to sup-
plement and clarify inter-

pretation of the standard only. If 
there are discrepencies contact 
NRK Support. 
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3. The minimum size bounding circles are then established on 
the plane containing the data while holding a common cen-
ter point and the distance between these is used to evaluate 
the cross section.

4. The check reports the worst of the cross section results.

Figure 26-30. Circularity

Cylindricity
Cylindricity checks ensure that all the specified points are the same 
distance from a common axis. The tolerance establishes the maxi-
mum allowable distance between two concentric cylinders contain-
ing the measurements of that part (Figure 26-31).

evaluation process within Sa:

1. Two coaxial cylinders are built bounding the extents of the 
data.

2. The cylinders are allowed to freely rotate to establish the min-
imum distance between them while still containing the data.

3. The final distance between these cylinders is compared to the 
tolerance for evaluation. 
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Figure 26-31. Cylindricity

Straightness*
Straightness is evaluated in cross sections. It ensure that all the mea-
sured points are within a specified proximity to a straight line.  This 
can be evaluated for lines directly or cylinders (axis), which define a 
zone where the median line must lie (Figure 26-32). 

evaluation process within Sa:

1. The direction vector is established for the measured feature 
(line or cylinder)

2. Cross sections are established along this direction vector and 
the data is divided into groups based upon their position 
along this vector.

3. A plane is fit to the first point in each cross section group (us-
ing the actual feature direction vector) and then the points 
are projected onto that plane

4. Median points are established for each cross section, either 
directly (for lines) or by fitting circles to the data (cylinder)

5. These median points are then compared to the nominal axis 
line and the check reports the worst of the cross section re-
sults.

Per Unit Length Straightness
Straightness can also be evaluated on a per unit length basis. This set-
ting ensures that the specified straitness is held within an acceptable 
distance but allows a gradual curve to occur on a large part. When 
selected the straightness tolerance will be evaluated only within the 
specified length and then a new segment will be evaluated in se-
quence down the part.  The per Unit Length Step Over percentage set-
ting controls how much overlap is used in adjacent evaluations. 



617

CHAPTER 26 ■ GD&T

Figure 26-32. Straightness

Straightness can also be evaluated using a per unit length setting. 
Typically all the measurements are used within a common tolerance, 
but with this setting enabled a tolerance can be applied within a 
specified length. To enable Per Unit Length open the annotation prop-
erties and Check the option. You will need to specify the Per Unit Length 
Distance,  which defines the length used for the evaluation and the Per 
Unit Length Step Over Percent which determines the extent of overlap in 
the analysis process. 

Flatness
Flatness checks ensure that all the specified points lie approximately 
on a common plane. The tolerance establishes the maximum allow-
able distance between two parallel planes bounding the associated 
measurements of the part (Figure 26-33).

1. Two parallel planes are built bounding the extents of the data.

2. These planes are allowed to freely rotate to establish the mini-
mum distance between them while still containing the data 
and the resulting distance is compared to the tolerance.

Figure 26-33. Flatness

Per Unit Area Flatness
Flatness can also be evaluated on a per unit area basis. This setting 
ensures that the specified flatness is held within an acceptable dis-
tance but allows a gradual curve to occur on a large part. To enable 
this mode,  check the per Unit area option under the tolerance and 
additional options will appear (Figure 26-34). 
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Figure 26-34. Per Unit Area Flat-
ness Tolerance Settings.

A separate length and width area designation can be used to apply 
the tolerance in a larger or smaller area along the two directions. The 
length direction is defined using the Z-axis of the selected SA Object. 

Figure 26-35. The Z-axis of the 
selected SA object is used to define 
the Length direction in a per unit area 
flatness check.

In the above example is applied to a 5 inch area along the length and 
a 2 inch area along the width assuming the working frame was se-
lected as the direction object. 

Orientation Checks

Angularity, Perpendicularity and Parallelism
Orientation checks require at least a single datum for evaluation. The 
measurements of the datum are first aligned to the datum features 
and then the measurements of the check feature are evaluated rela-
tive to that alignment.

Perpendicularity and Parallelism are special cases of an angularity 
check where the angle is either 90 or 0 degrees respectively and are 
therefore evaluated in the same way. Angularity checks ensure that 
all the specified points lie at approximately a specified angle relative 
to the datum features. The tolerance zone can be defined as planar 
region or as the deviation between two axes. 

evaluation process within Sa:

 ■ Planar Evaluation. The minimum distance between two paral-
lel planes at the specified angle containing the measurements 
of the feature (Figure 26-36).
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Figure 26-36. Planar Evaluation

 ■ Axial Evaluation. The minimum diameter of a cylindrical zone 
at the specified angle containing the measurements of the fea-
ture (Figure 26-37).

Figure 26-37. Axial Evaluation

Location Checks

Location checks are the heart of GD&T analysis and provide the great-
est flexibility and most complexity. They can be evaluated excluding 
datums entirely or by including as many datums as are needed to ful-
ly constrain the model. Only a simple example of how the evaluation 
process could be performed is presented.
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Profile of a Surface
Profile checks are quite versatile. They provide the ability to evaluate 
size, form, orientation and location and the tolerance boundary can 
either be symmetrical or asymmetrical as needed, using any number 
of datum references. Measurements are fit to the features to minimize 
the point deviations as allowed by the any degrees of freedom not 
locked down by the datums and the max deviations are then com-
pared to the tolerance boundary to evaluate the check (Figure 26-38).

evaluation process within Sa:

1. Feature measurements are allowed to rotate and shift, de-
pending on the datum constraints to minimize the point de-
viations relative to the specified surface. 

2. Evaluation is made based on the greatest point deviation  
with respect to nominal surface and tolerance boundardy.

Reporting

Surface profile, by default, establishes a tolerance zone which is 
equally disposed inside and outside the surface.  The check is a mea-
surement of the thickness required to enclose the data while still be-
ing equally disposed.  Which is why its double the largest error.

Measured Deviation is calculated by first finding the point furthest away 
from the boundary wall (the boundary being the extents of of the 
tolerance zone which could be asymetric with respect to the surface), 
then computing how far to the boundary as a positive number [A]. 

When a check passes, the Measured Deviation is reported as: 

[Total Tolerance Value]-[A*2].

When a check Fails, the Measured Deviation is reported as:

[Total Tolerance Value]+[A*2].

Distance Out of Tolerace is reported as: [A*2]

Figure 26-38. Profile of a Surface

In order to specify an asymmetric tolerance zone for a profile check, 
open the annotation properties and edit the two tolerance fields. 
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 ■ Tolerance. Defines the total tolerance band used by the check 
from the inner extent to the outer. 

 ■ OuterTolerance. Defines the location of the outer tolerance 
on the positive or outer surface. This value controls the relative 
placement of the full tolerance with respect to the surface. For 
a symmetric tolerance this should be exactly 1/2 the tolerance 
value, and for a tolerance exclusively on the outside of the sur-
face this value should equal the total tolerance. 

Composite Surface Profile
Composite Surface Profile Checks provide a means to evaluate the 
overall position of a set of features and combine that with a tighter 
evaluation of the relative position of those features with respect to a 
less restricted set of datum constraints all within a single check.   

evaluation process within Sa:

What makes Composite Surface Profile checks unique from two 
separate position checks is that composite checks provide a great-
er degree of freedom in the lower segment check than would be 
allowed through a secondary check. Take the following check for 
example(Figure 26-39):

 

Figure 26-39. Example Compos-
ite Surface Profile

1. The part is first fit to Datum A, B, and C, which fully locks down 
all degrees of rotation and translation and the upper segment 
of the control frame is evaluated. 

2. The pattern is then completely released to translate freely and 
rotate within the degrees of freedom not locked down by da-
tum A to fit the nominal pattern. They key here is that transla-
tion is completely unconstrained.

This is very different from two independent checks. In this case the 
upper segment is evaluated, and then in the second check is evalu-
ated separately. In this case the difference is slight but the part is lim-
ited in its ability to move toward and away from datum A, where in a 
composite check that would not be the case (Figure 26-40). 

 

Figure 26-40. Example Com-
pound Check
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The difference is more apparent with two datums in the lower seg-
ment. The part is both constrained in position to datum A and B. This 
restriction in translation and only allows the part to only slide in a 
straight line perpendicular to the datums to fit the data, while a com-
posite check would only hold rotation for the lower tier evaluation.  

Profile of a Line
Line profile is much like surface profile except that it is a 2D check. 
The tolerance zone is normal to the surface profile of the feature at 
a cross-section. This can be a useful if you want to evaluate a single 
portion of a surface at a location or a set of parallel location evaluated 
in cross sections (Figure 26-41). 

 ■ You must associate a direction object (SA object) with the line 
profile annotation. This direction object defines the direction 
along which the data is divided into cross-sections for analysis.

evaluation process within Sa:

1. The direction vector for analysis is established from the direc-
tion object chosen. 

2. Cross sections are established along this direction vector and 
the data is divided into groups.

3. A plane is fit to the first point in each cross section group (us-
ing the actual feature direction vector) and then the points 
are projected onto that plane.

4. Measurements are allowed to rotate based on the datum con-
straints to minimize the point deviations. 

5. The extent of the max point deviation doubled to describe 
the fit deviation zone and compared to the tolerance to eval-
uate the check. 

Figure 26-41. Profile of a Line
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Position (True Position)
Position checks provide the ability to evaluate size, orientation and 
location. The number of datums specified, the number of measure-
ments and the type of feature determines the way in which the 
evaluation is conducted. Here we will just consider a basic hole posi-
tion check. For cylinder evaluation options see “Datums and Feature 
Checks” on page 594.

 ■ The degrees of freedom controlled by the datums determine 
if it checks a point location or an axis. In evaluating the True 
Position of a feature relative to a single datum axis you are es-
sentially checking the coaxiality of that feature relative to that 
datum.

 ■ Note that when specifying a MMC or LMC position tolerance a 
second annotation must also be included on the same feature 
to specify the nominal dimension.  If you do not an error “No 
size tolerances defined for feature” will be seen. This second an-
notation will be automatically recognized and included in the 
evaluation (Figure 26-42).

evaluation process within Sa:

1. The feature measurements are used to establish the center 
point or axis of the measured feature. 

2. The maximum point or axial deviation is minimized after 
aligning to the datums and using any  degrees of freedom 
not locked down by the datums.

3. The maximum deviation is doubled to define the measured 
deviation, any bonus tolerances are applied, and compared to 
the tolerance zone for evaluation.

Reporting

Measured Deviation is calculated by first finding the largets center or axis 
point deviation from the nominal feature and doubling it to define 
the tolerance band required for the part to pass. 

Distance Out of Tolerace is reported as the radial distance from the maxi-
mum deviation to the tolerance boundary. Or the distance a drill bit 
would have to move for the part to pass when checking the place-
ment of a hole. 
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Figure 26-42. Basic Position 
Check

Tolerance Definitions Zones

Several Tolerance Zones options can be set for position evaluations 
on different features(Figure 26-43). 

Figure 26-43. Tolerance Zone 
Options for a Position Annotation

 ■ None. Which is a default setting that will apply either a cylin-
drical, planar or spherical tolerance zone based on the selected 
geometry type. 

 ■ Cylindrical. Tolerance zone is a cylinder sized by the tolerance 
value centered around the nominal cylinder axis.  The axis of 
the actual cylinder must fall inside this tolerance zone.

 ■ Planar. Two parallel planes spaced apart by the tolerance val-
ue centered on the nominal cylinder axis are used to define the 
tolerance zone. This allows the actual to slide back and forth 
between the planes. Note that this setting requires a fully con-
strained condition or it will rotate to a perfect result.

 ■ Spherical. Currently only supported for spheres. 

The geometry type has a direct influence on how a position check is 

Note:  “Planar” Tolerance 
Zones require a reference 

plane selection. Adding a position 
check using “None” as the toler-
ance zone will use the selected 
Planar face by default without ad-
ditional selection.
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evaluated. Cylinders can be evaluated as lines, circles, or full cylinders 
based on a user select (see “Cylinder Evaluation Methods.” on page 
598). The extent of the evaluation is established by the extent of the 
measurements unless otherwise specified.

The offsets on points used in a position check on a line are ignored. 
The expectation as that measurements are on the axis.

Composite True Position
Composite Position Checks provide a means to evaluate the position 
of a pattern of features and combine that with a tighter evaluation 
of the position of each feature relative to each other feature within 
a single check. So for example, this allows you to check if a bolt hole 
pattern matches the correct location on the part at a lower tolerance 
while also verifying that the pattern is correct at a higher tolerance.

evaluation process within Sa:

1. The upper tier is evaluated following the position check guid-
lines above. 

2. The feature is then released to translate freely and rotate 
within the degrees of freedom not locked down by datums in 
the second tier and evaluated again. 

3. The check is passed only if both evaluations pass.  

Figure 26-44. Composite True 
Position Check

Circular Runout*
Circular runout is a cross-section check that is used to evaluate fea-
tures relative to a datum axis. With surfaces constructed around a da-
tum axis it establishes a width variation normal to that surface evalu-
ating both circularity and coaxiality around the datum axis.

evaluation process within Sa:

1. The actual feature type is first established (circle or cylinder) 
based on the nominal type (feature to which the annotation 
is attached), and this feature type is fit to the entire data set to 
establish the direction vector
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2. Cross sections are established along this direction vector and 
the data is divided into groups based upon their position 
along this vector.

3. Measurements are allowed to rotate based on the datum con-
straints to minimize the point deviations for all cross sections. 

4. The extent of the max point deviation relative to the surface 
normal is doubled to describe the fit deviation zone for each 
cross-section. 

5. The check returns the worst of the cross section results.

Total Runout
Total runout is used to evaluate surfaces constructed around a datum 
axis it establishes a width variation normal to that surface. The evalu-
ation zone is continuous providing a cumulative evaluation of devia-
tions in circularity, straightness, coaxiality, taper, and profile relative 
to this axis.  

evaluation process within Sa:

1. Measurements of the datum are fit to the datum feature to 
establish a nominal axis.

2. These features are translated along the nominal axis as al-
lowed by any additional datum constraints to minimize the 
maximum and minimum point deviations. 

3. The extent of the maximum point deviation relative to the 
surface normal is then doubled to define the diametric mea-
sured deviation and compared to the tolerance zone to report 
the result. 

Concentricity*
Concentricity requires a single datum to be defined. The measure-
ments of the datum are first aligned to this datum and then the mea-
surements of the check feature are evaluated relative to this datum 
by establishing a median point for each cross section and comparing 
its position relative to the axis of the datum feature.

evaluation process within Sa:

1. The measurements of the datum are aligned to the datum 
feature which orients the nominal feature and the measure-
ments of it. 

2. The actual feature type is established (circle or cylinder) based 
on the nominal type (feature to which the annotation is at-
tached) and fit to the entire data set to establish the direction 
vector for this measured feature.

3. Cross sections are established along this direction vector and 
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the data is divided into groups based upon the distance of 
each point along this direction vector and the cross section 
width definition.

4. The data in each cross section is evaluated independently. A 
circle is fit to the data in each group using the datum direction 
axis and the center or “medial” point established. 

5. The distance of each median point from the datum axis is 
used for the evaluation. 

Figure 26-45. Evaluating 
Concentricity

GD&T Workflow
GD&T inspection within SA is broken down into two distinct process-
es:

 ■ Design. Which is the upfront process of importing or construc-
tion annotations, defining tolerances and setting up datums 
and feature checks to scripting an inspection process.

 ■ Inspection. Which is basically the process of associating the 
correct points with the correct datums and feature checks for 
analysis. Reporting is then automatic as part of this inspect.  

SA provides 3 levels of inspection design:

1. Guided Inspection. Which is a fully featured option for laying out 
guide points on features, showing where to measure, control-
ling the view, and even instrument tooling and measurement 
profile.  

2. Inspection Bar Trapping and Direct Association. In addition to GR-Fea-
tures GD&T Datums and Feature Checks are included in the 
Inspection bar which can be used to quickly script the inspec-
tion sequence.

3. Feature Inspection Auto Filter. SA provides an intelligent proximity 
filter tool that can be used both with cloud data and points 
(with offsets) that will search the data and associate the cor-
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rect measurements with the selected datums and feature 
checks.

Guided Inspection

SA’s Guided Inspection provides an option for a GD&T inspection de-
signer to layout exactly how and where to measure a part. It also pro-
vides a rehearse function that allows the designer to walk through 
the script in simulation to check the workflow. Once complete, the 
resulting script can then graphically walk a measurement technician, 
with little to no metrology knowledge, through the measurement 
process.  This guided inspection is broken into 3 pieces: Design, Re-
hearse and Inspect.

Building a Guided Inspection - Design
To build a guided GD&T Inspection an inspection designer should be-
gin with a fully annotated model. This annotated model can either be 
imported from a CAD package or built within SA. SA objects should 
be converted to bounded surfaces before beginning the inspection 
design to allow nominal guild points to be placed on the nominal 
features. The design process should be conducted as follows:

1. Begin by right-clicking on the annotations in the tree and 
building feature checks. The majority of the inspection design 
including view orientations and nominal points are saved 
with the datums and feature checks.

2. Right-clicking in the tree and select Inspection > Design. There 
are three location where you can find this option. You can 
right-click on the collection containing the GD&T datums and 
feature checks to work through the design of all datum and 
feature checks at once, or you select the datums or feature 
checks only if you only want to work on designing the portion 
of the GD&T inspection.

3. Once started the GD&T inspection designer walks through 
designing the inspection for each GD&T feature in order just 
as a user would measure them. For each feature the following 
designations can be made:

 ■ Save View for Inspection. If checked the current view will be 
saved with the datum or feature check and the view will be set 
to this view when the Inspection > Rehearse or Inspection > Inspect 
routines are run.

 ■ Create Nominal Points. Nominal point measurement loca-
tions can be layed out on the model by graphically clicking on 
the model in the graphic view. The click selection order will be 
duplicated in the guided inspection. These point locations are 
saved as a point group and are saved with the Group Name and 
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Point Name specified in the dialog. If you wish to remove the 
associated point locations you can use the “Clear NomPts” but-
ton at the bottom of the dialog.

 ■ Measurement Profile Name. The measurement profile for the 
instrument being used for the inspection can be set through 
the inspection designer as well. When the inspector is prompt-
ed to measure this feature the measurement profile specified 
here will be sent to the active instrument.

 ■ Enable Inspection Automatic Measurement. When enabled 
this option will automatically begin the specified measure-
ment mode on the active instrument.

 ■ Inspection Design - Item # of #. This set of toggle buttons 
provides a convenient way of progression the included inspec-
tion features. The total number of features included in the item 
list depend on the selection method, whether you selected to 
design only the datums, feature checks, or included the entire 
inspection in the design by selecting Inspection > Design for the 
entire collection. The settings for each inspection feature are 
saved automatically when you exit the current feature.

Guided Inspection - Rehearse
Once a guided GD&T inspection has been built the designer can then 
use the Inspection>Rehearse routine to simulate the measurement 
process. This option allows the designer to walk through the inspec-
tion process in simulation using mouse clicks for measurements to 
simulate the complete GD&T inspection routine built through the 
Inspection>Design process.

1. To begin the inspection right-click on either the collection, the 
datums or the feature check categories and select Inspection 
> Rehearse depending on the number of features you wish to 
include in the rehearsal. When you do so the following dialog 
will be displayed with the following options (Figure 26-46):

Figure 26-46. Inspection > 
Rehearse dialog.
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 ■ Group Name/Point Name. Specifies the group and target 
names for the click points (simulated measurements) to be 
saved.

 ■ Random Noise Magnitude. This entry allows you to add ran-
dom noise to the data measurements to simulate a more realis-
tic result. The recorded point location will be randomly gener-
ated within the specified radius of the point click point on the 
surface.

 ■ Skip Measured Features. When checked this option allows 
the feature progression buttons to skip features that already 
have measurements associated and progress to features that 
do not. This is helpful when all but a few skipped features have 
been measured and you want to automatically progress to 
those particular features.

 ■ Number of Nominal Points. These progress buttons provide 
the number of design measurements expected for the features 
and allows the user to skip through the measurement points 
to record measurements for only the points desired. It also al-
lows you to backtrack and add additional measurements at a 
particular guide location.

 ■ Inspection Design - Item # of #. This set of toggle buttons 
provides a convenient way of progression the included inspec-
tion features. The total number of features included in the item 
list depend on the selection method, whether you selected to 
design only the datums, feature checks, or included the entire 
inspection in the design by selection Inspection>Design for 
the entire collection. The settings for each inspection feature 
are saved automatically when you exit the current feature.

2. Simply click on the surface where the bulls eyes is displayed 
to simulate a measurement of that location. The bulls eyes will 
automatically increment through the saved measurement lo-
cations. When all measurements are taken for a feature the 
dialog will automatically increment to the next feature in the 
list just as the inspection was designed.

Guided Inspection - Inspect
Once a guided GD&T inspection has been built through the 
Inspection>Design process, a measurement technician can then 
right-click on the collection and select Inspection>Inspect to conduct 
the inspection of a part. The guided inspection will walk the operator 
through the inspection laid out by the designer and allow them to 
measure the part as specified. As measurements are taken they will 
be associated with the appropriate feature is the tree and an analysis 
will be carried out automatically. For an operator it can be as easy as 

Tip:  Be sure to delete any  
measurements created in the 

Rehearse process before begin-
ning the Inspect process.
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measuring the point on the part designated by the bulls-eyes laid out 
on the nominal CAD part. The process flow is as follows:

1. To begin the inspection right-click on either the collection, 
the datums or the feature check categories and select Inspec-
tion> Inspect depending on the number of features you wish 
to include in the inspection. When you do so the inspection 
will begin and the following will occur:  the view will be set 
to the saved view for the feature; the measurement profile 
will be set on the instrument specified; or the first inspection 
point will be displayed on the nominal part.

2. A dialog box (Figure 26-47) will be displayed with the follow-
ing options and active trapping will begin for that feature:

Figure 26-47. Inspection > 
Inspect dialog.

 ■ Skip Measured Features. When checked, this option allows 
the feature progression buttons to skip features that already 
have measurements associated and progress to features that 
do not. This is helpful when all but a few skipped features have 
been measured and you want to automatically progress to 
those particular features.

 ■ Highlight Cylinder Features. This check box triggers an ad-
ditional cylinder to be graphically drawn on the CAD model to 
clearly depict which cylindrical surface to measure in addition 
to highlighting the specific CAD faces.

 ■ # of # Nominal Points. These progress buttons are displayed 
only when saved measurement locations are included in the 
inspection. They provide the number of design measurements 
expected for the features and allows the user to skip through 
the measurement points to record measurements for only the 
points desired. It also allows you to backtrack and add addi-
tional measurements at a particular guide location.

 ■ Inspecting # of # Features. This set of toggle buttons provides 
a convenient way of progression the included inspection fea-
tures. The total number of features included in the item list de-
pend on the selection method, whether you selected to design 
only the datums, feature checks, or included the entire inspec-
tion in the design by selection inspection>design for the entire 
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collection. The settings for each inspection feature are saved 
automatically when you exit the current feature.

3. Simply measure the actual part where indicated by the bulls 
eye is displayed on the nominal part within SA. The bulls eyes 
will automatically increment through the saved measure-
ment locations. When no nominal measurement locations 
are save with the feature it is assumed that the measurement 
technician will measure the appropriate number of on the 
designated surfaces.

4. When all measurements are taken for a feature the dialog will 
automatically increment to the next feature in the list just as 
the inspection was designed. If nominal measurement loca-
tions were not included in the inspection design then the fea-
ture should be incremented manually when sufficient mea-
surements are take.

Inspection Bar Trapping and Direct Association

In addition to classical Design and Inspection routines intended to 
separate the GD&T inspection design phase from the inspection or 
operation phase, SA provides a number of tools available to more ad-
vanced GD&T users performing the inspection of a part.

Trapping Measurements from a Live Instrument
Measurements can be captured or “Trapped” directly from a live in-
strument while measuring without either building or utilizing the 
guided inspection process. For an advanced user, directly measuring 
points on a part and having those measurements automatically asso-
ciated to a particular feature can be the fast way to conduct an analy-
sis. Trapping can be started for any datum or feature check in either 
of two ways:

Trapping through the Instrument

1. Connect to your instrument.

2. Right-click on the particular Datum or Feature Check you wish 
to trap.

3. When finished measuring, right-click on the feature a second 
time and select Stop Trapping Measurements.

Trapping through the Inspection Tab in the Toolkit

1. Connect to your instrument.

2. Double-click on the particular Datum or Feature Check you 
wish to trap measurements to in the Inspection tab. 

3. When finished measuring, press the stop button (INSERT 
ICON) or press the progress button (INSERT ICON) to move to 
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the next or previous item in the Inspection tab list. 

Either of these operations will begin trapping to the feature. If you 
have more than one instrument you will be prompted to choose 
which instrument you wish to trap measurements from. While trap-
ping is active the feature will become highlighted in both the Inspec-
tion tab and in the tree as well as being displayed with the point count 
in the Heads Up Display and will remain highlighted until trapping is 
stopped.

Directly Associating Data with a Feature
As soon as Annotations are available, Feature Checks and Datums can 
be built and data can be associated with those features. A user could 
potentially measure all the features on the part independently of the 
GD&T analysis process and then come back after the fact and associ-
ate the appropriate measurements with the corresponding Datums 
and Feature Checks. To associate data with a datum or a feature check 
just right-click on the feature in the tree and select Associate Points or 
Associate Clouds. This will clear the list of currently associated points 
and or point clouds associated with the feature, if any are currently 
associated, and associate the selected points or clouds with the fea-
ture. Once features have associated data they can be evaluated all at 
once by right-clicking on the feature checks and selecting Evaluate 
all Checks. 

Show Only Active Feature Check or Datum

A right-click option exists in the Feature Checks and Datums cate-
gory’s to enable Show Only active Feature check or Show Only active 
datum. During a measurement process this option can be quite help-
ful in that it limits the displayed annotations to only those features 
directly linked to the feature in question (Figure 26-48). 



634

SPATIALANALYZER USER MANUAL

Figure 26-48. Show Only Active 
Feature Check Option Enabled

Remeasure Failed Checks Only

Many users asked for an easy way to go back and remeasure only the 
checks that failed on a prior inspection.  This option, available through 
the Feature Checks category right-click menu provides the ability to do 
just that.  Selecting this option does the following:

1. Users the “Lock Out Trapping” option to hide passing feature 
checks from the Inspection panel. 

2. Clears the data from the existing feature checks

3. Starts actively trapping to the first check in the list. 

Feature Inspection Auto Filter

If you have measured your part independently of any type of Guided 
Inspection or Measurement Trapping but you have pre-aligned to a 
CAD model, it is still quite simple to associte points to the necessary 
checks. To do so, use the autofilter function to assign points to the 
correct checks. The steps in this process are as follows:

1. Double check that datums feature checks are built from your 
annotations and ready to recieve points. If not right-click on 
the annotation category and select Make Feature Checks. 

2. Navigate to GD&T > Feature Inspection Auto Filter All Checks.  Select 
individual points, point groups, or even point clouds, and 
choose a proximity threshold used to include points with 
particular checks. Then simply press OK. For more details (see 
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“Auto Filter to Faces” on page 253). 

If you need to pick up additional point measurement taken along the 
axis of a cylinders, these can be obtained with a second run using the 
aditional true position point detection check box (Figure 26-49).  Also 
if you want to populate only a selection of checks you can used the 
function GD&T > Feature Inspection Auto Filter Selected Checks. This function 
works the same only it will ask you to choose which checks to con-
sider.  

3. Once this is done then navigate to GD&T > Evaluate all Feature 
Checks to complete the GD&T analysis. 

This is a particularly useful approach to GD&T analysis when using a 
scanner. If you initially locate a scanner and then fully scan the part 
you are evaluating you can then filter the scan data to the CAD Faces 
associate the individual scans to the appropriate Features and in two 
clicks of a mouse button go from a single unfiltered cloud to a com-
pleted GD&T analysis ready for reporting.

Additional True Position Point Detection. 
The GD&T Feature Inspection Auto Filter works great for most appli-
cations except for True Position Checks using alternate cylinder eval-
uation modes. Additional Hole Measurement Modes may include:

 ■ Measure a single point in the hole (axis)

 ■ Measure 2 points on the axis

 ■ Place a dowel pin in the hole and measure it, indirectly measur-
ing the hole (either as a circle or a scan)

 ■ Measure the hole scanning with a pin nest 

This check box was added specifically to fill this need. This check box 
option converts the operation from a surface filter to a comparison to 
cylinders defined by those surfaces. 
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Figure 26-49. True Position Point 
Detection

 

Points are therefore compared to both the axis of the cylinder de-
fining the pin or hole and the surface of that cylinder such that it is 
no longer bounded by the ends of the hole but can extend upward 
along its axis. 

Figure 26-50. Evaluated feature 
checks.
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GD&T Reporting
The report bar will provides the results of a GD&T Check and provides 
a preview of the resulting table that would be added to a report using 
the current reporting settings. Viewing a feature check in the report 
bar or adding them directly to a report also triggers the evaluation 
process, updating the results if needed.   

By default a minimum amount of information is presented showing 
the Pass/Fail result as shown in Figure 26-51. 

Figure 26-51. Basic Check Result

However, much more detailed information is available should it be 
needed by editing the Reporting Options for a check through the 
Right-click menu in the tree. These options include(Figure 26-52):

Reporting Options

Figure 26-52. Report Options

 

 ■ Graphical Summary. The default pass/fail information also in-
cluded in the graphic view with the annotation.

 ■ Include Title in Graphical Summary. Provides an option to 
include the check name along with the Graphical Summary 
(Figure 26-53).

Figure 26-53. Basic Check  Title  
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 ■ Datum and Tolerance Summary Table. Reports the essential 
datum fit results, tolerance and fit transform used as part of the 
check evaulation.

 ■ Feature Summary. This table provides additional details on 
the specific features evaluated in the check.  This includes spe-
cifics from the details table and bonus tolerance information. 

 ■ Position/Surface Deviation Vector Creation. With this option 
enabled a vector  group will be built or updated each time the 
check is evaluated or as specified. This vector group inherits 
the check tolerances and graphically depicts the check results.  

 ■ Details Table. This table provides a full list of the point names, 
positions and offsets used in the valuation as well as the solved 
feature details for both the nominal and actual features. 

 ■ Include Lower Tier Result Tables. This option provides the 
ability to generate a second additional report tables describing 
the results specific to the lower tier evaluation in a composite 
check. 

 ■ Default Settings. We provide the ability to set the desired lev-
el of detail for a particular check and apply those settings to 
other checks through these buttons. 

Reporting Frame
A specific reporting frame can be set for any check. This is done per 
check through the right-click menu in the tree. Setting a reporting 
frame will not impact the check results but it will control the X,Y, Z 
values reported in the report tables. As with the Reporting options 
this frame designation can then be assigned to any other number of  
checks at once. 

Datum and Tolerance Summary Table
The Summary Table provides the essential information necessary to 
understand the way a check was evaluated. This information includes 
three things: the evaluation result, the transform and the datum fit. 

 ■ Measured Deviation. Represents the true GD&T computed re-
sult used to determine if the check passes or fails. It represents 
the tolerance zone required for the part to pass and is com-
pared to the tolerance designated in the annotation.  

 ■ Distance Out of Tolerance. This value is shown to help clarify 
the extent of deviation. It represents the distance you would 
have to move for the check to pass (or the radial distance out). 

 ■ Fit Transform. This transform defines the deviation between 
the current point locations in the job and the final datum align-
ment used to evaluate the check relative to the World Frame 



639

CHAPTER 26 ■ GD&T

(see “GD&T Alignment” on page 601). 

 ■  Datums Fit Results. The Max, Average and Standard Devia-
tion for the residual deviations are reported for each datum.  

Feature Summary Table
The Feature Summary Table provides a slimmed down version of the 
feature information that has always been available in the Details Ta-
ble, without all the details on the individual points. These tables will 
display the following additional information (Figure 26-55): 

Figure 26-54. Feature Summary

 ■ Measured Deviation. The is the Measured Deviation for the 
single feature. If only one feature is being inspected then it will 
match the check results. The check results will report the re-
sults for the worst feature in the list if more than one exists. 
The feature summary allows you to identify the results for each 
feature independently. 

 ■ Distance Out of Tolerance.  The is the Distance Out of Toler-
ance for the single feature. If only one feature is being inspect-
ed then it will match the check results. The check results will 
report the results for the worst feature in the list if more than 
one exists. The feature summary allows you to identify the re-
sults for each feature independently. 

 ■ Nominal. This section includes the position and orientation 
and physical statistics of the nominal feature.

 ■ Actual. Displays the position and orientation and physical sta-
tistics of the measure feature. 

For true position Checks: 

Position checks provide even greater detail including the following:
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Figure 26-55. Feature Summary 
Table

 ■ Tolerance Zone. This is the tolerance zone used to evaluate 
the specific feature. This is equal to the check tolerance plus 
the bonus tolerance used if any. 

 ■ # Points. The number of points associated with the specific 
feature.

 ■ Diametric Deviation. If evaluating a cylindrical feature the 
nominal, actual and delta diameter will be displayed. 

 ■ Length Deviation. If evaluating a cylindrical feature the nomi-
nal, actual and delta length will be displayed. 

 ■ Solved Points. For a cylinder the solved points represent the 
measured cylinder extents used for the evaluation. 

 ■ Solved Point Deviations. This section displays the delta dis-
tance from the Actual features solved points to the Nominal 
feature or axis. These values can be displayed graphically by 
creating a vector group to represent the solved point devia-
tions using the selection in the Reporting Options (Figure 26-
56).

Figure 26-56. True Position 
Deviation Vectors

Details Table
In addition to the solved feature reporting the details table includes  
a specific list of each of the points included in the check and their 
properties. 

 ■ Actual Data. This list of points shows which points were used 
for the evaluation.  It includes name, location and offsets as 
well as deviation information for surface evaluations. 



641

CHAPTER 26 ■ GD&T

Trouble shooting a Failed Check

Figure 26-57. Failed Check 
Results Summary Table.

When a check fails, it will report two values for troubleshooting pur-
poses: the Measured deviation and distance Out of tolerance (see Figure 
26-57). The first number (0.0208) is the Measured deviation or the size 
of the tolerance zone required for the part to pass. The second num-
ber (0.0128), is the distance out of tolerance or the necessary expan-
sion of the tolerance zone in order for the part to pass. For the above 
profile check, the sum of the check tolerance plus the distance Out of 
tolerance will equal the Measured deviation (0.008+.0128=.0208). 

By convention, Position checks are reported differently. The distance 
out of tolerance is reported as the distance the drill would have to 
move for the check to pass, the sum of the check tolerance plus two 
times the distance out of tolerance will equal the Measured devia-
tion(0.008+2*0.0039=0.0158) (Figure 26-58). 

Figure 26-58. Reported values for 
a position check showing the Distance 
Out of Tolerance value.

If a check fails check the following: 

1. First consider to what extent the check failed. If its large, check 
the datum  alignment and transform. If the error is small check 
your fit residuals. 

2. Within the Summary table is a “Fit Transform” section. Check 
to see if the transform is close to zero. If not, check the datum 
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settings to verify that the alignment is set up correctly. Its of-
ten helpful to align to the evaluated position to see what’s 
causing the issue. For more information see “GD&T Align-
ment” on page 601. 

3. The Summary table also tells you how well you data fit the 
datums. By checking to see if there was a bad fit to one of 
the datums you will see if the datums are contributing signifi-
cantly to the error. 

Adding Checks to a Report

Any individual feature check results can easily be added to an SA Re-
port using the following methods: 

 ■ Individual Drag / Drop. Checks can be added individually 
through a drag and drop process like any other reportable ob-
ject in the tree. 

 ■ Collection Drag / Drop. All the checks in a collection can be 
added to a report at one time by selecting the Feature Checks 
category in the tree and draging it into a report. 

 ■ Composite Quick Report. Each individual check has a right-
click menu option to be either included or excluded from a 
Composite Quick Report. To generate a quick report for all the 
feature checks not excluded at once, right-click the Feature 
Check category and selecting Composite Quick Report > Generate. 
This report will also include a screen capture if a view is defined 
for the check. 

Figure 26-59. Composite Quick 
Report Example
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Inspection Summary Table
In addition to individual check reporting a custom summary table 
can  now be built including a selection of particular checks. To do 
so Right-click on the Feature Check category and select Create Inspec-
tion Summary Table. This option allows feature checks to be grouped as 
needed through an F2 selection prompt building a custom table with 
the selected checks. 

The Custom Report Tables are designed to display only the necessary 
information on a single line (Figure 26-60). 

Figure 26-60. Summary Table

When a custom table is added to a report it will become semi-static in 
that changes to the table will require a refresh of the report. 

how to Create easy Gd&t report tables - 

https://www.youtube.com/watch?v=Y4tid7CgZOi

Dynamic Table Construction
GD&T checks can also be included in custom table added directly 
with in an SA report. These custom table can be configured to refer-
ence a particular check’s attributes. This provides a means to build 
a fully customized table with results in any order desired. For more 
information (see “Tables” on page 662).
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Building New Reports
Reporting begins with the items you wish to report. By selecting 
something in the SA TreeBar a preview of the report table for that 
item will be displayed in the “Report Bar” on page 646.

Reports can be generated in SA in several different ways depending 
on the complexity of the report you need. The primary methods are:

 ■ Quick Reports. Quick reports are designed to be a one-click 
access point to the information you need for a collection, ob-
ject category or selection of objects. 

 ■ Direct SA Report Construction. The “SA Reports” are dynam-
ic, flexible and interactive parts of an SA job file. They allows a 
user to “drag and drop” items from the tree into the Report Edi-
tor where items can be arranged, formatted and edited to con-
vey the user intent. If values/information change in the tree, 
the SA report will reflect those changes automatically. 

 ■ SA Report Templates. Report templates can be built in ad-
vance and formatted with custom headers/footers, custom 
tables and entry fields and fully populate for a specific report-
ing task. They then updated as measurements are taken. More 
complexity can be add with interactive MP/SDK scripts  to or-

This chapter covers basic SA reporting capabilities, report generation 
and user option controls. It also covers graphical reporting tools such 
as Dimensions, Callouts and Charting. Additional details on configuring 
reporting of any particular object type or feature can be found in the 
related chapter on that object type. For example Relationships or GD&T 
each have their own reporting sections.

Reporting
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ganize a report in advanced and its content prior to generating 
a report. 

Reports can then be exported directly to PDF, an Excel sheet or added 
to a Word document as needed.   

Report Bar
The Report Bar serves two primary purposes: it can serve as a quick 
reference to view greater details relating to the selected object either 
in the tree or in the graphics; and it provides a preview of the report 
table available to be added to a report. 

Displaying the Report Bar

To display the Report Bar use the menu option Report>Report Bar Visible 
or press the Report bar button on the Reporting page of the ribbon 

menu 

On the Reporting page of the Users Options there are additional custom 
configuration controls:

 ■ Show Report Bar Controls. This check box controls the dis-
play of the Report Bar Toolbar.

 ■ Show Report Bar Grid. This check box provides the ability to 
hide the grid background display from the report back.  

Adding an Item
To add an item in the Report Bar simply select an item in the tree by 
single-clicking the item. Once selected it will display in the Report 
Bar. The currently selected item in the tree will always display in the 
current Report Bar Tab (Figure 27-1).

  

Figure 27-1. The item currently 
selected in the tree is displayed in the 
Report Bar.
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Building Reports Using the Report Bar

Report Bar is a great way to view object properties and values quickly 
and can be used to generate a simple report. Multiple items can be 
added to the Report Bar for continuous reviewing. Once finished, the 
Report Bar can be cleared or sent directly to an SA Report for final 
output.

Report Toolbar Controls
The report bar controls can be turned On/Off from the Reporting tab 
of the Users Options in the Report Bar Settings section. 

Figure 27-2. A vector group in the 
Report Bar.

 ■ Capture Current View. Creates a picture item in the tree of 
the current graphical view. The picture will display in the report 
bar under the current tab.

 ■ Clipboard Help. Displays help information regarding meth-
ods of copying Report Bar data to the clipboard.

 ■ Object Properties. Displays the current tab object proper-
ties.

 ■ Current Object Report Options. Displays the report op-
tions for the current tab.

 ■ Include Current Object in Composite Report. Sets the 
current object to be used in a Composite Report.

 ■ Quick Report. Generates a Quick Report from the current 
tab.

 ■ Generate Quick Report from Tab Order. Generates a 
Quick Report from all open Report Bar tabs in order from left to 
right. 

 ■ New Report Tab. Creates a new tab in the Report Bar.

 ■ Close All Tabs except Current. Closes all Report Bar tabs 
except for the currently selected tab.
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 ■ Refresh Report. Refreshes the Report Bar with current in-
formation.

Adding multiple items to the Report Bar requires multiple tabs. Add a 
new tab by using the icon. The new tab will appear with the cur-
rently selected tree item. Select the next item from the tree to view.

Removing an Item
To remove a Report Bar item, click the “X” icon in the bottom right-
hand corner of the Report Bar (Figure 27-3). All tabs, except the cur-
rent tab, can be cleared by using the icon.

Figure 27-3. Removing a Report 
Bar item.

Generating a Report
If needed, an SA Report can be generated from one or all of the Re-
port Bar tabs. Use to generate a report of the current tab or to 
generate a report from al Report Bar tabs.

Generating Reports

Quick Reports

A Quick Report is a fast and easy way to create an SA Report of either a 
single object or multiple objects, when using Composite Quick Re-
port.

Creating a Quick Report
To create a Quick Report of a single item, right-click the item of in-
terest in the tree and select Generate Quick Report. An SA Report of the 
object will be created and saved in the tree.

Creating a Composite Quick Report
A Composite Quick Report provides a fast way to create an SA Report 
of several items. A Composite Report can be generated for an entire 
job file from the menu Reports>Composite Report - All Collections, created 
by right-clicking on an individual collection in the tree or by select-
ing a single category in the tree. In each case you can select Composite 
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Quick Report to generate a report including the items in the selected 
category. 

To exclude or include individual item from a Composite Quick Report, 
simply right-click the respective item in the tree and toggle the  In-
clude in Composite Quick Report check box.

SA Report Builder Utility

An interactive report designer utility is also available through Reports 
> Report Builder Utility. This tool makes it easier to build a report with 
the information needed in the order you desire. It provides a means 
to select items in a list format, either from the tree or by using an F2 
selection method, and then organize those features as desired using 
drag and drop (Figure 27-4).  

When the report is organize as desired the Insert Reported Items but-
ton can be used to generate a new report or add the items to the cur-
rently open SA report (replacing the existing content). 

Figure 27-4. Report Builder Utility
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Reporting User Settings 

There are a number User Option settings that can be applied to con-
trol the way in which reports are generated. These are found on the 
Reporting Tab(Figure 27-5). 

Figure 27-5. User Option Settings 
for Reporting

Automatic Header Addition
The report header can be pre-configured as follows:

 ■ Logo File.  The path to a company logo or any image you would 
like to add to the header of a newly generated report. 

 ■ Company Byline. A text entry that can be added on the top 
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left of the report header (Figure 27-6). 

Figure 27-6. Example Default 
Template and Company Byline

Default Report Template
Any SA Report in a job file can be set as a report template. When this 
is done, the content from the template is copied as a beginning point 
for the new report. This can also be done by simply right-clicking on 
an SA Report and selecting Default Template.

Quick Report Output
Quick Reports can be generated as either Excel files, SA Reports or SA 
documents. You can also choose from the following options:

 ■ Quick Reports include Current View Image. A screen capture 
of the graphics will be automatically added with each reported 
object. 

 ■ Quick Reports Include Report Name in Header. The optional 
setting adds the report name to the header of the newly cre-
ated report. Disabling this option excludes a report title.

 ■ Quick Reports include Object Notes. When enabled an ad-
ditional table is created for each object in the report with any 
Object notes. 

Default Page Settings
The settings for each SA report generated will include the page set-
tings defined in this default section. 

Event Reporting
The length and complexity of events can be controlled here.

Report bar Settings
Options to show or hide the report bar controls and grid are available. 

Web Reports
Choose to limit web reports to Mono Chrome display. 
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SA Reports

Creating an SA Report

An empty SA Report can be created by going to Reporting > Add SA Re-
port. This will add an empty report to the SA tree and automatically 
open the editor in preparation for items to be added to the report 
(Figure 27-7). 

Figure 27-7. Empty SA Report

Adding Items to an SA Report
Simply L-Click and hold on an item in the tree and drag it over the 
report editor and release it to add that item to the SA Report in that 
location.  Once inside the report, item report tables can be moved 
and positioned within the report by dragging them as well.

Building an SA Report
In addition to adding items to an SA Report one at a time, a report can 
be generated from a selection of the items you want to include in a 
report. There are several ways to do that which are discussed in detail 
later in the chapter:

 ■ Composite Quick Report (see “Creating a Composite Quick Re-
port” on page 648) 

 ■ Using the Report Builder Utility

 ■ Creating a Report from Report Bar Tabs (see “Building Reports 
Using the Report Bar” on page 647)

 ■ Using a Report Template (Figure 27-8)
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Figure 27-8. An SA report as it 
appears in the tree.

To open/edit an existing SA Report, expand the SA Reports category 
in the tree and right-click and select View. You can also double-click 
the respective SA Report to view it (Figure 27-8).

The Report Designer

The Report Designer is the canvas on which the user will create their 
report. The Report Designer supports standard functionality such as 
click and drag, re-sizing and Left/Right Clicking with context menus. 
The Report Designer also contains a toolbar (Figure 27-9) with useful 
reporting tools and options.

Report Toolbar

Figure 27-9. The Report Designer 
toolbar.

 ■ Global Reporting Options/Page Setup. Displays SA Re-
port options such as Page Layout, Default Fonts and other op-
tions.

 ■  Jump to Next. This button provides a convenient way to 
navigate between entry fields for operators filling out reports.

 ■  Lock Report. When clicked the SA Report becomes static 
and will no longer receive updates from the tree.

 ■  Report Refresh. Refreshes the SA Report with the cur-
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rent values from the tree. This only needed for special calcula-
tions such as report tags and callout images that are not fully 
dynamic or to refresh a section of a report that was locked and 
could not dynamically refresh. 

Page Layout and Display 
The report appearance can be formatted as use the page Global Re-

porting Options/Page Setup  button(Figure 27-10).

Figure 27-10. Report Page 
Settings

Default Fonts. The default fonts used in different entries can be set inde-
pendently. These come in 3 separate categories:

 ■ Tabular entries include object tables, fields and custom tables. 

 ■ Text entries which include basic text blocks added in a report.

 ■ GD&T tables which use a custom GD&T font only. 

Page Setup and Table Styling Options. 

The Page Setup button provides control over Portrait or Landscape 
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display as well as page size and margin controls. 

The Table Styling Option button offers table header color control and 
grid display options for all object tables in the report. 

Page Grid.

The engineering grid displayed by default on an SA Report is used for 
graphical layout purposes and will not print unless you enable the 
print Grid option. 

Report Header & Footers

The contents of the report header can be formatted to include a logo 
image and a company byline (Figure 27-11). To include this informa-
tion navigate to User Options on the reporting tab.

To edit the report header or footer content, double click within the 
crosshatched area to activated it. The size of the region can be con-
trolled by selecting the separator line and dragging it up or down on 
the page. The content within the header or footer is duplicated on all 
pages within the SA Report.

The display of the separator lines and an option to hide the header 
and footer on the cover page is available.

Figure 27-11. A report header in 
the Report Designer.

Export Options

The export options are available on the top right side of the SA report 
header for easy access.

 ■  Export to Excel. Exports the current SA Report to Micro-
soft Excel.

 ■  Save As PDF. Allows the current SA Report to be saved as 
a PDF document using the built in Spatial Analyzer PDF Printer. 
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If for some reason this printer has not been installed correctly 
or cannot be accessed any standard PDF printer such as Adobe 
or Microsoft can also be accessed from the printer choice in the 
Print Current Report Options.

 ■  Print Current Report. Displays print dialog for the cur-
rent SA Report.

Directly linking a report to an Excel Report
In addition to exporting an entire report to an excel file, individual 
item tables can be directly linked to Excel (*.xls). This provides the 
ability to specify the workbook address for report items, using either 
absolute sheet!col/row or named cell references (Figure 27-12).

Figure 27-12. Controls for 
specifying the export location for a table 
linked to an Excel file.

  

To use this directed export capability an Excel file must first be se-
lected using the Connect to Excel button (Figure 27-13).

Figure 27-13. Connect to Excel 
button used to link a report to an excel 
file.
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Once a connection to an Excel file has been established a Sychronize 
button will be come visible. This global “Synchronize” operation will 
output all report items to the connected spreadsheet for which a val-
id workbook address has been established.  

The connected Excel file remains open as a background process while 
a report is connected to it.  The changes made will therefore, not up-
date the associated Excel file until the connection has been termi-
nated using the Disconnect from Excel button and the “Save” option 
performed.

Adding Elements to the body of a Report

Adding basic text blocks
Click any open space and start typing to add text. Or paste text from 
clipboard into any open space (Figure 27-14).

Figure 27-14. A report annotated 
with some text.

Additional Object shapes can be added to the report as well to link 
tables or to highlight particular sections of a table. These objects in-
clude: 

 ■ Box. Which can be used to define any rectangular shape. 

 ■ Ellipse. Which can be used to define circular objects of any 
shape or size. 

 ■ Line. Which also can be set to display as an arrow. 

Report Fields

Fields are text boxes that accept input via the keyboard or can be set  
to report dynamically computed information or by a Measurement 
Plan. The types of fields are as follows:

 ■ Input Fields. Fields intended for input from the user. They dis-
play a yellow background (red until filled in, if a required field). 
The navigation tool at the top of an SA report guides a user 
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through entry when input fields are used Figure 27-15. 

Figure 27-15. Example Input 
fields as part of a small table, showing 
input and required input file

 ■ Output Fields. Fields intended to display output, either us-
ing the selected field value directly or using a custom defined 
Tag value set through a MP script. These fields have gray back-
grounds.

 ■ Dynamic Fields. Dynamic fields are defined by a user selected 
Attribute. Attributes include GR-feature values, GD&T results, 
vector groups statistics, or dimensional values.

 ■ Equation Fields. Equations provide a means to compute val-
ues directly within a report using variables that can be manu-
ally entered or based upon attribute references. 

To add a field to a report, right-click on the canvas and select Add New 
Field (Figure 27-16).
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Figure 27-16. Newly Added 
Report Field.

To add an input field, choose the Input radio button. If it is a required 
field, check the Required option. A required field will have a red back-
ground until it is filled in, and any attempts to print the report or send 
it to PDF will display a warning dialog.

To add an output field, choose the Output radio button. The value dis-
played in output fields can be set from a specific value, or from a tag 
(see below).

Using Tags
Every field (both input and output fields) can be assigned a tag. There 
are two types of tags: system tags and user-defined tags.

 ■ System tags include << Date/Time >> and << Filename 
>> and automatically populate the field with the current date/
time or filename (additional system tags will be added in the 
future). System tags can only be assigned to output fields. To 
create a system tag, select one of the system tags from the 
dropdown list in the Tag field.

 ■ User-defined tags are tags that you have created yourself (such 
as “MyTag” that allow you to reference the field from measure-
ment plans so that a script can fill out the field automatically. To 
create a user-defined tag, just type a unique tag name into the 
Tag field. You can also assign an existing tag to a field in order to 
populate multiple fields with the same value.

Dynamic Attributes in Fields
Dynamic Attributes can be selected using GR-feature criteria and re-
porting values, GD&T settings and results, vector groups statistics, or 
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dimensional values. These can be selected in advance and will dy-
namically update as measurements are made and values are updated.

An attribute is defined using a string format such as the following 
which will appear in the Field View line:

“a::Bolthole pattern4::relationship$Magnitude xYZ#6*1.000”

 ■ A::BoltHole Pattern4::Relationship. The relationship to refer-
ence.

 ■ $Magnitude XYZ. Defines the criteria to reference (in this case 
the XYZ deviation between the nominal and measured)

 ■ #6. Defines the numeric resolution of the result

 ■ *1.000. Provides a means to scale the attribute by a fixed mul-
tiplier. This can be helpful in reporting diametric deviation as 
an example. 

Equation Fields
When more complex computational results are needed an equation 
field can be added. Equations are self-contained computational ele-
ments that use a set of variables is inputs for an equation. Variables 
are defined as manually entered values, attributes or references to 
other cells in a table (Figure 27-17).

Figure 27-17. Basic Equation 
computing the minimum value in a list 
of attributes

These expressions may contain:

 Variables such as X, Y, Z, TEMP, STRESS, STRAIN etc.

 Functions such as SIN(X), MIN(A,B), MYFUNC(D)

 Constants such as 2, 3, 50
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 Scientific notation like: 3E+10

 Arithmetic operators: +,-,*,/,%(modulus),^(power)

 Logical operators  : =,<,>,<>,>=,<=,!(not),&(and),|(or)

 Table cell locations like: cell(2, 1) or cell(0, 3)

Example expressions are:

 X+Y/2

 SIN(X)+AVG(A,B,C)

 SUM(X,Y,Z,K,L)/5

 IF(1, 2, 3) is 2, 

IF (condition, val1, val2) means that if “condition” is not zero, then re-
sult is “val1”, otherwise the result is “val2”.

Additional predefined functions are available under the Help button 
in the Equation Editor.  

Field Value
A field value is used to populate the field. Field values are always 
displayed in the field itself, and are changed when a script or a user 
modifies the field.

Field Display options
A basic field will appear in the report as a rectangular box in the re-
port. It can be moved and sized as needed by click dragging either on 
the center of the field or on the middle of an edge respectively. Typi-
cally the length of the field should be set large enough to ensure that 
any text expected will fit within the field (Figure 27-18). 

Figure 27-18. Basic Field’s ap-
pearance in an SA Report

Fields can also be displayed as a Check Box or as a Combo Box which al-
lows selection from a pre-populated list (Figure 27-19). 

Figure 27-19. Check Box and 
Combo box examples in use in an SA 
Report. 
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Tables

Tables provide a convenient means to align and group a set of report 
fields together. To add a table to a report, right-click the canvas and 
select Add New Table. You can choose from:

 ■ Add New Empty Table. Specify a name for the table, and the 
desired number of rows and columns.

 ■ Add New Relationship Attributes Table. The number of rows 
and columns are defined by the number of GR-Features select-
ed and the attributes to include. The Attribute selection order 
is used to define the table columns (Figure 27-20).

Figure 27-20. Attribute Selection 
as part of building a new relationship 
attributes table.

 ■ Add New Feature Check Attributes Table. Also builds a table 
using the selected attributes for a list of feature checks.

 ■ Add new Dimensions Attribute Table. Also builds a table us-
ing the selected attributes for a list of dimensions.

Tables can be resized by dragging their corners, or the left/right/bot-
tom sides. Interior cells can be resized by dragging any internal hori-
zontal or vertical line. Drag the interior of any cell to move the entire 
table.  

The properties of each cell can also be adjusted. Add an input or out-
put field to a cell by right-clicking a cell and selecting Cell Options. You 
can also convert a cell into a Check box or a Combo box as needed. 



663

CHAPTER 27 ■ REPORTING

Table Properties. 
To modify the number of rows or columns in a table, right-click the 
table and select Table Properties (Figure 27-21).

Figure 27-21. Table Properties 
control provides title and sizing.

The table properties includes control over the display of an optional 
title row and colorization of out of tolerance dynamic attributes. 

To insert or delete rows or columns or to change the alignment of a 
cell, right-click a cell and then choose Cell Options.

Modifying Items in the report

Items in the report can be modified by right-clicking the report item 
and selecting Report Options. Depending on the item, a context sensi-
tive menu will appear. All items have the following common options: 
Report Options, Remove from Report, Bring to Front, Send to Back, and Properties.

Object Placement in a Report
SA’s approach to reporting has been to provide complete flexibility in 
placing objects on a page for reporting. Rather than being restricted 
to a standard sequential table display, each page can be arranged as 
needed much like a Microsoft PowerPoint slide. Additional auto-ar-
range functions were added to simplify reporting with large reports. 
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Page Positioning
Tables within a dynamic report can be positioned dynamically as 
needed. They can also be placed precisely using right-click page 
alignment option including Center, Left and Right justified. Object lay-
ering is also supported with Bring to Front and Send to Back controls as 
well as a Remove Object Overlap option. 

Set Auto Arrange
Large sections of a report can be selected and formatted as needed 
using the right-click Set Auto Arrange functions. These include:

 ■ Set Auto Arrange Start. Establishes a starting point for the se-
lection and auto arrange process. Selection will continue to an 
Auto Arrange Stop point or the end of the report, whichever 
comes first. 

 ■ Set Auto Arrange Stop. Establishes a stopping point for selec-
tion and auto arrange.

 ■ Select Auto Arrange Block. Selects all the items within the 
Auto arrange block from start to end. 

 ■ Execute Auto Arrange. Evenly distributes the tables within 
the auto arrange block. 

Report Templates
SA Report Templates offer a repeatable method for creating reports 
of items from the tree. Once created they can be used repeatedly.

Creating an SA Report Template
Select Reports>Add New SA Report Template from the menu and a report 
template will be created in the tree (Figure 27-22).
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Figure 27-22. The SA Report 
Template dialog.

Inside the SA Report Template the inputs and outputs are controlled 
in the Report Instructions box (Figure 27-23). Simply use the Add or Remove 
buttons to control items availability in the report.

Figure 27-23. The Report Instruc-
tions box.

The Output Selection defines the output format and location of the report 
when it is generated (Figure 27-24). Choose from embedded loca-
tions or external locations.
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Figure 27-24. The Output Selec-
tion box.

Generating the Report
Once the Report Template is designed and saved, a report can be 
generated. Simply right-click the respective SA Report Template and 
choose Generate (Figure 27-25). The report will be created and saved in 
the prescribed output format.

Figure 27-25. Generating a 
report from a template.

Object Report Options
Items in the tree have report options that can be accessed and con-
figured per the users needs. You can access these options by right-
clicking the object and selecting Report Options either from within the 
report directly or from selecting the object in the SA Treebar menu. 

 ■ For Object reporting options refer to the sections starting with  
“Spatial Analyzer provides the capability to build both static 
and dynamic points and geometry. For example, a cylinder can 
be constructed from a print at a defined location with a preset 
length and diameter, or dynamically update as measurements 
are taken. In order for geometry to dynamically update a re-
lationship is used to connect the list of points measured with 
the object that is fit to those points. However, the object that 
is build is the same in each case and will be described here. 
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For more information on Geometry Relationships and dynamic 
features refer to “Geometry Relationships” on page .” on page 
327.

 ■ For relationship reporting options refer to: “Reporting Options 
and Controls” on page 516.

 ■ For GD&T reporting options refer to: “Reporting Options” on 
page 637.

Events

SA Events provide detailed information for major events that occur in 
SA. These events can be viewed in the Report Bar or be added to any 
Report (Figure 27-26). Events are created automatically when certain 
functions are performed and are stored in the tree.

SA Events are generated for many actions which include operations 
such as :

 ■ Best-Fit Transformations

 ■ Best-Fit Geometry

 ■ Move Objects by Minimizing Relationships

 ■ Unified Spatial Metrology Networks (USMN)

 ■ Quick Align to CAD

 ■ Queries

 ■ CAD Imports

and more to come!

 

Figure 27-26. A best fit transfor-
mation event in the tree.

Queries

The Reporting Tab of the Ribbon menu provides direct access to SA’s 
query functions. Queries operate like a static relationship, providing 
a snapshot of the current distances between objects. For more infor-
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mation on queries (see “Queries” on page 477)and vector group con-
struction see “Query Basics” on page 478).

Dimensions
Dimensions provide a simple method to annotate the graphical view 
with both linear and angular dimensions between any combination 
of points and objects (Figure 27-27). They are dynamic entities in that  
both the numeric values and the leader lines update in real time as 
the points and objects move in the job file. This allows you to set up 
dimensions in advance and see changes graphically as fits or align-
ments are updated with each new measurement. 

Figure 27-27. Dimensions 
between hole centers.

Standardized dimensional analysis is a separate process performed 
using GD&T checks. For more information on dimensional checks  see 
“Creating GD&T Annotations” on page 580. 

Types of Dimensions

There are several different types of dimensions that you can create:

 ■ Point to Point. Shows the linear distance between two points.

 ■ Point to Object. Shows the linear distance between a point 
and any object.

 ■ Object to Object. Shows the linear distance or angle between 
any two objects.

 ■ Diameter/Radius. Shows the diameter or radius of a circle or 
cylinder.

Both Point to Point and Point to Object dimensions can also be ex-
tracted directly from a point cloud.
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Working With Dimensions

To Create a Dimension:

Dimensions can be built in one of the following ways:

 ■ From the Query>Make Dimension menu, select the desired dimen-
sion type. Select the appropriate points or objects to dimen-
sion. A new dimension will appear in the graphical view.

 ■ When the Query Results dialog is displayed as the result of an 
appropriate query, check the Create Dimension checkbox (Figure 
27-28):

Figure 27-28. The Create 
dimension checkbox in the Query 
Results dialog.

 ■ Select a dimension configuration from the drop-down on the 
Reporting tab of the ribbon bar. The icons provide the ability to 
pre-configure dimension to display as desired depending on 
the icon selection. 
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Figure 27-29. Icons for Pre-
configured Dimension Construction

Properties Common to all Dimensions

Default Visual Display Settings 
A set of default Dimension Settings are available through the Users Op-
tions on the display tab. These default settings will be used any time a 
new dimension is created and include the following properties:

Dimension Default Colors

 ■ Dimension Default Color. Dimension color can be set inde-
pendently as needed for the text, leader and arrow head. The 
default colors are defined within the Users Options (Figure 27-
30). 

Figure 27-30. User Dimension 
Color Options
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Text Settings

Dimensions can be oriented based on their leader lines, or can be set 
to always face the screen:

 ■ Text Size. Controls the height of the displayed dimension. 

 ■ Screen. The dimension always faces the screen.

 ■ Along. The dimension is oriented along the leader line.

 ■ Lateral Offset. This value allows the dimension to be shifted 
laterally relative to its axis on the XY plane of the reference 
frame.

 ■ Offset Along Dimension Line. This value allows the user to 
shift the placement of the text along the dimension line and 
can be entered as either a positive or negative number.  

To Interactively Change the Graphical Placement of Multiple Dimensions at Once:

 ■ Right-click the dimensions category in the tree and select Di-
mension Cursor Operations to open the dialog. While this dialog is 
open dimensions can be positioned graphically using the key-
board shortcuts listed (Figure 27-31). 

Figure 27-31. Dimension Cursor 
Operations 

 

To Change Settings for All Dimensions in a single Collection:

All dimensions in a collection have a set of common properties which 
can be adjusted at one time using the option within the dimension 
category right-click menu. These controls are ideal for editing text 
size and placement and include the following:

 ■ Right-click the dimensions category in the tree
and select Set Common Properties to open the Common Dimen-
sion Properties dialog (Figure 27-32).
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Figure 27-32. Set Common 
Properties Dialog

To Change a Single Dimension’s Properties:

 ■ Double-click the dimension in the tree, or

 ■ Right-click the dimension in the tree or graphical view and se-
lect Properties (see “Type Specific Dimension Properties” on page 
673).

To Apply settings from one Dimension to a selection of others:

An Apply to Selected Dimension button is available in each dimension 
properties dialog. When selected you will first be prompted to select 
the dimensions you wish to consider. This will show a filtered list with 
only applicable dimensions of the same type. 

You will then see an options dialog which allows you to choose and 
preview the dimension properties that you are applying to the se-
lected dimensions .
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Figure 27-33. Apply to Selected 
Dimensions Optional Controls

Cloud Point Mode
Dimensions can be created directly from point clouds by checking 
the optional Cloud Point Mode check box. This enables Point to Point 
and Point to Objects dimensions to be built directly from point cloud 
data. Because of the inherent noise in cloud data, the user click point 
selection is used to define a volume or Voxel and the most represen-
tative point in that volume is then converted into a point and used 
for the dimension placement. This voxel size is also user controllable. 

Type Specific Dimension Properties

The dimension type specific properties are listed below. 

Point to Point Dimensions

These dimension types depict the distance between two points (Fig-
ure 27-34).
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Figure 27-34. The properties of a 
Point to Point dimension.

In the dimension Measurement section, each point has an offset set-
ting:

 ■ No Offset. Dimension from the target or point’s center.

 ■ Add Target Offset. Adds the target’s offset to the dimension. 
This simulates an inside caliper (as if you’d measured the inside 
of a box).

 ■ Subtract Target Offset. Subtracts the target’s offset from the 
dimension. This simulates an outside caliper (as if you’d mea-
sured the outside of a box).

 ■ Tolerance. A single tolerance value can be set per dimension 
which can be displayed either as a nominal +/- value or as a 
range. This setting will influence the display and the report 
table.

 ■ Dimension Notes. Notes can be added to the Dimension as 
trailing text. 

The other major advantage to point to point dimensions is the ability 
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to isolate reported to a single axis component or 2D component:

 ■ Dimension Components. Dimensions can be set to report ei-
ther the direct line deviation (Magnitude) or can report devia-
tions along a single or set  of axes (X,Y,Z) relative to the Dimen-
sion Reference Frame.  Simply check the components you wish 
the dimension to consider. 

You can also control the display orientation for the dimension, as de-
scribed in “Properties Common to all Dimensions” on page 670.

Point to Object Dimensions

Figure 27-35. Properties of a 
Point to Object dimension.

In the dimension Measurement section, the point offset controls are 
the same as a point to point dimension with addition of an option to 
Use radial Offset Component. If enabled, the radial component of the 
measurement offset will be used for compensation instead of the pla-
nar component. This is useful, for instance, when you are measuring 
the distance from the closest point in a hole to a surface edge and are 
acquiring the hole measurement with a pin nest. On the other end of 
the dimension, the object can have one of four settings:

 ■ Origin. Distance to the object’s internal origin (Figure 27-36). 
For instance, the center of a circle or plane.
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 ■

Figure 27-36. Point to Origin.

Plane. Distance to the plane of the object, if applicable (Figure 
27-9).

 ■

Figure 27-37. Point to XY Plane.

Axis. Distance to the object’s projected (extended) axis (Figure 
27-38).

 ■

Figure 27-38. Point to Axis.

 Surface. Show the distance to the closest point on the object’s 
surface/line/curve (Figure 27-11).
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Figure 27-39. Point to Surface.

You can control the display orientation of the dimension as described 
in “Properties Common to all Dimensions” on page 670.

2D Point to Object Angular Dimensions
Point to Object dimensions report the minimum distance between a 
point and an object unless a reporting frame is asserted. In that case 
the dimension is projected to the XY plane of the reporting frame. 
This provides a means to build a 2D dimension between a point and 
an objects. 
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Object to Object Dimensions

Figure 27-40. Object to Object 
Dimension properties.

The dimension can be tied to one of three features of each object:

 ■ Origin. The distance from the object’s internal origin. This fea-
ture setting for the dimension does not allow angular dimen-
sioning, therefore the Angular option becomes grayed out.

 ■ Z Axis. The distance to the object’s projected Z axis (if Linear is 
selected), or the angle to the object’s internal Z axis (if Angular 
is selected).

 ■ XY Plane. The distance to the object’s XY plane (if Linear is se-
lected), or the angle to the object’s XY plane (if Angular is se-
lected).

Two settings particular to angular dimensioning dictate where the 
angular dimension appears:

 ■ Dimension Radius. The distance of the angular dimension 
from the mutual intersection of the two objects.

 ■ Angular Location. This button cycles through the four quad-
rant representations of the given angle, as illustrated in Figure 
27-26.

Note:  The internal Z axis of 
an object is typically the ob-

ject’s normal (for planes, circles, 
etc.) the Z axis (for frames) or the 
line direction (for lines).
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Figure 27-41. Angular quadrants

You can control the display orientation of the dimension as described 
in “Properties Common to all Dimensions” on page 670.

2D Object to Object Angular Dimensions
Angular dimensions between two objects by default report the mini-
mum angle between the two include objects unless a reporting frame 
is asserted. In that case the dimension is projected to the XY plane of 
the reporting frame. This provides a means to build a 2D dimension 
between two objects. 

Diameter / Radius Dimensions

Figure 27-42. A diametrical 
dimension.

Diameter/Radius dimensions are ideal when the diameter or radius of 
a circle, cylinder, or sphere needs to be dimensioned (Figure 27-7).

The diameter/radius dimensions are shown in Figure 27-2:
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Figure 27-43. Properties of a 
Diameter/Radius dimension.

 ■ Display Angle. Specifies the angle around the circle to which 
the dimension is oriented.

 ■ Dimension Radial Offset. For angular dimensions this value 
controls the vertical shift of the text inward or outward from 
the apex of the dimension. 

You can control the display orientation of the dimension as described 

in “Properties Common to all Dimensions” on page 670.
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Callout Views and Callouts
Callouts offer a quick and easy way to annotate the graphical 3D view 
in SpatialAnalyzer with screen oriented labels that are dynamic and 
easy to read. Callout views offer a wide range of control and flexibil-
ity to define a perspective on a job file and isolate the display of the 
objects of interest. These can be used interactively for inspection and 
define a reportable image that can be added directly to a report. A 
simple example callout is shown in  Figure 27-44.

Figure 27-44. Geometry relation-
ship callouts in the graphical view.

Creating a Callout View

Callouts are typically composed of two functional parts: 

 ■ Callout View. Which defines the perspective used to display 
the callout and controls any additional visibility settings.                

 ■ Callouts. These are the actual annotations added to the graph-
ics that display information about the particular objects of in-
terest. Multiple callouts can be added to the same Callout View.

Creating a Callout View
To create a new callout view simply press the button in the Main 
Toolbar or use the add icon on the Reporting page of the Toolkit. This 
will create and activate a callout view in the tree. Double-Clicking a 
callout view in the tree will activate or deactivate (turn on and off) 
this callout.
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Figure 27-45. An activated 
callout as it appears in the tree.

Adding Callouts to a Defined Callout View
Callouts can be added to just about any object displayed in the graph-
ics in SA. To add a callout first define a callout view or set an existing 
callout as active and then select a callout type from the drop down 
list on the Reporting tab of the ribbon menu. It can also be found in 
the Main Toolbar or from the icons in the toolkit in the classic menus. 
Add callouts to points or objects by clicking on them in either the 
graphics or in the tree bar (Figure 27-46).

Figure 27-46. Adding Callouts
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Callout View Properties

Enabling Callout Display
Single click in the tree updates the callout view in the report bar but 
not in the view, while double click in the tree should set the callout 
as active for the job file, asserts the saved view perspective and visual 
controls defined in the view. 

Callouts can also be tied directly to GR-Features as part of an inspec-
tion process such that the desired perspective and labels are dis-
played when trapping begins on the feature (see “Visual Controls” on 
page 512). 

Default Callout Properties
The default configuration for newly created callout views is defined 
within the Users Options. On the Display Tab in the Default Settings section 
is a  Callouts button which opens a default callout view configura-
tion. Edits to this control will modify the newly created callout view 
properties for that job. This configuration can also be saved as part of 
a template file.

Figure 27-47. Callout view 
properties.

Much like composing a photograph, the callout view defines the per-
spective on the job. In its simplest form, it sets the view orientation 
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and zoom depth on the 3D objects shown in the graphics. 

Save Viewpoint
The Save Viewpoint button provides the operator the ability to rede-
fine the saved view orientation and zoom depth used to display the 
features of interest. The initial view is saved when the callout is cre-
ated and can be redefined at any time. 

Lock Viewpoint
The Lock check box allows a user to lock the current view of the call-
out so that the graphics cannot be rotated. This option also is help-
ful in more precisely defining the location of callouts relative to 3D 
objects. If you are working on monitors with different aspect ratios 
this option will ensure callouts are placed precisely on the viewing 
plane regardless of the proportions of the graphics. All other modes 
maintain the placement of callouts with respect to the placement on 
the screen.

Recall Working Frame
The Recall Working Frame checkbox allows the callout to set the work-
ing frame to a specified frame when the callout is activated. This can 
be helpful when reporting a section of the job relative to a particular 
coordinate frame. However, changing working frame will require a 
job recompute which can slow the display process. 

Recall Visible Layers
The goal of the recall Visible Layer option is to hide everything but 
the specific items you want to display when the callout is enabled. 
This visibility is defined as a layer which is named and saved in Layer 
Manager (see “The Layer Manager” on page 685). 

The idea is to have many callouts each with an independent layer or 
list of displayed items. So generally you will have 1 layer per callout, 
but you can also re-use an existing layer so the visibility does not 
need to be edited for all items in the job (with hundreds of objects, 
this can be handy) before adding a callout visibility layer. The idea is  
to select existing layers by name. 

The recall visible layers check box is used to turn on or off this mode. 

 ■ With the check box off… the visible items are not changed

 ■ With the check box on… the visible items in the referenced 
layer will be displayed.

The Add a new Layer button should build a new layer if a layer does 
not exist yet for the callout, saving the list of currently displayed items 
in the graphics when the layer is built. 

The Update Current Layer button should be used to update the cur-
rently selected layer with any changes in visibility for the objects.
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The Layer name field is used to identify the name of a layer to be re-
called. This allows an existing layer to be referenced. But if a layer of 
that name does not exist it should not be applied until it is defined 
first.

Annotation Display Properties
The final section of the callout view allows the default graphic display 
options to be set for the callout view. This will set the default proper-
ties for each new callout added to that particular callout view. 

Enable Scalable Callouts
An option exists within the right-click menu of the Callout category in 
the tree to Enable Scalable Callouts. This option makes it possible to ad-
just the overall display size for all the callouts within a callout view. To 
do so right-click on the callout category in the tree and choose Enable 
Zoomable Callouts. Then within an active callout view, hover over one 
of the callouts and hold Ctr+Shift and use the mouse wheel to adjust 
the callout size as needed. 

The Layer Manager

Often, when working with complex files, you may find yourself show-
ing and hiding sets of related objects in the tree. For instance, if you 
have a CAD model and measurements of several sub-systems on 
an assembly, you may wish to view only a given sub-system in the 
graphical view.

For this purpose, you can create layers. You can assign objects to cer-
tain layers, then show or hide layers. This serves as a very quick way to 
show and hide multiple objects at once.

Every file contains a Default layer that cannot be deleted.

To Show the Layer Manager:

 ■ From the menu, select View>Layer Manager. The Layer Manager 
dialog appears (Figure 27-48).

Figure 27-48. The Layer Manager.
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To Define a New Layer:

1. In the SA file, show only those objects you’d like to appear on 
the layer.

2. In the Layer Manager, click the Make New Layer button.

3. Type a new name for the layer, then click OK.

4. The Layer Manager will show the new layer and indicate the 
number of objects on the layer, and the number of objects 
currently visible.

To Show or Hide Layers:

1. In the Layer Manager, select one or more layers to hide or 
show.

2. Click one of the following buttons:

 ■ Hide. Hides the selected layer. Objects already hidden remain 
hidden.

 ■ Hide Only. Hides only the selected layer. Objects on other lay-
ers are shown.

 ■ Hide All. Hides all layers. The only remaining visible objects 
will be those that don’t belong on a layer.

 ■ Show. Shows the selected layer in addition to the objects al-
ready visible.

 ■ Show Only. Shows only the contents of the layer, hiding all 
other objects.

 ■ Show All. Shows all layers. The only remaining hidden objects 
will be those that don’t belong on a layer.

To Rename a Layer:

1. In the Layer Manager, select the layer to rename, then click 
the Rename button.

2. Type a new name for the layer, then click OK.

To Delete a Layer:

1. In the Layer Manager, select one or more layers to delete.

2. Click one of the following buttons:

 ■ Delete Layers and Entities. Deletes the layers and any objects 
on those layers.

 ■ Delete Layers - Leave Entities. Deletes the layers but any ob-
jects on those layers remain.

To Add or Remove an Object From a Layer:

1. Right-click on the object in the tree or graphical view and se-
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lect Layer Info from the context menu.

2. The Layer List dialog appears, showing the layers that cur-
rently contain the object.

Figure 27-49. The Layer List 
dialog. This object is only on the default 
layer.

3. Do one of the following:

 ■ To remove the object from a layer, select the layer and click Re-
move From Layer.

 ■ To add the object to one or more layers, click the Add to Layer but-
ton. In the Add to Layers dialog, select the layers you’d like to 
add the object to, then click OK.

Types of Callouts

Text
A text callout provides the ability to add a simple text box to the 
graphic view. This can be helpful both in annotation reporting im-
ages and in guided inspections. This can be expanded by Right-click 
within the text box to add dynamic reporting attributes in-line with 
user defined text.

Point Labels
Point Label callouts provides a quick way to add a name label to a 
specific point or set of points. These callouts can be converted direct-
ly to Point Coordinate callouts if desired at any time.  

Point Coordinates
Point Coordinate callouts are pre-configured to provide basic point 
name and position information (Figure 27-50).

Figure 27-50. A point coordinate 
callout.

Right-Click the Point Coordinate or Point Label callout to access the 
properties and display configuration for that callout type (Figure 27-
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51).

Figure 27-51. Point callout 
properties.

Point Comparison
A Point Comparison callout can be used like a dimension to display 
the difference in position between two selected points. Their deltas 
are computed by subtracting the first selected from the second se-
lected. Right-Click the callout to access properties (Figure 27-52).

Figure 27-52. A point comparison 
callout.
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Figure 27-53. Properties for a 
point comparison callout.

Group Comparison
This callout option provides an efficient way to compare the corre-
sponding point pairs in two selected groups.  It adds individual point 
comparison callouts to each of the matched points in each group. 
Their deltas are computed by subtracting the first selected from the 
second selected. Right-Click the callout to access properties.

Vectors
Vector callouts annotate selected vectors with a vector group. They 
can be configured to display both the magnitude and tolerance infor-
mation as needed (Figure 27-23), which can be configured through 
the right-click properties (Figure 27-22).

Min/Max Vector Group
In many cases users are only really interested in annotating the larg-
est or smallest deviations displayed by a vector group. The Min/Max 
Vector Group callout provides a means to specify how many callout 
to add and have them added automatically to the vector group by 
picking any single vector in that group. 
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Figure 27-54. A vector callout.

Figure 27-55. Vector callout 
properties.

Relationship
While relationships are not actually graphical entities, they can still be 
used in displaying key information about the objects or points within 
the job file. Callouts can be added to any relationship by selecting 
the relationship either through the tree or by using the F2 selection 
menu. An example Geometry relationship callout is shown in (Figure 
27-3). Right-Click the callout to access the extensive relationship call-
out properties (Figure 27-24).
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Figure 27-56. A relationship 
callout.

Figure 27-57. Relationship 
Callout properties

Object and Object Label
These annotations can be added to any object. Just like point labels 
the Object labels only list a name for the object but can be converted 
to full object callouts at any time.  Annotates selected object proper-
ties (Figure 27-1). Right-Click the callout to access properties.
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Figure 27-58. An object callout.

Charting
Charting is the most effective way to display relative differences be-
tween data points, particularly as they relate to sequential changes. 
SA offers basic chart generating capabilities and export options for 
more advanced charting applications.  

 Figure 27-59. Example Chart

Available Charts

Vector Group Charting
The following chart types are available for vector groups (Figure 27-
60):
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 ■ Moving Range SPC Chart. Moving Range charts are used to 
monitor individual values over time with respect to control lim-
its for the individual values.

 ■ Bullseye Chart. Bullseye Charts are used to pot two param-
eters relative to a specific goal. 

 ■ Run Chart. A Run Chart or run-sequence plot is a graph that 
displays observed data in a time sequence, providing a basic 
plot of a Primary and Auxiliary parameter. 

Figure 27-60. Chart Type Options

Feature SPC Charting
Moving Range SPC Charts can be added for the following features 
(Figure 27-61):

 ■ Relationship Criteria. Charting is available for Average, Max, 
Min, RMS and StdDev values. 

 ■ Geometry Relationship (GR) Feature Criteria. The options 
will depend on the geometry type and reflect the available cri-
teria.

 ■ GD&T Feature Check Results. Charts can be used to plotted 
changes in features checks results when multiple checks are 
made based  upon a single annotation. 

 ■ Dimension Magnitudes. Charts can be used to plotted chang-
es in dimension values  



694

SPATIALANALYZER USER MANUAL

Figure 27-61. Example circle 
position SPC chart

Chart Plot Region Controls:

The following basic chart configurations can be made (Figure 27-62):

 ■ Titles. Chart titles can be edited as needed. 

 ■ Rainbow Coloring. A red and green colorization can be ap-
plied to the chart back ground with respect to the control lim-
its.

 ■ Control Limits. A dotted line can be drawn on the chart to dis-
play the upper and lower control limits. This can be turned on 
and of and the Ordinate value adjusted (see Ordinate below).

 ■ Specification Limits. The chart plotted area can be adjusted 
to display Observation values within the specified High and 
Low limits. 

 ■ Chart Range. The plotted value index can be adjusted to dis-
play data within a specific range of values. Both a start and stop 
control index can be specified. 

Chart Buttons
 ■ Print. The Print button will export the current chart to you de-

fault printer.

 ■ JPG. The JPG button will export the current chart as an image 
file saved in the selected directory. 

 ■ Copy. The Copy button will save an image of the current chart 
to the windows clipboard and can then be pasted in another 
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document.

Right-Click Export to Excel
The right-click menu for a chart offers an Export to Excel option which 
will export a *.csv file containing the raw observation data used for 
the chart. 

 ■

Figure 27-62. Run Chart Options

Chart Statistical Results

Ordinate
The Ordinate is a term which defines the y-coordinate or vertical of a 
point in a two-dimensional system.  In SA charts this value is used to 
drive the placement of the upper and lower control limits and defines 
represents the Sigma value or standard deviation used. 

Upper and Lower Control Limits (UCL & LCL)
These are the lines drawn above and below the process control line 
(PLC average or RBAR running  average) in Range and Observation  
charts.  They are computed from the available data and placed equi-
distant from the PCL line.  It is formulated using the average deviation 
times the positive and negative standard deviation, which in this case 
is the Ordinate.  Points plotted above or below the control limits are 
considered out of control.
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Process Sigma
Process Sigma is a measure of the variation in a process relative to 
customer requirements.  We measure defects on a scale of defects per 
million opportunities (DPMO).  Any instance of failing to meet cus-
tomer requirements is a defect, so a high number for DPMO is unde-
sirable. This is implemented 

Process sigma, as implemented within the context of SPC, is devel-
oped from the moving R average value -- it is NOT directly calculated 
from the data. The moving R values are the absolute value of the delta 
between adjacent observations.  The average of these R values is R_
BAR. Estimated process standard deviation = R_BAR / 1.128.

Upper and Lower Specification Limits (USL & 
LSL)

A value that represents the highest and lowest range in a variable 
typically these limits are set by a customer requirement.

Cp and Cpk
 ■ Cp – Process capability. A simple and straightforward indica-

tor of process capability

 ■ Cpk – Process capability index.  Adjustment of Cp for the ef-
fect of non-centered distribution. (measures how close you are 
to your target and how consistent you are to your average per-
formance.

Use an analogy of hitting a target to help understand. If you hit the 
target in the same spot forming a good group this is a high Cp  (PRE-
CISION).  Now imagine that this tight grouping had actually landed 
on the bullseye, you now have a high Cpk (ACCURACY).

Kurtosis
Kurtosis is a measure of the sharpness of the peak of a frequency-
distribution curve.  It is a descriptor of the shape of a probability dis-
tribution, which is used along with skewness.  Kurtosis is sometimes 
confused with a measure of the peakedness of a distribution. How-
ever, kurtosis is a measure that describes the shape of a distribution’s 
tails in relation to its overall shape. 

Kurtosis quantifies whether the shape of the data distribution match-
es the Gaussian distribution.  Gaussian distribution has a kurtosis of 
0. A flatter distribution has a negative kurtosis. A distribution more 
peaked than a gaussian distribution has a positive kurtosis. 
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Figure 27-63. Kurtosis

Skewness
Skewness is a term in statistics used to describe asymmetry from the 
normal distribution in a set of statistical data. Skewness can come in 
the form of negative skewness or positive skewness, depending on 
whether data points are skewed to the left and negative, or to the 
right and positive of the data average. 

When data is skewed to the right, the mean and the median of the set 
are both greater than the mode. (Mean is the average, Median is the 
data center, and Mode is the number which occurs the most). Further, 
the mean is greater than the median in most cases. Conversely, when 
data is skewed to the left, the mean and the median are both less than 
the mode. In addition, as a rule, the mean is less than the median.

Figure 27-64. Skewness

 Photos
Pictures can also be added to SA and directly to SA reports. Drag-Drop 
photos into the graphics to save them in the tree for later use or di-
rectly into a report. They can also be imported by using the File>Import 
options. 

Screen shots can be captured using the Capture button on the Re-

porting page . 
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The picture can be placed into the report by dragging, as with other 
items (Figure 27-65).

Figure 27-65. Dragging a picture 
into a report.

Once the picture is in the report it can be re-sized by dragging a cor-
ner of the image.
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What is Measurement Uncertainty?
Put simply measurement uncertainty is a statement of how sure you 
are that the objects true position is where you say it is. 

Being able to estimate uncertainty is important. Many organizations 
have standards requiring that measurements include a statement of 
the measurement’s uncertainty. For instance, the International Or-
ganization for Standardization (ISO) “Global Product Specification” 
requires that part measurements have both measured values and un-
certainties, and the National Institute of Standards and Technology 
(NIST) specifies that “a measurement result is complete only when ac-
companied by a quantitative statement of its uncertainty.” 

It is important to realize that uncertainty calculations are always go-
ing to be a process of estimation. Instrument manufacturers have put 
a lot of effort into isolating and quantifying the accuracies of their 
measurement systems and reporting an accuracy spec with their 
product. However, in a real measurement application there are many 
more factors that can influence uncertainty. Examples include: 

 ■ Instrument uncertainty and accuracy at a given distance

 ■ Added targeting or tooling uncertainty

 ■ Environmental influences, such as wind, vibration, etc.

“A measurement result is complete only when accompanied by a quanti-
tative statement of its uncertainty.” –National Institute of Standards and 
Technology (NIST). This chapter introduces measurement uncertainty, 
discusses how uncertainty is calculated in SA, and provides some guid-
ance on refining measurement uncertainty estimation. 

Measurement 
Uncertainty
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 ■ Operator influences, particularly with instruments that rely on 
sighting.

 ■ Geometry contributions

 ■ Fixturing influences

 ■ Scale or temperature uncertainty

 ■ Networking instruments builds interrelated measurement sys-
tems whose combined characteristics are dramatically differ-
ent than the individual source measurements.

In addition, measurement uncertainty statements typically report a 
spherical uncertainty and do not address the more complex geomet-
ric nature of a measurement in determining its accuracy. Surprisingly 
the simplification of reporting a +/- value may lead you to overes-
timate the true uncertainty if you were to look at the position in 3 
dimensional space. 

SA takes a different approach to uncertainty estimation by striving 
for objectivity.  It provides a clearly defined set of variables to actively 
model the uncertainty in measurements from the primary contrib-
uting variables, it provides a means to build and visualize these un-
certainties in 3D and then evaluate the influence of instrument po-
sition and point distribution based upon these defined variables. It 
provides a tool that enables metrologists, engineers, customers, and 
even managers to communicate effectively.   

Measurement Uncertainty and Visualization in SA

The best way to determine the uncertainty in the measurements from 
your instrument in your environment is to measure a point many times 
under those conditions. For example, if you were to simply measure 
a point 100 times you would end up with a group of points all with 
slight deviations from one another. There would be a greater number 
of points near the center of the group and fewer as you looked out-
ward from that center location to the few outliers along the periphery 
(Figure 28-1). This variation can be described in statistical terms as a 
Gaussian distribution. 
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Figure 28-1. Multiple measure-
ments of the same target

SpatialAnalyzer takes this fundamental principle and expands on it 
to provide the ability to compute and report unique measurement 
uncertainty estimates for each and every supported instrument. 
Rather than providing a long list of computed uncertainty estimates, 
SA presents uncertainty data visually as a point cloud (around the 
measurement) that represents the target’s region of uncertainty. This 
point cloud is called a sensitivity cloud and represents what you could 
expect to see if you were to take many measurements of that same 
point location.

Mathematically SA utilizes a Gaussian random number generator 
(utilizing a Box-Muller algorithm) to build this sensitivity cloud. Con-
sidering that real-world, natural processes tend to have a Gaussian 
distribution this is a logical choice to model the expected distribu-
tion.  It builds uncertainty clouds in three dimensions based upon the 
uncertainty values of the instrument and a user specified number of 
samples. The amount and type of error that is inserted is based on the 
precision of the measuring device.

Calculating Uncertainty of a Point in SA
To calculate the uncertainty of a point in SA you can simply go to the 
properties menu of a specific point and press the Compute button 
(Figure 28-2). This will build an uncertainty cloud for that point. You 
can also build a set of uncertainty clouds for selected points using the 
command Analysis> Coordinate Uncertainty>Create Point Uncertainty Fields
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Figure 28-2. Computing Uncer-
tainty for a Point

The magnification and confidence interval for uncertainty cloud dis-
play properties can be changed under the User Options. These com-
puted values and resulting uncertainty cloud are based upon several 
setting: 

1. The User Options settings for the confidence interval, the 
number of samples to compute, and the magnification value 
used to help visualize the cloud in the graphics.

2. Instrument Uncertainty settings for the instrument that took 
the measurement.

Confidence Interval and User Option Settings
The Users Options provides a set of controls for both uncertainty 
computation and reporting purposes on the Analysis tab (Figure 28-3).

Figure 28-3. Uncertainty Compu-
tation Controls

The Confidence Interval directly determines the reported uncertainty 
magnitude values reported for a point. For example, if you use the de-
fault 1.0 sigma Confidence Interval then you are making a statement 
in your report that you have a 68.26% confidence that the true mea-
surement lies within the uncertainty parameters. If you want higher 
confidence, you can set the uncertainty to 3.0 sigma for example, 
which will greatly increase the uncertainty magnitudes reported but 
allow you to state a 99.74% confidence (Figure 28-4). 
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Figure 28-4. Normal or Gaussian 
Distribution

The number of samples used in this calculation can also be adjusted. 
The default is 1000. Increasing the number of samples give you a bet-
ter estimate but will also take more time to compute. Reducing the 
number will accelerate the process but cause outliers to have a great-
er influence on the results. 

Sensitivity clouds are handled differently than other point clouds. For 
this reason we have a separate magnification value which helps visu-
alize these clouds graphically. Increasing the magnification value will 
scale the cloud about the measurement to make it easier to see. The 
deviations can also be depicted as lines drawn from the measured 
point. 

Is that +/- or the total uncertainty?
The uncertainty that we report is related to the standard deviation of 
the data.  Picture the normally distributed bell curve with a mean at 
the peak, and vertical lines at standard deviation multiples on either 
side of the mean.  The uncertainty we report is the distance from the 
mean to the standard deviation of the user’s choice.  So the expected 
value of the measurement is the coordinate +/- our reported uncer-
tainty.
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Figure 28-5. Graphic depicting 
SA’s reporting of uncertainty for a point 
in 2D

In the image above (Figure 28-5),  a point is located at X = 2.5 and Y=4. 
The reported uncertainty of 1 sigma in X and 2 in Y translates to an 
uncertainty range of 1.5 to 3.5 in X and 2 to 6 in y. 

If a USMN composite point has an X coordinate of 1.0000”  and an 
uncertainty in X of 0.0006” at a 2 sigma confidence interval, we can 
say with 95.46% confidence that the true X value is between 0.9994” 
and 1.0006”.

Instrument Uncertainty Values  
The point location uncertainty of a measurement is computed based 
upon the uncertainty parameters of the instrument that recorded the 
measurement. The Uncertainty Variables can be accessed through an 
instrument’s property menu and will differ depending on the type of 
instrument (Figure 28-6). 
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Figure 28-6. Instrument Uncer-
tainty Variables

CMM Instrument Uncertainty
PCMM arms and other robotic instruments have a series of joints that 
each contribute to the measurement error. Therefore an arm with 
7 degrees of freedom will have 7 separate joint uncertainty values.  
These values could potentially be changed to reflect the performance 
of a particular arm. Each of these variables will contribute to the in-
struments measurement uncertainty. 

Trackers / EDM Theodolite and other polar 
Instruments

Looking more closely at the uncertainty settings for a Tracker or Total 
Station you will see there are 4 initial parameters. Much like a robot 
these parameters directly correlate to the mechanical controls or en-
coders used to determine the location of a measurement, and are de-
picted graphically in (Figure 28-7): 

 ■ Theta or Horizontal Angle. The angular accuracy of the in-
strument in determining vertical position of a target.

 ■ Phi or Vertical Angle. The angular accuracy of the instrument 
in determining horizontal position of a target.

 ■ Distance Error. The fundamental accuracy of the instrument 
in determining distance at any range. 

 ■ Parts per million. Compounds the distance error the further 
the point is from the instrument base.  
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Figure 28-7. Component Instru-
ment Uncertainty for a Tracker

The Aperture Error parameters are a more recent addition which provide 
an alternative means of defining angular uncertainty for a polar instru-
ment. Aperture Error can be used either as an alternative to or in con-
junction with Theta and Phi angle measurement uncertainties(Figure 
28-8). 

Figure 28-8. Example Aperture 
uncertainty settings. These settings 
could be used as a starting reference for 
uncertainty modeling applications.

 ■ Threshold (in job linear units). Defines the base error thresh-
old which could model the minimum uncertainty in the loca-
tion of a reflector in the nest.

 ■ Parts per Million. The error propagation value which is used to 
define the rate of error expansion with distance, much like the 
rate of growth of an error cone about the Line of Sight (LOS).
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The legacy approach of using elevation and azimuth as angular errors 
scaled by distance can produce surprising results near-polar orienta-
tions. Think of a turret gunner who can only move the gun up and 
down (PHI) and on a rotating platform (THETA). If he points the gun 
straight up, no amount of rotation will move his point of aim, i.e., un-
certainty in THETA has no effect but he had better get PHI right if he 
wants to hit a target on the polar axis. Although this is mathematically 
valid, customers have observed that this did not explain field results 
that did not appear to exhibit this sort of singular uncertainty profile.

Aperture uncertainty addresses this with the addition of a radial un-
certainty parameter perpendicular to the LOS. This parameter has 
both a fixed minimum and a PPM component which expands pro-
portionally based on the distance to a target, and is not influenced 
by polar direction. This “APERTURE” uncertainty is reasonably generic 
defining an expanding uncertainty cone and supports compensation 
for uncertainties such as SMR targets (fixed minimum component) 
as well as other contributors that are better modeled as uncertainty 
scaled by distance.

With the addition of APERTURE uncertainty, the user now has com-
plete control over what components of uncertainty they want to 
model and in what direction they are asserted. The fixed angular plus 
PPM component together with the APERTURE fixed plus PPM compo-
nent offer a completely generic set of uncertainty modelling options 
that were previously missing.

For a very simple model, the following uncertainties are in play:

 ■ The instrument points to the target (with some uncertainty in 
both PHI and THETA). This is what I am referring to as SERVO er-
ror because PHI and THETA feed directly into the measurement 
result. Not considering uncertainty in distance to target for this 
case.

 ■ The target reflector center affects where the target is perceived 
to be (fixed APERTURE uncertainty).

 ■ The target reflection forms a beam spot on an image sensor 
within the laser tracker. Based on the activated image sensor 
elements, the instrument SERVO loop drives the beam to cen-
ter the beam spot on the image sensor. The beam spot on the 
image sensor will cover more than one sensor element and its 
shape will probably not be a perfect circle so the accuracy with 
which the center of the beam spot is determined will produce 
some amount of distance scaled APERTURE error. 

This example is probably as simple as things can get. There will cer-
tainly be other sources of uncertainty due to refraction though air at 
varying temperatures, thermal plumes, vibration, inconsistent target 
placement, target mount stability, etc. These can be realistically mod-
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eled by lumping them in with APERTURE uncertainty using fixed and/
or distance scaled components. 

Default Instruments Uncertainty Settings
The first question that every instrument reseller asks when they start 
to use SA is “why are the default instrument uncertainty values so 
high”. It’s important to remember that the default Instrument Un-
certainty Variables are not intended to match the manufacturer in-
strument specifications. Rather, they are intended to encompass all 
the uncertainty in the measurements. These values have been deter-
mined to be a conservative first guess as to the overall error result-
ing from the instrument accuracy and real-world variability resulting 
from work in the field.   In many cases these values have turned out to 
be accurate depictions of the true measurement uncertainty. 

It’s helpful to keep in mind that the default values are intended to be 
an initial estimate. Through the use of a USMN network alignment it is 
possible to experimentally determine the true instrument uncertain-
ty parameters for your instrument in your environment. These values 
can then be entered into the Instrument Properties and to provide a 
better estimation of further point uncertainties within those specific 
condition. For more information on the process refer to the Chapter 
on USMN (see “Using USMN” on page 726).

Basic Uncertainty Computation Process for a Tracker/Total Station:

A basic point uncertainty computation for a tracker or total station or 
other spherical measurement device is performed as follows:

1. The linear distance from instrument to the coordinate is de-
termined.

2. The Confidence Interval set in the Users Options is used in 
conjunction with the Uncertainty Variables set in the instru-
ment properties to determine the range of potential uncer-
tainty in each parameter (Horizontal Angle, Vertical Angle, 
and Distance).

3. The point coordinates values are perturbed using a Gaussian 
random number generator (utilizing a Box-Muller algorithm) 
to build a new point coordinate, injecting random error into 
each of these instrument variables.

4. The process is repeated as many times as is necessary to built 
an uncertainty cloud as large as is requested. 

The distribution of the resulting uncertainty points can be viewed in 
3 dimensions and will have different characteristics depending on 
the instrument uncertainty variables and the distance. A direct com-
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parison between a laser tracker and a total station provides a good 
example of the differences in cloud shape with different uncertainty 
parameters.

Figure 28-9 depicts a magnified uncertainty cloud for a laser tracker. 
Laser trackers have accurate distance measurements, but often the 
angular measurements are not nearly as accurate. As a result the un-
certainty clouds inherits a flat “pancake” shape--there is less uncer-
tainty in distance than angle, so the uncertainty cloud tends to be 
thin (along the line of sight) and wide (perpendicular to the line of 
sight).

Figure 28-9. A tracker measure-
ment’s uncertainty cloud.

Notice also that as measurements get further away from the tracker, 
the uncertainty becomes larger, manifested as larger uncertainty 
clouds (Figure 28-10).

Figure 28-10. Changes in Cloud 
shape with Distance

On the other hand, a total station’s azimuth/elevation angle measure-
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ments can be far more accurate compared to its distance measure-
ments. Notice how the uncertainty clouds are elongated and cigar-
shaped: there are high uncertainties along the line-of-sight, but low 
uncertainties perpendicular to the line-of-sight (Figure 28-11).

Figure 28-11. The uncertainty 
cloud for measurements from a total 
station.

Viewed side-by-side (Figure 28-12), the differing characteristics of 
each instrument result in drastically different measurement uncer-
tainties (in size, shape, and density):

Figure 28-12. Comparing the 
shapes of the two uncertainty clouds.

 Basic Uncertainty Computation Process for a PCMM Arm

The uncertainty characteristics of a portable CMM arm are even more 
complex, depending on the behavior of the encoder in each joint and 
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the configuration of the arm when the measurement is taken. How-
ever, the computation process follows the same sequence: 

1. The individual joint angles and lengths for each segment are 
recorded with each measurement along with the final point 
coordinate relative to the instrument base.

2. The Confidence Interval set in the Users Options is used in 
conjunction with the Uncertainty Variables set in the instru-
ment properties to determine the range of potential uncer-
tainty in each parameter (Each individual joint’s uncertainty)

3. The point coordinates values are perturbed using a Gaussian 
random number generator (utilizing a Box-Muller algorithm) 
to build a new point coordinate, injecting random error into 
each of these instrument variables. 

4. The process is repeated as many times as is necessary to built 
an uncertainty cloud as large as is requested. 

Figure 28-13. The uncertainty 
cloud shapes for a portable arm.

Uncertainty for Points with Multiple Observations

For instruments that do not provide a distance component, points 
must be built with more than one observation. It is also possible to 
combine additional shots into any point computation. The uncertain-
ty of that point therefore is based upon 2 factors:   

1. The network or instrument placement uncertainty for each 
instrument measuring the point. This uncertainty needs to be 
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determined as part of the network alignment operation. 

2. The composite point uncertainty. Which is calculated based 
up on the size of the overlapping point uncertainty fields. 

Because the instrument placement uncertainty plays such an impor-
tant role in point uncertainty calculations for combined point uncer-
tainties this subject is covered as part of the weighted bundle section 
of the USMN chapter (see “Weighted Bundle” on page 722).                

Measurement Analysis with Uncertainty Fields
This section addresses applications of coordinate uncertainty fields 
beyond the uncertainty in a measured coordinate value.  Often, the 
measurement task is not only to determine XYZ coordinate values of 
points as measured by the instrument, but also to evaluate the true, 
as-built, shape of an object.  In these cases, the coordinate values 
measured by the instrument are only an intermediate result in the 
metrology job.

This means that in order to determine the uncertainty of the actual 
geometrical analysis operation, other methods must be used.  The 
discrete point cloud uncertainty fields are well-suited for such an 
analysis.

Point to Point Distance Uncertainty

The uncertainty in the distance between two points can be comput-
ed with a function within SpatialAnalyzer.  Use the menu selection 
Query >> Sensitivity Cloud to >> Sensitivity Cloud.  Select any two points 
that have uncertainty fields associated with them to complete the 
process.  SA uses the uncertainty cloud from each point to compute 
the geometric uncertainty between the points (Figure 28-14).   

Figure 28-14. Query Sensitivity 
Cloud to Sensitivity Cloud

The analysis includes:
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 ■ Nominal Length. The length between the points

 ■ Uncertainty. The uncertainty in that nominal length reported 
based on the standard deviations of all the distances pairs be-
tween the two uncertainty fields.  

 ■ Min & Max. The minimum and maximum distances between 
the points.  

 ■ Range.  Distance between the min and max distance.

Geometry Fit Uncertainty

The fitting of measured data to geometrical shapes is quite common 
in measurement analysis.  One of the most common is the sphere fit.  
Tooling ball measurement is very common since it is often used to 
corresponding common measurements or transform into nominal 
coordinate systems.  The measurement device may measure several 
hundred points on the tooling ball, perform a best-fit sphere analysis, 
and return the center of the sphere as the XYZ value.  In this case, a 
statement of the uncertainty in the sphere fit should accompany the 
XYZ center point of the sphere.

Using the discrete point cloud representation of the uncertainty field, 
it is a straightforward task to determine the effect of the measure-
ment uncertainty on the resulting geometrical fit.  A description of 
this process follows:

First, a geometrical fitting operation is performed on the actual mea-
surement values, or the optimal common points as determined in 
the simultaneous system combination portion of the USMN solution.  
This result is stored as the baseline for the geometrical properties.  In 
the case of a sphere-fit, the results are a center point (X, Y, and Z), and 
a radius.

Next, the geometric fit operation is repeated for all the points in the 
uncertainty fields.  The result is a list of geometrical parameters repre-
senting the “uncertainty field” of the geometry.  These sets of parame-
ter values may be evaluated using methods similar to the uncertainty 
field numerical evaluations.  By computing the standard deviation of 
each of the variable lists, and applying the desired confidence inter-
val, a fit uncertainty statement may be given.

If the uncertainty fields for the points in the fit contain a different 
number of uncertainty field points, the largest quantity is used in the 
analysis.  When the uncertainty field index exceeds the total number 
of points in the smaller clouds, they just loop back to the first point 
and reuse the cloud.

Sphere Fit Uncertainty Example
The measurement of a tooling ball with a laser tracker is accomplished 
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by sweeping the laser tracker target across the sphere to obtain suf-
ficient coverage for a sphere fit.  Typically, laser tracker targets are 
1.5 inch spheres with a center-mounted retro-reflector.  Figure 28-15 
shows two sets of measurement data on a ½ inch tooling ball.  One 
set shows typical coverage of the sphere while the other shows inad-
equate coverage.

Figure 28-15. Tooling Ball 
measurements using an SMR

Notice that the data is offset from the actual sphere.  This target off-
set is one of the factors that must be properly handled in all mea-
surement analysis.  In the case of a sphere fit, this is accomplished by 
adjusting the objective function so that the optimal solution is one 
where the measured points are ½ of the target diameter away from 
the best-fit sphere.

As discussed previously, the analysis begins with a computation of 
the best-fit sphere for all the actual measured points.  This is stored as 
the nominal value to which all subsequent fits are compared.  Then, 
the first point from each cloud is used and another fit is performed.  
The results are tabulated.  This process is repeated for the second 
point, third, and so on until all the points in the cloud are exhausted.  
The result is a tabulation of sphere fit results.  By applying basic statis-
tics to these results, a statement of their uncertainty is made. In this 
particular case, the entire process was repeated twice, once for the 
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small data set, and then again for the larger data set.  The results of 
this analysis are shown in Table 11.6.

 

Figure 28-16. Sphere Fit Analysis

Sphere Measurement Coverage Comparison

This example not only underscores the importance of adequate mea-
surement coverage when fitting a sphere, but it also demonstrates 
the need for uncertainty analysis.  Depending on the measurement 
instrument and the shape of the uncertainty fields, the uncertainties 
in geometrical fits can be significant.

Cylinder Fit Uncertainty
Applying these methods to other geometrical shapes is a straightfor-
ward process.  In this example, two sets of cylinder measurement data 
are investigated.  The first maintains a thin area of coverage on the 
surface of the cylinder, while the second covers a larger portion of the 
surface.  The analysis methods are identical to those in the previous 
example with the exception of the parameters that are tabulated.  
Figure 28-17 shows the actual measurement data sets used in this 
example and the resulting best-fit cylinder.  Figure 28-18 shows the 
numerical results of the analysis and provides a comparison of the 
two measurement geometries. Notice the reduction in the uncertain-
ty of both the axis of the cylinder and the diameter in the case of the 
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large coverage measurements. 

Figure 28-17. Cylinder Measure-
ments

 

Figure 28-18. Cylinder Fit Uncer-
tainty Analysis

How to Perform a Geometry fit with Uncertainty: 

In order to calculate the uncertainty in the Geometry fit 

1. Use Analysis>Coordinate Uncertainty>Create Point Uncertainty Fields 
to build the uncertainty clouds for your measurements.

2. Use Analysis>Coordinate Uncertainty>Fit Geometries using Uncertainty 
Fields to begin the analysis. 

3. Select the geometry type to use for the Fit. 
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The analysis will be performed and the results reported for review. 
To  save the results externally select the Save to File option or simply 
choose Accept. This will build an event in the tree with the recorded 
statistics that can be added to a report (Figure 28-19).

Figure 28-19. Cylinder Fit Event

Interpreting the Results
The following information is reported when performing a Geometry 
fit with Uncertainty analysis:

Fit summary: 

 ■ Number of points.  (131 points) The number of point selected 
for the  analysis.   

 ■ Uncertainty field count ranges. (1000 to 1000) Each point has 
it’s own uncertainty cloud build prior to the analysis. This field 
states the min and max number of uncertainty points build for 
list of point using in the computation. 

 ■ Confidence Interval. (1.0 sigma or 68.26%)  As uncertainty is 
statistic process, we give the result at 1 sigma in this case. You 
could change this value inside User Option>Analysis>Uncertainty

 ■ Working Frame. (A::WORLD) Result are always given in specific 
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axis, this is the frame used for the result (the active one when 
the analysis was done).  

 ■ Units. ( (mm)/(deg) ) Values without units mean nothing, so 
the results are given using.

Feature Uncertainty Results :

 The computed uncertainty values for the feature:

 ■ Feature Type. (Sphere, Plane, Circle, Cylinder, Line, Paraboloid)

 ■ Center Uncertainty. (X=4.7252, Y=1.9704, Z=0.3409) The com-
ponent uncertainty of the center point along each axis of the 
working frame (Circles & Sphere’s only).

 ■ Diameter Uncertainty. (0.0004in ) The uncertainty in the di-
ameter of the feature (Circle, Sphere, and Cylinder only) 

 ■ Normal Vector Uncertainty. (0.2011(deg.)) 3D angle uncer-
tainty in the normal vector of the feature described.

 ■ Projected Angles. The component representation of the nor-
mal vector of the feature axis:

 ■   Angle about +X from +Y in YZ plane. ( 0.1353) Angle  
  uncertainty about the X axis, trigonometric orientation

 ■   Angle about +Y from +Z in XZ plane. (0.1488) Angle  
  uncertainty  around Y axe, trigonometric orientation

 ■   Angle about +Z from +X in XY plane. (145.2861) An 
  gle uncertainty around Z axe, trigonometric orienta 
  tion. note that it’s normal to have a big uncertainty in  
  rotation about a cylinder’s axis because this position is  
  not constrained. 

 ■ D Uncertainty. (0.0124 [Millimeters]) The 3D equation of a 
plane can be described by Ax+By+Cz+D=0, where D is the un-
certainty in the placement/distance from the reporting frame 
origin (Planes only). 

 ■   Position. (x=-0.258814, y=-0.000017, z=-0.965927)  
  reported origin or centroid location of the plane   
  also resolved by the ABCD notation. 

 ■   Rotation. (Rx=-169.2707, Ry=-10.5442, Rz=134.0061)  
  representation of a planes normal vector relative to  
  the working frame. 

 ■ Percent Coverage. The extent of surface coverage provided 
by the measurements (Sphere’s only). 

 ■ Focal Length Coverage. (0.001) The uncertainty in the focal 
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length (Paraboloid only). 

Computation Statistics:

 ■ Analysis time. (0.1 sec) Statistics calculation take time, espe-
cially if you have a lot of points and larger numbers of uncer-
tainty samples (minimum 300, generally 1000). 

Feature Fit Results: 

The computed statistics of the best fit feature. This section describes 
the position, orientation, and size of the best possible feature fit de-
termined by the uncertainty analysis. 

Deviation Statistics :

The deviation statistics for the best fit feature. 

 ■ Mean. The mean deviation of the points from the feature.

 ■ RMS. RMS = Root Mean Square or the quadratics mean if you 
prefer. 

 ■ Magnitude:   

   |Max|  = 0.049358     |Min|  = 0.049352 (mm) min and max error 

 value in absolute (without + or -)

 ■ Signed   

   Max  = 0.049358       Min  = -0.049356 (mm) min and max error 

 value
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What is USMN

Figure 29-1. Part of a large USMN 
network.

What is USMN?

USMN (Unified Spatial Metrology Network) is an advanced tool for 
combining common measurements for two or more instruments into 
a single instrument network. It has several major benefits over other 
analysis tools, such as a best-fit:

Spatial Analyzer provides one of the most advanced network alignment 
tools on the market (USMN). Through the use of advanced weighting 
algorithms, customized instrument uncertainty and by calculating the 
intersections between 3D uncertainty clouds it provides the most robust 
network alignment  possible. 

Unified Spatial 
Metrology Network
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 ■ It provides a means for calculating a “weighted bundle”: the 
most likely position and orientation for all instruments and tar-
gets in a measurement network.

 ■ It provides the capability of calculating realistic uncertainties 
for measurements in a measurement network.

 ■ It can be used to evaluate the real-world uncertainties of in-
struments on an individual basis.

Let’s consider each of these benefits in order to get a true grasp on 
the benefits of USMN.

Spatial analyzer tutorial: USMn Overview - https://www.youtube.com/
watch?v=kgviSEkMu70

Weighted Bundle

As discussed in the previous chapter on Measurement Uncertainty 
(see “Measurement Analysis with Uncertainty Fields” on page 712), 
each instrument type has its own uncertainty characteristics. By sim-
ulating measurements of a point while inducing normalized random 
error using those uncertainty variables its possible to build uncer-
tainty clouds for points measured by that instrument. This provides 
an accurate estimate of the points uncertainty both visually in 3D as 
well as numerically. Viewed side-by-side (Figure 29-2), the differing 
characteristics of each instrument result in drastically different mea-
surement uncertainties (in size, shape, and density):

Figure 29-2. Comparing the 
Shapes of Two different Uncertainty 
Clouds

Now, consider the situation in which a long part is to be measured. 
Due to its shape, this part might require multiple instrument stations 
along its length. In order to tie all of the measurements into a single 
coordinate system, a number of common points are measured be-
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tween adjacent sets of instruments, and then these points are best-
fit together to determine the overall instrument network. For some 
cases, this method is a perfectly valid approach, and in fact, this is 
the approach taken by other metrology software packages for tying a 
network of instruments together. In particular, fairly small instrument 
networks with low uncertainty requirements can use this approach 
without problems.

However, using best-fit introduces error stack-up, very similar to the 
idea of tolerance stack-up in engineering drawings. This error stack-
up can be significant. Figure 29-3 depicts an instrument network us-
ing a best-fit compared to the true instrument positions (ghosted). A 
slight error for the first set of common points (between Instruments A 
& B) will move the position and orientation of Instrument B out of its 
true position. By fitting Instrument C to Instrument B, not only does 
Instrument C inherit the error from the first set of common points 
(which has now been “leveraged” by its distance from those common 
points), but now errors in the common points between Instruments B 
& C cause even more error to stack up. The end result is a network that 
could potentially be quite different from reality.

Figure 29-3. Positional errors 
resulting from leap-frogging an instru-
ment along a length.

When more accuracy is desired--or when the measurement network 
is elongated, large scale, fairly 2-dimensional, or C-shaped (non-
closed, meaning the first instrument is not tied back to the last), then 
best-fitting is usually inadequate. Some examples of real-world mea-
surements that get significant benefit from USMN include particle ac-
celerator measurements (very large and mostly 2-dimensional), large 
linear measurements with high accuracy requirements (such as the 
catapult rail on an aircraft carrier), and large “open” networks (such as 
measurement of two sides of a building).

Instead of using a best-fit, USMN takes an intelligent weighted bun-
dle approach. USMN examines each common measurement and con-
siders the characteristics of the instruments that measured them and 
their positions in space.  Components of instrument observations 
which are considered to have low uncertainty are assigned a higher 
weight than components that are considered to have higher uncer-
tainty. If a total station and laser tracker measure a common point 
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from different angles, then the angular measurement from the total 
station will be assigned more weight than that of the tracker, and the 
distance measurement from the laser tracker will be assigned more 
weight than that of the total station.

Once these weights are assigned, the instrument transforms are ad-
justed to calculate their most likely positions based on all available in-
formation. The net result is an instrument network that is significantly 
closer to reality than the best-fit network described above.

In summary, USMN considers each instrument’s uncertainty variables 
and perturbs instrument positions in order to get minimal measure-
ment closures on the common points. This is similar to a traditional 
bundle process, except the optimization process uses the estimates 
of the instrument uncertainties and the range of each observation to 
weight the individual contributions for each measurement.

Network Measurement Uncertainties
Instrument measurements (observations) can have uncertainties cal-
culated that indicate the uncertainty of a given measurement relative 
to the instrument. But when instruments are networked together, 
this simple uncertainty no longer applies, because the common point 
position in a networked measurement is really determined by a com-
bination of instruments that measured the common point. In fact, the 
computed common point in the real world never lies on top of any of 
the component observations (because the world is not perfect--un-
fortunately!). This highlights the second major advantage to USMN: 
the ability to calculate “net uncertainties” for common points.

Figure 29-4. The USMN composite 
point. (Note: The error between the 
total station and laser tracker measure-
ments are exaggerated for clarity).

Refer to Figure 29-4. A total station and laser tracker have measured a 
common target in a nest. Due to noise, operator error, and a number 
of other factors reminding us that the world is not perfect, each in-
strument “sees” the target in a slightly different position in space. As a 
result, the measured points end up in slightly different positions.

Not only can USMN calculate the most likely position of the real tar-
get based on instrument characteristics (referred to as a USMN Com-
posite Point), but it can also calculate the uncertainty of that com-
posite point. In Figure 29-4, the composite point is closer to the total 
station’s line-of-sight position (due to lower angular uncertainties of 
the total station), but is also much closer to the laser tracker’s distance 
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measurement (due to less uncertainty in the laser tracker’s distance 
measurement). The uncertainty of the composite point itself has less 
uncertainty than either of the instrument observations, because 
much of the total station’s uncertainty along the line of sight is ren-
dered extremely unlikely based on the laser tracker’s measurement.

“Real-World” Instrument Uncertainties
As mentioned earlier, instrument uncertainty values as published by 
the manufacturer are a good way to compare different measurement 
systems, but they are a poor way to predict real-world measurement 
uncertainty. A number of factors, such as the calibration/performance 
of an individual instrument, the technique of the operator, and the 
measurement environment have significant effects on uncertainty.

Each instrument in SA has associated with it Instrument Uncertainty 
Variables (Figure 29-5). These can be found in the Instrument Proper-
ties window. Uncertainty variables are used to model an individual 
instrument’s uncertainty characteristics.

Figure 29-5. Uncertainty variables 
for a tracker.

If you look at the uncertainty variables for a laser tracker or total sta-
tion, four values are provided (see image). These values together dic-
tate the uncertainties for the horizontal angle, vertical angle, and dis-
tance components for an instrument. They are used in concert with a 
measurement’s relative position from the instrument to determine 
the uncertainty of the individual measurement.

By default, the values assigned to uncertainty variables are experi-
mentally determined, conservative values for a given class of instru-
ment. In other words, they generally give a result that is “in the ball-
park”, but are probably a bit worse (higher uncertainty) than can truly 
be achieved with the instrument. This is done to a) err on the safe 
side, b) avoid conflict with instrument manufacturers, and c) avoid 
the need to continually update data as instruments evolve, which 
could be a time-consuming task.

In order to get the most realistic uncertainties for measurements and 
USMN, it is necessary to use uncertainty variable values that closely 
match the individual instrument, operator, and measurement envi-
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ronment characteristics. But how is this done? Manufacturers don’t 
(and can’t possibly) publish these values, and they differ from one 
instrument to the next and (to a lesser extent) from one operator/
measurement situation to the next.

USMN itself can be used to determine the most accurate values for 
these variables. This is done by setting up a set of monuments, and 
then moving an instrument around through the workspace, measur-
ing each of those monuments in turn.

Consider a situation in which an instrument, its operator, and the en-
vironment is perfect (and therefore would have zero uncertainty). A 
perfect instrument, after having measured all monuments from dif-
ferent positions, would see a given monument in the exact same lo-
cation in space. When fit together (using a traditional best-fit), there 
would be zero error. The observations would lie on top of each other 
perfectly. USMN would see this “perfection” and would report uncer-
tainty variables of zero (no error).

Of course, in reality this never happens. In the real world, an instru-
ment can measure a monument two different times and “see” it in 
a slightly different place. By analyzing the error between measure-
ments of a common point from the same instrument, in different po-
sitions, USMN can perform a complex calculation and determine the 
real-world uncertainty variables for a given measurement situation.

Using USMN
A USMN analysis can be performed by choosing Analysis>Coordinate 
Uncertainty>Unified Spatial Metrology Network. In this same menu is a 
second setting: Unified Spatial Metrology Network with Point Groups which 
is specifically for aligning your network solution to a nominal point 
group. 

Observations and Point Group Requirements for USMN

When setting up a network for analysis with USMN, there are several 
organizational requirements for instruments, measurements, point 
groups, and point names.  The requirements for USMN analysis are as 
follows:

Point Naming and Observation Requirements:
As with any measurement network, common targets must be mea-
sured by more than one instrument to form a network, therefore:

1. Individual point names must be common between groups 
as USMN will associate measurements from different instru-
ments based on point names. 

Note:  A group name does 
not need to include a specif-

ic reference to the instrument 
that made measurements to the 
points contained within it.   The 
designation of S1, S2…SN used 
above is to illustrate a convenient 
means of organizing the data for 
USMN analysis.
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2. Points in different groups with the same name must rep-
resent the same target. For example, MeasStation1::P1, 
MeasStation2::P1, … MeasStationN::P1 will be combined to 
compute the composite point P1.

Points without measurements are ignored, unless the point group is 
included as a ‘Nominal Group.’  Therefore:

3. A specific point in a given point group should have observa-
tions from only one instrument.

An instrument can make more than one measurement to a specific 
point. As an example, an instrument can have a front and back sight 
to a point or an instrument might have N front sight measurements 
to a point. Observations that are marked as ‘ignored’ are not included 
in the USMN network. The measurement details dialog for a point 
provides an interface to determine whether or not an observation is 
ignored.

Consider an example tree for a job ready for a USMN network as seen 
in the following figure (Figure 29-6).

Figure 29-6. Organizational setup 
for a USMN.

 ■ Points 1 and 2 (in the Station1 group) have no common mea-
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surements with other instruments.

 ■ Points 4, 5, 6, and 7 are shared with Station2.

 ■ Point 9 is shared by Station2 and Station3.

 ■ Point 10 is shared by Station2, Station3, and Station4.

 ■ Points 11-13 are shared by Station3 and Station4.

To help identify potential problems with point names, a warning dia-
log will display showing the Network Build point and instrument list-
ing. This dialog helps to identify  any potential problems when you 
first start the USMN process (Figure 29-7). You may see something line 
the following: 

Figure 29-7. USMN Network Build 
Settings

In the above dialog point groups are marked in red or blue to provide 
a warning that a user may want to exclude them. 

 ■ Red. Point groups marked in red indicate that there could be 
a potential collision. The instrument measured a point of the 
same name multiple groups. These points must represent the 
same target or be removed from consideration.

 ■ Blue. Points only measured by a single instrument are marked 
in Blue. These points do not contribute to the network solu-



729

CHAPTER 29 ■ UNIFIED SPATIAL METROLOGY NETWORK

tion and excluding them will increase the solution speed. Use 
the Check box to easily exclude all points measured by a single 
instrument. 

The primary output from USMN is a Composite Point Group. This 
group contains the optimal point coordinates (the most likely posi-
tion of the points) after solving the network. Inputs to USMN include 
both the instruments and their measurements. For a measurement to 
affect the calculation, it must have been measured from multiple in-
strument stations. The observations from different stations are made 
into different point groups, but should have the same target name.

USMN Dialog

The primary purpose of the USMN dialog is to help you optimize the 
network confidently and get the best Composite Point Group pos-
sible from the instrument stations and measurements. To do this, it 
provides many controls all accessed directly through the main dialog. 
The window is composed of 7 main parts (Figure 29-8).

Figure 29-8. The USMN dialog.

   1. Instrument Section
This section lists the instruments whose measurements are includ-
ed in the USMN network solution. Instruments can have different 
weights applied. So, for example, if one instrument station was set 
up in an unstable location, i.e. near a HVAC blower, up high on a large 
tripod, on a separate concrete pad, etc. The influence of that particu-
lar station on the entire network could be reduced by reducing the 
instrument’s weight relative to the other stations. 

Each instrument has a checkbox indicating whether that instrument 
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is allowed to move during the calculation. A USMN bundle (or any 
bundle, or that matter) is a  relative solution. That is, the solution can 
be reached relative to any instrument. As a result, all instruments may 
be checked (meaning all instruments will be perturbed to find the 
solution) or one may be unchecked (so that the solution is reached 
by perturbing all instruments EXCEPT the unchecked instrument). 
In both cases, the same end result is reached for the network itself, 
although the networks will end up in different places in space (and 
the uncertanties will be relative to different baselines). Regardless, al-
lowing all instruments to move will typically take longer to solve, but 
the resulting point uncertainties will be more uniform and represen-
tative of a network in which no one instrument is more important 
than another. Although the network solution is the same, the calcu-
lated uncertainties for the USMN Composite points will be different, 
because they are relative to different baselines. However, the relative 
uncertainties (differences between uncertainties) between each pair 
of points will remain the same.

More than one instrument may be fixed (unchecked) during a solu-
tion, although this is typically only done in rare cases and is generally 
not recommended, as the end result is a solution that is not an ideal 
spatial representation of an instrument network.

Figure 29-9. Instrument Section

An individual instrument in this list may be double-clicked to access 
specific instrument properties (Figure 29-9). This instrument Proper-
ties dialog provides access to the following settings:
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 ■ Weight Factor. The overall weight applied to the instrument. 
(weights can also be edited directly in the USMN dialog). 

 ■ Moving. This sets the check box determining if a particular in-
strument is considered to moved as part of the network.

 ■ Degree of Freedom. This set of 7 controls allows restriction 
of motion of a particular moving instrument as part of the 
network. Only checked fields are allowed to move. (note: XYZ 
component restriction are relative to the working frame, for in-
strument frame reference align the instrument model with the              
working frame prior to running the USMN).

 ■ Component Uncertainty. Provides direct access to the instru-
ments Uncertainty Variables. 

 ■ Point Computation Error Function. Error can be computed 
using the instruments uncertainty variables. If you choose to 
do so weights an be applied independently to each  variable. 
Alternatively error can be computed with respect to the XYZ of 
the working frame. 

In addition to individual instrument configurations there is also and 
option to choose between two Instrument Solution Reference Frame set-
tings. 

Figure 29-10. Instrument Solu-
tion Reference Frame Setting

 ■ Instrument Frame. In most cases, this is the best choice. This 
allows each instrument to be rotated independently about 
their own standing axis to find the ideal network solution and 
is the setting SA has always offered. 

 ■ Working Frame. This option provides a means to align instru-
ments relative to each other in any orientation and hold that 
orientation independent of their own standing axis.

2. Measurement Section
This section shows the current statistics with respect to each point 
in the network. These statistics will recompute as the network is ad-
justed and recomputed. This measurement-specific information is 
provided in number of columns which are described below (Figure 
29-11).
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Figure 29-11. Example Measure-
ments

The point list is automatically organized in the interface. Points with 
the highest ranking are listed first. A high ranking indicates a point 
with a higher chance of problems. Points with lower ranking suggest 
the target solution is better. However, each column can be sorted 
from either high to low or low to high by clicking on the column title. 

 ■ Weight. Each measurement can have a weight applied. If a 
point is considered less important or perhaps more erroneous, 
its weight can be reduced.

 ■ Point. Each point measured by an instrument in the USMN net-
work is listed by name.

 ■ Max Err. The maximum error is listed for each point that has 
been measured by more than one instrument. This depicts 
the maximum error between any individual measurement of a 
point and its optimal value.

 ■ Ranking. Displayed as a percentage, this indicates the per-
centage of the expected 3-sigma envelope consumed by the 
maximum measurement residual. This is an efficient method 
of determining which points may have measurement outliers. 
A point with a ranking of 100% has observations which are 
consuming the entire 3-sigma envelope. Points with smaller 
rankings are more tightly clustered around the optimal value. 
Lower rankings indicate better measurements.

 ■ Ux/Uy/Uz/Umag. The component and magnitude uncertain-
ties (in the active coordinate frame) for the optimal point. 
(These values only appear after an uncertainty field analysis 
has been performed).

 ■ Meas. A list of the instruments that have observations for a 
given point.  For instance, if a point shows 0 _ _ 3, this indicates 
that instrument index 0 and 3 each have a measurement for 
that point, while instruments 1 and 2 do not.

Further detail for a single point can be obtained by double-clicking 
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the point in the list (Figure 29-12).

Figure 29-12. Measurement 
Section- Expanded

The Point Properties dialog displays the contributing shots used to 
compute the network point. It provides control over:

 ■ Overall Weight. The weight used in the USMN for the point. 

Specific details on each point are displayed in the following columns: 

 ■ Weight. The weighting factor applied to the particular point, 
this weight is used in the composite point computation.

 ■ Instrument. Instruments that measured the point.

 ■ Error.  Component error (Err 1, Err 2, Err 3) shows the error con-
tribution per component.

 ■ Mag. The magnitude error for each point used in the compos-
ite point computation. 

 ■ Ranking. The percentage of the expected 3-sigma envelope 
consumed by the maximum measurement residual.

3. Solve Section
This section contains the parameters and controls for actually calcu-
lating the USMN solution (Figure 29-13). They are summarized below:
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Figure 29-13. Solve Section 
Controls

 ■ Auto Solve. This button performs a “Best-Fit then Solve” (see 
below), trims outliers at 100% (see below), then performs a 
“Solve” (see below). This automated process is recommended 
for well-understood networks and in applications where the 
process has to be automated. It is not recommended when first 
optimizing an unfamiliar network of measurements. Anytime 
outliers are eliminated from the network, the causes and de-
tails should be characterized and documented.

 ■ Do This Automatically. When the USMN dialog is displayed, 
an Auto Solve is automatically performed once.

 ■ Best-Fit Only. Performs a best-fit of the networked points. This 
is equivalent to performing a traditional best fit. Performing 
a best-fit prior to initiating the USMN solve drastically speeds 
up the calculation, because it provides for a much better initial 
starting point for the calculation.

 ■ Best-Fit then Solve. Performs a Best-Fit (see above) and Solve 
(see below) in one step.

 ■ Solve. Initiates a USMN calculation from the instrument’s cur-
rent positions. R-Click to Enable/Disable CUDA devices pro-
cessing (see “NVIDIA CUDA Devices” on page 738).

 ■ Instrument Settings. Allows you to modify properties for all 
instruments at one time.

 ■ Trim Outliers. Removes points or observations exceeding a 
specified Ranking threshold from the USMN solution. Recall 
that ranking is an indicator of the quality of a point. Points 
above the ranking threshold can either be weighted to zero 
or removed from USMN entirely. Therefore, this is an effective 
means for preventing poor measurements from tainting the 
USMN solution.

 ■ Exclude Measurements. Any measurements that should not 
be included in the USMN calculation can be excluded with this 
button.
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4. Uncertainty Field Analysis Section
USMN does not by default calculate the uncertainties of the resulting 
optimal (USMN Composite) points, because this calculation can take 
a fair amount of time. As a result, you must initiate this calculation 
yourself (Figure 29-14).

Figure 29-14. Uncertainty field 
analysis controls.

Uncertainty field analysis works by using the instrument uncertainty 
characteristics to slightly perturb measurements following a realistic 
Gaussian distribution. Each iteration of perturbed measurements is 
then treated as a separate USMN network. Each iteration is solved in 
turn, which allows for statistical generation of optimal point uncer-
tainties.

 ■ Samples. Specify the number of perturbations, or iterations, to 
perform. Higher numbers take proportionately longer to solve, 
but have more accurate uncertainty values. It has been statisti-
cally determined that 300 or more samples will provide results 
within 5% of the “statistically true” value, so 300 is considered 
the default. About 10,000-15,000 samples are required to get a 
result within 1% of the statistically true value.

 ■ Time Limit. When checked, the uncertainty field analysis will 
time out at this limit, regardless of the number of samples re-
quested. In this case, the number of completed iterations will 
be used.

 ■ Begin. Initiates the Uncertainty Field Analysis.

5. Summary
The summary section lists a general summary of the USMN calcula-
tion with the current settings. Each time the USMN network point list 
is updated or edited these value should be used as a review of the 
overall solution. The summary provides the following results (Figure 
29-15): 

Figure 29-15. Example  Summary

pointing error: 
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 ■ Overall RMS. The RMS deviation of each measured point to 
the solved network points. 

 ■ Average. The average of each measured point to the solved 
network points.  

 ■ Max. Largest Point Error for the network. The point name with 
this showing this error is listed in parenthesis.  

 ■ System Solution Time. Time to arrive at the network solution. 

 ■ Robustness Factor.  Is an indicator of the numeric instability 
of the solution and is the inverse of the Conditioning Number. 

To understand the Condition Number, it becomes necessary to know 
a bit about singular value decomposition, singular values, eigen vec-
tors, and eigen values – the sort of stuff that causes eyes to glaze over.  
The short description is that the process of numerical error minimi-
zation produces a system of matrices that are subjected to Jacobian 
operators and SVD to produce a set of orthogonal gradient vectors 
defined in solution parameter space that provide a direction towards 
a minimum (hopefully the global minimum) in solution space.  Once 
the solution has moved to the solution point, these gradient vectors 
should be such that any movement away from the solution point 
will make the error worse.  Ideally there will be as many orthogonal 
unique gradient vectors as there are solution parameters – the direc-
tion of steepest gradient will be a combination of these vectors.

The influence of each of these vectors is scaled by singular values, a 
large value means that small changes in the associated vector direc-
tion will have large impact on the solution result.

A small value means that the associated vector direction will have 
less impact on the solution result – in other words, the solution could 
wander further along this direction without substantially changing 
the solution result.  Consider a point on a plane, (Tx, Ty, and Rz) are 
still unconstrained and could take on any value and still retain its sta-
tus as a planar point – in solution space, a similar condition specific 
to a particular solution parameter means that that particular solution 
parameter (or some combination of solution parameters) is redun-
dant.

The ratio between the largest and the smallest singular value is the 
Condition Number – condition numbers nearer to unity are more 
robust and those that are very large are not as robust.  A condition 
number of 10000 (robustness = 0.0001) means that the largest con-
tributing vector has 10000 times more effect than the smallest.  This 
means that IF the smallest of the solution gradient vectors was only 
dependent upon one of the solution parameters which was not oth-
erwise used by any of other solution gradient vectors, then that pa-
rameter could vary significantly without significantly changing the 
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solution results – this would be a poorly resolved parameter.  Even 
worse would be that one or more of the solution gradient vectors 
might not affect the solution result at all – each of these vectors will 
result in a negative integral robustness contribution. 

A small Robustness (large Condition Number) value greater than zero 
is considered satisfactory for USMN.

A negative Robustness indicates a reduced number of degrees of 
freedom in solution parameter space along the solution gradient at 
the solution point – generally means redundant solution parameters 
relative to measurements (or alternately, insufficient number of mea-
surements to resolve solution parameters). Robustness = -3 would be 
that three of these vectors had no effect on the solution AT THE SO-
LUTION POINT.  This could indicate that the measurements taken are 
insufficient to resolve all of the solution parameters or that the solu-
tion is at a singular location.

 ■ Unknowns. The number of instruments in the network that 
are free to move times the 6 degrees of freedom considered 
in the solution (the first instrument in the list is not counted). 

 ■ Equations. The sum of the number of points from each of the 
instrument used in the network, times 3 to provide a 3 dimen-
sional solution.

Uncertainty Magnitude: 

 ■ Average. Average of the uncertainty magnitudes for each of 
the included network points

 ■ Max. Largest point uncertainty for the network. The point 
name with this showing this error is listed in parenthesis.  

 ■ Confidence Interval. The Sigma uncertainty interval used for 
the calculation. 

 ■ Samples. Number of samples used for each point in the com-
putation.

 ■ WCF. Working Coordinate Frame used to determine XYZ un-
certainty.

 ■ Uncertainty Analysis Time. Time to compute the uncertain-
ties for the network. 

It also provides access to information about scale bars included in the 
USMN calculation.

6. Reporting Section
This section provides a set of simple export options and some ex-
tremely sophisticated analysis tools for reporting results (Figure 29-
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16).

Figure 29-16. Reporting Section

 ■ Reporting. Three buttons provide a means to export the USMN 
results as a text file, and HTML file or an Excel file. These results 
are the same as those saved in the Event.

 ■ Instrument Uncertainty Analysis. This button computes the 
individual instruments uncertainties based upon the network 
solution (It requires Uncertainty Field Analysis to be performed 
first). 

 ■ CoVar. Analytical uncertainty covariance matrices for both 
points and instrument base locations can now be generated as 
*.csv file output.

The covariance can be reported as either the Error or Uncertainty.  For 
large networks that take a prohibitively long time to solve with the 
Monte Carlo approach (Uncertainty Field Analysis > Begin), the point 
uncertainties can be approximated with the Uncertainty Covariance 
matrices.

NVIDIA CUDA Devices
Using NVIDIA CUDA (Compute Unified Device Architecture) cores for 
USMN calculations provides an enhanced parallel processing option. 
It allows the use of the hundreds to thousands of cores contained 
within the GPU. On a decent NVidia graphics card (or alternately a 
Tesla module) this can significantly reduce the solve time for larger 
USMN networks. This requires a quality card and 64-bit SA.

There is an on/off option for this setting as a right-click function on 
the Solve button. This will activate CUDA devices if any are present and 
save the configuration to the registry so that it will persist between 
jobs. When CUDA devices are enabled/disabled, this transaction is 
logged so that the user can inspect the log for status.

Small USMN systems will not benefit from using CUDA devices.  Each 
USMN solution sequence will take approximately 4 iterations to com-
plete and the setup time to initialize and transfer data to the NVIDIA 
CUDA device simply adds more overhead time than is gained. So 
even if CUDA processing is enabled it will be ignored if an iteration 
takes less than 2 seconds. 

Large USMN systems (30 instruments or more with 30 points or more 
per instrument) will benefit greatly from using NVIDIA CUDA devices. 

A test showed the following results:
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       A network featuring 551 instruments with an average of 30 points 
per instrument and solving this system on a dual XEON (8 CPU cores)       
running at 2.39 GHz required 40 hours to solve (5 iterations at ~8 
hours each).  Solving this same system using NVIDIA CUDA devices       
(QUADRO P6000) reduced the solution time from 40 hours to 23 min-
utes.

Instrument Uncertainty Analysis
Once an Uncertainty Field Analysis is performed for a network this 
network solution can then in turn be used to determine the result-
ing uncertainty parameters in the Instruments that measured those 
points based upon the solved network points. Press the Instrument 
Uncertainty Analysis button to access the results (Figure 29-17). 

Figure 29-17. Instrument Uncer-
tainty Analysis

This uncertainty is then reported per instrument for each of 3 Uncer-
tainty Variable in the instruments properties (or XYZ for instruments 
with many variables). 

The default instrument uncertainty values are generic values which 
have proven over time to provide an accurate estimate of the uncer-
tainty of an instrument in an unknown environment under unknown 
conditions. However, if you wish to determine the best possible accu-
racy values for a particular instrument under your conditions you can 
use USMN to do so, using the following procedure: 

1.  Establish network of 8 or more fixed monuments to serve as 
control points.

2. Measure all the control points from at least 4 different physi-
cal locations using the same instrument, adding new stations 
to the job file for each instrument plant.

3. Perform a USMN on the network, compute the Uncertainty 
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Field Analysis and check the Instrument Uncertainty Analysis 
results.

4. Copy the resulting values into your instruments properties, 
updating the instruments Uncertainty Variables.

5. If desired, rerun the USMN Analsysis with the new Instrument 
Uncertainty Variables and compare the resulting Instrument 
Uncertainties. 

Here is an example graph of the change in accuracy (Vertical & Hori-
zontal Angle and Distance) as a result of 10 iterations of this process 
with an inhouse instrument. As you can see the values converge to a 
stable condition with repeated iterations. 

Figure 29-18. Angular & Distance 
Uncertainty Convergence

If you look at the change over the ten iterations, it quite small—less 
than the resolution of the encoders (Horizontal Angle Change ~0.06, 
Vertical Angle Change ~0.001 arcseconds and Distance Change 
~0.00012”). The initial “guesses” for this solution (which are the de-
fault values in SA) turn out to be good enough to get close on the 
very first iteration. 

This provides a means of evaluating the performance of your particu-
lar instrument under particular real-world conditions.  Those values 
can then be used for the instrument uncertainties when you perform 
your true measurements and provide an even greater confidence 
that the uncertainty in your points reflect the results you will see with 
your instrument. 

The Instrument Transform Uncertainty Fields are also computed and 
reported in the event as part of this process. A graphical representa-
tion of the position and orientation of this transform uncertainty can 
be displayed using Analysis> Coordinate Uncertainty> Show Instrument Trans-
form Uncertainty Fields (USMN). This will hide the instruments and display 
only the uncertainty graphics while enabled.

Tip:  Uncertainty Settings can 
easily be copied between in-

strumnets using the following 
command:  Analysis>Coordiante 
Uncertainty>Instrument Uncertainty 
Settings>Copy Settings  Between In-
struments
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Covariance Analysis
Analytical uncertainty covariance matrices for both points and instru-
ment base locations can now be generated as *.csv file output (as of 
SA version 2015.11.06).

Methods employed are those as described in the paper “On the Rep-
resentation and Estimation of Spatial Uncertainty” by Randall C. Smith 
and Peter Cheeseman published in “The International Journal of Ro-
botics Research”, Vol. 5, No. 4, Winter 1986.

Uncertainty covariance report includes:

 ■ Composite point uncertainty covariance matrix data relative to 
working frame

 ■ Instrument base uncertainty covariance matrix data relative to 
world frame

 ■ Chi-square “Goodness of Fit” assessment (values << 1 indicate 
data too good to be true, values >> 1 indicate measurement 
errors much greater than expected)

 ■ Robustness:  Solution solver SVD ((min(singular values) / 
max(singular values)) -- negative values reflect the number of 
redundant degrees of freedom

 ■ Singular value tolerance threshold (minimum value an singular 
value is permitted to assume to be considered non-zero)

 ■ Number of input equations

 ■ Number of ignored equations

 ■ Number of active equations

 ■ Number of variables

 ■ Number of independent variables

 ■ Working frame

 ■ Composite instrument base parameter covariance matrix

 ■ Composite instrument base parameter correlation matrix

    The input points used to develop a composite point are used to gen-
erate an error covariance matrix.  This data may be helpful in terms of 
evaluating the data spread of the input points about the composite 
point. This data will not be generated for any composite point with 
less than three input points.

R-Click on “CoVar” button will allow the user to experiment with dif-
ferent values of singular value tolerances (default is 0.01).     

7. Apply Results Section
The Apply Results section controls how the calculated results are ap-
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plied to the job file (Figure 29-19).

Figure 29-19. Apply Results 
Section

 ■ Create Composite Group. When checked, creates the optimal 
(USMN Composite) point group, using the name specified in 
the user entry field.

 ■ Create Point Uncertainty Fields. When checked, applies un-
certainty fields (calculated via the Uncertainty Field Analysis) 
to the USMN composite points. These fields represent the re-
sulting uncertainty of the network points.

 ■ Update composite point offsets. This option provides the 
ability to pass point offsets on to the composite point group 
provided that all the input shots have the same offsets.

 ■ Apply instrument and point group transforms in SA. If 
unchecked, no instruments or points in SA will be physically 
moved in the file.

 ■ De-Activate measurements weighted to zero. If checked, 
any measurements that have been weighted to zero in the 
Measurement Section will be deactivated in SA.

Basic USMN Solution Process

The following describes the steps for a basic USMN solution process, 
without calculating uncertainty fields for the USMN composite group.

1. Ensure that the job file matches the requirements in Observa-
tions and Point Group Requirements for USMN.

2. Select Analysis>Coordinate Uncertainty>Unified Spatial Metrology Net-
work.

3. When prompted, select the instruments to include in the 
USMN network, then press Enter.

4. The USMN dialog will be presented (see USMN Dialog).

5. Ensure that the instrument settings are correct (moving/non-
moving, weights, DOF constraints, etc).

6. Click Best-Fit then Solve.

7. Examine the max error and ranking values.
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8. If desired, click the Trim Outliers button and trim any measure-
ments beyond your desired ranking.

9. Click the Solve button and observe the results.

10. Verify that Create composite group is checked.

11. Click the Apply button. The instruments/point groups will be 
located, and a USMN Composite point group will be created 
representing the ideal position of each meausurement.

For a more in-depth example on basic USMN, see the tutorial Basic 
USMN.
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About Measurement Plans
Measurement Plans (MPs) is the name given to the scripting capabil-
ity built into SpatialAnalyzer. MPs are similar to macros in that they 
can repeat a series of steps for you—but the similarities end there. 
MPs actually have significantly more capability—scripts make calcu-
lations, branch to different behavior based on decisions, gather user 
input, read and write to files, and execute custom code. In that sense, 
scripts share more traits with a programming language than a macro.

However, true programming languages have a complex syntax, often 
take many years to master, and have a high learning curve. MPs are 
designed to share as much capability as possible with programming 
languages while still dramatically lowering the learning curve com-
pared to learning a programming language.

Scripts can vary from simple utilities constructed in just a few minutes 
to comprehensive inspection plans that provide go/no-go automa-
tion and drive other machinery such as robots or CNC machines.

MPs are available for editing and executing on SA Ultimate or higher. 
They cannot be created, edited, nor executed on SA Professional.

SpatialAnalyzer contains a powerful scripting environment that gives 
you the ability to automate tasks ranging from measurement, to analy-
sis, and reporting. Scripts can introduce efficiencies into your metrology 
processes that cannot be overstated.

Measurement 
Plans
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Running a Measurement Plan
Scripts can be created in two formats:

 ■ Embedded. An embedded MP is stored in the SA job file and 
listed in the tree (Figure 30-1).

 ■ External. An external MP is stored as a separate .MP file on the 
file system. It is completely independent of any job file.

Both embedded and external scripts have essentially the same func-
tionality and behavior (although there are some advanced reasons 
why you might choose one over the other).

Figure 30-1. An embedded MP.

If you would like some example scripts to view or run, they are in-
cluded with the SA install in the Samples/MP Scripts folder.

To Run an External MP:

1. From the SA menu, select Scripts > Run Measurement Plan.

2. Navigate to the .mp file and select it.

3. The script will load into the MP Bar (Figure 30-2). If the auto-run 
Mps option is enabled (see “To Enable/Disable Auto-Running 
of Scripts:” on page 747), the script will begin executing im-
mediately. If this option is disabled, you must click the run 
button in the MP Bar to run the script.

Figure 30-2. A script ready to run 
in the MP Bar.

To Run an Embedded MP:

1. In the tree, locate the script in the Measurement Plans cat-
egory (see Figure 30-1) and double-click it, or right-click it and 
select Run from the context menu.

2. The script will load into the MP Bar (Figure 30-2). If the auto-run 
Mps option is enabled (see “To Enable/Disable Auto-Running 



747

CHAPTER 30 ■ MEASUREMENT PLANS

of Scripts:” on page 747), the script will begin executing im-
mediately. If this option is disabled, you must click the run 
button in the MP Bar to run the script.

To Run a Script from the MP Editor:

1. Load the script into the editor.

2. Do one of the following:

 ■ Click the run button at the top of the editor,

 ■ From the editor’s menu, select File > Run, or

 ■ Press Ctrl + R.

3. The script will load into the MP Bar (Figure 30-2). If the auto-run 
Mps option is enabled (see “To Enable/Disable Auto-Running 
of Scripts:” below), the script will begin executing immediate-
ly. If this option is disabled, you must click the run button
in the MP Bar to run the script.

To Enable/Disable Auto-Running of Scripts:

1. Click the User Options icon or press Ctrl+U (default key-
board shortcut.

2. Navigate to the Automation tab. Toggle the auto-run Mps (applies 
for double-click in tree and Scripts>>run Measurement plan) 
option.

Quick MPs
You can assign Measurement Plan scripts to the menus (Figure 30-3), 
so that any script can be executed by selecting it specifically from the 
SA menu (or from a toolbar, if you’ve customized the SA user inter-
face). You can assign up to 30 scripts to Quick MP slots for easy execu-
tion.

This immediate execution of Quick MPs is excellent for listing a library 
of commonly-used scripts or for testing a script during development.

Warning:  Making chang-
es to Quick MP slots 
modifies your User Inter-

face Profile. Changes must be 
saved to your UI profile in order to 
retain the settings the next time 
SA is run.
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Figure 30-3. Scripts have been 
assign to Quick MP slots 1, 2, and 3.

To Assign a Script to a Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. In the QuickMP Assignments dialog, click the Add button.

3. In the Quick MP Assignment window, specify the parameters 
for the script:

 ■ ID. Which of the 30 slots (from one through 30) should be used 
for the script.

 ■ Display Name. The name for the script that you’d like to use in 
menus or toolbars.

 ■ Location. Select embedded Mp if the script is embedded, or ex-
ternal Mp File if the script is an external file.

 ■ Collection/Name/File. If the script is embedded, specify the 
collection containing the script and the name of the script it-
self as it appears in the tree. If the script is external, the path to 
the script file to run.

4. Click OK to accept the settings, then OK again to close the 
QuickMP Assignments window.

5. Save the changes to the UI profile as specified in “Custom UI 
Profiles” on page 62.

If you now select Scripts > Quick MP, you should see your script listed.

To Edit a Script’s Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. In the QuickMP Assignments dialog, select the Quick MP to 
modify and click the Edit button.

3. Specify the desired settings as indicated in “To Assign a Script 
to a Quick MP Slot:” on page 748.

4. Click OK to accept the settings, then OK again to close the 
QuickMP Assignments window.

 zTip: In most cases, you should use 
external scripts with Quick MPs.
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5. Save the changes to the UI profile as specified in “Custom UI 
Profiles” on page 62.

To Remove a Script from a Quick MP Slot:

1. In the menus, select Scripts > Quick MP > Configure Quick MPs.

2. Select the Quick MP script to delete, then click the Delete but-
ton.

3. Save the changes to the UI profile as specified “Custom UI Pro-
files” on page 62.

To Run a Script from a Quick MP Slot:

1. In the menus, select Scripts > Quick MP.

2. Choose the script you’d like to execute.

3. The script will execute immediately, even if the auto-run Mps 
option is disabled (see “To Run an External MP:” on page 746)

To Assign a Script to Any Menu or Toolbar:

1. Assign the script as a Quick MP as described in “To Assign a 
Script to a Quick MP Slot:” on page 748.

2. Assign the Quick MP slot’s menu item to a toolbar or menu as 
described in “Customizing Toolbars & Menus” on page 64.

Working With Measurement Plans
Measurement Plan Scripts are not text-based. Instead, SA uses a 
graphical editor for writing scripts, which is not as basic as a macro 
recorder but also not as complicated as a text-based scripting envi-
ronment.

As described in “Running a Measurement Plan” on page 746, you 
can create your script as an embedded script or as an external script. 
There are advantages and disadvantages to each.

Embedded Measurement Plans:

 ■ Are stored as part of the SA file, therefore are easier to find and 
bundle with a script.

 ■ Are easier to execute and edit, since you can access them di-
rectly from the tree.

 ■ May not work if you need to create a new SA file or load an SA 
file as part of the script, since such actions will clear the embed-
ded scripts from the tree.

 ■ Make version maintenance, reuse, and distribution of scripts 
more difficult, since you need to export the script to a separate 
file in order to use it with other SA files.

Tip:  In general, we recom-
mend using external script 

files unless your script is fairly 
short and simple.

Warning:  You cannot use 
embedded scripts that 
have more than one 

script (such as a script with a sub-
routine) with an “Open SA File” or 
“New SA File” command. An ex-
ternal script is necessary in such a 
scenario.
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External Measurement Plans:

 ■ Are stored as a separate .mp file, therefore you must navigate 
to the file to execute it.

 ■ Are able to work with any scripting commands—creating a 
new SA file or loading an existing file does not create problems.

 ■ Are much better suited to script maintenance, reuse, version-
ing, and distribution.

You can start writing an embedded script or start writing a script in 
an external file. Likewise, you can export an embedded script to an 
external file or import an external script file as an embedded script.

To Start a New Embedded Measurement Plan Script:

1. In the menus, select Scripts > Embedded Measurement Plans > Create 
New.

2. Specify a name for the new script. This is how the embedded 
script will be named in the tree.

3. The MP Editor will appear, ready for input.

To Start a New Measurement Plan Script in an External File:

1. In the menus, select Scripts > Create/Edit Measurement Plan.

2. The MP Editor will appear, ready for input.

To Import an External Script File as an Embedded Script:

1. Select Scripts > Embedded Measurement Plans > Embed existing .MP 
file.

2. Navigate to the script file to embed and select it.

To Export an Embedded Script to an External File:

1. Right-click the script in the tree and select Export from the con-
text menu.

2. Specify a file name for the new external file, then click Save.

To Edit an Existing External Script File:

1. From the menu, select Scripts > Create/Edit Measurement Plan...

2. The MP Editor will appear.

3. Do one of the following:

 ■ In the editor’s menu, select File > Load, or

 ■ Press Ctrl + L.

4. Select the desired file.

To Edit an Existing Embedded Script:

1. Right-click the script in the SA tree and select Edit from the 
context menu.
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To Start a New Script in an Existing Editor Window:

 ■ From the editor’s menu, select File > New, or

 ■ Press Ctrl + N.

To Save Your Script:

 ■ From the editor’s menu, select File > Save or File > Save As..., as 
applicable, or

 ■ Press Ctrl + S (Save) or Ctrl + Shift + S (Save As...).

Protecting Scripts

Once you have finalized a script, you will often want to protect it from 
accidental (or intentional) modification. You can password-protect a 
script so that it cannot be modified. Once protected, the script will 
no longer load into the editor. However, protecting a script does not 
prevent it from being executed, or from viewing the commands used 
to create the script.

To Password-Protect a Script:

1. Load the script into the editor.

2. From the editor’s menu, select Protect > Set Password.

3. In the Set Password dialog, enter the desired password twice, 
then press OK.

4. Save the script.

To Open A Protected Script:

1. Load the script into the editor as usual.

2. When prompted, enter the password for the script.

To Remove Protection from a Script:

1. Load the script into the editor. You will need the password for 
this operation.

2. From the menu, select Protect > Remove Password.

3. Confirm the operation.

Generating SDK Code

The MP Editor has the capability of automatically generating the SDK 
code needed to repeat a script’s functionality in both the C++ and 
Visual Basic languages. This code can then be copied, pasted into an 
SDK project, and (with limited changes) be executed directly in com-
piled code. For more on the SDK, refer to the next chapter (SA SDK).

To Generate SDK Code for a Script:

1. Load the desired script into the editor.
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2. From the editor’s menu, select SDK > View SDK Code.

3. In the SDK Code Viewer dialog, select the desired language, 
Visual C++ or Visual Basic.

4. The code will automatically be copied to the Windows clip-
board and can be pasted directly into any text editor or Inte-
grated Development Environment.

The MP Editor
If you will be writing Measurement Plans, you’ll be doing it in the MP 
Editor (Figure 30-4). Some companies even have employees whose 
primary (or only) job responsibility is to write Measurement Plans—
these people may spend most of their working hours in this editor!

Figure 30-4. The MP Editor.

Command List

Variables/FindResults/Connections View

Step List

For those used to the legacy MP Editor in SA 2014.04.15 and earlier, 
this new editor has an enormous number of improvements. The most 
notable are:

 ■ Command list and script are now integrated into one window. 
More screen real estate is devoted to your script.

 ■ Multiple commands can be displayed at once for easy refer-
ence.

 ■ Every command is a collapsable tree item, allowing easy ex-
pand/collapse behavior. This is particularly useful for “keeping 
track” of commands that you haven’t finished editing.

 ■ Commands can be rearranged through easy drag and drop.

 ■ Commands can be locked to prevent changes once they’re fi-
nalized.

 ■ Changing entry methods (such as switching from “Enter Meth-
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od” to “Reference” is dramatically faster than before with quick-
select buttons.

 ■ Most references can be selected directly in the step editor (in-
stead of the large table that was displayed in older versions), 
causing less disorientation.

 ■ Long comments can be seen completely, whereas they would 
be obscured in the old editor.

 ■ A variable list shows any defined variables and their types for 
reference.

 ■ A debug mode allows you to get “MP Watcher” functionality 
directly in the editor. You can see argument values directly in 
the editor as the script executes.

 ■ Current variable values are displayed while in debug mode.

 ■ A Connections viewer allows you to easily view commands that 
reference or are referenced by the current command, and jump 
to those steps quickly.

 ■ Lots of keyboard shortcuts for loading, saving, running, ex-
panding and collapsing, selecting, etc. are available—making 
for a fast workflow.

 ■ Automatic expansion and collapse of applicable commands 
(an option) makes for quick selection of references.

 ■ An “expert mode” suppresses warning messages about dele-
tion of commands.

 ■ Configurable alternating row colors for less eyestrain.

 ■ Automatic refresh of subroutine arguments.

 ■ Faster setting of breakpoints/comments.

 ■ More obvious indentation.

 ■ For new commands, if a step reference becomes invalid, it will 
switch to -1, forcing a command to fail instead of jumping to 
the start of the script. This makes it easier to find incomplete 
arguments in a command.

Overview

The MP Editor provides a graphical interface for writing scripts. It car-
ries a few traits from a traditional IDE (Integrated Development Envi-
ronment) that experienced programmers might recognize. But most 
importantly, it is not a text editor. Scripts are written in a point-and-
click, drag-and-drop fashion instead of writing text-based commands. 
This makes the learning curve more acceptable for most users.

There are three main sections in the editor (Figure 30-4):

 ■ Command List. This is a hierarchical tree showing every com-
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mand that could possibly be added to a script, organized by 
type.

 ■ Connections/Find Results/Variables View. This view pro-
vides an optional display of 3 diferent  screens: 

1. Connections. This screen shows a two way list of intercon-
nectivity with the currenlty selected step. This could also be 
named references because it displays a list of steps that the 
current step references and a second list of steps that refer-
ence this step.  

2. Find Results. Working in conjuction with the MP Search but-
ton, this screen displays the resulting steps from the current 
search.

3. Variables. This screen displays either a list of the variables, 
variable types, and (if debugging) variable values defined in 
the current script. 

 ■ Step List. The majority of the window is devoted to the Step List, 
which displays the individual steps of the script itself and al-
lows for editing of the script’s arguments.

A Measurement Plan is a procedural script that executes one line at 
a time. Normally, the script executes in a linear fashion, proceeding 
from one command to the next. However, there are commands that 
cause execution to jump to another location in the script. There are 
also commands that branch to different parts of the script (or to dif-
ferent scripts altogether) based on some value.

Everything in Measurement Plan scripting is zero-based. That is, all 
counting begins with zero, whereas in the regular world we typically 
start counting from one. The first step in a script is step zero, the first 
argument in a command is argument zero, the first item in a list (ar-
ray) is item zero, and so on. If you have any programming experience, 
you will be used to this convention.

About Commands

When a command is first added to a script, it will be in expanded form 
so that it can easily be modified (Figure 30-5).

Figure 30-5. A newly-added com-
mand, in expanded form.

Commands can also be collapsed to one line at any time to save space 
or simplify your view (Figure 30-6).

Figure 30-6. A collapsed com-
mand.
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To understand the command’s parameters, let’s look at this command 
in more detail. Each item in the command’s detail view is numbered 
in Figure 30-7 and discussed below.

Figure 30-7. A command’s 
parameters.

1. Step Number
Every command in a script has a specific step number, used to order 
and identify steps in the script. Step numbers start from zero, so the 
first step in a script is step zero. You can rearrange single steps or en-
tire groups of steps.

2. Command Name
The name of the command is listed at the top of the entry. This is a 
read-only field that allows you to view the name of the command be-
ing examined. The name of the command in Figure 30-7 is Integer 
Math Operation.

3. Comment
Each step can have a user-defined comment (Add 3+5 in this case). 
This comment is simply a single line into which you can type anything 
you’d like. Comments are typically used to provide “human-readable” 
text to accompany the commands, so that someone reading a script 
(often times, that’s you!) can understand the intent of the command.

Comments can only be one line in length. When you collapse a com-
mand, the comment appears to the right of the command name. 
When expanded, the comment appears below the command name 
in a field that can be edited.

A few tips regarding comments:

 ■ Keep them brief. Long comments clutter up the screen, take 
time to enter, and take longer to read.

 ■ Comment Only When Necessary. New script writers have 
a tendency to add a comment to every line. Don’t. Only add 
comments if you feel like they’re needed.

 ■ Don’t be redundant. If the command itself is clear, there’s no 
need to add a comment. For instance, in Figure 30-7, it’s clear 
that we’re adding 3+5, so the comment is redundant.

 ■ The above three rules are not set in stone. If you feel like 
a comment is needed, add one. For example, it may be clear 
what a command is doing when you’re looking at its details, 
but when it’s collapsed, you can’t see what it’s doing. So it may 
be acceptable to add a comment in that case. Use your own 
discretion.
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4. Arguments
Every command added to a script has zero or more arguments. Argu-
ments are the vehicle by which you can communicate with a com-
mand, and by which a command can communicate with you as the 
script’s author. There are two types of arguments:

 ■ Input Arguments. These are values that can be supplied to a 
command as input. They help the command determine what 
it is supposed to do. Most input arguments are required, but 
some are optional.

 ■ Return Arguments. Return arguments are used to return in-
formation or results back from a command after it executes.

In Figure 30-7, the command has three input arguments: zero 
through two (A0 through A2). It has one return argument: A3 (notice 
the grayed-out “Result only” fields).

In this example, we want to perform a math operation on two inte-
gers (whole numbers). We obviously need to provide both of those 
numbers, in addition to the math operation that we want to perform. 
Those are the input arguments.

Once the command completes, we need a place to store the result of 
the operation so that we can refer to it later. The result of the addition 
in this case is stored in A3.

5. Data Type
Every argument has a data type (this will not be new for those with 
programming experience). A data type indicates the type of informa-
tion that an argument is expecting. You must feed an argument data 
of a compatible data type—otherwise, SA will prevent the operation 
or the script will fail at runtime. For instance, you cannot provide a let-
ter to an argument expecting a number. After all, what is the numeric 
value of that letter?

There are just four primary data types:

 ■ Integer. Whole numbers, such as 10, 10000, 0, and -502. These 
values are represented exactly, but there is a limit to the range 
of this number. In general, you need not worry about this limit 
for scripting applications.

 ■ Double. Decimal numbers, such as 3.1415926535, 2.781, 0.0, 
or -1.125. These numbers are in general not represented exact-
ly, so expect numerical errors to creep into your calculations. 
These errors are typically well beyond the precision of portable 
metrology work, so they’re not usually a worry, but you should 
take care when trying to compare one double value to another. 
You may expect them to be the same but they may actually 
be very slightly different. Double values also have limits on the 
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range of values they can represent, but in general you need not 
worry about this limit for scripting applications.

 ■ Boolean. A value that represents one of two possible values, 
such as true/false, on/off, left/right, or yes/no.

 ■ String. A sequence of one or more alphanumeric characters, 
such as a sentence or prompt.

There are many more data types in scripts in addition to these four, 
but virtually all other data types in scripts are derivations of these four 
main types. For example, there is a Collection Name data type, but 
it is really a string. This means that any argument that expects a Col-
lection Name can also be fed a string, and vice versa.

6. Description
Every argument has a description field. This is more of a human-read-
able description of what the argument is for.

7. Entry Method
A dropdown which appears when clicking in this column allows you 
to specify how you want to supply the information for the argument. 
For example, do you want to type it in, or feed it from some other 
command?

There are many entry methods. The most common are covered here:

 ■ Enter Value. The argument’s value is typed directly into the 
command—known as hard coding the value.

 ■ Reference. The value is fed into the argument from some other 
command. For example, the result of a math operation might 
be fed into another command for further processing.

 ■ Variable. The value for the argument is retrieved from a vari-
able by specifying the variable’s name. The variable must be of 
a compatible data type for the given argument.

 ■ Pick. The value is selected from a limited dropdown list of val-
ues.

 ■ Dialog. The value is specified graphically in a dialog.

8. Argument Value
The argument’s value is specified in this field.

 ■ Hard coded values appear as typed.

 ■ References appear as a combination of step number and argu-
ment number. For instance, Ref {S3 A4} indicates that you 
are feeding the value stored in step 3, argument 4 into the cur-
rent argument.

 ■ Variables are specified by entering the variable name.

Note:  Some data types are 
simply more descriptive 

names for other data types. These 
are called proxy data types. Col-
lection Name is an example of a 
proxy data type.
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9. Entry Method Quick-Select
A series of buttons for the most common entry methods are listed to 
the right of the argument value. By clicking these buttons, you can 
immediately change the entry method for the argument and directly 
enter the value. Users familiar with SA’s legacy script editor will find 
this new method of argument entry dramatically faster than the old 
method, while also requiring less clicking.

Only buttons applicable to a given argument are displayed, although 
often times there are more entry methods than buttons. (In other 
words, only the most common entry methods have buttons).

Entering Commands

Before you add a command to a script, you must find it in the Command 
List first. When you are just starting out, you will probably find com-
mands by browsing the list. However, once you have more experi-
ence under your belt, you will begin memorizing key phrases of com-
mon commands and find them by simply typing a phrase to search 
for in the Search field above the Command List. 

To Add a Command to a Script:

1. Select the step after which you’d like the new command to 
be added. (If no step is selected, the new command will be 
added to the end of the script).

2. Find the desired command in the command list, or search for 
it by typing into the Search field. Use the + and - buttons to ex-
pand or collapse categories in the command list.

3. Double-click the desired command, or select it and press En-
ter.

To Delete a Command from a Script:

1. Select one or more commands by clicking on their command 
name. (Standard Windows contiguous and non-contiguous 
selection is supported).

2. Press the Delete key.

Editing Commands

Once you have commands in your script, various editing operations 
can be performed.

To Select a Single Command:

 ■ Click in the row containing the command’s name, or

 ■ Use the up/down arrow keys on the keyboard while the step 
list has focus.

Note:  If you cannot find a 
button for the appropriate 

entry method, look for it in the en-
try method dropdown (7).
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To Select Several Contiguous Commands:

1. Click the row containing the first command’s name.

2. Hold down Shift and click the row containing the last com-
mand’s name.

To Select Several Non-Contiguous Commands:

1. Click the row containing the first command’s name.

2. Hold down Ctrl and click additional rows containing subse-
quent command’s names.

All clicked commands will now be selected.

To Select All Commands:

 ■ Use contiguous selection above, or

 ■ Choose Edit > Select All from the editor’s menu, or

 ■ Press Ctrl + A.

To Clear Your Selection:

 ■ Click away from any commands in the step list, or

 ■ Choose Edit > Deselect All from the editor’s menu, or

 ■ Press Ctrl + Shift + A.

To Rearrange Commands:

 ■ To move a single command, drag it by clicking on its command 
name and drop it anywhere on the command you’d like the 
command to follow.

 ■ To drop a command BEFORE another command, hold down 
the Shift key while dropping.

 ■ To rearrange multiple steps, select them (standard Windows 
contiguous and non-contiguous selection is supported), then 
drag and drop them onto the step after which you’d like the 
group of steps to appear. Hold down Shift when dropping to 
place the group of steps before the command.

To Expand or Collapse Commands:

1. Select one or more commands (standard Windows contigu-
ous and non-contiguous selection is supported).

2. Do one of the following:

 ■ Click the or  button,

 ■ Double-click the row containing the command name, or

 ■ Press the right arrow (expand) or left arrow (collapse) keys on 
the keyboard.

To Copy Commands:

1. Select one or more commands.
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2. Do one of the following:

 ■ From the editor’s menu, select Edit > Copy, or

 ■ Press Ctrl + C.

To Paste Commands:

1. First copy one or more commands as described above.

2. Select the command after which you’d like to paste.

3. Do one of the following:

 ■ From the editor’s menu, select Edit > Paste, or

 ■ Press Ctrl + V.

Resizing Columns

Although it may not be obvious, the MP Editor has a number of resiz-
able columns. You can adjust these to better fit the column’s contents, 
or if you have made the editor window large.

To Resize Columns:

1. Expand any command so that its arguments are visible.

2. Place the cursor just to the left of the Description, Entry Meth-
od, Value, or Entry Method Quick-Select Button columns. The 
cursor will change to indicate that you can drag left and right.

3. Drag the column to the desired width.

Hard Coding Argument Values

hard coding involves manually entering values into an argument. This 
is done when the value for an argument is known at development 
time and is not expected to change.

To Hard Code an Argument Value:

1. Ensure the entry method dropdown for the desired argument 
is set to enter Value, or click the button.

2. Enter the value into the argument’s value field, as specified 
below (the most common cases are described):

 ■ Simple Data types. Doubles, strings, integers, and other sim-
ple data types can be entered by typing the values directly into 
the field.

 ■ Boolean types. For arguments of type Boolean, you can ei-
ther type TRUE or FALSE (case insensitive) or, as a shortcut, 
type a nonzero value to represent TRUE and 0 to represent 
false. (It will automatically convert this value to TRUE or FALSE 
when you press Enter.
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 ■ Collection Object Names. If you’re entering the name of an ob-
ject, type the collection name, followed by two colons, followed 
by the object name. For example, Measured::AxisLine. If 
you leave off the collection name and simply type AxisLine, 
the command will try to find the object named AxisLine in 
whichever collection is active at the time the command is ex-
ecuted.

 ■ Point Names. To specify a point name, type the collection, 
group name, and point name separated by a pair of colons. 
For instance, Measured::Tie-Ins::1. You can leave off the 
collection name to indicate that you want to find the group 
and target in the active collection at the time the command is 
executed. For example, Tie-Ins::1 will look for point 1 in a 
Tie-Ins group for the active collection.

 ■ Reference Lists. Some commands, such as Concatenate 
Strings, expect reference lists, which are simply lists of items. 
To enter these, click the entry field, which will open the List Edi-
tor (Figure 30-8). Use this to add, rearrange, or remove items 
from the list.

Figure 30-8. The String List 
Editor.

Referencing Arguments

The true power of scripting comes not from a script that repeats a 
sequence of steps exactly as before, but in making decisions and be-
having differently based on parameters that may be different from 
the last time the script was executed.

The most common way of supporting this “non-hard coded” behavior 
in scripts is through the use of references. A reference is essentially a 
link or a connection to another value in your script. It is a way to feed 
a value from some other command in your script into the current ar-
gument.

For example, one step may multiply two values together. You can 
then feed the result of that calculation into an input argument in an-
other command to further operate on it.

Tip:  If multiple arguments 
from different commands are 

going to refer to the same value, 
it is generally best for all of them 
to reference the same argument. 
Doing so ensures that future 
changes only require changing 
one argument.



762

SPATIALANALYZER USER MANUAL

To Reference an Argument:

1. Ensure the entry method dropdown for the desired argument 
is set to reference, or click the button.

The editor will highlight yellow all arguments that are of a compatible 
type for the given argument. If an argument is already being refer-
enced, it will be highlighted blue. If the auto expand/Collapse Steps 
option is enabled in the MP Editor options, any commands contain-
ing compatible arguments will be automatically expanded to show 
them. These commands will collapse again when the reference is se-
lected.

2. Click on the highlighted argument to reference, or Esc to can-
cel.

Using Variables

Most if not all programming languages support the concept of vari-
ables. Variables allow you to define a name that is associated with a 
value. This allows you to refer to that value by name. The advantage 
of this is that while a script is running, you may change or overwrite 
the value of that variable, but anywhere you refer to it by name, you’ll 
always retrieve its current value. In many scripting situations, this can 
lead to dramatically simpler scripts.

Variables must be of the appropriate data type to store a given value. 
For instance, an integer variable can store a whole number, but it can-
not store a double. Likewise, a point name variable can store a point 
name, but it cannot store a vector.

You can define a variable by using the Set [____] Variable com-
mands. (There is a different command for each variable type). These 
commands create a variable with the specified name that stores the 
specified value. You can then refer to that value by its variable name.

To overwrite or change the value stored under a variable, simply use 
another Set [_____] Variable command using the same vari-
able name.

To Enter a Variable Argument:

1. Ensure that the entry method dropdown for the desired argu-
ment is set to Variable, or click the button.

2. Type the name of the variable into the argument’s value field.

The value of the variable will be retrieved at the time the command is 
executed and used as the argument’s value.

Variables View
In the bottom-left-hand side of the MP Editor is a dropdown that al-
lows you to select the Variables view (Figure 30-9).

Note:  An argument cannot 
reference itself. Such circular 

references do not make sense.

Warning:  Do not at-
tempt to reference an ar-
gument that will not con-

tain a value at the time the 
command is executed. This results 
in undefined (and generally incor-
rect) behaivor.
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Figure 30-9. A list of the defined 
variables.

The Variables view allows you to see all of the defined variables in 
the current script, as well as their data type. Additionally, while de-
bugging, the value of the variable at the current point of execution is 
displayed in the Value column.

In addition to debugging uses, having a list of defined variables avail-
able allows you to easily reference the name when typing a variable 
in by hand.

Some lists, such as Point Name Reference Lists and Collection Object 
Name Lists also support a special Ctr+Shift double click option to dis-
play a new pannel with the names of the items defined in the variable 
while in debug mode (Figure 30-10). 

Figure 30-10. Accessing Lists in 
the Variables View

Connections View

Occasionally, you may wish to see or jump to commands which are 
somehow related to the currently selected step. For example, if you 
delete a command, it would be nice to see which commands refer-
ence that step. After all, by deleting that step, any commands that 
reference it will need to be corrected.

As another example, you may have a command that jumps to a given 
step. If you want to insert a new command before that step and have 

Note:  For simplicity, vari-
ables defined in other scripts 

are not displayed. Variables de-
fined in subroutines are not visi-
ble to a calling script, so listing  a 
subroutine’s variables would be 
pointless. While editing a subrou-
tine, the editor doesn’t know 
which script is considered its par-
ent, so a parent script’s variables 
are not displayed either.
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the command jump to it instead, you will need to adjust the step 
reference. These types of situations are where the Connections View 
comes in handy.

The Connectiosn View provides two lists of steps: 

 ■ A list of steps that have references to the selected step

 ■ A list of steps that are referenced by the selected step

Simply click on any of the step references in the Connection View to 
navigate to that step in the Step List editor. 

MP Find and Replace

It is often important to be able to find specific entries within a long 
script quickly an efficiently. The MP Find and Replace functions were add-
ed to fill that need. The MP Search button (also accessible through 
Ctr+F for find or Ctr+H for Relpace) will bring up a dialog for this ap-
plication (Figure 30-11). 

Figure 30-11. MP Find and 
Replace Dialog

This dialog is desiged to work in conjunction with the Find Results 
View pannel (Variables, Find Results and Connections View).  To find 
the entry you are looking for consider the following:

1. Open the Find and Replace dialog (Ctr+F). 

2. Select from the check boxes to idenify what you are looking 
for. You can search all fields by checking each box or isloate 
your seach to just one fields such as the “Argument Value” 
which is the entry field for most arguments. 

3. Press the Find All button once to build a list. 

At this point you can either use the Prev and Next to navigate through 
the results or close the Find and Replace dialog entirely and use the for-
ward and backward buttons at the top of the editor. 
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These buttons will move the focus in the script from one entry to the 
next in sequence. However, the fastest way to navigate through your 
search results is to look in the Find Results View pannel. This pannel 
will show you a list of steps and individual arguemnts within those steps 
that include the search results. Simply click on and entry to navigate to 
that specific argument in the script (Figure 30-12).

 
Figure 30-12. Find and Replace 
Search Results

The MP Find and Replace dialog will idenify items that are both in the 
primary script and within a list. However, it will not allow you to navi-
gate through a list to find a single entry. In order to find a single point 
name in a long list of names for example a second search button has 
been added to the List dialog (Figure 30-13). 
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Figure 30-13. Additional List 
Search Function

Commenting Out Commands

Sometimes, you may wish to “comment out” commands. Comment-
ing out commands will temporarily disable them—they remain in 
your script, but the script will skip them during execution. As a re-
sult, you can easily remove a portion of your script and then restore it 
into the script with a simple click. This is extremely useful while test-
ing your script—you may wish to try something without a section of 
commands, or you may wish to remove a block of your script simply 
to shorten the length of time it takes for a script to execute. Deleting 
these commands instead would not be a great approach, since add-
ing them back in would require a lot of work.

Although commented commands are not executed, they are still a 
part of your script—references to those commands remain. If other 
commands reference a commented command, they will most likely 
fail at runtime, because the commented command is not executed, 
so its values may not be calculated.

Steps which have been commented out will have a speech bubble 
icon next to them (Figure 30-14).
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Figure 30-14. Steps 0 through 3 
are commented out.

To Comment Out Commands:

1. Select the commands you’d like to comment out.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected step numbers until a small comment bubble icon ap-
pears , (Figure 30-14), or

 ■ Right-click the selection and select Comment Line (REM) from the 
context menu.

To Uncomment Commands:

1. Select the commands to uncomment.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected step numbers until all icons are cleared, or

 ■ Right-click the selection and deselect Comment Line (REM) in the 
context menu.

To Clear All Comments:

 ■ Right-click any step and select Clear All Comments from the con-
text menu.

Setting Breakpoints

When testing, you often want to run a script at “full speed”, then have 
the script pause at a certain point so that you can slowly step through 
a certain area of your script. For example, if there is a tight loop at the 
start of a script that executes thousands of times, it would be exhaust-
ing to step through the loop manually one line at a time. Instead, what 
is needed is a way to run the loop at full speed, then pause afterward.

Breakpoints enable this capability. Any line can be set as a breakpoint, 
and you can set as many breakpoints in your script as you’d like (Fig-
ure 30-15). When set as a breakpoint, an executing script will pause 
prior to executing the line on which the breakpoint is set. You can 
then choose to step forward one line at a time, or continue running 
“at full speed”.
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Figure 30-15. Steps 5 and 12 
have been set as breakpoints.

To Set Breakpoints:

1. Select the commands you’d like to set as breakpoints.

2. Do one of the following:

 ■ Click in the right half of the gray column to the left of the se-
lected steps until a breakpoint icon appears (Figure 30-15), 
or

 ■ Right-click one of the selected steps and choose Breakpoint (BRK) 
from the context menu.

To Clear Breakpoints:

1. Select the steps whose breakpoints you’d like to clear.

2. Do one of the following:

 ■ Right-click one of the selected steps and uncheck Breakpoint 
(BRK) in the context menu, or

 ■ Click in the right half of the gray column to the left of one of the 
selected steps until no icon is displayed.

To Clear All Breakpoints:

 ■ Right-click any command and select Clear All Breakpoints from 
the context menu.

Locking Commands

When you are satisfied one or more command’s parameters, you can 
lock those commands to prevent accidental modification. Locking a 
command provides a number of advantages:

 ■ They cannot be reordered in the script, so you cannot acciden-
tally move them around.

 ■ They cannot be deleted.

 ■ Changes cannot be made to their arguments.

To Lock or Unlock Commands:

1. Select the commands you’d like to lock/unlock.

2. Do one of the following:
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 ■ Right-click one of the selected commands and toggle the Lock 
entry in the context menu, or

 ■ Click in the left half of the gray column to the left of one of the 
selected steps until the lock icon appears (to lock) or disap-
pears (to unlock).

To Unlock All Commands:

 ■ Right-click any command and select Clear All Locks from the con-
text menu.

Entering Comments

When a command is expanded, a line directly beneath the command’s 
name says << Click to Enter Step Comment >>. In this field, 
you can type any comment to help document your script. Simply click 
in the field and start typing.

When you collapse a command, its comment will be placed next to 
the command name.

Indenting Commands

You can indent commands to help set them off as being part of a loop 
or branch of code, similar to how programmers indent their code to 
improve readability of the source code.

To Indent Commands:

1. Select the commands you’ d like to indent.

2. Press Tab. The command will shift over by one tab space.

To Remove Indention:

3. Select the commands you’d like to unindent.

4. Press Shift + Tab.

Setting Command Colors

You can change the background color of one or more commands in 
the editor to help differentiate a section of your script.

To Change Command Colors:

1. Select the commands you’d like to change.

2. Right-click one of the selected commands and choose Set 
Background Color from the context menu.

3. Choose a new color, then click OK. To reset the color back to its 
default, choose white.

Note:  Multi-line comments 
are not currently supported.
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Grouping Commands

When working with longer scripts it can often helpful to group steps. 
This can make it much easier to navigate a large script and provides a 
convenient way to isolate and identify key sections of code.

To Group Steps Together

Select the steps you wish to group together by first selecting the first 
step in the group and then Shift+Left Click on the last step in the 
group. These steps should become highlighted. Then right-click and 
select Group Steps. 

A script either has grouping or does not. Therefore when you build 
a group from selected steps it will create 3 groups. The steps prior 
to your selection will be in an initial group, the steps you selected 
will be in a group, and the remainder of the script will fall into a final 
group. Additional groups can then be build by subdividing these in-
tial groups by selecting an additional set and again grouping them. 

Each group can be labeled with a group title to clearly identify what 
is contained within that group and the step ranges are automatically 
displayed (Figure 30-16).  

Figure 30-16. Grouping Steps

Enabling/Disabling Grouping

Grouping can be turned on and off as desired without losing the 
grouping definition and groups can be removed or added as needed. 
The grouping definition is for display only and will not impact the 
performance of an MP when it is running. 
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Working with Subroutines

Subroutines are a powerful means of expanding a script. It allows a 
sub-section of code to be saved separately and called any time it’s 
needed. This can greatly reduce the size of single MP and allow you to 
use a common subroutine in several applications. 

Subroutines are structured as follows:

 ■ Within your master script add a step called Run Subroutine.

 ■ Build a second script that has an initial step Define Subroutine In-
put Values and a final step Define Subroutine Return Values. The addi-
tion of these two steps makes a script a subroutine that can be 
called from the master script.

Sharing Information with Subroutines
Adding Input and Return Arguments

The Run Subroutine step is unique in that the number of arguments in 
the step will change based upon the number of input and return ar-
guments defined in the subroutine. 

Lets say for example that you want to pass a user’s name to a sub-
routine. To do this, select the Define Subroutine Input Values step in your 
subroutine and press the Add button(Figure 30-17) which will appear 
at the top of the editor when the set is selected.  

Figure 30-17. Adding an Input 
Argument in a Subroutine

The same is true for the return Values. You will want to add any inputs 
to the subroutine and any returns you want to use and then when 
you connect it to the main script those arguments will appear in the 
Run Subroutine step in the main script. Continuing this example an 
input string “User Name” and a return argument “Report Name” were 
added to the subroutine and you can see they both appear as part of 
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the Run Subroutine command within the main script: 

Figure 30-18. Run Subroutine 
Input and Return Arguments appear 
when defined within the Subroutine

This means that your workflow will be to: 

1. Build your subroutine and add all the input and return argu-
ments you want first.

2. Within your main script add the Run Subroutine command and 
point it at the subroutine.

3. Wire up all the inputs and returns to that subroutine. 

Sharing Variables with a Subroutine

Within it the Run Subroutine step, Argument A1 is “Share parent Vari-
ables”. This option is off by default so that you can use the same vari-
able names in the main script and the subroutine without fear of con-
fusion, but if you want you can enable it. When you do a variable in 
set in the Main script should then be available in the subroutine as 
well. 

Writing Your First Script
Let’s go through the process of writing a short simple script just to see 
how it’s done. This script will ask for a number between 1 and 10, and 
it will count up to that number starting from 1. For instance, if the user 
enters 2, our script will display 1, 2, then exit.

1. Start a new script in the editor.

We first need to ask the user for the number to count to. We’ll do this 
using the Ask for Integer command, which allows the user to 
enter a whole number and returns the value entered.

2. In the search field above the command list, type Ask For I.

The search field will filter the available commands down—the Ask 
For Integer command should be the only one remaining.

3. Double-click the command in the command list, or select it 
and press Enter. It will get added as the first line in our script.
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4. In the Question to Ask argument, click in the box and type Please 
Enter a number from 1 to 10, then press Enter.

5. In the Enforce Min/Max Values? argument, click in the box and type 
1, then press Enter. The value becomes TRUE. This allows us 
to ensure that the user can only supply a value within a given 
range.

6. Set the Min Value to 1 and the Max Value to 10.

7. In the search field/command list, find the command Exit 
Measurement Plan (again, starting to type this name in the 
search field is the fastest way to find the command). Add it to 
the script (it will appear at the end).

8. Back in the Ask for Integer command, set the Step to jump to 
if Canceled argument to 1. If the user clicks the cancel button, the 
script will jump to the Exit Measurement Plan command 
in step 1 and exit.

9. Make sure a line in step 0 is selected, then add the command 
Create Counter. In the Counter Value argument, set the value 
to 1. This will be the initial value of our counter.

10. Next, add an Integer Comparison command. This will al-
low us to check the current counter value against the value 
the user entered so we can determine when to stop counting.

11. Click below the command name where it says << Click to 
Enter Step Comment >>. Type Keep Counting? or a 
similar comment.

12. In the Integer A argument, click the reference quick-select but-
ton , then click the yellow box in Step 1, argument 0. The 
argument should now say Ref {S1 A0}.

We have now set this argument to reference the current counter’s 
value in step 1, argument 0. This will feed the current counter value 
into this argument at runtime.

13. In the Comparison Type argument, click the box and select <= from 
the dropdown list.

14. For Integer B, again click the reference button and select step 
0, argument 7.

Essentially, this command is now comparing the “current” counter val-
ue against the number that the user entered. If the current counter is 
less than or equal to the supplied number, the command will jump to 
the Step if TRUE step. Otherwise, the command will jump to the Step if FALSE 
step. However, we don’t yet have these steps written, so we can’t yet 
fill them in.

Let’s consider what happens if the current counter is less than or 

Tip:  For any boolean argu-
ment, you can type 0 to rep-

resent FALSE or any nonzero 
number to represent TRUE. The 
value will be converted automati-
cally when you hit Enter.
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equal to the supplied value. In this case, we want to display the cur-
rent counter value.

15. After the Integer Comparison command, add a Notify 
User Integer command. Click the command name to se-
lect it and press Tab to indent the line over once (we’re now 
inside the body of a loop).

Your script should now appear as depicted in Figure 30-19.

Figure 30-19. Our first script, 
so far.

16. In the Reported Value argument, click the reference button and 
select step 1, argument 0 (the counter value). This will display 
the current counter value to the user at runtime.

We need to increment the counter, or else we’ll be stuck in an infinite 
loop.

17. Add an Increment Counter command after the Notify 
User Integer command. Click the reference button and 
select the counter in step 1, argument 0. Press Tab to indent 
the command name.

When this command is reached, the current counter value will auto-
matically be incremented by one. 

Almost done. Now that we’ve incremented the counter, we need to 
jump back to our test—the comparison—to see if we should contin-
ue the loop.

18. Add a Jump to Step command. In the Step ID argument, enter 
2 to jump back to the Integer Comparison command.

The last thing we need to do is fix the step references in the Integer 
Comparison command.

19. In the Integer Comparison command, set the Step if TRUE 
value to 3. This will enter the body of the loop if we’re still 
counting.
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20. Set the Step if FALSE value to 6. When we’re done counting and 
the counter becomes greater than the entered value, we’ll 
exit the script.

21. Select all commands by pressing Ctrl + A. Then press the 
left arrow key to collapse all commands at once.

Let’s lock the commands so we don’t accidentally change them.

22. Ensure all commands are still selected, then click the left 
side of the column to the left of the step numbers. A pad-
lock should appear on every line, indicating the lines are now 
“read-only” (Figure 30-20).

Figure 30-20. All steps are now 
locked.

That’s it! Our script is done. Let’s test it.

23. Click the run button in the editor. If auto-run is disabled 
(see “To Enable/Disable Auto-Running of Scripts:” on page 
747), click the same button in the MP Bar.

Did your script run as you expected? If not, try to find any errors and 
correct them.

Debugging
A large portion of the time spent writing a script is often spent on 
debugging—that is, finding any bugs and errors in the script and cor-
recting them so that the script runs flawlessly in an execution envi-
ronment.

There are several ways to test and evaluate your script’s behavior.

Stepping Through a Script

One of the most obvious but still useful techniques for testing a script 
is to simply step through its evaluation one line at a time. This gives 
you the opportunity to view the effect of each command as it’s ex-
ecuted—typically, scripts execute too quickly to observe what’s hap-
pening.

When a script is loaded into the MP Bar, you can step forward one line 
at a time by clicking the Next Step button.
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In the MP Editor, you can enable debugging mode by clicking the 
Debug button . When you do this, the Next Step button will ap-
pear in the editor window, allowing you to step through the script.

Debug Mode

The MP Editor has a debug mode that you can enable. Debug mode 
(Figure 30-21) provides several benefits for testing:

 ■ You can step through a script one line at a time.

 ■ Each command’s arguments will display their runtime values, 
so that as you step through the script you can see the actual 
runtime values stored with each argument.

 ■ The Variables view shows the current value of each variable as 
you step through the script.

Figure 30-21. Debug mode 
shows variable values (left column) and 
current argument values.

These three items provide most of the tools you need to discover er-
rors in your script.

Debug mode only works with a single script. This means that if a sub-
routine is called, you will not see any changes in the MP Editor win-
dow until the subroutine returns and execution continues in the cur-
rent script. To view values in parent scripts and subroutines as a script 
executes, use the MP Watcher.

To Enable Debug Mode:

1. In the editor, click the Debug button . In debug mode, all 
arguments will become read-only and they will display their 
current values.

2. Run the script or step through it using the controls at the top 
of the window.

MP Watcher

The MP Watcher is very similar to debug mode in the editor. It is a sep-
arate window that allows you to view the current values of all com-

Note:  Scripts will run notica-
bly slower in debug mode. 

This is typically fine, since you’re 
testing—but it is something to be 
aware of.
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mand arguments as a script is executing. However, the MP Watcher 
adds each line to a list as it is executed. This means that unlike debug 
mode in the editor, if a script calls a subroutine, the subroutine’s val-
ues can be seen while that subroutine is executing. Moreover, in a 
loop each iteration through the loop will add additional lines to the 
list, whereas in debug mode the previous iteration is “overwritten” 
with the current iteration’s values.

The MP Watcher is shown in Figure 30-22. It will only show com-
mands that are executed starting from the time that the window was 
opened. In other words, it is possible to run partway through a script, 
then open the MP Watcher. Only commands from that point on will 
be displayed.

Scripts will run noticeably slower with the MP Watcher open, so make 
sure that this window is not open when execution speed is impor-
tant. (Typically, this is fine, since the window is only used during the 
testing phase of script development).

To Print the Contents of the MP Watcher Window:

 ■ Click the Print button.

To Export the Contents of the MP Watcher to an Excel Spreadsheet:

 ■ Click the Excel Export button.

To Export the Contents of the MP Watcher to a PDF File:

 ■ Click the PDF Export button.

To Clear the Contents of the MP Watcher Window:

 ■ Click the Clear button.

To Search for Content in the MP Watcher Window:

 ■ Click the Search button. You can search for text in the title, the 
comment field, for a specific value, or search among a specific 
command.

To Limit the Number of Steps Displayed in the MP Watcher:

 ■ Click the Options button. Set the Max displayed Steps option, 
then click OK.
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Figure 30-22. The MP Watcher in 
mid-execution.
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SA SDK
The SpatialAnalyzer SDK provides a means by which to write custom 
applications that utilize Measurement Plan functionality within Visual 
C++, VB.NET, or other development environments that support Ac-
tiveX controls. Once the SDK engine has been added to the develop-
ment environment, Measurement Plan steps can be executed from 
within the programming language.

The advantages of the SDK over Measurement Plans include the fol-
lowing:

 ■ Since the code is written in a full-featured programming lan-
guage (such as Visual C++ or VB.NET), it offers the full flexibility 
and power of those programming languages.

 ■ Complex math operations and data manipulation is often easi-
er than when written in MPs.

 ■ There is no need to write routines to transfer data back and 
forth between MPs and custom external applications--all data 
is handled within the SDK application itself.

 ■ SDK code is compiled and can be distributed as a true applica-
tion.

 ■ SDK code is more difficult to reverse engineer than MPs, so pro-

The ability to automate measurement, analysis, and reporting tasks in 
SA can prove to save an enormous amount of money, time, and effort. 
Automation through Measurement Plans or the SA SDK can introduce 
efficiencies in your metrology processes unmatched by anything else.

SA SDK
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prietary processes can be kept more secure.

The disadvantages of the SDK when compared to MPs include the 
following:

 ■ It is more difficult to understand for a user not familiar with 
programming. Creating automated routines is less intuitive.

 ■ It requires at least basic knowledge of a real programming lan-
guage and development environment.

SDK Engine

Whenever a client application that you have developed is executing, 
the SpatialAnalyzer SDK engine will automatically start and appear 
minimized on the Taskbar. Figure 31-1 shows the engine in its maxi-
mized state:

Figure 31-1. The window dis-
played when the SDK Engine is running.

Automatic Code Generation

SpatialAnalyzer supports the automatic generation of SA SDK code 
for Visual Basic and Visual C++ languages through the MP Editor. This 
is an excellent way to prototype SDK applications, or convert MPs into 
full SA SDK applications. To access this sample code, set up an MP 
with your desired arguments. Then, press the SDK Code Generation 
button in the MP Editor (Figure 31-2).

Figure 31-2. The SDK Code 
Generation button.

The necessary code will be displayed in a window and automatically 
copied to the Windows clipboard (Figure 31-3).
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Figure 31-3. The SDK Code Viewer.

You can then paste this code into your SDK application.

Setting Up an SDK Project

VB.NET
1. Create a new Visual Basic Windows Forms Application project 

within Visual Studio (Figure 31-4). Select File>New Project.  

Figure 31-4. Creating a new 
VB.NET project.

2. Type a name for your application, then press OK.

3. Select Project>Add Reference...  
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Figure 31-5. Adding the SpatialA-
nalyzerSDK COM object.

4. In the Add Reference dialog, select the COM tab, then scroll 
down in the list and choose SpatialAnalyzerSDK.  Click OK (Figure 
31-5).

5. Double-click the form in your project. You should be present-
ed with the code for the Form1_Load method of your form (Fig-
ure 31-6).  

Figure 31-6. The default form.

6. Replace this class code with the following:

Public Class Form1
’Declare an object for the SA SDK Interface

Private NRKSdk As SpatialAnalyzerSDK.SpatialAnalyzerSDK
‘Declare an enumerated type that defines the various return codes from the SA 
‘SDK Interface.
 
Enum MPStatus
 SDKERROR = -1
 UNDONE = 0
 INPROGRESS = 1
 DONESUCCESS = 2
 DONEFATALERROR = 3
 DONEMINORERROR = 4
 CURRENTTASK = 5
End Enum

‘Allocate the SDK Interface object
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.
EventArgs)
Handles MyBase.Load
 NRKSdk = New SpatialAnalyzerSDK.SpatialAnalyzerSDK
End Sub

End Class
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7. Ensure SA is running, then compile and run the application.

Visual C++
1. Create a new Visual C++ MFC project within Visual Studio (Fig-

ure 31-7).  Select File>New Project...

 

Figure 31-7. Creating a new MFC 
C++ project.

2. Type a name and location for your project, then click OK.

3. For purposes of illustration, let’s assume a dialog application 
is created (Figure 31-8). Note that the Dialog based radio button 
is selected:

Figure 31-8. The MFC Application 
Wizard.

4. In the next dialog, ensure that Automation is selected (Figure 
31-9).  
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Figure 31-9. Ensuring that the 
Automation checkbox is selected.

5. Now add the SDK to the application. From the Solution Explor-
er, right-click the application in the tree and select Add>Class 
(Figure 31-10).

Figure 31-10. Adding a new class.

6. Select MFC Class From TypeLib, then click Add (Figure 31-11). 

Figure 31-11. Adding an MFC 
class.

7. Select SpatialAnalyzerSDK<1.0> from the Available type libraries drop-
down. Then click the >> button to add ISpatialAnalyz-
erSDK to the Generated Classes section. Click Finish. 

8. CSpatialAnalyzerSDK.h will automatically be added to 
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your project and contains all of the available SDK declarations.

Sending Commands to SA

Establishing a Connection
The SDK consists of a set of function calls that allow the specification 
and execution of MP Steps. Before executing any commands in SA, 
your SDK code must first connect to SpatialAnalyzer. You can connect 
to SA using one of two methods: Connect (deprecated) and ConnectEx. 
The deprecated Connect() method returns a simple boolean YES or NO 
answer, indicating whether the connection was successful:

‘Connect to SA. If unable to connect, display a failure message.
If Not(NRKSdk.Connect(“localhost”)) Then 
 MsgBox(“Failed to connect with automation server!”) 
End If

The ConnectEx() method allows you to pass a long integer variable (by 
reference) and obtain a status code from the command which indi-
cates whether a connection was successful or not, and why:

‘Connect to SA. If unable to connect, display a failure message.
Dim statusCode As Long
NRKSdk.ConnectEx(“localhost”, statusCode)
If (statusCode)
 Msgbox(“Connection error, code: “ & statusCode)
End If

‘Possible values for statusCode include:
‘CONNECTED = 0,
‘CONNECTION IN USE = -1     An  SDK Client is already connected to SA
‘INVALID_LICENSE   = -2     Invalid SA SDK license
‘COULD_NOT_CONNECT = -3     Failed to connect to specified host
‘SDK_SOCKET_ERROR  = -4     Other Socket error

Executing an MP Step
Once you’ve successfully connected, you can now execute any MP 
command by adhering to the following process:

Declaring the Command
The first step in executing a command is to tell the SDK which MP 
command you want to execute by using the setStep() method:

‘Tell SA which MP step we’re defining.
NRKSdk.setStep(“Construct a Point in Working Coordinates”)

This example would tell SA that you are in the process of defining 
the Construct a Point in Working Coordinates command. Note that the 
string provided as an argument to the setStep() method must match 
the name of the MP command exactly.

Setting the Arguments
Once you’ve declared the command, you need to provide input argu-
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ments using the argument setting methods such as setVectorArg() and 
setPointNameArg():

‘Set the “Working Coordinates” argument of the command.
NRKSdk.SetVectorArg(“Working Coordinates”, 10.1234, 20.2345, 30.5678)

‘Set the Point Name argument of the command.
‘We want to put this point in the active collection, in the TestGrp point 
‘group, and name it “TestPt”.
NRKSdk.SetPointNameArg(“Point Name”, “”, “TestGrp”, “TestPt”)

When doing this, the first string provided to the methods is from the 
Description field of the MP command. This string must match what is 
seen in the MP, in English. The remaining arguments to the method 
depend on the type of argument.

Executing the Command
Now that the MP command is fully defined, you need to tell SA to ex-
ecute the step. This is performed using the executeStep() method:

‘Create a boolean variable to hold the result of the execution.
Dim bSendStatus As Boolean

‘Execute the step, and assign the result to our boolean variable.
bSendStatus = NRKSdk.ExecuteStep()

Checking the Result of a Command
If the SDK fails to execute the command (for example, because you 
have not properly defined the arguments), then bSendStatus (above) 
will be False. If the command succeeds, the value will be True and you 
can further obtain the MP step result using the getMPStepResult() meth-
od. That is, you can determine whether the MP step passed, partially 
failed, or completely failed:
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‘Only do this if the MP command executed properly.
If (bSendStatus) Then
 ‘Declare a long integer to hold the result code.
 Dim result As Long
 ‘Get the MP step result, and assign it to result.
 NRKSdk.GetMPStepResult(result)

 ‘Check the result of the MP command.
 Select Case result
  Case MPStatus.DONESUCCESS
   Msgbox(“Success!”)
  Case MPStatus.DONEMINORERROR
   Msgbox(“Partial Success!”)
  Case MPStatus.DONEFATALERROR
   Msgbox(“Failure!”)
  Case MPStatus.SDKERROR
   Msgbox(“There was an SDK Error!”)

   ‘Create an object to hold the error message
   Dim msgArray As Object

   ‘Display the text returned from execution attempt to 
                         ‘user...
   If (NRKSdk.GetMPStepMessages(msgArray)) Then
    ‘Declare a variable to hold the array index.
    Dim i

    ‘Declare a string to hold the message
    Dim msg As String = “”

    ‘Loop through the array to assemble the
                                 ‘message.
    For idx = LBound(msgArray) To      
                                        UBound(msgArray)
         msg += msgArray(idx) + Chr(10) + 
                                         Chr(13)
    Next

    ‘Now display the message.
    MsgBox(msg)
   End If
  Case MPStatus.UNDONE
    msgbox(“Command hasn’t been executed!”)
  Case MPStatus.INPROGRESS
    msgbox(“The command is currently being executed...”)
  Case MPStatus.CURRENTTASK
    msgbox(“The step is the current task.”)
 End Select
End If

Getting Return Arguments
If an MP contains a “Result Only” argument, then the result argument 
can be retrieved by a calling the appropriate argument get methods, 
such as getVectorArg() and getPointNameArg(). For example, if the MP step 
successfully executes and a vector result argument is returned, the 
following code could be used to retrieve the result:
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If (bSendStatus) Then
 ‘Declare a long int to hold the return code.
 Dim result As Long
 NRKSdk.GetMPStepResult(result)
 If (result = MPStatus.DONESUCCESS) Then
   ‘Get the return values and store in variables.
   Dim xVal, yVal, zVal As Double
   NRKSdk.GetVectorArg(“Vector Representation”, xVal, yVal, zVal)
 End If
End If



CH
A

PT
ER 32

789

What Is OPC?
OPC is an acronym that originally stood for “OLE for Process Control”, 
but has since been renamed to “Open Platform Communications”. It 
is a standard originally developed in 1996 to enable communication 
of real-time factory data between various hardware devices and soft-
ware applications from different manufacturers.

OPC as a communication standard enables various devices in a man-
ufacturing environment to communicate among themselves—for 
instance, allowing real-time measurement data to be monitored by 
other hardware, or to track part progress through an assembly line in 
a real-time database.

SA & OPC
The OPC DA (Data Access) server functionality is available in SA Ulti-
mate (64-bit only). SA’s implementation is based on version 2.05 of 
the OPC DA specification. Any client that complies with this specifica-
tion can communicate with SA’s server—that is, that client has the 
ability to read from and write to SA’s OPC server.

SA supports the OPC standard, enabling a wide-variety of possibilities 
for real-time communication between itself and other applications or 
process control hardware. This chapter discusses the capabilities and use 
of this interface.

The OPC 
Interface
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Prerequisites
In order to activate and use the OPC DA server in SA, the following 
prerequisites must be satisfied:

 ■ The OPC Core Components Redistributable (x64) 3.0 package 
must be installed on the system,

 ■ 64-bit SA Ultimate must be installed,

 ■ SA’s OPC server must be registered and enabled, and

 ■ The OPC server DCOM and network settings must be config-
ured for remote client access.

The OPC Foundation (http://www.opcfoundation.org) provides a 
compliance test client for the data access 2.05 specifications to all of 
its members. A sample client which can be used to try out new SA 
functionality can be downloaded for free from one of the following 
websites:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

Configuring the OPC Server

Step 1: Creating a DCOM User

Windows 7 Home Premium

1. Login to Windows 7 under an administrator account.

2. Under the Windows Control Panel > User Accounts, select Man-
age another account. Then click Create a new account.

3. Add a new administrative user OPCUser, password nrkopc.

Windows 7 Professional
1. Under the Windows Control Panel, select Administrative Tools, then 

select Computer Management.

2. Expand the Local Users and Groups item in the tree.

3. Right-click Users and select New User... from the context menu.

4. Enter OPCUser for the User Name and nrkopc for the password. 
Enter a description as well (Figure 32-1).

5. Click Create, then Close.

 zTip: It is recommended that you 
create a system restore point prior to 
changing the system configuration.

 XNote: For Windows 7 Home Premium, 
this must be an administrator account.

http://www.opcfoundation.org
http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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6. Add the new user to the Distributed COM Users group 
(Figure 32-2).

Step 2: Disable Windows Firewall

1. Under Windows Control Panel, select Windows Firewall.

2. From the sidebar, select Turn Windows Firewall On or Off.

3. Select the turn off Windows Firewall (not recommended) op-
tion.

Figure 32-1. Setting up an OPC 
user account.

Figure 32-2. Making the new user 
a member of the Distributed 
COM Users group.

Step 3: Adjust User Account Control Settings

1. As administrator, type uac in the start menu.

2. Set the UAC to never notify, then click OK.
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3. Restart the computer.

Step 4: Install SA

1. Log into the OPCUser account.

2. Install SA as usual.

3. If SA automatically starts at the end of the install, close it.

Step 5: Install OPC Core Components

1. Run the OPC Server Utility (C:\Program Files (x86)\New 
River Kinematics\SpatialAnalyzer <version>\
x64\OpcServerUtility.exe).

2. If the core components are missing on your system, the utility 
will notify you—continue with the following. Otherwise, skip 
to step 6.

3. To install the missing components, you download the OPC 
Core Components Redistributable (x64) package from the 
OPC Foundation website (https://opcfoundation.org/).

4. After installing the core components, restart your computer.

Step 6: Register the NRK OPC DA Server

1. Login to the OPCUser account.

2. Ensure SA is not running, then run the OPC Server Utility (see 
Step 5, item 1).

3. Click the Register SA OPC Server button.

Step 7: Enable the OPC Server in the SA Configuration

1. Run SA Ultimate (x64) or greater.

2. In SA’s User Options dialog, select the Machine Configuration tab.

3. Turn on the enable OpC Server option. The server will now run 
in the future whenever SA is running.

Step 8: Test the Server with a Local Client

1. Install a client onto the machine. For instance:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

2. Start the client application.

3. Verify that the NRK OPC DA Server is presented in the list of 

https://opcfoundation.org/
http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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local v2 data acess servers.

4. Connect to the SA OPC server and browse its tags.

5. Add items to the client’s group and verify that data is updat-
ing as appropriate.

6. Once proper local operation is verified, close the local OPC cli-
ent and SA Ultimate before continuing on.

Step 9: Configuring System-wide DCOM Settings

1. Ensure you’re logged in as OPCUser.

2. Run the OPC Server Utility (step 5, item 1).

3. Click the View DCOM Configuration button.

4. Right-click on My Computer and select Properties from the 
context menu.

5. In the Default Properties tab, ensure that the enable distributed 
COM on this computer option is enabled. The Default Authentica-
tion Level should be set to Connect, and the Default Impersonation Level 
should be set to identify (Figure 32-3).

Figure 32-3. Setting the 
computer’s default component services 
properties.

6. Select the COM Security tab. Click the Edit Default... button in the Ac-
cess Permissions group.

7. In the Access Permission dialog, add permission for Every-
one and the ANONYMOUS LOGON users, then click OK.

8. Click the Edit Limits... button in the Access Permissions group.

9. In the Access Permission dialog, add permission for Every-

 XNote: At least one tag (NRK SA Ver-
sion) is always available in the OPC 
server’s address space. If you add an 
instrument to your job file, SA automati-
cally adds the instrument’s coordinates 
to the address space.

 XNote: Both of these are required for 
OPC functionality.
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one and the ANONYMOUS LOGON users, then click OK.

10. Click the Edit Default... button in the Launch and Activation Permissions 
group.

11. In the Launch and Activation Permission dialog, add permis-
sion for Everyone and the ANONYMOUS LOGON users, then 
click OK.

12. Click OK again to close the My Computer Properties dialog.

Step 10: Configure the OPC Server’s Specific DCOM Settings

1. In the Component Services window, open the properties of 
the NRK SA OPC DA Server (Figure 32-4).

Figure 32-4. Opening the 
properties for the NRK SA OPC DA Server 
component.

 

2. In the General tab, set the Authentication Level to default.

3. Verify that the Security tab’s Launch and Activation Permissions are set as 
indicated in Figure 32-5 (no launch is allowed).

Figure 32-5. Settings for the 
Security tab.

4. Verify that the Security tab’s Access Permissions are set as indicated in 
Figure 32-6.

 XNote: Do not adjust system-wide 
COM security Launch and Activation 
permissions limits (the Edit Limits... but-
ton).

 XNote: The OPC clients are not allowed 
to launch SA. For this purpose the Local 
Path parameter is not configured and the 
Location tab’s parameters are not set.
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Figure 32-6. The Security tab’s 
Access Permissions.

5. In the Endpoints tab, verify that DCOM Protocols and Endpoints are set to 
defaults (the default is TCP/IP).

6. Set the Identity to interactive User to allow displaying of the SA 
GUI elements on the server side.

Refer to the following section to configure the client side.

Configuring the OPC Client

Step 1: Create an OPC User Account & Install Components

1. Follow the instructions described in  “Step 1: Creating a DCOM 
User” on page 790.

2. Follow the instructions described in “Step 5: Install OPC Core 
Components” on page 792.

Step 2: Configure System-Wide DCOM Settings

1. Ensure you’re logged in as OPCUser.

2. Run the OPC Server Utility (step 5, item 1).

3. Click the View DCOM Configuration button.

4. Right-click on My Computer and select Properties from the 
context menu.
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5. In the Default Properties tab, ensure that the enable distributed 
COM on this computer option is enabled. The Default Authentica-
tion Level should be set to Connect, and the Default Impersonation Level 
should be set to identify (Figure 32-3).

6. Select the COM Security tab. Click the Edit Limits... button in the Access 
Permissions group.

7. In the Access Permission dialog, add permission for Every-
one and the ANONYMOUS LOGON users, then click OK.

8. Click the Edit Limits... button in the Launch and Activation Permissions 
group.

9. In the Launch and Activation Permission dialog, add permis-
sions for Everyone, Distributed COM Users, and ANONY-
MOUS LOGON, then click OK.

Step 3: Test the OPC Server Connection

1. Restart the computer.

2. Install a client onto the machine. For instance:

 ■ www.softing.com/opc (select OPC Classic options)

 ■ www.matrikonopc.com/products/opc-desktop-tools/opc-ex-
plorer.aspx

3. Start the client application.

4. Browse the remote OPC server to verify that data is being re-
ceived.

Using SA’s OPC Server
Once the server is up and running, the server’s identifications (class 
ID, description, and program ID) are displayed in the client (Figure 32-
7).

Figure 32-7. The SA OPC DA server 
identifications.

The following parameters are available to the OPC server:

 ■ Active coordinate values for each live instrument as a 3-entry 
array of doubles (XYZ).

 ■ Active coordinate values for each live instrument as separate 
values (X, Y, and Z).

 ■ The current SA version.

 ■ The full name of each instrument.

http://www.softing.com/opc
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
http://www.matrikonopc.com/products/opc-desktop-tools/opc-explorer.aspx
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The tag name for each coordinate includes the collection and instru-
ment ID for the associated instrument—for example, A::0.x (Figure 
32-8).

Figure 32-8. Tags for single-
coordinate items in the OPC server.

Point coordinates are presented with A::0.xyz tag names in the array 
format (Figure 32-9):

Figure 32-9. A coordinate as an 
array.

MP Support

Measurement Plan commands have been added to support interfac-
ing with SA’s OPC server—both setting and retrieving values from the 
server’s address space. These commands include:

 ■ Set OPC DA Tag Value Double

 ■ Get OPC DA Tag Value Double

 ■ Set OPC DA Tag Value Integer

 ■ Get OPC DA Tag Value Integer

These commands are detailed in the MP Command Reference. The 
“set” commands will create a double or integer in the server’s address 
space under the specified tag name. This value can be retrieved from 
the address space using the corresponding “get” command, or can be 
updated (overwritten) by specifying another “set” command.



798

SPATIALANALYZER USER MANUAL

This Page Intentionally Left Blank.



CH
A

PT
ER 33

799

SA Machine
SA Machine contains all of the features of SA Ultimate + Native CAD, 
but also allows interfacing with robots and CNC machines. This per-
mits calibration and compensation of robots and large volume CNC 
machines to high degrees of accuracy. It also enables robotic script-
ing, teach pendant behavior, and linear or joint space robotic control.

 Usually, robots are delivered by the manufacturer with default kine-
matic models that are accurate to on the order of about 1/2 - 1/4”. 
This depends on the manufacturer, product, calibration level, and 
other factors. Many manufacturers offer calibration packages that 
might improve this accuracy to perhaps 0.1”. CNC machines (espe-
cially large-volume machines) can also encounter the same sorts of 
issues (although they are usually more accurate). Regardless, this de-
fault accuracy is nowhere near what’s necessary for precision applica-
tions. There are several reasons for this. One might be that the manu-
facturer’s kinematic model is not quite right or doesn’t incorporate 
things like the stiffness of the linkages or the weights of tools on the 
machine very well (if at all).  

SA’s Robot and Machine calibration functions have a few purposes. 
The first benefit is that they can be used to calculate a significantly 
more accurate kinematic model than is provided by the manufacturer 

Note:  While SA Ultimate al-
lows robot calibration, only 

SA Machine can connect with ro-
bots to enable true real-time com-
pensation and control.

SpatialAnalyzer has the unique ability to integrate portable metrology 
measurements for the calculation of true metrology-compensated robot 
and CNC machine calibrations. 

Machine 
Calibration
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by default. The following discussion will refer to robots, but it applies 
equally well to CNC machines.  

To calculate a new kinematic model, a robot is commanded to go to 
a set of poses throughout the desired volume of use and whose posi-
tions in the robot controller’s coordinates are known. For each pose, 
measurements are taken on the robot’s end effector to determine the 
actual position of the tool compared to where it was “asked” to go. 
These measurements can be taken with a single measurement from a 
6-DOF measurement device, or they can be taken by measuring 3 tar-
gets with a 3-DOF measurement device. (Any measurement method 
that results in 6-DOF information can be used, including photogram-
metry).

Once a set of commanded positions and measured “actual” positions 
are determined, this data is run through a series of kinematic algo-
rithms to determine an accurate kinematic model for the specific ro-
bot (machine) of interest. Using this kinematic model, any position 
that you’d like to send the robot to is first backed through this kine-
matic model to give the controller a new set of positions. In other 
words, based on the calculated kinematic model, SA Machine tells the 
controller where the robot ought to go (based on its kinematics) to 
end up where you want it to be. This results in a drastically improved 
result, (to accuracies of about 0.010”, for example). Although this is a 
big improvement, it can be taken a step further.  

Now that the robot has gone where we think it should go, the end-ef-
fector can be measured again, which tells us where the robot actually 
went compared to where we expected it to be. We can then iterate 
through the kinematic model to give a small correction to the robot, 
getting it even closer to the desired target. We have demonstrated ac-
curacies to about 0.001”-0.002” using this method, which is quite ac-
curate for a robot. Given the accuracy of the encoders on the robot’s 
servos, this can’t be beat without more accurate hardware encoders. 
This process is a great way to position tools and other items with very 
high accuracy/repeatability.

Robots in SA

Adding a Robot to SA
There are two ways to add a robot to SA.

 ■ To load an existing SA Robot use Analysis>SA Machine - Robots and 
Machines>Add Machine>Load .SAMachine File (kinematics and graphics).

 ■ To create a new Robot use Analysis>SA Machine - Robots and 
Machines>Add Machine> Add Serial Robot>Using Kinematic Definition 
File.

Once a robot is added to the tree it is displayed under the Robots and 
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Machines category.

Robot Category
This category contains the specific Robot or Machine with the respec-
tive components and calibrations (Figure 33-1).

Figure 33-1. The properties of a 
Kuka KR 5 robot.

 ■ Show. Show/Hide all components

 ■ Show Link Frames. Show/Hide Link Frames

 ■ Properties. Displays properties

 ■ Teach Pendant. Displays teach pendant dialog in which user 
can control robot via several different methods.

 ■ Edit Machine to World Transform. Displays machine base 
transform dialog allowing for the machine to be transformed 
with respect to the current frame.

 ■ Command Controller Motion. Sends move commands to ma-
chine based on controller kinematics or SA kinematics.

 ■ Simulate Motion. Simulates move commands to machine 
based on SA kinematics.

 ■ Delete. Delete machine from SA TreeBar.

 ■ Make Frame at last end-effector update. Creates a SA coordi-
nate frame at the last end-effector position.

 ■ Add Graphical Entity. Adds a new component.

 ■ Save to File. Saves current machine to .SAMachine file.

Components
The Components sub-category contains each link of the robot with 
its respective graphical representations (Figure 33-2).



802

SPATIALANALYZER USER MANUAL

Figure 33-2. The properties of the 
robot’s waist joint.

 ■ Properties. Displays the Manipulator Segment Properties - 
Denavit-Hartenberg Dialog. Here the Segment Transform and 
Joint Variables can be modified.

 ■ Set Kinematic Control Frame. Select the Link Frame for the 
component.

 ■ Delete. Deletes the selected component.

 ■ Add CAD to Component. Select surfaces to attach to compo-
nent at current location.

 ■ Make Frame at current location. Creates a SA coordinate 
frame at the current component location.

Calibrations

Figure 33-3. A calibration in the 
tree.

 ■ Calibration Interface. Displays the Calibration Interface for 
the respective calibration set.

 ■ Trap Measurements from an Instrument. Allows incoming 
measurements to be paired with current joint sets.

 ■ Stop Trapping Measurements. Stops the trapping of incom-
ing measurements.

 ■ Delete Calibration. Deletes selected calibration.
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 ■ Import Joint Poses and match to measurements. Imports 
Joint Poses and pairs with selected measurements. Often used 
when a live interface to a Robot is unavailable.

 ■ Export Joint Poses. Exports the Joint Poses from the selected 
calibration set.

Controlling a Robot from SA

There are several ways to control a Robot from SA. The following sec-
tions will cover the various methods.

SA Teach Pendant
The SA Teach Pendant (Figure 33-4) allows for Robot control from SA 
instead of the physical teach pendant. The SA Teach Pendant allows 
for individual actuator inputs, Cartesian moves and graphical input.

Figure 33-4. The Teach Pendant 
dialog.

 ■ Actuator Movement. Select the actuator to move and either 
enter the value or use the slider to increase/decrease the value. 
Select the Drive button to apply the movement to the Robot 
Controller.

 ■ Cartesian Movement. Here the TCP can be moved in Carte-
sian space about either the Tool, Base or World frame. Simply 
slide the respective sliders and then click the Drive button to ap-
ply the movement to the Robot Controller.
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 ■ Graphical Movement. Allows the user to graphically move the 
Robot and then apply the movement to Robot Controller by 
clicking the Drive button.

 ■ Command Machine. The Drive button sends over the specified 
movement in either Joint space or Cartesian space.

 ■ Auto Drive. Automatically sends movement to the Robot Con-
troller when values change.

Move to Frame
The Move to Frame commands (Figure 33-5) allow robot movements 
to be calculated from the selection of Coordinate Frames in SA. When 
used, the user will be prompted to select a frame. From here, the ro-
bot will be moved to the selected position either in controller kine-
matics or SA Kinematics.

Figure 33-5. The Move to Frame 
commands.

Measurement Plan
The SA Measurement Plan scripting language also includes several 
commands for controlling Robots. As the above section describes 
Move to Frame, similar commands are available in MP. MP is a great 
tool for automating data acquisition and robot movement.

 ■ Move Robot/Machine to Frame

 ■ Move Robot/Machine to Named Destination

 ■ Set Robot/Machine Parameter

 ■ Compute Robot/Machine Adjusted Goal Frame

Collecting Calibration Measurements

Collecting data for a Robot calibration only takes a few steps. Two sce-
narios exist: Collecting joint sets from a live robot or importing joint 
sets.
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To Collect Measurements from a Live Robot

1. Ensure that SA and the Robot are connected via the SA Robot 
Driver.

2. Add a new calibration by right-clicking Calibrations and se-
lect Add Calibration.

3. Right-click the newly added calibration and select Trap Mea-
surements from an Instrument.

4. Now the calibration set is ready to receive measurements and 
joint sets. As a measurement is received a corresponding joint 
set is recorded. Simply move the Robot to various poses and 
record measurements (Figure 33-6).

Figure 33-6. Pose data for a 
calibration set.

To Import Measurements and Robot Poses

1. Ensure the proper Robot poses are formatted in a .txt or 
.csv file:

<name>,<j1>,<j2>,etc.

2. Collect measurements for each pose and ensure the point 
names match the respective pose names.

3. Add a new calibration by right-clicking Calibrations and se-
lecting Add Calibration.

4. Right-click the newly-added calibration and select Import Joint 
Poses and match to measurements. You will be prompted to 
select the points and pose file.

Calibration Interface

The calibration interface is used to compute the new kinematic mod-
el for the robot based on the recorded poses and measurements (Fig-
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ure 33-7).  

Figure 33-7. The Machine Calibra-
tion dialog.

 ■ Components. Displays the current components for the current 
Machine. Right-click a component to access properties.

 ■ Pose Name and Errors. Displays each pose and correspond-
ing positional and rotational errors. Uncheck a pose to remove 
from solution.

 ■ Measured Point in Tool Coordinates. Used to define the mea-
sured target in the TCP frame when using single point measure-
ments. Not needed when using a 6 degree of freedom target.

 ■ Rough-fit tool tips to measurements. Performs a best-fit of 
the tool tip locations to the measurements to ensure a good 
initial condition for the optimization.

 ■ Settings. Displays the tool orientation weighting factor.

 ■ Generate Report. Generates a final report to Excel with solu-
tion results and kinematic properties.

 ■ Degrees of Freedom. Degrees of freedom for the base, link-
ages and tool of Robot.

 ■ Run Calibration. Executes the optimization.

 ■ Solution. Displays current position and orientation errors and 
RMS values.
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Best Practice for Running a Calibration
1. With measurements and poses captured, open the calibration 

interface by right-clicking the calibration set of interest and 
choosing Calibration Interface.

2. Ensure a good initial starting condition by pressing Rough-fit 
tool tips to measurements. The overall errors will reduce greatly as 
the measurements and tool tip positions are best-fit to one 
another.

3. The initial Degrees of Freedom (DOF) are to allow the base 
and tool to move freely while maintaining the nominal kine-
matics (Figure 33-8). The tool DOF should only be set to 6 DOF 
when 6 DOF measurements are present. Press Run Calibration to 
start the optimization.

Figure 33-8. The Degrees of 
Freedom box.

4. Now, if desired, allow the Robot kinematics to vary by choos-
ing Partial or Full (Figure 33-9). Press Run Calibration to start the 
optimization.

Figure 33-9. Choosing a partial 
robot DOF solution.

5. At any time, make sure to validate any potential outliers and 
remove by un-checking the pose and re-running the optimi-
zation by pressing Run Calibration.

6. Once satisfied with optimization, generate a report for exter-
nal sources and/or apply the new calibration to SA by press-
ing Apply.

7. This calibration will now be used when moving the robot with 
SA Kinematics.

Figure 33-10. The Move to Frame 
option.

Kuka Robot Deployment
Below are the necessary components to operate SA and SA Robot 
Driver with Kuka Robots.
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XML Channel configuration and Data format files (C:\KRC\Roboter\INIT)
 ■ RAC.xml

 ■ RAC+.xml

 ■ XmlApiConfig.xml (set tcp/ip address and port of remote ac-
cess computer – secondary fixed ip on remote computer)

KRL Client Communication  (C:\KRC\Roboter\KRC\R1\Program)
 ■ SAKRL.dat

 ■ SAKRL.src

KRL Client motion programs (called by SAKRL.SRC   C:\KRC\Roboter\KRC\R1\Pro-
gram)

 ■ MoveToFrame.SRC and .DAT

 ■ MoveToJointSet.SRC and .DAT

 ■ HitEStop.SRC

VxWorks Communication Configuration (C:\Windows)
 ■ vxWin.ini (robot controller VxWorks tcp/ip address modified 

under e={……})

Server application and data format files on remote computer
 ■ SARobotDriver.exe

 ■ EKX Server.exe

 ■ RACData.xml

 ■ Global Data  (c:\KRC\Roboter\KRC\R1\System)

 ■ $config.dat

SA Robot Driver – Kuka Controller Requirements
 ■ KR C2 Controller

 ■ Kuka System Software

 ■ KSS v.5.5

 ■ Kuka Ethernet KRL XML

 ■ v. 1.2

 ■ 3COM Ethernet Card Option

Denavit-Hartenberg Notation1

The first step in calibrating a manipulator is to understand its nominal 
kinematic parameters, and the controller’s ability to accept new, cali-
brated values for these parameters. This section will describe how to 

1 For a more detailed description of Denavit-Hartenberg nota-
tion see Craig, J. J., 1989, Introduction to Robotics: Mechanisms and 
Control, Addison Wesley, New York.
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represent a robot’s kinematics. Most manipulators are serial devices, 
meaning they are composed of a series of links and joints connected 
in an open chain.  Denavit-Hartenberg  notation is a standard means 
for specifying the kinematics of a manipulator. See the example table 
below, then a brief description of the meaning of the parameters.

Figure 33-11. A robot and its 
Denavit-Hartenberg (D&H) table.

Link α a d θ Type

1 0.0 0.0 0.0 0 Revolute

2 -90.0 0.0 0.0 0 Revolute

3 0 8.0 -4.8 0 Revolute

4 -90.0 0.0 8.0 0 Revolute

5 -90.0 0.0 0.0 0 Revolute

6 -90.0 0.0 0.0 0 Revolute

Links are rigid members; joints allow relative motion between the 
links. The chain starts at the base, or ground link, and ends at the 
working tool. Except for the tool link and the base, each individual 
link in the chain begins and ends with a joint. The tool may be a grip-
per, paint sprayer, welding tip, electro-magnet or any of a wide vari-
ety of devices. Common manipulators use only revolute (turning) or 
a prismatic (sliding) joints to connect links. More complicated forms 
of joints can always be modeled as a combination of these simple 
elements. The function of a link is merely to fix the relationship be-
tween the joints at either end of the link. As long as the two joints are 
held at the same relative position and orientation with respect to one 
another, the link serves only as a rigid connector. The actual physical 
shape of the link can be changed  without altering the kinematic rela-
tionship between the two interconnected joints.

A kinematic description of the manipulator is generated by SpatialAn-
alyzer  using the standard Denavit-Hartenberg  notation. This remark-
ably simple representation uses only two values to describe each link, 
and two additional values to describe the joint connection between 
adjacent links. Links are described in terms of their length (a) and the 
twist they maintain between adjacent joints (α), as explained below.
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 ■ Twist Angle (α). The angle between the first and second joint 
axes on a link. This angle is measured in a right-hand sense 
when viewed directly along the common normal.

 ■ Link Length (a). The distance between the two joint axes of a 
link. This distance must be measured along a line that is normal 
(i.e. perpendicular) to both joint axes. This line is referred to as 
the common normal between the joint axes.  If the joint axes 
intersect (a common arrangement in industrial manipulators), 
the link will have zero length. The joint connection between 
adjacent links is described in terms of the offset (d) and the 
joint angle (θ), as explained below.

 ■ Offset (d). The distance between the common normal of one 
link and the common normal of the next, measured along the 
axis of the joint connecting the two links.

 ■ Joint Angle (θ).  The angle between the common normal of 
one link and the common normal of the next, measured about 
the axis of the joint connecting the two links.

The four parameters α, a, d, and θ, when taken for each link and joint 
in the chain, provide a complete kinematic description of the manip-
ulator. When taken together with a description of the physical shape 
of each link and limits on joint motion, an accurate simulation of ro-
bot motion and operating workspace can be developed.

In addition, there is usually a Joint Offset value computed during the cali-
bration. This value represents the difference between the “kinematic 
zero” of a joint, and the mechanical zero based on how the encoder 
was set in the joint mechanism.

For a more detailed description of Denavit-Hartenberg notation see:

Craig, J. J., 1989, Introduction to Robotics: Mechanisms and Control, 
Addison Wesley, New York
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Tutorial Index:
Spatial Analyzer Setup and Configuration:

“Installing Spatial Analyzer (SA)” on page 812

“Displaying Ribbon Menus” on page 812

“Customizing New SA Job Files” on page 813

Basic Operations

“Navigating the Graphical View” on page 814

“Point  Properties and Data Management” on page 819

“Coordinate Systems In SA” on page 826

Instrument Connection and Operation

“Connecting an Instrument” on page 838

“Basic Tracker Operation Using the Instrument Toolbar” on page 838

Basic Alignments

“Measure Nominal Points” on page 847

“Drift Check Verification and Re-Alignment” on page 851

“Using Best-Fit to Align Point Measurements” on page 857

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Tutorials
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“Quick Align to CAD” on page 864

Feature Measurement

“Creating Features from Existing Points” on page 869

“Cloud Based Part Inspection with an Arm” on page 893

“Inspection with GD&T” on page 899

Reporting

“Basic Point Analysis” on page 905

“Creating Callouts” on page 911

“Reporting With SA Reports” on page 915

Installation and Configuration

Installing Spatial Analyzer (SA)

SA is a Windows only application. To run SA on a mac a windows com-
patibility environment must be run through Boot Camp or a similar 
application.

The current version of SA, as well as a beta testing version, can be 
downloaded from the kinematics.com webpage here:

https://kinematics.com/download/downloadindex.php

To install the application double click on the SpatialAnalyzer ####.exe 
file and follow the directions. 

For more information on installation and licensing refer to: 

“Getting Started” on page 5

Displaying Ribbon Menus
Starting in 2019 a ribbon menu was added to SA. This ribbon menu 
was designed to incorporate the best of the classic menus and the 
Toolkit menu and streamline SA workflow. The display of the ribbon 
menu is optional and enabled with a check box option on the Display 
tab of the Users Options “Show Ribbon Bar” (Figure 34-21):
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Figure 34-1. Default SA Window. 
The On/Off control for the Ribbon menu 
is found in the User Options on the 
Display Tab.

 The following tutorials will use the Ribbon menu display. Buttons 
within the tabs are referenced as [Tab Name]>[Section Name]>[Button 
Name]>[Sub Button Name]. So as an example, you can rename a 
point by going to the Home(the tab to select)>Point Editing (ribbon sec-
tion to look in)>Rename (the large icon). You can also rename many 
points using a naming patter by going one level deeper Home>Point 
Editing>Rename>Points using a Name Pattern , indicating to use the drop 
down button under Rename and select from within.

Customizing New SA Job Files
Much of SA can be customized. Some basic settings are saved in the 
registry and will persist when SA is closed and reopened. However, 
much of the settings are saved within a job file. To customize how a 
new job file looks you can save a template by doing the following:

1. Configure a job file such that it has the settings you would like 
to see when SA opens.

2. Select File>Save as Read-Only SA Template (Figure 34-107) 
and save the file within the C:\Analyser Data\Templates direc-
tory as “default.xit64”. 

Figure 34-2. Saving a Job File as a 
Read Only Template

Additional template files can be saved and opened as needed but the 
default template is used for newly created job files automatically. 
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Basic Operations

Navigating the Graphical View

Here is a summary of the mouse-clicks and keyboard shortcuts for 
navigating the graphical view (Figure 34-3). A printable list of short-
cust is also available here: “Keyboard shortcuts” on page 920”Key-
board shortcuts” on page 920.

Figure 34-3. KeyBoard Shortcuts 
for Graphical control

Navigating the Graphical View Tutorial

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover basic view control 
functions.

 ■ Areas Covered. Hiding and Showing of objects, background 
color, panning, zooming and rotating.

 ■ Time to Complete. Approximately 15 minutes.

Changing Render Settings
Here we will change the render mode for the SA graphics from wire-
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frame to solid.

1. Open Query Points to Surface.xit from the Samples 
directory under Help>Open Sample SA Files. When a file is opened, 
surfaces are by default rendered in wireframe mode in order 
to open the file as quickly as possible.

When a new file is opened, the CAD surfaces are displayed in wire-
frame mode by default. This avoids the wait that might be required if 
the surfaces were to be solid rendered in the view – something that 
could be a lengthy operation in a large, complex file.

2. The Render settings can be changed with the render mode 
icons available on the Home >Display section(Figure 34-114). 

Figure 34-4. Render mode 
controls

Try each of the Render settings. Now render the model solid by using 
the Solid icon (Figure 34-114).  

 ■  Wireframe. Geometry is displayed as edges only, and hidden 
edges are visible. 

 ■  Hidden Line Removed. Geometry is displayed as edges only, 
but hidden edges are not displayed. 

 ■  Solid + Edges. Solid surfaces are rendered in addition to edg-
es. 

 ■  Solid. Solid surfaces are rendered without edges. 
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Figure 34-5. Rendering in solid-
shaded mode.

Change Background Color
Let’s change the background color from a gradient to a solid color.

3. Access the background color options by using the Back-
ground button on the main toolbar also in the display section 

of the Home tab .

4. In the Background dialog (Figure 34-6), select the Solid color 
radio button. Now select a solid color by clicking the current 
solid color swatch. The color palette will display--choose a 
green color and press OK. Exit the background color dialog 
by pressing OK. After your eyes adjust...go back and change 
the background color to white by using the shortcut for white.



817

CHAPTER 34 ■ TUTORIALS

Figure 34-6. Changing the 
background color.

Hide and Show
Let’s experiment with the ways to hide and show points, objects, and 
other SA entities. In addition to the menu controls in the Visibility sec-
tion you can directly interact with the parts in the tree or the graphics:

5. Hide the vector group called Boat error_Vectors_Blotches from 
the tree. Expand the Vector Group category in the tree. Now right-
click Boat error_Vectors_Blotches and uncheck Show. The ob-
ject name will be greyed out in the tree (Figure 34-7). To show 
a hidden item, simply select Show again.  

Figure 34-7. Hiding the vector 
group in the tree.
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TRANSLUCENCY
6. Right-click on the dish surface in the graphical view and select 

Translucency. Change the setting to Translucent and click OK.

Figure 34-8. Changing CAD  trans-
lucency so you can see through it.

Zoom, Pan and Rotate
Now that we can change colors, render, and hide/show objects, let’s 
learn how to manipulate the graphical view. See the Graphical View 
section for more information regarding Zoom, Pan and Rotate.

Zoom

1. Zoom in on the graphical view by placing your cursor over a 
zoom point of interest and rolling the scroll wheel forward on 
your mouse.

2. Zoom out by using the Page Down key.

3. Left-click in a region in which you’d like to zoom, drag a rect-
angle around that region, then release the cursor in the op-
posite corner to fit the zoom to your rectangle.

4. Now let’s put all visible objects back in the view by using Au-
toscale . You can also use the hot key (Alt+A).

Pan

5. Try panning by clicking and holding the center scroll wheel 
on the mouse. Then proceed to drag your mouse. If you don’t 
have a middle mouse button you can pan by holding down 
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the Shift key while pressing the left mouse button and 
dragging the mouse.

6. You can also use the arrow keys on the keyboard to pan the 
view up, down, left and right.

Rotating

7. Now let’s rotate the graphical view. Press and hold the right 
mouse button and drag the mouse. You will quickly notice 
that the view pivots about a particular point in space.

8. Let’s change the rotation center by selecting the View Rota-
tion Center button from the toolbar. Select one of the 
points at the corner of the model. Now rotate and you will see 
how the view pivots about the selected point.

Preset Views

Preset views are available which allow for quick orientation of the 
graphical view.

9. Press the drop down beside the  icon and select Top. This 
will orient the view with respect to the World frame. 

10. Saved presets can also be used. Now select the vector view 
preset view from the list.

Conclusion
We have now covered many ways to render objects, change back-
ground colors, show/hide objects and manipulate the graphics.

Point  Properties and Data Management

Keywords
 ■ Point Group. A group of points that share a commonality.  This 

could be a set of points that all define a specific feature, or all 
make up a group of fiducials. 

 ■ Measured Point.  A point that was measured from an instru-
ment and will have all metadata associated with it. Measured 
points are automatically tied to an instrument and will move 
with it any time an instrument’s alignment is adjusted.

 ■ Constructed Point.  A point that is created manually in a job 
file or a point that is imported.  

 ■ Target Offset.  The amount that a point will needs to be shifted 
prior to checking its deviation from an object.  This is typically 
established when the point is measured via the instrument in-
terface. 
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Opening a file to play with
1. In the Ribbon Bar, go to the HELP tab. In the Documentation 

section, choose  Documentatoin>Sample Files.

2. Open the SA file Best Fit points to points.xit. 

VIEW POINT PROPERTIES
3. Expand the Points Groups category in the tree to show Sta-

tion1 and Nominals point groups.

4. Now expand the Station1 and Nominals point groups to dis-
play the points in each. Take note of the icons for each point 
(Figure 34-9).  

Figure 34-9. Measured vs. Con-
structed Points.

(NOTE:  The red icons for the Station1 point group indicate they are 
measured points from an instrument.  The blue icons for the Nomi-
nals point group indicates they are constructed or imported points.)

5. Single left-click on the white triangle next to P1 located in the 
Station1 point group to see its X, Y, and Z values relative to the 
working frame.

6. Open the full target information for P1 by double-clicking it in 
the tree or graphically.  Right-clicking to open the properties 
is also an option (Figure 34-116). 
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Figure 34-10. Right-click to Open 
Point Properties

7. Select Measurement Details, to open the metadata for P1.  This 
will show you all the information that is attached to this point.

8. After reviewing select Done to close the dialog.

9. Notice at the bottom of the Target Information dialog there 
is a place where the planar and radial target offsets can be 
changed.  Select OK to exit the target information dialog. 

POINT MANAGEMENT
SA handles off sets by always recorded the center of the probe and 
recording the offsets as part of the point’s properties. This allows SA 
to applying those offsets when a geometry fit or query is performed 
and use the direction vector of each point to object comparison to 
determine the exact off set direction. This ensures that the most ac-
curate offset is always used (Figure 34-11).
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Figure 34-11. Offsets Recorded 
with a Point

Both Planar and Radial offsets are saved in a points properties. The 
planar offset is the primary offset used for most everything. Anytime 
you measure a surface the query direction provides the “planar direc-
tion for comparison. Radial offsets are secondary, only being used as 
part of a geometry fit where such as in a pin-net measurements of a 
hole. In this case the circle can be fit first, in plane, and then the radius 
can be adjusted as needed (Figure 34-12).

These values are set automatically for you when you select the cor-
rect tooling in the instrument interface and measure from within SA, 
but they can easily be adjusted.
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Figure 34-12. Planar and Radial 
Offsets

We noticed earlier that the point offset for P1 was 0.75” planar and 
radial.  Let’s change those point offsets to 1” for every point in the Sta-
tion1 point group.

10. Right-Click on the Station1 point group in the tree and select 
“Set Point Properties”. 

Figure 34-13. Set Properties for 
Multiple Points at one time.

 ■ A. Select the top checkbox to change the target offsets. 

 ■ B. Type “1.0” in the textbox next to “Planar and Radial” to change 
the offsets to the desired value. 
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 ■ C. Select second checkbox to apply the settings to the mea-
surements.

 ■ D. Click OK to update the points.

11. Check the properties of any point in the Station1 point group 
to ensure the planar and radial offsets show 1”, respectively.  
Then Click Ok to close.

12. In the Ribbon Bar, select Group Manager.  This will show you 
every point group in the SA job file and its values.

13. Here we can rename multiple points simultaneously.  (Ensure 
to have the Station1 point group selected). Press Ctrl+h to 
bring up the “Replace” dialog.  

Figure 34-14. Renaming Points 
Using Group Manager

 ■ A. Type “P” in the search field. 

 ■ B. Type “Nom_” in the replace field. 

 ■ C. Click OK.

EXPORT/ IMPORT POINTS
14. Right-Click on the Nominals point group in the tree and select 

“View Point List”.
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15. In the next dialog click “Export to Text file”.

16. You will be prompted to select every point in the list shown, 
select “Yes”.

17. Next you will need to choose a location to save the exported 
point list.  Choose the desktop, the default file name will be 
“Point List.txt”, click Save.

18. In the next dialog, the Ascii Export dialog, you can change 
some of the export settings, but here we will select OK.

19. Finally, you will see your saved point list in notepad.  You can 
close this window and return to the job file.

20. Now, at the top left corner of the SA Job file, click on the file 
menu icon and follow the steps laid out in the below image to 
import the Ascii File. 

Figure 34-15. Importing Points 
from an AScii Text file.

21. When prompted, select the file that you would like to import 
and choose the Point List.txt file that you previously saved to 
your desktop.

22. The Ascii Import window will open.  All the settings should be 
set correctly by default, so select Import at the bottom of the 
dialog.

23. An import report will open to notify you that 7 points were 
imported correctly.  Click OK. NOTE:  In the tree there should 
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now be another point group named Point List.txt and should 

include the 7 points that were exported.

Coordinate Systems In SA

Overview of How to Control Coordinate Sys-
tems

Spatial Analyzer provides a lot of flexibility when it comes to defining 
a base coordinate for a job file. There are lots of terms for this in differ-
ent software packages including:

 ■ Spatial Reference System

 ■ Coordinate Reference Systems

 ■ Coordinate Reference Frame

 ■ Frame of Reference

 ■ 6D location

SA uses the shortest and simplest term and calls a coordinate refer-
ence frame simply a “Frame”. Each job file has a base reference for the 
job file which is called the “WORLD” frame. Any time you open a new 
job file you will find that it already has a frame in it called “WORLD” 
which defines the base reference for the job file (Figure 34-16).

Figure 34-16. The World Frame is 
the Base reference for the entire job file.

Also notice that this WORLD frame is marked in bold blue letters and 
labeled “(Working)”. That means that this frame is used to define the 
reported locations of anything else in the job file. So if you were to 
create a cylinder and wanted to report its location you are imme-
diately given its location in a Cartesian coordinate system with the 
WORLD frame defining the origin of this reference. 

Building a Cylinder at a specific location

1. To build a cylinder navigate to the Construction Tab and in 
the Build manually drop down select Cylinder.
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Figure 34-17. Build a Cylinder by 
entering its coordinates.

2. The Properties of the newly created cylinder will pop up. To 
accept the default properties, select close at the bottom right 
of the window. 

In the example below the cylinder shown is 24” away in X and shifted 
9” away in Y and its origin is perfectly on the XY Plane with respect to 
the World Frame (Figure 34-18).

Figure 34-18. Location of a 
cylinder in 3D space with respect to the 
World frame.

Changing the Working Frame
What is unique about SA is that at any time you can select any frame 
in the job file, right-click on it and select Make Working Frame and it 
becomes the working frame for the job. This changes the reporting 
of all objects in the job file to now report their location with respect 
to the new “Working Frame”. In the image below a new frame was 
added to the prior example file without editing the location of either 
the World frame or the Cylinder. Once the New Frame was marked as 
Working the cylinder’s coordinates were updated to reflect its posi-
tion relative to the New Frame.
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Figure 34-19. Resulting change 
in location of a cylinder’s coordinates 
when a new frame is set as Working.

Its easy to tell which frame is the current working from because it 
is both clearly displayed in the graphics (only the working frame is 
drawn in 3D while the other frames in the job are shown as lines) and 
marked in the tree:

Figure 34-20. The Working frame 
in the tree is marked in Bold.

Setting A Reporting Frame
There are times when its helpful to be able to report the location of an 
object with respect to a frame that is not the current working frame. 
This can also be done and is set within the object’s properties by edit-
ing the “Reporting” Frame. 

Frames can be created in many ways, including being directly mea-
sured from any 6D probing device, and define a location. Including 
reporting a position and rotation in space they can also be used for 
alignment.

Working With Frames Tutorial

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will explore working with dif-
ferent coordinate frames, and see how the working coordinate 
frame affects the values reported in SpatialAnalyzer.

 ■ Areas Covered. Creating points and geometry, geometry 
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fitting, frame construction/activation, transformations, and 
point/object queries.

 ■ Time to Complete. Approximately 30 minutes.

Creating Entities to Work With
For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

3. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the Quick Access Toolbar.

 

4. Let’s create a few points to work with in the workspace. To 
do this, go to the Construction Tab and Press Build Manually 
press Ctrl+P.

5. In the Add Points to Model dialog (Figure 34-21), let’s place 
the points into a collection called nominal and a point group 
called nominalpoints. We’ll give the first point a name of 1. 
Give the point an X coordinate of 15, a Y coordinate of 10, 
and a Z coordinate of 7.  We’re entering these coordinates as 
Cartesian (XYZ) coordinates, so we’ll leave that setting at the 
default:  

Figure 34-21. Adding a point.

6. Click the Add Point button, then click Done. In the graphical 
view, you should see a point created at the specified coordi-
nate. If you don’t see it, autoscale the view by clicking the Au-
toscale button in the Quick Access Toolbar , pressing 
Alt+A.

7. In the tree view, you should see that the nominal collection 
now exists. Since it did not exist when you created the point, 



830

SPATIALANALYZER USER MANUAL

SA created this collection for you.

8. In the tree, (if necessary) click the disclosure triangle next to 
nominal to expand the list of items in the Nominal collection. 
Note that there is an item in the list named point Groups. SA 
sorts items in the tree based on their category. Expand the 
point Groups category, and you’ll see that SA created the nom-
inalpoints point group, because it did not already exist.

9. Expand the nominalpoints point group to show all points con-
tained within the point group, then click the triangle next to 
the single point to show the coordinate of the point named 
1. You should see the coordinates that you just entered (Fig-
ure 34-22).

Figure 34-22. The newly-added 
point.

10. The default collection in your SA file is currently ac-
tive, because it is depicted in bold blue font in the tree. 
Let’s activate our new nominal collection. Right-click on the 
nominal text in the tree and, from the context menu, choose 
Make Active Default Collection. Now, any geometry that you create 
will be placed into the active nominal collection.

11. Now let’s create another point. SA saves a history of the 
most recently used commands so that you don’t have to 
select them from the menu again if you’re repeating a sin-
gle command several times. To use this history, hold down 
Ctrl+Shift+Tab. In the upper-left corner of the graphical 
view, a menu should appear showing your recent commands 
since you started SA, with the most recent command at the 
top (Figure 34-23). You can also access this control directly on 
the Home Tab
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Figure 34-23. The list of recent 
commands.

12. Choose the Construct>New Points>Build Manually button from the 
list. Notice that SA remembers the last collection and point 
group that was used for this command. Enter 2 for the point 
name, and give it a coordinate of (20, 20, 20). Click the Add 
Point button.

13. After clicking the button, notice that SA automatically incre-
ments the point name by one. This behavior is found com-
monly in different parts of SA, and is intended to save time 
from typing, since incrementing names by one is so com-
mon.  Change the coordinates to (5,5,5) and click the Add 
Point button again to create the third point, then click the 
Done button to close the dialog.

14. Now let’s create a plane to work with. From the menu, select 
Construct>Plane(s)>Enter. The Plane dialog will appear (see Fig-
ure 34-26 on page 832), allowing you to specify properties 
for the newly created plane.

15. Leave the plane’s name at the default of Plane, and click the 
Transform button. Locate the plane at (35, 0, 0) and assign it 
an Rx value of 90°. Click the Update button.

16. If necessary, autoscale or zoom out so you can see the newly-
created plane relative to the points.

17. With the plane in view, set the Rx value back to 0°, and change 
Ry to 90°. Again, hit the Update button to see the plane change 
orientation. Now, click the increment arrows next to the Ry 
field and notice how the plane is rotating around the active 
coordinate frame’s Y axis. We’ll set the Ry value to 160°. Click 
the Update button, then click the “X” in the corner of the Plane 
Position dialog to close the window.

Note:  The Autoscale key-
board shortcut of Alt+A will 

only work if the graphical view 
has the focus, by clicking once on 
it.
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Figure 34-24. The Plane Position 
dialog.

18. In SA (as in mathematics), planes extend infinitely in two di-
mensions. So, the boundaries that are depicted in the graphi-
cal view are purely to give you an idea of the location and 
orientation of the plane--the actual plane is not bounded. 
Notice also that planes have an arrow drawn along their nor-
mal to indicate the direction of the plane. All geometry and 
surfaces have normal directions, which define the positive side of 
the geometry. All measurements with offsets in SA are always 
compensated relative to this positive side:  

Figure 34-25. The positive side of 
a plane is indicated with an arrow.

19. The plane’s normal direction can be reversed to face the op-
posite direction. In the Plane dialog, click the Reverse button.  

Figure 34-26. Selecting the op-
tion to draw a plane’s normal vector.

 

Notice how the arrow flips to face the opposite direction. Turn 
off the plane’s arrow so that it’s no longer drawn in the graph-
ical view by deselecting the Draw checkbox in the Plane dialog 
(Figure 34-26). Close the dialog by clicking the Close button 
or the “X” in the corner of the window.

20. Finally, let’s create a circle to work with. This time, rather than 
creating a circle and specifying its position and orientation, 
let’s fit a circle to the three points that we created earlier. 
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Orient your view so that you can see all three points. From 
the menus, choose Construct>Circle(s)>Fit to Points or press 
Ctrl+Alt+C. You will be prompted for the points that will 
define the circle fit. Hold down the Shift key, and click-drag 
to define a rectangle around the three points. In the bottom-
left corner of the SA window, you should see a message say-
ing “Picked 3 Points”. If you look in the treebar, the selected 
points will highlight bold and blue,  and they will change to 
a highlight color in the graphical view. Press Enter to accept 
the selection.

21. You will be presented with the Circle Fit dialog (Figure 34-27), 
which allows you to define the parameters and results of the 
fit operation. Since three points perfectly define a circle, our 
resulting circle will end up passing through all three points 
exactly. Notice that the Max and RMS errors are zero:

Figure 34-27. The Circle Fit 
dialog.

22. In the bottom-left corner of the Circle Fit dialog, press the Car-
dinal Pts button. SA will ask you for the name of the group in 
which you’d like to place the cardinal points. Enter nominal-
points and click OK. 

23. Press OK  again and the Circle dialog will appear. Give the 
circle a name of MyCircle. Notice the Draw checkbox again. Se-
lect it to see that circles have a normal direction as well, and 
notice that two points have been created from our circle fit: 
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one on the circle’s center, and another along the normal of 
the circle. These are the Cardinal Points. Turn the Draw checkbox 
back off, and click the Close button.

In the next section, we’ll create some coordinate frames using a few 
different methods.

Creating Frames
Coordinate frames are crucial to many functions in SpatialAnalyzer 
and metrology in general. They define the locations and directions 
that are important to you or the features that you’re measuring. SA 
has a number of powerful ways to create coordinate frames to meet 
all of the needs you might encounter on a day-to-day basis.

1. In the graphical view, note that the World frame is currently 
the working frame. The working frame is rendered with col-
ored arrows representing each of the axis directions: red for X, 
green for Y, and blue for Z. In the tree, you will also notice that 
the working coordinate frame is rendered in a bold blue font.

2. Let’s create a new coordinate system, offset it from the cur-
rent World frame, and change its orientation. From the menu, 
choose Construct>Frame>Enter. Give the frame the name Offset 
Frame. This command creates a new coordinate frame with 
the same position and orientation as the working coordinate 
frame. We want to move our new frame. Click the Transform 
button to bring up the Frame Position dialog (Figure 34-28). 
Offset the frame by 10 units in X, Y, and Z, and also rotate the 
frame by +45° about the Z axis. Click the Update button to see 
the new frame move to the new position:

Figure 34-28. Creating a new 
frame.

3. Close the Frame Position and Frame dialogs, and verify for 
yourself visually that the new frame’s origin is located at (10, 
10, 10) in the active (World) frame’s coordinate system. Verify 
also that your constructed frame is rotated 45° about the ac-
tive coordinate frame’s Z-axis. Notice that SA uses the right-



835

CHAPTER 34 ■ TUTORIALS

hand rule. If the thumb of your right hand is pointed along 
the axis of rotation, then curling your thumbs from one of the 
remaining axes to the other will define the sense of positive 
rotation. Our newly-created frame is drawn as a set of 3 or-
thogonal lines. The thicker colored arrows are only drawn on 
the coordinate frame that is currently active.

4. Let’s activate our newly-created coordinate frame. Click on 
the A::World button in the WCF Toolbar (your button may 
look slightly different depending on the name of your default 
collection):  

Figure 34-29. The WCF Toolbar.

5. From the Object Selection dialog, double-click the Offset 
Frame frame. The button’s title will immediately change to re-
flect the new working frame, and the new frame will be ren-
dered as active.

6. Now let’s construct a frame on our circle. Objects can have 
frames constructed on them. The specific behavior is depen-
dent on the type of object, but for a circle, the frame will be built 
with its origin on the center of the circle and its Z-axis along 
the circle’s normal. From the menu, select Construct>Frame>On 
an Object. When prompted for the object, double-click the My-
Circle circle. Name our new frame Frame On Circle and close 
the Frame dialog.

7. Finally,  let’s create a coordinate frame whose origin is at one 
of our circle points, whose X-axis points directly to the second, 
and whose Z axis clocks along the point defining the circle’s 
normal. From the menu, choose Construct>Frame>3 Points>Origin, 
X axis>Point on XZ Plane. For the origin point, double-click the 
point in the tree named nominal::nominalpoints::1. Note that 
SA uses a convention to denote the “complete location” of an 
entity. For objects, it includes the collection, followed by two 
colons, then the object name. For points, it includes the col-
lection, followedby two colons, followed by the group name, 
followed by two more colons, and finally followed by the 
point name.

8. Let’s pick the Point along X axis by clicking on it visually in the 
graphical view. We want to pick the nominal::nominalpoints::2 
point, but how do we know which is which? From the menu, 
choose View>Show Point Labels (or press Alt+L). This will toggle 
on and off the display of labels for the points. Ensure that the 
Point along X axis prompt is still displayed, and in the graphi-
cal view, double-click the point labeled 2.
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9. When prompted for the Point along XZ plane, double-click 
the point on normal point. In the Frame dialog, give the frame 
a name of Clocked Frame and close the dialog.

Activating Frames
When analysis values are reported by SpatialAnalyzer, they are almost 
always reported in the working coordinate frame, unless otherwise 
specified. For example, when you query two points to determine the 
distance between them, you will be presented with the magnitude of 
the distance (in the current units), which will remain the same regard-
less of the working frame. However, you’ll also get delta values along 
each active frame axis (dX, dY, dZ). In some cases, you can explicitly 
specify the frame to report results in, regardless of which frame is cur-
rently active.

1. With the Offset Frame frame still active, right-click on the 
nominalpoints point group and choose Expand All Entries from 
the context menu. You should now be able to view the X/Y/Z 
coordinates for all of the point group’s points (Figure 34-30).

Figure 34-30. Viewing the point 
coordinates.

2. In the tree, right-click on Clocked Frame and choose Make Work-
ing Frame from the context menu. Notice that the point coor-
dinates change immediately to reflect the new coordinate 
frame’s position and orientation.

3. Let’s look at the point coordinates further. Point 1 is located at 
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(0, 0, 0) because we used it to define the origin of our working 
frame. Point 2 has Y and Z coordinates of 0 because the X axis 
points directly to it. Finally, the point On normal point has a 
Y coordinate of zero, since we defined the frame so that the 
point lies in the frame’s XZ plane.

4. Next, activate the Frame on Circle frame. The Center point is at 
the origin, and the point on normal point is along the Z axis. 
In the tree, right-click on MyCircle and choose properties from 
the menu. In the Circle dialog, click the Transform button. 
Notice that the circle has position and orientation values of 
zero, since the active frame was created on the circle. (In other 
words, the frame was created at the circle’s internal object ori-
gin). Close both dialogs.

5. Now we’ll measure a few distances. From the menu, choose 
Query>Point to>Point (or press Ctrl+D). When prompted, dou-
ble-click the Center point for the 1st point and point on nor-
mal for the second. In the Query Results dialog, the two points 
have dX and dY values of zero (since they both lie along the Z 
axis of the active frame). If you were paying close attention (or 
have a photographic memory), you’ll notice that the distance 
between the two points is the same as the circle radius.

6. This time, activate the Offset Frame frame and follow the in-
structions in the previous step to compare the two points 
again. This time, notice that the two points have nonzero dX, 
dY, and dZ values, since they do not lie along the direction of 
any of the active frame’s axes.

7. Let’s determine the distance of one of our points from our 
plane. From the menu, choose Query>Point to>Object. Double-
click point on normal for the point, and plane as the plane. 
The Query Results dialog will display the distance of the point 
from the plane along the active frame’s X, Y, and Z axes.

Conclusion
In this tutorial, we saw ways to create different geometric entities 
such as points, circles, and planes. We also explored a few methods 
of frame construction, and saw how results reported from commands 
can be influenced by the working coordinate frame.
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Connecting an Instrument
Spatial analyzer (SA) is a software designed for measurement applica-
tions. It provides a window into a 3D world where measured point 
locations can be viewed from different angles and comparisons can 
be made between where measurements are in space. These measure-
ments can be either imported or measured directly by an instrument. 

In order to connect an instrument in SA, navigate to the Instrument tab 
of the Ribbon menu and Press the Add button.

Figure 34-31. Instrument Add 
Button.

When you add an instrument to SA it defines an instrument station 
placement in the application’s 3D world. Measurements from this in-
strument station are linked to this instrument model. 

If you have connected to an instrument before then more than likely 
all you have to do to connect to that instrument again is to press the 
Connect button. However, initial setup and configuration requires a 
few more steps depending on the instrument type for that reason we 
have a selection of quickstart guides which were designed to help 
connect a particular instrument. 

For connection information regarding a specific instrument refer to 
the appropriate chapter of the Instruments Manual.

Each chapter has an overview section regarding the type of instru-
ment and the common functions used by all the instruments of that 
type and at the end is a selection of mode specific quickstart guides 
with specifics on how to connect. 

For tutorials with specific instrument types see:

“Basic Tracker Operation Using the Instrument Toolbar” on page 838

“Cloud Based Part Inspection with an Arm” on page 893.

Basic Tracker Operation Using the Instrument Toolbar

This tutorial walks through basic connection and operation using a 
Leica AT960 as an example. 
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ADDING AN INSTRUMENT MODEL TO SA
1. Open a blank SA Job File. 

2. Go to the INSTRUMENT tab. In the INTERFACE section, select 

the add instrument icon,  .

3. The ADD INSTRUMENTS TO SA dialog will open.  Follow steps 
in Figure 34-32 below. 

Figure 34-32. Add Instrument 
Options.

 

 ■ A. Select the All Instruments filter if it is not already selected.

 ■ B. Single left-click the tracker you would like to add to the job 
file.  The Leica AT960 is selected here, but you can also make a 
selection from the or Faro or API sections as well.

 ■ C.  Selection Options from below the instrument image.

4. When you select the Options button, as displayed in the figure 
above, the Add Instrument Options dialog will open.  Follow 
the steps in Figure 34-33 below.
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Figure 34-33. Add Instrument 
Options.

 ■ d. Select Quickset as the instrument stand.

 ■ e. Ensure the Run Interface checkbox is UNCHECKED. 

 ■ f.  Click OK. 

The instrument placement can be changed when necessary. The de-
faults will suffice for this exercise, though in real world use, this would 
just be a preliminary position prior to locating your instrument to a 
part or reference system.  The current selection will position our in-
strument relative to World Frame, 50 inches along the X axis.  So, our 
instrument’s position once added, will be X=50, Y=0, and Z=0.)

5. Select Add Instrument button to add the instrument model to 
the job file. 

CONNECTING TO AN INSTRUMENT
For this tutorial we will connect to a tracker in simulation mode, which 
does not require an actual instrument.

6. In the INSTRUMENT tab In the INTERFACE section, select the 

dropdown in the Connect icon,  .

7. Select Laser Trackers from the dropdown.  

8. In the Connect to SpatialAnalyzer dialog, select the tracker 
model you just added. Click OK.

Each tracker move will involve adding a new instrument model to the 
job file. These represent tracker station placements and you could 
have many within a single job file.

9. In the Tracker Connection dialog, uncheck the Connect to 
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Tracker checkbox.  this will ensure that our computer connects 
to the instrument in simulation mode.  When actually connect-
ing to your instrument you will want this box checked. If you 
were to connect to a live instrument, this dialog povides the 
ability to adjust the IP address and ping the instrument.

Figure 34-34. Connect to Tracker 
Dialog.

10. Click Ok.

INSTRUMENT TOOLBAR
The instrument toolbar is a simplified instrument interface which al-
lows the user to name points, define tooling and initiate measure-
ments easily.  See image below for explanation (Figure 34-35).

Figure 34-35. Instrument Toolbar 
Controls

 ■ a. Beam Status indicator

 ■ b. Steer Tracker Head control

 ■ C. Tooling Quick-Select

 ■ D. Target Name

 ■ E. Measurement Profiles

 ■ F. Alarms

 ■ G. Checks/Utilities

 ■ H. Battery Status 
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 ■ I. Access button to the full instrument interface.

Depending on who might have last used the tracker, you may see 
the full instrument interface when you connect, because this status 
is saved. This full interface can be undocked from the SA such that it 
appears as a stand alone application (Figure 34-36). If so you will see 
it in the windows task bar as a reflector icon. To switch back to the In-
strument Toolbar use the button on the bottom right of the interface. 

Figure 34-36. The Full Tracker In-
terface shown as a separate application.

11. Click the red beam status icon.  It will turn green to emulate 
the action of locking on to a reflector.

12. Click in the target name box to edit the point name (Figure 
34-37). 
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Figure 34-37. Instrument Inter-
face Point Naming Control.

13. In the Instrument Interface Point Naming window make sure 
the collection letter is A, Group is Temp, and Target is P1.  Once 
you have entered that information click OK. (The + and – sym-
bols on the right side of the dialog allow you to increment or 
decrement the group and target names.)

14. In the Tooling Quick-select section, select the SMR 1.5” option.

15. Now, in the Measurement Profile section select the single 

point option  .  A point will be measured and the X,Y, and 
Z of that point will flash in the top left corner of the graphical 
view (HUD) along with the point name.

16. In the treebar you will see a new Point Groups category has 
been created.  Expand that category and see the new point 
group “Temp” has been created which includes point “P1”.

TOOLING DEFINITIONS
We can change the tooling quick selects so that they show the most 
frequent tools we use for easy access.  To change them we need to 
right-click on the icon in the tooling quick select section that we 
would like to change.  That same action will allow us to build new 
tooling definitions as well.

17. Right-click on the SMR 1.5” tooling definition in the instru-
ment toolbar.  Then select the drop-down to see the available 
tooling choices.  If you do not see what you are looking for 
you can define new target .  
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Figure 34-38. Target Quick Select.

18.  Select define new target and click OK.

19. The Reflectors and Targets Dialog will open.  We will define a 
few new tooling definitions.  See Figure 15-5.

The top-left table will show the manufacturer definitions which are 
those that come directly from the instrument.  The larger table at the 
bottom are the targets defined within SA that can be assigned as a 
quick-select and used during measurement acquisition.  
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Figure 34-39. Building Targets 
within the Reflector/Targets Database

 ■ A. Select the RRR 1.5in in the Manufacturer’s Definition section.

 ■ B. Click Add:  From Selected Reflector.

 ■ C. Click the three checkboxes shown.  This will create target 
definitions that includes a Pin Nest, Plane Nest, and Edge Nest.  
Ensure the offsets for each tooling coincide with the physical 
tooling that will be used. Click OK when done.

Notice that the three tooling definitions that were created are now 
in the large table at the bottom of the Reflectors and Targets Dialog.  
Check the probe radius, extra planar offset, and lateral offset to en-
sure the values reflect the offsets you are wanting to add.

Figure 34-40. Newly Constructed 
Target Definitions.
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20. Click OK to exit the database.

MEASUREMENT PROFILES
When taking measurements, we have the choice of how we would 
like to acquire the points.  We can also change the behavior of the 
measurement profiles.  Below are the four most common measure-
ment profiles (Figure 34-41). 

 ■ Single Point.  When pressed takes a single point measurement. 

 ■ Stable Point. When pressed will start a mode that allows you 
to hold the SMR stable within a certain space for a certain 
amount of time and a measurement will be taken.  This allows 
us to take measurements without someone repeatedly hitting 
the measure button.

 ■ Spatial Scan.  When pressed will start a mode that takes incre-
mental measurements as the SMR is moved a certain distance.  
This is a continuous measurement and can be very useful when 
taking a multitude of measurements very quickly on a part.

 ■ Tooling Ball. Used when measuring tooling balls typically for 
alignment purposes.  This allows us to measure around the 
tooling ball to create a sphere, which in turn generates a center 
of that sphere which is the measured center that can be used 
for alignment.

Figure 34-41. The 4 Basic Mea-
surement Modes in the Toolbar.

To change the parameters of these measurement profiles, just right-
click the icon and edit the parameters. For the single and stable point 
modes, there are three selections:

 ■ Fast. This mode takes .5 second worth of samples. 

 ■ Standard. This mode takes two seconds of samples. 

 ■ Precise.  This mode takes five seconds of samples. 

What this means is that the Leica 960 operates at 1000 Hz; therefore it 
takes 500 samples during fast mode operation.
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The Red, Yellow, Green and Blue silhouettes represent a user defined 
measurement profile.  You can right-click either one of them, click a 
drop down, and choose from a variety of other predefined measure-
ment options.  When chosen they will  be assigned to that silhouette.

Utilities and Checks
The final icons in the toolbar is the alarm icon and Checks/Utilities.  
See below.

Figure 34-42. Alarms Checks and 
Utilities Controls Available from the 
Toolbar.

21. Press the Alarms button and then check the Discrete Point RMS 
Monitor checkbox. You will now be notified in the graphics if a 
measured point exceeds the set threshold.

Measure Nominal Points

1. Open the SA file containing your reference points needed for 
alignment or import the points into an existing file. 

2. In the Ribbon Bar, go to the INSTRUMENT tab and follow the 
steps in (Figure 34-43):

Figure 34-43. Add, connect, and 
locate an instrument.
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Benefits

This process prevents the user from having to extract center points

1. Open the SA file containing your reference points needed for 
alignment or import the points into an existing file. 

2. In the Ribbon Bar, go to the INSTRUMENT tab and follow the 
steps in FIGURE x-1:

a. Select Add. 

b. Select Connect.  

c. Select Locate.

3. Choose Measure Nominal Points.

4. Select the Nominal Point Group. This is the previously estab-
lished reference group.

DIALOG SETTINGS
5. Check that your optional settings are correct for your job (re-

member that these settings will vary depending on the job) 
(Figure 34-44):

Figure 34-44. Locate Instrument 
by Measuring Nominals dialog.

a. Change the group name for the group to contain measured points 
and click Apply. 

b. Check the Vary Scale box if you would like to “float the scale” (See 
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Temperature Compensation module for details).  

c. Check the Hold Level box to make sure that a leveled instrument 
stays parallel to the Z-axis. 

d. The Closest Point box is checked by default to ensure that after 
three points are measured and an initial locate is performed, points 
may be measured without selecting the row first and SA will auto-
matically give the deltas between its closest corresponding point. 

e. Change the Tolerance box to display the dMag in RED and assign 
a point as out of tolerance. Click Apply after changing the tolerance. 

RECORDING POINTS
6. If you are measuring out of order, then click on the row of the 

first point that you would like to measure. There are several 
options for taking measurements, as shown in (Figure 34-45):

Figure 34-45. Measuring in the 
Locate Instrument Measure Nominals 
dialog.

a. Measure Manually. When clicked, the selected target in the list is 
measured. If the target already exists, an additional observation is 
added. 

b. Point At. Points the instrument at the selected target and attempts 
to lock on. This applies only if the instrument supports pointing/tar-
get acquisition.

c. Delete. Deletes the selected target. 

d. Single Point. Attempts to point at, acquire, and measure the select-
ed target. 

e. Multiple Points. Attempts to consecutively point at, acquire, and 
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measure all points in the list. 

COMPLETING THE ALIGNMENT
7. Once all of the points have been measured (or all points that 

can be seen), then check the MAX and RMS and ensure that 
the deviations are within tolerance. If so, then choose Fin-
ished-Locate Instrument (Figure 34-46). 

Figure 34-46. Checking RMS 
and Max magnitudes and locating the 
instrument.

a. RMS and Max statistics are displayed here. 

b. Finished – Locate Instrument locates the instrument to the nominal 
group. 

REPORTING THE ALIGNMENT
8. In the SA Treebar, expand the Events category and double-

click on the last item added. This will display your alignment 
results in the Report Bar (Figure 34-47).
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Figure 34-47. Locate Measure 
Nominals Report Table.

Drift Check Verification and Re-Alignment

A Drift Check is a crucial part of the measurement process since it 
gauges how much your instrument has moved relative to the part 
you are measuring. Without recorded drift checks, your data is unreli-
able.

Key Points

 ■  Ensure that you have at least three control points. 

 ■ Perform drift checks frequently and on regular intervals. The 
frequency will need to increase the tighter the tolerances. 

 ■ Get to know your instrument and your working environment 
to establish an expected threshold for a drift check. If you have 
an idea of how accurate your instrument is under your expect-
ed working conditions, it will become second nature to accept 
and continue or add a new instrument and re-align.

 ■ All drift checks are stored in the EVENTS category in the treebar 
for traceability and reporting purposes.  

Getting Started
This tutorial is for a points based inspection and alignment.

1. Open a new SA file. 

2. Add and Connect your instrument. You will need the SA demo 
part for this exercise, but not the CAD model. 
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SETTING UP DRIFT POINTS WHEN YOU ARE NOT ALIGNING TO A REFERENCE SYSTEM

In this exercise we are not aligning to the part, but simply measur-
ing some of the as-built conditions of the part. Therefore, we do not 
have a reference system to tie in to but we still need to measure some 
initial points to check drift throughout the inspection and at the end.

3. Select the Instrument Control bar, name the Group Reference 
Points and the Target 1 (Figure 34-48). 

Figure 34-48. Naming Reference 
Points

4. Measure the six points shown below in Figure 34-49, ensuring 
that the probe is as stable as possible. 
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Figure 34-49. Six reference points 
to be used as drift checks

Before beginning your inspection, you may want to ensure that your 
setup is stable, and the reference points were measured properly. We 
recommend that you check the deviation of each point in real time. 
There is no need to record these points since you have not begun the 
measurement process yet. 

5. In the tree bar, right-click on the point group A::REFERENCE 
POINTS and select Add Watch Window. 

6. Place the probe in each hole and make sure the deviation is 
what you would expect. If it is not, delete this point group, 
correct your setup and begin again at step 3. 

7. Measure the three planes in FIGURE X*3 by following the 
steps below:

a. In the Features tab, type Plane 1 in the name box.

b. Check the box Repeat for Inspection.

c. Click  the Plane button.

d. Measure this plane. 

e. In the Inspection Bar, click Next.

f. Measure Plane 2 and click  Next.

g. Measure Plane 3.
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Figure 34-50. Three datum 
planes.

PERFORMING A DRIFT CHECK

The occurrence of a drift check during an inspection will vary. Many 
metrologists check drift at specific time intervals if their job will take a 
long time to complete. If your environment is temperature controlled 
and very stable, you may choose to check a drift every hour. If you 
work in an unstable environment you may want to check a drift every 
ten minutes. If you measure a great number of points and you would 
like to immediately validate those, then checking a drift at varying 
time intervals may be ideal. Or perhaps a crane moved overhead, and 
you want to check stability. There is not a one-size-fits-all standard for 
checking drift in portable metrology.

8. In the Ribbon Bar, navigate to the Instrument tab, and select 
Drift Check in the instrument Station Controls section. 

9. Select the A::REFERENCE POINTS point group as the Drift Point 
Reference Group.

10. Measure points 1-6. 

11. Look below to Figure 34-51 to find the RMS and MAX errors. 
The RMS error is ________. The MAX error is _______. For 
training purposes, let’s say that this drift is acceptable. 



855

CHAPTER 34 ■ TUTORIALS

 

Figure 34-51. The Drift Check 
Dialog

12. Click Finished – Drift Acceptable in the bottom-left of the dia-
log. 

13. Measure the two circles in Figure 34-52 (below):

 

Figure 34-52. Measure two 
circles as shown.
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WHEN A DRIFT CHECK FAILS

1. To simulate a loss of drift, move the part slightly. 

2. Repeat steps 8-10. 

3. The RMS Error is ________. The MAX error is _______.  These 
errors should be much higher than if a loss of drift occurred 
naturally over time or due to temperature change. 

Since we have lost stability, a new instrument must be added and 
aligned to the original reference points established by the first instru-
ment station. There is a way to perform these steps automatically by 
using the “bad” drift points. 

4. In the Drift Check dialog, select Add new Instrument: Trans-
form. 

5. The Locate Instrument by Measuring Nominals dialog will appear. 
This prevents you from having to re-measure your reference 
points again. 

6. If you are satisfied with the alignment, click Finished – Locate 
Instrument.

You must now re-measure Circle 1 and Circle 2 since there is no way 
to prove that drift was lost after these features were measured. 

7. Right-click on Circle 1 and select Delete Associated Points. 

8. Click Yes to confirm deletion. 

9. Repeat step 20-21 for Circle 2. 

THE FINAL DRIFT CHECK

10. Right-click on the instrument in the graphical view and select 
Drift Check.

11. Select the point group A::DRIFT RE-LOCATE as the drift point 
reference group. 

12. Measure points 1-6.

13. Ensure that the drift is acceptable before clicking Finished – 
Drift Acceptable in the bottom-left of the dialog. 
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Using Best-Fit to Align Point Measurements

In this tutorial, we have a set of nominal points (fiducials), and we’ve 
measured those nominal points with a laser tracker. Our task here is to 
locate the instrument by fitting the measured points to the nominals.

We’ll start by opening a tutorial file included with your installation 
of SA. In SA, choose Help>Open Sample SA Files.  Choose the Best Fit 
Points to Points.xit file. This file contains a laser tracker which 
has measured a series of 7 points, each of which has a corresponding 
nominal point.

1. 

Figure 34-53. Best Fit Points to 
Points Example file

Let’s locate our instrument to the nominal points. In the tree, 
right-click the tracker and choose Locate. From the Locate In-
strument dialog, choose Best Fit (Figure 34-54).  
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Figure 34-54. Locating using 
Best Fit.

2. You will be prompted to select the Nominals Group. Click one 
of the nominal (fiducial) points in the graphical view. When 
you do, the prompt will ask for the Measured Group, and you 
should then click one of the measured points. 

The Best Fit alignment operates by fitting together points within 
two separate point groups by fitting together points with the same 
names. In this file the points are not named the same within the two 
point groups. As a result you will see the following dialog open (Fig-
ure 34-118):
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Figure 34-55. Automatic rename 
option provided by the Best Fit align-
ment.

There are a number of ways to rename points for this type of align-
ment but this tool uses an advanced Inter-point distance calculation to 
identify the relative placement of points in the two groups and usu-
ally does a pretty good job of matching up the names. 

3. Press OK and accept the renaming of the Station1 points, and 
the Best Fit dialog should open. 

4. The default value of 0.1” (2.54 mm) works fine for our inter-
point distance match tolerance. We know that each of our 
measured points should be within 0.1” (2.54 mm) of our nom-
inals after a best-fit it performed, so all of the points within 
this threshold will be renamed. (Note that this function would 
probably not work if the nominal points were symmetrical. 
In that case, SA wouldn’t know how to orient the measured 
points, and the resulting points may not be named correctly).

5. You will be presented with the proposed name changes. Click 
Accept to make the changes. The Station1 point names now 
match the nominals point names. We’re now set to do a points 
to points best fit.

6. 

Fitting the Points

1. We saw how to use best fit from the instrument’s Locate 
menu. Let’s look at how to do it from the main menu. Choose 
Instrument>Locate (Transform to Part)>Best Fit.   As before, pick 
nominals for the nominal group and Station1 for the mea-
sured group. The Best-Fit Transformation dialog will appear 
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(Figure 34-56). At the top of this window, we’re allowing 6 de-
grees of freedom for the fit: X, Y, Z, Rx, Ry, and Rz, which is what 
we want in this case. Notice the table at the bottom, which is 
currently displaying the nominal coordinates and resulting 
deltas. Click the Actuals checkbox to display the coordinates of 
the measured points. Notice that the fit hasn’t yet been per-
formed, and as a result the deltas are quite large. That’s why 
the Re-fit button (with the two chasing arrows) and the fit re-
sults are highlighted blue.

Figure 34-56. The Best-Fit 
Transformation dialog.

2. Click the Re-fit button to calculate the fit. Immediately, the 
results of the fit are displayed (Figure 34-57).



861

CHAPTER 34 ■ TUTORIALS

Figure 34-57. The fit results.

3. Notice that each field is color-coded based on the Toler-
ance Coloring Zones in the dialog.  Deltas between 0.0000-
0.0200” are not colored, deltas from 0.0200-0.0400” are yel-
low, 0.0400-0.0600” are blue, and 0.0600” and greater are 
red. Looking at the results of the fit, point M3 has a very 
large dX value relative to the other points. This is highlight-
ed by the red coloring. Click the “dX” column header twice 
to sort the values, with the highest value in the top row. 
 
It looks like our M3 point has a significantly higher dX error 
than the other points, so that point is suspect. Let’s temporar-
ily remove it from the fit to see how the solution is affected. 
Uncheck the checkbox in the Name column for point M3. Since 
this changes the fit, you again need to click the Re-fit button.

4. Immediately, the errors drop dramatically, which backs up our 
theory that the M3 point is not good. Let’s give our tolerance 
warning indicators smaller values, for good measure. Click the 
ellipsis button in the Tolerance Coloring Zones section of the dia-
log. In the Tolerance Zone Coloring dialog (Figure 34-58), set 
the values to 0.005”, 0.010”, and 0.020” respectively.
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Figure 34-58. The Tolerance Zone 
Coloring dialog.

5. After the change, none of the rows are highlighted, so we 
know that all errors are within 0.005”. In fact, we can easily see 
that the largest error is just under 0.002”.

6. Now take a look at each of the individual components. The larg-
est dX error is 0.0006”, which we deem to be acceptable. The 
largest dZ error is 0.0004”, which is also acceptable. But notice 
that two of the dY errors are -0.0011” and 0.0016”.  These are 
at least double the largest errors of any of the other compo-
nents. Suppose that we believe that the Y values  from those 
two points might be unreliable. The best-fit dialog allows us 
to weight these individual components to zero, so that they 
do not affect the fit. Let’s do that now, starting with the point 
with the larger error.

7. Check the Weights checkbox so that we can see the individual 
component weights being applied. Double-click the M2 row. 
In the Best-Fit Item dialog (Figure 34-59), click the 0 button 
under the Y component to set its component weight to zero 
and click the OK button.

Figure 34-59. The Best-Fit Item 
dialog.

8. Click the Re-fit button.  (Note that it’s usually best to make 



863

CHAPTER 34 ■ TUTORIALS

small changes and re-fit, so you can gradually see how the 
changes affect the solution). Now that the new solution is cal-
culated, the new largest dY is under 0.001”, so we may con-
sider this to be acceptable.

9. Click the Apply Transformation button. The instrument immediately 
snaps to the nominals (Figure 34-60). We’ve now performed a 
fairly complicated fitting operation with ease. We’ve removed 
a point from the fit operation, and weighted an individual 
component from another point to zero to exclude it from the 
fit. As a result, we brought our errors from over 0.030” to un-
der 0.001”. Since most of the points and components are still 
in the fit, we can still be confident that the fit is good.

Figure 34-60. After the best fit.

Reviewing the Fit

1. Let’s review the results of our fit. When the fit was completed, 
an event was created in the tree called Best Fit transformation. 
Turn on the Report Bar by selecting Reports>Report Bar Visible 
from the menus (if necessary), and click the event in the tree 
to select it.

2. In the Report Bar, notice that you can view all of the results 
from the fit, including the points and components that were 
excluded from the fit or assigned special weights.
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Quick Align to CAD

Quick Align is a tool used to align a measurement device to a nominal 
CAD model. Like its name suggests, it is a fast, easy process. However, 
some caution should be taken when selecting the points used in the 
Quick Align. A small error in measured data can have a large effect on 
the final alignment. For this reason, this section will deal with how to 
best select points on the CAD model for Quick Align.

First lets import a CAD model to work with

1. Open a new SA file.  

2. In the Quick Access toolbar select Auto Import and navigate 
to the SA DEMOPART_inches.CATPart within the samles 
directory (C:\Program Files (x86)\New River Kinematics\Spati-
alAnalyzer 2020.04.09_65432\Samples) (Figure 34-61).

Figure 34-61. Importing CAD 
with the Auto Import Button

3. In the Choose CAD Features dialog, first uncheck the top box 
to de-select all items. Then, check the two boxes in the sur-
faces category as shown (Figure 34-62). This will exclude all 
the additional model details which we won’t be needing for 
this exercise.

Figure 34-62. Select Surfaces to 
Import
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4. In the home tab in the view controls section, use the drop-
down arrow next to the surface rendering command (Figure 
34-63).

Figure 34-63. Setting the Render 
Mode to Solid with Edges

Your model should now appear as follows(Figure 34-64):

Figure 34-64. Imported NRK Part

Next Add an Instrument and Connect

More details on that process can be found here “Connecting an In-
strument” on page 838. 

Now we can Align using Quick Align

1. From the Alignment tab, choose Quick Align (Figure 34-65). 
Or simply right-click on the instrument you want align and 
select Locate>Quick Align to CAD.

Figure 34-65. Quick Align to CAD 
button in the Ribbon Menu

When choosing points for the next dialogue, it is important to re-
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member that these points must fully constrain your model. This is 
easy to envision for a model that has several flat and perpendicular 
sides, but can be more challenging for models with an organic shape. 
You should still think of this type of alignment as a 3-2-1 alignment. 
First, pick three points on the primary interface. Next, pick two points 
on the secondary interface, and finally at least one point on the ter-
tiary interface of the CAD model. You can think of this as a plane, line, 
point alignment.

Another important factor to consider when choosing the alignment 
points is whether your instrument will be able to measure those 
points in its current physical location to the part. For a laser tracker, 
you should consider line of sight restrictions, and for a portable CMM 
arm, you should consider the reach of the instrument to ensure that 
all points you select on the surface will be able to be measured. If 
there are features or surfaces of the part which are critical, adjust the 
location or orientation of your instrument to ensure that those can be 
measured.

The minimum points required for a quick align is 6 points. Again this is 
related to the 3-2-1 method of alignment. However, there is NO max-
imum number of points. The more points you choose in the align-
ment, the more confidence you will have in the alignment accuracy. 

2. When prompted, pick 3 points on the top surface of the base 
model (to define a plane), then two points on the front of the 
Vertical face (forming a line), and finally a point on the left 
side (Figure 34-66).
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Figure 34-66. Quick Align Points

In this exercise, these are the points chosen. Note how they complete-
ly constrain translation in X, Y, and Z as well as rotation in Rx, Ry, and 
Rz. The order of selection is also shown. The points don’t necessarily 
have to be measured in any particular order, but, from an inspector’s 
standpoint, it helps to group the points together by area because the 
points must be measured in the order selected. 

3. The next step is to directly measure these points on your cad 
model. If you have already measured these points you can 
also pick the measurements associated with each alignment 
point (Figure 34-67).

Figure 34-67. Picking Measure-
ments that have already been taken as 
an alternative to direct measurement

In this case, instead of measuring the points, select the ‘Pick Measure-
ment’ button and click on the inspection points in order. The points 
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are in order from p0 to p5. Choose each one in order by double click-
ing on them in the tree or single clicking on them in the graphics 
window.

4. You should see the results below (Figure 34-68). Choose Ac-
cept to confirm alignment

Figure 34-68. Quick Align results 
showing a perfect fit with 6 points, the 
minimum for a 3-2-1 alignment.
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Feature Inspection
Geometry Construction verses GR-Features

SA uses Geometry Relationships (GR-Features) to effectively link 
nominal and measured geometry with the measured points creat-
ing dynamic geometry ready to report.  These features can be built 
in advance or after measurements are made and, once built, provide 
a template for future measurements.  Static geometry construction 
is still an option but has generally been replaced by feature based 
measurement.

Why GR-Features verses GD&T
Geometry can also be inspected using our ASME and ISO compliant 
Standardized GD&T inspection process either separately or in combi-
nation with feature measurement. The primary reason these evalua-
tion processes are separate in SA are: 

1. Standardized GD&T feature checks use a built in datum align-
ment GR features display deviations using the current job 
alignment which provide greater visual feedback.

2. GD&T feature use standardized inspection processes that 
are designed to establish if a part is within specification. This 
means that it optimizes fits using bounding thresholds in its 
mathematical evaluation. GR features use an RMS fit to help 
identify measurement error.  

As a general rule of thumb start with GR features which help identify 
measurement errors and are more flexible. Then move to GD&T in-
spection for part inspection following a standard protocol. 

Creating Features from Existing Points

This tutorial is set up to be a broad overview of Feature construction 
possibilities using the Features tab of the Ribbon menu. 

To begin by opening a sample file to work with. 

1. In the Ribbon Bar, go to the HELP tab. In the Documentation sec-
tion, choose Sample Files. 

2. Open the SA file GD&T with Multigage.xit. 

3. Go to the HOME tab. In the View Controls section, select the  
Solid   render mode.

4. Go to the Visibility section and select  Hide Selected Items, 
selecting all the annotations. We will be inspecting without 
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GD&T today.

5. Next, go to the FEATURES tab. 

CREATING FEATURES WITH EXISTING POINTS

6. In the New Feature Controls section.

7. In the white box type “Datum A”, which will be the name of 
the created feature.

8. Change the Data Association, by selecting  , then choosing  
.

9. Select   , then select the Datum A point group which will 
result in the creation of a plane.

10. Press Enter to confirm your selection. Our graphical view 
should look like (Figure 34-69). 

 

Figure 34-69. Plane Feature 
Creation.

11. Return to the Ribbon Bar and in the white box and type “Large 
BH”.

12. Select  , then select the Large BH point group which will 
result in the creation of a cylinder.

CHECKING FIT SETTINGS AND CREATING CARDINAL POINTS

13. Double-click on the Large BH relationship in the SA Treebar 
and follow the steps in Figure 34-70 (below):
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Figure 34-70. Changing the 
measured side of a cylinder.

 a. Select Fit Settings.

b. Choose the first option in the section labeled Measured….

c. Click Ok. 

Notice the diameter value will increase since we have just changed 
the measured side of the cylinder from outside to inside (Figure 34-
71).

Figure 34-71. The diameter value 
reported for the criteria.

14. Follow the steps in Figure 34-72 (below) to set the cardinal 
points for the Large BH cylinder.
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Figure 34-72. Creating Cardinal 
Points. 

d. Select Create cardinal points when fitting checkbox.

e. Click Cardinal Points Settings. 

f.  Select the radio button next to Make Custom Group Name. 

g. Then type “Large BH Centers” in the Group Name: box.

h. Click Ok.

i. Click Ok.

SETTING A PROJECTION PLANE

This will set a geometry exactly in the plane it is getting projected 
to.  We are going to make four circles and then project them to our 
Datum A plane. 

15. Return to the Ribbon Bar and in the white box and type “Pat-
tern BH1”.

16. Change the Data Association, by selecting   

17. Select  , then select the points designated in Figure 34-
73.  This can be done by holding down the shift key and simul-
taneously holding down the mouse left click and dragging a 
box around the desired points.

18. Then hit Enter.
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Figure 34-73. Selecting point for 
circle creation.

19. Repeat steps 14 – 17 while moving to the next hole “Pattern 
BH2”, and so on until four circles are created.

(The newly created circles may be oriented incorrectly, which is why 
we need to project them to a plane.)

20. Double-click on the Pattern BH1 relationship in the SA Tree-
bar and follow the steps in Figure 34-74 (below):

Figure 34-74. Setting a projec-
tion plane for circles.
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a. Check the box next to Project to Plane.

b. Single left-click GR-Datum A to select the projection plane.

c. Click Ok.

APPLYING TO SELECTED RELATIONSHIPS 

 The settings of one geometry relationship can be applied to 
other relationships of the same type.  We will apply the projection 
plane of Pattern BH1 circle to the rest of the holes in the pattern.  Fol-
low steps in Figure 34-75 and Figure 34-76.

Figure 34-75. Applying settings 
to selected relationships.

a. Click Apply to Selected Relationships 

b. Check the boxes next to the other circle relationships.

c. Click Ok.
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Figure 34-76. Selecting the set-
tings to apply to other relationships.

d. Check the box next to Projection Plane Settings. 

e. Click Ok.

Note:  A projection plane can be set prior to selecting points via the 
Features Tab of the ribbon bar.  See below.

Figure 34-77. Setting a projec-
tion plane in the Features Tab.

CREATING DYNAMIC GEOMETRY

21. In the white box type “Datum B”, which will be the name of the 
created feature.

22. Change the Data Association, by selecting  .

23. Select  , then select the Datum B point group which will 
result in the creation of a plane.
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24. Press Enter to confirm your selection. 

25. Next click the drop-down form the line feature and select Two 
Planes Intersection (Figure 34-78). 

Figure 34-78. Creating an 
intersection line.

26. In the following selection prompts, graphically select the Da-
tum A plane then the Datum B plane by single-clicking.

Fitting Geometry from Points

This tutorial provides a more in-depth look at feature construction 
and basic geometry fitting using points.

SA’s interactive Geometry Fit Interface is able to fit a wide variety 
of geometric shapes to any set of measured, constructed, or cloud 
points. It also provides an alternative means to build features. In this 
tutorial, you will learn how to best fit data to four of the most com-
monly created shapes: circles, cylinders, lines and planes.

1. To begin, open the tutorial file in SA included with your instal-
lation. Choose Help>Open Sample SA Files and select Geometry 
Fit.xit.

If you expand the items in the tree bar on the left, you will see that 
this file contains two separate instruments. The laser tracker mea-
sured points in the point groups Circle and Plane. The portable 
arm measured the points in the point group named Cylinder. These 
instruments were located to an established coordinate system using 
a best fit points to points transformation. This transformation was 
performed for visual purposes only and will not be demonstrated in 
this tutorial.

Best Fit a Plane to Points
There are several ways to fit geometry in SA. The simplest option is to 
right-click on the appropriate point group and select Fit Geometry from 
the context menu. If you’ve measured features into different point 
groups (as you should), this will fit the geometry to the entire point 
group, which is almost certainly what you want.
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2. Right-click the Plane point group and select Fit Geometry from 
the context menu.

3. The Geometry Fit Interface will appear. Here you can control 
the fit tolerance, points used in the calculation, output param-
eters, and everything else related to the fit. Select the Plane op-
tion from the drop down (Figure 34-79). Be sure to check the 
Make Geometry Relationship option in order to build a feature or 
you will simply build a static construction.

Figure 34-79. The Geometry 
Fit Interface.

Fit Tolerance
4. Click on the Point List button. This will display the Geometry Fit 

Point Listing dialog (Figure 34-80) which shows you the fit er-
ror for individual points and permits the application of Toler-
ance Coloring Zones.

Tolerance Coloring Zones can be defined with values of your choos-
ing and help you gauge how well the plane fits the selected data. You 
may change the tolerance zones as well as their colors by selecting 
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the ellipses icon . In this example, one point lies outside of the 
0.015” tolerance zone. Four points are highlighted yellow because 
their error lies in the Limit 1 tolerance zone. All other points that are 
not highlighted are considered completely in-tolerance.

Figure 34-80. A geometry fit’s 
point listing.

5. Let’s uncheck the out-of-tolerance point highlighted in pink 
to remove it from the fit. Once unchecked, the fit will need to 
be recomputed. Press the recompute button , which will 
have a dark blue background indicating the currently dis-
played fit data is not reflective of the current settings. Evaluat-
ing the new fit results, all points are now considered in toler-
ance. Close out the point listing dialog box.

Controlling Probe Offset
By selecting which probe you are using while collecting data, you will 
allow for SA to automatically calculate the offset when fitting geom-
etry. For this particular plane, a 1.5” SMR was used and as a result SA 
has already shifted the plane 0.75” to compensate for the probe ra-
dius (Figure 34-81).

Figure 34-81. The plane is 
automatically offset from the measured 
points.

6. Click the Fit Details button. Among the statistics about the fit 
and the resulting geometry, the dialog also indicates that all 
points have offsets of 0.75”. Close this window.
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7. Check the Override checkbox (which overrides the target off-
sets to 0.0” by default) and notice how the plane now rests 
approximately on the measured points.

Figure 34-82. Overriding the 
offset to 0.0”.

8. Uncheck the Override checkbox to again use the measured 
probe offset of 0.75”. 

In certain less common measurement situations (such as indirect 
measurement or when using a backing bar), you may wish to reverse 
the geometry offset direction or the direction of the resulting geom-
etry. The reverse checkbox in the Planar Offset Direction box and the reverse 
Object normal Vector checkbox are intended to be used for this pur-
pose.

Creating Entities
It is sometimes desired to create probe compensated points—that is, 
points which represent the point of contact of the probe on the mea-
sured feature (instead of points representing the center of the probe). 
This can easily be accomplished by selecting the Offset Pts button. 

Exercise
Now that you have discovered how simple it is to interact with the 
geometry fit interface when constructing a best fit plane to points, it’s 
time to try an exercise utilizing three other geometric shapes with the 
remaining data on your own.

 ■ Best fit a circle to its measured points.

 ■ Best fit a cylinder to its measured points.

 ■ Best fit a line to the cardinal points constructed from both the 
circle and cylinder.

If you need help or would like to check your work, follow the steps 
below.

Best Fit a Circle To Its Measured Points

1. All points for the circle fit were measured in the same point 
group. Right-click on the group in the tree and select Fit Ge-
ometry.

2. Click the Point List button. Several points are highlighted pink 
(Figure 34-83). Uncheck the point with the highest magni-
tude and recompute. Several points are still highlighted pink 
so uncheck the point with the highest magnitude once again 
and recompute. All points are now in tolerance (Figure 34-83).
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Figure 34-83. The point list for 
the circle, showing many out of toler-
ance points.

Figure 34-84. The fit improves 
dramatically after removing a few stray 
points.

3. Since the final step requires us to best-fit a line using cardi-
nal points, click the Cardinal Pts button. The point group Fitted 
CircleCardinal Points has been created. 

4. Click OK to accept.

Best Fit a Cylinder To Its Measured Points

1. All points for the cylinder fit were measured in the same point 
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group, so right-click on the group and select Fit Geometry.

2. Since the tolerance box lets us know that 0 of 16 points are 
out-of-tolerance (assuming the defined tolerance is accept-
able to us), we do not need to look at the point list.

3. Click the Cardinal Pts button to create the point group Fitted 
CylinderCardinal Points. 

4. Click OK to accept.

Best Fit a Line To The Cardinal Points Constructed from both the circle and cylinder.

1. The cardinal points constructed from the circle and cylinder 
are located in separate point groups, right-click on this gorup 
and select Fit geometry.

2. Select all points in both cardinal points groups by using either 
the F2 command or graphically clicking on the points them-
selves.

3. Of the five points, one is out-of-tolerance. Uncheck the point 
with the largest amount of error from the Point List dialog and 
recompute. 

4. Click OK to accept.

Conclusion
This tutorial has covered the basics of geometry creation and how to 
create a best fit plane. The interface we covered is generic for all the 
geometry fits which makes fitting geometries extremely simple.

Geometry Relationships

 ■ Skill Level. Intermediate

 ■ Description. In this tutorial, we will cover how to create geom-
etry relationships for reporting.

 ■ Areas Covered. Creating Fit only, Compare only and Fit and 
Compare Relationships.

 ■ Time to Complete. Approximately 20 minutes.

Fit and Compare Relationship
1. In SA, start by opening the Geometry Relationship.xit 

file from the Samples directory under Help>Open Sample SA Files.

2. We will first make a relationship that will take measured points, 
fit geometry to those points, and compare this geometry back 
to the nominal geometry. Navigate to Relationships>Geometry 
Comparison>Fit and Compare to Nominal.   Select the nominal ge-
ometry and then select the points from the Measured points 
point group that are above the red circle. Accept the default 
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name for the relationship.

3. Double-click the Fit Circle - Big hole relationship in the tree to 
expose the Geometry Relationship Report Options. Here you 
can control tolerance, fit constraint and geometry fit settings 
(Figure 34-85).

Figure 34-85. The Geometry 
Relationship Report options.

4. Let’s change the Fit Settings so that circle is offset correctly. By 
default it was treated as an outside measured circle when in 
fact it was an inside measured circle (Figure 34-86).
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Figure 34-86. Setting the circle fit 
options to offset outward.

5. Let’s set a tolerance for the X and Y components of 0.001”. 
Double-click the X column in the properties dialog. The Cri-
teria Properties dialog will appear. Set the tolerance for both 
high and low tolerances (Figure 34-87).  

Figure 34-87. Modifying the high 
and low tolerances for the X attribute.

6. Now uncheck the Z and MagXYZ rows. Press OK to accept and 
close the dialog.

7. Right-click Fit Circle - Big hole and select Add Callout (Figure 34-
88).



884

SPATIALANALYZER USER MANUAL

Figure 34-88. Adding the rela-
tionship callout to the circle.

8. The best part about a Geometry Relationship is its ability to 
dynamically update--if the points change, the geometry and 
reported values will update accordingly. Select Instrument>Drag 
Graphically and move the instrument around in the graphical 
view. Notice how the geometry and callout update automati-
cally (Figure 34-89). Press ESC to cancel and restore the instru-
ment position.  

Figure 34-89. The callout 
automatically updates as the situation 
changes.

Fit Only Relationship
1. Fit Only relationships are similar to Fit and Compare to nomi-

nal. Select Relationships>Geometry Comparison>Fit only and select 
the group of points that are rectangular in shape. You will be 
prompted to select a geometry to fit to the selected points-
-select plane. Accept the default name.

2. Right-click Fit plane and select Add Callout. Fit only relationships 
utilize the same Geometry Relationship Report Options as Fit 
and Compare to Nominal, although with different reported 
items (Figure 34-90 and Figure 34-91).
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Figure 34-90. A fit-only relation-
ship.

Figure 34-91. Geometry 
Relationship report options for fit-only 
relationships.

 

Compare Only Relationships
1. Now let’s compare two circles.  Select Relationships>Geometry 

Comparison>Compare Only and select the nominal::Small hole 
and Measurements::Small hole Measured items from the tree 
and accept the default name.

2. Right-click Circle: Small hole Measured - Small hole and select 
Add Callout.

3. Compare only relationships utilize the same Geometry Rela-
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tionship Options as well (Figure 34-92 and Figure 34-93).

Figure 34-92. Compare-only 
relationships.

Figure 34-93. Geometry Rela-
tionship report options for compare-
only relationships.

 Conclusion
Geometry Relationships provide a quick and powerful method for 
creating and comparing geometry dynamically.
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Figure 34-94. Various geometry 
relationships in a job.

Contoured Surface Alignment and Evaluation with Relationships

 ■ Skill Level. Intermediate.

 ■ Description.  In this tutorial, we will explore the advantages of 
relationships, and look at how to create them.

 ■ Areas Covered. Points to Objects Relationships, Groups to Ob-
jects Relationships, Relationship Reports.

 ■ Time to Complete. Approximately 20 minutes.

Building the Relationships
Relationships are an extremely powerful concept that enable real-
time examination of the positions and/or orientations between en-
tities in SA. Using relationships, you can get dynamically updated 
comparisons between measured and nominal points, points and ge-
ometry, coordinate frames, and other entities. There are two sides to 
relationships: the reporting side, and the relationship minimization 
side. Relationship minimization is available in SA Ultimate and higher, 
and will be explored in a different tutorial.

1. We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files. Choose the 
Relationships.xit file.

2. This file contains a sample CAD model of a hydroplane, along 
with a series of measured points along different surfaces of 
the model (Figure 34-95). Since this sample file already has 
constructed relationships, let’s delete them to create them 
from scratch. In the tree, right-click on the relationships cat-
egory and choose Delete All from the menu. Confirm the dele-
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tion.

Figure 34-95. The measured 
points have not yet been aligned to the 
model.

3. Currently, our measured points are not aligned to the model. 
That’s OK--for the purposes of this demo, we’ll ignore that fact. 
We now want to compare our measured points to the CAD 
surface, and see how our measured part deviates from nomi-
nal. We’ll use a series of Groups to Objects relationships to ex-
tract this information. In the menu, select Relationships>Groups 
to Objects. For the relationship name, enter Canopy.

4. The Query Point to Surface Options dialog will appear (Fig-
ure 34-96). This dialog allows you to specify how you want 
the relationship to compare the measured points to the sur-
face. The set of buttons at the top of this dialog allow you to 
specify how the resulting deviations will be depicted in the 
view. All four options give the same numeric result--they just 
control how the resulting deviation vectors are displayed, and 
the sense (positive or negative) of the deviation. We want to 
know the deviation from the CAD to the offset point (probe 
contact point). Leave all of the other options at their defaults 
and press Enter.
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Figure 34-96. Query Point to 
Surface options.

5. When prompted for the groups, double-click the Canopy point 
group, then press Enter.

6. When prompted for the objects, double-click the hYdrOdeCK 
surface, then press Enter to complete the command.

7. Notice that the Canopy relationship has been added to the 
tree.  If you expand the relationship, you’ll see the absolute 
max error, RMS error, max signed error, and minimum signed 
error for the comparison of all of the points in the selected 
group to the selected surface.

8. Let’s open up the Relationship Report so we can see this re-
lationship’s values update in real-time. Double-click the re-
lationships category. The Relationships Report dialog shows 
the desired relationship parameters for a given collection in 
real-time.

9. By default, only the relationship summary is displayed. Let’s 
turn on more details. Right-click the Canopy relationship and 
choose Report Options from the menu.  In the Report Options 
dialog (Figure 34-97), select the Single Line format:
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Figure 34-97. Report Options for 
the relationship.

10. Click OK to accept the change. In the Relationship Report win-
dow, you can now see the deltas and resulting deviations for 
each point, as well as a summary for the relationship.

11. Let’s move the instrument up in Z. Since measurements are 
“tied to” instruments, the resulting measured points will move 
up in Z as well. Expand the instruments category and right-
click on the instrument. Choose Properties from the context 
menu.  In the Instrument Properties dialog, click the Transform 
button. Click on the up arrow for the Z value to move the in-
strument up in Z, and watch as the Relationship Report up-
dates all of the calculations. After moving the instrument up 
a little bit in Z, close the dialog and click OK in the Instrument 
Properties dialog. Notice now that our measured points are 
now well above the CAD surface.

12. Close the Relationship Report window by clicking the Done but-
ton. Let’s create another relationship for the measurements 
of the sides of the Hydroplane. Choose Relationships>Groups to 
Objects and give the relationship the name Sides. Leave the pro-
jection options at the defaults and click OK.
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13. This time, let’s assign the point group to the relationship AF-
TER we’ve created it. This illustrates the idea that you can set 
up relationships in a nominal file prior to measuring anything, 
then assign measured points later. (You can even automati-
cally assign them AS you measure by “Trapping Measure-
ments”). Just press Enter to continue through the Groups 
prompt. As before, when prompted for the Objects, pick the 
hYdrOdeCK surface and press Enter to finish the command. 
Here, you’ve set the relationship up so that only the surface 
has been assigned--the groups involved in the relationship 
are not yet specified.

14. Expand the Sides relationship. Note that the tree indicates 
that there are No Points Specified. Let’s fix that. Right-click on 
the collection, and in the context menu, choose Associate 
Data>Points>Groups. Double-click the top group and press En-
ter.

15. Let’s check to make sure that we’ve assigned the right objects 
to our relationship.  Right-click the Sides relationship in the 
tree and choose Highlight Entities. The hYdrOdeCK surface will 
highlight, as well as the top point group. We just made a mis-
take! We accidentally selected the top group instead of the 
Sides  group! No problem, we’ll fix it. From the menu, select 
View>Clear All Highlights to remove the highlighting. Right-click 
the collection, and repeat step 14, only this time, select the 
Sides group.

16. The collection should now be set up correctly. Go ahead and 
set up a Groups to Objects relationship between the top 
group and the hYdrOdeCK surface as well, and name it top.

17. Notice the horizontal plane named tabletop plane. This part 
was surveyed on a flat tabletop, so it would be impossible to 
measure the bottom surface of the object. Instead, we cre-
ated a nominal plane representing the top of the table, and 
measured a few points around the edges of the part to estab-
lish the table surface. Let’s build a relationship between the 
plane points and the tabletop plane plane, which we’ll use in 
a later tutorial (Minimizing Relationships) to fit our measured 
data to the CAD model.

18. From the menu, select Relationships>Points to Objects. Give the 
relationship a name of tabletop, and accept the default pro-
jection options. When asked for the points, double-click the 
6 green points around the edge of the model (the ones in the 
plane group). We could have done this using a Groups to Ob-
jects relationship, but we wanted you to see a different way to 
create a relationship. Press Enter to accept the points.
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19. When prompted for the objects, double-click the horizontal 
tabletop plane plane. Press Enter to complete the command.

20. We also measured a scribe line passing through our part 
which indicates the part’s centerline. We measured this line 
by placing the probe directly over the scribe line and measur-
ing the points. Repeat steps 18 and 19 one final time to create 
a relationship between the Centerline points and the CL plane 
plane. Give the relationship a name of Centerline.  However, 
this time, in the projection options, override the target offset 
value to zero (Figure 34-98). Since we measured a centerline 
and want to compare it to a plane defining the centerline of 
the part, we do not want to account for a probe offset.  In oth-
er words, we want to compare the center of the probe to the 
plane directly, as seen at right.

Figure 34-98. Overriding target 
offsets to zero.

21. We’ve now set up 5 relationships that show the real-time 
deviation between selected features and the corresponding 
measured points. As the instrument that measured the points 
is moved around, the relationships immediately recalculate 
and update the deviation values. This real-time re-calculation 
is very useful, particularly with instrument alignment and re-
al-time building/part mating processes.

Conclusion
In the next tutorial, Minimizing Relationships, we’ll explore the power 
of Relationship Minimization and discover how it can be used to per-
form a variety of complex alignments with constraints.
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Cloud Based Part Inspection with an Arm

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to scan a part , 
align to CAD and extract features. 

 ■ Areas Covered. 

 ■ Time to Complete. Approximately 15 minutes.

Start SA and Connect Arm 
The first step is to connect to a PCMM Arm with a scanner. For this 
tutorial we will use a Hexagon Absoulte arm.

1. In SA, start a new job file by selecting File>New File from the 
menu or choosing the New File Icon from the Quick Access  
toolbar.

2. Go to the INSTRUMENT tab. In the INTERFACE section, select 

the add instrument icon,  .

3. The ADD INSTRUMENTS TO SA dialog will open.  Select the 
arm you want to connect from the list Figure 34-32 below. 

Figure 34-99. Add Instrument 
Options.

 A. Select the All Instruments filter if it is not already selected.

 ■ B. Single left-click the arm you would like to add to the 
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job file.  The Hexagon Absolute is selected here, but you can 
also make a selection from the or Faro or API sections as well.

4. In the INSTRUMENT tab In the INTERFACE section, select the 

Connect icon  , to connect the arm. For arm driver infor-
mation or connection troubleshooting refer to the arm quick-
start guild for your model arm. The arm interface should ap-
pear 

Figure 34-100. PCMM Arm 
Instrument Toolbar

 ■ A.  The probe diameter 

 ■ B. The Collection Group and Target Name used for the 
next measured point.

 ■ C.  The 3 primary measurement modes (Single Point, Spa-
tial Scan, and Cloud Scan)

 ■ D. Checks and Utilities.

Many scanners such as the Hexagon Absolute change measurement 
modes automatically between point probing and cloud scanning. 

Scanning a Part on a Tabletop

Clipping planes define an exclusion zone which eliminates unwanted 
cloud data. Assuming you have a part on a flat surface, this surface 
can be measured as a plane and used for cloud data “clipping”. 

5. To measure a clipping plane you need to first decide if you 
want to measure it with points or by scanning the plane, and 
set the measurement mode you want, to begin we will use 
points.

6. From the Clouds & Surface Tab select Prepare Clipping Plane (Fig-
ure 34-101).

Figure 34-101. Selecting Prepare 
Clipping Plane.
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7. Measure the table top or surface you are using to define the 
clipping plane (the surface your part is sitting on). The Cloud 
Clipping Plane we added should be actively trapping and col-
lect the measurements, automatically fitting a plane (Figure 
34-102).

Figure 34-102. Trapping into a 
Clipping Plane feature

8. Stop Trapping. This can be done but pressing the Next but-
ton on the arm. It can also be done from the controls on the 
Inspection bar or by directly right-clicking on the Clipping 
Plane in the tree.

Configuring the View and Scanning your part

The most important thing when scanning is to make sure you have 
good scan coverage. The easiest way to see that is to enable the in-
strument view and zoom in tight. 

1. From the Home tab in the View section select enable Viewpoint 
from instrument Updates.

Figure 34-103. Enabling view-
point from Instrument. 

2. Change the Group name in the instrument toolbar, this group 
name will be used for the newly measured cloud. 

3. Scan the part. 

Compare to CAD

1. Import CAD by going to File>Import>CAD Formats . CAD im-
port can be performed at any point in the measurement pro-
cess and can be performed by simply drag-dropping a file 
into the graphics.

2. Align your scan to the CAD file by right-clicking on the cloud 
and selected Align to CAD. When prompted select the CAD 
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model(s) you have scanned and press OK. 

You will see an alignment report like this (Figure 34-104). If you are 
happy with the results press Yes to accept. But if the fit looks ques-
tionable press the Perform N-Point Alignment button. 

 

Figure 34-104. Cloud to CAD 
Alignment Results.

To Align using an N-Points Alignment perform the following steps:

1. Arrange the second graphic window and Align Cloud to CAD 
dialog so that you can see both the CAD model and cloud 
scan to facilitate selection of corresponding points such as 
the below (Figure 34-105):
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Figure 34-105. Align Cloud to 
CAD windows and arrangement.

2. Press the Control Points button in the Align Cloud to CAD dialog 
and select at least 3 points on the CAD model.  These points 
should be on surfaces with good scan coverage. 

3. Press the Rough Align Points button and graphically select a 
corresponding cloud point from the axillary view for each of 
the control points you placed on the CAD.

4. Press Perform Alignment and accept the alignment by press-
ing Exit when you are happy with the results. 

Report Overall Part Acceptance with a Color Map

Rather than using vectors to report deviations you can get much nic-
er results with cloud data by using a voxel display. 

5. Disconnect the arm so that it is no longer connected to SA. 

6. Build a cloud to CAD relationship between your scan and the 
CAD model.

7. Adjust Voxel Settings and colorization levels to build heat map

Report  Individual Features 

Identify Features to extract

Extract features 
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Add overview heatmap to Report

Add features to report
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Inspection with GD&T

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to perform a 
GD&T inspection with nominal CAD and native GD&T annota-
tions.

 ■ Areas Covered. Importing CAD with GD&T annotations, cre-
ating Datums and Feature Checks, Associating/Trapping mea-
surements and Reporting.

 ■ Time to Complete. Approximately 15 minutes.

Importing CAD with GD&T Annotations

The first step for this tutorial is to import the nominal CAD model with 
GD&T annotations. 

1. In SA, start a new job file by selecting File>New File from the 
menu or choosing the New File Icon from the Quick Access  
toolbar.

2. Import the native CAD model with GD&T annotations by se-
lecting File>Import>CAD File Formats>Direct CAD Access or use the 
Auto Import  button on the Quick Access toolbar.

3. Choose SA DEMOPART_inches.CATPart from the Samples 
file folder in the SpatialAnalyzer install directory (C:\Program 
Files (x86)\New River Kinematics\SpatialAnalyzer xxxx.xx.xx\
Samples).

4. When the Choose CAD Features dialog appears (Figure 34-
106), turn off the points and lines but make sure the Annota-
tions are selected and press OK.  

Figure 34-106. The Direct CAD 
Access settings with the Selective 
Importer.
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5. Once imported, you will find the Annotations category is created 
in the tree along with the Surfaces, which contains each indi-
vidual annotation for the model Figure 34-107.

 

Figure 34-107. Annotations in 
the graphical view.

Annotations define the tolerances, datums used and all the graphical 
aspects of the annotation attached to the model. It also holds the link 
to the specific CAD faces used for analysis. 

You may also see a new collection appear following the import.  We 
will bring in the saved views from the CAD model for the annotations 
as callouts that you can use for reporting if desired. 

Creating GD&T Datums and Feature Checks

For this tutorial we will inspect only one of the GD&T Features. 

6. Create a New Collection in the SA Tree bar and name it *GD&T”. 
Just like annotations, Feature Checks cannot be moved to an-
other collection once created so be sure the GD&T collection 
you create is the Default Collection.   

7. Right-click Geometrical tolerance.34 in the tree and choose 
Make Feature Check. You will notice two new categories are cre-
ated, GD&T Datums and Feature Checks. 

These two new categories act as bins for the respective measure-
ments.  Here we wanted to build a feature check for a Surface Profile 
annotation which referenced 3 datum features so the datum features 
were built for you as well automatically. 
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Figure 34-108. Feature Checks 
and Datums built in the tree

Inspecting GD&T Datums and Feature Checks

1. The next step is to associate measured points to the respec-
tive GD&T Datum or Feature Check.

 ■  If you already have points in the job file you can right-click on 
the feature check and select Associate Points.

 ■ For this tutorial we will assume that an instrument is present. 
So let’s add an instrument and run the interface. See the Instru-
ments section (see “Connecting an Instrument” on page 838) 
for information regarding adding and running an instrument. 

2. Now that the instrument is added and running, open the In-

spection Bar from the Home tab  and double click on the 
feature you want to measure in order to start trapping (Figure 
34-109).

Figure 34-109. Selecting by 
double clicking on the feature of interest 
in the Inspection bar.

3. Once measurements are complete for a feature, press the 

next button  to advance to the next feature and continue 
measuring. Once all measurements are made the inspection 
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is complete.

4. Since we did not take any actual measurements, lets open 
GD&T with Multigage.xit from the Samples directory 
under Help>Sample SA Files.

5. In the GD&T with Multigage.xit file, all the GD&T Datums 
and Feature Checks have points associated.

Reporting the Results

1. To see the results of the Feature Checks evaluation, simply 
select the Feature Check of interest and the results will dis-
play in the Report Bar. If the report bar is not visible, turn it on 

using Reporting>Report Bar  . By default only a minimum 
pass/fail result is displayed:

Figure 34-110. Feature check 
results for a surface profile check.

2. Right-click the Feature Checks category in the tree and select 
Evaluate All Checks. 

3. To build a summary table for all, or a selection of check re-
sults, there is an additional option under the Feature Checks 
category to Create Inspection Summary Table. In this file, a table 
has already  been built for you. 

4. Navigate to the Gdt Feature Check Summary within the Custom 
Report Tables section, right-click on it and select add to active Sa 
report (Figure 34-111).
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Figure 34-111. A Custom Sum-
mary Table with GD&T feature check 
results.

Note that one of the checks in this file failed. Lets add additional de-
tails on this particular check to the report. 

5. Right-Click on the Surface Profile Check 2 Feature Check in 
the tree and select Reporting Options. 

6. Enable additional reporting tables for this check as follows 
(Figure 34-112), then press OK.

Figure 34-112. Feature Check 
Reporting Options

7. Add these additional tables to the report by right-clicking on 
the Feature Check and selecting Add to Active SA Report. 
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8. You may want to do the same with the Surface Profile Check 2 
vector group created as part of this evaluation.

Figure 34-113. Additional details 
tables included for a failed check.

When a check fails, it will report two values for troubleshooting 
purposes: the Measured Deviation and Distance Out of Tolerance 
(see Figure 26-57). The first number (0.0208) is the Measured Devia-
tion or the size of the tolerance zone required for the part to pass. 
The second number (0.0128), is the Distance out of Tolerance or the 
necessary expansion of the tolerance zone in order for the part to 
pass. For the above profile check, the sum of the check tolerance 
plus the Distance Out of Tolerance will equal the Measured deviation 
(0.008+.0128=.0208). 

Conclusion

In this tutorial, we covered how to import CAD with GD&T annota-
tions and how to create, measure and report feature checks.
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Analysis and Reporting 

Basic Point Analysis

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to perform ba-
sic point analysis.

 ■ Areas Covered. Query Point to Point, Query Point to Object 
and Query Points to Objects.

 ■ Time to Complete. Approximately 20 minutes.

Creating Entities to Work With
For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

1. In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2. Create a set of random points by using Ctrl+Alt+Z or Constru
ct>Point(s)>Layout>Random Points. Use the default settings.

3. Now create a plane by using Construct>Plane(s)>Enter and ac-
cept the default settings.

Calculating Point to Point Distance
Calculating the distance between two points is a very common analy-
sis operation and provides a good starting point for learning basic 
analysis in SA.

1. Using the points we created above, let’s determine the dis-
tance between two points. Use Query>Point to>Point or Ctrl+D 
and select two points by single-clicking in the graphical view.

2. The distance between the two points will be reported in the 
Query Results dialog (Figure 34-114). The delta values for each 
component are expressed in the active coordinate frame. The 
point to point distance is calculated from the centers of the 
selected points. Any target offset, if present, will be ignored.

Figure 34-114. The query results 
dialog.
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3. To record the point to point check the Create dimension op-
tion check box in the bottom left corner. This will create a di-
mension stored in the SA tree as well as display the deviation 
graphically (Figure 34-115).

Figure 34-115. The query as a 
Dimension.

Calculating Point to Object Distance
Another common analysis operation is calculating the distance be-
tween a point and an object, which is reported as the closest distance 
between that point and the object. Let’s calculate the distance be-
tween one of the random points and the plane we created earlier.

1. Select Query>Point to>Object from the menu. Select one of the 
random points and then the plane. The resulting distance be-
tween the point and the plane is displayed (Figure 34-116). 
Notice that the dx and dy values are zero. Since we’re compar-
ing a point to a plane, and the plane’s normal is along the Z 
axis, there is no delta-x or delta-y component. (Said another 
way, the closest point on the plane to the selected point is 
directly below that selected point).  

Figure 34-116. Querying a point 
to an object.

2. Like the Point to Point query, the results are stored in the tree 
as an event (Figure 34-117).
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Figure 34-117. The Point to 
Object query as a dimension.

Dimensions of different types, both linear and angular, can be added 
through the toolkit as well using the selection of icons on the Report-
ing tab. Once added dimension can also be formatted through their 
properties in any way that you need (Figure 34-118). 

Figure 34-118. Dimensions and 
their properties

Calculating Multiple Points to Object Distanc-
es

During analysis operations it is often desirable to calculate the dis-
tance between multiple points and objects. To do this, a Points to Ob-
jects query can be performed. The output of this query is a vector 
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group which gives a numerical and graphical representation of the 
point to object deviations.

1. Go to Query>Points to>Objects and select all of the random 
points. Then, select the plane when prompted for the ob-
jects. The Query Point to Surface Options dialog will appear 
(Figure 34-119). Here you can choose which direction the Vec-
tor should point and access general options. By default the 
vector (whisker) will point from the object to the point. Let’s 
also create a point group with points that are offset toward 
the object by the target radius. (Think of these as the “contact 
points”, or the points where the measurement tooling would 
have been touching the object being measured). Press OK.  

Figure 34-119. The options for 
querying points to objects.

2. A Vector Group will be created and the properties dialog will 
appear (Figure 34-120).  
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Figure 34-120. The vector group 
properties dialog.

3. To change the appearance of the vectors change the magnifi-
cation, size, and style of the vector. Change the magnification, 
vector style and blotch size to match Figure 34-121.  

Figure 34-121. The Vector Group 
Display Options.

4. Now change the colorization of the vectors and apply a tol-
erance for colorization. There are four different colorization 
methods (Figure 34-122). Choose Toleranced (Go/No-Go).  
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Figure 34-122. Colorization 
options.

Now the vector group reflects the display and colorization changes 
(Figure 34-123).

Figure 34-123. The result.
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Creating Callouts

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to create callout 
views with graphical annotations.

 ■ Areas Covered. Creating a Callout View, Creating Callout An-
notations and Locking the view.

 ■ Time to Complete. Approximately 10 minutes.

Creating A Callout View

1. In SA, start by opening the Blower Shroud.xit file from 
the Samples directory under Help>Open Sample SA Files.

2. Before we create a callout view, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3. Now create a callout view by clicking the Callout icon . Call-
out 1 view will be created in the tree and will be active (Figure 
34-124).

Figure 34-124. The newly-added 
callout view.

Creating Callout Annotations
1. Let’s create a callout annotation in the graphical view. Start by 

clicking the arrow by the icon. A series of annotation types 
will appear. Let’s start with a simple Point Comparison. Select 
Point Comparison from the drop down and select two points to 
compare. An annotation will appear and you can now place 
the annotation accordingly by left-clicking and dragging (Fig-
ure 34-125).
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Figure 34-125. The point com-
parison callout.

2. Now let’s create some annotations for a few of the vectors in 
the vector group. Start by clicking the arrow by the icon 
and select Vectors. When prompted select the vectors of inter-
est. The Vector Callouts dialog will appear with view options 
(Figure 34-126). This dialog will allow you to select display op-
tions for the callouts. Once satisfied, press OK (keep callouts). Feel 
free to place the annotations accordingly by left-clicking and 
dragging (Figure 34-127).    

Figure 34-126. The Vector 
Callouts dialog.
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Figure 34-127. Vector callouts 
have been added.

Locking the Callout view
1. Right-click on Callout 1 in the tree and select Properties (Figure 

34-128).

Figure 34-128. The Callout Page 
properties.

2. Select Lock in the Viewpoint section. When the viewpoint is 
locked, the view will be recalled when the callout is activated.

3. Double-click Callout 1 in the tree. This will deactivate the call-
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out.

4. Rotate and zoom the view to be different than the callout.

5. Now double-click Callout 1 in the tree. This will activate the 
callout. Notice how the view returns to the locked position.
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Reporting With SA Reports

 ■ Skill Level. Beginner.

 ■ Description. In this tutorial, we will cover how to create a re-
port using the SA Report designer.

 ■ Areas Covered. Creating an SA Report, dragging out items, 
changing report options.

 ■ Time to Complete. Approximately 15 minutes.

Creating an SA Report
In this tutorial, our goal is to create a report comparing measured data 
to CAD. We will use a sample file and create the report from that data.

1. In SA, start by opening the Query Points to Surface.
xit file from the Samples directory under Help> Open Sample 
SA Files. 

2. Before we start the report, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3. Create an SA report by selecting Report>Add SA Report. The SA 
Report editor will appear, and the report is automatically 
stored in the tree under the SA Reports category (Figure 34-
129).    

Figure 34-129. The newly-added 
report.

Figure 34-130. The Report 
Designer.

4. Let’s add an item to the SA Report. Click and drag the Boat 

Note:  This file contains data 
that was measured with a 

portable CMM arm.  The measure-
ments were compared to the 
nominal model using Query> 
Points to> Objects.
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error_Vectors_Blotches vector group into the report (Figure 
34-131).

Figure 34-131. Adding a vector 
group to the report.

5. Now let’s change the reporting options for the vector group 
so that only the vector magnitude will be displayed. Right-
click anywhere on the vector group table and select Report Op-
tions.

6. Uncheck the Point A, Point B and Delta components and press 
OK.  The SA Report will update and reflect your changes.

7. Let’s add an image of the current graphics view to the report. 
Orient the SA graphics as you’d like, and press the Picture icon

in the toolbar. The picture will be stored in the tree, as pic-
tured in Figure 34-132.

Figure 34-132. The screenshot 
has been added to the tree.

8. Click the photo, drag it over a table in the SA Report, and re-
lease the mouse button to add the photo to the report.
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9. The photo will have the same aspect ratio (width to height 
ratio) as the graphical view when it was taken. If you need to 
resize the image, hold down Ctrl and drag over the image, 
or grab a corner of the image to resize it as necessary. Drag 
the tables around to rearrange the report as you’d like (Figure 
34-133).  

10. Items in a report can be moved by dragging them manually 
and positioning them as you would like. To dynamically ad-
just the placement of items in the report right-click and select 
auto-arrange> Set auto-arrange Start. This will place a start 
tag in your report for where you want selection to start. 

11. Right-click again and select Execute Auto-Arrange to remove 
overlap in tables below your start tag . If you noticed there is 
also an option to set a stop point for more control or to select 
all the entities so you can manually move them as a group. 

Figure 34-133. Auto-Arrange 
Controls

12. The report is automatically saved into the tree. If you’d like, 
you can print the report, send it to a PDF, or export to Excel.
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The following page is a list of default keyboard shortcuts that ship with 
SpatialAnalyzer. To become a more efficient user of SA, it is recommend-
ed that you try to become familiar with as many of these shortcuts as 
possible.

Keyboard 
Shortcuts



Action Shortcut

Rotate (Orbit)   (Drag)

Zoom In/Out

Pg Up/Pg Dn

 Scroll Up/Down

Ctrl +  + Drag Up/Down

Pan

   

Shift +  (Drag) 

 (Drag)

Recenter View  (Click to Center)

Zoom to Selection  + Drag Rectangle

Autoscale Alt+A

Clipping Planes Alt+X

Previous View Ctrl + Alt + 

Next View Ctrl + Alt + 

Graphical View

Action Shortcut

Fit Geometry Ctrl + G

Fit Line Ctrl + Alt + L

Fit Circle Ctrl + Alt + C

Fit Plane Ctrl + Alt + P

Fit Cylinder Ctrl + Alt + Y

Fit Sphere Ctrl + Alt + S

Geometry Fit
Action Shortcut

Add Instrument Alt + I

Point at a Point  (Double-click on point)

Instruments

Action Shortcut

Point to Point Ctrl + D

Group to Group Ctrl + W

Queries

Action Shortcut

Best Fit Points to Points Ctrl + B

USMN Alt + U

Analysis

Action Shortcut

Construct Points Ctrl + P

Layout Random Points Ctrl + Alt + Z

Patch Normal Shift Ctrl + M

Construct Line 2 Points Ctrl + L

Geometry Construction

Action Shortcut

Repeat Command Ctrl + Tab

Command History Ctrl + Shift + Tab

Graphical Selection Mode F3 (During Selection)

List Selection F2

Undo to Restore Point Ctrl + Z

Create Restore Point Alt + Space

Pick Working Frame Alt + W

User Options Ctrl + U

General

Action Shortcut

Open File Ctrl + O

Save File Ctrl + S 

File

Action Shortcut

Show Point Labels Alt + L

Hover Ctrl + H

Cloud Display Control Ctrl + T

Refresh F5

View

Action Shortcut

Object Properties Alt + Q

Copy then Transform Ctrl + C

Delete Objects Delete

Delete Points / Cloud Points Alt + D / Ctrl + Alt + D

Add User Note Ctrl + N

Edit

KEYBOARD SHORTCUTS

Action Shortcut

Inspection Bar Previous Ctrl + F7

Insp. Bar Stop Ctrl + F8

Insp. Bar Next F8

Instrument Toolbar Measure F6

Inst. Toolbar Iterate Profile F9

Inst. Toolbar Iterate Tooling F10

Inst. Toolbar Lock Beam F12

Inspection
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Linear Least Squares Adjustment
Least squares is a procedure for adjusting observations containing 
random errors. It was developed in the latter part of the eighteenth 
century by Karl Gauss. It was not used much until computers became 
commonplace because of the lengthy calculations required. Spati-
alAnalyzer uses it in many routines (transformations, best-fit lines-
planes-circles etc), to provide the best and most consistent answer 
for fitting problems.

For a group of equally weighted observations (or measurements in 
our case), the basic condition that is enforced in least squares adjust-
ments is that the sum of the squares of the residuals is minimized. 
Residual is another term for the difference between a measured value 
and its most probable (or “correct”) value. For 3D coordinate metrol-
ogy, one example of a residual would be the difference between the 
true X-coordinate for a point and the actual X-coordinate measure-
ment.

The method of least squares is a criterion for fitting a specified model 
to observed data. In this case, the specified model is the reference set 

Although not at all essential to get benefit out of the software, this sec-
tion provides background knowledge on some of the math behind Spa-
tialAnalyzer.

Math Reference
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of points (or expected values), and the observed data are typically 
your measurements of the reference set of points. Let’s use a common 
use of the least squares adjustment as an example. The least squares 
line routine is a commonly used method for computing the best-fit 
line from a series of measurements of a linear function. The distance 
your car travels when you’re driving at a particular speed is an ex-
ample of a linear function. In this example, you are trying to drive 
your car at a constant speed and measure how far you have gone and 
the time it took you to get there. While driving, it is likely that a little 
error is going to creep into the process—you’re not going to be able 
to . That error is generally referred to as random error. Least squares 
adjustment techniques are really good at dealing with this type of 
error and are able to produce a reasonable and consistent answer in 
spite of it. An example is shown in the figures. The time is plotted on 
the X-axis and the distance on the Y-axis.

The points are the paired measurements made of time verses the dis-
tance traveled, which is linear in this case because you were trying to 
maintain a constant speed. To find what is considered the “best line” 
through the data the least squares line routine is used. In this case, 
the residual that gets minimized is the difference (squared) from a 
measured point to the line that best describes the distance you trav-
eled verses the time it took. The least squares line routine will find 
a line, such that the sum of the distances (squared) from the data 
points to the line is the minimized. The figure shows a line that best 
fits those points; it was solved for with the best-fit line routine in Spa-
tialAnalyzer.

The slope of the best-fit line is actually the average speed that you 
traveled on your trip. This line is the most consistent way of determin-
ing where you probably where at any point in time during your trip.

The least square line adjustment was able to use this set of measure-
ments even through each point had some error, and it produced a 
high-quality and reliable answer. This ability of dealing with measure-
ments that have at least some component of random error and still 
being able to produce consistent and representative answers is why 
the technique is used in SpatialAnalyzer.

Basics of Spatial Transformations
Homogeneous transformations—transforms for short—can be used 
to represent the position and orientation of one coordinate frame 
(system) with respect to another coordinate frame. A general trans-
formation matrix can be conveniently represented as a four by four 
matrix; however, only twelve of the sixteen numbers are typically 
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used in this application1. This representation is unique—i.e., there 
is only one transformation matrix that unambiguously describes a 
particular relative position and orientation. The problem with repre-
senting all transforms as a matrix is that this representation is over-
constrained. We know, for example, that a rigid object in space has 
only six degrees-of-freedom—three positional and three rotational. 
You simply don’t need all twelve numbers in the 4x4 matrix to rep-
resent the relative position and orientation. Let’s look at other more 
compact representations.

First of all, we need to define which coordinate frame is described 
relative to the other. Let’s assume we have frames A and B, and that 
we wish to describe frame B relative to A (Figure B-1).

Figure B-1. Two coordinate frames 
in space.

x

z

y

x

z
y

A B

Position is easy—we simply describe the x, y, and z components of 
the origin of B. Note these terms are the distances along the x, y, and 
z axes of frame A. Also note the position of A relative to B would not, 
in general, be the negative of these values. (This would only be the 
case if the corresponding axes for the two frames were all parallel). 
Rotation is not as easy as position. To describe rotations, certain stan-
dard conventions have been adopted. These are by no means the 
only possible methods. The following sections will discuss different 
viewpoints that are commonly used to discuss transforms, then we 
will discuss simple unit rotations, and go on to develop compound 
rotation methods.

The old viewpoint debate: Are we describing or transforming?

This section only becomes necessary because of the language that 
individuals use to discuss transforms. This is one of the most common 
sources of errors in dealing with spatial transformations. Transforms 
can be used in two different ways:

 ■ As a descriptor. This is the way we will always talk about trans-
forms in SpatialAnalyzer. This is the description of one frame 

1 The four-by-four matrix is typically used because it is symmet-
ric. Numerical routines can generally be made more efficient when 
the numerical pieces are symmetric.
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relative to another. For example, frame B relative to frame A.

 ■ As a transform operator. In this case we ask the question: 
what operations we do to frame A to rotate and translate it to 
the position and orientation of B? In some cases, it’s natural to 
think about transforms in this way. For example, if you want to 
describe the position of a box as it moves, it’s natural to think 
about the rotations and translations that it is subjected to over 
time.

The final result is a little counter-intuitive—but essentially, it doesn’t 
matter which view point you use—they both produce the exact same 
results. You just need to be aware of the fact that despite the language 
used, the math is the same. Many people incorrectly interpret one as 
the inverse of the other.

Unit Rotation Matrices

Before we can discuss compound rotations, we need to develop the 
building blocks of unit rotations. These are simply rotations that oc-
cur about any given principal coordinate axis (X, Y, or Z). They are as 
follows:

Rx(θ) =




1 0 0
0 cos θ − sin θ
0 sin θ cos θ


 Ry(θ) =




cos θ 0 sin θ
0 1 0

− sin θ 0 cos θ


 Rz(θ) =




cos θ − sin θ 0
sin θ cos θ 0

0 0 1




Or, for the particular example of an X rotation of 30°, a Y rotation of 
60°, and a Z rotation of 90°:

Rx(30◦) =




1 0 0
0 0.866 −0.500
0 0.500 0.866


 Ry(60◦) =




0.500 0 0.866
0 1 0

−0.866 0 0.500


 Rz(90◦) =




0 −1 0
1 0 0
0 0 1




Compound Rotations

Using the building blocks of the above unit rotations, we can now 
proceed to develop more complex compound rotations. As we stated 
earlier, a rotation matrix is unique. However, the descriptive methods 
we often use to describe a rotation are not. The same physical orien-
tation can be described in an infinite number of ways. We’ll explore 
the most common below.

Fixed Angle XYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the X-axis of A (XA), then about the Y-axis of A 
(YA), then about the Z-axis of A (ZA). We can express this as:

Rxyz(30◦, 60◦, 90◦) = Rz(90◦)Ry(60◦)Rx(30◦) =




0.000 −0.866 0.500
0.500 0.433 0.750
−0.866 0.250 0.433
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Fixed Angle ZYX
In this case, we again start with frame A and B coincident. We then ro-
tate frame B about the Z-axis of A (ZA), then about the Y-axis of A (YA), 
then about the X-axis of A (XA). We can express this as:

Rzyx(90◦, 60◦, 30◦) = Rx(30◦)Ry(60◦)Rz(90◦) =




0.000 −0.500 0.866
0.866 −0.433 −0.250
0.500 0.750 0.433




Euler Angle XYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the X-axis of B (XB), then about the Y-axis of B 
(YB), then about the Z-axis of B (ZB). Note that the axes of frame B ro-
tate during the operations. We can express this as:

Rx′y′z′(30◦, 60◦, 90◦) = Rx(30◦)Ry(60◦)Rz(90◦) =




0.000 −0.500 0.866
0.866 −0.433 −0.250
0.500 0.750 0.433




Euler Angle ZYX
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the Z-axis of B (ZB), then about the Y-axis of B 
(YB), then about the X-axis of B (XB). Note that the axes of frame B ro-
tate during the operations. We can express this as:

Rz′y′x′(90◦, 60◦, 30◦) = Rz(90◦)Ry(60◦)Rx(30◦) =




0.000 −0.866 0.500
0.500 0.433 0.750
−0.866 0.250 0.433




Euler Angle ZYZ
In this case, we will start with frame A and B coincident. We will then 
rotate frame B about the Z-axis of B (ZB), then about the Y-axis of B 
(YB), then again about the Z-axis of B (ZB). Note that the axes of frame 
B rotate during the operations. We can express this as:

Rz′y′z′(90◦, 60◦, 90◦) = Rz(90◦)Ry(60◦)Rz(90◦) =



−1 0 0
0 −0.500 0.866
0 0.866 0.500




Equivalent Angle Axis
This representation is a little different from the others given in that 
it does not result from the combination of unit rotations. This con-
vention stems from the fact that for any given rotation there exists a 
unique axis of rotation and magnitude of rotation. If we rotate about 
a unit vector K and amount θ we find that the following matrix results:

R(K, θ) =




KxKxvθ + cos θ KxKyvθ − Kz sin θ KxKzvθ + Ky sin θ
KxKyvθ + Kz sin θ KyKyvθ + cos θ KyKzvθ − Kx sin θ
KxKzvθ − Ky sin θ KzKyvθ + Kx sin θ KzKzvθ + cos θ




where vθ = (1 − cos θ) and Kx, Ky, Kz are the components of unit vector 
K. Through an inverse analysis we can extract the (K, θ) for any rota-
tion matrix.
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Quaternions (also known as Euler Parameters)
A Quaternion is simply another way of expressing the information 
that is inherent in the equivalent angle-axis representation. Namely,

ε1 = Kx sin

(
θ

2

)
ε2 = Ky sin

(
θ

2

)
ε3 = Kz sin

(
θ

2

)
ε4 = cos

(
θ

2

)

Notes on Decimal Precision and Rounding
Decimal Precision

The precision with which a 64bit double value can be stored is roughly 
the machine epsilon * value of double, approximately 2.220446e-16.

Epsilon can be approximated by finding the smallest value for which 
((1.0 + epsilon) – 1.0) <> 0.

This means that a double can never be better than 15 decimal places 
(scientific notation).

As a practical matter, subsequent to a reasonably limited number of 
mathematic operations, a double is generally no better than 12 or 13 
decimal places (scientific notation).

If a set of points are imported into SA into the world frame, then a 
point recorded as (-247.5, 0, -247.5) should resolve X and Z to the 
same displayed value when displayed with zero significant digits – in 
this case, the values for X and Z should be stored as identical double 
representations.

If, however, this point is imported into a working frame different from 
world, it will be subjected to a coordinate transform so that it will be 
stored in world coordinates – points are ALWAYS stored relative to the 
WOrLd frame.

pt_stored = t_world_wrt_working * pt_imported

Now when the point is displayed in the working frame, X and Z val-
ues may no longer be precisely the same – they will have been twice 
transformed.

pt_wrt_working = t_working_wrt_world * pt_stored

pt_wrt_working = t_working_wrt_world * t_world_wrt_working * p_
imported

Every time a point goes through a transform, it will be subjected to 
multiple multiplications and additions for each coordinate compo-
nent.

So, if you start out with a point recorded as (-247.5, 0, -247.5) such that 
X and Z are precisely equal and end up with a case where X and Z are 
not precisely equal, then this means this point has been subjected to 
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coordinate transformations.

Rounding
Double values within SA are recorded and stored using full available 
decimal precision. The units control within the Users Options>Display tab 
(Decimal Digits for Display) offers an option to control the number of dis-
played digits, but this controls only the displayed representation of 
the values for reporting purposes. 

Rounding for display is controlled by the standard C++ unit conver-
sions. This means that a value rounded to 3,1, 0 decimal places would 
appear as:

[-247.4999999999000124]

-247.500

-247.5

-247

Alternatively:

[-247.5000000000099876]

-247.500

-247.5

-248

These results may appear inconsistent when comparing rounded val-
ues to each other but should be more understandable with respect to 
the full precision value. 
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